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Disclaimers

Lattice makes no warranty, representation, or guarantee regarding the accuracy of information contained in this document or the suitability of its
products for any particular purpose. All information herein is provided AS IS, with all faults, and all associated risk is the responsibility entirely of the
Buyer. The information provided herein is for informational purposes only and may contain technical inaccuracies or omissions, and may be otherwise
rendered inaccurate for many reasons, and Lattice assumes no obligation to update or otherwise correct or revise this information. Products sold by
Lattice have been subject to limited testing and it is the Buyer's responsibility to independently determine the suitability of any products and to test
and verify the same. LATTICE PRODUCTS AND SERVICES ARE NOT DESIGNED, MANUFACTURED, OR TESTED FOR USE IN LIFE OR SAFETY CRITICAL
SYSTEMS, HAZARDOUS ENVIRONMENTS, OR ANY OTHER ENVIRONMENTS REQUIRING FAIL-SAFE PERFORMANCE, INCLUDING ANY APPLICATION IN
WHICH THE FAILURE OF THE PRODUCT OR SERVICE COULD LEAD TO DEATH, PERSONAL INJURY, SEVERE PROPERTY DAMAGE OR ENVIRONMENTAL
HARM (COLLECTIVELY, "HIGH-RISK USES"). FURTHER, BUYER MUST TAKE PRUDENT STEPS TO PROTECT AGAINST PRODUCT AND SERVICE FAILURES,
INCLUDING PROVIDING APPROPRIATE REDUNDANCIES, FAIL-SAFE FEATURES, AND/OR SHUT-DOWN MECHANISMS. LATTICE EXPRESSLY DISCLAIMS
ANY EXPRESS OR IMPLIED WARRANTY OF FITNESS OF THE PRODUCTS OR SERVICES FOR HIGH-RISK USES. The information provided in this document
is proprietary to Lattice Semiconductor, and Lattice reserves the right to make any changes to the information in this document or to any products at
any time without notice.

Inclusive Language

This document was created consistent with Lattice Semiconductor’s inclusive language policy. In some cases, the language in underlying tools and
other items may not yet have been updated. Please refer to Lattice’s inclusive language FAQ 6878 for a cross reference of terms. Note in some cases
such as register names and state names it has been necessary to continue to utilize older terminology for compatibility.
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Abbreviations in This Document

A list of abbreviations used in this document.

Abbreviations Definition

AES Advanced Encryption Standard
AHB-Lite Advanced High-performance Bus — Lite
APB Advanced Peripheral Bus

AXl14 Advanced eXtensible Interface 4

BMC Baseboard Management Controller
BSP Board Support Package

CRE Cryptographic Engine

ECDSA Elliptic Curve Digital Signature Algorithm
ESFB Embedded Security Function Block
GPIO General Purpose Input/Output

GUI Graphical User Interface

HDL Hardware Description Language

12C Inter-Integrated Circuit

13C MIPI Improved Inter-Integrated Circuit
IP Intellectual Property

ISK Image Signing Key

JTAG Joint Test Action Group

KAK Key Authentication Key

LED Light Emitting Diode

MRK Master Root Key

0scC Oscillator

OTP One Time Programmable

PFR Platform Firmware Resilience

PLL Phase-Locked Loop

QSPI Quad Serial Peripheral Interface

RBP Rollback Protection

RISC-V Reduced Instruction Set Computer-V (five)
RoT Root of Trust

RX Real Time OS (RISC-V for RTOS applications)
SDK Software Development Kit

SGE Software Generator Engine

SGPIO Serial GPIO

SH-Bash Shell Program

SKP Secure Key Provisioning

SMBus System Management Bus

SoC System on Chip

SPI Serial Peripheral Interface

UART Universal Asynchronous Receiver Transmitter
UFM User Flash Memory

usB Universal Serial Bus

© 2025 Lattice Semiconductor Corp. All Lattice trademarks, registered trademarks, patents, and disclaimers are as listed at www.latticesemi.com/legal.
All other brand or product names are trademarks or registered trademarks of their respective holders. The specifications and information herein are subject to change without notice

FPGA-UG-02217-1.1


http://www.latticesemi.com/legal

= LATTICE

1. Introduction

This document provides a comprehensive guide on how to set up and use the Lattice Sentry™ 4.0 solution utilizing the
MachXO5™-NX LFMXO5-55TD device. It walks you through the required tools, software set-up procedures, project
workflow, programming and configuration, using demo and demo tools, and troubleshooting.

2. Required Tools

2.1. Software Requirements
e Lattice Propel™ Configuration:
e Lattice Propel: Propel2024.1_2406150513_p.exe
Lattice Propel 2024.1 used in this solution can be downloaded from the following web pages:
Lattice Propel 2024.1 for Windows
Lattice Propel 2024.1 for Linux
e Lattice Sentry Patch: Lattice_Sentry_4.0_Solution_(Propel2024.1 patch)_Prod.exe
Contact Tech Support to get this patch.
e Lattice Radiant™ Configuration:
e Lattice Radiant: 2024.1.0.34.1_Radiant.exe
Lattice Radiant 2024.1 used in this solution can be downloaded from the following web pages:
Lattice Radiant 2024.1 for Windows
Lattice Radiant 2024.1 for Linux
e Lattice Radiant Control Pack XO5D: 2024.1.0.34.1_Radiant_Ctrl_Pack_XO5D.exe
Contact Tech Support to get this control pack.
e  Provision Tool
Contact Tech Support to get Provision Tool.
e Image Signing Tool
Contact Tech Support to get Image Signing Tool. The preliminary version is available.
e Terminal emulator program such as PuTTY to view UART messages

2.2. Hardware Requirements

e  Lattice Sentry Demo Board for MachXO5-NX LFMX05-55TD, Rev B

e 12V power supply for the Lattice Sentry Demo Board

e 2 USB cables (Type-A to Type-B Mini)

e Two-position shunt connectors

e  Lattice 2B Programming Cable

e DediProg programmer (optional, could be used for programming BMC image into an external flash)

2.3. License Requirements

The following licenses are required:
e |SC_CTL_LFMXO5-55TD
e LSC_ESFB55D_ES

3. One-time Software Setup Steps

3.1. Download IP from IP Catalog

In Lattice Propel Builder, make sure the following IPs are installed. Some IPs are installed automatically with the Lattice
Sentry 4.0 Propel Patch. The rest can be downloaded from the IP Catalog. Make sure the version number of each IP

www.latticesemi.com/legal
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matches the one shown in Table 3.1 to avoid potential compatibility issues. Figure 3.1 shows the IP Components Used

in Sentry 4.0 Template.
Table 3.1. Sentry 4.0 Required IP

IP Name Version Source
GPIO 1.6.2 IP Catalog
RISC-V RX 24.0 IP Catalog
Lattice Sentry I2C Filter 1.3.0 IP Catalog
I13C Controller 3.3.0 IP Catalog
AXI14 to AHB-Lite Bridge 1.2.0 IP Catalog
AXI14 to APB Bridge 1.2.0 IP Catalog
AXI4 Interconnect 1.2.2 IP Catalog
AXl4-Lite Clock Management 1.1.0 Sentry 4.0 Propel Patch
Lattice RoT ESFB 2.0.0 Sentry 4.0 Propel Patch
Lattice Sentry QSPI Monitor 2.0.0 Sentry 4.0 Propel Patch
Lattice Sentry QSPI Master Streamer 2.0.0 Sentry 4.0 Propel Patch
SGPIO Master 1.1.0 Sentry 4.0 Propel Patch
Lattice Sentry SMBus Mailbox 2.2.0 Sentry 4.0 Propel Patch
Tightly Coupled Memory 14.0 Propel Base Install
AHB-Lite to APB Bridge 1.1.0 Propel Base Install
AHB-Lite Interconnect 131 Propel Base Install
APB-Interconnect 121 Propel Base Install
PLL 1.9.0 Propel Base Install
OSC for CRE 14.0 Propel Base Install

* |[{F Components

1F| axi2ahbl0:1.2.0
F| axi_interconnect(:1.2.2
1F| bmc_program_gpic(:1.6.2
f| clock_management0:1.1.0
1F| i2c_filter0:1.3.0
1F| i2c_filter1:1.3.0
1f| i3c_controller(:3.3.0
iF| lattice_esfb0:2.0.0
‘| gspi_monitor(:2.0.0
1F| gspi_streamer0:2.0.0
iF| sgpio_master(:1.1.0
1F| smbus(0:2.2.0
1F| smbus1:2.2.0
F| tem0:1.4.0
1F| ucpul:2.4.0
1F| ahbl2apbi1:1.1.1
if| ahbl_interconnect(:1.3.1
1F| apb_interconnect1:1.2.1
F| flexible_pll:1.9.0
1F| osc_cre0:1.4.0
F| pll0:1.9.0

Figure 3.1. IP Components Used in Sentry 4.0 Template
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3.2. Enable Controlled Device License in Lattice Radiant Software
To enable the controlled device license in Lattice Radiant software:

1. In Lattice Radiant software, from the menu, select Tools -> Options -> Startup.

2. Enable the Check Controlled Device License item (Figure 3.2).

3. Restart Lattice Radiant software for this setting to take effect.

4. Note that this setting should persist once it has been set.

Options X
General Startup File Assodations Directories MNetwork Settings
General
At Lattice Radiant Software startup
Show Start Page A
6 Automatic check for software update when Lattice Radiant Software launchs
Color ® Every time
Daily
Weekly
,\< ) Automatic fetch IP list from IP Server daily
Tools Check Controlled Device License I
[0]'4 Cancel Apply

Figure 3.2. Check Controlled Device License

© 2025 Lattice Semiconductor Corp. All Lattice trademarks, registered trademarks, patents, and disclaimers are as listed at www.latticesemi.com/legal.
All other brand or product names are trademarks or registered trademarks of their respective holders. The specifications and information herein are subject to change without notice
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Before creating the SoC project in Lattice Propel Builder, make sure you have downloaded the correct versions of all IP

blocks used in the project, as shown in the Download IP from IP Catalog section.

1. Create a project directory for the SoC and C projects locally on your computer, as shown in Figure 4.1.

1\ -
H X

=| Documents
Meetings
Microsoft Teams Chat Files

&=| Pictures

Videos

Home Share WView
v » ThisPC » Windows (C:) » lscc » projects ~ O Search projects
Apps = Mame . Date medified Type
Attachments Sentryd_0 7/2/202412:12 BM File folder
[ Desktop

Size

Figure 4.1. Local Project Directory for Creating SoC and C Project

Launch Lattice Propel Builder 2024.1.

From the menu, select File -> New SoC Design.

Enter a project name which ends in _soc. Click Browse to navigate to the empty project directory created in Step 1.

Click Next (Figure 4.2).

“y, Propel Create Project

Design Information
Enter & name for your design and specify a directory where the design files will be stored.

Project:

Language: | Verilog

Mame: sentry4_0_soc
Location C:/flsccjprojects/Sentry4_0 -
Create Project at C:/lscc/projects/Sentry4_0/sentry4_0_soc

Mext =

Browse...

Cancel

Figure 4.2. Design Information

5. Select Lattice Sentry 4.0 RoT Project, then click Next (Figure 4.3).
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N

Propel Create Project

Select Template

Select a template by name and version from the list of templates.

User Only

Empty Project

Lattice Sentry 4.0 RoT Project

Lattice Sentry RoT Project
Lattice Sentry RoT Project (256)

Lattice Sentry RoT Project (484)

RISC-V MC Dual Processor Project

RISC-V MC SoC Project
RISC-V MC 50C Project Avant
RISC-V MC SoC Project ECP3
RISC-V RX SoC Project
RISC-V RX SoC Project Avant
RISC-V SM SolC Project

SHA-3 CFU Project

Processor
RISC-V MC,RISC-V SM,RISC-V RX
RISC-V RX
RISC-V MC
RISC-V MC
RISC-V MC
RISC-V MC
RISC-V MC
RISC-V MC
RISC-V MC
RISC-V RX
RISC-V RX
RISC-V 5M

RISC-V RX

Neone

None

Mone

Mone

Mone

Mone

Mone

MNone

MNone

MNone

MNone

MNone

Mone

Template Info:

Version

Lattice Sentry 4.0 RoT Project on Lattice Sentry 4.0

a) Processor - RISC-V RTOS PIC/TIMER

b) TCM
) ESFB

d) QSPI_Master_Streamer
&) QSPI_Monitor
) Smbus_Mailbox

a) I12C_Filter

h) I13C_Controller

) SGPIO

1) AXIL_Clock_Management

k) GPIO

Supported Boards:

Lattice Sentry 4.0 Demo Board(A)

Template Manager | 4

< Back Mext >

Cancel

Figure 4.3. Create Lattice Sentry 4.0 RoT Project

6. Select Lattice Sentry 4.0 Demo Board for Board. Then, click Next (Figure 4.4).

4. Propel Create Project

Select Device

Select & device or board for current template.

Board ~ Device Information:
Name Version Part Mumber: LFMX05-55TD-8BBG400C
Lattice Sentry 4.0 Demc Board A Liees 53000
LUTs: 40000
Registers: 40000
EBR Blocks: 54
LRAM: B
DSP (18x 18 Multiplier): 110
ADC Blocks: 1
PLLs: 4
DLLs: 2
PCSs: 1
AlUs: 1
DPHYs: o
PIO Cells: 291
PIQ Pins: 291
< Back Next = Cancel

Figure 4.4. Create SoC Project — Select Device
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7. Make sure the solution is Sentry 4.0. Then, click Next (Figure 4.5).

4, Propel Create Project X

System Application Level
(choose an application)

Sentry 4.0
The Lattice Sentry solutions stack includes everything system
designers need to evaluate, develop, test and deploy a NIST

SPB00-153-compliant, FPGA-based Platform Firmware Resiliency
(PFR) Root of Trust.

@ s-ityao

< Back Mext > Cancel

Figure 4.5. Create SoC Project — Select Application

8. Choose number of Peripherals, as shown in Figure 4.6. Then, click Next.

4 Propel Create Project X
Basic Info: Choose number of Peripherals:
Systemn App Level: === Peripheral ===
Sentry 4.0 Lattice Sentry 12C Filter 2 &)
Processor : Lattice Sentry QSPI Monitor 1 (o)
sM A
Lattice Sentry QSPI Master Streamer 1 v
System Memory : A
AXI4-Lite Clock Management 1 v
toml
- ~
Memeory Range (KB) : Lattice RoT ESFB 1 v
~ ~
256 v Lattice Sentry SMBus Mailbox 2 v
System Clock (MHz) : sgpio_master 1 c
dk_f
- I3C Controller 1 &
Pre-defined Base Ini : -
GPIO 1 v

ini_soc/sfb_ip_base_sentry.ini

< Back Mext = Cancel

Figure 4.6. Create SoC Project — Select Peripherals
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9. The next dialog box shows the SoC sketch. Click Next and finish (Figure 4.7).

4. Propel Create Project hed
RISC-V
ax_bus waimDMH;
qspi_monitord qspi_streamerD clock_managemen]0

040080000 0x40000000 040100000

L ahbl bus waimDMH;
i2c_filterD i2c_filter1 lattice_esfb0
0x4011b000 0x4011c000 0x4011d000

aEb bus DEw25MHL

smbus0 smbus1 sgpio_masterd i3c_controllerQ bnc_program_gpid0
0x40108000 0x40110000 0x4011a000 0x40118000 0x40118000
< Back Next = Cancel

Figure 4.7. Create SoC Project — SoC Sketch

10. The SoC project opens in Lattice Propel Builder (Figure 4.8).
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“ Propel Builder [C:/lscc/projects/Sentryd_0/sentryd_0_soc/sentryd_0_soc/sentryd_D_soc.sbx] Device: LFMXO3-35TD-8BBG400C Board: Lattice Sentry 4.0 Demo Board(4) — [m] x
File Edit View Design Tools Window Help
FERAOCHs MERReoELERS @QQQa B
Design View o Schematic Address . StartPage
a LFMX035-55TD-BBBGA0DC = g
= 1 sentryd_0_soc <§> |_ )
v {7 Instances ‘|_|_‘='_l
v I ahbl2apbl_inst
» 1 shbl_interconnectl inst ﬁ
» 1 aph_interconnect]_inst ‘_E
» % axi2ahbl0_inst —
v 1 axiinterconnect_inst 3
v I bmc_program_gpio0_inst — |
b 2 clock_managementd_inst ===
v 1E expr 0 inst
b I expr_Tinst 3
b I expr2inst |
b ZE flexible pll_inst
v L i2c fitterD_inst ==
v L i2c fitter]_inst B
v I i3c_controllerd_inst - H—
v LF lattice_esfbO_inst "I = =
v 1F osc_crelinst —— "|
v I plioinst —
v 1F gspi_monitorl_inst = — f
b I qspi_streamer inst v@% - s ]
v 1F sgpio_master0 inst 1]
v iF smbusO_inst I_ —
v 1F smbusT_inst il
v TF temlinst - t L L
¥ iE ucpullinst
+ Sm s %J i i A
: : =
Properties
Name: = sgpio_master0_inst ——II:
Type: Instance =
Path: sentry4_0_soc/sgpio_master0_inst
VLMV: |atticesemi.com:ip:sgpio_master0:1.1.0 _EC‘,_I
St .
1P Catalog Design View q b
Tl Console [m]
INFO <2359992> - Port width does not match for port 'AWID' in interface 'axi_interconnectd_inst.AXI S00' and interface 'ucpu0_inst.AXI M DATA' -
INFO <2359 - Port width does not match for port 'BID' in interface 'axi_interconnect0_inst.AXI S00' and interface 'ucpu0_inst.AXI M DATA'
INFQ <2359992> - Port width does not match for port 'RID' in interface 'axi_interconnectO inst.BXI S00' and interface 'ucpud_inst.AXI M DATA'
)

Figure 4.8. SoC Project — Created

11. Choose File -> Save or click the Save icon to save SoC project (Figure 4.9).

<
File Edit View Design Tools Window Help

.- =[A] - AMEENOoBNuURSe @Qacaa B

Figure 4.9. Propel Builder Save Icon

12. Choose Design -> Validate or click the Validate icon to validate SoC project (Figure 4.10).

#.
File Edit View Design Tools Window Help

ssEaA o cnamEzromune aacaa B

Figure 4.10. Propel Builder Validate Icon

13. Choose Design -> Generate or click the Generate icon to generate the SoC project (Figure 4.11).

© 2025 Lattice Semiconductor Corp. All Lattice trademarks, registered trademarks, patents, and disclaimers are as listed at www.latticesemi.com/legal.
All other brand or product names are trademarks or registered trademarks of their respective holders. The specifications and information herein are subject to change without notice

FPGA-UG-02217-1.1

13



http://www.latticesemi.com/legal

= LATTICE

-

File

'+

Edit

-

View Design Tools Window Help

B Q‘SWQ:‘&*';' P QQQQ.

Figure 4.11. Propel Builder Generate Icon

14. The SGE file, sys_env.xml, is generated through the Generate step. It is located in the following director:

< Workspace> / <SoC Project> /sge/< sys_env.xml

4.2,

Generate Bitstream in Lattice Radiant Software

1. In Lattice Propel Builder, choose Design -> Run Radiant or click the Lattice Radiant software icon to open the SoC
project in Lattice Radiant software (Figure 4.12).

A

File Edit

n Y

View Design Tools Window Help

=) « MES NS @ & I eaaa ®

Figure 4.12. Lattice Radiant Software Icon

2. Sign the bitstream through the following steps.

From the menu, choose Tools -> Bitstream Security Settings.
When the Password dialog box pops up, click OK with the default password LATTICESEMI.

In the Keys dialog box, make the following selections (Figure 4.13).

Check the checkbox next to AES2 Encryption and enter key:
1F1316A755086123B563EC726DD9A5BA915C65BAC6584BF8ES51COASED37BF1F6

Check the checkbox next to ECDSA. Choose Authentication Mode ECDSA-256 from the drop-down menu
and enter keys:

Public Key
6BD2BE7740EC2EBFF5AFB698296FFF3D09731CAC23C12E196BA92B5DADB65073CEOD320B4213D7ADD3
F27C08B0158CBESFOEC8DD023CAASAFECASEFD41FF49D7

Private Key

968411DA7986DC4F6031F84A641610E2DB6A4C3BDA1550B11E619A51266A7CB2

For KeyBlob, choose Normal from the drop-down menu. Choose Authentication Mode ECDSA-384 from
the drop-down menu.

For KAK, enter keys:

Public Key
1f6c4a9fddcf7fbd815f4e9bcc0ad97b54f222dda9bdclc3bd1a79ea283bb2ff4288639f34c173c0acf8456¢c0b
€757a0d5ff99832c676033a772979b738fd8bacd3975c3df48cfd996ceb948698ae23c23d6cee67bd07d4b7d
bd147977071258

Private Key
9223bae8b8ce2fe76847f1a7a82651217d3f5698656658a3cb43cf7369c80a8f85a898bbf046c87259395e89
921e60a4

For ISK, enter ISK ID 0.

Click Auto Generated Key Pair for ISK.

Note: The ISK key pairs are automatically saved in the Security Settings folder of the SoC project. Once
generated, these keys can be used consistently during project development, until an ISK key is revoked.
This eliminates the need to constantly auto-generate new ISK key pairs.

Click OK.
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Dialog
AES2 Encryption
Key: 1F1316A755086123B563EC726DD9ASBAS15C65BACES84BFBESICOASED37BF1FG

ECDSA

Authentication Mode: ECDSA-256 ~

Public key:

Load from File...

Auto Generated Key Pair

6BD2BE7740EC2EBFF5AFBG98296FFF3D09731CAC23C12E196BA92B5DADBA5073CE0D320B4213D7ADD3F27¢ | Load from File...
Private key:  968411DA7986DC4F6031F84A641610E2DBAA4C3BDAL550B11E619A51266A7CB2 Load from File...
KeyBlob
Mode:  Normal hd Authentication Mode:  ECDSA-384 ~
KAK
Auto Generated Key Pair
Public key: 1F6C4ASFDDCF7FBDB15F4E9BCCOA497B54F222DDAIBDCIC3BD1A79EA283BB2FF4288639F34C173C | Load from File...
Private key:  9223BAESBBCEZFE76847F1A7AB2651217D3F5698656658A3CB43CF7369C80A8F85A898BBF046CE72° | Load from File...
ISK
ISKID: |0 RISKID: 0-255 Auto Generated Key Pair
Public key:  6CEFAFCCF57DDEDB0O37BDACFI4AGEC2DA1C1CF86FEB4CCEQ81A10119D80DBACI7199FES0EESDCCI | Load from File...
Private key:  9CED1DFFEAC8993895D183738E973CD34D8E5019C63338258A03EA65C891BD768C81E07CFC67528/ | Load from File...

OK

Auto Generated Key

Cancel

Figure 4.13. Key Dialog Box

3. After you click OK in this dialog box, the keyblob and keys are stored in a Security Setting directory in the following

location: < Workspace>/<SoC Project>/security_setting (Figure 4.14).

The files keyblob_normal.bin and isk.prv are input to the image signing tool, which is described in the
Sign the Firmware File section. These files and other key files may be saved and used during project development.
Key files can also be loaded directly into Lattice Radiant Bitstream Security Settings without the need of

copy-pasting keys into the text boxes.

' = | security_setting
Home Share View
« v 1 <« lscc » projects » Sentryd 0 » sentryd 0_soc » security_setting v O
~
Videos " MName Date modified
[ This PC [ ] isk.prv 7/12/202
B 3D Objects 18] isk.pub '
[ Desktop L kakpry
5 @ kak.pub
=| Documents ~
& | | keyblob_normal.bin
; Downloads Ij sentryd_(_soc.bek
J’ Music |:| sentryd_0_soc.prv
&=/ Pictures @ sentryd_(_soc.pub
m Videos IJ- sentryd_(_soc.secproj
i Windows (C:)
e R A N
9 items

Search security_setting
Type Size
PRV File
Microsoft Publish...
PRV File
Microsoft Publish...
BIN File
BEK File
PRV File
Microsoft Publish...
SECPROJ File

TKB
TKBE
TKE
TKBE
2KE
TKB
1KBE
TKB
2KB

Figure 4.14. Security Setting Directory

4. In Lattice Radiant software, click the green arrow to run through the Synthesis/Map/PAR/export process to

generate a signed bitstream (Figure 4.15).

© 2025 Lattice Semiconductor Corp. All Lattice trademarks, registered trademarks, patents, and disclaimers are as listed at www.latticesemi.com/legal.
All other brand or product names are trademarks or registered trademarks of their respective holders. The specifications and information herein are subject to change without notice

FPGA-UG-02217-1.1

15


http://www.latticesemi.com/legal

Lattice Sentry 4.0 MachXO05-NX LFMXO05-55TD Walkthrough Guide :..LATT’CE

User Guide

Lattice Radiant Software -[C:/Iscc/projects/Sentryd_0/sentry4_0_soc/sentryd_0_soc.rdf] - Reports
File Edit View Project Tools Window Help

s-@-B OC QeaQQ B AL 00D HE |

n Synthesize Design n Map Design u Place &Route Design u Export Files

Q> Find Text N x ?Startpage Reports

Figure 4.15. Lattice Radiant Software Synthesis/Map/PAR Process

5. The generated bitstream is located in the following directory:

< Workspace>/<SoC Project>/impl1/<project_name>_impl_1.bit

4.3. Create C Project in Lattice Propel SDK

1. In Lattice Propel Builder, choose Design -> Run Propel SDK or click the Lattice Propel SDK icon in the ribbon to
create and open the firmware project (Figure 4.16).

C

File Edit View Design Tools Window Help

-5 R smEeshomegcglacaaa m

Figure 4.16. Lattice Propel SDK Icon

2. Inthe Lattice Propel Launcher dialog box, click Browse and navigate to the directory created for the SoC and C
projects in the Create SoC Project in Lattice Propel Builder section, step 1 (Figure 4.17).

6 Lattice Propel Launcher X

Select a directory as workspace

Lattice Propel uses the workspace directory to store its preferences and development artifacts.

Workspace: |C:\Iscc\projects\Sentryri_D V| | Browse...

[] Use this as the default and do not ask again
b Recent Workspaces

Launch Cancel

Figure 4.17. Lattice Propel Launcher — Select Directory for Creating SoC and C Project

3. Lattice Propel SDK is launched from Propel Builder. The tools automatically locates the sys_env.xml file, which is

located in the sge folder of the SoC Project directory, and associate the C project with this SoC file. This ensures the

addresses and IP drivers align. If the tools do not automatically locate the sys_env.xml file, click Browse, located
next to the System env text box, and navigate to the sys_env.xml file manually.

4. Enter a project name for the firmware project and click Next (Figure 4.18).
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S C/C++ Project

Load System and BSP

Load lattice systermn environment file and B5P package

Select system environment file and BSP package

System emv: | Ciflscc/projects/Sentryd_0fsentryd_0_soc/sentryd_0_soc/../sge/sys_envxml

Select processor core to create C/C++ Project

Core selected: | ucpul_inst

Project type:  |C

System information

Browse...

Device Family CPU Mame
LFMHO5 riscv_rtos

Instance Mame

ucpul)_inst

Project name: sentr_\,f4_0_c|

Use default lecation

Choose file systern: | default

[ Build the project

Location: | Chlscc\projectsi\Sentryd_Ohsentryd 0_c

Create a debug launch configuration for  OpenOCD

Browse...

@ < Back Finish

Cancel

Figure 4.18. Create Firmware Project

5. Inthe following dialog box, keep the default options and click Finish.

6. The firmware project is generated in Lattice Propel SDK.

7. Select the firmware project from the Project Explorer view and click the Build icon to build it (Figure 4.19).
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i Sentryd_0 - Lattice Propel

File Edit Source Refactor Navigate Search Project Run LatticeTools Window Help

mriul s Rl @-s-E-6- -0 @~
: A =

- v T v] »

(- Project Explorer X ==

> I% sentryd 0_c

Figure 4.19. Build Firmware Project

8. The project should be built without errors.
9. The.mem file generated when the project is built is located in the following directory (Figure 4.20):

< Workspace>/<C Project>/Debug/<project_name>.mem

M 5 | Debug = a X
Home Share View o
<« v « lscc » projects > Sentryd 0 > sentryd 0 c > Debug v &  Search Debug L
Microsoft Teams Chat Files o Name Date modified Type Sze
= Pictures src 7/2/2024 2241 PM File folder
Videos || makefile File 4
B This pC |] objects.mk MK File
aa ) | sentry4_0_c.bin BIN File 63
) 3D Objects y o
| sentryd_0_c.elf ELF File 430
I Desktop ] sentryd_0_clst LST Fite 1477
| Documents ] sentryd_0_c.map MAP File 324
& Downloads | | | sentryd 0_c.mem MEM File 158
D Music | sources.mk MK File
& Pictures

Figure 4.20. Location of Firmware .mem File

10. This.mem file needs to be signed using an image signing tool, before being programmed through the provisioning
flow. See Sign the Firmware File and Program MachXO5-NX LFMXO5-55TD Device with the Provisioning Tool
sections for more details.
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5. Importing SoC and C Projects from Existing Project

This section describes the workflow to import existing SoC and Firmware projects into a fresh workspace. It should be
used if one is working on a design which has components or firmware added on top of the base template.

5.1. Create a Blank Workspace

1. Create a project directory for the SoC and C projects locally on your computer (Figure 5.1).

= | projects
“ Home Share View
v 4 » ThisPC » Windows (C:) » Iscc » projects v O Search projects
Videos ) Name Date modified Size
3 This PC Sentryd 0 7/2
¥ 3D Objects Sentryd_0_import 7,
I Desktop
| Documents
4 Downloads
D Music

Figure 5.1. Project Directory for Importing SoC and C Projects

2. Ensure that the directory from which you are importing the SoC project is correct.

5.2. Import SoC Project into Workspace
1. Launch Lattice Propel SDK 2024.1.

2. Inthe Lattice Propel launcher, click Browse and navigate to the directory created in the Create a Blank Workspace
section, Step 1 (Figure 5.2).

$ Lattice Propel Launcher d

Select a directory as workspace

Lattice Propel uses the workspace directory to store its preferences and development artifacts,

Workspace: |C:\Iscc\projects\Sentr}rrl_D_import V|E Browse... i

[] Use this as the default and do not ask again

» Recent Workspaces

Launch Cancel

Figure 5.2. Lattice Propel Launcher - Select Directory for Importing SoC and C Projects

3. Inthe Project Explorer view, click Import projects, or choose File -> Import Projects from the menu (Figure 5.3).
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3 Sentryd_0_import - Lattice Propel

File Edit Source Refactor Mavigate

Search  Prof

To add a project:

ﬁv = II| ?{b:-v-'.‘_‘v @v 537 lﬁve
[ Project Explorer = =)
BES Y §

There are no projects in your workspace.

Create a new Lattice SoC Design

Project

Q Create a new Lattice C/C++ Project

ﬁ Create a project...
£2g |mport projects...

Figure 5.3. Import Projects

4. Inthe Import window, select Lattice Propel -> Lattice SoC Design Projects into Workspace. Click Next (Figure 5.4).

$ Import

Select

Import Lattice SoC Design projects into the workspace.

O >

225

Select an import wizard:

| type filter text

> [= General

» = CfC++

» = Git

3 [ Install

w [ Lattice Propel
$ Lattice C/C++ Projects into Workspace
4, Lattice S5oC Design Projects into Workspace

» [= Qomph

> = Run/Debug

» [= SVEditor

» [ Team

» [= XML

®

Finish Cancel

Figure 5.4. Import SoC Design Projects into Workspace
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5. Click Browse next to Select Root Directory and navigate to the directory which contains the SoC project to be
imported. Click Select Folder (Figure 5.5).

3 Select Folder

L » ThisPC » Windows () » lscc > projects » Sentryd 0 v O Search Sentry4_0 P
Organize +  Mew folder = (7]

Meetings A Mame Date modified Type Size
Microsoft Teams Chat F metadata File folder
&=| Pictures

sentryd 0_c File folder

Videos sentryd_0_soc File folder

[ This PC
. 3D Objects
[ Desktop
[Z] Documents
4 Downloads
b Music
=] Pictures

B Videos

s Windows (C) v

Folder: |

Select Folder Cancel

Figure 5.5. Workspace with SoC Project to Import

6. The Import tool automatically identifies the SoC project (Figure 5.6). If the SoC project does not show up in the list,
make sure that the SoC project’s outer directory folder ends with the characters “_soc,” and repeat Steps 3-6.

3% Import O >
Import Lattice SoC Design Projects
Select a directory to search for existing Lattice 5oC Design Projects.
Select root directory | Clscchprojectsi\Sentryd 0 V| | Browse...
Projects:
sentryd 0 _soc (Chlscchprojectsh\Sentryd_Ohsentryd 0 soc) Select All
Deselect All
Refresh
?\ < Back Mext = Finish Cancel

Figure 5.6. Identify Lattice SoC Design Projects
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Select the SoC project and click Finish.

The SoC project directory shows up in the Project Explorer view.

Select the SoC project and click the Propel Builder icon to open the SoC project in Lattice Propel Builder.
10. The SoC project opens in Lattice Propel Builder (Figure 5.7).

. Propel Builder [Ci/lsce/projects/Sentry4_0/sentry4_0_soc/sentry4_0_soc/sentry4_0_soc.shx] Device: LFMX05-55TD-8BEGA00C Board: Lattice Sentry 4.0 Demo Board(4)

File Edit View Design Tools Window Help

[ s >

FEA OCHA BNEG

L3 T aeaea .

Design View m] Schematic Address & start Page
I3 LFMXO5-55TD-88BGA00C =

-
= 1 centryd 0 soc & |_
= £ Instances |
1k ahbl2apbi_inst — 0
1 ahbl_interconnect0_inst
i} apb_interconnect] _inst ;E

TF axi2ahbl0_inst

Ik expr0_inst
IF expr_i_inst
IF expr2.inst
I flexible_pll_inst
TF i2c_filterd_inst
ﬂ i2c_filter1_inst

TF axi_interconnect0_inst )
IF bmc_program_gpiol_inst

1
IF clock_management0_inst

1 i3c_controllerl_inst
1F lattice_esfb0_inst
1 osc_crel_inst

I plio_inst

IF gspi_menitorD_inst

IF qspi_streamer0_inst

IF sgpio_masterD_inst
1F smbus0_inst

i smbusl_inst

TF temOiinst

ZF ucpul_inst

» 25 Ports

fv v v v v v v v v vvvvvvvwrowrvrwwoworw

Properties

Name:  sgpio_master0_inst

Type: Instance

Path: sentry4 0_soc/sgpio_master0_inst
VLNV: latticesemi.com:ip:sgpio_master:1.1.0 _%

|
r
IP Catalog Design View d
Tel Console
INFO <2359 Port width does not match for port 'AWID' in interface 'axi_interconnect0_inst.RXI_500' and interface 'ucpul_inst.AXI M DATA'
INFO <2359 Port width does not match for port 'BID' in interface 'axil_interconnect0_inst.RXI_S500' and interface 'ucpul_inst.AXI M DATAR'
INFO <2359992> - Port width does not match for port 'RID' in interface 'axi_interconnect0_inst.RXI_500' and interface 'ucpul_inst.AXI M DATA'

%

Figure 5.7. SoC Project — Imported

11. Choose File -> Save or click the Save icon to save the SoC project (Figure 4.9).
12. Choose Design -> Validate or click the Validate icon to validate SoC project (Figure 4.10).

13. Choose Design -> Generate or click the Generate icon to generate the SoC project (Figure 4.11).

14. Follow the steps in the Generate Bitstream in Lattice Radiant Software section to open the SoC project in Lattice

Radiant and generate a bitstream.

5.3. Import C Project into Workspace
1. Launch Lattice Propel SDK 2024.1.

2. In Lattice Propel Launcher, click Browse and navigate to the directory created in the Create a Blank Workspace

section, Step 1 (Figure 5.2).

In the Project Explorer view, click Import projects, or choose File -> Import Projects from the menu (Figure 5.3).

In the Import window, select Lattice Propel -> Lattice C/C++ Projects Into Workspace. Click Next (Figure 5.8).
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% Import O >

Select

Import Lattice C/C++ projects into the workspace, @

Select an import wizard:

| type filter text |

3 = Gerneral

» = C/C++

» = Git

» [= Install

w = Lattice Propel
g Lattice C/C++ Projects into Workspace
4. Lattice SoC Design Projects inte Workspace

» = Qomph

» [= Run/Debug

3 [= SVEditor

» (= Team

» (= KML

@ < Back Finish Cancel

Figure 5.8. Import Lattice C/C++ Projects into Workspace

5. Click Browse next to Select Root Directory and navigate to the directory which contains the C project to be
imported. Click Select Folder (Figure 5.9).

© 2025 Lattice Semiconductor Corp. All Lattice trademarks, registered trademarks, patents, and disclaimers are as listed at www.latticesemi.com/legal.
All other brand or product names are trademarks or registered trademarks of their respective holders. The specifications and information herein are subject to change without notice.

FPGA-UG-02217-1.1 23


http://www.latticesemi.com/legal

IL.Jitet:cGeL;‘aizr;try 4.0 MachX05-NX LFMX05-55TD Walkthrough Guide :..LATT’CE

7% Select Folder X
1 > This PC » Windows (C) » lscc » projects » Sentryd 0 v | & Search Sentryd 0 p-l
Organize + New folder e [7]

Meetings 2 MName Date modified Type Size

Microsoft Teams Chat F metadata

[&] Pictures sentryd 0 ¢

2024 2:11 PM File folder
/2024 2:19 PM File folder
Videos sentryd 0 _soc 7/3/2024 7:05 PM File folder

3 This PC
. 3D Objects
[ Desktop
Documents
‘ Downloads
J’! Music
[&=] Pictures
B videos
22 Windows (C) v

Folder: | ‘

Select Folder Cancel

Figure 5.9. Import C Project into Workspace

6. The Import tool automatically identifies the C project, as shown in Figure 5.10.

@ Import O x
Import Lattice C/C++ projects =
Select a directory to search for existing Lattice C/C++ projects, 7

Select root directory: | Chlscc\projectsh\Sentry4 0 w | Browse...
Projects:

sentryd 0_c (Chlscch\projects\Sentryd Ohsentryd 0 c) Select All

Deselect All
Refresh

® < Back Mext = Cancel

Figure 5.10. Identify Lattice C/C++ Projects
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7. Select the C project and click Finish.
8. When a dialog box pops up to ask about overwriting .setting, click Yes to All (Figure 5.11).

£t Question x

Overwrite 'settings' in folder 'sentryd 0_c'7

es Yes To All Mo Mo To All Cancel

Figure 5.11. C Project Import Settings Question

9. The C project directory shows up in the Project Explorer view.
10. Select the firmware project in the Project Explorer view and click the Build icon to build it (Figure 4.19).
11. The .mem file generated when the project is built is located in the following directory (Figure 4.20):

< Workspace>/<C Project>/Debug/<project_name> mem

12. This .mem file needs to be signed using an image signing tool, before being programmed through the provisioning
flow. See the Sign the Firmware File and Program MachXO5-NX LFMXO5-55TD Device with the Provisioning Tool
sections for more details.
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6. Project Workflow

As changes are made to the C or SoC projects, this workflow must be followed to update other pieces of the project.

6.1. Lattice Propel SDK Workflow

If any updates are made to the C project, after building the project, the .mem file must be signed with an image signing
tool and the device can be re-provisioned with the new firmware using the Provisioning Tool.

6.2. Lattice Propel Builder Workflow

If any updates are made to the SoC project in Lattice Propel Builder, the project must be re-generated in Lattice Propel
Builder. Then, Synthesis/Map/PAR/Export must be rerun in Radiant.

If modifications made to the SoC project in Lattice Propel Builder causes the memory map to change, such as adding or
removing a component, the Lattice Propel SDK firmware project must be updated.

To update the Lattice Propel SDK firmware project:

1. Inthe Project Explorer view of Lattice Propel SDK, right-click on the C project and choose Update Lattice C/C++
Project... (Figure 6.1).

8 Sentry4_0 - sentry4_0_c/src/main.c - Lattice Propel

File Edit Mew » WNindow Help
milhg Go Into AL =] "*’d: Ny %
Open in New Window
1 Project Show In Alt+Shift+W >
- Ty <
ez sen Paste Ctrl+¥  hg_object binding_object;
¥ Delete Delete
Remove from Context Ctrl+Alt+Shift+Down  Bnce s_sgpio master®;
sgpio_ctrl test;
Source v F1 sgpio_ctrl_test;
Move... | instance i3cme@;
Fehron =] | instance i3cml;
fag  Import... .
tance pfr_instance;
9 Export.. tance *pfr_inst = &pfr_instance;
Build Project gtus_t user_image_status = {@};

Clean Project log_info log_info;

Refresh F5 | create(struct st_pfr_instance *pfr_inst)

Close Project
g_device_family = DEVICE_FAMILY;

Close Unrelated Project version = PFR VERSION:
Build Configurations >
Build Targets » psole X [T Properties| & Terminal w‘ &4 4 <§>|
Index >
format=herkeley "sentry4_@_c.elf”
Q Runis » dec hex filename
111888  1b4ce sentry4 @ _c.elf
45 DebugAs * Y4 e c.siz
Profile As >

Memory Deployment
-0 binary --gap-fill @ "sentry4_@_c.elf" "sentry4_@ c.
Create Lattice Application Template able Header -Output "sentry4 @ _c.mem" -MEM 32

Update Lattice C/C++ Project... y4_B_c.mem
#7 Run C/C++ Code Analysis
Team N

Compare With »

Restore from Local History...

® errors, 6 warnings. (took 9s.156ms)

Figure 6.1. Update Lattice C Project

2. Inthe Update System and BSP dialog box, click Browse next to New System Env and navigate to the following file
(Figure 6.2):

< Workspace >/< SoC Project >/sge/sys_env.xml
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5 Open s
&« v s ThisPC » Windows [C:) » Iscc > projects > Sentryd D > sentryd 0 soc > sge » v || | Searchsge Lo
Organize = Mew folder EEEN (I 0
- <7xm] versijon="1.0"
Meetings A Name Date modified o encoding="utf-8"7> ¢
Mi ft Te Chat E . <lattice:systemEnv
\crosott feams £ha application File xmIns :ipxact="http://www.accellera
| Pictures be, Eile -0rg/XMLSchema/IPXACT/1685-2014"
P xmins:lattice="http://www. lattices
Videos soc_svd File emi.com/lattice"s
e | i <lattice:system>
[ This PC L= L <lattice:general>
= <lattice:vendor>
2D Objects Tattice</lattice:vendor>
- <lattice:Tibrary>
[ Desktop Propel</lattice:library>
— <lattice:name>sentryd_
| Documents O_soc</lattice:name>
ly Downloads <lattice:version=2024.1</Jattice:v
ersion>
& Music <lattice:deviceFamily=
- LFMX05</Tattice:deviceFamiTy>
&=/ Pictures
m Videos <lattice:templateName>*</lattice:t
emplateName> : . b .
w5 Wi : <lattice:bspLocation>
L TS wf< > heneTarricashont Aot
File name: |sysienv.xm| w | *xml v

Figure 6.2. Directory Location of sys_env.xml

3. Click Open.
4. Check the checkbox next to Re-generate toolchain parameters and linker script (Figure 6.3).

03 C/C++ Project = O X

Update System and BSP

Select system environment file and BSP package

Current System enw: | C:flscc/projects/Sentryd_0/sentryd_0_c/src/sys_env.aoml |

MNew Systemn enw: | C:flscc/projects/Sentryd_0/sentryd_0_soc/sge/sys_envxml | Browse...

Re-generate toolchain parameters and linker script
Update BSP package

Update BSP Driver Information

Driver Mame Current [P Version (Driver Version) Mew [P Version (Driver Version)
riscv_rtos 2.4.0(24.0) 2.4.0(24.0)

gpio 1.6.2 (1.6.2) 1.6.2 (1.6.2)
axil_clock_management 1.1.0 1.1.0

i2c_filter 1.3.0(1.3.0) 1.3.0(1.3.00

i2c_filter 1.3.0(1.3.0) 1.3.0(1.3.00
i3c_controller 3.3.001.00) 3.3.00.00)
Lattice_RoT_ESFB 2.0.0 (1.0.0) 2.0.0 (1.0.0)
gspi_meonitor_top 2.00 2.00
gspi_master_streamer_ax... 2.00 2.00

sgpio 1.1.0 1.1.0
smbus_mailbox 2.2.0(2.2.0) 2.2.0 (2.2.0)
smbus_mailbox 2.2.0(2.2.0) 2.2.0 (2.2.0)

Update Cancel

Figure 6.3. Update System and BSP

5. If the checkbox for Update BSP Package is checked, all firmware driver files in the BSP directory are replaced with
the default firmware drivers provided by the IP Catalog. Any changes that have been made to any files in the BSP
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directory are overwritten. Checking this checkbox also updates sys_platform.h with the addresses and other
macros associated with the most recently generated Lattice Propel Builder SoC project.

6. If changes have been made to any files in the BSP directory, make a backup copy of these files before checking the
checkbox for Update BSP Package. After updating the system and BSP, manually replace the default firmware driver
files with the backup ones.

Click Update.
Now that the C project has been updated. Refer to Lattice Propel SDK Workflow.

6.3. Lattice Radiant Software Workflow

If modifications are made to the constraints or HDL code in Lattice Radiant software, the Synthesis/Map/PAR/export
process must be rerun. This is the final step in the project build process. No updates to Lattice Propel SDK or Lattice
Propel Builder are necessary.
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7. Policy Editor

The Policy Editor is a GUI-based tool accessible from Lattice Propel SDK. It is used to set the customer keys, customer
lock settings, and customer policy settings. It generates a customer_policy.bin file which is programmed into the
MachX05-NX LFMXO05-55TD device using the Provision Tool. A sample customer_policy.bin file is provided in the
Provision Tool directory.

1. Launch Lattice Propel SDK and open the current workspace.

2. From the menu, select Lattice Tools -> Lattice RoT Tools for MachX05-55TD -> Policy Editor, as shown in
Figure 7.1.

Q Sentryd 0 - sentryd 0_c/src/main.c - Lattice Propel
File Edit Source Refactor Mavigate Search Project Run | LatticeTools  Window Help

'.-j'J_u u|®vﬁv@5@@% » ‘T Open Design in Propel Builder ' v
By Project Explorer X # Generate and Open Diamond Project <:‘=={-> Y 8 =0

® get_dryrun_customer_resault{uint8_t) : int Generate and Open Radiant Project

® get_mctp_i3c_phase(void) : mctp_idc_phase_e Lattice Sentry Tools for MachX0Q3D »

@ gpic_BOOT_T_MINUS_Oistruct st_pfr_instance®) : voic Lattice Sentry Tools for Mach-NX >

@ gpic BOOT_T MINUS Tistruct st_pfr_instance®) : voic Lattice Sentry Tools for MachX05-55TD 3

® gpio_pfr_ctrl(struct st_pfr_instance®, bool) : void -

Lattice RoT Tools for MachX03-35T0 ¥ Policy Editor

4® i3c_hub_configure_at_first_boot() : void
4@ i3c_master_hotjoin_cb(void*) : uint8_t Demo GUI
® i3c_metp_send(struct i3c_master_instance®, uintd_t*, uintd_t) : uintd_t

4® i3chwrite_nbytes(const unsigned char®, uint8_t) : void

Figure 7.1. Open Policy Editor

3. The Policy Editor GUI opens (Figure 7.2).

3 Lattice Customer Policy Editor - o X
Configuration Output
Test Mode Permit Num of KAK keys is set to 8,
Dprovision  FCuT 0 Customer UFM Start Address(Hex) in Bytes  Customer UM Size{Hex) in Sectors
[ 00f00000 2 0000001e
Image Auth method |ECDSA384-1 ~ ff 0016000 0000001e
Number of KAK keys |8 =1 B 00f3000 0000001e
3 0053000 0000001e
Num of UFM sectors & il 0078000 0000001e
M Zeroization £ Nullification 5 0096000 0000001e
Image Min Ver(Hex) 00000000 | 1 ¢ o000 Somote
—l 7 00fd2000 0000001e
[ Sentry Flag
Sentry FW Min Ver(Hex) 00000000
Y—_——
Customer Keys(Her) 3 Customer Lock
KAK public key hash{0] | D287FEBC3 E61C38CA2A EE0507C6C914DBCCFAA79368C0IC | |Input Public Key | Clear Bl Customer JTAG port to ESFB Lock |G:nolock
KAK public key hash{1] | DADESDDA23F6304BEF 543C19634F TD7BDEC SETASCAATOSFIALCTA3FASD 1 | |Input Public Key | | Clear JIl Customer Policy Sector Erase Lock G:nolock v
KAK public key hash(2] | FCTCFE67SB9FF 3F366EAB42D1FATETTAL00; 27151ESEB09DEAE3TEAABT1A28504DCAAZSEBBE 16BEO00000000000000K] | Input Public Key | | Clear | Jff§ Customer Data UFM[D] Erase Lock (& nolock
KAK public key hashi3] | 10CAEF84D7525800C 52785087 1E3E873331F8 1E6D2AAD3322606 DAOFAEDIICAE2TODALF MESEOF6F B236967245B640C0000000000000000] | Input Public Key | | Clear | [[f Customer Data URMI1] Erase Lock (Ginolock
KAK public key hash(4] | 75375¢ 102893C 1002F1DB122159317CTC16B4AFO0BASOAF 2BT03 154CBFTAI3IBASCETOTAATBAC | [input PublicKey] [[Ciear] [ €U2tom Ots UFM2) Erase Lock [Gimofock
5 r = . - — o == = 1 Customer Data UFM3] Erase Lock G:nolock
KAK public key hash(5] | SAD236B3E0CTSD4F2D, 11869C0DISIVATE: 6820221 4D Input Public Key | Clear
Customer Data UFM[4] Erase Lock O:nolock v
KAK public key hash{6] | DOAC008SCDO44€1893F 1CFBC23E 106EDAMEBDAC2058ALFTFDI1ET01FAC214500000000000000( | Input Public Key | | Clear
= 4 Customer Data UFM[S] Erase Lock |G:nolock v
KAK public key hash{7] | 603362A8CFEFID396EEAC, 521BA0 1357ECC65395850C | Input Public Key = Clear
Customer Data UFMI6] Erase Lock |G:nolock v
MRK public key hash{0] | 774942484, TAC2FDTEFC TEBDAC13A69891319FE34FC | Input Public Clear
Bubfichey bty | - &9 Customer Data UFM(T] Erase Lock @ nolock
UFM AES Key Salt | S0E01AAOF89C323CEEAEAGO307F DES2EF 1 TAGC00095A362997T7468A68D74DAE ] Clear
er User Image
JencryptimageOnly D
Image AES key | 1F1316A7550261238563EC 7260D9ASBAI15C6SBACE SEABFBEST CIASEDITBF 176 | | Clear
Image ECDSA public key | 6802BE77406C 1CAC23C 126 421307 0880158CBESFOECEDDO23CAAIAFECASEFL] | Clear
Open Generate

Figure 7.2. Policy Editor GUI

Policy Editor includes the following components, as labelled in Figure 7.2:

Area 1 for Configuration Settings, Area 2 for UFM Sector definitions, Area 3 for Customer Keys, Area 4 for Customer
Lock, and Area 5 for Customer User Image. These components are listed below and introduced one by one.
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Configuration Settings (1)

e Test Mode Permit:
If both boxes are checked, the test mode pins (SW4 on the Lattice Sentry 4.0 Demo Board) can be used. If
either box is unchecked, the test mode pins cannot be used to go into that mode, and the board always
boots to Normal Mode. It is recommended to keep these boxes checked during development.

e Image Auth Method:
Authentication method for KAK, ISK, and MRK keys.

e Number of KAK Keys:
You can configure 1-8 KAK keys.

e Number of UFM Sectors:
You can configure 1-8 UFM sectors.

e  Zeroization/Nullification:
Checking these boxes means that zeroization and/or nullification is allowed.

e Image Min Ver:
Minimum bootable SoC image version. Enter 00000000 to allow any SoC image to boot, regardless of
version number. SoC image is set by Lattice Radiant software when the bitstream is generated. By default,
it is the timestamp at the time of bitstream generation.

e Sentry Flag:
Sentry Flag must be checked.

e Sentry FW Min Ver:
Minimum bootable firmware version. Enter 00000000 to allow any firmware to boot, regardless of
version number. The firmware version is an argument given to the image signing tool. If a signed
firmware’s version is lower than the Sentry FW Min Ver in the customer policy, the firmware does not
boot.

UFM Sectors (2)

e Thereis a total of 1 MB reserved for User Flash Memory. You can configure this space however you
choose, in 1-8 UFM sectors.

e The minimum size for one UFM sector is 4 KB, and this unit is also referred to as a sector since it is
essentially a SPI Sector.

e General use UFM begins at address 0xFO0000.

e  For every UFM sector, you can configure the starting address and select how many SPI sectors are
included.

e Inthe default case, all eight UFM sectors are used and they are of equal size, so each UFM sector contains
31 SPI sectors, or 128 KB.

Customer Keys (3)

e You can configure up to eight KAK keys. For each KAK key, you should enter the key and the Policy Editor
GUI calculates the hash. Only the hash is stored on the device, not the key itself.

e  AES Key Salt:
This AES key salt is used to encrypt the UFM content using the AES GCM algorithm.

Customer Locks (4)

e The customer JTAG port, customer policy sector, and each UFM sector can be unlocked, soft locked, or
hard locked.

e Nolock:
The port or sector is fully accessible.
e Soft lock:

The port or sector can be locked and unlocked by the Orchestration FW to perform updates via the ESFB.
e Hard lock:
The port or sector is permanently locked. The port is not accessible. The sector is OTP, read-only.
Customer User Image Key (5)
e The Image AES Key in the Policy Editor must be the same as the AES2 Encryption key used in Lattice
Radiant software’s Bitstream Security Settings, which is used to sign the customer image .bit file.
e The Image ECDSA Public Key in the Policy Editor must be the same as the ECDSA Public Key used in Lattice
Radiant software’s Bitstream Security Settings, which is used to sign the customer image .bit file.
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e The image AES key and image ECDSA public key are used to encrypt and sign the customer SoC and
firmware images, and the config engine uses the same keys to decrypt and verify these images.

4. After adjusting the settings in the Policy Editor, click the Generate button to generate a customer policy .bin file.

5. Place the customer policy .bin file in the Provision Tool directory and use the Provision Tool to program the
MachX05-NX LFMXO5-55TD device with this customer policy file.
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8. Programming and Configuration

8.1. Program the BMC into CertusPro-NX Flash
Option 1: Use DediProg to program the external SPI Flash with the BMC .bit file.
Option 2: Use Lattice Radiant Programmer to program the external SPI Flash.
1. Install the following jumpers to scan the JTAG chain:
JP12,JP19, JP51, JP52, JP53, JP54, JP55, JP56
2. Install the following jumpers to set up the CertusPro-NX device in the JTAG chain:
JP47[1:2], IP48[3:4]
3. Install jumper JP15 to hold the MachXO5-NX LFMXO5-55TD device in reset while the CertusPro-NX device is being
programmed.
4. Set up the jumpers for Flash C:
e  For Flash A: JP39[2:3], JP40[2:3], JP56[2:3]
e  For Flash B: JP39[2:3], JP40[2:3], JP57[2:3]
e  For Flash C: JP33[2:3], JP34[2:3], JP54[2:3]
e  For Flash D: JP33[2:3], JP34[2:3], JP55[2:3]

Figure 8.1 shows the Sentry Demo Board with jumpers for BMC programming marked.
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Figure 8.1. Lattice Sentry Demo Board with Jumpers for BMC Programming Marked
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5. Launch Radiant Programmer.
6. Click the Scan Device icon in the ribbon to scan the device (Figure 8.2).
u Radiant Programmer - Untitled xcf *
File Edit View Run Tools Help
fEmg B R Ty E
Enable Status Device Family Device Operation
1 LFCPNX LFCPNX-100 Fast Configuration
Figure 8.2. Lattice Radiant Programmer Scan Device Icon
Device Family should be LFCPNX and Device should be LFCPNX-100.
Double-click in the Operation field to open the Device Properties dialog box.
In Device Properties, select:
o Target Memory: External SPI Flash Memory (SPI FLASH)
e Port Interface: JTAG2SPI
e Access Mode: Direct FLASH Programming
10. Select Erase, Program, Verify in Operation to open the dialog box.
11. Load the BMC_I2C.bit file to Programming Options: Programming file
Note: Two OOB buses are supported, one over 12C and one over I13C. By default, the Sentry 4.0 firmware uses the
12C bus. To use the I3C OOB bus instead, program BMC_I3C.bit into the CertusPro-NX device and change the
variable assignment pfr_mctp_path = MCTP_OVER_I2C to pfr_mctp_path = MCTP_OVER_I3C in the firmware.
12. Select the following SPI Flash Options (Figure 8.3):
e  Family: SPI Serial Flash
e Vendor: Micron
e Device: MT25QL01
e  Package: 16-Pin SOP2
13. Set SPI Programming Start address (hex) to 0x00000000.

© 2025 Lattice Semiconductor Corp. All Lattice trademarks, registered trademarks, patents, and disclaimers are as listed at www.latticesemi.com/legal.

All other brand or product names are trademarks or registered trademarks of their respective holders. The specifications and information herein are subject to change without notice

FPGA-UG-02217-1.1

33


http://www.latticesemi.com/legal

Lattice Sentry 4.0 MachXO5-NX LFMXO05-55TD Walkthrough Guide

User Guide

= LATTICE

£3 LFCPNX - LFCPNX-100 - Device Properties ? X
General Device Information
Device Operation
Target Memaory: External SPI Flash Memory (SPT FLASH) '
Port Interface: JTAG2SPI w~
Access Mode: Direct Programming ~
Operation: Erase,Proagram,Verify ~
Programming Options
Programming file: Lcmr Cnrpreskb:pISEﬂh'H.D_JunSDJ’BMC;’BMC_IZC.bit| voa| [OnAZED
SPI Flash Options
Family: SPI Serial Flash W
Vendaor: Micron w
Device: MT250L01 ~
Package: 16-Pin SOP2 ~
SPI Programming
Data file size (Bytes): 2555304 | [ Load fram File
Start address (Hex): 0x00000000 '
End address (Hex): 000260000 W
[] Turn off addresses auto updating
|:| Erase SPI part on programming error
[] secure 5PI flash golden pattern sectors
oK Cancel

Figure 8.3. CertusPro-NX Device BMC Image Programming Options

14. Click on the Program icon to program the device and wait for a success message (Figure 8.4).

u Radiant Programmer - Untitled.xccf *
File Edit View Run Tools Hel
Hpd s BRE Ry B
Enable Status I Device Family Device Operation
1 LFCPMNX LFCPMX-100 Fast Configuration

Figure 8.4. Lattice Radiant Programmer Program Device Icon

15.

Remove Flash C jumpers and install JP54[1:2]. Leave JP54[1:2] installed while running the demo.
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8.2. Sign the Firmware File
The .mem file generated by Lattice Propel SDK needs to be signed with an ISK private key before being programmed
onto the LFMXO5-55TD device.
The ISK private key must be the same as in the ISK key pair which signed the bitstream in Lattice Radiant software, as
shown in the Generate Bitstream in Lattice Radiant Software section.
The SKP tool can be used to sign the firmware file. The SKP is an internal, Lattice only tool. A customer-facing image
signing tool is currently under development. Alternatively, a custom script or firmware signing tool can be used.
To sign the firmware file using the SKP tool:
1. Copy sentry40_ c.mem file to SKP_Tool_RBP folder.
2. Copy isk384.prv from the SoC project folder to SKP Tool RBP folder.
3. Sign Sentry C binary.
Use SKP tool to sign sentry40_ c.mem file and output RiscVImage.bin.

>> Skp.exe --genpacket --rbp_version "12345678" --ecdsaprvfile "isk384.prv" --
ecdsaprvpwd "LATTICESEMI" --riscvimage "sentry4@_ c.mem" -- keyblob
"keyblob_normal.bin"

8.3. Program MachXO5-NX LFMXO5-55TD Device with the Provisioning Tool

The Provisioning Tool is used to program the customer SoC, Firmware image, UFM, and Customer Policy through soft
JTAG.

Follow the steps below for first-time board provisioning. To reprovision the board with updated images, follow the
steps in the Reprovisioning section.

1. Connect the PC to the HW-USBN-2B cable with a USB cable.

2. Make the following connections between the board and the HW-USBN-2B cable:
e ]6-1 connects to the red(VCC) wire of the HW-USBN-2B cable.
e ]6-3 connects to the white(TCK) wire of the HW-USBN-2B cable.
e J6-5 connects to the orange(TDI) wire of the HW-USBN-2B cable.
e  ]6-7 connects to the purple(TMS) wire of the HW-USBN-2B cable.
e 16-6 connects to the brown(TDO) wire of the HW-USBN-2B cable.
e ]6-2 connects to the black(GND) wire of the HW-USBN-2B cable.

3. Set SW4 pins as follows:
e SWA4.1=0FF
o SW4.2 =0FF
e SW4.3=0FF
e SW4.4=don’t care
4. Power on the board.

5. Theinput files to the Provision Tool are shown in the following Table 8.1.

Table 8.1 Provisioning Tool Input Files

Input Filename Source Description

Generated by the Lattice Propel

iov Locki .
Policy Editor tool. Key, Policy, Lock information

Customer Policy | sentry_customer_policy.bin

Generated and signed by the Lattice

Radiant software. Signed .bit file containing SoC image

Customer Image | <project_name>_impl_1.bit

Generated by Lattice Propel. Then,
<project_name>.bin it is signed by the image signing
tool.

Orchestration
FW Image

Signed .bin file containing firmware
image
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Input Filename Source Description
. Optional data or images to store in the
Customer UFM customer_ufm.bin Generated by the user. UFM sector of the MachXO5-NX device.

Note: If any of these files have been modified, replace them in the Provision_Tool directory.

6.

7.

8.

Run Provision Tool using .bat file:

a. Open sentry_provision_demo.bat for editing and make sure the filenames match the files included in the
Provision Tool directory.

b. Double-click sentry_provision_demo.bat to run the provision flow.

c. Select the correct USB port. The name of the port should have Lattice HW-USBN-2B in it, for example,
Lattice HW-USBN-2B Ch A Location XXX. Input the ID of the port.

Run Provision Tool using the command line:
a. Open Windows command line and navigate to the Provision Tool directory.
b. Execute the following command:

rot_provision_tool.exe -p {Customer Policy bin file} -x {FW Image bin file} -a
{Customer Image bit file} -u {Customer UFM bin file} -m @ -s

c. Select the correct USB port. The name of the port should have Lattice HW-USBN-2B in it, for example, Lattice
HW-USBN-2B Ch A Location XXX. Input the ID of the port.

After provisioning is finished, the system triggers a soft reboot.

8.4. Reprovisioning

After provisioning the board for the first time, subsequent updates are made by reprovisioning.

1.

Connect the Lattice 2B Programming cable to the board and the PC as described in the
Program MachXO5-NX LFMXO5-55TD Device with the Provisioning Tool section, Steps 1-2.

Set SW4 pins as follows:

e SW4.1=0FF
e SW4.2=0N
e SWA4.3=0FF

SW4.4 = don’t care

Power on the board.

Copy over any of the four Provision Tool input files from Table 8.1 into the Provision Tool directory. Note that none
of these files are required. Only the files in need of updating should be included.

Run Provision Tool using the command line:
Open the Windows command line and navigate to the Provision Tool directory.
b. Execute the following command, with optional arguments (Figure 8.5):

rot_provision_tool.exe -p {Customer Policy bin file} -x {FW Image bin file} -a
{Customer Image bit file} -u {Customer UFM bin file}

c. Select the correct USB port. The name of the port should have Lattice HW-USBN-2B in it, for example,
Lattice HW-USBN-2B Ch A Location XXX. Input the ID of the port.
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- Lattice Semicond ~ Cor| B . . on_tool.exe -a Sentry4®

on Tool. Vers

of p
stablished

Figure 8.5. Sentry Provision Tool Reprovision CUA Image

d. After provisioning finishes successfully, execute the following command to set the Provision Done bit
(Figure 8.6):
rot_provision_tool.exe -s

sion_Tool»rot_provision_tool.exe -s

Figure 8.6. Provision Tool Set Provision Done

6. Power cycle the board to boot from the updated image.
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9. Running the Demo and Using Demo Tools

9.1. Basic Demo (UART and LEDs)

After programming the BMC image into CertusPro-NX Flash C and running the Provision Tool to program the customer
image, firmware image, customer policy, and optional UFM into MachXO5-NX LFMXO5-55TD device, the board is ready
to run the demo.

1.

6.

Connect a USB cable between J2 and a PC for UART output from MachX05-NX LFMXO5-55TD. Make sure JP1 and
JP2 are not installed.

Make sure SW4 is set as follows:

e SW4.1=0FF

e SW4.2 =0OFF

e SW4.3=0FF

e SW4.4=don’t care

Power on the board.

Open a serial terminal emulator, such as PuTTY.

Connect to the higher number of the two COM ports. The baud rate is 115200 (Figure 9.1).

% PuTTY Configuration 7 X
Category:
= Sgssinn Basic options for your PuTTY session
B Ter L.l:lglging Specify the destination you want to connect to
?Em}'g:bnard Serial line Speed
- Bel |coms |[115200 |
- Features Connection type:
- Window ()SSH (@ Seral (O)Other: |Telnet v
- Appearance
- Behaviour Load, save or delete a stored session
- Translation Saved Sessions
[+~ Selection |
- Colours
[=)- Connection Default Settings losd
.. Data
- Proy Save
- 55H
- Serial SILE
- Telnet
- Rlagin
- SUPDUP Close window on exit:
() Mways () Never (8 Only on clean exit
About Help Cancel

Figure 9.1. PuTTY Configuration

UART print statements should be visible on the terminal (Figure 9.2).
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EF COMS - PuTTY

Figure 9.2. MachX05-NX LFMXO5-55TD Device UART Output

7. The 7-segment LED should display 4.

8. After the BMC boots, the following LEDs should be on:
e D53, D43, D52, D42, D50, D39, D48, D37
e D25,D26,D27, D28, D29, D30, D31, D32

9.2. Demo GUI

There are two demo GUIs included in the Sentry 4.0 patch. Both can be accessed from Lattice Propel SDK, through the
Lattice Tools menu. The Lattice Sentry Demo GUI in the Lattice Sentry Tools for MachXO5-NX LFMXO5-55TD device
demonstrates PFR functionality. The Demo GUI in the Lattice RoT Tools for MachXO5-NX LFMXO5-55TD device
demonstrates Root of Trust functionality.

The Lattice Sentry Demo GUI connects via UART to the CertusPro-NX device, which represents a BMC in a server
environment. The user selects commands from a menu of options in the GUI. When the user clicks Send Command in
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the demo GUI, the CertusPro-NX (BMC) device sends a read or write command through the OOB channel to the
LFMXO5-55TD device. As the LFMXO5-55TD device executes the command, there may be print statements on
LFMXO5-55TD’s UART terminal. After the command is executed, a success or failure message is sent from the
LFMXO5-55TD device to the CertusPro-NX device, and a message is printed on the Demo GUI console.

Before running the Lattice Sentry demo GUI, make sure all DEBUG macros in the firmware are defined as 1 instead of 0.
This is to ensure verbose UART output from the LFMXO5-55TD Sentry design as it responds to commands from the
BMC through the demo GUI. These macros are located in the firmware file pfr_conf.h (Figure 9.3).

89 #define MAIN DEBUG 1

98 #define 00B_DEBUG 1
91 #define MANIFEST_DEBUG 1

92 #define FLASH_MONITOR_DEBUG 1

93 #define LOG_DEBUG 1
94  #define FLASH_COMMON_DEBUG 1
95 #define FLASH_ID DEBUG 1
96 #define MCTP_DEBUG 1
597 #define SMBUS_MCTP _DEBUG 1

Figure 9.3. DEBUG macros in pfr_conf.h

To run the Lattice Sentry Demo GUI:

1. Connect a USB cable from J2 to your PC and open a serial terminal for the higher number port with baud rate
115200 to connect to the LFMXO5-55TD device.

Connect a second USB cable from J3 to your PC. Do not open a serial terminal for this connection.
Launch Lattice Propel SDK and open the Sentry 4.0 firmware workspace.

From the menu, select Lattice Tools -> Lattice Sentry Tools for MachX05-55TD -> Lattice Sentry Demo GUI
(Figure 9.4).

3 Sentryd0 - Sentry40_c/src/main.c - Lattice Propel
File Edit Seource Refactor Mavigate Search Project Run | LatticeTecls  Window Help
i | Br{rm B & o, . T Open Design in Propel Builder D [~ L =
[t Project Explorer X g ¢ Generate and Open Diamond Project
VT;; Sentryd0_c Generate and Open Radiant Project +3333%> COPYRIGHT NOTICE <c<ccccccce
%“P Binaries Lattice Sentry Tools for MachX03D > s e
- ; 19-2824 by Lattice Semiconductor Cor
[ Includes Lattice Sentry Tools for Mach-NX e 7
5 ste Lattice Sentry Tools for MachX05-35T0 » Lattice Sentry Demo GUI r ------
= Debug .
[¥] SentrydD_claunch o ’ [= LE IS USED BY OR GENERATED BY the
[ 8 // DEVELOPMENT SUITE, WHICH INCLUDES PROPEL BUILDER AND
18 // Lattice grants permission to use this code pursuant
11 // terms of the Lattice Propel License Agreement.
12 7/
13 // DISCLAIMER:

Figure 9.4. Launch Lattice Sentry Demo GUI

5. When the Demo GUI window opens, click Scan Ports (Figure 9.5).
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UART Control

Authenticate Image ~

Command 1D:1

Console Output

8 Lattice Sentry Demo GUI for MachX05-35TD

Image ID
000
<

1=Pri 2=5ec
01

COM3 ~ | [JoFF | 0x01 0x00 0x01 OxFD

Send Command

port list:

Serial port: COM3
Serial port: COME
Serial port: COM7
Serial port: COM4
Serial port: COM3

Clear

Figure 9.5. Lattice Sentry Demo GUI Scan Ports

6. Click the drop-down menu next to BMC and select the lower numbered port for the USB cable connected to J3

(Figure 9.6).

8 Lattice Sentry Dermo GUI f

Console Output

or MachX05-33TD - O >
UART Control
Authenticate Image | | Image D 1=Pri 2=5ec
000 01
Command ID:1 < >
Scan Ports Read Log BMC |COM3 V| [ oFF | 01 000 001 0xFD Send Cemmand

port list:

Serial port: COM3
Serial port: COME
Serial port: COMT7
Serial port: COM4
Serial port: COM3

7. Click the checkbox next to OFF to connect the BMC to the selected port.

8. Make sure a success message is displayed on the Demo GUI console (Figure 9.7).

Figure 9.6. Lattice Sentry Demo GUI Select BMC Port
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% Lattice Sentry Demo GUI for MachX03-35TD — O X
UART Control
Authenticate Image  ~ Image ID 1=Pri 2=5ec
000 Ox01
Command ID:1 = =
Scan Ports Read Log BMC |coms ~ ON | 0x07 0x00 0x01 0xFD Send Command

10.

11.

Conscole Qutput

Send version check cmd OxBC 0x03 000! ~
Response data: 31 02 00
versien numberis 2.0

Sending 12C read command: 0x61 0x00
Response data: 31 00 DE
CPLD RoT Static Identifier: DE

Sending 12C read command: (eB1 001
Response data: 31 01 01
CPLD RaT Release Version: 01

Sending 12C read command: 0x61 0x02
Response data: 31 02 02
CPLD RoT SWN: 02

Sending 12C read command: 063 Cx0d
Response data: 31 04 00 FF FOOF1 00
version support: 00 FF FOOFT 00

Open port COMB successfully!

Clear

Figure 9.7. Lattice Sentry Demo GUI BMC Connection Success

Select an OOB command from the drop-down menu under UART control. Modify the command options as desired.

Click Send Command to prompt the BMC to send a UART command to the LFMXO5-55TD device. In this example,

the Authenticate Image command has been sent, with the options of Image ID 0 and Primary Image (0x01).

After the command is sent, data should be displayed on the LFMX05-55TD serial terminal from UART print
statements. A Done/Success message should be displayed on the demo GUI terminal (Figure 9.8).
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ac — O X
UART Control
Authenticate Image | | Image (D 1=Pri 2=5ec
0x00 01
Command ID:1 = =
Scan Ports Read Log BMC | come v [ZON | 0x010x00 0xD7 OxFD Send Command

Console Output

Response data: 31 00 DE
CPLD ReT Static |dentifier: DE

Sending 12C read command: (w61 (w01
Response data: 31 0101
CPLD ReT Release Version: 01

Sending 12C read command: (x61 (w02
Response data: 31 02 02
CPLD ReTSVN: 02

Sending |12C read command: (x63 (x4
Response data: 31 04 00 FF FOF1 00
version support: 00 FF FOF1 00

Open port COME successfully!

Sending 12C write command: (01 000 001 0xcFD

Response data: 3001 00 FE
Command: 01 Status: 00 Done/Success

Clear

Figure 9.8. Lattice Sentry Demo GUI Send Command

12. Click Read Log to view the most recent log entry. Continue clicking Read Log to view earlier log entries

(Figure 9.9).

ach - O X
UART Centrol
Authenticate Image | | Image D 1=Pri 2=5ec
0x00 001
Command ID:1 < >
Scan Ports Read Log BMC | came ~ oM 0%01 0x00 001 OxFD Send Command

Censele Qutput

Response data: 31 01 01
CPLD RoT Release Version: 01

Sending 12C read command: 0x61 0x02
Response data: 31 02 02
CPLD RoTSVN: 02

Sending 12C read command: 0x63 0x04
Response data: 31 04 00 FF FO F1 00
wversion support: 00 FF FOF1 00

Open port COME successfully!

Sending 12C write command: (k01 0x00 0x01 0xFD

Response data: 30 01 00 FE
Command: 01 Status: 00 Done/Success

Reading log...
Response data: 31 04 00 00 00 0101 00 00 00 00 00 00 FF F4

Logindex:10 Event: Authenticate Img|D: 0 Pri/Sec: 0 Auth Pass/ Vers Pass/ Timestamp: 0:0:0  Last log index: 255

Clear

Figure 9.9. Lattice Sentry Demo GUI Read Log

13. Some Demo GUI commands require Secure OOB mode. To enter Secure OOB mode, select Enable Secure Session
from the UART Control drop-down menu (Figure 9.10).
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UART Contrel

8 Lattice Sentry Demo GU| for MachX03-55TD

Authenticate Image a | 0x00
Recover Image <
Clear Leg

Authenticate Imageii¥d ||mage\D

1=Pri 2=5ec
0x01

Enable SPI Filter
Select Flash
Read Time

Set Time

Read IRQ

Exit Secure Mod.
Enable Secure
Enable JTAG Debug
EEPROM Byte Write
EEPROM Page Write

on

BMC |coms  ~ [Zon |0x010x000x010xFD

Send Command

EEPROM Byte Read b1 .
EEPROM Page Read
Flash Mode Select .
Flash Sector Erase p: 0x61 0x02
Flash Chip Erase
Flash Page Write
Flash Byte Write .
Flash Page Read ‘;60:163000}{04
Flash Commen Crnd 00
Flash Common Read v |
=—r ly
Sending 12C write command: 001 Cx00 0x01 0xFD
Response data: 3001 00 FE
Command: 01 Status: 00 Done/Success
Reading log...
Response data: 31 0A 00 00 00 01 01 00 00 00 00 00 00 FF F4
Logindex:10  Event: Authenticate |mgID: 0 Pri/Sec:0 Auth Pass/ Vers Pass/ Timestamp: 0:0:0 Last log index: 253
w
Clear
Figure 9.10. Lattice Sentry Demo GUI Enable Secure Session
14. Change the input argument to 0x02 to use ECDSA-384 authentication (Figure 9.11).
% Lattice Sentry Demo GUI for MachX05-55TD — m] x
UART Contrel
=
0x02]
Command ID:209 = =
Scan Ports Read Log BMC  coms v| Zon | DxD10x02 Dx2C Send Command

Censole Output

Response data: 3101 01
CPLD RoT Release Version: 01

Response data: 31 02 02
CPLD ReT SVM: 02

Response data: 31 04 00 FF FO F1 00
version support: 00 FF FO F1 00
Open port COME successfully!

Response data: 30 01 00 FE

Reading leg..

Log index:10  Event: Authenticate

Sending 12C read command: (w61 (02

Sending 12C read command: 0x63 (04

Sending [2C write command: 0x01 000 0x01 0xFD

Command: 01 Status: 00 Done/Success

Respense data: 31 04 00 00 00 01 01 00 00 00 00 00 00 FF F4

ImgID: 0 PrifSec: 0 Auth Pass/ VersPass/ Timestamp: 0:0:0 Last logindex: 255

Clear

Figure 9.11. Enable Secure Session Options

15. Click Send Command.

16. Wait for a Done/Success message to appear on the Demo GUI console. Now Secure OOB mode is enabled and all
commands can be run (Figure 9.12).
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G Lattice Sentry Demo GUI for MachX0

UART Contrel

Enable Secure Sessio | | 2=En 384

w02

Command I0:209

ScanPorts | Readlog BMC [coMé  ~| Hlon |0xD1 0x02 0x2C ‘ [ Send Command

Console Qutput
CPLD RoT SVN: 02 A

Sending 12C read command: (k63 0x04
Response data: 31 04 00 FF FO F1 00
wversion support: 00 FF FO F1 00

Open port COME successfully!
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Figure 9.12. Lattice Sentry Demo GUI Secure OOB Mode Enabled
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10. Troubleshooting

10.1. Verification Error in Lattice Radiant Programmer

Problem Description: The following error message shows during programing devices in Lattice Radiant Programmer.
ERROR - Verification Error...when Processing function: 'CHECK_ID'

Solution: Select Use custom Clock Divider and change the TCK Divider Setting to 5.

10.2. SoC Project Does Not Fully Generate

Problem Description: Lattice Propel Builder generates a blank project, or a project with components missing.

Solution: Make sure the correct version of all IPs are installed in Lattice Propel Builder before generating the project.
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Technical Support Assistance

Submit a technical support case through www.latticesemi.com/techsupport.

For frequently asked questions, please refer to the Lattice Answer Database at
www.latticesemi.com/Support/AnswerDatabase.
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Revision History

Revision 1.1, April 2025
Section Change Summary

In the Software Requirements section:

e  added links of Lattice Propel 2024.1 for Windows and Lattice Propel 2024.1 for Linux for
users to download Lattice Propel 2024.1;

Required Tools e added links of Lattice Radiant 2024.1 for Windows and Lattice Radiant 2024.1 for Linux
for users to download Lattice Radiant 2024.1;

e added instructions for users to contact Tech Support to get Lattice Sentry Patch,
Lattice Radiant Control Pack XO5D, Provision Tool, and Image Signing Tool.

Revision 1.0, July 2024
Section Change Summary

All Production release.
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