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service without notice and assumes no obligation to correct any errors contained 
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Type Conventions Used in This Document
Convention Meaning or Use

Bold Items in the user interface that you select or click. Text that you type 
into the user interface.

<Italic> Variables in commands, code syntax, and path names.

Ctrl+L Press the two keys at the same time.

Courier Code examples. Messages, reports, and prompts from the software.

... Omitted material in a line of code.

.

.

.

Omitted lines in code and report examples.

[ ] Optional items in syntax descriptions. In bus specifications, the 
brackets are required.

( ) Grouped items in syntax descriptions.

{ } Repeatable items in syntax descriptions.

| A choice between items in syntax descriptions.
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Analyzing Power Consumption

Lattice Radiant Power Estimator analyzes the power consumption of Lattice 
Semiconductor FPGA devices. It provides the functions of Power Calculator 
in Estimation mode. The tool uses parameters such as voltage, temperature, 
process variations, air flow, heat sink, resource utilization, activity, and 
frequency to calculate the device power consumption.

In this document, Power Estimator is referred to as Power Calculator (in 
Estimation mode).

Starting Power Estimator

Power Estimator is available from the Windows Start menu. You can run 
Power Estimator without having to install or open the Lattice Radiant 
software.

The Power Calculator - Startup Wizard enables you to create a new project 
based on a selected device or to open an existing project file (.pcf).

 To estimate power consumption based on a selected device, select 
Estimate power with device selection.

Type a name for the project file in the File Name box and browse to the 
desired directory for the project. Make your selections from the device 
menus.

The device selection menus appear at the bottom of the Startup Wizard. If 
you are using Avant, the Power Screen field becomes available and 
allows you to select power screen limits based on your device. This 
feature sets the maximum static leakage current your device will consume 
when tested by Lattice Semiconductor. Please work with Lattice Sales to 
confirm that this setting is suitable for your FPGA project. 
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If you would like to use a template of resource settings, select the Use 
Template option, click Select, and do one of the following:

 Select Specify Resource by Design Type, and then select the 
design type from the drop-down menu and click OK.

 Select Specify Resource by Component Utilization, and then select 
from the options provided and click OK.

The Use Template text box displays the resource settings or the design 
type that you selected.

When you click OK, Power Calculator opens and loads the device settings 
you specified.

 To open an existing project, select Open existing PCF file. 

Click the Browse button to navigate to the .pcf file and click OK.

When you click OK, Power Calculator opens. 

Inputs
When you first launch Power Estimator, it shows default resource information 
based on the targeted device. 

Additionally, Power Calculator accepts the value change dump file as optional 
input. The value change dump file, <project_name>.vcd, which is an ASCII 
file containing activity and frequency information. Its format is specified by the 
IEEE 1364 standard. It should be in the format of gate-level simulation and 
match the design. The .vcd file preserves waveform information that can be 
displayed in third-party tools such as ModelSim/QuestaSim.

If you provide a post-routed simulation .vcd file, Power Calculator looks up the 
clock signals in the .vcd file and compares them to each clock in the Power 
Calculator pages. If the clock names match, Power Calculator takes the 
frequency data from the .vcd file and populates the frequency columns, the 
activity factor (AF(%)) columns, or all, in the pages that contain these 
columns.

See Also

 “Importing a Value Change Dump (.vcd) File” on page 19

 “Changing the Global Default Activity Factor” on page 18
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Outputs
Power Calculator generates power calculation results in tabular format from 
information extracted from the design project. All of this information, when 
saved, is kept in the project’s Power Calculator file (.pcf).

Power Calculator also generates a power calculation report, which can be 
viewed in HTML or text format. It also generates power graphs that show how 
power consumption is affected with varying voltage, temperature, and clock 
frequency. 

See Also

 “Generating Power Graphs” on page 28

 “Viewing the Power Calculator Report” on page 30

Static and Dynamic Power Consumption
Power Calculator reports the dynamic and static portion of the power 
dissipation. Power refers to the power consumed by the design. It is based on 
the extracted data from a placed and routed design file (.udb) or on the 
estimation information that you provide. 

The dynamic portion is the power consumed by the used resources while they 
are switching. The power dissipation of the dynamic portion is directly 
proportional to the frequency at which the resource is running and the number 
of resource units used. 

The static portion of power consumption is the total power consumed by the 
used and unused resources.
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Activity Factor Calculation
To calculate the power consumption for the routing interconnect, logic, and 
the read/write ports in an embedded block, Power Calculator requires a 
frequency and an activity factor percentage. The activity factor percentage is 
the percentage of time that a registered output node is active relative to a 
specified clock. Most of the resources associated with a clock domain run or 
toggle at a percentage of the frequency at which the clock runs. 

The frequency appears as the “Freq. (MHz)” column on most pages. The 
activity factor percentage appears as the “AF (%)” column.

Understanding the Default Activity 
Factor
Power Calculator assigns a default activity factor of 12.5% to most data 
signals. This means that these signals, on the average, change state once 
every 8 clock cycles. For example, the AF% of a signal in the Logic Block 
page is set at 12.5% by default.

Clock-related signals, on the average, change once every cycle. As such, 
these signals are assigned a default activity factor of 100%. A PLL is an 
example of such periodic signals that change every cycle. 

Some default AF% values are also set at 10%. An example is the default 
activity factor of some categories on a RAM. This means that these signals, 
on the average, change every 10 clock cycles.

Most of these default activity factor values are widely accepted in the industry.

See Also

 “Importing a Value Change Dump (.vcd) File” on page 19

 “Changing the Global Default Activity Factor” on page 18

 “Changing the Global Default Frequency Setting” on page 20

Note
MPP data is transferred at very fast rates that a default activity factor of 100% is 
provided/recommended for MPPHYX4 and MPPCIEX8.
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Enable Factor Calculation
To calculate the power consumption in some IP, such as Logic Block, DSP, 
etc., Power Calculator requires an enable factor (EF) percentage from 0 to 
100%. The EF is the percentage of time that the IP is enabled. Enter the 
enable factor percentage in the "EF (%)" column.

The enable factor percentage appears as the “EF (%)” column.

See Also

 “Importing a Value Change Dump (.vcd) File” on page 19

Power Calculator Window Features
Power Calculator main window displays the software mode being used and 
the currently selected page of power consumption information. When you first 
open Power Calculator, the Power Summary page appears by default. All 
other pages of information for the device are made available from the tabs 
arranged at the bottom of the main window. This section describes these 
features and the color coding of cells.

Software Mode
Power Calculator provides estimates of power consumption based on the 
device resources or template that you provide. This mode enables you to 
estimate the power consumption for your design before the design is 
complete or even started. It is useful for “what if” analysis. You must supply 
the frequency, activity factor, and voltage.
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Power Summary
Power Summary provides an overview of power consumption conditions. It is 
the first page that opens when you run Power Calculator. The Power 
Summary enables you to change the targeted device, operating conditions, 
voltage, and other basic parameters. Updated estimates of power 
consumption are then displayed based on these changes. 

Device

The Device section enables you to select a device family, package, part 
name, performance grade, and operating conditions. It displays power 
information based on these selections.

You can specify one of the following operating conditions, depending on the 
device. As this is device dependent, please refer to the device data sheet for 
more accuracy.

 Industrial – Devices are rated at 105 degrees Celsius.

 Commercial – Devices are rated at 85 degrees Celsius.

 Automotive – Devices are rated at 125 degrees Celsius.

If you are using Avant, the Power Screen field becomes available and allows 
you to select power screen limits based on your device.

Device Power Parameters Section

The Device Power Parameters section contains information pertaining to the 
device process conditions and power model status.

The process type specifies the corners or conditions under which the device 
was manufactured. It can be one of the following:

 Typical – to reflect the typical amount of current consumed by the circuit. 

 Worst – to reflect the maximum amount of current consumed by the 
circuit.

The Power File Revision displays the status of the model: 

 Advanced – The power file has all the constants, functions, formulas, and 
defaults. The constants are based on silicon simulation data without 
extracted layout parameters. The status of this file is “advanced.”

 Preliminary – The power file has all the constants, functions, formulas, 
and defaults. The constants are based on nominal silicon characterization 
data rather than simulation data. The status of this file is “preliminary.”

 Final/Production – The power file has all the constants, functions, 
formulas, and defaults. The constants are based on silicon 
characterization data that includes characterization of corner lots and 
conditions rather than simulation data. The status of this file is 
“production.”
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Environment Section

The Environment section displays information about the operating 
temperature of the device. The Thermal Profile button enables you to choose 
the thermal impedance model for the power-consumption or current-
consumption calculation. The Ambient Temperature cell allows you to specify 
the surroundings at which the device is expected to operate, in degrees 
Celsius. Temperature values must be between -40 and +125 degrees Celsius.

Effective Theta-JA specifies the cumulative thermal impedances of a 
particular system. This figure is used in calculating the junction temperature 
(Tj) of a die in a particular environment according to the following formula:

Tj = power * theta_effective + ambient_temperature

Junction Temperature specifies the temperature of the device within the 
device package, in degrees Celsius. You can adjust the junction temperature 
by using the models in the Thermal Profile dialog box. If the calculated value 
in the Junction Temperature box is either higher than 125 degrees Celsius or 
higher than the maximum junction temperature allowed for a particular device 
and operating conditions, a red text appears in the Junction Temperature box.

Maximum Safe Ambient specifies the maximum safe operating temperature 
for a die. If this temperature is exceeded, the semiconductor physics of the 
silicon change, so the die can operate erratically. The life of the device is also 
shortened.

Voltage/Dynamic Power Multiplier

This section contains information about the estimated power or current 
consumption by power supply. The Dynamic Power Multiplier specifies the 
derating factor for the dynamic portion of the power consumption. Power 
Calculator does not include derating for dynamic power. This factor enables 
you to change the number by the derating factor that you want to apply. The 
derating factor specified must be between 0.5 and 2. The default is 1.0.

Current by Power Supply

This section displays the static, dynamic, and total current consumption in 
amperes.

Power by Power Supply

This section displays the static, dynamic, and total power consumption in 
watts, the value of which is rounded to three digits after the decimal point.

Power by Block

This section displays the total power consumption by the different types of 
blocks in watts, the value of which is rounded to three digits after the decimal 
point.
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Peak Startup (A)

This section shows how much peak startup current each supply in the design 
draws, in amperes. When the “N/A” notation appears in this column, it means 
that no data is available yet. However, you can call Lattice Semiconductor 
Technical Support for this information.

Power Calculator Pages
Each time Power Calculator opens, it displays the Power Summary, which 
shows the targeted device, operating conditions, voltage, and other basic 
information. Additional pages are available from the tabs arranged at the 
bottom of the window. Except for Graph and Report, each of these pages 
allows you to view, edit, and add elements. The number and types of pages 
that are available depends on the selected device. 

Pages Available for Most Device Families

Block RAM

The Block RAM page displays the power consumed by the embedded block 
RAM (EBR) in the design and the factors that affect it. Power-consumption 
calculation for the Block RAM page requires the frequency and activity factor 
per clock domain.

Misc

The Misc page includes any non-generic IP, such as oscillators, i2c, and spi. 
These IPs do not have their own page due to negligible power contribution.

PLL

The PLL page displays the estimated power consumed by the phase locked 
loops in the design and the factors that influence it. The power-consumption 
calculation is based on the input frequency, the number of PLLs in the design, 
and internal feedback architecture of PLL in the device.

The PLL page is available for all devices.

Power Matrix

The Power Matrix page shows the amount of power pulled by each 
component in the design from multiple power sources. Two tabs are provided, 
allowing you to view the current usage (A) and power usage (W) of each type 
of component.
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Logic Block

The Logic Block page displays the estimated power consumed by the logic in 
the design and the factors that affect it. Power-consumption calculation in the 
Logic section requires both the frequency and an activity factor per clock 
domain. Power calculation is also based on the specified number and enable 
factor of LUTs, distributed RAMs, ripple-carry logic circuits, and registers 
driven by the clock.

Clocks

The Clocks page displays the estimated power consumed by the clocks in the 
design and the factors that affect it. Dynamic power calculation is based on 
the frequency of each clock.

The Clocks page only reports clocks that go to the clock tree, such as Primary 
Clock, Secondary Clock and Edge Clock.

I/O

The I/O page displays the estimated power consumed by the I/Os in the 
design and the factors that affect it. The power-consumption calculation for 
this page requires the frequency, activity factor, and number of inputs or 
outputs per clock domain. For bidirectional signals, it requires the number of 
bidirectional I/Os, input and output frequency, and input and output activity 
factor per clock domain. If you use an .udb file, Power Calculator extracts the 
information for the I/O page directly from the .udb file. If you do not use an 
.udb file, Power Calculator assigns the default resource usage values 
according to the design’s family. 

You can enable I/O standby mode from Bank I/O table or from user’s design. 
If “Allow Standby INR” is “Yes” in bank voltage table, all differential input/bidi I/
Os are standby-enabled; if “Allow Standby INR” is “No” in bank voltage table, 
all differential input/bidi I/Os are standby-disabled except MIPI DPHY input/
bidi I/Os, MIPI DPHY input/bidi I/Os can be either standby-enabled or 
standby-disabled. If “Allow Standby DIFFIO” is “Yes” in bank voltage table, all 
differential output I/Os are standby-enabled; if “Allow Standby DIFFIO” is “No” 
in bank voltage table, all differential output I/Os are standby-disabled except 
MIPI DPHY output I/Os, MIPI DPHY output I/Os can be either standby-
enabled or standby-disabled.

I/O Termination

The I/O Termination page enables you to provide information about external 
terminations for the I/Os. You can specify the average equivalent thevenin 
resistive load in ohms (Rth) and the equivalent thevenin voltage in volts (Vth). 
Power-consumption calculation is based on the power consumed by the 
external termination that you provide.
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Graph

The Graph page displays three types of graphs: 

 Power vs. VCC Supply Voltage

 Power vs. Ambient Temperature

 Power vs. Frequency

Each graph displays two plots—typical and worst case. Use the Edit > Graph 
Settings command to change the graphs to be displayed. The dialog box 
enables you to specify the range, step, X axis, and Y axis of each graph. See 
“Generating Power Graphs” on page 28 for more information.

To prevent any unnecessary calculations and additional processing time, 
graphs are only generated when you select the Graph tab. During the graph 
generation time, you cannot change tabs and must wait for the graph 
calculations to finish before performing any other action. If you switch tabs 
and change any information that will alter the power, the graphs will be 
regenerated when you next select the Graph tab. 

Report

The Report page contains a summary of the estimated power-consumption or 
current-consumption data calculated by Power Calculator. Information is 
taken from the Power Summary and from each page of the Power Calculator 
user interface. 

In the Power Model section, the Status can be Preliminary, Advanced, or 
Final.

 Preliminary – The power file has all the constants, functions, formulas, 
and defaults. The constants are based on nominal silicon characterization 
data rather than simulation data.

 Advanced – The power file has all the constants functions, formulas, and 
defaults. The constants are based on silicon simulation data without 
extracted layout parameters.

 Final/Production – The power file has all the constants, functions, 
formulas, and defaults. The constants are based on silicon 
characterization data that includes characterization of corner lots and 
conditions rather than simulation data.

The report is available in both text (ASCII) and HTML. It is updated each time 
you make a change to any of the data in the editable cells.
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Pages Dependent on Selected Device/ Device Architecture

LED

The LED page allows you to generate the constant current sources. The 
signal name for Input is “EN” and “LEDPU” for Output. Default Signal Value 
for unconnected port: Input is “0”

Input EN : Logic “0” 

The LED page is available for all devices.

DDRPHY

The DDRPHY page displays the estimated power consumed by DDRPHY in 
the design and the factors affecting it. The frequency, activity factor, enable 
factor, and type and number of DDRPHY’s powered by each clock are all 
required for the power-consumption calculation on this page. 

MPP

The MPP page displays the estimated power consumed by MPPHYX4 and 
MPPCIEX8 in the design and the factors affecting it. The protocol, data rate, 
activity factor, enable factor, link width, and number of MPPHYX4s and 
MPPCIEX8s are all required for the power-consumption calculation on this 
page. The MPP uses 100% activity factor by default.

DSP

The DSP page displays the estimated power consumed by the digital signal 
processors in the design and the factors that affect it. The power-consumption 
calculation for this page requires the frequency, activity factor, enable factor, 
and the type and number of DSPs driven by each clock. 

SRAM

The SRAM page displays the power consumed by the single port RAM used 
by the design and the factors that affect it. Power-consumption calculation for 
the SRAM page requires the frequency and activity factor per clock domain.

LRAM

The LRAM page displays the power consumed by the Large RAM blocks and 
the factors that affect it. It allows the entry of LRAM type, frequency, activity 
factor, enable factor, and number of blocks.

SGMIICDR

The SGMIICDR page displays the power consumed by the SGMII (Serial 
Gigabit Media Independent Interface)/CDR (Clock Data Recovery) blocks and 
the factors that affect it. It allows the entry of frequency, activity factor, enable 
factor, and number of blocks.
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DDRDLL

The DDRDLL page displays the power consumed by the DDRDLL (Double 
Data Rate Delay Locked Loop) master delay control blocks and the factors 
that affect it.  It allows the entry of frequency, activity factor, enable factor, and 
number of blocks.

DLLDEL

The DLLDEL page displays the power consumed by the DLLDEL (Delay 
Locked Loop Delay) slave delay blocks and the factors that affect it.  It allows 
the entry of frequency, activity factor, enable factor, and number of blocks.

DQS

The DQS page displays the power consumed by the DQS (DDR memory 
strobe) blocks and the factors that affect it. It allows the entry of DQS gearing 
mode, frequency, activity factor, enable factor, and number of blocks.

MIPIDPHY

The MIPIDPHY page displays the power consumed by the MIPIDPHY (Mobile 
Industry Processor Interface Physical layer) blocks and the factors that affect 
it. It allows the entry of data rate, activity factor, and duty cycles for transmit/
receive and low power/high speed. The MIPIDPHY has VCCDPHY and 
others power domains, and it uses 100% activity factor and 80% HS duty 
cycle for all dynamic power calculation. Customer can specify HS duty cycle 
in either continuous (normal power consumption) or non-continuous (power 
saving condition) clocking mode. For continuous clocking mode, the 
MIPIDPHY supports X4/X3/X2/X1 mode operation.

The MIPIDPHY page is available for CrossLink-NX device only.

ADC

The ADC page displays the power consumed by the ADC (Analog to Digital 
Converter) block and the factors that affect it.  It allows the entry of frequency, 
activity factor, enable factor, number of blocks, and comparator enables.

ALU

The ALU page displays the power consumed by the ALU (Arithmetic Logic 
Unit) block and the factors that affect it. It allows the entry of frequency, 
activity factor, enable factor, and number of blocks.

PCIE

The PCIE page displays the power consumed by the PCIe (Peripheral 
Component Interconnect Express) hardened block and the factors that affect 
it. It allows the entry of activity factor, enable factor, number of blocks, and 
PCIe speed. The data rate (2.5G, 5G, 8G) cannot be input directly, it is based 
on the type. The PCIE uses 100% activity factor by default for all dynamic 
power calculation including VCC power domain.



ANALYZING POWER CONSUMPTION : Power Calculator Window Features

Lattice Radiant Power Estimator User Guide 13

PCS

The PCS page displays the power consumed by the PCS hardened block and 
the factors that affect it. It allows the entry of activity factor, enable factor, 
number of blocks, number of lanes and data rate. It includes PCIE_LL (PCIe 
Link layer) and PCS table. The data rate (2.5G, 5G, 8G) in PCIE_LL cannot be 
input directly, it is based on the type. When PCIE_LL is used (there is a line in 
PCIE_LL table and # PCIE = 1), the PCS data rate will be set to the same 
value as PCIE_LL data rate automatically. If no PCIE_LL is used, the PCS 
data rate can be set by user.

Color Coding of Cells
The background colors of the cells on Power Calculator pages have the 
following significance:

 White – The cell is editable. When you edit the contents of this type of cell, 
the software mode does not change. If the software is in calculation mode, 
it will remain in calculation mode. If the software is in estimation mode, it 
will remain in estimation mode.

 Green – The cell is read-only or contains output from the software. 

 Lite Yellow – The cell contains data extracted from a design file, such as 
an .udb file. If you enter data into this type of cell and the software is in 
calculation mode, it will change to estimation mode unless you enter data 
into the Performance Grade, Operating Conditions, and Process Type 
boxes. If the software is in estimation mode, it will remain in estimation 
mode.

 Red – The calculated value in the Junction Temperature box is either 
higher than 125 degrees Celsius or higher than the maximum junction 
temperature allowed for a particular device and operating conditions. The 
Junction Temperature box is the only cell that can display red text.

The font colors in the cells on Power Calculator pages have the following 
significance:

 Blue – Indicates default values.

 Grey out – Indicates values that cannot be edited on the I/O page. Since 
the I/O page has columns for inputs, outputs, and bidirectionals, red font 
prevents you from altering an I/O that is not valid. For example, if the I/O 
type belongs only to an I/O input, the cell in the # of Inputs column would 
display a value in black font, indicating that it is editable. The cells in the # 
of Outputs and the # of Bidi columns, however, would display values in 
gray font to indicate that they cannot be edited.

 Black – Indicates all other text.
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Working with Power Calculator Files
When you first open a Power Calculator file (.pcf), it contains default 
information based on the device. When you enter data into Power Calculator 
pages and save the changes, the information is stored in the .pcf file. You can 
create a new Power Calculator file by saving the current .pcf file as a new file 
or click File > New File from the File menu.

To save a Power Calculator file, choose File > Save or press Ctrl+S or click 
. To save a Power Calculator file as a new file, choose File > Save File As, 

and in the dialog box, navigate to the desired directory. Type a name in the file 
name box and click Save. 

Entering Data
Based on the device, Power Calculator extracts information such as package, 
part, performance grade, and operating conditions. You can modify the device 
settings and the editable cells on any page. 

Power Calculator allows you to enter data directly in the editable cells. It also 
enables you to make global changes to frequency, activity factor by changing 
the default setting in the Frequency Settings, Activity Factor, and Enable 
Factor Settings dialog boxes. You can use a simulation file to populate 
Frequency, AF (activity factor) cells.

Editing Cells
Power Calculator includes built-in design rule checks. It automatically checks 
values that you enter into editable cells to ensure that they do not violate 
design rules. If you attempt to enter an inappropriate value in the Type, # I/P, # 
O/P, or # Bidi cell in the I/O page, Power Calculator will block the invalid value 
and display the previous value in the cell. 

Power Calculator also provides tool tips that display the valid range of values 
for an editable cell. To ensure that the value you are entering is a valid one, 
hold your mouse over the cell to view the tool tip.

Most cells on Power Calculator pages are editable text cells that enable you 
to type a modified value. Others cells, such as the Device and Power 
parameters sections of the Power Summary page, contain visible drop-down 
menus for making a selection. Still others, such as those in the Type column 
on the I/O page, contain hidden drop-down menus that become visible when 
you double-click a cell.

To edit a cell:

 Depending on the type of cell you are editing, do one of the following:

 Double-click the editable cell, type a new value, and then press Enter 
or click anywhere outside the cell.
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 Select a value from the visible drop-down list.

 Double-click the cell and select a value from the drop-down list that 
appears.

Power Calculator calculates the results automatically and displays them. It 
also updates the Report page.

See Also

 “Power Calculator Pages” on page 8

 “Color Coding of Cells” on page 13

 “Cutting and Pasting Cell Contents” on page 17

 “Copying and Pasting Cell Contents” on page 17

 “Changing Values Automatically” on page 18

Editing Pages
You can change the settings and values on any Power Calculator page and, if 
desired, save the results to a separate Power Calculator File (.pcf) in the 
Analysis Files folder. 

To edit Power Calculator pages:

1. On the Power Summary page, modify any settings in the Device section 
as desired. 

When you select a different device, Power Calculator compares the 
design’s requirements against the available resources in the selected 
device. If the selected device is not suitable for the design—for example, if 
the number of LUTs in the design exceeds those available in the device, 
the number can't be entered, user may move cursor to the editable cell, 
and refer to the value range to reduce the design size to fit the smaller 
device.

2. In the Device Power Parameters section of the Power Summary page, set 
the Process Type option, which specifies the process corners or 
conditions under which the device was manufactured. It can be one of the 
following:

 Typical – specifies typical conditions to reflect the typical amount of 
current consumed by the circuit. 

 Worst – specifies fast conditions to reflect the maximum amount of 
current consumed by the circuit.

3. In the Environment section of the Power Summary page, do the following:

 Click Thermal Profile to select a thermal impedance model or enter 
your own Effective Theta-JA value. 

 Change the ambient temperature, as desired.

See “Controlling Operating Temperature” on page 23



ANALYZING POWER CONSUMPTION : Entering Data

Lattice Radiant Power Estimator User Guide 16

4. In the Voltage/Dynamic Power Multiplier section, enter new values, as 
desired, for voltage and DPM. 

The voltage is the estimated power consumption by power supply. DPM is 
the derating factor for the dynamic portion of the power consumption. 

5. Select other tabs and enter values into the editable cells of the other 
Power Calculator pages. The number and types of pages varies according 
to the device family.

6. Save your changes.

See Also

 “Power Calculator Pages” on page 8

 “Editing Cells” on page 14

Adding and Deleting Clock Rows
You can easily add and delete clock rows on the Power Calculator pages. 

To add a clock row to a page:

1. Right-click inside the desired table and choose Add Row from the pop-up 
menu.

2. Enter the appropriate data in the cells that have a white or light yellow 
background. Some columns with a light yellow background, such as Type, 
offer drop-down menus from which you can select settings.

To delete a clock row from a page:

 Right-click in the row that you want to delete and choose Remove Row.

See Also

 “Editing Cells” on page 14
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Cutting and Pasting Cell Contents
You can cut the contents of a cell in a clock row and paste them in a cell in the 
same row or another row.

To cut and paste cell contents:

1. Double-click the desired cell to select its contents, and then right-click.

2. From the pop-up menu, select Cut. Alternatively, you can press Ctrl+x.

You cannot cut the contents of any cells or columns that include a drop-
down menu or text that is read-only.

3. Double-click the cell into which you want to paste the contents that you 
have cut, and then right-click.

4. From the pop-up menu, select Paste. Alternatively, you can press Ctrl+v.

See Also

 “Editing Cells” on page 14

 “Changing Values Automatically” on page 18

Copying and Pasting Cell Contents
You can copy the contents of a cell in a clock row to a cell in the same row or 
another row.

To copy and paste the contents of a cell:

1. Double-click the desired cell to select its contents, and then right-click.

2. From the pop-up menu, select Copy. Alternatively, you can press Ctrl+c.

3. Double-click the cell into which you want to paste the contents that you 
have copied, and then right-click.

4. From the pop-up menu, select Paste. Alternatively, you can press Ctrl+v.

See Also

 “Editing Cells” on page 14

 “Changing Values Automatically” on page 18
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Changing Values Automatically
When you change values on any of the pages, Power Calculator recalculates 
the results automatically. For example, when you change the frequency of a 
clock in one cell and press Enter, Power Calculator automatically changes the 
frequency for that clock in all Frequency cells.

You can also use the Activity Factor Settings and Frequency Settings dialog 
boxes to make changes to all frequency, activity factor cells.

See Also

 “Changing the Global Default Activity Factor” on page 18

 “Changing the Global Default Frequency Setting” on page 20

 “Importing a Value Change Dump (.vcd) File” on page 19

Reverting to Calculation Mode
After you have made changes that causes the software to run in estimation 
mode, Power Calculator allows you to revert to calculation mode, under the 
following circumstances:

 The changes you made have not been saved to the .pcf file.

To revert to calculation mode from estimation mode:

1. Choose Edit > Revert to Calculation Mode.

2. In the Confirm dialog box, click Yes to confirm that you want to discard all 
the changes that you made in estimation mode.

Power Calculator removes all the changes you made and reverts to the 
settings in the .pcf file.

See Also

 “Software Mode” on page 5

Changing the Global Default Activity Factor
Power Calculator automatically assigns a default activity factor in the cells of 
the pages that display an activity factor, such as AF (%), or that use an activity 
factor in calculations, such as Input AF (%). These default values appear in 
blue font. You can use the Edit menu to globally change this default activity 
factor.



ANALYZING POWER CONSUMPTION : Importing a Value Change Dump (.vcd) File

Lattice Radiant Power Estimator User Guide 19

To globally change the default activity factor:

1. Choose Edit > Activity Factor Settings.

2. In the Power Calculator - Activity Factor Settings dialog box, enter the 
new activity factor in the Activity Factor Default text box.

3. Click OK. 

All the default activity factors appearing in blue font are changed to the new 
activity factor. Power Calculator automatically saves the new default.

If you manually change an activity factor in only one cell, the font becomes 
black to indicate that it is not a default value. 

You can use a .vcd file to populate the cells that display or use activity factors. 
The resulting values are not considered defaults and therefore appear in 
black font.

See Also

 “Activity Factor Calculation” on page 4

Importing a Value Change Dump (.vcd) File
Power Calculator enables you to import a value change dump (.vcd) file of 
simulation results into your project. Normally, you would import a .vcd file only 
when you want the Frequency, AF (activity factor) cells on Power Calculator 
pages to be populated with frequency and activity factor data from the .vcd 
file. 

To ensure that Power Calculator populates the Frequency and AF cells with 
the VCD information, make sure that you follow these requirements:

 The .vcd file should be in the format of gate-level simulation, and it should 
match the design.

 A post-PAR timing simulation netlist must be used for name matching. You 
cannot use the RTL design.

 A stimulus must be used in the simulator that actually toggles the signals 
you are interested in; otherwise, you will see no difference in Power 
Calculator after the VCD is read.
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To import a .vcd file into your project:

1. Choose Edit > Open Simulation File to open the Power Calculator – 
Open Simulation File dialog box. 

2. In the VCD File box, type or select the path and name of the .vcd file that 
you want to open.

3. In the Module Name in VCD box, specify the name of the module in the 
.vcd file from which to take the frequency and activity factor data.

4. Select the Case Sensitive option if the name of the .vcd file to be imported 
is case-sensitive.

5. Click OK.

Power Calculator Frequency and AF cells are now populated with the data 
from the .vcd file.

See Also

 “Changing the Global Default Frequency Setting” on page 20

Changing the Global Default Frequency Setting
You can globally change the default frequency values for the clocks listed in 
the Power Calculator pages. These default values appear in blue font in the 
Freq. (MHz) columns. 

You can change this global frequency value in the Frequency Settings dialog 
box.

To globally change the default frequency setting by specifying a value:

1. Choose Edit > Frequency Settings.

2. In the Frequency Settings dialog box, enter the new frequency in the 
Frequency Default cell, in megahertz.

The default is 0 megahertz.

3. Click OK.

Note
The Use Frequency TWR option is not available in Power Estimator.
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Estimating Resource Usage
Power Calculator allows you to specify an estimate of resources that the 
design will use, for the purpose of power analysis. The estimate can be based 
on design type or on component utilization. Based on your selections, Power 
Calculator immediately displays the number of resources that will be utilized 
for each type.

To estimate resource usage based on design type:

1. Choose Edit > Resource Settings.

2. In the dialog box, select Specify Resource by Design Type.

3. Select the design type from the drop-down menu.

Power Calculator calculates the resource usage based on the design and 
displays the utilization in the bottom portion of the dialog box.

4. Click OK.

To estimate resource usage based on component utilization:

1. Choose Edit > Resource Settings.

2. In the dialog box, select Specify Resource by Component Utilization.

3. Do one or both of the following:

 Select a Small, Medium, or Large option based on the design size.

Power Calculator displays a percentage of Logic, I/O, and EBR based 
on your selection.

 Select a percentage from the Logic(%), I/O(%), and EBR(%) drop-
down menus.

Power Calculator calculates the resource usage based on your selections 
and displays the utilization in the bottom portion of the dialog box.

4. Click OK.

See Also

 “Estimating Routing Resource Usage” on page 22
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Estimating Routing Resource Usage
You can estimate the amount of routing resources that your design will use for 
the purpose of power analysis.

To estimate routing resource usage:

1. Choose Edit > Estimation Mode Settings.

The Power Calculator - Estimation Mode Settings dialog box appears.

2. From the Routing Resource Utilization drop-down menu, select the 
amount of routing resources that you expect your design to use. 

 Low – Uses a small amount of routing resources. 

Select this option if you have a datapath oriented FPGA architecture 
with low fanout nets.

 Medium – Uses an average amount of routing resources. This is the 
default setting 

Select this option if your design is a mix of datapath and control style 
logic. If unsure of your design style, retain the Medium default setting.

 High – Uses a large amount of routing resources.

Select this option if your design has high numbers of high fanout nets 
that span large areas of the FPGA.

These settings are further illustrated in the figure below.

3. Click OK.

See Also

 “Estimating Resource Usage” on page 21
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Running Immediate Calculation
The Calculate button allows you to run power calculation with a mouse-click 
after you have made changes to your power calculation. 

To enable the Calculate button:

1. Choose Edit, then uncheck Calculate Immediately. The Calculate button 
appears on the top-right of the Power Summary page.

2. Click the Calculate button. The power calculation result will be updated, 
and the red note will disappear.

Controlling Operating Temperature
Minimizing the device’s operating temperature is critical to reducing power 
consumption.

A device has two parts: the die, which is the silicon inside the device, and the 
package, which is the outer shell. Each die-package combination has a 
thermal resistance value (often referred to as theta), which is a measure of 
how well the combination can dissipate heat. Lower values indicate better 
heat dissipation for the device.

Thermal impedance is the cumulative individual thermal resistances of a 
defined network. Power Calculator offers different models that provide ways 
to calculate the thermal impedance for a given device when it is mounted on 
the board. These models cover scenarios related to board sizes, air flows, 
and heat sinks that affect the thermal impedance. You can use these models 
to calculate the thermal impedance for the scenario that you choose.

You can choose the thermal impedance models by clicking the Thermal 
Profile button in the Environment section at the top right of the Power 
Summary page.

These thermal impedance models use the following terminology:

 Junction temperature – the temperature of the die in the device package, 
in degrees Celsius. You can adjust the junction temperature by choosing a 
model that applies a heat sink and changes the air flow value. Junction 
temperature is also affected by the package that you select in the 
Package Type box. In addition, the changes that you enter in many of the 
editable (white and turquoise) cells on the Power Summary page affect 
junction temperature.

 Heat sink – any material or object that dissipates unwanted heat from a 
device by absorbing it and conducting it away to a surface from which it 
dissipates into its surroundings. The reduction of junction-to-ambient 
thermal impedance depends on different factors, such as the speed and 

Note: 
Any changes cause a note “Power result is dirty. Manually click ‘Calculate’ 
button to run power calculation.” shown in red color.
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direction of the air flow over the heat sink and the materials used to attach 
the heat sink to the package. For heat-sink properties and proper 
attachment methods, contact your heat-sink manufacturer for 
specifications.

 Air flow – the movement of air around the device in a package to cool it. It 
is measured in linear feet per minute (LFM). The higher the air flow value 
you select, the greater the cooling effect on the device.

 Ambient temperature – the expected operating temperature, in degrees 
Celsius, of the medium surrounding a device in a package. 

 Theta JA – the thermal impedance between the silicon die and the 
ambient air within a JEDEC-defined environment. The boards used to 
measure these values have four layers, and their size is defined by 
JEDEC specifications.

 Effective Theta JA – similar to Theta JA, but defined as the sum of all the 
package and board thermal resistances outside of a JEDEC-defined 
environment. It indicates how well the heat dissipates from the die to the 
ambient (air) for a particular thermal network as a whole outside of a 
JEDEC-defined environment.

 Theta JB – indicates how well the heat dissipates from the junction on the 
silicon die to the board. 

 Theta JC – indicates how well the heat dissipates from the junction of the 
die to the package case in which it is enclosed, as defined by the JEDEC 
specifications.

 Theta BA – indicates how well the heat dissipates from the board to the 
ambient (air). 

 Theta CS – indicates how well the heat dissipates from the package case 
to the heat sink. It is a measure of the thermal resistance of the interface 
material that makes contact between the package case and the heat sink 
attached to the package. It can be thermal grease, double-sided sticky 
tape, glue, or phase-shift material. 

 Theta SA – indicates how well the heat dissipates from the heat sink to the 
ambient (air).

See Also

 “Power Calculator Pages” on page 8
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Selecting a Thermal Impedance Model
You can experiment with various board sizes, heat sinks, and air flow settings 
to select a thermal impedance model for your design. The choice of board 
affects the Theta JB and Theta BA values, and the heat sink and air-flow 
selections affect the Theta SA and Theta JA values.

To select a thermal impedance model:

1. In the Environment section of the Power Summary page, click Thermal 
Profile.

The Effective Theta-JA specifies the cumulative thermal impedance of a 
particular system. This figure is used in calculating the junction 
temperature (Tj) of a die in a particular environment according to the 
following formula:

Tj = power * theta_effective + ambient_temperature.

2. In the Power Calculator - Thermal Profile dialog box, select the source of 
the effective thermal impedance (effective Theta JA) value:

 If you want Power Calculator to calculate the effective Theta JA value 
from the selections that you make in the Board Selection, Heat Sink 
Selection, and Airflow Selection drop-down menus, choose Use 
Thermal Models. 

 If you want to provide your own effective Theta JA value, choose 
User-Defined Effective Theta-JA.

3. If you chose Use Thermal Models: 

a. Select the size of the board that to use from the Board Selection drop-
down menu:

 JEDEC Board (2S2P) – Specifies that a board defined by JEDEC 
specifications be used. These specifications are based on real 
boards and measurements conducted in the lab used by Lattice 
Semiconductor. For packages < 27.0 mm in length, the buried 
planes are 74.2 mm x 74.2 mm (3” x 3”). For packages larger than 
or equal to 27.0 mm, the buried planes are 99.6 mm x 99.6 mm (4” 
by 4”). Power Calculator uses Theta JA or Theta JC, depending on 
the type of heat sink selection you make in the Heat Sink Selection 
menu. Theta JA is used only if you choose No Heat Sink. The 
ThetaJA value is the published value measured in the lab.

 Small Board – Specifies that a board that is slightly larger than the 
JEDEC board be used. The board is assumed to be 6” to 8” 
square. This setting adds the Theta JB value to the board thermal 
impedance.

Note
The current values provided with the thermal models are averages of different values, 
and they are provided as a courtesy. To produce better predictions, it is advised that 
you submit your own thermal values.
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 Medium Board – Specifies that a medium board be used, one that 
is assumed to be 8” to 12” square. This setting adds the Theta JB 
value to the board thermal impedance. 

 Large Board – Specifies that a large board be used, one that is 
assumed to be larger than 14” square. This setting adds the Theta 
JB value to the board thermal impedance.

b. Select the type of heat sink from the Heat Sink Selection drop-down 
menu:

 No Heat Sink – Specifies that no heat sink be used. Theta JA is 
used, and you must choose the air flow from the Airflow Selection 
menu. The No Heat Sink setting is the default.

 Low-Profile Heat Sink – Specifies that a short heat sink be used.

 Medium-Profile Heat Sink – Specifies that a medium heat sink be 
used. This setting adds the Theta JC value to the Heat Sink 
thermal impedance.

 High-Profile Heat Sink – Specifies that a tall heat sink be used.

 Custom-Profile Heat Sink – Enables you to specify your own heat-
sink value in the Theta-SA for Custom Heat Sink box. The Airflow 
Selection option is not available when you select Custom-Profile 
Heat Sink.

c. Select the air flow in linear feet per minute (LFM) from the Airflow 
Selection drop-down menu:

 0 LFM

 200 LFM

 500 LFM

If you use a heat sink, the 0 LFM setting is not available. 

The Airflow Selection option is not available when you select Custom-
Profile Heat Sink from the Heat Sink Selection menu.

Note
Many factors can affect the actual thermal properties and change the values, 
including: 

 The number of board layers.

 Airflow over the board.

 Number of devices powered up around the device package and their distance 
from the package.

 Thickness of the copper and the width of the traces on each layer. 

 Number of thermal vias. 

 Shape and thickness of each power and ground plane below the transfer of 
heat from the die to the ambient environment. 

As a result, users are encouraged to make their own thermal measurements or 
simulations and use them in Power Calculator to see what kind of junction 
temperature might result.
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4. If you chose User-Defined Theta-JA Effective, enter your effective thermal 
impedance value in the Effective Theta-JA box. Values entered must be 
greater than 0.

This box is not available if you selected Use Thermal Models.

5. Click OK.

The new effective Theta JA value now appears in the Effective Theta-JA box 
in the Environment section of the Power Summary page.

See Also

 “Controlling Operating Temperature” on page 23

 “Changing the Ambient Temperature” on page 27

Changing the Ambient Temperature
The ambient temperature is the expected operating temperature, in degrees 
Celsius, of the medium surrounding a device in a package. You can select an 
ambient temperature in the range of -40 to 125 degrees Celsius. 

To change the ambient temperature:

 In the Environment section of the Power Summary page, enter a value, in 
degrees Celsius, in the Ambient Temperature box and press Enter or click 
anywhere outside the cell.

The value entered must be between -40 and +125 degrees Celsius. The 
default value is 25 degrees Celsius for all devices.

When you change the value in the Ambient Temperature box, Power 
Calculator updates the following cells:

 Junction Temperature.

 Values in the Static (A) and Total (A) columns of the Current by Power 
Supply and Power by Power Supply sections.

 The totals in the Power by Block Column.

If you enter a value that is beyond the commercial, industrial, or automotive 
device limits, you will receive an error message that displays the range of 
valid values.

See Also

 “Controlling Operating Temperature” on page 23

 “Selecting a Thermal Impedance Model” on page 25
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Viewing and Printing Results
In addition to the automatically generated reports from power settings, Power 
Calculator also provides graphs of power consumption and enables you to 
print information from the pages and generate a comma-separate value file 
(.csv) from the command line.

Generating Power Graphs
Power Calculator can create graphs showing how power consumption is 
affected when you vary the voltage, temperature, and clock frequency in the 
design. You can generate three default power graphs on the Graph page: 

 Power vs. Supply Voltage

 Power vs. Ambient Temperature

 Power vs. Frequency

Each graph displays a typical and worst case plot. You can select the X axis 
and Y axis for each graph.

Graphs are only generated when you select the Graph tab. During graph 
generation, you cannot select a different tab until the calculations are finished. 
If you change the information in any other page that alters the power, the 
graphs will be regenerated when you again select the Graph tab. If you do not 
change any power information, the graphs will not be regenerated.

To generate the Power vs. Supply Voltage graphs:

1. Choose Edit > Graph Settings.

2. In the Power by Section part of the Graphs Settings dialog box, set the 
following options:

a. In the Y Axis box, select Total Power or the specific type of block 
power to display, such as I/O or Block RAM, to place on the Y axis of 
the graph.

b. In the X Axis box, select the type of supply voltage to place on the X 
axis of the graph.

c. In the Lower Limit box, enter the lower boundary of the voltage range 
on the X axis. The lower limit can be 5 percent lower than the nominal 
supply value. 

d. In the Upper Limit box, enter the upper boundary of the voltage range 
on the X axis. The upper limit can be 5 percent higher than the 
nominal supply value. 

e. In the Resolution box, enter the step in which the supply voltage 
values on the X axis should appear. The voltage supply step is limited 
to a resolution of .01.

3. Click OK to close the dialog box and apply the settings.

4. Click the Graph tab to see the resulting charts.
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To generate the Power vs. Ambient Temperature graphs:

1. Choose Edit > Graph Settings.

2. In the Power by Temperature part of the Graphs Settings dialog box, set 
the following options:

a. In the Y Axis box, select Total Power or the type of block power, such 
as I/O or Block RAM, to place on the Y axis of the graph.

b. In the X Axis box, select Ambient Temperature for the X axis of the 
graph. Temperature is in degrees Celsius.

c. In the Lower Limit box, enter the lower boundary of the temperature 
range on the X axis. The range limits are determined by the device’s 
operating condition:

 Industrial: –40 through 105

 Commercial: 0 through 85

 Automotive: –40 through 125

d. In the Upper Limit box, enter the upper boundary of the temperature 
range on the X axis. The range limits are determined by the device’s 
operating condition:

 Industrial: –40 through 105

 Commercial: 0 through 85

 Automotive: –40 through 125

e. In the Resolution box, enter the step in which the temperature values 
on the X axis should appear. The temperature step is limited to 
resolution of 10 degrees Celsius.

3. Click OK to close the dialog box and apply the settings.

4. Once the graphic data has been prepared, click the Graph tab to see the 
resulting charts.

To generate the Power vs. Frequency graphs:

1. Choose Edit > Graph Settings.

2. In the Power by Frequency part of the Graphs Settings dialog box, set the 
following options:

a. In the Y Axis box, select Total Power or the specific type of block 
power, such as I/O or Block RAM, to place on the Y axis of the graph.

b. In the X Axis box, select the clock to place on the X axis of the graph. 
It can be any of the clocks listed on the Clocks page. 

c. In the Lower Limit box, enter the lower boundary of the frequency 
range on the X axis. The lower boundary is limited to 0 MHz. 

d. In the Upper Limit box, enter the upper boundary of the frequency 
range on the X axis. The upper boundary is limited to 10000 MHz. 

e. In the Resolution box, enter the step in which the frequency values on 
the X axis should appear. The default frequency increment is 20 MHz.

3. Click OK to close the dialog box and apply the settings.
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4. Once the graphic data has been prepared, click the Graph tab to see the 
resulting charts.

Viewing the Power Calculator Report
The report page contains a summary of the estimated power consumption or 
current consumption data calculated by the Power Calculator. It is available in 
text (ASCII), HTML, and .csv formats, and it is updated each time you make a 
change to any of the data in the editable cells.

To view the Power Calculator report:

 To view the results in text format, click the Report tab.

 To view the results in HTML format, click View HTML Report.

 To view the results in .csv format, click Generate CSV Report. 

Printing Information
After calculating power, you can print the results displayed on any of the 
pages, including the Report and Graph pages. Optionally, you can preview 
pages before printing.

To preview and print:

1. In the Power Calculator window, click the tab of the desired page.

2. Choose File > Print Preview to activate the Print Preview dialog box.

Use the zoom tools and the Fit Page and Fit Width buttons on the toolbar 
to position the page in the window. 

When there are multiple pages, use the Next, Last, Previous, and First 
arrows to navigate through them. 

3. Select the Portrait or Landscape button on the toolbar.

4. Click Print to queue the results to a printer.

5. In the Print dialog box, click Print.

To print information from a page:

1. In the Power Calculator window, click the tab of the desired page.

2. Choose File > Print.

3. In the dialog box, click Print.

See Also

 “Entering Data” on page 14

 “Power Calculator Pages” on page 8
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Generating a Power Calculator Report 
in CSV Format
A consolidated report of data in all the Power Calculator pages can be 
generated in .csv format. This allows you to analyze the results in an external 
spreadsheet application that supports CSV. 

To generate a Power Calculator report in CSV format:

1. Click the Generate CSV Report button at the upper right-hand corner of 
the Power Calculator window.

2. in the Generate CSV Report dialog box, browse to the target directory for 
the report.

3. Type a name in the File name box and click Save.
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