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Disclaimers

Lattice makes no warranty, representation, or guarantee regarding the accuracy of information contained in this document or the suitability of its
products for any particular purpose. All information herein is provided AS IS, with all faults, and all associated risk is the responsibility entirely of the
Buyer. The information provided herein is for informational purposes only and may contain technical inaccuracies or omissions, and may be otherwise
rendered inaccurate for many reasons, and Lattice assumes no obligation to update or otherwise correct or revise this information. Products sold by
Lattice have been subject to limited testing and it is the Buyer's responsibility to independently determine the suitability of any products and to test
and verify the same. LATTICE PRODUCTS AND SERVICES ARE NOT DESIGNED, MANUFACTURED, OR TESTED FOR USE IN LIFE OR SAFETY CRITICAL
SYSTEMS, HAZARDOUS ENVIRONMENTS, OR ANY OTHER ENVIRONMENTS REQUIRING FAIL-SAFE PERFORMANCE, INCLUDING ANY APPLICATION IN
WHICH THE FAILURE OF THE PRODUCT OR SERVICE COULD LEAD TO DEATH, PERSONAL INJURY, SEVERE PROPERTY DAMAGE OR ENVIRONMENTAL
HARM (COLLECTIVELY, "HIGH-RISK USES"). FURTHER, BUYER MUST TAKE PRUDENT STEPS TO PROTECT AGAINST PRODUCT AND SERVICE FAILURES,
INCLUDING PROVIDING APPROPRIATE REDUNDANCIES, FAIL-SAFE FEATURES, AND/OR SHUT-DOWN MECHANISMS. LATTICE EXPRESSLY DISCLAIMS
ANY EXPRESS OR IMPLIED WARRANTY OF FITNESS OF THE PRODUCTS OR SERVICES FOR HIGH-RISK USES. The information provided in this document
is proprietary to Lattice Semiconductor, and Lattice reserves the right to make any changes to the information in this document or to any products at
any time without notice.

Inclusive Language

This document was created consistent with Lattice Semiconductor’s inclusive language policy. In some cases, the language in underlying tools and
other items may not yet have been updated. Please refer to Lattice’s inclusive language FAQ 6878 for a cross reference of terms. Note in some cases
such as register names and state names it has been necessary to continue to utilize older terminology for compatibility.
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Abbreviations in This Document

A list of abbreviations used in this document.

Abbreviation

Definition

ASCII

American Standard Code for Information Interchange.

Board Support Package, the layer of software containing hardware-specific drivers and libraries to function

BSP in a particular hardware environment.

DUT Design Under Test.

CDT C/C++ Development Tools.

CPU Central Processing Unit.

GUI Graphical User Interface.

FPGA Field Programmable Gate Array.

HDL Hardware description language.

IBIS Input Output Buffer Information System.

IDE Integrated Development Environment.

IP Intellectual Property.

JEDEC Joint Electron Device Engineering Council.

0oCD On-Chip-Debugging.

OEM Original Equipment Manufacturer.

OpenOCD Open On-Chip Debugger.

RISC.V Reduced Instruction Set Computer-V. A free and open instruction set architecture (ISA) enabling a new era
of processor innovation through open standard collaboration.

RISC-V MC Lattice RISC-V for Micro-Controller Soft IP.

RISC-V SM Lattice RISC-V for State-Machine Soft IP.

RISC-V RX Lattice RISC-V for RTOS Soft IP.

SDK Software Development Kit. A set of software development tools that allows the creation of applications for
software package on the Lattice embedded platform.

SoC System-on-Chip. An integrated circuit that integrates all components of a computer or other electronic
systems.

SRAM Static Random Access Memory.

UART Universal Asynchronous Receiver/Transmitter.

ul User Interface.

UFM User Flash Memory.

VHDL Very-High-Speed Integrated Circuit Hardware Description Language.

QEMU A generic and open source machine emulator and virtualizer.

RTOS Real Time Operating System

FreeRTOS A market-leading RTOS for microcontrollers and small microprocessors.
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1. Introduction

Lattice Propel™ is a complete set of graphical and command-line tools to create, analyze, compile, and debug both
FPGA-based hardware and software processor systems.

1.1. Purpose
Embedded system solutions play an important role in FPGA system design, allowing you to develop software for a
processor in an FPGA device. It provides the flexibility for you to control various peripherals from a system bus.

To develop an embedded system on an FPGA, you need to design the System-on-Chip (SoC) with an embedded
processor and develop system software on the processor. Lattice Propel helps you develop your system with a RISC-V
processor, peripheral IP, and a set of tools.

The purpose of this document is to introduce Lattice Propel SDK tool and flow to help you quickly get started to build a
small demo system. You can find recommended flows of using Lattice Propel SDK in this document as well.

1.2. Audience

The intended audience for this document includes embedded system designers and embedded software developers
using Lattice FPGA devices. The complete list of supported devices can be found in Lattice Propel Release Notes. The
technical guidelines assume readers have expertise in the embedded system area and FPGA technologies.
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2. Lattice Propel Development Suite

Lattice Propel development suite includes:
e anintegrated development environment (IDE), which is the framework of Lattice Propel;
e Lattice Propel Builder, which is for SoC design;

e Lattice Propel SDK, which is for system software development.

2.1. Eclipse IDE

Eclipse IDE provides the Propel development suite a platform to manage the SoC project and the Embedded C/C++
Project in the same workspace.

The SoC project, which extends from the Propel Builder project, provides easy interaction with other Lattice design
tools, such as Lattice Diamond™ within Propel.

The Embedded C/C++ Project provides a platform for developing or debugging application code within Eclipse IDE. The
project can be created directly from the SoC project with a pre-set Board Support Package (BSP) and applications by
using Propel development suite.

2.2. Lattice Propel Builder

Lattice Propel Builder allows you to assemble the larger functional blocks of the design hierarchy. Propel Builder
enables you to instantiate modules and IP from the IP Catalog in a schematic view, and can easily connect the modules.
Propel Builder also helps you customize address spaces within modules, such as a processor. In Propel development
suite, Propel Builder is used to create a microprocessor integrated platform for both hardware and software
development.

Refer to Lattice Propel 2024.1 Builder User Guide (FPGA-UG-02212) for more detailed information.

2.3. Lattice Propel SDK

Lattice Propel SDK is based on Eclipse Embedded C/C++ Development Tools (CDT). It allows you to create, build, and
debug software application projects that drive the platform within the Eclipse framework.

The main features are:
e Create, build, debug, or manage embedded applications for Lattice RISC-V CPU/SoC solution.
e  Provide extra build steps to generate the binary and memory files required for deployment.

e  Build using the latest industry standard open source components and tools for RISC-V firmware development and
debugging.

e  Support Picolibc for RISC-V, and provide lightweight standard library implementation.

e  Provide fully-configurable toolchain definitions.
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3. Lattice Propel Tool Flows

The Propel tool flows including SoC project design flow, C/C++ project design flow, system simulation flow, and
programming and On-Chip-Debugging (OCD) flow, are discussed in detail in the following sections.

3.1. Propel Environment

3.1.1. Running Lattice Propel

After installing Lattice Propel, you can launch Propel from the desktop shortcut icon or from the Windows Start menu.
When Lattice Propel is invoked, a dialog (Figure 3.1) pops up. You can browse to select where to locate the workspace.
For normal needs, just click Launch to pick the default location and continue running Lattice Propel.

g Lattice Propel Launcher d

Select a directory as workspace

Lattice Propel uses the workspace directory to store its preferences and development artifacts.

Workspace: | w Browse...

(] Use this as the default and do not ask again

» Recent Workspaces

Figure 3.1. Select Workspace Dialog

After the workspace location is chosen, a single workbench window is displayed using default Propel SDK perspective.
The default Propel SDK perspective contains the following five functional areas (Figure 3.2).

Note: A perspective is a group of views and editors in the Workbench window. A workspace is the directory where
stores your work and it is used as the default content area for your projects as well as for holding any required
metadata. A workbench is the desktop development environment in Eclipse IDE platform.

1. Menu bar and Toolbar, including: File menu, Edit menu, Source menu, Refactor menu, Navigate menu,
Search menu, Project menu, Run menu, LatticeTools menu, Window menu, and Help menu.

Project Explorer view: displays projects in the workspace.
Editor view: provides capability of editing source files.

Outline view: displays an outline of a file that is currently open in the editor area.

v wnN

Log area includes these views: Problem view, Tasks view, Console view, Properties view, and Terminal view.
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B G B R @ S E-G it -0 QOB F- HE 10 FOIRS D Y -G -erD|

Q iE|E
= O

I
There is no active editor that
provides an outline.

There are no projects in your workspace.
To add a project:

Create a new Lattice 5oC Design
Project
Q Create a new Lattice C/C++ Project
rﬁ Create a project...
Ex3 lmport projects...

2

2 Problems [ Tasks | & Console 52 . [T Properties | & Terminal B~~~ = 08
o consoles to display at this time.

Figure 3.2. Propel Workbench Window

3.1.2. Importing Lattice SoC Design Projects

In Propel SDK, you can use the Import Wizard to import Lattice SoC design projects into workspace. Existing SoC design

projects created by either Propel SDK or Propel Builder can also be imported into Workspace by choosing Lattice
Propel > Lattice SoC Design Projects.

1. From Lattice Propel SDK, choose File > Import....
The Select wizard opens (Figure 3.3).

© 2024 Lattice Semiconductor Corp. All Lattice trademarks, registered trademarks, patents, and disclaimers are as listed at www.latticesemi.com/legal.
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£ Import O x

Select

Import Lattice SoC Design projects into the workspace, Iﬁ

Select an import wizard:

| type filter text |

» [= General

v OFC++

s = Git

» [ Install

w [ Lattice Propel
ﬁ Lattice C/C++ Projects into Workspace
4 Lattice SoC Design Projects into Workspace

» = Oomph

» [= Run/Debug

» [= SVEditor

5 = Team

» = XML

@ <= Back Mext = Finish Cancel

Figure 3.3. Import Projects Wizard - Lattice Propel

2. Select Lattice Propel > Lattice SoC Design Projects into Workspace. Click Next.
The Select wizard switches to Import Lattice SoC Design Projects wizard page (Figure 3.4).

© 2024 Lattice Semiconductor Corp. All Lattice trademarks, registered trademarks, patents, and disclaimers are as listed at www.latticesemi.com/legal.
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0% Import (Il >
Import Lattice SoC Design Projects

Select a directory to search for existing Eclipse projects.
Select root directory | D0\ W Browse..,
Projects:

SoC_deme (DASoC_dema) Select All
Deselect All
Refresh
?) < Back Next > Finish Cancel

Figure 3.4. Import Lattice SoC Design Projects Wizard

3. Locate the directory containing the projects by clicking the Browse button.
4. In Projects area, select the SoC design project or projects you want to import.
5. Click Finish to start the importing process.

3.1.3. Importing Lattice C/C++ Projects

In Propel SDK, you can use the Import Wizard to import existing Lattice C/C++ projects created by Propel SDK 2023.2 or
later into workspace by choosing Lattice Propel > Lattice C/C++ Projects.

1. From Lattice Propel SDK, choose File > Import....

The Select wizard opens (Figure 3.5).
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2 Import O X

Select

Import Lattice C/C++ projects into the workspace, Iﬁ

Select an import wizard:

| type filter text |

» [= General

» [= C/C++

» [= Git

» [ Install

w [= Lattice Propel
S Lattice C/C++ Projects into Workspace
4., Lattice SoC Design Projects into Workspace

» = Qomph

» = Run/Debug

» [~ SVEditor

» [~ Team

» [= XML

® < Back Finish Cancel

Figure 3.5. Import Projects Wizard — Lattice Propel

2. Select Lattice Propel > Lattice C/C++ Projects into Workspace. Click Next.

The Select wizard switches to Import Lattice C/C++ Projects wizard page (Figure 3.6).

% Import O

*
Import Lattice C/C++ projects E:‘_—]_
|

Select a directory to search for existing Lattice C/C++ projects.

Select root directory: | Divriscv_mc_helloworld V| | Browse... |
Projects:
riscv_mc_helloworld (D\riscv_mc_helloworld) Select All
Deselect All
Refresh
® = Back Mext =» Finish Cancel

Figure 3.6. Import Lattice C/C++ Projects Wizard
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3.1.4. Create Customized C/C++ Template

In Propel SDK, you can select a Lattice C/C++ project in current workspace to create a user application template for
creating new Lattice C/C++ project.

1. From Lattice Propel SDK, choose Project > Create Lattice Application Template or right click on a project > Create
Lattice Application Template

Create Lattice Application Template wizard page (Figure 3.7).

7% Create Application Template O X
Application Template Configuration =
/ /
/ /
Create an Application Template for new Lattice C/C++ Project. 9
General Toplchain  |P Settings
v W] = src [£] FreeRTOSConfig.h
~ (W] (= FreeRTOS [ T linker.Id
[m] (= include [ main.c
~ [m] (= portable [ os.c
(|] = MemMang [8] syscalls
m] = config @ syscall.h
General
Export Source |riscv_rtos_freertos w

Ternplate Mame | My FreeRTO5 Project

Custom-FreeRTOS-Project

1.FreeRTOS Kernel V10.0.1 with two tasks:
Descripton taskl, pmp test and led blink.

task2, uart print.
2.Use heap_4 for default memory management.
3.Mew Features,

Figure 3.7. Create Application Template

2. You can input Template name, Description, Toolchain Configurations, IP Settings etc., and select files for creating
template.
3. Click Finish.

3.2. SoC Project Design Flow

A new SoC design project including a Propel Builder design can be started from the Lattice Propel sets. Follow the steps
below to create a new SoC design project.

3.2.1. Creating an SoC Design Project

To start a Lattice SoC Design Project from Propel:

1. In Lattice Propel, choose File > New > *n Lattice SoC Design Project.

© 2024 Lattice Semiconductor Corp. All Lattice trademarks, registered trademarks, patents, and disclaimers are as listed at www.latticesemi.com/legal.
All other brand or product names are trademarks or registered trademarks of their respective holders. The specifications and information herein are subject to change without notice
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The Create SoC Project wizard opens (Figure 3.8). In the Create SoC Project wizard, you can specify a device or a

board for a Template SoC project.

e To specify a device for your new Template SoC project, use the drop-down menu to select desired device
information, including Processor, Family, Device, Package, Speed, and Condition. Also, select RISC-V SoC

Project or Empty Project in the Template Design field (Figure 3.8).

7% SoC Project O d
Create SoC Project —
Create 5oC project of selected template |
Project name: | ExampleSoC
Use default location
Location: | CAlscc\propel2024. T\workspace\ExampleSoC Browse...
Choose file systern: | default
Language: | Verilog ~
] Board
Device Select
Processor: |RISC-V MC ~ | Family: ~
Device: LEMXO3D-9400HC ~ | Speed: ~
Package: |CABGA236 ~ | Condition: ~
Template Design
Emgﬁ Project RISC-V MC IP based 50C Project.
Components included:
a) Processor - RISC-V MC wy/ PIC/TIMER
b) GPIO
) ASRAM - Asynchronous SRAM
d) UART - Serial port

Figure 3.8. Specify a Device for Template SoC Project

© 2024 Lattice Semiconductor Corp. All Lattice trademarks, registered trademarks, patents, and disclaimers are as listed at www.latticesemi.com/legal.
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e  Or, to specify a board for a new Template SoC project, check the Board checkbox (Figure 3.9).

Note: You can choose VHDL/Verilog in the Language field.

3% SoC Project | X

Create SoC Project —

Create 50C project of selected template

Project name: | ExampleSoC

Use default location

Chlscc\propel\2024.1\workspace\ExampleSoC Browse...
default
Language: | Verilog ~
Board
Board Select
Certus-MNX Versa Evaluation Processor: | RISC-V MC hd

CertusPro-MNX Evaluation

CrossLink-NX Evaluation

ECP5-5G Versa

Lattice Sentry Demo Board for Mach-MNX (256)
Lattice Sentry Demo Board for Mach-NX (484)
Lattice-Avant Evaluation

Machx02 Breakout

MachX03D Breakout

MachX03D PFR Demo

Template Design

Emga Project RISC-V MC IP based SOC Project.
a) Processor - RISC-V MC w/ PIC/TIMER

Components included:
b) GPIO
=]

ASRAM - Asynchronous SRAM
d) UART - Serial port

Figure 3.9. Specify a Board for Template SoC Project

From the Board Select area, select the desired board, such as MachXO3D Breakout.

Enter a project name.

Note: Do not include periods, colons, or spaces in the project name.
4. (Optional) To change the default location, clear the Use default location option, then browse for another location.
Choose a file system.
Select a desired platform template design. In particular, select empty project for building system from scratch.

Click Finish.

The SoC design project is created in workbench, and its design is opened and displayed in Lattice Propel Builder

(Figure 3.12).

© 2024 Lattice Semiconductor Corp. All Lattice trademarks, registered trademarks, patents, and disclaimers are as listed at www.latticesemi.com/legal.
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3.2.2. Open an SoC Design in Propel Builder
Within an SoC project, there is a Propel Builder design.
To open Propel Builder for an SoC project:

1. Inthe Project Explorer view, select an SoC project.

2. Open the SoC project in one of the following ways from Lattice Propel:

e Choose LatticeTools > . Open Design in Propel Builder (Figure 3.10).

LatticeTools | Window  Help

4. Open Design in Propel Builder

#  Generate and Open Diamond Project
Generate and Open Radiant Project
Lattice Sentry Toels for MachX03D >
Lattice Sentry Tools for Mach-NX >

Figure 3.10. LatticeTools Menu

e Click the Propel Builder icon M on the toolbar.

e Right-click the SoC project from Project Explorer. Choose Open Design In > H'I'l Propel Builder from the popup

menu (Figure 3.11).

Restore from Local History...

Open Design In > l & Propel Builder
Team » = Diamond
Compare With > Radiant

Figure 3.11. Project Explorer Popup Menu

3. The SoC Design is opened and displayed in Propel Builder (Figure 3.12).

% Propel Builder [C:/Iscc/propel/2024,
File Edit View Design Tools Window Help

s-THA 9 L MEENOoBAYeE QQ@Q A
Designiisy o schematic Address . start Page
3 LCMXO3D-0400HC-5BG256C -
~ 1F ExampleSoC &) o
b 5P Instances
» 2= Ports
bR Nets
- Components
[ cpu0:2.4.0
(2] gpio0:1.6.1
[] sysmem0:2.0.0
[ vart0:1.2.0 |_ cput_inst
[15] ahbl0:1.3.0 [Bra st wewm eyl
[ ahbl2apb0:1.1.0 i el £

[T apb0:1.2.0 ;:jg i “::lq;?_ {_
J

Properties

Name: | ExamplesoC

Type: Instance

Path: ExampleSoC

VLNV: Tl
File:  C:Vecclpropel (2024, 1iworkspacel

« »
1P Catalog Design View 0 5
Tel Console [m]

% sbp_design save
% sbp_design generate

INFO <2358188> - Start: sbp_design generate.
INFO <2359190> - Finished: sbp_design generate.

% sbp_design pge sge -1 (C:\lscc\propel\2024.l\workspace\ExampleSoC\ExampleSoC/ExampleSoC.sbx} -o {Ci/lsce/propel/2024.1/workspace/ExampleSoC/ExampleSoc/ ../} -
nc o

Figure 3.12. Propel Builder Window
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4. (Optional) Modify the design in Propel Builder as desired. Most of the templates include a functional-ready SoC
design.
Note: You can only create an SoC design using Empty Project template inside the Propel Builder. Refer to
Lattice Propel Builder 2024.1 User Guide (FPGA-UG-02196) for more details on how to create an SoC design using
Empty Project template.

3.2.3. Open Design in Lattice FPGA Design Software

Within an SoC project, you can create a Lattice FPGA design project including a Propel Builder design, and then open
the FPGA design project in appropriate software. There are two FPGA Design Software available, Lattice Diamond and
Lattice Radiant™. Depending on the device family used in the SoC project, only one of the FPGA Design software can be
selected from the User Interface (Ul), the other is grayed out. If the MachXO3D or LFMNX device family is used, the
Lattice Diamond related menu items are active from Lattice Propel Ul. If the LIFCL or LFD2NX device family is used, the
Lattice Radiant related menu items are active from Lattice Propel Ul.

To open FPGA Design Software for an SoC project from Lattice Propel:

1. (Optional) Set Lattice FPGA design software installation location from Lattice Propel. By default, Lattice Propel can
find the proper Lattice FPGA design software installation location, usually the latest version installed on the PC. You
can overwrite it following steps below.

Choose Window > Preferences. The Preferences dialog opens (Figure 3.13).

Select Propel Setting from the left pane. Click the Browse button to pick up the installation location of Diamond or
Radiant. Or, leave the Radiant Location and Diamond Location fields blank, as default. Lattice Propel can find the
location automatically.

{71 Preferences O X

type filter text | Propel Setting = - 3
General

C/C++ Radiant Location
Context |

Help | Browse...

Install/Update

LiClipse Diamond Location
MCU |

Oomph

Propel Setting

Remote Development SoC Templates Install Path
Run/Debug

SVEditer

SWTChart Extensions
Terminal Application Templates Install Path

Validation | Ci\Users\swang(1\PropelEmbeddedSWLocal |
Version Control (Team)
KML

| Browse...

| C:/Users/swang01/PropelTemplatelLocal |

Restore Defaults Apply

'i?:' |[\_4. ridy @ @ Apply and Close Cancel

Figure 3.13. Propel Preferences Dialog

2. Inthe Project Explorer view from the Propel main Graphical User Interface (GUI), select an SoC project.

3. Open the SoC project in one of the following ways:
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e Choose LatticeTools > * Generate and Open Diamond Project; Or, choose LatticeTools >

>

Open Radiant Project.

e Click the Diamond icon

e Right-click an-SoC project from the Project Explorer. Choose Open Design In >
Radiant from the right-click menu.

Design In >

“%"or the Radiant icon

from the toolbar.

Generate and

‘Diamond. Or, choose Open

4. The Diamond/Radiant project for SoC is generated at background and is launched (Figure 3.14/Figure 3.15).

# Lattice Diamond - Start Page - u] X
File Edit View Project Design Process Tools Window Help
A-E-Ha B8y ih @GERIVAAQ B
ZECEHESESCEEQR=UsoVMBY EBEHNENE:@
File List 8 X [ start Page [ & x
v [ ExampleSaC A
LCMXO3D-9400HC-5BG256C .
. i strateics Project: Release Notes FPGA Design Guide ~
B Ag [ open... Lattice Dismond Software 3.13 Release Notes Design Flanning
& Area
1/0 Assistant fRnen... User Guides HDL Coding Guidelines
Quick {3 Import ispLEVER Project... Lattice Diamend 3.13 User Guide Timing Closure
Timing Recent Projects: Lattice Synthesis Engine for Diamend User Guide  Other Tool Guides
Strategy1 Lattice Diamond 3.13 Platform Designer User Guide ModelSim User Manual
v [EH impi1 Clarity Designer User Guide ModelSim GUI Reference Manual
¥ L InputFiles Lattice Diamond 3.13 Programming Tools User ModelSim Command Reference Manual
M ExampleSoC/lib/latticesemi.cor Guide
ModelSim Tutorial
M ExampleSoC/lib/latticesemi.cor Reveal User Guide
¥ SxampleSoC/lib/| Synplify Pro User Guide
ampleSoC/lib/latticesemi.corv Revesl Troubleshooting Guide cynplify Pro Ref Manual
¥ ExampleSeC/lib/latticesemi.com ynpilty Pra Reference Manua
Lattice Diamond 3.13 Installation Guide for Windows
Wi ExampleSoC/lib/latticesemi.com Software Update Center Synplify Pro Language Support Reference Manual
N . Lattice Diamond 3.13 Installation Guide for Linux Tk
¥ ExampleSoC/ib/latticesemi.cor Currently running Lattice Diamond software versions: el
M ExampleSoC/lib/latticesemi.com 3.13.0.56.2 Reference Guides ) Lattice on the Web
@ ExampleSoC/ExampleSoC_Top. No updates available Lattice Diamoend 3.13 FPGA Libraries (HTML version) Lattice Semiconductor
M ExampleSoC/ExampleSoC.y Last check time: Tue Apr 16 09:25:17 2024 Lattice Diamond 3.13 FRGA Libraries (PDF version) o
S v Help Lattice Solution v
Flelist  Process  Hierarchy
[Tcl Console & x
> source "C:/lscc/propel/2024.1/workspace/ExampleSoC/diamond setup_template.tcl™
>
Td Console Output Error Warning™ Info*
Ready Mem Usage: 167,532K

Figure 3.14. Diamond Project
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Lattice Radiant Software - Reports - [m} x
File Edit View Project Tools Window Help
o= F3 z] = o ' (nr =
"B H 9D« Qe I nL e@erNBEERGQORER G
> u Synthesize Design u Map Design u Place & Route Design u Export Files i
Qv Frd Text,.. 2 x 2 start Page | Reports A
=
= [ ExampleSoC
1 LIFCL-40-8BGA00C Reports ExampleSoC Project Summary
< Strategies Implementation Name: impl_1 Performance Grade: 8H
—
2| Area
— _ Strategy Name: Strategy1 Operating Condition: con
2=| Timing
5] Part Number: LIFCL-40-8BG400C Synthesis Syn
- fiSteteavt » (1] Synthesis Reports
~ /7 impl_1(Synplify Pro) Family LIFCL Timing Errors:
v Input Files
3 Device: LIFCL-40 Project Created 202
+ [ Pre-Synthesis Canstraint Files iMapBepois :
Synplify Pro Package: CABGA400 Project Updated 202
. ; : »
b ) el Enaerilids @ RENERES Project File: Cillsecipropeli2024. 11w ExampleSoC/E rar
Debug Files
Script Files | D Export Reports Implementation Location: C:fiscc/propel/2024 1/ workspace/ExampleSoC/impl 1
Analysis Files
Pregramming Files
El 9 » [7] Misc Reports Resource Usage
4 3
LUT4. 0 10 Buff 0
+ I} ExampleSoC - ExampleSaC.y M s
b TF vartD{uartl_inst) - uartly PFU Register 0 EBR 0
b TF sysmemO(sysmem0_inst) - sysmem...
v TF plio(pli0_inst) - plid.v
v IF oscO{oscinst) - pscD ‘ i
4 ﬂ gpioligpiol_inst) - gpicl.v > source "C:/lscc/propel/2024.l/workspace/ExampleSoC/radiant setup template.tcl” [t x5
v TF cpul(cpud_inst) - cpuly
v 1 F apb(apb0_inst) - apb0.v
» ZE ahbl2apb0(ahbl2apb0_inst) - ahbl2a...
» ZE ahbl0(ahbl0_inst) - ahblo.w
O File List [E] Source Template =] 1P Catalog Tdl Console = output E? Message

Figure 3.15. Radiant Project

(Optional) From the File List view of the Diamond/Radiant software:

¢ modify the top-level RTL file (<proj_name>_Top.v) to match the SoC design, presupposition of which is that
there is a top-level RTL file in your SoC design; or

e create a top-level RTL file (<proj_name>_Top.v) to match the SoC design, if the SoC design is created from an
Empty Project template and there is no top-level RTL file in your SoC design.

(Optional) Modify constraint file (<proj_name>.lpf/<proj_name>.pdc) to match the SoC design, if you have
modified the SoC design.

Note: This step is a must for the SoC design created from the Empty Project template.
Process the design in Lattice Diamond/Radiant.

In Diamond software, switch to Process view of the project (Figure 3.16). Make sure at least one file, IBIS Model,
Verilog Simulation File, VHDL Simulation File, Bitstream File, or JEDEC file, is checked in the Export Files section fo

programming. Choose Process > I Run.

r
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2 Synthesize Design
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_, ¥ SmelfyP Project: Release Notes FPGA Design Guide a
2 Translate Design o
v 2 Mop Design # Open Lattice Diamond Software 3.13 Release Notes Design Flanning
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[0 2 Map Trace B vew... User Guides HDL Coding Guidelines
[0 2 Verilog Simulation File [ Import ispLEVER Project... Lattice Diamend 3.13 User Guide Timing Closure
2 VHDL Simulation File oot Lattice Synthesis Engine for Diamond User Guide Other Tool Guides
Recent Projects:
v 2 Place & Route Design Lattice Diamond 3.13 Platform Designer User Guide ModelSim User Manual
-
0] & Place & Route Trace Clarity Designer User Guide ModelSim GUI Reference Manual
[J & 170 Timing Analysis
- g Analy: Lattice Dismond 3.13 Programming Tools User Guide  ModelSim Command Reference Manual
-
O & Thermal Analysis Reveal User Guide ModelSim Tutorial
~ 2 Export Files
O 2 135 Model Reveal Troubleshooting Guide Synplify Pro User Guide
0] 2 Verilog Simulation File Lattice Diamond 3.13 Installation Guide for Windows  Synplify Pro Reference Manual
[0 & VHDL Simulation File Lattice Diamond 3.13 Installation Guide for Linux Synplify Pro Language Support Reference Manual
" Software Update Center
& Bitstream File Curent de e Dismond softw Reference Guides Telf Tk
- urrently running Lattice Diamond software version:
& JEDEC File o n"sﬁ z < Lattice Diamond 3.13 FRGA Libraries (HTML version)  Lattice on the Web
. Lattice Diamond 3.13 FRGA Libraries (PDF version Lattice Semiconductor
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synpwrap -msg -prj "ExampleSoC_impll_synplify.tcl® -log "ExampleSol_impll.srf”
Copyright (C) 1992-2023 Lattice Semiconductor Corporation. All rights reserved.
Lattice Dizmond Version 3.13.0.56.2
INFC - Synplify synthesis engine is launched.
v

Tcl Console Output  Error
Start: Synplify Pro

Warning

Info™

Mem Usage: 582,392 K

Figure 3.16. Generate Programming File in Lattice Diamond

In Lattice Radiant software, from the Process Toolbar, click Export Files (Figure 3.17).

Lattice Radiant Software - Reports - x
File Edit View Preject Toels Window Help
S — = H
[+] | @ Q Q Q @ ”
o O womr | [ roconacomn o[ s | |
Qe FndTet. A x Y Start Page ] Reports ° A
« [ ExampleSoC . Synthesize Design
Synplify P
I LIFCL-40-8BG400C Reports - ymplify Pro
) Post-Synthesis Timing Analysis
< Strategies . X Performance Grade g H
= a Post-Synthesis Simulation File
| Area
j— Map D Operating Condition: con
== Timing ap Design
: Mep Timing Analysis {BG400C Synthesis syn
£ strategyt ¥ [Z] Synthesis Reports Place & Route D.
= . . ace oute Design
v 7 impl_1 (Synplify Pro} Timing Errors:
) Place & Route Timing Analysis
3 Input Files — 202
4 1/0 Tirming Anak roject Created: !
+ [ Pre-Synthesis Constraint Files MapREDOTS /0 Timing Analysis o
Synplify Pro Export Files ] Project Updated: 202
Bitstream File
o i i 3
» [ Post-Synthesis Constraint Files RHCEEROUIEREDOIS \BIS Model 36/2024. 1hworkspace/ExampleSoC/ExampleSoC.rdl
Debug Files -
§ ~ Gate-Level Simulation File 2eli2024 1/workspace/ExampleSoCimpl 1
Script Files W » [7] Export Reports e et
Analysis Files
Programming Files
¥ 2] Misc Reports
4 3
LUT4: 0 10 Buffers: 0
- x
3 PFU Register; 0 EER 0
3
3
3 ‘ _ 3
b > source "C:/lscc/propel/2024.1/workspace/ExampleSoC/radiant_setup_template.tcl" o
r > prj_run PAR -impl impl 1
3
3
3
[ File List  [E] Source Template 1] 1P Catalog Td Console = output Bl Message

Figure 3.17. Generate Programming File in Lattice Radiant

The Programming file is generated. The generated programming file can be used in Programmer.

Note: Programmer is a tool that can program Lattice FPGA SRAM and external SPI Flash through various interfaces,
such as JTAG, SPI, and I°C.
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3.2.4. Generating System Environment by Building Project

System environment package including the system environment file and the BSP package is required for the embedded
C/C++ project.

To generate system environment package from Lattice Propel:
1. Inthe Project Explorer view, select an SoC project.
2. Choose Project > Build Project.

3. Check the building result in the Console view (Figure 3.18).

{2 Problems || Tasks | Bl Console < = Properties | & Terminal

X% &REE ~ -
<terminated> sge [SDP Builder] Ch\lscch\propel2024. 1\ tools\python38_embed\python.exe (Terminated Apr 16, 2024, %:33:11 AM] [pid: 8%08]

WARNING - (PGE SoCDesign) cpu®_inst_TIMER_IRQ M@ remains uncennected
INFO - (PGE) Finished: sge generated

Figure 3.18. Build Result of SoC Project

3.2.5. About SoC Design Project

The SoC project creating starts with a functional-ready SoC design and a default simulation environment. In the Project
Explorer view, open an SoC project folder and all its sub-folders. The project contains (but is not limited to) the
following files (Figure 3.19), some of which may vary upon opening the SoC design project in Diamond or Radiant
software:

e <proj_name>: folder containing a Propel Builder design including the .sbx file.

e <proj_name>/application: folder containing functional-ready embedded application source codes.
e impll: folder containing the implementation of Lattice Diamond/Radiant project.

e sge: folder containing generated package necessary for creating C/C++ project.

e verification: folder containing the SoC verification project.

e verification/sim: folder containing the simulation environment.

e <proj _name>.ldf: Lattice Diamond project file.

e <proj_name>.lpf: Lattice Diamond project logical preference file.

e <proj_name>.rdf: Lattice Radiant project file.

e <proj_name>.pdc: Lattice Radiant project post-synthesis constraints.

e <proj _name>.txt: description file from the template.
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=
(- Project Explorer = 0
2

v =% ExampleSoC

v = ExampleSoC
= lib
ExampleSoC_tmplyv
Vi ExampleSoC_tmplvhd
Example5SoC_Top.v
Example5oC.layout
7| ExampleSoC.sbx
Example5SoCwv
= impll
v = sge
= bsp
= soc_svd
fai) cpulyaml
ﬁ sys_env.xml
w = verification
= lib
jsen Example5oC_v.json
7| ExampleboC_v.sbx
diamond_setup_template.tcl
[] ExampleSoC.Idf
Example5oC.Ipf
ExampleSoC. bt

Figure 3.19. Contents of SoC Project

3.3. C/C++ Project Design Flow

3.3.1. Creating a Lattice C/C++ Project

To start a Lattice C/C++ Project from Lattice Propel:

Choose File > New > 5| Lattice C/C++ Project.

The C/C++ Project wizard opens with the Load System and BSP page (Figure 3.20).
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38 C/C++ Project O X

Load System and BSP —

Load lattice system environment file and BSP package

Select system environment file and BSP package

System env: | Cllscch\prope2024. 1\ workspaceiHelloWorldSoCsgelsys_envacml ~ Browse...

Select processor core to create C/C++ Project

Core selected: | cpul_inst

Projecttyper | C ~

System information

Device Family CPU Name Instance Name

Mach¥Q3D riscy_mc cpul_inst

Select Example Application

Example-HelloWorld-blink-uart

1.Led blink
The corresponding SoC project should include gpio instance.

2.Uart print
There art tow ways to support uart print:
a) The correspending 5o0C project should include uart instance or local uart.
b) Enable Semihosting(System Library) when creating this project.

Project name: | fiscv_me_helloworld

Use default location

Location: | Chlscc\propel2024.1\workspacehriscv_me_helloworld Browse...

Choose file systerm: | default

[] Build the project
Create a debug launch configuration for  OpenOCD

® < Back Finish Cancel

Figure 3.20. Load System and BSP Dialog

2. Browse to the SoC project folder and select the system environment file sys_env.xml.

All system environment files available in the current workspace can be selected from the System env drop-down

menu. If you select or enter QEMU RISC-V Virtual SoC System, you can select QEMU application template to create
project (Figure 3.21).
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£33 C/C++ Project O *

Load System and BSP —

Load lattice system environment file and BSP package

Select systemn environment file and BSP package

S WO EMU RISC-V Virtual 50C System R Browse...
Chlzcc\propel2024. 1" workspace\HelloWorldSoC\zsge\sys_env.axml

Select proce:
Core selected: | spike ~
Project type: | C ~

System information

Machine Name CPU Mame
spike

Select Example Application

QEMU_helloworld Project Example_QEMU_hellowarld

1.QEMU test.
2.5emihost print.

Note:
1.Please select Semihosting(System Library) when creating this project.

Project name: | spike_gemu_hellowaorld

Use default location

Ty,

Cihlsec\propeh2024. hworkspace\spike_gemu_helloworld Browse...

default

[]Build the project
Create a debug launch configuration for | QEMLU

® < Back Finish Cancel

Figure 3.21. Load System and BSP Dialog

If the platform has more than one processor, choose one core.
Select the project type, C or C++.
Select the application in the Example application list.

o v kW

There is a default project name. You need to check it. Suggest not using periods, colons, or spaces in your project
name. Though spaces are allowed, they may cause certain issue with some tools.

7. By default, the Use default location option is checked. The default file system is selected automatically. Suggest
using the default location unless you have special need to a special location.

8. The Build the project option is unchecked by default. If you want to build the project automatically, you can check
the option.

9. By default, the Create a debug launch configuration for option is checked and a default launch configuration is
created accordingly.

10. Click Next. The Lattice Toolchain Setting dialog opens (Figure 3.22).
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£} C/C+ Project d x

Lattice Toolchain Setting

Configuration: | Debug ~

Lib Setting  C/C++ Compiler C/C++ Linker

(_) Mo default libraries (-nodefaultlibs)
() Newlib

(O Newlib-nano (--specs=nano.specs)
(®) Picolibe (--specs=picolibc.specs)

Printf Level
(®) Integer only printf (-DPICOLIBC_INTEGER_PRINTF_SCANF)

() Float printf (-DPICOLIBC_FLOAT_PRINTF_SCANF)
() Full printf (-DPICOLIBC_DOUBLE_PRINTF_SCANF)

System Library
(® Default

(O Semihosting (--oslib=semihost)
() Dummyhosting (--oslib=dummyhost)

':?:' < Back Mext = Cancel

Figure 3.22. Lattice Toolchain Setting Dialog

11. By default, two toolchain configuration modes, Debug and Release, can be chosen from the Configuration
drop-down menu.

e Debug configuration creates executables containing additional debug information that lets the debugger make
direct associations between the source code and the binary files generated from the original source.

e Release configuration provides the tools with options setting to create an application with the best
performance.

You can modify frequently-used library, compiler, and linker options for each configuration. For a complete
toolchain setting, go to project properties after creating the project. Refer to the Advanced Tool Chain Setting
section.

e In Lib Setting tab, standard C library can be reconfigured. Picolibc (C Libraries for Smaller Embedded Systems)
is selected by default and it supports different printf levels.

e In C/C++ Compiler tab, optimization level and debug level can be reconfigured for each toolchain
configuration.

e In C/C++ Linker tab, Remove unused code (--gc-sections) is checked by default for garbage collection of unused
code.
12. Click Finish.

The Lattice C/C++ project is created and is displayed using the Propel SDK perspective. A perspective is a collection
of tool views for a particular purpose. The Propel SDK perspective is for creating Lattice C/C++ programs.
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3.3.2. Updating a Lattice C/C++ Project

When you make changes to an SoC project, sometimes you want to synchronize the changes to an existing Lattice
C/C++ project instead of creating a new Lattice C/C++ project. In this case, you can use the update C/C++ project
feature.

Note: This feature overwrites the corresponding files or settings of your existing C/C++ project. Be sure to back up your
C/C++ project before using this feature.

To update a Lattice C/C++ Project from Lattice Propel:

1.

Generate the latest system environment package according to the Generating System Environment by Building
Project section.

In the Project Explorer view, select a C/C++ project.
Choose Project > Update Lattice C/C++ Project....
The C/C++ Project wizard opens for updating system and BSP (Figure 3.23).

o
wrd

Update System and BSP

Select system environment file and BSP package

Current System enwv: | C/flscc/propel/2024.1/workspace/Example/src/sys_env.xml |

MNew System enw: | C:f/Users/Lattice/Crosslink_MX_ledi_HW_Radiant,/sge/sys_env.aeml | Browse...

(] Re-generate toolchain parareters and linker script
[]Update BSP package

Update BSP Driver Information

Driver Mame Current P Version (Driver Version) Mew IP Version (Driver Version)
Tiscv_mc 24.0 241
gpio 1.6.1 1.6.2 (1.6.2)
system_memory 2.00 2.0.1 (2.0.1)
uart 1.3.0 1.3.1 [1.3.1}

Update Cancel

Figure 3.23. Update System and BSP Dialog

Browse to the SoC project folder and select the system environment file sys_env.xml.
Select the checkbox for what you can update:

e Re-generate toolchain parameters and linker script: check this option if you want to modify CPU or memory in
the system.

e Update BSP package: check this option if you want to add additional IP components into the system.
Click Update to make changes for the selected C/C++ project.
Click Yes. (Figure 3.24).
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This feature overwrites the corresponding files or settings of
your existing C/C++ project. Be sure to back up your C/C++
project befare using this feature. Do you want to continue?

Yes Mo
Figure 3.24. Update System and BSP Confirm Dialog

3.3.3. Building a Lattice C/C++ Project

To build a Lattice C/C++ project in Lattice Propel:

1. Inthe Project Explorer view, select a C/C++ project.

2. Follow steps below if you want to change the active build configuration:

Choose Project > Build Configurations > Manage.... Or, click the Configuration icon % on the toolbar.

b. The Manage Configurations dialog opens (Figure 3.25) for choosing active configuration. By default, a Debug
configuration creates executables containing additional debug information that lets the debugger make direct
associations between the source code and the binary files generated from the original source. A Release
configuration provides the tools with options setting to create an application with the best performance.

S Example: Manage Configurations d
Configuration Description Status
Debug Active
Release
Set Active MNew... Delete Rename...

Figure 3.25. Manage Configurations Dialog

3. Choose Project > Build Project. Or, click the Build icon % on the toolbar.
4. The results of the build command are displayed in the Console view (Figure 3.26).

[2) Problems | 4= Tasks | &) Console 3 [ Properties | & Terminal L 4 <ﬁ>| wl @A = | MmEB--= O
CDT Build Console [Example]

Invoking: GNU RISC-V Cross Print Size
riscv-none-embed-size --format=berkeley "Example.elf”
text data bss dec hex filename
1262 8 2728 3996 fo6 Example.elf
Finished building: Example.siz

Invoking: Lattice Create Memory Deployment
riscv-none-embed-cbjcopy -0 binary --gap-fill @ "Example.elf” “Example.bin™; srec_cat "Example.bin”

-Binary -byte-swap 4 -DISable Header -Output "Example.mem” -MEM 32
Finished building: Example.mem

15:58:18 Build Finished. @ errors, @ warnings. (tock 5s5.21ms)

Figure 3.26. Build Result of C/C++ Project
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3.3.4. About Lattice C/C++ Project

The Lattice C/C++ project starts with source code. In the Project Explorer view, open a C/C++ project folder and all its
sub-folders. The project contains:

src/bsp/driver: folder containing driver codes from the IP in the platform.

src/bsp/sys_platform.h: header file that defines DEVICE_FAMILY (the Lattice FPGA), address mapping, and any IP
parameters that can be used by the drivers.

src/main.c: source file containing the main routine, which is the entry-point of a C/C++ program.
src/cpu.svd: system view description file used for peripherals registers view at debug perspective.
src/cpu.yaml: processor description file used at debugging time.

src/linker.ld: linker script file.

src/sys_env.xml: system environment file describing aspects of the platform, such as memory spaces.

After building the project, the build output can be found in each build configuration folder, the Debug folder or the
Release folder (Figure 3.27). The Debug or Release folder contains:

<proj_name>.elf: executable file used in on-chip debugging.

<proj_name>.bin: binary file used in deploying the application to flash memory.
<proj_name>.Ist: extended listing file generated by tool objdump.

<proj_name>.map: linker map file.

<proj_name>.mem: Lattice system memory initialization file used in System_Memory IP.

<proj_name>.launch: Debug launch configuration.

Note: Some of the files listed in Figure 3.27 are intermediate files that you do not need to take care of.
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57 Project Explorer = 0

v = Example
q-,ff Binaries
[t Includes
w 2 src

v (& bsp
(= driver
[n] riscv_errors.h
[n] sys_platform.h

[ main.c
[ utils.c
[H] utils.h
£ cpu.svd
cpuyaml
el linker.ld

£
iE sys_envaeml

w = Debug

[ src
%5 Example.elf - [riscv/le]

|=| Example.bin

Example.lst
Exarnple.map
Example.mem
| @ makefile

| @ objects.mk

| @ sources.mk

|%] Examplelaunch
2% ExampleSoC

Figure 3.27. Contents of C/C++ Project

3.3.5. Assisting in developing Code

Lattice Propel is based on Eclipse IDE. You can write application code following the process and usage of the same tools
as any in Eclipse IDE. You can get more detailed information regarding Eclipse IDE from the Lattice Propel online help.

For writing code, Lattice Propel SDK provides two extra aids:
e Lattice System Platform: An overview of the processor platform can be displayed (Figure 3.28).

e Linker Editor: An overview of the memory regions of linker script can be displayed. You can modify key linker
parameters via the graphical interface (Figure 3.29).
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G Lattice Platform > = &
General
Vendor ‘ lattice
Library: ‘ Propel
Name: ‘ ExampleSeC
Version: [ 2024.1

DeviceFamily: | MachX03D

SysiD: (o

Selected Core: ‘ cpul_inst

JTAG Channel: | 14

component ipMame ipVersion driverVersion vendar baseAddress range irg
cpul_inst riscy_mc 240 latticesemi.com

pic_timer_mem_map  PIC_Timer_Registers OxFFFFOO00D 000000200
sysmem{_inst system_memaory 2,00 latticesemi.com 0x O
gpiol_inst gpio 1.6.1 latticesemi.com 0x00004400 (0x00000400 IRC_51
uartl inst uart 1.3.0 latticesemi.com O 1% IRQ_S0

Overview | sys_envxml

Figure 3.28. Lattice System Platform

S Lattice Platferm Tl Linker 3 = g

Linker Script: linker.Id
Available Memory Regions

MName Attributes  Base Address Size
sysmemb_inst WK 00 04000

STACK and HEAP Size

HEAP_SIZE: | 0x0 |
STACK_SIZE: | 0xA00 |

Section to Memory Region Mapping

CODE: | sysmem{_inst

DATA:  sysmem(_inst

Section Name Memeory Region "
text sysmeml_inst
«ctors sysmem0_inst
dtors sysmem{_inst
rodata sysmem{_inst
.data sysmem{_inst
bss sysmem{_inst w

Overview] Iinker.|d|

Figure 3.29. Linker Editor

3.3.6. Advanced Tool Chain Setting

Follow the process below to modify the tool chain settings of a C/C++ project.

To change tool chain setting in Project Properties in Lattice Propel:

1. Inthe Project Explorer view of Lattice Propel, select a C/C++ project.

2. Choose Project > Properties. The Properties for current project opens (Figure 3.30).

3. Select Settings of C/C++ Build category from the left pane. Select the Tool Settings tab.
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$ Properties for Example

type filter text

Resource
Builders
w C/C++ Build
Build Variables
Environment
Legging
Settings
Tool Chain Editor
C/C++ General
MCU
Project Matures
Project References
Run/Debug Settings
SystemVerilog Project Properties
Task Repesitory
Task Tags
Validation

Settings

Configuration: |Debug [ Active ]

B Tool Settings i3 Toolchains M Devices # Build Steps

@ Target Processor
(# Optimization
# Warnings
@ Debugging
~ %3 GNURISC-V Cross Assembler
(2 Preprocessor
@ Includes
(2 Warnings
(%2 Miscellaneous
w 83 GMWU RISC-V Cross C Compiler
@ Preprocessor
(22 Includes
@ Optimization
@ Warnings
(2 Miscellaneous
~ B GNURISC-Y Cross C Linker
@ General
(25 Libraries
(#5 Miscellaneous
w 3 GMU RISC-V Cross Create Listing
(2 General
~ [ GNU RISC-V Cross Print Size
@ General
~ %3 Lattice Create Memaory Deployment
(# General

RV32l (-march=rv32i*) ~

I Multiply extension (RVM)
] Atomic extension (RVA)

None ~

Compressed extension (RVC)

Floating point ABI

ILP32 (-mabi=ilp32*%) w
Mene W
Teolchain default ~
Teclchain default ~

~ | | Manage Configurations...

Build Artifact Binary Parsers @ |4 |*

Toolchain default (-mtune) w

[[15mall prologue/epilegue (-msave-restore)

Force string eperations to call library functions (-mmemcpy)

Other target flags |

Restore Defaults Apply

Apply and Close Cancel

Figure 3.30. Properties of C/C++ Project

4. Customize the tools and tool options. All your customization can be resulted in the build configuration in the Tool
Settings properties tab. The build configuration is used during your C/C++ project building.

Note: The setting for each configuration, Debug or Release, is independent.

5. Click Apply and Close to save the change.

Note: You may need to clean the project to make the new setting take effect for the whole project.

3.4. System Simulation Flow

The SoC Project created from template has a default simulation environment for you to setup and start functional
simulation. It is generated automatically along with the SoC project creation. You can use it as a start point and

customize accordingly.

The default simulation environment is with the following features:
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e  Provides similar user experience as real board-level debugging, such as for Hello World SoC, key components
including RISC-V MC, System memory, and UART.

e Simulates user-modified template SoC with extended HDL designs.

e Simulates the whole system using real C/C++ projects as stimulus with the necessary modification and with all the
details for debugging.

e Supports user extension with a friendly and flexible approach.

3.4.1. Launch Simulation
To launch simulation:
1. In Propel Builder, update the SoC design to enable simulation features.

e Enable the checkbox for Simulation Mode, and disable the checkbox for Debug Enable for RISC-V MC IP
module in the General area (Figure 3.31).

“, Module/IP Block Wizard X

Configure Component from IP riscv_mc Version 1.2.0
Set the following parameters to configure this component.

Diagram cpul Configure IP
| Property Value
* General
Simulation Mode ]
Debug Enable
Compressed Instruction Extension &
PIC Enable =
CpUU Timer Enable =
PIC and Timer Base Address (32'h00000000 ~ 32'hFFFFFFFF) | 32'hFFFFO0D00
- IRQ_SOAHBL_MU_INSTFE - Mumber of Interrupt Requests [2 - 8] 2
—(4HIRQ_S1 AHBL_M1_DATA4~
—{dk_i TIMER_IRQ_MO4H}~
—rst_n_i system_resetn_o—
riscv_mc
4 » | Mo DRC issues are found.
Generate Cancel

Figure 3.31. Configure Module RISC-V MC

e Enable the checkbox for Initialize Memory for system_memory IP module from the Initialization area of the
General tab, and set Initialization File generated from the corresponding C/C++ project (Figure 3.32).
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4. Module/IP Block Wizard x

Configure Component from Module system_memory Version 1.0.2
Set the following parameters to configure this component.

Diagram sysmem0 Configure IP
General Port 50 Settings Port 51 Settings
Property Value

Memory Address Depth [1 - 32768] | 8192

sysme moO Data Bus Width(bits) 2
- ~, Memory Type EBR
Port Count [1-2] 2
)\‘HBL_SO ECC Enable
Enable Arbiter
AHBL_S1 vAROSweamer
Enable FIFO Streamer

— ahbl_hclk_i oo

—ahbl_hresetn_i

Initialize Memaory

o S Initialization File Format hex

system._memory ||[Cimsis A —

4 4 Mo DR.C issues are found.

Generate Cancel

Figure 3.32. Configure Module System Memory

2. Click the Switch icon on the toolbar to switch between SoC design and SoC verification project (Figure 3.33).

3. After the SoC design is switched to an SoC verification project, click the Generate icon E; to generate the

simulation environment for OEM ModelSim. Click the Launch Simulation icon m (Figure 3.33).
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4, Propel Builder [Ci/lscc/propel/2023.2/workspace/ExampleSoC/verification/ExampleSeC_v.sbx] Device: LCMXO3D-9400HC-5BG236C Board: NA - m] b4
File Edit View Design Tools Window Help
0= -3 | ) f ™
3 & « MEENOoEB QQA@AQ@
Design View a Schematic Address . Start Page
LCMX03D-0400HC-5BG256C e
= 1F ExampleSoC_v Sy -
v ¥ Instances sysclk_rst_geni_inst uart_modell_inst
b Nets
- c t:
ormpenents th_dk_o uart_rx_data_debug[7:0]—
[£F] sysclk_rst_gen1:1.0.0 1'b0
[#] uart_model1:1.0.0 dut_clk_i dut_rst_of— uart_tx_data_debug[7:0]=
1'b0 .
dut_rst_i dut_dk_of— dk uart_rx_break_debugl—
th_rst_o rstn uart_rx_valid_debugf—
uart_rxd uart_tx_busy_debugl—
Properties
uart_tx_en_debug— dut_inst
Mame: | ExampleSoCv | 0 1 T ameme— Sy -
uart_txd @ |
Type: Instance [l 1
Path: ExampleSoC_v —:clk_i :
VLNV lattice:systembuilder:ExampleSoC | | ) th_D:_
rxd_i
9 : . — . . 1
File: C:/lscc/propel 2023, 2/workspace/l : . gp|0_|0[7:0]|—
irstn_i 1
____________ A
4 »
1P Catalog Design View B -
Tl Console =]
INFCG <2355134> - Finished: sbp design close -
Finished: "sbp_design close”
% sbp design open -name ExampleSoC v -path {C:/lscc/propel/2023.2/workspace/ExampleSoC/verification/ExampleSoC_v.sbx} -

Figure 3.33. SoC Verification Project

4. ModelSim is launched running simulation for the SoC verification project. The corresponding waveform of the SoC
verification project for the Hello World project is shown (Figure 3.34). Check the waveform.

™ ModelSim DE 20203 - [a] x
File Edit View Compile Simulate Add Wave Tools Layout Bookmarks Window Help
|8 38 -8 sRBD 0-ME | W[ SHRH||[o e B el REEAS 2AMS][ AT 2 4] e s ~|
[ oot onzacss Al a-a-2@-2| [0 wm e[ & oleu ] L& el i £ € o Y
[aqanss| L ymml
$sm -Defaut —— i H | x| §aobeas —— i H 4 x| | gul Wave=Defalt H o x
¥|Instance
ol viest B viestidut insted.o =
& & GSR_INST 2 jvtest/dut_instjrstn
< & dut_inst & Mestidss T

- B sysck_rst_pen1_inst
- 8 vart_model1_inst
@ =ASSIGN=82
-l st
| #vem_capacity=

4 fvtestjdut_inst/bed_o
£ vtestjuart_model1_inst/ck

Figure 3.34. Waveform of Hello World Project

3.4.2. Simulation Details
The default simulation environment is located at the generated sim folder inside the SoC verification project in Lattice
Propel. It contains:

[sim] -- generated simulation environment
[hdl_header]
soc_regs.v -- register definitions of all the components in DUT/SOC
sys_platform.v - base address, user settings of all the components in DUT/SOC
[misc]
* ¥ -- all the mem, hex, txt files will be copied here
flist.f -- file list for HDLs
msim.do -- do script for simulator, it can be gsim for Questasim
wave.do -- do script for adding signals in waveform window
<project_name>.sv -- top testbench, SystemVerilog based

You can extend more verification features in the top testbench.
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About Hello World Project

The Hello World Project is designed to print some strings using a top-level UART port. The testbench instantiates a
UART model to receive these data. Each byte (refer to uart_rx_data shown in Figure 3.34) can be checked using ASCII
format. Meanwhile, this UART model also supports sending the data to Design Under Test (DUT). The data is stored in a
text file and is enabled by the STIMULUS_GEN parameter.

3.5. Programming and On-Chip-Debugging Flow

This section describes the process of testing and debugging application code on the actual hardware including the
Lattice FPGA with the hardware design installed. Debugging with Propel SDK follows the same process and uses of the
same tools in Eclipse IDE.

Before debugging, download the hardware design created from Diamond/Radiant Programmer. Refer to the User
Guide of the specific evaluation board for more details on the evaluation board.

3.5.1. Creating a Debug Launch Configuration

To debug a program, a debug launch configuration must be created. Most of the settings for a debug launch
configuration can be automatically entered. Only a few settings need to be manually configured.

To create a debug launch configuration:
1. Inthe Project Explorer view of Lattice Propel, select a C/C++ project.

2. Build the project and ensure the executable file is available. Refer to the Building a Lattice C/C++ Project section for
details on the process.

3. Choose Run > Debug Configurations....
The Debug Configurations dialog opens (Figure 3.35).

£ Debug Configurations O *

Create, manage, and run configurations

[ § - X | = Y v MNarne: | Example Debug |
|t}"pEfi|tEI'tE><t | [E] Main . [Z] CableConn| %5 Debugger| = Startup| & Source| [] Common| &, SVD Path

[E] C/C++ Application o Project:

[E] C/C++ Attach to Application

[E] C/C++ Postmortern Debugger | Bxample Er

[E] C/C++ Remote Application C/C++ hpplication:

Cif C/C++ Unit
[©] GDE Hardware Debugging
v [£1GDB OnenOCN Nebunging Variables... Search Project... Browse...
| Example Debug
[£] GDE QEMU Debugging
R Launch Group Build Cenfiguration: | Select Automatically ~
= Launch Greup (Deprecated)

| Debug\Example.elf

Build (if required) before launching

(Z) Enable auto build () Disable auto build

(®) Use workspace settings Configure Workspace Settings...
. i Revert Apply
Filter matched 11 of 11 items

Figure 3.35. Debug Configurations Page

4. Double-click GDB OpenOCD Debugging to create a new launch configuration.

A multi-tab page is displayed. The Main tab should already be filled in with the project name, application file name,
and location.
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Select the CableConn tab (Figure 3.36). This tab enables you to select a specific device on a specific cable port.

Click the Detect Cable button. Select the specific cable port from the Port drop-down list. By default, the first
available cable port: FTUSB-0 is selected.

Click the Scan Device button. Select the specific device from Device drop-down list. By default, the first available
device on selected cable port is selected.

Select the JTAG channel number from Channel drop-down list. By default, channel 14 is selected with the same
value as the processor preset.

Keep the cable speed so that you can use the default clock divider.

Note: You need to repeat the Detect Cable and Scan Device steps if you have plugged or unplugged the cable.

o
fsa

Create, manage, and run configurations

ﬁ . = R| — T MName: | Example Debug |
|t5-'pefi|tertext | [E| Main ||[£] CableConn| %5 Debugger| = Startup | B Source | [] Common | &, SVD Path
[E] C/C++ Application Cable Settings
L] C/Cor+ Attach to Application Port | FTUSB-1,USB2,Dual RS232-HS A Location 0001 +| [ Detect Cable
[c | C/C++ Postmortemn Debugger
[E] C/C++ Remote Application Device Settings
Cif C/C++ Unit
Device: | LCMXO3D-9400HC:0x212E3043 - Scan Device

[©] GDB Hardware Debugging
v [E] GDE Open0OCD Debugging
[ ] Example Debug
[£] GDB QEMU Debugging Channel: 14 ¥
2 Launch Group

JTAG Channel Setting

Speed Settings
(®) Use Default Clock Divider
(_) Use Custom Clock Divider

Revert Appl
Filter matched 10 of 10 items ks s

@

Figure 3.36. CableConn Tab of Debug Configurations

Select the Debugger tab (Figure 3.37). It is critical that the Config options field contains the correct command line
options to be passed to OpenOCD.

-c "set port S{PORT}" is required for the selection connected to the Lattice cable. The value of variable “S{PORT}’
comes from the cable settings of the CableConn tab.

-c "set target S{DEVICE}" is required for the selection of a specific device on the Lattice cable. The value of variable
“S{DEVICE}" comes from the device settings of CableConn tab.

-c “set channel S{CHANNEL}” is required for setting the JTAG channel. The value of variable “S{CHANNEL}” comes
from the jtag channel setting of the CableConn tab.

-c "set tck S{TCKDIV}" is required for setting the clock divider of the Lattice cable. The value of variable “S{TCKDIV}”
comes from the speed setting of the CableConn tab.
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£ Debug Configurations O *

Create, manage, and run configurations

O [ & 8|E|\l_])' Name:
| type filter text |

Example Debug
Main CableConn ﬁ\ﬁi Debugger

Startup| E/ Source| i=| Common| %_ SVD Path|

~ [£] GDB OpenOCD Debugging OpenQCD Setup ~
[c] Example Debug Start OpenOCD locally
[£] GDB QEMU Debugging -
& Launch Group Executable path: | S{openocd_path}/${openocd_executable} | | Browse... | |\|’ar|ab|5... |

Actual executable: | Chlscc\propel\2024.1\sdk\eclipse\/../ openocd/bin/openocd.exe |

(to change it use the global or workspace preferences pages or the project properties page)

GDEB port:
Telnet port:

Tel port:

Cenfig options: -c 'echo "DEBUG_EMABLE=S${DEBUGENABLE}" -c "set target S{DEVICE}" -c "set tck S{TCKDIV}"

-¢ "set port ${PORT)" -c "set channel S{CHAMNMEL}" -c "set cmdlength S${CMDLENGTH}" -¢
"set loc S{LOCATION}" -f interface/lattice-cable.cfg -c "set RISCV_SMALL_YAML
{8{ProjDirPath}/src/cpu.yaml}”" -f target/riscv-small.cfg

Allocate console for OpenULD Allocate console tor the telnet connection

GDE Client Setup

i . Revert Apply
Filter matched 4 of 10 items

® Debug | | Close

Figure 3.37. Debugger Tab of Debug Configurations

7. (Optional) Select the Common tab (Figure 3.38). The Save as > Local file option is selected by default. This causes
the debug launch configuration to be saved into the workspace.

You can change the setting of the Save as field to Shared file. In this way, the debug launch configuration is saved
into the project and this aids the project portability.
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S Debug Configurations

Create, manage, and run configurations

MY K IR

| type filter text |

w [€] GDB OpenOCD Debugging
[t | Example Debug
[c] GDB QEMU Debugging
& Launch Group

Filter matched 4 of 10 items

MName: | Example Debug

Main | CableConn |3'¢>: Debugger| = Startup | 'E:/ Source II o, SVD Path|
Save as &
(O Local file
(® Shared file: | \Example | Browse...
Display in favorites menu Encoding
[ % Debug (® Default - inherited (UTF-8)
[0 @ Run () Other | 150-2859-1
Standard Input and Output
Allocate console (necessary for input) v
Revert Apply

©)

Close

Figure 3.38. Common Tab of Debug Configurations

8. Remain settings as default. Do not change the settings unless necessary, or unless you understand what effect

these changes may bring.

9. Click Apply to keep the current settings.

10. Click Close.

Note: By default, C/C++ Application, C/C++ Attach to Application, C/C++ Postmortem Debugger, C/C++ Remote

Application, C/C++ Unit, GDB Hardware Debugging are hidden on the Debug Configurations page. If you want to use

them, you can disable the Filter checked launch configuration types (Figure 3.39).
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R
ii Preferences

type filter text

| | Launch Configurations G- §

General

C/C++

Context

Help

Install/Update

LiClipse

MCU

Oomph

Propel Setting

Rernote Development

w Run/Debug

Console

w Launching

Default Launchers
Launch Configurations

MCU Peripherals Views
Perspectives
String Substitution
View Management
View Performance

SVEditor

SWTChart Extensions

Terminal

Validation

Version Control (Team)

XML

~ ey

Launch Configuration Filters

Filter configurations in closed projects
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3.5.2. Starting a Debug Session

Figure 3.39. Launch Configurations

Before starting a debug session, be sure that:

e The Lattice cable is connected to the computer.

e The target device is power ON.

e The hardware design has a debug enabled processor module and already programming into the target device.

With the above steps completed properly, follow the steps below to start the debug session from Lattice Propel.

1. Choose Run > Debug Configurations....
If necessary, expand the GDB OpenOCD Debugging group.

2
3. Select the newly-defined configuration.
4

Click the Debug button (Figure 3.38).

Alternatively, for later sessions, use the Debug icon #F on the toolbar. Do not click the Debug icon directly. Instead,
click the down arrow beside the Debug icon. Select the desired debug configuration from the drop-down menu

(Figure 3.40).

#vav%vlgg Y vl
[c| 1Example Debug

Debug As >
Debug Configurations...

Organize Faverites...

Figure 3.40. Debug Icon on Toolbar
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5. Wait for a few seconds for switching to debug perspective, starting the server, connecting to the target device,
starting the gdb client, downloading the application, and starting the debugging session.

6. The Lattice Propel Window displays, as shown in Figure 3.41. The execution stops right at the beginning of the
main() function.

S workspace - Example/src/main.c - Lattice Propel - O x

File Edit S5ource Refactor Mavigate Search Project Run  LatticeTools Window Help

Al | @i |0 ® 3@ b SO RS-0 R-iI®E e E oy
Q BB
4% Debug 52 [ Project Explorer = B |2 main.c £ = O |[m=v &2 % B|STE| T, P| ™ -
= | i 8 35 // LATTICE DOES NOT WARRANT OR REPRESENT THAT THIS FILE, ITS COI & 4 E|| L=€j = 2

USE THEREOF DOES NOT INFRINGE ON THIRD PARTIES' INTE
RIGHTS, INCLUDING ANY PATENT. IT IS THE USER'S RESPONSIBILIT* Name Type
v il Bample.elf ESIGN FOR CONSISTENCY AND FUNCTIONALITY Tt (BB uint8_t
w ¥ Thread #1 (Suspended : Signal : 0:Signal 0) IFTWARE VALIDATION METHODS.
= main() at main.c:46 Oxddc . S mmmmmmmmmmmmmmmmmoomomomoommomooooooooooooooommoooooo
s openocd.exe

s riscv-none-embed-gdb

v [E] Example Debug [GDB Open0CD Debugging]

#include "utils.h"|

int main(void) {
static uintd t idx = @;
DEBUG_PRINTF("Helle RISC-V world!\r\n");
LED_SET{ALL_OFF);

while (true) {

LED SET(LED ON(idx)); ( =
if (++idx == LED_COUNT) { Name @ idx "
idx = o3 Details:e '\@'
} Default:e "\@'
Decimal:@
if (RTL_SIM) { Hex: 8x8
A1l san. v Rinaru.n v
< >
& Console | 4t Registers | & Terminal |[2] Problems | (3 Executables | G Debugger Console 53 0 Memory El~=08B

Example Debug [GDB OpenOCD Debugging] 8 cross_prefix jgdb8{cross_suffix} (777)

Program stopped. v
T e
Writable Smart Insert 42:19: 2503 ] 165M of 334M o:

Figure 3.41. Debug Perspective

Note: If you need to do Reveal and Propel On-Chip-Debug concurrently, it is recommended to launch Propel SDK
On-Chip-Debug first before launching Reveal.

3.5.3. Peripherals Registers View

Peripherals registers view provides an easy-to-use interface for examining or modifying the values of peripheral
registers during a debug session.

To use peripherals registers view in Lattice Propel (Figure 3.42):
1. Make sure an active debug session is run and shown in the debug perspective.

2. Find the Peripherals view which is in the same window with the Variables and Breakpoints views. For any reason,
if this view is not found, re-open it from Window > Show View > Peripherals.

The Peripherals view lists all peripherals available in the system view description svd file within the C/C++ Project.

3. Selecting a peripheral in the Peripherals view can open a Memory Monitor that is mapped to the corresponding
peripheral memory area.

4. You can examine and modify the value of the peripherals register in the Memory view.
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% workspace - Example/src/main.c - Lattice Propel - [m] x
File Edit Source Refactor Mavigate Search Project Run  LatticeTools Window Help
Hmig = T S B = S = A G R R s A N N - R R R R R e R s A
: P
5 Debu 22 5 Proja} = B || [ mainc & = (%)= Variables (oo Breakpoints (H Expression;%_. Peripherals 2 = B8
B k| B || @/ HE 8
w [c] Example Debug [GDB OpenOCD 42 #include "utils.h™ Peripheral Address Description
v i E’GT':P'E-:L orended ] %, cpud_inst OxFFFFO000
v rea uspended : 5i = int main(voi . DOD0ED0D
D?DE mainO:tm:in‘cdﬁDx&lgu stat:Ec Ui")"tg_t idw = 85 % gp\o@_ln;t gOOOOOOOO
sl openocd.exe DEBUG_PRINTF{"Hello RISC-V world!\rin"); O sysmem0_inst
A ) LED_SET(ALL_OFF); 1'%, uartd_inst 0x00008400
s riscv-none-embed-gdb
while (true) {
LED_SET(LED_OM{idx)};
< >
if (++idx == LED_COUNT) {
idx = @;
}
< >
2 Console ﬂ'\’é? Registers (@ Terminal ﬂ_f_ Problems (O Executables (E Debugger Con;oll(ﬂ Memory Xi“ = 0
g o [ ."Jl -4 L._|<;'=€> B~ &
Monitors 4= 38 % (7 gpiclinst 0xB000 & . o New Renderings..|
@ cpullinst Register Address Value =
% gpiol_inst ~ 2, gpiol_inst 000003000
@ uvartl_inst + 0 RD_DATA_REG 00003000 00003000
o rd_data [7:0] 00
5 im0 \WR_DATA_REG 0x00008004 0x00008004
4 Mo SET_DATA_REG 0x00008008 0x00008008
4 1m0 CLEAR_DATA REG 0x0000800C 0x0000800C
5 1 DIRECTION_REG 0x00008010 0x00008010
< > 100 |MT TVDE RER MreNNNNANTA v0NNNRNTA v

Mof334M [

Figure 3.42. Peripherals View in Debug Perspective

3.5.4. Serial Terminal Tool

Serial port communication is frequently used during the microcontroller debugging. Lattice Propel SDK provides a
built-in terminal tool including serial support for debugging.

To launch a serial terminal:

1. Find the Terminal view nested to the Console view. If this view is not found, re-open it from Window > Show View

> Terminal.

2. Inthe Terminal view, click the Open a Terminal iconE . The Launch Terminal dialog opens (Figure 3.43).

3. Choose the Serial Terminal and configure the Serial port with Baud rate.

7% Launch Terminal O *

Choose terminal: | Serial Terminal -
Settings
Serial port: | COM1 w
Baud rate: | 115200 v
Data size: |8 w
Parity: Mone ~
Stop bits: |1 ~
Encoding: | Default (150-8853-1) w

@

Figure 3.43. Launch Terminal Dialog
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4. Click OK. A connection opens.

5. (Optional) Click the Toggle Command Input icon that adds an edit box to enter text (Figure 3.44).

E Plohlemswo Euecutahls} B2 it EE| [E] @ = g

Figure 3.44. Terminal View
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4. Propel Tutorial — Hello World

This Hello World project can be found from the template. The Hello World project provides a template of using
hardware and software design with the minimal resource required.

Following this tutorial, you can easily create a hardware and software project. After that, you can run the project on
your evaluation board.

The tutorial uses a MachX03D breakout board for demonstration. It uses R5232 UART function. To enable RS232 UART
function on the MachXO3D breakout board, the following reworks on the board are required.

1. Hardware reworks on MachXO3D breakout board.

Short R14 and R15 using 0 Q resistors, as shown in Figure 4.1.

D)
@ 176
:— -

® @ remR2s

—

MachX03D Breakout Baard

REV A P/N:LCMX03D-9400HC-B-EVN o000
SNLATTICE qeee

| SN SEMICONDUCTORy
000

ez () g Y
oo o RZ4RGS = £ :
. | g. o000
LATTICE ~o000
LCMXO3D-9400HC >0 ®®
5BG256CAS - - *e O ¢
29107H12 Y Y X X )

L NN

'YX X

vidi@
£ld1 @
s1d1®

&=l
]

——
(=
e

[ B

aNe

9141 @

@0 @ 0wy /==
SR39

F5 E3 Bl CIGND|D2 E2 F2 G2 GND[H2 J3 KI L3 GND|L2 M3 M2 N3 105
104 F3 D3 G3 C2|D1 EI F1 GI GND[HI H3 J2 J1 GND[L1 M1 NI H6 103jm 40

P00 OOPOIOGIOGIOGIOGOIOGPIOOGPOOIOGPOO R
POPPPOGOGIOGIOGIOGOGIOGIOGIOGOOGO®®®|uxn

Figure 4.1. MachX03D Breakout Board
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Open the FT_Prog software. Select DEVICES > Program.
Make sure Port B is configured as RS232 UART in Hardware and Virtual COM Port in Driver. See Figure 4.2.

Configure the FTDI device with FT_Prog software to enable the UART function.
Connect the MachX03D breakout board to host PC and power ON.

Select DEVICES > Program from the FT_Prog software again. From the opened Program Devices dialog, click

Program.

Device Tree

Property

Value

=¥z Device: 0 [Loc ID:0x0]

==k FT EEPROM
f=b Chip Details
= USB Device Descriptor
=9 USB Config Descriptor
[=p USB String Descriptors
E=b Hardware Specific

-=p Suspend DBUS7

-=p TPRDRY

H=y Port A

==y Port B

il dHardware

f=b Driver

= 10 Pins

RS232 UART
245 FIFO
CPU FIFO
OPTO Isolate

Device Tree

Property

Value

=¥z Device: 0 [Loc ID:0x0]

==k FT EEPROM
f=b Chip Details
= USB Device Descriptor
=9 USB Config Descriptor
[=p USB String Descriptors
E=b Hardware Specific

-=p Suspend DBUST

-=p TPRDRY

H=y Port A

==y Port B

'=> Hardware

tms B

=y 1O Pins

D2XX Direct
Vitual COM Port

3.

4.1. Creating SoC Design Project and Preparing Hardware Design

To start an SoC Design Project from Lattice Propel:

Figure 4.2 Configure the FTDI Device

All the reworks for the MachXO3D breakout board are completed.

Choose File > New > H'I'l Lattice SoC Design Project.

MC SoC Project template.

Click Finish. An SoC project is created.

The Create SoC Project wizard opens (Figure 4.3). Enter a project name, such as HelloWorldSoC. Select the RISC-V
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7 soC Project a *
Create SoC Project —
Create 50C project of selected template J_
= _I
Project name:l HelloWoerldSoC I
Use default location
Location: | Ch\lscchpropel2024. 1\workspace\HelloWorld5oC Browse...
Choose file systern: |default” %
Board
Board Select
Certus-MNX Versa Evaluation Processor: | RISC-V MC <

CertusPro-MX Evaluation

CrossLink-MX Evaluation

ECP3-5G Versa

Lattice Sentry Demo Board for Mach-MX (256)
Lattice Sentry Demo Board for Mach-MNX (484)
Lattice-Awvant Evaluation

Template Design

Empty Project RISC-V MC IP based 50C Project.

RISC-V MC 5o0C Project

Compeonents included:
a) Processor - RISC-V MC wy PIC/TIMER
b) GPIO
c) ASRAM - Asynchronous SRAM
d) UART - Serial port

@ [ Fnsh | Cancel

Figure 4.3. Create SoC Project Wizard

4. The created SoC project can be found in the workbench. Its design is opened and displayed in Propel Builder for
review (Figure 4.4).
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. Propel Builder [C:/lscc/propel/2024.1/workspace/HelloWorldSeC/HelloWorldSoC/HelloWorldSoC.shx] Device: LCMX03D-9400HC-3BG256C Board: MachX03D Breakout
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i
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Name: | HelloWorldSoC

2pb0_inst
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Path:  HelloWorldSoC
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File:  CiVscc\propel {2024, Tywarkspace )

4 »
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Tel Console

Design View

% sbp_design save

% sbp_desi ensrate
INFO <2359
INFO <2352190>
% sbp_design pge sge

- Start: sbp design generate.
- Finished: sbp design generate.

-i {C:\1lscc\propel\2024.1\workspace\HelloWorldSoC\HelloWorldSoC/HelloWorldSoC.sbx} —o {C:/lscc/propel/2024.1/workspace/HelloWorldSoC/
HelloWorldSeC/../} -nc

Figure 4.4. Propel Builder Window

(Optional) In Propel Builder, update the SoC design to set the preloaded software. Enable the checkbox for Initialize
Memory for system_memory IP module from the Initialization area of the General tab, and set Initialization File
(Figure 4.5) generated from the corresponding Hello World C project in the Creating Hello World C Project section.

“. Module/IP Block Wizard =

Configure Comp from Module sy u Y L
Set the following parameters to configure this component.

1.1.2

Diagram sysmem{ Configure TP
General Port S0 Settings Port 51 Settings
Property Value
~ General
Memory Address Depth [1- 32768] 4096
sysmemo Dats Bus Widlth(bits) 32
Memory Type EBR
Port Count [1-2] 2
—H BL So Enable Arbiter
- FIFO Streamer
—{-AHBL_S1
— ahbl_hclk_i ~pluitizkoats
Initialize Memory = l
] ahbl hresetn i nitialization File Forma %
- - I Initialization File §‘.f..fHeIIoWorIdeebungeIIoWorId.mern !
system_memory
4 > = No DRC issues are found.

Generate Cancel

Figure 4.5. Configure Module System Memory
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4.2. Launching Lattice Diamond
Launch Lattice Diamond from the created SoC project. To do that:
1. In Propel Project Explorer view, select the SoC project HelloWorldSoC.

2. Click the Diamond icon ™~
Diamond.

3. Switch to Process view of the Diamond project and make sure Bitstream File or JEDEC File is checked in the Export
Files section (Figure 4.6).

" on the toolbar. A Diamond project is created and thus opened automatically in Lattice

4. Choose Process > I Run. Wait for generating programming file successfully. You can see a green checkmark
before each successfully completed process.

- :
# Lattice Diamond - Start Page - -
|
|%'@'Hw;\'@. By hGERRQQQEHE EEE-O
PECRESE S CEEGARUsSoVBY HEHEE:
Process 8 X ([ startPage [ Reports 8 x
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[ & Map Trace

[ & Verilog Simulation File

[ 2 VHDL Simulation File
v & Place & Route Design

[0 2 Place & Route Trace

[ Import ispLEVER Project. ..

Recent Projects:

Lattice Diamond 3.13 User Guide

Lattice Synthesis Engine for Diamend User Guide
Lattice Diamond 3.13 Platform Designer User Guide
Clarity Designer User Guide
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Other Tool Guides
Modelsim User Manual

ModelSim GUI Reference Manual

[ 2 10 Timing Analysis
[ & Thermal Analysis
v :3 Export Files

Lattice Diamond 3.13 Programming Tools User Guide ModelSim Command Reference Manual
Reveal User Guide ModelSim Tutorial

Reveal Troubleshosting Guide Synplify Pro User Guide

Lattice Diamond 3.13 Installation Guide for Windows  Synplify Pro Reference Manual

Lattice Diamond 3.13 Installation Guide for Linux synplify Pro Language Support Reference Manual

]
Software Update Center
& Bitstream File carent de s Dromond safi Reference Guides Telf Tk
- urrently running Lattice Diamond software version: R
+ JEDECFile i1s nyss » o Lattice Diamend 3.13 FPGA Libraries (HTML versicn)  Lattice on the Web
e Lattice Diamond 3.13 FPGA Libraries (PDF version)  Lattice Semiconductor
Mo updates available N
Answer Dat
Last check tme: Sat Oct 7 14:53:15 2023 Help newer batabase
Lattice Diamond 3.13 Help (HTML version) Lattice Solutions ©
File list  Process Hierarchy
Output 8 x

L
synpwrap -msg -prj "HelloWorldSoC_impll_synplify.tcl® -log "HelloWorldSoC_impll.srf”
Copyright (C) 1832-2023 Lattice Semiconductor Corporation. All rights ressrved.
Lattice Diamond Version 3.13.0.56.2

INFO - Synplify synthesis engine is launched.

Td Console Qutput Error Warning Info*

Start: Synplify Pro

Mem Usage: 513,124 K

Figure 4.6. Generate Programming File

4.3. Programming the Target Device

Once the programming file is exported successfully in the last section, it is ready to program the target device. Make
sure the evaluation board is powered ON and connected correctly to the host PC before performing the following
procedure.

1. Click the Programmer icon % on the toolbar of the Lattice Diamond Project Explorer.

2. The Programmer: Getting Started dialog pops up (Figure 4.7). Click OK.
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i Programmer Getting Started ? X

Select an Action

@ Create a new project from a JTAG scan
Cable: |HW-USBN-2B (FTDI)  + | Port: - Detect Cable

TCK Divider Setting (0-30x):

(") Create a new blank project

D Open an existing programmer project

Impart file to current implementation

C:flsccfpropel {2024, 1/workspace HelloWorldSoC fimpl 1impl 1, xcf

Cancel

Figure 4.7. Programmer Getting Started Dialog

3. Review the Device Family, Device, Operation, and File Name in the Programmer window (as shown below).

BB® GO B

Enable Status Device Family Device Operation File Mame

1 MachX03D LCMXO3D-9400HC SRAM Fast Configuration 12/50CHelloW/impl1/SoCHelloW_impl1.bit | ...

Ak
4. Click the Program icon “~=* to download the programming data file to the device.

4.4. Creating Hello World C Project

Creating C project requires a system environment from SoC project as input.
1. In Propel Project Explorer view, select the SoC project HelloWorldSoC.
2. Choose Project > Build Project.

System environment of the select SoC project is generated under the SoC project folder. Check the result from the
Console view (Figure 4.8).

[2! Problems [ Tasks | & Console % = Properties | A& Terminal

 R%| P EE O
<terminated> sge [SDP Builder] Chlscchpropelh2024.1\tools\python38_embed\python.exe (Terminated Apr 16, 2024, $:53:11 AM) [pid: 8908]
WARNING - (PGE SoCDesign) cpu@_inst_TIMER_IRQ M@ remains unconnected
INFO - (PGE) Finished: sge generated

Figure 4.8. Build Result of HelloWorld SoC Project

3. Choose File > New > @ Lattice C/C++ Project.
The C/C++ Project wizard opens with the Load System and BSP page (Figure 4.9).
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Q C/C++ Project O

Load System and BSP —

Load lattice system environment file and B5SP package

Browse...

Select processor core to create C/C++ Project

Core selected: | cpull_inst ~
Project type: |C ~
System information
Device Family CPU Mame Instance Name
MachX03D riscv_mc cpul_inst
Select Example Application
Hello World Project Example-HelloWorld-blink-uart
1.Led blink
The corresponding SoC project should include gpio instance.
2.Uart print
There art tow ways to support uart print:
a) The correspending SoC project should include uart instance or local uart.
b) Enable Semihosting(System Library) when creating this project.
Project name: | riscv_mc_helloworld
Use default location
Location: | Chlscc\propel2024.\workspace\riscv_mc_helloworld Browse...

Choose file systern: |default

[]Build the project
Create a debug launch configuration for | OpenOCD

® < Back Finish Cancel

Figure 4.9. Load System and BSP Page

Select the system environment file just generated (Figure 4.9).

Change project name to HelloWorld (Figure 4.9). Click Next. Then click Finish.
The C project is created and displayed in the workbench.

Choose Project > Build Project.

Check the build result from the Console view (Figure 4.10).
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{2 Problems | v Tasks | & Console 22 O Properties | 4 Terminal 4 qp <}='=.>| aH Rk —Eml 2B~~~ 08
CDT Build Console [HelloWarld]
...................... ot o we Sy TR Smoeeer Sw o=
text data bss dec hex filename "
1262 5] 2728 3998 fo96 HelloWorld.elf
Finished building: Hellokorld.siz
Invoking: Lattice Create Memory Deployment
riscv-none-embed-ocbjcopy -0 binary --gap-fill @ "HelloWorld.elf" "HelloWorld.bin™; srec_cat "HellowWorld.bin™
-Binary -byte-swap 4 -DISable Header -Output "HelloWorld.mem™ -MEM 32
Finished building: Hellokorld.mem
16:56:57 Build Finished. @ errors, @ warnings. (tecck 4s.81ems)
v

Figure 4.10. Build Result of HelloWorld C Project

4.5. Running Demo on MachX03D Breakout Board — Hello World

1. Find the Terminal view nested to the Console view. If this view is not found, re-open it from Window > Show View

> Terminal.

In the Terminal view, click the Open a Termin

al icon E.

Choose the Serial Terminal and configure the Serial port with Baud rate 115200 (Figure 4.11).

Note: The serial port number depends on specific PC.

i '
i% Launch Termina

Choose terminal:

Settings

I O

Serial Terminal

Serial port: | COM1 o

Data size: |8

Stop bits: |1

Baud rate: | 113200 w

Parity: MNone ~

Encoding: | Default (150-8859-1) w

Figure 4

Choose Run > Debug Configurations....

©® N o un &

Click the Debug button.

.11. Launch Terminal Dialog

Click OK. A serial connection communicating with UART is ready.

In the Project Explorer view, select the C project, HelloWorld.

Double-click GDB OpenOCD Debugging to create a new launch configuration (Figure 4.12).

Wait for a few seconds for switching to the debug perspective, starting the server, allowing it to connect to the
target device, starting the gdb client, downloading the application, and then starting the debugging session.

Note: This demo uses the default debug confi

guration options.
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7 Debug Configurations O X
Create, manage, and run configurations
O®EX | v~ Narme: | HelloWorld Debug |
| type filter text | Main CableConrﬂ 35 Debuggeﬂ = Startup\l By Source\l =] Common\l =, SVD P‘athw
[€] C/C++ Application Project:
[€] C/C++ Attach to Application
[E] C/C++ Postmortem Debugger | HelloWorld | | Browse... |
[£] C/C++ Remote Application C/C++ Application:
co-r -
[ C/Ce+ Unit _ [ Debug\HelloWorld.elf |
[ ] GDB Hardware Debugging
v [£] GDB Open0CD Debugging | Variables... | |Search Ploject...| | Browse... |
[c] HelloWorld Debu.g Build (if required] before launching
[] GDB QEMU Debugging
L Launch Group Build Cenfiguraticn: | Select Automatically V|
= Launch Group (Deprecated)
piep () Enable auto build () Disable auto build
(®) Use workspace settings Configure Workspace Settings...
Revert Appl
Filter matched 11 of 11 items o
® Debug | | Close

Figure 4.12. Debug Configurations Page

9. Click the Resume icon 1% on the toolbar. The serial terminal outputs Hello RISC-V world! (Figure 4.13).

3 workspace - Examplefsrc/main.c - Lattice Propel - O X
File Edit Source Refactor MNavigate Search Project Run LatticeTools Window Help
C-HR Bi2is|mnmdogidl: | S0i6e HF-O0-Q- P Jpil o Oy Q B|laE
%5 Debug X {5 Project EW = B |[[g mainc x ~_[E] main) at main.c:51 0x392 W = O ||®=Varia (‘o Brea @"-f Expr |2 Disas X = Panp} 8
5 .
%|iv 8 35 int main(void) { “ [ Enter location here Y| & & [BlBl o et 8
w [C] Example Debug [GDB OpenOCD Debt 9 static uint8 t ddx=9; . ~
v (2 Example.elf 2 51 uart_init(&uart_core_uart, UARTB_
4@ Thread #1 (Running : User Requ 1 uart_init(&uart_core_uart, UART@_INST_BASE_ADDR, UARTB_INST_S¥S_CLK, UART@_I 20000392 L as,s
nﬁ d 2 2000839C 1i a4,l
openocc.exe 3 #ifdef LSCC_STDIO_UART_APB [eeeeise Lui a3, xlc
W riscv-none-embed-gdb 4 extern struct uart_instance *g_stdio_uart; 80008320 addi  a3,a3,512 # @x1c208
5 g_stdic_uart = &uart_core_uart; 6aBB83a4 1i a2,3s
6 #endif eeeRe3a3 Llui al,exs
7 ‘oeeRa3aa addi al,al,l824 # @x3400
8 printf("Hello RISC-V world!\ri\n"); feeeniac Lui a@,8xl
9 LED_SET(ALL_OFF); 83606300 addi  a@,ad,-11208 # Bxba® <uart_c
o 8@6083b4 jal @x98 <uart_init>
1 while (true) { 55 g_stdio_uart = &uart_core_uart;
2 LED_SET(LED_ON(idx)); 000003b6 lui as,exl
3 @oeea3ba lui ad,exl
4 if (++idx == LED_COUNT) { 288003ba addi  a4,34,-11208 # Bxba@ <uart_c
5 idx = @; 886083be sw a4,-1284(a5) # Bxbdc <g_std
6 3 55 printf("Hello RISC-V world!\rin")
7 2eeea3c2: Llui as,exl
3 if (RTL_STM) { 0000034 addi  a@,a5,-1264 # @xble
a delayMs(1); 200883c8: jal @x524 <puts>
) 1 else { v ca LEN SETIALI NERY. i
< > < >
(T =) ; il _- - =
Conso\a(am Registers. (=B Progress (&' Terminal L__, Pmb\amq Q B(ecutablaq E Debugger Consolaw i] Memory] B ‘ ! W H @ (=]
] <Closed> COMI ¢ |
Hello RISC-V world!
< >
—
Closed - Encoding: windows-1252 'V:ia

Figure 4.13. Run Result of Hello World Project
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5. Propel Tutorial — FreeRTOS

The FreeRTOS templates are based on FreeRTOS 202210.01 LTS. Refer to https://www.freertos.org/ for more details.
There are two FreeRTOS templates, FreeRTOS-LTS-minimal and FreeRTOS-LTS-PMP-Blinky.

FreeRTOS-LTS-minimal is the same as the opensource FreeRTOS, except choosing RISC-V portable code. You can start
self-development from this template.

FreeRTOS-LTS-PMP-Blinky is a sample project, which demonstrates how to create tasks, create queues, perform queue
data send and receive, and how to use soft timer.

This tutorial uses a CertusPro-NX™ Evaluation Board with RISC-V RX SoC Project for demonstration.
Example C project is FreeRTOS-LTS-PMP-Blinky.

5.1. Preparing the Hardware and Programming the Target Device
1. Create RISC-V RX SoC Project with CertusPro-NX Evaluation Board (Figure 5.1). Click Finish.
2. Select Project > Generate.

3. Generate the programing file by running Lattice Radiant software in this SoC Project.

4

Program the programing file to the target device, CertusPro-NX Evaluation Board.

@ SoC Project O *

Create SoC Project
Create 5oC project of selected template

Project name: | Example5oC

Use default location

Ch\lscch\propeh2024.1\workspace\ExampleSoC Browse...
default
Language: |Verilog ~
Board
Board Select
[ Certus-NX Versa Evaluation | Processor: RISC-V RX it

|CertusPro-NX Evaluation |
CrossLink-MNA Evaluation

ECP5-5G Versa

Lattice Sentry Demo Board for Mach-MNX (256)
Lattice Sentry Demo Board for Mach-Nx (484)
Lattice-Avant Evaluation

MachXO2 Breakout

MachXO3D Breakout

MachXO3D PFR Demo

Template Design

[Emoty Proiect | [ rISC-V RX IP based SOC Project. ~
3HA-3 LFU Froject Components included:

a) Processor - RISC-V RX with TCMs, PLIC and CLINT

b) GPIO

c) O5C and PLL

d) UART - Serial port

€] Glue Logic

£l A¥] intercnnnect &7

Figure 5.1. Create SoC Project
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5.2. Creating FreeRTOS-LTS-PMP-Blinky C Project

1. Select File > New > L& Lattice C/C++ Project.
The C/C++ Project wizard opens with the Load System and BSP page (Figure 5.2).

Q C/C++ Project O X
Load System and BSP —
Load lattice system environment file and B5P package |
Select system environment file and BSP package
System env: | Chlscch\propel\2024.1\workspace\ExampleSoC\sgelsys_envxml Browse...
Select processor core to create C/C++ Project
Core selected: | cpul_inst -
Project type:  |C ~
System information
Device Family CPU Name Instance Name
LFCPMX riscv_rtos cpull_inst
Example-FreeRTOS-LTS-PMP-blink -

Hello World Project

RISC-V RX Derno Project

Base on FreeRTOS 202210.01 LTS.

1.FreeRTO5 Kernel V10.5.1 with sample of tasks,

queues and soft timer:
task1, task status print.

task2, PMP test and queue data send.

cnft timer receive nnene data then dn | FN hlink

W

Project name: | riscv_rtos_freertos_pmp_blinky

Use default location

Laocation: | Chlscc\propel\2024.1\workspace\riscv_rtos_freertos_pmp_blinky Browse...
Choose file systern: | default

[1Build the project

Create a debug launch configuration for  OpenOCD

® < Back Finish Cancel

Figure 5.2. Load System and BSP Page

In System env field, select the system environment file from the RX core SoC project just generated.

Select Project > Build Project.

Check the build result from the Console view (Figure 5.3).
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ol O d
&l Console X x|@ﬁ<§>|ﬁuﬁ 5&@|=‘E'Fﬁ'mﬁ
CDT Build Consele [riscv_rtos_freertos_pmp_blinky]
./src/vector.o A

Finished building target: riscv_rtos_freertos_pmp_blinky.elf

Inveking: GNU RISC-V Cross Create Listing
Inveking: GNU RISC-V Cross Print Size
Inveking: Lattice Create Memory Deployment
riscv-none-embed-chjdump --source --all-headers --demangle --line-numbers --wide
"riscv_rtos_freertos_pmp_blinky.elf"” > "riscv_rtos_freertos_pmp_blinky.lst"
riscw-none-embed-size --format=berkeley "riscv_rtos_freertos_pmp_ blinky.elf"
riscw-none-embed-objcopy -0 binary --gap-fill @ “"riscv_rtos_freertos_pmp_blinky.elf"
"riscv_rtos_freertos_pmp_blinky.bin"; srec_cat "riscv_rtos_freertos_pmp_blinky.bin" -Binary -byte-swap 4 -DISable
Header -Output "riscv_rtos_freertos_pmp_blinky.mem" -MEM 32

text data bss dec hex filename

282008 56 13852 413e8 alSc riscv_rtos_freertos_pmp_blinky.elf
Finished building: riscv_rtos_freertos_pmp_blinky.lst
Finished building: riscv_rtos_freertos_pmp_blinky.siz

Finished building: riscv_rtos_freertos_pmp_blinky.mem
sh D:\lscc\propel\2824.1\sdk\eclipsel/. . /tools/bin/ipl32f_2 ipl32.sh riscv_rtos_freertos_pmp_blinky.elf

1+8 records in
1+8 records out

15:82:43 Build Finished. 8@ errors, @ warnings. (tock 28s.473ms)

Figure 5.3. Build Console

5.3. Running FreeRTOS C Project

1.

2
3.
4

In the Project Explorer view, select the C project just created, riscv_rtos_freertos_pmp_blinky.
Choose Run > Debug Configurations....

Choose riscv_rtos_freertos_pmp_blinky in GDB OpenOCD Debugging (Figure 5.4).

Click the Debug button.

Wait for a few seconds for switching to the debug perspective, starting the server, allowing it to connect to the
target device, starting the gdb client, downloading the application, and then starting the debugging session.

Note: This demo uses the default debug configuration options.

Find the Terminal view nested to the Console view. If this view is not found, re-open it from Window > Show View
> Terminal.

In the Terminal view, click the Open a Terminal icon E

Choose the Serial Terminal and configure the Serial port with Baud rate 115200 (Figure 5.5).

Note: The serial port number depends on the specific PC.

Click OK. A serial connection communicating with UART is ready.

Click the Resume icon U® on the toolbar. The serial terminal outputs running logs (Figure 5.6).
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8 Debug Cenfigurations

Create, ge, and run ig

O F @

x' T Mame: |r|scvirtosjreertosipmpibhnky

|type filter text

Main] Cab\aCﬂnn|f§» Debugger| = Startup| iy Source‘ =] Commﬂn|?ﬁ SVD Path|

~ [£] GDB OpenOCD Debugging

Project:
E riscv_rtos_freertos_pmp_blinky =

E GDB QEMU Debugging |riscvjtosjreerto;ﬁpmpﬁblinky | | Browse...
i@ Launch Group C/C++ Application:
| Debug'riscv_rtos_freertos_pmp_blinky.elf
Variables... ‘ | Search Project... ‘ | Browse...
Build (if required) before launching
Build Configuration: |Select Automatically V|
() Enable auto build (") Disable auto build
(®) Use workspace settings Configure Workspace Settings...
Filter matched 4 of 10 items ] Apply
@ Debug | | Close

Figure 5.4. Debug Configurations Page

i Launch Terminal O *

Choose terminal: |Serial Terminal ~ |
Settings
Serial port: w |
Baud rate: V|
Data size: w |
Parity: w |
Stop bits: ~ |
Encoding: | Default (1S0-8859-1) v/

@ [ok || concel

Figure 5.5. Launch Terminal Dialog
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B %

w riscv_rtos_freertos_pmp_blinky.elf
@ Thread #1 (Running: User Request)
,a openocd.exe
) riscv-none-embed-gdb

i §
w E riscv_rtos_freertos_pmp_blinky [GDE OpenO

68 pmp_init();

61 os_init();

62 printf("\nFreeRT0S 282218.81 LTS on RISC-V.\n");
63 pmp_pre_init();

| Enter location here

{;‘ workspace - riscv_rtos_freertos_pmp_blinky/src/main.c - Lattice Propel — m} X

File Edit 5Source Refactor MNavigate Search Project Run  LatticeTools Window Help

G-I 22w ponerzs (s S0 8eRH-0- QA -i®d9-ide

HrfH-CP e m Q B| &

45 Debug % {5 Project Explorer] = B |[£} Lattice Platform [@ 0x0 (@ main.c = B8 U‘J=V(°o B D >y = 08
59 bsp_init(); ~ - ||

& %Sl 1o

g

64 Beeesicc: jal ra,@x4b7s A
65 /* Create the queue. */ 260 pmp_init();
66 xQueue = xQueueCreate( mainQUEUE_LENGTH, sizeof( ui 8ee853d8: jal ra,@xcee
67 261 os_init();
638 if( xQueue != NULL ) BEEE53d4: jal Bx577e <
69 262 printf("\nFreef
7@ /* Create the task. */ BeBB53d6: Jui a5,0x7
71 retv = xTaskCreate( tasks_info_task, "info Task & 2a0853d3: addi al,a5,-1%t o
e fbrra - AnTARTTU . o DT = < Bl o
PrDbIEms(c Executables (ﬂ Debugger Co (n Memory (E Console (@ gprof (@‘ Terminal X = 08
B &L BES

B comio x |

* enter store access fault exception handler, mepc=8x8e8@84f12
* exception ignored
@ write/read @x820@974c done, out-@x8e002808

@ expectation(m-mode): write/read @xeeee97se will succeed
@ write/read 8xB8RG9758 begin, in=Bx@@6A5678

@ write/read @x@eea375@ done, out-8x8@885678

@ write/read secured region with sys-call:

@ expectation: write/read exeeeea7se will succeed

@ write/read @x@ee@975@ begin, in=@xeoeddefa
@ write/read 8xBBREI750 done, out=Bx8068defe

i@ pmp test end

TX task 31472 is running 1, send 8x16
soft timer, receive @xlé
TX task 31472 is running 2, send @xfa

Figure 5.6. Running/Debugging Windows
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6. Propel Tutorial — Code Coverage

Code coverage is about validating the number of lines of codes executed under a test process. This, in turn, helps in
analyzing how well and comprehensively a software application is being tested. In other words, it is the quantitative
measurement of the percentage or degree of executed source code of software application during testing. Code
coverage enables you to gauge the completeness of your test cases more accurately.

The code coverage function is supported in RISC-V RX Demo C Project and FreeRTOS-LTS-PMP-blinky C Project.
This tutorial uses a CertusPro-NX Evaluation Board with RISC-V RX SoC Project for demonstration.

Example C project is RISC-V RX Demo Project.

Note: This example C project needs more system memory. The suggested value is 0x20000.

6.1. Preparing the Hardware and Programming the Target Device
1. Create RISC-V RX SoC Project with CertusPro-NX Evaluation Board (Figure 5.1). Click Finish.

2. Propel Builder automatically opens. In Propel Builder, double-click tcm0_inst in the Schematic view, set a larger
value for Address Depth both in Port SO (Figure 6.1) Settings and Port S1 Settings (Figure 6.2). Click Generate.

Select Project > Generate.
Generate the programing file by running Lattice Radiant software in this SoC Project.

Program the programing file to the target device, CertusPro-NX Evaluation Board.

4. Module/IP Block Wizard >

Configure Component from Module localbus_tcm Version 1.4.0
Set the following parameters to configure this component.

Diagram tcmd Configure IP
General Port 50 Settings Port 51 Settings
Property Value
Port 50: Data Width [1 - 64] 32

Port 50: Address Depth [2 - 106496] 32763

tcmo Read Port : Enable Qutput Register (50)
Byte Enable for Port 50 [¥]
_OCAL_BUS_DATA Reset behavior for Port SO sync
—OCAL_BUS_INSTR Edit Address Range Port S0
—sys_clk
—sys_rst_n

localbus_tcm

4 3

Document Mo DRC issues are found.

Generate Cancel

Figure 6.1. tcmO_inst Port SO Address Depth Settings
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4y, Module/IP Block Wizard *

Configure Component from Module localbus_tcm Version 1.4.0
Set the following parameters to configure this component.

Diagram tcmi Configure IP
General Port 50 Settings Port 51 Settings
Property Value

Port 51: Data Width [1- 4]
Port 51: Address Depth [2 - 106456] 32768

tCITIO Read Port : Enable Qutput Register (51)
Byte Enable for Port S1
— OCAL BUS DATA Reset behavior for Port 1 sync
—(4FLOCAL_BUS_INSTR Edit Address Range Port 1
—{sys_clk
—sys_rst_n

localbus_tcm

4 ]

Document Mo DRC issues are found.

Generate Cancel

Figure 6.2. tcmO_inst Port S1 Address Depth Settings

6.2. Creating RX Demo C Project
1. The RX Demo C project can be created through the Load System and BSP page (Figure 6.3).
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% C/C++ Project O x

Load System and BSP *

Load lattice system environment file and BSP package |

Select system environment file and BSP package

System env: | CGhlscc\propel\2024. 1\workspace\ExampleSoCisgesys_envacml v| Browse...

Select processor core to create C/C++ Project

Core selected: | cpull_inst ~

Project type: | C ~

System information

Device Family CPU Name Instance Name

LFCPMX riscv_rtos cpul_inst

Select Example Application

FreeRTOS-LTS minimal Project Example-RxDemo-rvos-task
FreeRTOS-LTS PMP-Blinky Project
Timing Profiling Project 1.5imple RVOS.
i 2.Task execution and scheduling.
3.Uart print.

Project name: | riscv_rtos_mcdemo

Use default location
Location: | Chlscc\propel2024.1\workspace\riscv_rtos_mndemo Browse...
Choose file systern: |default

[ Build the project

Create a debug launch configuration for  OpenOCD

@ < Back FEinizh Cancel

Figure 6.3. Create RX Demo C Project

In System env field, select the system environment file from the RX core SoC project just generated.
Select RISC-V RX Demo Project and check the project name.

Click Next. The Lattice Toolchain Setting dialog opens. Click the C/C++ Compiler tab (Figure 6.4).
Select the checkbox Generate gcov information.

Click Finish.

o vk wbn
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$ C/C++ Project O X

Lattice Toolchain Setting

Configuration: | Debug ~

Lib Setting C/C++ Compiler  C/C++ Linker

[ Enable all commen warnings (-Wall)
Enable uart function (-DLSCC_STDIO_UART_APE)
[ Verbose (-v)

iGenerate gcov information (-ftest-coverage -fprofile-arcs)

[] Generate gprof information (-pg)

Optimization level | None(-00) A

Debug level Maximum(-g3)

@' < Back Mext = Cancel

Figure 6.4. C/C++ Compiler

6.3. Compiling and Running Demo

6.3.1. Compiling C Project
1. Inthe Project Explorer view, select the C project, riscv_rtos_rxdemo.

2. Select Project > Build Project.

6.3.2. Running Demo

1. Inthe Project Explorer view, select the C project, riscv_rtos_rxdemo.

2. Select Run > Debug Configurations....

3. Double-click GDB OpenOCD Debugging to create a new launch configuration (Figure 6.5).
4. Click the Debug button.
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Wait for a few seconds for switching to the debug perspective, starting the server, allowing it to connect to the
target device, starting the gdb client, downloading the application, and then starting the debugging session.

Note: This demo uses the default debug configuration options.

% Debug Configurations m] X

Create, manage, and run configurations

MC = X | B W~ Name: ‘riscvjtosirxdemo Debug
|t}-pef|\tertext | [ Main | [] CableConn | %5 Debugger| = Startup | % Source| [[] Common | 2 SVD Path
[E] C/C++ Application o Project
[T] C/C++ Attach to Application
[E] C/C++ Postmortem Debugger |h5cv7rtoijdemo ez
[£] C/C++ Remate Application C/Cr+ Application:

Cif C/C++ Unit
[T] GDB Hardware Debugging
~ [&] GDE Open0CD Debugging Variables... Search Project... Browse...
[©] riscv_rtos_rederno Debug
[T] GDB QEMU Debugging

| Debughriscv_rtos_rcdemo.elf

Build (if required) before launching

@ Launch Group Build Configuration: |Select Automatically ~
() Enable auto build () Disable auto build
(®) Use workspace settings Configure Workspace Settings...
Revert Apply

Filter matched 10 of 10 items

Figure 6.5. Debug Configuration

5. Select Run > Resume. Then the console output logs.

Wait for a few minutes, until the console logs: do coverage data dump and coverage data dump done
(Figure 6.6).

6. Select Run > Terminate to stop running.

) Console 111 Registers | ™ Terminal |'_ Problems | €2 Executables | B4 Debug

riscv_rtos_redemo_dttt Debug [GDB OpenQCD Debugging]
Task 2: Running...

Task @: Running...

Task 2: Running...

Task 1: RunninTask 2: Running...
Task @: Running...

g.

Task 2: Running...

Task 1Task 2: Running...

Task @: Running...
Running...

Task 2: Running...

do coverage data dump

coverage data dump done

Figure 6.6. Console Logs

6.3.3. Display Coverage Information

1. Check the coverage files (Figure 6.7).

2. Double click one of the coverage files and click OK (Figure 6.8).

3. Wait for a few seconds, the coverage information is displayed (Figure 6.9).

For detailed usage of code coverage, refer to Help - Eclipse Platform and enter Gcov View in the Search box.
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wv (=5 riscv_rtos_ncdemo
> t;" Binaries
> I@J Includes
5 2 src
w = Debug
W [ srC
v = bsp
v (= driver
> (= gpio
» [ riscv_rtos
(= uart
> uart.o - [riscv/le]
| & subdir.mk
uart.d
[ uart.gcda
@ uart.gcno
» = mvos
S main.o - [riscv/le]

main.d

B main.gcda

& main.gcno

L@ subdir.mk
» f} riscv_rtos_rxdemo.elf - [riscv/1e]
| makefile
| @& objects.mk
\Z| riscv_rtos_rcdemo.bin

riscv_rtos_rcdemo.lst

riscv_rtos_rcdemo.map
riscv_rtos_ncdemo.mem

| @ sources.mk

Figure 6.7. Coverage Files

e
i Geov - Open coverage results..,

Binary File

Please enter here the binary file which produced the coverage data.

| Ic:\lscc\propel2023.2\workspace\riscv| | Workspace...

Coverage result
() Show coverage details for main.c only.

(®) Show coverage for the whole selected binary file

Figure 6.8. Open Coverage Results
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T
2 printf("Watchdog Timeout!\n");

#endif
5 #ifdef LOCAL UART INST_BASE_ADDR

local uart init(&local uart core, LOCAL UART INST BASE ADDR, CPU FREQUENCY, CPU@ INST BAUD RATE, 1, 8);
#endif

iob_init(lscc_uart putc, lscc_uart_getc, lscc_uart_flush);

9

g

94

25~ static void software interrupt_handler(void *ctx)
96 {

a7 // printf("Software Interrupt Handler!\n");
L schedule0);

og ¥

1ee

181= void start_kernel(void)

182 {

183 #ifdef UART_INST_BASE_ADDR

104 uart_init(&s_uart_core, UART_INST BASE_ADDR, CPU_FREQUENCY, UART INST BAUD RATE, 1, 8);

printf(“Hello, RVOS!\n");

pmp_init(};
printf("the granularity of pmp is &%d.\n", pmp_granularity(});
pmp_entry t entries[] = {
{ PMP_CFG_MODE_TOR, PMP_CFG_PER_R | PMP_CFG_PER_W | PMP_CFG_PER X, @xffffffff »> 2 }

}s
for {uint32 t i = @; i < sizeof(entries)/sizeof({entries[8]}; ++i)

[

if (pmp_entry write(i, &entries[i]) !'= @)

printf("failed to write pmp entry %d.\n", i);

[
Wk

}

page_init();
printf("page_init done.\n");
trap_init();
printf("trap_init done.\n");
plic_init();
printf("plic init done.\n"):

el el sl
[N ]

¥
[ N N

2] Problems |¥] Tasks | E) Console | [ Properties | & Terminal | [ geov %

program runs = 0
program file : Chlscc\propel\2023.2\workspacelriscv_rtos_ncdemot\Debug\riscv_rtos_redemo.elf
timestamp : 10/8/23, 4:36 PM

P type filter text

MName Total Lines Instrumented ...  Executed Lines  Coverage %

v Summary 3734 835 209 I 35.81%
cache.c 76 9 0 _ 0.0%
clint.c 130 37 3 _— 20.19%
clint.h 75 3 3 — 100.0%
clint.h ] 3 3 — 100.0%
debug.c 64 5 0 _— 0.0%
exception.c 101 18 12 . 66.67%

Figure 6.9. Code Coverage Information

6.4. Enabling Code Coverage for Existing C Project

1.

2
3.
4

g

In the Project Explorer view, select the existing C project.
Choose Project > Properties > C/C++ Build > Settings.
Select GNU RISC-V Cross C Compiler > Preprocessor. Add the defined symbol, LSCC_COVERAGE (Figure 6.10).

Select GNU RISC-V Cross C Compiler > Miscellaneous. Add the compiler flag, -fprofile-arcs -ftest-coverage
(Figure 6.11).

Select GNU RISC-V Cross C Linker > Libraries. Add the library, smallgcov (Figure 6.12).
Select GNU RISC-V Cross C Linker > Miscellaneous. Add the linker flag, --defsym=_HEAP_SIZE=0x1000 (Figure 6.13).
Note: The 0x1000 is a suggested value and it can be changed to a proper value if necessary.

Select GNU RISC-V Cross C Linker > Miscellaneous. Check link flags in the label, Other linker flags. Make sure the
linker flag, --oslib=semihost, is supported (Figure 6.14).

Click Apply and Close.

Add line scoverage_init(); to the head of code section, add line scoverage_dump(); to the end of code
section. You can refer to the sample template.
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10. Rebuild this C project.

$ Properties for riscv_rtos_redemo_default

|type filter text

Settings

» Resource
Builders
w C/C++ Build
Build Variables
Environment
Logging
Settings
Taol Chain Editor
» C/C++ General
» MCU
Project Natures
Project References
Run/Debug Settings

Task Tags
» Validation

SystemVerilog Project Prope

Configuration:

) Tool Settings

Debug [ Active ]

L3

Manage Configurations...

%3 Toolchains ; Devices .i" Build Steps Build Artifact Binary Parsers (% | *

(& Warnings

@ Target Processor
(# Optimization

(# Debugging
~ 3 GNU RISC-V Cross Assembler
(%5 Preprocessor
22 Includes
(%2 Warnings
# Miscellaneous
~ B3 GMNU RISC-V Cross C Compiler
(# Preprocessor
22 Includes
@ Optirmization
@ Warnings
(# Miscellaneous

[J Do not search system directories (-nostding)
O Preprocess only (-E)

Defined symbels {-D) € & 8 2

g

Figure 6.10. LSCC_COVERAGE Symbol

e .
i Properties for riscv_rtos_ncdemo_

Build Variables
Environment
Logging
Settings
Tool Chain Editor
5 C/C++ General
» MCU
Project Natures
Project References
Run/Debug Settings
SystemVerilog Project Prope
Task Tags
> Validation

i® Tool Settings & Toolchains '

default m} X
type filter text Settings . -
> Resource

Builders
w C/C++ Build Configuration: Debug [ Active ]

~ | | Manage Configurations...

| Devices " Build Steps Build Artifact Binary Parsers €3 Error Parsers

(¥ Target Processor
(¥ Optimization
(# Warnings
(# Debugging
~ 53 GNU RISC-V Cross Assembler
(%2 Preprocessor
#2 Includes
2 Warnings
(#2 Miscellaneous
~ 53 GNU RISC-V Cross C Compiler
(%2 Preprocessor
#2 Includes
(2 Optimization
(2 Warnings
(2 Miscellaneous
~ 83 GMU RISC-V Cross C Linker

#2 General

[] Generate assembler listing (-Wa,-adhlns="S@.lst")

[] 5ave temporary files (--save-temps Use with caution!)
[ Verbose (-v)

| |
Other compiler flags | picolibc.specs -DPICOLIBC_INTEGER_PRINTF_SCANI-fprofila-arc; -f'te;t-coveragell

Figure 6.11. -fprofile-arcs -ftest-coverage Compiler Flag
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Q Properties for riscv_rtos_ncdemo_default

type filter text

Settings

> Resource
Builders
w C/C++ Build
Build Variables
Environment
Logging
Settings

» C/C++ General

» MCU
Project Matures
Project References

Task Tags
> Validation

Tool Chain Editor

Run/Debug Settings
SystemVerilog Project Props

Configuration: | Debug [

¥ Tool Settings 2 Toolchains

Active ] ~ | | Manage Cenfigurations...

Devices # Build Steps Build Artifact Binary Parsers 3 Error Parsers

(22 Target Processor
@ Optimization
@ Warnings

@ Debugging

(%2 Preprocessor

2 Includes

(2 Warnings

(# Miscellaneous
~ B3 GMU RISC-V Cros

@ Preprocessor

@ Includes

@ Optimization

(2 Warnings

(2 Miscellaneous

(2 General
@ Libraries
@ Miscellaneous

w B3 GMURISC-V Cross Assembler

~ B3 GMU RISC-V Cross C Linker

w B3 GMU RISC-V Cross Create Listing

Libraries (-1} € 5 85 &

= C Compiler

Library search path (-1)

848 8 4l ¢

Figure 6.12. smallgcov Library

type filter text

> Resource
Builders
~ C/C++ Build
Build Variables
Environment
Logging
Settings
Tool Chain Editor
» C/C++ General
> MCU
Project Matures
Project References
Run/Debug Settings
SystemVerilog Project Prope
Task Tags
» Validation

G Properties for riscv_rtos_mdemo_default

Settings

Configuration:

Debug [ Active ]

& Tool Settings i Toolchains M Devices

~ | | Manage Configurations...

# Build Steps Build Artifact

Binary Parsers @ Error Parsers

(22 Target Processor
(2 Optimization
# Warnings
@ Debugging
~ B3 GNU RISC-V Cross Assembler
(22 Preprocessor
2 Includes
(2 Warnings
# Miscellaneous
~ B GNU RISC-V Cross C Compiler
(% Preprocessor
(2 Includes
(2 Optimization
(2 Warnings
# Miscellaneous
w %% GNU RISC-V Cross C Linker
@ General
(22 Libraries
(2 Miscellaneous

~ % GNU RISC-V Cross Create Listing

Linker flags (-Xlinker [eption])

€& 8 5L

Other objects

a0 8§

Figure 6.13. --defsym=_HEAP_SIZE=0x1000 Linker Flag
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$ Properties for riscv_rtos_nedemo_default

type filter text

» Resource
Builders
~ C/C++ Build
Build Variables
Environment
Logging
Settings
Toel Chain Editor
» C/C++ General
> MCU
Project Natures
Project References
Run/Debug Settings
SystemVerilog Project Prope
Task Tags
» Validation

Settings

Configuration: | Debug [ Active]

i Tool Settings &3 Toolchains M Devices # Build Steps Build Artifact Binary Parsers @ Error Parsers

(5% Target Processor

Linker flags (-Xlinker [option])

(2 Optimization
(% Warnings
(£ Debugging
~ 5 GMU RISC-V Cross Assembler
(2 Preprocessor
(& Includes
(2 Warnings
(£ Miscellaneous
~ ) GMU RISC-V Cross C Compiler
(¥ Preprocessor

Other object:
(2 Includes e onects

(2 Optimization

LEEAR= RN

(5 Warnings

(£ Miscellaneous

~ B3 GMNU RISC-V Cross C Linker

% General

(& Libraries

(2 Miscellaneous

~ [ GNU RISC-V Cross Create Listing
(& General

~ B GNU RISC-V Crass Print Size Generate map |“S{BuiIdAmfactFiIEBaseName}.map”
(£ General [[] Cross reference (-Xlinker --cref)

v B} Lattice Create Memory Deployment | Print link map (-Xlinker --print-map]
(% General

[J Use newlib-nane (--specs=nano.specs)
[] Use float with nano printf {-u _printf_float)
[[] Use float with nane scanf (-u_scanf float)
[ De not use syscalls (--specs=nosys.specs)
[ verbose (-v)

Other linker flags | --specs=picelibc.specs -DPICOLIBC_INTEGER_PRINTF_SCA|

-oslib=semihost

Figure 6.14. --oslib=semihost Linker Flag
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7. Propel Tutorial — Timing Profiling

Timing profiling is an important aspect of software programming. Through profiling one can determine the parts in
program code that are time consuming and need to be re-written. This helps make user program execution faster,
which is always desired.

The timing profiling function is supported in Timing Profiling Project.
This tutorial uses a CertusPro-NX Evaluation Board with RISC-V RX SoC Project for demonstration.

Note: Timing Profiling Project needs more system memory, the suggestion value is 0x20000.

7.1. Prepare the Hardware and Programming the Target Device
1. Create RISC-V RX SoC Project with CertusPro-NX Evaluation Board (Figure 5.1). Click Finish.

2. Propel Builder automatically opens. In Propel Builder, double-click tcm0O_inst in the Schematic view and set a larger
value for Address Depth both in Port SO Settings (Figure 6.1) and Port S1 Settings (Figure 6.2). Click Generate.

Select Project > Generate.
Generate the programing file by running Lattice Radiant software in this SoC Project.

5. Program the programing file to the target device, CertusPro-NX Evaluation Board.

7.2. Creating Timing Profiling C Project

1. The Timing Profiling C project can be created through the Load System and BSP page (Figure 7.1).
2. In System env field, select the system environment file from the RX core SoC project just generated.
3. Select Timing Profiling Project and check the project name.

4. Click Next. Click Finish.
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£t C/C++ Project O x

Load System and BSP —

Load lattice system environment file and BSP package

Select system environment file and BSP package

System env: | Chlscc\propel2024. 1'workspace\ExampleSoChsgelsys_envaxml -~ Browse...

Select processor core to create C/C++ Project

Core selected: | cpul_inst v
Projecttype: | C ~
System information

Device Family CPU MName Instance Name

LFCPMX riscv_rtos cpull_inst
Select Example Application
FreeRTO5-LT5 minimal Project Example-Timing-Profiling ~
FreeRTOS-LT5 PMP-Blinky Proiect
[ Timing Profiling Project ‘ 1.Generate timing profiling information and report.
Hello World Project 2.Using different implementations of memory
RISC-V RX Demo Project functions for demo.

Note:
1.Please select Semihosting(System Library) when

rreatinn thic nrniert

Project name: |riscv_rtos_gprof

Use default location
Cihlscchpropel2024.T\workspace\riscv_rtos_gprof Browse...

default

[]Build the project
Create a debug launch configuration for | Open0CD

?\. < Back Finish Cancel

Figure 7.1. Create Timing Profiling Project

7.3. Compiling and Running Demo

7.3.1. Compiling C Project

1. Inthe Project Explorer view, select the C project, riscv_rtos_gprof.

2. Select Project > Build Project.

7.3.2. Running Demo
1. Inthe Project Explorer view, select the C project, riscv_rtos_gprof.

2. Select Run > Debug Configurations....
3. Select riscv_rtos_gprof in GDB OpenOCD Debugging (Figure 7.2).
4

Click the Debug button.

Wait for a few seconds for switching to the debug perspective, starting the server, allowing it to connect to the
target device, starting the gdb client, downloading the application, and then starting the debugging session.

Note: This demo uses the default debug configuration options.
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£t Debug Configurations O x

Create, manage, and run configurations

0 rﬂ} o B X | = ? M Mame: |riscv_rtos_gprof
|typeﬁ|tertext | Main] CableConn| 5 Debugger| [ Startup| Bp Source| = Common| 5 SVD Pathl
v [&] GDB OpenOCD Debugging Project:
[c] risev_rtos_gprof
E GDB QEMU Debugging | riscy_rtos_gprof | Browse...
% Launch Group C/C++ Application:
| Debughriscv_rtos_gprof.elf
Variables... Search Project... Browse...
Build (if required) before launching
Build Configuratien: | Select Automatically ~
(_) Enable aute build () Disable auto build
(®) Use workspace settings Configure Workspace Settings...
Revert Appl
Filter matched 4 of 10 items — BoY

®

Figure 7.2. Debug Configuration

5. Select Run > Resume. Then the console output logs.
Wait for a few minutes, until the console logs: Test success! file "gmon.out" has been generated.

6. Select Run > Terminate to stop running.

7.3.3. Display gprof Viewer
1. Find the gmon.out file in Project Explore of the riscv_rtos_gprof project. Double-click this file (Figure 7.3). Click OK.
2. Wait for a few minutes. The gprof Viewer opens (Figure 7.4).

For detailed usage of gprof Viewer, refer to Help - Eclipse Platform and type in GProf View in the Search box.
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3% workspace - riscy_rtos_gprof/src/main.c - Lattice Propel — 0 X

File Edit Source Refactor Mavigate Search Project Run LatticeTools Window Help

O-rHele 0% sl S0ReR 4 -0- %O 4
BB ey Q E| &4
45 Debug | (1 Project Ex = O |[k Lattice Platform | (4] main.c X = 0wV X\ %Br|4E|Tp| = O
B & 18 // SPECIFICALLY DISCLAIMS ANY IMPLIED WARRANTY OF MERCHANT , =% = =
= ? § 19 // FITNESS FOR A PARTICULAR PURPOSE. LATTICE DOES NOT WAR i | ) §
> @ ExampleSoC 2@ // FUNCTIONS CONTAINED HEREIN WILL MEET LICENSEE'S REQUIRE Name Type
vg riscv_rtos_gprof 21 // LICENSEE'S OPERATION OF ANY DEVICE, SOFTWARE OR SYSTEM
> $¥ Binaries 22 // OR ITS CONTENTS WILL BE UNINTERRUPTED OR ERROR FREE, OF
> @ Includes 23 // HEREIN WILL BE CORRECTED. LICENSEE ASSUMES RESPONSIBIL
24 // SELECTION OF MATERIALS TO ACHIEVE ITS INTENDED RESULTS,
» BB sre 25
» & Debug 26 | £t Gmon File Viewer: binary file... X
¥ gmon.out 27
[¥] riscv_rtos_gprof.launch i: Binary File
30 Please enter here the binary file which preduced the profile data.
3L
22| [Esce\propen 2004 \workspacelriscy| | Workspace...| | File System...
33
34
35
36
3 ok || cancel < >
39
Ly T ——
a1
42 #include <stdio.h>
43 #include <string.h>
44 #include "board.h"
45 #include "gprof.h”
A6 #imclada "fimar Wt M
< >
4B Terminal HE Problems (0 Executables (ﬁ Debugger Console (E Console X = 0O

EX% GREE 2

<terminateds> riscv_rtos_gprof [GDB OpenOCD Debugging] openocd.exe (Terminated Apr 23, 2024, 5:19:59 PM)

(3266) timeh (/32) A
(3267) instreth (/32)

(3922) mvendorid (/32)

(3923) marchid (/32)

(3924) mimoid (/32) h
<

I riscv_rtos_gprof/gmon.out

Figure 7.3. gmon File Viewer

% workspace - riscv_rtos_gprof/src/main.c - Lattice Propel - O X

Eile Edit Source Refactor Navigate Segrch Project Run  LatticeTools Window Help

(D-HGR B rUrENec IR SORSEH-0- A dI- S
PR ARl Q s
X ® = O mainc X = 0@ var X % Bre |9 Ep| B pei| = O
18 // SPECIFICALLY DISCLAIMS ANY IMPLIED WARRANTY OF MERCHANTABILITY O = d
i:b ? § 19 // FITNESS FOR A PARTICULAR PURPOSE. LATTICE DOES NOT WARRANT THAT " il cls | 03 ef §
» 13 ExampleSoC 26 // FUNCTIONS CONTAINED HEREIN WILL MEET LICENSEE'S REQUIREMENTS, OR Name Type
v&c risev_rtos_gprof 21 // LICENSEE'S OPERATION OF ANY DEVICE, SOFTWARE OR SYSTEM USING THI
» 4% Binaries 22 // OR ITS CONTENTS WILL BE UNINTERRUPTED OR ERROR FREE, OR THAT DEF
5 I@] Includes 23 // HEREIN WILL BE CORRECTED. LICENSEE ASSUMES RESPONSIBILITY FOR
24 // SELECTION OF MATERIALS TO ACHIEVE ITS INTENDED RESULTS, AND FOR
> B8 sre 25 // PROPER INSTALLATION, USE, AND RESULTS OBTAINED THEREFROM. LICEN
> [ Debug 26 // ASSUMES THE ENTIRE RISK OF THE FILE AND ITS CONTENTS PROVING DEF
[ gmon.out 27 // OR FAILING TO PERFORM PROPERLY AND IN SUCH EVENT, LICENSEE SHALL
[X] riscv_rtos_gprofl|| 28 // ASSUME THE ENTIRE COST AND RISK OF ANV REPAIR, SERVICE, CORRECTI < >
29 // ANY OTHER LIABILITIES OR DAMAGES CAUSED BY OR ASSOCIATED WITH TH
3@ // SOFTWARE. 1IN WO EVENT SHALL LATTICE BE LIABLE TO ANY PARTY FOR
31 // INDIRECT,SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES, INCLUDIN w
< >
@Termma\ ﬂ:': Problems ro Executables (E Debugger Consale rE Console | [ gprof X = 0

ER Y R T

gmon file: Gllscc\propel\2024. 1\workspace\riscv_rtos_gprofigmon.out

program file: C:/lscc/propel/2024.1/workspace/riscv_rtos_gprof/Debug/riscv_rtos_gprof.elf
timestamp: 4/23/24, 5:17 PM

2 bytes per bucket, each sample counts as 1.000ms

P type filter text

Name (location) Samples Calls Time/Call ‘BG'I'H'neV [a]
~ Summary ass i 100.0%
» timer.c 500 I 56.31%
» memfun.c 387 . 43.58%
» riscwh 1 _— 0.11%
» board.c ) — 0.0%
» clint.c o — 0.0%
> exception.c o — 0.0%
> gpie.c o I 0.0%
> gprof.c 0 —0.0%
» interrupt.c ) — 0.0%
» iob.c o _— 0.0%
< > > main.c o — 0.0% v

Figure 7.4. gprof Viewer
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7.4. Enabling Timing Profiling for Existing C Project

1. Inthe Project Explorer view, select the existing C project.

2. Select Project > Properties > C/C++ Build > Settings.

3. Select Debugging. Enable the Generate gprof information checkbox (Figure 7.5).

4. Select GNU RISC-V Cross C Compiler > Preprocessor. Add the defined symbol, LSCC_GPROF (Figure 7.6).

5. Select GNU RISC-V Cross C Linker > Libraries. Add the library, smallgprof (Figure 7.7).

6. Select GNU RISC-V Cross C Linker > Miscellaneous. Check link flags in the label, Other linker flags. Make sure the
linker flag, --oslib=semihost, is supported (Figure 7.8).

7. Click Apply and Close.

Open file linker.ld in the src folder. Set an enough value for _HEAP_SIZE (Figure 7.9).

Note: HEAP_SIZE is the size of heap memory, used for malloc. Timing profiling function requires additional heap
memory. The size is approximately 125%/175% of .text size.

9. Copy gprof.c and gprof.h to src folder, the files can be found from demo project created in the Creating Timing
Profiling C Project section.

10. Enable a hard timer. Add function profile_handler() into timer handle.

11. Add line gprof_init(); tothe line where profiling starts. Add line gmon_out () ; to the line where profiling
stops.

12. Refer to the demo project and make code correct.
13. Rebuild this C project.
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Q Properties for riscv_rtos_gprof

| type filter text

» Resource
Builders
s C/C++ Build
Build Variables
Environment
Logging
Settings
Tool Chain Editer
» C/C++ General
> MCU
Project Matures
Project References
Run/Debug Settings
SystemVerilog Project Properties
Task Tags
> Validation

Settings

Configuration: | Debug [ Active ]

& Tool Settings i Toolchains M Devices & Build Steps

@ Target Processor
@ Optimization
(2 Warnings
(%% Debugging
w B3 GNU RISC-V Cross Assembler
(22 Preprocessor
(22 Includes
@ Warnings
(2 Miscellaneous
w 3 GNU RISC-V Cross C Compiler
(22 Preprocessor
@ Includes
(2 Optimization
(22 Warnings
@ Miscellaneous
~ B3 GNU RISC-V Cross C Linker
(22 General
@ Libraries
(2 Miscellaneous
w 3 GNU RISC-V Cross Create Listing
(22 General
w %3 GNU RISC-V Cross Print Size
(# General
w B33 Lattice Create Memory Deployment
@ General

Debug level

Debug format

[ Generate prof information (-p)

Lv3

Build Artifact BinaryParsers 11"
Maximum (-g3) ~

Toolchain default ~

Manage Configuratiens...

e
r Generate gprof information (-pg)

Other debugging flags |

Restore Defaults Apply
® Apply and Close Cancel

Figure 7.5. Generate gprof Information
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$ Properties for riscv_rtos_gprof

|typefilter text

5 Resource
Builders
w C/C++ Build
Build Variables
Environment
Legging
Settings
Teol Chain Editor
» C/C++ General
» MCU
Project Matures
Project References
Run/Debug Settings
SystemVerilog Project Properties
Task Tags
» Validation

Settings

Cenfiguration: |Dehug [ Active ]

V| | Manage Conﬁguraiions...|

B Tool Settings 3 Toolchains [l Devices . Build Steps

(% Target Processar
& Optimization
%2 Wamings
@ Debugging
~ [ GNU RISC-V Cross Assembler
(22 Preprocessor
(22 Includes
(22 Warnings
(22 Miscellaneous
~ 83 GMU RISC-V Cross C Compiler
(2 Preprocessor
(22 Includes
# Optimization
@ Warnings
@ Miscellanecus
~ 83 GMU RISC-V Cross C Linker
£ General
(22 Libraries
(# Miscellaneous
~ [83 GMU RISC-V Cross Create Listing
(2 General
~ [ GMU RISC-V Cross Print Size
2 General
~ %3 Lattice Create Memory Deployment
2 General

[ Do not search systemn directories (-nostding)

[[]Preprocess only (-E)

Build Artifact Binary Parsers ll:l:‘

Defined symbols (-D)

& & 8 il P

Undefined symbals (-U)

=R ARERARY

| Restore Qefaulls| | Apply |

I.Apply and Closel | Cancel |

Figure 7.6. LSCC_GPROF Symbol
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3 Properties for riscv_rtos_gprof

|t)rpefilter text

» Resource
Builders
w C/C++ Build
Build Variables
Environment
Logging
Settings
Teol Chain Editor
» C/C++ General
> MCU
Project Matures
Project References
Run/Debug Settings
SystemVerilog Project Properties
Task Tags
> Validation

Settings

Cenfiguration: |Dehug [ Active ]

V| | Manage Configutations...l

i Tool Settings &) Toolchains

- Devices & Build Steps

Build Artifact BinaryParsers ll:l:‘

(22 Target Processor
# Optimization
@ Warnings
(# Debugging
~ B3 GNU RISC-V Cross Assembler
(% Preprocessor
@ Includes
(% Warnings
@ Miscellaneocus
~ B3 GMNU RISC-V Cross C Compiler
@ Preprocessor
(# Includes
(8 Optimization
2 Warnings
@ Miscellaneocus
~ 8 GMU RISC-V Cross C Linker
@ General
(2 Libraries
(# Miscellaneous
~ [ GNU RISC-V Cross Create Listing
@ General
~ 3 GNU RISC-V Cross Print Size
# General
w [y Lattice Create Memory Deployment
@ General

Libraries (-1}

8 & 85l

Library search path (-L)

848 34l &

| Restore Qe{auhsl | Apply |

|Apply and Closel |

Cancel |

Figure 7.7. smallgprof Link Library
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Q Properties for riscv_rtos_gprof

| type filter text

Settings

> Resource
Builders
~w CfC++ Build
Build Variables
Environment
Legging
Settings
Teol Chain Editor
» C/C++ General
> MCU
Project Matures
Project References
Run/Debug Settings

Task Tags
» Validation

SystemVerilog Project Properties

i
1
ik
4

(& Debugging
w B85 GNURISC-V Cross Assembler
(& Preprocessor
(2 Includes
(£ Warnings
(£ Miscellaneous

~ 3 GNU RISC-V Cross C Compiler

(& Preprocessor Other objects

8a 8 %l &

(2 Includes
(& Optimization
(£ Warnings
(£ Miscellaneous
~ &3 GNU RISC-V Cross C Linker
(2 General
(5 Libraries
@ Miscellaneous

~ B8 GNU RISC-V Cross Create Listing

(# General Generate map | "${BuildArtifactFileBaseName}.map"

~ B8 GNU RISC-V Cross Print Size
(% General

w B8 Lattice Create Memory Deployment
(% General

[[] Cross reference (-Klinker --cref)

[ Print link map (-Xlinker --print-map)
[[JUse newlib-nano (--specs=nano.specs)
[ Use float with nano printf (-u _printf_float)
[ Use float with nane scanf (-u _scanf_float)
[]Do not use syscalls (--specs=nosys.specs)
[ Verbose (-v)

Other linker flags | --specs=picolibc.specs -DPICOLIEC_\NTEGER_PRINTF_SCANFl-o;lib:sermho;t I

| Restore Qefaulls| | Apply | v

@ |Appl_',' and Clusel | Cancel |
Figure 7.8. --oslib=semihost Linker Flag
P
QF X
Tl Linker = g
1/* Lattice Generated linker script, for normal executables */ A
2
3 ENTRY (_start)
4
5 _HEAP_SIZE = DEFINED(_HEAP_SIZE) ?I HEAP SIZE : @x7000; I
& _STACK_SIZE = DEFINED{_ STACK SIZE) 7 - : 3
7
8 MEMORY]
o9
16 tcm@_inst (rwx) : org = Bx8@, len = @x20600
11}
12
13 SECTIONS )
Overview | linker.d |

Figure 7.9. _HEAP_SIZE in Linker Script File
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8. Propel Tutorial - QEMU

QEMU is a generic and opensource machine emulator and virtualizer.
For the detailed manual of QEMU, refer to System Emulation — QEMU documentation.

Lattice Propel 2024.1 includes a RISC-V QEMU simulator with no hardware required and a QEMU_helloworld template
for demonstration.

8.1. Creating QEMU Hello World C Project

1. Select File > New > @ Lattice C/C++ Project.
The C/C++ Project wizard opens with the Load System and BSP page (Figure 8.1).

Q C/C++ Project O X

Load System and BSP —

Load lattice system environment file and BSP package

Select systern environment file and BSP package

S SO NI OFMU RISC-V Virtual SoC System Browse...
Select proce

Core selected: | spike -
Project type:  |C -

System information

Machine Name CPU Name
spike

Select Example Application

A
1.QEMU test,
2.5emihost print.
MNote:
1.Please select Semihosting(System Library) when
creating this project.
v

Project name: | spike_gemu_helloworld

Use default location
-

Location: | Chlscch\propelh2024. T\workspace\spike_gemu_helloworld Browse...

Choose file systern: [default

[ Build the project
Create a debug launch configuration for  QEMLU

® < Back FEinizh Cancel

Figure 8.1. Load System and BSP Page

Select QEMU RISC-V Virtual SoC System using the drop-down menu of the System env field (Figure 8.1).
Select QEMU_helloworld Project and check the project name.
The C project is created and displayed in the workbench.

vk W

In the Project Explorer view, select the C project just created, spike_gemu_helloworld.
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6.
7.

Choose Project > Build Project.
Check the build result from the Console view (Figure 8.2).

i ] X

Bl Console % xl@ﬁﬂéﬂﬁuﬁ %;EW“‘E'ﬁ":E
CODT Build Console [spike_gemu_helloworld]

PLNLISIEW UUIIULIE Lal GELs SPIRE_GCIib_ 1 L LUWUl tu. ool

Invoking: @NU RISC-V Cross Create Listing

riscv-none-embed-objdump --source --all-headers --demangle --line-numbers --wide “spike_gemu_helloworld.elf” >
"spike_gemu_helloworld.lst™

Finished building: spike_gemu_helloworld.lst

Invoking: @NU RISC-V Cross Print Size
riscv-none-embed-size --format=berkeley “spike_gemu_helloworld.elf™

text data bss dec hex filename

2168 28 68157448 68159628 418888c spike_gemu_helloworld.elf
Finished building: spike_gemu_helloworld.siz

Invoking: Lattice Create Memory Deployment

riscv-none-embed-objcopy -0 binary --gap-fill @ "spike _gemu_helloworld.elf” “spike_gemu_helloworld.bin™;
srec_cat "spike_gemu_helloworld.bin™ -Binary -byte-swap 4 -DISable Header -Output "spike gemu_helloworld.mem
-MEM 32

Finished building: spike_gemu_helloworld.mem

sh D:\lscc\propel\2@24.1\sdk\eclipse\/. . /tocls/bin/ipl32f_2_ipl32.sh spike_gemu_helloworld.elf
1+@ records in
1+@ records out

11:89:44 Build Finished. @ errors, @ warnings. (took 7s5.291ms)

Figure 8.2. Build Console

8.2. Running QEMU C Project

1.

2.
3.
4

In the Project Explorer view, select the C project just created, spike_gemu_helloworld.
Choose Run > Debug Configurations....

Choose spike_gemu_helloworld in GDB QEMU Debugging (Figure 8.3).

Click the Debug button.

Wait for a few seconds for switching to the debug perspective, starting the server, allowing it to connect to the
target device, starting the gdb client, downloading the application, and then starting the debugging session.

Note: This demo uses the default debug configuration options.

Click the Resume icon % on the toolbar. The Console outputs running logs (Figure 8.4).
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% Debug Configurations m] X
Create, ge, and run i
CEHeEX BY- MName: [spike_gemu_helloworld
|t)'PEf“tE’tEXt | Mainl <3 Debuggerl =3 Startupl Yo Sourcel =] Common | 5 SVD Pathl
> [c] GDB Open0OCD Debugging Project
~ [£] GDB QEMU Debugging
E_:l spike_gemu_helloworld |sp|ke7qamu7hallowor\d | | Browse... |
@ Launch Group C/C++ Application:
| Debug\spike_gemu_helloworld.elf |
Variables... ‘ ‘Search Plcrjecl...| | Browse... |
Build (if required) before launching
Build Configuration: | Select A i v
(O Enable aute build (O Disable aute build
(®) Use workspace settings Configure Workspace Settings...
Revert Appl
Filter matched 6 of 12 items = Y
® | Debug | | Close

Figure 8.3. Debug Configurations Page

3 workspace - spike_gemu_helloworld/src/main.c - Lattice Propel - m] X

Eile Edit Source Refactor MNavigate Segrch Project Run  LatticeTools Window Help

G-HE B Ris  ruede it S0ReR -0 G-i® @4

H~fl~td oot Q iE| &
45 Debug X . [ Project Explorer. = O |[7% Lattice Platform €1 0x0 | [0l mainc | [6) main.c =8 |(wev x 0| =g
B % | i+ 42 #include <stdic.h> ~ fml == .1
. B >6| § 43 #include "utils.h” ‘ B §
v [&] spike_gemu_helloworld [GDB QEMU Debugy 44 Mame Type
~ (T2 spike_qemu_helloworld.elf [1] as

+& Thread #1 1 (CPU£0 [running]) (Runni
oo gemu-system-riscv32.exe
W riscv-none-embed-gdb

6= int main(void) {
uintd t idx = @;

printf("\n\nHelle QEMU RISC-V world!\nin"};

while (1) {
for (int 1 =7; i >=8 ; i--)

< >

ifii Registers ﬂl': Problems ro Executables (ﬂ Debugger Co (n Memory (E Console > & gprm’] - Termmaq = 0
X% BEREE -

spike_gemu_helloworld [GDB QEMU Debugging]

Invalid read at addr @x@, size 2, region '(null)', reason: rejected
Invalid read at addr 9x8, size 2, region '(null)', reason: rejected

Hello QEMU RISC-V world!

fatalelatatalclc]
20808801
abaaaala
apaaeall
‘aopaelon
20808101

Figure 8.4. Running/Debugging Windows
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Appendix A. Linker Script and System Memory Deployment
During the Lattice C/C++ Project creation, Lattice Propel SDK generates a linker script file, linker.ld, within the project.
This linker script file contains a memory region list parsing from the corresponding SoC design.

Note: lllegal memory regions are not imported to linker script. A memory region is considered illegal if it has any of the
following conditions:

e No connection to CPU
e Address space conflict

Each memory region has a list of attributes to specify whether or not using a particular memory region for an input
section (Figure A.1).

e r:Read-only section.
e w: Read/Write section indicating the memory region is connected to the data port of CPU.

e x: Executable section indicating the memory region is connected to the instruction port of CPU.

Linker Script: linker.ld

Available Memory Regions

Mame Attributes || Base Address Size
sysmermi_inst I 000000000 000008000
sysmeml_inst w 000010000 000008000

Figure A.1. Memory Regions in Linker Script

The generated linker script contains a mapping table of section pointing to the memory region (Figure A.2). Depending
on the attributes of each memory region, code section and data section can point to the same or different memory

regions.

Section to Memory Region Mapping

CODE: |sysmem0_inst =
DATA: |sysmeml_inst =

Section Mame Memory Region i
text sysmermn_inst 2
«ctors sysmem{_inst

dtors sysmermn_inst il

Overview | linker.ld

Figure A.2. Section to Memory Region Mapping

During the Lattice C/C++ Project building, Lattice Propel SDK generates Lattice system memory initialization files.
Depending on the number of the memory regions used, it generates single memory initialization file or multiple
memory initialization files. The following picture (Figure A.3) shows an example of multiple memory files being
generated, separated for code and data segments.
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3
A= ;r:bug Section to Memory Region Mapping

- 2= src
. ¥'s Example.elf - [noneslel -

=| Example_Codernem EIlE
Example Data.mem DATA:

I ['III

= Example.bin
=] Bamplelst Section Mame Memory Region
=] Example.ma E
=l p_ P text sysmem(_inst |l|
| @ makefile i

. .ctors sysmermn(_inst
| @ objects.mk i

Jdtors sysmem(_inst

| @ sources.mk o o -

=| tmp

Overview | linker.ld

Figure A.3. Linker Script and Generated Memory Files

If you modify the linker script manually after the Lattice C/C++ project creation, especially changing the number of the
used memory regions, the number of memory files generated during project building cannot be changed automatically.
You can re-configure the generation of memory files in Lattice Propel through the following ways:

1.
2.
3.

In the Project Explorer view of Lattice Propel, select a C/C++ project.
Choose Project > Properties. The Properties dialog opens showing the properties of the current project.
Select Settings of C/C++ Build category from the left pane. Select the Toolchains tab (Figure A.4).

Check Create memory file, if you point the code and data segments to the same memory region. Or, check Create
multiple memory files, if you point the code and data segments to separate memory regions.

Click Apply.
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Q Properties for HelloWorld

| type filter text

Resource

W

Builders
w C/C++ Build
Build Variables
Envircnment
Logging
Settings
Tool Chain Editor
C/C++ General
» MCU
Project Matures

W

Project References

Run/Debug Settings
SystemVerilog Project Properties
Task Repository

Task Tags

Validation

W

O X
Settings Dror 8
Configuration: | Debug [ Active ] ~| | Manage Cenfigurations...

B3 Tool Settings i Toolchains ! Devices ,j“ Build Steps Build Artifact Binary Parsers | * | *

Mame: | GMNU MCU RISC-V GCC (riscv-nene-embed-gcc) e
Architecture: | RISC-V v|
Prefix: | riscv-none-embed- |
Suffix: | |
C compiler: | gcc |
C++ compiler: | g++ |
Archiver: ar
Hex/Bin converter: | objcopy |
Listing generator: | objdump |
Size command: | size |
Build command: | make |

|

Remove command: | rm

Toolchain path: | §{eclipse_home}/../riscv-none-embed-gec/bin

(to change it use the global or workspace preferences pages or the project properties page
Build tools path: | §{eclipse_homel/../build_tools/bin

(to change it use the global or werkspace preferences pages or the project properties page

[] Create memory file

Create multiple memory files

Create extended listing
Print size

Restore Defaults Apply

@

Apply and Close Cancel

Figure A.4. Toolchains Tab of C/C++ Build Settings

5. Go back to the Tool Settings tab. The relevant Lattice memory deployment tools can be found (Figure A.5).
Customize the tool options as needed.

6. Click Apply and Close to save the change.

Note: The setting for each configuration, Debug or Release, is independent.
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i Tool Settings &3 Toolchains B Devices # Build Steps Build Artifact Binary Parsers EIZ'

(% Target Processor LIFill gaps in the data
(£ Optimization Data Walue 0

# Warnings
(# Debugging

w 83 GNU RISC-V Cross Assembler
(# Preprocessor
2 Includes
# Warnings
(# Miscellaneous

~ 33 GNU RISC-V Cross C Compiler
(# Preprocessor
2 Includes
(# Optimization
# Warnings
(# Miscellaneous

~ 83 GNU RISC-V Cross C Linker
# General
(2 Libraries
(# Miscellaneous

w B GMNU RISC-V Cross Create Listing
@ General

w B GMU RISC-V Cross Print Size
¥ General

w B8 Lattice Create Memory Deployment
@ General

w B8 Lattice Multi Memory Deployment (CODE SEGMENT)
@ General

w B8 Lattice Multi Memory Deployment (DATA SEGMENT)
¥ General

Address Range | 0xB8000

| Restore Defauhs| | Apply

Figure A.5. Tool Settings Tab of C/C++ Build Settings
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Appendix B. Standard C Library Support

Lattice Propel SDK bundles Picolibc as the standard library support (https://keithp.com/picolibc/). Picolibc is a set of
standard C libraries, both libc and libm, designed for smaller embedded systems with limited ROM and RAM. Picolibc
includes code from Newlib (https://sourceware.org/newlib/) and AVR Libc (https://www.nongnu.org/avr-libc/).

Printf and Scanf Levels in Lattice Propel SDK

Lattice Propel SDK provides three levels of printf support with the support of Picolibc, which can be selected when
creating a Lattice C/C++ project (Figure B.1), or be modified in the toolchain settings in the project properties after the
project is created, noting that the options in both compiler and linker need to be set (Figure B.2 and Figure B.3).

e Integer only printf (-DPICOLIBC_INTEGER_PRINTF_SCANF). This is the default selection in Lattice Propel SDK, which
removes the support for all float and double conversions to save code size.

e  Float only printf (-DPICOLIBC_FLOAT_PRINTF_SCANF). It requires a special macro for float values: “printf_float’. To
make it easier to switch between that and other two levels, that macro should also be correctly defined for the
other two levels.

Here is a sample program to demonstrate the usage:

#include <stdio.h>

void main(void) {

printf(" 2761 = %11d, Pi = %.17g\n", 111 << 61,
printf float(3.141592653589793));
}

e  Full printf (-DPICOLIBC_DOUBLE_PRINTF_SCANF). This offers full printf functionality, including both float and
double conversions.

System Library Interfaces Used in Lattice Propel SDK

Lattice Propel SDK provides three system library for stdio support with the help of Picolibc, which can be selected when
creating a Lattice C/C++ project (Figure B.1), or be modified in the toolchain settings in the project properties after the
project is created, noting that only the option in linker needs to be set (Figure B.3).

e Default. Use the default system library interface (UART) in BSP, this requires a UART instance inside the SoC design.
The default library is implemented in the processor driver code and no additional linker options are required.

e Semihosting (--oslib=semihost). Semihosting is a mechanism that enables code running on the target to
communicate with and use the 1/O of the host computer. Lattice Propel SDK provides semihosting support in
On-Chip-Debugging flow. It allows printing messages to the debugger console without relying on the UART
instance, and it also supports file 1/0.

e  Dummyhosting (--oslib=dummyhost). Dummy stdio hooks. This allows programs to link without requiring any
system-dependent functions. This is only used if the program does not provide its own version of stdin, stdout, and
stderr.
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78 C/C++ Project O X
Lattice Toolchain Setting
Configuration: | Debug w
Lib Setting  C/C++ Compiler C/C++ Linker
() Mo default libraries (-nodefaultlibs)
(O Newlib
() Mewlib-nano (--specs=nano.specs)
(®) Picolibe (--specs=picolibc.specs)
Printf Level
(®) Integer only printf (-DPICOLIBC_INTEGER_PRINTF_SCANF)
() Float printf (-DPICOLIBC_FLOAT_PRINTF_SCANF)
() Full printf (-DPICOLIBC_DOUBLE_PRINTF_SCANF)
Systern Library
(®) Default
O Semihosting (--oslib=semihost)
(O) Dummyhosting (--oslib=durmmyhost)
@ Mest= [ Finish | Cancel

Figure B.1. Lattice Toolchain Setting Dialog

Q Properties for Example

| type filter text

> Resource
Builders

w C/C++ Build
Build Variables
Environment
Logging
Settings
Tool Chain Editor

C/C++ General

MCU

Project Matures

v

Project References

Run/Debug Settings
SystemVerilog Project Properties
Task Repository

Task Tags

Validation

W

Settings

Cenfiguration: | Debug [ Active ]

(2 Target Processor
(2 Optimization
@ Warnings

@ Debugging

(E Preprocessor
(2 Includes
(% Warnings
(2 Miscellaneous

(2 Preprocessor
@ Includes
@ Optimization
# Warnings
(% Miscellaneous
~ B3 GMU RISC-V Cross C Linker

O *
=R =30
A
n | | Manage Configurations... |
& Tool Settings &3 Toolchains M Devices # Build Steps Build Artifact Binary Parsers @ Error Parsers
[ Generate assembler listing (-Wa,-adhlns="3@.Ist")
[]5ave temporary files (--save-temps Use with caution!)
« B GNU RISC-V Cross Assembler Other compiler flags | --specs=picolibc.specs -DPICOLIBC_INTEGER_PRINTF_SCANF
~ B GMWU RISC-V Cross C Compiler
v
|Appl}'and Closel | Cancel

Figure B.2. Properties of C/C++ Project — Compiler Options
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oW

v

a Properties for Example

| type filter text
» Resource

Builders

w CfC++ Build

Build Variables
Discovery Options
Environment
Logging
Settings
Tool Chain Editor
C/C++ General
MCU
Project Natures
Project References
Run/Debug Settings
SystemVerilog Projec
Task Repository
Task Tags
Validation

Settings

Configuration: Debug [ Active ]

% Tool Settings % Toolchains M Devices # Build Steps

(= Target Processor
(@ Optimization
(& Warnings
(= Debugging
~ B GNU RISC-V Cross Assembler
& Preprocessor
(& Includes
(& Warnings
(& Miscellaneous
~ B GNU RISC-V Cross C Comipiler
(= Preprocessor
(& Includes
(& Optimization
(= Wamings
(& Miscellaneous
~ B GNU RISC-V Cross C Linker
(= General
(& Libraries
(% Miscellaneous
~ B GNU RISC-V Cross Create Listing
(% General
~ H GNU RISC-V Cross Print Size
(& General
~ W Lattice Create Memory Deployment
(& General

~  Manage Configurations...

1 Build Artifact [u Binary Parsers @ Error Parsers

Linker flags (-Xlinker [option]) 0850
Other objects € 80 8 )
Generate map "%{BuildArtifactFileBaseMName}.map”

[[] Cross reference (-Xlinker --cref)

[ Print link map (-Xlinker --print-map)

[J Use newlib-nano (--specs=nano.specs)
[JUse float with nano printf (-u _printf_float)
[ Use float with nano scanf (-u _scanf_float)
[[]1Do not use syscalls (--specs=nosys.specs)

Verbase (-v)
r linker flags |-—specs=picolibc.specs -DPICOLIBC_INTEGER_PRINTF_SCANF --oslib=dummyhost | I

Restore Defaults

|

Apply

Cancel

Figure B.3. Properties of C/C++ Project — Linker Options
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Appendix C. Third-party Command-line Tools in Lattice Propel
SDK

Lattice Propel SDK integrates with a number of third-party command-line tools, which can be used with Propel User
Interface or as stand-alone command-line tools. You can find these command-line tools and their documentation
according to the following list.

1. Windows Build tools
Version: 4.2.1-1
Binaries Location: <Propel Installation Location>\sdk\build_tools\bin

Documents Location: <Propel Installation Location>\sdk\build_tools\share

2. OpenOCD
Version: 0.10.0
Binaries Location: <Propel Installation Location>\sdk\openocd\bin

Documents Location: <Propel Installation Location>\sdk\openocd\doc

3. GNU RISC-V Embedded GCC
Version: 10.2.0-1.2
Binaries Location: <Propel Installation Location>\sdk\riscv-none-embed-gcc\bin

Documents Location: <Propel Installation Location>\sdk\riscv-none-embed-gcc\share\doc

4. Picolibc
Version: 1.7.4

Binaries Location: <Propel Installation Location>\sdk\riscv-none-embed-gcc\riscv-none-embed\picolibc\riscv-none-
embed\lib

Documents Location: <Propel Installation Location>\sdk\riscv-none-embed-gcc\doc

5. SRecord
Version: 1.6.4
Binaries Location: <Propel Installation Location>\sdk\tools\bin

Documents Location: <Propel Installation Location>\sdk\tools\bin

6. QEMU RISC-V
Version: 7.2.5
Binaries Location: <Propel Installation Location>\sdk\gemu-riscv\bin

Documents Location: <Propel Installation Location>\sdk\gemu-riscv\bin
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Appendix D. Command-line Environment Setting Script in Lattice
Propel SDK

Lattice Propel provides a script to set necessary environment variables for running all Propel SDK command line tools. It
enables you to fast get up to using command line tools, especially for Lattice specific tools.

To use the script:

1. Run the script propel_commandline.cmd (Windows) or propel_commandline.sh (Linux) under <Propel Installation
Location>.

The message Lattice Propel Commandline is printed, and it lets you go to a new command line interface.

2. All command line tools in the Propel SDK can be run from this command line interface without any special
configuration.

Here are examples of using the command line tools within this script.
Example A: Build a C project under command line.

$ cd <C project Location>/Debug
$ make

Example B: Launching openocd under command line.

$ cd <C project Location>

$ openocd -c "gdb_port 3333" -c "set target 0" -c "set tck 1" -c "set port
FTUSB-0" -c "set RISCV_SMALL_YAML src/cpu.yaml” -f interface/lattice-cable.cfg
-f target/riscv-small.cfg
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Appendix E. Debugging with Attach to Running Target

The Attach to running target function means to do on-chip debugging on a running board, without resetting CPU and
reloading the .elf file to the board.

This function is particularly useful when debugging a system whose CPU runs software from preloaded memory.

The debugger is used to check CPU registers for narrowing down software problems.

Setting Memory Initialization to SoC Project
1. Open the corresponding SoC Project of the debugging C project.

2. Set Memory Initialization file (Figure E.1). Use the C project memory file. Refer to Appendix A on how to create
memory files.

Re-generate the programing file by running Lattice Radiant software in this SoC Project.
Program the programing file into the target device board.

5. The board can now run itself after power on. Keep it running.

4, Module/IP Block Wizard x

Configure Component from Module localbus_tcm Version 1.4.0
Set the following parameters to configure this component.

Diagram tcmd Configure IP
General Port 50 Settings Port 51 Settings
Property Value
~ General
Enable GSR. =
Memory Type EER
tcmO
ECC Enable
—OCAL BUS DATA Access Type for Part 50 RAW
- - MAccess Type for Port 51 RAW
—(4-LOCAL BUS_INSTR ATOMIC =
”( ~ FIFO_Streamer
| SYS_C Enable FIFO Streamer
—sys_rst_n
* Memory
Iocalbus_tcm Memaory Initialization Mernory File
Memory File =
Memary File Format hex
4 3
Document Mo DRC issues are found.

Generate Cancel

Figure E.1. Set Memory Initialization

Attach to Running Target
1. Select the corresponding C project. Go to the Debug Configurations page.
2. Select Startup tab. Check Attach to running target checkbox (Figure E.2), Click Apply. Click Debug.
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Q Debug Configurations

Create, manage, and run configurations

CReERX B Y-

MName: | riscv_rtos_freertos_pmp_blinky

| type filter text

v [C] GDB Open0CD Debugging
[€] riscv_rtos_freertos_pmp_blinky
> [£] GDB QEMU Debugging
L Launch Group

Filter matched 5 of 11 items

Main CableConn | %5 Debugger] = StartuplEE/ Source| [C] Common | L, SVD Path
ing target —

Initial Reset. Type: init

Enable Arm semihosting

Load Symbols and Executable
Load symbols
(®) Use project binary: riscv_rtos_freertos_pmp_blinky.elf

) Use file: Workspace... File Syster...

Symbols offset (hex): l:l

Load executable

Use project binary:  riscv_rtos_freertos_pmp_blinky.elf

Use file: Workspace... File Systern...

Executable offset (hex):

Runtime Ontinne

Revert Apply

@

3. Wait for a few seconds for switching to the debug perspective, as shown in Figure E.3. Click View Disassembly to

Figure E.2. Debug Configurations Page

display assembly code or C code.

Note: The C project should correspond to the memory file in the running board. If you modify the code, the C project
should be re-built and you need to go through steps in Set Memory Initialization to SoC Project again. If the memory

file in the running board does not correspond to the C project, it causes misalignment in running line and symbol table

and you get error information.
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®x|i» 3
w [E] riscv_rtos_freertos_pmp_blinky [GDE OpenQ
w [ riscv_rtos_freertos_pmp_blinky.elf

~ f# Thread 1 (Suspended : User Request)
Ohedc22
prvidleTask() at tasks.c:3,487 (x3cet
00
5 openccd.exe
5 riscv-none-embed-gdb

: workspace - Source not found. - Lattice Propel — O *
File Edit Mavigate Search Project Run LatticeTools Window Help
BrHR @il IA(S0ReRH -0 Q-id-iH~-F- 0G0
Q E|GH
Hs Debug % {5 Project Explorer} = B ||} Lattice Platfor (@ Orede22 [£] main.c 1 [€] main.c 1 = 8 [[x=v X\ % BT g2 D} e = g

Break at address "0x4c22" with no debug information available, or outside of
program code.

View Disassembly... |
Configure when this editor is shown

MName

()= xFreeHeapSpace
(9= xMinimurnEverF

8By et 8

Type
volatile size_t
reeHea volatile size_t

i1 Registers (L_': Problems (0 Executables (ﬁ Debugger Co (n Memory (E Console = gproﬂ o

Terminaq = B8

riscv_rtos_freertos_pmp_blinky [GDB OpenOCD Debugging]

X% BEERSEE 285

(66) fflags (/32)
(67) frm (/32)

(68) fesr (/32)
(69) uie (/32)

(7@) utvec (/32)
(129) uscratch (/32)
(13@) uepc (/32)
(131} ucause (/32)
(132) utval (/32)
(133) uip (/32)
(833) mstatus (/32)
(834) misa (/32)
(835) medeleg (/32)
£

Figure E.3. Debug Perspective
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Switching Back to Default Mode

If checking and unchecking the Attach to running target function several times, the configuration might become
incorrect. The suggested operation is to click Restore default (Figure E.4).

7% Debug Configuratiens m| *

Create, manage, and run configurations

|_| Ells) 0 [ xl = '\l? M MName: |riscv_rtos_freertos_pmp_blirllcy
|t)‘FlEfi|tEf text | Main | CableConn |3§§~ Debugger[ib Stanup] B Source| i=| Common| T, SVD Path
w [E£] GDB Open0CD Debugging ol

. P bii Load Symbols and Executable
|E| IFW_ﬂOS_ reertos_pmp_blinky Load symbols
[] riscv_rtos_gprof

w [E] GDE QEMU Debugging (®) Use project binary:  risev_rtos_freertos_pmp_blinky.elf
[E] spike_gemu_helloworld (O Use file: Workspace... File System...

Launch Group
® Symbolsoffset (hexl: | |

Load executable
(®) Use project binary:  riscv_rtos_freertos_pmp_blinky.elf

(O Use file: Workspace... File System...

Executable offset (hex): I:I

Runtime Options
[]Debug in RAM

Run/Restart Commands
Pre-run/Restart reset Type: (always executed at Restart)

[ 5et program counter at (hex):

Continue

Restore defaultsf

Revert Apply

Filter matched & of 12 items

)

Close

Figure E.4. Restore Defaults
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Technical Support Assistance

Submit a technical support case through www.latticesemi.com/techsupport.

For frequently asked questions, refer to the Lattice Answer Database at
www.latticesemi.com/Support/AnswerDatabase.
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