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Type Conventions Used in This Document

Convention Meaning or Use

Bold

<ltalic>
Ctri+L

Courier

Items in the user interface that you select or click. Text that you type
into the user interface.

Variables in commands, code syntax, and path names.

Press the two keys at the same time.

Code examples. Messages, reports, and prompts from the software.
Omitted material in a line of code.

Omitted lines in code and report examples.

Optional items in syntax descriptions. In bus specifications, the
brackets are required.

Grouped items in syntax descriptions.
Repeatable items in syntax descriptions.

A choice between items in syntax descriptions.
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Lattice Radiant Block-Based
Design Tutorial

The Block-Based Design (Macro) tool is used to create design blocks from
implemented module of a device family. This tutorial leads you through all the
basic steps of creating, reusing, and exporting a macro block.

A macro block is a portion of an FPGA design that can be preserved for reuse
afterwards. Some of the benefits of implementing macros in a design include
the ability to reuse blocks in other designs and the ability to design more
effectively as a team.

About the Tutorial

When you have completed this tutorial, you should be able to do the following:
Macro Creation
Create a Macro for your design.

Use Physical Designer to set placement and routing physical
constraints (optional).

Export Macro using three preservation levels:

Logical (Logic Macro)

Logical & Physical with Place Info (Firm Macro)

Logic & Physical with Placement & Routing Info (Hard Macro)
View macro .ipm package:

<macro_name>.mac

<macro_name>_bb.v

<macro_name>_bb_extra.v

<macro_name>_sim.vo
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About the Tutorial

<macro_name>.mdb
Macro Reuse

Import macro (.ipm) package as a design source into existing or new
project for reuse.

Loaded macro content into the design:
Logic Macro will be included in the post-synthesis netlist.
Firm/Physical Macro will be included in the post-MAP netlist.
Run Place & Route to recognize macro physical constraint if it is in the
macro package.
Time to Complete

About 45 minutes.

System Requirements

The Lattice Radiant software is required to complete the tutorial.

About the Tutorial Data Flow

The following figures illustrate the tutorial data flow of macro creation and
reuse.
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About the Tutorial

Macro Creation

Foundation/

Create Design New Project Openexisting | srverp
Import Source project Macro

Pre-Synthesis Constraint Editor

Synplify Pro (Design Netlist)

S — GuI

Entry
Create Logical ] Design Netlist

Macro

Synthesis  [—— MAP — PAR

Physical
Designer
Macro Region

Create
Physical —
Macro

Export Macro —

This diagram shows the steps for the macro creation process. First, a design
is made using a new or existing project. Then, a logical macro is created in
the Pre-Synthesis Constraint Editor, where the macro is defined. Once
changes are made in the Pre-Synthesis Constraint Editor, the defined macro
is saved in a.sdc file containing the Idc_create_macro constraint.

The next step is creating a macro region in Physical Designer (optional).
When you save your changes in Physical Designer, a .pdc file will be
generated containing the Idc_create_region constraint.

The next stage is exporting the macro using Logic, Firm, and Hard
preservation levels after macro has been defined. The macro package
generated by this export contains a number of files, including.mac, bb.v,
bb_extra.v, sim.vo, and.mdb files. These files provide the information you
need to use the macro and incorporate it into other designs or projects.
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Task 1: Create a New Macro Project

Macro Reuse

mac,
bb.y, bb_extra.y, si
m.vo, .mdb

S —
Macro .ipm files

. Existing
New Project Project
Synthesis —> MAP —>} PAR

Logical & Physical Logic & Physical with
with Place Info (Firm Placement & Routing
Macro) Info (Hard Macro)

Logical (Logic
Macro)

Logic, Firm, Hard Macro designs

Region with/without are merged into user design

Buffer constraint (if
pdc) exists

A,
— ——
Logic & Physical with
Logical (Logic SR Placement & Routing
Macro) Info (Hard Macro)

Place & Route with Place & Route with Place & Route with
Region Constraint Placement Constraint Placement & Routing
Constraint

This diagram shows the steps for the macro reuse process. First, the macro
.ipm files are imported and the content is loaded into the design. The Post-
synthesis Logic Macro is merged into the design, ensuring that the macro
constraint is honored. A region with or without a buffer constraint can be
specified if the .pdc file exists.

In Map Design, Firm Macro is merged into the design, incorporating the post-
MAP macro design with a placement constraint. Hard Macro is also integrated
into the design with both placement & route constraints.

In Place & Route Design stage, the Logic Macro undergoes place & route with
a region constraint, while the Firm Macro goes through place & route with a
placement constraint. Finally, the Hard Macro goes through place & route with
both placement and routing constraints.

Task 1: Create a New Macro Project
We will start by launching the Radiant software.
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Task 1: Create a New Macro Project

Opening the Project

To create a macro instance using a new project:
1. In the Radiant software, choose File > New Project.

If you have an existing project, steps 1 through 4 are optional. You can
proceed to step 5.

2. In the Add Source dialog box, click Add Source...

3. Browse to: <Radiant_install_path>/docs/tutorial/block_based_tutorial/
macro_create and select the top.v file.

Click Next.

4. In the Select Device dialog box, select a device family and choose the
options that you want for that device.

The iCE40UP device is not supported.
Click Next.
5. In the Select Synthesis Tool dialog box, choose Synplify Pro.

Note:

The Lattice Synthesis Engine (LSE) tool is currently not available for macro creation.

6. Click Tools > Pre-Synthesis Constraint Editor.

Synthesize Design runs when you open the Pre-Synthesis Constraint
Editor tool.

7. Click the - button in the Object Clock column to add clock constraints
(optional).

If clock constraints are added, the create_clock constraint will be shown
in the command line.

{2} Start Page Reports @1 Pre-Synthesis Constraint Editor *
Disable Object Clock Clock Name Waveform (ns) Period (ns) Frequency (MHz)
get_ports clk clk 7.000 142.857

Clock Generated Clock Cock Latency dock Uncertainty Clock Group Inputy/Qutput Delay Timing Exception

All Constraints (Using drag and drop to reorder the constraints)

| create_clock -name {clk} -period 7 [get_ports clk] |

8. In Pre-Synthesis Constraint Editor, click the Macro tab.

a. Click the - button in the Instance column to add shift registers.
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Task 1: Create a New Macro Project

@ Object Edit ? X
Object Type: INSTANCE ~ Hierarchical

Available Objects

ishift1
shift2
shift3
shiftd

Object Command

get_cells shift1

OK Cancel

In the example above, shift1, shift2, shift3, and shift4 are Instance
Names. The command is get_cells as shown in the Object Command
pane.

b. In the Macro Name column, the name is automatically set for the
macro instance.

You can also edit the name by double-clicking a cell under the Macro
Name column.

c. Inthe Use PIO column, you can select the ports of the module to
include the device pins inside the macro (optional).

d. In the Disable column, you can click on the checkbox if you do not
want to use the macro.

oY Start Page Reporis '@' Pre-Synthesis Constraint Editor *
Disable Instance Macro Name Use PIO
get_cells shift1 shift1_macro
get_cells shift2 shift2_macro
get_cells shift3 shift3_macro
get_cells shiftd shiftd_macro

e. Click File > Save or the Save [=] icon.

The defined macro will be saved as a synthesis constraint (.sdc) file.
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Task 2: Set Macro Region

You can also directly add Idc_create_macro constraint to the .sdc
file.

Note:

The default hierarchy separator for Synplify Pro is a “.” (period), while Radiant tools
use “/” (forward slash). If you create a sub-module under more than two hierarchy
levels, you need to manually add the set_hierarchy_separator {/} line or change the

“»

separator from “/” to “.” in the .sdc file.

9. Run Synthesize Design.

Task 2: Set Macro Region
After running Synthesize Design, you can set a macro region in Physical
Designer (optional).
To create a Macro Region in Physical Designer:
1. Open Physical Designer.

2. Right-click on the floorplan layout and select the Create MACRO
REGION... option.

The mouse pointer changes from an arrow to a cross symbol.
3. Draw a rectangle around the sites where you want to place the macro.
Create New MACRO REGION... dialog box opens.

Go to Location...

| Create MACROREGION... |
Create REGION.

Create GROUP BBox...
PROHIBIT Site
Edit Color...

4. In the Create New MACRO REGION dialog box:
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Task 2: Set Macro Region

|:| Create New MACRO REGION X
Macro Region Name: | Color:
LUTs: 2880 REGs: 2880 EBRS: 7
Row: (2 - 54) Column: {2 - 85)
Anchor: 7 26
Height: (1 - 48) Width: (1 - 60)
BBox: 20 20
Macro: shiftl -
Left : (0 -25) Right : (0 - 60)
Buffer Size: 1] 0
Top: (0-6) Bottom : (0 - 48)
1] 0
oK Cancel

a. Enter the Macro Region Name (mandatory).

Below the Macro Region Name field, the macro resource is displayed
as a guide for the BBox size (LUTs, REGs, and EBRs).

D Create New MACRO REGION X
Macro Region Name: | Color:
LUTs: 2880 REGs: 2880 EBRS: 7

To get an idea of what the minimum macro region size should be, you
can check the logic resource usage in the MAP Report (.mrp) file.

Calculating the region resources to compare macro resource usage is
different for each device family.

For example:

One PFU has 4 SLICEs (=8 LUTs + 8 REGs) for most devices, but 6
SLICEs (=12 LUTs + 12 REGs) per PFU for Avant.

You may also want to check non-SLICE type resource usage (e.qg.,
EBR and DSP). These two blocks only appear at one out of multiple
rows, and the resources covered by region also depend on the anchor
location.

b. Enter your desired values for the Anchor and BBox fields.
You must enter a value within range.

c. Inthe Macro dropdown menu, you can select the predefined macro
instance from the pre-synthesis macro creation.

d. Enter your desired value for the Buffer Size field (optional).
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Task 2: Set Macro Region

Buffer Size gives PAR an extra room to do the routing. The routing is
confined within the macro region plus its surrounding ring. The top,
bottom, right, and left buffer size could be set differently.

Note:

The current buffer cannot be used to place and route other logic during
“reuse” if you select the “Exclusive” option.

The Buffer Size range is device density dependent. You must enter a
value within the range.

e. Click the Color option to change the color of the macro region

(optional).

&

Macro Region Name: |~ mregionl

LUTs: 1536 REGs: 1536

Row: (2 - 54)
Anchor: 9
Height: (1 - 46)

BBox: 14

Macro: shif2

Left : (0-22)

¢ | [E] select Color X

olor:

EBRS: 5

Column: (2 - 85)
23
Width: (1- 63)

16

Right : (0 - 63)

Basic colors

HEEEEENC
NN
NN
(O ]
EEEEEEN ]
(N I [

Pick Screen Color

o 208

Red: | 165
‘Custom colors

Sat: 90 Green: | 213

gl Co— SEemmnEnl RICEEE
Top: (0-8) Bottom : (0 - 46)
0 o Add to Custom Colors HTML:  #asdsff
oK Cancel o canee
5. Click OK.

6. Click the Save [ icon in Physical Designer.

The created macro regions are saved into a post-synthesis constraint
(.pdc) file.

The .pdc file contains the following information:
Idc_create_region — defines the placement region.

buffer_left/-buffer_right/-buffer_top/-buffer_bottom (optional) —
defines routing region.

right 1 -buffer top 1 -buffer botta:

ith 13 -height 13 —buffer left 1 -buffer_right 1 -buffer top 1

th 13 -height 13 -buffer left 1 -buffer right 1 -buffer to)

7. Run Map Design

8. Click the Reports tab and expand Map Reports in the Project Summary
pane.
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Task 3: Run PAR to Complete Macro Creation

{or Start Page Reports ng Pre-Synthesis Constraint Editor |_| Physical Designer

Reports Map

Project Summary

¥ [ Synthesis Reports

~ || Map Reports

I_'Ih

* Map Resource Usage

Map Timing Analysis

*» [ Place & Route Reports

» [} Export Reports

This section lists the macros you have created and the total number of
resources used.

Task 3: Run PAR to Complete Macro Creation

After creating a macro region in the current project, run Place & Route
Design.
If you want to import an existing .pdc file, do the following:
1. In File List view, right-click on Post-Synthesis Constraints Files folder.
2. Click Add > Existing File.

Browse to where your existing .pdc file is located and click Add.

3. Run Place & Route Design.

Task U: Export Macro

1. Choose Tools > Export Macro
The Export Macro dialog box opens.

The macro data can be exported according to a specified preservation
level. You can also lower the preservation level of an exported macro after
importing it to a design.

Logical (Logic Macro)

After running Synthesize Design and Map Design, you can only
export to Logical preservation level.

Logical & Physical with Place Info (Firm Macro)
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Task 4: Export Macro

For Firm Macro, you can only export to Logical and Logical &
Physical with Place Info preservation levels after running Place
& Route Design.

Logic & Physical with Placement & Routing Info (Hard Macro)

After running Place & Route Design, you can export to Logical,
Logical & Physical with Place Info, and Logic & Physical with
Placement & Routing Info preservation levels.

Export Macro X
Macro Preservation Level
prrrsrmmms| | (@) Logical
& ishift2_macro Dgl(a‘ N T :
Logical & Physical with Place Info
4t shift3_macro

Logical & Physical with Route Info
T shift4_macro

Macre Name: Vendor: Lattice Version: 1.0
Support Radiant from Version: = 2023.2 to  undefined

Testbench File:

Document File:

Qther Files:

Export to: ro_Create3/create_sample/impl_1/shift2_macro_1_0.ipm

Export Close

You can also see the following fields in the Export Macro dialog box:

Macro Name — displays the name of the selected macro from the
Macro column in the left-hand pane.

Vendor — displays the vendor name.
Version — displays the Macro IP version, the default is always 1.0.

Support Radiant from Version to Version — displays the supported
maximum and minimum Radiant version. The maximum version could
be empty, but the minimum is the same as the current Radiant
version.

Testbench File — contains testbenches that allow you to do simulation
or evaluate the macro.

Document File — contains any document such as help, user guide, or
introduction file included in the macro.

Other Files — additional files to be exported with the macro.
Export to — default path where the macro package will be saved.
2. Choose the preservation level for each instance then click Export.
The exported Macros are saved as .ipm package files.
The macro .ipm package contains the following:

<macro_name>_.mac — contains general information of the macro
project.

<macro_name>_bb.v — synthesis header file of the macro project. It
is exported to define module interface for synthesis.

<macro_name>_bb_extra.v — synthesis header file exported with
additional information.
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Task 5: Reusing an Exported Macro

<macro_name>_sim.vo — exported for macro simulation. The file is
generated based on logic macro.

<macro_name>.mdb — exported Macro in unified constraints
database (.udb) format. Modules representing macros will be
extracted from design and exported to .mdb files. The macro will be
the top module in .mdb file. The name specified in Idc_create_macro
constraint will be used as the name of the top module.

Task 5: Reusing an Exported Macro

To add a Macro Block file in a new project:
1. In the Radiant software, choose File > New Project.

If you have an existing project, steps 1 through 4 are optional. You can
proceed to step 5.

2. In the Add Source dialog box, click Add Source...

a. Add the following files from the <Radiant_install_path>/docs/tutorial/
block_based_tutorial/macro_reuse directory.

top.v
macro_reuse.sdc
b. Click Next.
3. In the Select Device dialog box, select the following options:
Family: CrossLink-NX (LIFCL)
Device: LIFCL-40

Since LIFCL-40 was used to create the.ipm files in this example, it is
recommended to use this device. In this case, other devices will not work.

Click Next.
4. Select Synplify Pro as the synthesis tool.

Note:

Currently, the Lattice Synthesis Engine (LSE) tool is not available for macro reuse.

5. In the File List view, right-click Input Files.
6. Click Add > Existing File.

In the Add Existing File dialog box, browse to: <Radiant_install_path>/
docs/tutorial/block_based_tutorial/macro_reuse/impl_1

7. Select the following .ipm files:
shiftreg1_1_0.ipm
shiftreg2_1_0.ipm
shiftreg3_1_0.ipm
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Task 5: Reusing an Exported Macro

Click Add.

8. Enable the Copy file to directory check box, then click Add.

You can see the imported .ipm files in the Input Files folder.

= [ impl_1 (Synplify Pro)

-

iy source/impl_1/top.v

shiftreg1_bb.v

shiftreg2_bb.v

shiftreg3_bb.v

= |y source/impl_1/shiftreg1_1_0.ipm

= |y source/impl_1/shiftreg2_1_0.ipm

* |y source/impl_1/shiftreg3_1_0.ipm

9. Run Synthesize Design.

The post-synthesis Logic Macro is merged into your design.

It has <macro_name>_bb.v as the input. The logic synthesis tool treats
every module that matches <macro_name>_bb.v as a black box.

10. In the File List View, you can check the Project Properties by right-
clicking the selected .ipm file to see or change their value.

You can lower the preservation level value of the imported .ipm files.

If the imported macro’s preservation level is Firm Macro, you can
lower it to Logic Macro.

If the imported macro’s preservation level is Hard Macro, you can
lower it to Logic and Firm Macro.

Project Properties

~ [ macro_reuse
10 LIFCL-40-9BG400C
- 2 implL1

source/impl_1/top.v

1
source/impl_1/shiftreg1_1_0.ipm
source/impl_1/shiftreg2_1_0.ipm
1
1

source/impl_1/shiftreg3_1_0.ipm

source/impl_1/macro_jedi.sdc
= Area
= | Timing
24| Strategy1

Name: | shiftreg3_1_0.ipm Category: ~ Resource

Location:

Name Value

Preservation Level Logic, Placement & Routing

Include for Synthesis and Simulation

Cancel

11. Run Map Design.

For Firm Macro, the post-MAP macro design with placement constraint is

merged into your design.

For Hard Macro, the post-MAP macro design with placement and route

constraint is merged into your design.

Lattice Radiant Block-Based Design Tutorial
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Task 5: Reusing an Exported Macro

Open Physical Designer, the netlist shows the reused macro instances.
They contain information of the original region from the create stage.

2 Start Page Reports Physical Designer
X || Qv Find Tex:
» £F Instances: 2010
Ir ¥ Macro Instances
- [ Physical: 1002
~ IF shift2: R22C20((13, 13)ILEFT:1 RI
% tmp_reg[0]SLICE_2000: R22C20)
Ik tmp_reg[2]SLICE_2002: R22C20)
% tmp_reg[4]SLICE_2004: R22C20)
% tmp_reg[6]SLICE_2006: R22C20)
% tmp_reg[8]SLICE_2008: R22C20)
o % tmp_reg[10].SLICE_2010: R22C2)
= IF tmp_reg[12].SLICE_2012: R22C2)
[14]
[
[

1)

n

!
F] I tmp_reg[141SLICE_2014: R22C2

I tmp_reg[16]SLICE_2016: R22C2
@ I tmp_reg[18] SLICE_2018: R22C2
I tmp_reg[20].SLICE_2020: R22C2
B 1% tmp reql221SIICE 2022 R; (}v

1
1
1
1
1

12. Click the Reports tab and expand Map Reports in the Project Summary

pane.
{2} Start Page Reports
Reports Map
) Net wlZ: 1 loads
BiojecESLmmary Net w23: 1 loads
Net w34: 1 loads
Number of Physical Macro Instances: 2

4 Synthesis Reports < hift3
nstance: snirtc

Macro Name: shiftreg3
~ ['] Map Reports Device: LIFCL-40
Preservation: HARD

Anchor: R39C44
REG: 1000
Instance: shift2

Macro Name: shiftreg2
o T [REseinee Wt Device: LIFCL-40

Preservation: FIRM
H 22C20
Map Timing Analysis Affhor' R2ac20

REG: 1000

» [ Place & Route Reports Number of warnings: 0

Number of errors: 0

The Design Summary section of Map Report displays the following
information:

Total number of reused Firm and Hard macros in the design.
Device, preservation level, anchor, and main resources.

13. You can create a macro region with the Exclusive option in Physical
Designer.

In Physical Designer netlist, right-click on a macro instance under
the Physical folder.

Select the Reuse macro region... option.
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Task 5: Reusing an Exported Macro

{1} Start Page Reports Physical Designer
[ Q. ~ Find Te...
» { Instances: 2010
¥ { ¥ Macro Instances
@ ) = Logical: 1003
Ed = Physical: 1002

AATV1D 1

 shift2: R2p¢__ GO to parent

» 1E 10s

Reuse macro region...

The Reuse Macro Region dialog box opens.

You can only enable the Exclusive option. The text boxes are not

editable.
[Z] Reuse MACRO REGION *
Macro Region Name:  mregion3 Color:
LUTs: 1248 REGs: 1248 EBRS: 4
Row: (0 - 56) Column: (0 - 87)
Anchor: = 39 44
Height: (1 - 18) Width: (1 - 44)
BBox: 13 13
B exclusive
Macro: shift3 -
Left : (0 - 43) Right : (0 - 30)
Buffer Size: 1 1
Top : (0 -38) Bottom : (0 - 4)
1 1
Any hard macro cannot move.(Macro: shift3)
[8]4 Cancel

In the Reuse Macro Region dialog box, do the following:
Enter the Macro Region Name.

Click the Exclusive checkbox and select OK.

Click the Save [H] icon in Physical Designer.

The created macro regions are saved into a post-synthesis constraint
(.pdc) file.

If the Exclusive checkbox is enabled, the -exclusive option is added
to the Idc_create_region command line in the .pdc file.
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Summary of Accomplishments

3 start page Reports Physical Designer 3 sample.pdc

b

14. Run Place & Route Design.

Open Physical Designer and select Routing Mode to see the macro
instances in the physical netlist.

Reports Physical Designer

Summary of Accomplishments

You have completed the Lattice Radiant Block-Based Design Tutorial . In this
tutorial, you have learned how to:

Create a macro block in Pre-Synthesis Constraint Editor.
Create a macro region in Physical Designer
Export Macro using three preservation levels
Logical (Logic Macro)
Logical & Physical with Place Info (Firm Macro)
Logic & Physical with Placement & Routing Info (Hard Macro)

View the macro IPM package content
Import existing .ipm files for macro reuse.

Change the preservation level value of .ipm files.

Recommended References

You can find additional information on the subjects covered by this tutorial in
the Radiant Help:

Entering the Design > Block-Based Design - Using Macro Blocks >
Creating a Macro Block
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Recommended References

Entering the Design > Block-Based Design - Using Macro Blocks >
Creating a Macro Region

Entering the Design > Block-Based Design - Using Macro Blocks >
Reusing a Macro Block

Entering the Design > Block-Based Design - Using Macro Blocks >
Exporting Macro

Entering the Design > Block-Based Design - Using Macro Blocks > Macro
Usage Guidelines
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Revision History

The following table gives the revision history for this document.

Date Version Description

11/20/2023 2023.2  Updated to reflect changes in Radiant 2023.2.

6/22/2023 20231 Initial release.
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