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Type Conventions Used in This Document

Convention Meaning or Use

Bold

<ltalic>
Ctri+L

Courier

Items in the user interface that you select or click. Text that you type
into the user interface.

Variables in commands, code syntax, and path names.

Press the two keys at the same time.

Code examples. Messages, reports, and prompts from the software.
Omitted material in a line of code.

Omitted lines in code and report examples.

Optional items in syntax descriptions. In bus specifications, the
brackets are required.

Grouped items in syntax descriptions.
Repeatable items in syntax descriptions.

A choice between items in syntax descriptions.
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Lattice Diamo

Chapterl

Introduction

This user guide describes the main features, usage, and key concepts of the
Lattice Diamond® design environment. It should be used in conjunction with
the Release Notes and online help included with the product software. The
Release Notes document is also available on the Lattice Web site and
provides a list of supported devices.

nd Overview

Lattice Diamond uses an expanded project-based design flow and integrated
tool views so that design alternatives and what-if scenarios can easily be
created and analyzed. The Implementations and Strategies concepts provide
a convenient way to try alternate design structures and manage multiple tool
settings.

System-level information—including process flow, hierarchy, and file lists—is
available, along with integrated HDL code checking and consolidated
reporting features.

A fast Timing Analysis loop, ECO Editor, and Programmer provide capabilities
in the integrated framework. The cross-probing feature and the shared
memory architecture ensure fast performance and better memory utilization.

Lattice Diamond is highly customizable and provides Tcl scripting capabilities
from its built-in console or from an external shell.
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INTRODUCTION : User Guide Organization

User Guide Organization

This user guide contains all the basic information for using the Lattice
Diamond software. It is organized in a logical sequence from introductory
material, through operational descriptions, to advanced topics.

Key concepts and work flows are explained in “Design Environment
Fundamentals” on page 22 and “Lattice Diamond Design Flow” on page 64.

Basic operation of the design environment is described in “User Interface
Operation” on page 29.

Other parts of the book provide greater detail and practical usage information.
The chapter “Working with Projects” on page 49 shows how to set up project
implementations and strategies. “Working with Tools and Views” on page 79
describes the many tool views available.
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Getting Started

This chapter explains how to run Lattice Diamond and open or create a
project. It includes instructions for importing a project from ispLEVER and
explains key differences between Lattice Diamond and ispLEVER.

For more information about project fundamentals, see the chapters “Design
Environment Fundamentals” on page 22 and “Working with Projects” on
page 49.

Prerequisites

You should have already installed the Lattice Diamond software and product
license. See the Lattice Diamond Installation Notice for complete information
on product installation.

Running Lattice Diamond

To run Lattice Diamond, select Lattice Diamond from the installation location.
This opens the default Start Page.

Lattice Diamond 3.13 User Guide 10



GETTING STARTED : Running Lattice Diamond

Figure 1: Default Start Page
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Note

If you are using Windows 7, you can use the “pin” command from the Start menu to
place a Lattice Diamond shortcut on the Start menu or the Taskbar.

Do not use the “pin” command that is available from the Taskbar while Diamond is
running. If you do so, the shortcut will fail when you try to use it to launch Diamond.
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GETTING STARTED : Creating a New Project

Creating a New Project

The New Project wizard steps you through the process of creating a new
project, allowing you to name the project and its implementation, add source
files, and select a target device.

You can open the New Project Wizard using one of the following
methods:

On the Start Page, select New in the Project pane.
From the File menu, choose New > Project.
Several example project design files are included in Lattice Diamond. The

following example procedure shows how to create a new project using the
“mixedcounter” example.

On the Start Page, select Project > New.

Figure 2: Create a New Project

* Mew Project 7=
Create a Lattice Diamond Project

This wizard will guide you through the creation of a new project.

To create a Lattice Diamond project you will need to provide a
name and location for your project. Mext you will import source
files. You may adjust implementation options. Finally you will
process the source files to produce a programming file for a
specific FPGA device.

To continue, dick Next.

< Back MNext = ] | Cancel

Click Next to open the Project Name dialog box.

Click Browse to open the Browse for Folder dialog box. Navigate to the
Lattice Diamond examples directory and select the mixed_mode folder, as
shown:

Lattice Diamond 3.13 User Guide
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GETTING STARTED Creating a New Project

Figure 3: Project Name

r
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Figure 4: Project Browser
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GETTING STARTED : Creating a New Project

Enter a Project Name: Test.

Enter an Implementation Name: Test.

Figure 5: Enter Project and Implementation Name

» New Project M

Project Name Y
Enter a name for your project and specify a directory where the project >
data files will be stored.

Project:

Name: Test

Location:  C:/lscc/diamond/3.0/examples/mixed_mode hd

Implementation:
MName: Test

Location:  C:/lscc/diamond/3.0/examples/mixed_mode,/Test

[ <gack |[ nmet> |[ cancel

Click Next to open the Add Source dialog box.

Figure 6: Add Source

* Mew Project 7 ==
Add Source
Add HDL, EDIF netlist, LPF constraints, or other files. &
Source files: Add Source...| |Remove Source

[ Copy source to implementation directory

< Back ][ MNext = ][ Cancel

From this dialog box, you can add Verilog or VHDL source files, EDIF netlist
files, LPF constraint files, schematic, debug and analysis files or any other
project files. Diamond takes the source files and places them into the correct
folders for the new project.
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GETTING STARTED : Creating a New Project

Click Add Source to open a file browser in the project example location.

Open the source folder, select all Verilog and VHD files, and click Open to
add the files to the project.

Figure 7: Source

s = |

* MNew Project L X
Add Source
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Source files: Add Source... | |Remove Source
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C:/lsce/diamond/3.0/examples/mixed_maode/source/count_down.v
C:/lsce/diamond/3.0/examples/mixed_mode/source/count_down_2.v
C:/lsce/diamond/3.0/examples/mixed_maode/source/count_down_3.vhd
C:/lsce/diamond/3.0/examples/mixed_maode/source/count_up.v
C:/lsce/diamond/3.0/examples/mixed_mode/source/count_up_2.v

Copy source to implementation directory

| <Back || med> |[ cancel |

This process of browsing and adding source files can be done as many times
as needed before going to the next step.

Notice the option to “Copy source to implementation directory.” Select this
option if you want to copy the external source files to the project’s initial
implementation. If you prefer to reference these files, clear this option. See
“Implementations” on page 51 for further details.
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GETTING STARTED : Creating a New Project

Click Next to select the device.

Figure 8: Select Device
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(-

In this step you can select the target device, performance grade, package
type, operating conditions and part name. For our example, we will use the
default settings.

Click Next to open the Select Synthesis Tool dialog box.

Select the synthesis tool that you want to use.

Lattice Synthesis Engine (LSE) a synthesis tool custom-built for Lattice
products and fully integrated with Diamond.
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GETTING STARTED : Creating a New Project

Figure 9: Select Synthesis Tool
f * New Project l 28— X]

Select Synthesis Tool 2
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Click Next to open the Project Information summary.

Figure 10: Project Summary
[ + New Project . m M1

Project Information
The new project will be generated with the following specifications. -

Project:

Project Name: Test

Project Location: C/flscc/diamond/3.0/examples/mixed_mode

Implementation Name: Test
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Synthesis Tool: Synplify Pro

Import Source Files:
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C:/lscc/diamond/3.0/examples/mixed_mode/source/count_down_2.v
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C:/lscc/diamond/3.0/examples/mixed_mode/source/count_up.v
C:/lscc/diamond/3.0/examples/mixed_mode/source/count_up_2.v

Copy Source Files: Yes

< Back l I Finish ] I Cancel
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GETTING STARTED : Opening an Existing Project

At this step or any other step in the process, you can click the Back button to
review or change your selections.

Click Finish. The newly created project, shown in Figure 11, is now created
and open.

Figure 11: Opened Project
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Select the File List tab under the left pane, to view the Test project file list.
Select the Process tab, to view the design flow processes and status.

To close a project, choose File > Close Project.

Opening an Existing Project
Use one of the following methods to open an existing Lattice Diamond project:
On the Start Page, select Open from the Project pane.
From the File menu, choose Open > Project.

On the Start Page, select the desired project from the Recent Projects list.
Alternatively, choose a recent project from the File > Recent Projects
menu.

You can use the Options dialog box to increase the number of projects that
are shown in the Recent Projects list and to automatically load the previous
project at startup. Choose Tools > Options to open the dialog box. To
increase the number of recent projects listed, select General from the

Lattice Diamond 3.13 User Guide 18




GETTING STARTED : Importing an ispLEVER Project

Environment section, and then enter a number for “Maximum items shown in
Recent items list.” To automatically open the previous project during startup,
select Startup from the Environment section, and then choose Open
Previous Project from the “At Lattice Diamond startup” menu.

Figure 12: Open Recent Project

-

Project:

@Open...
EENEW...

[ Import ispLEVER Project...

m

Recent Projects:

@ Test

@ mixedcounter
@ mixed_mode

4 1 3

Importing anispLEVER Project

Use one of the following methods to import an ispLEVER project into Lattice
Diamond:

On the Start Page select Import ispLEVER Project from the Project
pane.

From the File menu, choose Open > Import ispLEVER Project

Figure 13: Import an ispLEVER Project
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Project:
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Recent Projects:

@ Test

@ mixedcounter
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4 1 3

The file browser applies a *.syn file filter to help you find ispLEVER
project files. The ispLEVER project is converted to a Lattice Diamond
project.

The import/conversion process has the following limitations:

Any .ngo files will need to be manually copied into the Lattice Diamond
project if these files were originally copied into the ispLEVER project; for
example, .ngo files that were copied from Lattice IP generation.

All .Ipc files are replaced with .ipx files in Lattice Diamond. You will need to
re-generate your IP by double-clicking the .Ipc file name. The wizard will
then open and help you generate the new .ipx file, replacing the .Ipc file.
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GETTING STARTED : Next Steps

Next Steps

If you select the “Copy source to Implementation directory” option, the
following additional limitations will apply:

Verilog include files specified within the Verilog source files will not be
copied.

Files associated with IPexpress Module .Ipc files (such as .v, .txt, .ngo)
will not be copied.

User-specified schematic symbols (.sym) will not be copied.

After you have a project opened in Lattice Diamond, you can go sequentially
through the rest of this user guide to learn how to work with the entire design
environment, or you can go directly to any topics of interest.

The chapters “Design Environment Fundamentals” on page 22 and
“Lattice Diamond Design Flow” on page 64 provide explanations of key
concepts.

“User Interface Operation” on page 29 provides descriptions of the
functions and controls that are available in the Diamond environment.

The chapters “Working with Projects” on page 49 and “Working with Tools
and Views” on page 79 explain how to run processes and use the design
tools.

“Tcl Scripting” on page 132 provides an introduction to the scripting
capabilities available, plus command-line shell examples.

“Advanced Topics” on page 140 provides further details about
environment options, shared memory, and Tcl scripting.

Differences from ispLEVER

There are a number of differences between Lattice Diamond and ispLEVER.
Key differences, especially regarding how projects are managed, include the
following:

iSpLEVER has multiple project types, but there is only one Diamond
project type. In ispLEVER, you need different projects types for each type
of source; for example, one project for Verilog and a different project for
VHDL. In Lattice Diamond, the project can include sources of different
types. For example, one Lattice Diamond project can contain both Verilog
and VHDL source files.

Lattice Diamond includes implementations and strategies. These do not
exist in ispLEVER.

ispLEVER parses source file hierarchy when a project is opened, and it
will question the existence of multiple top-level modules. Lattice Diamond
does not display hierarchy by default (though it can be configured to do
s0), and you need to set the top-level design unit if multiple top-level
modules exist.

Lattice Diamond 3.13 User Guide
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GETTING STARTED : Differences from ispLEVER

ispLEVER consists of a number of separate tools. Lattice Diamond is an
integrated tool environment.

All of the Lattice Diamond tool views share a common memory image of
design data. This means that changes to the design data are seen by all
tools.

Lattice Diamond projects do not allow simulation testbenches as source.
Only modules are contained within a Lattice Diamond project.

Lattice Diamond 1.3 and later supports the ability to mark individual
source files for simulation, synthesis, or both. This supports multiple file
testbenches and modules with different representations for simulation and
synthesis. ispLEVER only supported a single testbench file for simulation
and did not support different representations for the same module.

Lattice Diamond 3.13 User Guide
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Overview

Chapter 3

Design Environment
Fundamentals

This chapter provides background and discussion on the technology and
methodology underlying the Lattice Diamond software design environment.
Important key concepts and terminology are defined.

Understanding some of the fundamental concepts behind the Lattice
Diamond framework technology will increase your proficiency with the tool
and allow you to quickly come up to speed on its use.

Lattice Diamond is a software design environment that uses a project-based
methodology. A single project can contain multiple implementations and
strategies to provide easily managed alternate design structures and tool
settings.

The process flow is managed at a system level with run management controls
and reporting. Context-sensitive views ensure that you only see the data that
is available for the current state in the process flow.

The shared memory technology enables many of the advanced functions in
Lattice Diamond. Easy cross-probing between tool views and faster process
loops are among the benefits.

Note

You can run multiple instances of Lattice Diamond, by loading Lattice Diamond
multiple times. This enables you to run different Diamond projects at the same time.
However, you must not load the same project in more than one Lattice Diamond
software instance, because this can cause conflicts in the software.

You can also run Diamond remotely. Refer to the Lattice Diamond Installation Notice
for more information.

Lattice Diamond 3.13 User Guide

22



DESIGN ENVIRONMENT FUNDAMENTALS : Project-Based Environ-

Project-Based Environment

A project in Lattice Diamond consists of HDL source files, EDIF netlist files,
synthesis constraint files, LPF constraint files, Reveal debug files, script files
for simulation, analysis files for power calculation and timing analysis, and
programming files.

It also includes settings for the targeted device and the different tools. The
project data is organized into implementations, which define the project
structural elements, and strategies, which are collections of tool settings.

The following File List shows the items in a sample project.

Figure 14: File List

File List g X

4 {[8 mixedcounter:
Il LFE2-35E-5F672C
4 Strategies
E¥ Area
E#® 1/O Assistant
E¥ Quick
¥ Timing
Strategyl
Strategy?
[ER verilog_vhdl
4 [EH verilog_vhdl_edif
4 Input Files
B3 edif/rev_1/count8.edn
¥ source/topcounty
i source/typepackage.vhd [work]
¥ source/countl6.vhd [work]
Synthesis Constraint Files
4 LPF Constraint Files
[ mixedcounter_vipf
[ mixedcounter_vv.Ipf
[ mixedcounter vve.lpf
4 Debug Files
R reveallrvl
Script Files
4 Analysis Files
P9 mixedcounter.pcf
T mixedcounter.tpf
Programming Files
[EH vhdl

File List | Process | Hierarchy |

Each item that is displayed in bold means that it has been selected as the
active item for an implementation. An implementation displayed in bold means
that it has been selected as the currently active implementation for the
project. Your project must have one active implementation, and the
implementation must have one active strategy. Optional items, such as
Reveal hardware debugger files, can be set as active or inactive. This differs
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DESIGN ENVIRONMENT FUNDAMENTALS : Process Flow

Process Flow

from ispLEVER, where the existence of Reveal debugger files means that
debug is active.

The project is the top-level organizational element in Lattice Diamond, and it
can contain multiple implementations and multiple strategies. This enables
you to try different design approaches within the same project. If you want to
have a Verilog version of your design, you will make an implementation that
consists of only the Verilog source files. If you want another version of the
design with primarily Verilog files but an EDIF netlist for one module, you will
create a new implementation using the Verilog and EDIF source files. It will be
the same project and design, but with a different set of modular blocks.

Similarly, if you want to try different implementation tool options, you can
create a new strategy with the new option values.

You manage these multiple implementations and strategies for your project by
setting them as active. There can only be one active implementation with its
one active strategy at a time.

The Process View provides a system-level overview of the FPGA design flow.
Each major step in the design process is shown, along with an icon that
indicates its status. In the Map and Place & Route sections, you can select
optional subtasks to be run every time. These selections are saved on a
project basis. In the Export Files section, you can select the models or files
that you want to be exported with the Export Files process. For example, if
Bitstream File is checked, it will be generated and exported; if it is not
checked, it will not be generated and exported.

Figure 15: Process Flow

Process |§|

4 % Synthesize Design
%L Synplify Pro
%L Translate Design
4 % Map Design
%L Map Trace
2 Verilog Simulation File
¥ VHDL Simulation File
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4 2 Export Files
& IBIS Model
2 Verilog Simulation File
& VHDL Simulation File

The process status icons are defined as follows:
+ Process in initial state
%L Process completed successfully

7y Process completed with warnings, see Warning output
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%% Process failed, see Error output

Right-clicking a process opens the controls for running, stopping, or cleaning
up that process. The Run command runs the selected process if it is not up-
to-date. The Rerun command forces a process to run again, even if it is up-to-
date. The Rerun All command forces all processes to run again. The Clean
Up Process command resets all processes and returns the status to the
original state. To refresh a process state, see “Refreshing a Process State” on
page 68.

Figure 16: Process Run Pop-up Menu

Run
Rerun
Rerun All

Stop

Clean Up Process

Shared Memory

Lattice Diamond uses a shared memory architecture. All tool and data views
are looking at the same design data at any point in time. This means that
when you change a data element in one view of your design, all other views
will see the change, whether they are active or not.

When project data has been changed but not yet saved, an asterisk (*) is
displayed in the title tab of the view.

Figure 17: Title Tab with Changed Memory Indication

I Spreadsheet View * D

Notice that the asterisks indicating changed data will appear in all views
referencing the changed data.

If a tool view becomes unavailable, the Lattice Diamond environment will
need to be closed and restarted.

Context-Sensitive Data Views

The data in shared memory reflects the state or context of the overall process
flow. This means that views such as Spreadsheet View will display only the
data that is currently available, depending on process steps that have been
completed.

For example, Figure 18 shows that the Process flow has been completed
through Map Design but not through Place & Route Design. Therefore,
Spreadsheet View shows no pin assignments.
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Figure 18: Process Completed Through Map Design
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After Place & Route Design has been completed, Spreadsheet View displays
the pin assignments.

Figure 19: Process Completed Through Place & Route Design
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When you see a “Loading Data” message, it means that a process has been
completed and that the shared memory is being updated with new data.

Figure 20: Loading Data
-

Loading data. Please wait...

All tool views are dynamically updated when new data becomes available.
This means that when you rerun an earlier process while a view is open and
displaying data, the view will remain open but dimmed because its data is no
longer available.
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Cross-Probing

Cross-probing is a feature found in most tool views. Cross-probing allows
common data elements to be viewed in multiple tool views.

To see how this works, select a pin or signal in one view and right-click it.
Select Show In to see a list of cross-probing views for the selected element.

Figure 21: Show In Pop-up Menu

Show In Package Yiew

Device View
Metlist Wiew
MNCD Wiew
Floarplan Yiew

Assign Pins...

For example, Figure 21 shows a tab group consisting of Floorplan View and
Physical View. A signal is selected in Physical View.

Figure 22: Physical View with Selected Signal
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When you right-click the selected signal in Physical View and choose Show
In > Floorplan View, the same selected signal is highlighted on the Floorplan
View layout, as shown in Figure 23.
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Figure 23: Selection in Floorplan and Physical Views
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@ Physical view [
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= LATTICE

Overview

Chapter U

User Interface Operation

This chapter describes the user interface features, controls, and basic
operations. Each major element of the interface is explained. The last section
in the chapter describes common user interface tasks.

The Diamond user interface (Ul) provides a comprehensive, integrated tool
environment. The Ul is very flexible and configurable, enabling you to store
layout preferences.
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Figure 24: Main Window

This chapter will take you through the operation of the main elements of the
Ul, but you should also explore the controls at your own pace. Figure 24
shows the Lattice Diamond main window in the default state.
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Menus and Toolbars

At the top of the main window is the menu and toolbar area. High-level
controls for accessing tools, managing files and projects, and controlling the
layout are contained here. All of the functionality in the toolbars is also
contained in the menus. The menus also have functions for system, project
and toolbar control.

Figure 25: Menu and Toolbar Area

File Edit View Project Design Process Tools Window Help

P-E-HaBin PERAQQAQEE EEE D
ECHECESGEEGREUSQASNBY MREEEHE @

The toolbars are organized into functional sets. The display of each toolbar is
controlled in the View > Toolbars menu and also by right-clicking in the Menu
and Toolbar area. Each toolbar can be repositioned by dragging and dropping
it to a new location.
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Project Views

In the middle of the main window on the left side is the Project View area. This
is where the overall project and process flow is displayed and controlled.

Figure 26: Project View Area
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Tabs at the bottom of the Project View allow you to select between the
following views:

File List — Shows the files in the project organized by implementations and
strategies. This is not a hierarchical listing of the design.

Process — Shows the overall process flow and status for each step.

Hierarchy — Hierarchical design representation.
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Tool View Area

In the middle of the main window on the right side is the Tool View area. This
is where the Start Page, Reports View and all the Tool views are displayed.

Figure 27: Tool View Area

Test

Design Summary
4 Project
# Project Summary
4 Process Reports
[3 Map
[ Place & Route
[ Signal/Pad
[ JEDEC
4 Analysis Reports
[% Map Trace
[ Place & Route Trace
[ I/O Timing Analysis
4 Tool Reports
# Hierarchy Parsing Re...
[ Run BKM Check
[ PIO DRC
[ TCL Command Log
4 Messages
[ All Messages
[ User Defined Filters

Module Name: Test Synthesis: SynplifyPro
Implementation Name: Test Strategy Name: Strategyl
Last Process: State:

Target Device: LFXP10C-5F256C Device Family: LatticeXP
Device Type: LFEP10C Package Type: FPBGL254H
Performance grade: 5 Operating conditions: COM

Logic preference file: Test.lpf

Physical Preference file: Test/Test_Test.prf

Product Version: 3.0.0.47 Patch Version:

Updated: 2013/06/13 11:05:30
Implementation Location: C:/flscc/diamond/3.0/examples/mixed mode/Test
Project File: C:/lscc/diamond/3.0/examples/mixed mode/Test.ldf

Multiple tools can be displayed at the same time. The Window toolbar
includes controls for grouping the tool views as well as integrating all tool
views back into the main window.

Each tool view is specific to its tool and can contain additional toolbars and
multiple panes or windows controlled by additional tabs. The chapter
“Working with Tools and Views” on page 79 provides more details about each
tool and view.

Output and Tcl Console

Near the bottom of the main window is the Output and Tcl Console area.

Tabs at the bottom of this area allow you to select between Tcl Console,
Output, Error, Warning, Find Results, and Info. Tool output is automatically
sent to the Output tab, and Errors and Warnings are automatically sent to their
respective tabs.
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Figure 28: Multiple Tools
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Figure 29: Output and Tcl Console Area
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Status Information

At the very bottom of the main window is status information. The information
shown depends on the position of the mouse pointer, current memory usage,
and whether unsaved preference changes are in memory. For more
information on memory usage see “Advanced Topics” on page 140.

Figure 30: Status Information

Ready Mem Usage: 515,896 K

Basic Ul Controls

The Lattice Diamond environment is based on modern industry standard user
interface concepts. The menus, toolbars, and mouse pointer all behave in
familiar ways. You can resize any of the window panes, drag and drop
elements, right-click a design element to see available actions, and hold the
mouse pointer over an object to view the tool tip.
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Start Page

Each of the Project and Tool views as well as the Outputs and Tcl Console
items can be detached from the main window and operated as independent
windows. Simply click the detach button [=] in the upper-right corner.

After a view or item has been detached from the main window it can be

reattached by one of two methods:

For Project views, Outputs and the Tcl Console, double-click inside the
window title bar, and the window will be re-attached to the main window.

For Diamond Tool views, single-click the attach button [F in the upper-
right corner, and the window will be re-attached to the main window.

Additionally, an Integrate All Tools button § is available in the Window menu
and toolbar. This control gathers all detached views and reintegrates them

inside the main window.

Start Page

The Start Page contains selections for opening projects, hyperlinks to product
documentation, and software status and upgrade information. The Start Page
appears in the Tool View area by default when Lattice Diamond is first

launched.

Figure 31: Start Page
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The Start Page can be closed, opened, detached, and attached with the
Attach button. See “Basic Ul Controls” on page 33.

File List

The File List is a project view that shows the files in the project, including
implementations and strategies. It is not a hierarchical listing of the design,
but rather a list of all the design source, configuration and control files that

make up the project.
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Figure 32: File List
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At the top of the File List is the project name. Directly below the project name
is the target device, followed by the strategies, and then the implementations.
There must be one active implementation, and it must have one active
strategy. Active elements are indicated in bold.

You can right-click any file or item in the File List to access a pop-up menu of
currently available actions for that item. The pop-up menu contents vary,
depending on the type of item selected.

The File List view can be closed, opened, detached, and attached using the
double-click method. See “Basic Ul Controls” on page 33.

Lattice Diamond 3.13 User Guide 35



USER INTERFACE OPERATION : Process

Process

The Process View is a project view that displays the high-level process flow
for the project.

Figure 33: Process View
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The icons to the left of each step indicate the process status and are defined
as follows:

& Process in initial state

% Process completed successfully

7. Process completed with warnings, see Warning output
%% Process failed, see Error output

You can right-click any step in the Process view to access a pop-up menu of
currently available actions for that item, as explained in “Process Flow” on
page 24.

The Process view can be selected, closed, opened, detached, and attached
using the double-click method. See “Basic Ul Controls” on page 33.

Hierarchy

The Hierarchy view is a project view that displays the design hierarchy.

The Hierarchy View is displayed by default. If you would prefer that it not open
by default, simply close Hierarchy View. The next time you launch Diamond,
the Hierarchy View will not be opened. You can open it manually by selecting
it from the View > Show View menu.
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Figure 34: Hierarchy View
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Right-click any of the objects in the Hierarchy View to see the available
actions.

Figure 35: Hierarchy Item Pop-up Menu
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After synthesis, the Hierarchy view displays the calculated resource utilization
data, such as LUT4, registers, and I/0 registers. Device resources that would
be consumed are shown to the right of each module. The first number in each
column indicates the quantity of that resource that would be used by that
module and all of its submodules. The second number, in parentheses,
indicates the quantity of that resource that would be used by just that
module, not including any of its submodules.

The numbers are updated after the synthesis and map stages of the
implementation process.

The amount of information shown in the Hierarchy view can be controlled by
right-clicking in the header row. In the drop-down menu, select the resource
headers that you want displayed.
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Figure 36: Post-Synthesis Resource Utilization
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Figure 37: Post-Map Resource Utilization
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Reports

Resource information for a selected module can be exported to a .csv file or
to an ASCII text file. Right-click the desired module and choose the
appropriate Export Resource command.

The Hierarchy view can be selected, closed, opened, detached, and attached
using the double-click method. See “Basic Ul Controls” on page 33.

The Reports View provides a centralized reporting mechanism in the Tools
view area. The Reports View is automatically displayed and updated when
processes are run. It provides a separate tab for each implementation,

enabling you to quickly compare results.

Figure 38: Reports View
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Module Name: Test Synthesis: SynplifyPro
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Target Device: LFXP10C-5F256C Device Family: LatticeXP
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Product Version:

3.0.0.47

Patch Version:
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Implementation Location:
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Project File:

C:/lscc/diamond/3.0/examples/mixed mode/Test.ldf
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The Design Summary pane on the left provides hyperlinks to the Project
Summary, to report information for each step of the design process flow, and
to messages from the implementation process. The right pane displays the
report for the selected step.

When All Messages is selected in the Design Summary pane, all warning and
error messages are displayed in the right pane. Click the down-arrow at the
top right to display the filter options.

-

[ Show Filter Selection l

The filter options and commands, shown in Figure 39, enable you to narrow
the list by hiding certain categories of messages.

Figure 39: Message Filtering
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Process: [ | Synthesis [| Translate || Map [ Place &Route [ Export Filter Details...
Severity: ] J) Information = A Warning [ o Error
Hidden IDs: R4
1D Process Message el
-- Flnd in TEXtI“ Ctr|+F
2019901 Synthesis WARNING - CGO21:"C: Filter Messages Exactly like This
A \my_diamond_tutorial\LEDtest\s Filter Messages with This ID
already declared in this scope. . .
Filter Messages from This Process
2019991 Synthesis WARNING - CG921:"C: Filter M ith This Severi
A \my_diamond_tutorial\LEDtest\s izl i Ui Sy
declared in this scope. Filter Details List...
2019991 Synthesis WARNING - CG921:"C: . .
A \my_diamond_tutorial\LEDtest\s e e T
already declared in this scope. .
Locate in 4
2019991 Synthesis WARNING - CL118 :"C:
™ \my_diamond_tutorial\LEDtest\s Help F1

When you save a message filter, its name appears in the Messages section of
the Design Summary pane under “User Design Filters.” When you select the
filter, all the filtered messages are hidden in the report pane. When you re-
select All Messages, the filtered messages are again displayed.

You can right-click a report in the Design Summary list to access the Find in
Text command. Selecting this command opens a text search area at the
bottom of the Report View, shown in Figure 40.

The Report View can be selected, closed, opened, detached, and attached
with the Attach button. See “Basic Ul Controls” on page 33.
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Tool Views

Figure 40: Report View Find in Text
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# Map Trace
# Place & Route Trace | Best Par Run

@ I/O Timing Analysis PAR: Flace And Route Diamond Wersion 3.0.0.47.
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The Tool view area of the Ul displays the active tools. Each tool that you have
opened from the toolbar or the Tools menu is displayed. The Reports and
Start page, which can be opened from the toolbar or the Windows menu, are
also displayed. When multiple tools are active, the display can be controlled
with the tab group functions in the Window toolbar. See “Common Tasks” on
page 43 for more information on tab group functions.

Each tool view is specific to its tool and can contain additional toolbars,
multiple panes, or multiple windows controlled by additional tabs. See
“Working with Tools and Views” on page 79 for descriptions of each tool and
view, plus details on controlling their display.

In Figure 41, You will notice an asterisk (*) in the tool view tab title when there
has been a change to the shared memory.

The Tool views can be selected, closed, opened, detached, and attached
using the Attach button. See “Basic Ul Controls” on page 33.
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Tcl Console

Tcl Console

Output

Figure 41: Tool View Tab Title Showing Changed Data
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The Tcl Console is an integrated console for Tcl scripting. You can enter Tcl
commands in the console to control all of the functionality of Lattice Diamond.
Use the Tcl help command (help) to display a listing of the groups of Lattice

Diamond extended Tcl commands.

Figure 42: Tcl Console

Tcl Console

> help

For more information on a specific command,
dtc DLattice Diamond Tcl Conscle extended Tcl commands.
prj Project Manager extended Tcl commands.
ncd NCD extended Tcl commands.
ngd NGD extended Tcl commands.
hle HDL Explorer extended Tcl commands.
rvl Reveal Inserter extended Tcl commands.
rva Reveal Enalyzer extended Tcl commands.
pwc Power Calculator extended Tcl commands.
pgr Programmer extended Tcl commands.
psb Pojo2 extended Tcl commands.

type "help <command>":

»

m

The Tcl Console can be selected, closed, opened, detached, and attached
using the double-click method. See “Basic Ul Controls” on page 33.

The Output View is a read-only area where tool output is displayed.

The Output view can be selected, closed, opened, detached, and attached
using the double-click method. See “Basic Ul Controls” on page 33.
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Figure 43: Output View

Output

& X
—-Elaborating Design | =
-- (VERI-1482) RAnalyzing Verilog file C:/Program Files (x86)/LatticeDiamond/diamond/l.0/cae_library/synthesis/verilog/ecpl.v
—- (5T-1001) Root modules/entities/cells (1):
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Design load finished with (0) errors, and (2) warnings.

Time to process design: 3.823 seconds

S U

Error, Warning, and Info

The Error, Warning, and Info views are read-only areas where messages of a
specific severity are displayed. Right-clicking a message provides a menu of
commands, including Location > Text Editor, which opens the source file in
the Text Editor and highlights the location of the problem.

Figure 44: Error and Warning Display

Warning
X Find: \} Next J Previous D Case Sensitive
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[

A 2019991 WARNING - CL260 :"C\Iscc\diamond\3.0\examples\mixed_mode\source\col — cc gister bit 0 of c_up[2:0]

A 2019993 WARNING - MT420 [Found inferred clock count|clk with period 5.00ns. Pleas iz::;‘i\l" Cr+A | o object “pclk

Find in Text...

Location in v Text Editor
Help F1

The Error, Warning, and Info views can be selected, closed, opened,

detached, and attached using the double-click method. See “Basic Ul
Controls” on page 33.

Find Results

The Edit > Find in Files command enables you to search for information in the

files within your project directory. The search results are then displayed in the
Find Results view.

Figure 45: Find Results View

Find Results

F X
C:/lsce/diamond/3.0/examples/mixed_mode/source/count.v(7):output [2:0]c_down_2;
C:fIscc/diamond/3.0/examples/mixed_mode/source/count.v(8):output [2:0]c_down_3; | |
C:fIscc/diameond/3.0/examples/mixed_mode/source/count.v(11):count_down count_down_inst (.clk{clk), .rst(rst), .c_down(c_down)); —
C:fIscc/diameond/3.0/examples/mixed_mode/source/count.v(13):count_down_2 count_down_2_inst (.clk(clk), .rst(rst}, .c_down{c_down_2});
C:fIscc/diamond/3.0/examples/mixed_mode/source/count.v{14):count_down_3 count_down_3_inst (.clk(clk), .rst(rst}, .c_down{c_down_3));

C:fIscc/diamond/3.0/examples/mixed_mode/source/count_down.v(1}):module count_down (clk,rst,c_down)/* synthesis GSR="DISABLED" */;

< | 1] | »
| Tel Console | Output | Error | Warning ‘ Find Results | Info |
Ready Mem Usage: 235,292 K
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The Find Results view can be selected, closed, opened, detached, and
attached using the double-click method. See “Basic Ul Controls” on page 33.

Common Tasks

The Lattice Diamond Ul controls many tools and processes. The following
sections describe some of the more commonly performed tasks.

Controlling Views

All of the views in Lattice Diamond are controlled in a similar manner, even
though the information they contain varies widely. Here are some of the most
common operations:

Open — Use the View > Show Views menu selections or right-click in the
menu or toolbar areas to select a view from the pop-up menu.

Select — If a view is already open you can select its tab to bring it to the
front.

Close — Click the x in the upper right corner of the view, or right-click in
the menu or toolbar area and select the view from the pop-up menu to
clear the check mark.

Detach — Click the detach button [s] in the upper right corner of the view

Attach — Use one of the two following methods to re-attach a view to the
main window:

For project views, Output and the Tcl Console, double-click in the
window title bar.

For tool views, click the attach button .

Attach All tool views — To re-attach all tool views that have been
detached, click the Integrate All Tools button [ on the Window toolbar.

Move — Click and hold a view’s tab, and then drag and drop the view to a
different position among the open views.

Using a Tab Group

You can use the Window menu or the Window toolbar to split off a view and
control it as a separate tab group. This allows you to examine two open views
side by side. The controls work as follows:

[ Split Tab Group — Displays two views side by side.

A Merge Tab Group — Merges a split tab group back into the primary
view.

Move to Another Tab Group — Moves the selected tab to the other tab
group.

Switch Tab Group Position — Switches the positions of the two tab
groups.
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Figure 46 shows the display after selecting Split Tab Group.

Figure 46: Split Tab Group
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Figure 47 shows the display after selecting Switch Tab Group Position.

Figure 47: Switch Tab Group Position
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Managing Layouts

Diamond’s layout management utilities allow you to load a predefined layout
of views and to create your own customized layouts. Predefined and
customized layouts enable you to get to work immediately on a specific task,
such as analyzing your source code or setting design constraints.
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Using Predefined Layouts

Four predefined layouts are included with Diamond and are available from the
Window menu.

Figure 48: Diamond Predefined Layouts

Window

EE Split Tab Group
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=

Load Default Layout

Load Layout Analyze RTL
Save Layout... Enter Preferences
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Integrate All Tools Tining Analysts
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Reports
v Stark Page

Each of these predefined layouts is described in the Manage Layout dialog
box, which is also available from the Window menu.

Figure 49: Predefined Layouts

riM . R B B A i B " = = l
~* Manage Layout
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Type Layout Name [

Predefined Analyze RTL
Predefined Enter Preferences
Predefined Manage Project

Predefined Timing Analysis

L Information: Preview:

This layout arranges windows:

| - Timing Analysis
i - Spreadsheet (TPF)
i - Reports
Prerequisites: Place & Route process
i successfully completed.

To run Place & Route Design:

1. In the Process view, right click on Place
& Route Design.

2. In the pop-up menu, click Run to run the
flow through the Place & Route process.

The Information pane provides prerequisites and instructions for viewing all
the windows of the layout. For example, if you load the Timing Analysis
predefined layout and your design is still in the pre-route stage, you need to
run Place & Route in order to view the Timing Analysis View.
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You cannot modify or delete any of the predefined layouts from the Manage
Layout dialog box. However, you can load one of the predefined layouts into
Diamond’s main window, modify it by opening and closing or detaching views,
and then save the arrangement as a customized layout.

Loading a Predefined Layout

You can load a predefined layout by selecting it from the Window menu or
from the Manage Layout dialog box. When you load a predefined layout,
Diamond does not close any of the tool views that are already open. Any
currently open tool views that are part of the predefined layout will be
arranged according to the layout when it is loaded. Other open tool views will
remain in their current positions. For example, if you have Power Calculator
detached as a separate window when you load the “Analyze RTL” predefined
layout, Power Calculator will remain open and in its detached position.

Creating Customized Layouts

When you have the Ul set up the way you like, you can save the arrangement
as a customized layout by using the Window > Save Layout command. You
can save as many of these customized layouts as you want, giving each a
unique name. The names of saved customized layouts are added to the
Window > Load Layout menu, and they appear as “Customized Layouts” in
the Manage Layouts dialog box.

You can use the Manage Layout dialog box to delete a customized layout,
and you can open the Modify dialog box to make minor changes. The Modify
dialog box enables you to change the name of the customized layout and to
select or clear the “Launch view when loaded” option. However, it does not
allow you to add or delete tool views.

Using the “Launch view when loaded” Option

The “Launch view when loaded” option causes all of the layout’s tool views to
open when you load the customized layout. This gives you quick access to
the tools and is very useful for layouts that include only a few tool views. For
more complex layouts, this option can cause a long delay while each tool view
gets loaded with the layout. If your customized layout includes a lot of tool
views, you should clear this option.

Figure 50: Modify Layout
* Modify | LEJ &1

Name: Fower Analysis{

Description:  pgyer Calculator
HDL Diagram
Reports
Start Fage I

| Launch view when loaded
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Loading a Customized Layout

You can load a customized layout by selecting it from the Window menu or
from the Manage Layout dialog box. When you load a customized layout,
Diamond does not close any of the tool views that are already open. If the
customized layout is set to “Launch view when loaded,” the Load Layout
command will open all of the layout’s tool views that are currently unopened.
Any of the layout’s tool views that were already open will be arranged
according to the layout. Any other open tool views will remain in their current
positions.

If the customized layout is not set to “Launch view when loaded,” the Load
Layout command will not open any of the layout’s tool views. For these types
of layouts, first open the layout’s tool views that you need to work with, and
then choose the Load Layout command. The tool views will be arranged
according to the customized layout. You can later open any or all of the
remaining tool views that are part of the customized layout and choose the
Load Layout command again. These tool views will also be arranged
according to the layout.

Layout Management Commands

All of the commands for layout management are available from the Window
menu:

Load Default Layout — Loads the predefined or customized layout that
has been specified as the default in the Manage Layout dialog box. This
command gives you quick access to your default layout after you have
opened your project in Diamond.

Load Layout — Provides quick access to the predefined and customized
layouts.

Save Layout — Enables you to save the arrangement of all open views in
your current session as a customized layout. The Save Layout dialog box
shows a preview of the layout and lists all the views that will be included in
the customized layout.

Manage Layouts — Opens the Manage Layout dialog box, which allows
you to preview and load a predefined or customized layout, delete a
customized layout, and select a layout as the default so that it will open
with the Load Default Layout command. The Layout Name list displays
the default layout in bold type. If a lot of views are listed for a customized
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layout, you should leave the “Launch view when loaded” option cleared to
avoid a long wait as the layout is loaded.

Figure 51: Customized Layout as Default
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Cross-Probing Between Views

It is possible to select a data object in one view and see that same data object
in a different view. Right-click a selected object; if cross-probing is available
for that object you will see a Show In sub-menu with available views listed. If
you select a view that is not yet open, Diamond will open it automatically.
Cross-probing is available for most tool views.

Figure 52: Show In
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Working with Projects

This chapter covers projects and their elements. Implementations and
strategies are explained and some common project tasks are shown.

Overview

A project is the top organizational element in the Lattice Diamond design
environment. Projects consist of design, constraint, configuration, and
analysis files. There is only one project open at a time. A project can include
multiple design structures and tool settings.

You can create, open, or import a project from the Start Page. See “Getting
Started” on page 10 for instructions on creating a new project.

Figure 53: Opening a Project from the Start Page
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The File List view shows a project and its main elements.

Figure 54: Project Files in the File List
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The Project menu commands enable you to examine the project properties,
change the target device, change the severity level of warning messages, set
the synthesis tool, show the active strategy tool settings, and set the top level
design unit.

Figure 55: Project Menu
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Implementations

An implementation is the structure of a design and can be thought of as what
is in the design. For example, one implementation might use inferred memory
while another implementation uses instantiated memory. Implementations
also define the constraint and analysis parameters for a project.

There can be multiple implementations in a project, but only one
implementation can be active at a time. And there must be one active
implementation. Every implementation has an associated active strategy.
Strategies are a shared pool of resources for all implementations and are
discussed in the next section. An implementation is created whenever you
create a new project.

Implementations consist of the following files:
Input files
Synthesis constraint files
LPF constraint files
Debug files
Script files
Analysis files

Programming files

To add a new implementation to an existing project, right-click the project
name in the File List project view and select Add > New Implementation. In
the New Implementation dialog box, you can set the implementation name,
directory, default strategy, and you can add source files. When you select Add
Source, you have a choice of browsing for the source files or using a source
from an existing implementation.

Notice that you have the option to “Copy source to implementation directory.”
If this option is selected, the source files will be copied from the existing
implementation to the new implementation, and you will be working with
different source files in the two implementations. If you want the two
implementations to share the same source files and stay in sync, make sure
that this option is not selected.

To make an implementation active, right-click its name in the File List and
choose Set as Active Implementation.

To add a file to an implementation, right-click the implementation name or any
file folder in the implementation, and choose Add > New File or choose Add
> Existing File.
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Implementations

Figure 56: New Implementation
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Copy source to implementation directory

Properties...

oK ] [ Cancel

Input Files

Input files are the design source files for the project. Input files can be any

combination of Verilog, VHDL, and EDIF files.

Right-click an input file name to open a pop-up menu of possible actions for

that file.

Figure 57: Input File Actions
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You can use the “Include for” commands to specify that a source file be
included for both synthesis and simulation, synthesis only, or simulation only.
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Synthesis Constraint Files

Synthesis constraint files are constraint files that are directly interpreted by
the synthesis engine. Starting with the G-2012.09 (Diamond 2.1) release,
Synplify Pro replaced the old Synplify-style constraints (.sdc) with the
Synopsys standard timing constraints (.fdc). New constraints created in
Synplify Pro are in the new FDC format, by default, but the legacy SDC is still
supported. Synopsys has provided a script, sdc2fdc, which does a one-time
conversion of SDC files to the new FDC format. More information about this
script can be found in the Synplify Pro for Lattice User Guide.

An .sdc file or .fdc file can be added to an implementation if the selected

synthesis tool is Synplify Pro or Precision. If the selected synthesis tool is the
Lattice Synthesis Engine (LSE), a Lattice design constraint (.Idc) synthesis file
can be added. Constraints in the .Idc file use the Synopsys constraint format.

An implementation can have multiple synthesis constraint files. Multiple .sdc
or .fdc files can be active at the same time, but only one .Idc file can be active
at a time. Unlike LPF constraints, you must specify the active synthesis
constraint file.

LPF Constraint Files

LPF constraint files are logical preference files (.Ipf), source files for storing
logical constraints called preferences. Preferences that you add and edit
using Diamond’s preference-editing views, such as Spreadsheet View, are
saved to the active .Ipf file. The active logical preference file is then used as
input for post-synthesis processes.

An implementation can have multiple .Ipf files, but only one can be active at a
time.

Figure 58: LPF Constraint File
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Debug Files

The files in the Debug folder are project files for the Reveal Inserter. They are
used to insert hardware debug into your design. There can be multiple debug
files, and one or none can be set as active. To insert hardware debug into
your design, right-click a debug file name and choose Set as Active Debug
File from the pop-up menu. The debug file name becomes bold, indicating
that it is active.

Figure 59: Reveal Debug File Actions
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Set Top-Level Unit

Include for
Properties
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Script Files

The Script Files folder contains the scripts that are generated by the
Simulation Wizard. After you run the Simulation Wizard, the steps are stored
in a simulation project file (.spf), which can be used to control the launching of
the simulator.

Figure 60: Simulation Script File

"2 Simulation Wizard (2 [t
[———
Summary
Simulator : Active-HDL -

Project Name : simulationfile

Project Location : C:/lscc/diamond/3.2/examples/mixed_mode_5C

Simulation Stage: RTL

Simulation Files :
Ci/lscc/diamond/3.2/examples/mixed_mode_SC/simulationfile/count_down_3.vhd
Ci/lscc/diamond/3.2/examples/mixed_rmode_SC/simulationfile/count_down_2.v
C:/lsce/diamond/3.2/examples/mixed_mode_SC/simulationfile/count_up_2.v
C:/lscc/diamond/3.2/examples/mixed_mode_SC/simulationfile/count_down.v
C:/lsce/diamond/3.2/examples/mixed_mode_SC/simulationfile/count_up.v
Ci/lsce/diamond/3.2/examples/mixed_mode_SC/simulationfile/count.

Simulation Libraries : -

m

Run simulator
Add top-level signals to waveform display
Run simulation

< Back ] [ Finish ] [ Cancel

Analysis Files

The Analysis Files folder contains Power Calculator files (.pcf) and Timing
Preference files (.tpf). The folder can contain multiple analysis files, and one
or none can be set as active. The active or non-active status of an analysis file
affects the behavior of the associated tool view.

Programming Files

Programming files (.xcf) are configuration scan chain files used by the
Diamond Programmer for programming devices in a JTAG daisy chain. The
xcf file contains information about each device, the data files targeted, and
the operations to be performed.

An implementation can have multiple .xcf files, but only one can be active at a
time.You must specify the active file.
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Strategies

Strategies are collections of all the implementation-related tool settings in one
convenient location. Strategies can be thought of as recipes for how the
design will be implemented. An implementation defines what is in the design,
and a strategy defines how that design will be run. There can be many
strategies, but only one can be active at a time. There must be one active
strategy for each implementation.

Lattice Diamond provides four predefined strategies. Diamond also enables
you to create customized strategies. Predefined strategies cannot be edited,
but they can be cloned, modified, and saved as customized user strategies.
Customized user strategies can be edited, cloned, and removed. All
strategies are available to all of the implementations, and any strategy can be
set as the active one for an implementation.

To create a new strategy from an existing one, right-click the existing strategy

and choose Clone <strategy name> Strategy. Set the new strategy’s ID and
file name.

Figure 61: Cloning to Create a New Strategy

+ Clone Strategyl Strategy @
Strategy:
Strategy ID: Strategy3
File name: Strategy3 File extension: sty
Save to location:
C:/Usersfjoan/YON/Work/ActisDesign /Projects/Lattice Diamond/mixedcounter fmixedcounter =
[ oK ] | Cancel |

To make a strategy active, right-click the strategy name and choose Set as
Active Strategy.
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To change the settings in a strategy:
Double-click the strategy name in the File List view
Select the option type to modify

Double-click the Value of the option to be changed

Figure 62: Strategy Settings
[ *+ Strategies - Strategyl N - @Iﬁ

Description:
Process
4 7 Synthesize Design o
Synplify Pro Display catalog: |All hd | | Default
: Name Type Value — * I
p Map Design Allow Duplicate Modules T/F False
Map Trace Area T/F False i
4 Place & Route Desii |Arrange VHDL Files T/F True B
| Place & Route T |Clock Conversion T/F True
| 10 Timing Analy! | Command line Options Text
A Ti_ming Simulation | | pefault Enum Encoding List Default
ftstream Disable IO Insertion G False
I Export Diamond Settings to Synplify Pro GUI  List MNo
FSM Encoding T/F True
Fanout Guide Num 100
Force GSR List False
Eranuency (MH=7 i 200
||
| 4 1 3

oK l | Cancel Apply Help

The default values are displayed in plain blue font. Modified values are
displayed in italic bold font.

Strategies are design data independent and can be exported and used in
multiple projects.

Area

The Area strategy is a predefined strategy for area optimization. Its purpose is
to minimize the total logic gates used while enabling the tight packing option
available in Map. It is commonly used for low-density devices such as
MachXO.

Applying this strategy to large and dense designs might cause difficulties in
the place and route process, such as longer time or incomplete routing.
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Figure 63: Area Predefined Strategy

+ Strategies - Area (Read Only) @éj

Description: | Predefined setting for area

Process

4 7 Synthesize Design i -
Synplify Pro Display catalog: Default
Precision
ranslate Design
Map Design

=
Name Type Value
Allow Duplicate Modules T/F False

Map Trace
Place & Route Design Arrange VHDL Files T/F True
Place & Route Trace Clock Conversion T/F True
IO Timing Analysis Command line Options Text
Timing Simulation Default Enum Encoding List Default
Bitstream Disable IO Insertion TIF False 3
Export Diamond Settings to Synplify Pro GUL List No
FSM Encoding T/F True
Fanout Guide Num 100
Force GSR List False
Frequency (MHz) Num 1
MNumber of Critical Paths Num |
Number of Start/End Points Num
Output Netlist Format List None
Output Preference File T/F True
Pipelining and Retiming List Pipelining Only
Push Tristates T/F True -

Specifies optimization preference for area reduction over timing delay reduction.

OK l [ Cancel Apply

1/0 Assistant

The I/O Assistant strategy is a predefined strategy that is useful for I/O
design. It helps you select a legal device pinout and produce LOCATE and
IOBUF preferences for optimal 1/O placement.

The benefit is that you will get results in 1/0 placement information early on,
without having a complete design or any long run times after finishing place
and route. However, applying this strategy to your design might take extra
runtime, because it executes logic synthesis, translation, map, and I/O
placement processes.

If you use the I/0O Assistant strategy for your project, the generated .ncd file
will be incomplete. Running the Export Files > Bitstream File process or the
Export Files > JEDEC File process will fail. If you want to implement a
complete design, you will need to choose another strategy and rerun all
processes again. See “Lattice Diamond Design Flow” on page 64 for more
information.
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Figure 64: I/O Assistant Predefined Strategy
* Strategies - /O Assistant (Read Only) ==
Desaiption: | Predefined setfing for 1/O Assistant
Process
4 [T Synthesize Design
'_.',:)IT‘S)mplify P!cg Beplay calzbog il = =
(=1 .. =
— | Precmon. MName Type Value -
2] Translate Design [ Auto Hold-Time Correction | List Off
4 £ Map Design [ Clock Skew Minimization List Off
¥=| Map Trace | : : E
4 [ Place & Route Design :Cemmar\d ||ne.0pt|Dns T.ext -io
T 2 Place & Route Trace | Congestion-Driven Placement List Auto
‘E 10 Timing Analysis .Congestion-Driven Routing List 1
B3 Timing Simulation | Create Delay Statistic File T/F False E
= Bitstream | Disable Timing Driven T/F False
o | Generate TRACE report for each iteration  T/F False
| Guided PAR Matching Factor Num
| Guided PAR Report Matches T/F False
|Ignore Preference Errors T/F True
| Multi-Tasking Node List File
| NCD Guide File File
;Path-based Placement List Off
| Placement Effort Level [1-5] Mum 5
Placement Iteration Start Pt Num 1
| Placement lterations [0-99] Mum 1 i
ok || cancel ][ apply Hep |

Quick

The Quick strategy is a predefined strategy for doing an initial quick run. This
strategy uses very low effort level in placement and routing to get results with
minimum run time. If your design is small and your target frequencies are low,
this is a good strategy to try. Even if your design is large, you might want to

start with this strategy to get a first look at place-and-route results and to tune

your preference file with minimum runtime.
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The Quick strategy will give you results in the least possible time. However,

the quality of these results in terms of achieved frequency will probably be

low, and large or dense designs might not complete routing.

Figure 65: Quick Predefined Strategy

“+ Strategies - Quick (Read Only)

Process
4 7 Synthesize Design
E Synplify Pro
%= Precision
E Translate Design
- E Map Design
@ Map Trace
- @ Place & Route Design
2 Place & Route Trace
E2 10 Timing Analysis
@ Timing Simulation
= sitstream

Lo lEs

Desaription: | Predefined setiing for quick

Place & Route Design

Defauit
Na’me Type Value -
Disable Timing Driven T/F False
Generate TRACE report for each iteration T/F False
Guided PAR Matching Factor Num
Guided PAR Report Matches T/F False
Ignore Preference Emors T/F True
Multi-Tasking Node List File
NCD Guide File File
Path-based Placement List Off
Placement Effort Level [1-5] MNum 1
Placement Iteration Start Pt Num 1 -
Placement Iterations [0-29] Mum 1 1
Placement Save Best Run [1-99] MNum 1
Remove previous design directory T/F True
Routing Delay Reduction Passes [0-100]  Num 4
Routing Passes [1-1000] Mum
Routing Rescurce Optimization [0-6] Num a B
Routing method List Default -
ok [ conce [ oy |[ hep
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Timing

The Timing strategy is a predefined strategy for timing optimization. Its
purpose is to achieve timing closure. The Timing strategy uses very high effort
level in placement and routing. Use this strategy if you are trying to reach the
maximum frequency on your design. If you cannot meet your timing
requirements with this strategy, you can clone it and create a customized
strategy with refined settings for your design. This strategy might increase
your place-and-route run time compared to the Quick and Area strategies.

Figure 66: Timing Predefined Strategy

* Strategies - Timing (Read Only) L7 =
Desaription: | Predefined setting for timir
Process
4 Synthesize Design . ) Al
Sy catadon: -
B2 Synplify Pro Display catalog:
[E=] Precision Narne Type Value
z Translate. Design Generate PUR in the Netlist T/F True
‘ !\i«‘.p Design Generate X for Setup/Hold Violation T/F False
3] Map Trace Hold Check Min Speed Grad TF Fal
= 'C mn 1 L ! alse
Place & Route Design MOI X h.e Modul pp :f 2 T
= Place & Route Trace Utlc_ e I_x erxt L
10 Timing Analysis Negative Setup-Hold Times T/F frue
Timing Simulation Retarget Speed Grade LA
=| Bitstream Timing Simulation Max Delay between buffers (ps) Num
Verilog Hierarchy Separator Text
Write Verbose Netlist T/F False
OK | Cancel | Apply | Help |

User-Defined

You can define your own customized strategy by cloning and modifying any
existing strategy. You can start from either a predefined or a customized
strategy.
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Common Tasks

Working with projects includes many tasks: creating the project, editing
design files, modifying tool settings, trying different implementations and
strategies, saving your data.

Creating a Project

See “Creating a New Project” on page 12 in the “Getting Started” chapter for
step-by-step instructions.

Changing the Target Device

There are two ways to access the Device Selector dialog box for changing the
target device:

Double-click the device in the project File List view or right-click it and
choose Edit.

Choose Project > Device

Setting the Top Level of the Design

If multiple top levels exist in the hierarchy of your HDL source files, you will
need to set the top-level design unit. After generating the hierarchy, choose
Project > Active Implementation > Set Top-Level Unit. Alternatively, right-
click the implementation and chose this command from the pop-up menu

Figure 67: Top-Level Design Unit
* - Project Properties @ ﬁ?—j

4 [[f mixed

i LFSC3GAL5E-5F256C . - -
4 L—E Timing Location:  C:/lscc/diamond/2.2/examples/mixed_mode/Timing

Name:  Timing Category: Implementation

[ source/count_up_2.v
B source/county
B source/count_down.v Top-Level Unit count e
B source/count_down_2v HDL Parameters
B sourcefcount_ down_3vhd
B sourcefcount_upv
B mixed.lpf Verilog Include Search Path
[EH mixed
B Area
[}}?—v IO Assistant
[5 Quick
[Z# Timing
Strategyl

Name Value

WHDL Library Name work

oK l | Cancel
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In the Project Properties dialog box, select Value next to Top-Level Unit and
select the desired top level unit from the list.

You can also use the Hierarchy View to set the top-level unit. Right-click any
level in the Hierarchy View and choose Set as Top-Level Unit.

Editing Files
You can open any of the files for editing by double-clicking or by right-clicking
and choosing Open or Open with.

Saving Project Data

In the File menu are selections for saving your design and project data.
Save — Saves the currently active item.
Save As — Opens the Save As dialog box to save the active item.
Save All — Saves all changed documents.
Save Project — Saves the current project.

Save Project As — Opens the Save Project As dialog box to save the
active project.

Archive Project — Creates a zip file of the current project in a location you
specify.
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Lattice Diamond Design Flow

This chapter describes the design flow in Lattice Diamond. Running
processes and controlling the flow for alternate what-if scenarios is explained.
A summary of the major differences from the ispLEVER flow is included.

Overview

The FPGA implementation design flow in Lattice Diamond provides extensive
what-if analysis capabilities for your design. The design flow is displayed in
the Process view.

Figure 68: Design Flow

Process E
4 % Synthesize Design

%L Synplify Pro
% Translate Design

4 % Map Design
&} -‘,, Map Trace
&} : Verilog Simulation File
[C] ¥ VHDL Simulation File
4 % Place & Route Design
&} : Place & Route Trace
[ 2 10 Timing Analysis
4 2 Export Files
[C] & IBIS Model
&} : Verilog Simulation File
[C] ¥ VHDL Simulation File
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Design Flow Processes

The design flow is organized into discrete processes, where each step allows
you to focus on a different aspect of the FPGA implementation.

Synthesize Design

This process runs the selected synthesis tool (Synplify Pro is the default) in
batch mode to synthesize your HDL design.

Translate Design

This process converts the EDIF file output from synthesis to the Native
Generic Database (NGD) format. If the design utilizes Lattice NGO netlist
files, such as generated Lattice IP, the netlist will also be read into the design.
The Translate Design process is not present when the Lattice Synthesis
Engine (LSE) has been selected as the synthesis tool.

Map Design

This process maps the design to the target FPGA and produces a mapped
Native Circuit Description (.ncd) design file. Map Design converts a design’s
logical components into placeable components.

The Map Design process also generates timing analysis and simulation files
when you have selected them before running Map Design:

Map Trace — Creates a post-map timing report file (.tw1) that helps
determine where timing constraints will not be met. This report can be
viewed in Report View. In post-map timing analysis, Trace determines
component delays and uses estimated routing delays. The estimation
method used is based on the setting for “Route Estimation Algorithm” in
the Map Trace section of the active strategy. This can be used to detect
severe timing issues, such as deep levels of logic, without incurring the
runtime of PAR.

Verilog Simulation File — Generates a Verilog netlist of the mapped
design that is back annotated with estimated timing information. This
generated _map_vo.vo file enables you to run a simulation of your design.

VHDL Simulation File — Generates a VHDL netlist of the routed design
that is backannotated with estimated timing information. This generated
_map_vho.vho file enables you to run a simulation of your design.

The timing analysis and simulation files can also be generated separately by
double-clicking each one.

Place & Route Design

This process takes a mapped physical .ncd design file and places and routes
the design. The output is an .ncd file that can be processed by the design
implementation tools. Auto Hold Time Correction, which is enabled by default
in the active strategy, causes Place & Route to process setup and hold time
requirements in a single flow and concurrently. This option improves timing
closure without increasing runtime.
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The Place & Route Design process also generates timing and SSO analysis
files when you have selected them before running Place & Route Design:

Place & Route Trace — Creates a timing report (.twr) that enables you to
verify timing. This report can be viewed in Report View. In post-route
timing analysis, Trace analyzes path delays and reports where these
occur in the design.

I/O Timing Analysis — Runs I/O timing analysis and generates an I/O
Timing Report that can be viewed in Report View. The report is an analysis
of inputs and outputs across all potential silicon to help ensure that the
board design is compatible. The report shows the constraints to which the
board design will need to adhere.

For each input port in the design, this report shows the worst case setup
and hold time requirements. For each output port, it shows the worst case
min/max clock-to-out delay. The computation is performed over all
performance grades available for the device and at the voltage and
temperature specified in the preference file. I/O timing analysis also
automatically determines the clocks and their associated data ports.

Thermal Analysis (MachXO3L/LF 9400C/E devices only) — Must be run
for MachXO3L/LF 9400C/E devices before running Bitstream File and
JEDEC File processes. The Thermal Analysis process calculates the
maximum safe ambient temperature for the design implemented in a
MachX03-9400C and mounted on three standard boards: JEDEC, Small,
and Medium boards. This is to assist designers to determine if their
design, implemented in a MachXO3L/LF 9400C/E device, could safely be
used in their application environment.

The thermal analysis software uses the clock specified in the TWR file. If
the clock frequency is not set in the TWR file, the thermal analysis
process errors out. The designer can either set the clock frequency in the
strategy section or in the timing constraint file which will be reported in the
TWR file after running Timing Analysis.

The Thermal Analysis report will include Device Operation Conditions,
Operating Clock frequency, Percentage of LUT utilization; Percentage of I/
O Utilization, and Activity Factor information.

The report contains Thermal Impedance and Maximum Ambient
temperature based on three different Board Mounts, No Heat Sink, and
No Air Flow.

By default, the Thermal Analysis process is checked. Uncheck this box if
you do not wish to run this process.

Export Files

This process generates the IBIS, simulation, and programming files that you
have selected for export:

IBIS Model — Generates a design-specific 1/0 Buffer Information
Specification model file (.ibs). IBIS models provide a standardized way of
representing the electrical characteristics of a digital IC’s pins (input,
output, and I/O buffers).
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Verilog Simulation File — Generates a Verilog netlist of the routed design
that is backannotated with timing information. This generated .vo file
enables you to run a timing simulation of your design.

VHDL Simulation File — Generates a VHDL netlist of the routed design
that is backannotated with timing information. This generated .vho file
enables you to run a timing simulation of your design.

JEDEC File — Generates a JEDEC file for programming the device.
JEDEC is the industry standard for PLD formats. In the Lattice Diamond
software, JEDEC refers to the fuse map of your design for the selected
device. This option is applicable only to non-volatile FPGAs such as
LatticeXP, LatticeXP2, MachXO, MachX02, MachXO3D, MachXO3L, and
MachXO3LFP.

Bitstream File — Generates a configuration bitstream (bit images) file,
which contains all of the design’s configuration information that defines
the internal logic and interconnections of the FPGA, as well as device-
specific information from other files. This option is applicable only to
volatile SRAM-based FPGAs, such as LatticeECP/2/M, LatticeECP3,
LatticeSC/M.

PROM File — Generates an output file in one of several programmable
read-only memory (PROM) file formats. This option is applicable only to
volatile SRAM-based FPGAs, such as LatticeECP/2/M, LatticeECP3,
LatticeSC/M.

The files for export can also be generated separately by double-clicking each
one.

Running Processes
For each step in the process flow you can perform the following actions:
Run — Runs the process, if it has not yet been run.
Rerun — Reruns a process that has already been run.
Rerun All — Reruns all processes from the start to the selected process.
Stop — Stops a running process.
Clean Up Process — Clears the process state and puts a process into an

initial state as if it had not been run.

The state of each process step is indicated with an icon to the left of the
process:

& Process in initial state
%L Process completed successfully
7 Process completed with warnings, see Warning output

%% Process failed, see Error output
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The Reports View displays detailed information about the process results,
including the last process run. In the Tool Reports section, it shows the results
of SSO analysis that has been set up in Spreadsheet View.

The Messages section shows warning and error messages and allows you to
filter the types of messages that are displayed. See “Reports” on page 38.

Figure 69: Reports View of Last Process Run

Eile Edit View Window

mixed & X

Design Summary

mixed project summary

4 Project
@ Project Summary Module Name: mixed Synthesis: SynplifyPro
4 Process Reports Implementation Name: mixed Strategy Name: Timing
> g Synplify Pro Last Procesa: I/0 Timing Analysis State: FPazsed
> @ Map Target Device: LF3C3GA1SE-S5F256C Device Family: Lattice3C
> ® Place & Route Device Type: LF3C3GA1SE Package Type: FPBGAZSE
g % SlgnaIfPad Performance grade: 5 Operating conditions: CoM
D Bitstream Logic preference file: mixed.lpf
a .
AnalySIS Reports Physical Preference file: mixed/mixed mixed.prf
> ¥ Map Trace
Product Version: 3.0.0.47 Patch Version:
> ¥ Place & Route Trace
. @ /0 Tlmlng Analysis Updated: 2013/06/13 15:54:06
4 Tool Reports Implementation Location: C:/lscc/diamond/3.0/examples/mixed mode/mixed
D VO S50 Analysis Project File: C:/lscc/diamond/3.0/examples/mixed mode/mixed.ldf

“E] Hierarchy Parsing Report
[ Run BKM Check
[% PIO DRC
» # TCL Command Log
4 Messages
¥ All Messages
¥ User Defined Filters

mixed | timing |

Refreshing a Process State

You can choose Design > Refresh Design to refresh the process state. For
example, after running a certain process, you have made changes to a source
file using a source editor outside Lattice Diamond. Then you can use Refresh
Process to check the most recent state of the processes. This will also update
the Hierarchy view and Reveal Inserter with any design changes.

Implementation Flow and Tasks

Implementations organize the structure of your design and allow you to try
alternate structures and tool settings to determine which ones will give you
the best results.

You might want to try different implementations of a design using the same
tool strategy, or try running the exact same implementation with different
strategies to see which scenario will best meet your project goals. Each
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implementation has an associated active strategy, and when you create a
new implementation you must select its active strategy.

To try the same implementation with different strategies you will need to
create a new implementation/strategy combination. Right-click the project
name in the File List and choose Add > New Implementation. In the dialog
box, the Add Source selection allows you to use source from an existing
implementation. The Default Strategy selection allows you to choose from the
currently defined strategies.

Figure 70: Adding a Source to a New Implementation

e 5
+ New Implementation |i|éj
Mame: verilog_vhdi2 Synthesis Tool: |5ynpliﬁf Pro - |
Directory:  verilog_vhd2 Default Strategy: |Area v|

Location:  C:/lscc/diamond,’3. 2fexamples/mixed_mode_5Cjverilog_vhdl2

Source files: Add Source ™

C/lsce/diamond,3.2/examples/mixed_mode_5C/Test/source/count.v
C/flsce/diamond/3.2/examples/mixed_mode_SC/Test/source/count_down.v
C/lsce/diamond/3.2/examples/mixed_mode_SC/Test/source/count_down_2.v
C/lsce/diamond;3.2/examples/mixed_mode_SC/Test/source/count_down_3.wvhd

el
i
E

C/lsce/diamond,3.2/examples/mixed_mode_SC/Test/source/count_up.v
C/lsce/diamond,3.2/examples/mixed_mode_5C/Test/source/count_up_2.v
C/lsce/diamond/3.2/examples/mixed_mode_SC/Test.Ipf

| Copy source to implementation directory

oK | | Cancel

If you want to use the exact same source for the new and the existing
implementations, make sure that the “Copy source to implementation
directory” option is not selected. This will ensure that your source is kept in
sync between the two implementations.

Run Management

Use Run Manager to run different implementations. Each implementation will
use its active strategy. Choose Tools > Run Manager or click the Run
Manager & button on the toolbar.-

Run Manager runs the entire process flow for each selected implementation.
If you are running multiple implementations on a multi-core system, Run
Manager will distribute them so that they are executed in parallel.

You can use the Run Manager list to set an implementation as active. Right-
click the implementation/strategy pair and choose Set as Active.
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Figure 71: Run Manager

£33 Run Manager =Rl X
File Window B
0 ions are hidden. Click to configure visible
| ] Implementation<Strategy> CurrentStep  Status Next Step  Worst Slack  Timing Score Worst Slack (Hold) Timing Score (Hold) Slice Unrouted Net Number Of Signals Number Of Connections
4 mixed<Strategyl> N/A Completed N/A 5.366 0 0.169 0 14/7584 0 N/A N/A
N/A N/A N/A N/A 5366 0 0169 0 14/7584 0 N/A N/A
E N/A N/A N/A N/A 5552 0 0141 0 14/7584 0 N/A N/A
B N/A N/A N/A N/A 5486 0 0169 0 14/7584 0 N/A N/A
N/A N/A N/A N/A 5392 0 0154 0 14/7584 0 N/A N/A
N/A N/A N/A N/A 5381 0 0154 0 14/7584 0 N/A N/A
4[7 mixed250<Strategy2> N/A Completed  N/A 2659 0 0181 0 14/7584 0 N/A N/A
N/A Select All ‘A 2659 0 0.181 0 14/7584 0 N/A N/A
N/A Unselect All VA 2849 0 0154 0 14/7584 0 N/A N/A
N/A N VA 2697 0 0.167 0 14/7584 0 N/A N/A
N/A un 2 2819 0 0159 0 1477584 0 N/A N/A
N/A tl Rerun VA 2726 0 0153 0 14/7584 0 N/A N/A
Pause
e Stop
[€l Show/Hide Implementation
[ Export
Set As Active
Show Report 4

For an implementation that uses multiple iterations of place-and-route, you
can select the run that you want to use as the active netlist for further
processes. Right-click the desired run, and choose Set as Active. Multiple
place-and-route (PAR) iterations are specified in the Place & Route section of
the active Strategy.

To examine the reports from each process, make an implementation active,
and then select the Reports View. For multiple Place & Route iterations, the
PAR report is not updated when the iteration is made active.

Synthesis Constraint Creation

Synthesis constraints, in the format of the Synopsys® Design Constraint
(SDC) language, can be added to a design implementation. Constraints can
also be added in the Synopsys standard timing constraints format in the form
of FPGA Design Constraint (FDC) files.

If you are using Synplify Pro or Precision for synthesis, the constraints will be
included in an .sdc file or .fdc file. If you are using the Lattice Synthesis
Engine, which is available for MachXO, MachX0O2, MachXO3D, MachXO3L,
MachXO3LFP, and Platform Manager (2) designs, the synthesis will be
included in an .Idc file.

To create a new synthesis constraint file, right-click the Synthesis Constraint

Files folder in the File List pane and choose Add > New File. In the New File
dialog box, select LDC Constraint Files or SDC Files from the Source Files list
and give the file a name. If you selected SDC Files, the .fdc extension will be
added by default, but you have the option of selecting the .sdc extension from
the drop-down menu.

If you selected SDC Files, open the file in the Source Editor to add the
constraints. If you selected LDC Constraint Files, the LDC Editor will open
displaying the spreadsheet and six tabs for creating and editing synthesis
constraints.
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Figure 72: New Synthesis Constraint File

+ New File B

Categories: Source Files:
Source Files " LDC Files
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E3 EDIF Netlist Files

[ Preference Files
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[E System Verilog Files
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Name: Ext: |fdc -
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Add to Implementation  attributes

Figure 73: LDC Editor

| i Start Page | Reparts - attributes_ldc.ldc * ] =
Type Port Clock Value(ns)
1 Input [all_inputs] clock 51_200000
2 Output [all_outputs] clock 1.200000
3

For detailed information about setting SDC constraints, see Applying Lattice
Synthesis Engine Constraints and the Constraints Reference Guide in the
Lattice Diamond online Help.

LPF Constraint Creation

The logical preference file (.Ipf) is the source file for storing constraints called
preferences. Logical preferences in the .Ipf file are used as input to post-
synthesis processes. These preferences can be created using Diamond’s
preference-editing views. The following steps illustrate how you might assign
and edit logical preferences in Lattice Diamond and implement them at each
stage of the design flow.

1. If desired, define some constraints at the HDL level using HDL attributes.
These attributes from source files will be included in the EDIF netlist, and
they will be displayed in Lattice Diamond after you run the Translate
Design process.
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2. Open one or more of the following views to create new constraints or to

modify existing constraints from the source files and save them as
preferences.

Spreadsheet View — This is the primary view for setting constraints.
Set timing objectives such as fyyax and I/O timing, define signaling
standards, and make pin assignments. Assign clocks to primary or
secondary routing resources. Set parameters for simultaneous
switching outputs for SSO analysis. Define groups of ports, cells, or
ASIC blocks. Create UGROUPs from selected instances to guide
placement. Establish REGIONs for UGROUPs or for reserving
resources.

Package View — Examine the pin layout of the design. Modify signal
assignments and reserve pin sites that should be excluded from
placement and routing. Examine SSO analysis by pin. Run P1O design
rule check to check for legal placement of signals to pins.

Device View — Examine FPGA device resources. Reserve sites that
should be excluded from placement and routing.

Netlist View — Examine the design tree by the element names of
ports, instances, and nets so that the names can be used when
defining preferences. Assign selected signals by dragging them to
Package View. Set timing and location constraints. Create UGROUPs
of logical instances to guide placement and routing. Set BLOCK
preferences for selected nets.

Floorplan View — Examine the device layout of the design. Draw
bounding boxes for UGROUPs. Draw REGIONSs for the assignment of
groups or to reserve an area. Reserve sites and REGIONSs that should
be excluded from placement.

When you modify preferences in Diamond, the “Preferences Modified”
indicator appears in the status bar on the right.

Save the preferences to the logical preference file (.Ipf).
The “Preferences Modified” indicator is cleared from the status bar.

Run the Map Design process (map). This process reads the .ngd and .Ipf
files and produces a native circuit description file (.ncd) and a physical
preference file (.prf). The .prf file is an internal file generated by the Map
engine that contains preferences used by the PAR engine. The .prf file is
not intended to be edited by the user because edits will be lost when it is
regenerated.

Run the Map TRACE process and examine the timing analysis report.
This is an optional step, but it can be a quick and useful way to identify
serious timing issues in design and preference errors (syntax & semantic).
Modify preferences as needed and save them.

Run the Place & Route Design process (par). This process reads the post-
MAP .ncd file and the .prf file, and it appends placement and routing to a
post-PAR .ncd file.

Open views directly or by cross-probing to examine timing and placement
and create new UGROUPs. Also examine the Place & Route Trace report.
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Timing Analysis View — Examine details of timing paths. Cross probe
selected paths to Floorplan and Physical Views. Create one or more
timing preference files (.tpf) and experiment with sets of modified
preferences for the purpose of timing analysis, using the TPF
Spreadsheet View. Copy the best results to the .Ipf file.

NCD View — Examine placement assignments. Cross probe to
Physical View and open detailed views of selected blocks. Create new
UGROUPs, as needed, from selected instances in NCD View.

8. Modify preferences or create new ones using any of the views. Save the
preference changes and rerun the Place & Route Design process.

Simulation Flow

The simulation flow in Diamond allows the use of testbenches, including
multiple file testbenches. Additionally, multiple representations of the same
module can be supported, such as one for simulation only and one for
synthesis only.

Diamond can automatically add top level signals to the waveform display in
the simulator and automatically start the simulator running.

The Simulation Wizard will automatically include any files that have been set
for simulation only or for both simulation and synthesis. You can select the top
of the design for simulation independent of the implementation design top.
This allows easy support for testbench files, which are normally at the top of
the design for simulation but not included for implementation. The
implementation wizard will export the design top to the simulator, along with
source files, and set the correct top for the SDF file if running timing
simulation.
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The File List view shows an implementation’s input files for simulation. This is
a listing of source files and does not show design hierarchy.

Figure 74: Input Files for Simulation

File List g X

Il LFE2-35E-5F672C
4 Strategies
E¥ Area
E#® 1/O Assistant
E¥ Quick
¥ Timing
Strategyl
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4 Input Files
B3 edif/rev_1/count8.edn
¥ source/topcounty
i source/typepackage.vhd [work]
¥ source/countl6.vhd [work]
Synthesis Constraint Files
4 LPF Constraint Files
[ mixedcounter_vipf
[ mixedcounter_vv.Ipf
[ mixedcounter vve.lpf
4 Debug Files
RS reveallrvi
Script Files
4 Analysis Files
P9 mixedcounter.pcf
T mixedcounter.tpf
Programming Files

[ER vhdi

File List | Process | Hierarchy |

After you add a module, use the Include For menu to specify how the module
file is to be used in the design.

When you are ready to simulate, you can export the design using the
Simulation Wizard. Choose Tools > Simulation Wizard or click the
Simulation Wizard button == on the toolbar. The wizard will lead you through
a series of steps: selecting a simulation project name and location, specifying
the simulator to use (if you have more than one installed), selecting the
process stage to use (from RTL to Post-Route Gate-Level + Timing), and
selecting the language (VHDL or Verilog) and source files. You can also run
the simulation directly from the wizard.
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Simulation Flow

Figure 75: Include For Commands
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Figure 76: New Simulation Project

7 Simulation Wizard ?

Simulator Project Name

Enter a name for your simulator project and spedify a directory where the project file will be

stored.
Project name: | simple_sim]|
Project location: | C:/flscc/diamond;3. 12fexamples/SimpleDesign_XO3L | m
Simulator
(® Modelsim

Active-HDL

After you have set up the simulator project and specified the implementation
stage and source files to be included, the Simulation Wizard parses the HDL
and testbench. The last step is to specify the simulation top module.
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Figure 77: Simulation Top Module
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In some designs, the compile order of the HDL files passed to the simulator
might result in compilation warnings. In most cases, these compilation
warnings can be safely ignored. The warnings can be eliminated in one of two
ways:

The correct compilation order for the HDL files can be set in the File List
view. After the correct order for the files is set manually, the files will be
sent to the simulator, which will eliminate any compilation warnings.

The correct compilation order for the HDL files can be set in the
Simulation Wizard during the “Add and Reorder” step. After the correct
order for the files is set manually, the files will be sent to the simulator,
which will eliminate any compilation warnings.

1/0 Assistant Flow

Defining a device pinout can be a complicated process because of constraints
in the board layout and the FPGA architecture, and it is typically done long
before the entire FPGA design is complete. The I/O Assistant, a special
predefined strategy within Diamond, assists you with this task, enabling you to
produce an FPGA-verified pinout early on based upon board layout
requirements.

The I/O Assistant strategy helps you select a legal device pinout and produce
LOCATE and IOBUF preferences for optimal 1/0 placement. The only design
content required to validate an 1/O plan is an HDL model of the 1/O ports.
Details of the internal logic can be treated as a black box. The primary output
of the 1/0 Assistant flow is a validated placement of 1/O signals that can be
backannotated to the logical preference file.
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The 1/O Assistant strategy is a read-only predefined set of properties for the
design flow. The following sequential steps are typical for the I/O Assistant
design flow:

1.

Create a top-level module in HDL that describes all of the ports in the
design. You can do so manually or use the I/O modules generated by
IPexpress.

Make the I/O Assistant strategy active for your project. From the
Strategies folder in the File list pane, right-click 1/0O Assistant and choose
Set as Active Strategy.

Synthesize your HDL as you would normally.

If you are using Synplify Pro, Lattice Diamond will automatically pass the
required attributes and header files for 1/0 Assistant flow when you run the
Translate Design process. It will also automatically pass the required
attributes and header files if you are using the integrated Lattice
Constraint Engine (LSE) for a MachXO, MachX02, MachXO3D,
MachXO3L, MachXO3LFP, or Platform Manager (2) design.

If you are running synthesis in stand-alone mode, you will need to include
these attributes and header library files in the source code before
synthesis. See the synthesis tool documentation for more information.

Constrain your design to add banking location preferences, 1/0 types, I/O
ordering, and minor customizations. You can set these preferences using
Spreadsheet View or you can do this manually.

To set the preferences in Spreadsheet View, choose Tools >
Spreadsheet View and edit the I/Os.

To set I/0O preferences manually, double-click the name of the project’s
logical preference file (.Ipf) from the Constraints folder in the File List
view.

When implementing DDR interfaces, it is recommended that you generate
the required DDR modules using IPexpress along with the port definitions.
This will enable the tool to check for any DDR-related rules that are being
violated.

Run the Place & Route Design process.

The process maps and places the I/Os based on the preferences, the I/O
Assistant strategy, and the architectural resources. The output is a pad
report (.pad) to guide future placement and a placed and routed native
circuit description .ncd that contains only 1/Os.

Examine the I/O Placement results by doing one or more of the following:

From the Process Reports folder in the Reports window, select
Signal/Pad to open the PAD Specification File and examine the
pinout.

Choose Tools > Package View, and then choose View > Display 10
Placement to view the pin assignments on the layout to cite areas for
minor customization.

To view the results of timing constraints:

Run the Place & Route Trace process and open the Place & Route
Trace report from the Reports window.
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7.

10.

11.

Run the I/O Timing Analysis process and open the I/0O Timing Report
from the Reports window.

Make any needed adjustments to the 1/O preferences, as you did in
Step 4.

Rerun Place & Route Design.

Repeat steps 5 through 7 as necessary to achieve your I/O placement
objectives.

From Package View, choose Design > Backannotate Assignments to
copy the 1/0 preferences to the logical preference file, and then choose
File > Save.

I/O placement preferences are written to the end of the .Ipf file and will
take precedence over any existing preferences that may conflict with
them.

Create a new strategy or add an existing one. Set the strategy as the
active one, and take your design through the regular flow.

Summary of Changes from ispLEVER

Although the design processes are very similar between the Diamond and
ispLEVER, there are a number of improvements and differences to be aware
of if you are an experienced ispLEVER user.

Synthesize Design and Translate Design steps in Lattice Diamond replace
the Build Database step in ispLEVER.

Exporting designs to simulation is done with the Simulation Wizard in
Lattice Diamond.

Timing analysis can be performed using the Timing Analysis View in
Lattice Diamond without having to re-implement the design. See “Timing
Analysis View” on page 103 for more details.

Reports from the design process steps are viewed independently of the
process state. Therefore, viewing a process report will not cause a
process to be rerun. In ispLEVER, viewing a report causes a process to
be rerun.
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Working with Tools and Views

This chapter covers the tools and views controlled from the Lattice Diamond
framework. Tool descriptions are included and common tasks are described.

Overview

The Lattice Diamond design environment streamlines the implementation
process for FPGAs by combining the tool control and data views into one
common location. Two main features of this design environment make it easy
to keep track of unsaved changes in your design and examine data objects in
different view:

Shared Memory — Lattice Diamond uses shared memory that is
accessed by all tools and views. As soon as design data has been
changed, an asterisk * appears in the tab title of the open views, notifying
you that unsaved changes are in memory.

Cross Probing — Shared design data in Lattice Diamond enables you to
select a data object in one view and display it in other views. This cross-
probing capability is especially useful for displaying the physical location
of a component or net after it has been implemented.
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View Menu Highlights

The View menu and toolbar control the display of toolbars, project views and
display control. Also included in the View menu are the important project-level
features Start Page, Reports, and Preference Preview.

Start Page

The Start Page is displayed by default when you run Lattice Diamond. The
three panes within the Start Page enable you to open projects, read product
documentation, and view the software version and updates. You can modify

startup behavior by choosing Tools > Options.

Figure 78: Start Page
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The Start Page gives you quick access to recent projects and to product

documentation. It can be opened, closed, detached and attached (using the

icon method).
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Figure 79: Reports View

Reports

The Reports view provides one central location for all project and tool report
information. It is displayed by default when a project is open. Separate tabs
are provided for each implementation, enabling you to view the results from
multiple implementations at the same time.
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The Design Summary pane of the Reports view is organized into Project,
Process Reports, Analysis Reports, Tool Reports, and Messages. The
different file icons indicate whether a report has been completed (green check
mark), has never been generated (blank note paper), or is out of date (orange
question mark). Select any item to see its report.

The Reports view also allows you to filter the messages from the
implementation processes so that you can find the most useful messages out
of what may be a very large number. To set up a filter, choose All Messages
on the left. All the messages from the implementation processes are shown.
Select message types, such as process, severity level, or message ID, that
you want to hide, leaving a much smaller number to study. You can also save
the settings for later use. See “Reports” on page 38 for more details about
message filtering.

The Reports view is the primary, central view for all process report
information. It can be opened, closed, detached and attached (using the icon
method).
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Tools

Preference Preview

Preference Preview shows the design’s logical preferences as they exist in
shared memory, which includes unsaved preferences as well as those in the
logical preference file (.Ipf). When you first open Lattice Diamond, Preference
Preview shows the contents of the active .Ipf file. As you use preference views
such as Spreadsheet View and Package View to add or modify constraints,
Preference Preview reflects those changes. What you see in Preference
Preview will be reflected in the .Ipf file when you use the Save command.

Figure 80: Preference Preview

@ Preference Preview [ & %

BLOCK RESETPATHS ;
BLOCK ASYMCHPATHS ;

FREQUENCY PORT “dock”™ 120.000000 MHz ;

The Preference Preview is a read-only view of logical preferences and can be
opened, closed, detached, and attached (using the attach button).

The entire FPGA implementation process tool set is contained in Lattice
Diamond. You can run a tool by selecting it from the Tools menu or toolbar.

This section provides an overview of each of these tools. More detailed
information is available in the user guides, which you can access from the
Start Page or from the Lattice Diamond Help. Detailed descriptions of external
tools can be found in their product documentation.
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Spreadsheet View

Spreadsheet View provides an interactive spreadsheet format for viewing and
assigning design constraints. Its collection of preference sheets enables you
to assign preferences such as PERIOD, FREQUENCY, I/O timing, and
LOCATE to optimize placement and routing. Preferences can also be set for
SSO Analysis and clock jitter.

Figure 81: Spreadsheet View
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Architecture: LatticeSC Device: LFSC3GA15E Package: FPBGA256

The Port and Pin Assignments sheets allow you to view I/Os by signal or pin
attributes and use the Assign Pins or Assign Signals functions to make
assignments. Custom columns are also available on the Port and Pin
Assignments sheet. Custom columns enable you to add your own
information, such as notes for specific signals or pins or design data for third-
party tools. You can create an unlimited number of custom columns, and you
can include the column when you export to a Lattice CSV file or a Pin Layout
File. Right-click any column heading to add a custom column.

Figure 82: Adding a Custom Column
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As soon as the target device has been specified, Spreadsheet View enables
you to set global preferences. After synthesis and translation, it allows you to
explore other devices of the same family for possible pin migration, as
explained in “Pin Migration” on page 143.

After synthesis and translation, all of the preference sheets become available
for editing.

Diamond enables you to export all Spreadsheet View preferences to a single
Apf file for later reference. Use the command File > Export > All SSV
Preferences to LPF. The .Ipf file of exported preferences includes not only
the assignments you have made, but all default preferences as well. It also
includes any assignments that you have not yet saved.

Port Assignments

The Port Assignments sheet provides a signal list of the design and shows
any pin assignments that have been made. It enables you to assign or edit pin
locations and other attributes by entering them directly on the spreadsheet. It
also enables you to assign pins in the Assign Pins dialog box by right-clicking
selected signals and selecting Assign Pins from the pop-up menu.

Figure 83: Spreadsheet View Port Assignments
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By default, the ports are grouped by direction—Input, Output, and
Bidirectional—plus an “Others” category that includes user-defined port
groups. This allows you to quickly focus, for example, on Output ports by
closing the display of Input ports or vice versa. If you prefer to display the port
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rows in a single ungrouped alphabetical list, clear the “Show Group Row(s)”
selection from the View > Display Group Row(s) menu.

Note

The default I/O type is LVCMOS25. Make sure this setting matches the 1/0 in your
design.

Pin Assignments

The Pin Assignments sheet provides a pin list of the device and shows the
signal assignments that have been made. It enables you to edit signal
assignments or assign new signals by right-clicking selected pins and
selecting Assign Signals from the pop-up menu.

Figure 84: Spreadsheet View Pin Assignments
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16 A15 FIO:PT43D | HDC N LVCMOS25  c_down_2[0] Output
17 B11 FIO:PT33A  QOUT P LVCMOS25  c_down_2[1] Output
8018 B12 FIO:PT36C D3 P LVCMOS25  c_down_2[2] Output
l 19 B14 FIO:PT41A | CSt1 LVCMOS25  c_down_3[0] Output
?Ef 110 C10 FIO:PT27A |MPICLK/PCLKT1_0 |P LVCMOS25  c_down_3[1] Output
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112 C12 FIO:PT35A D1 P LVCMOS25  c_up[0] Output
113 D8 FIO:PT28C | RDY LVCMOS25  c_up[1] Output
114 D10 FIO:PT37A D5 P LVCMOS25  c_up[2] Output
115 D12 FIO:PT37D |WRN N LVCMOS25  c_up_2[0] Output
116 D13 FIO:PT38A |RDN B %
Port Assignments Pin Assignments Clock Resource Route Priority | Cell Mapping Global Preferences | Timing Prefe 4 | »

Architecture: LatticeSC Device: LFSC3GAL5E Package: FPBGA256

By default, the rows of pins are grouped by bank number. You can also view
the differential pin pair groupings within each bank by selecting “Show
Differential Group Row(s)” from the View > Display Group Row(s) menu. If
you prefer to display the rows of pins in a single ungrouped alphabetical list,
clear the “Show Group Row(s)” selection from the View > Display Group
Row(s) menu.
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Clock Resource

The Clock Resource sheet enables you to apply a clock domain to the
device's primary or secondary clock or prohibit the use of primary and
secondary clock resources to route the net. For LatticeECP2 devices, it
enables you to use edge clock resources. For LatticeECP3 devices, it enables
you to assign a secondary clock to a clock REGION that has already been
defined.

Route Priority

The Route Priority sheet enables you to set the PRIORITIZE preference,
which assigns a weighted importance to a net or bus. To set this preference,
drag the desired nets from Netlist View to the Route Priority sheet. You can
then select a priority value for each net. Values range from 0 to 100.

Cell Mapping

The Cell Mapping sheet enables you to set the USE DIN and USE DOUT cell
preferences for flip-flops in your design. The PIO Register column allows you
to set the register to True or False. The True setting moves registers into the
I/Os. The False setting moves registers out of the I/Os. To set these
preferences, drag the desired registers from Netlist View to the Cell Mapping
sheet.

Global Preferences

The Global Preferences sheet enables you to set preferences that affect the

entire design, such as junction temperature and voltage; BLOCK preferences
applied to all paths of a particular type; and USERCODE. Also included in the
Global sheet are sysCONFIG preferences for FPGA devices that support the
sysCONFIG configuration port.

Timing Preferences

The Timing Preferences sheet displays all timing preferences that have been
set in the design, including BLOCK preferences for specific nets,
FREQUENCY, PERIOD, INPUT_SETUP, CLOCK_TO_OUT, MULTICYCLE,
and MAXDELAY. You can create a new timing preference by double-clicking
the preference name, which opens the dialog box. To modify an existing
timing preference, double-click the preference name, edit the information in
the dialog box, and click the Update button.

Group

The Group sheet displays any groups that have been created and enables
you to define a new cell, port, or ASIC group or create a new universal group
(UGROUP). Double-click the group type to open the dialog box and create a
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new group preference. To modify an existing group preference, double-click
the group name, edit the information in the group dialog box, and click the
Update button.

Misc Preferences

The Miscellaneous sheet enables you to define REGIONS, assign Vref
locations, and reserve resources by setting a PROHIBIT preference. To set a
new miscellaneous preference, double-click the preference type to open the
dialog box. To modify an existing miscellaneous preference, double-click the
preference name, edit the information in the dialog box, and click the Update
button.

Package View

Package View shows the pin layout of the target device and displays the
assignments of signals to device pins. Package View interacts with Netlist
View for assigning pins, enabling you to drag selected signals to the desired
locations on the pin layout to establish LOCATE preferences. Each pin that is
assigned with a LOCATE preference is color-coded to indicate the port
direction of the related signal port. Package View allows you to edit these
assignments, and it allows you to reserve sites on the layout that you want to
exclude from placement and routing.

After synthesis and translation, Package View allows you to explore other
devices of the same family for possible pin migration, as explained in “Pin
Migration” on page 143.

As you move your mouse pointer over the layout, pin descriptions and
locations are displayed in tool tips and in the status bar. The View > Show
Differential Pairs command displays fly wires between differential pin pairs
and identifies the positive differential pins.

To filter the display of banks and pin types, click the Pin Display Selection
button [iZ on the toolbar. The Pin Display Selection dialog box allows you to
clear the selections of banks and pin types so that only those that you want to
view are displayed.

Package View is available as soon as the target device has been specified.

Device View

Device View provides a categorized index of device resources based on the
target device. Statistics cover System P1Os, User P10s, PFUs, PFFs, sysDSP
blocks, sysMEM blocks, IOLOGIC, PLL/DLLs, and other embedded ASIC
blocks. Device View enables you to use the Prohibit command to reserve
sites that you want to exclude from placement and routing.

From Device View, you can cross probe selected resources to their sites in
Package View, Floorplan View, and Physical View.
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Figure 85: Package View
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Device View is available as soon as the target device has been specified.

Netlist View

Netlist View displays the design elements of the post-synthesis native generic
database (NGD) netlist. The NGD is a binary speed-optimized data structure
that is used by the system to browse the logical netlist.

Netlist View organizes the netlist by ports, instances, and nets. Netlist View
provides a toolbar button and design tree view for each of these categories to
make it easier to create timing or location preferences.

Each design tree view is equipped with utilities for filtering the list and
searching for elements.

From Netlist View, you can drag selected signals to Package View to assign
them, drag selected nets to Spreadsheet View’s Route Priority sheet to
prioritize them, and drag registers to the Cell Mapping sheet to specify
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registers for flip-flops. You can use the right-click menu to set timing
preferences for selected nets and to create logical groups from selected

instances.

Netlist View is available after synthesis and translation.

Figure 86: Pin Display Selection Dialog Box
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Figure 88: Netlist View Ports Design Tree
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Figure 89: Netlist View Instances Design Tree
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NCD View

NCD View provides a categorized index of synthesized design resources and
consumption based on the target device and the in-memory native circuit
description (NCD) database. Statistics cover System PIOs, User P1Os, PFUs,

PFFs, sysDSP blocks, sysMEM blocks, IOLOGIC, PLL/DLLs, and other

embedded ASIC blocks.

NCD View is organized by nets and instances and provides a toolbar button
and design tree view for each of these categories.
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Figure 90: Netlist View Nets Design Tree
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Each design tree view is equipped with utilities for filtering the list and

searching for elements.

From NCD View, you can create a new UGROUP preference from selected

instances. You can also access schematic or tabular detailed views for

selected instances.

NCD View is available after a successful run of Place & Route.
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Figure 92: NCD View Nets Design Tree
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IPexpress

IPexpress is a collection of functional modules that can be used to generate
Verilog or VHDL source for use in your design. Modules are functional blocks
of design that can be reused wherever that function is needed. They are
optimized for Lattice device architectures and can be customized. Use these
modules to speed your design work and to get the most effective results.

Many basic modules are included in IPexpress. They provide a variety of
functions including /O, arithmetic, memory, and more. A recommended way
to use IPexpress is to select the import module option which will include an
.ipx file in your source list. This file can be used to regenerate the module for
any changes.

Choose Tools > IPexpress to see the full list of available modules.

In addition to the included modules, an IP Server button is provided that
enables you to connect to the Lattice IP server, explore the available IP, and
select those that you would like to download and install. IPexpress indicates
whether an IP from the IP server is compatible with the running software
release. The three states are compatible, incompatible, or unsupported.

Lattice IP can be purchased or used in a trial mode. Refer to the Lattice
website for a list of the available IP functions. For more information, see the
IPexpress Module Reference Guide.
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Figure 93: IPexpress
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Platform Designer

Platform Designer tool which enables you to build and control a complete
hardware management system. With Platform Designer, you can build and
control:

Platform Manager 2

Platform Manager 2 in a two-device (LPTM21 and LPTM21L)
configuration

Certain devices in the MachXO2HC/HE family with external Analog Sense
and Control (ASC) devices

Certain devices in the MachXO3LF family with external ASC devices
Certain devices in the ECP5U/UM family with external ASC devices.

The larger LPTM21 device can configure both ASC and/or LPTM21L as slave
devices.

Each Platform Manager 2 device is made up of an analog sense and control
block and an FPGA block. These two blocks provide the necessary
programmable building blocks to enable integration of various combinations
of hardware management functions into a single chip.

Platform Designer’s integrated design environment allows you to configure
the device, implement the hardware management algorithm, simulate, assign
pins, and finally generate the JEDEC files required to program and configure
the device on the circuit board. It also allows you to import other HDL files to
integrate other desired functions.
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Figure 94: Platform Designer
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You can launch Platform Designer by creating a new project in Diamond that
targets supported devices. You can also launch Platform Designer by opening
an existing Platform Designer project file (.ptm).

For more information, see “Designing with Lattice Diamond Platform
Designer” in the Diamond online Help or refer to the Platform Designer User
Guide.

Clarity Designer

Like IPexpress, Clarity Designer is an easy way to use a collection of
functional blocks from Lattice Semiconductor. But Clarity Designer doesn't
just customize intellectual property (IP). It actually creates a package of
modules, including wiring the modules together and creating placement
constraints for DDR and PCS pins. This package can contain a single module
or the entire design.

The resulting Clarity Designer module can be used to aid with developing the
board design and firmware while developing the FPGA design, cutting the
total development time.

Clarity Designer is used with ECP5 only.

Clarity Designer has three major tabs:

Catalog provides a list of the available modules and IP. Use Catalog to
select the modules you want in the project and to customize them. You
can also download more IP from the Lattice website.
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Builder helps you make connections between your customized modules.

Planner provides a graphic way to place DDR pins and PCS components
before synthesis. You can run design rule checks on the placement while
still in the earliest stages of designing.

Reveal Inserter

Reveal Inserter allows you to add debug information to your design to allow
hardware debugging using Reveal Analyzer. Reveal Inserter enables you to
select the design signals to use for tracing, triggering, and clocking. Reveal
Inserter will automatically generate the debug core, and insert it into a
modified design with the necessary debug connections and signals. Reveal
Inserter supports VHDL, Verilog, and EDIF sources. Mixed-HDL designs are
represented by the synthesis EDIF netlist. After the design has been modified
for debug, it is mapped, placed and routed with the normal design flow in
Lattice Diamond.

The File List Debug file folder contains the debug files for Reveal Inserter.

Figure 95: File List View with Reveal Debug Project File
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One or none of the debug files can be active at a time. If no debug file is
active, hardware debug will not be inserted into the design when it is
implemented.

Launching Reveal Inserter

To launch Reveal Inserter, choose Tools > Reveal Inserter or click the
Reveal Inserter @ button on the toolbar. When Reveal Inserter is launched,
the debug file it uses will depend on the following conditions:

If an active debug file exists, it will be used. An inactive debug file will be
used if it is the only one available.

If an active or inactive debug file in the File List Debug folder is double-
clicked, it will be used.

If multiple debug files exist and no debug file is set as active, a dialog box
will enable you to select one of the inactive debug files.

If no debug files exist, Reveal Inserter will use a default configuration.

The sections of Reveal Inserter include Trace Signal Setup and Trigger Signal
setup views.

Figure 96: Reveal Inserter Trace Signal Setup
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Figure 97: Reveal Inserter Trigger Signal Setup
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Setting up and Inserting Debug

A Debug menu becomes available after Reveal Inserter is launched. It
includes controls for managing cores, managing trace signals, running DRC,
and inserting debug.

See the Reveal User Guide for more information on setting up debug
information with Reveal Inserter.

After you have your debug set up, choose Debug > Insert Debug or click the
Insert Debug = button on the vertical toolbar to insert debug into your design.
This will set the current debug file as active.

When the design is fully implemented and programmed, you can run Reveal
Analyzer to debug your design.

Reveal Analyzer

After you generate the bitstream or JEDEC file, you can use Reveal Analyzer
to debug your FPGA circuitry. Reveal Analyzer gives you access to internal
nodes inside the device so that you can observe their behavior. It enables you
to set and change various values and combinations of trigger signals. After
the specified trigger condition is reached, the data values of the trace signals
are saved in the trace buffer. After the data is captured, it is transferred from
the FPGA through the JTAG ports to your computer.
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Figure 98: Insert Debug
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To launch Reveal Analyzer, choose Tools > Reveal Analyzer or click the
Reveal Analyzer @t button on the toolbar. The Reveal Analyzer Startup
Wizard allows you to use an existing Reveal Analyzer file or create a new
one. If there is only one Reveal Analyzer project file in your implementation, it
will automatically bypass the wizard and open that file. To make a new file,
use the menu New File command.

Figure 99: Reveal Analyzer Setup Wizard
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The Reveal Analyzer view consists of a Trigger Setup view and a Waveform
view. In the Trigger Setup view are areas displaying the Trigger Unit, Trigger
Expression, Trigger Options and Trigger Position. Also in this view are
controls to select which core to use to enable for triggering the analyzer.

When you choose Run, the analyzer connects to the hardware, configures
the debug logic, and waits for the trigger conditions. Once triggered, the data
is uploaded to the analyzer. The Run command also switches the display to
the Waveform view.

Figure 100: Reveal Analyzer
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The Waveform view has controls for running, zooming and window controls in

the menu and toolbar areas.

Figure 101: Reveal Analyzer Waveform View
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Right-clicking in the waveform area brings up a pop-up menu with selections
for changing the cursor mode for panning, zooming, or selecting plus
selections for managing cursors, changing the clock period, and exporting
waveforms.

The Data column in the view shows the data for the active cursor. The Reveal
Analyzer supports multiple cursors which can be added, removed, and
position changed within the waveform. Selecting the cursor and dragging it
will produce a rubber band effect which can be used for measuring time
intervals.

See the Reveal User Guide for more information on using Reveal Analyzer.

Floorplan View

Floorplan View provides a large-component layout of your design. It displays
user constraints from the logical preference file (.Ipf) and placement and
routing information. All connections are displayed as fly-lines.

Floorplan View allows you to create REGIONs and bounding boxes for
UGROUPs and specify the types of components and connections to be
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Figure 102: Reveal Analyzer Waveform Cursor Controls
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Figure 103: Floorplan View
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displayed. As you move your mouse pointer over the floorplan layout, details
are displayed in tooltips and in the status bar:

the number of resources for each UGROUP and REGION

the number of utilized slices for each PLC component

the name and location of each component, port, net, and site
If your design uses the incremental design flow, Floorplan View will display
partitions that are included in the design and allow you to edit them. For more

information, refer to “Using Incremental Design Flow” in the Diamond online
Help.
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Floorplan View is available as soon as the target device has been specified.

Physical View

Physical View provides a read-only detailed layout of your design that
includes switch boxes and physical wire connections. Routed connections are
displayed as Manhattan-style lines, and unrouted connections are displayed
as fly-lines.

Figure 104: Physical View
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As you move your mouse pointer slowly over the layout, the name and
location of each REGION, group, component, port, net, and site are displayed
as tool tips and also appear in the status bar. The tool tips and status bar also
display the group name for components that are members of a group.

The Physical View toolbar allows you to select the types of elements that will
be displayed on the layout, including components, empty sites, switch boxes,
switches, pin wires, routes, and timing paths.

If your design uses the incremental design flow, Physical View will display
partitions that are included in the design. For more information, refer to “Using
Incremental Design Flow” in the Diamond online Help.

Physical View is available after placement and routing.
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Logic Block View

Logic Block View is available from either Physical View or Floorplan View, and
enables you to examine logic details of one or more placed and routed
components. It provides either a schematic or tabular view, depending on the
type of component selected.

Figure 105: Logic Block Schematic View
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Schematic views of PIO and PFU/PFF components can be accessed from
NCD View, Floorplan View, and Physical View. Tabular views of PLL, EBR,
and DSP blocks can be accessed from Floorplan View and Physical View.
Right-click one or more selected components and choose Logic Block View.

Multiple Logic Block Views can be opened at one time, up to the maximum
that has been set in the Tool > Options dialog box for Physical View.

Timing Analysis View
Timing Analysis View provides a graphical way to navigate timing information

and a fast timing analysis loop that allows dynamic path changes without
having to re-implement or remap your design.
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The File List view of your project contains the Timing Analysis preference files

(.tpf) in the Analysis folder. One or none of the .tpf files can be active.

Figure 106: Timing Analysis Preference File
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Launching Timing Analysis View

When Timing Analysis View is launched, it uses the active .ipf file. If there is
no active .tpf file, it will read timing preferences from the logical preference file
(.Ipf) for its initial timing calculations. You can also double-click any active or
inactive .tpf file in the File List to launch Timing Analysis View using the
settings from the selected .tpf file.

Figure 107: Timing Analysis View
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The sections in Timing Analysis View display the trace settings from your
active strategy and the preferences from the active .tpf or .Ipf file. All timing
preferences are listed in the Preference Reports section of the Preferences
pane. If you have selected the “Check Unconstrained Paths” option in the
active strategy, the Other Reports section will contain a list of suggested
preferences for unconstrained paths. You can then examine the path table for
each suggested preference, including the classification, Start Point, and End
Point of each unconstrained path.
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Timing Analysis View also provides views of the path table, detailed path
tables, schematic path and report.

Figure 108: Timing Analysis Schematic Path View
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The Timing Analysis vertical toolbar on the left contains the following controls:

Export — Exports the timing paths to a cvs file.

Settings — Allows you to change settings for a timing analysis run. To
change the settings permanently, you must edit the trace settings of the
active strategy.

Change Timing Preferences — Displays the Timing Preferences tab of the
Spreadsheet view. This is a graphical view of the .tpf file.

Fit All Columns — Sizes each column of the Detailed Path Table to fit the
information displayed.

View All Columns — Sizes all columns of the Detailed Path Table to fit
inside the window.

Path Table — Displays or hides the path table.

Report: setup — Displays or hides the Report:Setup tab.

Schematic Path view — Displays or hides the Schematic Path View tab.
Detailed Path Tables — Displays or hides the Detailed Path Tables tab.

Update — When this button is visible and rotating, indicates a preference
has been changed. When clicked, it recalculates timing.
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Timing Analysis View enables you to cross-probe a selected timing path to
view it in Floorplan View or Physical View, or to jump to the specific section of
the timing report. Right-click a path, a schematic block, or highlighted text in
the report, and then choose the desired command from the “Show In” pop-up
menu.

Updating Timing Preference File Settings

When you change a timing preference, you must run Update to recalculate
the timing. Use the following steps to change timing preferences, recalculate
timing, and save your preferences:

1. In Timing Analysis View, click the Change Timing Preferences # button
on the vertical toolbar. This opens Spreadsheet TPF View.

2. Modify a preference in Spreadsheet TPF View. An asterisk indicating a
data change appears in both the Spreadsheet and Timing Analysis tabs.

3. Select Timing Analysis View again.

The Update % button in the vertical toolbar is now visible and rotates,
indicating that a timing preference has changed and that the timing has
not yet been recalculated.

4. Click the rotating Update button to recalculate the timing.

5. To save the .tpf file, make sure that Timing Analysis View is active, and
then choose File > Save.

Timing Analysis view must be active in order to use the File > Save
command. You cannot save timing preferences from Spreadsheet TPF
View.

Exporting TPF Settings

To save your TPF settings to the logical preference file, first select the Timing
Preferences tab of Spreadsheet TPF View. Right-click the preference you
want to export and choose Export to LPF. This will export the selected setting
to the active .Ipf file.

Importing In-Memory Timing Preferences

If you edit timing preferences in the regular Spreadsheet View after you have
launched Timing Analysis View, you must import these in-memory timing
preferences in order to run timing analysis on them.

1. In Timing Analysis View, click the Change Timing Preferences i button
on the vertical toolbar.

2. In the TPF Spreadsheet View, choose File > Import > Copy LPF to TPF.

Return to the Timing Analysis View main window and click the Update &
button.
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Figure 109: Export TPF
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Netlist Analyzer

Netlist Analyzer works with Lattice Synthesis Engine (LSE) to produce
schematic views of your design while it is being implemented. (Synplify Pro
also provides schematic views.) Use the schematic views to better
understand the hierarchy of the design and how the design is being
implemented.

The Netlist Analyzer window has four parts:
Toolbar provides buttons for various functions.
Browser provides nested lists of module instances, ports, and nets.

Schematic view shows a schematic of the design. Depending on the size
of the design, the schematic may be made of multiple sheets.

Mini-map, which is a miniature view of the sheet, helps you pan and zoom
in the schematic view.

Netlist Analyzer can have multiple schematics open. The open schematics
are shown on tabs along the bottom of the window.

There are several ways to adjust the view of a schematic and to navigate
through the hierarchy.

For detailed information about Netlist Analyzer, see About Netlist Analyzer in
the Lattice Diamond online Help.
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Figure 110: Netlist Analyzer
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LDC Editor

The Lattice Design Constraints (LDC) Editor is a synthesis constraint tool for
use with the Lattice Synthesis Engine (LSE). Currently, the Lattice Synthesis
Engine and LDC Editor support the MachXO, MachX02, MachXO3D,
MachXO3L, MachXO3LFP, and Platform Manager device families.

LSE is a synthesis tool custom-built for Lattice products and fully integrated
with Diamond. Depending on the design, LSE may lead to a more compact or
faster placement of the design than another synthesis tool would do. LSE can
be run from the Diamond main window or through the command line, similar
to the other integrated synthesis tools.

The LDC Editor uses a spreadsheet style user interface that enables you to
quickly create and edit Synopsys Design Constraints and save them to a
Lattice Design Constraint file (.Idc). You can create several .Idc files and
select one of them to serve as the active synthesis constraint file for the
current implementation.

After you have selected the Lattice Synthesis Engine (LSE) as the synthesis
tool, the LDC Editor will open automatically each time you create or open an
JIdc file. You also have the option of viewing and editing .Idc files in the Source
Editor. The LDC Editor includes individual tabs for Clocks, Inputs/Outputs,
and Delay Paths. Each sheet enables you to define synthesis constraints by
double-clicking a cell and selecting or typing a value.
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Figure 111: LDC Editor
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The Clocks tab allows you to define an alias to be associated with an existing
clock port or net from the source file. Double-click the Source cell to select an
existing clock port or net, and then enter an alias for the clock in the Clock
Name cell. Enter a clock period in nanoseconds.

Inputs/Outputs

The Inputs/Outputs tab enables you to specify an input or output delay relative
to a clock. Double-click the Type cell to select the type of delay (input or
output), and then select from the input or output ports in the Port cell. In the
Clock cell, select an existing clock or an alias name that has been defined for
a clock. Enter a delay value in nanoseconds.

Delay Paths

The Delay Paths tab allows you to define a Multicycle path, specify a
Max_Delay for a timing path, and identify a False path that is to be excluded
from timing analysis. Double-click the Delay Type cell to select the type of
delay, and then specify the path information, delay, and cycles as appropriate.

For detailed information about setting SDC constraints, see Applying Lattice
Synthesis Engine Constraints and the Constraints Reference Guide in the
Lattice Diamond online Help.

Schematic Editor

Schematic Editor works in conjunction with Symbol Editor and Symbol Library
Manager. You design by laying out symbols for basic functions and other
modules and drawing wires between their ports. You can also create your own
library of custom schematic symbols.

To begin a new schematic design, choose File > New > File.

For more information, see the “Entering the Design” section of the Lattice
Diamond online Help.
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Power Calculator

Power Calculator estimates the power dissipation for your design. It uses
parameters such as voltage, temperature, process variations, air flow, heat
sink, resource utilization, activity and frequency to calculate the device power
consumption. It reports both static and dynamic power consumption.

Power Calculator files (.pcf) are managed in the Analysis Files folder of the

File List.

Figure 112: Power Calculator File
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To launch Power Calculator from Diamond, choose Tools > Power
Calculator or click the Power Calculator {7 button on the toolbar.

When Power Calculator is launched, the .pcf file it uses will depend on the

following conditions:

If an active .pcf file exists, it will be used. An inactive .pcf file will be used if

it is the only one available.

If an active or inactive .pcf file in the File List Analysis Files folder is

double-clicked, it will be used.
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If no .pcf file exists, Power Calculator will perform power calculations
based on the current open design.

Power Calculation Modes

Power Calculator opens in estimation mode or calculation mode, depending
on the status of the selected .pcf file. If it opens in calculation mode, it will
import any Bank VCCIO settings that are in the preference file and display
these settings on the I/O page. When you make certain data changes in
calculation mode, Power Calculator reverts to estimation mode. If you are
using a named .pcf file and have not yet saved the changes, Power Calculator
will enable you to revert to calculation mode by using the Edit > Revert to
Calculation Mode command.

Power Calculator Pages

When Power Calculator opens, it displays the Power Summary page, which
enables you to change the targeted device, operating conditions, voltage, and
other basic parameters. Updated estimates of power consumption are then
displayed based on these changes. Tabs for other pages, including Power
Matrix, Logic Block, Clocks, 1/0, I/O Term, Block RAM, Graph, and Report,
are arranged across the top. The number and types of these pages will
depend on the target device.

Figure 113: Power Summary
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Implementation Comparisons

Power Calculator enables you to compare the power consumption among
multiple implementations of your design. Each implementation must target the
same device and have at least one power calculator project file (.pcf). You can
access the implementation comparisons from the Edit menu.

Figure 114: Implementation Comparisons

‘4] Power Calculator - Compare power between multiple implementations

5 .

Implementation power (W)

Implementation

:fIsce/dia...
& mixedl C:/lsc/dia...

Logic Block Clocks I/O EFB Misc Total
0.002830 0.000356 0.002905 0.000023 0.031764 0.037878
0.045292 0.001594 0.045896 0.000027 0.031774 0.124583

View HTML l |Generate Text Repor‘t| | Close | | Help

Added Features for Low-Power Architecture

Three power modules are available for MachX02, MachXO3D, MachXO3L,
MachXO3LFP, and Platform Manager 2 devices: Power Controller, Dynamic
Bank Controller, and Power Guard. You can generate these modules from
IPexpress. Refer to the IPexpress Module Reference Guide for more
information. Power Calculator provides tools for taking advantage of these
features, including the Power Option Controller, which is accessible on the
Power Summary page. It enables you to conserve power by turning on and off
blocks in the chip that consume power, manage the entrances and exits of
signals, and use power guard (PG) to stop signals from entering the chip.

First, set the standby, shut-off, and power guard options that you want to
allow, using the appropriate Power Calculator pages. Afterwards, return to the
Power Summary page, click the Power Control button to open the Power
Option Controller, and select the elements to be turned off during low-power
operation.
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Figure 115: Power Option Controller for MachX02, MachXO3D,
MachXO3L, MachXO3LFP, and Platform Manager 2
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Power Option Controller

For MachX02, MachXO3D, MachXO3L, MachXO3LFP, and Platform
Manager 2 devices, the Power Option Controller includes the following
options for turning off elements that have been placed in standby mode:

Disable Bandgap — Turns off the Bandgap. When this options is selected,
analog circuitry such as the PLLs, on-chip oscillator, and referenced and
differential 1/0O buffers are also turned off.

Disable POR — Turns off the power-on-reset circuit, which monitors VCC
levels. When the POR circuitry is turned off, limited power detection
circuitry is still active. This option is only recommended for applications in
which the power supply rails are reliable.

Disable OSC — Turns off the on-chip oscillator.
Disable PLL — Turns off the selected phase-locked loop.
The Power Option Controller includes the following dynamic bank options for

MachX02, MachXO3D, MachXO3L, MachXO3LFP, and Platform Manager 2
devices:

Disable InRd — Turns off the referenced and differential input buffers for a
selected bank.

Disable LVDSO — Turns off the LVDS output buffer for a selected bank.

Enable PG — Enables Power Guard for the selected bank.
Standby Mode Power Comparisons

For the low-power MachX02, MachXO3D, MachXO3L, MachXO3LFP, and
Platform Manager 2 devices, Power Calculator estimates the amount of
power used by components that can be placed in standby mode and
compares this usage with non-standby mode. The results are presented in a
comparison chart that you can access from the Edit menu.
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Average Time-Based Power Usage

When you target a MachX02, MachXO3D, MachXO3L, MachXO3LFP, and
Platform Manager 2 device, you will typically be using standby mode, regular
mode, and shutdown mode for various periods of time. Power Calculator
provides an estimate of the average power used, based on the percentage of
time taken by each of these modes. As shown in Figure 117, the comparisons
are presented in a table that you can access from the Edit menu

Figure 116: Standby Mode Comparison Chart

;L;j Power Calculator - Comparison c... l @ LoX
Comparison chart of power (W)

tandby On  Standby Off
Logic Block | . 0000662
Clocks 0.000072 0.000073
I/O 0.000058 0.000059
EFB 0.000006 0.000006
Misc 0.002676 0.031526
Total 0.003466 0.032326

0K l I Help

Figure 117: Time-Based Power Usage Table
/.| Power Calculator - Average power and thermal over time ol X
Average power and thermal over time
Power in Shutdown Mode (P1) mwW Power in Standby Mode (P2) mW Power in Full Power Mode (P3) mW
0.0000 3.4660 32.3260

% of Time Period in Shutdown Mode (T1) | % of Time Period in Standby Mode (T2) | % of Time Period in Full Power Mode (T3)

20

30 50

Average Power over total time period (mwW)

P1*T1+P2*T2+P3*T3

T1+T2+T3

17.2028

Close l I Help
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Non-Integrated Power Calculator

Power Calculator is also available as a non-integrated tool, which you can
launch without opening Diamond. The non-integrated Power Calculator
provides all the same functionality as the integrated version. To open the non-
integrated Power Calculator from the Windows Start menu, select Programs
> Lattice Diamond > Accessories > Power Calculator. The Startup Wizard
enables you to create a new Power Calculator project, based on a selected
device or a processed design, or to open an existing Power Calculator project
file (.pcf).

Lattice also provides a Power Estimator application that is available as a
separate installation. Power Estimator provides the same estimation mode
functionality of Power Calculator and does not require an installation of
Diamond. The Power Estimator Startup Wizard allows you to estimate power
based on a selected Lattice device or based on an existing Power Calculator
project file.

For more information on Power Calculator see Analyzing Power Consumption
in the Lattice Diamond online Help.

ECO Editor

The Engineering Change Order (ECO) Editor enables you to safely make
changes to an implemented design without having to rerun the entire process
flow. Choose Tools > ECO Editor or click the ECO Editor = : button on the
toolbar.

ECOs are requests for small changes to be made to your design after it has
been placed and routed. The changes are directly written into the native
circuit description database file (.ncd) without requiring that you go through
the entire design implementation process.

ECOs are usually intended to correct errors found in the hardware model
during debugging. They are also used to facilitate changes that had to be
made to the design specification because of problems encountered when
other FPGAs or components of the board design were integrated.
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Figure 118: ECO Editor

% £ ECO Editor =Rl X
Eile Edit View Window Help E
a0 Type Name Pin Bank IO_TYPE PULLiv"IODE DRIVE  SLEWRATE PCICLAMP -
1 Input clk A10 0 LVCMOS25 UP NA FAST OFF

2 Input rst A15 1 LVCMOS25 UP NA FAST OFF

3 Output c_down[1] E21 2 LVCMOS25 UP 12 FAST OFF

4 Qutput c_down[2] E22 2 LVCMOS25 UP 12 FAST OFF

5 Output c_up 20] F1 7 LVCMOS25  UP 12 FAST OFF I

6 Output c_down[0] F22 2 LVCMOS25 UP 12 FAST OFF

7 Output c_up_2[2] K20 2 LVCMOS25 UP 12 FAST OFF |

8 Output c_up_2[1] L19 2 LVCMOS25 UP 12 FAST OFF r

9  Output c_up[1] M20 3 LVCMOS25 UP 12 FAST OFF

10 Output c_down_3[1] N19 3 LVCMOS25 UP 12 FAST OFF

11 Output c_down_3[2] N20 3 LVCMOS25 UP 12 FAST OFF

12 Output c_up[2] N21 3 LVCMOS25 UP 12 FAST OFF

13 Output c_up[0] P21 3 LVCMOS25 UP 12 FAST OFF

14 Output c_down_3[0] P22 3 LVCMOS25 UP 12 FAST OFF

15 Output c_down_2[0] P4 6 LVCMOS25 UP 12 FAST OFF

16 Output c_down_2[2] R21 3 LVCMOS25 UP 12 FAST OFF -

o setng [P Frogaring” [ emary iaiation” | Sraivrones WG|
Ready

The ECO Editor includes windows for editing I/O settings, PLL settings, and
memory initialization values. It also provides a Change Log window for you to
track changes between the modified .ncd file and the post-PAR .ncd file.

Note

After you edit your post-PAR, routed .ncd file, your functional simulation and
timing simulation will no longer match.

For more information, see Applying Engineering Change Orders in the Lattice
Diamond online documentation.

Programmer

After you have placed and routed the design and generated the JEDEC or
bitstream file, you can use Diamond’s integrated Programmer to program the
target device. Choose Tools > Programmer. Programmer detects the cable
type, scans the device chain, creates the XCF file, and downloads the data
file to the device. If you wish to program, for example, a dual boot or a merged
hex file into an SPI Flash device, you must first use the Deployment Tool to
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generate the hex file. See “Deploying the Design with the Deployment Tool” in
the Lattice Diamond online Help for information about converting file types
with Deployment Tool.

Figure 119: Programmer

¢} Diamond Programmer - LEDtestxcf = | B
File Edit View Design Help
o SO0 2 S
Enable Status Device Family Device Operation File Name Cable Settings -
1 LatticeECP3 LFE3-35EA éFast Program ...amand_tutorial LEDtest/LEDtest LEDtest.bit

Port: FTUSB-0 -

1/O Settings

@ Use default 1/O settings

) Use custom 1/O settings

Cable and 1/O Settings

Programmer supports serial, concurrent (turbo), and microprocessor
programming of Lattice devices in PC and Linux environments. Device chains
can be scanned automatically using the Programmer graphical user interface.

Programmer is integrated into the Diamond software environment, and is also
available in a standalone version.

Features include:
Scan chain and display chain contents (.xcf file)
Download data files to devices
Create/modify/display .xcf file

Generate files based on the .xcf file (Tcl/command line only)

Programmer uses a Single Document Interface (SDI) where a single .xcf
project is displayed per Programmer instance. Opening additional .xcf files in
Diamond-integrated mode will close the current .xcf and open the specified
xcf.

The main view displays the devices in the current Programmer project
resulting from the Scan action, or from manual creation in a table.

Double-clicking on an uneditable cell or right-clicking and selecting Device
Properties opens a dialog that displays more information about the selected
device. Additionally, some entries may be edited directly on the table by
clicking.
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Columns can be displayed or hidden by choosing View > Columns. The
default columns that are displayed are Process, Status, Device Family,
Device, Operation, File Name, File Date/Time, Checksum, USERCODE, and
Verbose Logging.

Additional columns are available, but are hidden by default. The columns are
Device Vendor, Device Full Name, and Device Description.

The following columns are directly editable from the table:
Enable
Device Family
Device
File Name

Verbose Logging

Some of these columns become uneditable (grayed out) if the selected
operation or other option does not support it. For example, File Name will be
grayed out for a 'Bypass' operation.

Each row has a column enabling the device. Devices where the enable option
is not selected will not be programmed. They will effectively be treated as a
bypass operation. This allows one .xcf file to be used whether programming
all devices in a scan chain or just a single device.

Each row has a column for the device status. The status indicates whether the
operation performed was successful or not. This field is also used for read
back operations to display what is read back if the data to display is short. For
larger data sets that are read back, a dialog box is displayed.

Programmer can also be used as a stand-alone tool. From the Windows Start
menu, choose Programs > Lattice Diamond > Accessories > Diamond
Programmer.

For more information about programming a device with Programmer, see the
“Programming the FPGA” section of the Lattice Diamond online Help.

Soft Error Injection

Ambient radiation occasionally collides with a circuit component in a way that
alters its logical state. This effect is strongest at high altitudes, where the
Earth’s protective electromagnetic field is weaker. SEI (Soft Error Injection)
Editor allows you to generate single-bit errors, insert them into a bitstream,
and detect them for analysis, simulating the effect of radiation damage on the
device’s configuration memory. SEI Editor currently supports the following
devices:

ECP5U
ECP5UM
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SEI Editor is available after you have placed and routed your design and
generated a bitstream.

Running SEI Editor

You can run SEI Editor after you have placed and routed your design and
generated a bitstream.

To run SEI Editor:
Choose Tools > SEI Editor
SEI Editor appears.

Figure 120: SEI Editor
4] SEI Editor (=B e
im

1D SEI File Name Method Block Site Frame Bit In Frame

1 0 simple_adder_sei 0 Unused PFU

SEl can manage multiple errors with a variety of options. The SEI| Editor
toolbar has three buttons:

Run — {: Run all selected error insertions.
Add — i Add a new error for insertion.
Remove — i Remove the selected error insertion.

The SEI Editor has the following columns:

Enable — Select this option to insert the error described on the current
row.

ID — The error's ID number. This value is read-only.

SEIl File name — The name of the file containing the inserted error. You
can modify this filename by double-clicking it and entering a new name.

Method — This option determines whether the error is inserted into an
unused or random block. Selecting Unused inserts the error into an
unused block, which will not affect the design logic. Selecting Random
inserts the error into a random block, which may or may not affect the
design logic. You can change an error's Method by double-clicking it and
selecting a new value from the drop-down menu.

Block — The block where the error was inserted, in one of the following
categories:

PFU
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EBR

DSP

ANY
Routing
Unclassified

You can direct errors into unused PFU, EBR, or DSP blocks, or into a
randomly-chosen unused block. You can change the destination Block by
double-clicking it and selecting a new value from the drop-down menu.

Site — The exact Site of the inserted error. Errors inserted into a Routing
block or Unclassified block do not have a Site. This field is read-only.

Frame — The data frame of the inserted error. This field is read-only.

Bit In Frame — The bit of the inserted error within the displayed data
frame.

For more information about using SEI Editor, see the “Analyzing your Design
using Soft Error Injection” section in the Lattice Diamond online Help.

Deployment Tool

Deployment Tool is a stand-alone tool available from the Diamond
Accessories. The Deployment Tool enables you to convert data files to other
formats and use the data files to generate other data file formats. A four-step
wizard helps you create a new deployment and select the deployment type,
input file type, and output file type.

For more information about using the Deployment Tool, see the “Deploying
the Design with the Deployment Tool” in the Lattice Diamond online Help.

Model 300 Programmer

The Model 300 Programmer is a simple engineering device programmer that
allows you to perform single-device programming directly from a PC or Linux
environment. The Model 300 Programmer hardware and software support all
JTAG devices produced by Lattice, with device Vcc of 1.8, 2.5, 3.3, and 5.0V.
The Model 300 Programmer software controls the programming process. It is
available as a stand-alone tool from the Lattice Diamond Accessories menu.

For more information about using the Using the Model 300 Programmer
software, see the “Using the Model 300 Programmer” section in the Lattice
Diamond online Help.
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Figure 121: Deployment Tool

r Diamend Deployment Tool- C:/my_diamond_tutorial/LEDtest/LEDtest.ddt E@gj
File Edit Help
feall s A= -~ =< = s =
External Memory: Hex Conversion
Step 1 of 4: Select Input File(s)
File Name Device Family Device
1 C/my_diamend_tutorial /LEDtest/LEDtest_L EDtest. bit LatticeECP3 LFE3-35EA
L
Figure 122: Model 300 Programmer
r@ Model 300 Programmer - new model300.job @M’
File Edit View Design Help
I |
Status  Device Family Device Device Package  Model 300 Adapter  Device Full Mame Operation File Mame | Hardware Settings g x
LatticexP2 LFXP2-1TE  484-ball fpBGA  PN-F484/LFXP2  .P2-17E-XXF484 FLASH Erase,Program,Verify  ..p/up2_top_xp2_to Cable Settings
cave

T

<0

Custom port (HEX):

Voltage Selected

Pwr(RDY) Wec{ON) 18V 2.5V 3.3V 5.0V
@ [ e & 6 &

Output

Lattice VM Drivers detected (HW-DLN-3C (Parallel), HW-USBN-24)
Programmer device database loaded

INFO - Detected HuW-USBN-24 cable at port EzUSB-0

Cable Auto Detection Activated.

Mo HW-DLN-3C (parallel) cable detected.

Lattice HW-USBN-2A cable detected.

Mo Lattice HW-USEN-2B (FTDI) cable detected.

INFO - Model300 file opened successfully.

| »

n
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Programming File Utility

The Programming File Utility is a stand-alone tool that allows you to view,
compare, and edit data files. When comparing two data files, the software
generates an output (.out) file with the differences highlighted in red. The
Programming File Utility is a stand-alone tool that is available from the Lattice
Diamond Accessories menu.

Figure 123: Programming File Utility

% Programming File Utility - [C:/test/xp2/fir_eval/xp2/impl/synplify/xp2_top/xp2_top_xp2_top,jed] l == ﬁ]

m File Edit Command Tools Configuration Window Help - | =] %
& Ic

MOTE DEVICE NAME:  LFXP2-17E-7FPEGA484™ -

MOTE PIN ASSIGNMENTS™ =l

MNOTE PINS rfi : N21: out™

MOTE PINS rstn : AB20 : in*

MNOTE PINS dout[37] : U15 : out™
MNOTE PINS dout[36] : ¥14 : out™
MNOTE PINS dout[35] : AA13 : out™
MNOTE PINS dout[34] : N16 : out™
MNOTE PINS dout[33] : AA14 : out™
MNOTE PINS dout[32] : M22 : out™
MNOTE PINS dout[31] : P22 : out™
MNOTE PINS dout[30] : R21: out™
MNOTE PINS dout[29] : N18 : out™
MNOTE PINS dout[28] : P21 : out™
MNOTE PINS dout[27] : T14 : out™
MNOTE PINS dout[26] : T20 : out™
MNOTE PINS dout[25] : T15 : out™
MOTE PINS dout[24] : U12 : out™
MNOTE PINS dout[23] : AA1G : out™
MNOTE PINS dout[22] : R17 : out™
MNOTE PINS dout[21] : AB19 : out™ -
T R doafmed . saAr . s

4 1 (3

For more information about using the Using the Programming File Utility, see
the “Using Programming File Utility” section in the Lattice Diamond online
Help.

Download Debugger

Download Debugger is a stand-alone software tool for debugging Serial
Vector Format (SVF) files, Standard Test And Programming Language
(STAPL) files, and Lattice Embedded (VME) files. Download Debugger allows
you to program a device, and edit, debug, and trace the process of SVF,
STAPL, and VME files.

For more information about using Download Debugger, see the “Debugging
SVF, STAPL, and VME Files” in the Lattice Diamond online Help.

Partition Manager

Partition Manager is the Diamond graphical user interface (GUI) used to
perform such tasks such as preservation data control, re-implementation
effort control, region assignment, and acts as the central interface between
the user and partition database. Partition Manager supports partitioned
designs for both LatticeECP2M and LatticeECP3 devices
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Figure 124: Download Debugger

' ™

Download Debugger - [C/my_diamond_tutorial/LEDtest/Test.svf] l =B gj

S File Edit Command Configuration Window Help =S
-8B H 8 m b % & F & b 60 @ 3 E

. -
! Diamond Rewveal Analyzer SVF

1

! initialize SDR and 5IR end state
ENDCR ILDLE;

ENDIR ILLE;

! initialize Header and Trailer
HDR 0O;

HIR 0O;

TDR 0O;

TIR 0O;

m

! getTargetHubs

! enable ER1

SIR & TDI (32):

! set reveal core
SDR 21 TDI (00014):
! enable ERZ

SIR & TDI (38);:

! enable ERZ

SIR & TDI (38);:

! enable ERZ

SIR & TDI (38);:

! Set 0Odd Parity readback

SDR 36 TDI (c20000000):

SDR 36 TDI (c20000000) TDO (000000000) MASK (FFFFFFFEF);

! enable ERZ
S5IR & TDI (38);

Partition Manager is only available if Incremental Flow is enabled for an
implementation in the project and can be run when the flow is at the pre-Map,
post-Map, or post-PAR stage.

Partition Manager can be used after the post-Map stage to create new
partitions, edit partition information or remove existing partitions. New
partitions can be created for hierarchical modules. You can edit existing
partition information such as partition's preservation data level,
reimplementation effort, anchor and bounding box. Existing partitions can be
deleted and the flow rerun without the deleted partitions.

When a partition’s information has been updated in either Partition Manager
or Floorplan View, the Diamond process is reset to the Translate process.

The GUI for the Partition Manager is in the form of a table. Each row
corresponds to a partition in the project. The columns for each row are for the
partition name, partition source, the preservation data, the reimplementation
effort, the partition anchor and bounding box. All attributes except Partition
Name and Partition Source may be edited.
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Default values are shown in blue. Anchor and bounding box cells are blank if
they are not set for the partition. The top partition module in the project is
always in the first row. A color selection box allows you to change the color of
the partition in as it appears in Diamond Floorplan View.

Figure 125: Partition Manager

[ StartPage [ Reports | €) partition Manager [ | T
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4 iohasic
4 7 Instances: 117
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IF vce

TE clki_pad

IE clkr_pad

IE cikt_pad

4 I compa_inst(CGROUP_compa_inst)
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ZE 12data[0]
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£E r2datal2]
TF r2data[3]
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ZE r2data[5]
£E r2datal6]
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-

Partition Name Partition Source  Preservation Data  Reimplementatio Partition Anchor & BBox  Color

= 1 CGROUP_TOP_MODULE iobasic SYNTHESIS ROUTED UNGUIDED -

2 CGROUP_compa_inst TRANSLATE PLACED GUIDED

Remove Partition | |Discard all Changes Apply

Figure 126: Run Manager

For more information about Partition Manager and incremental design, refer
to “Using Incremental Design Flow” in the Diamond online Help.

Run Manager

Run Manager runs the processes for the different implementation/strategy
combinations. Choose Tools > Run Manager or click the Run Manager &;
button on the toolbar.

Show/Hide Implementation...

[ Export
Set As Active
Show Report

5”3 Run Manager (= M
File Window lim}
0 ions are hidden. Click to configure visible
£ | [ Implementation<Strategy> Current Step ~ Status Mext Step Worst Slack ~ Timing Score  Worst Slack (Hold) Timing Score (Hold) Slice Unrouted Net MNumber Of Signals Number Of Connections
4 [ mixed<Strategyl> N/A Completed N/A 5.366 1] 0.169 [ 14/7584 0 N/A N/A
N/A N/A N/A N/A 5.366 o] 0.169 0 14/7584 0 N/A N/A
=1 N/A N/A N/A N/A 5.952 o] 0141 0 14/784 0 N/A N/A
[E2 N/A N/A N/A N/A 5.486 o] 0.169 0 14/7584 0 N/A N/A
N/A N/A N/A N/A 5392 o 0154 0 14/7584 0 N/A N/A
N/A N/A N/A N/A 5381 0 0154 0 14/7584 0 N/A N/A
4 [/ mixed250<Strategy2> N/A Completed  N/A 2,659 o 0181 0 14/784 0 N/A N/A
N/A Select All ‘A 2659 o] 0.181 0 14/7584 0 N/A N/A
N/A Unselect All ‘A 2849 o] 0154 0 14/7584 0 N/A N/A
N/A A 2697 o 0167 0 14/7584 0 N/A N/A
N/A Ru A 2.819 0 0159 0 14/7584 0 N/A N/A
N/A Rerun A 2726 0 0153 0 14/7384 0 N/A N/A
Pause
— Stop

Run Manager takes the design through the entire process flow for each
selected implementation. If you are running on a multi-core system, Run
Manager will distribute the iterations so that they are executed in parallel. The
options “Maximum number of implementation processes in run manager” and
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“Maximum number of multi-par processes in run manager” are available in the
Environment > General section of the Tool Options dialog box. Choose
Tools > Options to access it. These options enable you to set the maximum
number of processes to run in parallel. Generally, the maximum number of
processes should be the same as the number of cores in your processor; but
if the strategy is using the “Multi-Tasking Node List” option for Place & Route
Design, this number should be set to one.

You can use the Run Manager list to set an implementation as active. Right-
click the implementation/strategy pair and choose Set as Active.

For an implementation that uses multiple iterations of place-and-route, you
can select the iteration that you want to use as the active netlist for further
processes. Expand the implementation list, right-click the desired iteration,
and choose Set as Active. The active iteration is displayed in italics.

To examine the reports from each process, set an implementation as active,
and then select the Reports View.

See the “Managing Projects” section of the Lattice Diamond online Help for
more information about using implementations, strategies, and Run Manager.

Synplify Pro for Lattice

Synplify Pro for Lattice is an OEM synthesis tool used in the Lattice Diamond
design flow. Synplify Pro runs in batch mode when you run the Synthesize
Design step in Process View. To examine the output report, select Synplify
Pro in the Process Reports folder of Reports View.

Figure 127: Synthesis Report
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You can also run Synplify Pro in interactive mode. Choose Tools > Synplify
Pro for Lattice or click the Synplify Pro £ button on the toolbar.

For more information, see the Synplify Pro User Guide, which is available
from the Lattice Diamond Start Page or the Synplify Pro Help menu.

Mentor ModelSim

The Mentor® ModelSim® Lattice FPGA Edition tool is an OEM simulation tool
that is closely linked to the Lattice Diamond environment. It is not run as part
of the Process implementation flow. To run ModelSim, choose Tools >
ModelSim Lattice-Edition or click the ModelSim §g button on the toolbar.

See “Simulation Flow” on page 73 for more information about simulating your
design. See “Simulation Wizard” on page 127 for information about creating a
simulation project to run in ModelSim.

For complete information about ModelSim, see ModelSim’s online
documentation, which is available from the ModelSim Help menu.

Simulation Wizard

The Simulation Wizard enables you to create a simulation project for your
design. To open Simulation Wizard, choose Tools > Simulation Wizard or
click the Simulation Wizard = button on the toolbar. The wizard leads you
through a series of steps that include selecting a simulation project name and
location, specifying the simulator to use (if you have more than one installed),
selecting the process stage to use (from RTL to Post-Route Gate-Level +
Timing), specifying the language (VHDL or Verilog), and selecting the source
files. You can optionally run the simulation directly from the wizard.

Figure 128: Simulation Wizard

7 Simulation Wizard ? *

Simulator Project Name
Enter a name for your simulator project and spedify a directory where the project file will be
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Project name: | simple_sim]| |
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< Back Cancel
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Common Tasks

Lattice Diamond gathers the many FPGA implementation tools into one
central design environment. This gives you common controls for active tools,
and it provides shared data between views.

Controlling Tool Views

Tool views are highly configurable in the Lattice Diamond environment. You
detach a tool view to work with it as a separate window, and you can create
tab groups to display two views side-by-side.

Detaching and Attaching a Tool View

Each Diamond integrated tool view contains a Detach s button in the upper-
right corner that allows you to work with the tool view as a separate window.

After a tool view is detached, the Detach button changes to an Attach
button, which reintegrates the view into the Lattice Diamond main window.

You can detach as many tool views as desired. The Window menu keeps
track of all open tool views and allows you to reintegrate one or all of them
with the main window or detach one of them. Those that are already
integrated are displayed with a check mark.

Figure 129: Window Integrate Tools Menu

Window | Help

Split Tab Group

Merge Tab Group
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Load Default Layout
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Spreadsheet View

You can also use the Integrate All Tools button on the toolbar to dock all
detached views back into the main window.
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Tab Grouping

Lattice Diamond allows you to split one or more active tools into a separate
tab group. You can use the Window menu or the toolbar buttons to create the
tab group and control the display.

Figure 130: Tool Tab Controls
(B

The Split Tab Group button separates the currently active tool into a
separate tab group. Having two separate tab groups enables you to work with
two tool views side-by-side. This is especially useful for dragging and
dropping to make preference assignments; for example, dragging a port from
Netlist View to Package View to assign it to a pin or dragging nets to the
Route Priority preference sheet to prioritize them.

Having two separate tab groups is also useful for examining the same data

element in two different views, such as the Floorplan and Physical View
layouts.

Figure 131: Split Tab Group with Side-by-Side Layout Views
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You can move an active tool view from one tab group to another by dragging
and dropping it, or you can use the Move to Another Tab Group [ button on
the toolbar.

To switch the positions of the two tab groups, click the Switch Tab Group
Position [F] button on the toolbar.

To merge the split tab group back into the main group, click the Merge Tab
Group [R button on the toolbar.
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Figure 132: Split Tab Group with Switched Positions
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Using Zoom Controls

Lattice Diamond includes display zoom controls in the View toolbar. There are
controls for increasing or reducing the scale of the view, fitting the display
contents to the window view area, and fitting a selected area or object to the
window view area.

Displaying Tool Tips

When you place the cursor over a graphical element in a tool view, a tool tip
appears with information on the element. The same information displayed in
the tool tip will also be displayed temporarily in the status bar on the lower left
of the main window.

Setting Display Options

The Options dialog box, which is available from the Tools menu, enables you
to specify general environment options as well as customize the display for
the different tools. Tool options include selections for color, font and other
graphic elements.
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Common Tasks

Figure 133: Tool Options
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Tcl Scripting

This chapter describes the Tcl scripting capabilities in Lattice Diamond. The
internal TCL Console and external TCL Console are described as well as
some of the extended Tcl commands for Lattice Diamond control.

Overview

Tool Command Language (Tcl) is a scripting language used for controlling
software tools and automating tool control and testing. It is very useful for
controlling batch operation of processes. The Lattice Diamond design
environment includes an interactive Tcl Console and extended Lattice
Diamond Tcl commands.

Tcl Console

You can view the integrated Tcl Console by selecting its tab at the bottom of
the Lattice Diamond main window. You can enter “help” at the Tcl prompt to
see the major groups of Tcl commands for Lattice Diamond.

Figure 134: Tcl Console and Command Groups

Tcl Console @

> prj_project open "C:/lscc/diamond/examples/mixedcounter/mixedcounter.ldf"
C:/lacc/diamond/examples/mixedcounter/mixedcounter.ldf

> help

For more information on a specific command, type "help <command>":

»

dte Lattice Diamond Tcl Console extended Tel commands.
prj Project Manager extended Tcl commands.

ncd NCD extended Tcl commands.

ngd NGD extended Tcl commands.

hle HDL Explorer extended Tcl commands.

rvl Reveal Inserter extended Tcl commands.

rva Reveal Enalyzer extended Tcl commands.

pwe Power Calculator extended Tcl commands.

pgr Programmer extended Tcl commands. -

n
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The integrated Tcl Console can be opened, closed, detached, and attached
(using the double-click method).

External Tcl Console

All of the Lattice Diamond Tcl commands that are available in the integrated
Tcl Console can also be used in the external console that is included with the
Lattice Diamond installation. To open the external Tcl Console, go to the Start
menu and choose Lattice Diamond > [ TCL Console. In Linux, enter:
<install_path>/bin/lin/pnmainc.

Select this Tcl Console to run the external Tcl shell. You can enter “help” at the
prompt to see the major groups of Tcl commands for Lattice Diamond. Help
on individual commands is available both in the online Help and from the
“help” command within the console. The console’s help command can be
used to get the top level help, help for a particular dictionary, or help for an
individual command.

Figure 135: Running Commands in an External Tcl Shell
B¥ TCL Console — | ) [

% help -
For more information on a specific command, type “"help <command>":

prj Project Manager extended Tcl commands.

ncd NCD extended Tcl commands.

ngd NGD extended Tcl commands.

hle HDL Expleorer extended Tcl commands.

rul Reveal Inserter extended Tcl commands.

sbp System builder planner extended Tcl commands.

rva Reveal Analyzer extended Tcl commands.

pwe Power Calculator extended Tcl commands.
il pgr Programmer extended Tcl commands. .
icf Incremental Design Flow Database extended Tcl commands.
cmp Compile Lattice FPGA simulation libraries.

m

To use an existing Tcl script file use “source <script_file>.tcl”. To save
commands in the Tcl Console to a script file use “save_script <script_file>.tcl”.

See “Tcl Scripts” on page 144 for more information on writing Tcl scripts.

Running a Tcl Script When Launching Diamond You can use a
command line shell to launch the Diamond software and automatically run a
Tcl script. Your Tcl script can be standard Tcl commands as well as Diamond-
specific Tcl commands.

To launch Diamond and run a Tcl script:

In the Tcl console or other command line shell, enter the following
command:

On Windows:
pnmain.exe -t<tcl path file>

On Linux:
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Commands

diamond -t<tcl path file>

Sample Diamond Tcl Script  The following simple Tcl script, running in
Windows, opens a project and runs the design flow through the MAP process.

prj project open C:/test/iobasic _diamond/iol.ldf
prj run Map -impl iol

The above example is saved in Windows as the file mytcl.tcl in the directory
C:/test. By running the following command in a DOS shell or the Tcl console in
Windows, the Diamond GUI starts, the project i01.Idf opens, and the MAP
process automatically runs.

pnmain.exe -tc:/test/mytcl.tcl

Every function available in the user interface is available to you as part of the
extended Tcl commands for Lattice Diamond. You can create scripts to run
design flow processes and manage project data as well as perform all
standard Tcl operations.

The help command (help) is very useful for getting listings of available
commands and their syntax.

> help

For more information on a specific command, type "help <command>":

dtc Lattice Diamond Tcl Console extended Tcl commands
prj Project Manager extended Tcl commands

ncd NCD extended Tcl commands

ngd NGD extended Tcl commands

hle HDL Explorer extended Tcl commands

rvl Reveal Inserter extended Tcl commands

rva Reveal Analyzer extended Tcl commands

pwc Power Calculator extended Tcl commands

pgr Programmer extended Tcl commands

icf Incremental Design Flow Database extended Tcl commands
cmp Compile Lattice FPGA simulation libraries

The following sections show the help command and output for each major
grouping of the Lattice Diamond extended Tcl commands. You can use the
help command for more information on each specific group or command. See
“Tcl Scripts” on page 144 for more information on writing Tcl scripts.

Lattice Diamond Tcl Console

> help dtc

Lattice Diamond Tcl Console extended Tcl commands:

history: Shows the commands history
reset: Reset History and clear up console
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clear: Clear up console

save_ script: Saves a script of executed commands
Usage: save_ script <script name>

set prompt: Set a new prompt

Usage: set prompt <newPrompt>

Project Manager

> help prj

Project Manager extended Tcl commands. For more information on a specific
command, type hlp <command-name>:

prj project Project commands to manipulate project

prj src Project source commands to manipulate project
sources

prj impl Project implementation commands to manipulate
implementation

prj strgy Project strategy commands to manipulate
strategies

prj _run Project flow running command to run a flow
process

prj syn Project synthesis tool commands to list or set
synthesis tool

prj dev Project device commands to list or set the

device used in the project

NCD

> help ncd

NCD extended Tcl commands. For more information on a specific command,
type the command without any options:

ncd port NCD port command

ncd inst NCD instance command
ncd net NCD net command

ncd attr NCD attribute command

NGD

> hlp ngd

NGD extended Tcl commands. For more information on a specific command,
type the command without any options:

ngd port NGD port command

ngd inst NGD instance command
ngd net NGD net command

ngd attr NGD attribute command
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Reveal Inserter

> help rvl

Reveal Inserter extended Tcl commands. For more information on a specific
command, type hlp command-name:

rvl project
project

rvl core
project

rvl trace RVL trace commands to manipulate trace signals
and optins for a debug core in current project

rvl tu RVL trigger unit commands to manipulate trigger
units for a debug core in current project

rvl te RVL trigger expression commands to manipulate
trigger expressions for a debug core in current project

rvl tokenmgr RVL token manager commands to manipulate tokens
in current project

RVL project commands to manipulate reveal insert

RVL core comands to manipulate cores in current

Reveal Analyzer

> help rva

Reveal Analyzer extended Tcl commands. For more information on a specific
command, type hlp command-name:

trace commands
core commands
tu commands

Reveal Analyzer
Reveal Analyzer
Reveal Analyzer
Reveal Analyzer te commands

Reveal Analyzer trigger options
Reveal Analyzer project commands

rva trace
rva_ core

rva tu

rva te

rva_ trigoptn
rva_project

Power Calculator

> help pwc

Power Calculator extended Tcl commands. For more information on a specific
command, type hlp command-name:

Power Calculator command commands
Power Calculator device command
Power Calculator parameters command

pwc_command
pwc device
pwc parameters

pwc_thermal Power Calculator thermal command
pwc_settings Power Calculator settings command
pwc_supply Power Calculator supply command
pwc_logicblocks Power Calculator logicblocks command
pwc_clocks Power Calculator clocks command
pwc_inout Power Calculator inout command
pwc_blockram Power Calculator blockram command
pwc _dspblock Power Calculator dspblock command
pwc_plldll Power Calculator plldll command
pwC_maco Power Calculator maco command
pwc_serdes Power Calculator serdes command
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pwc_writereport Power Calculator writereport command
pwc_efb Power Calculator efb command

pwc_misc Power Calculator misc command
pwC_power Power Calculator power control command
> help pgr

Programmer extended Tcl commands. For more information on a specific
command, type help command-name:

pgr_project Programmer project commands
pPgr program Programmer program commands

Incremental Design Flow

> help icf

Incremental Design Flow Database extended Tcl commands. For more
information on a specific command, type hlp command-name:

icf data Commands to load or save the partition info for
Incremental Design

icf part Set options on partition

Compile Lattice FPGA Simulation
Libraries

> help cmp
Compile Lattice FPGA simulation libraries. For more information, type the
following command without any options:

> cmpl libs

Tcl Scripting From Command-Line Shells

Lattice Diamond Tcl Scripts can also be run directly from a command-line
shell such as DOS or bash. For this to be accomplished, certain environment
variables need to be set up and a Tcl script created.
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Lattice Diamond Example Tcl Script

The following example shows a Tcl script created for implementing an existing
project:

prj project open "C:/example path name/file name.ldf"
prj run Synthesis -impl cardgameFPGA

prj run Translate -impl cardgameFPGA

prj run Map -impl cardgameFPGA

prj run PAR -impl cardgameFPGA

prj run PAR -impl cardgameFPGA -task PARTrace

prj run Export -impl cardgameFPGA -task Bitgen

prj project close

DOS Script for Running Lattice
Diamond Tcl Script

To run the Lattice Diamond Example Tcl script in a Windows DOS shell, the
commands from the following DOS script need to be entered:

set LSC_INI PATH=

set LSC_DIAMOND=true

set TCL_LIBRARY=C:\lscc\diamond\3.I1\tcltk\lib\tcl8.5

set FOUNDRY=C:\lscc\diamond\3.1\ispFPGA

set PATH=%FOUNDRY%\bin\nt;%PATH%
C:\1lscc\diamond\3.1\bin\nt\pnmainc.exe project.tcl > output.txt

The DOS script assumes that the default directory installation is used for the
Lattice Diamond software. If the software is installed into a different directory,
the script will need to be modified.

Bash Script for Running Lattice
Diamond Tcl Script on Windows

Similar to the DOS script, the following example shows how to run a Lattice
Diamond Tcl in a Cygwin bash shell on Windows:

export TEMP=/cygdrive/c/TEMP

export LSC_TINI PATH=""

export LSC DIAMOND=true

export TCL LIBRARY=/cygdrive/c/lscc/diamond/3.1/tcltk/lib/
tcl8.5

export FOUNDRY=/cygdrive/c/lscc/diamond/3.1/ispFPGA

export PATH=SFOUNDRY/bin/nt:S$PATH
/cygdrive/c/lscc/diamond/3.1/bin/nt/pnmainc.exe project.tcl >
outputl.txt

Like the DOS script, the bash script assumes that the default directory
installation is used for the Lattice Diamond software. If the software is
installed into a different directory, the script will need to be modified.
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Bash Script for Running Lattice
Diamond Tcl Script on Linux

Lattice Diamond software is supported on Linux also. The following is an
example for running the Lattice Diamond Tcl script example in a Linux bash
shell:

export TEMP=/tmp

export LSC INI PATH=""

export LSC_DIAMOND=true

export TCL LIBRARY=/usr/local/lscc/diamond/3.1/tcltk/1lib/tcl8.5
export FOUNDRY=/usr/local/lscc/diamond/3.1/1ispFPGA

export PATH=$FOUNDRY/bin/nt:$PATH
/usr/local/lscc/diamond/3.1/bin/lin/diamondc project.tcl >
outputl.txt

As in the previous examples, the Linux example assumes that the default
directory installation is used for the Lattice Diamond software. If the software
is installed into a different directory, the script will need to be modified.
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Advanced Topics

This chapter explains advanced concepts, features and operational methods
for Lattice Diamond.

Shared Memory Environment

The Lattice Diamond design environment uses a shared memory architecture.
Shared memory allows all internal tool views to access the same image of the
design at any point in time. Understanding how shared memory is being used
can give you insight into managing the environment for optimum
performance, especially when your design is large.

There is one shared database that contains the device, design, and
preference information in system memory.

Generating the hierarchy of your design uses an additional database separate
from the main shared memory database.

External tools referenced from within Lattice Diamond, such as those for
synthesis and simulation, use their own memory in addition to what is used by
Lattice Diamond.

When you launch the first tool view that accesses shared memory, it will take
longer than the launch of subsequent views.
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Memory Usage

The main window of the Ul displays a memory usage figure in the lower right
corner.

Figure 136: Memory Usage
Mem Usage: 235,148 K

This indicates the current memory usage for the Lattice Diamond
environment, including all open tools.

Clear Tool Memory

The “Clear Tool Memory command, available from the Tools menu, clears the
device, design, and preference information from system memory. Clearing the
tool memory can speed up memory-intensive processes such as place and
route. When your design is very large, it is good practice to clear memory
prior to running place and route.

If you have open tool views that will be affected by clearing the tool memory, a
confirmation dialog box will open to give you the opportunity to cancel the
memory clear.
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Environment and Tool Options

Environment and Tool Options

Lattice Diamond provides many environment control and tool view display
options that enable you to customize settings. Choose Tools > Options to
access these options.

Figure 137: Environment and Tool Options
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The Options dialog box is organized into functional folders. You can use the
context-sensitive help button in the upper right to view information about
each parameter in a folder. Click the context-sensitive help button, and then
click the item of interest.

Figure 138: Context-Sensitive Help Information
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Commonly configured items include:

Environment > General > Automatically Generate Hierarchy — Runs the
Generate Hierarchy function whenever a project is opened.

Environment > Startup — Enables you to configure the default action at
startup and also to control the frequency of checking for software updates.
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Environment> File Associations — Allows you to set the programs to be
associated with different file types based on the file extensions.

The tool view folders include customizable display properties such as color
and font.

Pin Migration

The “Incompatible Pins” dialog box helps you migrate pin assignments to a
different device of the same family and package. This information enables you
to save your current pinout while you explore other devices.

Figure 139: Incompatible Pins Dialog Box
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The “Incompatible Pins” dialog box is available from the View menu in
Spreadsheet View or Package View after the Translate Design process. After
selecting one or more devices for possible pin migration, you can view the
incompatible pins in Package View and in the Pin Assignments sheet of
Spreadsheet View.

For more information about pin migration, refer to “Migrating Pin
Assignments” in the Lattice Diamond online Help.
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Batch Tool Operation

Tcl Scripts

The core tools in the FPGA implementation design flow can all be run in batch
mode using command-line tool invocation or scripts. For detailed information,
see the Command Line Reference Guide, available from the Lattice Diamond
Start Page.

The Diamond Extended Tcl language enables you to create customized
scripts for tasks that you perform often in Lattice Diamond. Automating these
operations through Tcl scripts not only saves time, but also provides a uniform
approach to design. This is especially useful when you try to find an optimal
solution using numerous design implementations.

Creating Tcl Scripts from Command
History

A good first step in Tcl programming is to create a Tcl script by saving some
command history and then modifying it as needed. This allows you to get
started by using existing command information.

To create a Tcl command script using command history:

1. In the Tcl Console window, first perform a reset command so that your
script won’t contain any of the actions that may have already executed.

reset
2. Now perform the commands that you want to save as a script.

3. Optionally, enter the history command in the Tcl Console window to
ensure that the commands you wish to save are in the console’s memory.

4. In the Tcl Console window, type:
save script <script name>

where <script_name> is any identifier that has no spaces and contains no
special characters except underscores. For example, myscript or
design_flow_1 are acceptable script name values, but my$script and my
script are invalid.

It is possible to give your <script_name> value a file path and name if you
want to keep it in a sub-folder in your project or in a folder where you
generally keep your scripts. However, you must save it to an existing
folder. File paths, using forward slashes, with an identifier are valid if using
an absolute file path to an existing folder.

5. Navigate to your script file and use the text editing tool of your choice to
make any necessary changes, such as deleting extraneous lines or
invalid arguments.
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In most cases, you will need to edit the script you saved and take out any
invalid arguments or any commands that cannot be performed in the Lattice
Diamond environment due to a conflict or exception. You will need to revisit
this step later if, after running your script, you experience any run errors due
to syntax errors or technology exceptions.

Creating Tcl Scripts from Scratch

Tcl commands can be written directly into a script file. You can use any text
editor, such as Notepad or vi, to create a file and type in the Tcl commands.

Sample Tcl Script

The following Tcl example shows a simple script that opens a project, runs the
entire design flow through the Place & Route process, and then closes the
project. A typical script would probably contain more steps, but you can use
this example as a general guideline.

prj project open "C:/lscc/diamond/edif counter/edif.ldf"
prj run PAR -impl edif -forceAll
prj project close

Running Tcl Scripts

You can run scripts from the Lattice Diamond integrated Tcl Console whether
your project is opened or not. You can also run scripts from the external Tcl
Console prompt window. The following example procedure uses the
integrated Tcl Console and the sample Tcl script from the previous section:

To run a Tcl script that opens a project, runs processes and closes the
project:

1. Open Lattice Diamond but do not open your project. If your project is
open, choose File > Close Project.

2. In the Diamond main window, click the Tcl Console tab at the bottom to
open the console.

3. Ifthere are previously issued commands in the console, type reset in the
console command line to refresh your session and clear out all previous
commands.

4. Run the source command using the absolute file name and path to your
script.

source C:/lscc/diamond/1.4/examples/edif counter/myscript?2

The sample Tcl script opens the project, runs the flow through Place &
Route, and closes the project.
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As long as there are no syntax errors or invalid arguments, this procedure
should open your project, and you should see the processes running to
completion.

If there are errors in the script, you will see the errors in red in the Tcl Console
after you attempt to run it. You will then need to return to your script and edit it
as needed.

Project Archiving

A Diamond project archive is a single compressed file (.zip) of your project.
The project archive can contain all of the files in your project directory, or it
can be limited to source-related files. When you use the File > Archive
Project command, the dialog box provides the option to “Archive all files
under the Project directory.” When you select this option, the entire project is
archived. When you clear this option, only the project’s source-related files,
including strategies, are archived. Many of these source-related files must be
archived in order to achieve the same bitstream results for a fully
implemented design.

Whichever archiving method you select, if your project contains source files
stored outside the project folder, the remote files will be compressed under
the remote_files subdirectory in the archive; for example:

<project_name>/remote_files/sources
<project_name>remote_files/strategies

When unarchiving, you must manually move the archived remote files to the
original locations or the project will not work.

Appendix A “File Descriptions” on page 147 provides lists of the file types
used in Diamond, including those generated during design implementation.
The Archive column indicates the files that must be archived in order to
achieve the same bitstream results.
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File Descriptions

The following tables describe many of the files that are used in Lattice
Diamond, including files generated by the implementation processes. A check
mark in the Archive column indicates that a file of this particular type, when
used in implementing the design, must be included in the project’s archive in
order to create the same bitstream results.

Table 1: Source Files

File Type
.edf

.edn

fdc

.ipx

dc

Adf

lib

Isdc

Definition Function Archive?
Default EDIF source file generated by  Used in design translation to create the .ngd J
Precision netlist.

Default EDIF source file generated by  Used in design translation to create the .ngd J
Synplify netlist.

FPGA Design Constraint file Used for specifying design-specific constraints

for SynplifyPro or Precision synthesis tools. FDC J
replaces the legacy SDC format.

Manifest file generated by IPexpress.  Enables changes to be made to a module or IP
IPexpress.

SDC constraints file Used for specifying design-specific constraints
for the Lattice Synthesis Engine (LSE).

Diamond Project file Used for managing and implementing all project
files in Diamond.

Schematic symbol library Used for adding symbols to a schematic source
file.

Diamond project logical preference file Stores logical constraints for developing and
implementing the design.

SDC constraints file for Lattice Used for specifying design-specific constraints.
Synthesis Engine (LSE)

Al A A A A A
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Table 1: Source Files (Continued)

File Type

.mem

.ngo

.pcf

.ptm

.rva

vl

.sch

.sdc

.spf

sty

.sym

tpf

.vhd

.wdl

xcf

Definition

Memory Generator source file

Native Generic Object (NGO) netlist
format
Power Calculator project file

Platform Designer project file

Reveal Analyzer file

Reveal Inserter debug file

Schematic source file

SDC constraints file

Simulation project file, a script file
produced by the Simulation Wizard

Strategy file

Symbol Editor source file

Timing Analysis Preference file

Verilog source file

VHDL source file

Waveform Editor source file

Configuration chain file

Function

Specifies the initial contents for the memory
modules in your design. Required for creating
ROM and optional for creating RAM modules.

Used as an alternative to HDL for creating a
black-box module.

Stores power analysis results from information
extracted from the design project.

Holds analog sense and control settings, logic,
and port information, for the project.

Defines the Reveal Analyzer project and
contains data about the display of signals in
Waveform View.

Defines the Reveal project and its modules,
identifies the trace and trigger signals, and
stores the trace and trigger options.

Schematic representation of the circuit in terms
of the components used and how they connect
to each other.

Used for specifying design-specific constraints
for Synplify Pro or Precision synthesis tools.
SDC is replaced by the FDC format in but is still
supported in Diamond.

Used for running the simulator for your project
from Diamond.

Defines the optimization control settings of
implementation tools such as logic synthesis,
mapping, and place and route.

Used for creating symbols or primitive elements
that represent an independent schematic
module.

Used for obtaining quick analysis of timing
preferences.

Verilog description of the circuit structure and
function.

VHDL description of the circuit structure and
function.

Used for creating test stimulus files for
simulation.

Used for programming devices in a JTAG daisy
chain.

Archive?
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Table 2: IPexpress Files

File Type
Module Files

%instName.Ipc

%instName.v

%instName.vhd

%instName_tmpl.v

%instName_tmpl.vhd

tb_%instName_tmpl.v

tb_%instName_tmpl.vhd

IP Files

%instName.lpc

%instName_bb.v

%instName_beh.v

%instName_inst.v

%instName_inst.vhd

%instName.ngo

pmi_*.ngo

Definition

Module parameter configuration
file

Verilog module file

VHDL module file

Verilog template file

VHDL module template file

Verilog testbench template

VHDL module testbench file

IP parameter configuration file

Verilog IP black box file

Verilog IP behavioral file

Verilog IP instantiation file

VHDL IP instantiation file

IP database file

Support database files

Function

Stores the user configurations for the
module.

Verilog netlist generated by IPexpress to
match the user configuration of the
module.

VHDL netlist generated by IPexpress to
match the user configuration of the
module.

Atemplate for instantiating the generated
module. This file can be copied into a
Verilog file.

A template for instantiating the generated
module. This file can be copied into a
VHDL file.

A simple Verilog testbench for the
generated module. Can be edited to add
more vectors, which will be overwritten
during module regeneration.

A simple VHDL testbench for the
generated module. Can be edited to add
more vectors, which will be overwritten
during module generation.

Used for recreating or modifying the core
in the IPexpress tool.

Provides the Verilog synthesis black box
for the IP core and defines the port list.

Provides a behavioral simulation model
for the IP core.

Provides a Verilog instance template for
the IP core.

Provides a VHDL instance template for
some IP cores. Archiving this file, though
optional, will make it easier to write a top-
level VHDL file and copy and paste the
instantiation section from this file.

Provides the netlist in encrypted format
for the IP core and is used by Map and
PAR tools.

Provides the netlist files in encrypted
format for the Lattice parameterizable
module instances (PMI) used within the
IP core.

Archive?
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Table 2: IPexpress Files (Continued)

File Type

%IPName_params.v

* ixt

Definition

IP parameters file

SERDES configuration file

Table 3: Implementation Files

Function

Archive?

Contains the Verilog parameters used by J

the IP core simulation model.

Contains the SERDES configuration that J

is required during bitgen process.

File Type Definition Function Archive?

.bgn Bitstream generation report file Reports results of a bit generation (bitgen) run
and displays information on options that were
set.

.bit Bitstream file Used for SRAM FPGA programming.

.edi SynplifyPro EDIF output file Netlist file generated by Diamond. The file
extension must be changed to .edf or .edn in
order to import it into a project.

.ibs Post-Route 1/0 buffer information Used for analyzing signal integrity and

specification file (IBIS) electromagnetic compatibility (EMC) on
printed circuit boards

.ior Post-PAR 1/0 Timing Analysis file For each input data port, reports setup and
hold time requirements and min/max clock-to-
out delay for each output port.

Jjed JEDEC file Used for Flash FPGA programming.

_map.ncd Mapped native circuit description netlist  Includes mapping information.

file

_mapvho.sdf Post-map SDF simulation file for VHDL Used for post-map functional simulation.

_mapvho.vho Post-map simulation file for VHDL Used for post-map functional simulation.

_mapvo.sdf  Post-map SDF simulation file for Verilog  Used for post-map functional simulation.

_mapvo.vo Post-map simulation file for Verilog Used for post-map functional simulation.

.mcs PROM file Used for SRAM FPGA programming

.mrp Map Report file Provides statistics about component usage in
the mapped design.

.ncd Post-route native circuit description netlist Includes placement and routing information.

file

.ngd Native generic description file produced  Used by Map to map logical elements to

by the ngdbuild translation process. physical elements in the native circuit
description file (.ncd).

.ngo Native generic object file generated by Used as input to ngdbuild, which converts the

the edif2ngo translation process. .ngo to an .ngd file.
Contains logical descriptions of the
design’s components and hierarchy.
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Table 3: Implementation Files (Continued)

File Type Definition

.pad Post-Route PAD report file

.par Post-Route Place & Route report file

.prf Physical preference file produced by the
Map Design process

.SSO Post-PAR SSO analysis file

w1 Post-Map TRACE analysis file

Awr Post-PAR TRACE analysis file

.vho Post-Route VHDL simulation file

.vOo Post-Route Verilog simulation file

_vho.sdf Post-Route SDF simulation file for VHDL

_vo.sdf Post-Route SDF simulation file for Verilog

Table 4: Incremental Design Flow Files

File Type  Description

icf Incremental Compilation Database File
\inc1\* First backup of incremental files

\inc2\* Second backup of incremental files
\golden\* Golden backup of incremental files

Function Archive?

Lists all programmable 1/O cells used in the
design and their associated primary pins.

Summarizes information from all iterations
and shows the steps taken to achieve a
placement and routing solution.

Used as an input file to placement, routing
and TRACE.

Reports the noise caused by simultaneously
switching outputs.

Estimates pre-route timing.
Reports post-route timing.
Used for post-route simulation.
Used for post-route simulation.
Used for timing simulation.

Used for timing simulation.

Function Archive?

Contains design partition placement and
compilation strategy directives for incremental
design flow.

v
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REVISION HISTORY

Revision History

The following table gives the revision history for this document.

Date Version Description

08/18/2023 3.13 Updated to reflect changes in Diamond 3.13.
10/19/2021 3.12 SP1  Added support for MachXO3LFP.
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