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Glossary
A glossary of terms used in this document.
Terms Definition
ASCII American Standard Code for Information Interchange.
BSP Board Support Package, the layer of software containing hardware-specific drivers and libraries to function
in a particular hardware environment.
DUT Design Under Test.
CDT C/C++ Development Tools.
CPU Central Processing Unit.
GUI Graphical User Interface.
FPGA Field Programmable Gate Array.
HDL Hardware description language.
IBIS Input Output Buffer Information System.
IDE Integrated Development Environment.
IP Intellectual Property.
JEDEC Joint Electron Device Engineering Council.
0oCD On-Chip-Debugging.
OEM Original Equipment Manufacturer.
OpenOCD Open On-Chip Debugger.

Perspective

A group of views and editors in the Workbench window.

A tool can program Lattice FPGA SRAM and external SPI Flash through various interfaces, such as JTAG, SPI,

Programmer and I2C.

RISC.V Reduced Instruction Set Computer-V. A free and open instruction set architecture (ISA) enabling a new era
of processor innovation through open standard collaboration.

RISC-V MC Lattice RISC-V for Micro-Controller Soft IP.

SDK Software Development Kit. A set of software development tools that allows the creation of applications for
software package on the Lattice embedded platform.

SoC System-on-Chip. An integrated circuit that integrates all components of a computer or other electronic
systems.

SRAM Static Random Access Memory.

UART Universal Asynchronous Receiver/Transmitter.

ul User Interface.

UFM User Flash Memory.

VHDL Very-High-Speed Integrated Circuit Hardware Description Language.

Workspace The fiirectory whgre stores your work, it is used as the default content area for your projects as well as for
holding any required metadata.

Workbench Refers to the desktop development environment in Eclipse IDE platform.
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1. Introduction

Lattice Propel™ is a complete set of graphical and command-line tools to create, analyze, compile, and debug both
FPGA-based hardware and software processor systems.

1.1. Purpose
Embedded system solutions play an important role in FPGA system design allowing you to develop software for a
processor in an FPGA device. It provides flexibility for you to control various peripherals from a system bus.

To develop an embedded system on an FPGA, you need to design the System-on-Chip (SoC) with an embedded
processor and develop system software on the processor. Lattice Propel helps you develop your system with a RISC-V
processor, peripheral IP, and a set of tools.

The purpose of this document is to introduce Lattice Propel SDK tool and flow to help you quickly get started to build a
small demo system. You can find recommended flows of using Lattice Propel SDK in this document as well.

1.2. Audience

The intended audience for this document includes embedded system designers and embedded software developers
using Lattice FPGA devices. The complete list of supported devices can be found at Lattice Propel Release Notes. The
technical guidelines assume readers have expertise in the embedded system area and FPGA technologies.
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2. Lattice Propel Development Suite

Lattice Propel development suite includes:
e anintegrated development environment (IDE), which is the framework of Propel;
e Lattice Propel Builder, which is for SoC design;

e Lattice Propel SDK, which is for system software development.

2.1. Eclipse IDE

Eclipse IDE provides the Propel development suite a platform to manage the SoC project and the Embedded C/C++
Project in the same workspace.

The SoC project, which extends from the Propel Builder project, provides easy interaction with other Lattice design
tools, such as Lattice Diamond® within Propel.

The Embedded C/C++ Project provides a platform for developing or debugging application code within Eclipse IDE. The
project can be created directly from the SoC project with a pre-set Board Support Package (BSP) and applications by
using Propel development suite.

2.2. Lattice Propel Builder

Lattice Propel Builder allows you to assemble the larger functional blocks of the design hierarchy. Propel Builder
enables you to instantiate modules and IP from the IP Catalog in a schematic view, and can easily connect the modules.
Propel Builder also helps you customize address spaces within modules, such as a processor. In Propel development
suite, Propel Builder is used to create a microprocessor integrated platform for both hardware and software
development.

Refer to Lattice Propel 2022.1 Builder User Guide (FPGA-UG-02177) for more detailed information.

2.3. Lattice Propel SDK

Lattice Propel SDK is based on Eclipse Embedded C/C++ Development Tools (CDT). It allows you to create, build, and
debug software application projects that drive the platform within the Eclipse framework.

The main features are:
e Create, build, debug, or manage embedded applications for Lattice RISC-V CPU/SoC solution.
e  Provide extra build steps to generate the binary and memory files required for deployment.

e  Build using the latest industry standard open source components and tools for RISC-V firmware development and
debugging.

e Support Picolibc for RISC-V, and provide lightweight standard library implementation.

e  Provide fully-configurable toolchain definitions.
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3. Lattice Propel Tool Flows

The Propel tool flows including SoC project design flow, C/C++ project design flow, system simulation flow, and
programming and On-Chip-Debugging (OCD) debugging flow, are discussed in detail in the following sections.

3.1. Propel Environment

3.1.1. Running Lattice Propel

After installing Lattice Propel, you can launch Propel from the desktop shortcut icon or from the Windows Start menu.
When Propel is invoked, a dialog (Figure 3.1) pops up. You can browse to select where to locate the workspace. For
normal needs, just click Launch to pick the default location and continue running Propel.

Q Lattice Propel Launcher ¥

Select a directory as workspace

Lattice Propel uses the workspace directory to store its preferences and development artifacts.

Workspace: | w Browse...

[[J Use this as the default and do not ask again

» Recent Workspaces

Figure 3.1. Select Workspace Dialog

After the workspace location is chosen, a single workbench window is displayed using default Propel SDK perspective.
The default Propel SDK perspective contains following five functional areas (Figure 3.2).

1. Menu bar and Toolbar.
Project Explorer view: displays projects in the workspace.
Editor view: provides capability of editing source files.

Outline view: displays an outline of a file that is currently open in the editor area.

vk W

Log area includes these views: Problem view, Tasks view, Console view, Properties view, and Terminal view.
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| £t workspace - Lattice Propel - O * |

File Edit 5Scurce Refactor MNavigate Search Project Run  LatticeTools Window Help

B HE S R g8 E- @ k-0 Q@S - HE1IDSOIRP - F D[

Project Explorer &2

BESYT &

There are no projects in your workspace.
To add a project:

There is no active editor that
provides an outline.

Create a new Lattice 5oC Design
Project

Q Create a new Lattice C/C++ Project
rﬁ Create a project...
Ex3 lmport projects...

[T Properties | & Terminal

Mo consoles to display at this time.

Figure 3.2. Propel Workbench Window

3.1.2. Importing General Projects

In Propel SDK, you can use the importing project wizard to import existing projects into workspace except for Lattice
SoC design created by Lattice Propel Builder.

Note: You can only import projects which are created or managed by Propel SDK by choosing General > Existing Project
into Workspace in Propel SDK.

1. In Lattice Propel (SDK), choose File > Import....
The Select wizard opens (Figure 3.3).

© 2022 Lattice Semiconductor Corp. All Lattice trademarks, registered trademarks, patents, and disclaimers are as listed at www.latticesemi.com/legal.
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Q Import

Select

Create new projects from an archive file or directory.

Select an import wizard:

| type filter text

w = General
& Archive File
1= Existing Projects into Workspace
[ File System
[T Preferences
[ Projects from Folder or Archive
» [= CfC++

®

Einish Cancel

Figure 3.3. Import Projects Wizard — General

2. Select General > Existing Project into Workspace. Click Next.

The Import wizard switches to Import Projects wizard (Figure 3.4).

© 2022 Lattice Semiconductor Corp. All Lattice trademarks, registered trademarks, patents, and disclaimers are as listed at www.latticesemi.com/legal.
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2 Import O X
Import Projects o
Select a directory to search for existing Eclipse projects. { /
|
(®) Select root directory: | D:\J V| Browse...
() Select archive file: Browse...
Projects:
test (D:\test) Select All
Deselect All
Refresh
Options
[]5earch for nested projects
I Copy projects into workspace I
[]Close newly imported projects upon completion
[ Hide projects that already exist in the workspace
Working sets
[] Add project to working sets MNew...
Select...
?\' < Back Mext » Cancel
Figure 3.4. Import Existing Projects Wizard
3. Choose either Select root directory or Select archive file, clicking the associated Browse button to locate the

directory or file containing the project.

Select the project or projects you want to import in the Projects area.

Click Finish to start the importing process.

3.1.3. Importing Lattice SoC Design Projects

Be sure to check the Copy projects into workspace option so that your original projects do not get updated.

In Propel SDK, you can use the Import Wizard to import Lattice SoC design projects into workspace. Existing SoC design
projects created by either Propel SDK or Propel Builder can also be imported into Workspace by choosing Lattice
Propel > Lattice SoC Design Projects.

1. From Lattice Propel SDK, choose File > Import....
The Select wizard opens (Figure 3.5).
© 2022 Lattice Semiconductor Corp. All Lattice trademarks, registered trademarks, patents, and disclaimers are as listed at www.latticesemi.com/legal.
All other brand or product names are trademarks or registered trademarks of their respective holders. The specifications and information herein are subject to change without notice.
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2. Select Lattice Propel > Lattice SoC Design Projects into Workspace. Click Next.

Q Import

Select
Import Lattice SoC Design projects into the workspace.

Select an import wizard:

| type filter text

= General
= C/C++
= Git
= Install
~ (= Lattice Propel
o Lattice SoC Design Projects into Worksapce
= Oomph
= Run/Debug

®

Finish

Cancel

Figure 3.5. Import Projects Wizard — Lattice Propel

The Select wizard switches to Import Lattice SoC Design Projects wizard page (Figure 3.6).

7% Import O d
Import Lattice SoC Design Projects
Select a directory to search for existing Eclipse projects.
Select root directory | D ~ Browse...
Projects:
SoC_demo (DASaC_dema) Select All
Deselect All
Refresh
® < Back Mext » Cancel

Figure 3.6. Import Lattice SoC Design Projects Wizard

3. Locate the directory containing the projects by clicking the Browse button.

In Projects area, select the SoC design project or projects you want to import.

5. Click Finish to start the importing process.

© 2022 Lattice Semiconductor Corp. All Lattice trademarks, registered trademarks, patents, and disclaimers are as listed at www.latticesemi.com/legal.
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3.2. SoC Project Design Flow

A new SoC design project including a Propel Builder design can be started from the Lattice Propel sets. Follow the steps

below to create a new SoC design project.

3.2.1. Creating a SoC Design Project

To start a Lattice SoC Design Project from Propel:

1. In Lattice Propel, choose File > New > “ Lattice SoC Design Project. The Create SoC Project wizard opens

(Figure 3.7).
7% SoC Project O x
Create SoC Project —
Create SoC project of selected template
Project name: | ExampleSoC
Use default location
Chlscchpropel\,  \workspace\ExampleSoC Browse...
default
Template selection
Processor: | RISC-V MC ~ | Family: MachXO3D ~
Device: LCMXO3D-9400HC ~ | Performance: 5 ~
Package: |CABGA236 ~ | Condition: Commercial ~
Board: MachXO3D Breakout ~
Template Design
Empty Project Hello World Project. Components included:
m@ a) Processor - RISC-V MC wy/ PIC/TIMER
b} GPIO
c) ASRAM - Asynchronous SRAM
d) UART - Serial port

Figure 3.7. Create SoC Project Wizard

2. Enter a project name.

Note: Do not include periods, colons, or spaces in the project name.

3. (Optional) To change the default location, clear the Use default location option, then browse to another location.

Choose a file system.

Select a desired platform template design. In particular, select empty project for building system from scratch.

Click Finish.

The SoC design project is created in workbench, and its design is opened and displayed in Propel Builder

(Figure 3.10).

© 2022 Lattice Semiconductor Corp. All Lattice trademarks, registered trademarks, patents, and disclaimers are as listed at www.latticesemi.com/legal.
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3.2.2. Open a SoC Design in Propel Builder
Within a SoC project, there is a Propel builder design.
To open Propel Builder for a SoC project:

1. Inthe Project Explorer view, select a SoC project.

2. Open the SoC project in one of the following three ways from Propel:
e Choose LatticeTools > . Open Design in Propel Builder (Figure 3.8).

LatticeTools | Window  Help

4. Open Design in Propel Builder

#  Generate and Open Diamond Project
Generate and Open Radiant Project
Lattice Sentry Toels for MachX03D >
Lattice Sentry Tools for Mach-MNX >

Figure 3.8. LatticeTools Menu

e  Click the Propel Builder icon M on the toolbar.

e Right-click the SoC project from Project Explorer. Choose Open Design In > IH'I'l Propel Builder from the popup
menu (Figure 3.9).

Restore from Local History...

Open Design In * 4. Propel Builder
Team »  »  Diamond
Compare With » Radiant

Figure 3.9. Project Explorer Popup Menu

3. SoC Design is opened and displayed in Propel Builder (Figure 3.10).

. Propel Builder [C\lscc\propel\2.0hworkspace\ExampleSoC\ExampleSoC/ExampleSoC.sbx] Device: LCMX03D-8400HC-5BG256C - [m] *
File Edit View Design Window Help

oA O C #« B8 x4
Design View (m]
~ 1} ExampleSoC
» @ Instances
3 2 Ports
K fE Mets et st et
M Components B 4] L -
[ cpu0:1.0.0 A .
[T gpio0:1.2.0 . ] 1 o | gio iz
@ sysmem0:1.0.0 L

Haele®& QQQQ

Schematic Address Start Page

LaR]

Properties

Name:

Type: Instance i
Path: ExampleSoC
VLNV: lattice:systembuilder:Examp

4 3

IP Catal... DesignVi.. =

Tel Console [m|
%

Figure 3.10. Propel Builder Window
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(Optional) Modify the design in Propel Builder as desired. Most of the templates include a functional-ready SoC
design.

Note: You can only create a SoC design using Empty Project template inside the Propel Builder. Refer to

Lattice Propel Builder 2022.1 User Guide (FPGA-UG-02177) for more details on how to create a SoC design using
Empty Project template.

3.2.3. Open Design in Lattice FPGA Design Software

Within a SoC project, you can create a Lattice FPGA design project including a Propel Builder design, and then open the
FPGA design project in appropriate software. There are two FPGA Design Software available, Lattice Diamond and
Lattice Radiant™. Depends on the device family used in the SoC project, only one of the FPGA Design software can be
selected from the User Interface (Ul), the other is grayed out. If MachXO3D or LFMNX device family is used, the Lattice
Diamond related menu items are active from Propel Ul. If LIFCL or LFD2NX device family is used, the Lattice Radiant
related menu items are active from Propel UL.

To open FPGA Design Software for a SoC project from Propel:

1.

2.
3.

(Optional) Set Lattice FPGA design software installation location from Propel. By default, Propel can find the proper
Lattice FPGA design software installation location, usually the latest version installed on the PC. You can overwrite
it following steps below.

Choose Window > Preferences. The Preferences dialog opens (Figure 3.11).

Select Propel Setting from the left pane. Click the Browse button to pick up the installation location of Diamond or
Radiant. Or, leave the Radiant Location area and Diamond Location area blank, as default. Propel can find the
location atomically.

{71 Preferences O >

type filter text | Propel Setting L=l ~ §

General A
C/C++ Radiant Location
Help |
Install/Update
LiClipse

MCU Diamand Location
Mylyn |

| Browse...

Oomph | Browse...

Propel Setting
Remote Development

Run/Debug
SVEditor
Team
Terminal

Validation - Restore Defaults Apply

'/?3' I\_‘_ 15 (@' 'C;' Apply and Close Cancel

Figure 3.11. Propel Preferences Dialog

In the Project Explorer view from the Propel main Graphical User Interface (GUI), select a SoC project.

Open the SoC project in one of the following ways:

&
e Choose LatticeTools > Generate and open a Diamond project; Or, choose LatticeTools > Generate and
open a Radiant project.

e Click the Diamond icon : or the Radiant icon from the toolbar.
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e Right-click a SoC project from the Project Explorer. Choose Open Design In >

Design In >

Radiant from the right-click menu.

Diamond. Or, choose Open

4. Diamond/Radiant project for SoC is generated at background and is launched (Figure 3.12/Figure 3.13).

* Lattice Diamond - Start Page - O *
File Edit View Project Design Process Tools Window Help
PrE-Had gy ;@ aaqa | ] Bl
& 25 pd ™ = £ [r— —
PECHECHSCEHEGA=USSSVMBY BENEHE G
File List & X i} start Page [ Reports [ 2 x
v @ ExampleSoC
LCMXO3D-9400HC-5BG256C -
o = Strateai Project: Release Notes FPGA Design Guide ~
rategies . . . .
@9 AS @ODEH--- Lattice Diamend Software 3.12 Release Notes Design Planning
27 Area
1/0 Assistant E MNew... User Guides HOL Ceding Guidelines
Quick [ Import ispLEVER Project... Lattice Diamond 3.12 Release Notes Timing Closure
Timing Recent Projects: Lattice Diamond 3.12 User Guide Other Tool Guides
Strategyl 8 Examplesor Lattice Synthesis Engine for Diamond User ModelSim Users Manual
pit 4 socz GLHl.jE . . ModelSim GUI Reference Manual
Input Files Lattice Diamond 3.12 Platform Designer User ModelSim Command Reference Manual
¥ ExampleSoC/ExampleSoC_ {3 soc Guide Modelsim Tororia
M ExampleSoC/ExampleSoCy [ hello Clarity Designer User Guide geeisim fuena
: : Synplify Pro User Guide
Synthesis Constraint Files Lattice Diamoend 3.12 Programming Tools User
v LPF Constraint Files Guid Synplify Pro Reference Manual
[ ExampleSoClpf Software Update Center Reveal User Guide Synplify Pro Language Support Reference
Debug Files Currently running Lattice Diamond software version: Reveal Troubleshooting Guide Manual
Script Files 3.12.0.240.2 Lattice Diamond 3.12 Installation Guide for TelfTk
Analysis Files No updates available Windows Lattice on the Web
Programming Files Last check ime: Thu Mar 13 13:46:39 2021 tattlc:e Diamond 3.12 Installation Guide for Lattice Semiconductor
inux
< > Answer Datahase ¥
File List Process Hierarchy
ITd Console g X
» source "C:/lscc/propel/2.0/workspace/ExampleSol/diamond setup_template.tcl”
>
Td Console Cutput Error Warning® Info*
Ready Mem Usage: 127,628 K

Figure 3.12. Diamond Project
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Lattice Radiant Software - Reports — m} X
File Edit View Project Tools Window Help
. A ] = 2| = 5 L
¢ B KB M ( Qe I aL oEEERyGOR
} n Synthesize Design u Map Design u Place & Route Design n Export Files H
~ [E ExampleSoC M ox ﬁ Start Page — Reports B
I UFCL-40-9BG4001 -
=4 Strategies
=] Area Reports ExampleSoC Project Summary
i=| Timing Implementation Name: impl_1 Performance Grade
7 Strategyl
- ﬁ impl_1 (Synplify Pro) Strategy Name: Strategy1 Operating Conditior
~ B Input Files Part Number: LIFCL-40-0EG400! Synthesis:
.| ExampleSoC/ExampleSoC.v  |=] Synthesis Reports
&2 Pre-Synthesis Constraint Files Family: LIFCL Timing Errors:
Lattic=llSE ¥ [7) Map Reports Device: LIFCL-40 Project Created
Synplify Pro
- Post-Synthesis Constraint Files Package: CABGA400 Project Updated:
4
BxampleSoC pde Place & Route Reports Project File: C:iscoipropel/2.0iorkspace/ExampleSoC/ExampleSoC.
Debug Files L
Script Files Implementation Location: Cuilscc/propel/2. 0fworkspace/ExampleSoCfimpl 1
o » [=]l Export Reports
Analysis Files
Programming Files
» (2 Misc Reports Resource Usage
- I ExampleSoC - ExampleSoCwv ® LUT4 0 10 Buffers:
v TE uartD{uartD_inst) - uartlay
v IF sysmem{(sysmem{_inst) - sysme... AL EmEEE T il
3 ﬂ oscD(osc0 inst) - osclw !
v 1% gpicO(gpiol_inst] - gpioDv 9 — D
3 ﬂ cpulicpul_inst) - cpuls > source "C:/lscc/propel/2.0/workspace/ExampleSoC/radiant setup template.tcl™ Rl
v 1E apbO(apb0L_inst) - apb0.v
Starting: parse design source files
3 -
ﬂ ahbl2apb0{ahblzapbl_inst) - ahbl2 (VERI-1482) Analyzing Verilog file 'C:/lscc/radiant/3.0/cae library/synthesis/verilog/lifcl.v"'
» 1E ahbl0(ahbl0_inst) - ahblO.y - -
O Filetist [El source Template  Z] 1P Catalog Td Console = output E’ Message

Figure 3.13. Radiant Project

5. (Optional) From the File List view of the Diamond/Radiant software:

¢ modify the top-level RTL file (<proj_name>_Top.v) to match the SoC design, presupposition of which is that
there is a top-level RTL file in your SoC design; or

e create a top-level RTL file (<proj_name>_Top.v) to match the SoC design, if the SoC design is created from an
Empty Project template and there is no top-level RTL file in your SoC design.

6. (Optional) Modify constraint file (<proj_name>.lpf/<proj_name>.pdc) to match the SoC design, if you have
modified the SoC design.
Note: This step is a must to the SoC design that is created from Empty Project template.

7. Process the design in Lattice Diamond/Radiant.

In Diamond software, switch to Process view of the project (Figure 3.14). Make sure at least one file, IBIS Model,
Verilog Simulation File, VHDL Simulation File, Bitstream File, or JEDEC file, is checked in the Export Files section for

programming. Choose Process > I Run.
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# Lattice Diamond - Start Page - O s
File Edit View Project Design Process Tools Window Help
A-g-rHa8ra b @ERRIQAQ Y i
o & gd fi M g s = =
CEHESEG T @ @ sovMB Y EERER
& x ([ start Page [ Reports [ & x
3 Synthesize Design
-
Synplify Pro -
- : T'tp;y i Project: Release Notes FPGA Design Guide "
ranslate Design
v o Man D 9 {7 Open... Lattice Diamond Software 3.12 Release Notes Design Planning
+ Map Design . -
[ 2 Map Trace FRNew... User Guides H.DL. Coding Guidelines
[ & Verilog Simulation File [ Import ispLEVER Project... Lattice Diamond 3.12 Release Notes Timing Closure
[ & VHDL Simulation File Recent Projects: Lattice Diamond 3.12 User Guide Other Tool Guides
v & Place & Route Design 778 ExampleSoc Lattice Synthesis Engine for Diamond User ModelSim Users Manual
-
] * Place & Route Trace 8 socz Guide . . ModelSim GUI Reference Manual
oz 1/0 Timing Analysis Lattice Diamond 3.12 Platform Designer User ModelSim Command Reference Manual
[ 2 Thermal Analysis [ soc Guide ModalSim Tutorial
~ 2 Export Files 8 hello Clarity Designer User Guide @ e. Im Tuteria .
[0 & 18IS Madel Lattice Diamond 3.12 Programming Teols User Synplify Pro User Guide
0] 2 Verilog Simulation File Guid Synplify Pro Reference Manual
O : VHDL Simulation File Software Update Center Reveal User Guide Svnplifiv Pro Language Support Reference
M
2 Bitstream File Currently running Lattice Diamond software version: Reveal Troubleshooting Guide anua
2 JEDECFile 3.12.0.240.2 Lattice Diamond 3.12 Installation Guide for 19/ 1K
Mo updates available Wmdﬂws. . Lattice on the Web
Last check time: Thu Mar 18 13:46:39 2021 Il:_attu:e Diamend 3.12 Installation Guide for | stice Semiconductor
e Answer Datahase b
File List Process Hierarchy
Output 8 x
synpurap -msg -prj "Example5oC_impll_synplify.tcl” -log "ExampleSoC_impll.srf™ ~
Copyright (C) 1992-2020 Lattice Semiconductor Corporation. All rights reserwved.
Lattice Diamond Version 3.12.0.240.2
INFO - Synplify synthesis engine is launched. v
Td Console Qutput Error Warning Info=
Start: Synplify Pro Mem Usage: 313,848 K

Figure 3.14. Generate Programming File in Lattice Diamond

In Radiant software, from the Process Toolbar, click Export Files (Figure 3.15).

Lattice Radiant Software - Reports

File Edit View Project Tools Window Help

=- A o =
e aQaaa BE
o (W] u Map Design n Place & Route Design u Export Files B

~ [E ExampleSoC Eag 1Y Start Page [ Reports
I3 LIFCL-40-9BG4001

» 21l Export Reports
EI Analysis Files P p

1 Programming Files
» 2l Misc Reports

LUT4 0
PFU Register: 0

4

> source "C:/lscc/propel/2.0/workspace/ExampleSoC/radiant setup template.tcl”

Starting: parse design source files

> prj_run Synthesis —impl impl 1

Td Console = OQutput E1 Message

O File st [E source Template Elr Catalog

. L\ Synthesize Design
= Strategies
- = Argea R rts L\ Synplify Pro
r:—\ Tirmin epo = Post-Synthesis Timing Analysis
':? St a‘g 1 Post-Synthesis Simulation File Performance Grade
5 rategy .
v % impl_1 (Synplify Pro) Map Design ] ] Operating Conditior
* [ Input Files ] Map Timing Analysis
. ExampleSoC/ExampleSoCv » [Z] Synthesis Reports Place & Route Design o400 LIRS
- E Pre-Synthesis Constraint Files = Place & Route Timing Analysis Timing Errors:
£ Lattice LSE 1/0 Timing Analysis
& S;n:\:'-y . *» 5l Map Reports Export Files Project Created:
Bitst: Fil .
< EI Post-Synthesis Constraint Files = ! II::I:!I ':I Project Updated:
» odel
&b bh":'lp'e pde AEESRINEHIE B - Gate Level Simulation File 212 0workspace/ExampleSeG/ExampleSoC i
ebug Files i
7 Script Files 212 0/workspace/ExampleSoCimpl 1

(VERI-1482) Analyzing Verilog file 'C:/lscc/radiant/3.0/cae_library/synthesis/verilog/lifcl.v'

GIE]

10 Buffers

EBR:

Figure 3.15. Generate Programming File in Lattice Radiant

The Programming file is generated. The generated programming file can be used in the Programmer.
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3.2.4. Generating System Environment by Building Project

System environment package including the system environment file and the BSP package is required for the embedded
C/C++ project.

To generate system environment package from Propel:
1. Inthe Project Explorer view, select a SoC project.
2. Choose Project > Build Project.

3. Check the building result in the Console view (Figure 3.16).

{2 Problems |4 Tasks | B Console 2 1 Properties | @@ Terminal = B8

X% HEzEE -
<terminated> sge [SDP Builder] C\lscc\propel\d.0hvtools\python38_embed\python.exe
Warning - Unconnectien: cpu® inst TIMER_IRQ M@ remains unconnected
INFO - Finished: sge generated

Figure 3.16. Build Result of SoC Project

3.2.5. About SoC Design Project

The SoC project creating starts with a functional-ready SoC design and a default simulation environment. In the Project
Explorer view, open a SoC project folder and all its sub-folders. The project contains the following files but not limited
to the following files (Figure 3.17), some of which may vary upon your opening the SoC design project in Diamond or
Radiant software:

e <proj_name>: Folder contains a Propel Builder design including the .sbx file.

e <proj_name>/application: Folder contains functional-ready embedded application source codes.
e impll: Folder contains the implementation of Diamond/Radiant project.

e sge: Folder contains generated package necessary for creating C/C++ project.

e verification: Folder contains the SoC verification project.

e verification/sim: Folder contains the simulation environment.

e <proj_name>.ldf: Diamond project file.

e <proj_name>.lpf: Diamond project logical preference file.

e <proj_name>.rdf: Radiant project file.

e <proj name>.pdc: Radiant project post-synthesis constraints.

e <proj_name>.txt: Description file from the template.
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f|ﬁ.'1"‘_‘| Project Explorer 2

I

)
i’y
=]

w = ExampleSoC
w = ExampleSoC
» [= application
» = lib
ExampleSoC_tmply
Vi ExampleSoC_tmplvhd
ExampleSeC_Top.v
ExampleSoC.shx
ExampleSoCwv
» = impll
v [= sge
» [ application
» = bsp
% [= soc_svd
fu) cpul.yaml
ﬂ sys_env.xml
w = verification
» [= lib
% = sim
json ExampleSoC_v.json
Example5SoC_v.shx
diamond_setup_template.tcl
[€] ExampleSoC.ldf
ExampleSoC.lpf
ExampleSoC.tt

soo | O

Figure 3.17. Contents of SoC Project
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3.3. C/C++ Project Design Flow

3.3.1. Creating a Lattice C/C++ Project

To start a Lattice C/C++ Project from Propel:

1. Choose File > New > @ Lattice C/C++ Project.
The C/C++ Project wizard opens with the Load System and BSP page (Figure 3.18).

g C/C++ Project O 4

Load System and BSP —

Correct systermn environment file and get toolchain pararmeter

Select system environment file and BSP package

System env: | Chlscc\propel\2022. Thworkspacet\ExampleSoChsgelsys_emvaoml w~ Browse...

Select processor core to create C/C++ Project

Core selected: | cpul_inst ~

Project type: | C ~

System information

Device Family CPU MName Instance Mame

MachXQ3D riscv_mc cpul_inst

Project name: | Example

Use default location
Chlscc\propel2022. 1\workspace\Example Browse...

default

@' < Back Einish Cancel

Figure 3.18. Load System and BSP Dialog

2. Browse to the SoC project folder and select the system environment file sys_env.xml.
All system environment files available in the current workspace can be selected from the System env: drop-down
menu.

3. Ifthe platform has more than one processor, choose one core.
Choose the project type, C or C++.

Enter a project name. Suggest not using periods, colons, or spaces in your project name. Though spaces are
allowed, they may cause certain issue with some tools.

© 2022 Lattice Semiconductor Corp. All Lattice trademarks, registered trademarks, patents, and disclaimers are as listed at www.latticesemi.com/legal.
All other brand or product names are trademarks or registered trademarks of their respective holders. The specifications and information herein are subject to change without notice.

22 FPGA-UG-02176-1.0


http://www.latticesemi.com/legal

l.:LATTICE Lattice Propel 2022.1 SDK

User Guide

6. By default, the Use default location option is checked. The default file system is selected automatically. Suggest
using the default location unless you have special need to a special location.

7. Click Next.
The Lattice Toolchain Setting dialog opens (Figure 3.19).

01 C/C++ Project O >

Lattice Toolchain Setting

Configuraticn: | Debug ~

Lib Setting  C/C++ Compiler C/C++ Linker

(") Ne default libraries (-nodefaultlibs)
(O Newlib

() Newlib-nano (--specs=nano.specs)
(®) Picolibc (--specs=picolibc.specs)

Printf Level
(®) Integer only printf (-DPICOLIBC_INTEGER_PRIMTF_SCANF)

() Float printf (-DPICOLIBC_FLOAT_PRINTF_SCANF)
(2 Full printf (-DPICOLIBC_DOUBLE_PRINTF_SCANF)

System Library
(@) Default

O Semihosting (--oslib=semihost)
(O Dummyhosting (--oslib=dummyhost)

l:?:' < Back Mext > Cancel

Figure 3.19. Lattice Toolchain Setting Dialog

8. By default, two toolchain configuration modes, Debug and Release, can be chosen from the Configuration
drop-down menu.

e Debug configuration creates executables containing additional debug information that lets the debugger make
direct associations between the source code and the binary files generated from the original source.

e Release configuration provides the tools with options setting to create an application with the best
performance.

You can modify frequently-used library, compiler, and linker options for each configuration. For a complete
toolchain setting, go to project properties after creating the project. Refer to the Advanced Tool Chain Setting
section.

e In Lib Setting tab, standard C library can be reconfigured. Picolibc (C Libraries for Smaller Embedded Systems)
is selected by default and it supports different printf levels.

e In C/C++ Compiler tab, optimization level and debug level can be reconfigured for each toolchain
configuration.

e In C/C++ Linker tab, Remove unused code (--gc-sections) is checked by default for garbage collection of unused
code.
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Click Finish.

The Lattice C/C++ project is created and is displayed using the Propel SDK perspective. A perspective is a collection
of tool views for a particular purpose. The Propel SDK perspective is for creating Lattice C/C++ programs.

3.3.2. Updating a Lattice C/C++ Project

When you make changes to a SoC project, sometimes you want to synchronize the changes to an existing Lattice C/C++
project instead of creating a new Lattice C/C++ project. In this case, you can use the update C/C++ project feature.

Note: This feature overwrites the corresponding files or settings of your existing C/C++ project. Be sure to back up your
C/C++ project before using this feature.

To update a Lattice C/C++ Project from Propel:

1.

Generate the latest system environment package according to the Generating System Environment by Building
Project section.

In the Project Explorer view, select a C/C++ project.
Choose Project > Update Lattice C/C++ Project....
The C/C++ Project wizard opens for updating system and BSP (Figure 3.20).

o
]

Update System and BSP

Select systern environment file and BSP package

Systern enw: | Ci/flscc/propel/2022.1 /workspace/ExampleSoC/sge/sys_envaxml Browse...

[[] Re-generate toolchain pararneters and linker script
[JUpdate BSP package

Update Cancel

Figure 3.20. Update System and BSP Dialog

Browse to the SoC project folder and select the system environment file sys_env.xml.
Select the checkbox for what you can update:

e Re-generate toolchain parameters and linker script: check this option if you want to modify CPU or memory in
the system.

e Update BSP package: check this option if you want to add additional IP components into the system.

Click Update to make changes for the selected C/C++ project.

3.3.3. Building a Lattice C/C++ Project
To build a Lattice C/C++ project in Propel:

1.
2.

In the Project Explorer view, select a C/C++ project.

Follow steps below if you want to change the active build configuration:

a. Choose Project > Build Configurations > Manage.... Or, click the Configuration icon & on the toolbar.

b. The Manage Configurations dialog opens (Figure 3.21) for choosing active configuration. By default, a Debug
configuration creates executables containing additional debug information that lets the debugger make direct
associations between the source code and the binary files generated from the original source. A Release
configuration provides the tools with options setting to create an application with the best performance.
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Q Exarnple: Manage Configurations X

Configuration Description Status

Debug Active

Release

Set Active Mew... Delete Rename...

Figure 3.21. Manage Configurations Dialog
3. Choose Project > Build Project. Or, click the Build icon % on the toolbar.
4. The results of the build command are displayed in the Console view (Figure 3.22).
|2 Problems | =] Tasks | &) Console &3 [ Properties | & Terminal &4 <|="=.>| H @ =% | = BEB--= 0
CDT Build Conscle [Example]
A
Invoking: GNU RISC-V Cross Print Size
riscv-none-embed-size --format=berkeley "Example.elf”
text data bss dec hex filename
1262 =] 2723 3996 f96 Example.elf
Finished building: Example.siz
Invoking: Lattice Create Memory Deployment
riscv-none-embed-cbjcopy -0 binary --gap-fill @ "Example.elf” "Example.bin"; srec_cat "Example.bin”
-Binary -byte-swap 4 -DISable Header -Output “Example.mem" -MEM 32
Finished building: Example.mem
15:58:18 Build Finished. @ erreors, 8 warnings. (took 5s5.21ms)
v

Figure 3.22. Build Result of C/C++ Project

3.3.4. About Lattice C/C++ Project

The Lattice C/C++ project starts with source code. In the Project Explorer view, open a C/C++ project folder and all its
sub-folders. The project contains:

src/bsp/driver: Folder contains driver codes from the IP in the platform.

src/bsp/sys_platform.h: Header file that defines DEVICE_FAMILY (the Lattice FPGA), address mapping, and any IP
parameters that can be used by the drivers.

src/main.c: Source file contains the main routine, which is the entry-point of a C/C++ program.
src/cpu0.svd: System view description file used for peripherals registers view at debug perspective.
src/cpu0.yaml: Processor description file used at debugging time.

src/linker.ld: Linker script file.

src/sys_env.xml: System environment file describing aspects of the platform, such as memory spaces.

After building the project, the build output can be found in each build configuration folder, the Debug folder or the
Release folder (Figure 3.23). The Debug or Release folder contains:

<proj_name>.elf: Executable file used in on-chip debugging.

<proj_name>.bin: Binary file used in deploying the application to flash memory.
<proj_name>.lIst: Extended listing file generated by tool objdump.
<proj_name>.map: Linker map file.

<proj_name>.mem: Lattice system memory initialization file used in System_Memory IP.
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Note: Some of the files listed in Figure 3.23 are intermediate files that you do not need to take care of.

3.3.5. Writing Code

5 Project Explorer &3

v (== Example
d:;? Binaries
i Includes
w [ sre
v (& bsp
[= driver
[h| sys_platform.h
[ main.c
[ utils.c
[H utils.h
[ cpub.svd
cpulyaml
el linker.ld

Fi
i% sys_envxml

w = Debug
[= src
%5 Example.elf - [none/le]
|=| Examplebin
Examplelst

Example.map
Example.mern

| & makefile

| @ objects.mk

| @ sources.mk
=% ExampleSoC

Figure 3.23. Contents of C/C++ Project

=
DD

Lattice Propel is based on Eclipse IDE. You can write application code following the process and usage of the same tools
as any in Eclipse IDE. You can get more detailed information regarding Eclipse IDE from the Propel online help.

For writing code, Lattice Propel SDK provides two extra aids:

e Lattice System Platform: An overview of the processor platform can be displayed (Figure 3.24).

e Linker Editor: An overview of the memory regions of linker script can be displayed. You can modify key linker
parameters via the graphical interface (Figure 3.25).
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DeviceFamily: | MachX03D

Bsplocation: | bsp

72 Lattice Platform = g
General
Vendor: [ Iattice |
Library: | Propel |
Name: | ExamplesoC |
Version: | 20221 |
|
|

component ipname version wvendor baseAddress range irg
cpul_inst rsCV_moc 230 latticesemi.com

pic_timer_mem_map  PIC_Timer_Registers O FFEFOO00 (%800
sysmem{_inst systemn_memory 112 latticesemi.com (0] e 4000
gpicd_inst gpic 1.60 latticesemi.com (3000 D400 IRC_51
uart0_inst uart 1.3.0 latticesemi.com (3400 (400 IRQ_S0

Overview | sys_env.xml

Figure 3.24. Lattice System Platform

$ Lattice Platform Tl Linker : = g

Linker Script: linker.Id

Available Memory Regions
Mame Attributes  Base Address Size
sysmem(_inst Wy 0 (e 4000

STACK and HEAP Size

HEAP SIZE: | 0xD |

STACK_SIZE: | 0xADD |

Section to Memory Region Mapping

Section Name Mermory Region &
text sysmerm{_inst
.ctors sysmemi_inst
.dtors sysmem(_inst
rodata sysmem_inst
.data sysmemi_inst
s sysmem{_inst w

Overview | linker.Id |

Figure 3.25. Linker Editor
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3.3.6. Advanced Tool Chain Setting

Follow the process below to modify the tool chain settings of a C/C++ project.

To change tool chain setting in Project Properties in Propel:

1. Inthe Project Explorer view of Propel, select a C/C++ project.

2. Choose Project > Properties. The Properties for current project opens (Figure 3.26).

3. Select Settings of C/C++ Build category from the left pane. Select the Tool Settings tab.

£ Properties for Example O X

type filter text Settings =R 2 -

Rescurce

00

Builders
w C/C++ Build Configuration: |Debug [ Active] ~ | | Manage Configurations...
Build Variables
Environment
Logging ¥ Tool Settings i Toolchains M Devices #* Build Steps Build Artifact Binary Parsers @ |4 |*
Settings
Tool Chain Editor (% Target Processor Architecture RV32| (-rmarch=rv32i*) w
C/C++ General (# Optimization
MCU @ Warnings
Project Matures (2 Debugging
Project References ~ 133 GNURISC-V Cross Assembler Floating point Mene w
Run/Debug Settings (2 Preprocessor Compressed extension (RVC)
SystemVerileg Project Properties (2 Includes -
Task Repository @ Warnings Integer ABI ILP32 (-mabi=ilp32*) ~
Task Tags (#5 Miscellaneous Floating point ABI
Validation w 3 GMU RISC-V Cross C Compiler
@ Preprocessor Tuning Teolchain default ~
(22 Includes
@ Optimization
( Warnings Small data limit | 8

[J Multiply extension (RVIM)
] Atomic extension (RVA)

None ~

Code model Toclchain default ~

(# Miscellaneous

~ i3 GNU RISC-Y Cross C Linker
@ General [[]Small prologue/epilogue (-msave-restore)

Align Toolchain default (-mtune) ~

@ Libraries Force string eperations to call library functions (-mmemcpy)
(# Miscellaneous Other target flags |
~ I35 GNU RISC-V Cross Create Listing
(#2 General
w 83 GMU RISC-V Cross Print Size
@ General
~ I3 Lattice Create Memery Deployment
@ General

Restore Defaults Apply

@' Apply and Close Cancel

Figure 3.26. Properties of C/C++ Project

4. Customize the tools and tool options. All your customization can be resulted in the build configuration in the Tool
Settings properties tab. The build configuration is used during your C/C++ project building.

Note: Setting for each configuration, Debug or Release, is independent.
5. Click Apply and Close to save the change.

Note: You may need to clean the project to make the new setting take effect for the whole project.
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3.4. System Simulation Flow

The SoC Project created from template has a default simulation environment for you to setup and start functional

simulation. It is generated automatically along with the SoC project creation. You can use it as a start point and

customize accordingly.

The default simulation environment is with the following features:

e  Provides similar user experience as real board-level debugging, such as for Hello World SoC, key components

including RISC-V MC, System memory, and UART.

e Simulates user-modified template SoC with extended HDL designs.

e Simulates the whole system using real C/C++ projects as stimulus with the necessary modification and with all the

details for debugging.

e  Supports user extension with a friendly and flexible approach.

3.4.1. Launch Simulation
To launch simulation:

1. In Propel Builder, update the SoC design to enable simulation features.

e Enable the checkbox for Simulation Mode, and disable the checkbox for Debug Enable for RISC-V MC IP

module in the General area (Figure 3.27).

., Module/IP Block Wizard

Configure Component from IP riscv_mc Version 1.2.0
Set the following parameters to configure this component.

Diagram cpul Configure IP
| Property
~* General
Simulation Mode
Debug Enable
Compressed Instruction Extension
PIC Enable
CpUU Tirer Enable
PIC and Timer Base Address (32'h00000000 ~ 32'hFFFFFFFF)
- IRQ_SOAHBL_MU_INSTFE - Mumber of Interrupt Requests [2 - 8]
—HHIRQ_S1 AHBL_M1_DATA4~
—{dk_i TIMER_IRQ_MOH—
—rst_n_i system_resetn_o—
riscv_mc
4 » Mo DRC issues are found.

Value

3
2

Fa

'hFFFFOD0D

Generate

Cancel

Figure 3.27. Configure Module RISC-V MC
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Enable the checkbox for Initialize Memory for system_memory IP module from the Initialization area of the

General tab, and set Initialization File generated from the corresponding C/C++ project (Figure 3.28).

“. Module/IP Block Wizard

Configure Component from Module system_memory Version 1.0.2
Set the following parameters to configure this component.

Diagram sysmem0

.

sysmem0O
.
AHBL_SO
AHBL_S1
— ahbl_hclk_i
—ahbl_hresetn_i
iy

system_memory

Configure IP
General Port 50 Settings Port 51 Settings
Property Value

Memory Address Depth [1 - 32768] | 8192

Data Bus Width(bits) 32
Memory Type EER
Port Count [1-2] 2
Enable Arbiter

Enable FIFO Streamer

Initialize Memory

Initialization File Format

Initialization File

Example/Debug/Example.mem

Mo DR.C issues are found.

Generate Cancel

Figure 3.28. Configure Module System Memory

2. Click the Switch icon on the toolbar to switch between SoC design and SoC verification project (Figure 3.29).

il
3. After the SoC design is switched to a SoC verification project, click the Generate icon L& to generate the simulation

environment for OEM ModelSim. Click the Launch Simulation icon .' (Figure 3.29).

30
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. Propel Builder [C:/lscc/propel/2.0/workspace/ExampleSoC/verification/ExampleSoC_v.shx] Device: LCMXO3D-8400HC-3B6256C — O x
File Edit View Design Window Help
- = = . T~
CERDCTA IREROEE QQQQ
Design View m| Schematic Address Start Page
- E ExampleSoC_v S
3 {? Instances . .
b Nets sysclk_rst_genl_inst uart_model1_inst
- Compaenents . th_clk_o uart_rx_data_debug e
[£Z] sysclk_rst_gen1:1.0.0 1.20 dut_ck_dut_rst_o uart_tx_data_debugp=
[Z] uart_modeit:1.0.0 b0 dut_rst_dlut_ck_o Ik uart_n¢_break_debugl—
th_rst_o rstn uart_r¢_valid_debug—
uart_rxd uart_t_busy_debugl—
Properties x uart_tx_en_debug—
Name: uart_txd
Type: Instance
Path: ExampleSoC_v
WLNV: lattice:systembuilder:Exame =
4 »
IP Catal... DesinVi.. g
Tel Conscle m}
Finished: "sbp_design close" h
% sbp_design open -name ExampleSoC v -path {C:/lscc/propel/2.0/workspace/ExampleSoC/verification/ExampleSoC v.sbx}
% -

Figure 3.29. SoC Verification Project

4. ModelSim is launched running simulation for the SoC verification project. The corresponding waveform of the SoC
verification project for the Hello World project is shown (Figure 3.30). Check the waveform.

M ModelSim DE 20203

- o x

file Edit View Compile Simulste Add Wave Tools Layout Bookmarks Window Help
|8-s@=8 J.,Gan,g'_n‘;,.ugumb h]@"? ”ﬂﬁ| G (5 oo EEEBAG Ennm“!:‘! L@ 8 || tevout simlace !|
[ Comrtoro fonzacss Al a-a-2@-2| [0 wm e[ & oleu ] L& el i £ € o Yy
|eaeassa|| L a/mimi
B om -vefadt ——:—— # d x] e .
R .
=l viest .

+ GSR_INST

;:nu(:ns( 2 [vtestidut_instjrstn

£ vtestidut_instjred i
4. testjdut_inst/ted_o
2 [viestjuart_model1_inst/dk
4 [vtestiuart_modell_instrstn

- B sysck_rst_pen1_inst
- 8 vart_model1_inst
@ =ASSIGN=82
-l st
| #vem_capacity=

4 jetestjuart_model1_instjuart_red

. vtestjuart_model1_insthuart_ted
fvtestjuart_model1_inst/uar _debug
testjuart_model1_inst/uart_rx_valid_debug

Figure 3.30. Waveform of Hello World Project

3.4.2. Simulation Details

The default simulation environment is located at the generated sim folder inside the SoC verification project in Propel.
It contains:

[sim] -- generated simulation environment
[hdI_header]
soc_regs.v -- register definitions of all the components in DUT/SOC
sys_platform.v - base address, user settings of all the components in DUT/SOC
[misc]
* ¥ -- all the mem, hex, txt files will be copied here
flist.f -- file list for HDLs
msim.do -- do script for simulator, it can be gsim for Questasim
wave.do -- do script for adding signals in waveform window
<project_name>.sv -- top testbench, SystemVerilog based

You can extend more verification features in the top testbench.
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About Hello World Project

The Hello World Project is designed to print some strings using a top-level UART port. The testbench instantiates a
UART model to receive these data. Each byte (refer to uart_rx_data shown in Figure 3.30) can be checked using ASCII
format. Meanwhile, this UART model also supports sending the data to Design Under Test (DUT). The data is stored in a
text file and enabled by STIMULUS_GEN parameter.

3.5. Programming and On-Chip-Debugging Flow

This section describes the process of testing and debugging application code on the actual hardware including the
Lattice FPGA with the hardware design installed. Debugging with Propel SDK follows the same process and uses of the
same tools of any of those in Eclipse IDE.

Before debugging, download the hardware design created from Diamond/Radiant Programmer. Refer to the User
Guide of the specific evaluation board for more details on the evaluation board.

3.5.1. Creating a Debug Launch Configuration

To debug a program, a debug launch configuration must be created. Most of the settings for a debug launch
configuration can be automatically entered. Only a few settings need to be manually configured.

To create a debug launch configuration:
1. Inthe Project Explorer view of Propel, select a C/C++ project.

2. Build the project and ensure the executable file is available. Refer to the Building a Lattice C/C++ Project section for
details on the process.

3. Choose Run > Debug Configurations...
The Debug Configurations dialog opens (Figure 3.31).

7t Debug Configurations O *

Create, manage, and run configurations

[ § = *| B Y- Name:|ExampIeDebug |

|t}"pEfi|tEI'tl':5<t | [£] Main . [Z| CableConn| %3 Debugger| = Startup| & Source| [C] Commen| &, SVD Path
[©] C/C++ Application

Project:
[©] C/C++ Attach to Application g
[©] C/C++ Postmortem Debugger | Example | Browse...
[€] C/C++ Remote Application CfC++ Application:

Cif C/C++ Unit
[t ] GDB Hardware Debugging
w [t | GDB Open0CD Debugging Variables... Search Project... Browse...
¢ | Example Debug
[c| GDB QEMU Debugging
L Launch Group Build Cenfiguration: | Select Automatically ~
@ Launch Group (Deprecated)

| DebughExample.elf

Build (if required) before launching

(") Enable auto build () Disable auto build
(®) Use workspace settings Configure Workspace Settings...
Revert Apply

Filter matched 11 of 11 items

Figure 3.31. Debug Configurations Page
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4. Double-click GDB OpenOCD Debugging to create a new launch configuration.

A multi-tab page is displayed. The Main tab should already be filled in with the project name, application file name,
and location.

5. Select the CableConn tab (Figure 3.32). This tab enables you to select a specific device on a specific cable port.

Click the Detect Cable button. Select the specific cable port from the Port drop-down list. By default, the first
available cable port: FTUSB-O0 is selected.

Click Scan Device button. Select the specific device from Device drop-down list. By default, the first available device
on selected cable port is selected.

Select the jtag channel number from Channel drop-down list. By default, channel 14 is selected with the same
value as the processor preset.

Keep the cable speed so that you can use the default clock divider.

1% Debug Configurations O X |
Create, manage, and run configurations @‘:\
P x| = -

: Name: Example Debug

Main | () CableConn . % Debugger| & Startup| &~ Source [ Comman 2. SVD Path
[€] C/C++ Application Cable Settings
[£] C/C++ Attach to Application
[E

Port: FTUSB-0,USB2 Lattice XO3D Breakout Board A Location 0000 ~ || Detect Cable
[£] C/C++ Postmortem Debugger
[€] C/C++ Remote Application Device Settings
Cif C/C++ Unit
/G Device: | LCMXO3D-9400HC:0x212E3043 v| | Scan Device
le| GDBE Hardware Debugging
~ [£] GDB OpenOCD Debugging JTAG Channel Setting
[c] Example Debug Channel: 14 »

& Launch Group

¥ Launch Group (Deprecated) Speed Settings
(@ Use Default Clock Divider
(O Use Custom Clock Divider

Filter matched 10 of 10 items i s

@ Close

Figure 3.32. CableConn Tab of Debug Configurations

6. Select the Debugger tab (Figure 3.33). It is critical that the Config options field contains the correct command line
options to be passed to OpenOCD.

-c "set port S{PORT}" is required for the selection connected to Lattice cable. The value of variable “S{PORT}’comes
from the cable settings of CableConn tab.

-c "set target S{DEVICE}" is required for the selection specific device on the Lattice cable. The value of variable
“S{DEVICE}” comes from the device settings of CableConn tab.

-c "set channel S{CHANNEL}" is required for setting JTAG channel. The value of variable “S{CHANNEL}” comes from
the jtag channel setting of CableConn tab.

-c "set tck S{TCKDIV}" is required for setting clock divider of the Lattice cable. The value of variable “S{TCKDIV}”
comes from the speed setting of CableConn tab.
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Q Debug Configurations

Create, manage, and run configurations

ERCELEER | B Y~ MNare: |ExampIeDebug
| type filter text | Main | CableCenn I?ﬁﬁ‘- Debugger] "3 Startup| Ep Source| = Commonl T, SVD Path|
[E] C/C++ Application Open0OCD Setup ~
[E] C/C++ Attach to Applicatior Start OpenOCD locally
[c] C/C++ Postmortem Debugg :
[E] C/C++ Remote Application Executable path: | S{openccd_path}/${openocd_executable} | | Browse...| |\|’arlablﬁ... |
Cif C/C++ Unit Actual executable: | ChIscc\propel2022. T\sdk\eclipse\/../openocd/bin/openccd.exe |
[€] GDB Hardware DEbqulhg (to change it use the global or workspace preferences pages or the project properties page)
w [€ | GDB OpenOCD Debugging
[T] Example Debug GDB port: 3333
[ GDE QEMU Debugging Telnet port
R Launch Group
Tel port:
Config options: -c 'echo "DEBUG_EMABLE=S{DEBUGEMABLE}" -c "set target S{DEVICE}" -c "set tck
S{TCKDIV}" -c "set port S{PORT}" -c "set channel ${CHANMEL}" -f interface/lattice-
cable.cfg -c "set RISCV_SMALL_YAML {5{ProjDirPath}/src/cpulyaml}” -f target/riscv-
small.cfg
Allocate console for OpenOCD Allocate console for the telnet connection
GDE Client Setup v
< >
) . Rewvert Apply
Filter matched 10 of 10 items
® Debug | | Close

7.

Figure 3.33. Debugger Tab of Debug Configurations

(Optional) Select the Common tab (Figure 3.34). The Save as > Local file option is selected by default. This causes
the debug launch configuration to be saved into the workspace.

Change setting the Save as field to Shared file to let the debug launch configuration saved into the project that aids

the project portability.

34
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Q Debug Configurations

Create, manage, and run configurations

O PR x| =R MName: | Example Debug |
| type filter text | Main ( CableConn ﬁi?- Debugger I’g. Startup (E/ Source ﬂ-—=| Common .72, SVD Path
[E] C/C++ Application Save as -
[E] C/C++ Attach to Application ) Lecal file
[t] C/C++ Postmortem Debugger .
[t] C/C++ Remote Application © Shared file: | \Example | Browse...
Coo .
i C/Ce+ Unit . Display in favorites menu Encoding
[t ] GDB Hardware Debugging @® Defautt - inherited (UTF-2
v [t | GDB Open0OCD Debugging [ 4 Debug e
7] Example Debug O Orun O Other | 150-2850-1
[t] GDE QEMU Debugging
i Launch Group
= Launch Group (Deprecated)
Standard Input and Output
[+] Allocate console (necessary for input) "
Revert Appl
Filter matched 11 of 11 items = Ry

@

Figure 3.34. Common Tab of Debug Configurations

Remain settings as default. Do not change the settings unless necessary, or unless you understand what effect
these changes may have.

9. Click Apply to keep the current settings.
10. Click Close.

3.5.2. Starting a Debug Session
Before starting a debug session, be sure that:
e Lattice cable is connected to the computer.

e The target device is power ON.

e The hardware design has a debug enabled processor module and already programming into the target device.

With the above steps completed properly, follow the steps below to start the debug session from Propel.
1. Choose Run > Debug Configurations...

2. If necessary, expand the GDB OpenOCD Debugging group.

3. Select the newly-defined configuration.

4. Click the Debug button (Figure 3.34).

Alternatively, for later sessions, use the Debug icon ’:3: on the toolbar. Do not click the Debug icon directly. Instead,

click the down arrow beside the Debug icon. Select the desired debug configuration from the drop-down menu
(Figure 3.35).
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#5; - 0 - ‘% - .g @ & v I
[c| 1Example Debug
Debug As >

Debug Configurations...

Organize Faverites...

Figure 3.35. Debug Icon on Toolbar

5. Wait for a few seconds for switching to debug perspective, starting the server, connecting to the target device,
starting the gdb client, downloading the application and starting the debugging session.

6. The Propel Window displays as shown in Figure 3.36 The execution stops right at the beginning of the main()

function.
£ workspace - Example/src/main.c - Lattice Propel - O x
File Edit Source Refactor Mavigate Search Project Run  LatticeTools Window Help
i 82 |@iBiw|m 0 @682 ¢ SIS -0- QU i@ F-ideif-F-Ce-o- ™
Q E| G
45 Debug 2 " {5 Project Explorer = g = B |[m=v 2 %e|fE|E P = B
3 2 T WARRANT OR REPRESENT THAT THIS F ITS cor . = 2
i=  E -~ = 2
= | ] L DOES NOT INFRINGE OM THIRD PARTIES' I ECTUA & E‘l Lo
w [£] Example Debug [GDB OpenOCD Debugging] ENT. IT IS THE USER'S RE IBILIT MName Type
v :ﬁ Example.elf CONSISTE = idx uint8_t
~ o Thread #1 (Suspended : Signal : 0:Signal 0} M
= main() at main.c:46 Oxddc
L] openocd.exe #include "utils.h"]
gl riscv-none-embed-gdb
= int main(void) {
static uintd_t idx = @;
DEBUG_PRINTF("Hello RISC-V world!\r\n");
LED_SET(ALL_OFF);
while (true) {
LED_SET(LED_ON(idx)); < 5
if (++idx == LED COUNT) { Name : idx A
idx = @; Details:@ "\@'
} Default:e "\@'
Decimal:@
if (RTL_SIM Hex:8x@
‘Aﬂ1?.,uc2«;{. v Rinarv-f v
< >
2 Console | 55 Registers | 42 Terminal [2] Problems | (3 Executables EDebuggErConsale & i} Meraory B~-=0O
Example Debug [GDE OpenOCD Debugging] 8{cross_prefixlgdbS{cross_suffix} (777)
A
Program stopped. ~
T S
Writable Smart Insert 42:19: 2503 : 165M of 334M m:

Figure 3.36. Debug Perspective

3.5.3. Peripherals Registers View

Peripherals registers view provides an easy-to-use interface for examining or modifying the values of peripheral
registers during a debug session.

To use peripherals registers view in Propel (Figure 3.37):
1. Make sure an active debug session is run and shown in the debug perspective.

2. Find the Peripherals view which is in the same window with the Variables and Breakpoints views. For any reason,
if not found, re-open from Window > Show View > Peripherals.

The Peripherals view lists all peripherals available in the system view description svd file within the C/C++ Project.

3. Selecting a peripheral in the Peripherals view can open a Memory Monitor that is mapped to the corresponding
peripheral memory area.

4. You can examine and modify the value of the peripherals register in the memory view.
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% workspace - Example/src/main.c - Lattice Propel - [m] x

File Edit Source Refactor Mavigate Search Project Run  LatticeTools Window Help
Awifhd IRl Ed3e PSSRSO RS HFE -0 - WO F-J i -G 0or0 |
e, 5 | (45
5 Debu 22 5 Proja} = B || [ mainc & = B8 |[x)= Variables (oo Breakpoints (H Expresd ons | 7. Peripherals 52 = B8
B % | i 2 B ettt A il =
w [£] Example Debug [GDB Open0OCD 42 #include "utils.h™ Peripheral Address Description
v i Example.eif 3 AT, cpul_inst OxFFFFO000
v u?}lhread.‘ﬂ (Susp.ended : Sig = int ':::::E:Dif:,tg ¢ o - o &%, gpiol_inst 0x0D002000
= main() at main.c:46 O _ =Y D%_ sysmemi_inst 0x00000000

DEBUG_PRINTF("Hello RISC-V world!\rin");

while (true) {
LED_SET(LED_ON(idx));

if (++idx == LED_COUNT) {
idx = @;
}
v

< >

2 Console ﬂ'\’é? Registers (@ Terminal ﬂ::_ Problems (O Executables (E Debugger Cor“ = 0 Memory % E ‘ = 0
P I TR
Monitors = % % (7. gpiolinst 0x8000 53 . I New Rendering;ﬂ
@ cpullinst Register Address Value =
@ gpioQ_inst ~ 2, gpiol_inst 000008000
@ uartl inst ~ }iil RD_DATA_REG 0x00002000 0x00002000
o rd_data [7:0] 00
5 I \WR_DATA_REG 000003004 000003004
5 I SET_DATA_REG 000003008 000003008
5 v CLEAR_DATA_REG 0x0000S00C 0x0000S00C
5 1 DIRECTION_REG 000003010 000003010
< > . [T TVDE RE( v0NNNRNTA MreNNNNANTA v

D TEEE

Figure 3.37. Peripherals View in Debug Perspective

3.5.4. Serial Terminal Tool

Serial port communication is frequently used during the microcontroller debugging. Propel SDK provides a built-in
terminal tool including serial support for debugging.

To launch a serial terminal:
1. Find the Terminal view nested to the Console view. If not found, re-open from Window > Show View > Terminal.

2. In the Terminal view, click the Open a Terminal iconE . The Launch Terminal dialog opens (Figure 3.38).

3. Choose the Serial Terminal and configure the Serial port with Baud rate.

7% Launch Terminal O X

Choose terminal: | Serial Terminal ~
Settings
Serial port: | COM1 “
Baud rate: | 113200 w
Data size: |8 v
Parity: MNone ~
Stop bits: |1 ~
Encoding: | Default (150-8359-1) e

@

Figure 3.38. Launch Terminal Dialog
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4. Click OK. A connection opens.
5. (Optional) Click the Toggle Command Input icon that adds an edit box to enter text (Figure 3.39).

@ thlems}ﬂ Euecutahls} B it E 5 EE| H_ E @ = O

Figure 3.39. Terminal View
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4. Propel Tutorial — Hello World

This “Hello World” project can be found from the template. The “Hello World” project provides a template of using
hardware and software design with the minimal resource required.

Following this tutorial, you can easily create a hardware and software project. After that, you can run the project on
your evaluation board.

The tutorial uses a MachXO03D breakout board as demonstration. It uses R$232 UART function. To enable R$232 UART
function on the MachX03D breakout board, the following reworks on the boards are required.

1. Hardware reworks on MachXO3D breakout board.

Short R14 and R15 using 0 Q resistors, as shown in Figure 4.1.

D)
@ 176
:— -

® @ remR2s

—

MachX03D Breakout Baard

REV A P/N:LCMX03D-9400HC-B-EVN o000
SNLATTICE qeee

| SN SEMICONDUCTORy
000

ez () g Y
oo o RZ4RGS = £ :
. | g. o000
LATTICE ~o000
LCMXO3D-9400HC >0 ®®
5BG256CAS - - *e O ¢
29107H12 Y Y X X )

L NN

'YX X

vidi@
£ld1 @
s1d1®

&=l
]

——
(=
e

[ B

aNe

9141 @

@0 @ 0wy /==
SR39

F5 E3 Bl CIGND|D2 E2 F2 G2 GND[H2 J3 KI L3 GND|L2 M3 M2 N3 105
104 F3 D3 G3 C2|D1 EI F1 GI GND[HI H3 J2 J1 GND[L1 M1 NI H6 103jm 40

P00 OOPOIOGIOGIOGIOGOIOGPIOOGPOOIOGPOO R
POPPPOGOGIOGIOGIOGOGIOGIOGIOGOOGO®®®|uxn

Figure 4.1. MachX03D Breakout Board
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2. Configure the FTDI device with FT_Prog software to enable UART function.
Connect the MachX03D breakout board to host PC and power ON.

Open FT_Prog software. Select DEVICES > Program.
Make sure Port B is configured as RS232 UART in Hardware and Virtual COM Port in Driver. See Figure 4.2.

Select DEVICES > Program from the FT_Prog software again. From the opened Program Devices dialog, click

Program.

Device Tree

Property

Value

=& Device: 0 [Loc ID:0x0]
S=» FT EEPROM
F=$ Chip Details
i=p USB Device Descriptor
=y USB Config Descriptor
i=p USB String Descriptors
=/=p Hardware Specific
-=p Suspend DBUST
-=p TPRDRY
+H=p Port A
E= Port B
-+ [
[H=p Driver
=y 10 Pins

RS232 UART
245 FIFO
CPU FIFO
OPTO Isolate

Device Tree

Property

Value

=& Device: 0 [Loc ID:0x0]
S=» FT EEPROM
F=$ Chip Details
i=p USB Device Descriptor
i=» USB Config Descriptor
i=p USB String Descriptors
=/=p Hardware Specific
-=p Suspend DBUST
-=p TPRDRY
H=p Port A
E= Port B
'=> Hardware
-+

H=p 10 Pins

Figure 4.2 Configure the FTDI Device

3. All the reworks for the MachX0O3D breakout board are completed.

D2XX Direct
Vitual COM Port

4.1. Creating SoC Design Project and Preparing Hardware Design

To start a SoC Design Project from Propel:

Choose File > New > U'h Lattice SoC Design Project.

2. The Create SoC Project wizard opens (Figure 4.3). Enter a project name, such as HelloWorldSoC. Select the Hello

World Project template.
3. Click Finish. A SoC project is created.
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7% SoC Project O *
Create SoC Project —_—
Create 5ol project of selected template ’_ .
Project name: | HelloWoarldSoC I
Use default location
Location: | Chlscc\propely  \workspace\HelloWorldSoC Browse...
Choose file systerm: [default
Template selection
Processor: | RISC-V MC ~ | Farnily: MachXO3D ~
Device: LEMXO3D-S400HC ~ | Performance: 5 ~
Package: |CABGAZSE ~ | Condition: Commercial ~
Board: MachXO3D Breakout ~

Template Design

Helle World Project. Components included:
a) Processor - RISC-V MC wy/ PIC/TIMER
b) GRIO
c) ASRAM - Asynchronous SRAM
d) UART - Serial port

'Hello World Project

® coce

Figure 4.3. Create SoC Project Wizard

4. The created SoC project can be found in the workbench. Its design is opened and displayed in Propel Builder for
review (Figure 4.4).

4 Propel Builder [Chlscc\propel2.0\workspace\ExampleSoC\ExampleSoC/ExampleSoC.sbx] Device: LCMXO3D-9400HC-3BG236C
File Edit View Design Window Help
— = Y
s & H P N e
Design View mi Schematic Address Start Page
- ExampleSoC
3 {'—FE Instances
3 gCl Ports
ahtiZaph_jn
b MNets N = aphal st
A Components i .
e st
|| cpu0:1.0.0 l—m vl — | (T
wrns
2| gpio0:1.2.0 1
@ sysmem0:1.0.0

CHE®E QQQQ

—> geio k{7.0]

FA

Properties =i T

Name:

Type: Instance
Path: ExampleSaC

VLNV: lattice:systembuilder:Examp ~
4 »

IP Catal... Design Vi.. F

|-t 3
Tel Console a
%

Figure 4.4. Propel Builder Window
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5. (Optional) In Propel Builder, update the SoC design to set the preloaded software. Enable the checkbox for Initialize
Memory for system_memory IP module from the Initialization area of the General tab, and set Initialization File
(Figure 4.5) generated from the corresponding Hello World C project in the Creating Hello World C Project section.

% Module/IP Block Wizard X

Configure Component from Module system_memory Version 1.1.2
Set the following parameters to configure this component.

Diagram sysmem0 Configure IP
General Port 50 Settings Port 51 Settings
Property Value
* General
Memory Address Depth [1 - 32768] | 4096
Sysmemo Data Bus Width(bits) 32
Memeory Type EBR
Port Count [1-2] 2

-HBL—SO crv—
—-AHBL_S1

—ahbl_hclk_i ™ Initiakzation
Initialize Memory
| ahbl hresetn i Initialization File Format hex
- - Initialization File :././HelloWorld/Debug/HelloWorld.mem

system_memory

[l » | Mo DRC issues are found.

Generate | Cancel

Figure 4.5. Configure Module System Memory

4.2. Launching Lattice Diamond

Launch Lattice Diamond from the created SoC project. To do that:

1. In Propel Project Explorer view, select the SoC project HelloWorldSoC.

2. Click the Diamond icon  on the toolbar. A Diamond project is created and thus opened automatically in Lattice
Diamond.

3. Switch to Process view of the Diamond project and make sure Bitstream File or JEDEC File is checked in the Export
Files section (Figure 4.6).

4. Choose Process > < Run. Wait for generating programming file successfully. You can see a green checkmark
before each successfully completed process.
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v 2 Place & Route Design ) ExamplesoC Lattice Synthesis Engine for Diamend User ModelSim Users Manual
-
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E : 1/0 Timing Analysis EEISDE Iéautréc: Diamond 3.12 Platform Designer User ModelSim Command Reference Manual
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O : IBIS Model Lattice Diamond 3.12 Programming Tools User Synplify Pro User Guide
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] 2 VHDL Simulation File Software Update Center Reveal User Guide Synplif‘y Pro Language Support Reference
2 Bitstream File Currently running Lattice Diamond software version: Reveal Troubleshooting Guide Manua
] JEDEC File 3.12.0.240.2 Lattice Diamond 3.12 Installation Guide for
& ice Diamond llation Guide for  19/TK
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Last check time: Thu Mar 18 13:46:39 2021 Il:_attlce Diamond 3.12 Installation Guide for Lattice Semicenductor
inux
Answer Datahase hd
File List Process Hierarchy
Output a8 x
synpwrap -msg -prj "ExampleSoC_impll synplify.tcl™ -log "ExampleSol_impll.srf"
Copyright (C) 1992-2020 Lattice Semiconductor Corporation. All rights reserved.
Lattice Diamond Version 3.12.0.240.2
INFO - Synplify synthesis engine is launched. v
Td Comsole  Output | Error  Wamning  Info®
Start: Synplify Pro Mem Usage: 313,948 K

Figure 4.6. Generate Programming File

4.3. Programming the Target Device

Once the programming file is exported successfully in last section, it is ready to program the target device. Make sure
the evaluation board is powered ON and connect correctly to host PC before performing the following procedure.

1.
2.

3.

Click the Programmer icon % on the toolbar of the Lattice Diamond Project Explorer.

The Programmer: Getting Started dialog pops up (Figure 4.7). Click OK.

i} Programmer: Getting Started

Select an Action

@ Create a new project from a JTAG scan
Cable: |HW-USBN-2B (FTDI)

TCK Divider Setting (0-30x):

() Create a new blank project

O Open an existing programmer project

¥ | Port: |FTUSB-O

Detect Cable

Import file to current implementation

C: flscefpropelf2.0/workspace ExampleSaC fimpl 1 fimpl 1. xcf

Cancel

Figure 4.7. Programmer Getting Started Dialog

Review the Device Family, Device, Operation, and File Name in the Programmer window (as shown below).
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@ 8 8
Enable Status Device Family Device Operation File Mame
1 & MachX03D LCMXO3ID-5400HC SRAM Fast Configuration & HelloWordSaC/impll/HelleWerldSaC _impll

g+ |

4. Click the Program icon “*+ to download the programming data file to the device.

4.4. Creating Hello World C Project

Creating C project requires a system environment from SoC project as input.
1. In Propel Project Explorer view, select the SoC project HelloWorldSoC.
2. Choose Project > Build Project.

System environment of the select SoC project is generated under the SoC project folder. Check the result from the
Console view (Figure 4.8).

I#] Problems F.‘é Tasks (E Console &3 = Properties} = Terminaq = 8
X %|EplEEE 0

<terminated> sge [SDP Builder] C\lscc\propel\2.0htoels\python38_embed\python.exe

Warning - Unconnection: cpu@ inst TIMER_IRQ M@ remains unconnected
INFO - Finished: sge generated

Figure 4.8. Build Result of HelloWorld SoC Project

3. Choose File > New > |t Lattice C/C++ Project.
The C/C++ Project wizard opens with Load System and BSP page (Figure 4.9).
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Choose file systern: | default

01 C/C++ Project O d
Load System and BSP —
Correct system environment file and get toelchain parameter J_
—_ _I
Select system environment file and BSP package
I System enw: | Chlscch\propel 2022 Thworkspace\ExampleSoClsgelsys_envaml v| | Browse... |
Select processor core to create C/C++ Project
Core selected: |cpuﬂ_inst V|
Project type: |C V|
Systermn information
Device Family CPU Marne Instance Mame
MachXO3D riscy_mc cpul_inst
Project name: | HelloWaorld)|
Use default location
Location: | Chlscc\propeh2022. 1\workspace\HelloWorld Browse...

®

Finish

Cancel

Figure 4.9. Load System and BSP Page

Select the system environment file just generated (Figure 4.9).

5. Enter project
The C project

name “HelloWorld” (Figure 4.9). Click Next. Then click Finish.

is created and displayed in workbench.

Choose Project > Build Project.

Check the bui

Id result from the Console view (Figure 4.10).
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{2 Problems || Tasks | & Console 2 [ Properties | & Terminal

CDT Build Console [HelloWarld]

...................... T ] i

text data bss dec hex filename
1262 5] 2728 3998 f96 HelloWorld.elf

Finished building: Hellokorld.siz

Invoking: Lattice Create Memory Deployment

4 45| EEE BB -§-= 08

riscv-none-embed-ocbjcopy -0 binary --gap-fill @ "HelloWorld.elf" "HelloWorld.bin™; srec_cat "HellowWorld.bin™

-Binary -byte-swap 4 -DISable Header -Output "HelloWorld.mem™ -MEM 32

Finished building: Hellokorld.mem

16:56:57 Build Finished. @ errors, @ warnings. (tecck 4s.81ems)

Figure 4.10. Build Result of HelloWorld C Project

4.5. Running Demo on MachX03D Breakout Board — Hello world

1. Find the Terminal view nest to the Console view. If not found, re-open from Window > Show View > Terminal.

2. Inthe Terminal view, click the Open a Termin

al icon E.

3. Choose the Serial Terminal and configure the Serial port with Baud rate 115200 (Figure 4.11).

Note: Serial port number depends on specific

PC.

P .
i% Launch Termina

Choose terminal:

Settings

Serial Terminal

Serial port: | COM1

Baud rate: | 113200

Data size: |8
Parity: MNone
Stop bits: |1

Encoding: | Default (150-8359-1)

Cancel

Figure 4.11. Launch Terminal Dialog

4. Click OK. A serial connection communicate with UART is ready.
5. Inthe Project Explorer view, select C project “HelloWorld”.
6. Choose Run > Debug Configurations...
7. Double-click GDB OpenOCD Debugging to create a new launch configuration (Figure 4.12).
8. Click the Debug button.

Wait for a few seconds for switching to debug perspective, to start the server, and to allow it to connect to the

target device, start the gdb client, download the application, and then start the debugging session.

Note: This demo uses default debug configuration options.
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Q Debug Configurations

Create, manage, and run configurations

ERCECEER | v Name: | HelloWorld Debug |
| type filter text | Main CableConrﬂ 35 Debuggeﬂ = Startup\l By Source\l =] Common\l =, SVD P‘athw

[€] C/C++ Application Project:

[€] C/C++ Attach to Application

[E] C/C++ Postmortem Debugger | HelloWorld | | Browse... |

[£] C/C++ Remote Application C/C++ Application:

co-r -

[ C/Ce+ Unit _ [ Debug\HelloWorld.elf |

[ ] GDB Hardware Debugging

w [C] GDB OpenQCD Debugging Variables... | |Search Ploject...| | Browse... |
(€] HelloWorld Debqg Build (if required] before launching

[] GDB QEMU Debugging

L Launch Group Build Cenfiguraticn: | Select Automatically V|

= Launch Group (Deprecated)

piEen (_) Enable auto build () Disable auto build
(®) Use workspace settings Configure Workspace Settings...
Revert Appl

Filter matched 11 of 11 items o
@ Debug | | Close

Figure 4.12. Debug Configurations Page

9. Click the Resume icon 1% on the toolbar. The serial terminal outputs “Hello RISC-V world!” (Figure 4.13).

Dcoms ¢

8 workspace - HelloWorld/src/main.c - Lattice Propel - m] X ‘
File Edit Source Refactor Navigate Search Project Run LatticeTools Window Help
Ov | SO -QUr @S Vv oBin|pumres.o|Bs S0 dvHrvroOrvv|m Q in| e
4% Debug 52 It Project Explo | = B |/[d mainc _ [[€]0x0__ [[d) mainc 3 = O | (= Vari |% Bre | Exp | Mod [=7 Disa 2 . F.Peri| = O
. & 0o >
B %l 8 A3=int main(void) { ~ [Enter location here || &1 @ BI@| 5 = &
v [€] HelloWorld Debug [GDB OpenOCD C 49 static uint8_t idx = @; 5 uin:_ -~
v & HelloWorid.elf 50 0000021a:  addi sp,sp,-32 -
+@ Thread #1 (Running : User Requ |51 uart_init(&uart_core_uart, UARTO_INST_BASE_ADDR, UART@_I 0000021c:  sw s1,20(sp)
# openocd.exe 52 51 uart_init(&uart_core_uart, UAR
4 riscv-none-embed-gdb 53 #ifdef LSCC_STDIO_UART_APB 0000021e: 1u§ a3,0xlc
54 extern struct uart_instance *g_stdio_uart; 00000220:  lui s1,0x8
55 g_stdio_uart = &uart_core_uart; 00000222:  addi al,s1,1024 # 0x8400
56 #endif 00000226 : 1i a5,8
57 00000228:  1i ad,1
58 printf("Hello RISC-V world!\r\n");| 0000022a:  addi  a3,a3,512 # 0x1c200
59 LED_SET(ALL_OFF); 0000022e:  1i a2,38
60 00000232 addi a0,gp,-1964
61 while (true) { 48 int main(void) {
62 LED_SET(LED_ON(idx)); 00000236:  sw ra,28(sp)
63 00000238 : sw s0,24(sp)
64 if (++idx == LED_COUNT) { 0000023a:  sw s2,16(sp)
65 idx = 0; - 51 vart_init(&uart_core_uart, UAR
66 } 0000023c:  addi s0,gp,-1964
67 48 int main(void) {
68 if (RTL_SIM) { 00000240 : sw s3,12(sp)
69 delayMs(1); 00000242 sw s4,8(sp)
70 1 alea f N2 00000244 : jal 0x90 <uart init> b
< > < >
© Console | !1!l Registers | $® Terminal % #] Problems| @ Executables @ Debugger Console| 0 Memory! O|aaiEad~D

Hello RISC-V world!

—
Writable Smart Insert 58:39:2889

&

Figure 4.13. Run Result of Hello World Project
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Appendix A. Linker Script and System Memory Deployment
During the Lattice C/C++ Project creation, Propel SDK generates a linker script file, linker.ld, within the project. This
linker script file contains a memory region list parsing from the corresponding SoC design.

Note: lllegal memory regions are not imported to linker script. A memory region is considered illegal if it has any of the
following conditions:

e No connection to CPU
e  Address space conflict

Each memory region has a list of attributes to specify whether or not use a particular memory region for an input
section (Figure A. 1).

e r:Read-only section.
e w: Read/Write section indicating the memory region is connected to the data port of CPU.

e x: Executable section indicating the memory region is connected to the instruction port of CPU.

Linker Script: linker.ld
Available Memory Regions

MName Attributes || Base Address Size
sysmemi_inst % 0:400000000 (0400008000
sysmermnl_inst w 0:400010000 0:400008000

Figure A. 1. Memory Regions in Linker Script
The generated linker script contains a mapping table of section pointing to memory region (Figure A. 2). Depending on

the attributes of each memory region, code section and data section can point to the same or different memory
regions.

Section to Memory Region Mapping

CODE: |sysmem0_inst -
DATA: |sysmeml_inst -

Section Mame Memory Region i
text sysmermn(_inst 2
.ctors sysmem(_inst

Jdtors sysmermn(_inst 1

Overview | linker.ld

Figure A. 2. Section to Memory Region Mapping

During the Lattice C/C++ Project building, Propel SDK generates Lattice system memory initialization files. Depending
on the number of the memory regions used, it generates single memory initialization file or multiple memory
initialization files. The following picture (Figure A. 3) shows an example of multiple memory files being generated,
separate for code and data segments.
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- (A2 sre

4 = Debug Section to Memory Region Mapping

- 2= src
. 5 Example.elf - [nonefle]

Example_Code.rnem CODE:
Exarnple_Data.mern DATA:

wllF ['|||' ['|||'

= Example.bin
=] Example.lst Section Name
=] Example.map
dext
| @ makefile +
| @ objects.mk o

Jdters
| @ sources.mk o

Memory Region
sysmem(_inst
sysmermn(_inst

sysmem(_inst

E tmp

Overview | linker.ld

Figure A. 3. Linker Script and Generated Memory Files

If you modify the linker script manually after the Lattice C/C++ project creation, especially change the number of the
used memory regions, the number of memory files generated during project building cannot be changed automatically.
You can re-configure the generation of memory files in Propel by:

1.
2.
3.

In the Project Explorer view of Propel, select a C/C++ project.

Choose Project > Properties. The Properties dialog opens showing the properties of the current project.

Select Settings of C/C++ Build category from the left pane. Select the Toolchains tab (Figure A. 4).

Check Create memory file, if you point code and data segments to same memory region. Or, check Create multiple

memory files, if you point code and data segments to separate memory regions.
Click Apply.
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% Properties for HelloWorld O x

| type filter text Settings Sy v 8
» Resource
Builders

s CfC++ Build Configuration: | Debug [ Active ] ~ | | Manage Configurations...

Build Variables
Envircnment

Logging B3 Tool Settings i Toolchains ‘M Devices # Build Steps Build Artifact Binary Parsers | * | *
Settings
Tool Chain Editor Mame: | GMNU MCU RISC-V GCC (riscv-nene-embed-gcc) e
» CfC++ General )
. MCU Architecture: | RISC-V w |
Project Matures Prefix: | riscv-none-embed- |
Project F‘.eferenc.es Suffix: | |
Run/Debug Settings
SystemVerileg Project Properties C compiler: | gec |
Task Repository C++ compiler | g++ |
Task Tags
s Validation Archiver ar

Hex/Bin converter: | ohjcopy

Listing generator: | objdump

Build command: | make

Size command: | size |

Remove command: | rm

Toolchain path: | §{eclipse_home}/../riscv-none-embed-gec/bin

(to change it use the global or workspace preferences pages or the project properties page
Build tools path: | §{eclipse_homel/../build_tools/bin

(to change it use the global or werkspace preferences pages or the project properties page

[] Create memory file

Create multiple memory files
Create extended listing
Print size

Restore Defaults Apply

@ Apply and Close Cancel

Figure A. 4. Toolchains Tab of C/C++ Build Settings

5. Go back to the Tool Settings tab. The relevant Lattice memory deployment tools can be found (Figure A. 5).
Customize the tool options as needed.

6. Click Apply and Close to save the change.
Note: Setting for each configuration, Debug or Release, is independent.
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B9 Tool Settings i) Toolchains M Devices . Build Steps Build Artifact Binary Parsers II‘Z‘

(2 Target Processor LIFill gaps in the data
(22 Optimization Diata Walue 0

@ Warnings
@ Debugging

w 83 GNU RISC-V Cross Assembler
@ Preprocessor
@ Includes
@ Warnings
@ Miscellaneocus

w B85 GNU RISC-V Cross C Compiler
@ Preprocessor
@ Includes
@ Optimization
@ Warnings
@ Miscellaneocus

w 83 GNU RISC-V Cross C Linker
@ General
@ Libraries
@ Miscellaneocus

w 83 GNU RISC-V Cross Create Listing
@ General

w 83 GNU RISC-V Cross Print Size
@ General

Address Range | (x8000

w 83 Lattice Create Memory Deployment
@ General

w 83 Lattice Multi Memory Deployment (CODE SEGMENT)
(2 General

~ B3 Lattice Multi Memary Deployment (DATA SEGMENT)
(& General

| Restore DefauHs| | Apply |

Figure A. 5. Tool Settings Tab of C/C++ Build Settings
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Appendix B. Standard C Library Support

Propel SDK bundles Picolibc as the standard library support (https://keithp.com/picolibc/). Picolibc is a set of standard
C libraries, both libc and libm, designed for smaller embedded systems with limited ROM and RAM. Picolibc includes
code from Newlib (https://sourceware.org/newlib/) and AVR Libc (https://www.nongnu.org/avr-libc/).

Printf and Scanf levels in Propel SDK

Propel SDK provides three levels of printf support with the support of Picolibc, which can be selected when creating a
Lattice C/C++ project (Refer to Figure B. 1), or be modified in the toolchain settings in the project properties after the
project is created, noting that the options in both compiler and linker need to be set (Refer to Figure B. 2 and

Figure B. 3).

e Integer only printf. This is the default selection in Propel SDK, which removes the support for all float and double
conversions to save code size.

e  Float printf. It requires a special macro for float values: “printf_float™. To make it easier to switch between that and
other two levels, that macro should also be correctly defined for the other two levels.

Here is a sample program to demonstrate the usage:

#tinclude <stdio.h>

void main(void) {
printf(" 2761 = %11d, Pi = %.17g\n", 111 << 61, printf_float(3.141592653589793));

}

e  Full printf. This offers full printf functionality, including both float and double conversions.

System Library Interfaces used in Propel SDK

Propel SDK provides three system library for stdio support with the help of Picolibc, which can be selected when
creating a Lattice C/C++ project (refer to Figure B. 1), or be modified in the toolchain settings in the project properties
after the project is created, noting that only the option in linker needs to be set (refer to Figure B. 3).

e Default. Use the default system library interface (UART) in BSP, this requires a UART instance inside SoC design.

e Semihosting. “Semihosting” is a mechanism that enables code running on the target to communicate with and use
the 1/0 of the host computer. Propel SDK provides semihosting support in On-Chip-Debugging flow. It allows
printing messages to the debugger console without relying on the UART instance.

e Dummyhosting. Dummy stdio hooks. This allows programs to link without requiring any system-dependent
functions. This is only used if the program doesn't provide its own version of stdin, stdout, stderr.
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0% C/C++ Project

Lattice Toolchain Setting

Configuration: | Debug

Lib Setting  C/C++ Compiler C/C++ Linker

() Mo default libraries (-nedefaultlibs)

() Newlib

(O Mewlib-nano (--specs=nano.specs)

(®) Picolibe (--specs=picolibc.specs)

Printf Level

(®) Integer only printf (-DPICOLIBC_INTEGER_PRINTF_SCANF)
() Float printf (-DPICOLIBC_FLOAT_PRINTF_SCANF)
() Full printf (-DPICOLIBC_DQOUBLE_PRINTF_SCANF)

Systern Library
(®) Default

(O) Semihosting (--oslib=semihost)
() Dummyhosting (--oslib=durnmyhost)

< Back MNext = Cancel

Figure B. 1. Lattice Toolchain Setting Dialog
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Q Properties for Example

| type filter text

> Resource
Builders
w C/C++ Build
Build Variables
Environment
Logging
Settings
Tool Chain Editor
» C/C++ General
> MCU
Project Matures
Project References
Run/Debug Settings
SystemVerilog Project Properties
Task Repository
Task Tags
» Validation

Settings

Configuration: | Debug [ Active ]

% Tool Settings £ Toolchains

@ Target Processor
(2 Optimization
(# Warnings

(2 Debugging

@ Preprocessor
@ Includes
(# Warnings
(2 Miscellaneous

(22 Preprocessor
(2 Includes
(2 Optimization
(22 Warnings
@ Miscellanecus
~ B3 GMU RISC-V Cross C Linker

O X
=1 A= 1
A
A | | Manage Conﬁgutatiom...|
- Devices # Build Steps Build Artifact Binary Parsers @ Error Parsers
[] Generate assembler listing (-Wa,-adhlns="S@.lst")
[]5ave temporary files (--save-temps Use with caution!)
[ Verbose (-v)
« B GNU RISC-V Cross Assembler Other compiler flags | --specs=picolibc.specs -DPICOLIBC_INTEGER_PRINTF_SCANF I
~ B8 GMU RISC-V Cross C Compiler
v
|Apply and Closel | Cancel

Figure B. 2. Properties of C/C++ Project — Compiler Options
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(= Libraries
(& Miscellaneous
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~ ® GNURISC-V Cross Print Size [ Cross reference (-Xlinker --cref)
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[ Use float with nano printf (-u _printf_float)
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Figure B. 3. Properties of C/C++ Project — Linker Options
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Appendix C. Third-party Command-line Tools in Lattice Propel
SDK

The Propel SDK integrates with a number of third-party command-line tools, which can be used with Propel User
Interface or as stand-alone command-line tools. You can find these command-line tools and their documentation
according to the following list.

1.

Windows Build tools
Version: 4.2.1-1
Binaries Location: <Propel Installation Location>\sdk\build_tools\bin

Documents Location: <Propel Installation Location>\sdk\build_tools\share

OpenOCD
Version: 0.10.0
Binaries Location: <Propel Installation Location>\sdk\openocd\bin

Documents Location: <Propel Installation Location>\sdk\openocd\doc

GNU RISC-V Embedded GCC
Version: 10.2.0-1.2
Binaries Location: <Propel Installation Location>\sdk\riscv-none-embed-gcc\bin

Documents Location: <Propel Installation Location>\sdk\riscv-none-embed-gcc\share\doc

Picolibc
Version: 1.7.4

Binaries Location: <Propel Installation Location>\sdk\riscv-none-embed-gcc\riscv-none-embed\picolibc\riscv-none-
embed\lib

Documents Location: <Propel Installation Location>\sdk\riscv-none-embed-gcc\doc

SRecord
Version: 1.6.4
Binaries Location: <Propel Installation Location>\sdk\tools\bin

Documents Location: <Propel Installation Location>\sdk\tools\bin
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Appendix D. Command-line Environment Setting Script in Lattice
Propel SDK

Propel provides a script to set necessary environment variables for running all Propel SDK command line tools. It
enables you to fast get up to using command line tools, especially for Lattice specific tools.

To use the script:

1. Run the script propel_commandline.cmd (Windows) or propel_commandline.sh (Linux) under <Propel Installation
Location>.

The message "Lattice Propel Commandline" is printed, and let you go to a new command line interface.

2. All command line tools in the Propel SDK can be run from this command line interface without any special
configuration.

Here are examples of using the command line tools within this script.

Example A: Build a C project under command line.

$ cd <C project Location>/Debug
$ make

Example B: Launching openocd under command line.

$ cd <C project Location>

$ openocd -c "gdb port 3333" -c "set target 0" -c "set tck 1" -c "set
port FTUSB-0" -c "set RISCV_SMALL YAML src/cpu0.yaml" -f
interface/lattice-cable.cfg -f target/riscv-small.cfg
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Technical Support Assistance

Submit a technical support case through www.latticesemi.com/techsupport.
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