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Type Conventions Used in This Document
Convention Meaning or Use

Bold Items in the user interface that you select or click. Text that you type 
into the user interface.

<Italic> Variables in commands, code syntax, and path names.

Ctrl+L Press the two keys at the same time.

Courier Code examples. Messages, reports, and prompts from the software.

... Omitted material in a line of code.

.

.

.

Omitted lines in code and report examples.

[ ] Optional items in syntax descriptions. In bus specifications, the 
brackets are required.

( ) Grouped items in syntax descriptions.

{ } Repeatable items in syntax descriptions.

| A choice between items in syntax descriptions.
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Chapter 1

Lattice Radiant Software 3.2 
Installation Guide for Windows

This document provides installation instructions for Lattice Radiant® Software 
for Windows.

Radiant software supports iCE40 UltraPlus™,CertusPro™NX (LFCPNX) 
Certus™-NX (LFD2NX) CrossLink™-NX (LIFCL) Certus™-NX-RT (UT24C) 
CertusPro™-NX-RT (UT24CP) MachXO5-NX (LFMXO5).

Radiant software is available in a 64-bit version.The 64-bit version of Radiant 
software is optimized to run on Windows 64-bit systems. Radiant software 
must be running on Windows 64-bit systems.

System Requirements
The following are the basic system requirements for Radiant software on 
Windows:

 Intel Pentium or Pentium-compatible PC

 64-bit OS

 Windows 10

 Approximately 10 GB free disk space

 Computer Memory Requirement: 16 GB Recommended for running a 
single project. If running multiple projects, the memory requirement will be 
higher

Note
The available devices vary depending on the type of license.
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 Network adapter and network connectivity

 1024 X 768 graphics display

 Microsoft-compatible mouse and mouse driver

 A Web browser with Javascript capability

 Adobe Acrobat Reader

Contacting Technical Support
FAQs The first place to look. The Answer Database provides solutions to 
questions that many of our customers have already asked. Lattice 
Applications Engineers are continuously adding to the Database.

To access the Answer Database, go to www.latticesemi.com > Support > 
Answer Database.

Telephone Support Hotline Receive direct technical support for all Lattice 
products by calling Lattice Applications from 5:30 a.m. to 6 p.m. Pacific Time.

 For USA & Canada: 1-800-LATTICE (528-8423)

 For other locations: +1 503 268 8001

In Asia, call Lattice Applications from 8:30 a.m. to 5:30 p.m. Beijing Time 
(CST), +0800 UTC. Chinese and English language only.

 For Asia: +86 21 52989090

E-mail Support

 techsupport@latticesemi.com

For Local Support Contact your nearest Lattice Sales Office.

Installing Radiant Software for Windows
The following sections describe product options and installation instructions 
for Radiant software for Windows.

Note
A node-locked license is based on the physical (hard-coded) address provided by 
the network adapter. Network connectivity is not necessarily required for a node-
locked license. In the absence of a network connection, you can install the NWLink 
IPX/SPX protocol to force the recognition of your NIC card ID (see “Licensing for 
Radiant Software and Stand-Alone Power Estimator” on page 11).

A floating license requires access to the license server, so both a network adapter 
and connectivity are required.

http://www.latticesemi.com
http://www.latticesemi.com/en/Support/AnswerDatabase.aspx
mailto:techsupport@latticesemi.com
http://www.latticesemi.com/Buy.aspx
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Software Product Options
Table 1 shows the product options for the installation of Radiant software for 
Windows.

Table 2 shows the tools included in the Radiant software for Windows option. 

Table 1: Radiant Design Tools Installation Options
Product Option Description

Radiant software for 
Windows

Installs the Radiant software design tools for all Lattice Semiconductor FPGA 
designs. Table 2 lists the tools included in this option.

FPGAs Installs the FPGA design environment.

ModelSim Lattice 
Edition

Installs Siemens® ModelSim™ Lattice Edition simulation tool. A license for ModelSim 
is included.

Programmer Drivers Installs drivers for the Radiant Programmer tool, which loads FPGAs with the 
designs.

Table 2: Tools Included in the Radiant Software for Windows Option
Tool Description

Project Management 
Tools

Includes the Reports view, and the Security Setting tool to enable you to create and 
maintain the project, keep track of the stages in the design implementation process, 
review reports, and compare different implementations of the project.

Design Entry Tools Include Source Editor and Device Constraint Editor, which offer VHDL, Verilog, 
schematic, and mixed-mode design entry support and design structure check..

Design Simulation 
Tools

Include Simulation Wizard and ModelSim Lattice Edition for performing functional 
simulation for the projects and creating the test stimulus files.

Design Constraints 
Application Tools

Include Physical Designer, and Netlist Analyzer to enable you to set constraints for 
implementing the design.

Design 
Implementation 
Tools

Include Synplify Pro for Lattice, Lattice Synthesis Engine (LSE), Clear Tool Memory, 
Map, Place & Route, and Bit Generation to ease the design implementation process.

Analyzing Static 
Timing, Power 
Consumption, and 
Signal Integrity Tools

Include Timing Analysis View and Power Calculator to enable you to estimate the 
design performance, experiment with different configurations, and to calculate power 
consumption.

Programming the 
FPGA Tool

Include Programmer, Deployment Tool, Download Debugger, and Programming File 
Utility tools to let you program the FPGAs.

Testing and 
Debugging On-chip 
Tools

Includes Reveal Inserter and Reveal Analyzer to let you complete the final stage of 
developing a design: testing in the actual FPGA, either on a test board or in your 
system.

HTML Help and User 
Documentation

Includes complete instructions for designing with Radiant software design tools and 
third-party tools. Also provides user manuals, tutorials, example design projects, and 
access to technical documentation from the Lattice Semiconductor Web site.

Tcl/Tk Scripting Tool Enables you to automate Radiant software design processing.



LATTICE RADIANT SOFTWARE 3.2 INSTALLATION GUIDE FOR WINDOWS : Installing Radiant Software for Windows

Lattice Radiant Software 3.2 Installation Guide for Windows 9

Installation Procedure
Radiant software is available for download from the Lattice Radiant 
Downloads & Licensing web page located at 
http://www.latticesemi.com/latticeradiant. Click the Downloads tab. Some 
documents and downloads are not visible to anonymous visitors. To view all 
items, please log in to your Lattice account. Follow the product download 
instructions and uncompress the software.

To install the Lattice Semiconductor Radiant software for Windows:

1. Close all applications before starting Radiant software installation.

2. Double-click on the Radiant software installer you downloaded to launch 
the installation process.

3. The Welcome To Lattice Radiant Software 3.2 Setup dialog box opens.

4. Click Next to select Installation Folder.

5. The default destination folder is C:\lscc\radiant\3.2. Click Browse to 
change the drive or destination folder.

6. Click Next to open the Product Options dialog box.

7. Select the Radiant software components that you want to install by 
selecting or clearing each of the listed options. If you have purchased 
third-party synthesis and simulation tools directly from the third-party 
vendors, you can clear the ModelSim Lattice Edition product options.

The FPGAs product option has additional options for selecting the Lattice 
FPGA devices that you want to install. To set the additional options, select 
FPGAs and click the device.

8. Click Next to open the License Agreement dialog box.

http://www.latticesemi.com/latticeradiant
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Figure 1: Select Components

9. Read the license agreement. If you agree, click I accept the license to 
open the Start Menu shortcuts dialog box.

10. Click Next to open the Select Program Folder dialog box. The default 
name of the program group is Lattice Radiant Software 3.2. If you want 
to change the name, change it in the Program Folder text box.

11. Click Next to display the Ready to Install dialog box. Review the current 
settings: the destination folder and components selected. If everything is 
correct, select Install to start the installation.

12. In the Installation Wizard Complete dialog box, read the confirmation note 
and click Finish. 

Note
Do not close the installation window. The window automatically closes once the 
installation is completed.

Note
If you encounter a problem when opening a Radiant project on a virtual machine 
(VM), you will need to set the environment variable “QT_OPENGL=angle”.
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13. If you have never installed any Lattice Software before, the FlexNet 
License Finder dialog box will pop up to ask you for the license. Select the 
desired license option and click Next to complete the license installation.

Figure 2: Flex License Finder

Licensing for Radiant Software and 
Stand-Alone Power Estimator
When installation is complete, you will need to use the Lattice website to 
apply a license to your Radiant software. 

The license you received is based on the identification of your network 
interface card (NIC). The NIC ID or equivalent is the 12-character 
hexadecimal physical address. License your software early to avoid any down 
time.

You can also get the NIC via an alternate network interface, such as a 
wireless interface.

To obtain a license file for your Radiant software:

1. Go to Lattice Semiconductor Software Licensing page: 
www.latticesemi.com/licensing

2. Select Lattice Radiant Software.

3. Follow the on-screen instructions.

Note
The available devices for Radiant software can vary, depending on the type of license.
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Optional Floating License Setup
To enable a floating license, you must have a license server set up on a 
Windows or Linux server to monitor your Radiant software license. Each client 
PC must have the LM_LICENSE_FILE variable set to point to the license file 
on the server.  

Before you start the server setup, ensure that TCP/IP is installed and that the 
client machines can communicate with the server by name. At the prompt in a 
Command Prompt window, type the following:

ping <hostname>

Table 3 lists the files used for license management for 64-bit systems. The 
files are located at:

<Radiant_install_path>\ispfpga\bin\nt64

Note
Radiant software uses the following network communication ports (TCP/IP socket 
ports):

 Port 80 – This is the standard HTTP web access port.  Radiant software uses this 
port in the following cases:

 When the Lattice Radiant software has updates from the Lattice web site:

 IP or reference designs are downloaded from the Lattice web site:

 When message ID's are sent.

 Port 7788 – This is the port used by the Radiant software to check the floating 
license between the software and license server.  This port is configurable by 
changing the license files.

Table 3: License Management Files
Filename Version Description

lmgrd.exe 11.16.4.0 The license server program.

lmutil.exe 11.16.4.0 FLEXlm utility for diagnosing, reporting, and controlling 
licensing.

lmtools.exe 11.16.4.0 Program that sets up the server for floating licenses.

lattice.exe 11.16.4.0 The Lattice Semiconductor licensing daemon.

Note
Users of the ispLEVER 7.0 or older software must bring down the previous license 
daemon and start the new license daemon.
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Editing the License File
After obtaining a floating license from Lattice Semiconductor, you must edit 
the license file to specify the server name and the paths to the Lattice 
daemon. An example of a floating license file is shown below.
SERVER nodename 001143D94535 7788
DAEMON lattice daemon_path
FEATURE LSC_ADVANCED lattice 8.0 01-jan-9999 100 EE7E589FBD53 \

VENDOR_STRING="ispLEVER Advanced"
FEATURE LSC_BASE lattice 8.0 01-jan-9999 100 F901F7E7F4F1 \

VENDOR_STRING="ispLEVER Base"
FEATURE LSC_RADIANT lattice 10.0 01-jan-9999 100 6D8288983379 \

VENDOR_STRING=LSC_RADIANT
FEATURE LSC_OBSOLETE_DEVICE lattice 10.0 01-jan-9999 100 7D131CCD0F18 \

VENDOR_STRING=LSC_OBSOLETE_DEVICE  

To edit the license file:

1. Edit the SERVER line by replacing nodename with the host name of the 
server for which you requested your license.dat file. You may also need to 
change the PORT NUMBER (7788).

2. Edit the DAEMON lattice line by replacing daemon_path with the path 
to the lattice daemon, for example:

C:\lscc\radiant\3.2\ispfpga\bin\nt64\lattice.exe

3. Edit the ModelSim DAEMON line, replacing daemon_path with the path to 
ModelSim Lattice Edition. For ModelSim, the path is:

% <install_path>/radiant/3.2/modeltech/win32loem/mgcld

When you are editing these lines, make sure that they are typed exactly as 
you received them.

License Server Setup
To set up your license manager as a system service:

1. Copy the license file (license.dat) to 
<Radiant_install_path>\license\license.dat.

2. Double-click the <Radiant_install_path>\ispfpga\bin\nt64\lmtools.exe file 
to open the LMTOOLS dialog box.

3. Choose the Config Services tab in the LMTOOLS dialog box.

Note
The “\” followed by a carriage return indicates a line continuation.

Note
Windows 7 users may need to right click on LMTOOLS.exe and select Run as 
Administrator.
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4. Change Service Name to Lattice FLEXlm Service 1.

5. Browse and set lmgrd.exe to <install_path>\ispfpga\bin\nt64\lmgrd.exe.

6. Browse and set the license file to <install_path>\license\license.dat.

7. Browse and set the debug log file to <install_path>\license\lattice.log.

8. Click Save Service.

9. Select the Start/Stop/Reread tab.

10. Click Start Server.

11. Select the Config Services tab.

12. Select View Log to view the lattice.log file. Check to see if there are any 
problems starting the license server. If there are no problems, close the 
log file.

13. Choose Start > All Programs > Lattice Radiant Software 3.2 to verify 
license checkout (this will be reflected in the lattice.log file). Close 
Radiant.

14. Choose the Start/Stop/Reread tab in the LMTOOLS dialog box.

15. Select Stop Server.

16. Select the Config Services tab. Select Use Services and Start Server at 
Power-Up.

17. Click Save Service, and then select File > Exit.

18. Restart the Windows server system.

19. Start the Radiant software again to verify that the license server is running 
as a service.

Windows License Server Setup for 
ModelSim Lattice Edition
If you want to run the ModelSim Lattice Edition software, you must have a 
separate license file for ModelSim Lattice Edition installed.

The steps below show you how to setup a server-based license for ModelSim 
Lattice Edition.

Modify the license file. 

See below for the example:

SERVER put_server_name_here 283A4D51E5C8 1717

DAEMON mgcld path_to_mgcld

INCREMENT latticemsim mgcld 2020.10 24-sep-2021 4 
2F51711882B1345257E8 \

    VENDOR_STRING=E0A4806A HOSTID=283a4d51e5c8 
ISSUER="ModelSIM Lattice" \
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    SN=72951337 SIGN2="016B 9A3C 250A 4BE0 4EA2 6214 A021 
CABE 0739 573F \

    D7E9 BC45 3706 2F63 8829 122B D282 EBFC A8B1 62AB 78C5 4F8E 
F369 CE8E \

    306B F3C5 1F73 4941 503A D5CB"

 Replace put_server_name_here with the name of your server or PC.

 Replace path_to_mgcld with the path to the mgcld executable. In the 
ModelSim OEM edition, the path is <install_dir>/win32loem/

SERVER L-PF1KDFY9 283A4D51E5C8 1717

DAEMON mgcld C:\Mentor\modelsim\modeltech\win32loem

INCREMENT latticemsim mgcld 2020.10 24-sep-2021 4 
2F51711882B1345257E8 \

    VENDOR_STRING=E0A4806A HOSTID=283a4d51e5c8 
ISSUER="ModelSIM Lattice" \

    SN=72951337 SIGN2="016B 9A3C 250A 4BE0 4EA2 6214 A021 
CABE 0739 573F \

    D7E9 BC45 3706 2F63 8829 122B D282 EBFC A8B1 62AB 78C5 
4F8E F369 CE8E \

    306B F3C5 1F73 4941 503A D5CB"

Start the license server using LMTools.

Run LMTools is located at: <install_dir>/win32loem/lmtools.exe

1. In the Config Services tab:

 Create a Service Name

 Browse to the path of the lmgrd.exe file ( <install_dir>/win32loem/)

 Browse to the path of the license file

 Browse to the location of where you want to create the log file.

 Save the Service by click “Save Service” button.
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Figure 3: LMTools_Config Services

2. In the Server/License File tab, select “Configuration using Services”

3. In the Start/Stop/Reread tab, click “Start the Server” button.

4. In the Server Status tab, click “Perform Status Enquiry” button to ensure 
that the server will be started properly.

5. If you see that your daemon is up and see the number of licenses 
available, your server has started successfully. 

Configure your LM_LICENSE_FILE environment variable:

 In Control Panel --> Advanced system settings --> Environment 
Variables, modify or create your LM_LICENSE_FILE to include the 
port@servername.  In the example LM_LICENSE_FILE value is:  
1717@L-PF1KDFY9).

Floating License Configuration
In this configuration, Radiant software is installed on your license server (for 
license manager utilities and daemons) and on each client that uses Radiant 
software. This configuration gives the best run-time performance.

After you receive your floating license and ensure that the license manager is 
running, install the Radiant software locally on each client that will use the 
floating license.

Note

Radiant floating license is not available in the website. User will have to 
request a Support Case (http://www.latticesemi.com/Support/
SubmitSupportTicket).

http://www.latticesemi.com/Support/SubmitSupportTicket
http://www.latticesemi.com/Support/SubmitSupportTicket
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Set your system variable LM_LICENSE_FILE to point to 
TCP/IP_PORT@hostname

Setting up Floating License on Linux
You can also put the Radiant software license on a Linux machine. Then each 
client (Windows or Linux) points to the license file on the Linux machine. In 
this case, you need to set the environment variable LM_LICENCE_FILE value 
to License_Port_number@linux_host_name. Or, have the 
LM_LICENSE_FILE value set to the path to a license file on the client that is 
set up with the SERVER name of the Linux_host_name and 
License_Port_number.

Troubleshooting Licensing Problems
If you encounter problems with your license, refer to Table 4 for common 
FLEXlm error messages and possible causes or solutions. 

If you encounter any software-related problems, review the following common 
troubleshooting scenarios before calling Lattice Semiconductor Technical 
Support:

 Ensure that your environment variable settings are set correctly, including 
the TEMP user variable. 

 For Windows, your system should contain the following environment 
settings:

SET LM_LICENSE_FILE=<install_path>\license\license.dat

Table 4: FLEXlm Error Messages
FLEXlm Error Message Possible Causes or Solutions

Invalid parameter [-42, 252]  The LM_LICENSE_FILE variable has not been set properly.

 The license file is invalid.

 An invalid feature is specified in the license file.

Invalid parameter [-42, 252:10061]
Winsock error code

 You have a floating license, and the license daemon has not 
been started at the Windows NT server.

 The network connection between the server and the client 
has not been established.

Invalid parameter [-12, 122]
Invalid returned data from license server

The node name of the Windows NT server does not match the 
one in your floating license file.

Invalid parameter [-5, 222]
No such feature exists

The feature could not be found in the license file.

! License Check Failed You either have a node-locked license or you do not have a 
license file. Contact Lattice Semiconductor Technical Support for 
a valid floating license file.
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You can verify these settings by accessing the System Properties dialog 
box from your Windows system. Select the Advanced tab and the 
Environment Variables section.

If Radiant software still does not run after you have installed your new license 
file and confirmed that your environment variables are correct, gather the 
following items:

 A screen capture showing the error message

 A text file that contains a listing of the environment setup for your PC. 
From an Command Prompt window, issue the set > env.txt command.

 Your license.dat file

Combine these items in a zip file and e-mail it to 
techsupport@latticesemi.com. Include an explanation of the problem.

Running Multiple Versions of Lattice Software
Radiant software enables you to run FPGA designs on platforms on which 
Radiant and previous Diamond/ iCE are installed. You can run current and 
previous versions.

Running Radiant Software
After the software and license configuration have been installed, you can 
invoke Radiant software.

Running Radiant Software Locally
If you have installed Radiant software on your local machine:

 In Windows 7, choose Start > All Programs > Lattice Radiant Software 
3.2 > Radiant Software.

 In Windows 8/8.1 or Windows 10, choose Apps > Lattice Radiant 
Software 3.2 > Radiant Software.

The Radiant software main window is invoked.
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Running Radiant Software using 
Windows Remote Desktop
You can also install Radiant software on a shared disk, installation procedure 
of which is exactly the same as that for the local installation. After the license 
file setup, you can access the shared disk from the Windows Explorer and 
then invoke Radiant software from that installation directory by double-clicking 
<boot_drive>:\<Radiant_install_directory>\bin\nt64\pnmain.exe

When the installation is finished, make sure to set the LM_LICENSE_FILE 
environment variable to be the location of your license file. When you use a 
client-server setup, it is recommended that you use a floating license. Then 
set LM_LICENSE_FILE=7788@nodename. Confirm that it works by selecting 
and compiling one of the examples on the client.

Finding the Installation History
The Radiant software records a log of the installation history, which you can 
find from the Radiant software main window.

To view the installation history:

1. Open the Radiant software main window.

Select Help > About Lattice Radiant Software. See the Installation History 
tab.

Updating Lattice Radiant Software
After you have registered and licensed your installation, check the Lattice 
Semiconductor Web site for new software updates, device support, and 
enhancements. Make sure that you have the latest software by checking for 
updates regularly. 

To activate UPDATE:
1. To enable automatically check for software update when Radiant software 

is launched, if you don’t see Update window pops up. In Start page do as 
follows:

 Select the Startup tab of the Options dialog box in Tools, click 
“Automatically check for software update when Lattice Radiant 
Software launches” and choose how often it will check.

Figure 4: Startup Tab of the Options Dialog Box
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When Radiant software is launched, it will connect to the Internet 
automatically to check for updates.

Changing the Network Setting
To enable automatic checking, you must indicate how your computer 
accesses the Internet.

To change the Internet connection settings:

1. Select the Network Setting tab of the Options dialog box in Tools.
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Figure 5: Network Settings Tab of the Options Dialog Box

2. Select the Use a Proxy Server option if you must go through a proxy 
server before connecting to the Internet. The proxy server prevents 
outsiders from breaking into your organization’s private network. Ask your 
system administrator for the URL address and port assignment. This 
option is turned on by default.

If you use direct Internet access, do not select the Use a Proxy Server 
option on this tab.

Installing Updates
When you use the Auto Check feature, UPDATE notifies you whenever an 
update version of Radiant software becomes available. You receive 
notification when you open the Radiant software main window.
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To check and install the recommended update:

 Launch Radiant software and the UPDATE software goes online to check 
for an update. If one is available, the Radiant software update version will 
be displayed in the Available update versions field.

 Click Download to save the update to a directory and install it later.

 Click Install to download and install the selected update version (as the 
version number specified in the Available update versions field) right 
away.

To install a downloaded update:

1. Close all Radiant tools.

2. Go to the location where you saved the update version.

Double-click the update file and follow the on-screen instructions.

Running Radiant Software from the Command Line
There are two ways to run the Radiant software from the command line: 
through Radiant Tcl Console or by running executable files directly.

Running Stand-Alone Radiant Tcl 
Console
Radiant software development environment includes Radiant Tcl Console, 
which allows you to run scripts for automating common tasks. Radiant Tcl 
Console is also available outside of the user interface in order to run custom 
scripts. To launch the stand-alone Radiant Tcl Console, enter the following on 
a command line:

% <install_path>/bin/nt64/pnmainc

You can run Power Calculator by running:

% <install_path>/bin/nt64/pwcmain

These commands configure the environment allowing all of the underlying 
design tools to be run. Refer to the online Help for more information about the 
command line.
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Installing Stand-Alone Radiant Programmer
Programmer is included in the Radiant software installation and consists of six 
tools:

 Radiant Programmer

 Deployment Tool

 Download Debugger

 Programming File Utility

 Install & Uninstall Cable Drivers

If you want to use Programmer, Deployment Tool, Download Debugger, or 
Programming File Utility without installing Radiant software, you can install 
the stand-alone Programmer.

The stand-alone Programmer is available in 64-bit versions.

Follow the product download instructions and uncompress the software. For 
more information on how to download stand-alone Programmer, go to 
http://www.latticesemi.com/Latticeradiant and click the Downloads tab. Some 
documents and downloads are not visible to anonymous visitors. To view all 
items, please log in to your Lattice account. 

To install the stand-alone Programmer:

1. Close all applications before starting installation.

2. Double-click on the Programmer installer you downloaded to launch the 
installation process.

3. The Welcome To Lattice Radiant Programmer setup dialog box opens.

4. The default destination folder is C:\lscc\programmer\radiant\3.2. Click 
Browse to change the drive or destination folder.

5. Click Next. The default name of the program group is Lattice Radiant 
Programmer 3.2. If you want to change the name, change it in the 
Program Folder text box.

6. Click Next to open the Select Components dialog box.

7. Click Next to open the License Agreement dialog box.

8. Read the license agreement. If you agree, click I accept the license. then 
click Next to open the Start Menu shortcuts dialog box.

9. The default shortcuts name is "Lattice Radiant Programmer 3.2". Type a 
new name in the text box if you wish to change it.

10. Click Next to start installing the selected components

11. In the InstallShield Wizard Complete dialog box, read the note and click 
Finish.

http://www.latticesemi.com/latticeradiant
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Install and Uninstall Cable Drivers

To start the Install & Uninstall Cable Drivers:

 In Windows 7, choose Programs > Lattice Radiant Programmer 3.2 > 
Install & Uninstall Cable Drivers from the Windows Start menu.

 In Windows 8/8.1 or Windows 10, choose Apps > Lattice Radiant 
Programmer 3.2 > Install & Uninstall Cable Drivers

Parallel port or USB drivers are required to program Lattice devices using the 
Lattice download cables. To install the drivers, you must have administrative 
privileges.

Two drivers installation options are available in the Drivers Install/Uninstall 
dialog box.

Figure 6: Driver Installation Options

 Parallel port driver – Supports device programming through the parallel 
port of your PC. The driver can be installed on Windows 7, Windows 8/
8.1, and Windows 10.USB port driver – Supports device programming 
through the USB port of your PC. The driver can be installed on Windows 
7, Windows 8/8.1, and Windows 10. This is for the HW-USBN-2A USB 
cable.

 FTDI USB driver – This supports Lattice HW-USBN-2B USB cable and 
Lattice evaluation boards with FTDI (Future Technology Devices 
International) USB host chip. The driver does not support Windows 2000 
and earlier operating systems.

1. In the Drivers Install/Uninstall dialog box (Figure 6), select the desired 
driver and click Install.

2. When prompted, verify the USB cable is plugged in and click Yes.

Note
The first time the FTDI driver is installed, the Windows operating system may 
report that Windows can't verify the publisher of this driver software. Select “Install 
this driver software anyway.” This warning will not occur on subsequent 
installations.
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3. In the Installation Wizard Complete dialog box, and click OK. 

Starting Stand-Alone Radiant 
Programmer

To start the stand-alone Radiant Programmer:

 In Windows 7, choose Programs > Lattice Radiant Programmer 3.2 > 
Radiant Programmer from the Windows Start menu.

 In Windows 8/8.1 or Windows 10, choose Apps > Lattice Radiant 
Programmer 3.2 > Radiant Programmer.

Starting Stand-Alone Deployment Tool

To start the stand-alone Deployment Tool:

 In Windows 7, choose Programs > Lattice Radiant Programmer 3.2 > 
Deployment Tool from the Windows Start menu.

 In Windows 8/8.1 or Windows 10, choose Apps > Lattice Radiant 
Programmer 3.2 > Deployment Tool.

Starting Stand-Alone Download 
Debugger

To start the stand-alone Download Debugger:

 In Windows 7, choose Programs > Lattice Radiant Programmer 3.2 > 
Download Debugger from the Windows Start menu.

 In Windows 8/8.1 or Windows 10, choose Apps > Programs > Lattice 
Radiant Programmer 3.2 > Download Debugger.

Note
Do not close the installation window. The window automatically closes once the 
installation is completed.
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Starting Stand-Alone Programming File 
Utility

To start the stand-alone Programming File Utility:

 In Windows 7, choose Programs > Lattice Radiant Programmer 3.2 > 
Programming File Utility from the Windows Start menu.

 In Windows 8/8.1 or Windows 10, choose Apps > Lattice Radiant 
Programmer 3.2 > Programming File Utility.

Installing Stand-Alone Radiant Reveal Logic 
Analyzer

Radiant Reveal Logic Analyzer is included in the Radiant software installation. 
If you want to use the tool without installing Radiant software, first download it 
from the Lattice Semiconductor Web site. 

Radiant Reveal Logic Analyzer is available in 64-bit versions.

For more information on how to download stand-alone Radiant Reveal Logic 
Analyzer, go to http://www.latticesemi.com/Latticeradiant and click the 
Downloads tab. Some documents and downloads are not visible to 
anonymous visitors. To view all items, please log in to your Lattice account. 

To install the stand-alone Radiant Reveal Logic Analyzer:

1. Close all applications before starting installation.

2. Double-click on the Radiant Reveal installer you downloaded earlier to 
launch the installation process.

3. The Welcome To Lattice Radiant Reveal setup dialog box opens.

4. Click Next to open the Installation Folder dialog box.

5. The default destination folder is C:\lscc\reveal\radiant\3.2. Click Browse 
to change the drive or destination folder.

6. Click Next to open the Select Components dialog box.

7. Click Next to open the License Agreement dialog box.

8. Read the license agreement. If you agree, click I accept the license. then 
click Next to open the Start Menu shortcuts dialog box.

9. The default shortcuts name is Lattice Radiant Reveal 3.2. Type a new 
name in the text box if you want to change it.

10. Click Install to begin installing the selected components to the selected 
folder.

11. In the Installation Wizard Complete dialog box, read the note and click 
Finish.

http://www.latticesemi.com/latticeradiant
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Starting Stand-Alone Reveal Logic 
Analyzer
To start the stand-alone Reveal Logic Analyzer:

 In Windows 7, choose Programs > Lattice Radiant Reveal 3.2 > Reveal 
Logic Analyzer from the Windows Start menu.

 In Windows 8/8.1 or Windows 10, choose Apps > Lattice Radiant 
Reveal 3.2 > Reveal Logic Analyzer.

Installing Stand-Alone Power Estimator

Power Calculator is included in the Radiant software installation. If you want 
to use the tool without installing Radiant software, you can install the stand-
alone Power Estimator, available for download from the Lattice 
Semiconductor Web site. 

Power Estimator is available in 64-bit versions.

For more information on how to download stand-alone Power Estimator, go to 
http://www.latticesemi.com/Latticeradiant and click the Downloads tab. Some 
documents and downloads are not visible to anonymous visitors. To view all 
items, please log in to your Lattice account.

To install the stand-alone Power Estimator:

1. Close all applications before starting installation.

2. Double-click on the Power Estimator installer you downloaded to launch 
the installation process.

3. The Welcome To Lattice Radiant Power Estimator setup dialog box 
opens.

4. Click Next to Installation Folder dialog box.

5. The default destination folder is C:\lscc\powerestimator\radiant\3.2. Click 
Browse to change the drive or destination folder.

6. Click Next to open the Select Components dialog box.

7. Click Next to open the License Agreement dialog box.

8. Read the license agreement. If you agree, click I accept the license.

9. Click Next to open the Start Menu shortcuts dialog box. The default name 
of the program group is Lattice Radiant Power Estimator 3.2. If you 
want to change the name, change it in the Program Folder text box.

10. Click Next to start installing the selected components.

11. In the Install Wizard Complete dialog box, read the note and click Finish.

http://www.latticesemi.com/latticeradiant
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Starting Stand-Alone Power Estimator
 In Windows 7, choose Programs > Lattice Radiant Power Estimator 

3.2 > Radiant Power Estimator from the Windows Start menu.

 In Windows 8/8.1 or Windows 10, choose Apps > Lattice Radiant Power 
Estimator 3.2 > Radiant Power Estimator.

Downloading and Installing Soft IP
Soft IP can be downloaded from the Lattice website. Use the Install a User IP 
feature of IP Catalog to install a Soft IP.

To download and install a Soft IP:

1. Using a web browser, download the Soft IP installer from the Lattice 
website.

2. In the Radiant IP Catalog, click on the Install a User IP  button.

3. In the Select user IP package file to install dialog box, browse to the 
Radiant Software IP Package (.ipk) file, and click Open.

 The Soft IP will be installed into a folder in the user’s personal directory. 
For example: C:/Users/<username>/RadiantIPLocal/<IP_name>.

 The Soft IP will be added into the IP Catalog.

Troubleshooting
If you encounter any software-related problems after installing Radiant, 
review the following common troubleshooting scenarios before calling Lattice 
Semiconductor Technical Support:

 Ensure that your environment variable settings are set correctly, including 
the TEMP user variable. 

 Your should also have the following system environment setting pointing 
to the license file:

SET LM_LICENSE_FILE=<Lattice_license_path>\license.dat

If you have multiple installations of Lattice software, this variable may 
have multiple paths in it. If there are problems, you may need to manually 
edit the variable.

You can verify these settings by accessing the System Properties dialog 
box from your Windows system. Select the Advanced tab from that dialog 
box and go to the “Environment Variables” section.

Note
The stand-alone Power Estimator requires a license. See “Licensing for Radiant 
Software and Stand-Alone Power Estimator” on page 11.
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 If you have problems with the display, ensure that your system video 
display is set to a screen resolution of 1024 x 768 or more and that your 
video display is set to use 256 or more screen colors.

 Opening the online Help may be interrupted by one of the following 
messages on the Internet Explorer Information Bar:

 “To help protect your security, Internet Explorer has restricted this file 
from showing active content that could access your computer. Click 
here for options...”

 “To help protect your security, Internet Explorer has restricted this file 
from running scripts or ActiveX controls that could access your 
computer. Click here for options...”

 “To help protect your security, Internet Explorer has restricted this 
webpage from running scripts or ActiveX controls that could access 
your computer. Click here for options...”

This can happen if you have Internet Explorer as your default browser. 

To see the Help, click on the Information Bar and choose Allow Blocked 
Content. A dialog box with an expanded warning opens. Click Yes.

To avoid these warnings, either use a different browser or turn off the 
warning for active content in Internet Explorer. 

To turn off the warning:

1. In the Internet Explorer, choose Tools > Internet Options.

2. Click the Advanced tab.

3. Under Security, select Allow active content to run in files on My 
Computer.

4. Click OK.

When All Else Fails
If the Radiant software still does not run after you have installed your new 
license file and confirmed that your environment variables are correct, gather 
the following items:

 A screen capture showing the error message.

 A text file that contains a listing of the environment setup for your PC. 
From a Command Prompt window, issue the set > env.txt command.

 Your license.dat file.

Note
Doing either of these means that when you open any Web page that is resident on 
your computer—not just Radiant software Help—the page will automatically run 
any active content that it has. While active content is common and can be very 
useful, malicious content can damage your files. Be sure you trust the software on 
your computer.
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Put these items into a zip file and e-mail it to techsupport@latticesemi.com, 
including an explanation of the problem.

mailto:techsupport@latticesemi.com
mailto:techsupport@latticesemi.com
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Revision History

The following table gives the revision history for this document.

Date Version Description

02/13/2018 1.0 Initial Release.

04/12/2019 1.1  Update for Radiant software 1.1

 Add Stand-Alone Radiant Power Estimator.

 Update hypertext.

09/24/2019 1.2 Add CrossLink-NX.

12/2/2019 1.3 Update for Radiant software 2.0.

6/3/2020 1.4 Update for Radiant software 2.1.

11/3/2020 1.5 Add ModelSim and update for Radiant software 2.2.

12/7/2020 1.6 Updates for ModelSim floating license.

05/05/2021 1.7 Updates for Ubuntu system library.

12/06/2021 1.8 Update for Radiant software 3.1.

08/09/2022 1.9 Update for Radiant software 3.2.
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