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Acronyms in This Document

A list of acronyms used in this document.

Acronym Definition
BSP Board Support Package, the layer of software containing hardware-specificdriversand libraries to function
in a particular hardware environment.
DUT Design Under Test.
SDK Embedded System Design and Develop Kit. A set of software developmenttools that allows the creation of
applications for software package on the Lattice embedded platform.
IDE Integrated Development Environment.
OEM Original Equipment Manufacturer.
The directory where stores your work, itis used as the default content area for your projects as well as for
Workspace . .
holdingany required metadata.
Workbench Refersto the desktop developmentenvironmentin Eclipse IDE platform.
A tool can program Lattice FPGA SRAM and external SPI Flash through various interfaces, such as JTAG, SPI,
Programmer

and I2C.

Perspective

A group of views and editorsin the Workbench window.

A free and openinstruction set architecture (ISA) enablinga new era of processor innovation through open

RISC-V standard collaboration.

RISC-V MC Lattice RISC-V for Micro-Controller Soft IP

SoC Systemon Chip. An integrated circuit that integrates all components of a computer or other electronic
systems.

SRAM Static Random Access Memory.

UFM User Flash Memory.
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1. Introduction

Lattice Propel™ is a complete set of graphical and command-line tools to create, analyze, compile, and debug both
FPGA-based hardware and software processor systems.

1.1. Purpose

Embedded system solutions play an important role in FPGA system design allowing you to develop software for a
processor in an FPGA device. It provides flexibility for you to control various peripherals from a system bus.

To develop an embedded system on an FPGA, you need to design the System-on-Chip (SoC) with an embedded
processor and develop system software on the processor. Lattice Propel helps you develop your system with a RISC-V
processor, peripheral IP, and a set of tools.

The purpose of this document is to introduce Lattice Propel SDK tool and flow to help you quickly get started to build a
small demo system. You can find recommended flows of using Lattice Propel SDK in this document as well.

1.2. Audience

The intended audience for this document includes embedded system designers and embedded software developers
using Lattice FPGA devices. The complete list of supported devices can be found at Lattice Propel Release Notes. The
technical guidelines assume readers have expertise in the embedded system area and FPGA technologies.
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2. Lattice Propel Development Suite

Lattice Propel development suite includes:
e anintegrated development environment (IDE), which is the framework of Propel;
e lattice Propel Builder, which is for SoC design;

e lattice Propel SDK, which is for system software development.

2.1. Eclipse IDE

Eclipse IDE provides the Propel development suite a platform to manage the SoC project and the Embedded C/C++
Project in the same workspace.

The SoC project, which extends from the Propel Builder project, provides easy interaction with other Lattice design
tools, such as Lattice Diamond® within Propel.

The Embedded C/C++ Project provides a platform for developing or debugging application code within Eclipse IDE. The
project can be created directly from the SoC project with a pre-set Board Support Package (BSP) and applications by
using Propel development suite.

2.2. Lattice Propel Builder

Lattice Propel Builder allows you to assemble the larger functional blocks of the design hierarchy. Propel Builder
enables you to instantiate modules and IP from the IP Catalog in a schematic view, and can easily connect the modules.
Propel Builder also helps you customize address spaces within modules, such as a processor. In Propel development
suite, Propel Builder is used to create a microprocessor integrated platform for both hardware and software
development.

Refer to Lattice Propel 2.2 Builder User Guide (FPGA-UG-02156) for more detailed information.

2.3. Lattice Propel SDK

Lattice Propel SDK is based on Eclipse Embedded CDT (C/C++ Development Tools). It allows you to create, build, and
debug software application projects that drive the platform within the Eclipse framework.

The main features are:
e Create, build, debug, or manage embedded applications for Lattice RISC-V CPU/SoC solution.
e Provide extra build steps to generate the binary and memory files required for deployment.

e Build using the latest industry standard open source components and tools for RISC-V firmware development and
debugging.

e Support Picolibc for RISC-V, and provide lightweight standard library implementation.

e  Provide fully-configurable toolchain definitions.
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3. Lattice Propel Tool Flows

The Propel tool flows including SoC project design flow, C/C++ project design flow, system simulation flow, and
programming and On-Chip-Debugging (OCD) debugging flow, are discussed in detail in the following sections.

3.1. Propel Environment

3.1.1. Running Lattice Propel

After installing Lattice Propel, you can launch Propel from the desktop shortcut icon or from the Windows Start menu.
When Propel is invoked, a dialog (Figure 3.1) pops up. You can browse to select where to locate the workspace. For
normal needs, just click Launch to pick the default location and continue running Propel.

Q Lattice Propel Launcher ¥

Select a directory as workspace

Lattice Propel uses the workspace directory to store its preferences and development artifacts.

Workspace: | w Browse...

[[J Use this as the default and do not ask again

» Recent Workspaces

Figure 3.1. Select Workspace Dialog

After the workspace location is chosen, a single workbench window is displayed using default Propel SDK perspective.
The default Propel SDK perspective contains following five functional areas (Figure 3.2).

Menu bar and Toolbar.

Project Explorer view: displays projects in the workspace.

Editor view: provides capability of editing source files.

Outline view: displays an outline of a file that is currently open in the editor area.

vk wn

Log area includes these views: Problem view, Tasks view, Console view, Properties view, and Terminal view.
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| £t workspace - Lattice Propel - O * |

File Edit 5Scurce Refactor MNavigate Search Project Run  LatticeTools Window Help

B S- Q- g -&8-F-@-%$-0- - @2 - RE 1B

Project Explorer &2

BESYT &

There are no projects in your workspace.
To add a project:

There is no active editor that
provides an outline.

Create a new Lattice 5oC Design
Project

Q Create a new Lattice C/C++ Project
rﬁ Create a project...
Ex3 lmport projects...

[T Properties | & Terminal

Mo consoles to display at this time.

Figure 3.2. Propel Workbench Window

3.1.2. Importing General Projects

In Propel SDK, you can use the importing project wizard to import existing projects into workspace except for Lattice
SoC design created by Lattice Propel Builder.

Note: You can only import projects which are created or managed by Propel SDK by choosing General > Existing Project
into Workspace in Propel SDK.

1. In Lattice Propel (SDK), choose File > Import....
The Select wizard opens (Figure 3.3).

© 2022 Lattice Semiconductor Corp. All Lattice trademarks, registered trademarks, patents, and disclaimers are as listed at www. latticesemi.com/legal.
All other brand or product names are trademarks or registered trademarks of their respective holders. The specifications and information herein are subject to change without notice.
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Q Import

Select

Create new projects from an archive file or directory.

Select an import wizard:

| type filter text

w = General
& Archive File
1= Existing Projects into Workspace
[ File System
[T Preferences
[ Projects from Folder or Archive
» [= CfC++

®

Einish Cancel

Figure 3.3. Import Projects Wizard — General

2. Select General > Existing Project into Workspace. Click Next.

The Import wizard switches to Import Projects wizard (Figure 3.4).
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2 Import O X
Import Projects —'._ﬁ‘:l__
Select a directory to search for existing Eclipse projects. { ‘
(®) Select root directory: | D:\J V| Browse...
() Select archive file: Browse...
Projects:
test (D:\test) Select All
Deselect All
Refresh
Options
[]5earch for nested projects
Copy projects into workspace
[]Close newly imported projects upon completion
[ Hide projects that already exist in the workspace
Working sets
[] Add project to working sets MNew...
Select...
@' < Back Mext » Cancel

Figure 3.4. Import Existing Projects Wizard

3. Chooseeither Select root directory or Select archive file, clicking the associated Browse button to locate the
directory or file containing the project.
Select the project or projects you want to import in the Projects area.
Be sure to check the Copy projects into workspace option so that your original projects do not get updated.

Click Finish to start the importing process.

3.1.3. Importing Lattice SoC Design Projects

In Propel SDK, you can use the Import Wizard to import Lattice SoC design projects into workspace. Existing SoC design
projects created by either Propel SDK or Propel Builder can also be imported into Workspace by choosing Lattice

Propel > Lattice SoC Design Projects.
1. From Lattice Propel SDK, choose File > Import....
The Select wizard opens (Figure 3.5).
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2 Import O X

Select

Import Lattice SoC Design projects into the workspace. @

Select an import wizard:

| type filter text |

= General ~
= C/C++
= Git
= Install
~ (= Lattice Propel
o Lattice SoC Design Projects into Worksapce
= Oomph
= Run/Debug v

® < Back Finish Cancel

Figure 3.5. Import Projects Wizard — Lattice Propel

2. Select Lattice Propel > Lattice SoC Design Projects into Workspace. Click Next.
The Select wizard switches to Import Lattice SoC Design Projects wizard page (Figure 3.6).

7% Import O d

Import Lattice SoC Design Projects
Select a directory to search for existing Eclipse projects.

Select root directory | D ~ Browse...
Projects:
SoC_dema (D:N\SoC_demo) Select All
Deselect All
Refresh

® < Back MNext = Cancel

Figure 3.6. Import Lattice SoC Design Projects Wizard

3. Locatethe directory containing the projects by clicking the Browse button.
4. In Projects area, select the SoC design project or projects you want to import.
5. Click Finish to start the importing process.

© 2022 Lattice Semiconductor Corp. All Lattice trademarks, registered trademarks, patents, and disclaimers are as listed at www.latticesemi.com/legal.
All other brand or product names are trademarks or registered trademarks of their respective holders. The specifications and information herein are subject to change without notice.

FPGA-UG-02155-1.0 13


http://www.latticesemi.com/legal

Lattice Propel 2.2 SDK ....LATTICE

User Guide

3.2. SoC Project Design Flow

A new SoC design project including a Propel Builder design can be started from the Lattice Propel sets. Follow the steps
below to create a new SoC design project.

3.2.1. Creating a SoC Design Project
To start a Lattice SoC Design Project from Propel:

1. In Lattice Propel, choose File > New > “v Lattice SoC Design Project. The Create SoC Project wizard opens
(Figure 3.7).

7% SoC Project O x

Create SoC Project —

Create SoC project of selected template

Project name: | ExampleSoC

Use default location
Chlscchpropel\,  \workspace\ExampleSoC Browse...
default

Template selection

Processor: | RISC-V MC ~ | Family: MachXO3D ~
Device: LCMXO3D-9400HC ~ | Performance: 5 ~
Package: |CABGA236 ~ | Condition: Commercial ~

Board: MachXO3D Breakout ~

Template Design

Empty Project Hello World Project. Components included:
a) Processor - RISC-Y MC w/ PIC/TIMER
b} GPIO

c) ASRAM - Asynchronous SRAM

d) UART - Serial port

Figure 3.7. Create SoC Project Wizard

2. Entera project name.
Note: Do not include periods, colons, or spaces in the project name.

3. (Optional) To change the default location, clear the Use default location option, then browse to another location.
Choose a file system.

Select a desired platform template design. In particular, select empty project for building system from scratch.
5. Click Finish.

The SoC design project is created in workbench, and its design is opened and displayed in Propel Builder
(Figure 3.10).
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3.2.2. Open a SoC Design in Propel Builder
Within a SoC project, there is a Propel builder design.
To open Propel Builder for a SoC project:

1. IntheProject Explorer view, select a SoC project.

2. Open the SoC project in one of the following three ways from Propel:

e Choose LatticeTools > . Open Design in Propel Builder (Figure 3.8).

LatticeTools = Window Help

4, Open Design in Propel Builder

#  Generate and Open Diamond Progjct
Generate and Open Radiant Progjct
Lattice Sentry Tools for MachXO3D >
Lattice Sentry Tools for Mach-NX >

Figure 3.8. LatticeTools Menu

e Click the Propel Buildericon H'I'\nonthetoolbar.

e Right-click the SoC project from Project Explorer. Choose Open Design In > IH'I'l Propel Builder from the popup

menu (Figure 3.9).

Restore from Local History...

Open Design In * 4. Propel Builder
Team »  »  Diamond
Compare With » Radiant

Figure 3.9. Project Explorer Popup Menu

3. SoC Designis opened and displayed in Propel Builder (Figure 3.10).

. Propel Builder [C\lscc\propel\2.0hworkspace\ExampleSoC\ExampleSoC/ExampleSoC.sbx] Device: LCMX03D-8400HC-5BG256C
File Edit View Design Window Help

] = B o B = N €
Design View (m]
~ 1} ExampleSoC

» @ Instances

3 2 Ports

4 rE Mets seisd v agid] st
M Components B a0 4] v s

[ cpu0:1.0.0 - [ | e

B2ed QQQAAQ

Schematic Address Start Page

AP pit 4

[ gpic0:1.2.0

[—C> qia_ii{7:0]

@ sysmem0:1.0.0

LaR]

Properties

Name:

Type: Instance i

Path: ExampleSoC

VLNV: lattice:systembuilder:Examp
4 3

1P Catal... Design Vi... F

Tel Console
%

Figure 3.10. Propel Builder Window

© 2022 Lattice Semiconductor Corp. All Lattice trademarks, registered trademarks, patents, and disclaimers are as listed at www.latticesemi.com/legal.
All other brand or product names are trademarks or registered trademarks of their respective holders. The specifications and information herein are subject to change without notice.

FPGA-UG-02155-1.0

15


http://www.latticesemi.com/legal

mLATTICE

4. (Optional) Modify the design in Propel Builder as desired. Most of the templates include a functional-ready SoC
design.

Note: You can only create a SoC design using Empty Project template inside the Propel Builder. Refer to
Lattice Propel Builder 2.2 User Guide (FPGA-UG-02156) for more details on how to create a SoC design using Empty
Project template.

3.2.3. Open Design in Lattice FPGA Design Software

Within a SoC project, you can create a Lattice FPGA design project including a Propel Builder design, and then open the
FPGA design project in appropriate software. There are two FPGA Design Software available, Lattice Diamond and
Lattice Radiant™. Depends on the device family used in the SoC project, only one of the FPGA Design software can be
selected from the user interface, the other is grayed out. If MachXO3D or LFMNX device family is used, the Lattice
Diamond related menu items are active from Propel Ul. If LIFCL or LFD2NX device family is used, the Lattice Radiant
related menu items are active from Propel UL.

To open FPGA Design Software for a SoC project from Propel:

1. (Optional)Set Lattice FPGA design software installation location from Propel. By default, Propel can find the proper
Lattice FPGA design software installation location, usually the latest version installed on the PC. You can overwrite
it following steps below.

Choose Windows > Preferences. The Preferences dialog opens (Figure 3.11).

Select Propel Setting from the left pane. Click the Browse button to pick up the installation location of Diamond or
Radiant. Or, leave the Radiant Location area and Diamond Location area blank, as default. Propel can find the
location atomically.

{71 Preferences O >

type filter text | Propel Setting L=l ~ §

General A

C/C++ Radiant Location
Help |

Install/Update

LiClipse

MCuU Diamond Location
Mylyn |

Oomph

Propel Setting

Remote Development

| Browse...

| Browse...

Run/Debug
SVEditor
Team
Terminal

Validation - Restore Defaults Apply

'/?3' I\_‘_ 15 (@' 'C; Apply and Close Cancel

Figure 3.11. Propel Preferences Dialog

2. Inthe Project Explorer view from the Propel main GUI, select a SoC project.

3. Open the SoC project in one of the following ways:

e Choose LatticeTools>  Generate and open a Diamond project; Or, choose LatticeTools > Generate and
open a Radiant project.

e Clickthe Diamondicon . orthe Radianticon from the toolbar.
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e Right-click a SoC project from the Project Explorer. Choose Open Design In >

Designin >

Radiant from the right-click menu.

Diamond. Or, choose Open

4. Diamond/Radiant project for SoC is generated at background and is launched (Figure 3.12/Figure 3.13).

* Lattice Diamond - Start Page - O *
File Edit View Project Design Process Tools Window Help
PrE-Had gy ;@ Kaaqa =]
& £ gd T - o —_— —
PECHECHSCEHEGA=USSSVMBY BENEHE G
File List & X i} start Page [ Reports [ 2 x
v @ ExampleSoC
LCMXO3D-9400HC-5BG256C -
o = Strateai Project: Release Notes FPGA Design Guide ~
rategies . . . .
Fz’ AS @DDE”--- Lattice Diamend Software 3.12 Release Notes Design Planning
27 Area
1/0 Assistant @ MNew... User Guides HOL Ceding Guidelines
Quick [ Import ispLEVER Project... Lattice Diamond 3.12 Release Notes Timing Closure
Timing Recent Projects: Lattice Diamond 3.12 User Guide Other Tool Guides
Strategyl 8 Examplesor Lattice Synthesis Engine for Diamond User ModelSim Users Manual
pit 4 socz GLHl.jE . . ModelSim GUI Reference Manual
Input Files Lattice Diamond 3.12 Platform Designer User ModelSim Command Reference Manual
¥ ExampleSoC/ExampleSoC_ {3 soc Guide Modelsim Tororia
M ExampleSoC/ExampleSoCy [ hello Clarity Designer User Guide geeisim fuena
: : Synplify Pro User Guide
Synthesis Constraint Files Lattice Diamoend 3.12 Programming Tools User
v LPF Constraint Files Guid Synplify Pro Reference Manual
[ ExampleSoClpf Software Update Center Reveal User Guide Synplify Pro Language Support Reference
Debug Files Currently running Lattice Diamond software version: Reveal Troubleshooting Guide Manual
Script Files 3.12.0.240.2 Lattice Diamond 3.12 Installation Guide for TelfTk
Analysis Files No updates available Windows Lattice on the Web
Programming Files Last check ime: Thu Mar 13 13:46:39 2021 tattlc:e Diamond 3.12 Installation Guide for Lattice Semiconductor
inux
< > Answer Datahase ¥
File List Process Hierarchy
ITd Console g X
» source "C:/lscc/propel/2.0/workspace/ExampleSol/diamond setup_template.tcl”
>
Td Console Cutput Error Warning® Info*
Ready Mem Usage: 127,628 K

Figure 3.12. Diamond Project
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Lattice Radiant Software - Reports

File Edit View Project Tools Window Help

r— = =
- B O QQaQQ E
’ u Synthesize Design u Map Design u Place & Route Design

« [E ExampleSoC A x 1Y startPage | Reports
8 LFCL-40-9BG400!
< Strategies
=] Area Reports
=] Timing
'? Strategy1
= E impl_1 (Synplify Pro)
=4 Input Files
.| BampleSoC/ExampleSoC.v * |=] Synthesis Reports
=4 Pre-Synthesis Constraint Files
Latt'c_e LoE * =1 Map Reports
Synplify Pro
v Post-Synthesis Constraint Files
ExampleSoC.pdc + |51 Place & Route Reports
Delj.lug I.:iles |
Sang F"e? 4 Export Reports
Analysis Files

Programming Files

b |1 Misc Reports

~ 1} ExampleSoC - ExampleSoC.v x®
» 1 F uartD{uartd_inst) - vartl.v
3 D sysmemO(sysmem0_inst) - sysme..,
v 1F osch{oscO_inst) - osclv
v I gpic0(gpiol_inst) - gpiol.w d
y IF cpul({cpul_inst) - cpulav
v 1} apbO(apb0_inst) - apb.v
y TF ahbl2apbl({ahbl2apbl_inst]) - ahbl2...
v 1} ahbl0(ahbl0_inst) - ahblox -

O AleList [ Source Template 2] 1P Catalog Td Consale = output

Starting: parse design source files
(VERI-1482) Analyzing Verilog file 'C:/lscc/radiant/3.0/cae_library/synthesis/verilog/lifcl.v'

E’ Message

fy G-
n Export Files 4

ExampleSoC Project Summary

Implementation Name:
Strategy Name:

Part Number:

Family:

Device:

Package

Project File

Implementation Location:

Resource Usage
LUT4

PFU Register:

> source "C:/lscc/propel/2.0/workspace/ExampleSoC/radiant_setup_template.tcl”

Ly
impl_1 Performance Grade
Strategy1 Operating Conditior
LIFCL-40-9EG400! Synthesis:

LIFCL Timing Errors:
LIFCL-40 Project Created
CABGA400 Project Updated:

C/Iscoipropel/2 0fworkspace/ExampleSoC/ExampleSoC n

C:flsco/propel/2.0fworkspace/ExampleSeCimpl 1

0 10 Buffers

0 EBR:

Tu
X

Figure 3.13. Radiant Project

5. (Optional) From the File List view of the Diamond/Radiant software:

o modify the top-level RTLfile (<proj_name>_Top.v) to match the SoC design, presupposition of which is that

thereis a top-level RTL file in your SoC design; or

e createa top-level RTLfile (<proj_name>_Top.v) to match the SoC design, if the SoC design is created from an

Empty Project template and thereis no top-level RTL file in your SoC design.

6. (Optional) Modify constraint file (<proj_name>.lpf/<proj_name>.pdc) to match the SoC design, if you have

modified the SoC design.

Note: This step is a must to the SoC design that is created from Empty Project template.

7. Process thedesignin Lattice Diamond/Radiant.

In Diamond software, switch to Process view of the project (Figure 3.14). Make sure at least one file, IBIS Model,
Verilog Simulation File, VHDL Simulation File, Bitstream File, or JEDEC file, is checked in the Export Files section for

programming. Choose Process >I Run.
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File Edit View Project Design Process Tools Window Help
A-g-rHa8ra b @ERRIQAQ Y i
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& x ([ start Page [ Reports [ & x
3 Synthesize Design
-
Synplify P -
- : T'rlp:;y e Project: Release Notes FPGA Design Guide "
ranslate Design
v o Man D 9 {7 Open... Lattice Diamond Software 3.12 Release Notes Design Planning
+ Map Design . -
[ 2 Map Trace FRNew... User Guides H.DL. Coding Guidelines
[ & Verilog Simulation File [ Import ispLEVER Project... Lattice Diamond 3.12 Release Notes Timing Closure
[ & VHDL Simulation File Recent Projects: Lattice Diamond 3.12 User Guide Other Tool Guides
~v & Place &Route Design EﬂExamp\eSDC Lattice Synthesis Engine for Diamond User ModelSim Users Manual
-
[0 & Place & Route Trace Guide ModelSim GUI Reference Manual
p [ socz ; .
oz 1/0 Timing Analysis Lattice Diamond 3.12 Platform Designer User ModelSim Command Reference Manual
0 —- EEISDE Guide
Thermal Analysis =
-
~ 2 Export Files 8 hello Clarity Designer User Guide MDdEI_S‘m Tutorial .
O ;_,“ IBIS Model Lattice Diamend 3.12 Programming Tools User Synplify Pro User Guide
0] 2 Verilog Simulation File Guid Synplify Pro Reference Manual
[ & VHDL Simulation File Software Update Center Reveal User Guide 5ynplif|y Pro Language Support Reference
2 Bitstream File Currently running Lattice Diamond software version: Reveal Troubleshooting Guide Manual
2 JEDECFile 3.12.0.240.2 Lattice Diamond 3.12 Installation Guide for 19/ 1K
Mo updates available Wmdﬂws. . Lattice on the Web
Last check time: Thu Mar 18 13:46:39 2021 Il:_attu:e Diamend 3.12 Installation Guide for | stice Semiconductor
inux
Answer Datahase b
File List Process Hierarchy
Output 8 x
synpurap -msg -prj "Example5oC_impll_synplify.tcl” -log "ExampleSoC_impll.srf™ ~
Copyright (C) 1992-2020 Lattice Semiconductor Corporation. All rights reserwved.
Lattice Diamond Version 3.12.0.240.2
INFO - Synplify synthesis engine is launched. v
Td Console Qutput Error Warning Info=
Start: Synplify Pro Mem Usage: 313,848 K
Figure 3.14. Generate Programming File in Lattice Diamond
In Radiant software, from the Process Toolbar, click Export Files (Figure 3.15).
Lattice Radiant Software - Reports - [m} *

File Edit View Project Tools Window Help

=- A o =
e aQaaa BE
o (W] u Map Design n Place & Route Design u Export Files B

~ [E ExampleSoC Eag 1Y Start Page [ Reports
I3 LIFCL-40-9BG4001

GIE]

. L\ Synthesize Design
= Strategies
- = Argea R rts L\ Synplify Pro
r:—\ Tirmin epo = Post-Synthesis Timing Analysis
':? St a‘g 1 Post-Synthesis Simulation File Performance Grade
*4l Strategy .
v % impl_1 (Synplify Pro) Map Design ] ] Operating Conditior
* [ Input Files ] Map Timing Analysis
. ExampleSoC/ExampleSoCv » [Z] Synthesis Reports Place & Route Design o400 LIRS
- E Pre-Synthesis Constraint Files = Place & Route Timing Analysis Timing Errors:
£ Lattice LSE 1/0 Timing Analysis
& S;n:\:'-y . *» 5l Map Reports Export Files Project Created:
Bitst: Fil .
v [ Post-Synthesis Constraint Files = ! II::I:!I ':I Project Updated:
» odel
&b bh":'lp'em"'k HREEDG FETIE (REEE B - Gate Level Simulation File 212, Diworkspace/ExampleSoG/ExampleSoC. i
ebug Files i
7 Script Files N Export Reporls 212 0/workspace/ExampleSoCimpl 1
EI Analysis Files
1 Programming Files
- " *» 5 Misc Reports
LUT4: 0 10 Buffers
PFU Register: 0 EBR:
1 - 3
> source "C:/lscc/propel/2.0/workspace/ExampleSoC/radiant setup template.tcl” [Ea x "

Starting: parse design source files
(VERI-1482) Analyzing Verilog file 'C:/lscc/radiant/3.0/cae_library/synthesis/verilog/lifcl.v'
> prj_run Synthesis —impl impl 1

Td Console = OQutput E1 Message

O File st [E source Template Elr Catalog

Figure 3.15. Generate Programming File in Lattice Radiant

The Programming file is generated. The generated programming file can be used in the Programmer.

© 2022 Lattice Semiconductor Corp. All Lattice trademarks, registered trademarks, patents, and disclaimers are as listed at www. latticesemi.com/legal.
All other brand or product names are trademarks or registered trademarks of their respective holders. The specifications and information herein are subject to change without notice.

FPGA-UG-02155-1.0 19


http://www.latticesemi.com/legal

mLATTICE

3.2.4. Generating System Environment by Building Project

System environment package including the system environment file and the BSP package is required for the embedded
C/C++ project.

To generate system environment package from Propel:

1. IntheProject Explorer view, select a SoC project.

2. Choose Project > Build Project.

3. Checkthe building result in the Console view (Figure 3.16).

{2 Problems |4 Tasks | B Console 2 1 Properties | @@ Terminal = B8

X% HEzEE -
<terminated> sge [SDP Builder] C\lscc\propel\d.0hvtools\python38_embed\python.exe
Warning - Unconnectien: cpu® inst TIMER_IRQ M@ remains unconnected
INFO - Finished: sge generated

Figure 3.16. Build Result of SoC Project

3.2.5. About SoC Design Project

The SoC project creating starts with a functional-ready SoC design and a default simulation environment. In the Project
Explorer view, open a SoC project folder and all its sub-folders. The project contains the following files but not limited
to the following files (Figure 3.17), some of which may vary upon your opening the SoC design project in Diamond or
Radiant software:

e <proj_name>: Folder contains a Propel Builder design including the .sbxfile.

e <proj_name>/application: Folder contains functional-ready embedded application source codes.
e impll: Folder contains the implementation of Diamond/Radiant project.

e sge: Folder contains generated package necessary for creating C/C++ project.

e verification: Folder contains the SoC verification project.

e verification/sim: Folder contains the simulation environment.

e <proj name>.ldf: Diamond project file.

e <proj_name>.lpf: Diamond project logical preference file.

e <proj name>.rdf: Radiant project file.

e <proj name>.pdc: Radiant project post-synthesis constraints.

e <proj name>.txt: Description file from the template.
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w = ExampleSoC
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ExampleSoC_Top.v
ExampleSoC.shx
ExampleSoCw
» = impll
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» [= application
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% = soc_svd
cpul.yaml
ﬂ sys_env.xml
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¥ = sim
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Figure 3.17. Contents of SoC Project
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3.3. C/C++ Project Design Flow

3.3.1. Creating a Lattice C/C++ Project

To start a Lattice C/C++ Project from Propel:

1. ChooseFile > New > @ Lattice C/C++ Project.
The C/C++ Project wizard opens with the Load System and BSP page (Figure 3.18).

0} C/C++ Project a

Correct system environment file and get toolchain parameter

Select system environment file and bsp package

System env: | C:\Iscc\propel\2.0\workspace\ExampleSoC\sge\sys_env.xml Browse...

Select processor core to create C/C++ Project

Core selected: | cpu0_inst
Project type: | C

System information

Device Family CPU Name Instance Name
MachX03D riscv_mc cpul_inst
‘,\?)' < Back Next > Finish Cancel

Load System and BSP —

Figure 3.18. Load System and BSP Dialog

2. Browseto the SoC project folder and select the system environment file sys_env.xml.

All system environment files available in the current workspace can be selected from the System env: drop-down

menu.

3. If the platform has more than one processor, choose one core.
Choose the project type, C or C++.

5. Click Next.
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The C/C++ Project dialog opens (Figure 3.19).

£33 C/C++ Project O *

C/C++ Project —
Create C/C++ project of selected type

Project name: | Example

Use default location
Location: | CAlscc\propeh2.0hworkspace\Example Browse...

Choose file systern: |default

Project type: Toolchains:

= GNU Autotools RISC-V Cross GCC
v = Executable
& Empty Project
® Lattice C/C++ Project
& Hello World RISC-V C Project
& Hello World AMSI C Project
(z= Shared Library
(7= Static Library
= Makefile project

Show project types and teolchains only if they are supported on the platform

?\ < Back Finish Cancel

Figure 3.19. Create C/C++ Project Dialog

6. Entera project name. Suggest not using periods, colons, or spaces in your project name. Though spaces are
allowed, they may cause certain issue with some tools.

7. Bydefault, the Use default location option is checked. The default file system is selected automatically. Suggest
using the default location, unless you have special need to a special location.

8. Select a project type. Select a toolchain. Normal choice is Lattice C/C++ Project and RISC-V Cross GCC.
9. Click Next.
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The Lattice Toolchain Setting dialog opens (Figure 3.20).

1 C/C++ Project O *

Lattice Toolchain Setting

Configuration: | Debug ~

Lib Setting  C/C++ Compiler C/C++ Linker

(") Ne default libraries (-nodefaultlibs)
O Newlib

(O Newlib-nano (--specs=nano.specs)
(®) Picolibe (--specs=picolibc.specs)

Printf Level
(®) Integer only printf (-DPICOLIBC_INTEGER_PRINTF_SCANF)

() Float printf (-DPICOLIBC_FLOAT_PRINTF_SCANF)
() Full printf (-DPICOLIBC_DOUBLE_PRINTF_SCANF)

System Library
(® Default

] Semihasting (--oslib=semihost)
(O Dummyhosting (--oslib=dummyhost)

'/?3' < Back Mext = Cancel

Figure 3.20. Lattice Toolchain Setting Dialog

10. By default, two toolchain configuration modes, Debug and Release, can be chosen from the Configuration
drop-down menu.

e Debug configuration creates executables containing additional debug information that lets the debugger make
direct associations between the source code and the binary files generated from the original source.

e Release configuration provides the tools with options setting to create an application with the best
performance.

You can modify frequently-used library, compiler, and linker options for each configuration. For a complete

toolchain setting, go to project properties after creating the project. Refer to the Advanced Tool Chain Setting

section.

e In Lib Setting tab, standard C library can be reconfigured. Picolibc (C Libraries for Smaller Embedded Systems)
is selected by default and it supports different printf levels.

e In C/C++ Compiler tab, optimization level and debug level can be reconfigured for each toolchain
configuration.

e In C/C++ Linker tab, Remove unused code (--gc-sections) is checked by default for garbage collection of unused
code.

11. Click Finish.
The Lattice C/C++ project is created and is displayed using the Propel SDK perspective. A perspective is a collection
of tool views for a particular purpose. The Propel SDK perspective is for creating Lattice C/C++ programs.
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3.3.2. Updating a Lattice C/C++ Project

When you make changes to a SoC project, sometimes you want to synchronize the changes to an existing Lattice C/C++
project instead of creating a new Lattice C/C++ project. In this case, you can use the update C/C++ project feature.

Note: This feature overwrites the corresponding files or settings of your existing C/C++ project. Be sure to back up your
C/C++ project before using this feature.

To update a Lattice C/C++ Project from Propel:

1. Generatethe latest system environment package according to the Generating System Environment by Building
Project section.

In the Project Explorer view, select a C/C++ project.
Choose Project > Update Lattice C/C++ Project....
The C/C++ Project wizard opens for updating system and BSP (Figure 3.21).

01 C/C++ Project = O X

Update System and BSP

Select system environment file and bsp package

System enwv: | t:,a‘Iscce'plopel.:’E.U/wmkspacefE:ampleSo(ﬁng-’sys_Ehv.xml Browse...

(] Re-generate toclchain parameters and linker script
(] Update BSP package

Cancel

Figure 3.21. Update System and BSP Dialog

Browse to the SoC project folder and select the system environment file sys_env.xml.
5. Select the checkbox for what you can update:

e Re-generatetoolchain parameters and linker script: check this option if you want to modify CPU or memory in
the system.

e Update BSP package: check this option if you want to add additional IP components into the system.
6. Click Update to make changes for the selected C/C++ project.

3.3.3. Building a Lattice C/C++ Project
To build a Lattice C/C++ project in Propel:
1. IntheProject Explorer view, select a C/C++ project.
2. Follow steps below if you want to change the active build configuration:
a. Choose Project > Build Configurations > Manage.... Or, click the Configuration icon ¥ on the toolbar.

b. The Manage Configurations dialog opens (Figure 3.22) for choosing active configuration. By default, a Debug
configuration creates executables containing additional debug information that lets the debugger make direct
associations between the source code and the binary files generated from the original source. A Release
configuration provides the tools with options setting to create an application with the best performance.
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Q Exarnple: Manage Configurations

Configuration Description Status

Debug Active

Release

Set Active Mew... Delete Rename...

Figure 3.22. Manage Configurations Dialog

3. Choose Project > Build Project. Or, click the Build icon % on the toolbar.

4. The results of the build command are displayed in the Console view (Figure 3.23).

[2] Problems | ] Tasks | & Console &2 [ Properties | & Terminal 4L q4p <_E|>| A

CDT Build Conscle [Example]

Invoking: GNU RISC-V Cross Print Size
riscv-none-embed-size --format=berkeley "Example.elf”
text data bss dec hex filename
1262 =] 2723 3996 f96 Example.elf
Finished building: Example.siz

Invoking: Lattice Create Memory Deployment

riscv-none-embed-cbjcopy -0 binary --gap-fill @ "Example.elf” "Example.bin"; srec_cat "Example.bin”

-Binary -byte-swap 4 -DISable Header -Output “Example.mem" -MEM 32
Finished building: Example.mem

15:58:18 Build Finished. @ erreors, 8 warnings. (took 5s5.21ms)

Figure 3.23. Build Result of C/C++ Project

3.3.4. About Lattice C/C++ Project

The Lattice C/C++ project starts with source code. In the Project Explorer view, open a C/C++ project folder and all its

sub-folders. The project contains:

e src/bsp/driver: Folder contains driver codes from the IP in the platform.

e src/bsp/sys_platform.h: Header file that defines DEVICE_FAMILY (the Lattice FPGA), address mapping, and any IP

parameters that can be used by the drivers.

e src/main.c: Source file contains the main routine, which is the entry-point of a C/C++ program.

e src/cpu0.svd: System view description file used for peripherals registers view at debug perspective.

e src/cpuO.yaml: Processor description file used at debugging time.
e src/linker.ld: Linker scriptfile.

e src/sys_env.xml: System environment file describing aspects of the platform, such as memory spaces.

After building the project, the build output can be found in each build configuration folder, the Debug folder or the

Release folder (Figure 3.24). The Debug or Release folder contains:

e <proj _name>.elf: Executable file used in on-chip debugging.

e <proj name>.bin: Binary file used in deploying the application to flash memory.

e <proj_name>.Ist: Extended listing file generated by tool objdump.

e <proj_name>.map: Linker map file.

e <proj_name>.mem: Lattice system memory initialization file used in System_Memory IP.
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Note: Some of thefiles listed in Figure 3.24 are intermediate files that you do not need to take care of.

3.3.5. Writing Code

Lattice Propel is based on Eclipse IDE. You can write application code following the process and usage of the same tools
as any in Eclipse IDE. You can get more detailed information regarding Eclipse IDE from the Propel online help.

5 Project Explorer &2

v (== Example
d:;? Binaries
i Includes
w [ sre
v (& bsp

[== driver

[h] sys_platform.h
[ main.c
[ wutils.c
[K] utils.h
[ cpulsvd
cpullyaml
el linker.Id

£
i% sys_envaeml

w = Debug

[=% src

%S: Example.elf - [none/le]
|| Example.bin
Example.lst
Example.map
Example.rmem

| @& makefile

| @ objects.mk

| & sources.mk

= ExampleSoC

For writing code, Lattice Propel SDK provides two extra aids:

0

':n\J

Figure 3.24. Contents of C/C++ Project

tn e e ]

Lattice System Platform: An overview of the processor platform can be displayed (Figure 3.25).

Linker Editor: An overview of the memory regions of linker script can be displayed. You can modify key linker
parameters via the graphical interface (Figure 3.26).
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i% Lattice Platform 52 = g
General
Vendor: | Jattice |
Library: | Propel |
Mame: | ExampleSoC |
Version: | 2.0 |
DeviceFamily: | MachX03D |
Bsplocation: | bsp |
component ipnarme version  vendor basefAddress  range irg
cpull_inst riscV_mc 1.0.0 latticesemi.com D FEFFODD0 200
sysmem0_inst  system_memory  1.0.0 latticesemi.com  OxD 03000
gpiod_inst gpic 120 latticesemi.com  Dx3000 400 IRQ_S1
uart(_inst uart 1.0.1 latticesemi.com D 8400 400 IRQ_50
Overview s_t,rs_env.xmll
Figure 3.25. Lattice System Platform
% Lattice Platform rﬁ Linker 2 = g
Linker Script: linker.ld
Available Memory Regions
MName Attributes  Base Address Size
sysmermn{_inst rwx Ox0 03000
STACK and HEAP Size
HEAP_SIZE: | 0xD |
STACK_SIZE: | 0xA0D |
Section to Memory Region Mapping
Section Mame Memaory Region 2
sysmermn{_inst
«ctors sysmem{_inst
dtors sysmermn{_inst
rodata sysmem{_inst
data sysmermn{_inst
bss sysmem{_inst W

Overview | linker.d |

Figure 3.26. Linker Editor
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3.3.6. Advanced Tool Chain Setting
Follow the process below to modify the tool chain settings of a C/C++ project.
To change tool chain setting in Project Properties in Propel:
In the Project Explorer view of Propel, select a C/C++ project.
Choose Project > Properties. The Properties for current project opens (Figure 3.27).
Select Settings of C/C++ Build category from the left pane. Select the Tool Settings tab.
£ Properties for Example O X
type filter text Settings = - B
Resource
Builders
w C/C++ Build Configuration: |Debug [ Active] ~ | | Manage Configurations...
Build Variables
Environment
Logging %) Tool Settings I3 Toolchains M Devices . Build Steps Build Artifact Binary Parsers @ |4 |
Settings
Tool Chain Editer (% Target Processor Architecture RV32| (-march=rv32i%) v
f ix] imizati
C/C++ General = Opt@lzatmn ] Multiply extension (RVM)
MCU @ Warnings ) .
R 4 B ] Atomic extension (RVA)
Project Matures (22 Debugging
Project References ~ 133 GNURISC-V Cross Assembler Floating point Mene w
Run/Debug Settings (2 Preprocessor Compressed extension (RVC)
SystemVerilog Project Properties (2 Includes Int: ARl ILP32 biciln3Z
Task Repository (2 Warnings MegeEr {-mabi=ilp327) e
Task Tags (# Miscellaneous Floating point ABl | None v
Validation w 3 GMU RISC-V Cross C Compiler
@ Preprocessar Tuning Teolchain default ~
b
9 Includes Code model Teolchain default ~
@ Optimization
(& Warnings Small data limit | 8
=M
9 Miscellaneous Align Toolchain default (-mtune) ~
w 83 GMU RISC-V Cross C Linker
@ General [[]Small prologue/epilogue (-msave-restore)
@ Libraries Force string eperations to call library functions (-mmemcpy)
(# Miscellaneous Other target flags |
~ I35 GNU RISC-V Cross Create Listing
(#2 General
w 83 GMU RISC-V Cross Print Size
@ General
~ I3 Lattice Create Memery Deployment
@ General
Restore Defaults Apply
@' Apply and Close Cancel

Figure 3.27. Properties of C/C++ Project

Customize the tools and tool options. All your customization can be resulted in the build configuration in the Tool
Settings properties tab. The build configuration is used during your C/C++ project building.

Note: Setting for each configuration, Debug or Release, is independent.
Click Apply and Close to save the change.
Note: You may need to clean the project to make the new setting take effect for the whole project.
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3.4. System Simulation Flow

The SoC Project created from template has a default simulation environment for you to setup and start functional
simulation. It is generated automatically along with the SoC project creation. You can useit as a start point and

customize accordingly.

The default simulation environment is with the following features:

e Provides similar user experience as real board-level debugging, such as for Hello World SoC, key components
including RISC-V MC, System memory, and UART.

e Simulates user-modified template SoC with extended HDL designs.

e Simulates the whole system usingreal C/C++ projects as stimulus with the necessary modification and with all the

details for debugging.

e  Supports user extension with a friendly and flexible approach.

3.4.1. Launch Simulation

To launch simulation:

1. In Propel Builder, update the SoC design to enable simulation features.

e Enable the checkbox for Simulation Mode, and disable the checkbox for Debug Enable for RISC-V MC IP
module in the General area (Figure 3.28).

., Module/IP Block Wizard

Diagram cpul

Configure Component from IP riscv_mc Version 1.2.0
Set the following parameters to configure this component.

Configure IP

cpul

[HIRQ_SOAHBL_MO_INSTR=H
[IRQ_S1 AHBL_M1_DATAH

—{dk_i TIMER_IRQ_MOH
—rst_n_i system_resetn_o
riscv_mc

| Property
~ General
Simulation Mode
Debug Enable
Compressed Instruction Extension
PIC Enable
Tirer Enable
PIC and Timer Base Address (32'h00000000 ~ 32'hFFFFFFFF)
Mumber of Interrupt Requests [2 - 8]

Mo DRC issues are found.

*

Value
[~ ]
v
=
=
32'hFFFFODD0
2

Generate Cancel

Figure 3.28. Configure Module RISC-V MC
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e Enable the checkbox for Initialize Memory for system_memory IP module from the Initialization area of the

General tab, and set Initialization File generated from the corresponding C/C++ project (Figure 3.29).

“. Module/IP Block Wizard

Configure Component from Module system_memory Version 1.0.2
Set the following parameters to configure this component.

Diagram sysmem0 Configure IP
General Port 50 Settings Port 51 Settings
Property Value

Memory Address Depth [1 - 32768] | 8192

sysme moO Data Bus Width(bits) £
- ~, Memory Type EER
Port Count [1-2] 2
AHBL_SO0
Enable Arbiter
AHBL_S1 vAFOSweamer
Enable FIFO Streamer

—ahbl_hclk_i

—ahbl_hresetn_i

Initialize Memory

M v, Initialization File Format
System_memory Initialization File ../Example/Debug/Example.mem
4 4 Mo DR.C issues are found.

Generate Cancel

Figure 3.29. Configure Module System Memory

2. Click the Switch icon on the toolbar to switch between SoC design and SoC verification project (Figure 3.30).

3. Afterthe SoCdesignis switched to a SoC verification project, click the Generate icon' & to generate the simulation
environment for OEM ModelSim. Click the Launch Simulation icon .' (Figure 3.30).
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., Propel Builder [Ci/lscc/propel/2.0/workspace/ExampleSoC/iverification/ExampleSoC_v.sbx] Device: LCMXO3D-9400HC-3BG256C - O X

File Edit View Design Window Help

3 E - ] <\ 1 T ﬁ L. »]

cEHB QQa@AQ

Design View = Schematic Address Start Page
- ﬂ ExampleSoC_v -
b ﬁ Instances . 5
v Nets sysclk_rst_gen1_inst uart_modell_inst
- . Components b th_ck_o uart_nx_data_debugp=
[T sysclk_rst_gen1:1.0.0 ll g dut_ck_dut_rst_o uart_tx_data_debug=
@ uart_model1:1.0.0 1'b0 dut_rst_dut_clk_o Ik uart_rx_break_debugl—
th_rst_o rstn uart_rx_valid_debugf—
vart_rd uart_tx_busy_debugf—
Properties uart_tx_en_debug— dut_inst
MName: uart_txd E :
L—Jclk_i 1
Type: Instance : txd ol
. md_i T
Path: ExampleSoC_v :' gpio_io!
VLNV: lattice:systembuilder:Examg = 1rstn
1 MO TEEEEEEE
IP Catal... DesignVi.. S
Tel Console |

Finished: "sbp_design close"

% sbp design open -name ExampleSoC_v -path {C:/lscc/propel/2.0/workspace/ExampleSoC/verification/ExanpleSoC v.sbx}
% -

Figure 3.30. SoC Verification Project

4. ModelSim is launched running simulation for the SoC verification project. The corresponding waveform of the SoC
verification project for the Hello World project is shown (Figure 3.31). Check the waveform.

™ ModelSim DE 20203 - [a] x
File Edit View Compile Simulate Add Wave Tools Layout Bookmarks Window Help

|8 38 -8 sRBD 0-ME | W[ SHRH||[o e B el REEAS 2AMS][ AT 2 4] e s ~|

[ Comrtoro fonzacss Al B a2 [ (o oo wfs [ [« B4 B[ £ L LT E 5[ e- €3 | s BTy
[aqanan

B om -vefadt ——:—— # d x]

¥|Instance

+ 2l GSR_INST out_c_ £ vtestidut_instjrstn_
. . £ ptestidut_instfed_i
“u fvtest/dut_inst/ted_o

- B sysck_rst_pen1_inst
- 8 vart_model1_inst
@ =ASSIGN=82

-l st
| #vem_capacity=

£ vtestjuart_model1_inst/ck

Figure 3.31. Waveform of Hello World Project

3.4.2. Simulation Details

The default simulation environment is located at the generated sim folder inside the SoC verification project in Propel.
It contains:

[sim] -- generated simulation environment
[hdl_header]
soc_regs.v -- register definitions of all the components in DUT/SOC
sys_platform.v  --base address, user settings of all the components in DUT/SOC
[misc]
** -- all the mem, hex, txt files will be copied here
flist.f --file list for HDLs
msim.do -- do script for simulator, it can be gsim for Questasim
wave.do -- do script for adding signals in waveform window
<project_name>.sv -- top testbench, SystemVerilog based

You can extend more verification features in the top testbench.
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About Hello World Project

The Hello World Project is designed to print some strings using a top-level UART port. The testbench instantiates a
UART model to receive these data. Each byte (refer to uart_rx_data shown in Figure 3.31) can be checked using ASCI|
format. Meanwhile, this UART model also supports sending the data to Design Under Test (DUT). The datais stored in a
text file and enabled by STIMULUS_GEN parameter.

3.5. Programming and On-Chip-Debugging Flow

This section describes the process of testing and debugging application code on the actual hardware including the
Lattice FPGA with the hardware design installed. Debugging with Propel SDK follows the same process and uses of the
same tools of any of those in Eclipse IDE.

Before debugging, download the hardware design created from Diamond/Radiant Programmer. Refer to the User
Guide of the specific evaluation board for more details on the evaluation board.

3.5.1. Creating a Debug Launch Configuration

To debug a program, a debug launch configuration must be created. Most of the settings for a debug launch
configuration can be automatically entered. Only a few settings need to be manually configured.

To create a debug launch configuration:
1. IntheProject Explorer view of Propel, select a C/C++ project.

2. Build the project and ensure the executable file is available. Refer to the Building a Lattice C/C++ Project section for
details on the process.

3. Choose Run > Debug Configurations...
The Debug Configurations dialog opens (Figure 3.32).

7t Debug Configurations O *

Create, manage, and run configurations

Iﬁ x = X | B Y~ MNarne: | Example Debug

|t}"pEfi|tEI'tl':5<t | [£] Main . [Z| CableConn| %3 Debugger| = Startup| & Source| [C] Commen| &, SVD Path
[©] C/C++ Application o Project:
[©] C/C++ Attach to Application
[c] C/C++ Postmortem Debugger | Example | Browse...
[©] C/C++ Remote Application C/C++ Application:

Cif C/C++ Unit
[t ] GDB Hardware Debugging
w [t | GDB Open0CD Debugging Variables... Search Project... Browse...
¢ | Example Debug
[c| GDB QEMU Debugging
L Launch Group Build Cenfiguration: | Select Automatically ~
@ Launch Group (Deprecated)

| DebughExample.elf

Build (if required) before launching

(") Enable auto build () Disable auto build
(®) Use workspace settings Configure Workspace Settings...
Revert Apply

Filter matched 11 of 11 items

Figure 3.32. Debug Configurations Page
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Double-click GDB OpenOCD Debugging to create a new launch configuration.

A multi-tab page is displayed. The Main tab should already be filled in with the project name, application file name,
and location.

5. Select the CableConn tab (Figure 3.33). This tab enables you to select a specific device on a specific cable port.
Click the Detect Cable button. Select the specific cable port from the Port drop-down list. By default, the first
available cable port: FTUSB-0 is selected.

Click Scan Device button. Select the specific device from Device drop-down list. By default, the first available
device on selected cable port is selected.
Select the jtag channel number from Channel drop-down list. By default, channel 14 is selected with the same
value as the processor preset.
Keep the cable speed so that you can use the default clock divider.
1% Debug Configurations O X |
Create, manage, and run configurations @‘:\
E X|E h —| Name: | Example Debug
type filter text Main | [) CableConn . % Debugger ¥ Startup| 5~ Source =] Common| 2. SVD Path
| C/C++ Application Cable Settings

C/C++ Attach to Application

Port: FTUSB-0,USB2 Lattice XO3D Breakout Board A Location 0000 ~ | Detect Cable

| C/C++ Postmortem Debugger
[€] C/C++ Remate Application Device Settings
Cii ¢/C Unit
U C/Ce+ Uné Device: LCMXO3D-9400HC:0x212E3043 v | Scan Device
le| GDBE Hardware Debugging
[€] GDB OpenOCD Debugging JTAG Channel Setting

[t] Example Debug Channel: 14 »

% Launch Group

¥ Launch Group (Deprecated) Speed Settings
(@ Use Default Clock Divider
(O Use Custom Clock Divider

Filter matched 10 of 10 items

@ Close

Figure 3.33 CableConn Tab of Debug Configurations

Select the Debugger tab (Figure 3.34). It is critical that the Config options field contains the correct commandline
options to be passed to OpenOCD.

-c "set port S{PORT}" is required for the selection connected to Lattice cable. The value of variable “S{PORT}”comes
from the cable settings of CableConn tab.

-c "set target S{DEVICE}" is required for the selection specific device on the Lattice cable. The value of variable
“S{DEVICE}” comes from the device settings of CableConn tab.

-c "set channel S{CHANNEL}" is required for setting JTAG channel. The value of variable “S{CHANNEL}” comes from
the jtag channel setting of CableConn tab.

-c "set tck S{TCKDIV}" is required for setting clock divider of the Lattice cable. The value of variable “S{TCKDIV}”
comes from the speed setting of CableConn tab.

34
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2 Debug Configurations m} X ‘
Create, manage, and run configurations ﬁ_
HEREX B Y~ .‘Name:lExampleDebug Il
[type filter text | |2 Main| [2 CableConn |3 Debugger , # Startup| - Source| ] Common % SVD Path ;
[€] C/C++ Application 0OpenOCD Setup Al
[€] C/C++ Attach to Application Start OpenOCD locally
[€] C/C++ Postmortem Debugger l | -
[E] C/C++ Remote Application Executable path: | ${openocd_path}/${openocd_executable) Browse.. Variables...
Cii C/C++ Unit Actual executable: {C:\Iscc\propel\Z.Z\sdk\edipseV.Jopenocd/bin/openocd.exe
E GDB Hardware Debugging (to change it use the global or workspace preferences pages or the project properties page)
v [€] GDB OpenOCD Debugging
GDB port: 3333
[€] Example Debug P g
# Launch Group Telnet port: |4444
# Launch Group (Deprecated) Tl port:
Config options: fI[ - “set target ${DEVICE)" -c "set tck S{TCKDIV}" -c "set port ${PORT)" ~c "set channel
${CHANNEL}" -f interface/lattice-cable.cfg -c "set RISCV_SMALL_YAML
{${ProjDirPath)/src/cpul.yaml}” -f target/riscv-small.cfg
Allocate console for OpenOCD Allocate console for the telnet connection
GDB Client Setup v
Filter matched 10 of 10 items Reyoi Apply
@ Close

Figure 3.34 Debugger Tab of Debug Configurations

7. (Optional) Select the Common tab (Figure 3.35). The Save as > Local file option is selected by default. This causes
the debug launch configuration to be saved into the workspace.

Change setting the Save as field to Shared file to let the debug launch configuration saved into the project that

aids the project portability.
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Q Debug Configurations

Create, manage, and run configurations

CEHeRExX | =R MName: | Example Debug
| type filter text | Main ( CableConn ﬁi?- Debugger (Eb Startup (E/ Source ﬂ-—=| Common .72, SVD Path
[E] C/C++ Application Save as -
[E] C/C++ Attach to Application ) Lecal file
[t] C/C++ Postmortem Debugger .
[E] C/C++ Remote Application Qe Te | \Bxample | e
Coo .
i C/Ce+ Unit . Display in favorites menu Encoding
[t ] GDB Hardware Debugging . .
« [€] GDB OpenOCD Debugging O #Debug (®) Default - inherited (UTF-8)
721 Example Debug O @ Run (O Other | 150-8850-1
[t] GDE QEMU Debugging
L Launch Group
= Launch Group (Deprecated)
Standard Input and Output
Allocate console (necessary for input) "
Revert Appl
Filter matched 11 of 11 items Ry

@

Figure 3.35 Common Tab of Debug Configurations

Remain settings as default. Do not change the settings unless necessary, or unless you understand what effect
these changes may have.

9. Click Apply to keep the current settings.
10. Click Close.

3.5.2. Starting a Debug Session

Before starting a debug session, be sure that:

e lattice cable is connected to the computer.
e The target deviceis power ON.

e The hardware design has a debug enabled processor module and already programming into the target device.

With the above steps completed properly, follow the steps below to start the debug session from Propel.
1. Choose Run > Debug Configurations...

2. If necessary, expand the GDB OpenOCD Debugging group.
3. Select the newly-defined configuration.
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4. Click the Debug button (Figure 3.35).

Alternatively, for later sessions, use the Debug icon®¥ on the toolbar. Do not click the Debug icon directly.
Instead, click the down arrow beside the Debug icon. Select the desired debug configuration from the drop-down
menu (Figure 3.36).

#5; - 0 - ‘% - .g @ & v I
[c| 1Example Debug
Debug As ¥

Debug Configurations..,

Organize Favorites..,

Figure 3.36. Debug Icon on Toolbar

5. Wait for a few seconds for switching to debug perspective, starting the server, connecting to the target device,
starting the gdb client, downloading the application and starting the debugging session.

6. The Propel Window displays as shown in Figure 3.37. The execution stops right at the beginning of the main()

function.
o ferefrrat .
i} workspace - Example/src/main.c - Lattice Propel - O x
File Edit 5curce Refactor Mavigate Segrch Project Run  LatticeTools Window Help
Fmig |BiBis|m o ®m3 o ol LGRS B -0 -Q-idE &/ deif-F 0oyt
Q | @t
45 Debug 22 [ Project Explorer = 8 || [£ maine &2 = 0 |[m=v 2\ % B|6fE| T P| ™ = 8
B | i E 35 o _;ITICE DOES H?T r';l.RR;l.H'[ OR IEEPRESEHT THAT TﬂI? FILE, %TS COr A = E‘| L=€j el E
. 36 // USE THER DOES NOT INFRINGE ON THIRD PARTIES" I ECTUA
[ Example Debug [GDB OpenOCD Debugging] 37 4/ L MNarne Type
w17 Example.elf 38 // E USE (9= iche uintd t
~ o Thread #1 (Suspended : Signal : 0:Signal 0} 3a /)
= main() at main.c:46 Oxddc fe i
L o.peno(d.axe :E #include "utils.h"]
g riscv-none-embed-gdb
int main(void) {
static uintd t idx = @;
DEBUG_PRINTF("Hello RISC-V world!\r\n");
LED_SET(ALL_OFF);
while (true) {
LED SET(LED ON(idx)); e =
if (++idx == LED_COUNT) { Name : idx ~
idx = @; Details:@ '\@'
¥ Default:e '\@’
Decimal:@
if (RTL_SIM Hex:@x@
‘An1?.,ucaﬂi. v RinaruveB v
< >
& Console | 1t Registers | & Terminal |[2] Problems | {3 Executables | G} Debugger Console 53 [ Memory B~-=0
Example Debug [GDB Open(OCD Debugging] 8 cross_prefix jgdb&{cross_suffix} (777)
~
Program stopped. ™
T o
Writable Smart Insert 42:19: 2503 1 165M of 334M o:

Figure 3.37. Debug Perspective

3.5.3. Peripherals Registers View

Peripherals registers view provides an easy-to-use interface for examining or modifying the values of peripheral
registers during a debug session.

To use peripheral registers view in Propel (Figure 3.38):
1. Makesurean active debug session is run and shown in the debug perspective.

2. Findthe Peripherals view which is in the same window with the Variables and Breakpoints views. For any reason,
if not found, re-open from Window > Show View > Peripherals.

The Peripherals view lists all peripherals available in the system view description svd file within the C/C++ Project.
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3. Selecting a peripheral in the Peripherals view can open a Memory Monitor that is mapped to the corresponding
peripheral memory area.

4. You can examine and modify the value of the peripherals register in the memory view.

% workspace - Example/src/main.c - Lattice Propel - [m] *

File Edit Source Refactor Mavigate Search Project Run  LatticeTools Window Help

I RN TR R I e R ST Y- R R T R RSP R
4 Debu 2 N 5 Proja} = 8 || [ mainc 2 = 8
=l | i 8 if Jf e e e ~
~ [£] Example Debug [GDB Open0CD 22 #include "utils.h" Peripheral Address Description
v i} Example.cif 43 1'% epul_inst OxFFFFODDD
~ o Thread #1 (Suspended : Sig = int main(veid) { %, gpiel_inst 0x000D02000
= main() at main.c:46 Gxd static uintd_t idx - 8; =) N 00000000
S J—— DEBUG_PRINTF("Hello RISC-V world!\rin"); 0%, sysmem0_inst O«
»s °P ) LED_SET(ALL_OFF); A F, uartinst 000008400
s fiscv-none-embed-gdb
while (true) {
LED_SET(LED_ON{idx));
< >
if (++idx == LED_COUNTY {
idx = @;
}
v
< >
2 Console ﬂ'\’é? Registers (@ Terminal ﬂ_:_ Problems (O Executables (@ Debugger Cor‘ole a Memary i ) = B8
my e [ | o) R S| B - 8
Monitors = 38 % (7 gpiclinst 0x8000 57 . o New Renderings..|
@ cpul_inst Register Address Value G
@ gpiolinst v % gpiol_inst 0xD000B000
@ uvartd_inst + I RD_DATA_REG 000003000 000003000
o rd_data [7:0] 00
1010 WR_DATA_REG 0x00008004 0x00008004
> it SET_DATA_REG (h 00008008 (h 00008008
4 1m0 CLEAR_DATA REG 0x0000800C 0x0000800C
4t DIRECTION_REG (500008010 (500008010
< > 10 |NT TVDF RF MreNNNNANTA MreNNNNANTA v

Mof334M [

Figure 3.38 Peripherals View in Debug Perspective

3.5.4. Serial Terminal Tool

Serial port communication is frequently used during the microcontroller debugging. Propel SDK provides a built-in
terminal tool including serial support for debugging.

To launch a serial terminal:

1. Findthe Terminal view nested to the Console view. If not found, re-open from Window > Show View >Terminal.
2. IntheTerminalview, click the Opena Terminal iconE . The Launch Terminal dialog opens (Figure 3.39).

3. Choosethe Serial Terminal and configure the Serial port with Baud rate.
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Q Launch Terminal O 4
Choose terminal: |Selia| Terminal V|
Settings
Serial port: | COmM1 v|
Baud rate: | 115200 ~|
Datasize: 8 ~|
Parity: |None v|
Stop bits: |1 ~|
Encoding: |Defau|t (150-8859-1) v|
@ [ ok ]| cance |

Figure 3.39. Launch Terminal Dialog

4. Click OK. A connection opens.
5. (Optional) Click the Toggle Command Input icon that adds an edit box to enter text (Figure 3.40).

E Plohlems}u Euecutahls} 2 it E =x EE| H_ @ @ = g

Figure 3.40. Terminal View
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4. Propel Tutorial —Hello World

This “Hello World” project can be found from the template. The “Hello World” project provides a template of using
hardware and software design with the minimal resource required.

Following this tutorial, you can easily create a hardware and software project. After that, you can run the project on

your evaluation board.

The tutorial uses a MachX03D breakout board as demonstration. It uses RS232 UART function. To enable RS232 UART

function on the MachX03D breakout board, the following reworks on the boards are required.
1. Hardware reworks on MachXO3D breakout board.

Short R14 and R15 using 0 Q resistors, as shown in Figure 4.1.
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Figure 4.1. MachX03D Breakout Board
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2. Configurethe FTDI device with FT_Prog software to enable UART function.

Connect the MachX03D breakout board to host PC and power ON.

Open FT_Prog software. Select DEVICES > Program.
Make sure Port B is configured as RS232 UART in Hardware and Virtual COM Port in Driver. See Figure 4.2.
Select DEVICES > Program from the FT_Prog software again. From the opened Program Devices dialog, click

Program.

Device Tree

Property

Value

=& Device: 0 [Loc ID:0x0]
S=» FT EEPROM

F=$ Chip Details
i=p USB Device Descriptor
=y USB Config Descriptor
i=p USB String Descriptors
=/=p Hardware Specific

-=p Suspend DBUST

-=p TPRDRY

+H=p Port A

E= Port B

-+ [

[H=p Driver

=y 10 Pins

RS232 UART
245 FIFO
CPU FIFO
OPTO Isolate

Device Tree

Property

Value

=& Device: 0 [Loc ID:0x0]
S=» FT EEPROM
F=$ Chip Details
i=p USB Device Descriptor
i=» USB Config Descriptor
i=p USB String Descriptors
=/=p Hardware Specific
-=p Suspend DBUST
-=p TPRDRY
H=p Port A
E= Port B
'=> Hardware
-+

H=p 10 Pins

D2XX Direct
Vitual COM Port

Figure 4.2 Configure the FTDI Device

3. Allthereworks for the MachX0O3D breakout board is completed.
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4.1. Creating SoC Design Project and Preparing Hardware Design
To start a SoC Design Project from Propel:

1. Choose File> New > IH'I'n Lattice SoC Design Project.

2. The Create SoC Project wizard opens (Figure 4.3). Enter a project name, such as HelloWorldSoC. Select the Hello
World Project template.

3. Click Finish. A SoC project is created.

7% SoC Project O *

Create SoC Project p—
Create 5ol project of selected template

Project name: | HelloWerldSoC I

Use default location

Location: | Chlsec\propely  \workspace\HelloWorldSoC Browse...
Choose file systern: [default

Template selection

Processor: | RISC-V MC ~ | Family: MachXO3D ~
Device: LCMXO3D-9400HC ~ | Performance: 5 ~
Package: |CABGAZ56 ~ | Condition: Commercial ~

Board: MachXO3D Breakout ~

Template Design

Helle World Project. Coemponents included:
a) Processor - RISC-V MC w/ PIC/TIMER
b) GPIO
c) ASRAM - Asynchronous SRAM
d) UART - Serial port

H—T.:IE World Project

@

Figure 4.3. Create SoC Project Wizard

4. The created SoC project can be found in the workbench. Its design is opened and displayed in Propel Builder for
review (Figure 4.4).
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File Edit View Design Window Help

6 =) 7 % H B D
Design View m|
= 1 ExampleSoC =
3 ijtlnstances
3 gC' Ports
3 ,rE Mets

Schematic Address Start Page

*

4, Propel Builder [Chlscc\propel\2.Ohworkspace\ExampleSoC\ExampleSoC/ExampleSoC.sbx] Device: LCMXO3D-9400HC-5BG256C

b
=

- Components
@ cpu:1.0.0
[ gpiot:1.2.0

QQQ Q

[~ a7

@ sysmem(0:1.0.0

-
Properties =il

st i

Name:

Type: Instance

i

Path: ExampleSeC

WLNV: lattice:systembuilder:Examp ¥
»

4
IP Catal...
Tel Console
L]

Design Vi...

Figure 4.4. Propel Builder Window

5. (Optional) In Propel Builder, update the SoC design to set the preloaded software. Enable the checkbox for Initialize
Memory for system_memory IP module from the Initialization area of the General tab, and set Initialization File
(Figure 4.5) generated from the corresponding Hello World C project in the Creating Hello World C Project section.

4, Module/IP Block Wizard

Configure Comp t from Module system_| ry Vi 1.1.2

Set the following parameters to configure this component.

X

~ FIFO Streamer

—HBL_Sl

—ahbl_hclk_i .

Diagram sysmem0( Configure IP
General Port S0 Settings
Property Value
~ General
Memaory Address Depth [1-32768] 4096
sysmemo Data Bus Width(bits) 2
-~ Memaory Type EBR
Port Count [1-2] 2
—H BL_SO Enable Arbiter

Port 51 Settings

Initialize Memory

Initialization File Format

— ahbl_hresetn_i

Initialization File

system_memory

No DRC issues are found.

Generate || Cancel

Figure 4.5. Configure Module System Memory
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4.2. Launching Lattice Diamond

Launch Lattice Diamond from the created SoC project. To do that:

1. In Propel Project Explorer view, select the SoC project HelloWorldSoC.

2. Clickthe Diamondicon
Diamond.

on thetoolbar. A Diamond project is created and thus opened automatically in Lattice

3. Switch to Process view of the Diamond project and make sure Bitstream File or JEDEC File is checked in the Export

Files section (Figure 4.6).

4. Choose Process > l=d Run. Wait for generating programming file successfully. You can see a green checkmark

before each successfully completed process.

* Lattice Diamond - Start Page - *
File Edit View Project Design Process Tools Window Help
P-Er-hdaggeag NhegEBRRQAK:EE
2 Y = =] o FE (T - "y m— ety =
PECHEEESCHEGESLSSVE FEEEHE S
Process & % k{E‘ Start Page [[J Reports [ o) x
iv 2 Synthesize Design
o = Synplify Pro -
N - * Synplify B Project: Release Notes FPGA Design Guide -
+ Translate Design ] o . . . .
v 2 Map Desi = Open... Lattice Diamond Software 3.12 Release Notes Design Planning
+ Map Design X
[ 2 Map Trace £ ew... User Guides HDL Coeding Guidelines
[0 & Verilog Simulation File {38 mport isoLEVER Project... Lattice Diamond 3.12 Release Notes Timing Closure
O : WYHDL Simulation File Recent Proj . Lattice Diamond 3.12 User Guide Other Tool Guides
v 2 Place & Route Design ) ExamplesoC Lattice Synthesis Engine for Diamend User ModelSim Users Manual
-
O - Place & Route Trace @] soc2 Guide ModelSim GUI Reference Manual
E : 1/0 Timing Analysis Eﬁsnc Iéautréc: Diamond 3.12 Platform Designer User ModelSim Command Reference Manual
¥ Thermal Analysis =
~ 2 Export Files 8 hello Clarity Designer User Guide ModelSim Tutorial
O : IBIS Model Lattice Diamond 3.12 Programming Tools User Synplify Pro User Guide
[1 & Verilog Simulation File Guid Synplify Pro Reference Manual
] 2 VHDL Simulation File Software Update Center Reveal User Guide Synplif‘y Pro Language Support Reference
2 Bitstream File Currently running Lattice Diamond software version: Reveal Troubleshooting Guide Manua
= JEDEC File 3.12.0.240.2 Lattice Diamond 3.12 Installation Guide for Tel/The
No updates available Windows Lattice on the Web
Last check time: Thu Mar 18 13:46:39 2021 Il:_attlce Diamond 3.12 Installation Guide for Lattice Semicenductor
inux
—_— Answer Datahase hd
File List Process Hierarchy
Output a8 x
synpwrap -msg -prj "ExampleSoC_impll synplify.tcl™ -log "ExampleSol_impll.srf"
Copyright (C) 1992-2020 Lattice Semiconductor Corporation. All rights reserved.
Lattice Diamond Version 3.12.0.240.2
INFO - Synplify synthesis engine is launched. v
Td Comsole  Output | Error  Wamning  Info®
Start: Synplify Pro Mem Usage: 313,948 K

Figure 4.6. Generate ProgrammingFile

4.3. Programming the Target Device

Once the programming file is exported successfully in last section, it is ready to program the target device. Make sure
the evaluation board is powered ON and connect correctly to host PC before performing the following procedure.

1. Clickthe Programmericon % onthetoolbar of the Lattice Diamond Project Explorer.
2. The Programmer: Getting Started dialog pops up (Figure 4.7). Click OK.
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i} Programmer: Getting Started ? X

Select an Action

@ Create a new project from a JTAG scan
Cable: |HW-USBN-2B (FTDI)  ~ | Port: |FTUSB-0 - Detect Cable

TCK Divider Setting (0-30x):

() Create a new blank project

O Open an existing programmer project

Import file to current implementation

C: flscefpropelf2.0/workspace ExampleSaC fimpl 1 fimpl 1. xcf

Cancel

Figure 4.7. Programmer Getting Started Dialog

3. Review the Device Family, Device, Operation, and File Name in the Programmer window (as shown below).

@ s O B
| Enable Status Device Family Device Operation File Mame
1 MachX03D LCMXO3ID-5400HC SRAM Fast Configuration | ...e/HelloWorld5oC/impll/HelloeWerldSoC_impll
4. Clickthe Programicon “+* to download the programming data file to the device.

4.4. Creating Hello World C Project

Creating C project requires a system environment from SoC project as input.
1. In Propel Project Explorer view, select the SoC project HelloWorldSoC.
2. Choose Project > Build Project.

System environment of the select SoC project is generated under the SoC project folder. Check the result from the
Console view (Figure 4.8).

1] Problems [v=] Tasks | B Console i2 [ Properties| & Terminal = 8

X% HEPEE S
<terminated> sge [SDP Builder] C\lscc\propel\2.0htoels\python38_embed\python.exe

Warning - Unconnection: cpu@ inst TIMER_IRQ M@ remains unconnected
INFO - Finished: sge generated

Figure 4.8 Build Result of HelloWorld SoC Project

3. ChooseFile > New > [ Lattice C/C++ Project.
The C/C++ Project wizard opens with Load System and BSP page (Figure 4.9.).
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{53 C/C++ Project m] X
Load System and BSP —
Correct system environment file and get toolchain parameter '
System env: | C:\Iscc\propel\2.0\workspace\ExampleSoC\sge\sys_env.xml v] Browse...
Select processor core to create C/C++ Project
Core selected: | cpul_inst v
Projecttype: | C v
System information
Device Family CPU Name Instance Name
MachX03D riscv_mc cpul_inst
@ < Back Next > Finish Cancel
Figure 4.9. Load System and BSP Page
4. Select the system environment file just generated (Figure 4.9.). Click Next.
5. Enter project name “HelloWorld” (Figure 4.10). Click Next. Then click Finish.
The C project is created and displayed in workbench.
31 C/C++ Project O X
C/C++ Project —
Create C/C++ project of selected type ]_
e |
Project name: | HelloWorld |
Uze default location
Location: | Chlsec\propel2.0hworkspace\HelloWorld Browse...

Choose file systern: el s

Project type:

Toolchains:

» = GNU Autotools I
w = Executable

& Empty Project

& Lattice 5/ C++ Project

& Hello World RISC-V C Project

@& Hello Warld AMSI T Proiect N

RISC-V Cross GCC

Show project types and toolchains only if they are supported on the platform

@ |

< Back ||

Next> | Finish

Cancel

Figure 4.10. Create C Project Page

46

2022 Lattice Semiconductor Corp. All Lattice trademarks, registered trademarks, patents, and disclaimers are as listed at www. latticesemi.com/legal.
All other brand or product names are trademarks or registered trademarks of their respective holders. The specifications and information herein are subject to change without notice.

FPGA-UG-02155-1.0


http://www.latticesemi.com/legal

s LATTICE

Lattice Propel 2.2 SDK

User Guide
6. IntheProject Explorer view, select the C project “HelloWorld”.
7. Choose Project > Build Project.
8. Check the build result from the Console view (Figure 4.11).
{2 Problems | ] Tasks | & Console 22 [ Properties | & Terminal 4 4 <='|'=|>| q @A =k | s == I S i I S
COT Build Console [HelloWorld]
...................... L
text data bss dec hex filename 2
1262 8 2728 3990 f96 Helloworld.elf

Finished building: HellokWorld.siz

Inveking: Lattice Create Memory Deployment

riscv-none-embed-objcopy -0 binary --gap-fill @ "HelloWorld.elf™ "HelloWorld.bin™; srec_cat "HelloWorld.bin™
-Binary -byte-swap 4 -DISable Header -Output "HelloWorld.mem" -MEM 32

Finished building: Hellokorld.mem

16:56:57 Build Finished. @ errors, @ warnings. (took 4s.816ms)

Figure 4.11. Build Result of HelloWorld C Project

4.5. Running Demo on MachXO3D Breakout Board — Hello world

1. Findthe Terminal view nest to the Console view. If not found, re-open from Window > Show View > Terminal.

2. Inthe Terminal view, click the Open a Terminal icon =)

3. Choosethe Serial Terminal and configure the Serial port with Baud rate 115200 (Figure 4.12).

Note: Serial port number depends on specific PC.

e .
i+ Launch Terminal

Choose terminal: | Serial Terminal

Settings

Serial port: | COM1

Baud rate: |113200
Data size: |8
Parity: Mone

Stop bits: |1

Encoding: | Default (ISO-2859-1)

@

Cancel

Figure 4.12. Launch Terminal Dialog

Click OK. A serial connection communicate with UART is ready.
In the Project Explorer view, select C project “HelloWorld”.
Choose Run > Debug Configurations...

© N o 0k

Click the Debug button.

Double-click GDB OpenOCD Debugging to create a new launch configuration (Figure 4.13).
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Wait for a few seconds for switching to debug perspective, to start the server, and to allow it to connect to the
target device, start the gdb client, download the application, and then start the debugging session.

Note: This demo uses default debug configuration options.

$ Debug Cenfigurations

Create, manage, and run configurations

CEeEX| B Y-

| type filter text

[£] C/C++ Application

[t] C/C++ Attach to Application

[£] C/C++ Postrnortern Debugger

[t] C/C++ Remote Application

Cif C/C++ Unit

[ ] GDB Hardware Debugging
w [t | GDB Open0CD Debugging

[©] HelloeWorld Debug

[t ] GDB QEMU Debugging

L Launch Group

= Launch Group (Deprecated)

Filter matched 11 of 11 itemns

MNarme: | HelloWorld Debug |
Main CableConrﬂ g3 Debugger\l B Startup\l Bp Sourcew =] Commorﬂ 5 SvD Path\l
Project:
| HelloWorld | Browse...
C/C++ Application:
| Debug\HelloWorld.elf

Variables... Search Project... Browse...
Build (if required) before launching
Build Cenfiguration: | Select Automatically w
() Enable auto build () Disable auto build
(®) Use workspace settings Configure Workspace Settings...
Rewvert Apply

®

Figure 4.13. Debug Configurations Page

9. Click the Resume icon UP on the toolbar. The serial terminal outputs “Hello RISC-V world!” (Figure 4.14).
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8 % | § \Was- int main(void) { ~ || Enter location here || &1 @ [BI@| r5 o §
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v & HelloWorld.elf | 3 0000021a:  addi  sp,sp,-32 -
+ Thread #1 (Running : User Requ = 51 uart_init(&uart_core_uart, UART@_INST_BASE_ADDR, UART@_I 0000021c:  sw s1,20(sp) [
+ openocd.exe | W52 51 uart_init(&uart_core_uart, UAR'
W riscv-none-embed-gdb 53 #ifdef LSCC_STDIO_UART_APB 0000021e: 1u§ a3,0exlc
54 extern struct uart_instance *g_stdio_uart; 00000220: 1“1. s1,0x8
55 g_stdio_uart = &uart_core_uart; 00000222:  addi  al,s1,1024 # 0x8400
56 #endif 00000226 : 1i a5,8
57 00000228:  1i a4,1
58 printf("Hello RISC-V mr1d|\,.\,,-);| 0000022a: aqu a3,a3,512 # 0x1c200
59 LED_SET(ALL_OFF); 0000022¢ : 1i . a2,38
60 00000232: addi  a@,gp,-1964
61 while (true) { 48 int main(void) {
62 LED_SET(LED_ON(idx)); 00000236:  sw ra,28(sp)
63 00000238 : sw 50,24(sp)
64 if (++idx == LED_COUNT) { 0000023a:  sw 52,16(sp)
65 idx = @ 51 vart_init(&uart_core_uart, UAR
66 } 0000023c:  addi s0,gp,-1964
67 48 int main(void) {
68 if (RTL_SIM) { 00000240:  sw $3,12(sp)
69 delayMS(1); 00000242 sw s4,8(sp)
70 1 alca / N2 00000244:  jal 0x90 <uart init> g
< - > < >
© Console |1 R [ 89 Te 2P | © Executables @ Debugger Console| @ Memory! O aabEaP=0
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Figure 4.14. Run Result of Hello World Project
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Appendix A. Linker Script and System Memory Deployment

During the Lattice C/C++ Project creation, Propel SDK generates a linker script file, linker.ld, within the project. This
linker script file contains a memory region list parsing from the corresponding SoC design.

Note: lllegal memory regions are not imported to linker script. A memory region is considered illegal, if it has any of the
following conditions:

e Noconnectionto CPU

e Address space conflict

Each memory region has a list of attributes to specify whether or not use a particular memory region for an input
section (Figure A. 1).

e r:Read-only section.

e w: Read/Write section indicating the memory region is connected to the data port of CPU.

e x: Executable section indicating the memory region is connected to the instruction port of CPU.

Linker Script: linker.ld
Available Memory Regions

MName Attributes || Base Address Size
sysmemi_inst % 0:400000000 (0400008000
sysmermnl_inst w 0:400010000 0:400008000

Figure A. 1. Memory Regions in Linker Script
The generated linker script contains a mapping table of section pointing to memory region (Figure A. 2). Depending on

the attributes of each memory region, code section and data section can point to the same or different memory
regions.

Section to Memory Region Mapping

CODE: |sysmem0_inst -
DATA: |sysmeml_inst -

Section Mame Memory Region i
text sysmermn(_inst 2
.ctors sysmem(_inst

Jdtors sysmermn(_inst 1

Overview | linker.ld
Figure A. 2. Section to Memory Region Mapping
During the Lattice C/C++ Project building, Propel SDK generates Lattice system memory initialization files. Depending

on the number of the memory regions used, it generates single memory initialization file or multiple memory
initialization files. The following picture (Figure A. 3) shows an example of multiple memory files being generated,

separate for code and data segments.
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- (A2 sre
4 (= Debug

- 2= src

. 5 Example.elf - [nonefle]
Example_Code.rnem
Exarnple_Data.mern

= Example.bin

=] Example.lst
=] Example.map
| @ makefile

| @ objects.mk

| @ sources.mk
=| tmp

Section to Memory Region Mapping

Section Mame
ged
.«ctors

.dtors

»

Memory Region

|m

sysmem(_inst
sysmermn(_inst

sysmem(_inst

Overview | linker.ld

Figure A. 3. Linker Script and Generated Memory Files

If you modify the linker script manually after the Lattice C/C++ project creation, especially change the number of the
used memory regions, the number of memory files generated during project building cannot be changed automatically.
You can re-configure the generation of memory files in Propel by:

1. Inthe Project Explorer view of Propel, select a C/C++ project.

2. Choose Project > Properties. The Properties dialog opens showing the properties of the current project.
3. Select Settings of C/C++ Build category from the left pane. Select the Toolchains tab (Figure A. 4).

Check Create memory file, if you point code and data segments to same memory region. Or, check Create multiple

memory files, if you point code and data segments to separate memory regions.

4. Click Apply.
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% Properties for HelloWorld O x

| type filter text Settings Sy v 8
» Resource
Builders

s CfC++ Build Configuration: | Debug [ Active ] ~ | | Manage Configurations...

Build Variables
Envircnment

Logging B3 Tool Settings i Toolchains ‘M Devices # Build Steps Build Artifact Binary Parsers | * | *
Settings
Tool Chain Editor Mame: | GMNU MCU RISC-V GCC (riscv-nene-embed-gcc) e
» CfC++ General )
. MCU Architecture: | RISC-V w |
Project Matures Prefix: | riscv-none-embed- |
Project F‘.eferenc.es Suffix: | |
Run/Debug Settings
SystemVerileg Project Properties C compiler: | gec |
Task Repository C++ compiler | g++ |
Task Tags
s Validation Archiver ar

Hex/Bin converter: | ohjcopy

Listing generator: | objdump

Build command: | make

Size command: | size |

Remove command: | rm

Toolchain path: | §{eclipse_home}/../riscv-none-embed-gec/bin

(to change it use the global or workspace preferences pages or the project properties page
Build tools path: | §{eclipse_homel/../build_tools/bin

(to change it use the global or werkspace preferences pages or the project properties page

[] Create memory file

Create multiple memory files
Create extended listing
Print size

Restore Defaults Apply

@ Apply and Close Cancel

Figure A. 4. Toolchains Tab of C/C++ Build Settings

5. Gobackto the Tool Settings tab. The relevant Lattice memory deployment tools can be found (Figure A. 5).
Customize the tool options as needed.

6. Click Apply and Close to save the change.
Note: Setting for each configuration, Debug or Release, is independent.
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B9 Tool Settings i) Toolchains M Devices . Build Steps Build Artifact Binary Parsers II‘Z‘

(2 Target Processor LIFill gaps in the data
(22 Optimization Diata Walue 0

@ Warnings
@ Debugging

w 83 GNU RISC-V Cross Assembler
@ Preprocessor
@ Includes
@ Warnings
@ Miscellaneocus

w B85 GNU RISC-V Cross C Compiler
@ Preprocessor
@ Includes
@ Optimization
@ Warnings
@ Miscellaneocus

w 83 GNU RISC-V Cross C Linker
@ General
@ Libraries
@ Miscellaneocus

w 83 GNU RISC-V Cross Create Listing
@ General

w 83 GNU RISC-V Cross Print Size
@ General

Address Range | (x8000

w 83 Lattice Create Memory Deployment
@ General

w 83 Lattice Multi Memory Deployment (CODE SEGMENT)
(2 General

~ B3 Lattice Multi Memary Deployment (DATA SEGMENT)
(& General

| Restore DefauHs| | Apply |

Figure A. 5. Tool Settings Tab of C/C++ Build Settings
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Appendix B. Standard C Library Support

Propel SDK bundles Picolibc as the standard library support (https://keithp.com/picolibc/). Picolibc s a set of standard
C libraries, both libc and libm, designed for smaller embedded systems with limited ROM and RAM. Picolibc includes
code from Newlib (https://sourceware.org/newlib/) and AVR Libc (https://www.nongnu.org/avr-libc/).

Printf and Scanf levels in Propel SDK

Propel SDK provides three levels of printf support with the support of Picolibc, which can be selected when creating a

Lattice C/C++ project (Refer to Figure B. 1), or be modified in the toolchain settings in the project properties after the

project is created, noting that the options in both compiler and linker need to be set (Refer to Figure B. 2 and

FigureB. 3).

e Integer only printf. This is the default selection in Propel SDK, which removes the support for all float and double
conversions to save codessize.

e Float printf. It requires a special macro for float values: “printf_float". To make it easier to switch between that and
other two levels, that macro should also be correctly defined for the other two levels.

Here is a sample program to demonstrate the usage:

#include <stdio.h>

void main(void) {
printf(" 2761 = %11d, Pi = %.17g\n", 111 << 61, printf_float(3.141592653589793));

}

o Full printf. This offers full printf functionality, including both float and double conversions.

System Library Interfaces used in Propel SDK

Propel SDK provides three system library for stdio support with the help of Picolibc, which can be selected when
creating a Lattice C/C++ project (refer to Figure B. 1), or be modified in the toolchain settings in the project properties
after the project is created, noting that only the option in linker needs to be set (refer to Figure B. 3).

e Default. Use the default system library interface (UART) in BSP, this requires a UART instance inside SoC design.

e Semihosting. “Semihosting” is a mechanism that enables code running on the target to communicate with and use
the 1/0 of the host computer. Propel SDK provides semihosting support in On-Chip-Debugging flow. It allows
printing messages to the debugger console without relying on the UART instance.

e Dummyhosting. Dummy stdio hooks. This allows programs to link without requiring any system-dependent
functions. This is only used if the program doesn't provide its own version of stdin, stdout, stderr.
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0% C/C++ Project

Lattice Toolchain Setting

Configuration: | Debug

Lib Setting  C/C++ Compiler C/C++ Linker

() Mo default libraries (-nedefaultlibs)

() Newlib

(O Mewlib-nano (--specs=nano.specs)

(®) Picolibe (--specs=picolibc.specs)

Printf Level

(®) Integer only printf (-DPICOLIBC_INTEGER_PRINTF_SCANF)
() Float printf (-DPICOLIBC_FLOAT_PRINTF_SCANF)
() Full printf (-DPICOLIBC_DQOUBLE_PRINTF_SCANF)

Systern Library
(®) Default

(O) Semihosting (--oslib=semihost)
() Dummyhosting (--oslib=durnmyhost)

< Back MNext = Cancel

Figure B. 1. Lattice Toolchain Setting Dialog
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Figure B. 2. Properties of C/C++ Project — Compiler Options
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Figure B. 3. Properties of C/C++ Project — Linker Options
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Appendix C. Third-party Command-line Tools in Lattice Propel
SDK

The Propel SDK integrates with a number of third-party command-line tools, which can be used with Propel User
Interface (Ul) or as stand-alone command-line tools. You can find these command-line tools and their documentation
according to the following list.

1. Windows Build tools
Version: 4.2.1-1
Binaries Location: <Propel Installation Location>\sdk\build_tools\bin

Documents Location: <Propel Installation Location>\sdk\build_tools\share

2. OpenOCD
Version: 0.10.0
Binaries Location: <Propel Installation Location>\sdk\openocd\bin
Documents Location: <Propel Installation Location>\sdk\openocd\doc

3. GNURISC-V Embedded GCC
Version: 10.1.0-1.1
Binaries Location: <Propel Installation Location>\sdk\riscv-none-embed-gcc\bin
Documents Location: <Propel Installation Location>\sdk\riscv-none-embed-gcc\share\doc

4., Picolibc
Version: 1.5.1

Binaries Location: <Propel Installation Location>\sdk\riscv-none-embed-gcc\riscv-none-embed\picolibc\riscv-none-
embed\lib

Documents Location: <Propel Installation Location>\sdk\riscv-none-embed-gcc\riscv-none-embed\picolibc\riscv-
none-embed\doc

5. SRecord
Version: 1.6.4
Binaries Location: <Propel Installation Location>\sdk\tools\bin

Documents Location: <Propel Installation Location>\sdk\tools\bin
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Appendix D. Command-line Environment Setting Script in Lattice
Propel SDK

Propel provides a script to set necessary environment variables for running all Propel SDK command line tools. It
enables you to fast get up to using command line tools, especially for Lattice specific tools.

To usethescript:

1. Runthe script propel_commandline.cmd (Windows) or propel_commandline.sh (Linux) under <Propel Installation
Location>.

The message "Lattice Propel Commandline" is printed, and let you go to a new command line interface.

2. Allcommand linetools in the Propel SDK can be run from this command line interface without any special
configuration.

Here are examples of using the command line tools within this script.
Example A: Build a C project under command line.

$ cd <C project Location>/Debug
$ make

Example B: Launching openocd under command line.

$ cd <C project Location>

$ openocd -c "gdb port 3333" -c "set target 0" -c "set tck 1" -c "set
port FTUSB-0" -c "set RISCV_SMALL YAML src/cpu0O.yaml" -f
interface/lattice-cable.cfg -f target/riscv-small.cfg
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Technical Support Assistance

Submit a technical support case through www.latticesemi.com/techsupport.
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