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Acronyms in This Document

A list of acronyms used in this document.

Acronym Definition

BSP Board Support Package, the layer of software containing hardware-specific drivers and libraries to function
in a particular hardware environment.

DUT Design Under Test.

SDK Embedded System Design and Develop Kit. A set of software development tools that allows the creation of
applications for software package on the Lattice embedded platform.

IDE Integrated Development Environment.

OEM Original Equipment Manufacturer.

Workspace The t.jirectory wh.ere stores your work, it is used as the default content area for your projects as well as for
holding any required metadata.

Workbench Refers to the desktop development environment in Eclipse IDE platform.

Programmer A tool can program Lattice FPGA SRAM and external SPI Flash through various interfaces, such as JTAG, SPI,

and I2C.

Perspective

A group of views and editors in the Workbench window.

A free and open instruction set architecture (ISA) enabling a new era of processor innovation through open

RISC-V standard collaboration.

RISC-V MC Lattice RISC-V for Micro-Controller Soft IP

SoC System on Chip. An integrated circuit that integrates all components of a computer or other electronic
systems.

SRAM Static Random Access Memory.

UFM User Flash Memory.
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1. Introduction

Lattice Propel™ is a complete set of graphical and command-line tools to create, analyze, compile, and debug both
FPGA-based hardware and software processor systems.

1.1. Purpose

Embedded system solutions play an important role in FPGA system design allowing you to develop software for a
processor in an FPGA device. It provides flexibility for you to control various peripherals from a system bus.

To develop an embedded system on an FPGA, you need to design the System-on-Chip (SoC) with an embedded
processor and develop system software on the processor. Lattice Propel™ helps you develop your system with a RISC-V
processor, peripheral IP, and a set of tools.

The purpose of this document is to introduce Lattice Propel SDK tool and flow to help you quickly get started to build a
small demo system. You can find recommended flows of using Lattice Propel SDK in this document as well.

1.2. Audience

The intended audience for this document includes embedded system designers and embedded software developers
using Lattice FPGA devices. The complete list of supported devices can be found at Lattice Propel Release Notes. The
technical guidelines assume readers have expertise in the embedded system area and FPGA technologies.

www.latticesemi.com/legal
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2. Lattice Propel Development Suite

Lattice Propel development suite includes:
e anintegrated development environment (IDE), which is the framework of Propel;
e Lattice Propel Builder, which is for SoC design;

e Lattice Propel SDK, which is for system software development.

2.1. Eclipse IDE

Eclipse IDE provides the Propel development suite a platform to manage the SoC project and the Embedded C Project
in the same workspace.

The SoC project, which extends from the Propel Builder project, provides easy interaction with other Lattice design
tools, such as Lattice Diamond® 3.11 within Propel.

The Embedded C Project provides a platform for developing or debugging application code within Eclipse IDE. The
project can be created directly from the SoC project with a pre-set Board Support Package (BSP) and applications by
using Propel development suite.

2.2. Lattice Propel Builder

Lattice Propel Builder allows you to assemble the larger functional blocks of the design hierarchy. Propel Builder
enables you to instantiate modules and IP from the IP Catalog in a schematic view, and can easily connect the modules.
Propel Builder also helps you customize address spaces within modules, such as a processor. In Propel development
suite, Propel Builder is used to create a microprocessor integrated platform for both hardware and software
development.

Refer to Lattice Propel Builder 1.1 User Guide (FPGA-UG-02116) for more detailed information.

2.3. Lattice Propel SDK

Lattice Propel SDK is based on Eclipse Embedded CDT (C/C++ Development Tools). It allows you to create, build, and
debug software application projects that drive the platform within the Eclipse framework.

The main features are:
e (Create, build, debug, or manage embedded applications for Lattice RISC-V CPU/SoC solution.
e  Provide extra build steps to generate the binary and memory files required for deployment.

e  Build using the latest industry standard open source components and tools for RISC-V firmware development and
debugging.

e Support Newlib and nano for RISC-V, and provide lightweight standard library implementation.

e  Provide fully-configurable toolchain definitions.

www.latticesemi.com/legal
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3. Lattice Propel Tool Flows

The Propel tool flows including SoC project design flow, C project design flow, system simulation flow, and
programming and On-Chip-Debugging (OCD) debugging flow, are discussed in detail in the following sections.

3.1. Propel Environment

3.1.1. Running Lattice Propel

After installing Lattice Propel, you can launch Propel from the desktop shortcut icon or from the Start menu. When
Propel is invoked, a dialog (Figure 3.1) pops up. You can browse to select where to locate the workspace. For normal
needs, just click Launch to pick the default location and continue running Propel.

Q Lattice Propel Launcher @

Select a directory as workspace

Lattice Propel uses the workspace directory te store its preferences and development artifacts,

Workspace: 1 - Browse...

Use this as the default and do not ask again

» Recent Workspaces

[ Launch ] | Cancel

Figure 3.1. Select Workspace Dialog

After the workspace location is chosen, a single workbench window is displayed using default Propel SDK perspective.
The default Propel SDK perspective contains following five functional areas (Figure 3.2).

1. Menu bar and Toolbar.
Project Explorer view: displays projects in the workspace.
Editor view: provides capability of editing source files.

Outline view: displays an outline of a file that is currently open in the editor area.

v W

Log area includes these views: Problem view, Tasks view, Console view, Properties view, and Terminal view.

www.latticesemi.com/legal


http://www.latticesemi.com/legal

::LATTICE Lattice Propel SDK El.l
User Guide

File Edit Source Refactor Mavigate Search Project Run  LatticeTools Window Help _
D-EHR ®-8-0inSqei@ @ -E-C-it-0 -0 @ PH1IL-F-Be -2

= g = g
BES 7T &

There are no projects in your workspace,
To add a project:

There is no active editor that provides
an outline.

Create a new Lattice C project

. Create a new Lattice SoC Design Project
Y Createa project...

Ex Import projects...

[ Problems 4| Tasks| & Console &2 =] Pmperlis}@Terminaq m B~~~ = 0O

5

Figure 3.2. Propel Workbench Window

3.1.2. Importing General Projects

In Propel SDK, you can use the importing project wizard to import existing projects into workspace except for Lattice
SoC design created by Lattice Propel Builder.

Note: You can only import projects which are created or managed by Propel SDK by choosing General > Existing Project
into Workspace in Propel SDK.

1. In Lattice Propel (SDK), choose File > Import....

The Select wizard opens (Figure 3.3).

© 2020 Lattice Semiconductor Corp. All Lattice trademarks, registered trademarks, patents, and disclaimers are as listed at www.latticesemi.com/legal.
All other brand or product names are trademarks or registered trademarks of their respective holders. The specifications and information herein are subject to change without notice.
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G Import
Select

Create new projects from an archive file or directory.

Select an import wizard:

type filter text

4 [~ General
B Archive File
|1 Existing Projects into Workspace |
[ File System
[T Preferences
[} Projects from Folder or Archive
[ (= C/C++ =

| »

m

@ < Back Next » Finish

Figure 3.3. Import Projects Wizard — General

2. Select General > Existing Project into Workspace. Click Next.

The Import wizard switches to Import Projects wizard (Figure 3.4).

© 2020 Lattice Semiconductor Corp. All Lattice trademarks, registered trademarks, patents, and disclaimers are as listed at www.latticesemi.com/legal.
All other brand or product names are trademarks or registered trademarks of their respective holders. The specifications and information herein are subject to change without notice.
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Select the project or projects you want to import in the Projects area.
Be sure to check the Copy projects into workspace option so that your original projects do not get updated.

Click Finish to start the importing process.

3.1.3. Importing Lattice SoC Design Projects

S Import

Import Projects

Select a directory to search for existing Eclipse projects.

(@ Select root directony:

() Select archive file:

Projects:

I]|
o)
o

|1
|"J

I &

Browse...

Browse...

bsp_demo (F\bsp)

Select All

Dezelect All

1!

Refresh

Options

["] Search for nested projects

Copy projects into workspace

["| Close newly imported projects upon completion
[] Hide projects that already exist in the workspace

Working sets

[ Add project to working sets

©)

Select...

|| Cancel

Figure 3.4. Import Existing Projects Wizard

Choose either Select root directory or Select archive file, clicking the associated Browse button to locate the
directory or file containing the project.

In Propel SDK, you can use the Import Wizard to import Lattice SoC design projects into workspace. Existing SoC design

projects created by either Propel SDK or Propel Builder can also be imported into Workspace by choosing Lattice

Propel > Lattice SoC Design Projects.

1. From Lattice Propel SDK, choose File > Import....

The Select wizard opens (Figure 3.5).
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i Import = [ -E ]
Select \
Impert Lattice SoC Design projects into the workspace. g e E |

Select an import wizard:

type filter text

»

» = General
= CfC++
s = Git
s = Install
4 [= Lattice Propel
o Lattice SoC Design Projects into Worksapce
> = Oomph
> = Run/Debug -

m

?) < Back Next > G

Figure 3.5. Import Projects Wizard — Lattice Propel

2. Select Lattice Propel > Lattice SoC Design Projects into Worksapce. Click Next.

The Select wizard switches to Import Lattice SoC Design Projects wizard page (Figure 3.6).

£ Import = [ s]
Import Lattice SoC Design Projects

I, Some projects cannot be imported because they already exist in
the workspace

Select root directory F:\ -

Projects:

[ Select All
SoC_demo (F\SoC_dema)
Deselect All
?\ Mest > [ Finish J [ Cancel

Figure 3.6. Import Lattice SoC Design Projects Wizard

3. Locate the directory containing the projects by clicking the Browse button.
4. In Projects area, select the SoC design project or projects you want to import.

5. Click Finish to start the importing process.

© 2020 Lattice Semiconductor Corp. All Lattice trademarks, registered trademarks, patents, and disclaimers are as listed at www.latticesemi.com/legal.
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3.2. SoC Project Design Flow

A new SoC design project including a Propel Builder design can be started from the Lattice Propel sets. Follow the steps

below to create a new SoC design project.

3.2.1. Creating a SoC Design Project
To start a Lattice SoC Design Project from Propel:

1. In Lattice Propel, choose File > New > “ Lattice SoC Design Project. The Create SoC project wizard opens

(Figure 3.7).

S SoC Project

Create SoC project

Create SoC project of selected template

Project name: ExarmpleSoC
Use default location
C\lscchpropelil 1\workspace\ExampleSoC
default

Template selection

Browse...

Processor: |RISC-V MC - | Family: MachX03D

’)

Device: | LCMXO3D-3400HC - | Performance: [5

’)

Package: [CABGAZEE v] Board: [Breakout

°]

Template Design

Empty Project
Hello World Project

Helle World Project. Components included:
a) Processor - RISC-V MC wy/ PIC/TIMER
b) GPIO
c) ASRAM - Asynchronous SRAM
d) UART - serial port

Finish | |

Cancel

Figure 3.7. Create SoC Project Wizard

2. Enter a project name.
Note: Do not include periods, colons, or spaces in the project name.

3. (Optional) To change the default location, clear the Use default location option, then browse to another location.

Choose a file system.

Select a desired platform template design. In particular, select empty project for building system from scratch.

Click Finish.

The SoC design project is created in workbench, and its design is opened and displayed in Propel Builder

(Figure 3.10).
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3.2.2. Open a SoC Design in Propel Builder
Within a SoC project, there is a Propel builder design.
To open Propel Builder for a SoC project:

1. Inthe Project Explorer view, select an SoC project.

2. Open the SoC project in one of the following three ways from Propel:

e Choose LatticeTools > . OpenDesign in Propel Builder (Figure 3.8).

LatticeTools | Window Help

4, Open Design in Propel Builder
Generate and Open Diamend Progjct

Generate and Open Radiant Progjct

Lattice Sentry Dermo GUI
Lattice Sentry Manifest Manager

Figure 3.8. LatticeTools Menu

e  Click the Propel Builder icon *n on the toolbar.

e Right-click the SoC project from Project Explorer. Choose Open Design In > IH'I'\l Propel Builder from the popup

menu (Figure 3.9).

Restore from Local History...

Open Design In v | 4. Propel Builder
Update Lattice Project Diamend
Team 3 Radiant

Figure 3.9. Project Explorer Popup Menu

3. SoC Design is opened and displayed in Propel Builder (Figure 3.10).

., Propel Builder
File Edit View Design Window Help

s 5 A BB x® QQQQ

Info o Schematic Address
v 1} Exam pleSoC

3 ﬁ Instances

=zt et
amm
arm w4
avmpm g

=N Noh =3

4 3 Ports aiiiaghi) jnst
' -
H Mets : N
A Components I,
@ cpul:1.0.0 —J
[ gpio0:1.2.0 |_ - 1 ——
—
@ sysmem(:1.0.0 +mim u:,_W_TH._I S st | .
S ™ +armm syzmaml_imt
Properties =_<—D L ey w:: .
2-LD AmELmL
Mame: ExampleSoC iy
i proven
Type: Instance i
L=
Path: ExampleSoC I I

VLNV:  lattice:systembuilder:Exam

Catalog Info
Td Console

Figure 3.10. Propel Builder Window
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4. (Optional) Modify the design in Propel Builder as desired. Most of the templates include a functional-ready SoC
design.
Note: You can only create an SoC design using Empty Project template inside the Propel Builder. Refer to
Lattice Propel Builder 1.1 User Guide (FPGA-UG-02116) for more details on how to create an SoC design using
Empty Project template.

3.2.3. Open Design in Lattice FPGA Design Software

Within an SoC project, you can create a Lattice FPGA design project including a Propel Builder design, and then open
the FPGA design project in appropriate software. There are two FPGA Design Software available, Lattice Diamond® and
Lattice Radiant™. Depends on the device family used in the SoC project, only one of the FPGA Design software can be
selected from the user interface, the other is grayed out. If MachXO3D or LFMNX device family is used, the Lattice
Diamond related menu items are active from Propel Ul. If LIFCL or LFD2NX device family is used, the Lattice Radiant
related menu items are active from Propel UL.

To open FPGA Design Software for an SoC project from Propel:

1. (Optional) Set Lattice FPGA design software installation location from Propel. By default, Propel can find the proper
Lattice FPGA design software installation location, usually the latest version installed on the PC. You can overwrite
it following steps below.

Choose Windows > Preferences. The Preferences dialog opens (Figure 3.11).

Select Propel Setting from the left pane. Click the Browse button to pick up the installation location of Diamond or
Radiant. Or, leave the Radiant Location area and Diamond Location area blank, as default. Propel can find the
location atomically.

gpreferences = @
x Propel Setting - v 8
- General -
- C/C++ Radiant Location
- Help —
- Install/Update lml
- MCU
- Mylyn Diamond Location
- Qomph =

Propel Setting Browse...

- Remote Development
- Run/Debug
- SVEditor
. Team
- Terminal
Validation

| Restore Defaults| | Apply |

|

'?:' I\_‘ 1] ':@' NP [Appl}rand CIoseH Cancel |

Figure 3.11. Propel Preferences Dialog

2. Inthe Project Explorer view from the Propel main GUI, select an SoC project.

3. Open the SoC project in one of the following ways:

L
e Choose LatticeTools > Generate and open a Diamond project; Or, choose LatticeTools > Generate and
open a Radiant project.

e (Click the Diamond icon ‘ or the Radiant icon from the toolbar.
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e Right-click an SoC project from the Project Explorer. Choose Open Design In >

Design In > Radiant from the right-click menu.

4. Diamond/Radiant project for SoC is generated at background and is launched (Figure 3.12/Figure 3.13).
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File Edit View Project Design Process Tools Window Help
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M BampleSoC/lib/latticesemi.com/ip/ahbl2aph0/1.0.0/rtl/ah|_| — :
M3 ExampleSoC/lib/latticesemi.com/ip/uart0/1.0.0/tl/ uartd.v
M BampleSoC/lib/latticesemi.com/ip/timerd/1.0.0/rtl/timerd
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Managing Projects
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Guide
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Clarity Designer User
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Figure 3.12. Diamond Project
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Figure 3.13. Radiant Project
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(Optional) From the File List view of the Diamond/Radiant software:

e modify the top-level RTL file (<proj_name>_Top.v) to match the SoC design, presupposition of which is that
there is a top-level RTL file in your SoC design; or

e create a top-level RTL file (<proj_name>_Top.v) to match the SoC design, if the SoC design is created from an
Empty Project template and there is no top-level RTL file in your SoC design.

Note: This step is a must to the SoC design that is created from Empty Project template.

Process the design in Lattice Diamond/Radiant.

(Optional) Modify constraint file (<proj_name>.lpf/<proj_name>.pdc) to match the SoC design, if you have
modified the SoC design.

In Diamond software, switch to Process view of the project (Figure 3.14). Make sure at least one file, IBIS Model,
Verilog Simulation File, VHDL Simulation File, Bitstream File, or JEDEC file, is checked in the Export Files section for

programming. Choose Process > 1= Run.
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m
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FPGA Libraries {HTML
wersion)
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Copyright (c) 1995-2001 Lucent Technologies Inc. All rights reserved.
Copyright (c) 2001 Agere Systems 211 rights reserved.
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Td Console | Output | Error | Warning® | Info* ‘

Start: Map Design Mem Usage: 184,752 K

Figure 3.14. Generate Programming File in Lattice Diamond

In Radiant software, from the Process Toolbar, click Export Files (Figure 3.15).
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Figure 3.15. Generate Programming File in Lattice Radiant

The Programming file is generated. The generated programming file can be used in the Programmer.

3.2.4. Generating System Environment by Building Project

System environment package including the system environment file and the BSP package is required for the embedded
C project.

To generate system environment package from Propel:

1.
2.
3.

In the Project Explorer view, select an SoC project.
Choose Project > Build Project.
Check the building result in the Console view (Figure 3.16).

{2 Problems (-.E,. Tasks (E Console &2 = Propenieq@Terminaq = O
EX% GEEE -5
<terminated> sge [SDP Builder] C\lscc\propel'l.1\pge\pge.exe

Warning [SBX]: Unconnection: cpu@ inst TIMER IRQ M@ remains unconnected -
Info: C:\lscchpropelil.l\workspace\ExampleSoC\sgeisys_env.xml generated

Info: C:\lscchpropeli\l.1\workspace\ExampleSoC\sge\bsphsys platform.h generated

Info: C:\lscchpropelil.l\workspace\ExampleSol\sgel\bsp generated

Figure 3.16. Build Result of SoC Project
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3.2.5. About SoC Design Project

The SoC project creating starts with a functional-ready SoC design and a default simulation environment. In the Project
Explorer view, open an SoC project folder and all its sub-folders. The project contains the following files but not limited
to the following files (Figure 3.17), some of which may vary upon your opening the SoC design project in Diamond or

Radiant software:

e <proj_name>: Folder contains a Propel Builder design including the .sbx file.

e <proj_name>/application: Folder contains functional-ready embedded application source codes.

e <proj_name>_v: Folder contains the SoC verification project.

e <proj_name>_v/sim: Folder contains the simulation environment.

e Impll: Folder contains the implementation of Diamond/Radiant project.

e sge: Folder contains generated package necessary for creating C project.

e <proj_name>.ldf: Diamond project file.

e <proj _name>.lpf: Diamond project logical preference file.

e <proj_name>.rdf: Radiant project file.

e <proj name>.pdc: Radiant project post-synthesis constraints.

e <proj_name>.txt: Description file from the template.

7 Project Explorer &2

4 [ ExampleSoC
4 [ ExampleSoC
» = application
» (= lib
> =% mem_report
ExampleSoC_tmplv
Vh ExampleSoC_tmplvhd
|| ExampleSoC.layout
“ ExampleSoC.sbx
ExampleSoCwv
4 [ ExampleSoC_v
» = lib
: = sim
|=| ExampleSoC_v,json
7| ExampleSoC_v.shx
> (= impl_1
> (= sge
|=| ExampleSoC.pdc
ExampleSoCordf
ExampleSoC.bd
radiant_setup_template.tcl

|'|||' |'|||' [: |

Figure 3.17. Contents of SoC Project
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3.3. C Project Design Flow

3.3.1. Creating a Lattice C Project
To start a Lattice C Project from Propel:
1. Choose File > New > @ Lattice C Project.
The C Project wizard opens with the Load system and bsp page (Figure 3.18).

G C Project = @

Load system and bsp —

Correct system environment file and get toolchain parameter

Select system environment file and bsp package

T 0 LW O Isc ol propeli ] 1hworkspacel\ExampleSo Clsgelsys_envaon| IRl 10T

Select the core type to create C Project

Core selected: | cpul_inst v]

System information
Device Family CPU Mame Instance Mame

LIFCL risCv_mc cpul_inst

?) < Back Nest > Finish

Figure 3.18. Load System and BSP Dialog

2. Browse to the SoC project folder and select the system environment file sys_env.xml.

All system environment files available in the current workspace can be selected from the System env: drop-down
menu.

3. If the platform has more than one processor, choose one core.
Click Next.
The C Project dialog opens (Figure 3.19).
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£ CProject = |5 mesd]
C Project
Create C project of selected type |

Project name: Example|

Use default location

Chlscchpropeld 1\workspace\Example Browse...
default
Project type: Toolchains:
s (= GMU Autoteols - RISC-V Cross GCC

4 (= Executable
& Empty Project
& Lattice C Project
& Hello World RISC-V C Project
& Hello World AMSI C Project
» (= Shared Library B
> (= Static Library -

m

Show project types and teclchains only if they are suppoerted on the platform

? <Back | Net> | Finish

Figure 3.19. Create C Project Dialog

Enter a project name. Suggest not using periods, colons, or spaces in your project name. Though spaces are
allowed, they may cause certain issue with some tools.

By default, the Use default location option is checked. The default file system is selected automatically. Suggest
using the default location, unless you have special need to a special location.

Select a project type. Select a toolchain. Normal choice is Lattice C Project and RISC-V Cross GCC.
Click Next.

The Lattice toolchain setting dialog opens (Figure 3.20).

FPGA-UG-02115-1.0
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S C Project = @

Lattice toolchain setting

Configuration: | Debug -

Lib Setting | C Compiler | C Linker

Mo default libraries(-nodefaultlibs)
Mewlib

@ Mewlib-nano

Finich ] | Cancel

'?\' < Back

Figure 3.20. Lattice Toolchain Setting Dialog

9. By default, two toolchain configuration modes, Debug and Release, can be chosen from the Configuration
drop-down menu.

e Debug configuration creates executables containing additional debug information that lets the debugger make
direct associations between the source code and the binary files generated from the original source.

e Release configuration provides the tools with options setting to create an application with the best
performance.

You can modify frequently-used library, compiler, and linker options for each configuration. For a complete
toolchain setting, go to project properties after creating the project. Refer to the Advanced Tool Chain Setting
section.

e In Lib Setting tab, standard C library can be reconfigured. The nano version of library (Newlib-nano) is selected
by default for small embedded usage.

e In C Compiler tab, optimization level and debug level can be reconfigured for each toolchain configuration.

¢ In C Linker tab, Remove unused code (--gc-sections) is checked by default for garbage collection of unused
code.

10. Click Finish.

The Lattice C project is created and is displayed using the Propel SDK perspective. A perspective is a collection of
tool views for a particular purpose. The Propel SDK perspective is for creating Lattice C programs.

3.3.2. Updating a Lattice C Project

When you make changes to an SoC project, sometimes you want to synchronize the changes to an existing Lattice C
project instead of creating a new Lattice C project. In this case, you can use the update C project feature.

Note: This feature overwrites the corresponding files or settings of your existing C project. Be sure to back up your C
project before using this feature.

To update a Lattice C Project from Propel:

1. Generate the latest system environment package according to the Generating System Environment by Building
Project section.

2. Inthe Project Explorer view, select a C project.
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3. Choose Project > Update Lattice C Project....
The C Project wizard opens for updating system and bsp (Figure 3.21).

{3 CProject [F=N[HCh ==

Update system and bsp

Select system envirenment file and bsp package
Systemn env:  Ci/fIscc/propel/L.1/workspace/hello/sge/sys_env.aml Browse...

/| Re-generate toolchain parameters and linker script

| Update bsp package

Update | | Cancel

Figure 3.21. Update System and BSP Dialog

Browse to the SoC project folder and select the system environment file sys_env.xml.
Select the checkbox for what you can update:

e Re-generate toolchain parameters and linker script: check this option if you want to modify CPU or memory in
the system.

e Update bsp package: check this option if you want to add additional IP components into the system.
6. Click Update to make changes for the selected C project.

3.3.3. Building a Lattice C Project
To build a Lattice C project in Propel:
1. Inthe Project Explorer view, select a C project.

2. Follow steps below if you want to change the active build configuration:

a. Choose Project > Build Configurations > Manage.... Or, click the Configuration icon & on the toolbar.

b. The Manage Configurations dialog opens (Figure 3.22) for choosing active configuration. By default, a Debug
configuration creates executables containing additional debug information that lets the debugger make direct
associations between the source code and the binary files generated from the original source. A Release
configuration provides the tools with options setting to create an application with the best performance.

Q Example: Manage Configurations @
Configuration Description Status
Debug Active
Release
Set Active | New... | | Delete | | Rename... |
[ oK l | Cancel |

Figure 3.22. Manage Configurations Dialog
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Choose Project > Build Project. Or, click the Build icon I;% on the toolbar.

The results of the build command are displayed in the Console view (Figure 3.23).

[2! Problems | ] Tasks | Bl Conscle i3 1 Properties | & Terminal L4 | H MED =N | = EB~-f~-= 0
CDT Build Console [Example]

Invoking: GNU RISC-V Cross Print Size e
riscv-none-embed-size --format=berkeley "Example.elf”

text data bss dec hex filename

1118 2] 4208 5318 14ck Example.elf

Finished building: Example.siz
Invoking: Lattice Create Memory Deployment File
srec_cat Example.bin -Binary -fill @ @ @x@@e@8888 -byte-swap 4 -DISable Header -Output “Example.mem”

-MEM 32
Finished building: Example.mem

B89:86:81 Build Finished. @ errors, @ warnings. (took 4s.618ms)

Figure 3.23. Build Result of C Project

3.3.4. About Lattice C Project

The Lattice C project starts with source code. In the Project Explorer view, open a C project folder and all its
sub-folders. The project contains:

src/bsp/driver: Folder contains driver codes from the IP in the platform.

src/bsp/sys_platform.h: Header file that defines DEVICE_FAMILY (the Lattice FPGA), address mapping, and any IP
parameters that can be used by the drivers.

src/main.c: C file contains the main routine, which is the entry-point of a C program.

src/cpu0.svd: System view description file used for peripherals registers view at debug perspective.
src/cpu0.yaml: Processor description file used at debugging time.

src/linker.ld: Linker script file.

src/sys_env.xml: System environment file describing aspects of the platform, such as memory spaces.

After building the project, the build output can be found in each build configuration folder, the Debug folder or the
Release folder (Figure 3.24). The Debug or Release folder contains:

<proj_name>.elf: Executable file used in on-chip debugging.

<proj_name>.bin: Binary file used in deploying the application to flash memory.
<proj_name>.lIst: Extended listing file generated by tool objdump.
<proj_name>.map: Linker map file.

<proj_name>.mem: Lattice system memory initialization file used in System_Memory IP.

Note: Some of the files listed in Figure 3.24 are intermediate files that you do not need to take care of.
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7 Project Explorer &2

[
e’y
:\J

4[5 Example

>1’;?

> [l

Binaries
Includes

PRECEs

F

iy [y =) [&) &)

(= bsp

s (= driver

- [ sys_platforr.h
main.c
utils.c
utils.h
cpul.svd
cpul.yaml

S
T linker.Id

P

i3 sys_envaml

4 (= Debug

»

»

= src

%5 Example.elf - [none/le]
Z| Example.bin

=] Example.lst

=] Example.map

Z| Example.mermn

| @ makefile

| @ objects.mk

| @ sources.mk

- = ExampleSeC

Figure 3.24. Contents of C Project

3.3.5. Writing Code

oon

Lattice Propel is based on Eclipse IDE. You can write application code following the process and usage of the same tools
as any in Eclipse IDE. You can get more detailed information regarding Eclipse IDE from the Propel online help.

For writing code, Lattice Propel SDK provides two extra aids:

e Lattice System Platform: An overview of the processor platform can be displayed (Figure 3.25).

e Linker Editor: An overview of the memory regions of linker script can be displayed. You can modify key linker

parameters via the graphical interface (Figure

3.26).
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% Lattice Platform &4 = 0
General
Vendor lattice
Library: PGE
MName: ExampleSeC
Version: 11
DeviceFamily: LIFCL
BspLocation:  bsp
compeonent ipname version  vendor basefddress  range irg
cpul_inst riscv_mc 100 latticesemi.com OxFFFFO000 (00000300
sysmemi_inst  system_memeory 102 latticesemi.com  0:00000000 (0400008000
gpicl_inst gpic 121 latticesemi.com  0x00008400 0:400000400  IRQ 51
uartd_inst uart 101 latticesemi.com (00008000 0x00000400  IRQ_SD
Overview | sys_env.xml
Figure 3.25. Lattice System Platform
{-r""} = - =
i} Lattice Platform (E Linker &2 |
Linker Script: linker.ld
Available Memory Regions
Mame Attribut... Base Address Size
; WK 0200000000 0x00008000
STACK and HEAP Size
HEAP_SIZE:  0x0
STACK_SIZE: (xAD0
Section to Memory Region Mapping
Section Mame Memory Region -
text sysmermn(_inst
.ctors sysmem(_inst
Jdtors sysmermn(_inst
rodata sysmem(_inst
.data sysmem(_inst -
Overview | linker.Id | |

Figure 3.26. Linker Editor
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3.3.6. Advanced Tool Chain Setting

Follow the process below to modify the tool chain settings of a C project.

To change tool chain setting in Project Properties in Propel:

In the Project Explorer view of Propel, select a C project.

Choose Project > Properties. The Properties for current project opens (Figure 3.27).

Select Settings of C/C++ Build category from the left pane. Select the Tool Settings tab.

$ Properties for Example

type filter text

> Resource
Builders
a4 (f/C++ Build
Build Variables
Environment
Legging
Settings
Tool Chain Editor
» CfC++ General
- MCU
Project Natures
Project References
Run/Debug Settings
Task Repositery
Task Tags
> Validation

Settings

Configuration: ’Debug [ Active |

'] ’Manage Configurations,

]

5 Tool Settings | %3 Toolchains | B Devices | 4 Build Stepsl

Build Artifactl Binary Parsersl o[

3

@ Target Processor
(2 Optimization
(22 Warnings
(%2 Debugging
4 B3 GMU RISC-V Cross Assembler
(% Preprocessor
(2 Includes
@ Warnings
(2 Miscellaneous
4 B85 GMU RISC-V Cross C Compiler
(2 Preprocessor
@ Includes
# Optimization
@ Warnings
(# Miscellaneous
4 B3 GMU RISC-V Cross C Linker
2 General
(22 Libraries
(2 Miscellaneous
4 B3 GMU RISC-V Cross Create Flash Image
@ General
4 83 GMU RISC-V Cross Create Listing
@ General
4 83 GMU RISC-V Cross Print Size
@ General
4 83 Lattice Create Memory Deployment File
2 General

Optimization Level ’None (-00) v]
Message length (-fmessage-length=0)

‘char' is signed (-fsigned-char)

Function sections (-ffunction-sections)

Data sections (-fdata-sections)

[ Mo commen unitialized {-fne-common)

[[] De not inline functions {-fro-inline-functions)

[T] Assume freestanding environment (-ffreestanding)

[] Disable builtin (-fro-builtin)

[T] Single precision constants (-fsingle-precision-constant)
[Z] Position independent code (-fPIC)

[T Link-time optimizer (-flto)

] Disable loop invariant move (-fno-move-loop-invariants)

Other optimization flags

[ Restore Defaults] [ Apply

[Apply and CIoseJ ’ Cancel

Figure 3.27. Properties of C Project

Customize the tools and tool options. All your customization can be resulted in the build configuration in the Tool
Settings properties tab. The build configuration is used during your C project building.

Note: Setting for each configuration, Debug or Release, is independent.

Click Apply and Close to save the change.

Note: You may need to clean the project to make the new setting take effect for the whole project.
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3.4. System Simulation Flow

The SoC Project created from template has a default simulation environment for you to setup and start functional
simulation. It is generated automatically along with the SoC project creation. You can use it as a start point and
customize accordingly.

The default simulation environment is with the following features:

e  Provides similar user experience as real board-level debugging, such as for Hello World SoC, key components
including RISC-V MC, System memory, and UART.

e Simulates user-modified template SoC with extended HDL designs.

e Simulates the whole system using real C projects as stimulus with the necessary modification and with all the
details for debugging.

e  Supports user extension with a friendly and flexible approach.

3.4.1. Launch Simulation
To launch simulation:
1. In Propel Builder, update the SoC design to enable simulation features.

e Enable the checkbox for Simulation Mode, and disable the checkbox for Debug Enable for RISC-V MC IP
module in the General area (Figure 3.28).

4, Module/IP Block Wizard ==

Configure Component from Module riscy_mc Version 1.0.0
Please set the following parameters to configure this component.

Diagram cpul Configure IP

Property Value

~ General
Simulation Mode ]
Debug Enable
PIC Enable ]
Timer Enable =

cpuO PIC and Timer Base Address (32'h00000000 ~ 32'hFFFFFFFF) | 32'hFFFFO000

MNurmber of Interrupt Requests [2 - 8] 2

—(HHIRQ_SOAHBL_MO_INSTRH
—~{4HIRQ_S1 AHBL_M1_DATAH

—{ck_i TIMER_IRQ_MOH
—rst_n_i system_resetn_o
riscv_mc

No DRC issues are found.

Generate Cancel

Figure 3.28. Configure Module RISC-V MC
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e Enable the checkbox for Initialize Memory for system_memory IP module from the Initialization area of the
General tab, and set Initialization File generated from the corresponding C project (Figure 3.29).

“. Module/IP Block Wizard E

Configure Component from Module system_memeory Version 1.0.2
Please set the following parameters to configure this component.

Diagram sysmem(

Configure IP

sysmemO

General Port 50 Settings
Property Value

Memory Address Depth [1-131072] 8192

p
—HBL_SO
—HBL_Sl

—ahbl_hclk_i

A

—ahbl_hresetn_i

Port 51 Settings

- Data Bus Width(bits) 32
Memory Type EBR
Port Count [1 - 2] 2
ECC Enable
Enable Arbiter
Enable FIFO Streamer
Initialize Memory
=
J Initialization File Format hex

system_memory

I Initialization File

sropel/1. 1/warkspace/Example/Debug/Example.mem | ... J

Mo DRC issues are found.

Generate Cancel

Figure 3.29. Configure Module System Memory

2. Click the Switch icon on the toolbar to switch between SoC design and SoC verification project (Figure 3.30).

3. After the SoC design is switched to an SoC verification project, click the Generate icon E; to generate the

simulation environment for OEM ModelSim. Click the Launch Simulation icon .' (Figure 3.30).
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% Propel Builder [C:/Iscc/propel/1.1/workspace/ExampleSoC/ExampleSoC_v/ExampleSoC_v.sbx] Device: LCMXO3D-9400HC-586256C [=] =]
File Edit View Design Window Help

o5 M S FHEExoEHB QQQAQ

Desgrihen 0 Schematic Address
hd Ex leSoC )
ib:EfF:TF: 2= sysclk_rst_genl_inst _dut inst__ -
nstances i
dut_clk_oj= [l 1
4 Mets ' = ik i 1
i llbU dut_clk_idut_rst_oj— 1 = gpio_ic[7:0]}=
- Components 1 bUdut it dk Jrstn_i td )
[ uart_ model1:1.0.0 threk _ =i Z
[£F] sysclk_rst_gen1:1.0.0 uart_modell_inst
led[7:0]
vart_rx_datza_debug[7:0]
-~ ai
Properties k vart_be_data_debug[7:0]
N vart_rx_brezk_dsbug
MName: m: o vart_rx_valid_debug
Type: Instance - uart_tc_busy_debug|
Path: ExampleSoC_v uart_tc_en_debug
WLMY:  lattice:systembuilder:ExampleSoC w10 ¥ uart_bxd
4 3
1P Catalog Design View P » =

Figure 3.30. SoC Verification Project

4. ModelSim is launched running simulation for the SoC verification project. The corresponding waveform of the SoC
verification project for the Hello World project is shown (Figure 3.31). Check the waveform.

™ ModelSim DE 20203 - o X
File Edit View Compile Simulate Add Wave Tools Layout Bookmarks Window Help

0-5H 8 $RBO 0L | W[ SHRH||[o e B el REEAS 2AMS][ AT 2 4] e s ~|

Al 2-s- 22| [0 m e[ % o w i & EEd e 3E 5[] I3 | s v g @

Bl sysdk_rst_gen1_inst
8l vart_model1_nst
& =ASSIGN=62

& std
| #vem_capacity=

4. Viestidut inst/bed_o

F huqmt__mdeu:ml,u:
£ [vtestiuart_model1_instrstn

Figure 3.31. Waveform of Hello World Project

3.4.2. Simulation Details

The default simulation environment is located at the generated sim folder inside the SoC verification project in Propel.
It contains:

[sim] -- generated simulation environment
[hdl_header]
soc_regs.v -- register definitions of all the components in DUT/SOC
sys_platform.v  -- base address, user settings of all the components in DUT/SOC
[misc]
* ¥ -- all the mem, hex, txt files will be copied here
flist.f -- file list for HDLs
msim.do -- do script for simulator, it can be gsim for Questasim
wave.do -- do script for adding signals in waveform window
<project_name>.sv -- top testbench, SystemVerilog based

You can extend more verification features in the top testbench.
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About Hello World Project

The Hello World Project is designed to print some strings using a top-level UART port. The testbench instantiates a
UART model to receive these data. Each byte (refer to uart_rx_data shown in Figure 3.31) can be checked using ASCII
format. Meanwhile, this UART model also supports sending the data to Design Under Test (DUT). The data is stored in a
text file and enabled by STIMULUS_GEN parameter.

3.5. Programming and On-Chip-Debugging Flow

This section describes the process of testing and debugging application code on the actual hardware including the
Lattice FPGA with the hardware design installed. Debugging with Propel SDK follows the same process and uses of the
same tools of any of those in Eclipse IDE.

Before debugging, download the hardware design created from Diamond/Radiant Programmer. Refer to the User
Guide of the specific evaluation board for more details on the evaluation board.

3.5.1. Creating a Debug Launch Configuration

To debug a program, a debug launch configuration must be created. Most of the settings for a debug launch
configuration can be automatically entered. Only a few settings need to be manually configured.

To create a debug launch configuration:
1. Inthe Project Explorer view of Propel, select a C project.

2. Build the project and ensure the executable file is available. Refer to the Building a Lattice C Project section for
details on the process.

3. Choose Run > Debug Configurations...
The Debug Configurations dialog opens (Figure 3.32).

$ Debug Configurations =

Create, manage, and run configurations

(B ¢ = ¥ | = Name: Example Debug

type filter text ] Main . [Z| CableConn| %5 Debugger| [+ Startup 1 Source| [[] Common |, SVD Path
@ C/C++ Application Project:
[£] C/C++ Attach to Application .
[€] C/C++ Postmortem Debugger Example Browse...
[c] C/C++ Remote Application C/C++ Application:

Cii C/C++ Unit
[c] GDB Hardware Debugging
4 [t | GDB Open0CD Debugging Variables... | | Search Project... | | Browse... |
[ | Example Debug
@ Launch Group

Debug'\Example elf

Build {if required) before launching

= Launch Group (Deprecated) Build Configuration: | Select Automatically v|
Enable auto build Disable auto build
@ Use workspace settings Configure Workspace Settings...

Filter matched 10 of 10 items

(‘:?:. Debug ] | Close

Figure 3.32. Debug Configurations Page
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4. Double-click GDB OpenOCD Debugging to create a new launch configuration.

A multi-tab page is displayed. The Main tab should already be filled in with the project name, application file name,
and location.

5. Select the CableConn tab (Figure 3.33). This tab enables you to select a specific device on a specific cable port.

Click the Detect Cable button. Select the specific cable port from the Port drop-down list. By default, the first
available cable port: FTUSB-0 is selected.

Click Scan Device button. Select the specific device from Device drop-down list. By default, the first available
device on selected cable port is selected.

Keep the cable speed so that you can use the default clock divider.

$ Debug Configurations

Create, manage, and run configurations

[ & = Rl = W v MName: Example Debug

type filter text (] Main | 2| CableConn . %% Debugger| b Startup| %~ Seurce| ] Commaon| &, SVD Path
[©] C/C++ Application Cable 5ettings
Do e || o 3 (e
[€] C/C++ Remote Application Device Settings

Cif C/C++ Unit
[£] GDB Hardware Debugging Device: ’ '] I Scan Device ]
4 [c]| GDB OpenOCD Debugging
[t ] Exarnple Debug
2 Launch Group

Speed Settings
@ Use Default Clock Divider

B Launch Group (Deprecated) () Use Custom Clock Divider
1
Revert Apply
Filter matched 10 of 10 items o
':?:' Debug l [ Close

Figure 3.33 CableConn Tab of Debug Configurations

6. Select the Debugger tab (Figure 3.34). It is critical that the Config options field contains the correct command line
options to be passed to OpenOCD.

—c "set port S{PORT}" is required for the selection connected to Lattice cable. The value of variable
“S{PORT}’comes from the cable settings of CableConn tab.

—c "set target S{DEVICE}" is required for the selection specific device on the Lattice cable. The value of variable
“S{DEVICE}"comes from the device settings of CableConn tab.

—c "set tck S{TCKDIV}" is required for setting clock divider of the Lattice cable.
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Q Debug Configurations

Create, manage, and run configurations

O E e B 8| B T~ Mame: Example Debug

type filter text Main r CableConn ﬁg’ﬁ Debugger [ Startup\l B, Source} 5| Commorﬂ &, SVD Path\l
[©] C/C++ Application OpenOCD Setup i
[E] C/C++ Attach to Application Start OpenOCD locally
[E] C/C++ Postmortern Debugger
[€] C/C++ Remote Application Executable path:  ${openccd_path}/${openccd_executable} Browse...

m

Cif C/C++ Unit

Actual executable: Chlscch\propeil.\sdkieclipsel/../openocd/bin/openocd.exe
[t ] GDB Hardware Debugging

to change it use the global or workspace preferences pages or the project pr
4 [T | GDB Open0OCD Debugging - J P pag P
[E] Example Debug| GDB port: 3333
L Launch Group Telnet port: 4444
= Launch Group (Deprecated)
pier Tel port: G666

Config options: | _¢ "set target ${DEVICE]" -¢ "set tck $TCKDIV}" -c "set port ${PORT}" -

interface/lattice-cable.cfg -c "set RISCV_SMALL_YAML
{8{ProjDirPath}/src/cpull.yaml}” -f target/riscv-small.cfg

. . Revert Apply
Filter matched 10 of 10 items =

€) i

Debug ] [ Close

Figure 3.34 Debugger Tab of Debug Configurations

(Optional) Select the Common tab (Figure 3.35). The Save as > Local file option is selected by default. This causes
the debug launch configuration to be saved into the workspace.

Change setting the Save as field to Shared file to let the debug launch configuration saved into the project that
aids the project portability.
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3

$ Debug Configurations

Create, manage, and run configurations

OFeE X | B Y~ Mame: Example Debug
type filter text Main Ifﬁ? Debugger Ifb Startup rE/ Source rﬁ Cummo;\\_%_, SVD Path\l
] C/C++ Application Save as i
€] C/C++ Attach to Applicatior ) Local file
[©] CfC++ Postmorter Debugg ® Shared fil L
[t] C/C++ Remote Application @ Shared file:  \Example Browse... =
ci .
U (/Cr+ Unit . Display in favaorites menu Encoding
[t] GDB Hardware Debugging . . .
4 [£] GDB OpenOCD Debugging '] 45 Debug @ Defauit - inherited (UTF§)
[T] Example Debug [ @Run @ Other [150-8859-1
& Launch Group
= Launch Group (Deprecated)
‘| 1 G [ — ] [ — ]
eve
Filter matched 10 of 10 items B

® [ Debug ] [ Close l

Figure 3.35 Common Tab of Debug Configurations

8. Remain settings as default. Do not change the settings unless necessary, or unless you understand what effect
these changes may have.

9. Click Apply to keep the current settings.
10. Click Close.

3.5.2. Starting a Debug Session

Before starting a debug session, be sure that:

e Lattice cable is connected to the computer.

e The target device is power ON.

e The hardware design has a debug enabled processor module and already programming into the target device.
With the above steps completed properly, follow the steps below to start the debug session from Propel.

1. Choose Run > Debug Configurations...

2. If necessary, expand the GDB OpenOCD Debugging group.

3. Select the newly-defined configuration.
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4. Click the Debug button (Figure 3.35).

Alternatively, for later sessions, use the Debug icon #\S on the toolbar. Do not click the Debug icon directly.
Instead, click the down arrow beside the Debug icon. Select the desired debug configuration from the drop-down
menu (Figure 3.36).

F$-0-Q-®5 v~
[€] 1 Example Debug
Debug As 3

Debug Configurations...

Organize Favorites..,

Figure 3.36. Debug Icon on Toolbar

5. Wait for a few seconds for switching to debug perspective, starting the server, connecting to the target device,
starting the gdb client, downloading the application and starting the debugging session.

6. The Propel Window displays as shown in Figure 3.37. The execution stops right at the beginning of the main()

function.
G workspace - Example/src/main.c - Lattice eSDK EI@
File Edit Source Refactor MNavigate Search Project Run  LatticeTools Window Help
-G RiEsrrerze o pS|sBeit-0- A @S- deidi-i-Ce-a- M Qs BE
5 Debug &[5 Project Expl = O |[ ¢ mainc 5 = O |[w=va 2~ % Br | Ex | B\ Mo| '3, Pe = 0
Dk B o0 - EEIEER
2
AEgampleDebug[GDB OpenOCD Debugg S Name : main.c MName Type Value
4 i Bxampleelf 4 Author : ${author) 9 idx uint8_t [ENE
a ¢ Thread #1 (Suspended : Signal ; 0:5; 5 Version
= main() at main.c:15 OxZac 6 Copyright : $(copyright)
5 openocd.exe : Description : Hello World in C, Ansi-style
p niscv-none-embed-gdb ; F
10
11 #include “utils.h"
2
3= int main(void) {
4 static uintd_t idx = @;
5 DEBUG_PRINTF("Hello RISC-V world!\rin"});
LED_SET(ALL_OFF); [z i - 3
while (true) { “Emeo‘ti‘?f > o i
LED_SET(LED_ON({didx)); eralis: -
SET(LED_ON(idx)); Default:e \@° E
if (++idx == LED_COUNT) { Decimal:@
idx = 8; = Hz.ax‘ 2 <
— _ Rinaru.a
< m 3 4 »
onsole | sit! Registers | ; erminal |2 Problems | Executables ebugger Console emo = - =
B Console [ 1! Reg ST I [[E Probl {2 Executables | G2 Debugger Console &2 . [0 Memory =] [}
Example Debug [GDE Open0OCD Debugging] ${cross_preficigdb${cross_suffi} (777)
Program stopped. e
main () at ../src/main.c:15
15 DEBUG_PRINTF("Hello RISC-V world!\[F\n");

« [ m K b

167Mof275M |

Figure 3.37. Debug Perspective

3.5.3. Peripherals Registers View

Peripherals registers view provides an easy-to-use interface for examining or modifying the values of peripheral
registers during a debug session.

To use peripheral registers view in Propel (Figure 3.38):
1. Make sure an active debug session is run and shown in the debug perspective.

2. Find the Peripherals view which is in the same window with the Variables and Breakpoints views. For any reason,
if not found, re-open from Window > Show View > Peripherals.

The Peripherals view lists all peripherals available in the system view description svd file within the C Project.

3. Selecting a peripheral in the Peripherals view can open a Memory Monitor that is mapped to the corresponding
peripheral memory area.
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4. You can examine and modify the value of the peripherals register in the memory view.

G waorkspace - cccfsrc/main.c - Lattice Propel EI
File Edit Source Refactor Mavigate Search Project Run LatticeTools Window Help
Hml g | BiDis| o mEs e s SO ReR Oy @S wilvh vt oo |
B | G
5 De = lfﬁPro] ~ O |[@ stdioh f cdefsh (@ main.c % “_[8 crt0.S ]»z = B ||®=Variables = B8
; 41 3
i i - i
= | J 42 #include "utils.h" ) . E| :
4 [&] ccc Debug [GDB OpenO 43 Peripheral Address Description
4 i cecelf

445 int main(void) { 2 cpulinst  OxFFFFO000
45 static uint8_t idx = @; ¥ . gpio0_inst  0x00008000
46 DEBUG_PRINTF("Hello RISC-V world!\rin"); 1'% sysmem0_in: 0x00000000

47 LED_SET(ALL_OFF); 2, uartO_jnst  0x00008400

2 Thread #1 (Runnin
s openocd.exe
W riscv-none-embed-ge

=

B
=]

49 while (true) {
50 LED_SET(LED_ON(idx));

« | 1 »

52 if (++idx == LED COUNTY { =
< 11 | »

& Console ﬂ‘u’.‘a? Registers (=B Progress (@ Terminal ([ Problems fO Executables [E Debugger Cons(|
m Y
Monitors = ¥ % (% gpio0_inst: 0x8000 2 . 4= New Renderings..]
@ gpioQ_inst Register Address Value il
@ uart0_inst 4 2, gpio0_inst 0x00008000
@ cpul_inst 4 1 RD_DATA_REG 0x00008000 0x00008000 =
w rd_data [7:01 0x0
. 1m0 WR DATA REG |Fie|c|: rd_data, "Read actual values of GPIO's", Read onM
v i SET_DATA_REG 000008008 0x00008008
¢+ 44 CLEAR_DATA_REG 0x0000800C 0x0000800C
4 I ) » il DIRECTION_REG 000008010 0x00008010 -

[EMr 2eom [T

Figure 3.38 Peripherals View in Debug Perspective

3.5.4. Serial Terminal Tool

Serial port communication is frequently used during the microcontroller debugging. Propel SDK provides a built-in
terminal tool including serial support for debugging.

To launch a serial terminal:
1. Find the Terminal view nested to the Console view. If not found, re-open from Window > Show View > Terminal.
2. Inthe Terminal view, click the Open a Terminal icon =] . The Launch Terminal dialog opens (Figure 3.39).

3. Choose the Serial Terminal and configure the Serial port with Baud rate.
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Choose terminal: [SeriaITelminaI VI
Settings

Serial port: COM1 -
Boud rate: |115200 -
Datasize |8 -
Parity: [Nane vl
Stop bits: |1 -
Encoding: | Default (150-8859-1) -

@ | ok || Cancel |

Figure 3.39. Launch Terminal Dialog

4. Click OK. A connection opens.
5. (Optional) Click the Toggle Command Input icon that adds an edit box to enter text (Figure 3.40).

E Plohlemswo Euecutahls} 2 it EE| H_ @ = B

Figure 3.40. Terminal View
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4,

Propel Tutorial — Hello World

This “Hello World” project can be found from the template. The “Hello World” project provides a template of using
hardware and software design with the minimal resource required.

Following this tutorial, you can easily create a hardware and software project. After that, you can run the project on

your evaluation board.

The tutorial uses a MachXO03D breakout board as demonstration. It uses R$232 UART function. To enable RS232 UART

function on the MachX03D breakout board, the following reworks on the boards are required.

1. Hardware reworks on MachX03D breakout board.

Short R14 and R15 using 0 Q resistors, as shown in Figure 4.1.

390CCCCOCCOCCCOOCCCOOFENJ

MachX03D Breakout Baard

REV A P/N:LCMX03D-9400HC-B-EVN :..:LATTICE

SWW SEMICONDUCTORYy

L (N W)
s o R24R86

LATTICE

LCMXO3D-9400HC
5BG256CAS
29107H12

ze =
013 13 1 0 0
j'- .§.. .'.. #

J
24 RO8] RST N&G

0<:
L
4,

aNe

9141 @

11 Ki
|

¥ R2 {
LR N L R

T
TX X
'YX X
T XXX
Seeee
Seeee
0000
*eeee
XXX
YXX

F5 E3 Bl CIGND|D2 E2 F2 G2 GND[H2 J3 KI L3 GND|L2 M3 M2 N3 105
104 F3 D3 G3 C2|0D1 EI F1 GI GND[HI H3 J2 J1 GND{L1 M1 NI H6 103

X oy
Y X X X XXX XXXXX

Figure 4.1. MachX03D Breakout Board
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2. Configure the FTDI device with FT_Prog software to enable UART function.

Connect the MachX03D breakout board to host PC and power ON.

Open FT_Prog software. Select DEVICES > Program.
Make sure Port B is configured as RS232 UART in Hardware and Virtual COM Port in Driver. See Figure 4.2.

Select DEVICES > Program from the FT_Prog software again. From the opened Program Devices dialog, click

Program.

Device Tree

Property

Value

=& Device: 0 [Loc ID:0x0]
S=» FT EEPROM
Fi=» Chip Details
i=p USB Device Descriptor
i#=p USB Config Descriptor
i=p USB String Descriptors
=/=p Hardware Specific
-=p Suspend DBUST
-=p TPRDRY
=y Port A
E= Port B
-+ [
=P Driver
H=p 10 Pins

RS232 UART
245 FIFO
CPUFIFO
OPTO Isolate

Device Tree

Property

Value

=& Device: 0 [Loc ID:0x0]
S=» FT EEPROM
F=» Chip Details
i=p USB Device Descriptor
i#=p USB Config Descriptor
i=p USB String Descriptors
=/=p Hardware Specific
-=p Suspend DBUST
-=p TPRDRY
=y Port A
E= Port B
'=> Hardware
g Driver|

+H=p 10 Pins

D2XX Direct
Vitual COM Port

Figure 4.2 Configure the FTDI Device

3. All the reworks for the MachXO3D breakout board is completed.
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4.1. Creating SoC Design Project and Preparing Hardware Design

To start an SoC Design Project from Propel:

Choose File > New > *n Lattice SoC Design Project.

The Create SoC Project wizard opens (Figure 4.3). Enter a project name, such as HelloWorldSoC. Select the Hello

World Project template.

Click Finish. An SoC project is created.

5o Prject e
Create SoC project p—

Create 50C project of selected template

= =l

Project name: HelleWerldSoC

Use default location

Location: | Chlscchesivl Mworkspace\HelloWaorldSoC Browse...
Choose file systemn: | default
Template selection
Processor: ’RISC-V v] Family: ’MachX[ED V]
Device: [LCMXO3D-9400HC ~ | Performance: [6 -
Package: ’CABGMM v] Board: ’PFRDevelop v]
Platform templates
[Emnty Temolate | Hello World Project template containing: -
|Hello World Project a) VEX - 32b RISC-V CPU with debugger
FFK Solution Froje b} GPIO - Up to 32 bit /'O

d) TIMER

) ASRAM - Asynchrenous SRAM

f) UART - serial port
@ [ Finish || Cancel

Figure 4.3. Create SoC Project Wizard

4. The created SoC project can be found in the workbench. Its design is opened and displayed in Propel Builder for

review (Figure 4.4).

40
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. Propel Builder EI

File Edit View Design Window Help

s & & A

Info m]

G QQaQQ

Schematic Address
+ 1 HelloWorldSoC
4 1? Instances
=
b =7 Ports —_
L3 rE Nets
o s
- . Components
| cput:n.0.0 L l
[TF] gpio0:1.2.0 L - i
@ sysmem(:1.0.0 =am im‘ln;nﬁ_l 2o s .
o e . oaTa g [ d .
T ) _|...,,,, ammrm
Properties ,;fj% I Py == —
)
i frace
el I
Catalog Info
Td Console =

Figure 4.4. Propel Builder Window

4.2. Launching Lattice Diamond

Launch Lattice Diamond from the created SoC project. To do that:

1.

2.

In Propel Project Explorer view, select the SoC project HelloWorldSoC.
Click the Diamond icon  on the toolbar. A Diamond project is created and thus opened automatically in Lattice
Diamond.

Switch to Process view of the Diamond project and make sure Bitstream File or JEDEC File is checked in the Export
Files section (Figure 4.5).

Choose Process > <4 Run. Wait for generating programming file successfully. You can see a green checkmark
before each successfully completed process.

*+ Lattice Diamond - Start Page

File Edit | View | Project Design Process Tools Window Help

PrE-Ha 8| rudhieERAQACAEEE & &

e AFERO N : B G i sSBQH>” EEHEE:G
Process g i[2 Start Page [ 5| Reports [ | [=][=
a % Synthesize Design
%L synplify Pro i o -
) T“ )I‘ tp Sy Project: e User Guides Reference Guides e
ranslate Design A
e ,..‘.' 9 & Open... Lattice Diamond Release  Stratzay
i 4 & Map Design = ew Notes !
D 2 Map Trace il New... L X X Constraints
x Vap o E Lattice Dismond User Hardware How-T =
[ & Verilog Simulation File [ Import ispl EVER Project... Guide ardware How-To
[7] 2 VHDL Simulation File Recent Projects: B Lattice Synthesis Engine  Lattice Modules
4 2 Place & Route Design Eﬂ HelloworldseC for Diamond User Guide  FPGA Libraries (HTML
[[] 2 Place & Route Trace =e lsoe Managing Projects version)
. . F ExampleSo -
B : 10 Timing Analysis P\a_tform Designer User xfs'?ollj";jmnﬁ (PDF
[[] & Thermal Analysis Guide
4 2 ExportFiles Software Upgrade Recommended |- Entering the Design Command Line
- L - Tcl Commands
] « IBIS Model Currently running Lattice Diamond software version: H Clarity Designer User
[[] & Verilog Simulation File 3.11.0.396.4 Manual Glossary
2 VHDL Simulation File Dialmur‘\d‘upd‘ates available: Simulating the Design Design Tool Reference
< Bitstream File — ' - Applying Design ;
2* JEDEC File iodobn Bolaons Constraints Tutorials
* 4 . ] ¢+ T ) B Lattice Diamond Tutarial -
File List Process Hierarchy
S
Qutput & X
Copyright (c) 1995 ATsT Corp. A1l rights reserved. -
Copyright (c) 1995-2001 Lucent Technologies Inc. All rights reserved.
Copyright (c) 2001 Agere Systems All rights reserved. O
Copyright (c) 2002-2019 Lattice Semiconductor Corporaticn, All rights reserved. .
TdConsole | Output | Emor | Warning® | Info* |
Start: Map Design Merm Usage: 184,752 K

Figure 4.5. Generate Programming File
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4.3. Programming the Target Device

Once the programming file is exported successfully in last section, it is ready to program the target device. Make sure
the evaluation board is powered ON and connect correctly to host PC before performing the following procedure.

1.
2.

3.

4.

Click the Programmer icon LJ on the toolbar of the Lattice Diamond Project Explorer.
The Programmer: Getting Started dialog pops up (Figure 4.6). Click OK.

il Programmer: Getting Started @

Select an Action

@ Create a new project from a JTAG scan

Cable: [HW-USBN-28 (FTDI)  + | Port: [FTUSE-0 v || Detect cable

TCK Divider Setting (0-30x): 1 |2

() Create a new blank project
() Open an existing programmer project
C:fUsersxyu/Desktop/Cableserver Problem in LMS Testproject_versa fimpl 1impl 1. xcf

Import file to current implementation

C:flsccfpropelf 1. 1jworkspace HelloWorldSoC fimpl 1 fimpl 1. xcf B

[ OK ” Cancel ]

Figure 4.6. Programmer Getting Started Dialog

Review the Device Family, Device, Operation, and File Name in the Programmer window (as shown below).

s O B
Enable Status Device Family Device Operation File Mame
1 MachX03D LCMXO3ID-5400HC SRAM Fast Configuration | ...e/HelloWorld5oC/impll/HelloeWerldSoC_impll
Click the Program icon “** to download the programming data file to the device.

4.4. Creating Hello World C Project

Creating C project requires a system environment from SoC project as input.

1.
2.

In Propel Project Explorer view, select the SoC project HelloWorldSoC.
Choose Project > Build Project.

System environment of the select SoC project is generated under the SoC project folder. Check the result from the
Console view (Figure 4.7).
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I_:: Problems (Ej Tasks (E Console &3 = Propertieq = Terminaq = B8

EX% EEEREEE DN
<terminated> sge [SDP Builder] Chlscc\propell 1\pge\pge.exe
Warning [5BX]: Unconnection: cpu@_inst TIMER_IRQ_M@ remains unconnected -
Info: C:\lscchpropell\l.l\workspace\HelloWorldSeC\sge'sys_env.xml generated
Info: C:\lscch\propelil.l\workspace\HellokWorldsoChsge\bspisys_platform.h generated
Info: C:\lscchpropelil.lwerkspace\HelloWorldSoChsge\bsp generated

Figure 4.7 Build Result of HelloWorld SoC Project

3. Choose File > New > Lattice C Project.
The C Project wizard opens with Load system and bsp page (Figure 4.8.).

{1 CProject

Load system and bsp p—

Correct system envirenment file and get toolchain parameter |

Select system environment file and bsp package
System env:  Chlscc\propell.lworkspace\HelloWorldSeCisgelsys_envaml -

Select the core type to create C Project

Core selected: | cpul_inst v]

System information

Device Family CPU Mame Instance Mame

MachXO3D riscv_mc cpul_inst

@ < Back Nest » Finish

Figure 4.8. Load System and BSP Page

4. Select the system environment file just generated (Figure 4.8.). Click Next.
5. Enter project name “HelloWorld” (Figure 4.9). Click Next. Then click Finish.
The C project is created and displayed in workbench.
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3 CProject (=0 ESH =
C Project —
Create C project of selected type
Project name: HelloWorld|
Use default location
Chlscc\propell IhworkspaceiHelloWorld Browse...
default
Project type: Toolchains:
> = GNU Autotools RISC-V Cross GCC
4 [= Executable
@® Empty Project
@ Lattice C Project
@ Hello World RISC-V C Project
@ Hello World ANSI C Project
> (= Shared Library
> [= Static Library
> = Makefile project
Show project types and toclchains only if they are supported on the platform
@ [ <Back [ Net> [ Finsh
Figure 4.9. Create C Project Page
6. Inthe Project Explorer view, select the C project “HelloWorld”.
7. Choose Project > Build Project.
8. Check the build result from the Console view (Figure 4.10).

[#] Problems [4£] Tasks | @ Console &3 [T Properties| (& Terminal
COT Build Console [HelloWorld]

T LSLV IO - CNUCU =S LEE =101 8 L-UE1 RELTy (IS LLUWUT LU -S40
text data bss dec hex filename
11le @ 42838 5318 14cé HelloWorld.elf

Finished building: HelloWorld.siz

Invoking: Lattice Create Memory Deployment File

srec_cat Helloworld.bin -Binary -fill @ @ @x@@@@3@@@ -byte-swap 4 -DISable Header -Output

Finished building: HelloWorld.mem

1@:3@:24 Build Finished. @ errors, @ warnings. (toock 4s5.466ms)

4B B ®r8-8-=0

"HellowWorld.mem"

Figure 4.10. Build Result of HelloWorld C Project

-MEM 32

4.5. Running Demo on MachXO3D Breakout Board — Hello world

1.
2.

Find the Terminal view nest to the Console view. If not found, re-open from Window > Show View > Terminal.

In the Terminal view, click the Open a Terminal icon E.

Choose the Serial Terminal and configure the Serial port with Baud rate 115200 (Figure 4.11).

Note: Serial port number depends on specific PC.
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S Launch Terminal m@

Choose terminal: [SeriaITerminaI vl
Settings
Serial port: COMI14 -
Baud rate: 115200 -|
Data size: [8 VI
Parity: [None VI
Stop bits: [1 VI
Encoding: ’Default (150-8859-1) vl

?\ [ OK J [ Cancel l

Figure 4.11. Launch Terminal Dialog

Click OK. A serial connection communicate with UART is ready.

In the Project Explorer view, select C project “HelloWorld”.

Choose Run > Debug Configurations...

Double-click GDB OpenOCD Debugging to create a new launch configuration (Figure 4.12).
Click the Debug button.

Wait for a few seconds for switching to debug perspective, to start the server, and to allow it to connect to the
target device, start the gdb client, download the application, and then start the debugging session.

© N o v

Note: This demo uses default debug configuration options.
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Create, manage, and run configurations

0 [ @ X | Uil MName: HelloWorld Debug
type filter text E| Main %5 Debugger| i Startup| % Source| [] Common| =, SVD Path|
E C/C++ Application o Project:
[c] C/C++ Attach to Application
[c] C/C++ Postmortem Debugger HelloWorld LTSS
[€] C/C++ Remote Application C/C++ Application:

Cif C/C++ Unit
[c] GDB Hardware Debugging
4 [C] GDB Open0OCD Debugging Variables.. | [Search Project..| | Browse.. |
|[c] HelloWorld Debug |
& Launch Group

Debug\HelloWorld.elf

Build (if required) before launching

= Launch Group (Deprecated) Build Configuration: |Select Automatically ']
() Enable auto build () Disable auto build
@ Use workspace settings Configure Workspace Settings...
Revert Appl
Filter matched 10 of 10 items [ Rever [ aesty |

@ [ Debug [ close |

Figure 4.12. Debug Configurations Page

9. Click the Resume icon P on the toolbar. The serial terminal outputs “Hello RISC-V world!” (Figure 4.13).

File Edit Source Refactor Mavigate Search Project Run LatticeTools Window Help

HHR B rnE e s @S SESE-O- R @E Vil meror Q| BE
45 Debug 22 [ ProjectBipl | = O |[E mainc | (€] (gelbl2]procl42000] threadGrovplillgebl2]. | (€] main.c 2 = 0 |[w-v[eep[TE[mM[=D R\ Fp| = 0O
=R E - Enter location here - 8 6nEE)
.
4[] HelloWorld Debug [GDB OpenOCD Debu l: / Fi o
4 & HelloWorld.eff 11 #include "utils.h” N
@ Thread #1 (Running : User Request| | 12 ]

W openocd.exe 15= int main(wvoid) { — 800002ac:  li a@,10888 -

W& riscv-none-embed-gdb 14 static uintd_t idx = @; @0000208:  jal ra,@x360 <uartPuts
15 DEBUG_PRINTF("Helle RISC-V world!\rin"); 16 LED_SET(ALL_OFF);
16 LED_SET(ALL_OFF); epeeezba:  lui  a5,BxB
17 ) 000082b8:  addi  a5,a5,1828 # BxB48.
18 while (true) { . B00082bc: 1i a4,1823
19 LED_SET(LED_ON(idx)); 208002c8:  Sw a4,8(as)
20 . ) A 19 LED_SET(LED_ON(idx))
21 if (++idx == LED_COUNT) { E e@eee2c4:  lbu a5,1112{zero) # @x
22 idx = 8; @BBO02CE:  mv a4,a5
23 } epeep2cc:  1i as,1
24 ‘Beepa2de: s11 a5,a5,ad
25 delayMs(508); BOBBB2AL : 1i ad,1823
26 1 200002d8: sub a4,a4,a5
27 eeeea2dc: Lui as,ex3
28 return 8; | @@0082e8:  addi  a5,a5,1828 # Bx848.
29 } 20BEB2e4 : sw a4,8(as5)
38 < 21 if (4+ide == 1FD o T

< u | " g L
= Terminal 52 [£) Pmblemsw [¥] mcmabls] Debugger Consolsq i Mgmmﬂ

Hello RISC-V world!

1

4 mn | 3

Connected - Encoding: Default (I50-8858-1) | writable | Smart Insert [17:1:0m AR 2 [

all o

Figure 4.13. Run Result of Hello World Project
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Appendix A. Linker Script and System Memory Deployment
During the Lattice C Project creation, Propel SDK generates a linker script file, linker.Id, within the project. This linker
script file contains a memory region list parsing from the corresponding SoC design.

Note: lllegal memory regions are not imported to linker script. A memory region is considered illegal, if it has any of the
following conditions:

e No connection to CPU
e  Address space conflict

Each memory region has a list of attributes to specify whether or not use a particular memory region for an input
section (Figure A. 1).

e r:Read-only section.
e w: Read/Write section indicating the memory region is connected to the data port of CPU.

e  x: Executable section indicating the memory region is connected to the instruction port of CPU.

Linker Script: linker.ld

Available Memory Regions

MName Attributes || Base Address Size
sysmemi_inst % 0:400000000 (0400008000
sysmermnl_inst w 0:400010000 0:400008000

Figure A. 1.Memory Regions in Linker Script
The generated linker script contains a mapping table of section pointing to memory region (Figure A. 2). Depending on

the attributes of each memory region, code section and data section can point to the same or different memory
regions.

Section to Memory Region Mapping

CODE: |sysmem0_inst -
DATA: |sysmeml_inst -

Section Mame Memory Region i
text sysmermn(_inst 2
.ctors sysmem(_inst

Jdtors sysmermn(_inst 1

Overview | linker.ld

Figure A. 2. Section to Memory Region Mapping

During the Lattice C Project building, Propel SDK generates Lattice system memory initialization files. Depending on the
number of the memory regions used, it generates single memory initialization file or multiple memory initialization
files. The following picture (Figure A. 3) shows an example of multiple memory files being generated, separate for code
and data segments.
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- (A2 sre
4 (= Debug

- 2= src

. 5 Example.elf - [nonefle]
Example_Code.rnem
Exarnple_Data.mern

= Example.bin
=] Example.lst

=] Example.map
| @ makefile

| @ objects.mk

| @ sources.mk

=| tmp

Section to Memory Region Mapping

Section Mame
ged
.«ctors

.dtors

Memory Region

»

|m

Overview | linker.ld

Figure A. 3. Linker Script and Generated Memory Files

If you modify the linker script manually after the Lattice C project creation, especially change the number of the used
memory regions, the number of memory files generated during project building cannot be changed automatically. You
can re-configure the generation of memory files in Propel by:

1. Inthe Project Explorer view of Propel, select a C project.
2. Choose Project > Properties. The Properties dialog opens showing the properties of the current project.
3. Select Settings of C/C++ Build category from the left pane. Select the Toolchains tab (Figure A. 4).
Check Create memory file, if you point code and data segments to same memory region. Or, check Create multiple
memory files, if you point code and data segments to separate memory regions.
4. Click Apply.
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Figure A. 4. Toolchains Tab of C/C++ Build Settings

5. Go back to the Tool Settings tab. The relevant Lattice memory deployment tools can be found (Figure A. 5).
Customize the tool options as needed.

6. Click Apply and Close to save the change.
Note: Setting for each configuration, Debug or Release, is independent.
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Figure A. 5. Tool Settings Tab of C/C++ Build Settings
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Technical Support Assistance

Submit a technical support case through www.latticesemi.com/techsupport.
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Revision History

Revision 1.0, November 2020

Section

Change Summary

All

Initial release.
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