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Type Conventions Used in This Document

Convention Meaning or Use

Bold

<Italic>
Ctrl+L

Couri er

()
{1}

Items in the user interface that you select or click. Text that you type
into the user interface.

Variables in commands, code syntax, and path names.

Press the two keys at the same time.

Code examples. Messages, reports, and prompts from the software.
Omitted material in a line of code.

Omitted lines in code and report examples.

Optional items in syntax descriptions. In bus specifications, the
brackets are required.

Grouped items in syntax descriptions.
Repeatable items in syntax descriptions.

A choice between items in syntax descriptions.
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Lattice Radiant Software
Tutorial

The next generation design tool for FPGA design, Lattice Radiant™ software
is designed to address the needs of high-density FPGA designs.

This tutorial leads you through all the basic steps of designing and
implementing VHDL and/or Verilog designs targeted to the Lattice iCE40
UltraPlus device family. It shows you how to use several processes, tools, and
reports from the Radiant software to import sources, run design analysis, view
design hierarchy, and inspect strategy settings. The tutorial then proceeds to
step through the processes of adding and editing a strategy, specifying the
synthesis requirements, examining the device resources, setting timing and
location assignments, and editing constraints to configure the settings to
implement the design to the target device.

Learning Objectives

When you have completed this tutorial, you should be able to do the following:
Create a new Radiant software project
Create a PLL using IP Catalog
Verify functionality with simulation
Inspect strategy settings
Examine resources
Set timing and location assignments
Run Synthesis process
Run Map Design and check reports
Run Place and Route

Examine Post Place and Route results
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Analyze power consumption

Run Export Utility programs

Download a bitstream to an FPGA

Use Reveal Inserter to add On-chip debug logic

Use Reveal Logic Analyzer to perform logic analysis

Time to Complete This Tutorial

The time to complete this tutorial is approximately 90 minutes.

System Requirements
The following is required to complete the tutorial:
Radiant software

(Optional) iCE40 UltraPlus Breakout Board to download a bitstream and
to insert debug logic using Reveal Inserter. See Figure 23 on page 37.

Note

For more information on the iCE40 UltraPlus Breakout Board, go to:
http://www.latticesemi.com/en/Products/DevelopmentBoardsAndKits/
iCE40UltraPlusBreakoutBoard.aspx

(Optional) Lattice HW-USBN-2B Download Cable to run Reveal Analyzer.
See Figure 33 on page 48.

Note

For more information on the Lattice HW-USBN-2B Download Cable, go to:
Programming Cables User Guide.

To perform the Reveal Analyzer Task 16, connector pins must be soldered to
iCE40 UltraPlus Breakout Board headers. See Figure 33 on page 48.

Online Help and the Lattice Radiant Software User
Guide

You can find online help information on any tool included in the tutorial at any
time by choosing Help > Lattice Radiant Software Help.

Another excellent resource is the Lattice Radiant Software User Guide.

8 Lattice Radiant Software Tutorial
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About the Tutorial Design

The design in this tutorial consists of a Verilog HDL module, and a VHDL
module. The design that you create is targeted for the iCE40 UltraPlus device.

About the Tutorial Data Flow

Figure 1 illustrates the tutorial data flow through the FPGA design system.
You may find it helpful to refer to this diagram as you move through the tutorial
tasks.
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About the Tutorial Data Flow

Figure 1:

Tutorial Data Flow
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Task 1: Create a New Radiant Software Project

Projects are used to manage input files, constraints, and optimization options
related to an FPGA implementation. While there are a number of tasks you
can perform independent of a project, most designs start with creating a new
project.

Note

Some of the screen captures in this tutorial may have been taken from a version of
Radiant software that differs from the one you are using. There may be slight
differences in the graphical user interface (GUI), but the software functions the same.

To create a new project:

1. Do one of the following depending on your operating system:
From your Windows desktop, choose Start > All Programs > Lattice
Radiant Software > Radiant Software.
From your Linux platform shell window or C-shell window, execute:
<instal | _pat h>/bin/lin64/ Radi ant

The Radiant Software Design Environment appears, as shown in
Figure 2.

Figure 2: Radiant Software Design Environment
File Edit View Project Design Tools Window Help
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{2t Start Page
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Project

Recent Project List

New Project Open Project Open Example

Infermation Center

\

Getting Staried Tutorials User Guides Suppori Center
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The initial layout provides the Start Page, which provides a list of common
project actions like New Project to run the New Project wizard, Open
Project to open a pre-existing project, and Open Example.
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Task 1: Create a New Radiant Software Project

For almost all questions, the place to start is Radiant software online Help.
It describes the FPGA design flow using Radiant software, the libraries of
logic design elements, and the details of the Radiant software design
tools. The Help also provides easy access to many other information
sources. The Help can be accessed from Help > Lattice Radiant Help.

Open a new project in one of the following ways:

On the Start page, click the New Project button.

From the Radiant software main window choose File > New >
Project.

The New Project wizard opens.
Click Next.
Specify the project name: LEDtest.

Note

File names for Radiant software projects and project source files must
start with a letter (A-Z, a-z) and must contain only alphanumeric
characters (A-Z, a-z, 0-9) and underscores ().

Click Browse. In the Project Location dialog box, browse to where you
want to store the project’s files, such as C:/my_radiant_tutorial, as
shown in Figure 3. Click Select Folder.

Leave the Implementation Name as the default: impl_1. The directory to
store the implementation is automatically displayed in the Location box.
We will talk about creating a new implementation later in this tutorial.

Figure 3: New Project Window

A

New Project Lﬁj

Project Hame
Enter a name for your project and specify a directory where the project data files
will be stored.

Project:

Mame: LEDtest]

Location: | C:fmy_radiant_tutorial * | | Browse...
Project will be created at C:jmy_radiant_tutorial LEDtest I:‘ Create subdirectory
Implementation:

Mame: impl_1

Location: = Cifmy_radiant_tutorial LEDtest/fimpl_1

< Back Mext = Cancel Help

7. Click Next.

12
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10.
11.

12.

13.

The Add Source dialog box appears.
Click Add Source.
The Import File dialog box appears.

Navigate to the folder containing the source files, which are located in the
<radiant_install_directory>/docs/tutorial/Radiant_tutorial directory. Select
the following files (using the Shift or Ctrl keys) in the directory:

LED_control.v
rgb_led_top.vhd
testbench.v

and click Open.

The Add Source step of the Wizard appears with all the selected source
files added.

Select Copy source to implementation directory.

De-select Create empty constraint files. This option is not required for
this tutorial.

Click Next.
The Select Device dialog box appears.
Select the following device options:
Family: iCE40UP
Device: iCE40UP5K
Operating Condition: Industrial
Package: SG48
Performance Grade: High-Performance_1.2V
Part Number: iCE40UP5K-SGA48I

The dialog box should resemble Figure 4. The Device Information box on
the right side shows (as applicable) available Voltage, LUTs, Registers,
EBR Blocks, DSPs, PLLs, DLLs, PCSs, PIO Cells, and PIO Pins.

Lattice Radiant Software Tutorial
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Task 1: Create a New Radiant Software Project

Figure 4. New Project Wizard Device Selector Dialog Box

~
Mew Project L&J
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PLLs: 1
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PIO Pins: 39
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Part Mumber:
ICE40UP 5K-5G481 =7
e Data Sheet for Device
< Back Mext = Cancel Help
h
14. Click Next.

15.
16.

17.

18.

The Select Synthesis Tool dialog box opens.
Choose Lattice LSE.
Click Next.

The Project Information dialog box appears. The project information
includes project name, location, implementation name, device, synthesis
tool, and import source.

Click Finish.

The File List (left side of screen) is populated and the Reports view (right
side of screen) appears.

The File List displays the components of the project. The File List
organizes project files by categories: Strategies, and Implementation
including Input Files, Constraint Files, Debug Files, Script Files, Analysis
Files, and Programming Files. You may adjust file order by dragging and
dropping file names in the list. Properties of each file are accessed by
right-clicking the file and selecting Properties from the pop-up menu.

Note

You can also see Area, Quick, and Timing listed in the Strategies folder in the File
List view. These are predefined strategies supplied by Lattice Semiconductor that
solve particular design requirements. For details of these predefined strategies,
refer to the Radiant software online Help.

In the File List, right-click Synthesis Constraint Files and choose Add >
Existing File.

14
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LATTICE RADIANT SOFTWARE TUTORIAL : Task 1: Create a New Radiant Software Project

Add Existing File dialog box appears.

19. Browse to <radiant_install_directory>/docs/tutorial/Radiant_tutorial
(typically C:/Iscc/radiant/<version_number>/docs/tutorial/Radiant_tutorial)
and select the file timing_constraints.ldc. Choose Copy file to
Implementation’s Source directory, and click Add.

20. In the File List, right-click Post Synthesis Constraint Files and choose
Add > Existing File.

Add Existing File dialog box appears.

21. Browse to <radiant_install_directory>/docs/tutorial/Radiant_tutorial
(typically C:/Iscc/radiant/<version_number>/docs/tutorial/Radiant_tutorial)
and select the file design_constraints.pdc. Choose Copy file to
Implementation’s Source directory, and click Add.

22. In the File List, right-click testbench.v and choose Include for >
Simulation.

The File List should appear as shown in Figure 5.

Figure 5: File List View

~ [£I] LEDtest
ICE40UPSK-SGART

< Strategies

T
x

i=| Area
2=| Quick
2= Timing
iy Strategyl
~ [ impl_1 (Lattice LSE)
< Input Files
iy sourcefimpl_1/LED_controlv
i3 sourcefimpl_1/rgb_led_top.vhd
e Sourcefimpl_1/testbench.a
< Pre-Synthesis Constraint Files
source/impl_1/timing_constraints.ldc
< Post-Synthesis Constraint Files
source/impl_1/design_constraints.pdc
Debug Files
Script Files
Analysis Files

Programming Files

23. The Process Toolbar, shown in Figure 6, lists all the processes available,
such as Synthesize Design, Map Design, Place & Route Design, and
Export Files. A process is a specific task in the overall processing of a
source or project. You can view the available processes for a design in the
Process Toolbar.

24. Click the Task Detail View to see detailed information of the
processes.

Figure 6: Process Toolbar and Task Detail View

Process Toolbar Task Detail View
l =l

Synthesize Design é\" Map Design ﬁf; Place & Route Design “ Export Files
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The Reports view allows you to examine and print process reports. There
are two panes in the Reports view. The left pane lists the reports. The right
pane displays the reports.

Log messages are displayed in the Output frame of the Radiant software
main window.

Task 2: Create a PLL Using IP Catalog

IP Catalog is an easy way to use a collection of modules from Lattice
Semiconductor. With IP Catalog, these modules can be extensively
customized. They can be created as part of a specific project or as a library
for multiple projects.

In this task, you will generate a phase lock loop (PLL) module to import into
your design.

1. Open IP Catalog. IP Catalog is accessed via a tab at the lower left of the
Radiant software. Click the tab to view the list of available modules and IP.

O Flelst [l Source Template E] 1P Catalog

2. Inthe Module/IP tree, Module > Architecture_Modules, double click
PLL.

3. Inthe Module/IP Block Wizard, specify general project information and the
base file name for the module or IP.

Instance Name is the base name for the module’s files (that is, with
no extension). For this tutorial enter the name pll_24M.

The Create In box is the location for the customized module’s files.
For this tutorial use default directory:
C:/my_radiant_tutorial/LEDtest/impl_1.

4. Click Next.
The Module/IP Block Wizard dialog box opens.
In the dialog box, set the following options:
Input Frequency: 12
Output Frequency: 24
Check Enable Lock Port

Leave all other values as default. The module dialog box should appear
as shown in Figure 7.
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Figure 7: Configuration Block of Module PLL

;
2] Module/IP Block Wizard =0

Configure Block of Module pll
Please set the following parameters to configurate this design block.

Diagram pll_24M Configure pll_24M:
Property Value

MNumber of Output 1

Input Frequency(MHz) [10 - 133] 12

Feedback Mode Mo Compensation mode

Enable External Divider

pll_24M

lock o
ref clk i

] outcore o
rst n_i

outglobal_o S o

pll

PLLOUT Tolerance % 5.0

Additional Delay Adjustment Mode FIXED
Additional Delay Adjustrent Setting 0
Enable Lock Port
Enable Bypass Port ]

Mo DRC errors are found.

| < Back ||Generahe || Cancel |

5. Click Generate. The Check Generating Result dialog box should appear
as shown in Figure 8.
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Figure 8: Check Generating Result Dialog Box
("2 ] Module/IP Block Wizard ===

Check Generating Result
Please check the design block generating message & result summary in the panel below. Uncheck option ‘Insert to project’ if you don't want to
add this IP to your design.

Design block 'pll_24M' is successfully generated.
Module: pll  Version: 1.0.1

Vendor: latticesemi.com

Language: Verilog

Generated files:

top_level_verilog: rtlfpll_24M.v
black_box_verilog: rifpll_24M_bb.v
testbench_parameters_verilog: testbenchjundefined
template_vhdl: misc/pll_24M_tmpl.vhd
testbench_instance_verilog: testbench undefined
timing_constraints: constraints/undefined
IP-XACT_output_file: component.xml

1P package file: pll_24M.ipx

timing_constraints: constraints/undefined

cfg: pll_24M.cfg

template_verilog: misc/pll_24M_tmpl.v

D Insert to project

< Back Finish

6. Ensure that Insert to project is checked.
7. Click Finish.

Task 3: Verify Functionality with Simulation

The Radiant software provides an interface to create a new simulation project
file that can be imported into a standalone simulator. The Radiant software
can export Active-HDL and ModelSim® simulation files.

Aldec® Active-HDL™ is an integrated environment designed for simulation of
VHDL, Verilog/SystemVerilog, EDIF, and SystemC designs.

In this task, you will simulate the design using Active-HDL and analyze the
resulting waveforms.

To simulate the design:
1. Make sure all the Source files are included in the simulation.

a. Inthe File List pane, under Input Files, select source files
LED_control.v and rgb_led_top.vhd using the Shift or Ctrl keys.
Right-click and select Include For > Synthesis and Simulation.

b. In the File List pane, under Input Files, right-click on source file
pll_24M.ipx, and select Include For > Synthesis and Simulation.

Note

The testbench.v file should be included for Simulation only.
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Choose Tools > Simulation Wizard or click @ on the Radiant software
toolbar.

The Simulation Wizard dialog box appears.
Click Next.
The Simulator Project Name dialog box appears.
Perform the following:

Specify Project name: simulationfile.

Click “Browse...” button to browse to where you want to store the
project’s file. For this tutorial use default directory
C:/my_radiant_tutorial/LEDtest.

Select Active-HDL is the Simulator dialog box.
Select RTL in the Process Stage dialog box.
Click Next.

If you left the default selection as the project file location in the
previous step, click Yes in the dialog box that asks whether you want
to create a new folder.

The Add and Reorder Source dialog box appears. Make sure all source
files are present in the Source Files list. Leave the Automatically set
simulation compilation file order box checked.

Click Next.
The Parse HDL Files for Simulation dialog box appears.
Click Next.

The Summary dialog box appears. Make sure that Run simulator, Add
top-level signals to waveform display, and Run simulation are all
selected.

Click Finish.

The Aldec Active-HDL software is launched and the simulation starts
automatically. After completing the simulation, a dialog box appears
stating “Simulation has finished. There are no more vectors to simulate.”

Click OK.

The waveform appears, as shown in Figure 9.

Lattice Radiant Software Tutorial
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Figure 9: Simulated Waveform
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10. In Active-HDL, click Simulation > Run or click * to run the simulator for
some more time. Simulate the design until it stops automatically.

11. In Active-HDL, use the zoom tools (View > Zoom) to see how the
waveform is changing.

12. Choose File > Exit to close Active-HDL.
The Design Browser dialog box appears.
13. Click OK to stop the simulation.
The Save File dialog box appears.

14. Click No.

Task U: Inspect Strategy Settings

Implementations define the design structural elements for a project, including
source code, constraint files, and debug insertion. Implementation contains all
source files, constraint files, debug files, scripts, and analysis files.

A strategy is a collection of settings for controlling the different stages of the
implementation process (synthesis, map, place & route, and so on).
Strategies can control whether the design is optimized for area or speed, how
long place and route takes, and many other factors. The Radiant software
provides a default strategy, which may be a good collection to start with, and
some variations that you can try. You can modify Strategyl, shown in the
Strategies section in Figure 10, and create other strategies to experiment with
or to use in different circumstances. Predefined strategies can also be cloned
and then modified.

20
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Task 4: Inspect Strategy Settings

" X o |EDtest:
1 icE40UPSK-SG48I * (CE40UP5K-5GA8I:
4 Strategies * Strategies:
- '7 impl_1 (Lattice LSE) * impl_1 (Lattice LSE):
3 Input Files * Input Files:
3 Pre-Synthesis Constraint Files *  Pre-Synthesis Constraint Files:
3 Post-Synthesis Constraint Files *  Post-Synthesis Constraint Files:
Debug Files * Debug Files:
» Script Files *  Script Files:
Analysis Files *  Analysis Files:
Programming Files *  Programming Files:

Figure 10: File List View, including Implementations and Strategies

To view synthesis settings:

1. From the File List view, double-click Strategy1l.

Project Name

Input File Library

Pre-Synthesis Constraint File Library
Post-Synthesis Constraint File Library

Used for Reveal debugging

Used for Simulation Wizard

Used for Power Calculator and Timing Wizard
Used for programming a device

Device Part Number
Strategy Types
Implementation (Synthesis Tool}|

The Strategies - Strategyl dialog box, shown in Figure 11, appears.

2. Click Synthesize Design >

LSE.

A set of default global synthesis timing constraints and optimization
settings appears in the panel. LSE settings are displayed as the default in

the dialog box.

Figure 11: Strategies - Strategy 1

Strategies - Strategyl

S

Description:

Process

o Synthesize Design
Synplify Pro
{LSE

o Post-Synthesis

Post-Synthesis Timing Analysis
o Map Design
Map Tirming Analysis
o Place & Route Design
Place & Route Timing Analysis
Timing Simulation

Bitstream

Namme
Allow Duplicate Modules
Carry Chain Length
Command Line Options
DSP Style
DSP Utilization
Decode Unreachable States
Disable Distributed RAM
EBR Utilization
F5M Encoding Style
Fix Gated Clocks
Hardware Evaluation
Intermediate File Dump
Loop Limit
Macro Search Path

QK

All

Cancel

¥ | Default

Value

DsP
100

100
Auto
Enable

1850

Help

Note

When each strategy is selected, descriptive text appears in the lower panel of the
dialog box. Default values in the strategies dialog box are shown in blue while changed

values are shown in black.

Lattice Radiant Software Tutorial
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3. Click OK to close the Strategies dialog box.

Task 5: Set Timing and Location Assignments

Timing and location assignments constrain logic synthesis, as well as
backend map, place, and route programs to help meet your design
requirements. A well-constrained design helps optimization algorithms work
as efficiently as possible. In this section you'll set default timing constraints for
the operating frequency and I/O timing then assign package pins to specific
I/0O signals.

To set timing constraints:

1. From the Tools menu, choose Timing Constraints Editor > Pre-
Synthesis Timing Constraint Editor, or click the arrow in the @/~ icon
on the Radiant software toolbar, and from the pulldown menu, choose
Pre-Synthesis Timing Constraint Editor.

The Pre-Synthesis Timing Constraint Editor appears.

2. Click the Detach Tool icon = atthe upper right corner of the Pre-
Synthesis Timing Constraint Editor to detach the Pre-Synthesis Timing
Constraint Editor from the Radiant software main window.

In the Frequency (MHz) box, change 11.1111 to 12 as shown in
Figure 12. Period (ns) is recalculated and changes to 83.333. Enable
box should stay unchecked.

Figure 12: Pre-Synthesis Timing Constraint Editor
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File Edit Window Help !
BAa o

Disable Object Clock Clock Name Waveform (ns) Period (ns) Frequency (MHz)
get_ports clkl2M c_clkl2m 83333 12
Clock Generated Clock Clock Latency Clock Uncertainty Clock Group Load Capacitance InpL4 ¥

All Constraints (Using drag and drop to reorder the constraints)
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create_generated_clock -name {c_clk24M} -source [get_ports clkl2M] -multiply_by 2 -duty_cycle 50 [get_nets UL/clk24M]

set_output_delay -
set_output_delay -
set_output_delay -
set_output_delay -
set_output_delay -

clock [get_clocks c_clk24M] -
clock [get_clocks c_clk24M] -
clock [get_clocks c_clk24M] -
clock [get_clocks c_clk24M] -
clock [get_clocks c_clk24M] -

max 20 [get_ports RED]
max 20 [get_ports BLU]
max 20 [get_ports GRN]
min1 [get_ports RED]
min 1 [get_ports BLU]

3. Inthe Pre-Synthesis Constraint Editor, choose File > Save and name the
file timing_constraints.ldc. Click Save.
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The change is saved in the timing_constraints.ldc constraints file. Close
the Pre-Synthesis Constraint Editor.

From the File List view of the Radiant software main window double-click
the timing_constraints.ldc file under Synthesis Constraint Files.

The Source Editor appears with the ASCII .Idc file. Note the timing
constraints defined so far.

5. Close the Source Editor.

To set location constraints:

1. From Tools menu, choose Tools > Device Constraint Editor or click

on the Radiant software toolbar.
The Device Constraint Editor appears.

Click the Detach Tool icon = at the upper right corner of the Device
Constraint Editor.

The Device Constraint Editor is detached from the Radiant software main
window as shown in Figure 13.
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Figure 13: Device Constraint Editor
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v = All Port N/A NAA WA
v [ Input N/A NAA | N7A N/A NA | NG
v & Clock N/& N/A | N/A N/& N/& M/
@ clid2M | N/A 35 0 LVCMOS33 | NA 100
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[ color_sell0] | N/A 25 0 LVCMOS33 | NA 100
[ color_selll]  N/A bE 0 LVCMOS33 | NA 100
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3. Select the Port tab, in the lower left corner, from within the Device
Constraint Editor.

4. Right-click the cell in Row 1, Column IO_Type. The Name of this row is All
Port.

Note that LVCMOS33 is selected by default. Cell entries in the Device
Constraint Editor are color-coded to indicate the source of a constraint
setting:

Black - User-defined setting.

Blue - Default.

Green - Implied by the synthesis-defined constraint setting.
Yellow - Implied by another user-defined setting.

5. Close the Device Constraint Editor.
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Task 6: Run Synthesis Process

Reports

Project Summary

» [ Synthesis Reports

» [1] Map Reports

» [1] Place & Route Reports

» [ Export Reports

» [ Misc Reports

Synthesis is the process of translating a register-transfer-level design into a
process-specific, gate-level netlist that is optimized for Lattice Semiconductor
FPGAs. Radiant software can be used with almost any synthesis tool. Radiant
software comes with two tools fully integrated: Synopsys Synplify Pro for
Lattice and Lattice Synthesis Engine (LSE). “Fully integrated” means that you
can set options and run synthesis entirely from within the Radiant software.

You will be using LSE to synthesize your design for the iCE40 UltraPlus
FPGA.

To synthesize the design and examine resource utilization:
1. From the Process Toolbar, click Synthesize Design.

When the system is finished, take a look at the icon next to Synthesize

Design. A green check mark p indicates success; a red X H indicates
failure.

2. To see design hierarchy, click View > Show Views > Hierarchy.
Hierarchy window appears in the lower left corner of the FileList tab.

Click any module of interest to see its hierarchy.

3. To view post synthesis resource usage, click View > Reports, or click the
Reports tab. The Synthesis report is displayed, as shown in Figure 14.
Note that your Synthesis report results may differ slightly from what is
shown in the example.

Figure 14: Synthesis Report

LEDtest Project Summary

Implementation Name: impl_1 Performance Grade:
Strategy Mame: Strategy1 Operating Condition:
Part Mumber: ICE40UPSK-5G48] Synthesis:
evice Family: iCE40UP Timing Errors:

ce Type: ICE40UPSK Project Created:
Package Type: 5G48 Project Updated:
Project File: C:/my_radiant_tutorial/lLEDtest/LEDtest rdf
Implementation Location: Cimy radiant tutorialll EDtestimpl 1

Resource Usage

The Resource Usage table displays the number of logical resources within
each level of the design.

» LUT4 represents the total LUT4 count utilization throughout the
design.

» PFU Registers represents the total PFU register utilization

throughout the design.
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Task 7: Run Map Design and Check Reports

Timing and location assignments constrain logic synthesis, map, place, and
route programs to help meet your design requirements.

Reports

Project Summary

» [ Synthesis Reports

~ [£] Map Reports

Map

Map Resource Usage

Map Timing Analysis

* [l Place & Route Reports

» [ Export Reports

» [ Misc Reports

A well-constrained design helps optimization algorithms work as efficiently as
possible. In this section, you'll set default timing constraints for the operating
frequency and then assign package pins to specific 1/0 signals.

To run the Map process:

1. From the Process Toolbar, open Task Detail View (if closed) and

double-click Map Design.

The batch interface to logic synthesis and the design mapper run. When
finished, check the icon next to Map Design. A green check mark |2
indicates success; a red X H indicates failure.

Report files appears in the Reports view. To view each process report,
select the process in the Project Summary pane. Reports include
Synthesis Reports, Map Reports, Place & Route Reports, Export Reports,
and Misc Reports. Additional reports are available within each category.

From Project Summary, choose Map Reports > Map.

The Map Report, appears in the right panel as shown in Figure 15, Hover
your cursor over Contents to display the MAP Report table of contents.

In Project Summary, if a report has been generated, the icon appears as

. If the report has not yet been generated, the icon appears as . Use
the scroll bar to navigate through the report. Some of the reports are
divided into sections.

Figure 15: MAP Report

Map

Lattice Mapping Report File for Design Module 'LEDtest impl
Target Vendor: LATTICE
Target Device: iCE40UPSESG48

Target Performance: High-Performance 1.2V

Mapper: version Radiant Software (64-bit) 1.1.t.604.0
Mapped on: Wed Sep 05 11:33:11 2018

Design Information

Command line: map LEDtest _impl 1 syn.udb
C:/my_radiant_ tutorial/LEDtest/source/impl_1/design constraintes
LEDtest_impl l.udb -gui

Design Summary
Number of slice registers: 235 out of 5280 (4%)

Number of I/0 registers: 0 out of 117 (0%)
Number of LUT4s: 621 out of 5280 (12%)

Number of logic LUT4s: 444

Number of inserted feedthru LUT4s: 7

Number of ripple logic: 85 (170 LUT4s)
Number of IO sites used: 11 out of 3% (28%)

Number of IO sites used for general PIOs: B
Number of IO sites used for I3Cs: 0 ocut of 2 (0%)
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Task 8: Running Place and Route

Use the Process Toolbar to run the Place & Route Design process stages.

To run place and route:
1. From the Process Toolbar click Place & Route Design.

The place and route tools run. Intermediate results appear in the Output
frame of the Radiant software main window.

2. From the Reports tab, you can directly click on Place & Route Report. You
will find a Blue check mark appears before the reports generated
successfully. Expand the Place & Route Report section. Select Place &
Route.

Details about Place & Route appear in the right pane of the Reports view.
3. From Place & Route Report, select Place & Route Timing Analysis.

The Place & Route Timing Analysis Report appears in the right pane of
the Reports view.

4. Choose Tools > Physical View or click B on the Radiant software
toolbar.

The Physical View appears, shown in Figure 16. Physical View provides a
read-only detailed layout of your design that includes switch boxes and
physical wire connections.
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Figure 16: Physical View
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5. To zoom into a component:

a. Magnify the surrounding area by clicking and dragging a box around it
from left to right.

b. Click the component.

c. Click the Q button.

Right-click on the component and choose Show in > Floorplan View, as
shown in Figure 17, to display the Floorplan View.
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Figure 17: Physical View - Right-Click - Show in > Floorplan View
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6. To auto cross-probe between Floorplan View and Physical View, ensure
both views are attached to the Radiant software main window and then
right-click on the Floorplan View tab and select Split Tab Group.

The two views display in parallel, as shown in Figure 18.

When both Floorplan View and Physical View are open, an item that you
select in one of these views is automatically selected in the other. Auto
cross-probing is especially useful for immediate examination of
connections in both views.
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Figure 18: Cross Probing
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7. Right click on the Floorplan View tab and choose Move to Another Tab
Group.

Now both tabs are merged into a single group as before.

8. Close Floorplan View and Physical View tabs.

Task 9: Examine Post Place and Route Results

Static Timing Analysis can determine if your circuit design meets timing
constraints. Rather than simulation, it employs conservative modeling of gate
and interconnect delays that reflect different ranges of operating conditions on
various dies, providing complete verification coverage.

To examine timing analysis results:

1. Choose Tools > Timing Analysis View, or click E on the Radiant
software toolbar.

The Timing Analysis view appears.

2. Click the Detach Tool icon * at the upper right corner of the Timing
Analysis view.

The Timing Analysis view is detached from the Radiant software main
window and appears as shown in Figure 19.
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Figure 19: Timing Analysis View

ra Timing Analysis View =RACN X
File Edit Window Help "L
¥ Device information
MName Value
Design led_top
Family iced0tp
Device ICE40UPSK
Package 5G48
Performance High-Performance_1.2V
* Timing option setting information
MName Value
Run mode Setup and Hold Analysis ‘
Speed for setup & hold High-Performance_1.2V
Critical endpoints path number limit 10
Unconstrained endpoints path number limit 10
MNumber of paths per constraint 10
Start point number limit 10
End point number limit 1
Maximum slack limit
General Information Paths for All the Timing Constraints Critical Endpoint Summary Unconstrained Endpoint Summary Query
b //

-

3. Click the Paths for All Timing Constraints tab (on the lower left of the
Timing Analysis view) and select create_generated_clock-name.

The Paths summary in the center of the Timing Analysis view is populated
with Start Point, End Point, Setup/Hold Constraint, Slack, Delay, Source
Clock, Destination Clock, and Analysis Type.

4. Select Row 1 of the Paths summary.

The Path Detail tab in the right pane is populated with details.

5. Choose Edit > Timing Option Setting....

The Settings dialog box appears, as shown in Figure 20.
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Figure 20: Timing Setting Dialog Box

5 Timing Option Setting

S

Summary Option

Run mode:
Speed for setup & hold:

Critical endpoints path number limit:

Unconstrained endpoints path number limit:
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Query Option
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Setup and Hold Analysis -

High-Performance_1.2V -

ns

oK Cancel

4

Enter 20 into the Number of paths per constraint field and click OK.

The Timing Analysis view is refreshed with the additional path data.

Task 10: Analyze Power Consumption

Included with the Radiant software is Power Calculator, which estimates the
power dissipation for a given design. Power Calculator uses parameters such
as voltage, temperature, process variations, air flow, heat sink, resource
utilization, activity, and frequency to calculate the device’s static and dynamic
power consumption.

To analyze power consumption:

1. Choose Tools > Power Calculator or click & on the Radiant software

toolbar.

Power Calculator opens in Calculation mode.

Power Calculator provides two modes for reporting power consumption:

Estimation Mode:

In estimation mode, Power Calculator provides estimates of power
consumption based on the device resources or template that you
provide. This mode enables you to estimate the power consumption
for your design before the design is complete or even started.

Calculation Mode:

In calculation mode, Power Calculator calculates power consumption
on the basis of device resources taken from a design’s .udb file, or
from an external file such as a value change dump (.vcd) file, after
placement and routing. This mode is intended for accurate calculation
of power consumption, because it is based on the actual device

utilization.
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Editing data in white cells, such as voltage, frequency, activity factor,
and thermal data, does not change mode. Editing data in yellow cells,
such as design data, will change calculation mode to estimation mode.

2. Click Detach Tool icon » at the upper right corner to detach Power
Calculator from the Radiant software main window, as shown in Figure 21.

Figure 21: Power Calculator

'@' Power Calculator - Untitled |
File Edit Help !
[ E
Software Mode: | Calculation

Device Environment

Family: ICE40UP ~ | Performance grade: | High-Performance_1.2v = Thermal Profile...

Device: ICE40UP 5K ~ | Operating conditions: | Industrial A Ambient Temperature(=C): 25

Package type: | 5G48 ¥ | Part Names: ICE40UP 5K-5G481 b Effective Theta-JA{C/W): 15.7604

Device Power Parameters Junction Temperature(®C): | 25.01

Process Type: | Typical ~ | Power File Revision: | Final Maximum Safe Ambient(*C): | 99.97

Current by Power Supply Power by Power Supply

Voltage/Dynamic Power Multipiier Power by Blodk (W) Peak Startup
Voltage DPM Static (A)  Dynamic (A)  Total (&) Static (W) = Dynamic (W) = Total (W)
Vee 1.200 1.00 0.000520 0.000520 0.000624 Logic Block
Veeindd | 3300 100 0.000045 Clocks
Veeio 2.5 2,500 1.00 (0.000000 o
Veciol8 1800 1.00 PLL
Vecio 1.2 1.200 1.00 Block RAM
0.000534 0.000534 0.000669 0.000000 | 0.000665 Dsp
SRAM
LED 0.000493
Misc 0.000010
Total 0.000668
Power Summary Power Matrix Logic Blodk Clocks 1j0 PLL Block RAM D3P SRAM LED Misc Graph 4
3. Inthe Device Power Parameters section select the following parameter:

Process Type: Worst.

4. Click the Thermal Profile... button in the Environment section.
The Power Calculator — Thermal Profile dialog box appears.

5. Inthe Board Selection section, select the following parameter:
Small board.

6. Click OK.

After a short while the new temperature results become available in the
Environment section.

In the title bar of Power Calculator, “Untitled” appears with an asterisk,
which indicates an in-memory change to the timing constraints. You can
save the change to a Power Calculator File (.pcf) by choosing File > Save
File As and giving it a name and location. The .pcf file will then appear in
the Analysis Files folder of the File List Pane.
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7. Close Power Calculator. If you chose not to save in the previous step, a
Save dialog box will now appear. Click No to discard the change.

Task 11: Run Export Utility Programs

Use the Process Toolbar to generate files for exporting. One of the files
exported will be a bitstream file (.bin) which will be used to program an iCE40
UltraPlus device in the next task.

1. Click the Task Detail View to see detailed information of the
processes.

2. Under Export Files, ensure the following are selected:
IBIS Model
Gate-Level Simulation File
3. Click the Run button ® on the Radiant software Process Toolbar.

The Radiant software generates the selected files and saves them in your
project directory.

Task 12: Download a Bitstream to an FPGA

This task requires that you have an iCE40 UltraPlus Breakout Board. In the
previous section, you generated export files including a bitstream file (.bin). In
this section, you will use the Radiant software Programmer to download a
bitstream to a iCE40 UltraPlus FPGA mounted on a board.

This tutorial design displays RGB colors on iCE40 UltraPlus Breakout Board
with an iICE40QUP device. The colors are selected using the switches,
controlled by the color_sel [1:0] signal. Switches allow you to control the
Brightness, Blink Rate, Breathiness and Blink Enable signals and display
RGB color on the board LED.

For this design we have selected 50 percent Brightness, 2x Breath Ramp and
1sec Blink Rate.

The top level design is provided with 12MHz clock from on-board oscillator
which is given to a PLL to be multiplied to 24MHz clock. The design is running
at 24MHz.

The “LED_control” module generates “Pulse Width Modulated (PWM)” waves
and these modulated waves are driven by an RGB driver to keep the RGB
LED continuously “on” or blinking. This blinking capability depends on
“RGB_BIlink_En” signal. If the RGB_BIlink_En signal is enabled, the RGB LED
blinks. Otherwise, it is continuously “on.” RGB_Blink_En is active high.
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The following block diagram shows how the RGB LED is controlled.

clk1i2M

RGB_Blink_En

color_sel[1:0]

REDn
GRNn
LED_control RGBDRVA
Primitive BLUn
RGB_LED_TOP

Table 1 describes the ports and signals of the design.

Table 1: Ports and Signals

Port

Input Ports

Output Ports

Signal
clki2Mm

rst

RGB_BIlink_En

color_sel[1:0]
REDnN
GRNn

BLUn

Description

12MHz on board oscillator given to top
module

Reset

Enabling and Disabling the blinking of RGB
LED.

Selects the color to be displayed.
Drives RED color
Drives GREEN color

Drives BLUE color

Ensure shunts on the board are configured as shown in Figure 22. For more
information, refer to the iCE40 UltraPlus Breakout Board User Guide.
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Figure 22: iCE40 UltraPlus Breakout Board Shut Positions

J28 - Enable DONE LED

DOME  VBUS_5V
. HILATTICE
SEMICONDUCTOR.

iCE40 UltroPlus Bregkout Boord
REV.A
iCE4QUPSK-B-EVN
Copyright © 2016
Mode in USA

J51 - Enable
12 MHz clock

+3_ IV2EA
8A

J27 - RGB Shunts

J6 - Program SPI
Flash or iCE40UP
J7 - Isolate

SPI Flash CSn

Figure 23 shows the iCE40 UltraPlus Breakout Board connected to the

computer via USB cable.
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Figure 23: iCE40 UltraPlus Breakout Board connected to Computer with
USB cable

To download the bitstream to the FPGA on the board:

Remove any Lattice USB Programming cables from your system.

Connect a USB cable from your computer to the iCE40 UltraPlus
Breakout board. Give the computer a few seconds to detect the USB
device before moving to step 4.

Choose Tools > Programmer, or click ¥ on the Radiant software
toolbar.

In the Cable Setup box, click Detect Cable.

a. Cable should be set at HW-USBN-2B (FTDI).

b. Port should be set at FTUSB-O0.

Ensure that the proper device is selected by doing the following:

a. Click in the Device Family column and select iCE40 UltraPlus from
the pulldown menu.

b. Click in the Device column and select iCE40UP5K from the pulldown
menu.

Right-click the cell labeled iCE40UP5K and select Device Properties to
open the Device Properties dialog box. Ensure the settings are as follows:
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For Target Memory, choose Compressed Random Access Memory

(CRAM) from the pull-down menu.
For Port Interface, choose Slave SPI from the pull-down menu.

For Access Mode, choose Direct Programming from the pull-down
menu.

For Operation, choose Fast Configuration from the pull-down menu.

Select the bitstream file named LEDtest_impl1.bin from your
LEDTest > impl_1 folder as the programming file, as shown in
Figure 24.

Figure 24: Device Properties Dialog Box

f £ iCE40 UltraPlus - iCE40UPSK - Device Properties l D )
[ General | Device Information |

Device Operation

Target Memory: lCompressed Random Access Memory (CRAM) ~ ]

Port Interface: lSIave SPI hd ]

Access Mode: lDirect Programming = ]
Operation: IFast Configuration = ]
Programming Options

Programming file: C:fmy_radiant_tutorial LEDtest/impl_1/LEDtest_impl_1.bin D
[ OK ] I Cancel I

7. Click OK.

8. In Programmer, choose Run > Program Device or click £ on the
Programmer toolbar to initiate the download.

9. If the programming process succeeded, you will see a green-shaded
PASS in Programmer’s Status column. Check the Programmer output
console to see if the download passed.

The RGB LED on the iCE40 UltraPlus Breakout Board will glow and
slowly blink on and off. Table 2 lists how the Breakout Board switches
affect the RGB LED using this tutorial design.

Table 2: iCE40 UltraPlus Breakout Board Switch Description

Switch Signal Description

37A color_sel[1] Used to select the color.

36B color_sel[0] Used to select the color.

44B RGB_BIlink_En In UP position, RGB LED blinks.

In DOWN position, RGB LED stops blinking.
49A rst In UP position RGB LED will not glow.

In DOWN position, RGB LED glows.
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Task 13: Use Reveal Inserter to Add On-Chip Debug
Logic

In this task, you will use Reveal Inserter to configure a Reveal core based on
triggering conditions and the desired trace buffer. The primary output of
Reveal Inserter is a modified version of your design with one or more cores
instantiated and the core logic ready for mapping, placement, and routing.

Note that the current version of the Radiant software support for UltraPlus
devices does not support multi-core debug.

To generate and add a Reveal core:

1. Choose Tools > Reveal Inserter or click ii'flj} on the Radiant software
toolbar.

2. Click Detach Tool icon = atthe upper right corner to detach Reveal
Inserter.

Reveal Inserter is detached from the Radiant software main window, as
shown in Figure 25.
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Figure 25: Reveal Inserter Main Window

r ~
% Reveal Inserter - Untitled SRRCN X
File View Debug Window Help !
=o i ‘".1"§| Datasets
2| led_top_LAD @ Trace
Sample Clock Implementation -
Buffer Depth 256 - Timestamp -
Sample Enable Data Capture Mode
Sample Enable @ Single Trigger Capture
T Multiple Trigger Capture
-
-
-
Indude trigger signals in trace data
Dataset Design Tree Trace Signal Setup Trigger Signal Setup
L

3. Click on the Trace Signal Setup tab, if it is not already selected.
4. From the Design Tree tab, expand the led_top.
5. Drag the following signals from the Design Tree pane to Trace Data pane.
rgb_blink_en
color_sel
red_pwm
grn_pwm
blu_pwm
6. Select the Include Trigger Signals in Trace Data option.
The name of the bus now appears in bold font in the Design Tree pane.
7. Expand ul(LED_control_uniq_1).

8. Drag the clk24M signal from the Design Tree pane to the Sample Clock
box or type ul/clk24M in the Sample Clock box.

9. From the pulldown menu in the Buffer Depth box, select 4096.
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10. Set Data Capture Mode to Multiple Trigger Capture and Minimum
Samples Per Trigger to 32.

The Trace Signal Setup tab should now resemble Figure 26.

Figure 26: Trace Signal Setup Tap
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b "Lla blink_state[1:0]
b "la blu_accumn[31:0]
b "la blu_intensity[4:0]
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Signal Search
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Dataset Design Tree Trace Signal Setup Trigger Signal Setup
h

Setting Up the Trigger Units

Here you will set up the trigger units in the Trigger Unit section of the Trigger
Signal Setup tab.

To set up the trigger units:
1. Click on the Trigger Signal Setup tab.

2. Minimize the ul(LED_control_uniq_1) folder if still expanded. Drag the
rst signal from the Design Tree pane to the Signals (MSB:LSB) box in the
Trigger Unit pane.

3. Click Add to add a second trigger unit.
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4. Drag the rgb_blink_en signal from the Design Tree pane to the Signals
(MSB:LSB) box in row 2 of the Trigger Unit pane.

5.

Leave all other values as default.

Setting Up the Trigger Expressions

Now you will set up the trigger expressions in the Trigger Expression section
of the tab.

To set up the trigger expressions:

1.

In the Name box in the Trigger Expressions section, use the default name

of TEL.

In the Expression box, type TU2, and then Enter on your keyboard. The

RAM Type automatically changes to 1 EBR.

The Trigger Signal Setup tab should now should now resemble Figure 27.

Figure 27: Trigger Signal Setup Tap

f 9% Reveal Inserter - Untitled * =REC X )
File View Debug Window Help !
A

= b "L grn_intensity[4:0] Triager Unit
b "L grn_intensity_step[31:0]
E b "Lu gm_peak(31:0] MName Signals (M5B:L5B) Operator Radix Value
grn_pwm 1 TU st == Bin 0
b "L grn_set[1:0] 2 Tu2 rgh_blink_en == Bin 0
b "L off_max_cnt[27:0]
b "L pwm_count[17:0]
b L. ramp_count[27:0]
b "La ramp_max_cnt[27:0]
b "L red_sccum[31:0] Add Default Trigger Radix Bin =
b "L red_intensity[4:0] :
b "La red_intensity_step[31:0] Trigger Expression
b "La red_peak[31:0] MName Expression RAM Sequence Max Sequenc  Max Event
red_pwm Type Depth Depth Counter
» "L red_set[1:0] i |[usl I d L d
rst
b L. steady_count[27:0]
4
blu
“L. blu_pwm@Tc Add Remove
blun
clid2m
= color_sel[1:0]@Tc -
gm
L. grn_pwm@Tc Trigger Out
grnn Enable Trigger Out Met =
Signal Search Polarity | Minimum pulse width
Search
Dataset Design Tree Trace Signal Setup Trigger Signal Setup
b
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Inserting the Debug Logic

Now you will insert the debug logic into the design project.

To insert the debug logic:

1. Choose Debug > Insert Debug or click & .

2. Inthe Insert Debug to Design dialog box, shown in Figure 28, be sure that

the Activate Reveal File in Design Project option is selected.

Figure 28: Insert Debug to Design Dialog Box

@ Insert Debug to Desi... &Iﬂ

Please select core(s) you want to insert.

led_top_LAO

Activate Reveal file in design project

Cancel Help

3. Click OK. Name the file reveal_rgb.

4. Click Save.

Reveal Inserter imports the Reveal project (.rvl) file into the Radiant

software.

The .rvl file is now added to the Debug Files in the File List, as shown in
Figure 29.

Figure 29: File List with Debug File

+ [£I] LEDtest

[Eal

a ICE40UPSK-5G48]

-

Strategies

Area
Quick
Timing

i Strategyl

~ [ impl_1 (Lattice LSE)

-

5. In the Reveal Inserter window, choose File > Close Window.

Input Files

s sourcefimpl_1/LED_controlv

i3 sourcefimpl_1/rgb_led_top.vhd

o Sourcefimpl_1/testbench.a

i pl_24M/pll_24M.ipx

Pre-Synthesis Constraint Files
source/impl_1/timing_constraints.ldc

Post-Synthesis Constraint Files
source/impl_1/design_constraints.pdc

Debug Files

% reveal_rgb.rvl

Script Files

Analysis Files

Programming Files

source/impl_1/fimpl_lxcf
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Generating a Bitstream and
Programming the FPGA

Use the Process Toolbar to generate files for exporting and use Programmer
to download the bitstream to the FPGA. This task assumes that the iCE40
UltraPlus Breakout Board is connected to your computer with a download
cable.

To generate a bitstream:

1.

10.

Click the Task Detail View to see detailed information of the
processes.

Under Export Files, ensure the following is selected:
Bitstream File
Click the Run button ™ on the Radiant software Process Toolbar.

The Radiant software generates the selected files and saves them in your
project directory.

Choose Tools > Programmer, or click B4 on the Radiant software
toolbar.

In the Cable Setup box, click Detect Cable.
a. Cable should be set at HW-USBN-2B (FTDI).
b. Port should be set at FTUSB-O.

Ensure that the proper device is selected by clicking the cell in the Device
column and selecting iCE40UP5K from the pulldown menu.

Right-click the cell labeled iCE40UP5K and select Device Properties to
open the Device Properties dialog box. Ensure the settings are as follows:

For Target Memory, choose Compressed Random Access Memory
(CRAM) from the pull-down menu.

For Port Interface, choose Slave SPI from the pull-down menu.

For Access Mode, choose Direct Programming from the pull-down
menu.

For Operation, choose Fast Configuration from the pull-down menu.

Ensure that the bitstream file named LEDtest_impl1.bin is selected as
the programming file.

In Programmer, choose Run > Program Device or click £ on the
Programmer toolbar to initiate the download.

If the programming process succeeded, you will see a green-shaded
PASS in the Programmer Status column. Check the Programmer output
console to see if the download passed.
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Task 1U: Use Reveal Logic Analyzer to Perform Logic

Analysis

In this task, you will use Reveal Logic Analyzer to set up trigger conditions
and view trace buffer data from the on-chip Reveal core operating within the
device on the iCE40 UltraPlus Breakout Board.

The trigger setup influences under what specific conditions and how the
Reveal core trace signal states are displayed in Reveal Logic Analyzer’s
graphical user interface. You will explore just a few of the many ways to
trigger and trace the system.

Creating a New Reveal Logic Analyzer
Project

You must first create a Reveal Analyzer project.

To create a new Reveal Logic Analyzer project:

1. In the Radiant software main window, choose Tools > Reveal Analyzer
or click @ on the Radiant software toolbar.

The Reveal Analyzer Startup Wizard dialog box appears, as shown in
Figure 30.

2. Inthe upper left of the Reveal Analyzer Startup Wizard dialog box, select
Create a new File.

3. Type reveal_rgb in the box to name the file.
The .rva extension is added automatically.

4. In the pulldown menu on the top row next to the file name, choose HW-
USBN-2B (FTDI), if it is not already selected.

5. Click Detect.

The cable connected to the PC is detected, and is listed in the USB Port
box. Select FTUSB-1 from the dropdown menu.

6. Inthe RVL Source box, browse to
<project_directory>/reveal_rgb.rvl

Note
Do not click the Scan button. The device is soft JTAG.
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Figure 30: Reveal Analyzer Startup Wizard

Getting Started:

@ Create a new file reveal_rgh HW-USEN-2B (FTDI) ~
Multiple Device in JTAG Chain

USE port: FTUSE-1 (Lattice HW-USEN-2B Ch A Location 0001) ~

XCF source:

Debug device:

RVL source: C:/my_radiant_tutorial L EDtest/reveal _rgb.rvl Browse...

Open an existing file
File name:

Import file into current implementation

7. Click OK.

The Reveal Logic Analyzer main window now appears with the LA Trigger
tab selected, as shown in Figure 31. It contains the same trigger units and
trigger expressions that you set up in Reveal Inserter.

Figure 31: Reveal Analyzer

X Revenl Andyzer - G Lecan e

File View Design Window Help

A QQQ

Ready @ I led_top_LAD

Trigger Unit

MName = Signals (MSB:L5E) Operator  Radix Value

TU1 st == Bin 0

Tu2 raqb_blink_en == Bin a
Trigger Expression

MName  Expression Sequence Depth  Max Sequence Depth  Max Event Counter
BT TU2 1 1 1
Trigger Options Trigger Position: 2/32
Enable TE: ORAI ~ @ Pre-selected: | Pre-Trigger ~

Samples Per Trigger: | 32~ User-selected:

Mumber of Trigger: | 1 | (max 128) Final Event Counter:

LA Trigger LA Waveform

8. Choose Trigger Options:
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Samples Per Trigger: 512.
9. The default Trigger Position is: Pre-selected: Pre-Trigger.
In the Trigger position section, you can specify the trigger position relative to

the trace data. The numbers in the section title show the current position.The
two options to choose from include:

Pre-selected allows you to choose one of the standard positions.
Pre-Trigger: 32/512 of the way from the beginning of the samples.

Center-Trigger: 256/512 of the way from the beginning of the
samples.

Post-Trigger: 480/512 of the way from the beginning of the
samples.

User-selected allows you to choose a position with the slider.

The Reveal Analyzer LA Trigger tab should now appear as shown in
Figure 32.

Figure 32: Reveal Analyzer LA Trigger Tab

@ Reveal Analyzer - Cifmy_radiant_tutonal/reveal_rgb.rva *

File View Design Window Help

B QQa@Q

Ready = B led_top_La0

Trigger Unit
Mame | Signals (M5B:L5B) Operator  Radix

rst Bin
TUZ2 rgb_blink_en Bin
Trigger Expression
MName Expression Sequence Depth  Max Sequence Depth  Max Event Counter
ETE T2 1 1 1

Trigger Options Trigger Position: 32/512
Enable TE: ORAI ~ @) Pre-selected: |Pre-Trigger e

Samples Per Trigger: | 512 User-selected:

(max 128) Final Event Counter:

Mumber of Trigger: | 1

LA Trigger LA Waveform

Running Logic Analyzer

Now that Reveal Logic Analyzer is set up, you can run Logic Analyzer.
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This task requires that, at minimum, connector pins be soldered to Header C
of the iCE40 UltraPlus Breakout Board. Also, in addition to the USB cable, the
board must be connected to the computer with a Lattice HW-USBN-2B
Download Cable. The following photograph shows the iCE40 UltraPlus
Breakout Board connected to the computer with a USB cable and a Lattice
HW-USBN-2B Download Cable.

Figure 33: iCE40 UltraPlus Breakout Board with Header Pins Installed
and Connected to Computer with USB Cable and Lattice HW-USBN-2B
Download Cable
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The Lattice HW-USBN-2B Download Cable should be connected to Header C
of the iCE40 UltraPlus Breakout Board according to Table 3.

Table 3: Lattice HW-USBN-2B Download Cable to iCE40 UltraPlus
Breakout Board Connections

Lattice HW-USBN-2B Download Breakout Board Header C Pin
Cable Connector

VCC (Red) 3.3V

TDO/SO (Brown) 23B

TMS (Purple) 24A

TCK/SCLK (White) 25B_G3

TDI/S (Orange) 29B

GND (Black) GND

To capture data:

1. Click the Run button in the Reveal Analyzer toolbar.

The Run button changes into the Stop button and the status bar next
to the button shows the progress.

Reveal Analyzer first configures the modules selected for the correct
trigger condition, then waits for the trigger conditions to occur. When a
trigger occurs, the data is uploaded to your computer. The resulting
waveforms appear in the LA Waveform tab.

The second DIP switch from the right (44B) may immediately set off a
trigger. The trigger expression can now evaluate the next trigger unit and
generate a trigger for data to be captured.

If no trigger occurs click the Manual Trigger W button.

You now see the waveforms displayed, but the data may be varied as
shown in Figure 34.
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Figure 34: Reveal Analyzer Waveform

File View Design

B QQ

Completed

Window  Help [
= 3 led_top_LA0
Data

Bus/Signal

TU1

TU2

blu_pwm

gro_pwm
red_pwm
color_sel

rgb_blink_en

LA Trigger

LA Waveform

Summary of Accomplishments

You have completed the Lattice Radiant Software Tutorial. In this tutorial, you
have learned how to:

Create a new Radiant software Project
Create a PLL Using IP Catalog

Verify Functionality with Simulation
Inspect Strategy Settings

Examine Resources

Set Timing and Location Assignments
Run Synthesis Process

Run Map Design and Check Reports
Running Place and Route

Examine Post Place and Route Results
Analyze Power Consumption

Run Export Utility Programs

Download a Bitstream to an FPGA

Use Reveal Inserter to Add On-chip Debug Logic

Use Reveal Logic Analyzer to Perform Logic Analysis
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Recommended References

You can find additional information on the subjects covered by this tutorial in
the Radiant software online Help, and in the Lattice Radiant Software User
Guide.
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Revision History

The following table gives the revision history for this document.
Date Version Description

03/25/2019 1.1 » Updated Detach tool icon and Reveal Analyzer icon.

» Updated the following images: Task 2, Fig 2, Fig 5, Fig 6,
Fig 7, Fig 8, Fig 10, Fig 11, Fig 12, Fig 13, Fig 14, Fig 15, Fig
24, Fig 25, Fig 26, Fig 27, Fig 29, and Fig 30.

» Updated description in Task 5.

» Task2: Step 3 - removed statement regarding selecting
Verilog as a language option.

* Replaced ul(led_control_unig_1) with
ul(LED_control_uniq_1).

 Updated links to Lattice Radiant Software User Guide.

» Corrected link to Programming Cables User Guide.

02/07/2018 1.0 * |nitial Release.
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