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Copyright
Copyright © 2011 Lattice Semiconductor Corporation.

This document may not, in whole or part, be copied, photocopied, 
reproduced, translated, or reduced to any electronic medium or machine-
readable form without prior written consent from Lattice Semiconductor 
Corporation.

Trademarks
Lattice Semiconductor Corporation, L Lattice Semiconductor Corporation 
(logo), L (stylized), L (design), Lattice (design), LSC, CleanClock, E2CMOS, 
Extreme Performance, FlashBAK, FlexiClock, flexiFlash, flexiMAC, flexiPCS, 
FreedomChip, GAL, GDX, Generic Array Logic, HDL Explorer, IPexpress, 
ISP, ispATE, ispClock, ispDOWNLOAD, ispGAL, ispGDS, ispGDX, ispGDXV, 
ispGDX2, ispGENERATOR, ispJTAG, ispLEVER, ispLeverCORE, ispLSI, 
ispMACH, ispPAC, ispTRACY, ispTURBO, ispVIRTUAL MACHINE, ispVM, 
ispXP, ispXPGA, ispXPLD, Lattice Diamond, LatticeCORE, LatticeEC, 
LatticeECP, LatticeECP-DSP, LatticeECP2, LatticeECP2M, LatticeECP3, 
LatticeMico, LatticeMico8, LatticeMico32, LatticeSC, LatticeSCM, LatticeXP, 
LatticeXP2, MACH, MachXO, MachXO2, MACO, ORCA, PAC, PAC-
Designer, PAL, Performance Analyst, Platform Manager, ProcessorPM, 
PURESPEED, Reveal, Silicon Forest, Speedlocked, Speed Locking, 
SuperBIG, SuperCOOL, SuperFAST, SuperWIDE, sysCLOCK, sysCONFIG, 
sysDSP, sysHSI, sysI/O, sysMEM, The Simple Machine for Complex Design, 
TraceID, TransFR, UltraMOS, and specific product designations are either 
registered trademarks or trademarks of Lattice Semiconductor Corporation or 
its subsidiaries in the United States and/or other countries. ISP, Bringing the 
Best Together, and More of the Best are service marks of Lattice 
Semiconductor Corporation.

Other product names used in this publication are for identification purposes 
only and may be trademarks of their respective companies.

Limited Warranty
Lattice Semiconductor Corporation warrants the original purchaser that the 
Lattice Semiconductor software shall be free from defects in material and 
workmanship for a period of ninety days from the date of purchase. If a defect 
covered by this limited warranty occurs during this 90-day warranty period, 
Lattice Semiconductor will repair or replace the component part at its option 
free of charge.

This limited warranty does not apply if the defects have been caused by 
negligence, accident, unreasonable or unintended use, modification, or any 
causes not related to defective materials or workmanship.
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To receive service during the 90-day warranty period, contact Lattice 
Semiconductor Corporation at:

Phone: 1-800-LATTICE or (503) 268-8001
E-mail: techsupport@latticesemi.com

If the Lattice Semiconductor support personnel are unable to solve your 
problem over the phone, we will provide you with instructions on returning 
your defective software to us. The cost of returning the software to the Lattice 
Semiconductor Service Center shall be paid by the purchaser.

Limitations on Warranty
Any applicable implied warranties, including warranties of merchantability and 
fitness for a particular purpose, are hereby limited to ninety days from the date 
of purchase and are subject to the conditions set forth herein. In no event 
shall Lattice Semiconductor Corporation be liable for consequential or 
incidental damages resulting from the breach of any expressed or implied 
warranties.

Purchaser’s sole remedy for any cause whatsoever, regardless of the form of 
action, shall be limited to the price paid to Lattice Semiconductor for the 
Lattice Semiconductor software. 

The provisions of this limited warranty are valid in the United States only. 
Some states do not allow limitations on how long an implied warranty lasts, or 
exclusion of consequential or incidental damages, so the above limitation or 
exclusion may not apply to you.

This warranty provides you with specific legal rights. You may have other 
rights which vary from state to state.
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Type Conventions Used in This Document

Convention Meaning or Use

Bold Items in the user interface that you select or click. Text that you type 
into the user interface.

<Italic> Variables in commands, code syntax, and path names.

Ctrl+L Press the two keys at the same time.

Courier Code examples. Messages, reports, and prompts from the software.

... Omitted material in a line of code.

.

.

.

Omitted lines in code and report examples.

[ ] Optional items in syntax descriptions. In bus specifications, the 
brackets are required.

( ) Grouped items in syntax descriptions.

{ } Repeatable items in syntax descriptions.

| A choice between items in syntax descriptions.
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1
Installing Diamond Tools

This chapter provides installation instructions for the Lattice Diamond® 1.3 
software for Windows.

Diamond supports LatticeEC™, LatticeECP™, LatticeECP2™, 
LatticeECP2M™, LatticeECP3™, LatticeSC™, LatticeSCM™, LatticeXP™, 
LatticeXP2™, MachXO™, MachXO2™, and Platform Manager™ designs. 

System Requirements
The following are the basic system requirements for Lattice Diamond on 
Windows:

Intel Pentium or Pentium-compatible PC

Windows XP, Windows Vista (32-bit), or Windows 7 (32-bit or 64-bit) 

Note

The available devices vary depending on the type of license.

Note

If your operating system is Windows Vista, make sure you have installed all the 
latest patches from Microsoft.
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Approximately 5.75 GB free disk space

Network adapter 

1024 X 768 graphics display

Microsoft-compatible mouse and mouse driver

A Web browser with Javascript capability

Adobe Acrobat Reader 5.0 or later

Memory Requirements
Table 1 lists the minimum memory requirements and the recommended 
memory for all the Lattice Semiconductor FPGA families. Designing for the 
largest FPGAs may require more than the usual 2 GB of memory. For help in 
extending your memory to 3 or 4 GB, see “Extending Memory” on page 3.

Note

A node-locked license is based on the physical (hard-coded) address provided by 
the network adapter. Network connectivity is not necessarily required for a node-
locked license. In the absence of a network connection, you can install the NWLink 
IPX/SPX protocol to force the recognition of your NIC card ID (see “Licensing for 
Diamond” on page 13).

A floating license requires access to the license server, so both a network adapter 
and connectivity are required.

Table 1:  Recommended Memory for Windows

Device Size Minimum Recommended

LatticeEC, 
LatticeECP

Up to 20K LUT 512 MB 768 MB

Up to 50K LUT 768 MB 1 GB

LatticeECP2/M Up to 20K LUT 768 MB 1 GB

Up to 50K LUT 1 GB 1.5 GB

Up to 100K LUT 1 GB 2 GB

LatticeECP3 Up to 95K LUT 2 GB 3 GB

Up to 150K LUT1 3 GB 4 GB

LatticeSC/M Up to 40K LUT 768 MB 1 GB

Up to 115K LUT 1 GB 2.5 GB
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Extending Memory
Designing for the largest FPGAs may require more than the usual 2 GB of 
memory. For help in extending your memory to 3 or 4 GB, see the following.

In Windows XP
Normally, the Windows XP platform limits the amount of memory to a 
maximum of 2 GB for any Diamond program. You can configure Windows XP 
to allow 2-3 GB of memory by adding the /3GB switch to the end of the startup 
line in the boot.ini file. Before you take advantage of this capability, it is 
important that you read the following information:

Microsoft Knowledge Base Article #328269, which addresses a potential 
problem with the /3GB switch. Go to:
support.microsoft.com/?kbid=328269.

Microsoft article, “Memory Support and Windows Operating Systems,” 
which explains the use of the physical address extension (PAE) for 
Windows XP Professional and Windows Server 2003 Memory Support. 
Go to: www.microsoft.com/whdc/system/platform/server/PAE/
PAEmem.mspx

Microsoft Knowledge Base article #289022, “How to edit the Boot.ini file in 
Windows XP.” Go to:
support.microsoft.com/default.aspx?scid=kb;en-us;q289022

LatticeXP, 
LatticeXP2

Up to 20K LUT 512 MB 768 MB

Up to 50K LUT 768 MB 1 GB

MachXO, 
MachXO2

All 256 MB 512 MB

Platform Manager All 256 MB 512 MB

1. Designing for LatticeECP3 with more than 95K LUT, requires a Windows 7 64-bit 
operating system.

Table 1:  Recommended Memory for Windows (Continued)

Device Size Minimum Recommended

http://support.microsoft.com/?kbid=328269
http://www.microsoft.com/whdc/system/platform/server/PAE/PAEmem.mspx
http://www.microsoft.com/whdc/system/platform/server/PAE/PAEmem.mspx
http://support.microsoft.com/default.aspx?scid=kb;en-us;q289022
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In Windows 7
Lattice Diamond is a 32-bit application that can run in a Windows 7 64-bit 
system. With a Windows 7 32-bit system, Diamond can access up to 3 GB. 
With a Windows 7 64-bit system, Diamond can access up to 4 GB. See also:

Microsoft article, “Memory Limits for Windows Releases”. Go to:
msdn.microsoft.com/en-us/library/aa366778(VS.85).aspx

Contacting Technical Support

FAQs The first place to look. The Lattice FAQs provide solutions to 
questions that many of our customers have already asked. Lattice 
Applications Engineers are continuously adding to the FAQs as customer 
issues are resolved.

Online Forums Lattice Forums contain a wealth of knowledge and are 
actively monitored by Lattice Applications Engineers.

Telephone Support Hotline Receive direct technical support for all Lattice 
products by calling Lattice Applications from 5:30 a.m. to 6 p.m. Pacific Time.

For USA & Canada: 1-800-LATTICE (528-8423)

For other locations: +1 503 268 8001

In Asia, call Lattice Applications from 8:30 a.m. to 5:30 p.m. Beijing Time 
(CST), +0800 UTC. Chinese and English language only.

For Asia: +86 21 52989090

E-mail Support

techsupport@latticesemi.com

techsupport-asia@latticesemi.com

For Local Support Contact your nearest Lattice Sales Office.

http://www.latticesemi.com/support/faqs/index.cfm
http://msdn.microsoft.com/en-us/library/aa366778(VS.85).aspx
http://www.latticesemi.com/support/forums.cfm
mailto:techsupport@latticesemi.com
mailto:techsupport-asia@latticesemi.com
http://www.latticesemi.com/sales/index.cfm
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Installing Diamond 1.3 for Windows
The following sections describe product options and installation instructions 
for Diamond.

Software Product Options
Table 2 shows the product options for the installation of Diamond. 

Table 3 shows the tools included in the Diamond for Windows option. 

Table 2: Diamond Design Tools Installation Options

Product Option Description

Diamond for 
Windows

Installs the Diamond design tools for all Lattice Semiconductor FPGA designs. 
Table 3 lists the tools included in this option.

FPGAs Installs the FPGA design environment.

Synplify Pro for 
Lattice

Installs the Synopsys® Synplify Pro® for Lattice synthesis tool. A license for Synplify 
Pro is included.

Active-HDL Lattice 
Edition

Installs Aldec® Active-HDL™ Lattice Edition simulation tool. A license for Active-HDL 
is included.

Programmer Drivers Installs drivers for the Programmer tool, which loads FPGAs with the designs.

Table 3: Tools included in the Diamond for Windows Option

Tool Description

Project Management 
Tools

Include the Reports view, Run Manager, and the Security Setting tool to enable you 
to create and maintain the project, keep track of the stages in the design 
implementation process, review reports, and compare different implementations of 
the project.

Design Entry Tools Include Source Editor, Schematic Editor, Symbol Editor, Symbol Library Manager, 
IPexpress, Memory Generator, LatticeMico System, and HDL Diagram, which offer 
VHDL, Verilog, EDIF, schematic, and mixed-mode design entry support and design 
structure check.

Design Simulation 
Tools

Include Simulation Wizard, Active-HDL Lattice Edition, and Waveform Editor for 
performing functional simulation for the projects and creating the test stimulus files.

Design Constraints 
Application Tools

Include Spreadsheet View, Package View, Device View, Netlist View, NCD View, 
Floorplan View, and Physical View to enable you to set constraints for implementing 
the design.
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Installation Procedure
To install the Lattice Diamond software, first download it from the Lattice 
Semiconductor Web site. Follow the product download instructions and 
uncompress the software. For more information on how to download 
Diamond, go to http://www.latticesemi.com/latticediamond.

To install the Lattice Semiconductor Diamond software:

1. Close all applications before starting Diamond installation.

2. Double-click on the Diamond installer you downloaded to launch the 
installation process. There are other installers on the Web site also for 
installing LatticeMico.

Design 
Implementation 
Tools

Include the Process view, Synplify Pro for Lattice, and Clear Tool Memory to ease the 
design implementation process.

Analyzing Static 
Timing, Power 
Consumption, and 
Signal Integrity Tools

Include Timing Analysis View and Power Calculator to enable you to estimate the 
design performance, experiment with different configurations, and to calculate power 
consumption.

Programming the 
FPGA Tool

Includes Programmer to let you program the FPGAs.

Testing and 
Debugging On-chip 
Tools

Include Reveal Inserter, Reveal Analyzer, and LatticeMico Debugger to let you 
complete the final stage of developing a design: testing in the actual FPGA, either on 
a test board or in your system.

Applying 
Engineering Change 
Order Tool

Includes ECO Editor which supports engineering change orders by editing the output 
files from the place-and-route stage of the design implementation process.

EPIC Device Editor Provides device editing capability for engineering change management and detailed 
manipulation of FPGA implementation.

HTML Help and User 
Documentation

Includes complete instructions for designing with Diamond design tools and third-
party tools. Also provides user manuals, tutorials, example design projects, and 
access to technical documentation from the Lattice Semiconductor Web site.

ispLeverDSP 
Blockset

DSP function blockset for use with The MathWorks® MATLAB®/Simulink® design 
environment (available separately from The MathWorks).

Tcl/Tk Scripting Tool Enables you to automate Diamond design processing.

Table 3: Tools included in the Diamond for Windows Option (Continued)

Tool Description

http://www.latticesemi.com/latticediamond
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3. The Welcome To Lattice Semiconductor Diamond Setup dialog box 
opens.

4. Click Next to open the License Agreement dialog box.

5. Read the license agreement. If you agree, click Yes to open the Choose 
Destination Location dialog box.

6. The default destination folder is C:\lscc. Click Browse to change the drive 
or destination folder.

7. Click Next to open the Product Options dialog box.

8. Select the Diamond components that you want to install by selecting or 
clearing each of the listed options. If you have purchased third-party 
synthesis and simulation tools directly from the third-party vendors, you 
can clear the Synplify Pro for Lattice and Active-HDL Lattice Edition 
product options.

The FPGAs product option has additional options for selecting the Lattice 
FPGA devices that you want to install. To set the additional options, select 
FPGAs and click Change.

In the pop-up Select Subfeatures dialog box, you can select or deselect 
the features from the list. Click Continue to come back to the Product 
Options dialog box.

9. Click Next to open the Select Program Folder dialog box. The default 
name of the program group is Lattice Diamond 1.3. If you want to change 
the name, change it in the Program Folder text box.

10. Click Next to open the Start Copying Files dialog box.

11. Verify the settings when displayed.

12. Click Next to start installing the Diamond components.

13. When prompted to install drivers for using the ispDOWNLOAD® cable, as 
shown in Figure 1, click Yes, and follow the instructions in Installing 
Parallel Port Driver or USB Driver section. 

Figure 1: Prompt for Installing Parallel/USB Port Driver
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14. If you have selected the Active-HDL Lattice Edition option, you will be 
prompted to select a license option as shown in Figure 2. 

15. Select the desired license option and click Next. 

16. In the Restart Your System on Setup Completion dialog box, verify 
Diamond environment settings and click Next.

17. In the InstallShield Wizard Complete dialog box, read the note and click 
Finish. 

Figure 2: Active-HDL Lattice Edition Selection Dialog Box

Note

Clicking the Cancel button cancels the entire Diamond installation. Installation of 
Active-HDL cannot be cancelled at this point.

Note

Do not close the installation window. The window will automatically close when the 
installation completes.
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Installing Parallel Port Driver or USB Driver
Parallel port or USB drivers are required to program Lattice devices using the 
Lattice download cables. To install the drivers, you should have administrative 
privileges.

Three drivers can be installed or uninstalled with the LSC Drivers Install/
Uninstall dialog box.

Parallel port driver – Supports device programming through the parallel 
port of your PC. The driver can be installed on Windows XP, Server 2003, 
Vista (32-bit), and Windows 7 (32-bit).

USB port driver – Supports device programming through the USB port of 
your PC. The driver can be installed on Windows XP, Server 2003, Vista 
(32-bit or 64-bit), and Windows 7 (32-bit or 64-bit).

FTDI USB driver – Supports Lattice evaluation boards with FTDI (Future 
Technology Devices International) USB host chip. The driver does not 
support Windows 2000 and earlier operating systems.

To install the driver:

1. In the LSC Drivers Install/Uninstall dialog box, select one driver or All 
Drivers to be installed, as shown in Figure 3.

Figure 3: LSC Drivers Install/Uninstall Dialog Box

On a 32-bit Windows system On a 64-bit Windows system
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2. For 32-bit Windows system, if you selected LSC Windows Parallel Port 
Driver or All Drivers in step 1, select the desired parallel port driver from 
the Parallel Port Driver Installation Options:

Driver’s service starts on demand only (Default) – This driver allows 
PCs and laptops to enter system standby mode when Diamond 
Programmer or ispVM System is not running. This mode reduces the 
power consumption of your PC or laptop.

Driver’s service starts during startup of the system (Backwards 
Compatible) – This driver is backward-compatible with previous 
versions of Diamond Programmer, ispVM System, and ispDCD. 
However, it might prevent some PCs and laptops from entering 
system standby mode.

3. If another driver is already installed, you can click Uninstall if you want to 
remove it.

4. Click Install.

5. Click Close, and follow the installation instructions on the screen.

You must reboot your PC after installing the drivers. To use the USB port, 
install the USB driver and reboot your PC before connecting the USB cable to 
your PC. 

Adding ispLeverDSP Paths to MATLAB Search 
Path List and Windows System Environment 
Variables
In order to use ispLeverDSP blocksets, you must install both Diamond and 
MATLAB/Simulink, and take the following procedures to set the search path in 
both MATLAB and Windows System Environment Variables.

1. In the MATLAB startup window, choose File > Set Path to open the Set 
Path dialog box. Add the following paths to the search path list:

<diamond_install_path>\ispLeverDSP
<diamond_install_path>\ispFPGA\bin\nt

Note

If you skip the LSC Driver Install process during installation, you must re-install 
either the Diamond software or the stand-alone Programmer software, and 
use the steps described above. During installation, you can deselect features 
you do not wish to reinstall, and install Programmer drivers only.
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2. Go to the Windows Control Panel. Choose System > Advanced > 
Environment Variables > System Variables. Add the above two paths to 
the search path list.

3. After adding the two search paths in MATLAB and Windows Environment 
Variables tab, re-run MATLAB/Simulink.

Troubleshooting
If you encounter any software-related problems after installing Diamond, 
review the following common troubleshooting scenarios before calling Lattice 
Semiconductor Technical Support:

Ensure that your environment variable settings are set correctly, including 
the TEMP user variable. Your should also have the following system 
environment setting pointing to the license file:

SET LM_LICENSE_FILE=<Lattice_license_path>\license.dat

If you have multiple installations of Lattice software, this variable may 
have multiple paths in it. If there are problems, you may need to manually 
edit the variable.

You can verify these settings by accessing the System Properties dialog 
box from your Windows system. Select the Advanced tab from that dialog 
box and go to the “Environment Variables” section.

Make sure that your system video display is set to a screen resolution of 
1024 x 768 or more and that your video display is set to use 256 or more 
screen colors.

If Diamond is installed on a Windows XP, Windows Vista, or Windows 7 
system with administrator privilege and is to be used by an account in the 
“Users” group, make sure that the user account has permission to write 
the following folder and the configuration file in that folder:

<boot_drive>:\Documents and 
Settings\<login_name>\Application Data\LatticeSemi\*.ini

For a Windows 7 system, the folder is located at:

<boot_drive>:\users\<login_name>\AppData\LatticeSemi\*.ini

For the Windows Vista platform, the tools might not be displayed in the 
Diamond main window Tools menu. To display them properly, the user 
must have read/write permission for the .ini file.

Opening the online Help may be interrupted by one of the following 
messages on the Internet Explorer Information Bar:
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“To help protect your security, Internet Explorer has restricted this file 
from showing active content that could access your computer. Click 
here for options...”

“To help protect your security, Internet Explorer has restricted this file 
from running scripts or ActiveX controls that could access your 
computer. Click here for options...”

“To help protect your security, Internet Explorer has restricted this 
webpage from running scripts or ActiveX controls that could access 
your computer. Click here for options...”

This can happen if you are using Windows XP with Service Pack 2 and 
have Internet Explorer 6 or higher as your default browser. 

To see the Help, click on the Information Bar and choose Allow Blocked 
Content. A dialog box with an expanded warning opens. Click Yes.

To avoid these warnings, either use a different browser or turn off the 
warning for active content in Internet Explorer. 

To turn off the warning:

a. In the Internet Explorer, choose Tools > Internet Options.

b. Click the Advanced tab.

c. Under Security, select Allow active content to run in files on My 
Computer.

d. Click OK.

Favorites tab is missing:

Cookies must be enabled to see the Favorites tab. The Favorites tab is 
not available in Internet Explorer 7 and later.

If the Favorites tab is missing, check the permission for cookies in your 
browser (often in a Privacy tab in the Options or Preferences dialog box).

Note

Doing either of these means that when you open any Web page that is resident on 
your computer—not just Diamond Help—the page will automatically run any active 
content that it has. While active content is common and can be very useful, 
malicious content can damage your files. Be sure you trust the software on your 
computer.
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Licensing for Diamond
At the end of the installation, you will use the Web-based licensing capability 
to license your Diamond software. 

To use the software, you must receive a permanent Lattice Semiconductor 
software license based on the identification of your network interface card 
(NIC). The NIC ID or equivalent is the 12-character hexadecimal physical 
address. License your software early to avoid any down time.

To obtain a license file for your Diamond software:

1. Go to Lattice Semiconductor Software Licensing page: 
www.latticesemi.com/licensing

2. Select Lattice Diamond.

You will get the Lattice Diamond Software Licensing page.

3. Follow the on-screen instructions.

You can also get the NIC via an alternate network interface, such as a 
wireless interface.

In the absence of a network connection, you can install the NWLink IPX/SPX 
protocol to force the recognition of your NIC card ID.

To install the NWLink IPX/SPX protocol:

1. Right-click My Network Places on the desktop and select Properties.

A list of all the networks available opens.

2. Right-click Local Area Network and select Properties.

3. In the Local Area Connection Properties dialog box that appears, perform 
the following steps:

a. Click Install.

b. Select Protocol and click Add.

c. Select NWLink IPX/SPX.

d. Click OK and follow the instructions on the screen.

4. If needed, reboot your machine.

Note

The available devices for Diamond can vary, depending on the type of license.
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Finding the Installation History
Diamond records a log of the installation history, which you can find from the 
Diamond main window.

To view the installation history:

1. Open the Diamond main window.

2. Select Help > About Lattice Diamond. See the Installation History tab.

Optional Floating License Setup
To enable a floating license, you must have a license server set up on a 
Windows NT server to monitor your Diamond software license. Each client PC 
must have the LM_LICENSE_FILE variable set to point to the license file on 
the server.

Before you start the server setup, ensure that TCP/IP is installed and that the 
client machines can communicate with the server by name. At the prompt in 
an MS-DOS window, type the following:

ping <hostname>

Table 4 lists the files used for license management. The files are located at:

<diamond_install_path>\ispFPGA\bin\nt

Table 4: License Management Files

Filename Description

LMGRD.exe The license server program

LMUTIL.exe FLEXlm utility for diagnosing, reporting, and controlling licensing

LMTOOLS.exe Program that sets up the server for floating licenses

ispdsdmn.exe The Lattice Semiconductor licensing daemon

Note

The Diamond software uses FLEXlm 11.4 license administration software. Users of the 
ispLEVER 7.0 or older software must bring down the previous license daemon and 
start the new license daemon.
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Editing the License File
After obtaining a floating license from Lattice Semiconductor, you must edit 
the license file to specify the server name and the paths to the Lattice 
daemon. An example of a floating license file is shown below.

SERVER nodename 001143D94535 7788
DAEMON lattice daemon_path
FEATURE LSC_ADVANCED lattice 8.0 01-jan-9999 100 EE7E589FBD53 \

VENDOR_STRING="ispLEVER Advanced"
FEATURE LSC_BASE lattice 8.0 01-jan-9999 100 F901F7E7F4F1 \

VENDOR_STRING="ispLEVER Base"
FEATURE LSC_DIAMOND_A lattice 10.0 01-jan-9999 100 6D8288983379 \

VENDOR_STRING=LSC_DIAMOND_A
FEATURE LSC_OBSOLETE_DEVICE lattice 10.0 01-jan-9999 100 7D131CCD0F18 \

VENDOR_STRING=LSC_OBSOLETE_DEVICE  

To edit the license file:

1. Edit the SERVER line by replacing nodename with the host name of the 
server for which you requested your license.dat file. You may also need to 
change the PORT NUMBER (7788).

2. Edit the DAEMON lattice line by replacing daemon_path with the path 
to the lattice daemon, for example:

C:\lscc\diamond\1.3\ispfpga\bin\nt\ispdsdmn.exe

When you are editing these lines, make sure that they are typed exactly as 
you received them.

License Server Setup
To set up your license manager as a system service:

1. Copy the license file (license.dat) to 
<diamond_install_path>\license\license.dat.

2. Double-click the <diamond_install_path>\ispfpga\bin\nt\lmtools.exe file to 
open the LMTOOLS dialog box.

3. Choose the Config Services tab in the LMTOOLS dialog box.

4. Change Service Name to Lattice FLEXlm Service 1.

5. Browse and set lmgrd.exe to <install_path>\ispfpga\bin\nt\\lmgrd.exe.

Note

The “\” followed by a carriage return indicates a line continuation.
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6. Browse and set the license file to <install_path>\license\license.dat.

7. Browse and set the debug log file to <install_path>\license\lattice.log.

8. Click Save Service.

9. Select the Start/Stop/Reread tab.

10. Click Start Server.

11. Select the Config Services tab.

12. Select View Log to view the lattice.log file. Check to see if there are any 
problems starting the license server. If there are no problems, close the 
log file.

13. Choose Start > All Programs > Lattice Semiconductor > Lattice 
Diamond 1.3 to verify license checkout (this will be reflected in the 
lattice.log file). Close Diamond.

14. Choose the Start/Stop/Reread tab in the LMTOOLS dialog box.

15. Select Stop Server.

16. Select the Config Services tab. Select Use Services and Start Server at 
Power-Up.

17. Click Save Service, and then select File > Exit.

18. Restart the Windows server system.

19. Start Diamond again to verify that the license server is running as a 
service.

Windows XP License Server Setup for Active-
HDL Lattice Edition
If you want to use a floating license on a Windows XP system to run the 
Active-HDL Lattice Edition software, you should have a USB FLEXid keylock 
dongle and a separate license file (aldec_license.dat) for Active-HDL Lattice 
Edition. Before running the software, you need to install the dongle driver and 
set up the license server.

The steps below show you how to install the dongle driver and set up a 
Windows XP floating license server for Active-HDL Lattice Edition.

1. Obtain the USB FLEXid keylock dongle and the Active-HDL Lattice 
Edition license file (aldec_license.dat) from Lattice Semiconductor.

2. Install the driver files for the USB FLEXid keylock dongle by running 
<diamond_install_path>\active-hdl\Drivers\HASP\hasp_driver_install.bat.
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3. Plug in the USB FLEXid keylock dongle to the PC that will run the license 
server.

4. Download the Aldec license daemon package from ftp://
reguser:reguser@ftp.aldec.com/daemons/11.4/
aldec_windows_floating_license.zip.

5. Unpack the zip archive to a directory where you want to install the license 
server.

6. Copy the license file (aldec_license.dat) to the directory where you 
unpacked the server.

7. Modify the license file (aldec_license.dat) as follows.

Modify the SERVER line to reflect the nodename of your PC:

SERVER nodename FLEXID=9-xxxxxxxx 27000
SERVER myservername FLEXID=9-xxxxxxxx 27000

(Optional) Modify the VENDOR line to specify the vendor daemon 
path:

VENDOR ALDEC path_to_aldec

If the license file is in the local directory, you may remove the path 
parameter:

VENDOR ALDEC

8. Start the license server by running startlicense.bat.

9. Start the Active-HDL Lattice Edition software.

The Active-HDL License dialog box appears. Click Run license 
information. The Diagnose License dialog box then appears.

10. Confirm that the installation directory for Active-HDL is accurate and click 
Next. The Diagnose (License File) dialog box appears.

11. Specify the location of the license server using the syntax: <TCP-
port>@host_computer_name (27000@myservername). Click 
Refresh. Then click Next.

12. Click Finish.

13. Restart the Active-HDL Lattice Edition software.
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Floating License Configuration
In this configuration, Diamond is installed on your Windows license server (for 
license manager utilities and daemons) and on each client that uses 
Diamond. This configuration gives the best run-time performance.

Install Diamond on the license server first. After you receive your floating 
license and ensure that the license manager is running, install Diamond 
locally on each client that will use the floating license.

Set your system variable LM_LICENSE_FILE to point to 
TCP/IP_PORT@hostname

Setting up Floating License on Linux
You can also put the Diamond license on a Linux machine. Then each client 
(Windows or Linux) points to the license file on the Linux machine. In this 
case, you need to set the environment variable LM_LICENCE_FILE value to 
License_Port_number@linux_host_name. Or, have the LM_LICENSE_FILE 
value set to the path to a license file on the client that is set up with the 
SERVER name of the Linux_host_name and License_Port_number.

Troubleshooting
If you encounter problems with your license, refer to Table 5 for common 
FLEXlm error messages and possible causes or solutions. 

Table 5: FLEXlm Error Messages

FLEXlm Error Message Possible Causes or Solutions

Invalid parameter [-42, 252] The LM_LICENSE_FILE variable has not been set properly.

The license file is invalid.

An invalid feature is specified in the license file.

Invalid parameter [-42, 252:10061]
Winsock error code

You have a floating license, and the license daemon has not 
been started at the Windows NT server.

The network connection between the server and the client 
has not been established.

Invalid parameter [-12, 122]
Invalid returned data from license server

The node name of the Windows NT server does not match the 
one in your floating license file.
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If you encounter any software-related problems, review the following common 
troubleshooting scenarios before calling Lattice Semiconductor Technical 
Support:

Ensure that your environment variable settings are set correctly, including 
the TEMP user variable. For Windows, your system should contain the 
following environment settings:

SET LM_LICENSE_FILE=<install_path>\license\license.dat

You can verify these settings by accessing the System Properties dialog 
box from your Windows system. Select the Advanced tab and the 
Environment Variables section.

Make sure that your system video display is set to a screen resolution of 
1024 x 768 or more and that your video display is set to use 256 or more 
screen colors.

If Diamond still does not run after you have installed your new license file and 
confirmed that your environment variables are correct, gather the following 
items:

A screen capture showing the error message

A text file that contains a listing of the environment setup for your PC. 
From an MS-DOS prompt window, issue the set > env.txt command.

Your license.dat file

Combine these items in a zip file and e-mail it to 
techsupport@latticesemi.com. Include an explanation of the problem.

Invalid parameter [-5, 222]
No such feature exists

The feature could not be found in the license file.

! License Check Failed You either have a node-locked license or you do not have a 
license file. Contact Lattice Semiconductor Technical Support for 
a valid floating license file.

Table 5: FLEXlm Error Messages (Continued)

FLEXlm Error Message Possible Causes or Solutions
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Running Multiple Versions
Diamond enables you to run FPGA designs on platforms on which Diamond 
1.3 and previous ispLEVER or Diamond versions are installed.

If you have multiple versions of Lattice software installed, you will have 
multiple versions of ispLeverDSP blocksets. The MATLAB/Simulink installer 
does not remove the paths of old ispLeverDSP versions from the MATLAB/
Simulink software, so old blocksets might be used instead of the new 
blocksets. Follow these steps to manually remove paths of old ispLeverDSP 
from MATLAB/Simulink:

1. In MATLAB desktop, choose File > Set Path.

The Set Path dialog box appears.

2. In MATLAB search path list, remove old ispLeverDSP paths. Save and 
close the dialog box.

Running Diamond 
After the installation and the license configuration, you can invoke Diamond.

Running Diamond Locally
If you have installed Diamond on your local machine, choose Start > All 
Programs > Lattice Diamond 1.3 > Lattice Diamond. The Diamond main 
window is invoked.

Running Diamond using Windows Remote 
Desktop
You can also install Diamond on a shared disk, installation procedure of which 
is exactly the same as that for the local installation. After the license file setup, 
you can access that shared disk from the Windows Explorer and then invoke 
Diamond from that installation directory by double-clicking 
<boot_drive>:\<diamond_install_directory>\lscc\diamond\1.3\bin\
nt\pnwrap.exe

When the installation is finished, make sure to set the LM_LICENSE_FILE 
environment variable to be the location of your license file. When you use a 
client-server setup, it is recommended that you use a floating license. Then 
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set LM_LICENSE_FILE=7788@nodename. Confirm that it works by selecting 
and compiling one of the examples now on the client.

Pin Diamond to Start Menu or Taskbar
You can pin Diamond to your Windows Start menu or taskbar, so you can 
open it quickly and conveniently, rather than looking for Diamond in the Start 
menu.

To pin Diamond to the Start menu or Taskbar:

Choose the Windows Start menu. Find the Lattice Diamond 1.3 icon. 
Right-click the Lattice Diamond icon, and then click Pin to Start Menu or 
Pin to Taskbar. 

If you want to remove the pinned Diamond from the Start menu or the taskbar, 
right-click on a pinned Lattice Diamond icon from the Start menu or the 
taskbar, choose Unpin from Start Menu or Unpin this program from 
taskbar.

Updating Diamond
After you have registered and licensed your installation, check the Lattice 
Semiconductor Web site for new software updates, device support, and 
enhancements. Make sure that you have the latest software by checking for 
updates regularly. 

This process will only find updates to the version you have installed. For an 
upgrade to a new version, check the Lattice Web site.

To activate UPDATE:

1. Choose Start > All Programs > Lattice Diamond 1.3 > UPDATE.

The UPDATE window appears, as shown in Figure 4.

Note

You should not pin Diamond to the Taskbar through the minimized icon on the taskbar 
while Diamond is running. The resulting icon cannot successfully run Diamond.
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Figure 4: UPDATE Window 

After you invoke UPDATE, it will connect to the Internet automatically to 
check for updates.

2. In the UPDATE window, click Settings > Update Settings.

The Update Settings dialog box now appears, as shown in Figure 5.

Figure 5: Auto Setting Tab of the Update Settings Dialog Box 

Changing the Automatic Checking Settings
Diamond can automatically check for updates and activate a window showing 
the Diamond updates that are available.
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If you want to change or turn off the automatic update checking, change the 
settings in UPDATE as follows:

1. Select the Auto Setting tab of the Update Settings dialog box.

2. If you want to enable the automatic checking for software updates, make 
sure that the Automatic check for software updates when application 
starts option is turned on. By default, this option is turned on.

If you turned on the Automatic check for software updates when 
application starts option, indicate the frequency with which you want the 
checking to be performed: every time that Diamond is started, daily, or 
weekly. An every-time check is the default.

If you want to disable the automatic checking, turn off the Automatic 
check for software updates when application starts option.

3. Click OK.

Changing the Network Setting
To enable automatic checking, you must indicate how your computer 
accesses the Internet.

To change the Internet connection settings:

1. Select the Network Setting tab of the Update Settings dialog box, shown 
in Figure 6.

Figure 6: Network Settings Tab of the Update Settings Dialog Box 

2. Select the Use a Proxy Server option if you must go through a proxy 
server before connecting to the Internet. The proxy server prevents 
outsiders from breaking into your organization’s private network. Ask your 
system administrator for the URL address and port assignment. This 
option is turned on by default.
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If you use direct Internet access, do not select the Use a Proxy Server 
option on this tab.

Installing Updates
When you use the Auto Check feature, UPDATE notifies you whenever an 
update version of Diamond becomes available. You receive notification when 
you open the Diamond main window.

To check and install the recommended update:

Click Update. The UPDATE software goes online to check for an update. 
If one is available, the Diamond update version will be displayed in the 
Available update versions field.

Click Download to save the update to a directory and install it later.

Click Install to download and install the selected update version (as the 
version number specified in the Available update versions field) right 
away.

To install a downloaded update:

1. Close all Diamond tools.

2. Go to the location where you saved the update version.

3. Double-click the update file and follow the on-screen instructions.

When All Else Fails
If Diamond still does not run after you have installed your new license file and 
confirmed that your environment variables are correct, gather the following 
items:

A screen capture showing the error message

A text file that contains a listing of the environment setup for your PC. 
From an MS-DOS Prompt window, issue the set > env.txt command.

Your license.dat file 

Put these items into a zip file and e-mail it to techsupport@latticesemi.com, 
including an explanation of the problem.
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2
Installing LatticeMico 
Development Tools

You can install the LatticeMico Development Tools as a part of the Diamond 
software. The LatticeMico Development Tools will be installed by default in a 
folder called micosystem, which resides in the folder in which Diamond was 
installed. For example, the LatticeMico Development Tools could be installed 
in the <install_drive>:\lscc\diamond\1.3\micosystem directory.

Installing the LatticeMico Development Tools without Diamond, or stand-
alone, is not supported.

You can download the LatticeMico Development Tools from the Lattice 
Semiconductor Web site.

Installing LatticeMico with Diamond
This section describes how to install the LatticeMico Development Tools on 
top of the Diamond software. These procedures assume that you have 
already installed Diamond 1.3. 

To install the LatticeMico Development Tools:

1. Make sure you have installed Lattice Diamond 1.3.
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2. Double-click on the LatticeMico setup file you downloaded to launch the 
installation process. The LatticeMico Development Tools Setup dialog box 
automatically appears.

3. Click Next.

4. In the Product Options dialog, for full functionality, be sure that both the 
LatticeMico System and the GNU-based Compiler Tools options are 
selected. 

When you select the LatticeMico System option, the LatticeMico 
Development Tools do the following:

Install the Eclipse graphical user interfaces, which are components, or 
plug-ins, of the Eclipse development environment on which the 
LatticeMico System is based.

Enable Mico System Builder (MSB) to access all Lattice Diamond 
executables and functions.

Add the LatticeMico System icon to the Lattice Diamond 1.3 
Accessories folder on the Windows Start menu.

Add the LATTICEMICOSYSTEM environment variable.

If the LatticeMico System option is not selected to install, you cannot use 
the LatticeMico System graphical user interface. You can only use the 
LatticeMico Development Tools through the command line.

When you select the GNU-based Compiler Tools option, the LatticeMico 
Development Tools do the following:

Install gtools (C++/C tool chain) and cygwin.

Add the LatticeMico System SDK Shell icon to the Lattice Diamond 
1.3 Accessories folder on the Windows Start menu.

Enable the command-line mode for building C/C++ source codes.

Add the LATTICEGNUTOOLS environment variable.

If the GNU-based compiler is not installed, the C++/C and debug 
graphical user interfaces will not function correctly.

5. Click Next. You will get the License Agreement for LatticeMico System 
dialog.

Note

You can install LatticeMico System and the GNU-based Compiler Tools separately 
by checking only one box, but Lattice Semiconductor recommends that you accept 
the defaults and install both tools at the same time.
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6. Click Yes to accept the terms of the licensing agreement for LatticeMico 
Systems.

7. Click Yes to accept the terms of the licensing agreement for the GNU-
Based Compiler Tools.

8. The Choose Destination Location part of the LatticeMico Development 
Tools Setup dialog box now appears. As the current version of Diamond is 
installed, the default destination folder will be the same folder in which 
Diamond was installed. 

9. Click Next to accept the default destination folder.

10. The Select Program Folder dialog box opens. The default name of the 
program group is Lattice Diamond 1.3. If you want to change the name, 
change it in the Program Folder text box.

11. Click Next.

12. In the Start Copying Files part of the LatticeMico Development Tools 
Setup dialog box, click Next.

The installation begins. When it is finished, the LatticeMico Development 
Tools Installation Completing dialog box appears.

13. Click Finish.

14. Because the installation process added new environment variables, 
reboot your computer.

Starting LatticeMico Development Tools
You can start the LatticeMico Development Tools from the Windows Start 
menu.

To start the LatticeMico Development Tools:

Choose Programs > Lattice Diamond 1.3 > Accessories > LatticeMico 
System from the Windows Start menu.
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