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to correct any errors contained herein or to advise any user of this document
of any correction if such be made. LSC recommends its customers obtain the
latest version of the relevant information to establish, before ordering, that the
information being relied upon is current.

Type Conventions Used in This Document

Convention Meaning or Use

Bold

Items in the user interface that you select or click. Text that you type
into the user interface.

<Italic>

Variables in commands, code syntax, and path names.

Ctrl+L

Press the two keys at the same time.

Courier

Code examples. Messages, reports, and prompts from the software.

Omitted material in a line of code.

Omitted lines in code and report examples.

L1

Optional items in syntax descriptions. In bus specifications, the
brackets are required.

@

Grouped items in syntax descriptions.

{1}

Repeatable items in syntax descriptions.

A choice between items in syntax descriptions.
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This guide describes the new features of the Power Calculator in 7.0 and later
releases and explains how to import design files compiled in other releases
into the Power Calculator. It also provides troubleshooting information.

New Features

Power Calculator version 7.0 and later releases is completely new and
features greater granularity and more functionality than the previous version.
It also offers a new graphical user interface.

Graphical User Interface

Power by block includes both dynamic and static (for used and unused
resources) power for the block.

Static current and power per supply includes static leakage for both used and
unused resources.

Individual tabs include only the dynamic current calculations. The static
current for the resources is added to the current and power values in the
Report tab and the Power Summary tab.

The cells in the tabs are color-coded as follows:

¢ White indicates that the cell is editable

¢ Gold indicates that the cell is read-only or contains output from the
software.

¢ Cyan (turquoise) indicates that the cell contains data imported from an
.ncd file, a package thermal file, or both. You can edit the contents of the
cell.
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Design-rule checking is based on device capture in the software.

The fields for logic blocks, clocks, DSP blocks, PLL/DLLs, and the summary
report are similar to those in the previous version of the Power Calculator. The
I/0 tab features added modeling for external output terminations (static loads)
and default values (resistive load) for Rth and Vth. Block RAMs are now
separated into SP RAMs, DP RAMs, and DP True RAMs. Additionally, release
7.1 adds an I/0O Termination tab, which shows the power used by the
termination on the I/Os. This figure is actually a static number rather than the
dynamic number shown in the other tabs.

Menus

The Edit menu contains a new option, Estimation Mode Settings, which is
described in “Estimation Mode” on page 5.

Instead of using the wizard, which has been removed, you can now enter the
resource utilization directly in the tabs. You do not need to specify internal
routing resource utilization.

Thermal Profiles

The Power Calculator in the 7.0 and later releases includes a selection of
board, heat-sink, and airflow options. You can choose among the various
combinations or override them with your own theta-JA effective thermal
resistance value. All values are in degrees Celsius per watt (°C/W).

In the Power Summary tab in the Power Calculator window, you can change
the default thermal environment by selecting the Thermal Profile button,
shown in Figure 1.

Figure 1: Thermal Profile Button

Environmenit

Thermal Profile... |
Ambiert Temperature: lzs—
Effective Theta-Ja: |T
Junction Tempersture: lﬁ
Maximum Safe Ambient: IW

In the Thermal Profile dialog box, you see boxes for boards, heat sinks, and
airflow.
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In the Board Selection menu, shown in Figure 2, you can choose between
JEDEC-defined Theta JA values, a small board, a medium board, or a large
board.

Figure 2: Board Selection Menu

Power Calculator - Thermal Profile x|
% Use Thermal Modsls 7 User Defined Effective Theta-Ja

Eoard Selection

IMedium Eoard i l
JEDEC Bos )

Small Board
hedlium Board

Airflovy Selection

200 LFi v
Large Board
Effective Theta-JA
7.4
OK | Cancel |

Below the boards are the heat-sink selections, which are based on industry-
standard copper-pin heat sinks. The heat-sink values include the thermal
resistance of the thermal interface material, which is used to connect a heat
sink to the top of a package. The thermal interface thermal value is 1.6°C-cm/
W.

Low-, medium-, and tall-profile copper heat-sink thermal values are provided
as guidelines for you. Many factors will cause the actual values to vary,
including the actual airflow through the heat sink, the pressure on the heat
sink, and thermal interface material.

Figure 3: Heat Sink Selection Menu

Power Calculator - Thermal Profile x|
% Use Thermal Modsls 7 User Defined Effective Theta-Ja
Eoard Selection
’V IMedium Eoard i l
Heat Sink Selection Airflovy Selection
Mo Heat Sink i 200 LFh i

Loy Profile Heat Sink

Medium Profile Hest Sink e T
High Profile Hest Sink ,%I
Custom Prafile Hest Sink 2

OK | Cancel |

If you want to use your own heat-sink thermal value or adjust for a different
thermal interface material, choose Custom Profile Heat Sink in the Heat
Sink Selection menu, type in your own value in the box below Heat Sink
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Selection, as shown in Figure 4, then choose OK. Theta JC for this package

is added to your heat sink value and used in the calculations.

Figure 4: Specifying a Custom Heat Sink

Power Calculator - Thermal Profile x|

% Use Thermal Modsls

7 User Defined Effective Theta-Ja

IMedium Eoard i l

"Eioard Selection

Heat Sink Selection
Custom Profile Heat Sink i
EE

Airflovy Selection
(HEES i

OK

Effective Theta-JA
5.15

Cancel |

You can also change the airflow to accommodate your new board selection.
The JEDEC values in the Airflow Selection menu are Theta JA at 0 LFM, 200
LFM, and 500 LFM, as shown in Figure 5. They correspond to results
measured from a 2S2P JEDEC board in JEDEC-defined test chambers. You
can use the airflow values with both the board selection and the heat sinks.
These change in value, depending on your current selection. There is no zero

airflow for heat sinks.

Figure 5: Airflow Selection Menu

Power Calculator - Thermal Profile x|

% Use Thermal Modsls

7 User Defined Effective Theta-Ja

"Eioard Selection

IMedium Eoard i l

Heat Sink Selection
Mo Heat Sink i

Airflovy Selection
200 LFi
0 LFh
200 LFh

OK

Cancel
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Estimation Mode

The new Power Calculator offers an intelligent estimation algorithm that
calculates routing resource utilization based on the component (logic, EBR,
I/0, DSP, PLL/DLL, and so forth) utilizations that you provide. Calculation is
based on the statistical analysis of hundreds of designs. Using the block
resources that you specify, the algorithm calculates internal routing lines (x0,
x1, X2, x6, ISBs) and clock-tree utilization. You can select low, medium, or
high routing utilization.

Importing Designs into Power Calculator 7.0 and Later

The database for some of the newer devices in ispLEVER has been updated
to make the ispLEVER tools run faster and more efficiently. The placed and
routed design (*.ncd) files for these devices must be updated to this new
database.

Because of the enhancements to the Power Calculator’s capabilities in the 7.0
and later releases, you cannot open Power Calculator Project (*.pep) files
created in versions prior to 7.0 in the new Power Calculator.

Newer Design Families Placed and Routed in

Previous Releases

You can import into the Power Calculator LatticeECP2, LatticeECP2M,
LatticeXP2, LatticeSC, and LatticeSCM designs placed and routed in release
7.0 SP2. You can also import designs placed and routed in release 6.1 or
earlier, but you must place and route them again to update the .ncd files to
iISpLEVER 7.1 design files.

To import the design files into the Power Calculator:
1. Load the design into the Project Navigator.
Double-click Place & Route Design.

2
3. Choose Tools > Power Calculator.
4

In the Power Calculator main window, choose File > New or click [ to
activate the Power Calculator - New Project dialog box.

5. Inthe Project Name box, type in a name for your Power Calculator
project.

6. Inthe Project Directory box, enter the path and name of the directory
where the Power Calculator project (*.pep) file will be stored. You can use
the Browse button to browse to the correct directory. By default, the file is
stored in the main project folder.

7. Inthe NCD File box, enter the path and name of the new .ncd file to use.
You can use the Browse button to browse to the correct directory.

8. Click Finish.
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Older Design Families Placed and Routed in

Previous Releases

You can directly import LatticeECP/EC, LatticeXP, and MachXO designs
placed and routed in release 6.1 or earlier. Because there has been no
change to the database for these devices, the .ncd files are compatible
between ispLEVER 7.0 and previous versions.

All Design Families Placed and Routed in
ISPLEVER 7.0 or Later

You can import new designs for all devices if you have placed and routed
them with ispLEVER 7.0 or later software. The design files for these designs
were created with the new database. To import these files, you invoke the
Power Calculator and create a new Power Calculator project.

To import the design files into the Power Calculator:

1. Choose Tools > Power Calculator.

2. In the Power Calculator main window, choose File > New or click [ to
activate the Power Calculator - New Project dialog box.

3. Inthe Project Name box, type in a name for your Power Calculator
project.

4. Inthe Project Directory box, enter the path and name of the directory
where the Power Calculator project (*.pep) file will be stored. You can use
the Browse button to browse to the correct directory. By default, the file is
stored in the main project folder.

5. Inthe NCD File box, you can optionally enter the path and name of the
correct .ncd file to use. You can use the Browse button to browse to the
correct directory.

If an .ncd file is available in the project directory, its path and name is
automatically placed in the NCD File field.

6. Click Finish.
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Troubleshooting

You may encounter the following issues in using the 7.0 or later version of the
Power Calculator.

False Error Message Issued for LatticeSC

Estimation Mode

When you add EBR blocks to LatticeSC designs and the Power Calculator is
in estimation mode, the tool generates an error indicating that the number of
available EBR blocks has been exceeded.

Current and Power are Different in Calculation

and Estimation Modes

Current and power are different in calculation and estimation modes.
Calculation mode uses data from the exact utilization in the .ncd file, including
routing resources. Any change in the information extracted from the .ncd file
puts the Power Calculator into estimation mode and starts the estimation
mode routing resource calculation algorithm. However, the Power Calculator
cannot return to calculation mode once it is in estimation mode. Even if you
select the same device, the tool remains in estimation mode.

SERDES Power Supplies Are Not Listed for

LatticeSC Devices

SERDES power supplies are not listed for LatticeSC devices. In this version
of the Power Calculator, the coefficients are characterized to work with VCC.
The power for the SERDES channel is added in the VCC section, and the
number is correct.

LatticeSC and LatticeSCM Devices Have Too
Many Suffixes in 1/0O Tab

The I/0 types for the LatticeSC and LatticeSCM devices now indicate the
internal terminations, if used. Each legal combination is now in the form
IOType-Termination Information-Drive Strength.

SERDES Tab Options Are Different for

LatticeSC and LatticeECP2M Devices

SERDES tab options are different for LatticeSC and LatticeECP2M devices,
because of the way the SERDES blocks are characterized. The SERDES
channel power in LatticeSC devices depends on the gearing ratio and the
transmitter pre-emphasis and is independent of the SERDES modes.
SERDES channel power in LatticeECP2M devices is characterized to be
dependent on the mode in which SERDES is operating.
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