Copyright
Copyright © 2024 Lattice Semiconductor Corporation. All rights reserved. This document may not, in whole or part, be reproduced, modified, distributed, or publicly displayed without prior written consent from Lattice Semiconductor Corporation (“Lattice”).

Trademarks
All Lattice trademarks are as listed at www.latticesemi.com/legal. Synopsys and Synplify Pro are trademarks of Synopsys, Inc. Aldec and Active-HDL are trademarks of Aldec, Inc. ModelSim and QuestaSim are trademarks or registered trademarks of Siemens Industry Software Inc. or its subsidiaries in the United States or other countries. All other trademarks are the property of their respective owners.

Disclaimers
NO WARRANTIES: THE INFORMATION PROVIDED IN THIS DOCUMENT IS “AS IS” WITHOUT ANY EXPRESS OR IMPLIED WARRANTY OF ANY KIND INCLUDING WARRANTIES OF ACCURACY, COMPLETENESS, MERCHANTABILITY, NONINFRINGEMENT OF INTELLECTUAL PROPERTY, OR FITNESS FOR ANY PARTICULAR PURPOSE. IN NO EVENT WILL LATTICE OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER (WHETHER DIRECT, INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL, INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF PROFITS, BUSINESS INTERRUPTION, OR LOSS OF INFORMATION) ARISING OUT OF THE USE OF OR INABILITY TO USE THE INFORMATION PROVIDED IN THIS DOCUMENT, EVEN IF LATTICE HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. BECAUSE SOME JURISDICTIONS PROHIBIT THE EXCLUSION OR LIMITATION OF CERTAIN LIABILITY, SOME OF THE ABOVE LIMITATIONS MAY NOT APPLY TO YOU.

Lattice may make changes to these materials, specifications, or information, or to the products described herein, at any time without notice. Lattice makes no commitment to update this documentation. Lattice reserves the right to discontinue any product or service without notice and assumes no obligation to correct any errors contained herein or to advise any user of this document of any correction if such be made. Lattice recommends its customers obtain the latest version of the relevant information to establish that the information being relied upon is current and before ordering any products.
# Type Conventions Used in This Document

<table>
<thead>
<tr>
<th>Convention</th>
<th>Meaning or Use</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Bold</strong></td>
<td>Items in the user interface that you select or click. Text that you type into the user interface.</td>
</tr>
<tr>
<td><em>Italic</em></td>
<td>Variables in commands, code syntax, and path names.</td>
</tr>
<tr>
<td><strong>Ctrl+L</strong></td>
<td>Press the two keys at the same time.</td>
</tr>
<tr>
<td><strong>Courier</strong></td>
<td>Code examples. Messages, reports, and prompts from the software.</td>
</tr>
<tr>
<td>...</td>
<td>Omitted material in a line of code.</td>
</tr>
<tr>
<td>.</td>
<td>Omitted lines in code and report examples.</td>
</tr>
<tr>
<td>[ ]</td>
<td>Optional items in syntax descriptions. In bus specifications, the brackets are required.</td>
</tr>
<tr>
<td>( )</td>
<td>Grouped items in syntax descriptions.</td>
</tr>
<tr>
<td>{ }</td>
<td>Repeatable items in syntax descriptions.</td>
</tr>
<tr>
<td></td>
<td>A choice between items in syntax descriptions.</td>
</tr>
</tbody>
</table>
Contents

Chapter 1  Introduction  7

Chapter 2  Reveal Inserter  9
   Using JTAG Debugger  9
   Debug Flows  10
   Input and Output Files  14
   Limitations  14

Getting Started  16
   Starting Reveal Inserter  16
   Creating a New Reveal Inserter Project  17
   Opening an Existing Reveal Inserter Project  19
   Using the Reveal Controller Simulation Model  19

Managing the Cores in a Project  20
   Renaming a Core  20
   Removing a Core  21

Viewing Signals in the Design Tree Pane  21

Searching for Signals  22

Setting Up the Trace Signals  23
   Selecting the Debug Logic Core  23
   Selecting the Trace Signals  23
   Viewing Trace Signals and Buses  24
   Grouping Trace Signals into a Bus  25
   Ungrouping Trace Signals in a Bus  25
   Removing Signals and Buses from the Trace Data Pane  25
   Renaming a Bus  25
   Setting Required Sample Parameters  26
   Power-on Reset (POR) Debug  27
   Setting Sample Options  27

Setting Up the Trigger Signals  29
   Triggering  29
   Adding Trigger Units  38
   Renaming Trigger Units  38
### CONTENTS

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Setting Up Trigger Units</td>
<td>39</td>
</tr>
<tr>
<td>Removing Trigger Units</td>
<td>41</td>
</tr>
<tr>
<td>Adding Trigger Expressions</td>
<td>41</td>
</tr>
<tr>
<td>Renaming Trigger Expressions</td>
<td>42</td>
</tr>
<tr>
<td>Setting Up Trigger Expressions</td>
<td>42</td>
</tr>
<tr>
<td>Removing Trigger Expressions</td>
<td>44</td>
</tr>
<tr>
<td>Setting Up Virtual Switch/LED Settings</td>
<td>45</td>
</tr>
<tr>
<td>Configuring User Memory Setup</td>
<td>45</td>
</tr>
<tr>
<td>Configuring User Control Register Setup</td>
<td>46</td>
</tr>
<tr>
<td>Configuring User Status Register Setup</td>
<td>48</td>
</tr>
<tr>
<td>Configuring Hard IP Setup</td>
<td>49</td>
</tr>
<tr>
<td>Checking the Debug Logic Settings</td>
<td>49</td>
</tr>
<tr>
<td>Saving a Project</td>
<td>51</td>
</tr>
<tr>
<td>Inserting the Debug Logic Cores</td>
<td>51</td>
</tr>
<tr>
<td>Removing Debug Logic from the Design</td>
<td>52</td>
</tr>
<tr>
<td>Closing a Project</td>
<td>52</td>
</tr>
<tr>
<td>Exiting Reveal Inserter</td>
<td>52</td>
</tr>
<tr>
<td>Performing Logic Analysis with Reveal Analyzer</td>
<td>53</td>
</tr>
<tr>
<td>Using JTAGhub</td>
<td>53</td>
</tr>
<tr>
<td>JTAGhub Input and Output Ports</td>
<td>57</td>
</tr>
<tr>
<td>JTAGhub Ecosystem</td>
<td>59</td>
</tr>
<tr>
<td>JTAGhub Usage and Design Examples</td>
<td>59</td>
</tr>
<tr>
<td>JTAGhub Addressing Scheme</td>
<td>60</td>
</tr>
<tr>
<td>JTAGhub CORES</td>
<td>61</td>
</tr>
<tr>
<td>Setting Parameters and Connectivity</td>
<td>62</td>
</tr>
<tr>
<td>JTAG BYPASS Instruction in SOFTJTAG Chain</td>
<td>62</td>
</tr>
<tr>
<td>User Interface Descriptions</td>
<td>65</td>
</tr>
</tbody>
</table>

### Chapter 3  Reveal Analyzer  67

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>About Reveal Analyzer</td>
<td>68</td>
</tr>
<tr>
<td>Reveal On-Chip Debug Design Flow</td>
<td>68</td>
</tr>
<tr>
<td>Inputs</td>
<td>69</td>
</tr>
<tr>
<td>Outputs</td>
<td>69</td>
</tr>
<tr>
<td>Inserting the Debug Logic</td>
<td>70</td>
</tr>
<tr>
<td>Mapping, Placing, and Routing the Design</td>
<td>70</td>
</tr>
<tr>
<td>Generating a Bitstream File</td>
<td>70</td>
</tr>
<tr>
<td>Connecting to the Evaluation Board</td>
<td>71</td>
</tr>
<tr>
<td>Downloading a Design onto the Device</td>
<td>71</td>
</tr>
<tr>
<td>Starting Reveal Analyzer</td>
<td>72</td>
</tr>
<tr>
<td>Starting with a New File</td>
<td>73</td>
</tr>
<tr>
<td>Starting with an Existing File</td>
<td>74</td>
</tr>
<tr>
<td>Changing the Cable Connection</td>
<td>75</td>
</tr>
<tr>
<td>Selecting a Reveal Analyzer Core</td>
<td>75</td>
</tr>
<tr>
<td>Setting Up the Trace Signals</td>
<td>76</td>
</tr>
<tr>
<td>Setting the Trace Bus Radix</td>
<td>76</td>
</tr>
<tr>
<td>Adding Time Stamps to Trace Samples</td>
<td>76</td>
</tr>
<tr>
<td>Setting Up the Trigger Signals</td>
<td>77</td>
</tr>
<tr>
<td>Renaming Trigger Units</td>
<td>77</td>
</tr>
<tr>
<td>Setting Up Trigger Units</td>
<td>77</td>
</tr>
</tbody>
</table>
Introduction

The Radiant software contains the Reveal Inserter and the Reveal Analyzer tools used for design debugging. This guide describes Reveal Inserter and Reveal Analyzer.

One of the most common activities in debugging is logic analysis. To do this, use Reveal Inserter and Reveal Analyzer. You can use both with all supported FPGA devices.

Reveal continuously monitors signals within the FPGA for specific conditions, which can range from simple to quite complex. When the trigger condition occurs, Reveal can save signal values preceding, during, and following the event for analysis, including a waveform presentation. The data can be saved to a value change dump file (.vcd), which can be used with tools such as QuestaSim, or to an ASCII tabular format that can be used with tools such as Excel.

Before running Reveal Analyzer, use Reveal Inserter to add Reveal modules to your design. In these modules, specify the signals to monitor, define the trigger conditions, and other options. Reveal supports multiple logic analyzer cores using hard/soft JTAG interface. You can have up to 15 modules, typically one for each clock region of interest. When the modules are set up, regenerate the bitstream data file to program the FPGA.

A feature is enabling an added module called Reveal Controller. This controller module enables:

- Access to the control and status registers of the hard IPs such as I2CFIFO, PLL, PCIe, CDR, and DPHY via the LMMI (Lattice Memory Mapped Interface) slave interface
- Virtual switches and LEDs emulating on-board switches and LEDs to control and monitor a user design. Up to 32 switches and 32 LEDs are supported.
Read/write access to a bank of user registers and/or initialize memory post-configuration.

The main purpose is narrowing down to problem areas during debug cycles using a divide and conquer method into many small functional blocks to control and monitor the status of each block.

Before starting a test run, set up Reveal Analyzer. This includes setting a number of options, including modifying trigger conditions and customizing the waveform display. You can save these settings for later use. During and after a test run, view the incoming data in Reveal’s LA Waveform view. You can also save the data to a .vcd or .txt file to analyze with other tools.

Note:

Reveal supports IEEE-P1735 encryption. If this encryption is applied to a design, the design tree will allow only the visible ports and signals that are not encrypted to be inserted by the Reveal Inserter for triggering purposes.
Reveal Inserter

Reveal Inserter enables you to select which design signals to use for debug tracing or triggering, then generate a core on the basis of these signals and their use. After generating the required core, it generates a modified design with the necessary debug connections and links it to the signals. Reveal Inserter supports VHDL, Verilog, System Verilog and mixed-HDL flows for debug insertion. Once the design has been modified for debug, it is mapped, placed, and routed with the normal design flow in the Radiant software.

Using JTAG Debugger

JTAG can be used to access debug logic to test and analyze your design. Devices in Radiant support hard and soft JTAG cores. Hard JTAG is basically a JTAG block IP that is part of the device. Soft JTAG is built in RTL, which uses the device fabric logic.

In the iCE40 device, Reveal JTAG support is implemented using logic for JTAG state machine and GPIO pins for four JTAG pins (JTAG_TCK, JTAG_TDI, JTAG_TMS, and JTAG_TDO).

Consider the following recommendations:

- Lock the JTAG_TCK pin to PCLK or GR_PCLK to avoid using general routing, as clock general routing may violate the CLK 1-PLC rule. For an example of the ldc_set_location constraint:
  \[
  \text{ldc}\_\text{set}\_\text{location}\ \{\text{JTAG}\_\text{TCK}\} \:\text{--site} \ J2
  \]

- Lock pins JTAG_TCK, JTAG_TDI, JTAG_TMS, and JTAG_TDO on the same bank. Make other banks available for DDR, MIPI or LVDS usage.

- Set the frequency constraint as follows:
  \[
  \text{create}\_\text{clock} \:\text{--name} \ \{\text{JTAG}\_\text{TCK}\} \:\text{--period} \ 166.67
  \]
Likewise, in CrossLink device, there is no hard JTAG block and Reveal uses soft JTAG debug logic and GPIO pins for the four JTAG pins.

Refer to “Using JTAGhub” on page 54 for information about the use and merging of JTAGhubs in Nexus and Avant devices.

Debug Flows

Reveal Inserter features two debug flows. When you open Reveal Inserter, the Reveal Inserter Wizard prompts you to choose the debug flow to use.

- RTL (Pre-Synthesis) – This is the standard flow for debugging a design all at once. The user inserts the logic core before the design is synthesized the first time. Refer to “RTL (Pre-Synthesis) Debug Flow” on page 10 for details.

- Post-Synthesis – This flow allows you to insert debug logic after running synthesis. As such, this option is available if you have already run synthesis. It is useful for isolating or monitoring certain signals and focus your changes or improvements in specific areas of the design. Refer to “Post-Synthesis Debug Flow” on page 11 for details.

Figure 1: Reveal Inserter Wizard

RTL (Pre-Synthesis) Debug Flow

The following are the general steps in the Reveal Inserter RTL design flow.

1. Start Reveal Inserter.

2. In the Reveal Inserter Wizard, select RTL (Pre-Synthesis) as debug stage and click Finish.
3. Create a new Reveal Inserter project or open an existing Reveal Inserter project.
4. Add and set up analyzer and controller modules.
5. Insert the debug logic.
   This process generates and synthesizes the necessary debug logic.
   The generated .rvl is automatically imported into the Radiant software if you enabled the "Activate Reveal file in design project" option in the Insert Debug to Design dialog box.
6. Map, place, and route the design.
7. Generate the .bin bitstream file.
   If you want to perform logic analysis with Reveal Analyzer, continue with these steps:
8. Set up the cable connection with Programmer.
9. Download the design onto the device.
10. Start Reveal Analyzer and perform logic analysis with it.

Post-Synthesis Debug Flow
In post-synthesis debugging, it is required that you mark the specific signal objects that you want to monitor by adding the syn_rvl_debug synthesis attribute in the RTL source files. This allows you to keep track of these signals more easily as they are highlighted on the user interface. The syn_rvl_debug attribute is the same for both Synplify and LSE tools.

The syn_rvl_debug attribute performs two functions:
- This attribute highlights the signal so it can be easily identified in the user interface.
- After synthesis, this attribute tells the synthesis tool to preserve the signal without optimizing it. If it is a bus, the data width is also preserved. The synthesis tool passes the same attribute to the signal in the post-synthesis netlist (*.vm).

The syntax in Verilog/System-Verilog is:
/* synthesis syn_rvl_debug = 1 */;

The syntax in VHDL is:
attribute syn_rvl_debug : boolean;
attribute syn_rvl_debug of sig1 : signal is true

For example:
input clki /*synthesis syn_rvl_debug = 1 */,
wire clk1 /* synthesis syn_rvl_debug = 1 */;
reg [39:0] cnt /* synthesis syn_rvl_debug = 1 */;
reg [31:0] cnti /* synthesis syn_rvl_debug = 1 */;
The synthesis tool may add a suffix to the name of a signal with the syn_rvl_debug attribute. This change is minimal and the signal remains recognizable to the user.

The syn_rvl_debug attribute may be attached to top level input/output ports, which will be connected to the input/output buffers. In case of an input port with the syn_rvl_debug attribute, in the .vm file, the output of the input buffer should get the passed attribute. In case of an output port with attribute, in the .vm file, the input of the output buffer should get the passed attribute.

**Example 1**

RTL Code:

```verilog
input clki /* synthesis syn_rvl_debug = 1 */,
```

The expected output is:

```verilog
wire clki_c /* synthesis syn_rvl_debug = 1 */;
```

where `clki` is driving the input port of IB and `clki_c` is connected to the output port. This is similar in the output port:

```verilog
output dout /* synthesis syn_rvl_debug = 1 */,
```

The expected output is:

```verilog
wire dout_c /* synthesis syn_rvl_debug = 1 */
```

**Example 2**

RTL Code:

```verilog
reg [31:0] counter /*synthesis syn_rvl_debug = 1*/;
```

This is the expected .vm code when the exact signal name is preserved:

```verilog
wire [31:0] counter /*synthesis syn_rvl_debug = 1*/;
```

When the exact signal name cannot be preserved, some suffix(*) may be added.

```verilog
wire [31:0] counter_* /*synthesis syn_rvl_debug = 1*/;
```

**Example 3**

If the attribute is provided in the following way, it is applied to the last signal:

RTL Code:

```verilog
reg sig1, sig2, sig3 /*synthesis syn_rvl_debug = 1*/;
```
The expected .vm code is:

```vhdl
wire sig3 /*synthesis syn_rvl_debug = 1*/;
```

The synthesis tool may also expand/elaborate the RTL code if the attribute is attached to the states in the FSM. This depends on the type of encoding such as binary, one-hot and others.

Here is an example of highlighted signals attached with the syn_rvl_debug attribute.

**Figure 2: Marked Debug Signals**

![Image of highlighted signals](image)

**Note:**

Before you start post-synthesis debugging, make sure that there is no active .rvl project in your design. If there is, make it inactive. To change a file’s status to inactive, right-click the file in the File List view and choose Set as Inactive.

The following are the general steps in the Reveal Inserter Post-Synthesis debug flow.

1. After running synthesis, start Reveal Inserter.
2. In the Reveal Inserter Wizard, select Post-Synthesis as debug stage and click Finish.
   
   In the list of signals displayed in Reveal Inserter, the signals with the syn_rvl_debug attributes are highlighted for easy tracking.
3. Add and set up analyzer and controller modules, if needed.

**Note**

When Reveal Controller is used for switches in post-synthesis, make sure the signals are not driven by other signals in the design. Multiple driver issues produce an error in Place & Route.
4. Click the **Design Rule Check** button and fix errors, if needed.

5. Click the **Insert Debug** button.

6. In the Insert Debug to Design dialog box, select the modules to insert. Select **Activate Reveal file in design project** to include it in synthesis. This also sets other .rvl files as inactive.

7. Click **OK**. The .rvl file is listed in the File List pane under Debug Files.
   You will note that the Synthesize Design process bar now has a small white box to indicate that only Reveal is to be synthesized in post-synthesis stage.

8. Run **Synthesize Design**. Only the changes in Reveal are processed.
   In the Task Detail View, you will observe the added Post-Synthesis Reveal task in progress.

9. Map, place, and route the design.

10. Generate the bitstream file.
    If you want to perform logic analysis with Reveal Analyzer, continue with these steps:

11. Set up the cable connection with Programmer.

12. Download the design onto the device.

13. Start Reveal Analyzer and perform logic analysis with it.

**Input and Output Files**

The inputs to the Reveal Inserter flow are the following:

- VHDL, Verilog, and System Verilog files

Reveal Inserter generates the following files in the debug flow:

- Reveal Inserter project (.rvl) file, which contains the signal connections for each core and some settings for the debugging logic, such as maximum sequence depth and maximum event counter. The information in this file is statically set in Reveal Inserter and cannot be changed in Reveal Analyzer.

- Reveal Inserter settings (.rvs) file, which contains settings that can be dynamically changed without regenerating the debug logic. This information includes trigger units, comparison types, values, and trigger expressions. The information in this file is dynamically set in either Reveal Analyzer or in both Reveal Analyzer and Reveal Inserter.

- Reveal Inserter parameter (.rvp) file, which contains information needed for debug logic generation, is produced during the design implementation process.
Limitations

Reveal Inserter has the following limitations in the current release.

Unsupported VHDL, Verilog and System Verilog Features in Reveal Inserter

The following features that are valid in the VHDL, Verilog and System Verilog languages are not supported in Reveal Inserter when you use the RTL flow:

- Array types of two dimensions or more are not shown in the port or node section.
- Undeclared wires attached to instantiated component instances are not shown in the hierarchical design tree. You must declare these wires explicitly if you want to trace or trigger with them.
- Variables used in conditional statements like if-then-else statements are not available for tracing and triggering.
- Variables used in selection statements like the case statement are not available for tracing and triggering.
- If function calls are used in the array declaration, the actual size of the array is unknown to Reveal Inserter.
- Entity and architecture of the same design cannot be in different files.
- In Verilog, you must explicitly declare variables at the very beginning of a module body to avoid obtaining different results from various synthesis tools.
- In VHDL, you must declare synthesis attributes within an entity, not within an architecture, to avoid obtaining different results from various synthesis tools.
- Signals used in VHDL “generate” statements are not available for tracing and triggering.
- Signals that are VHDL user-defined enumerated types, integer type, or Boolean type are not available for tracing and triggering.
- Some signals in a System Verilog design appear in the signal hierarchy but are not available for triggering or tracing. These signals include:
  - Array types of two dimensions or more are not shown in the port or node section
  - Signals that are user defined enumerated types, integer type, byte/shortint/int/longint type
  - Signals that belong to typedef and interface

Syn_keep and Preserve_signal Attributes

In VHDL, always define the syn_keep and preserve_signal attributes as Boolean types when you declare them in your design. Synplify defines them as Boolean types, and Reveal Inserter will issue an error message if you define them as strings.
Signals Implemented as Hard Routes

Signals that are implemented as hard routes in the FPGA instead of using the routing fabric are not available for tracing or triggering. Examples are connections to IB and OB components. Many common hard routes are automatically shown as unavailable in Reveal Inserter, but some are not. If you select a signal for tracing or triggering that is implemented as a hard route, an error will occur during the synthesis, mapping, placement, or routing steps.

Dangling or Unconnected Nets

Dangling or unconnected nets in Verilog, System Verilog, or VHDL code are available for use with Reveal Inserter.

Synthesis Parameters

VHDL generics for synthesis must be added via HDL Parameters field in Project Properties. The current version does not support parameters via Command Line Options field in Synthesis Strategy setting.

Getting Started

After you create a project in the Radiant software, you can start Reveal Inserter and create a Reveal project. Or open an existing Reveal project for modification.

Starting Reveal Inserter

Reveal Inserter is started from the main window. Open the desired design project to have access to the tools.

To start Reveal Inserter:

- Do one of the following:
  - In the main window, choose Tools > Reveal Inserter.
  - In the toolbar, click the Reveal Inserter button.

Choose the debug flow in the Reveal Inserter Wizard and click Finish.

When Reveal Inserter opens, it shows the active Reveal project or, if there are no existing projects, Reveal Inserter creates one.
When Reveal Inserter opens a design, it must parse and statically elaborate it. In some cases, code successfully synthesized with some synthesis tools may be flagged as having an error when Reveal Inserter tries to open the design. In these cases, Reveal Inserter is interpreting the HDL code more strictly than the chosen synthesis tool. It is likely that the code would not synthesize with a different synthesis tool or would have other compliance issues.

To correct this problem, see the reveal_error.log file in the project directory. This file contains information and error messages that enable you to see any problems found in the design.

Creating a New Reveal Inserter Project

Before you can start Reveal Analyzer with a new .rva file, you need to be connected to your evaluation board with a download cable and have the board’s power turned on. The following steps can also be seen in Figure 3

To start Reveal Analyzer with a new file:

1. Issue the start command. To start:
   - For stand-alone in Windows, go to the Windows Start menu and choose Programs > Lattice Radiant Reveal > Reveal Logic Analyzer.
   - For stand-alone in Linux, go to a command line and enter the following:
     \[ <\text{Reveal install path}/bin/lin64/revealrva \]

     The Reveal Analyzer Startup Wizard dialog box appears.

2. If Reveal Analyzer opens with an existing file, choose File > Save As.
   The Save Reveal Analyzer File dialog box opens. Change the file name and click Save. You now have a new .rva file ready to work with.

3. In the Reveal Analyzer Startup Wizard dialog box, Select Create a new file (at the upper-left of the dialog box).
   The dialog box presents a few rows of boxes that need to be filled in. In the figure below, the numbers match up with the steps in this procedure and show where the boxes, buttons, and menus are for each step.

4. In the first second row, type in the base name of the file. The extension is added automatically.

5. If there are daisy-chained devices, select Multiple Device in JTAG Chain.

6. To the right of this row is a pulldown menu. Choose the type of cable that your board is connected to.

7. Select the port. The method depends on the cable type:
   - If USB, click Detect. Then choose from the active ports found. The following figure shows the row after choosing a USB type.
If parallel, select the port address. If it’s not one of the standard addresses given, select 0x and type in the hexadecimal address. Then click **Check** to verify that the connection is working. The following figure shows the row after choosing a parallel type.

8. If there are daisy-chained devices, click **Browse** in the XCF source row to find the XCF source file.

9. Click **Scan** to find the FPGA.

10. If there is more than one FPGA on your board, go to the “Debug device” menu and choose one that has a Reveal 📦 icon. The icon indicates the presence of a Reveal module.

11. Click **Browse** in the RVL source row to find the Reveal Inserter project (.rvl) file.

12. To add the new .rva file to the File List view, select **Import file into current implementation**. The .rva file works the same either way.

13. Click **OK**.
Opening an Existing Reveal Inserter Project

If you want to start with an existing file, you just need to have that .rva file in the design project. You need to be connected to the evaluation board only if you want to run a test and capture data.

To start Reveal Analyzer with an existing file:

1. Issue the start command. To start:
   - The stand-alone Reveal Analyzer in Windows, go to the Windows Start menu and choose Programs > Lattice Radiant Reveal > Reveal Logic Analyzer.
   - The stand-alone Reveal Analyzer in Linux, enter the following on a command line:
     
     ```bash
     <Reveal install path>/bin/lin64/revealrva
     ```
     
     The Reveal Analyzer Startup Wizard dialog box appears.
     
     If Reveal Analyzer opens with the .rva file you want to use, you’re ready to go. Otherwise continue with the following steps.

2. Select Open an existing file (in the lower part of the dialog box).
3. In the “File name” box, choose one of the available .rva files.
4. If the file you want is not in the menu, click Browse and browse to the desired .rva file.
5. Click OK.

Using the Reveal Controller Simulation Model

The Reveal Controller Simulation Model replicates the functionality of Reveal Controller in simulation.

To set up the Reveal Controller Simulation Model:

1. Choose Tools > Reveal Inserter to insert a reveal module into the design.
2. Run Synthesize Design to generate the reveal_workspace file.
   - If you insert Reveal Controller only, the tool will create the sim_src folder with the pre-synthesis Reveal generated source file under reveal_workspace.
   - If you insert Reveal Controller and Analyzer, the Reveal engine will not create the folder and no source files will be provided.
3. Click Tools > Simulation Wizard or click the icon in the toolbar.
4. In the Simulator Project Name and Stage dialog box, enter the project name.
Click **Next**.

5. In the Add and Reorder Source dialog box, select and add the source files from the sim_src folder.

   Click **Next**.

The following compiler directives are all enabled in the source file. You can use the OEM simulator or any stand-alone simulator to compile and simulate the Controller:

- `define en_sw
- `define en_led
- `define en_user_mem
- `define en_user_creg
- `define en_user_sreg

---

**Managing the Cores in a Project**

Each Reveal Inserter project can include multiple debug logic cores and one Reveal controller core. The core has its own settings for the debug logic, such as trace signals, trigger signals, sample clock, sample enable, and trigger output signal. These settings are called a dataset. In many cases, a single core is all that is required to debug a design.

When you open a new project, Reveal Inserter automatically adds the first debug logic core to the first dataset and gives it a name of `<top_module>_LA<number>`, where `top_module` is the name of the top module in the Reveal Inserter project, and `number` is a sequential number. The core name is case insensitive—for example, "core_LA0" is the same as "core_la0."

All Reveal cores are listed in the Dataset pane in the Reveal Inserter window.

---

**Note:**

For the Avant device, you need to add the PAR Strategy command line option "-exp WARNING_ON_PCLKPLC1=1" when using Reveal and JTAGH25 to avoid errors related to the jck_N clock.

---

**Renaming a Core**

You can rename a debug logic core if you want to change its initial name.
To rename a core or cores in a project:
1. Highlight the name of the core in the Dataset pane, and choose Debug > Rename Core, or right-click on the name of the core and choose Rename Core from the pop-up menu.
2. Type the new name of the module over the old name.

During the renaming process, Reveal Inserter verifies that:
- The core name begins with a letter and consists of letters, numbers, and underscores (_).
- The core name is not the same as that of any other core.
- The core name is not the same as that of any module or instance in the design.

Removing a Core
You can also remove a debug logic core.

To remove a core or cores from a project:
- Select the core in the Dataset pane, and choose Debug > Remove Core, or right-click on the name of the core and choose Remove Core from the pop-up menu.

Viewing Signals in the Design Tree Pane
In the Design Tree pane of the Reveal Inserter window, you can display the hierarchy of the whole design, including the ports and nodes in the top module and submodules, so that you can choose the signals to use for data tracing and triggering.

From the Design Tree pane, you can drag a signal to the upper half of the Trace Signal Setup tab to set it as a trace signal or drag it to the lower half of the tab to set it as a sample clock signal or a sample enable signal.

In the Design Tree pane, the names of trace, trigger, and control signals are in bold font if they are currently being used.

To view all signals in the design tree:
- Right-click on the design name in the Design Tree pane and choose Expand All from the pop-up menu.

To view the buses, ports, top-level signals, and top level of the hierarchy:
- Right-click on the design name in the Design Tree pane and choose Collapse All from the pop-up menu.
You can also view signals and buses in the Trace Data pane of the Trace Signal Setup tab.

**Searching for Signals**

You can search for a signal or signals and set the selected signals as trace signals, trigger unit signals, sample clock signals, or sample enable signals. You can search for signal names or patterns of characters.

**To search for a signal:**

1. In the Signal Search box in the Design Tree pane, enter the name of the signal or pattern to find. You can set a filter by using the case-insensitive alphanumeric characters and wildcards shown in the following table.

2. Click **Search**.

   - If Reveal Inserter finds only one signal, it highlights it in the Design Tree pane.
   - If Reveal Inserter finds multiple signals, it opens the Search Result dialog box to list all the signals found.

3. If you are searching for multiple signals, select the desired signals in the Search Result dialog box, and click **OK**.
   - Shift-click to select contiguous signals.
   - Control-click to select non-contiguous signals.

   The selected signals are now highlighted in the Design Tree pane.

From the Design Tree pane, you can drag signals to the Trace Data pane, the Sample Clock box, and the Sample Enable box in the Trace Signal Setup tab. You can also drag signals to the Signals (MSB:LSB) box in the Trigger Unit section of the Trigger Signal Setup tab.

Although the buses are displayed as “busname[n:m]” in the Design Tree pane, Reveal Inserter ignores the string after the bus name when it searches for buses. For example, if the design contains a bus called a[0:2], you can search for it by a pattern such as “a” or “a*,” but you cannot use a pattern such as “a[**].”

If a bus is named xyz, a search for xyz highlights the entire bus. A search for xyz* brings up the Search Result dialog box and all the individual signals in the xyz bus.
The following wildcards are supported in searches:

<table>
<thead>
<tr>
<th>Wildcard Character</th>
<th>Characters to Replace</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>?</td>
<td>Any single character</td>
<td>?a? is the middle character in a three-character string</td>
</tr>
<tr>
<td>*</td>
<td>Any sequence of characters</td>
<td><em>a</em> where the string contains the &quot;a&quot; character</td>
</tr>
<tr>
<td>[abc]</td>
<td>“a,” “b,” or “c”</td>
<td>[abc]* where the string begins with “a,” “b,” or “c”</td>
</tr>
<tr>
<td>[*abc]</td>
<td>Any character except “a,” “b,” or “c”</td>
<td>[<em>abc]</em> where the string does not begin with “a,” “b,” or “c”</td>
</tr>
<tr>
<td>[a-d]</td>
<td>Any character in the range of “a” through “d”</td>
<td>[a-d]* where the string begins with any character in the range of “a” through “d”</td>
</tr>
<tr>
<td>[*a-d]</td>
<td>Any character except those in the range of “a” through “d”</td>
<td>[<em>a-d]</em> where the string does not begin with any character in the range of “a” through “d”</td>
</tr>
</tbody>
</table>

**Setting Up the Trace Signals**

The first step in performing a logic analysis is to specify how the data from the trace bus will be captured. Use the Trace Signal Setup tab in the Reveal Inserter window to choose the signals from which to collect sample data in the selected core.

**Selecting the Debug Logic Core**

Before you configure the trace signals, select the debug logic core to configure in the Dataset pane. This is either the regular debug logic core or the controller core.

**Selecting the Trace Signals**

You can use either of two methods to select trace signals: dragging and dropping or using a search engine to find them. You can select up to 512 trace signals in each core.
To select trace signals by dragging and dropping:

- Select the desired signals in the Design Tree pane and drag them to the Trace Data pane in the Trace Signal Setup tab.

To select trace signals by using a search engine:

1. In the Signal Search box in the Design Tree pane, enter the name or pattern of the signal to find. You can set a filter by using case-insensitive alphanumeric characters and wildcards. See “Searching for Signals” on page 22 for information about the wildcards that you can use.
2. Click Search.
   - If Reveal Inserter finds only one signal, it highlights it in the Design Tree pane.
   - If Reveal Inserter finds multiple signals, it opens the Search Result dialog box to list all the signals found.
3. If you are searching for multiple signals, select the desired signals in the Search Result dialog box, and click OK.
   - The signals are now selected in the Design Tree pane.
4. Drag them to Trace Data pane in the Trace Signal Setup tab.

Viewing Trace Signals and Buses

In the Trace Data pane in the Trace Signal Setup tab, you can display the signals in buses or remove them from view.

To display all the signals in all the buses:

- Right-click in the Trace Data pane, and choose Expand All from the pop-up menu.

To hide all the signals in all the buses:

- Right-click in the Trace Data pane, and choose Collapse All from the pop-up menu.

To display all the signals in an individual bus:

- Right-click on the bus and choose Expand from the pop-up menu.

To hide all the signals in an individual bus:

- Right-click on the bus and choose Collapse from the pop-up menu.
Grouping Trace Signals into a Bus
You can group trace signals, buses, or both into a bus.

To group signals or buses into a bus or to add signals or buses to a bus:
1. In the Trace Data pane of the Trace Signal Setup tab, select the signals, buses, or both to be grouped.
2. Choose Debug > Group Trace Data.
3. Double-click the new bus and type in the desired name.

Ungrouping Trace Signals in a Bus
You can ungroup the signals or buses in a bus.

To ungroup the signals, buses, or both in a bus:
1. In the Trace Data pane in the Trace Signal Setup tab, select the signals, buses, or both to be ungrouped from the bus.
2. Choose Debug > UnGroup Trace Bus.

Removing Signals and Buses from the Trace Data Pane
You can remove signals from the Trace Data pane in the Trace Signal Setup tab.

To remove a signal or a bus from the Trace Data pane:
1. In the Trace Signal Setup tab, select the signals to be removed from the Trace Data pane.
2. Choose Debug > Remove Trace Data, or right-click and choose Remove from the pop-up menu. You can also press the Delete key.

Renaming a Bus
You can rename a bus.

To rename a bus:
1. In the Trace Data pane of the Trace Signal Setup tab, select the bus.
2. Choose Debug > Rename Trace Bus, or right-click and choose Rename from the pop-up menu.
3. Type the new name of the module over the old name.
Setting Required Sample Parameters

For each core, you must set the certain sample parameters for the trace signals.

To set the required sample parameters:

1. In the Sample Clock box in the Trace Signal Setup tab, type the name of the clock signal or drag the clock signal from the design tree shown in the Design Tree pane.

   **Note**

   On the board, make sure that the minimum sample clock frequency is at least that of the JTAG clock. If the sample clock speed is too slow, you will be unable to complete logic analysis with Reveal Analyzer.

   The sample clock frequency should be no more than 200 MHz.

2. In the Buffer Depth box, specify the size of the trace memory buffer.

   This parameter defines the number of trace bus samples that a core can capture. It can be set to a minimum of 16 or to powers of 2 from 16 to 65536. The buffer size is determined by the amount of embedded memory in the FPGA.

3. In the Implementation box, specify how the debug logic is to be implemented in the FPGA. You can choose one of the following:

   - EBR – Implements the debugging logic as embedded block RAM (EBR). This setting is the default.

4. In the Data Capture Mode box, select Single Trigger Capture or Multiple Trigger Capture. Single Trigger Capture is enabled by default.

5. If you choose Multiple Trigger Capture, you must also set the Minimum samples per trigger option, which specifies the minimum number of data samples to collect per trigger. The minimum is either 8 or 1/256 of the total buffer depth, whichever is greater. The maximum number of samples depends on the design.
Power-on Reset (POR) Debug

An automatic "trigger enable" signal must be built into the Reveal module to monitor POR functions. Before Reveal Analyzer starts, these functions happen immediately after the power-on of the test board. When the trigger enables signal transitions to "active," the module will watch for the trigger and collect samples. It is similar to clicking the Run button in Reveal Analyzer. When Reveal Analyzer starts, it loads and displays any data collected by the POR modules.

POR modules are not supported in iCE40UP devices.

To set a POR trigger enable:
1. In the POR Debug section, select Trigger Enable.
2. Find the POR trigger signal in the Design Tree view and drag it to the text box in the POR Debug section.
3. Choose whether the signal is Active High or Active Low.

Setting Sample Options

In addition to the required parameters, you can set options for the data sample.

Using a Sample Enable

A sample enable is an optional signal used to capture data only when the sample enable is active, either high or low. If you do not specify a sample enable signal, trace data is collected on every sample clock after the trigger.

You may want to use a sample enable in cases where you need to capture a lot of data, but the data is only important during certain times, not whenever the sample clock is running. In these cases, the sample enable is a "gate" that allows you to turn the capturing of data on and off. An example is a design that contains many different sections, but some sections only work during certain clock phases. You typically use a master clock and generate different signals for the phases. You could use one of the phases as the sample enable.

To set the sample enable:

- In the Sample Enable checkbox, indicate whether a sample enable signal is to be used. If you want to use a sample enable:
  a. Select the checkbox to indicate that a sample enable signal will be used. The checkbox is deselected by default.
  b. Enter the name of the sample enable signal in the box beneath the checkbox, or drag the signal from the Design Tree pane.
  c. In the box to the right of the signal name box, select either Active High, which means that trace data is captured when the sample
enable is high and the sample clock occurs, or **Active Low**, which means that trace data is captured when the sample enable is low and the sample clock occurs. Active High is the default.

Each sample shown in the trace buffer is only captured when the sample enable is active and there is a sample clock. Data samples can be discontiguous, unlike those in a normal data capture.

Additionally, it is possible that the actual trigger condition may occur when the sample enable is not active. This causes two changes from a normal data capture:

- The actual data values for the trigger condition may not be visible, because the data cannot be captured when the sample enable is inactive.
- Reveal Analyzer cannot accurately calculate the trigger point, since the trigger point may have occurred when the sample enable is inactive. Normally a trigger point is shown as a single marker on the clock on which the trigger occurred. If a sample enable is used, a trigger region that spans 5 clock cycles is shown instead. Reveal Analyzer can guarantee that the trigger occurred in this region, but it cannot determine during which clock cycle the trigger occurred.

The sample enable is a very useful feature, but it takes more understanding than a normal data capture.

**Adding Trigger Signals to Trace Signals**

You can add trigger signals to the trace signals so that the data from the trigger signals is included in the trace data. Tracing trigger signals increases the amount of logic used by the trace buffer.

**To add the trigger signals to the trace signals:**

- Select the **Include trigger signals in trace data** option. This option is turned off by default.

**Adding Time Stamps to Trace Samples**

In Reveal Inserter, you can optionally specify a sample clock count value to be stored with each trace sample to indicate the sample count clock value at which the sample was captured. This count is extra data (bits) captured into the trace buffer that increase the trace buffer's width. This time stamp enables you to see how many sample clock intervals have elapsed between data captures when you use a sample enable. It is useful in some cases when it is necessary to know if you captured the right data. A time stamp is also useful when you try to synchronize data between multiple cores, off-chip data, or both. For example, if you trigger two cores at the same time, you can use the time stamps on the trace samples to calculate how the data between the cores compares.
To add time stamps to the trace samples:

1. Select the Timestamp box in the Trace Signal Setup tab.

2. In the drop-down menu in the Bits box next to the Timestamp box, select the amount of trace memory storage needed by the time stamp, in bits.

   The number of bits for the timestamp is the number of bits in the maximum count of the timestamp. But each bit is equivalent to adding another signal to be traced, so the amount of trace memory needed is therefore much larger. The minimum number of bits that appears in the drop-down menu is obtained by multiplying the value in the Buffer Depth box by 2 and converting the result to an exponential value. For example, if the value in the Buffer Depth box is 256, the minimum number of bits in the Bits drop-down menu is calculated as follows:

   \[ 256 \times 2 = 512 \]

   \[ 512 = 2^9 \]

   So the minimum number of bits available in the Bits menu in this case is 9.

   The maximum number of bits available in the Bits menu is always 63.

### Setting Up the Trigger Signals

The Reveal software has some similarities to and some differences from external logic analyzers. An external logic analyzer typically offers up to a few dozen signals or channels and megabits worth of capture data depth. Internal or embedded logic analyzers have different constraints. An internal logic analyzer can offer thousands of signal connections, since no extra pins are required to connect to the signal. But the resources inside an FPGA force a limitation on the amount of data that can be captured, typically constrained to several thousand bits. This difference drives different requirements. An internal logic analyzer requires the ability to accurately pinpoint the desired event in order to capture a smaller amount of data around that precise event. The capabilities in the Reveal software are designed specifically for the triggering requirements of an internal logic analyzer.

### Triggering

With the Reveal software, it is easy to set up simple triggering conditions, as well as extremely complex triggers. Triggering in Reveal is based on the trigger unit and the trigger expression. A trigger unit is used to compare signals to a value, and a trigger expression is used to combine trigger units to form a trigger.

Some of Reveal’s triggering features are static and some are dynamic. Static features can only be changed in Reveal Inserter and require the design to be re-implemented by synthesis, map, place, and route. Although you can set most of the dynamic features in Reveal Inserter, you can change all dynamic
features when Reveal Analyzer is running, and you do not have to re-implement the design.

### Table 1: Where Trigger Features Can Be Changed

<table>
<thead>
<tr>
<th>Feature</th>
<th>Reveal Inserter</th>
<th>Reveal Analyzer</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Trigger Units</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Add</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Remove</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Name</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Signals</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Operator</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Radix</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Value</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Trigger Expressions</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Add</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Remove</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Name</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Expression</td>
<td></td>
<td></td>
</tr>
<tr>
<td>RAM type</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Maximum sequence depth</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Maximum event counter</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Single Trigger Capture</strong></td>
<td>Make available</td>
<td>✓</td>
</tr>
<tr>
<td><strong>Multiple Trigger Capture</strong></td>
<td>Make available</td>
<td></td>
</tr>
<tr>
<td>Number of samples per trigger</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Number of triggers</td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td><strong>Other Features</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>AND All versus OR All</td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Trace buffer depth</td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Timestamp</td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Trigger position</td>
<td></td>
<td>✓</td>
</tr>
</tbody>
</table>
Trigger Units
The trigger unit is used to compare a number of input signals to a value. A
number of different operators are available for comparison and can be
dynamically changed during analysis, along with the comparison value and
the trigger unit name.

You can change the signals in a trigger unit only in Reveal Inserter. Changing
the input signals requires the design to be re-implemented.

You can specify up to 16 trigger units for each debug core. A common
technique is to group associated input signals into a trigger unit. For example,
you might use a trigger unit for the address bus in a design, another for the
data bus, and another for the control signals.

Most of the trigger unit operators use standard logical comparisons between
the current value of the combined signals of the trigger unit and a specified
value. But some of the operators are unusual and need some explanation.

With the exception of “serial compare,” the operators can be changed in
Reveal Analyzer.

Standard Logical Operators
Reveal includes the following operators:

- `==` equal to
- `!=` not equal to
- `<` greater than
- `>` greater than or equal to
- `<` less than
- `<=` less than or equal to

Rising-Edge and Falling-Edge Operators
The “rising edge” and “falling edge” operators check for change in the signal
value, not the value itself. So the trigger unit’s specified value is a bit mask
showing which signals should have a rising or falling edge. A 1 means “look
for the edge;” a 0 means “ignore this bit.” A multiple-bit value is true if any of
the specified bits has the edge.

For example, consider a trigger unit defined as `cout[3:0]`, rising edge, 1110.
This trigger unit will be true only when `cout[3]`, `cout[2]`, or `cout[1]` have a rising
edge. What happens on `cout[0]` does not matter.

- `0000 > 1110`
- `0000 > 1111`
  True for the same reason. It does not matter whether `cout[0]` rises or not.
0000 > 0100
True because a rising edge on any of the specified bits is sufficient.

1000 > 1000

**Serial Compare**
The “serial compare” operator checks for a series of values on a single signal. For example, if a trigger unit’s specified value is 1011, the “serial compare” operator looks for a 1 on the first clock, a 0 on the next clock, a 1 on the next clock, and a 1 on the last clock. Only after those four conditions are met in those four clock cycles is the trigger unit true.

Serial compare is available only when a single signal is listed in the trigger unit’s signal list. The radix is automatically binary.

You can only set the serial compare operator in Reveal Inserter. You cannot change it or select it in Reveal Analyzer as you can the other operators.

**Trigger Expressions**
Trigger expressions are combinations of trigger units. Trigger units can be combined in combinatorial, sequential, and mixed combinatorial and sequential patterns. A trigger expression can be dynamically changed at any time. Each core supports up to 16 trigger expressions that can be dynamically enabled or disabled in Reveal Analyzer. Trigger expressions support AND, OR, XOR, NOT, parentheses (for grouping), THEN, NEXT, # (count), and ## (consecutive count) operators. Each part of a trigger expression, called a sequence, can also be required to be valid a number of times before continuing to the next sequence in the trigger expression.

**Detailed Trigger Expression Syntax**
Trigger expressions in both Reveal Inserter and Reveal Analyzer use the same syntax.

**Operators**
You can use the following operators to connect trigger units:

- & (AND) – Combines trigger units using an AND operator.
- | (OR) – Combines trigger units using an OR operator.
- ^ (XOR) – Combines trigger units using a XOR operator.
- ! (NOT) – Combines a trigger unit with a NOT operator.
- Parentheses – Groups and orders trigger units.
- THEN – Creates a sequence of wait conditions. For example, the following statement:
  
  TU1 THEN TU2

  means "wait for TU1 to be true, then wait for TU2 to be true."
The following expression:

\((TU_1 \& TU_2) \text{ THEN } TU_3\)

means “wait for TU1 and TU2 to be true, then wait for TU3 to be true.”

Reveal supports up to 16 sequence levels.

See **Sequences and Counters** below for more information on THEN statements.

- **NEXT** – Creates a sequence of wait conditions, like THEN, except the second trigger unit must come immediately after the first. That is, the second trigger unit must occur in the next clock cycle after the first trigger unit. See **Sequences and Counters** below for more information on NEXT statements.

- **# (count)** – Inserts a counter into a sequence. See **Sequences and Counters** below for information on counters.

- **## (consecutive count)** – Inserts a counter into a sequence. Like # (count) except that the trigger units must come in consecutive clock cycles. That is, one trigger unit immediately after another with no delay between them. See **Sequences and Counters** below for information on counters.

**Case Sensitivity**

Trigger expressions are case-insensitive.

**Spaces**

You can use spaces anywhere in a trigger expression.

**Sequences and Counters**

Sequences are sequential states connected by THEN or NEXT operators. A counter counts how many times a state must occur before a THEN or NEXT statement or the end of the sequence. The maximum value of this count is determined by the Max Event Counter value. This value must be specified in Reveal Inserter and cannot be changed in Reveal Analyzer.

Here is an example of a trigger expression with a THEN operator:

\(TU_1 \text{ THEN } TU_2\)

This trigger expression is interpreted as “wait for TU1 to be true, then wait for TU2 to be true.”

If the same example were written with a NEXT operator:

\(TU_1 \text{ NEXT } TU_2\)

it is interpreted as “wait for TU1 to be true, then wait *one clock cycle* for TU2 to be true.” If TU2 is not true in the next clock cycle, the sequence fails and starts over, waiting for TU1 again.

The next trigger expression:

\(TU_1 \text{ THEN } TU_2 \ #2\)
is interpreted as “wait for TU1 to be true, then wait for TU2 to be true for two sample clocks.” TU2 may be true on consecutive or non-consecutive sample clocks and still meet this condition.

The following statement:

`TU1 ##5 THEN TU2`

means that TU1 must occur for five consecutive sample clocks before TU2 is evaluated. If there are any extra delays between any of the five occurrences of TU1, the sequence fails and starts over.

The next expression:

`(TU1 & TU2)#2 THEN TU3`

means “wait for the second occurrence of TU1 and TU2 to be true, then wait for TU3.”

The last expression:

`TU1 THEN (1)#200`

means “wait for TU1 to be true, then wait for 200 sample clocks.” This expression is useful if you know that an event occurs a certain time after a condition.

You can only use one count (# or ##) operator per sequence. For example, the following statement is not valid, because it uses two counts in a sequence:

`TU1 #5 & TU2 #2`

Multiple count values are allowed for a single trigger expression, but only one per sequence. For two count operators to be valid in a trigger expression, the expression must contain at least one THEN or NEXT operator, as in the following example:

`(TU1 & TU2) #5 THEN TU2 #2`

This expression means “wait for TU1 and TU2 to be true for five sample clocks, then wait for TU2 to be true for two sample clocks.”

Also, the count operator must be applied to the entire sequence expression, as indicated by parentheses in the expression just given. The following is not allowed:

`TU1 #5 & TU2 THEN TU2 #2`

The count (#) operator cannot be used as part of a sequence following a NEXT operator. A consecutive count (###) operator may be used after a NEXT operator. The following is not allowed:

`TU1 NEXT TU2 #2`

The count (# or ##) operators can only be used in one of two areas:
> Immediately after a trigger unit or parentheses(). However, if the trigger unit is combined with another trigger unit without parentheses, a # cannot be used.

> After a closing parenthesis.

**Precedence**

The symbols used in trigger expression syntax take the following precedence:

> Because it inserts a sequence, the THEN and NEXT operators always take the highest precedence in trigger expressions.

> Between THEN or NEXT statements, the order is defined by parentheses that you insert. For example, the following trigger expression:

\[
TU_1 \land (TU_2 \lor TU_3)
\]

means “wait for either TU1 and TU2 or TU1 and TU3 to be true.”

If you do not place any parentheses in the trigger expression, precedence is left to right until a THEN or NEXT statement is reached.

For example, the following trigger expression:

\[
TU_1 \land TU_2 \lor TU_3
\]

is interpreted as “wait for TU1 & TU2 to be true or wait for TU3 to be true.”

> The precedence of the ^ operator is same as that of the & operator and the | operator.

> The logic negation operator (!) has a higher precedence than the ^ operator, & operator, or | operator, for example:

\[
!TU_1 \land TU_2
\]

means "not TU1 and TU2."

> The # and ## operators have the same precedence as the ^ operator, & operator, or | operator. However, they can only be used in one of two areas:

> Immediately after a trigger unit or trigger units combined in parentheses. However, if the trigger unit is combined with another trigger unit without parentheses, a # or ## operator cannot be used.

Here is an example of correct syntax using the count (#) operator:

\[
TU_1 \ #\ #\ #\ THEN\ TU_3
\]

This statement means “wait for TU1 to be true for two sample clocks, then wait for TU3.”

However, the following syntax is incorrect, because the count operator is applied to multiple trigger units combined without parentheses:

\[
TU_1 \land TU_2 \ #\ THEN\ TU_3
\]

> After a closing parenthesis. Use parentheses to combine multiple trigger units and then apply a count, as in the following example:

\[
(TU_1 \land TU_2) \ #\ THEN\ TU_3
\]

This statement means "wait for the combination of TU1 and TU2 to be true for two sample clocks, then wait for TU3."
Following is a series of examples that demonstrate the flexibility of trigger expressions.

**Example 1: Simplest Trigger Expression**
Following is the simplest trigger expression:

TU1

This trigger expression is true, causing a trigger to occur when the TU1 trigger unit is matched. The value and operator for the trigger unit is defined in the trigger unit, not in the trigger expression.

**Example 2: Combinatorial Trigger Expression**
An example of a combinatorial trigger expression is as follows:

TU1 & TU2 | TU3

This trigger expression is true when (TU1 and TU2) or TU3 are matched. If no precedence ordering is specified, the order is left to right.

**Example 3: Combinatorial Trigger Expression with Precedence Ordering**
In the following example of a combinatorial trigger expression, precedence makes a difference:

TU1 & (TU2 | TU3)

This trigger expression gives different results than the previous one. In this case, the trigger expression is true if (TU1 and TU2) or (TU1 and TU3) are matched.

**Example 4: Simple Sequential Trigger Expression**
Following is an example of a simple sequential trigger expression:

TU1 THEN TU2

This trigger expression looks for a match of TU1, then waits for a match on TU2 a minimum of one sample clock later. Since this expression uses a THEN statement, it is considered to have multiple sequences. The first sequence is “TU1,” since it must be matched first. The second sequence is “TU2,” because it is only checked for a match after the first sequence has been found. The “sequence depth” is therefore 2.

The sequence depth is an important concept to understand for trigger expressions. Since the debug logic is inserted into the design, logic must be used to support the required sequence depth. Matching the depth to the entered expression can be used to minimize the logic. However, if you try to define a trigger expression that has a greater sequence depth than is available in the FPGA, an error will prevent the trigger expression from running. The dynamic capabilities of the trigger expression can therefore be limited. To allow more flexibility, you can specify the maximum sequence depth when you set up the debug logic in Reveal Inserter. You can reserve more room for the trigger expression than is required for the trigger.
expression currently entered. If you specify multiple trigger expressions, each trigger expression can have its own maximum sequence depth.

**Example 5: Mixed Combinatorial and Sequential Trigger Expression**
Here is an example showing how you can mix combinatorial and sequential elements in a trigger expression:

TU1 & TU2 THEN TU3 THEN TU4 | TU5

This trigger expression only generates a trigger if (TU1 AND TU2) match, then TU3 matches, then (TU4 or TU5) match. You can set precedence for any sequence, but not across sequences. The expression (TU1 & TU2) | TU3 THEN TU4 is correct. The expression (TU1 & TU2 THEN TU3) | TU4 is invalid and is not allowed.

**Example 6: Sequential Trigger Expression with Sequence Counts**
The next trigger expression shows two new features, the sequence count and a true operator to count sample clocks:

(TU1 & TU2)#2 THEN TU3 THEN TU4#5 THEN (1)#200

This trigger expression means wait for (TU1 and TU2) to be true two times, then wait for TU3 to be true, then wait for TU4 to be true five times, then wait 200 sample clocks. The count (# followed by number) operator can only be applied to a whole sequence, not part of a sequence. When the count operator is used in a sequence, the count may or may not be contiguous. The always true operator (1) can be used to wait or delay for a number of contiguous sample clocks. It is useful if you knew that an event that you wanted to capture occurred a certain time after a condition but you did not know the state of the trigger signals at that time.

However, there is a limitation on the maximum size of the counter. This depends on how much hardware is reserved for the sequence counter. When you define a trigger expression, the Max Event Counter setting in the Trigger Expression section of Reveal Inserter and Reveal Analyzer specifies how large a count value is allowed in the trigger expression. Each trigger expression can have a unique Max Event Counter setting.

**Trigger Expression and Trigger Unit Naming Conventions**
You can rename trigger units and trigger expressions. The names can be a mixture of lower-case or upper-case letters, underscores, and digits from 0 through 9. The first character must be either an underscore or a letter. The names can be any length.
Adding Trigger Units

You can add trigger units only in Reveal Inserter. You cannot add them in Reveal Analyzer. You can change some of the trigger conditions defined in Reveal Inserter in Reveal Analyzer during hardware debugging.

All trigger units are automatically available for use in all trigger expressions defined.

Each core can support up to 16 trigger expressions. Each trigger unit consists of the following:

- Trigger unit name (label)
- Signals in the trigger unit
- Comparison function
- Radix of the trigger unit value
- Value of the trigger unit

To add a trigger unit:

1. If you want the buses in the new trigger units that you will add to have a certain radix by default, set that radix in the Default Trigger Radix box in the Trigger Unit section of the Trigger Signal Setup tab before you add any trigger units.

   Changing the trigger radix value does not affect any trigger units that were created before you made the change.

2. To add a new trigger unit, click Add in the Trigger Unit section of the Trigger Signal Setup tab.

   A line now appears in the Trigger Unit section, with a default trigger unit named TU<number>, where <number> is a sequential number. The first trigger unit is named TU1 by default.

Renaming Trigger Units

You can rename a trigger unit.

To rename a trigger unit:

- Double-click in the appropriate box in the Name column of the Trigger Unit section of the Trigger Signal Setup tab, backspace over the existing name, and type in the new name.
Setting Up Trigger Units

All signals must be defined for a trigger unit in Reveal Inserter. You cannot change them in Reveal Analyzer.

To set up a trigger unit:

1. If you want to change the default name of the trigger unit, backspace over the default name in the Name box in the Trigger Unit section of the Trigger Signal Setup tab and type the new name.

2. Specify the signals in the trigger unit:
   a. Double-click in the box in the **Signals (MSB:LSB)** column.
      
      The TU Signals dialog box appears.
   b. In the Select Signals box of the dialog box, highlight the signal or signals that you want to use in the trigger unit, and click > to move them to the box on the right. (Shift-click to select multiple signals.)
      
      Each trigger unit can have up to 256 signals. Since there are 16 allowable trigger units, each core can have a maximum of 4096 trigger signals.
   c. If you want to change the order of a signal in the list of signals, highlight its name and click the up arrow to move it up one line or the down arrow to move it down one line.
      
      The order of the signals affects how the comparison is performed.
   d. Click **OK**.

As an alternative to this procedure, you can drag and drop signals from the Design Tree pane to the Signals (MSB:LSB) box in a trigger unit.

If you want to select certain signals by using a search engine:

a. In the Signal Search box in the Design Tree pane, enter the name or pattern of the signal to find. You can set a filter by using case-insensitive alphanumeric characters and wildcards. See “Searching for Signals” on page 22 for information about the wildcards that you can use.

b. Click **Search**.

If Reveal Inserter finds only one signal, it highlights it in the Design Tree pane.

If Reveal Inserter finds multiple signals, it opens the Search Result dialog box to list all the signals found.

c. If you are searching for multiple signals, select the desired signals in the Search Result dialog box, and click **OK**.

   The signals are now selected in the Design Tree pane.

d. Drag them to Signals (MSB:LSB) box in the Trigger Unit section of the Trigger Signal Setup tab.

If you move the cursor over a trigger-unit line in the Signals box, the software displays a complete list of the signals in that trigger unit.
3. In the **Operator** column, set the comparators for the trigger condition. You can choose from the following states:

- `==` equal to
- `!=` not equal to
- `>` greater than
- `>=` greater than or equal to
- `<` less than
- `<=` less than or equal to
- Rising edge – compares on the rising edge of the clock
- Falling edge – compares on the falling edge of the clock
- Serial compare – compares until the trigger condition is met. For example, if the trigger condition is 10011, the serial compare option looks for a 1 on the first clock, a 0 on the next clock, a 0 on the next clock, a 1 on the next clock, and a 1 on the last clock. Only if those five conditions are met in those five clock cycles will the serial compare output be active.

The serial comparator is available only when a single signal is listed in the Trigger Unit signal list. If you choose this option, you must choose **Binary** in the Radix box.

You can only set the serial compare operator in Reveal Inserter. You cannot change it as you can other operators in Reveal Analyzer.

The default comparator is `==` (equal to).

For more information on the effect of the “Rising edge” and “Falling edge” operators, see “Triggering” on page 29.

Both the operator type and the trigger unit value can be changed in Reveal Analyzer during hardware debugging.

4. In the **Radix** column, set the radix of the trigger unit value given in the Value box by selecting a radix from the drop-down menu. You can choose one of the following:

- **Binary.** This is the default. You must choose Binary if you selected “Serial compare” as a comparator.
- Octal
- Decimal
- Hexadecimal
- `<token_set_name>`. To select `<token_set_name>`, information on these operators in Reveal Analyzer. See “Creating Token Sets” on page 81 for instructions on creating token sets.

5. In the **Value** column, enter the comparison value.

This value is the pattern of highs and lows that you want on the trigger unit that will initiate collection of the trace data. The default is binary, unless you selected `<token_set_name>` in the Radix column.
If you selected $<\text{token_set_name}>$ in the Radix column, a drop-down menu opens in the Value column. This menu lists all the tokens that you entered in the Token Manager dialog box for the chosen token set. Select any name. The only token sets available for a given bus must match the bit width of the bus. Other token sets will not be listed as choices for that bus.

You can use “x” for a don’t-care value in the Value column if you selected Binary, Octal or Hexadecimal in the Radix column and if you selected the $==, !=, \text{or serial compare operators}$ in the Operator column.

### Removing Trigger Units

You can remove trigger units in Reveal Inserter, but you cannot remove them in Reveal Analyzer.

**To remove a trigger unit:**

1. In the Trigger Unit section of the Trigger Signal Setup tab, click in any box in the line representing the trigger unit that you want to remove.
2. Click **Remove**.

### Adding Trigger Expressions

Trigger expressions are combinatorial or sequential equations of trigger units or both. Trigger expressions can be defined during insertion and changed in Reveal Analyzer. You can add up to 16 trigger expressions.

You can add trigger expressions only in Reveal Inserter. You cannot add them in Reveal Analyzer.

You can dynamically enable or disable individual trigger expressions before triggering is activated during hardware debugging.

**To add a trigger expression:**

- In the Trigger Expression section of the Trigger Signal Setup tab, click **Add**.

A line appears with the default trigger expression called TE$<\text{number}>$, where $<\text{number}>$ is a sequential number. The first trigger expression is named TE1 by default. You can rename the trigger expression by backspacing over the name and typing a new name.
Renaming Trigger Expressions

You can rename a trigger expression.

To rename a trigger expression:

- Double-click in the appropriate box in the Name column of the Trigger Expression section of the Trigger Signal Setup tab, backspace over the existing name, and type in the new name.

Setting Up Trigger Expressions

You set up the initial trigger expressions in Reveal Inserter, but you can change them and their names in Reveal Analyzer. You can also enable or disable trigger expressions in Reveal Analyzer. However, you cannot change the sequence depth, the maximum sequence depth, or the maximum event counter of the trigger expressions in Reveal Analyzer.

To set up a trigger expression:

1. If you want to change the default name of the trigger expression, backspace over the default name in the Name box in the Trigger Expression section of the Trigger Signal Setup tab and type the new name.

   You can also change the name of a trigger expression in Reveal Analyzer.

2. In the Expression box, enter the names of the trigger units and the operators that you want to use to connect them.

   You can use the following operators to connect trigger units:

   - & (AND) – Combines trigger units using an & operator.
   - | (OR) – Combines trigger units using an OR operator.
   - ^ (XOR) – Combines trigger units using a XOR operator.
   - ! (NOT) – Combines a trigger unit with a NOT operator.
   - Parentheses – Groups and orders trigger units.
   - THEN – Creates a sequence of wait conditions. For example, the following statement:
     
     TU1 THEN TU2
     
     means “wait for TU1 to be true,” then “wait for TU2 to be true.”

     The following expression:
     
     (TU1 & TU2) THEN TU3
     
     means “wait for TU1 and TU2 to be true, then wait for TU3 to be true.”

     Reveal supports up to 16 sequence levels.

     See “Triggering” on page 29 for more information on THEN statements.
REVEAL INserter: Setting Up the Trigger Signals

- NEXT – Creates a sequence of wait conditions, like THEN, except the second trigger unit must come immediately after the first. That is, the second trigger unit must occur in the next clock cycle after the first trigger unit. See “Triggering” on page 29 for more information on NEXT statements.

- # (count) – Inserts a counter into a sequence. See “Triggering” on page 29 for information on counters.

- ## (consecutive count) – Inserts a counter into a sequence. Like # (count) except that the trigger units must come in consecutive clock cycles. That is, one trigger unit immediately after another with no delay between them. See “Triggering” on page 29 for information on counters.

For more information on the precedence of these symbols in trigger expression syntax, see “Triggering” on page 29.

Reveal Inserter checks the syntax and displays the syntax in red font if it is erroneous.

Both the trigger units and operators associated with a trigger expression can be changed in Reveal Analyzer during hardware debugging.

3. From the drop-down menu in the Ram Type box, specify how the trigger expression is to be implemented in the debug logic. You can choose one of the following:

- EBR – Implements the trigger expression as embedded block RAM (EBR). Reveal Inserter calculates the appropriate number of EBRs. By default, the trigger expression is implemented as EBR.

The Sequence Depth box is read-only, so you do not need to enter data in this box.

4. From the drop-down menu in the Max Sequence Depth box, specify the maximum number of sequences, or trigger units connected by THEN operators, that can be used in a trigger expression.

You can choose 1, 2, 4, 8, or 16. Reveal supports up to 16 maximum sequence levels.

If the number in the Sequence Depth box is higher than that set in the Max Sequence Depth box, the number in the Max Sequence Depth box appears in red to indicate an error.

The Max Sequence Depth value is set statically in Reveal Inserter and cannot be changed in Reveal Analyzer.

5. From the drop-down menu in the Max Event Counter box, specify the maximum size of the count in the trigger expression (the count is how many times a sequence must occur before a THEN statement). You can choose 1 and powers of 2 from 2 to 65,536. The maximum is 65,536. The default is 1. If the largest counter value used in the trigger expression is larger than that set in the Max Event Counter box, the number in the Max Event Counter box appears in red.

You cannot change the Max Event Counter setting in Reveal Analyzer. You can only change it in Reveal Inserter.
You can also add a counter to the output of the final trigger from all the trigger expressions. This counter adds an option to the final trigger output that combines all the trigger expressions. It is similar to the AND All and OR All options in the Analyzer.

6. To add a counter to the output of the final trigger, do the following:
   a. Select the Enable final trigger counter checkbox in the lower left portion of the Trigger Signal Setup tab.
   b. From the drop-down menu in the Event Counter Value box, select the maximum size of the count of all the trigger expression outputs combined. You can choose powers of 2 between 2 and 65536.

Leaving the “Enable final trigger counter” option unselected is equivalent to setting the counter to a value of 1.

You can change the value of this parameter in Reveal Analyzer, but you cannot make the value bigger, so be sure to reserve enough space for the count that you think you will need.

7. If you want create a trigger-out signal, do the following in the Trigger Out section:
   a. Select the Enable Trigger Out option.
   b. If you want to create a net, type in the name of the signal that you want to use as the trigger output signal in the Net box.

   The default name of the trigger output signal is reveal_debug_<default_core_name>_net. An example is reveal_debug_count_LA0_net.
   c. In the Polarity box, select the polarity of the trigger output signal from the drop-down menu, either Active High or Active Low.
   d. In the “Minimum pulse width” box, enter the minimum pulse width of the trigger output signal, measured in cycles of the sample clock. You can input any value of 0 or greater as the minimum pulse.

Once you create a net as a trigger output signal, its name appears in the Trigger Output pane beneath the Design Tree pane.

**Removing Trigger Expressions**

You can disable a trigger expression from being used by deselecting the checkbox to the left of the trigger expression name in Reveal Analyzer, but you can remove a trigger expression only in Reveal Inserter.

**To remove a trigger expression:**

1. Click in any box in the line representing the expression that you want to remove.
2. Click Remove.
Setting Up Virtual Switch/LED Settings

The data pane consists of Virtual Switch/LED panels in which you drag and drop the RTL-defined switch and LED signals. A maximum of 32 bits can be selected for both Virtual Switch/LED signals.

To set up Virtual Switch/LED signals:

1. Select the top_Controller core in the Dataset view. (There can only be one Controller core.)
2. Click the Virtual Switch & LED Setup tab.
3. Select signals in the Design Tree by expanding the hierarchy or doing a name search in the Signal Search text box and clicking on Search.
4. Drag the desired signals to the Virtual Switch or LED data panels to the right. The width of the signals will automatically update between 1-32 entries at the top.
5. Beside the header title, Virtual Switch/LED Setting, there is a check box in which the Controller function for Virtual Switch/LED can be enabled/disabled.

Note

In order for this tab to display the Switch/LED names correctly and for the compilation tool flow to run through successfully, please use the Reveal Controller template from the Source Template Editor tool. See the help section: Entering the Design > HDL Design Entry > Using Templates.

Configuring User Memory Setup

Setting up the User Memory setting consists of assigning six mandatory ports (which must be defined in the user RTL design). The maximum data width is 32 bits.

The user design must include a memory block (EBR, Distributed Memory or PMI Memory) to be able set up User Memory.

The mandatory signals in the user design to set up User Memory are:

- Clock
- Clock_enable
- Wr_Rdn
- Address
- WData
- RData
To set up User Memory signals:

1. To select the top Controller core in the Dataset view, click on it. There can only be one Controller core. When you click on Add Controller, the control panel will appear. You can enable User Memory and connect to any lower-level hierarchy under the top-level, provided that all the ports are connected without any unconnected ports before and by selecting the corresponding memory port names. The Address and Data Width will be automatically updated.

2. Reveal Controller will add a mux between user logic and the Reveal Controller, which can be left blank or connected to the user logic. Once checked, click the User Memory Setup tab.

3. Select signals in the Design Tree and drag the signals to the desired position under Setting List in the User Memory Setup tab. As the pre-synthesis controller debug, no need to add any floating wires. For help finding signals see, “Searching for Signals” on page 22.

4. Drag the desired signals into the User Memory data panel to the right. You do not need to provide a clock if there is no user logic connected while the width of the signals will automatically update between 4-32 entries at the top.

5. Beside the title User Memory Setting, there is a check box in which the Controller function for User Memory signals can be enabled/disabled. If there is a noticeable reset port, it should be connected to an inactive reset signal so that it does not impact the controller functionality and it should not be in a floating state.
Configuring User Control Register Setup

The User Control Register Setup tab displays a table-like panel where you can enable the Control Register. The Control Register address ranges from 0x81000000 up to 0x810000f8.

You can add up to 32-address locations with a maximum data-width of 8-bit. If the signal has a data width greater than 8, it splits into 8-bit per address location with a unique label.

The user design must include the control registers as wires, which should not have any other drivers. They should be treated as asynchronous switches as they are changed with the JTAG clock.

These signals are read-writable from the controller.
To set up User Control Register:

1. Click the **User Control Register Setup** tab.

To set up User Control Register:

1. Click the **User Control Register Setup** tab.

2. Click the **Add** button. By default, a unique label is assigned to the Name column. You can edit this label by double-clicking it.

3. Drag-and-drop the corresponding signals from Design View to the **Control Signals** column.

   Or

4. Select the existing row and double-click the Control Signals column. The **Edit Signals** dialog box appears.

5. In the Edit Signals dialog box, do the following:
   a. Choose signals from the **Select Signals** pane.
   b. Click the forward button to move the signals to the right-hand pane.
   c. Change the order of the signals as desired.
   d. Click **OK**.

6. If you wish to delete a row from the Control Signals column, click the **Remove** button to delete the selected row.
Configuring User Status Register Setup

The User Status Register Setup tab displays a table-like panel where you can enable the Status Register. The Status Register address ranges from 0x81001000 up to 0x810010f8.

You can add up to 32-address locations with a maximum data-width of 8-bit. If the signal has a data width greater than 8, it splits into 8-bit per address location with a unique label.

The user design must include status registers as wires, which should be driven by registers to show the status of the different functional blocks of the design. These signals are read-only.

To set up User Status Register:

1. Click the User Status Register Setup tab.

2. Click the Add button. By default, a unique label is assigned to the Name column. You can edit this label by double-clicking it.

3. Drag-and-drop the corresponding signals from Design View to the Status Signals column.

Or

4. Select the existing row and double-click the Status Signals column. The Edit Signals dialog box appears.
5. In the Edit Signals dialog box, do the following:
   a. Choose signals from the Select Signals pane.
   b. Click the forward button to move the signals to the right-hand pane.
   c. Change the order of the signals as desired.
   d. Click OK.
6. If you wish to delete a row from the Status Signals column, click the Remove button to delete the selected row.

Configuring Hard IP Setup

The Hard IPs are automatically extracted from the RTL design and displayed in the data pane.

For the Inserter, the starting addresses for the IPs as shown is only for informational purpose. The addresses can be experimented in the Analyzer.

To set up Hard IP:

1. Click the Hard IP Setup tab.
2. Select Controller function for Hard IPs for analysis by enabling check boxes.

When implementing Reveal Controller for Hard IPs of PCS and PCIE, the implementation will not remove the user logic but will mux it with Reveal Controller logic. The following information explains this process:

- The user logic will access the LMMI interface and be active in the beginning of design for functions like link state machine. After that, the function needs to be inactive.
- When Reveal Controller gets access to the LMMI registers, it will select the mux during that time only. When there is no Reveal read/write command, it will de-select the mux.

Checking the Debug Logic Settings

Reveal Inserter automatically checks the settings of the debug logic before saving the project or inserting the debug logic cores, but you may want to check them independently beforehand. With one DRC command (Debug > Design Rule Check), you can verify the following:

- The core names begin with a letter and consist of letters, numbers, and underscores (_).
- A core name is not the same as that of any other core.
- The core name is not the same as that of any module already defined in the design.
The number of cores is between 1 and 15.
The number of trace signals is between 1 and 512.
The number of trigger signals is between 1 and 4096.
The number of trigger units and trigger expressions is between 1 and 16.
The number of trigger signals in a trigger unit is between 1 and 256.
A sample clock is specified.
The sample clock signal is a 1-bit signal already defined in the design.
A sample enable is specified.
The sample enable signal is a 1-bit signal already defined in the design.
The name of the trigger-out signal is given if this signal is enabled.
The name of the trigger-out signal is not the same as any signal already defined in the design.
The number of EBRs needed does not exceed the number available.
The design includes an input signal.
The syntax of the trigger expressions is correct.
The trigger expression sequence is less than or equal to the maximum sequence.
The trigger output signal is specified, if the Enable Trigger Out option is enabled.
The trigger output signal is not the same as the name of any signal in the design.
The values of the trigger unit are correct.
The names of the trigger units and the trigger expressions conform to the guidelines given in the “Trigger Expression and Trigger Unit Naming Conventions” on page 37.
The bit widths of the token values are the same as the bit widths of the trigger unit signals.

To check the logic debugging settings:

Choose **Debug > Design Ruler Check** or click ![ ] in the toolbar.

The results of the check are displayed in the Message tab. The Message tab also displays the total resource utilization, as in the following example:
The number of EBRs needed is 2.
Saving a Project

Once you set the debug options, save the project so that the project information is saved in an .rvl and an .rvs file. Reveal Inserter automatically performs a design rule check before it saves these files.

When you select Debug > Insert Debug or click the button, Reveal Inserter saves the project information in an .rvl and an .rvs file.

Note

Reveal Inserter generates a “signature” or tracking mechanism each time that debug logic is inserted into the design. The signature is placed into the project file and into the debug logic. Reveal Analyzer reads this signature to ensure that the FPGA has been programmed with the latest debug logic. Reveal Inserter generates a new signature every time the .rvl file is written, and Reveal Analyzer checks this signature each time that it runs the design. If you save the project in Reveal Inserter without re-running the implementation process, Reveal Analyzer issues an error message, even if the debug logic was not changed.

To save the project settings in the current directory:

- Choose File > Save or click in the toolbar to save the project in .rvl and .rvs files in your current directory.

To save the project settings in another directory:

- Choose File > Save As to save the project in .rvl and .rvs files in a directory other than the current directory. In the Select Project dialog box, browse to the desired directory, enter the name of the .rvl file in the File Name box, select .rvl in the Files of Type box, and click Save.

Inserting the Debug Logic Cores

When you finish setting up the trace and trigger signals, you can insert the Reveal modules into the design.

Note

Interactive and stand-alone synthesis are not compatible with Reveal modules. Reveal Inserter automatically uses the integrated synthesis option. Make sure your design project is set up for integrated synthesis if not done already.

To insert the debug logic modules into the design:

1. Choose Debug > Insert Debug.
2. In the Insert Debug to Design dialog box, select the modules to insert.
3. Select Activate Reveal file in design project.
   - If the .rvl file is not active in the design project, the Reveal modules will not be included during synthesis.
4. Click **OK**.

   Reveal Inserter performs a design rule check and saves the Reveal (.rvl) file. The Output view shows resource requirements and the DRC report for the modules. The .rvl file is listed in the File List pane under Debug Files.

5. Implement the design in the usual way.

**Removing Debug Logic from the Design**

You may want to remove the debug logic cores in pre-production versions of your device to free block RAM resources and LUT-based logic and to expand the design. If you want to remove the debug logic cores from your design, you must remove the .rvl file or set it as inactive. Otherwise, the cores will continue to be inserted.

**To remove the debug logic cores from the design:**

1. In the File List view, highlight the .rvl file and right-click.

2. Do one of the following:
   - To remove the Reveal modules but keep the project, choose **Set as Inactive**.
   - To delete the Reveal project, choose **Remove**.

The .rvl file is now removed from the design.

**Closing a Project**

**To close a Reveal Inserter project:**

- Choose **File > Close**.

**Exiting Reveal Inserter**

**To exit Reveal Inserter:**

- Click in the Reveal Inserter tab.
Performing Logic Analysis with Reveal Analyzer

After you have created your design project database with the Radiant software, generated a debug logic/controller core with Reveal Inserter, mapped, placed, and routed your design, and downloaded the design to the evaluation board, you can perform a logic analysis with Reveal Analyzer. Refer to “Reveal Analyzer” on page 67 for more information about performing logic analysis.

Using JTAGhub

A JTAGhub is a module that contains a JTAG core, which is either hard or soft, and around it is soft logic. A hard JTAG core wrapped by soft logic is a hard JTAGhub. A soft JTAG RTL core wrapped by soft logic is a soft JTAGhub.

In Nexus, a hard JTAGhub is referred to as JTAGH19 and a soft JTAGhub is called JTAGH19SOFT. In Avant, a hard JTAGhub is referred to as JTAGH25 and a soft JTAGhub is called JTAGH25SOFT. In pre-synthesis, you can have a maximum of 19 connected cores in Nexus and 25 connected cores in Avant. For details on the actual cores usable by Reveal or open to user instantiation and those reserved for certain other applications, refer to “JTAGhub Addressing Scheme” on page 61 and “JTAGhub CORES” on page 62.

In Reveal Inserter, JTAGhub is treated as a primitive which can be instantiated directly in user RTL.

Note

You can have several Reveal debug cores but only one controller core in your design.

There can only be one hard JTAG in a design. So if there are multiple hard JTAGhub instances, all these are merged by the post-synthesis utility. Multiple soft JTAGhubs, with or without merging, are acceptable.

A JTAGhub, either soft or hard is inserted as a black-box by Reveal Inserter for normal debugging and treated as a primitive for synthesis. It is added to the synthesis header file as a black-box. The logic is not optimized by the synthesis tool. The user can also manually instantiate the JTAGhub in the design.

Hard JTAGhub – Merged

If there is already one hard JTAGhub in the design and the user inserts another hard JTAGhub in Reveal, then the two hard JTAGhubs are merged.

On the other hand, there can be multiple soft JTAGhub instances in a design. These soft JTAGhubs may or may not be merged. Each soft JTAGhub needs four I/O ports and a JTAG cable.
This is an example of two soft JTAG instances that are merged. In this example, all the JTAG ports are connected. TDISOFT, TCKSOFT, TMSSOFT and TDOSOFT are the top-level ports of the design. If the user needs to insert Reveal debugger, then the user must use TDISOFT, TCKSOFT, TMSSOFT, TDOSOFT as the top level port names.
By merging JTAGhubs, only one set of I/O pins is required and only one set of logic is involved. Since merging minimizes logic resources, the design utilizes a minimal number LUTs.

**Figure 6: Soft JTAGhub - Merged**

![Soft JTAGhub - Merged Diagram]

**Soft JTAGhub – Not Merged**

This is an example of two soft JTAGhub instances that are not merged. In this diagram, the TDI, TCK, TMS, and TDO ports are connected to their corresponding top-level ports. The design has two independent sets of soft JTAG ports that are connected to two different cables. Hard JTAG is used for both programming and debugging. Both of these operations can be performed using the same cable and connection. Note that this is not true for soft JTAG.
Support for BYPASS Instruction in Soft JTAGhub

In JTAG, the BYPASS register is a single-bit pass-through register that connects the TDO and the TDI ports.

The user can create SOFT JTAGhub chains wherein the TDO port of the first device is connected to the TDI port of the next device. The TCK and TMS ports are all connected together.

Up to 22 devices can be linked in one chain. These devices can be Avant only, Nexus only, or a mix of the two. BYPASS instruction allows the other devices in the JTAG chain to be tested with minimal overhead.

Notes

- Designs generated in Lattice Propel can use hard JTAG, soft JTAG, or a mix of the two types, depending on the processor. If there are two processors, two independent debugging GDBs are used. In some devices, however, Propel can use only one soft JTAGhub.

- The JTAG primitive and JTAGH19/JTAGH25 cannot co-exist in a design. Likewise, JTAGA and JTAGH19SOFT/JTAGH25SOFT cannot be added together in one design. These result in an error.
JTAGhub Input and Output Ports

In JTAGhub, the standard TCK, TMS, TDI, and TDO ports are connected to the I/Os and go off-chip. All the other ports are connected to the FPGA fabric. When multiple sets of JTAGhubs are in the same design, all the JTAG ports are unique. Each set connects to one JTAG cable.

<table>
<thead>
<tr>
<th>Signal</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>TDI</td>
<td>Data shifted into the test or programming logic of the device.</td>
</tr>
<tr>
<td>TCK</td>
<td>Signal that synchronizes the internal state machine operations. In JTAG, TCK is not like a regular clock. It is pulsed when data is transmitted/received.</td>
</tr>
<tr>
<td>TMS</td>
<td>Signal sampled at the rising edge of TCK to determine the next state.</td>
</tr>
<tr>
<td>TDO</td>
<td>Data shifted out of the test or programming logic of the device.</td>
</tr>
<tr>
<td>JTCK</td>
<td>Signal similar to TCK and controlled by IP_ENABLE and ER2_TDO.</td>
</tr>
<tr>
<td>JTDI</td>
<td>Signal similar to TDI and controlled by IP_ENABLE and ER2_TDO.</td>
</tr>
</tbody>
</table>
A soft JTAGhub uses four GPIO ports with locate constraints. Hard JTAGhub pins are fixed in the device.

The TDI, TCK, TMS and TDO ports can be connected to the top-level of the user design.

The user or the tools must connect top-level ports to the TDI, TCK, and TMS of the JTAGhub. The TDO port may be connected to the top-level port for synthesis and may not be connected to the top-level port for simulation to avoid having multiple drivers.

If simulation is not required, it is recommended that the TDI, TCK, TMS input ports be tied to low and the TDO be unconnected.

**Notes**

- For debug cores inserted by Reveal Inserter, there is no support for simulation.
- For netlists generated in System Builder and Propel, it is possible to simulate the user design.
- Encrypted source files for JTAGH19/JTAGH25 and JTAGH19SOFT/JTAGH25SOFT are provided to compile and run the simulation. In an Avant project, the models will also be available in the OEM simulator.
JTAGhub Ecosystem

In a typical design, several Reveal debug cores and, normally, only one Reveal controller core may be present. There may likewise be user design logic and one or more RISC-V cores. These can all be connected to one JTAGhub and can communicate with the JTAG one at a time.

The JTAG cable connects to the machine with the Debug Analyzer and Reveal Controller tools. To set parameters and connectivity, the user can use the interface or run Tcl commands since these are all standard JTAG protocol commands. The RISC-V GDB debugging protocol can also be included. All these communicate with the cableserver, then the device driver, and onto the device through the JTAG cable.

Figure 9: JTAGhub Ecosystem

JTAGhub Usage and Design Examples

This section provides some examples of how JTAGhub is used in a design and recommendations for debugging. A general rule is to avoid using both hard and soft JTAGhubs if using only one cable. With multiple cables, hard and soft JTAGhubs can be mixed in the design.

Note: A design with RISC-V does not necessarily come from Propel.

Example 1. The design has no existing JTAGhub
In this case, the user can insert either a hard JTAGhub or a soft JTAGhub.

Example 2. The design contains one RISC-V with hard JTAGhub
In this case, the user should use hard JTAGhub for Reveal debugging with just one cable. If soft JTAG is used for Reveal debugging, another cable is required.

Example 3. The design contains one RISC-V with soft JTAGhub
In this case, the user should use soft JTAGhub for Reveal debugging. The soft JTAGhubs are merged and only one cable is required.

**Example 4. The design contains two RISC-V cores with hard JTAGhub**

In this case, the user should use hard JTAGhub for Reveal debugging. The hard JTAGhubs are merged and only one cable is required.

**Example 5. The design contains two RISC-V cores with soft JTAGhub**

In this case, the user should use soft JTAGhub for Reveal debugging.

**Example 6. The design contains one RISC-V with hard JTAGhub and the user instantiates another one hard JTAGhub**

In this case, the three hard JTAGhubs are merged and the user should use hard JTAGhub for Reveal debugging.

**Example 7. The design contains one RISC-V with soft JTAGhub and the user instantiates another one soft JTAGhub**

In this case, the three soft JTAGhubs are merged and the user should use soft JTAGhub for Reveal debugging.

**Example 8. The design contains multiple RISC-V cores with independent soft JTAGhubs**

In this case, the user must use multiple cables, one for each RISC-V processor and its associated soft JTAGhub.

**JTAGhub Addressing Scheme**

The following addressing scheme is used to address the individual cores from the Cableserver clients (Reveal Debug, Controller, RISCV GDB, User Instance - Avant). If the user manually instantiates JTAGhub in the design, it is recommended to use only CORE-17 and CORE-18.

The address length is 24 bits for Nexus and 32 bits for Avant.

<table>
<thead>
<tr>
<th>Address</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Nexus</strong></td>
<td></td>
</tr>
<tr>
<td>Bit[23]</td>
<td>Bit[23]</td>
</tr>
<tr>
<td>Bit[22:4]</td>
<td>19 bits for IP_ENABLE[18:0], one-bit for each core. To enable a core, the IP_ENABLE bit of that core is set high and other IP_ENABLE bits are set low.</td>
</tr>
<tr>
<td>Bit[2:0]</td>
<td>3-bit control, value of 6 means read</td>
</tr>
<tr>
<td><strong>Avant</strong></td>
<td></td>
</tr>
<tr>
<td>Bit[29]</td>
<td>Bit[29]</td>
</tr>
</tbody>
</table>
**JTAGhub CORES**

**Example Commands**

To enable read of the ID of a CORE

```markdown
! enable ER1
SIR 8 TDI (32); // 8-bit data with hex value 32
! set reveal core
SDR 24 TDI (800006); // 24-bit data with hex value 800006
```

To enable a CORE (CORE0 n this case)

```markdown
! enable ER1
SIR 8 TDI (32);
SDR 24 TDI (000016);
```

This table lists the CORE hex values for Nexus and Avant devices. In Nexus, CORE17 and CORE18 are open to any user instantiation. In Avant, CORE17 to CORE 24 are cores open to any user instantiation.

<table>
<thead>
<tr>
<th>Nexus</th>
<th>Avant</th>
</tr>
</thead>
<tbody>
<tr>
<td>CORE17 =&gt; SDR 24 TDI (200006);</td>
<td>CORE17 =&gt; SDR 32 TDI (00200006);</td>
</tr>
<tr>
<td>CORE18 =&gt; SDR 24 TDI (400006);</td>
<td>CORE18 =&gt; SDR 32 TDI (00400006);</td>
</tr>
<tr>
<td>CORE19 =&gt; SDR 32 TDI (00800006);</td>
<td></td>
</tr>
<tr>
<td>CORE20 =&gt; SDR 32 TDI (01000006);</td>
<td></td>
</tr>
<tr>
<td>CORE21 =&gt; SDR 32 TDI (02000006);</td>
<td></td>
</tr>
<tr>
<td>CORE22 =&gt; SDR 32 TDI (04000006);</td>
<td></td>
</tr>
<tr>
<td>CORE23 =&gt; SDR 32 TDI (08000006);</td>
<td></td>
</tr>
<tr>
<td>CORE24 =&gt; SDR 32 TDI (10000006);</td>
<td></td>
</tr>
</tbody>
</table>
Setting Parameters and Connectivity

When Reveal Inserter inserts a core, it sets the HUB_* value as “0b1” and connects the IP_ENABLE bit and the ER2_TDO bit.

Examples:

- For any user instantiation, the settings and connections are as follows for CORE-17
  
  ```
  parameter HUB_17 = "0b1";
  IP_ENABLE[17] is connected to the IP_ENABLE input port of the core.
  ER2_TDO[17] is connected to the ER2_TDO output port of the core.
  ```

- For any user instantiation, the settings and connections are as follows for CORE-18
  
  ```
  parameter HUB_18 = "0b1";
  IP_ENABLE[18] is connected to the IP_ENABLE input port of the core.
  ER2_TDO[18] is connected to the ER2_TDO output port of the core.
  ```

JTAG BYPASS Instruction in SOFTJTAG Chain

JTAG BYPASS instruction allows you to reduce overhead by passing over devices in a chain that do not need to be involved in the current action. These devices remain in functional mode but allow data to flow through to the next device in the chain. When debugging, you can also use BYPASS instruction to isolate what may be offending devices in the chain.

You can build a SOFTJTAG chain of Nexus devices, Avant devices, or a mix of both Nexus and Avant devices. Radiant supports up to 22 devices in a single chain.

The TDO port of the first device is connected to the TDI port of the next device in the chain. The TCK and TMS ports are connected together.
Each device with softJTAG interface can be debugged in Reveal when connected in a chain. For example, if multiple devices are connected in a chain, a specific target device can be selected to be debugged. You can mix hardJTAG and softJTAG interfaces as long as they are connected in a chain. The softJTAG interface only has access to the FPGA fabric and that is how debugging is done.

**Note:**

The softJTAG interface does not have access to configuration logic, so there are no programming and scanning functions.

**To scan debug devices in a chain with hardJTAG and softJTAG interfaces:**

1. Scan the devices in Radiant Programmer tool. The hardJTAG interface will be used in scanning these devices. Open Radiant Programmer and choose **Run > Scan Device**. The tool scans and lists the devices in a new .xcf file.

2. If there are devices connected in the chain using softJTAG interface, manually add these devices using **Edit > Add Device**.
3. Create the .xcf file. This .xcf file will be common for all the Reveal projects.

4. Open Reveal Analyzer and create a new project.

5. In the Reveal Analyzer/Controller Startup Wizard, select the Multiple Device in JTAG Chain option.

6. In the XCF source row, click **Browse** to locate and load the .xcf file that you created in Step 2.

7. In the Debug device row, click **Scan** to find the FPGA device.

**Note:**

Always load the .xcf source file before running scan. If you do not specify the .xcf source file, there will be an error message.
User Interface Descriptions

The Reveal Inserter window appears when you first choose Tools > Reveal Inserter or click on the 📈 icon.

The Reveal Inserter window includes the following features:

**Dataset pane**  Lists the cores in the current dataset. You debug a design with Reveal Inserter debug logic, using a certain sample clock. If you want to debug a multi-clock design, you can create a core for each sample clock region. These cores are listed in the Dataset pane. This pane can be detached as a separate window and can be hidden using the View menu.

**Design Tree pane**  Lists all the buses and signals in the design. The names of trace, trigger, and control signals are in bold font if they are currently being used.

One of the following strings appears after each signal name to indicate its use:

- @Tc indicates that the signal is a trace signal.
- @Tg indicates that the signal is a trigger signal.
- @C indicates that the signal is a control signal.

Similarly, one of the following strings appears after each bus name to indicate its use:

- @Tc indicates that all the signals in the bus are used only as trace signals.
- @Tg indicates that all the signals in the bus are used only as trigger signals.
- @Tc, Tg indicates that all the signals in the bus are used as trace signals and trigger signals. It also appears if all the signals are used as trigger signals and none of the signals in the bus are used as control signals and you selected the “Include trigger signals in trace data” option.
- @Mx indicates the following:
  - At least one signal in the bus is used as a control signal.
  - Some signals in the bus are used both as trigger signals and as other kinds of signals.
  - Some signals in the bus are used both as trace signals and as other kinds of signals, except that all the signals are used as trigger signals, none of the signals are used as control signals, and you selected the “Include trigger signals in trace data” option.

If you select or deselect the “Include trigger signals in trace data” option, the signal and bus names are immediately updated in the Design Tree pane. If you set a signal as a trigger signal and select the “Include trigger signals in trace data” option, the use of the signal is displayed as Tc, Tg, even though you did not drag the signal name to the Trace Data pane.

If you select a signal in the hierarchy, the Signal Information tab at the bottom of the Reveal Inserter window displays information about how it is used.
You can enlarge the width of this pane to see longer signal names by dragging the splitter at the right edge of the pane. This pane can be detached as a separate window and can be hidden using the View menu.

**Signal Search box** Enables you to search for a signal or a group of signals. You can enter a signal name or pattern. You can set a filter by using the case-insensitive alphanumeric characters and wildcards described in “Searching for Signals” on page 22.

If Reveal Inserter finds only one signal, it highlights it in the Design Tree pane. If it finds multiple signals, it opens the Search Signals dialog box to list all the signals found. When you click OK, the selected signals are highlighted in the Design Tree pane. From the Design Tree pane, you can drag signals to the Trace Data pane, the Sample Clock box, and the Sample Enable box in the Trace Signal Setup tab. You can also drag signals to the Signals (MSB:LSB) box in the Trigger Unit section of the Trigger Signals Setup tab.

**Trigger Output pane** Displays the names of the trigger output signals defined in the Trigger Out box in the Trigger Signal Setup tab.

This field displays the trigger output signals for all but the first core and only those output signals for which NET or BOTH were chosen. From the Trigger Out Nets box, you can drag the signal names to the top half of the Trace Signal Setup tab. This pane can be detached as a separate window and can be hidden using the View menu.

**Trace Signal Setup**

Activates the Trace Signal Setup tab.

**Trigger Signal Setup**

Activates the Trigger Signal Setup tab.

**Trace Data pane**

Displays the selected trace signals in the Trace Signal Setup tab.
Reveal Analyzer

Logic analyzers enable you to view signal information to debug design functionality. With external logic analyzers, you connect to pins on a board, set one or more trigger conditions, and sample and view collected data. Internal logic analyzers, such as Reveal Analyzer, depend on additional logic placed into the design for triggering and tracing, then transferring the data to a PC, usually through a JTAG connection, for viewing and analysis.

Reveal Inserter handles the task of inserting debug logic into your design. Before using Reveal Analyzer, you must use Reveal Inserter to allow debug access.

Reveal Analyzer enables you to configure trigger settings and extract information from a programmed device through the JTAG ports. It interfaces directly to the Reveal cores in the design. You can set up triggers, select capture modes, and run or stop the triggers. Reveal Analyzer displays the data captured on the silicon according to the settings that you specify.

Reveal Analyzer’s graphical user interface enables you to view the trace data of a signal or bus in a waveform viewer.

Although an evaluation board is normally required to run Reveal Analyzer, Reveal Analyzer includes a demonstration design that you can run without the evaluation board so that you can learn how to use the tool.

Reveal Analyzer requires the Programmer programming software to configure the specified device. The acquired data is displayed in the waveform viewer.

You can export waveform data to a value change dump (.vcd) file, which can be imported by such third-party tools as ModelSim or Active-HDL. You can also output a file in ASCII tabular format for exporting the data into other tools such as Excel.
About Reveal Analyzer

This section introduces some of the key features of Reveal Analyzer: the devices that it supports, the steps in its design flow, its inputs, and its outputs.

Reveal On-Chip Debug Design Flow

The following figure shows the Reveal insertion and logic analysis design flow.

Figure 13: Reveal Design Flow

Before accessing Reveal Analyzer, you must install a Lattice Semiconductor or USB download cable and a power supply between your computer and the evaluation board. Refer to “Connecting to the Evaluation Board” on page 71 for information on this procedure.

You do not need to install a cable and a power supply if you want to run the demonstration design that comes with Reveal Analyzer so that you can learn how to use the tool.

You must also have a design project that has had on-chip debug logic inserted by the Reveal Inserter software.

The general steps involved in performing a logic analysis are the following:

1. Start Reveal Inserter.
2. Configure the trace and trigger signal settings in Reveal Inserter.
3. Insert the debug logic with Reveal Inserter.
5. Map, place, and route the design.
6. Generate the bitstream data (.bin file).
7. Set up a cable connection.
8. Download the design onto the device by using Programmer.
9. Start Reveal Analyzer.
10. Create a new Reveal Analyzer project or open an existing one.
11. Configure the trigger settings for each core in each device that you want to use to perform logic analysis of the design.
12. Click the Run button to perform the logic analysis, and wait for the design to trigger and download the trace information into Reveal Analyzer from the board.
13. View the resulting waveforms for each core.
14. Optionally, you can export the waveform data for each core in a value change dump (.vcd) file for use in third-party tools or in an ASCII-format text (.txt) file.

Inputs
Reveal Analyzer requires the following as input:

- A design project
- A Reveal Analyzer settings (.rvs) file, which is output by Reveal Inserter or Reveal Analyzer. It contains all the dynamically changeable trigger settings, such as trigger unit operators, trigger unit values, and any trigger expressions.
- An existing Reveal Inserter project (.rvl file), which contains the connections for each core and all the static settings of the debugging logic. The information in this file is statically set in Reveal Inserter and cannot be changed in Reveal Analyzer.

A Reveal Analyzer project (.rva) file, which is the project file output by Reveal Analyzer in a previous session. It contains the information used by Reveal Analyzer, such as window settings, waveform trace signal positions, radixes, markers, and signal colors.

Outputs
Reveal Analyzer generates the following files:

- A Reveal Analyzer project (.rva) file, which contains the information such as window settings, waveform trace signal positions, radixes, markers, and signal colors. This file is also an input file when you re-open a project that you previously saved.
- A Reveal Analyzer trace (.trc) file, which contains the waveform information acquired from previous runs of Reveal Analyzer. When you first open Reveal Analyzer, the waveform displays this information until
you press the Run button. If the debug signals have been changed from a previous Reveal Analyzer run, incorrect information is displayed in the waveform when it is first opened. Once a run has been completed, the waveform contains valid information with the changed debug configuration.

- Optionally, a value change dump (.vcd) file, in which you can export waveform data for display in third-party tools such as ModelSim and Active-HDL. The .vcd file is an ASCII file containing header information, variable definitions, and variable value changes. Its format is specified by the IEEE 1364 standard.

- Optionally, an ASCII-format text (.txt) file, in which you can export waveform data for display in third-party tools such as ModelSim and Active-HDL. The .txt file is in a simple ASCII character-tab-delimited format. It includes a header line with the signal names, then each line contains the value for each signal, one line per each sample clock.

**Inserting the Debug Logic**

Before performing logic analysis with Reveal Analyzer, you must use Reveal Inserter to generate the debug logic and insert it into your design. You must also set up the trace and trigger signals to be used in Reveal Inserter.

**Mapping, Placing, and Routing the Design**

Once you build and translate the design, you map, place, and route the design.

To map, place, and route the design:

1. Double-click the **Map Design** process in the Process view.
2. Double-click the **Place & Route Design** process in the Process view.

All core clock pins must be located and driven by valid signals for successful hardware debugging.

**Generating a Bitstream File**

Now you generate a bitstream (.bin) file, as appropriate, to download into the device.

To generate a bitstream file:

- Double-click the **Export Files** process in the Process view.

  This process creates a .bin file that is ready for downloading into the device.
Connecting to the Evaluation Board

Reveal Analyzer requires that a Lattice Semiconductor parallel port cable or USB download cable and a power supply be installed between your computer and the evaluation board so that you can program the device with Programmer.

To connect the evaluation board to your computer:
1. Install a driver for the download cable, if it has not been previously installed.
2. Reboot your computer, if the driver was not previously installed.
3. Attach the parallel port or USB cable to the parallel port or USB port of your system.
4. Plug in the AC adapter to a wall outlet, and plug the other end into the power jack provided on the evaluation board.

Note
You should follow the handling and power-up advice provided in the Lattice Semiconductor device evaluation board documentation when using the evaluation board.

5. In the Radiant software, choose Tools > Programmer.
6. The Cable Setup Window view is default open.
7. Click Detect Cable button.
8. Attach the JTAG connector cable to the appropriate JTAG programming header of the evaluation board. See the device evaluation board documentation for details.

Refer to the Programmer Help for more information about your cable connection.

Downloading a Design onto the Device

To download a design onto the device, use Programmer. This process creates a scan chain configuration (.xcf) file. Reveal Analyzer derives the information in the downloaded design directly from the device on the board.

To download the design onto the device:
1. In Programmer, select File > New.
   A new programmer project window appears, enter Filename.
2. Click on Detect Cable button.
3. If there are multiple cables, select one from the Multiple Cables Detected dialog drop down list.
4. Click the ... button under File Name section.
5. Select the <design_name>.bin file, and click Open.


7. Click OK to close the Device Properties dialog box.

8. Choose Run > Program Device, or click the Program Device button on the toolbar.

   After a few moments, the download and programming activity will end. A green PASS button appears in the Status field.

9. Select File > Save Project As to save the configuration setup as an .xcf file.

10. The .xcf file must reside in the design project directory for Reveal Analyzer to use it. In the File Name box in the dialog box that appears, type in <design_name>.xcf, and click Save.


See the Programmer Help for detailed instructions on the downloading process.

---

**Starting Reveal Analyzer**

Before starting Reveal Analyzer you need to decide if you want to work with a new Reveal Analyzer (.rva) file or an existing one. The .rva file defines the Reveal Analyzer project and contains data about the display of signals in the LA Waveform view. You may want to start Reveal Analyzer with a new file to set up a new test. Start with an existing file to rerun a test, to set up a new test based on existing settings, or to just view the waveforms from an earlier test. (See “Starting with an Existing File” on page 74.)

How you start Reveal analyzer also depends on whether you are using it integrated with the Radiant software or using the stand-alone version, and on your operating system.
Starting with a New File

Before you can start Reveal Analyzer with a new .rva file, you need to be connected to your evaluation board with a download cable and have the board’s power turned on.

To start Reveal Analyzer with a new file:

1. Issue the start command:
   - For integrated with the Radiant software, go to the Radiant software main window and choose **Tools > Reveal Analyzer**.
   - For stand-alone in Windows, go to the Windows Start menu and choose **Programs > Lattice Radiant Reveal > Lattice Reveal Logic Analyzer**.
   - For stand-alone in Linux, go to a command line and enter the following:
     ```
     <Reveal install path>/bin/lin64/revealrva
     ```

2. If Reveal Analyzer opens with an existing file, choose **File > Save <file> As**.
   The Save Reveal Analyzer File dialog box opens. Change the filename and click **Save**. You now have a new .rva file ready to work with.

3. (Stand-alone only) In the Reveal Analyzer Startup Wizard dialog box, browse to the implementation directory. This is where the Reveal Inserter project (.rvl) file should be and where the .rva file will be created.

4. In the Reveal Analyzer Startup Wizard dialog box, select **Create a new file** (at the upper-left of the dialog box).
   The dialog box presents a few rows of boxes that need to be filled in.

5. In the next row, type in the base name of the file. The extension is added automatically.

6. To the right of this row is a drop-down menu. Choose the type of cable that your board is connected to.
   Another row in the dialog box changes to select the port.

7. Select the specific port. The method depends on the port type:
   - If USB, click **Detect**. Then choose from the active ports found. The following figure shows the second row after choosing a USB type.

   ![USB port selection](image)

   - If parallel, select the port address. If it’s not one of the standard addresses given, select **0x** and type in the hexadecimal address. Then click **Check** to verify that the connection is working. The following figure shows the second row after choosing a parallel type.
8. Click **Browse** in the RVL source row to find the Reveal Inserter project (.rvl) file.

9. To add the new .rva file to the File List view, select **Import file into current implementation**. (Not available in stand-alone.) The .rva file works the same either way.

10. Click **OK**.

**Starting with an Existing File**

If you want to start with an existing file, you just need to have that .rva file in the design project. You need to be connected to the evaluation board only if you want to run a test and capture data.

**To start Reveal Analyzer with an existing file:**

1. Issue the start command. To start:

   ▶ In the Radiant software main window, choose **Tools > **Reveal Analyzer.**

   ▶ The stand-alone Reveal Analyzer in Windows, go to the Windows Start menu and choose **Programs > Lattice Radiant Reveal > Lattice Reveal Logic Analyzer.**

   ▶ The stand-alone Reveal Analyzer in Linux, enter the following on a command line:

     ```bash
     <Reveal install path>/bin/lin64/revealrva
     ```

     If Reveal Analyzer opens with the .rva file you want to use, you’re ready to go. Otherwise continue with the following steps.

2. (Stand-alone only) In the RevealAnalyzer Startup Wizard dialog box, browse to the implementation directory. This is where the Reveal Inserter project (.rvl) file and where the .rva file should be.

3. In the Reveal Analyzer Startup Wizard dialog box, select **Open an existing file** (in the lower part of the dialog box).

4. In the “File name” box, choose one of the available .rva files.

5. If the file you want is not in the menu, click **Browse** and browse to the desired .rva file.

6. To add the new .rva file to the File List view, select **Import file into current implementation**. (Not available in stand-alone.) The .rva file works the same either way.

7. Click **OK**.
If the connection to your evaluation board has changed, either in the cable type or the computer port used, you need to tell Reveal Analyzer about the new connection. See “Changing the Cable Connection” on page 75.

Changing the Cable Connection

If you need to change how your evaluation board is connected to your computer, go ahead and make the change. Then go through the following procedure to change the Reveal Analyzer project.

To change the cable setting in a Reveal Analyzer project:
1. Make sure your evaluation board is connected and that its power is on.
2. If Reveal Analyzer is not already open, start it as described in “Starting with an Existing File” on page 74.
3. Choose Design > Cable Connection Manager.
   The Cable Connection Manager dialog box opens.
4. In the dialog box, choose the cable type.
   The second row in the dialog box changes to select the specific port.
5. Select the specific port. The method depends on the port type:
   - If USB, click Detect. Then choose from the active ports found.
   - If parallel, select the port address. If it’s not one of the standard addresses given, select 0x and type in the hexadecimal address. Then click Check to verify that the connection is working.
6. To change the clock speed of the cable connection, adjust the value of TCK Low Pulse Width Delay.
7. Click OK.

Selecting a Reveal Analyzer Core

After you have created a project, each Reveal core in the design will have a Reveal Analyzer window available to set triggers and view captured data. To display a Reveal Analyzer core:
   - Choose the only core from the check box. Only one core is supported.
Setting Up the Trace Signals

Although you can add trace signals only in Reveal Inserter, you can set radixes for them by using the LA Waveform tab.

Setting the Trace Bus Radix

You can set the radix of a trace bus displayed in the LA Waveform tab. You can choose a binary, octal, decimal, or hexadecimal radix. You can also use any token set whose bit width matches the bus.

To set the bus radix of a signal bus:
1. In the LA Waveform tab, select one or more buses.
   To select one bus, click on it. To select more than one, Control-click on each one. To select all buses in a range, click on one end of the range and Shift-click the other end. If you want to change all the signals in the waveform to the same radix, you do not need to select anything.
2. Right-click in one of the selected waveforms and choose Set Bus Radix.
   Be careful to click in the same row as one of your selections, or you will change the selection.
   The Set Bus Radix dialog box opens.
3. In the drop-down menu, choose the radix or token set.
4. In the Range drop-down menu, choose Selected signals or, if you want to change all the signals in the waveform to the same radix, choose All signals.
5. Click OK.

Adding Time Stamps to Trace Samples

In the Reveal Inserter, you can optionally specify a sample clock count value to be stored with each trace sample to indicate the sample count clock value at which the sample was captured. This count is extra data (bits) captured into the trace buffer that increase the trace buffer’s width. This time stamp enables you to see how many sample clock intervals have elapsed between data captures when you use a sample enable. It is useful in some cases when it is necessary to know if you captured the right data. A time stamp is also useful when you try to synchronize data between multiple cores, off-chip data, or both. For example, if you trigger two cores at the same time, you can use the time stamps on the trace samples to calculate how the data between the cores compares.

See Adding Time Stamps to Trace Samples in the Reveal Inserter Help for information on adding time stamps to trace samples in Reveal Inserter.
Setting Up the Trigger Signals

Before you perform logic analysis, you must define the conditions under which the trigger will start or stop the collection of data on the trace signals specified in Reveal Inserter. You must define these triggers for each core. Use the LA Trigger tab of the Reveal Inserter window to specify the trigger units and trigger expressions that start the collection of the sample data for the selected core. In Reveal Analyzer, you cannot add or remove new trigger units or trigger expressions, but you can change the values and operators in the trigger units and trigger expressions. In addition, you can disable a trigger expression from being used by clearing the checkbox to the left of the trigger expression name. You must make sure in Reveal Inserter that all signals that you might want to trigger on are included in the trigger units. In addition, you may want to create several trigger expressions ahead of time.

Renaming Trigger Units

You can rename a trigger unit.

To rename a trigger unit:

- Click in the appropriate box in the Name column of the Trigger Unit section of the LA Trigger tab, backspace over the existing name, and type in the new name.

Setting Up Trigger Units

All signals for a trigger unit must be defined in Reveal Inserter. You cannot change them in Reveal Analyzer.

To set up a trigger unit:

1. If you want to change the default name of the trigger unit, backspace over the default name in the Name column and type the new name.

2. If you want to add, change, or remove the signals in the Signals (MSB:LSB) column, you must add, change, or remove them in Reveal Inserter. You cannot add, change, or remove signals in Reveal Analyzer.

3. In the Operator column, set the comparators for the trigger condition. You can choose from the following states:
   - == equal to
   - != not equal to
   - > greater than
   - >= greater than or equal to
   - < less than
   - <= less than or equal to
   - Rising edge – compares on the rising edge of the clock
Falling edge – compares on the falling edge of the clock

Serial compare – compares until the trigger condition is met. For example, if the trigger condition is 10011, the serial compare option looks for a 1 on the first clock, a 0 on the next clock, a 0 on the next clock, a 1 on the next clock, and a 1 on the last clock. Only if those five conditions are met in those five clock cycles will the serial compare output be active.

Other operators cannot be changed to a serial compare, and a serial compare cannot be changed to another operator in Reveal Analyzer. These can only be changed in Reveal Inserter.

The serial comparator is available only when a single signal is listed in the Trigger Unit signal list. If you choose this option, you must choose Binary in the Radix box.

The default comparator is == (equal to).

4. In the **Radix** column, select a radix from the drop-down menu to set the radix of the trigger bus value given in the Value box. You can choose one of the following:
   - Binary. This is the default. You must choose Binary if you selected “Serial compare” as a comparator.
   - Octal
   - Decimal
   - Hexadecimal
   - `<token_set_name>`: To select `<token_set_name>`, you must have created token sets in Reveal Inserter. See the Reveal Inserter Help for information on this procedure.

5. In the **Value** column, enter the comparison value.

   This value is the pattern of highs and lows that you want on the trigger unit that will initiate collection of the trace data. The default is binary, unless you selected `<token_set_name>` in the Radix column.

   If you selected `<token_set_name>` in the Radix column, a drop-down menu opens in the Value column. This menu lists all the tokens that you entered in the Token Manager dialog box for the chosen token set. Select any name.

   You can use "x" for a don’t-care value in the Value column if you selected Binary, Octal or Hexadecimal in the Radix column and if you selected the ==, !=, or serial compare operators in the Operator column.
Renaming Trigger Expressions

You can rename a trigger expression.

To rename a trigger expression:

- Click in the appropriate box in the Name column of the Trigger Expression section of the LA Trigger tab, backspace over the existing name, and type in the new name.

Setting Up Trigger Expressions

You must set up the initial trigger expressions in Reveal Inserter, but you can change their names and some values in Reveal Analyzer. You can also enable or disable trigger expressions in Reveal Analyzer. However, you cannot change the sequence depth, the maximum sequence depth, or the maximum event counter of the trigger expressions in Reveal Analyzer.

To set up a trigger expression:

1. To enable a trigger expression, click the checkbox in the Enable column.
2. In the Expression box, enter the names of the trigger units that you want to use and the operators that you want to use to connect them.

   You can use the following operators to connect trigger units:
   - & (AND)
   - | (OR)
   - ^ (XOR)
   - ! (NOT)
   - Parentheses
   - THEN
   - NEXT
   - # (count)
   - ## (consecutive count)

   See “Triggering” on page 29 for information on these operators.

Reveal Analyzer checks the syntax and displays the syntax in red font if it is erroneous.

The setting in the Sequence Depth box is set by the software, so it is read-only. See “Triggering” on page 29 for more information on this parameter.

3. If you want to change the setting in the Max Sequence Depth box, you must change it in Reveal Inserter; you cannot change it in Reveal Analyzer. The number of sequences in the Trigger Expression box cannot exceed the number specified in the Max Sequence Depth box.
4. If you want to change the setting in the **Max Event Counter** box, you must change it in Reveal Inserter; you cannot change it in Reveal Analyzer.

5. In the POR Debug section, if you wish to connect POR when Analyzer opens, click the **Connect POR when Analyzer opens** check box.

6. Specify whether the final trigger occurs when one or all of the conditions specified by the trigger expressions is met before trace data is captured:
   - **AND All** indicates that the conditions specified by all the trigger expressions must be met before the trace data is captured.
   - **OR All** indicates that the conditions of one of the trigger expressions must be met before the trace data is captured. This option is the default.

   Only trigger expressions whose checkboxes are enabled are included in the AND or OR.

**Setting Trigger Options**

You can set a number of options to control the triggering.

1. **To set trigger options in Reveal Analyzer:** In the **Samples Per Trigger** box, select the number of samples to collect per trigger. The minimum is 16. The maximum is the trace buffer depth chosen in Reveal Inserter when the core is generated. The values available in the Samples Per Trigger box also change according to the number of triggers. If the number of triggers is set higher than 1, the samples per trigger multiplied by the selected number of triggers cannot exceed the trace buffer depth. Reveal Analyzer adjusts the Samples Per Trigger value, if necessary. The default number of samples per trigger is the sample buffer depth. For example, if the sample buffer depth is 2048, the default sample per trigger is 2048.

2. In the **Number of Triggers** box, select the trace buffer depth divided by the samples per trigger. The trace buffer depth is specified by the setting of the Buffer Depth parameter in the Trace Signal Setup tab in Reveal Inserter. The default is 1.

3. In the **Trigger Position** field, select **Pre-selected Position** or **User-selected Position**.
Creating Token Sets

You can create sets of “tokens,” or text labels, for values that might appear on trace buses. You can create tokens such as ONE, TWO, THREE, or Reset, Boot, Load. Tokens can make reading the waveforms in Reveal Analyzer easier and can highlight the occurrence of key values. See the following figure for an example. The row for the chstate bus uses tokens.

To create or modify a token set:

1. Choose Design > Token Set Manager.

   The Token Manager dialog box opens. If the Reveal project already has token sets defined, they are listed in the dialog box.

2. If you want to use token sets that were previously saved to a separate file, right-click in the dialog box and choose Import. In the Import Tokens dialog box, browse to the token (.rvt) file and click Open.

   The token sets in the .rvt file are added to the list in Token Manager.

3. To create a new token set, click Add Set.

   A new token set is started with default values. But it has no tokens defined yet.

4. To change the size of the token values, double-click the value in the Num. of Bits column and type in the new width, in bits. The width can be up to 256. The width must be the same as the bus that the token set will be used with.

   The Num. of Bits value can only be changed when the token set is empty. If there are any tokens, you will get an error message.

5. To create a new token, select a token set. Then click Add Token.

   A new token is created with default values. Repeat for as many new tokens needed.

6. You can modify token sets by doing any of the following:

   ▶ To change the name of a token or token set, double-click the name and type a new name. The name can consist of letters, numbers, and underscores (_). It must start with a letter.
To change the value of a token, double-click the value and type in a new value. Token values must be prefixed by one of the radix indicators shown in the following table:

<table>
<thead>
<tr>
<th>Radix</th>
<th>Prefix</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Binary</td>
<td>b'</td>
<td>b'110x0</td>
</tr>
<tr>
<td>Octal</td>
<td>o'</td>
<td>o'53</td>
</tr>
<tr>
<td>Decimal</td>
<td>d'</td>
<td>d'123</td>
</tr>
<tr>
<td>Hexadecimal</td>
<td>h'</td>
<td>x'0F2</td>
</tr>
</tbody>
</table>

If a value does not have a prefix, its radix is assumed to be binary. You can use an "x" in binary numbers as a don't-care value.

To remove a token or token set, select it. Then click **Remove**.

7. You can save the collection of token sets showing in the dialog box to a separate file for use in another project. To save the token sets, right-click and choose **Export**. In the Export Tokens dialog box, browse to the desired location and type in the name of the new token (.rvt) file. Click **Save**.

8. When you are done, click **Close** to close the dialog box. The token sets are automatically applied to the current Reveal project.

### Debugging with Reveal Controller

Reveal Controller is another divide-and-conquer mechanism for you to emulate an otherwise unavailable environment for power debug. For example, your evaluation board would only have a limited number of LEDs or switches but the virtual environment enables up to 32 bits. Register memory mapping and dumping of values is also easily manifested while visibility into Hard IPs is also enabled.

### Virtual LED Switch Console

Once Reveal Analyzer is set up and started, you are presented with three tabs, the first of which is a virtual LED/Switch console to emulate the board.

The top section, Virtual LED shows all the LEDs that were defined in the insertion stage. Once the board is running, you can see the LEDs flash in red and green as they would in the real hardware environment.

The lower section shows the virtual switch in which you can either enter the data as a hex value or can set the virtual dip switches.
Select Direct Mode to see the data and switches in real time instead of waiting until the Apply button is clicked.

**Note**

Switches are of type in/out. When defining switches in RTL, use the WIRE definition otherwise multiple input driver errors will be encountered later in the flow.

**User Memory Analysis**

The second tab is for User Memory Analysis. The title indicates the range of the User Memory map. Analysis follows no particular steps or order.

- Default Data: A value that will initialize all memory locations.
- Write Address/Data: Address and data in hex to be written.
- Read Address/Data: Enter address. The data is read back when ‘Read’ is selected.
- Memory File: You can dump from/to a range of memory addresses to a .mem file. A user can also **Load MemFile** to load a pre-configured memory file.

**Running User Control Register**

1. In the **User Control Register** tab, select a label from the **Name** column, then click the **Rd** button.

   User Control Register reads the value of the corresponding address location and executes the following TCL command:

   ```
   rva_run_controller -read_control "label"
   ```

2. Select a label from the **Name** column.

3. In the **WR Value** column, do the following:
   a. Enter desired value.
   b. Click the **Wr** button.

   User Control Register executes the following TCL command:

   ```
   rva_run_controller -write_control "label" -data value
   ```
4. Double-click a row in the **Control Signals** column to display the list of signals with their corresponding value.

5. In the User Control Register tab, click the **Apply All** button to apply the value of all address locations assigned by the Name column and execute multiple TCL commands sequentially.

6. Click the **Read All** button to read the value of all address locations assigned by the Name column and execute multiple TCL commands sequentially.

7. Click the **Load** button to load the value from the register file to all address locations of Control Register.

8. Click the **Dump** button to save the value of all address locations to a register file.

### Running User Status Register

1. In the **User Status Register** tab, select a label from the **Name** column, then click the **Rd** button.

   User Status Register reads the value of the corresponding address location and executes the following TCL command:

   ```
   rva_run_controller -read_status "label"
   ```
2. On the bottom left corner, click the Read All button.

   The Read All button reads the value of all address locations assigned by the Name column and executes multiple TCL commands sequentially.

3. On the bottom right corner, click the Dump button.

   The Dump button saves the value of all address locations to a register file.

4. Double-click a row in the Status Signals column to display the list of signals with their corresponding value.

**Hard IP Debug**

All the IP selected for analysis in Reveal Inserter are displayed here.

Main operations are reading/writing to memory locations.

**Note**

The detailed settings of each IP is beyond the scope of this help. Links will be provided to Application Notes to explain its usage.
Running Reveal Eye-Opening Monitor

The Reveal Eye-Opening Monitor can be launched from the Reveal Analyzer/Controller. You need to be connected to a board to be able to run the Eye-Opening Monitor.

To launch the Eye-Opening Monitor:

1. In the Radiant software main window choose **Tools > Reveal Analyzer/Controller**
   
   In the drop-down menu, choose **top_Controller** to display the **Hard IP** tab.

2. Click the **Hard IP** tab.
   
   If debugging a non-Avant device, scroll down to the PCS channels to locate the **Eye-Opening Monitor** button.

   If debugging an Avant device, the **Eye-Opening Monitor** button is located at the upper-right of the current IP instance.

3. Click the **Eye-Opening Monitor** button. The Eye-Opening Monitor dialog box is displayed.

   The figure below shows the Eye-Opening Monitor dialog box when debugging a non-Avant device.

   ![Eye-Opening Monitor (Non-Avant)](image)

   The figure below shows the Eye-Opening Monitor dialog box when debugging an Avant device. The Channel and Import options are added.

   ![Eye-Opening Monitor (Avant)](image)
4. In the Eye-Opening Monitor dialog box, select the quality of the eye diagram from the drop-down menu.

   It is recommended to select normal or low quality for a faster result, and select high quality for the final result. The default is normal quality.

   If you are debugging Avant SerDes multiple channels, select the channel to debug in the Channel drop-down menu.

5. Click the Run button to start the EOM process. You can stop the process at any time by clicking the Stop button.

6. After the EOM has finished running, it will display the eye diagram for the current channel. The figure below shows the Eye Diagram when debugging non-Avant devices.

   **Figure 15: Example of Eye Diagram for Non-Avant Devices**

   ![Eye Diagram](image)

At the bottom of the eye diagram for non-Avant devices, you can click the View Raw Data button to open the raw data file containing the number of samples and errors used in calculating the density of the eye diagram.
The raw data comes from the eom register.

The numbers from nsample_cur, nsample_pre, nerrors_cur, and nerrors_pre columns calculate the result.

The numbers are collected by reading the eom register of the PCS IP.

If you change the Reveal Controller options, you can re-run the EOM to display the new eye diagram and view the new raw data until the desired result is achieved.

**Importing an Existing EOM Result**

If you are debugging Avant SerDes, each time you run the EOM, the result is automatically saved as a .txt file in the project folder. The file name provides information on the EOM settings. For example, the file name `eom_normal_MPPHYX4Q1_L2.txt` tells you that the EOM result was generated using normal quality for the MPPHYX4Q1 instance with L2 or lane 2 as the selected channel.

To import an existing EOM result:

1. Click the **Import** button in the Eye-Opening Monitor dialog box.
2. The Select Existing EOM File dialog box is displayed. Selecting AVANT EOM (*.txt) displays only the EOM results for debugging the Avant device.
3. Select the .txt file and click **Open**. The Eye Diagram is displayed. The figure below shows the Eye Diagram when debugging Avant devices.
Performing Logic Analysis

After you have configured trigger settings in the LA Trigger tab, you can perform a logic analysis on a single core.

To perform logic analysis:

1. In the `<design_name>_LA<core_number>` check box in the toolbar, select the core on which to perform logic analysis.
2. Click on the Reveal Analyzer toolbar.

   The Run button changes into the Stop button and the status bar next to the button shows the progress.

Reveal Analyzer first configures the cores selected for the correct trigger condition, then waits for the trigger conditions to occur. Once the specified trigger has occurred, the data is downloaded to the PC. The resulting waveforms appear in the LA Waveform tab.

If the trigger condition is not met, Reveal Analyzer will continue running. In that case, you can use manual triggering, described in "Using Manual Triggering" on page 91.
Data Capture with Sample Enable

Triggers occur at every sample clock edge when the condition is met. Trace data is also captured on the sample clock edge. If a sample enable is used, each sample shown in the trace buffer is only captured when the sample enable is active and there is a sample clock. Data samples can be discontiguous, unlike those in a normal data capture.

It is also possible that the actual trigger condition may occur when the sample enable is not active, causing two changes from a normal data capture:

► The actual data values for the trigger condition may not be visible, because the data cannot be captured when the sample enable is inactive.

► Reveal Analyzer cannot accurately calculate the trigger point, since the trigger point may have occurred when the sample enable was inactive. Normally a trigger point is shown as a single marker on the clock on which the trigger occurred. If a sample enable is used, a trigger region that spans five clock cycles is shown instead. Reveal Analyzer can guarantee that the trigger occurred in this region, but it cannot determine during which clock cycle the trigger occurred.

The sample enable is a very useful feature, but it takes more understanding than a normal data capture.

Common Error Conditions

Please refer to the Reveal Troubleshooting guide for more information.

Stopping a Logic Analysis

You can stop a logic analysis while it is running.

To stop a logic analysis:

► Click .

This command only stops the logic analysis on the current core in the active window. You must stop each core separately.
Using Manual Triggering

If you set up a trigger but triggering fails to occur or you want to trigger manually instead of triggering when a signal condition occurs, you can use manual triggering to capture data. The captured data may then help you find out why triggering did not occur as you originally intended.

When you select manual triggering, Reveal Analyzer fills the buffer with data captured from that moment. In single-trigger capture mode, it fills the buffer and stops. In multiple-trigger capture mode, it captures one trigger and data. You can then continue to manually trigger as many times as the original triggering setup specified. If you want to capture fewer triggers, you can manually trigger the desired number of times, then press the Stop ( ■ ) button to stop the logic analysis. The buffer starts downloading the data.

To use manual triggering:

**Note**

A logic analysis must be running before you can use the Manual Trigger command.

1. After you start the logic analysis with the ▶ button, click ■. This command only applies to the logic analysis on the current core in the active window. You must trigger each core separately.
2. When you have captured the desired number of triggers in multiple trigger capture mode, click ■.

Viewing Waveforms

After running your logic analysis, you can view the trace buffer data in waveform format in the LA Waveform tab. Whenever the trace stops, Reveal Analyzer reads the trace samples back from the trace memory and automatically updates the signal waveforms.

If you perform a logic analysis, exit Reveal Analyzer, and then reopen it, the old data is displayed in the waveform until you perform a new logic analysis.

Viewing Logic Analysis

**To view a logic analysis:**

1. Click the LA Waveform tab.
2. Choose a module from the drop-down menu in the Reveal Analyzer toolbar.
Adjusting the Waveform Display

You can adjust the waveform display by panning and zooming. You can also adjust the colors.

Panning

You can move the waveform display in the LA Waveform tab so that you can view any part of it.

To pan the waveform display:
1. Right-click in the waveform and choose Pan Mode.
2. Press and drag the left mouse button to the left or the right.

Zooming In and Out

You can zoom in and out on a waveform in the Reveal Analyzer LA Waveform tab to increase or decrease the displayed time interval.

To zoom in on a waveform:
- Choose View > Zoom In, click , or right-click on the waveform and choose Zoom > Zoom In.

To zoom in on a specified area:
1. Right-click the waveform and choose Zoom Mode.
   The pointer changes to a cross.
2. Hold down the left mouse button and drag the pointer across the area you want to zoom in on.
   A shaded area appears on the waveform display.
3. Release the mouse button.
   The shaded area expands to fill the display.

To zoom out on a waveform:
- Choose View > Zoom Out, click , or right-click on the waveform and choose Zoom > Zoom Out.

To show the entire waveform in the window:
- Choose View > Zoom Fit.

To zoom to the trigger point:
- Right-click in the waveform and choose Zoom > Zoom Trigger.
To zoom to the start of the display:
- Right-click in the waveform and choose Zoom > Zoom Start

To zoom to the end of the display:
- Right-click in the waveform and choose Zoom > Zoom End

Setting a Trace Bus Radix
You can set the radix of a trace bus displayed in the LA Waveform tab. You can choose a binary, octal, decimal, or hexadecimal radix. You can also use any token set whose bit width matches the bus.

To set the bus radix of a signal or bus:
1. In the LA Waveform tab, click in the Data cell of the signal or bus. 
   A menu appears showing the different radices and any token sets that fit.
2. Choose the desired radix or token set.

To set the bus radix of multiple signals and buses:
This method can set several signals to the same radix but cannot use tokens.
1. In the LA Waveform tab, select one or more buses.
   To select one bus, click on it. To select more than one, Control-click on each one. To select all buses in a range, click on one end of the range and Shift-click the other end. If you want to change all the signals in the waveform to the same radix, you do not need to select anything.
2. Right-click in one of the selected waveforms and choose Set Bus Radix. 
   Be careful to click in the same row as one of your selections, or you will change the selection.
   The Set Bus Radix dialog box opens.
3. In the drop-down menu, choose the radix.
4. In the Range drop-down menu, choose Selected signals or, if you want to change all the signals in the waveform to the same radix, choose All signals.
5. Click OK.
Changing LA Waveform Colors
You can change the colors used by the waveform.

To change the colors:
1. Open the Options dialog box. Depending on which version of Reveal Analyzer you’re using, do one of the following:
   ▶ If integrated with the Radiant software, choose Tools > Options. Then, in the Options dialog box, choose Color in the left panel and then click on the Reveal Analyzer tab.
   ▶ If stand-alone, choose Design > Options.
2. Click on the color sample for the desired part of the LA Waveform view. The Select Color dialog box opens.
3. Select a color.
4. In the Select Color dialog box, click OK.
5. To see the effect of the change, click Apply.
6. Change other colors if desired.
7. Click OK.

Specifying the Clock Period
You can specify a clock period for your logic analysis. Setting the frequency enables you to determine the location of your cursors, as well as the distance between them. Frequency is determined by dividing 1 by the period.

To set the clock frequency:
1. Right-click the waveform and choose Set Clock Period.
2. In the Specify Clock Period dialog box, choose either picoseconds or nanoseconds for the period interval selector. Click the box next to Period to select picoseconds (ps) or nanoseconds (ns).
3. Place the cursor in either the Period or Frequency text box and type in the desired value. The other text box fills in automatically.
   Only integers are allowed. If you try to specify a frequency that would require a non-integer period, the period is truncated to an integer and the frequency is automatically adjusted. For example, typing 150 in the Frequency text box gives you a period of 6 and a frequency of 166.
4. Click OK.
Placing, Moving, and Locating Cursors

The LA Waveform view comes with three types of “cursors” to highlight moments in the waveform. The cursors are vertical lines cutting through all the signals at the leading edge of a clock cycle. See Figure 18 on page 103. The three types are:

- **Trigger.** A purple line with a “T” at the top, trigger cursors are automatically placed at the moment of each final trigger event. If the module used a sample enable signal and the exact moment of the trigger is unknown, the waveform shows a trigger cursor five clock cycles before the sample enable signal turned inactive and sampling stopped.

- **Active.** A red line appears wherever you click in the waveform. The Data column shows the values of the signals and buses at the moment highlighted by the active cursor.

- **User.** A blue line can be placed anywhere you want. Use these cursors to mark moments of interest. You can also use these cursors to maneuver about a long waveform with the Go to Cursor command.

Most cursor functions require that the LA Waveform view be in Select mode: right-click in the LA Waveform view and choose **Select Mode**.

**To create a user cursor:**

1. Click in the desired clock cycle.
   
   The active cursor appears. Make sure it is where you want the user cursor to be.

2. Right-click and choose **Add Cursor**.

**To move a user cursor:**

1. Zoom in so you can easily see and click in individual samples.

2. Click in the desired location.
   
   The active cursor appears. Make sure it is where you want the user cursor to be.

3. Carefully click in the sample to the right of the user cursor.
   
   You must click on or to the right of the user cursor. Otherwise you are just moving the active cursor to a neighboring sample.

   The user cursor and the active cursor exchange locations.

**To jump to a user cursor:**

- Right-click in the waveform and choose **Go to Cursor > <cursor>**.

   Cursors are identified by the sample index as shown in the green bar at the top of the waveform display.
To remove a user cursor:
1. Click on or near the cursor.
   The active cursor appears. Make sure it is on or next to the user cursor you want to remove.
2. Right-click and choose Remove Cursor.

To remove all user cursors:
- Right-click in the waveform and choose Clear All Cursor.

Counting Samples

You can easily count the number of samples in a range on the display.

To count samples:
- Click where you want to start counting and drag to the end of the range.
  While you’re dragging, the LA Waveform view shows two red lines and the number of samples between the lines.

Exporting Waveform Data

You can export waveform data to a value change dump (.vcd) file, which can be imported by such third-party tools as ModelSim or Active-HDL, or to an ASCII-format text (.txt) file. You must have performed a logic analysis, implemented a trigger on hardware, and captured data that is shown in the waveform display before you can export data.

To export data:
1. If you want the data to include an approximate measure of time instead of a simple count of clock cycles, right-click the waveform and choose Set Clock Period. See “Specifying the Clock Period” on page 94.
2. If you want to export only some of the signals, select them in the waveform. You can only export whole buses. If you select only some of the signals in a bus, you get the whole bus.
3. Right-click in the waveform and choose Export Waveform.
   The Export Waveform dialog box opens.
4. Browse to the location where you want to export the file.
5. Type in a name in the File name box.
6. Choose a file type.
7. If you are exporting only some of the signals, choose Selected signals in the Range box.
8. If you are exporting to .vcd, type in a module name. This will form the title in the .vcd file. If you leave the field empty, the module name will be “<unknown>”.

9. Click Save.

**Saving a Project**

You can save the trigger settings and waveform setup settings in a Reveal Analyzer project (.rva) file that you can use as an input file in the future. You can also save an existing .rva file in a file with a different name.

To save a Reveal Analyzer project:

* Choose File > Save <file>.

The project data is now output into an .rva file.

To save the project file with a different name:

1. Choose File > Save <file> As.
   
   The Save Reveal Analyzer File dialog box appears.
2. Browse to the directory in which you want to save the project.
3. In the File name box, type the file name.
4. Click Save.

**Exiting Reveal Analyzer**

To exit Reveal Analyzer:

* Choose File > Close.
User Interface Descriptions

The Reveal Analyzer window consists of the LA Trigger, LA Waveform.

LA Trigger Tab

The LA Trigger tab enables you to select the trigger signals and define the data values or pattern of data values that cause trace data collection to begin.

Trigger Unit

The parameters in the Trigger Unit section enable you to configure the trigger units, which are the basic trigger comparison mechanism in Reveal Inserter and Reveal Logic Analyzer. Trigger units allow comparison of the signal to a value that is entered during hardware debug. You can include up to 16 trigger units in a core. Each trigger unit consists of the following information:

Name  Specifies the name of the trigger unit. See “Trigger Expression and Trigger Unit Naming Conventions” on page 103 for the guidelines governing trigger unit names. The default name is TU<number>, where <number> is a sequential number. The first trigger unit is named TU1 by default.

Signals  Lists the signals in the trigger unit. You can select up to 4096 trigger signals. You can specify these signals only in Reveal Inserter.

Operator  Specifies the comparators that Reveal will use to compare the states of the trigger bus signals to the pattern of signal states that you set in the Trigger Signal Setup tab of Reveal Logic Analyzer. You can choose from the following states:

- == equal to. This comparator is the default.
- != not equal to
- > greater than
- >= greater than or equal to
- < less than
- <= less than or equal to
- Rising edge – Compares on the rising edge of the clock
- Falling edge – Compares on the falling edge of the clock
- Serial compare – Compares until the trigger condition is met. For example, if the trigger condition is 10011, the serial compare option looks for a 1 on the first clock, a 0 on the next clock, a 0 on the next clock, a 1 on the next clock, and a 1 on the last clock. Only if those five conditions are met in those five clock cycles will the serial compare output be active.

Other operators cannot be changed to a serial compare, and a serial compare cannot be changed to another operator in Reveal Logic Analyzer. These can only be changed in Reveal Inserter.
The serial comparator is available only when a single signal is listed in the Trigger Unit signal list. If you choose this option, you must choose Binary in the Radix box.

**Radix** Specifies the radix of the trigger bus. It can be one of the following:
- Binary. This is the default. You must choose Binary if you selected “Serial compare” as a comparator.
- Octal
- Decimal
- Hexadecimal
- `<token_set_names>`. To select `<token_set_name>`, you must have created token sets in Reveal Inserter. See the Reveal Inserter Help for information on this procedure.

**Value** Specifies the comparison value. This value is the pattern of highs and lows that you want on the trigger unit that will initiate collection of the trace data. The default is binary.

If you selected a `<token_set_name>` in the Radix column, a drop-down menu opens in the Value column. This menu lists all the tokens that you entered in the Token Manager dialog box for the chosen token set. Select any name.

You can use “x” for a don’t-care value in the Value column if you selected Binary, Octal or Hexadecimal in the Radix column and if you selected the ==, !=, or serial compare operators in the Operator column.

**Trigger Expression**
The parameters in the Trigger Expression section of the Trigger Signal Setup tab enable you to configure the trigger expressions, which are combinatorial, sequential, or both combinatorial and sequential equations of trigger units that define when the collection of the trace data samples begins. You can add up to 16 trigger expressions. Each trigger expression consists of the following information:

- **Enable** Determines whether the trigger expression is active when the triggering is enabled by the Run button.
- **Name** Specifies the name of the trigger expression. The default name is TE<`number`>, where `<number>` is a sequential number. The first trigger expression is named TE1 by default.

**Expression** Specifies the trigger units and the operator or operators that indicate the relationship of one trigger unit to other trigger units. You can use the following operators to connect trigger units:
- & (AND) – Combines trigger units using an & operator.
- | (OR) – Combines trigger units using an OR operator.
- ^ (XOR) – Combines trigger units using a XOR operator.
- ! (not) – Combines a trigger unit with a NOT operator.
- Parentheses – Groups and orders trigger units.
- THEN – Creates a sequence of wait conditions. For example, the following statement:

```
TU1 THEN TU2
```

means "wait for TU1 to be true," then "wait for TU2 to be true."

The following expression:

```
(TU1 & TU2) THEN TU3
```

means "wait for TU1 and TU2 to be true, then wait for TU3 to be true."

Reveal supports up to 16 sequence levels.

- NEXT – Creates a sequence of wait conditions, like THEN, except the second trigger unit must come immediately after the first. That is, the second trigger unit must occur in the next clock cycle after the first trigger unit.

- # (count) – Inserts a counter into a sequence. Sequences are groups of combinatorial operations connected by THEN operators. The counter counts how many times a sequence must occur before a THEN statement. The maximum value of this count is determined by the Max Event Counter value. It must be specified in Reveal Inserter and cannot be changed in Reveal Logic Analyzer.

Here are some examples.

The following statement:

```
TU1 #5 THEN TU2
```

means that TU1 must be true for five consecutive or non-consecutive sample clocks before TU2 is evaluated. The counts do not have to be sequential. TU1 does not have to be true five times in a row to satisfy this condition. It only has to be true fives times to meet this condition.

The next expression:

```
(TU1 & TU2)#2 THEN TU3
```

means "wait for the second occurrence of TU1 and TU2 being true, then wait for TU3."

The last expression:

```
TU1 THEN (1)#200
```

means "wait for TU1 to be true, then wait for 200 sample clocks." This expression is useful if you know that an event occurs a certain time after a condition.

You can only use one count (#) operator per sequence. For example, the following statement is not valid, because it uses two counts in a sequence:

```
TU1 #5 & TU2 #2
```

- ## (consecutive count) – Inserts a counter into a sequence. Like # (count) except that the trigger units must come in consecutive clock cycles. That is, one trigger unit immediately after another with no delay between them.
**Sequence Depth**  Specifies the number of sequences, which are groups of combinatorial operations connected by THEN operators, used in a trigger expression. Reveal supports up to 16 sequence levels.

For example, in the following figure, TE1 consists of one sequence, since it has no THEN operator. It therefore has a sequence depth of 1. TE2 has two sequences, TU1|TU2 and TU3 & TU2, linked by a THEN operator, so its sequence depth is 2. TE3 has three sequences:
- TU1 & TU3 & TU2 followed by THEN
- TU1 followed by THEN
- TU3

TE3 therefore has a sequence depth of 3.

**Figure 17: Trigger Expression Sequences**

<table>
<thead>
<tr>
<th>Enable</th>
<th>Name</th>
<th>Expression</th>
<th>Sequence Depth</th>
<th>Min Sequence Depth</th>
<th>Min Event Counter</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>TE1</td>
<td>TE1 &amp; TU2</td>
<td>1</td>
<td>2</td>
<td>1</td>
</tr>
<tr>
<td></td>
<td>TE2</td>
<td>TE1 &amp; TU2</td>
<td>2</td>
<td>2</td>
<td>1</td>
</tr>
<tr>
<td></td>
<td>TE3</td>
<td>TE1 &amp; TU2 &amp; TU3 &amp; TU2</td>
<td>2</td>
<td>4</td>
<td>1</td>
</tr>
</tbody>
</table>

**Max Sequence Depth**  Specifies the maximum number of sequences, or trigger units connected by THEN operators, that can be used in a trigger expression. You can set this option only in Reveal Inserter.

**Max Event Counter**  Determines the maximum size of the count in the trigger expression (the count is how many times a sequence must occur before a THEN statement). You can set this option from 1 to 65,536. The maximum is 65,536. The default is 1. You can set this option only in Reveal Inserter.

**AND All**  Indicates that the conditions specified by all the trigger expressions must be met before the trace data is captured.

**OR All**  Indicates that the conditions of one of the trigger expressions must be met before the trace data is captured. This option is the default.

**Samples Per Trigger**  Specifies the number of samples to collect per trigger. The minimum is 16. The maximum is the trace buffer depth chosen in Reveal Inserter when the core is generated. The values available in the Samples Per Trigger box also change according to the number of triggers. If the number of triggers is set higher than 1, the samples per trigger multiplied by the selected number of triggers cannot exceed the trace buffer depth. Reveal Logic Analyzer adjusts the Samples Per Trigger value, if necessary. The default number of samples per trigger is the sample buffer depth. For example, if the sample buffer depth is 2048, the default sample per trigger is 2048.

**Number of Triggers**  Specifies the trace buffer depth divided by the samples per trigger. The trace buffer depth is specified by the setting of the Buffer Depth parameter in the Trace Signal Setup tab in Reveal Inserter. The default is 1.
Trigger Position

**Pre-selected Position**  Specifies the position of the trigger point in the data stream. For example, 32/512 means the trigger point is the 32nd sample in the trace memory that has a total depth of 512 samples (from sample 0 to sample 511). You can use one of the following samples in the Position box:

- **Pre-Trigger** – Sets the trigger point at 1/16 of the total number of samples in the trace memory. For example, when the trace memory has a total number of 512 samples, 1/16 of these would be 32. The 32 setting means that 32 data samples are collected before the trigger occurs. The Pre-Trigger setting is helpful if you are mostly interested in the data states that occurred after the trigger event. Using the example just given, only 32 samples of data (from sample 0 to sample 31) that occur before the trigger are stored, but 480 samples of data (from sample 32 to sample 511) that occur after the trigger are stored.

- **Center-Trigger** – Sets the trigger point at 50 percent (1/2) of the total number of samples in the trace memory. For example, when the trace memory has a total number of 512 samples, 50 percent of these would be 256, so the trigger point would be set at 256. The Center-Trigger setting provides equal amounts of trace data before and after the trigger event. Using the example just given, 256 samples of data (from sample 0 to sample 255) that occur before the trigger are stored, and 256 samples of data (from sample 256 to sample 511) that occur after the trigger are stored.

- **Post-Trigger** – Sets the trigger point at 15/16 of the total number of samples in the trace memory. For example, when the trace memory has a total number of 512 samples, 15/16 of these would be 480. The Post-Trigger setting is helpful if you are mostly interested in the data states that occurred before the trigger event. Using the example just given, 480 samples of data (from sample 0 to sample 479) that occur before the trigger are stored, but only 31 samples of data that occur after the trigger are stored.

**Note**

The actual trigger position in the captured samples may not match the trigger position that you set in the Trigger Signal Setup tab. For example, if the trigger condition occurs before the trigger position set in the Trigger Signal Setup tab, the actual trigger position is earlier than that specified in the Trigger Signal Setup tab. Since the trigger occurred before enough samples were captured to fill the buffer, both the position is different and the total number of captured samples will be less than the set value. This condition is more likely to occur using the post-trigger setting. To avoid this, do not use a trigger condition that occurs immediately or very frequently.

**User-Selected Position**  Enables you to choose the trigger point from certain points selected by the tool.

**Trigger Position**  Shows the position of the trigger point in relation to the number of samples per trigger. It is in read-only notation at the very bottom of the Trigger Position section. For example, if you selected the Center-Trigger setting for the Pre-selected Position option and you selected 1024 samples in...
the Samples Per Trigger box, the Trigger Position field would display a trigger point equal to half the samples, 512/1024.

Trigger Expression and Trigger Unit Naming Conventions
You can rename trigger units and trigger expressions. The names can be a mixture of lower-case or upper-case letters, underscores, and digits from 0 through 9. The first character must be either an underscore or a letter. The names can be any length.

LA Waveform Tab
Waveforms are presented in a grid layout as shown in Figure 18 along with several features to help you find and analyze the data.

Bus/Signal Column Displays the names of the trace buses and signals in the selected module.

Data Column Displays the value of the bus or signal at the active cursor (a solid, red line that you can set in the waveform display). Buses also have a drop-down menu for setting the radix used in the Data column and in the waveform display. The menu includes token sets whose bit width matches the bus. See “Setting the Trace Bus Radix” on page 76.

Waveform Display Displays the trace data in waveform format. When there is room, bus values are included the display using the radix set in the Data column. You can zoom in and out, pan, and jump to various points.
The waveform display includes several other elements to help you read the display and analyze the data:

- Timestamp. The gray bar at the top of the display shows “timestamps” of the trace frames (actually, a simple count of the clock cycles). Timestamps are shown only if the Timestamp trace option was selected for the module in Reveal Inserter. See “Adding Time Stamps to Trace Samples” on page 76.

- Sample Index. The green bar near the top of the display shows a count of triggers and trace samples within each trigger’s data set. The sample indexes have the form $<$trigger$>:<$sample$. For example, 0:2 indicates the first trigger and the third trace sample for that trigger (the counts are zero-based). 2:10 indicates the third trigger and the eleventh trace sample for that trigger.

- Pointer. A red line that cuts across the timestamp and sample index bars, the pointer follows the horizontal movement of the mouse pointer across the waveform display. Use the pointer to see where you are in time as you examine the waveform.

- Cursors. Vertical lines cutting through all the signals, cursors mark moments in the waveform. See “Placing, Moving, and Locating Cursors” on page 95.
# Revision History

The following table gives the revision history for this document.

<table>
<thead>
<tr>
<th>Date</th>
<th>Version</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>06/28/2024</td>
<td>2024.1</td>
<td>Updated to reflect changes in Radiant 2024.1 software.</td>
</tr>
<tr>
<td>03/29/2024</td>
<td>2023.2.1</td>
<td>Updated to reflect changes in Radiant 2023.2.1 software.</td>
</tr>
<tr>
<td>11/27/2023</td>
<td>2023.2</td>
<td>Updated to reflect changes in Radiant 2023.2 software.</td>
</tr>
<tr>
<td>06/5/2023</td>
<td>2023.1</td>
<td>Updated to reflect changes in Radiant 2023.1 software.</td>
</tr>
<tr>
<td>02/27/2023</td>
<td>2022.1.1</td>
<td>Updated to reflect changes in Radiant 2022.1.1 software.</td>
</tr>
<tr>
<td>11/7/2022</td>
<td>2022.1</td>
<td>Updated to reflect changes in Radiant 2022.1 software.</td>
</tr>
<tr>
<td>06/6/2022</td>
<td>3.2</td>
<td>Updated to reflect changes in Radiant 3.2 software.</td>
</tr>
<tr>
<td>12/7/2021</td>
<td>3.1</td>
<td>Updated to reflect changes in Radiant 3.1 software.</td>
</tr>
<tr>
<td>05/1/2020</td>
<td>2.1</td>
<td>Updated to reflect changes in Radiant 2.1 software.</td>
</tr>
<tr>
<td>10/23/2019</td>
<td>2.0</td>
<td>Initial Release. Content was previously Appendix A of “Radiant Software User Guide.”</td>
</tr>
</tbody>
</table>