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Acronyms in This Document 
A list of acronyms used in this document. 

Acronym Definition 

BSP 
Board Support Package, the layer of software containing hardware-specific drivers and libraries to function 
in a particular hardware environment. 

DUT Design Under Test. 

SDK 
Embedded System Design and Develop Kit. A set of software development tools that allows the creation of 
applications for software package on the Lattice embedded platform. 

IDE Integrated Development Environment. 

OEM Original Equipment Manufacturer. 

Workspace 
The directory where stores your work, it is used as the default content area for your projects as well as for 
holding any required metadata. 

Workbench Refers to the desktop development environment in Eclipse IDE platform. 

Programmer 
A tool can program Lattice FPGA SRAM and external SPI Flash through various interfaces, such as JTAG, SPI, 

and I2C.  

Perspective A group of views and editors in the Workbench window. 

RISC-V 
A free and open instruction set architecture (ISA) enabling a new era of processor innovation through open 
standard collaboration. 

RISC-V MC Lattice RISC-V for Micro-Controller Soft IP  

SoC 
System on Chip. An integrated circuit that integrates all components of a computer or other electronic 
systems. 

SRAM Static Random Access Memory. 

UFM User Flash Memory. 
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 Introduction 
Lattice Propelϰ is a complete set of graphical and command-line tools to create, analyze, compile, and debug both 
FPGA-based hardware and software processor systems. 

 Purpose 
Embedded system solutions play an important role in FPGA system design allowing you to develop software for a 
processor in an FPGA device. It provides flexibility for you to control various peripherals from a system bus.  

To develop an embedded system on an FPGA, you need to design the System-on-Chip (SoC) with an embedded 
processor and develop system software on the processor. Lattice Propel helps you develop your system with a RISC-V 
processor, peripheral IP, and a set of tools.  

The purpose of this document is to introduce Lattice Propel SDK tool and flow to help you quickly get started to build a 
small demo system. You can find recommended flows of using Lattice Propel SDK in this document as well.  

 Audience 
The intended audience for this document includes embedded system designers and embedded software developers 
using Lattice FPGA devices. The complete list of supported devices can be found at Lattice Propel Release Notes. The 
technical guidelines assume readers have expertise in the embedded system area and FPGA technologies. 
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 Lattice Propel Development Suite 
Lattice Propel development suite includes: 

¶ an integrated development environment (IDE), which is the framework of Propel;  

¶ Lattice Propel Builder, which is for SoC design;  

¶ Lattice Propel SDK, which is for system software development. 

 Eclipse IDE 
Eclipse IDE provides the Propel development suite a platform to manage the SoC project and the Embedded C/C++ 
Project in the same workspace.  

The SoC project, which extends from the Propel Builder project, provides easy interaction with other Lattice design 

tools, such as Lattice DiamondÑ within Propel. 

The Embedded C/C++ Project provides a platform for developing or debugging application code within Eclipse IDE. The 
project can be created directly from the SoC project with a pre-set Board Support Package (BSP) and applications by 
using Propel development suite. 

 Lattice Propel Builder 
Lattice Propel Builder allows you to assemble the larger functional blocks of the design hierarchy. Propel Builder 
enables you to instantiate modules and IP from the IP Catalog in a schematic view, and can easily connect the modules. 
Propel Builder also helps you customize address spaces within modules, such as a processor. In Propel development 
suite, Propel Builder is used to create a microprocessor integrated platform for both hardware and software 
development.  

Refer to Lattice Propel 2.1 Builder User Guide (FPGA-UG-02143) for more detailed information. 

 Lattice Propel SDK  
Lattice Propel SDK is based on Eclipse Embedded CDT (C/C++ Development Tools). It allows you to create, build, and 
debug software application projects that drive the platform within the Eclipse framework. 

The main features are: 

¶ Create, build, debug, or manage embedded applications for Lattice RISC-V CPU/SoC solution. 

¶ Provide extra build steps to generate the binary and memory files required for deployment. 

¶ Build using the latest industry standard open source components and tools for RISC-V firmware development and 
debugging. 

¶ Support Picolibc for RISC-V, and provide lightweight standard library implementation. 

¶ Provide fully-configurable toolchain definitions. 
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 Lattice Propel Tool Flows 
The Propel tool flows including SoC project design flow, C/C++ project design flow, system simulation flow, and 
programming and On-Chip-Debugging (OCD) debugging flow, are discussed in detail in the following sections. 

 Propel Environment 

3.1.1. Running Lattice Propel 

After installing Lattice Propel, you can launch Propel from the desktop shortcut icon or from the Windows Start menu. 
When Propel is invoked, a dialog (Figure 3.1) pops up. You can browse to select where to locate the workspace. For 
normal needs, just click Launch to pick the default location and continue running Propel. 

 

Figure 3.1. Select Workspace Dialog 

After the workspace location is chosen, a single workbench window is displayed using default Propel SDK perspective. 
The default Propel SDK perspective contains following five functional areas (Figure 3.2). 

1. aŜƴǳ ōŀǊ ŀƴŘ ¢ƻƻƭōŀǊΦ 

2. tǊƻƧŜŎǘ 9ȄǇƭƻǊŜǊ ǾƛŜǿΥ ŘƛǎǇƭŀȅǎ ǇǊƻƧŜŎǘǎ ƛƴ ǘƘŜ ǿƻǊƪǎǇŀŎŜΦ 

3. 9ŘƛǘƻǊ ǾƛŜǿΥ ǇǊƻǾƛŘŜǎ ŎŀǇŀōƛƭƛǘȅ ƻŦ ŜŘƛǘƛƴƎ ǎƻǳǊŎŜ ŦƛƭŜǎΦ 

4. hǳǘƭƛƴŜ ǾƛŜǿΥ ŘƛǎǇƭŀȅǎ ŀƴ ƻǳǘƭƛƴŜ ƻŦ ŀ ŦƛƭŜ ǘƘŀǘ ƛǎ ŎǳǊǊŜƴǘƭȅ ƻǇŜƴ ƛƴ ǘƘŜ ŜŘƛǘƻǊ ŀǊŜŀΦ 

5. [ƻƎ ŀǊŜŀ ƛƴŎƭǳŘŜǎ ǘƘŜǎŜ ǾƛŜǿǎΥ tǊƻōƭŜƳ ǾƛŜǿΣ ¢ŀǎƪǎ ǾƛŜǿΣ /ƻƴǎƻƭŜ ǾƛŜǿΣ tǊƻǇŜǊǘƛŜǎ ǾƛŜǿΣ ŀƴŘ ¢ŜǊƳƛƴŀƭ ǾƛŜǿΦ  
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Figure 3.2. Propel Workbench Window 

3.1.2. Importing General Projects 

In Propel SDK, you can use the importing project wizard to import existing projects into workspace except for Lattice 
SoC design created by Lattice Propel Builder. 

Note: You can only import projects which are created or managed by Propel SDK by choosing General > Existing Project 
into Workspace in Propel SDK. 

1. In Lattice Propel (SDK), choose File > LƳǇƻǊǘΧ.  

The Select wizard opens (Figure 3.3). 

3 

1 

2 

4 
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Figure 3.3. Import Projects Wizard ς General 

2. Select General > Existing Project into Workspace. Click Next. 

The Import wizard switches to Import Projects wizard (Figure 3.4). 
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Figure 3.4. Import Existing Projects Wizard 

3. Choose either Select root directory or Select archive file, clicking the associated Browse button to locate the 
directory or file containing the project. 

4.  Select the project or projects you want to import in the Projects area. 

5. Be sure to check the Copy projects into workspace option so that your original projects do not get updated. 

6. Click Finish to start the importing process.  

3.1.3. Importing Lattice SoC Design Projects 

In Propel SDK, you can use the Import Wizard to import Lattice SoC design projects into workspace. Existing SoC design 
projects created by either Propel SDK or Propel Builder can also be imported into Workspace by choosing Lattice 
Propel > Lattice SoC Design Projects.  

1. From Lattice Propel SDK, choose File > LƳǇƻǊǘΧ.  

The Select wizard opens (Figure 3.5). 
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Figure 3.5. Import Projects Wizard ς Lattice Propel 

2. Select Lattice Propel > Lattice SoC Design Projects into Workspace. Click Next. 

The Select wizard switches to Import Lattice SoC Design Projects wizard page (Figure 3.6). 

 

Figure 3.6. Import Lattice SoC Design Projects Wizard 

3. Locate the directory containing the projects by clicking the Browse button. 

4. In Projects area, select the SoC design project or projects you want to import. 

5. Click Finish to start the importing process. 
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 SoC Project Design Flow 
A new SoC design project including a Propel Builder design can be started from the Lattice Propel sets. Follow the steps 
below to create a new SoC design project. 

3.2.1. Creating a SoC Design Project 

To start a Lattice SoC Design Project from Propel: 

1. In Lattice Propel, choose File > New >    Lattice SoC Design Project. The Create SoC Project wizard opens 
(Figure 3.7). 

   

Figure 3.7. Create SoC Project Wizard 

2. Enter a project name.  

Note: Do not include periods, colons, or spaces in the project name. 

3. (Optional) To change the default location, clear the Use default location option, then browse to another location. 
Choose a file system. 

4. Select a desired platform template design. In particular, select empty project for building system from scratch. 

5. Click Finish. 

The SoC design project is created in workbench, and its design is opened and displayed in Propel Builder  
(Figure 3.10). 
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3.2.2. Open a SoC Design in Propel Builder 

Within a SoC project, there is a Propel builder design.  

To open Propel Builder for a SoC project: 

1. In the Project Explorer view, select an SoC project. 

2. Open the SoC project in one of the following three ways from Propel:  

¶ /ƘƻƻǎŜ [ŀǘǘƛŎŜ¢ƻƻƭǎ Ҕ  hǇŜƴ 5ŜǎƛƎƴ ƛƴ tǊƻǇŜƭ .ǳƛƭŘŜǊ όCƛƎǳǊŜ оΦуύΦ 

  

Figure 3.8. LatticeTools Menu 

¶ /ƭƛŎƪ ǘƘŜ tǊƻǇŜƭ .ǳƛƭŘŜǊ ƛŎƻƴ  ƻƴ ǘƘŜ ǘƻƻƭōŀǊΦ  

¶ wƛƎƘǘπŎƭƛŎƪ ǘƘŜ {ƻ/ ǇǊƻƧŜŎǘ ŦǊƻƳ tǊƻƧŜŎǘ 9ȄǇƭƻǊŜǊΦ /ƘƻƻǎŜ hǇŜƴ 5ŜǎƛƎƴ Lƴ Ҕ  tǊƻǇŜƭ .ǳƛƭŘŜǊ ŦǊƻƳ ǘƘŜ ǇƻǇǳǇ 
ƳŜƴǳ όCƛƎǳǊŜ оΦфύΦ  

  

Figure 3.9. Project Explorer Popup Menu 

3. SoC Design is opened and displayed in Propel Builder (Figure 3.10). 

 

Figure 3.10. Propel Builder Window 
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4. (Optional) Modify the design in Propel Builder as desired. Most of the templates include a functional-ready SoC 
design.  

Note: You can only create an SoC design using Empty Project template inside the Propel Builder. Refer to  
Lattice Propel Builder 2.1 User Guide (FPGA-UG-02143) for more details on how to create an SoC design using 
Empty Project template.  

3.2.3. Open Design in Lattice FPGA Design Software 

Within an SoC project, you can create a Lattice FPGA design project including a Propel Builder design, and then open 
the FPGA design project in appropriate software. There are two FPGA Design Software available, Lattice Diamond and 
Lattice Radiantϰ. Depends on the device family used in the SoC project, only one of the FPGA Design software can be 
selected from the user interface, the other is grayed out. If MachXO3D or LFMNX device family is used, the Lattice 
Diamond related menu items are active from Propel UI. If LIFCL or LFD2NX device family is used, the Lattice Radiant 
related menu items are active from Propel UI. 

To open FPGA Design Software for an SoC project from Propel: 

1. (Optional) Set Lattice FPGA design software installation location from Propel. By default, Propel can find the proper 
Lattice FPGA design software installation location, usually the latest version installed on the PC. You can overwrite 
it following steps below.    

Choose Windows > Preferences. The Preferences dialog opens (Figure 3.11). 

Select Propel Setting from the left pane. Click the Browse button to pick up the installation location of Diamond or 
Radiant. Or, leave the Radiant Location area and Diamond Location area blank, as default. Propel can find the 
location atomically. 

 

Figure 3.11. Propel Preferences Dialog 

2. In the Project Explorer view from the Propel main GUI, select an SoC project.  

3. Open the SoC project in one of the following ways:  

¶ /ƘƻƻǎŜ [ŀǘǘƛŎŜ¢ƻƻƭǎ Ҕ DŜƴŜǊŀǘŜ ŀƴŘ ƻǇŜƴ ŀ 5ƛŀƳƻƴŘ ǇǊƻƧŜŎǘΤ hǊΣ ŎƘƻƻǎŜ [ŀǘǘƛŎŜ¢ƻƻƭǎ Ҕ DŜƴŜǊŀǘŜ ŀƴŘ 
ƻǇŜƴ ŀ wŀŘƛŀƴǘ ǇǊƻƧŜŎǘΦ 

¶ /ƭƛŎƪ ǘƘŜ 5ƛŀƳƻƴŘ ƛŎƻƴ   ƻǊ ǘƘŜ wŀŘƛŀƴǘ ƛŎƻƴ   ŦǊƻƳ ǘƘŜ ǘƻƻƭōŀǊΦ 
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¶ wƛƎƘǘπŎƭƛŎƪ ŀƴ {ƻ/ ǇǊƻƧŜŎǘ ŦǊƻƳ ǘƘŜ tǊƻƧŜŎǘ 9ȄǇƭƻǊŜǊΦ /ƘƻƻǎŜ hǇŜƴ 5ŜǎƛƎƴ Lƴ Ҕ 5ƛŀƳƻƴŘΦ hǊΣ ŎƘƻƻǎŜ hǇŜƴ 

5ŜǎƛƎƴ Lƴ Ҕ wŀŘƛŀƴǘ ŦǊƻƳ ǘƘŜ ǊƛƎƘǘπŎƭƛŎƪ ƳŜƴǳΦ 

4. 5ƛŀƳƻƴŘκwŀŘƛŀƴǘ ǇǊƻƧŜŎǘ ŦƻǊ {ƻ/ ƛǎ ƎŜƴŜǊŀǘŜŘ ŀǘ ōŀŎƪƎǊƻǳƴŘ ŀƴŘ ƛǎ ƭŀǳƴŎƘŜŘ όCƛƎǳǊŜ оΦмнκCƛƎǳǊŜ оΦмоύΦ 

 

Figure 3.12. Diamond Project 
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Figure 3.13. Radiant Project 

5. όhǇǘƛƻƴŀƭύ CǊƻƳ ǘƘŜ CƛƭŜ [ƛǎǘ ǾƛŜǿ ƻŦ ǘƘŜ 5ƛŀƳƻƴŘκwŀŘƛŀƴǘ ǎƻŦǘǿŀǊŜΥ 

¶ ƳƻŘƛŦȅ ǘƘŜ  ǘƻǇπƭŜǾŜƭ w¢[ ŦƛƭŜ όғǇǊƻƧψƴŀƳŜҔψ¢ƻǇΦǾύ ǘƻ ƳŀǘŎƘ ǘƘŜ {ƻ/ ŘŜǎƛƎƴΣ ǇǊŜǎǳǇǇƻǎƛǘƛƻƴ ƻŦ ǿƘƛŎƘ ƛǎ ǘƘŀǘ 
ǘƘŜǊŜ ƛǎ ŀ ǘƻǇπƭŜǾŜƭ w¢[ ŦƛƭŜ ƛƴ ȅƻǳǊ {ƻ/ ŘŜǎƛƎƴΤ ƻǊ 

¶ ŎǊŜŀǘŜ ŀ ǘƻǇπƭŜǾŜƭ w¢[ ŦƛƭŜ όғǇǊƻƧψƴŀƳŜҔψ¢ƻǇΦǾύ ǘƻ ƳŀǘŎƘ ǘƘŜ {ƻ/ ŘŜǎƛƎƴΣ ƛŦ ǘƘŜ {ƻ/ ŘŜǎƛƎƴ ƛǎ ŎǊŜŀǘŜŘ ŦǊƻƳ ŀƴ 
9ƳǇǘȅ tǊƻƧŜŎǘ ǘŜƳǇƭŀǘŜ ŀƴŘ ǘƘŜǊŜ ƛǎ ƴƻ ǘƻǇπƭŜǾŜƭ w¢[ ŦƛƭŜ ƛƴ ȅƻǳǊ {ƻ/ ŘŜǎƛƎƴΦ  

6.  όhǇǘƛƻƴŀƭύ aƻŘƛŦȅ ŎƻƴǎǘǊŀƛƴǘ ŦƛƭŜ όғǇǊƻƧψƴŀƳŜҔΦƭǇŦκғǇǊƻƧψƴŀƳŜҔΦǇŘŎύ ǘƻ ƳŀǘŎƘ ǘƘŜ {ƻ/ ŘŜǎƛƎƴΣ ƛŦ ȅƻǳ ƘŀǾŜ 
ƳƻŘƛŦƛŜŘ ǘƘŜ {ƻ/ ŘŜǎƛƎƴΦ  

bƻǘŜΥ ¢Ƙƛǎ ǎǘŜǇ ƛǎ ŀ Ƴǳǎǘ ǘƻ ǘƘŜ {ƻ/ ŘŜǎƛƎƴ ǘƘŀǘ ƛǎ ŎǊŜŀǘŜŘ ŦǊƻƳ 9ƳǇǘȅ tǊƻƧŜŎǘ ǘŜƳǇƭŀǘŜΦ 

7. tǊƻŎŜǎǎ ǘƘŜ ŘŜǎƛƎƴ ƛƴ [ŀǘǘƛŎŜ 5ƛŀƳƻƴŘκwŀŘƛŀƴǘΦ 

Lƴ 5ƛŀƳƻƴŘ ǎƻŦǘǿŀǊŜΣ ǎǿƛǘŎƘ ǘƻ tǊƻŎŜǎǎ ǾƛŜǿ ƻŦ ǘƘŜ ǇǊƻƧŜŎǘ όCƛƎǳǊŜ оΦмпύΦ aŀƪŜ ǎǳǊŜ ŀǘ ƭŜŀǎǘ ƻƴŜ ŦƛƭŜΣ L.L{ aƻŘŜƭΣ 
±ŜǊƛƭƻƎ {ƛƳǳƭŀǘƛƻƴ CƛƭŜΣ ±I5[ {ƛƳǳƭŀǘƛƻƴ CƛƭŜΣ .ƛǘǎǘǊŜŀƳ CƛƭŜΣ ƻǊ W959/ ŦƛƭŜΣ ƛǎ ŎƘŜŎƪŜŘ ƛƴ ǘƘŜ 9ȄǇƻǊǘ CƛƭŜǎ ǎŜŎǘƛƻƴ ŦƻǊ 

ǇǊƻƎǊŀƳƳƛƴƎΦ /ƘƻƻǎŜ tǊƻŎŜǎǎ Ҕ  wǳƴΦ  
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Figure 3.14. Generate Programming File in Lattice Diamond 

Lƴ wŀŘƛŀƴǘ ǎƻŦǘǿŀǊŜΣ ŦǊƻƳ ǘƘŜ tǊƻŎŜǎǎ ¢ƻƻƭōŀǊΣ ŎƭƛŎƪ 9ȄǇƻǊǘ CƛƭŜǎ όCƛƎǳǊŜ оΦмрύΦ 

 

Figure 3.15. Generate Programming File in Lattice Radiant 

The Programming file is generated. The generated programming file can be used in the Programmer. 
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3.2.4. Generating System Environment by Building Project 

System environment package including the system environment file and the BSP package is required for the embedded 
C/C++ project. 

To generate system environment package from Propel:  

1. In the Project Explorer view, select an SoC project. 

2. Choose Project > Build Project. 

3. Check the building result in the Console view (Figure 3.16). 

  

Figure 3.16. Build Result of SoC Project 

 

3.2.5. About SoC Design Project 

The SoC project creating starts with a functional-ready SoC design and a default simulation environment. In the Project 
Explorer view, open an SoC project folder and all its sub-folders. The project contains the following files but not limited 
to the following files (Figure 3.17), some of which may vary upon your opening the SoC design project in Diamond or 
Radiant software: 

¶ <proj_name>: Folder contains a Propel Builder design including the .sbx file. 

¶ <proj_name>/application: Folder contains functional-ready embedded application source codes.  

¶ impl1: Folder contains the implementation of Diamond/Radiant project. 

¶ sge: Folder contains generated package necessary for creating C/C++ project.  

¶ verification: Folder contains the SoC verification project. 

¶ verification/sim: Folder contains the simulation environment. 

¶ <proj_name>.ldf: Diamond project file. 

¶ <proj_name>.lpf: Diamond project logical preference file. 

¶ <proj_name>.rdf: Radiant project file. 

¶ <proj_name>.pdc: Radiant project post-synthesis constraints. 

¶ <proj_name>.txt: Description file from the template. 
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Figure 3.17. Contents of SoC Project 
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 C/C++ Project Design Flow 

3.3.1. Creating a Lattice C/C++ Project 

To start a Lattice C/C++ Project from Propel: 

1. Choose File > New >  Lattice C/C++ Project.  

The C/C++ Project wizard opens with the Load System and BSP page (Figure 3.18). 

  

Figure 3.18. Load System and BSP Dialog 

2. Browse to the SoC project folder and select the system environment file sys_env.xml.  

All system environment files available in the current workspace can be selected from the System env: drop-down 
menu. 

3. If the platform has more than one processor, choose one core. 

4. Choose the project type, C or C++. 

5. Click Next.  
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The C/C++ Project dialog opens (Figure 3.19). 

 

Figure 3.19. Create C/C++ Project Dialog 

6. Enter a project name. Suggest not using periods, colons, or spaces in your project name. Though spaces are 
allowed, they may cause certain issue with some tools.  

7. By default, the Use default location option is checked. The default file system is selected automatically. Suggest 
using the default location, unless you have special need to a special location. 

8. Select a project type. Select a toolchain. Normal choice is Lattice C/C++ Project and RISC-V Cross GCC. 

9. Click Next. 
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The Lattice Toolchain Setting dialog opens (Figure 3.20). 

  

Figure 3.20. Lattice Toolchain Setting Dialog 

10. By default, two toolchain configuration modes, Debug and Release, can be chosen from the Configuration 
drop-down menu.  

¶ 5ŜōǳƎ ŎƻƴŦƛƎǳǊŀǘƛƻƴ ŎǊŜŀǘŜǎ ŜȄŜŎǳǘŀōƭŜǎ ŎƻƴǘŀƛƴƛƴƎ ŀŘŘƛǘƛƻƴŀƭ ŘŜōǳƎ ƛƴŦƻǊƳŀǘƛƻƴ ǘƘŀǘ ƭŜǘǎ ǘƘŜ ŘŜōǳƎƎŜǊ ƳŀƪŜ 
ŘƛǊŜŎǘ ŀǎǎƻŎƛŀǘƛƻƴǎ ōŜǘǿŜŜƴ ǘƘŜ ǎƻǳǊŎŜ ŎƻŘŜ ŀƴŘ ǘƘŜ ōƛƴŀǊȅ ŦƛƭŜǎ ƎŜƴŜǊŀǘŜŘ ŦǊƻƳ ǘƘŜ ƻǊƛƎƛƴŀƭ ǎƻǳǊŎŜΦ  

¶ wŜƭŜŀǎŜ ŎƻƴŦƛƎǳǊŀǘƛƻƴ ǇǊƻǾƛŘŜǎ ǘƘŜ ǘƻƻƭǎ ǿƛǘƘ ƻǇǘƛƻƴǎ ǎŜǘǘƛƴƎ ǘƻ ŎǊŜŀǘŜ ŀƴ ŀǇǇƭƛŎŀǘƛƻƴ ǿƛǘƘ ǘƘŜ ōŜǎǘ 
ǇŜǊŦƻǊƳŀƴŎŜΦ 

You can modify frequently-used library, compiler, and linker options for each configuration. For a complete 
toolchain setting, go to project properties after creating the project. Refer to the Advanced Tool Chain Setting 
section. 

¶ Lƴ [ƛō {ŜǘǘƛƴƎ ǘŀōΣ ǎǘŀƴŘŀǊŘ / ƭƛōǊŀǊȅ Ŏŀƴ ōŜ ǊŜŎƻƴŦƛƎǳǊŜŘΦ tƛŎƻƭƛōŎ ό/ [ƛōǊŀǊƛŜǎ ŦƻǊ {ƳŀƭƭŜǊ 9ƳōŜŘŘŜŘ {ȅǎǘŜƳǎύ 
ƛǎ ǎŜƭŜŎǘŜŘ ōȅ ŘŜŦŀǳƭǘ ŀƴŘ ƛǘ ǎǳǇǇƻǊǘǎ ŘƛŦŦŜǊŜƴǘ ǇǊƛƴǘŦ ƭŜǾŜƭǎΦ 

¶ Lƴ /κ/ҌҌ /ƻƳǇƛƭŜǊ ǘŀōΣ ƻǇǘƛƳƛȊŀǘƛƻƴ ƭŜǾŜƭ ŀƴŘ ŘŜōǳƎ ƭŜǾŜƭ Ŏŀƴ ōŜ ǊŜŎƻƴŦƛƎǳǊŜŘ ŦƻǊ ŜŀŎƘ ǘƻƻƭŎƘŀƛƴ 
ŎƻƴŦƛƎǳǊŀǘƛƻƴΦ  

¶ Lƴ /κ/ҌҌ [ƛƴƪŜǊ ǘŀōΣ wŜƳƻǾŜ ǳƴǳǎŜŘ ŎƻŘŜ όππƎŎπǎŜŎǘƛƻƴǎύ ƛǎ ŎƘŜŎƪŜŘ ōȅ ŘŜŦŀǳƭǘ ŦƻǊ ƎŀǊōŀƎŜ ŎƻƭƭŜŎǘƛƻƴ ƻŦ ǳƴǳǎŜŘ 
ŎƻŘŜΦ 

11. Click Finish. 

The Lattice C/C++ project is created and is displayed using the Propel SDK perspective. A perspective is a collection 
of tool views for a particular purpose. The Propel SDK perspective is for creating Lattice C/C++ programs. 
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3.3.2. Updating a Lattice C/C++ Project 

When you make changes to an SoC project, sometimes you want to synchronize the changes to an existing Lattice 
C/C++ project instead of creating a new Lattice C/C++ project. In this case, you can use the update C/C++ project 
feature. 

Note: This feature overwrites the corresponding files or settings of your existing C/C++ project. Be sure to back up your 
C/C++ project before using this feature.  

To update a Lattice C/C++ Project from Propel: 

1. DŜƴŜǊŀǘŜ ǘƘŜ ƭŀǘŜǎǘ ǎȅǎǘŜƳ ŜƴǾƛǊƻƴƳŜƴǘ ǇŀŎƪŀƎŜ ŀŎŎƻǊŘƛƴƎ ǘƻ ǘƘŜ DŜƴŜǊŀǘƛƴƎ {ȅǎǘŜƳ 9ƴǾƛǊƻƴƳŜƴǘ ōȅ .ǳƛƭŘƛƴƎ 
tǊƻƧŜŎǘ ǎŜŎǘƛƻƴΦ 

2. Lƴ ǘƘŜ tǊƻƧŜŎǘ 9ȄǇƭƻǊŜǊ ǾƛŜǿΣ ǎŜƭŜŎǘ ŀ /κ/ҌҌ ǇǊƻƧŜŎǘΦ 

3. Choose Project > Update Lattice C/C++ tǊƻƧŜŎǘΧ. 

The C/C++ Project wizard opens for updating system and BSP (Figure 3.21). 

 

Figure 3.21. Update System and BSP Dialog 

4. Browse to the SoC project folder and select the system environment file sys_env.xml.  

5. Select the checkbox for what you can update: 

¶ wŜπƎŜƴŜǊŀǘŜ ǘƻƻƭŎƘŀƛƴ ǇŀǊŀƳŜǘŜǊǎ ŀƴŘ ƭƛƴƪŜǊ ǎŎǊƛǇǘΥ ŎƘŜŎƪ ǘƘƛǎ ƻǇǘƛƻƴ ƛŦ ȅƻǳ ǿŀƴǘ ǘƻ ƳƻŘƛŦȅ /t¦ ƻǊ ƳŜƳƻǊȅ ƛƴ 
ǘƘŜ ǎȅǎǘŜƳΦ 

¶ ¦ǇŘŀǘŜ .{t ǇŀŎƪŀƎŜΥ ŎƘŜŎƪ ǘƘƛǎ ƻǇǘƛƻƴ ƛŦ ȅƻǳ ǿŀƴǘ ǘƻ ŀŘŘ ŀŘŘƛǘƛƻƴŀƭ Lt ŎƻƳǇƻƴŜƴǘǎ ƛƴǘƻ ǘƘŜ ǎȅǎǘŜƳΦ  

6. Click Update to make changes for the selected C/C++ project. 

 

3.3.3. Building a Lattice C/C++ Project 

To build a Lattice C/C++ project in Propel: 

1. Lƴ ǘƘŜ tǊƻƧŜŎǘ 9ȄǇƭƻǊŜǊ ǾƛŜǿΣ ǎŜƭŜŎǘ ŀ /κ/ҌҌ ǇǊƻƧŜŎǘΦ 

2. Cƻƭƭƻǿ ǎǘŜǇǎ ōŜƭƻǿ ƛŦ ȅƻǳ ǿŀƴǘ ǘƻ ŎƘŀƴƎŜ ǘƘŜ ŀŎǘƛǾŜ ōǳƛƭŘ ŎƻƴŦƛƎǳǊŀǘƛƻƴΥ 

a. Choose tǊƻƧŜŎǘ Ҕ .ǳƛƭŘ /ƻƴŦƛƎǳǊŀǘƛƻƴǎ Ҕ aŀƴŀƎŜΧ. Or, click the Configuration icon  on the toolbar. 

b. The Manage Configurations dialog opens (Figure 3.22) for choosing active configuration. By default, a Debug 
configuration creates executables containing additional debug information that lets the debugger make direct 
associations between the source code and the binary files generated from the original source. A Release 
configuration provides the tools with options setting to create an application with the best performance. 
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Figure 3.22. Manage Configurations Dialog 

3. /ƘƻƻǎŜ tǊƻƧŜŎǘ Ҕ .ǳƛƭŘ tǊƻƧŜŎǘΦ hǊΣ ŎƭƛŎƪ ǘƘŜ .ǳƛƭŘ ƛŎƻƴ    ƻƴ ǘƘŜ ǘƻƻƭōŀǊΦ 

4. ¢ƘŜ ǊŜǎǳƭǘǎ ƻŦ ǘƘŜ ōǳƛƭŘ ŎƻƳƳŀƴŘ ŀǊŜ ŘƛǎǇƭŀȅŜŘ ƛƴ ǘƘŜ /ƻƴǎƻƭŜ ǾƛŜǿ όCƛƎǳǊŜ оΦноύΦ 

 

Figure 3.23. Build Result of C/C++ Project 

3.3.4. About Lattice C/C++ Project 

The Lattice C/C++ project starts with source code. In the Project Explorer view, open a C/C++ project folder and all its 
sub-folders. The project contains: 

¶ src/bsp/driver: Folder contains driver codes from the IP in the platform. 

¶ src/bsp/sys_platform.h: Header file that defines DEVICE_FAMILY (the Lattice FPGA), address mapping, and any IP 
parameters that can be used by the drivers. 

¶ src/main.c: Source file contains the main routine, which is the entry-point of a C/C++ program.  

¶ src/cpu0.svd: System view description file used for peripherals registers view at debug perspective. 

¶ src/cpu0.yaml: Processor description file used at debugging time. 

¶ src/linker.ld: Linker script file. 

¶ src/sys_env.xml: System environment file describing aspects of the platform, such as memory spaces. 

After building the project, the build output can be found in each build configuration folder, the Debug folder or the 
Release folder (Figure 3.24). The Debug or Release folder contains: 

¶ <proj_name>.elf: Executable file used in on-chip debugging. 

¶ <proj_name>.bin: Binary file used in deploying the application to flash memory. 

¶ <proj_name>.lst: Extended listing file generated by tool objdump.  

¶ <proj_name>.map: Linker map file. 

¶ <proj_name>.mem: Lattice system memory initialization file used in System_Memory IP. 
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Note: Some of the files listed in Figure 3.24 are intermediate files that you do not need to take care of. 

  

Figure 3.24. Contents of C/C++ Project 

3.3.5. Writing Code 

Lattice Propel is based on Eclipse IDE. You can write application code following the process and usage of the same tools 
as any in Eclipse IDE. You can get more detailed information regarding Eclipse IDE from the Propel online help.  

For writing code, Lattice Propel SDK provides two extra aids: 

¶ Lattice System Platform: An overview of the processor platform can be displayed (Figure 3.25). 

¶ Linker Editor: An overview of the memory regions of linker script can be displayed. You can modify key linker 
parameters via the graphical interface (Figure 3.26). 
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Figure 3.25. Lattice System Platform 

  

Figure 3.26. Linker Editor 

 

 

http://www.latticesemi.com/legal


 Lattice Propel 2.1 SDK 
 User Guide 
 

© 2021 Lattice Semiconductor Corp. All Lattice trademarks, registered trademarks, patents, and disclaimers are as listed at www.latticesemi.com/legal.  
All other brand or product names are trademarks or registered trademarks of their respective holders. The specifications and information herein are subject to change without notice. 

FPGA-UG-02142-1.0  29 

3.3.6. Advanced Tool Chain Setting 

Follow the process below to modify the tool chain settings of a C/C++ project. 

To change tool chain setting in Project Properties in Propel: 

1. In the Project Explorer view of Propel, select a C/C++ project. 

2. Choose Project > Properties. The Properties for current project opens (Figure 3.27). 

3. Select Settings of C/C++ Build category from the left pane. Select the Tool Settings tab. 

 

Figure 3.27. Properties of C/C++ Project 

4. Customize the tools and tool options. All your customization can be resulted in the build configuration in the Tool 
Settings properties tab. The build configuration is used during your C/C++ project building.  

Note: Setting for each configuration, Debug or Release, is independent. 

5. Click Apply and Close to save the change. 

Note: You may need to clean the project to make the new setting take effect for the whole project.   
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 System Simulation Flow 
The SoC Project created from template has a default simulation environment for you to setup and start functional 
simulation. It is generated automatically along with the SoC project creation. You can use it as a start point and 
customize accordingly. 

The default simulation environment is with the following features: 

¶ Provides similar user experience as real board-level debugging, such as for Hello World SoC, key components 
including RISC-V MC, System memory, and UART. 

¶ Simulates user-modified template SoC with extended HDL designs. 

¶ Simulates the whole system using real C/C++ projects as stimulus with the necessary modification and with all the 
details for debugging. 

¶ Supports user extension with a friendly and flexible approach. 

3.4.1. Launch Simulation 

To launch simulation: 

1. In Propel Builder, update the SoC design to enable simulation features. 

¶ 9ƴŀōƭŜ ǘƘŜ ŎƘŜŎƪōƻȄ ŦƻǊ {ƛƳǳƭŀǘƛƻƴ aƻŘŜΣ ŀƴŘ ŘƛǎŀōƭŜ ǘƘŜ ŎƘŜŎƪōƻȄ ŦƻǊ 5ŜōǳƎ 9ƴŀōƭŜ ŦƻǊ wL{/π± a/ Lt 
ƳƻŘǳƭŜ ƛƴ ǘƘŜ DŜƴŜǊŀƭ ŀǊŜŀ όCƛƎǳǊŜ оΦнуύΦ 

  

Figure 3.28. Configure Module RISC-V MC 
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¶ 9ƴŀōƭŜ ǘƘŜ ŎƘŜŎƪōƻȄ ŦƻǊ LƴƛǘƛŀƭƛȊŜ aŜƳƻǊȅ ŦƻǊ ǎȅǎǘŜƳψƳŜƳƻǊȅ Lt ƳƻŘǳƭŜ ŦǊƻƳ ǘƘŜ LƴƛǘƛŀƭƛȊŀǘƛƻƴ ŀǊŜŀ ƻŦ ǘƘŜ 
DŜƴŜǊŀƭ ǘŀōΣ ŀƴŘ ǎŜǘ LƴƛǘƛŀƭƛȊŀǘƛƻƴ CƛƭŜ ƎŜƴŜǊŀǘŜŘ ŦǊƻƳ ǘƘŜ ŎƻǊǊŜǎǇƻƴŘƛƴƎ /κ/ҌҌ ǇǊƻƧŜŎǘ όCƛƎǳǊŜ оΦнфύΦ 

   

Figure 3.29. Configure Module System Memory 

2. Click the Switch icon  on the toolbar to switch between SoC design and SoC verification project (Figure 3.30). 

3. After the SoC design is switched to an SoC verification project, click the Generate icon  to generate the 

simulation environment for OEM ModelSim. Click the Launch Simulation icon  (Figure 3.30). 
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Figure 3.30. SoC Verification Project 

4. ModelSim is launched running simulation for the SoC verification project. The corresponding waveform of the SoC 
verification project for the Hello World project is shown (Figure 3.31). Check the waveform.  

 

Figure 3.31. Waveform of Hello World Project 

3.4.2. Simulation Details 

The default simulation environment is located at the generated sim folder inside the SoC verification project in Propel. 
It contains: 

 

You can extend more verification features in the top testbench. 

[sim]                                           -- generated simulation environment 
         [hdl_header] 

soc_regs.v              -- register definitions of all the components in DUT/SOC 
sys_platform.v      -- base address, user settings of all the components in DUT/SOC 

         [misc] 
*.*                           -- all the mem, hex, txt files will be copied here 

                  flist.f                                 -- file list for HDLs 
                  msim.do                           -- do script for simulator, it can be qsim for Questasim 
                  wave.do                           -- do script for adding signals in waveform window 
                  <project_name>.sv        -- top testbench, SystemVerilog based 
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