Lattice Radiant Software 2.2
Help

November 5, 2020
Copyright
Copyright © 2020 Lattice Semiconductor Corporation. All rights reserved. This document may not, in whole or part, be reproduced, modified, distributed, or publicly displayed without prior written consent from Lattice Semiconductor Corporation (“Lattice”).

Trademarks
All Lattice trademarks are as listed at www.latticesemi.com/legal. Synopsys and Synplify Pro are trademarks of Synopsys, Inc. Aldec and Active-HDL are trademarks of Aldec, Inc. Modelsim and Questa are trademarks or registered trademarks of Siemens Industry Software Inc. or its subsidiaries in the United States or other countries. All other trademarks are the property of their respective owners.

Disclaimers
NO WARRANTIES: THE INFORMATION PROVIDED IN THIS DOCUMENT IS "AS IS" WITHOUT ANY EXPRESS OR IMPLIED WARRANTY OF ANY KIND INCLUDING WARRANTIES OF ACCURACY, COMPLETENESS, MERCHANTABILITY, NONINFRINGEMENT OF INTELLECTUAL PROPERTY, OR FITNESS FOR ANY PARTICULAR PURPOSE. IN NO EVENT WILL LATTICE OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER (WHETHER DIRECT, INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL, INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF PROFITS, BUSINESS INTERRUPTION, OR LOSS OF INFORMATION) ARISING OUT OF THE USE OF OR INABILITY TO USE THE INFORMATION PROVIDED IN THIS DOCUMENT, EVEN IF LATTICE HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. BECAUSE SOME JURISDICTIONS PROHIBIT THE EXCLUSION OR LIMITATION OF CERTAIN LIABILITY, SOME OF THE ABOVE LIMITATIONS MAY NOT APPLY TO YOU.

Lattice may make changes to these materials, specifications, or information, or to the products described herein, at any time without notice. Lattice makes no commitment to update this documentation. Lattice reserves the right to discontinue any product or service without notice and assumes no obligation to correct any errors contained herein or to advise any user of this document of any correction if such be made. Lattice recommends its customers obtain the latest version of the relevant information to establish that the information being relied upon is current and before ordering any products.
## Type Conventions Used in This Document

<table>
<thead>
<tr>
<th>Convention</th>
<th>Meaning or Use</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Bold</strong></td>
<td>Items in the user interface that you select or click. Text that you type into the user interface.</td>
</tr>
<tr>
<td><em>Italic</em></td>
<td>Variables in commands, code syntax, and path names.</td>
</tr>
<tr>
<td><strong>Ctrl+L</strong></td>
<td>Press the two keys at the same time.</td>
</tr>
<tr>
<td><strong>Courier</strong></td>
<td>Code examples. Messages, reports, and prompts from the software.</td>
</tr>
<tr>
<td>...</td>
<td>Omitted material in a line of code.</td>
</tr>
<tr>
<td>.</td>
<td>Omitted lines in code and report examples.</td>
</tr>
<tr>
<td>[ ]</td>
<td>Optional items in syntax descriptions. In bus specifications, the brackets are required.</td>
</tr>
<tr>
<td>( )</td>
<td>Grouped items in syntax descriptions.</td>
</tr>
<tr>
<td>{ }</td>
<td>Repeatable items in syntax descriptions.</td>
</tr>
<tr>
<td></td>
<td>A choice between items in syntax descriptions.</td>
</tr>
</tbody>
</table>
Contents

Chapter 1  Getting Started with Lattice Radiant Software  8
  Tutorials  8
  User Guides  9
  Getting Help  9
  Copyright, Trademarks, and Disclaimers  12

Chapter 2  Managing Projects  14
  Running the Radiant Software  15
  Creating a New Project  16
  Modifying a Project  18
  Importing Lattice Diamond Projects  18
  Targeting a Device  19
  Viewing Project Properties  19
  Saving Project Files  20
  Managing Project Sources  21
  Working with Implementations  31
  Using Strategies  34
  Analyzing a Design  39
  Running Processes  52
  Clearing Tool Memory  56
  Setting Options for Synthesis and Simulation  56
  Working with Run Manager  63
  Finding Results  69
  Viewing Logs and Reports  70
  Setting Tool and Environment Options  75
<table>
<thead>
<tr>
<th>Chapter</th>
<th>Section Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>3</td>
<td>Entering the Design</td>
<td>76</td>
</tr>
<tr>
<td></td>
<td>HDL Design Entry</td>
<td>77</td>
</tr>
<tr>
<td></td>
<td>Packaging IP Using Radiant IP Packager</td>
<td>103</td>
</tr>
<tr>
<td></td>
<td>Designing with Soft IP, Modules, and PMI</td>
<td>116</td>
</tr>
<tr>
<td>4</td>
<td>Securing the Design</td>
<td>127</td>
</tr>
<tr>
<td></td>
<td>HDL File Encryption Steps</td>
<td>129</td>
</tr>
<tr>
<td></td>
<td>Synthesizing Encrypted IP</td>
<td>132</td>
</tr>
<tr>
<td></td>
<td>Cross-probing in Encrypted Design</td>
<td>133</td>
</tr>
<tr>
<td></td>
<td>Secure Objects in the Design</td>
<td>133</td>
</tr>
<tr>
<td></td>
<td>Securing the Bitstream</td>
<td>144</td>
</tr>
<tr>
<td>5</td>
<td>Simulating the Design</td>
<td>151</td>
</tr>
<tr>
<td></td>
<td>Simulation in the Radiant Software</td>
<td>151</td>
</tr>
<tr>
<td></td>
<td>Timing Simulation</td>
<td>156</td>
</tr>
<tr>
<td></td>
<td>Third-Party Simulators</td>
<td>157</td>
</tr>
<tr>
<td>6</td>
<td>Applying Design Constraints</td>
<td>164</td>
</tr>
<tr>
<td></td>
<td>Multiple Entry Constraint Flow</td>
<td>164</td>
</tr>
<tr>
<td></td>
<td>Understanding Implications of Radiant Software Constraint Flows</td>
<td>166</td>
</tr>
<tr>
<td></td>
<td>Timing and Physical Constraints</td>
<td>168</td>
</tr>
<tr>
<td></td>
<td>Migrating from Former Lattice Diamond Preferences</td>
<td>169</td>
</tr>
<tr>
<td></td>
<td>Migrating Pin Assignments</td>
<td>171</td>
</tr>
<tr>
<td></td>
<td>Using Radiant Software Pre-Synthesis Constraints</td>
<td>175</td>
</tr>
<tr>
<td></td>
<td>Constraint Propagation</td>
<td>180</td>
</tr>
<tr>
<td></td>
<td>Using Radiant Software Tools</td>
<td>187</td>
</tr>
<tr>
<td></td>
<td>Applying Radiant Software Physical Constraints</td>
<td>225</td>
</tr>
<tr>
<td></td>
<td>Constraint Conflict Resolution</td>
<td>235</td>
</tr>
<tr>
<td></td>
<td>Checking Design Rules</td>
<td>238</td>
</tr>
<tr>
<td></td>
<td>Analyzing SSO</td>
<td>240</td>
</tr>
<tr>
<td></td>
<td>Exporting Pin Files</td>
<td>245</td>
</tr>
<tr>
<td>7</td>
<td>Implementing the Design</td>
<td>248</td>
</tr>
<tr>
<td></td>
<td>Synthesizing the Design</td>
<td>248</td>
</tr>
<tr>
<td></td>
<td>Mapping</td>
<td>255</td>
</tr>
<tr>
<td></td>
<td>Place and Route</td>
<td>261</td>
</tr>
<tr>
<td></td>
<td>Bit Generation</td>
<td>274</td>
</tr>
<tr>
<td>8</td>
<td>Analyzing Static Timing</td>
<td>281</td>
</tr>
<tr>
<td></td>
<td>Options for Timing Analysis Reports</td>
<td>282</td>
</tr>
<tr>
<td></td>
<td>Reading Timing Analysis Reports</td>
<td>282</td>
</tr>
<tr>
<td></td>
<td>Using Timing Analyzer</td>
<td>283</td>
</tr>
<tr>
<td>9</td>
<td>Analyzing Power Consumption</td>
<td>287</td>
</tr>
<tr>
<td></td>
<td>Starting Power Calculator from the Radiant Software</td>
<td>288</td>
</tr>
</tbody>
</table>
Setting Memory Initialization Values in ECO Editor 512
Running Design Rule Check 515

Chapter 14  **Strategy Reference Guide**  516
Synplify Pro Options 520
LSE Options 526
Post-Synthesis Options 533
Post-Synthesis Timing Analysis Options 534
Map Design Options 535
Map Timing Analysis Options 536
Place & Route Design Options 537
Place & Route Timing Analysis Options 540
IO Timing Analysis Options 541
Timing Simulation Options 541
Bitstream Options 542

Chapter 15  **Constraints Reference Guide**  545
HDL Attributes 546
Lattice Synthesis Engine Constraints 563

Chapter 16  **Lattice Module Reference Guide**  635
Finding Modules in This Guide 635

Chapter 17  **FPGA Libraries Reference Guide**  637
Primitive Library - iCE40 UltraPlus 639
Primitive Library - LIFCL 644
Primitive Library - LFD2NX 650
Alphanumeric Primitives List 656
DSP Inference Guide 900
Synthesis Attributes 902

Chapter 18  **Command Line Reference Guide**  904
Command Line Program Overview 904
Command Line Basics 906
Command Line Tool Usage 911

Chapter 19  **Tcl Command Reference Guide**  956
Running the Tcl Console 957
Accessing Command Help in the Tcl Console 959
Creating and Running Custom Tcl Scripts 959
Running Tcl Scripts When Launching the Radiant Software 962
Radiant Software Tool Tcl Command Syntax 963

**Revision History** 992
Getting Started with Lattice Radiant Software

Lattice Radiant® software is the complete design environment for Lattice Semiconductor Field Programmable Gate Arrays (FPGAs). The software includes a comprehensive set of tools for all design tasks, including project management, design entry, simulation, synthesis, place and route, in-system logic analysis, and more.

To help you experiment further, example projects are available. These examples are designed to illustrate different aspects of designing with Radiant software. To see the examples, click the (Open Example) button, or choose File > Open > Design Example. In the Open Example dialog box, choose an example you wish to open, and click OK.

The rest of the Help system provides complete instructions for the different stages of the Radiant design flow and extensive reference material.

See Also

Lattice on the Web

- Lattice Semiconductor
- Answer Database
- Lattice Solutions
- Intellectual Property

Tutorials

To quickly get some hands-on experience, try the following:

- Lattice Radiant 2.2 Tutorial with CrossLink-NX (LIFCL)
User Guides

To learn more about Radiant software, see the following User Guides and Reference Manuals:

- Lattice Radiant Software 2.2 Release Notes
- Lattice Radiant Software 2.2 User Guide
- Lattice Radiant Software Guide for Lattice Diamond Users
- Migrating iCEcube2 iCE40 UltraPlus Designs to Lattice Radiant Software
- Lattice Radiant Software IP User Guide
- Programming Tools User Guide for Radiant Software
- Reveal User Guide for Radiant Software
- Reveal Troubleshooting Guide for Lattice Radiant Software
- Lattice Radiant Software 2.2 Help (HTML)
- Lattice Radiant Software 2.2 Help (PDF)
- Lattice Radiant Software 2.2 Installation Guide for Windows
- Lattice Radiant Software 2.2 Installation Guide for Linux/Ubuntu
- ModelSim User’s Manual
- ModelSim GUI Reference Manual
- ModelSim Command Reference Manual
- ModelSim Tutorial
- Synopsys Synplify Pro for Lattice User Guide
- Synopsys Synplify Pro for Lattice Reference Manual

Getting Help

For almost all questions, the place to start is this Help. It describes the FPGA design flow using the Radiant software, the libraries of logic design elements, and the details of the Radiant design tools. The Help also provides easy access to many other information sources.

To make the most effective use of the Help, please review this section.

Opening the Help

The Help can be opened in several ways:

- In Windows, choose Start > Programs > Lattice Radiant Software > Accessories > Radiant Software Help.
- In the main window, choose Help > Lattice Radiant Software Help.
To go directly to the Help for the tool that you’re using, choose Help > <Tool Name> Help.

JavaScript must be enabled in your default browser. If you are have trouble opening the Help, see “Troubleshooting the Help” on page 11.

Using the Help

The Help has several features to help you find information.

Contents  The contents organizes the information in the Help. Look here to see what subjects are covered or to begin in-depth study of a subject.

Click the  (Menu) button to hide or show the contents pane.

Search  The search locates all topics that contain specific text. This can be the fastest way to find information once you are familiar with the contents of the Help.

Just start typing in the toolbar. The Search page opens after four characters with a list of topics. Keep typing to shorten the list.

Search results are ordered by the number and types of hits found. The first few topics are most likely to have substantial information on the search terms. Topics at the end of the list may have just a casual mention of the terms.

Some tips:

To find plurals and different verb tenses, just type the beginning of the word. For example, “search” finds search, searches, searching, and searched.

Capitalization does not matter.

Enter phrases between a pair of double-quote marks. For example: "block module". Sometimes you may see search hits that do not exactly match your phrase. This is because the search ignores certain common words like “for” and “the.” So the example would also find “block the module.”

Click All next to the Search field and select User Guides or Reference Guides to limit the scope of the search.

Search Navigation Tip

Internet Explorer’s forward and back buttons may not always work the way you expect with the Search page. To go back to the Search page, type in the toolbar. Just add a letter or space, or backspace. If you’re on the Search page and want to go back to the topic you were looking at, click the  next to the Search field.
**Type Conventions Used in This Document**

<table>
<thead>
<tr>
<th>Convention</th>
<th>Meaning or Use</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Bold</strong></td>
<td>Items in the user interface that you select or click. Text that you type into the user interface.</td>
</tr>
<tr>
<td><code>&lt;Italic&gt;</code></td>
<td>Variables in commands, code syntax, and path names.</td>
</tr>
<tr>
<td><strong>Ctrl+L</strong></td>
<td>Press the two keys at the same time.</td>
</tr>
<tr>
<td><strong>Courier</strong></td>
<td>Code examples. Messages, reports, and prompts from the software.</td>
</tr>
<tr>
<td>...</td>
<td>Omitted material in a line of code.</td>
</tr>
<tr>
<td>.</td>
<td>Omitted lines in code and report examples.</td>
</tr>
<tr>
<td>,</td>
<td></td>
</tr>
<tr>
<td>[ ]</td>
<td>Optional items in syntax descriptions. In bus specifications, the brackets are required.</td>
</tr>
<tr>
<td>( )</td>
<td>Grouped items in syntax descriptions.</td>
</tr>
<tr>
<td>{ }</td>
<td>Repeatable items in syntax descriptions.</td>
</tr>
<tr>
<td></td>
<td>A choice between items in syntax descriptions.</td>
</tr>
</tbody>
</table>

**Troubleshooting the Help**

If you are having trouble with the Help, check for the following situations:

**Active Content or Scripts Are Blocked** Opening the online Help may be interrupted by one of the following messages on the Internet Explorer Information Bar:

- “To help protect your security, Internet Explorer has restricted this file from showing active content that could access your computer. Click here for options…”
- “To help protect your security, Internet Explorer has restricted this file from running scripts or ActiveX controls that could access your computer. Click here for options…”

To see the Help, click on the Information Bar and choose **Allow Blocked Content**. A dialog box with an expanded warning opens. Click **Yes**.
To avoid these warnings, either use a different browser or turn off the warning for active content in Internet Explorer.

**Note**

Doing either of these means that when you open any Web page that is resident on your computer—not just Radiant Help—the page will automatically run any active content that it has. While active content is common and can be very useful, malicious content can damage your files. Be sure you trust the software on your computer.

**To turn off the warning:**

1. In Internet Explorer, choose **Tools > Internet Options**.
2. Click the **Advanced** tab.
3. Under Security, select **Allow active content to run in files on My Computer**.
4. Click **OK**.

**Back and Forward Buttons Do Not Work with the Search Page**

Internet Explorer’s back and forward buttons may not always work the way you expect with the Search page. Instead of returning to the Search page, you go to the previous or next topic. Instead of returning from the Search page to the previous or next topic, you stay on the Search page.

To go back to the Search page, type in the toolbar. Just add a letter or space, or backspace. If you’re on the Search page and want to go back to the topic you were looking at, click the ▼ next to the Search field.

**Contacting Technical Support**

**FAQs** The first place to look. The Answer Database provides solutions to questions that many of our customers have already asked. Lattice Applications Engineers are continuously adding to the Database.

**Technical Support Request** Submit a Technical Support Request through www.latticesemi.com/techsupport.

**For Local Support** Contact your nearest Lattice Sales Office.

**Copyright, Trademarks, and Disclaimers**

**Copyright** Copyright © 2019 Lattice Semiconductor Corporation. All rights reserved. This document may not, in whole or part, be reproduced, modified, distributed, or publicly displayed without prior written consent from Lattice Semiconductor Corporation (“Lattice”).
**Trademarks**  All Lattice trademarks are as listed at www.latticesemi.com/legal. Synopsys and Synplify Pro are trademarks of Synopsys, Inc. Aldec and Active-HDL are trademarks of Aldec, Inc. Modelsim and Questa are trademarks or registered trademarks of Siemens Industry Software Inc. or its subsidiaries in the United States or other countries. All other trademarks are the property of their respective owners.

**Disclaimers**  NO WARRANTIES: THE INFORMATION PROVIDED IN THIS DOCUMENT IS "AS IS" WITHOUT ANY EXPRESS OR IMPLIED WARRANTY OF ANY KIND INCLUDING WARRANTIES OF ACCURACY, COMPLETENESS, MERCHANTABILITY, NONINFRINGEMENT OF INTELLECTUAL PROPERTY, OR FITNESS FOR ANY PARTICULAR PURPOSE. IN NO EVENT WILL LATTICE OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER (WHETHER DIRECT, INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL, INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF PROFITS, BUSINESS INTERRUPTION, OR LOSS OF INFORMATION) ARISING OUT OF THE USE OF OR INABILITY TO USE THE INFORMATION PROVIDED IN THIS DOCUMENT, EVEN IF LATTICE HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. BECAUSE SOME JURISDICTIONS PROHIBIT THE EXCLUSION OR LIMITATION OF CERTAIN LIABILITY, SOME OF THE ABOVE LIMITATIONS MAY NOT APPLY TO YOU.

Lattice may make changes to these materials, specifications, or information, or to the products described herein, at any time without notice. Lattice makes no commitment to update this documentation. Lattice reserves the right to discontinue any product or service without notice and assumes no obligation to correct any errors contained herein or to advise any user of this document of any correction if such be made. Lattice recommends its customers obtain the latest version of the relevant information to establish that the information being relied upon is current and before ordering any products.
Managing Projects

You can create a project using the Lattice Radiant software with the New Project wizard. Launch the New Project Wizard by clicking the New Project button, or choose File > New > Project. The Radiant software creates a folder with a project file (.rdf) containing basic information about the project, the beginning of a physical design constraints (.pdc) file, which controls how the design is implemented in the map and place-and-route stages, and a default strategy (Strategy1.sty).

A “strategy” is a collection of settings for controlling the different stages of the implementation process (synthesis, map, place & route, and so on). Strategies can control whether the design is optimized for area or speed, how long place-and-route takes, and many other factors. The Radiant software provides a default strategy, which may be a good collection to start with, and some variations that you can try. You can modify Strategy1 and create other strategies to experiment with or to use in different circumstances.

The project folder contains a source folder, which contains project source files.

The project folder also contains an implementation folder. Implementation folders contain process reports and other information for different implementations, or versions, of a design. Having different project implementations helps you to experiment and compare different designs. You can check the details of each implementation in a set of process reports (choose View > Reports).

As you develop your design, routine tasks can be controlled through the Radiant software graphical user interface or through scripts. The Radiant software comes with command-line and Tcl commands for many of its functions.

See Also
- “Running the Radiant Software” on page 15
- “Creating a New Project” on page 16
- “Modifying a Project” on page 18
Running the Radiant Software

The Radiant software main window is the primary interface and provides an integrated environment for managing the project elements and processes, as well as accessing all Radiant software tools and views.

To run the Radiant software main window:

- From your Windows desktop, choose Start > All Programs > Lattice Radiant Software > Radiant Software.

  Note
  
  Lattice Radiant Software is the default Programs folder name when you install the Radiant software. Change this name accordingly if you have chosen another folder name during installation.

- From your Linux platform shell window or C-shell window, execute the following (case-sensitive):
  
  `<install_path>/bin/lin64/radiant`

See Also

- “Managing Projects” on page 14

Pin the Radiant Software to Start Menu or Taskbar

You can pin the Radiant software to your Windows Start menu or taskbar, so you can open it quickly and conveniently, rather than looking for the Radiant software in the Start menu.
To pin the Radiant software to the Start menu or Taskbar:

1. Choose the Windows Start menu and find the Lattice Software icon.
2. Right-click the Lattice Software icon.
3. Click Pin to Start Menu or Pin to Taskbar.

**Note**
You should not pin the Radiant software to the Taskbar through the minimized icon on the taskbar while the Radiant software is running.

If you want to remove the pinned Radiant Software from the Start menu or the taskbar, right-click on a pinned Radiant Software icon from the Start menu or the taskbar, choose Unpin from Start Menu or Unpin this program from taskbar.

**See Also** ▶ “Managing Projects” on page 14

## Creating a New Project

A project is a collection of all files necessary to create and download your design to the selected device. The New Project wizard guides you through the steps of specifying project name and location, selecting a target device, and adding existing sources to the new project.

**Note**
Do not place more than one project in the same directory.

**To create a new project:**

1. From the Radiant software main window, click the New Project button, or choose File > New > Project.
   The New Project wizard opens.
2. Click Next.
3. In the Project Name dialog box, do the following:
   - Under Project, specify the name for the new project.
     File names for Radiant software projects and project source files must start with a letter (A-Z, a-z) and must contain only alphanumeric characters (A-Z, a-z, 0-9) and underscores (_). Spaces are allowed.
   - To specify a location for your project, click Browse. In the Project Location dialog box, you can specify a desired location.
   - Under Implementation, specify the name for the first version of the project. You can have more than one version, or “implementation,” of the project to experiment with. For more information on implementations, refer to “Working with Implementations” on page 31.
   - When you finish, click Next.
4. In the Add Source dialog box, do the following if you have an existing source file that you want to add to the project. If there are no existing source files, click **Next**.

Click **Add Source**. You can import HDL files at this time.

   a. In the Import File dialog box, browse for the source file you want to add, select it, and click **Open**.
      The source file is then displayed in the Source files field.
   b. Repeat the above to add more files.
   c. To copy the added source files to the implementation directory, select **Copy source to implementation directory**. If you prefer to reference these files, clear this option.
   d. To create empty Lattice Design Constraint (.ldc) file and Post-Synthesis Constraint File (.pdc) files that can be edited at a later time, select **Create empty constraint files**. Refer to "Timing and Physical Constraints" on page 168 for more information about constraint files.
   e. When you finish, click **Next**.

1. In the Select Device dialog box, select a device family and a specific device within that family.
   a. Choose the options you want for that device.
   b. Click **Next**.

2. In the Select Synthesis Tool dialog box, select the synthesis tool that you want to use. This choice can be changed at any time. See "Selecting a Synthesis Tool" on page 58 for more information. When you finish, click **Next**.

3. In the Project Information dialog box, make sure the project settings are correct and then click **Finish**.

   **Note**

   If you want to change some of the settings, click **Back** to modify them in the previous dialog boxes of the New Project Wizard.

Once a project has been created, the Radiant software workspace opens in the main window and displays the following:
Modifying a Project

After creating a project, you can modify the project by using the right-click menu.

To modify a project:
1. Click on the File List tab at the bottom left side of the screen to display the File List view.
2. Right-click on any part of the project in the File List view.
   - The right-click menu varies upon the different part of the project you have chosen.
   - You can choose to edit a device in the Device Selector, add source files, implementations, or strategies as needed to the project, clone a strategy, set the current highlighted strategy as active strategy, exclude certain source files from an implementation or remove a file.
   - You can also edit properties of the project in the Project Properties dialog box. You can set the top-level unit, specify the VHSIC Hardware Description Language (VHDL) Library name, and Verilog Include Search path in the Project Properties dialog box.

See Also  ➤“Managing Projects” on page 14

Importing Lattice Diamond Projects

Design projects created in Lattice Diamond software can be imported into the Radiant software using the Import Diamond Project wizard. Imported Lattice Diamond projects are targeted to devices supported in the Radiant software. Lattice Diamond design preferences will be converted into Radiant software design constraints.
To import a Diamond software project into the Radiant software:
1. In the Radiant software, choose File > Open > Import Diamond Project.
2. In the Select Diamond Project dialog box, browse to the Diamond Project file (.ldf) and select it.
   The Import Diamond Project wizard appears. Click Next.
3. In the Select Device dialog box, choose Device Family, Device, Operating Condition, Package, Performance Grade, and Part Number. Click Next.
4. In the Project Name dialog box, specify the Name and Location of your project. Lists of files to be imported, and files not to be imported, appear.
5. Click Copy to Radiant project folder if you wish to copy the imported files into your new Radiant software project.
6. Click Finish.

See Also “Managing Projects” on page 14

Targeting a Device
The Radiant software lets you re-target a design to a different device any time during the design process.

To target a device:
1. In the File List view, double-click the device name.
   The Device Selector dialog box opens. It contains all available devices and their options.
2. Under Select Device, select a device family and a specific device within that family. Then choose the options you want for that device.
3. When you finish, click OK.
   The specified target device appears in the File List view.

See Also “Managing Projects” on page 14

Viewing Project Properties
After creating a project, you can view the project-related information in the Project Properties dialog box.

To view project properties:
1. Right-click on any part of the project in the File List view, and choose Properties.
   The Project Properties dialog box opens.
2. In the dialog box, you can see the name, category, and location of the selected file. You can enter values for some of the selected sections of the project in the Value field.

See Also ➤ “Managing Projects” on page 14

Saving Project Files

You can save changes to source files and to project properties. You can also save copies of individual files and whole design projects.

Saving Changes As you are making changes to source files or to the project properties you should frequently save the files. The Radiant software offers three save commands for this:

► File > Save: Saves the currently active item.
► File > Save All: Saves all the content changes.
► File > Save Project: Saves project properties such as the target device, implementation file lists, and strategy setting.
► File > Save Project As: Opens the Save Project As dialog to save the active project.
► Click the Save icon ( ).

Also, if there are any unsaved changes when you close a project, a dialog box will open offering a chance to specify which files you want to save.

Copying a Project You can make a copy of a design project to use as the beginning of another project. (If you want the copy to backup or move the project, see “Archiving a Project” on page 21 instead.) This process saves all source and other project files that are within the project folder to another folder. Referenced files are not included.

To copy a design project:
1. Choose File > Save Project As.
   The Save Project As dialog box opens.
2. In the dialog box, browse to where you want to save the copy.
3. Click the Create New Folder button to create a new project folder.
4. Type a new name for the folder and press Enter.
5. Double-click the new folder to open it.
6. If desired, give the project a new name in the “File name” box.
7. Click Save.
   If there are open files, the Save Modified Files dialog box may open. Select files to be saved before copying and click OK.
   The current design project closes and the new one opens.
Check references to files outside of the project folder. These may need adjustment.

Archiving a Project The Radiant software offers you an easy way to archive the current project. A project archive is a single compressed file (.zip) containing the information for the entire project. After archiving a project, you can reload it in the main window at any time.

When you archive a project that contains source files stored outside the project folder, the remote files are compressed under the remote_files subdirectory in the archive.

To archive the current project:
1. In the main window, make sure the project you want to archive is open.
2. Choose File > Archive Project.
3. In the Archive Project dialog box, specify the file name and location.
4. Click Save.
   The archive file is created and stored in the specified location.

To reload the archived project:
1. In the Radiant software main window, choose File > Open > Archived Project.
2. In the Select Archived Project File dialog box, browse to the archive file.
3. Click Open.
4. In the Open Archived Project dialog box, check the destination directory. If this is not where you want to place the project files, click the Browse (...) button.
5. In the Browse for Folder dialog box, browse to where you want to place the project files.
6. Click OK.
7. In the Open Archived Project dialog box, click OK.
   The project files are extracted to the specified folder and the project is opened in the Radiant software.

See Also ► “Managing Projects” on page 14
 ► “Copying a Project” on page 20

Managing Project Sources
The Radiant software combines design sources into different categories and lists them in the File List view, as well as any folders associated with them. The source files are classified and listed under these folders, which include Strategies, Input Files, Synthesis Constraint Files, Debug Files, Script Files, Analysis Files, and Programming Files.
The following files can be found in their respective folder, as shown in Figure 1.

**Table 1: Source File Locations**

<table>
<thead>
<tr>
<th>Files</th>
<th>Folder</th>
</tr>
</thead>
<tbody>
<tr>
<td>HDL/IP Module</td>
<td>Input Files</td>
</tr>
<tr>
<td>Logic Constraint</td>
<td>Post-Synthesis Constraint Files</td>
</tr>
<tr>
<td>Reveal Project</td>
<td>Debug Files</td>
</tr>
<tr>
<td>Power Calculator/Timing Constraints</td>
<td>Analysis Files</td>
</tr>
</tbody>
</table>

You can also see implementations listed in the File List view. For details about implementations, see “Working with Implementations” on page 31.

**File List View**  The File List view of the Radiant software main window lists all the design sources. The sources are categorized by different types and are identified with different icons. Bold items are active and will be used when processing the design project. Grayed out items will not be used.

**Table 2: Files Listed in the File List View**

<table>
<thead>
<tr>
<th>File Type</th>
<th>File Extension</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project Title</td>
<td>None</td>
</tr>
<tr>
<td>Target Device</td>
<td>None</td>
</tr>
<tr>
<td>Predefined Strategy (Area, I/O Assistant, Quick, and Timing)</td>
<td>.sty</td>
</tr>
<tr>
<td>Strategy1 (that can be customized)</td>
<td>.sty</td>
</tr>
<tr>
<td>Implementation</td>
<td>None</td>
</tr>
<tr>
<td>Verilog Files</td>
<td>.v, .veri, .ver, .vo, .h</td>
</tr>
<tr>
<td>Structural Verilog</td>
<td>.vm</td>
</tr>
<tr>
<td>SystemVerilog</td>
<td>.sv</td>
</tr>
<tr>
<td>IP Module Config Files</td>
<td>.ipx</td>
</tr>
<tr>
<td>Undefined or incorrect</td>
<td>Any source reference</td>
</tr>
<tr>
<td>Synthesis Constraint Files</td>
<td>.sdc, .fdc, .ldc</td>
</tr>
<tr>
<td>Reveal Project File</td>
<td>.rvl</td>
</tr>
<tr>
<td>Simulation Project File</td>
<td>.spf</td>
</tr>
<tr>
<td>Reveal Analyzer Files</td>
<td>.rva</td>
</tr>
<tr>
<td>Power Calculator Files</td>
<td>.pcf</td>
</tr>
<tr>
<td>Programmer Project File</td>
<td>.xcf</td>
</tr>
</tbody>
</table>
Creating a New Source File

You can create a new source from within the Radiant software or external to the Radiant software.

To create a new source file:

1. In the Radiant software main window, choose File > New > File.
   The New File dialog box opens.
2. In the dialog box, select the type of file you want to create under Categories and Source Files.
   a. Fill in the file name.
   b. Browse to choose a location for the file.
   c. Check the Add to Implementation option.
   d. Choose the Implementation you want the file to be part of.
3. Click New.
   The Radiant software starts an editor that you can use to enter the information for your new source file.
4. In the editor, create a source file.

### Note
- File names for Radiant software projects and project source files must start with a letter (A-Z, a-z) and must contain only alphanumeric characters (A-Z, a-z, 0-9) and underscores (_).
- In the Linux version of the Radiant software, when you save or export a file, the dialog box does not automatically append an extension to the file name you specify. That is the standard way Linux handles the Save As dialog box. You need to manually add the relevant file extension.

### See Also
- “Managing Projects” on page 14
- “Analyzing a Design” on page 39

## Importing an Existing Source File into a Project
You can easily import existing source files into your project. Source files for a project can be stored in different locations.

The files added to the project appear in the Input Files folder. You can adjust the file order by drag-and-drop. If several modules are detected as being uninstantiated, the last one will be automatically treated as the top-level module. You can also set the top-level module from the implementation property dialog box.

### To import an existing source file:
1. Choose **File > Add > Existing File** from the Radiant software. Or, with a project opened in the Radiant software, right-click the current implementation and choose **Add > Existing File**.

   The Add Existing File dialog box opens.

2. Browse for the source file you want to import.

3. Select the file and click **Open**

   The selected file is added to the Input Files folder of the File List view. If the source file is stored outside the project folder, the path of the file is displayed.

4. Double-click the imported file. The file can be opened in the associated editor (this is a Windows-only feature).

### Tip
- Radiant software project creation supports mixed language source files, allowing you to freely mix Verilog HDL and VHDL design. The Radiant software will figure out the hierarchy structure that is associated with the module names. You need to pay special attention to the module names and the case, as Verilog is case-sensitive and VHDL is case-insensitive.

### See Also
- “Managing Projects” on page 14
Adding Reveal Debug Information
Reveal Inserter manages the addition of Reveal debug information into the Radiant software source file. By default the Reveal Inserter project file (.rvl) will be automatically added to the File List view once Reveal Inserter has successfully merged trigger and trace signal features into your design. The procedure below describes how to manually import an .rvl file.

To import a Reveal project file (.rvl):
1. In the Radiant software main window, choose File > Add > Existing File.
   The Add Existing File dialog box opens.
2. Browse for the .rvl file you generated and select it.
3. Click Add.
   The selected .rvl file is listed in the File List view.
   You can have multiple Reveal project files for your project. However, you can only set only one .rvl file active at one time.

For more information, refer to "Testing and Debugging On-Chip" on page 455.

See Also  ► “Managing Projects” on page 14

Importing Test Stimulus Files Using Simulation Wizard
If your design needs Verilog test fixture (.v) or VHDL test bench (.vhd), use the Simulation Wizard.

If multiple hierarchical test stimulus files are to be used, you should first import the top-level test file, and then add lower-level test stimulus as dependency files. The Radiant software will run all these test files in a hierarchical order during the simulation process.

To import a test stimulus file:
1. In the Radiant software, choose Tools > Simulation Wizard.
   The Preparing the Simulator Interface dialog box opens.
2. Click Next.
3. In the Simulator Project Name dialog box, enter a name for your simulation project in the Project name field.
   a. Browse to find a desired location for your project.
   b. Choose either Active-HDL or ModelSim as the Simulator.
4. In the Process Stage dialog box, all the available process stages of the FPGA implementation strategy are automatically displayed. Choose the stage you want to run simulation.

5. Click **Next**.

6. In the Add Source dialog box, browse for your desired Verilog test fixture (.v) or VHDL test bench (.vhd) and select it. Check the **Copy Source to Simulation Directory** option if you need.

7. Click **Next**.

8. In the Summary dialog box, all your simulation project information is listed, including simulator name, project name, project location, simulation stage, simulation files, and simulation libraries.

   Check the “Run simulator” option if you want to run the simulation right away.

9. Click **Finish** to exit the Simulator Wizard. Your simulation project (.spf) is added to the Script Files folder of the File List view.

**Note**

The simulation flow in the Radiant software supports source files that can be set in the File List view to be used for the following purposes:

- Simulation & Synthesis (default)
- Simulation only
- Synthesis only.

This allows the use of test benches, including multiple file test benches. Additionally, multiple representations of the same module can be supported, such as one for simulation only and one for synthesis only.

Refer to “Simulating the Design” on page 151 for more details on how to use the Simulation Wizard.

**See Also** ➤ "Managing Projects" on page 14

**Managing Constraint Files**

The following are the different types of constraint files available in the Radiant software.

- Pre-synthesis constraint file: .fdc, .ldc
- Post-Synthesis Constraint file: .pdc

**About Synthesis Constraint Files** You can add .fdc files for Synplify Pro or .ldc files for Lattice Synthesis Engine (LSE), depending on the synthesis tool you choose. The files are listed in the Synthesis Constraint Files folder in the File List view.
Adding, Activating, Editing, and Removing Synthesis Constraint Files
You can add, activate, edit, or remove synthesis constraint files in your project.

To add a pre-synthesis constraint file:
1. Right-click the Pre-Synthesis Constraint Files folder in the File List view, and choose Add.
2. Choose New File if you want to add a new pre-synthesis constraint file.
   a. Select the source files to add.
   b. Enter a file name and select a location.
   c. Click New.
3. Choose Existing File if you want to add an existing pre-synthesis constraint file.
   a. Browse to the location of the pre-synthesis constraint file to add and select it.
   b. Click Add. The selected file is added to your project.

To activate a pre-synthesis constraint file:
- Right-click the pre-synthesis constraint file in the File List view of the Radiant software, and choose Set as Active.
  The selected pre-synthesis constraint file is now activated.

Note
- You can make zero or one .ldc constraint file active in your project.
- You can make multiple .fdc constraint files active in your project.

To edit a pre-synthesis constraint file:
- Double-click the pre-synthesis constraint file you want to edit from the File List view of the Radiant software. Or, right-click the pre-synthesis constraint file you want to edit from the File List view of the Radiant software and click Open.
  The selected pre-synthesis constraint file is opened in the Source Editor. You can edit the selected file in the editor. See “Using Templates” on page 81 for more information.

To remove a pre-synthesis constraint file:
- Right-click the pre-synthesis constraint file in the File List view of the Radiant software, and choose Remove.
  The selected file is removed from your project.
About Post-Synthesis Constraint Files  You can add one or more Physical Constraint files (.pdc) to your project. They are listed in the Post-Synthesis Constraint File folder of the File List view.

Note
You can set only one .pdc file active in your project at one time.

Adding, Activating, Editing, and Removing Post-Synthesis Constraint Files  You can add, activate, edit, or remove post-synthesis constraint files (.pdc) of your project.

To add a Post-Synthesis Constraint file:
1. Right-click the Post-Synthesis Constraint Files folder in the File List view of the Radiant software, and choose Add.
2. Choose New File if you want to add a new post-synthesis constraint file.
   a. Select the source files to add.
   b. Enter a file name and select a location.
   c. Click New.
3. Choose Existing File if you want to add an existing post-synthesis constraint file.
   a. Browse to the location of the post-synthesis constraint file to add and select it.
   b. Click Add. The selected file is added to your project.

To activate a Post-Synthesis Constraint file:
Right-click the post-synthesis constraint file in the File List view of the Radiant software, and choose Set as Active.

The selected file is activated.

Note
You can set only one .pdc file active in your project at one time.

To edit an Post-Synthesis Constraint file:
Double-click the post-synthesis constraint file you want to edit from the File List view of the Radiant software. Or, right-click the post-synthesis constraint file you want to edit from the File List view of the Radiant software.

The selected post-synthesis constraint file is opened in Source Editor. You can edit the selected file in the editor. See “Using Templates” on page 81 for more information.
To remove an Post-Synthesis Constraint file:

 Right-click the post-synthesis constraint file in the File List view of the Radiant software, and choose Remove.

The selected file is removed from your project.

See “Applying Design Constraints” on page 164 for more information.

See Also ➤ “Managing Projects” on page 14

Setting the Top-Level Unit for Your Project

The top-level unit (or module) of the design must be specified. If it’s not, the Radiant software will attempt to determine the top-level unit on its own.

Since the possibility exists that the Radiant software could choose the incorrect unit, it is recommended that you manually set the top-level unit.

To set the top-level unit for your project:

1. In the File List view, right-click the active implementation folder.
2. From the drop-down menu, choose Set Top-Level Unit.

The Project Properties dialog box opens with the cursor in the Top-Level Unit Value cell.

3. Type the name of the top-level unit.

The Value cell also shows an arrow for a drop-down menu. Usually the menu shows one name or just “<Edit>.” But if the Radiant software found multiple possible top-level units, the menu will show those names. If the correct top-level unit is in the menu, you can choose it.

4. Click OK.

If the hierarchy is up-to-date, the source file that contains the top-level unit is displayed in bold.

You can also change the top-level unit when experimenting with different designs or switching between simulation and synthesis.

See Also ➤ “Managing Projects” on page 14
Modifying a Source File

Double-click on a source file to edit it using the Source Editor.

Note

For Windows file associations to work properly with the Radiant software, choose Tools > Options > File Associations and assign default programs for any of the programs listed.

You can use the Source Editor to enter or edit VHDL (.vhd), Verilog HDL (.v), or constraints (.pdc) files.

Modifying a Source File using a Different Text Editor  Alternatively, you can use the text editor of your choice to edit your source files, and then import them into your project using File > Add > Existing File from the Radiant software main window.

Note

A .pdc file can also be created or edited in the Spreadsheet View.

Do the following to open a source file using a different text editor:

1. In the File List view, right-click the text file and choose Open with from the pop-up menu.
2. Click Add if you want to add your favorite text editor.

   Note

   If you've already added a new text editor, click Edit to open the source file in that editor.

3. Specify command arguments for the external editor. The mapping between the argument substitution values and the value which replaces them are:

   \%F = File Name; \%L = Line Number

   For example, to configure the gVim text editor, use the following command line: <path>/gvim +\%L \%F

   a. In the Options dialog box, choose File Associations. From the File Associations table, choose the file type you want to open/edit in the new text editor.
   b. Click Add, and use the External Program field to add the text editor, then click OK.
   c. Use the Edit or Remove button to manage your file and associated editor list.
   d. After adding or editing the external text editor, you can save it as your default text editor by clicking OK.

See Also  “Managing Projects” on page 14
Excluding a Source File

You can exclude specific source files from logic synthesis and simulation. The source files do remain in your design project, but won’t be synthesized or simulated by the software.

To exclude a source file:

1. In the File List view, right-click the target source file and choose Exclude from Implementation.

   The selected file is excluded from the implementation and the target file is grayed out.

Note

To include the source file again, right-click the target source file and choose Include in Implementation.

See Also  ➤ “Managing Projects” on page 14

Removing a Source File

You can remove a source file from a project by using the Radiant software Remove command or the Windows’ Delete command.

Removed source files are no longer part of your project. To simply exclude a file from logic synthesis and simulation, see “Excluding a Source File” on page 31.

To remove a source file from a project:

1. In the File List view, select the file that you want to remove.

2. Right-click the filename and choose Remove, or press the Delete key on your keyboard.

   The Radiant software removes the source from the project.

See Also  ➤ “Managing Projects” on page 14

Working with Implementations

Implementations define the design structural elements of a project. An implementation contains the structure of a design and can be thought of as the source and constraints to create the design. For example, one implementation may use inferred memory and another instantiated memory. There can be multiple implementations in a project, but only one implementation can be active at a time and there must be at least one implementation.
An implementation is automatically created whenever you create a new project. You can create new implementations using the source files of an existing implementation. You can also clone (copy) an existing implementation, which includes all related files and settings.

Implementations consist of:
- Gate-Level Simulation File
- Input files
- Constraint files
- Debug files
- Script files
- Analysis files
- Programming files

Creating New Implementations

To create a new implementation:
1. With the project opened in the Radiant software, choose File > New > Implementation.
2. In the New Implementation dialog box, enter a name for the new implementation.
   This name also becomes the default name for the folder of the implementation.
3. Change the name of the implementation’s folder in the Directory text box, if desired.
4. Change the location of the implementation’s folder if desired.
5. Choose the synthesis tool from the drop-down menu.
6. Choose the default strategy from the drop-down menu.
7. Add sources files by clicking Add Source and choosing either:
   - Browser to select individual files.
   - From Existing Implementation > <implementation name> to use the source files of an implementation that already exists in this design project.
8. If you want to copy all of the source files into the new implementation folder, giving you the freedom to change the files without affecting other implementations, select the Copy source to implementation directory option.
9. To view or set properties of the source files, select a file and click Properties. The Properties dialog box opens.
   a. To change a property, click in its Value cell and enter or choose the new setting.
Cloning Implementations

To clone an implementation:

1. In File List view, right-click on the name of the implementation that you want to copy and choose **Clone Implementation**.

   The Clone Implementation dialog box opens.

2. In the dialog box, enter a name for the new implementation. This name also becomes the default name for the folder of the implementation.

3. Change the name of the implementation’s folder in the Directory text box, if desired.

4. Decide how you want to handle files that are outside of the original implementation directory. Select one of the following options:
   
   - **Continue to use the existing references**
     
     The same files will be used by both implementations.
   
   - **Copy files into new implementation source directory**
     
     The new implementation will have its own copies that can be changed without affecting the original implementation. The Synthesis Tool text box and the Default Strategy text box are not editable.

5. Click **OK**.

Customizing Files in an Implementation

After creating an implementation, you can choose to include or exclude source files for the implementation. You can customize files that are under the Constraint Files, Debug Files, Script Files, and Analysis Files folders.

**Customizing Input Files**  You can choose to:

- Add a new source file or add an existing file.
- Include the file for Synthesis, Simulation, or Synthesis and Simulation.
- Exclude the file from the current implementation.
- Remove the file from the project.

**Activate or Deactivate Files**  You can have multiple files under each of the Constraint Files, Debug Files, Script Files, and Analysis Files folders in the File List view. But only one file can be active in each of those folders. To change a file’s status to active or inactive, right-click the file and choose **Set as Active** or **Set as Inactive**.

**Saving an Implementation**  If you want to save an implementation to the project, choose **File > Save Project** from the Radiant software main window.

See Also  ➤ “Managing Projects” on page 14
➤ “Using Strategies” on page 34
Using Strategies

A **strategy** provides a unified view of all settings related to the optimization controls of an implementation tool, such as logic synthesis, mapping, and place-and-route. There are two different kinds of strategies: predefined strategy and customized strategy.

Any number of strategies can be applied to your project to find the best solution to meet your design objectives. For example, you might have one strategy with fast placement and routing attempt to take a quick look at the design, and another that's higher level and more thorough that takes longer to meet timing constraints. Although you can create an unlimited number of strategies, only one can be active at a time for each implementation, and each implementation must have an active strategy.

Strategy settings are listed in the Strategies dialog box. Open the dialog box by double-clicking a strategy name in the File List view. Each strategy is stored as an .sty file.

**Predefined Strategy**  Several strategies are predefined and supplied by Lattice: Area, I/O Assistant, Quick, and Timing. They are designed to solve particular types of designs.

- **Area**
  The Area strategy attempts to minimize area by enabling the tight packing option available in map. Use this strategy to achieve area requirements.

  Applying this strategy to large and dense designs may cause some difficulties in the place-and-route process with longer run time or not completing routing. However, when it works, you will see an area reduction.

- **Timing**
  The Timing strategy attempts to achieve timing closure. The Timing strategy uses a very high effort level in place-and-route. Use this strategy if you are trying to reach the maximum frequency on your design. If you cannot meet timing requirement with this strategy, try to customize a strategy with individual settings.

  This strategy may increase your runtime on place-and-route compared to the Quick and Area strategies. However, you will get improved time performance results when it works.

**Customized Strategy**  Excluding the predefined strategies, all other strategies can be customized in the Strategies dialog box. Edit the settings of a strategy by:

- Double-clicking the strategy name in the File List view and opening the Strategies dialog box.
- Right-clicking the strategy in the File List view and choosing **Edit** to open the Strategies dialog box.

**See Also**

- “Managing Projects” on page 14
- “Creating a Strategy” on page 35
Creating a Strategy
New strategies can be created for your design.

To create a new strategy in the Radiant software:

   The New Strategy dialog box opens.
2. Enter a name for the new strategy.
3. Specify a file name for the new strategy.
4. Choose a directory to save the strategy file (.sty) to.

The new strategy is created with all the default settings of the current design. You can modify its settings in the Strategies dialog box.

To save the strategy changes to your current project, choose File > Save Project from the Radiant software main window.

See Also  ►“Managing Projects” on page 14

Cloning a Strategy
Clone any previously created strategy or any of the Lattice predefined strategies from the File List view. The new cloned file contains all settings of the strategy being cloned. You can then modify the settings for the cloned strategy from within the Strategies dialog box.

To clone a strategy:

1. In the File List view, right-click on the strategy you want to clone and choose Clone <name> Strategy.
   The Clone Strategy dialog box opens.
2. Enter a name for the new strategy in the Strategy ID field. Note that the name used automatically appears as the file name.
3. Change the file name, if desired.
4. Choose a directory to save the strategy file (.sty) to.
The cloned strategy contains all the settings of the base strategy. You can modify the settings for the cloned strategy in the Strategies dialog box.

To save the strategy changes to your current project, choose **File > Save Project** from the Radiant software main window.

**See Also** ▶ “Managing Projects” on page 14

---

**Adding an Existing Strategy**

A previously created strategy can be added to your design.

**Note**

A strategy copied from another design project may include incorrect settings, such as path names, that could cause problems. If you copy a strategy from another project, review its settings carefully and adjust them as needed.

**To add existing strategy to your design:**

1. In the Radiant software, choose **File > Add > Existing Strategy**.
2. In the Select Existing Strategy dialog box, browse to the desired strategy file (.sty) and click **Open**.
3. In the Add Existing Strategy dialog box, enter the name for the new strategy. The name chosen appears in the File List view.

**Note**

If the selected strategy file is not in the current project directory, you may want to select the **Copy strategy file to project directory** option to avoid using a file being used by another project.

4. Click **OK**.
   
   The new strategy appears in the File List view.

5. Double-click the new strategy to open the Strategies dialog box.

6. Review the settings to ensure they are appropriate for your current project. Be sure to check the following:

   ▶ Under Synthesize Design > LSE:
     
     ▶ Macro Search Path
     
     ▶ Memory Initial Value File Search Path

   ▶ Under Post-Synthesis:
     
     ▶ External Module Files (.udb)

7. After completing your review, click **OK**.

To save the strategy to your current project, choose **File > Save Project** from the Radiant software main window.
Specifying Strategy Options
Use the Strategy dialog box to specify settings for a specific design strategy process.

To specify strategy settings:
1. In the File List view, double-click the active strategy. The Strategies dialog box opens.
2. In the left-hand pane, select a process. The left-hand pane shows a list of processes. Each process has its own settings.
3. In the right pane, double-click the Value column for the setting to be changed. A pulldown menu is displayed with a choice of settings. You can also enter filenames or directory paths into the field shown.
4. Select the value from the drop-down list, or type in the text value, and click Apply.
5. Repeat steps 2-4 to specify more settings.
6. When you finish, click OK to close the dialog box.
   All of your changes are saved to your strategy (.sty) file.

Tip
When a setting is highlighted, a definition of it is displayed at the bottom of the dialog box. You can also press F1 to view additional information for the highlighted option.

Saving a Strategy
To save a new or cloned strategy, or any change of a strategy setting to your project, click File > Save Project from the Radiant software main window.

Setting Active Strategy
Set an active strategy if you have more than one strategy in a project.

To set an active strategy:
   Right-click the target strategy and choose Set as Active Strategy.
To view the settings of the active Strategy, choose **Project > Active Strategy**. From the submenu, choose the settings to view. The Strategies dialog box opens with the settings you have chosen. You can view or edit the values of the settings.

**See Also** ▶ "Managing Projects" on page 14

### Removing a Strategy

You can remove an inactive user strategy from your design.

**To remove an inactive user strategy:**

Right-click on the target strategy and choose **Remove**.

**See Also** ▶ "Managing Projects" on page 14

### Getting Help on Strategies

To find the online Help description of strategy settings, do one of the following:

- Open the “Strategy Reference Guide” in the Contents pane of the Radiant software Online Help to display all process options in the order they appear in the Strategies dialog box. See “Strategy Reference Guide” on page 516.
  - Choose the desired process option. Strategies associated with this process are displayed.
  - Use the scroll bar to select a setting and view its description.
  - In the Radiant software File List view, double-click a strategy name to open the Strategies dialog box.
  - Highlight a setting to display its brief definition at the bottom of the dialog box, or press **F1** to view additional information for the highlighted option.

**See Also** ▶ "Managing Projects" on page 14

▶ "Strategy Reference Guide" on page 516
▶ "Creating a Strategy” on page 35
▶ "Cloning a Strategy” on page 35
▶ “Adding an Existing Strategy” on page 36
▶ “Specifying Strategy Options” on page 37
▶ “Saving a Strategy” on page 37
▶ “Setting Active Strategy” on page 37
▶ “Removing a Strategy” on page 38
Analyzing a Design

You can analyze your design in the following ways while it is being implemented.

- Before synthesis: the Hierarchy view provides a nested list of all modules and commands to access the source code for individual modules, set up test benches, and more. See “Hierarchy View” on page 39.

After synthesis, schematic views are also available. These views depend on which synthesis tool you are using:

- LSE: you can use the Radiant software’s Netlist Analyzer to see and analyze the design.

If you are using LSE, Netlist Analyzer shows how the design is mapped to the device’s architecture.

See Also ▶ “Managing Projects” on page 14

Hierarchy View

The Hierarchy view appears in the left pane below the project file list view and shows the design hierarchy as a nested list of modules, and launches automatically when you open a project. If the Hierarchy view is not open, choose View > Show Views > Hierarchy from the Radiant software main window.

The Hierarchy view also shows the full path name of the files that define each module.

See Also ▶ “Managing Projects” on page 14

Commands in the Hierarchy View

Right-click in the Hierarchy view to get several useful commands described below.

Goto Source Definition This command opens the source editor with the source code that contains the definition for that object, and automatically scrolls the view to the position in the code where the object is defined. For objects that include multi-line definitions, the entire definition is highlighted.

Goto Source Instantiation This command brings you directly to the source file where the module is instantiated, making it easy to see and fix errors.

Goto Netlist Analyzer After synthesis has been run with LSE, this command opens Netlist Analyzer with a schematic view of the design element.
Verilog Test Fixture Declarations  This command creates the Verilog test fixture declarations include file (.tfi) based on the Verilog unit selected from the Hierarchy view. This include file should be referenced by your test fixture using: `include "<file_name>.tfi"`. By including the .tfi file in your simulation test fixtures, you ensure that the design and the test fixtures stay synchronized.

Verilog Test Fixture Template  This command creates a Verilog test fixture template file (“<module_name>_tf.v”) based on the Verilog unit selected from the Hierarchy view. The template file includes a Verilog design unit with a module declaration. Use the procedure below to create a Verilog test fixture from the “<module_name>_tf.v” file.

To create a Verilog test fixture from a Verilog Test Fixture Template (“<module_name>_tf.v”) file:
1. Open the “<module_name>_tf.v” file from the project directory.
2. Import the new .v file into the project as a Verilog test fixture. Then add codes to the user defined section to complete the stimulus for your design.

VHDL Test Bench Template  This command creates a VHDL template file (“<entity_name>_tb.vhd”) based on the VHDL unit selected from the Hierarchy view. The template file includes a VHDL design unit with a component declaration and an instantiation based on the entity interface of the first VHDL design unit encountered.

Use the following procedure to create a VHDL Test Bench from the “<entity_name>_tb.vhd” file.

To create a VHDL test bench from a VHDL Test Bench Template (“<entity_name>_tb.v”) file:
1. Open the “<entity_name>_tb.vhd” file from the project directory.
2. Import the new .vhd file into the project as a VHDL Test Bench. Then add codes to the user defined section to complete the stimulus for your design.

Note
Avoid using user-defined record type array in your design. Try to use standard data type such as std_logic_vector. Using your own defined record type array may cause the signal width to be incorrect in the VHDL test bench template file generated.

Set as Top-Level Unit  You can directly set the selected module as the top-level unit by using this command.

See Also  “Managing Projects” on page 14
About Netlist Analyzer

Netlist Analyzer works with LSE to produce schematic views of your design while it is being implemented. Use the schematic views to better understand the hierarchy of the design and how the design is being implemented.

Note

Synplify Pro also provides schematic views.

To start Netlist Analyzer:

1. Synthesize the design with LSE.
2. Choose Tools > Netlist Analyzer.
   The Netlist Analyzer window opens with the RTL netlist showing.
3. In the window’s tool bar, click one of the following buttons:
   - RTL View to see the design’s logic (gates and registers) after LSE has optimized it.
   - Technology View to see the design after synthesis and translated into Lattice primitive modules.

   - Open External File to browse to a desired netlist database (.vdb) file.
   A new tab opens and is filled as described below.

About Netlist Analyzer Views  The Netlist Analyzer window consists of four parts:

- Tool bar provides buttons for various functions.
- Netlist browser provides nested lists of module instances, ports, nets, and clocks.
- Schematic view shows a schematic of the design. Depending on the size of the design, the schematic may consist of multiple sheets.
- Mini-map, which is a miniature view of the sheet, helps you pan and zoom in the schematic view.

Netlist Analyzer can have multiple schematics open. The open schematics are shown on tabs along the bottom of the window.

Bold lines are buses. Green lines are clock signals.

Note that you can adjust the view of a schematic and navigate through the hierarchy in multiple ways.

See Also  "Managing Projects" on page 14
Setting Netlist Analyzer Options
With Netlist Analyzer you can specify the following:

- Labels in the schematics
- How the hierarchy gets expanded
- Highlight color
- Size of the sheets

To change tool options:
1. Choose Tools > Options.
   The Options dialog box opens.
2. In the left-hand list, find and expand Netlist Analyzer.

Refer to the following instructions for specific options.

To specify labels:
1. Under Netlist Analyzer, select Text.
2. Select the labels you want to see in the schematics.

To control how the hierarchy gets expanded:
1. Under Netlist Analyzer, select Schematic.
2. Adjust the values of the following items:
   - Hierarchy Depth: The number of levels to show when using the Dissolve Instances command. The default, 0, displays all levels.
   - Levels of Logic to expand: The number of additional levels to show with the Expand To/From command.
   - Search depth to expand: The number of additional levels to show with the Expand to FF/IO and Expand to Primitive commands. The default, 0, displays all levels.

To change the sheet size:
1. Under Netlist Analyzer, select Sheet.
2. Change the width and height as desired.

See Also  “Managing Projects” on page 14

Adjusting the Schematic View
Netlist Analyzer schematics are usually displayed on several sheets, depending on the size of the design. More than one schematic view can be open at the same time.
To change the sheet being displayed:

- Do one of the following:
  - Click the Next Sheet button.
  - Click the Previous Sheet button.
  - Click the arrow in the Goto Sheet button. In the drop-down menu, choose a sheet number.
  - Click the name at the end of a net on the left or right side of a schematic (but not a port). This takes you to the continuation of the net on another sheet.

To change the layout in a sheet:

- Right-click in the schematic and choose Regenerate.

See Also

“Managing Projects” on page 14

Zooming and Panning

You can zoom and pan within the Netlist Analyzer schematics using a variety of methods, including toolbar commands, dragging with the schematic, and Netlist Analyzer’s mini-map.

**Toolbar Commands** The following commands are available on the Radiant software toolbar.

- **Zoom In** – enlarges the view of the entire layout.
- **Zoom Out** – reduces the view of the entire layout.
- **Zoom Fit** – reduces or enlarges the entire layout so that it fits inside the window.
- **Zoom To** – enlarges the size of one or more selected objects on the layout and fills the window with the selection.
- **Pan** – enables you to use the mouse pointer to drag the layout in any direction. This command is useful for viewing a hidden area on the layout after zooming in.

**Zooming with Function Key Shortcuts** The following key combinations enable you to instantly zoom in or out from your keyboard.

- **Zoom In** – Ctrl++
- **Zoom Out** – Ctrl+-

**Zooming with the Mouse Wheel** The mouse wheel gives you finer zoom control, enabling you to zoom in or out in small increments.

- While pressing the Ctrl key, move the mouse wheel forward to zoom in and backward to zoom out.
MANAGING PROJECTS  :  Analyzing a Design

Zooming by Dragging  Zoom by holding the right mouse button and dragging:

- To zoom to fit the window, drag up and to the left. The image adjusts to fill the window.
- To zoom out, drag up and to the right. The distance you drag determines the amount of zoom. 1 means half as big, 2 means ¼ as big, and so on. The image is reduced and centered in the window.
- To zoom in, drag down and to the right. The distance you drag determines the amount of zoom. 1 means twice as big, 2 means four times as big, and so on. The image is enlarged and centered in the window.
- To zoom in on a specific area, start at the upper-right corner of the area that you want to see better and drag to the lower-left corner of the area. The area that you drag across is adjusted to fill the window.

Zooming and Panning with World View  The World View is a small display representation of a schematic that appears in the lower-left corner of the Netlist Analyzer window. The World View shows the entire sheet with a purple rectangle marking the area that is actually showing in the schematic view.

If the World View is not shown, click the World View button at the lower-right corner of the schematic view.

To enlarge the World View, click on one of the control tabs on the edge of the mini-map and drag.

To zoom, click on one of the control tabs of the purple rectangle and drag. As the rectangle changes size, the schematic view zooms in or out.

To pan, click in the purple rectangle and drag it so that it covers the area that you want to see. As you drag, the schematic view shifts.

Click on the spot that you want to see. The schematic view jumps to that spot and centers the view.

See Also  ►“Managing Projects” on page 14

Saving Schematics
You can save a schematic as either a PDF or SVG file. As a PDF file, the whole schematic is a single file with each sheet an 8.5-inch by 11-inch page. As an SVG file, only the currently displayed sheet is saved.

To save a schematic:

1. If saving as an SVG file, select the desired sheet.
2. Choose File > Export.
   The Export Schematic dialog box opens.
3. Browse to where you want to save the file.
4. Enter a file name.
5. Click the **Save as type** drop-down menu and choose PDF or SVG.
6. Click **Save**.

**See Also**  ►“Managing Projects” on page 14

### Printing Schematics

Use the print functions of the Radiant software to print the schematics.

**To print a schematic:**

1. Choose **File > Print Preview**.
   
   The Print Preview window opens.
2. Expand the Print Preview window to the desired size.
3. To maximize the printout, click **A** for landscape mode.
4. Click the Page setup **✓** button and adjust the paper size and margins, if necessary.
5. Click the Print **✓** button.
6. Adjust the printer settings if necessary and click **Print**.

**See Also**  ►“Managing Projects” on page 14

### Navigating the Design with Netlist Analyzer

Explore a design by selecting one or more objects and then right-clicking in the schematic view and choosing a command from the drop-down menu. These commands help you to:

- Focus on one part of the design.
- Flatten the layers of a hierarchy.
- Trace the paths between objects.
- Expand selected parts of the schematic.

Most commands can be reversed by clicking the Back **✓** button. They can be repeated by clicking the Forward **✓** button. To jump back to the original view after using one or more commands, right-click in the schematic view and choose **Restore Current Schematic**.

While exploring a design, you may see a need to set a synthesis constraint. If so, drag the port, net, or register to the relevant tab of LDC Editor. See “Handling Device Constraints” on page 176.

**To select objects:**

- Click the Select **✓** button and do one of the following:
Click on the object in the schematic view. Ctrl-click to select more objects.

Click on the object in the netlist browser. Ctrl-click to select more objects.

Click and drag to draw a selection rectangle around one or more modules in the schematic view. This method only selects modules, not ports or nets.

Right-click in the schematic view and choose Select All Schematic > Instances. This command selects all module instances showing on all sheets of the schematic.

Right-click in the schematic view and choose Select All Schematic > Ports. This command selects all ports displayed on all sheets of the schematic.

Right-click in the schematic view and choose Select All Sheet > Instances. This command selects all module instances displayed on the current sheet of the schematic.

Right-click in the schematic view and choose Select All Sheet > Ports. This command selects all ports displayed on the current sheet of the schematic.

You can keep an object highlighted, but not actively selected, by right-clicking in the schematic view and choosing Highlight. This highlights the selected objects using the selected color while you continue to explore the design. Highlighted objects are not “selected” for commands. Highlighting can be erased by using the Back button.

To erase highlighting and return an object to normal display, select the object and then right-click and choose Unhighlight.

See Also  "Managing Projects" on page 14

Focusing on Part of the Design
You can focus on a specific part of a design in one of several ways:

Filter the schematic.

Reduce it to selected modules.

Trim away objects that are in the way.

Request more details of a single module.

To filter the schematic:

1. Select one or more modules from either the netlist browser or schematic view.

2. Click the Filter Schematic button.

The schematic is replaced with the selected modules. Only nets connecting the selected modules are included. Use the commands described below to expand the schematic.
To filter with signal paths:
1. Select one or more modules.
2. Right-click anywhere in the schematic view and choose **Isolate Path**.
   
   The schematic is replaced with the selected modules and modules connected to the selected modules. Only nets connecting the modules are included.

To trim the schematic:
1. Select one or more objects to hide.
2. Right-click anywhere in the schematic view and choose **Less**.
   
   The selected objects disappear. If the objects include a branch of a net, the remaining branches become dotted lines to show that part of the net is hidden.

To see the structure inside a module:
1. Click the Push down/Pop up button.
2. Drag the cursor to the module.
   
   If there is further hierarchy to see (that is, if the module is not already a primitive), the cursor changes to a blue down arrow .
3. Click in the module with the blue down arrow.
   
   The schematic changes to show just the structure of the module at the next lower level of hierarchy. To go further down the hierarchy, continue to click in a module with a down arrow.

To go back up the hierarchy, click a green up arrow when it is not over a module.

To perform other commands in the schematic, click the Select button.

To quickly push down or pop up in a module:
Do the following to push down into a module while staying in select mode:

- Right-click the module and drag straight down until the words “push down” appear. Then release the mouse button.
- To go back up the hierarchy, right-click anywhere in the schematic view and drag straight up until the words “pop up” appear. Then release the mouse button.

To work on one module in RTL view:
1. Go to the Hierarchy view. If it is not showing, choose **View > Show Views > Hierarchy**.
2. Right-click on the desired module and choose **Goto RTL Definition**.
   
   Netlist Analyzer opens with the RTL view of the module. The rest of the design is not available in this schematic.
Flattening the Design
An alternative to viewing a hierarchy is to flatten the design, which displays all the layers together in a larger, more detailed schematic. By doing so, you do not have to keep track of where you are in the hierarchy. You can flatten the entire schematic or just selected modules.

To flatten the entire schematic:
1. Right-click anywhere in the schematic view and choose Flatten Schematic.
   The entire design is shown in terms of primitives.

To return to the original schematic, right-click and choose Unflatten Schematic.

To flatten a module:
1. Select the module.
2. Right-click and choose Dissolve Instances.
   The schematic expands to include the selected module’s primitives. Boundaries, ports, labels of the module, and all submodules are included to help identify and select the modules and their ports.

Tracing Paths between Objects
Use Netlist Analyzer to trace a signal within a complex schematic.

To trace a signal path:
1. Select two or more objects on the same or different sheets.
2. Right-click and choose Expand > Expand Paths.
   Nets and modules between the selected objects are highlighted. Modules along the paths are expanded to show primitives.

Expanding from a Module
After focusing a schematic on one or more modules, do the following to see what the modules are connected to.
To see all the nets attached to a module:
1. Select the module.
2. Right-click and choose one of the following:
   - **Show Connectivity**
     Highlights all nets attached to the selected module, expanding the schematic as necessary.
   - **Expand > Expand To/From**
     Highlights all nets attached to the selected module and all primitives attached to those nets, expanding the schematic as necessary.

To see the next higher level of the hierarchy:
1. Select a module, right-click and choose **Show Context**.
2. If nothing happens, click the Push down/Pop up button. Move the cursor to the schematic view, and click the green up-pointing arrow when it appears.

See Also  ➤ “Managing Projects” on page 14

Expanding from a Port
Instead of expanding all the nets from a module, you can expand the net from a single port. If the module is not a primitive, you have the choice of expanding outward or inward to a lower level of the module’s hierarchy. Make this choice by selecting a port pointing out or in.

To see what a single port is attached to:
1. Double-click the port.
   The schematic expands to show the port’s net and one other object that is on the net.
2. If the net appears as a dashed line, only part of the net is being shown. Double-click the port again to see another branch of the net.
   If the net shows as solid line, the full net is being displayed.
   If the net is fully visible, nothing else can be done.

To see a fuller signal path from a single port:
1. Select the port. If the port is on a module, take care whether it is pointing out or in.
2. Right-click and choose **Expand**.
   A sub-menu drops down.
3. Choose one of the following from the sub-menu:
   - **Expand to FF/IO**
Highlights the net until it finds a flip-flop or an I/O pin, expanding the schematic as necessary. Modules along the path are expanded to show primitives.

- **Current Level > Expand to FF/IO**
  Same as above except that modules are *not* expanded.

- **Expand to Primitive**
  Highlights the net and all attached primitives, expanding the schematic as necessary.

- **Current Level > Expand to Primitive**
  Same as above except that modules are *not* expanded.

**See Also**

- “Managing Projects” on page 14

### Expanding from a Net

You can expand a net to show all connected primitives and ports or to show just the primitive or port driving it.

**To see all modules on a net:**

1. Select the net.
2. Right-click and choose **Go to Connected Instances**.
   
   Highlights the selected net and all connected primitives and ports, expanding the schematic as necessary.

**To see just the driver of a net:**

1. Select the net.
2. Right-click and choose **Go to Driver**.
   
   Highlights the selected net and the driving primitive or port, expanding the schematic as necessary.

**See Also**

- “Managing Projects” on page 14

### Searching in Netlist Analyzer

With larger designs, finding objects may be easier with a text search. The Find function in Netlist Analyzer allows you to search for objects in the schematic using instance, symbol, port, and net names. Found objects can be selected in the netlist browser and schematic view.

**To search the design in Netlist Analyzer:**

1. Choose **Edit > Find**.
   
   The Find dialog box opens.
2. Select the type of object that you want to search for by clicking one of the tabs at the top of the dialog box.

3. Select the part of the design to search for by selecting a level in the Search box.

4. At the bottom-left of the dialog box is the Un-Highlight Search box. Click in this box and type in your search term. You can use the following wildcards:
   - * for any number of characters
   - ? for a single character

   Or, click the arrow at the end of the box and choose from a previously used search term.

5. Click either Find 200 or Find All.
   The found objects are listed in the UnHighlight box.

6. If you clicked Find 200 and want to see more results, click either Next 200 or Find All.

7. To highlight found objects in the schematic view, do one of the following:
   - Select the desired objects in the UnHighlight box and then click the -> (right arrow) button.
   - For all found objects, click the All -> button.

   The selected objects move to the Highlight box and are highlighted in the netlist browser and schematic view. The schematic view does not expand to show objects in other layers or on other pages.

8. To reduce the number of objects in the Highlight box, select unwanted objects and then click the <- (left arrow) button. You can find objects in the Highlight list using the Highlight Search box. Anything entered in the Highlight Search box is automatically searched for and selected.

9. When you have the Highlight list the way you want, click Close.

   Highlighted objects in the schematic view stay highlighted after the Find dialog box closes.

See Also  "Managing Projects" on page 14

Getting More Information about an Object
Additional information about an object in a schematic view is available, including names, number of fanouts, source code, and pins that the nets connect to.

To get more information about an object:
1. Select one or more objects.
2. In the schematic view, right-click the object of interest and choose Properties.
The Properties dialog box opens showing a list of properties for the object.

If the object is a module, the dialog box also has a drop-down menu listing all the ports of the module. Choosing a port shows the properties for that port.

If the object is a bus, the dialog box has a drop-down menu listing all the nets that make up the bus. Choosing a net shows the properties for that net.

3. Click **Close** when finished.

**To get the hierarchy name of an object:**

1. Select one or more objects.
2. In the schematic view, right-click and choose **Copy**.
3. Paste into any text editor.
   
   The format of the name will be similar to this example:
   
   `{i:UART_INST/u_txmitt/add_24}`
   
   The first letter is i for instance, n for net, or p for port.

**To get the source code for an object:**

1. Select one or more objects.
2. In the schematic view, right-click the object of interest and choose **Jump to > Jump to HDL File**.
   
   The Source Editor opens with the code highlighted.

**See Also**  
**“Managing Projects” on page 14**

---

**Running Processes**

A process is a specific task in the overall processing of a source or project. Typical processing tasks include synthesizing, mapping, placing, and routing. You can view the available processes for a design in the Process Toolbar.

**Process Toolbar**

Click the Task Detail View to see detailed information of the processes.

Processes are grouped into categories according to their functions.

**Synthesize Design**

Click on this process to have LSE synthesize the design. By default, this process runs the LSE tool. For details, see “Synthesizing the Design” on page 248.
If you are using Synplify Pro, choose Synplify Pro as the synthesis tool (Project > Active Implementation >Select Synthesis Tool). See “Selecting a Synthesis Tool” on page 58 for details).

- **Post-Synthesis Timing Analysis**
  Runs timing analysis after the Synthesize Design process.

- **Post-Synthesis Simulation File**
  Generates a netlist file `<file_name>_syn.vo` used for functional verification.

- **Map Design**
  This process maps a design to an FPGA. Map Design is the process of converting a design represented as a network of device-independent components (such as gates and flip-flops) into a network of device-specific components (configurable logic blocks, for example). For details, see the Implementing the Design > Mapping section in the online Help.

- **Map Timing Analysis**
  Runs Map timing analysis.

- **Place & Route Design**
  After a design has been translated into the Native Circuit Description (.ncd) format, you can run the Place & Route Design process. This process takes a mapped physical design .ncd file, places and routes the design, and outputs a file that can be processed by the design implementation tools. For details, see “Place and Route” on page 261.

- **Place & Route Timing Analysis**
  Runs Place & Route timing analysis.

- **I/O Timing Analysis**
  Runs I/O timing analysis.

- **Export Files**
  You can check the desired file you want to export and run this process.

- **Bitstream File**
  This process takes a fully routed physical design or .ncd file as input and produces a configuration bitstream (bit images). The bitstream file contains all of the configuration information from the physical design defining the internal logic and interconnections of the FPGA, as well as device-specific information from other files associated with the target device. For details, refer to “Bit Generation” on page 274.

**See Also**
- “Managing Projects” on page 14
- “Managing Project Sources” on page 21
- “Process State” on page 54
- “Starting a Process” on page 55
- “Forcing a Process to Run” on page 55
- “Stopping a Process” on page 55
“Cleaning Up Processes” on page 56

**Process State**

The Process Toolbar shows the state of the processes in the active implementation. Each state is identified with different icons, as shown in the table below.

<table>
<thead>
<tr>
<th>Process State</th>
<th>Process Toolbar Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Initial</td>
<td>![Initial Icon]</td>
<td>The process has never been run or an input dependency time stamp has changed since it was last run.</td>
</tr>
<tr>
<td>Completed</td>
<td>![Completed Icon]</td>
<td>The process has been run successfully.</td>
</tr>
<tr>
<td>Completed</td>
<td>![Completed Icon]</td>
<td>Process has been completed with unprocessed subtask(s)</td>
</tr>
<tr>
<td>Error</td>
<td>![Error Icon]</td>
<td>The process did not complete successfully.</td>
</tr>
</tbody>
</table>

**Conditions that Re-initialize Process State**

A process or report is re-initialized under the following conditions:

- A process state earlier in the sequence has changed.
- An input file of the process or report has changed since the last run. For example, changing the .pdc file will cause the map process to be rerun.

**Note**

Input file changes are only detected if done by the Radiant software Source Editor or a process or report triggered by the Radiant software main window. Changes applied by third-party text editors will NOT be detected.

- Process settings have changed.
- Target device has changed. All processes will be re-initialized.
- A **Force Run** function is run.

**See Also**

- “Managing Projects” on page 14
- “Running Processes” on page 52
- “Starting a Process” on page 55
- “Forcing a Process to Run” on page 55
- “Stopping a Process” on page 55
- “Cleaning Up Processes” on page 56
Starting a Process
You can start a process on a single source file or on an entire project.

To start a process, do one of the following:
- In the Process Toolbar, click the desired process.
- Right-click the process in the Process Toolbar and choose Run.

See Also
- “Managing Projects” on page 14
- “Running Processes” on page 52
- “Process State” on page 54
- “Forcing a Process to Run” on page 55
- “Stopping a Process” on page 55
- “Cleaning Up Processes” on page 56

Forcing a Process to Run
If the process is up-to-date (indicated by a check mark to the left of the process), it will not run again. However, you can force a process to run by doing the following:
- Right-click the process in the Process Toolbar and choose Force Run.

See Also
- “Managing Projects” on page 14
- “Running Processes” on page 52
- “Process State” on page 54
- “Starting a Process” on page 55
- “Stopping a Process” on page 55
- “Cleaning Up Processes” on page 56

Stopping a Process
Do the following to stop running a certain process:
- Right-click the process in the Process Toolbar and choose Stop.

See Also
- “Managing Projects” on page 14
- “Running Processes” on page 52
- “Process State” on page 54
- “Starting a Process” on page 55
- “Forcing a Process to Run” on page 55
- “Cleaning Up Processes” on page 56
Cleaning Up Processes
Reset all processes by right-clicking a process in the Process Toolbar and choosing the **Clean Up Process** command. This command returns the status of all of the processes back to their initial state.

**See Also** ▶ “Managing Projects” on page 14

Clearing Tool Memory
The Clear Tool Memory command, available from the Tools menu, clears the device, design, and preference information from system memory. Clearing the tool memory can speed up memory-intensive processes such as place-and-route. When your design is very large, it is good practice to clear memory prior to running place-and-route.

If you have open tool views that are affected by clearing the tool memory, a confirmation dialog box opens to give you the opportunity to cancel the memory clear.

**To clear tool memory:**
1. In the Radiant software main window, choose **Tools > Clear Tool Memory**.
2. In the dialog box, choose the tool you wish to clear memory information from.
3. Click **OK**.

For more information about shared memory, refer to the *Lattice Radiant Software User Guide*.

Setting Options for Synthesis and Simulation
The Radiant software is integrated with LSE, the Synplify Pro synthesis tool, and the ModelSim simulation tool. Besides the OEM tools, you can also let the Radiant software use LSE or Synplify Pro as the synthesis tool, and full-featured versions of ModelSim or Active-HDL as the simulation tool.

This section covers steps on how to do the following:
- Selecting synthesis and simulation tools
- Defining file order for synthesis and simulation
- Customizing synthesis tool processes
- Specifying VHDL library name
- Specifying the search path for Verilog include files

Performing interactive synthesis is also discussed in this section.
About Lattice Synthesis Engine

For most devices, LSE can be used as your synthesis tool instead of Synplify Pro for Lattice or any other third-party synthesis tool.

LSE is a synthesis tool custom-built for Lattice products and fully integrated with the Radiant software. Depending on the design, LSE may lead to a more compact or faster placement of the design than another synthesis tool. LSE can be run from the Radiant software main window or through the command line, similar to the other integrated synthesis tools.

In addition, LSE offers the following advantages:

- Enhanced RAM and ROM inference and mapping, including:
  - Multiple reads
  - Dual-port RAM in write-through, normal, and read-before-write modes mapped to EBR
  - Clock enable and read enable packing
  - Mapping for the minimal number of EBR blocks
  - EBR mapping for minimal power
  - Better support for wide-mode mapping
- Comprehensive GSR inference for area and timing.
- Post-synthesis Verilog netlist suitable for simulation.

When considering LSE, note the following limitations:

- IP must be generated with a synthesis tool other than LSE. So the synthesis of IP won't be affected by a change to LSE.
- Design code may need to be modified. Modifications may involve some VHDL requirements and inferring RAM, ROM, and I/O.
- SystemVerilog features are not supported.
- Does not include interclock domain paths in timing analysis.

Switching to Lattice Synthesis Engine

When changing to LSE from another synthesis tool, the following must be done:

- Consider creating a new design implementation. You can experiment with different settings without losing your previous work. See “Working with Implementations” on page 31.
Modify the Synopsys Design Constraint (.sdc) file into an .ldc file. See “Lattice Synthesis Engine Constraints” on page 563 and “Handling Device Constraints” on page 176.

Adjust the LSE strategy settings. See “LSE Options” on page 526 and “Optimizing LSE for Area and Timing” on page 251.

Review the LSE coding tips and consider applying them to your design. See “Coding Tips for LSE” on page 85.

Review the instructions for integrated synthesis. There are some differences with LSE. See “Integrated Synthesis” on page 253.

See Also  ► “Managing Projects” on page 14

Bus Naming in LSE Output
In the LSE output files, bus names are converted to individual signal names (sometimes known as “bit blasting”) and “_c_” is added. For example, the bus name sum[0:3] becomes:

```
sum_c_0
sum_c_1
sum_c_2
sum_c_3
```

See Also  ► “Managing Projects” on page 14

Selecting a Synthesis Tool
The Radiant software supports Verilog HDL and VHDL designs using LSE or Synplify Pro as the synthesis tool.

The Radiant software is fully integrated with LSE and Synplify Pro. “Fully integrated” means that you can set options and run synthesis entirely from within the Radiant software.

If you prefer, you can use other synthesis tools by running them independently of the Radiant software.

You can specify one of them as the synthesis tool for the currently active implementation of your project. Different implementations can have different synthesis tools specified.

To select a synthesis tool:
1. Make sure you have successfully installed LSE or Synplify Pro.
2. From the Radiant software main window, choose **Project > Active Implementation > Select Synthesis Tool**.

The Project Properties dialog box appears with the active implementation selected.
3. In the Project Properties dialog box, double-click the synthesis tool in the Value column.
4. From the drop-down menu, select a tool.
5. Click OK.

If you have chosen Synplify Pro, you can either use Synplify Pro for Lattice or your own full-featured Synplify Pro. By default, the Radiant software uses the Lattice version. If you want to use Synplify Pro for Lattice, you can use the main window to start running processes. If you want to use your own full-featured Synplify Pro, you need to specify the directory it is in by doing the following:

1. Choose Tools > Options > General.
   
   The Options dialog box opens.
2. In the Directories tab, clear the use OEM option.
3. Specify the installation path for Synplify Pro in the Synplify Pro field.
4. Click OK to save your settings.

If you have a different synthesis tool, you need to specify the directory in the Options dialog:

1. Choose Tools > Options > General. The Options dialog box opens.
2. In the Directories tab, specify the installation path for the Synthesis field.
3. Click OK to save your settings.

See Also  
“Managing Projects” on page 14
“Customizing Synthesis” on page 63

Specifying VHDL Library Name

The Radiant software supports VHDL design synthesis using LSE Synplify Pro. You can specify the library name for synthesizing individual VHDL sources and modules. By default, all project-related design sources are compiled into the “work” library.

The VHDL library name can also be specified in the Synplify Pro tool. See Synplify Pro Help for details.

To specify the VHDL library target in the main window:

1. In the File List view, right-click the VHDL source for which you want to specify a library name and choose Properties.
2. In the Project Properties dialog box, type in the library name you want in the Value field and click OK.
   
   The LSE Synplify Pro tool uses the specified library name to synthesize the selected VHDL source file or module.

See Also  
“Managing Projects” on page 14
Specifying Search Path for Verilog Include Files

The Radiant software supports Verilog design synthesis using LSE, or Synplify Pro. If a Verilog file is added to your design and additional files are referenced using the include directive, you can specify the search path in the Radiant software for searching include files.

**Note**

If the include file in your Verilog file changed after you opened the relevant project in the Radiant software, you need to use the **Rerun All** or **Rerun** command to force the process to rerun so that the Radiant software can reflect the changes of the include file.

You can also specify a Verilog include file search path directly in LSE, or Synplify Pro. See "Running SYNTHESIS from the Command Line" on page 921, and the Synplify Pro Help for details.

**Synplify Pro and LSE Search Path**

If you select Synplify Pro or LSE as the synthesis tool, you can only specify the search path for the entire project. Synplify Pro or LSE searches for the include file in the following order, and stops at the first occurrence of the include file it finds.

1. The directory of the file that specifies the 'include' directive.
2. The directories that are specified in the “Search Path” option for the entire project.
3. The current project path is added automatically by the Radiant software if you do not specify either the 'include' directive or the directories specified in the “Search Path” option for the entire project. Therefore, you do not need to specify the project path in the Radiant software. The path will be added automatically.

**Specifying Search Path in the Radiant software**

**To specify the search path in the Radiant software:**

1. In the File List view, right-click the implementation name if you want to specify the search path for the entire project.
2. Choose **Properties** from the right-click menu.

   The Project Properties dialog box opens.
3. In the dialog box, select **Verilog Include Search Path**, and do either of the following:
   - To add a single search path, click the Value field to enter a path.
   - To add multiple paths, click the ... button from the Value field to get the Verilog Include Search Path dialog box. Next, click the ➕ icon to browse for a new path and click **OK**. The new path is displayed in the Verilog Include Search Path dialog box. Repeat to add more paths.
You can use the ↑ and ↓ button to arrange the order of the paths, or use the × button to delete a path. Click OK when finished.

4. Click OK to exit the Project Properties dialog box.

The search paths you added are applied. The Synplify Pro tool uses the specified search paths to search for the include files referenced in your design other than the directory of the file that specifies the include directive.

See Also  
➤“Managing Projects” on page 14

**Specifying Verilog and VHDL Parameters**

You can add Verilog compiler directives and parameters or VHDL generics for the entire design in the properties of each design implementation. You may find this method an easier way to experiment with these settings.

To add Verilog compiler directives and parameters or VHDL generics:

1. In the File List view, right-click the implementation’s name and choose Properties.
   
   The Project Properties dialog box opens showing the implementation’s properties.

2. In the HDL Parameters row, click under Value.

3. Type the statements as a single text line with different statements separated by semi-colons (;).

4. When done, click OK.

See Also  
➤“Managing Projects” on page 14

**Selecting a Simulation Tool**

The Radiant software supports functional and timing simulation for Lattice FPGA devices using ModelSim/Questa Sim or Active-HDL. You can specify either one as the simulation tool for your project in the Simulation Wizard (Tools > Simulation Wizard from main window). For more details on how to use Simulation Wizard, see “Simulating the Design” on page 151.

See Also  
➤“Managing Projects” on page 14
Specifying Input Files for Simulation

If your design includes one or more test bench files to use in your simulation but you don’t want to synthesize them, you can specify this in the properties for each input file. New files are automatically marked for both synthesis and simulation.

To change the synthesis/simulation property of a file:
1. In the File List view, right-click the filename.
2. In the drop-down menu, choose Include for and then the desired property:
   - Synthesis and Simulation
   - Synthesis
   - Simulation

You can also set the synthesis/simulation property in the Project Properties dialog box. You can open the dialog box by choosing Project > Property Pages.

See Also  ►“Managing Projects” on page 14

Defining File Order for Synthesis and Simulation

The File List view lists design input files in a specific order. The synthesis or simulation tool uses that order to sequentially synthesize or simulate each input file. You can adjust the file order by the “drag and drop” operations. The file list can include a combination of VHDL and Verilog files. If you have not manually set a top-level module (in the Project Properties dialog box of the main window), the last file on the file list is normally treated as the top-level module.

File order is especially important for VHDL files. Package files must be first on the list because they are compiled before they are used. If design blocks are spread over several files, specify them in the following file order:
1. The file containing the entity,
2. The architecture file.
3. The file with the configuration.

Verilog file order is important when define statements are dedicated to a single file. This file should be compiled prior to any files that refer to the variables.

To define the file order for logic synthesis and simulation:
- In the Input Files section of the File List view, change the file order as you like by dragging the file name and dropping it to the desired location.
The new file order takes effect immediately. However, the order will only be saved once you save the design project.

See Also  ►“Managing Projects” on page 14

**Customizing Synthesis**

The Radiant software supports Verilog and VHDL synthesizing using LSE, and Synplify Pro.

You can adjust synthesis tool options and perform the logic synthesis process for your Verilog or VHDL design within the Radiant software.

**To adjust synthesis tool options and perform the synthesis process:**

1. Choose **Project > Active Strategy > <synthesis tool> Settings**.
2. The option settings of the selected process, LSE, or Synplify Pro are listed by default in the Strategies dialog box.
3. Double-click the Value field of the option. You can specify the option using the drop-down menu of the Value field.
4. Click **OK** to accept the new synthesis tool options and exit the Strategies dialog box.
5. In the Process view, double-click the Synthesize Design process to execute the selected synthesis tool.

If you prefer leveraging all the interactive features available in the synthesis tool while maintaining HDL source in the main window, see “Synthesizing the Design” on page 248 for more details.

See Also  ►“Managing Projects” on page 14

**Working with Run Manager**

Large designs can quickly get complicated, and the best approach is not always obvious or definite. There may be many ways to get optimal performance out of your design—the key is to find one option that works.

In Radiant software, each project can contain multiple source files, strategies, and implementations. Implementations are comprised of selected source files and only one strategy. You can create multiple implementations to bind different strategies.

After creating implementations, use Run Manager to run multiple synthesis and place and route passes, compare the results of multiple implementations for further analysis to get best solutions. Run Manager helps you to manage running the design implementation process with multiple project implementations (versions) and to compare the results. You can monitor progress, view reports, and quickly identify the best implementation.
See Also  ► “Using Strategies” on page 34
► “Working with Implementations” on page 31

Setting Up Run Manager

Before using Run Manager, consider if you want to do multiple place-and-route runs on individual implementations to get different timing and area results.

If you have a lot of implementations and don’t want to run them all, you may want to hide some of them in Run Manager.

Also, consider your system’s ability to run multiple processes. If you have several implementations running simultaneously in Run Manager, you may see performance problems because of RAM resource conflicts.

Setting Up Multiple Runs on an Implementation  You can get multiple place-and-route runs, using different seed values, on a single implementation. The different values can produce significantly different timing and area results.

To set up multiple place-and-route runs on an implementation:

1. In the File List view, right-click on the strategy of the implementation and choose Edit. Strategies are listed in the Strategies folder. If you are not sure which strategy is being used, you can check the Implementation column in Run Manager. It includes the strategy name for each implementation.

   The Strategies dialog box opens.

2. In the Process box, on the left, choose Place & Route Design.

3. Find Placement Iterations and double-click the Value box. Enter the number of place-and-route runs you want to make. (For more on this option, see “Placement Iterations” on page 538.)

4. Find Placement Save Best Run and double-click the Value box. Enter the number of place-and-route runs you want to see. Run Manager will show you this many of the best results. (For more on this option, see “Placement Save Best Run” on page 539.)

5. Click OK.

Hiding Implementations  Run Manager normally shows all the implementations of the project. But you can choose to hide any of the implementations from Run Manager except for the active implementation.

To change which implementations are showing:

1. Choose Tools > Run Manager.

   Run Manager opens with a table listing the implementations available. The row in bold font indicates the active implementation.
2. If you want to hide the active implementation, right-click an implementation that you will continue to show and choose Set As Active. This implementation becomes the active one for the project. The row changes to bold type and, in File List view, the implementation is expanded. The previously active implementation becomes inactive and can be hidden.

3. Highlight the implementation, right-click, and choose Show/Hide Implementation. The Show/Hide Implementation dialog box opens.

4. In one of the columns, select one or more implementations that you want to move to the other column.

5. Click the arrow button pointing to the other column.

6. When you have the Hidden and Show lists as you want them, click OK.

**Improving System Performance** You can improve your system’s performance while running Run Manager by limiting the number of processes sharing the memory. Allowing fewer processes means your computer spends less time swapping data in and out of the hard drive. But fewer processes than the number of available processors could mean processors sitting idle. You will need to find a balance based on your computer and the way you tend to use Run Manager.

**Running Run Manager**

After setting up Run Manager (see “Setting Up Run Manager” on page 64), you are ready to run your implementations.

**To process multiple implementations using Run Manager:**

1. Choose Tools > Run Manager. Run Manager opens with a table listing the implementations available. The row in bold font indicates the active implementation.

2. Select the implementations that you want to run by setting the check boxes. Select them all by clicking the check box in the heading row.

3. In Run Manager’s tool bar, click the Run button. You can force implementations that have already been run (the Status column says Completed) by clicking the Rerun button. While running, you can pause or stop the runs. Select a running item by clicking anywhere in its row. Then click either the Pause or Stop button. Run Manager may take a few moments to respond.

To continue a paused run, select it and click the Run button.

**Note**

The Process menu commands also control Run Manager, but they only affect the active implementation. This is true whether you choose the command from the Process menu in the menu bar or the right-click menu in the Process view.
4. When the runs are complete, compare the statistics that appear. These statistics provide a quick comparison of the quality of results. See “Reading the Run Manager Results” on page 66.

If you set up an implementation to do multiple place-and-route runs, click the plus sign to show the individual results. The top scoring result for each implementation is shown in italics and will be used in any further processing with that implementation.

5. If you want to save the results, go to Run Manager’s tool bar and click the Export button. In the Export Run Manager File dialog box, browse to where you want to save the results and enter a file name. Then click Save.

All the data showing in Run Manager are saved in a comma-separated values (.csv) file that can be opened with a spreadsheet tool such as Excel.

6. For more details, go to the Reports view. The Reports view shows a tab with a set of reports for each implementation. To jump to a specific report, in Run Manager, right-click the row for the implementation and choose Show Report > <report>. See “Viewing Logs and Reports” on page 70.

Also, examine the Output view, including checking for any warning or error messages.

7. After studying the results, you can select one of the implementations and one of its runs for further development. See “Selecting an Implementation and Run” on page 69.

---

**Reading the Run Manager Results**

Run Manager displays results with a table. Every implementation in the project gets a row. If an implementation did multiple place-and-route runs, each run has a row under its implementation. If you don’t see the separate place-and-route runs, expand the hierarchy tree under the implementation row.

Bold text shows the active implementation. Italic text shows the active run out of multiple place-and-route runs. This is the run that will be used in further processing of that implementation.

There are several columns showing the results for the implementations and the place-and-route runs. The columns are described below. Compare the results across rows to see which run worked best.

For the active implementation, you can see the status of the different processes by looking at the Process view. To see the status of another implementation, right-click the implementation in Run Manager and choose Set As Active.

For more details, check the Reports view. The Reports view shows a tab with a set of reports for each implementation run. See “Viewing Logs and Reports” on page 70.
**Changing the Display**  You can adjust the display by re-arranging the columns and sorting the runs. By default, many of the columns are hidden but you can choose which ones you want to see.

To change which columns are displayed:
- Right-click in any column heading and choose the column that you want to hide or show. Columns that are showing have a check mark. The Implementation<Strategy> column cannot be hidden.

To re-arrange columns:
- Click on the heading of the column that you want to move and drag it to where you want it.

To change the width of columns:
- Do one of the following:
  - Right-click in any column heading and choose Adjust Column Width to Contents.
    All columns are adjusted based on their contents.
  - Click on the right-hand border of a column and drag to make that column narrower or wider.

To sort the runs:
1. Click in the heading of the desired column.
   The rows are sorted according to the contents of that column.
2. To reverse the order of the rows, click in the same column again.

**Column Descriptions**  There are many columns of data available. Most of these apply only to the implementation rows, not the individual place-and-route runs.

- Implementation<Strategy>: The name of the implementation followed by the strategy (in angle brackets) that implementation is using. Use the check boxes to select which implementations to run. This column cannot be hidden.
- Current Step: The implementation process, such as Synthesis and Map, that is currently running.
- Status: The status of the implementation, such as Running, Pause, and Completed.
- Next Step: The next implementation process that will run after the current process finishes.
- Worst Slack: The worst timing slack for all timing constraints. Negative values indicate timing violations.
- Timing Score: The time, in picoseconds, by which the design is failing to meet the timing constraints. Zero means the run fully met the timing constraints.
If an implementation has multiple place-and-route runs, the implementation row shows the value of the active place-and-route run.

- **Worst Slack (Hold):** The worst timing slack for all timing constraints based on hold time. Negative values indicate timing violations.

- **Timing Score (Hold):** The time, in picoseconds, by which the design is failing to meet the timing constraints based on hold time. Zero means the run fully met the timing constraints.

- **Slice:** The number of slices used versus the total number available.

- **Unrouted Nets:** The number of unrouted nets. Anything larger than zero means that place-and-route did not finish.

If an implementation has multiple place-and-route runs, the implementation row shows the value of the active place-and-route run.

- **Run Time:** The total run time for the synthesis, map, and place-and-route processes, including multiple place-and-route runs. Times for translate, trace, and exporting files are not included. The format is `<hours>:<minutes>:<seconds>`.

- **Level/Cost:** The first number is the Placement Effort Level specified in the Place & Route Design section of the strategy, not necessarily the effort used.

  The second number is the number of placement iterations that were run to get a solution. If an implementation has multiple place-and-route runs, the second number is cumulative of preceding runs. That is, if the design only needs one iteration, the list of place-and-route runs shows 1, 2, 3, .... The implementation row shows the value of the active place-and-route run.

- **Location:** The full pathname for the implementation.

- **Start:** When synthesis started. Not applicable for EDIF projects.

- **Level/Cost:** The first number is the Placement Effort Level specified in the Place & Route Design section of the strategy, not necessarily the effort used.

  The second number is the number of placement iterations that were run to get a solution. If an implementation has multiple place-and-route runs, the second number is cumulative of preceding runs. That is, if the design only needs one iteration, the list of place-and-route runs shows 1, 2, 3, .... The implementation row shows the value of the active place-and-route run.

- **Description:** An editable text box. Initially it just has the implementation name but you can change it.

  To change the description of an implementation, double-click the Description cell. Then enter any text you want.

- **GSR:** The number of GSR used versus the total number available.

- **PIO:** The number of PIO used versus the total number available.

- **EBR:** The number of EBR used versus the total number available.

- **PCS:** The number of PCS used versus the total number available.
Number Of Signals: The number of signals in the design.

Number Of Connections: The number of connections in the design.

Selecting an Implementation and Run

After studying the results, you can select one of the implementations and one of its runs for further development.

To select an implementation and run:

1. Right-click on the implementation’s row and choose Set As Active.
   This implementation becomes the active one for the project. The row changes to bold type and, in File List view, the implementation is expanded. The previously active implementation becomes inactive.

2. If the implementation has multiple runs, right-click the preferred run and choose Set As Active.
   The results of this run will be used in further development such as exporting files. The row changes to italic type.

Finding Results

After you load a design in the Radiant software, you can find the information you need by doing the following.

1. Choose Edit > Find in Files from the Radiant software main window.
2. Type the text to find in the pop-up Find In Files dialog box.
3. Specify the search path and search filters.
4. Select the search parameters desired: Search subdir, Include hidden files, Match case, Match whole word, and Regular expressions.
5. Press Find. The results are displayed in the Find Results frame. Double-click any of the findings from the Find Results frame to open the associated source file in the associated editor. For example, if the finding is in a log file, the log file will be opened in the Reports view with the first finding appears on the first line.

You can search the Output log by clicking in the Output View (in the text, not on the tab) and then pressing Ctrl-F. This opens a basic text search dialog box at the top of the Output View. You can type the text in the Find text field and start a search.

Find Results View

If the Find Results are not automatically displayed in your Radiant software main window, select View > Show Views > Find Results to display them.

The Find Results view can be detached from the main window by clicking the detach icon on the upper-right corner of the view. After detaching, you can double-click on the title bar of the view to re-attach it back to the main window.
**Viewing Logs and Reports**

The Radiant software automatically generates log files for all project activities. The log files contain processing information, as well as error and warning messages. If you run processes, reports are generated.

**Viewing Logs**  A log file is displayed in the Output frame as a process is running. A scroll bar can be used to scroll up and down to view all log information.

Errors are displayed in red, while warnings are displayed in orange. A check mark indicates the view is displayed.

**Viewing Reports**  The Reports view displays reports for the major processes.

There are two panes in the Reports view. The left pane lists the report types. The reports in detail are displayed in the right pane.

<table>
<thead>
<tr>
<th>Type of Report</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project Summary</td>
<td>Lists the summary information of the project.</td>
</tr>
<tr>
<td>Map Report</td>
<td>Lists Map, Map Resource Usage, and Map Timing Analysis reports in HTML format.</td>
</tr>
<tr>
<td>Place &amp; Route Report</td>
<td>Lists Place &amp; Route, Signal/Pad, and Place &amp; Route Timing Analysis, and I/O Timing Analysis reports in HTML format.</td>
</tr>
<tr>
<td>Export Report</td>
<td>Lists Bitstream and IBIS Model reports in HTML format.</td>
</tr>
<tr>
<td>Misc Report</td>
<td>Lists Last Build Log, Tcl Command Log, and Constraint DRC in HTML format.</td>
</tr>
</tbody>
</table>

**Cross probing Reports**  Between the different tool views in Radiant, a user can click on a hyper-link icon to cross probe into that tool.

▶ Post-Synthesis & Map timing report links to Netlist Analyzer.
In the PAR timing report, user can cross probe to Netlist Analyzer, Physical Designer Placement Mode and Routing Mode.

Note

When the Reports tab is detached from Radiant main GUI, Reports window and Radiant main GUI are same level windows, which means they could be put in different displays, and also be put side by side.

But, if they are both in maximum size mode and displayed in same monitor, you may only see one. In this case if you view Reports window in maximum mode and use cross probing, it will cross probe to Radiant main GUI which is not activated and invisible. To check the cross probing result, please activate Radiant main GUI to make it visible.

Other Reports The Synthesize Design stage produces reports that do not appear in the Reports view. You can find these reports in the implementation folder by right-clicking the implementation name in the File List view and choosing Open Containing Folder. A window will open showing the contents of the folder. All of these reports can be read with a text editor.

One of the reports is a detailed description of the device resources that will be used by the design. This report is much more detailed than the synthesis report in the Reports view, as it includes the resources used by each module of the design. Similar information can also be found in the Hierarchy view. For Synplify Pro, look for <top_module>.areasrr; for Lattice Synthesis Engine, <top_module>.arearep.

See Also ➤ “Managing Projects” on page 14
➤ “Finding Results” on page 69

Navigating Errors and Warnings

If an error or a warning results from the specific line in an HDL source file, you can easily go to that line to edit the source file.

To navigate errors and warnings:

➤ In the Output View, located in the lower right of the Start Page, double-click the line describing the error or warning.

➤ Right-click the message and choose Location in > Text Editor. If the command is dimmed, there is no link to a source file. Depending on the message, more than one tool may be available to view the source.

Your default text editor opens with the appropriate HDL source file at the line number specified in the error or warning message. You can then modify the file to debug your design.

See Also ➤ “Managing Projects” on page 14
➤ “Finding Results” on page 69
Finding Text in Logs and Reports

You can search for text in the Output View.

To search for text in the Output View:
1. Right-click in the Output View and choose Find in Text.
   The Find toolbar appears.
2. In the Find text box, enter the text to search for. Check the Match Case or Match whole word only options as needed. As you type each character, the window displays any matches found.
3. Use the Next and Previous buttons in the Find toolbar to find other occurrences of the text.

To search for text in the Reports view:
1. Choose Edit > Find.
2. In the Find text box, enter the text to search for. Check the Match Case option if needed.

See Also
► “Managing Projects” on page 14
► “Finding Results” on page 69

Filtering Messages

The number of messages produced by the design implementation process can be very large. There are several ways to filter these messages to find the ones of most interest. Messages can be filtered by:

► Implementation process
► Severity (information, warning, and error)
► ID number
► Text

To set filter options:
As filters are added, the message list changes to show the latest results.
1. After running part or all of the implementation process, choose View > Show Views > Message.
2. Select the Messages Tab at the bottom of the screen.
3. Click on one of the following icons: Show Error ( ), Show Warning ( ), or Show Information ( ).
4. Specify any message ID to hide by right-clicking the desired message ID and choosing Filter > Filter Messages with This ID.
5. To hide a specific group of messages, right-click on a message and choose Filter > Filter Messages Exactly Like This, Filter Messages
from this Process, or Filter Messages with this Severity. This hides all messages with the same text, process, and severity.

To list only messages that have been hidden, right-click in the Message area and choose Filter > Filter Details List. The Detailed Filter List dialog box opens showing a list of the hidden messages.

6. To unhide messages, right-click in the Message area and choose Filter > Filter Details List. From the Detailed Filter List dialog box, uncheck the box in the Filter Enable column of the message(s) to unhide and click Apply.

7. To filter messages by process, in the Filter Message by Process button, click the down arrow to display the pop up menu. By default, all processes are selected with a checkmark. Processes include Synthesis, Map, Place & Route, Export, and Project. To filter messages to show only messages associated with a specific process or processes, uncheck the processes that you do not wish to view. Leave checked the process or processes for which you wish to view messages.

Changing Warnings to Errors

There may be warning messages in your design project that you want to place emphasis on. You can do so by changing these warnings to show the error severity level. You can also save these “promotions” to use in other design projects.

Promotions only show for messages with future actions. Promotions do not affect the display of messages from past actions.

Note:

After changing a warning to an error, the original flow will fail during the rerun process.

To change a warning to an error in the Messages Tab:

1. Right-click on the message to highlight and choose Change Severity with This ID to.

Not all warning messages can be highlighted in this way, so this command may be dimmed.

To change a warning to an error without the Reports view:


The Message Promotion dialog box opens.

2. In the IDs box, type the ID number of the message(s) that you want to promote. Separate multiple ID numbers with semi-colons (;).

3. Click Promote.
Not all warning messages can be promoted, so some ID numbers may be rejected.

4. Click **Close** when finished.

**To restore a message ID to the warning level:**

1. Choose **Project > Message Promotion/Demotion**.
   
   The Message Promotion dialog box opens.

2. Select the message to restore.

3. Click **Remove**.

4. Click **Close** when finished.

**To save the list of promoted messages for another project:**

1. Choose **Project > Message Promotion/Demotion**.
   
   The Message Promotion dialog box opens.

2. Click **Export**.

3. In the Export Promotion dialog box, browse to where you want to save the list.

4. Enter a file name.

5. Click **Save**.
   
   The list is saved to a file with a “.pmt” extension.

6. Click **Close** when finished.

**To use an existing list of promoted messages:**

1. Choose **Project > Message Promotion/Demotion**.
   
   The Message Promotion dialog box opens.

2. Click **Import**.

3. In the Import Promotion dialog box, browse to the list you previously saved and want to import.

4. Click **Open**.
   
   The list of messages appears in the Message Promotion dialog box.

5. Click **Close** when finished.

**See Also**  
►“Managing Projects” on page 14

**Getting Help for Messages**

Some messages offer a link to online Help that provides additional information. This information may help you better understand an error message or how to fix a specific problem.
To check for help on a message:
1. Right-click on the message in the Output View.
   A menu appears. The last item in the menu is Help. If it is dimmed, there is no help link.
2. If the Help command is available, click on it.
   The Help opens with the appropriate topic.

See Also ► “Managing Projects” on page 14

Setting Tool and Environment Options

The Radiant software provides many environment control and tool view display options that enable you to customize your settings.

To access these options:

Choose Tools > Options.

The Options dialog box is organized into functional folders.

Commonly configured items include:

- General settings -- allows you to set some common options, including:
  - Startup – enables you to configure the default action at startup and also to control the frequency of checking for software updates.
  - File Associations – allows you to set the programs to be associated with different file types based on the file extensions.
  - Directories -- Set directory location for Synthesis and Simulation tools.
  - Network Settings – Apply a proxy server and specify a host and port.
- Color settings -- allows you to set colors for such GUI features as fonts and backgrounds for various Radiant software tools, including:
  - General
  - Device
  - Design
  - Group
  - Reveal Analyzer
  - Source Editor

You can also change the Theme color of Radiant software (Dark or Light) using the Themes drop-down menu.

- Tools settings -- allows you to set options for various Radiant software tools, including the Device Constraint Editor, Nelist Analyzer, Timing Constraint Editor, and Source Editor. You can also to check Constraint design rule checking (DRC), prior to saving or when launching a tool.
You can enter your design, or describe the logic of our design, in several different ways and you can use the ways in almost any combination. Radiant software accepts, and helps create, Verilog, VHDL and SystemVerilog files. Design files can be created using Synplify Pro.

Setting specifications to control synthesis or simulation or to control how the design is implemented in hardware are treated as a separate topic. You will almost always want to at least start entering your design before setting constraints.

**Verilog, SystemVerilog, and VHDL** The hardware design languages (HDL) Verilog, SystemVerilog, and VHSIC Hardware Description Language (VHDL) are the usual ways to describe complex logic designs. You can create HDL files using your preferred HDL editor and then add them to your Radiant software design project, or you can create or edit them within the Radiant software.

**Modules** Modules are functional bits of design that can be re-used wherever that function is needed. To help your design along, the Radiant software provides a variety of modules for common functions. They are optimized for Radiant software device architectures and can be customized. Use these modules to speed your design work and to get the most effective results. See “Designing with Soft IP, Modules, and PMI” on page 116.

**Structural Verilog** Lattice Synthesis flow will by default generate a netlist which is a Structural Verilog (.vm) file. This .vm file can be used by itself as a whole design, or it can be referenced as an IP module to be used in another design. Any Verilog file -- Structural or Behavioral (.v or .vhdl) -- can be used for design entry.
**HDL Design Entry**

The Radiant software supports HDL design including pure VHDL design, pure Verilog design, and mixed VHDL and Verilog HDL design. You can use the integrated Source Editor to create and edit your HDL source files and any text-based files.

Source Editor is a text entry tool built into the Radiant software. You can use this tool to create and edit text-based files, such as HDL files, preference files, script files, test files, and project documentation files. Like many other advanced editing tools, it supports multiple file editing, wheel mouse scrolling, as well as popup menus for cut, copy, and paste operations. If a data source changes since the view was initialized, the view will detect this condition and provide you an option to refresh it.

Designed particularly for HDL file editing, Source Editor highlights the std_logic keywords and displays different HDL syntax elements with different colors. The color scheme can be customized in the Options dialog (Tools > Options from the main window). Also, Source Editor enables you to check correct pairing of parenthesis constructs and offers rich template features.

**Note**

To avoid errors, observe the following file naming rules:

- Do not leave blank spaces in file names when you save source files in Source Editor, otherwise the files could fail to generate the database.
- Begin file names with an alpha character (letter) rather than a numeric character (number).
- Use underscores (_) rather than leave blanks in file names.
- Unicode characters are not supported.
- Keep file names, and paths to files, short as possible.
- Linux operating system is case-sensitive. Use lower-case letters in file names to avoid issues with case-sensitive operating systems.

If you are going to use Lattice Synthesis Engine (LSE) to synthesize the design, there are helpful Verilog and VHDL coding tips in “Coding Tips for LSE” on page 85.

**See Also**
- “Running Source Editor” on page 77
- “Viewing Logs and Reports” on page 70

**Running Source Editor**

You can run Source Editor in several ways.

**To run Source Editor, do one of the following:**

- From the File List view, double-click a file—for example, filename.vhd
ENTERING THE DESIGN : HDL Design Entry

Creating HDL Source Files in Source Editor
You can create an HDL source file in Source Editor.

To create an HDL source in Source Editor:
1. From the Radiant software main window, choose File > New > File. In the New File dialog, choose Verilog Files, SystemVerilog, or VHDL Files from the Source Files list.
2. In the pop up New File dialog, fill in the Name and Location, and choose the file extension in the Ext field.
3. Check the Add to Implementation option if you want to add this source to the current project.
4. Click New.
5. In the pop up Source Editor, you can enter the text. When finished editing, click File > Save from the Radiant software main window.

Tip
You can detach Source Editor from the Radiant software main window by clicking the Detach Tool icon on the upper right corner of Source Editor. If you want to attach Source Editor back to the main window, click the Attach Window icon on the upper right corner of Source Editor window, or choose Window > Attach Window from Source Editor.

Editing Text Files
This section describes the editing functions in Source Editor.

Editing a Column of Text
You can cut, copy, and paste a column of selected text in Source Editor. You can also use the Tab key to increase the left indentation of the selected column.

To cut, copy, and paste a column of text:
1. Hold down Alt and then press and hold the left mouse button. Move the mouse over the text you want to copy. The selected text becomes highlighted in blue.

IMPORTANT!
This feature does not work on a Linux platform, because the Alt key is occupied by the Linux system.
2. Use the right-click commands or the commands on the Edit menu to cut, copy, and paste the selected text.

To indent a column of text:
1. Place the cursor in front of the text you want to indent.
2. Choose Edit > Advanced > Indent. Or, press Tab.

Source Editor increases the indent of the selected text column by one tab size. By “Matching Braces, Parenthesis, and Brackets” on page 79, you can change the position of the indent.

To uppercase a selection:
1. Highlight the text you want to change to uppercase.
2. Choose Edit > Advanced > Uppercase Selection. You will see the highlighted text become uppercase.

To lowercase a selection:
1. Highlight the text you want to change to lowercase.
2. Choose Edit > Advanced > Lowercase Selection. You will see the highlighted text become lowercase.

To comment text:
1. Highlight the text you want to add comment, or place the cursor in front of the text.
2. Choose Edit > Advanced > Comment/Uncomment. You will see “--” put ahead of the text (VHDL file only). You can add comment after “--” (VHDL file only).

Matching Braces, Parenthesis, and Brackets Source Editor monitors brace ( { } ), parenthesis ( ( ) ), and bracket ( [ ] ) constructs. You can match an opening brace (or bracket or parenthesis) with a closing one, and vice versa.

To jump to the matching brace, parenthesis, or bracket:
1. In Source Editor, place the editing cursor adjacent to an opening or closing parenthesis (or bracket or brace).
2. Choose Edit > Advanced > Match Brace.

The cursor will move to the corresponding opening or closing parenthesis (or bracket or brace). This allows you the check for the balanced braces around functions and statements.

You can use the Edit > Advanced > Select to Brace command to force the matching brace, parenthesis, or brackets to be highlighted along with the text in between the two braces, parenthesis, or brackets,
Using Bookmarks  You can insert bookmarks into the source file to mark places where you need to enter variables. Afterwards, each time you load the file, you can use the Edit > Bookmarks command to jump to those marks to enter or edit your variables.

To insert bookmarks in a file:
1. In Source Editor, open the file you want to insert bookmarks into.
2. Click the location in the file you want to insert a bookmark.
3. Choose Edit > Bookmarks > Toggle Bookmark.
   A mark is inserted at the beginning of the line where the cursor points.
4. Repeat step 2 and 3 to add more marks, if desired.

To find marks in a file:
1. In Source Editor, open the file where the bookmarks you want to find reside.
2. Choose Edit > Bookmarks > Previous Bookmark, or Edit > Bookmarks > Next Bookmark.
   The cursor jumps to the bookmark in the direction selected. You can start typing from the desired marked place to enter or edit the variable.
3. Repeat step 2 to find, enter, or edit more bookmarks, if desired.

Using Complete Word  When you type a keyword into Source Editor, choose Edit > Advanced > Complete Word. A list of the matching values are presented. You can then:
   ▶ Choose the first matching value by pressing Enter directly.
   ▶ Choose an alternate matching value by using the up/down arrow keys and then pressing Enter.
   ▶ Continue typing the rest of the value. If no matching value is found, nothing will be entered.

Searching and Replacing Tips  Use the following tips when searching or replacing text such as signal names:
   ▶ Use Control + F to launch the Find and Replace bar with the Find tab enabled. Enter the search term in the Find What box to find the search term in the Source Editor document.
   ▶ Use Control + H to launch the Find and Replace bar with the Replace tab enabled. Enter the search term in the Find What box and the term you wish to replace it with in the Replace With box. Select desired Find Options, and click either Replace, Replace All, or Find Next.
Using Templates

The Source Template tab provides templates for creating VHDL, Verilog, and constraint files, or you can create your own template. Templates increase the speed and accuracy of design entry.

Note:

Remember to replace dummy variables in the template with your own logic.

To access templates, click the Source Template tab in the lower left of the Radiant software main window to view and access template files. If the Source Template tab is not visible, click in the tool bar, or choose View > Show Views > Source Template.

Figure 3:

Templates are available for:

- Verilog
- VHDL
- Constraint
The following templates are available for each of the categories:

**Table 3: Templates Available in Source Editor**

<table>
<thead>
<tr>
<th>Category</th>
<th>Template Folders</th>
</tr>
</thead>
<tbody>
<tr>
<td>Verilog/VHDL</td>
<td>▶ Common Templates</td>
</tr>
<tr>
<td></td>
<td>▶ PMI Templates</td>
</tr>
<tr>
<td></td>
<td>▶ Primitive Templates</td>
</tr>
<tr>
<td></td>
<td>▶ Attribute Templates</td>
</tr>
<tr>
<td></td>
<td>▶ Encryption Templates</td>
</tr>
<tr>
<td></td>
<td>▶ User Templates</td>
</tr>
<tr>
<td>Constraint</td>
<td>▶ Timing Constraints</td>
</tr>
<tr>
<td></td>
<td>▶ Physical Constraints</td>
</tr>
<tr>
<td></td>
<td>▶ User Templates</td>
</tr>
</tbody>
</table>

For Constraint templates, the Timing Constraints folder and Physical Constraints folder contain templates for the supported constraint statements. User Templates allows you to create your own templates for future use.

**See Also**
- “Lattice Module Reference Guide” on page 635
- “Lattice Synthesis Engine Constraints” on page 563

**Inserting a Template into Your Source File**

You can insert templates into a source file you are editing with Source Editor.

**To insert a template into your source file:**

1. Open the source file in Source Editor. See “Running Source Editor” on page 77.

2. Click the Source Template tab in the lower left of the Radiant software main window to view and access template files. If the Source Template tab is not visible, choose View > Show Views > Source Template.

   Two panes open in Source Template tab. The upper pane shows the list of template folders. The lower pane is blank.

3. Place the cursor in your source document where you want to insert a template. This should be in a blank line.

4. Select the template you want to use in the template list.

   The code of the template appears in the lower pane.

5. Drag and drop to template from the template pane into the Source Editor.

   The selected template is inserted into the file after the cursor.

6. Be sure to replace all placeholders with real values. Placeholders are terms between angle brackets such as “<event_expression>.”
7. If needed, make further changes such as adding code to execute within a case statement.

**See Also**  ►“Instantiating a PMI Component” on page 123

### Creating a New Template

You can create new templates for your own use and save them into the User Templates folders. The new templates will be available for all implementations in the design project.

You can also create sub-folders to organize the templates that you create. If you plan on creating many templates, think about how to organize them before you start. There is no easy way to move templates once they have been created.

**To create a new template:**

1. Click the Source Template the tab in the lower left of the Radiant software main window to view and access template files. If the Source Template tab is not visible, choose **View > Show Views > Source Template**.

   Two panes open in Source Template tab. The upper pane shows the list of template folders. The lower pane is blank.

2. In the Source Template tab, expand the appropriate folder so that its User Templates folder is showing. Every top level folder has a User Templates folder. If the User Templates folder already has contents, expand it so you can see the contents.

3. If you want to create a sub-folder, right-click **User Templates** or one of its sub-folders and choose **New Folder**. Then right-click the new folder and choose **Rename**. Type the desired folder name and press **Enter**.

4. Right-click **User Templates** or one of its sub-folders and choose **New Template**.

   A new template icon appears under the folder.

5. Right-click the new template icon and choose **Rename**. Type in the desired template name and press **Enter**.

6. Type the code for your template in the lower pane of Template Editor.

   The new template is automatically saved.

### Deleting a User Template

You can only delete templates from a **User Templates** folder.

There is no undo command, so once a template is deleted it is permanently gone. So ensure you have chosen the correct template before deleting it.
To delete a template:

1. Click the Source Template tab in the lower left of the Radiant software main window to view and access template files. If the Source Template tab is not visible, choose View > Show Views > Source Template.

   Two panes open in Source Template tab. The upper pane shows the list of template folders. The lower pane is blank.

2. In Source Template tab, expand the folders so that the desired folder or template is showing.

   **Caution**

   Deleting a folder also deletes all templates under the folder.

3. Right-click that template or folder and choose Delete.

**Using Structural Verilog (.vm) in the Design Flow**

The Radiant software supports structural Verilog files (.vm) as an input module source for both LSE and Synplify Pro. Structural Verilog design entry is similar to Electronic Design Interchange Format (EDIF) design entry. Benefits of Structural Verilog over EDIF include:

- Allows individual module-level constraints.
- Allows simulation.

The following are Structural Verilog flow requirements:

- The top module must be HDL.
- The .vm and its associated .ldc files must have the same name.
- I/Os cannot be inserted insertion during .vm module synthesis.
- A Verilog Black Box instantiation module (_bb.v) is required for each .vm source file.

**How VM Flow Works**  The following provides an example of creating and using Structural Verilog (.vm) in the design flow.

1. Create a Radiant software project.
2. Add HDL sources.
3. Add timing constraints and save them to an .ldc file.
4. Synthesize the project without I/O insertion to create the .vm file.
5. Rename .vm and .ldc file to the module name. Repeat steps 2. through 5. until all .vm modules and .ldc files are created.
6. Add .vm files to the main project. The .ldc files are auto-associated.
7. Prepare a Verilog Black Box instantiation module for each .vm file.
8. Run the processes as normal after instantiating them from a top level. If processed properly, the Post-Synthesis Timing Constraint Editor will show all constraints for the .vm files.

Coding Tips for LSE

The following are some recommendations if you choose to use LSE to synthesize your design. Tips include how to write code to infer different types of I/O ports, avoiding conflicts between VHDL packages, using VHDL coding, and preparing Verilog blocking assignments.

About VHDL Coding

LSE typically applies the VHDL specification strictly, sometimes more strictly than other synthesis tools. The following are some coding practices that can cause problems with LSE:

`ieee.std_logic_signed` or `unsigned`  When preparing VHDL code for LSE, you can include either:

USE ieee.std_logic_signed.ALL;

or:

USE ieee.std_logic_unsigned.ALL;

DO NOT include both statements. Code with both signed and unsigned packages may fail to synthesize because operators would have multiple definitions. Some synthesis tools may allow this but LSE does not.
Strict Variable Typing  
LSE is more strict about variable type requirements than most synthesis tools. A std_logic_vector signal cannot be assigned to a std_logic signal and an unsigned type cannot be assigned to a std_logic_vector signal. For example:

```vhdl
din : in  unsigned (data_width - 1 downto 0);
dout : out std_logic_vector (data_width - 1 downto 0));
...
dout <= din; -- Illegal, mismatched assignment.
```

Mismatched assignments like this will generate errors that stop synthesis.

About Inferring Memory

To produce RAM and ROM in a design, you can write code for the design so that the synthesis tool infers the memory.

Inferring memory means that LSE, based on aspects of the code, implements a block of memory using programmable function units (PFU) or embedded block RAM (EBR) instead of registers. PFU is used for small memories and EBR for large. LSE can infer synchronous RAM, that is:

- Single-port, pseudo dual-port, or true dual-port.
- With or without asynchronous reset of the output.
- With or without write enables.
- With or without clock enables.

LSE can also infer synchronous ROM.

One of the advantages of inferring memory is that the design is portable to almost any FPGA architecture.

The following sections describe how to write code to infer different kinds of memory with LSE.

See Also

- “Inferring RAM” on page 86
- “Inferring ROM” on page 97

Inferring RAM

The basic inferred RAM is synchronous. It can have synchronous or asynchronous reads and can be either single- or dual-port. You can also set initial values. Other features, such as resets and clock enables, can be added when needed. The following lists the rules for coding inferred RAM. Figure 5 on page 87 (Verilog) and Figure 6 on page 88 (VHDL) show the code for a simple, single-port RAM with asynchronous read.

To code RAM to be inferred, do the following:

- Define the RAM as an indexed array of registers.
To control how the RAM is implemented (with distributed or block RAM), consider adding the syn_ramstyle attribute. See “syn_ramstyle” on page 611.

Control the RAM with a clock edge and a write enable signal.

For synchronous reads, see “Inferring RAM with Synchronous Read” on page 89.

For single-port RAM, use the same address bus for reading and writing.

For dual-port RAM, pseudo and true, see “Inferring Dual-Port RAM” on page 92.

If desired, assign initial values to the RAM as described in “Initializing Inferred RAM” on page 96.

Figure 5: Simple, Single-Port RAM in Verilog

```verilog
module ram (din, addr, write_en, clk, dout);
    parameter addr_width = 8;
    parameter data_width = 8;
    input [addr_width-1:0] addr;
    input [data_width-1:0] din;
    input write_en, clk;
    reg [data_width-1:0] mem [(1<<addr_width)-1:0];
    // Define RAM as an indexed memory array.
    always @(posedge clk) // Control with a clock edge.
    begin
        if (write_en) // And control with a write enable.
            mem[(addr)] <= din;
        assign dout = mem[addr];
    end
endmodule
```

See Also

“About Verilog Blocking Assignments” on page 98
library IEEE;
use IEEE.std_logic_1164.all;
use IEEE.std_logic_unsigned.all;

entity ram is
    generic (
        addr_width : natural := 8;
        data_width : natural := 8);
    port (
        addr : in  std_logic_vector (addr_width - 1 downto 0);
        write_en : in  std_logic;
        clk : in  std_logic;
        din : in  std_logic_vector (data_width - 1 downto 0);
        dout : out std_logic_vector (data_width - 1 downto 0));
end ram;

architecture rtl of ram is
    type mem_type is array ((2** addr_width) - 1 downto 0) of
        std_logic_vector(data_width - 1 downto 0);
    signal mem : mem_type;
    -- Define RAM as an indexed memory array.
begin
    process (clk)
    begin
        if (clk'event and clk = '1') then --Control with clock edge
            if (write_en = '1') then -- Control with a write enable.
                mem(conv_integer(addr)) <= din;
            end if;
        end if;
    end process;
    dout <= mem(conv_integer(addr));
end rtl;
Inferring RAM with Synchronous Read

For synchronous reads, add a register for the read address or for the data output. Load the register inside the procedure or process that is controlled by the clock. The following examples show the simple RAM for Verilog and VHDL modified for synchronous reads. Changes are in bold text.
Verilog Examples

Figure 7: RAM with Registered Output in Verilog

module ram (din, addr, write_en, clk, dout);
    parameter addr_width = 8;
    parameter data_width = 8;
    input [addr_width-1:0] addr;
    input [data_width-1:0] din;
    input write_en, clk;
    output [data_width-1:0] dout;
    reg [data_width-1:0] dout; // Register for output.
    reg [data_width-1:0] mem [(1<<addr_width)-1:0];
    always @(posedge clk)
        begin
            if (write_en)
                mem[(addr)] <= din;
            dout = mem[addr]; // Output register controlled by clock.
        end
endmodule

Figure 8: RAM with Registered Read Address in Verilog

module ram (din, addr, write_en, clk, dout);
    parameter addr_width = 8;
    parameter data_width = 8;
    input [addr_width-1:0] addr;
    input [data_width-1:0] din;
    input write_en, clk;
    output [data_width-1:0] dout;
    reg [data_width-1:0] raddr; // Register for read address.
    reg [data_width-1:0] mem [(1<<addr_width)-1:0];
    always @(posedge clk)
        begin
            if (write_en)
                begin
                    mem[(addr)] <= din;
                end
            raddr <= addr; // Read addr. register controlled by clock.
        end
    assign dout = mem[raddr];
endmodule
VHDL Examples

Figure 9: RAM with Registered Output in VHDL

```vhdl
library IEEE;
use IEEE.std_logic_1164.all;
use IEEE.std_logic_unsigned.all;

entity ram is
  generic (
    addr_width : natural := 8;
    data_width : natural := 8);
  port (
    addr : in  std_logic_vector (addr_width - 1 downto 0);
    write_en : in  std_logic;
    clk : in  std_logic;
    din : in  std_logic_vector (data_width - 1 downto 0);
    dout : out std_logic_vector (data_width - 1 downto 0));
end ram;

architecture rtl of ram is
  type mem_type is array ((2** addr_width) - 1 downto 0) of
    std_logic_vector(data_width - 1 downto 0);
  signal mem : mem_type;
begin
  process (clk)
  begin
    if (clk'event and clk = '1') then
      if (write_en = '1') then
        mem(conv_integer(addr)) <= din;
      end if;
    end if;
    dout <= mem(conv_integer(addr));
    -- Output register controlled by clock.
  end process;
end rtl;
```
Inferring Dual-Port RAM

The following applies for dual-port, pseudo or true RAM.

- When using two address buses:
  - If the design does not simultaneously read and write the same address, add the syn_ramstyle attribute with the no_rw_check value to minimize overhead logic.
  - If writing in Verilog, use non-blocking assignments as described in “About Verilog Blocking Assignments” on page 98.

The examples below are based on the simple RAM of Figure 5 on page 87 (for Verilog) and Figure 6 on page 88 (for VHDL).
Verilog Examples

Figure 11: Pseudo Dual-Port RAM in Verilog

```verilog
module ram (din, write_en, waddr, wclk, raddr, rclk, dout);
    parameter addr_width = 8;
    parameter data_width = 8;
    input [addr_width-1:0] waddr, raddr;
    input [data_width-1:0] din;
    input write_en, wclk, rclk;
    output [data_width-1:0] dout;
    reg [data_width-1:0] dout;
    reg [data_width-1:0] mem [(1<<addr_width)-1:0]
    /* synthesis syn_ramstyle = "no_rw_check" */
    always @(posedge wclk) // Write memory.
        begin
            if (write_en)
                mem[waddr] <= din; // Using write address bus.
        end
    always @(posedge rclk) // Read memory.
        begin
            dout <= mem[raddr]; // Using read address bus.
        end
endmodule
```

Figure 12: True Dual-Port RAM in Verilog

```verilog
module ram (dina, write_ena, addra, clka, douta, dinb, write_enb, addrb, clkb, doutb);
    parameter addr_width = 8;
    parameter data_width = 8;
    input [addr_width-1:0] addra, addrb;
    input [data_width-1:0] dina, dinb;
    input write_ena, clka, write_enb, clkb;
    output [data_width-1:0] douta, doutb;
    reg [data_width-1:0] douta, doutb;
    reg [data_width-1:0] mem [(1<<addr_width)-1:0]
    /* synthesis syn_ramstyle = "no_rw_check" */
    always @(posedge clka) // Using port a.
        begin
            if (write_ena)
                mem[addra] <= dina; // Using address bus a.
                douta <= mem[addra];
        end
    always @(posedge clkb) // Using port b.
        begin
            if (write_enb)
                mem[addrb] <= dinb; // Using address bus b.
                doutb <= mem[addrb];
        end
endmodule
```
VHDL Examples

Figure 13: Pseudo Dual-Port RAM in VHDL

library IEEE;
use IEEE.std_logic_1164.all;
use IEEE.std_logic_unsigned.all;

entity ram is
  generic (     
    addr_width : natural := 8;
    data_width : natural := 8);
  port (       
    write_en : in  std_logic;
    waddr    : in  std_logic_vector (addr_width - 1 downto 0);
    wclk     : in  std_logic;
    raddr    : in  std_logic_vector (addr_width - 1 downto 0);
    rclk     : in  std_logic;
    din      : in  std_logic_vector (data_width - 1 downto 0);
    dout     : out std_logic_vector (data_width - 1 downto 0));
end ram;

architecture rtl of ram is
  type mem_type is array ((2** addr_width) - 1 downto 0) of
    std_logic_vector(data_width - 1 downto 0);
  signal mem : mem_type;
  attribute syn_ramstyle: string;
  attribute syn_ramstyle of mem: signal is "no_rw_check";
begin
  process (wclk) -- Write memory.
  begin
    if (wclk'event and wclk = '1') then
      if (write_en = '1') then
        mem(conv_integer(waddr)) <= din;
        -- Using write address bus.
      end if;
    end if;
  end process;

  process (rclk) -- Read memory.
  begin
    if (rclk'event and rclk = '1') then
      dout <= mem(conv_integer(raddr));
      -- Using read address bus.
    end if;
  end process;
end rtl;
library IEEE;
use IEEE.std_logic_1164.all;
use IEEE.std_logic_unsigned.all;

entity ram is
  generic (
    addr_width : natural := 8;
    data_width : natural := 8);
  port (
    addra : in  std_logic_vector (addr_width - 1 downto 0);
    write_ena : in  std_logic;
    clka : in  std_logic;
    dina : in  std_logic_vector (data_width - 1 downto 0);
    douta : out std_logic_vector (data_width - 1 downto 0);
    addrb : in  std_logic_vector (addr_width - 1 downto 0);
    write_enb : in  std_logic;
    clkb : in  std_logic;
    dinb : in  std_logic_vector (data_width - 1 downto 0);
    doutb : out std_logic_vector (data_width - 1 downto 0));
end ram;

architecture rtl of ram is
  type mem_type is array ((2** addr_width) - 1 downto 0) of
    std_logic_vector(data_width - 1 downto 0);
  signal mem : mem_type;
  attribute syn_ramstyle: string;
  attribute syn_ramstyle of mem: signal is "no_rw_check";
begin
  process (clka) -- Using port a.
  begin
    if (clka'event and clka = '1') then
      if (write_ena = '1') then
        mem(conv_integer(addra)) <= dina;
        -- Using address bus a.
      end if;
      douta <= mem(conv_integer(addra));
    end if;
  end process;

  process (clkb) -- Using port b.
  begin
    if (clkb'event and clkb = '1') then
      if (write_enb = '1') then
        mem(conv_integer(addrb)) <= dinb;
        -- Using address bus b.
      end if;
      doutb <= mem(conv_integer(addrb));
    end if;
  end process;
end rtl;

See Also

► “Inferring RAM” on page 86
**Initializing Inferred RAM**
Create initial values for inferred RAM to initialize memory.

**Verilog**
Initialize RAM with the standard `$readmemb` or `$readmemh` tasks in an initial block. Create a separate file with the initial values in either binary or hexadecimal form. For example, to initialize a RAM block named "ram":

```verilog
global reg [7:0] ram [0:255];
initial
begin
    $readmemh("ram.ini", ram);
end
```

The data file has one word of data on each line. The data needs to be in the same order in which the array was defined. That is, for "ram [0:255]" the data starts with address 0; for "ram [255:0]" the data starts with address 255. The `ram.ini` file might start like this:

```
0A /* Address 0 */
23
5C
...```

**VHDL**
Initialize RAM with either signal declarations or variable declarations. Define an entity with the same ports and architecture as the memory. Use this entity in either a signal or variable statement with the initial values as shown below.

To initialize a RAM block named “ram,” define an entity such as:

```vhdl
entity ram_init is
    port (    clk : in std_logic;
              addr : in std_logic_vector(7 downto 0);
              din : in std_logic_vector(7 downto 0);
              we : in std_logic;
              dout : out std_logic_vector(7 downto 0));
end;
architecture arch of ram_init is
    type ram_init_arch is array(0 to 255)
        of std_logic_vector(7 downto 0);
    Then use the entity in a signal statement:
    signal ram : ram_init_arch := ("00001010",
                  "00100011",
                  "01011100",
                  ...    others => (others => '0'));
```

Or use the entity in a variable statement:

```vhdl
variable ram : ram_init_arch := ("00001010",
```

Lattice Radiant Software 2.2 Help
l => "00001010",
...
others => (l=>'1', others => '0'));

See Also

 “Inferring RAM” on page 86

Inferring ROM

To code the ROM to be inferred, do the following:

 Define the ROM with a case statement or equivalent IF statements.

 Assign constant values, all with the same width.

 Assign values for at least 16 addresses or half of the address space, whichever is greater. For example, if the address has 6 bits, the address space is 64 words, and at least 32 of them must be assigned values.

 To control how the ROM is implemented (with distributed or block ROM), consider adding the syn_romstyle attribute. See “syn_romstyle” on page 615.

Figure 15: ROM Inferred with Case Statement in Verilog

```verilog
module rom(data, addr);
    output [3:0] data;
    input [4:0] addr;
    always @(addr) begin
        case (addr)
            0 : data = 'h4;
            1 : data = 'h9;
            2 : data = 'h1;
            ...
            15 : data = 'h8;
            16 : data = 'h1;
            17 : data = 'h0;
            default : data = 'h0;
        endcase
    end
endmodule
```
About Verilog Blocking Assignments

LSE support for Verilog blocking assignments to inferred RAM and ROM, such as "ram[(addr)] = data;," is limited to a single assignment. Multiple blocking assignments, such as you might use for true dual-port RAM (see Figure 17 on page 98), or a mix of blocking and non-blocking assignments are not supported. Use non-blocking assignments instead (<=). See Figure 18 on page 99.

Figure 17: Example of RAM with Multiple Blocking Assignments (Wrong)

always @(posedge clka)
begin
  if (write_ena)
    ram[addr] = dina; // Blocking assignment A
    douta = ram[addr];
  end
always @(posedge clkb)
begin
  if (write_enb)
    ram[addr] = dinb; // Blocking assignment B
    doutb = ram[addr];
  end
**Figure 18: Example Rewritten with Non-blocking Assignments (Right)**

```verilog
always @(posedge clka)
begin
  if (write_ena)
    ram[addra] <= dina;
  douta <= ram[addra];
end
always @(posedge clkb)
begin
  if (write_enb)
    ram[addrb] <= dinb;
  doutb <= ram[addrb];
end
```

**About Verilog Generate Blocks**

If a module has multiple generate blocks, LSE requires that each block have a different name. Assign names with begin statements. See Figure 19 on page 99.

**Figure 19: Generate Blocks with Assigned Names**

```verilog
generate
begin: R1_gen // Name first generate block.
  genvar i1;
  for (i1=0; i1<=15; i1=i1+1)
    regset R1 (.clk(clk[i1]),.q(q[i1]),.d(d[i1]));
end
generate
begin: IR0_gen // Name second generate block.
  genvar i;
  for (i=0; i<=7; i=i+1)
    ioreg IR0 (.clk(clk[0]),.reset(rst[i]),.q(q[i]),.d(d[i]));
end
generate
generate
begin: R1_gen // Name first generate block.
  genvar i1;
  for (i1=0; i1<=15; i1=i1+1)
    regset R1 (.clk(clk[i1]),.q(q[i1]),.d(d[i1]));
end
generate
```

**Inferring I/O**

To specify a type of I/O port, follow these models.

**Verilog**

**Open Drain:**

```verilog
output <port>;
wire <output_enable>
assign <port> = <output_enable> ? 1'b0 : 1'bz;
```

**Bidirectional:**

```verilog
inout <port>;
wire <output_enable>
wire <output_driver>;
```
wire <input_signal>;
assign <port> = <output_enable> ? <output_driver> : l'bz;
assign <input_signal> = <port>;

**VHDL**

**Tristate:**

```vhdl
library ieee;
use ieee.std_logic_1164.all;
entity <tbuf> is
port (  
  <enable> : std_logic;
  <input_sig> : in std_logic_vector (1 downto 0);
  <output_sig> : out std_logic_vector (1 downto 0));
end tbuf2;
architecture <port> of <tbuf> is
begin  
  <output_sig> <= <input_sig> when <enable> = '1' else "ZZ";
end;
```

**Open Drain:**

```vhdl
library ieee;
use ieee.std_logic_1164.all;
entity <od> is
port (  
  <enable> : std_logic;
  <output_sig> : out std_logic_vector (1 downto 0));
end od2;
architecture <port> of <od> is
begin  
  <output_sig> <= "00" when <enable> = '1' else "ZZ";
end;
```

**Bidirectional:**

```vhdl
library ieee;
use ieee.std_logic_1164.all;
entity <bidir> is
port (  
  <direction> : std_logic;
  <input_sig> : in std_logic_vector (1 downto 0);
  <output_sig> : out std_logic_vector (1 downto 0);
  <bidir_sig> : inout std_logic_vector (1 downto 0));
end bidir2;
architecture <port> of <bidir> is
begin  
  <bidir_sig> <= <input_sig> when <direction> = '0' else "ZZ";
  <output_sig> <= <bidir_sig>;
end;
```

**Customizing Source Editor**

The following can be performed in Source Editor:
Select a default file language
Choose window modes (attached or detached).
Set encoding.
Configure line number showing.
Configure text wrapping.
Set printing options.

Setting File and Window Modes
Source Editor offers you the flexibility to configure file and window modes, such as line number showing, text wrapping, and printing options. The configuration can be applied to the current file, a specified type of file, or any new files created in Source Editor.

To select a default file language:
1. In Source Editor, choose View > Language. The following options are available: C++, Hypertext, Perl, Python, TCL, Verilog, VHDL, EDIF, SystemVerilog, Timing Constraint, and Physical Constraint.
2. Choose the desired language from the list. The language selected becomes the default language in Source Editor.

To attach or detach Source Editor from the Radiant software:
1. To detach Source Editor from the Radiant software main window, click the Detach Tool icon in the upper-right corner of Source Editor.
2. To attach Source Editor to the Radiant software main window, choose Window > Attach Window, or click on the Attach Tool icon in the upper-right corner of Source Editor.

Customizing Source Editor from the Radiant software Main Window

To customize Source Editor settings in the Radiant software main window:
1. In the Radiant software main window, choose Tools > Options.
2. In the Tools window, you can set settings in the each related section.

**General**

- **Show Line Number:** Displays line numbers of the files (on the left side of the Editor).
- **Show Indicator Margin:** Displays the side bar allowing you to select the whole row.
- **Show Folder Margin:** Displays the side bar (on the left side of the Editor) that is used to fold/unfold the syntax.
- **Tab Size:** Specifies how many spaces are entered when a tab character is pressed.
- **Restore:** Returns to the default setting.
Font
Lists the current font used in Source Editor. To change the current font, click the drop-down menu next to Font Family and select the desired font. To change the font size, click the drop-down menu next to Font Size and select the desired size. Click OK to exit. The selected font name, font type, and font size will be displayed in Source Editor.

Restore Returns all selections to their default settings.

3. In the Color window, you can set the default colors for the text, comments, numbers, keywords, and a variety of other options under the Source Editor tab.

Colors
Click in the Themes drop-down menu to select either a light or dark overall color theme for Source Editor.

To select a different color, double-click the color box next to the desired element to open the Select Color window. Click on the new color to use.

Restore Returns all selections to their default settings.

If you want to change to use your own text editor other than Source Editor, you can customize to add your own text editor and associated files to your own text editor program in the Options dialog. Select Tools > Options from the Radiant software main window, click on General, and then select the File Associations tab.

References
This section includes the following references.

Verilog HDL Language Reference
If you have installed Synplify Pro for Lattice, refer to the Synplify and Synplify Pro for Lattice Reference Manual in the Synplify Pro installation directory.

VHDL Language Reference
If you have installed Synplify Pro for Lattice, refer to the Synplify and Synplify Pro for Lattice Reference Manual in the Synplify Pro installation directory.
Packaging IP Using Radiant IP Packager

Radiant IP Packager allows external Intellectual Property (IP) developers -- including third party IP providers and customers -- to prepare and package IP in the Radiant Software IP format.

IP packages must contain certain mandatory file types, including:
- Metadata (.xml)
- RTL (<IP_name>.v and <v>.
- Documentation (introduction.html, user guide, etc).

IP packages can also contain certain non-mandatory file types, including:
- Plugin (.py)
- LDC (.ldc)
- Testbench (.v)
- License Agreement (.txt)
- Key (.txt)

A typical IP packaging procedure consists of the following steps:
1. The Radiant IP Packager encrypts the RTL files automatically if IEEE P1735-2014 pragma is specified in RTL files. For more information on encryption and defining pragmas, see “Running HDL Encryption from the Command Line” on page 914.
2. The Radiant IP Packager provides design rule check (DRC) on the files. For example, the DRC will check whether or not the metadata.xml syntax is valid.
3. The Radiant IP Packager inserts a default license agreement file if user doesn't specify one.
4. The Radiant IP Packager tool allows developers to combine multiple files associated with the IP into a single deployable .IPK file. This file can then be used in the Radiant Software environment to install the IP package in the user design environment.

See Also
- “Preparing IP Files for Packaging” on page 103
- “Running Radiant IP Packager” on page 114
- “Generating an IPK File with IP Packager” on page 115
- “Running HDL Encryption from the Command Line” on page 914

Preparing IP Files for Packaging

This section describes the preparation of IP files for packaging with IP Packager. The IP Packager supports the following file types:
- Metadata file (.xml)
- RTL files (.v)
- LDC file (.ldc)
Packaging IP Using Radiant IP Packager

- Plugin file (.py)
- Document Files (.htm, html)
- License Agreement (.txt)

The following describes each file type.

**Metadata file (.xml)** The “metadata.xml” file contains information on the IP including:

- Ports
- Parameters
- Attributes and functions for validating their intervals and relationships
- How the IP parameters will appear in the GUI. For example, some parameters might be visible or hidden, editable or fixed depending on other parameters values selected by the user.

The "metadata.xml" name for this file is mandatory for all IPs.

Metadata is provided in an XML file, following a suitable template available to the Soft IP Development Team. Metadata serves the following functions:

- Contains the definitions of IPs ports.
- Contains the definitions of parameters, alongside their valid intervals and relationships.
- Is used by the GUI to create an appropriately-looking dialog, such as specifying the way in which each parameter is presented graphically.
- Controls other aspects of how the IP is generated and synthesized.

**Note**

Radiant IP Packager supports Python v3.7. If your IP is packaged by IP Packager in Radiant software v2.0 or earlier, the Python script syntax format may not be compatible with Python v3.7. Please make sure your IP can run in Python v3.7.

When the user makes the necessary parameter selections and generates the IP, they shall see in the generated RTL the instance of IP specific to their requirement (such as appropriately set ports and parameters). There is a wrapper generated by the Python script which instantiates the IP’s RTL while applying the parameters selected by the user. The same Python script checks whether the selected combination of parameters is legal, and performs all necessary calculations. Only one Python script is present in the directory structure of each IP, and it contains all necessary functions.

The root node of the XML file is <ip>, which consists of:

- Attribute: "version"
- Three mandatory child nodes: <general>, <settings> and <ports>
- Two optional child nodes: <componentGenerators> and <estimatedResources>
The following is an example of Metadata layout:

```xml
    <lsccip:general>
        ......
    </lsccip:general>
    <lsccip:settings>
        ......
    </lsccip:settings>
    <lsccip:ports>
        ......
    </lsccip:ports>
</lsccip:ip>
```

The attribute “version” records the version of the XML metadata format. Current value is 1.0.

The following table lists child nodes of root node.

<table>
<thead>
<tr>
<th>Child Node</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>general</td>
<td>General information of the soft IP</td>
</tr>
<tr>
<td>settings</td>
<td>Configurable settings of the soft IP</td>
</tr>
<tr>
<td>ports</td>
<td>Ports of the soft IP</td>
</tr>
</tbody>
</table>

<general> node. <general> node describes general information about a soft IP, for example, name, version, category, etc. The following table describes Child nodes of <general> node.

<table>
<thead>
<tr>
<th>Child Node</th>
<th>Mandatory</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>vendor</td>
<td>No</td>
<td>Soft IP vendor. Official soft IPs should have vendor name. For example, “latticesemi.com”.</td>
</tr>
<tr>
<td>name</td>
<td>Yes</td>
<td>Name of the soft IP. The name is used to identify the soft IP, so it should be unique. For example, “adder”</td>
</tr>
<tr>
<td>display_name</td>
<td>No</td>
<td>Name to be displayed in the software. If “display_name” is not set, software displays “name” directly. For example, “Adder”</td>
</tr>
<tr>
<td>library</td>
<td>No</td>
<td>Library of the soft IP. If “library” is not set, the default value “ip” will be used. For example, “ip”, “interface”</td>
</tr>
<tr>
<td>version</td>
<td>Yes</td>
<td>Version of the soft IP. For example, 1.0.0.</td>
</tr>
</tbody>
</table>
The <settings> node should contain one or more <setting> nodes. In IP instance package, Verilog parameters are used to customize the soft IP. All user configurable parameters should be added to the <settings> section as <setting> nodes. Beside parameters, developers can also add <settings> nodes for user input only. Both parameters and inputs could be used in Python expressions to do dynamic evaluation.

The following table lists Attributes of <settings> nodes.

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Value</th>
<th>Mandatory</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>id</td>
<td>valid Python identity</td>
<td>Yes</td>
<td>The unique ID of the setting, which is also be referred as:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- variable name in Python expressions</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- variable name in parameterized template constraint file</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>For example, id=&quot;num_outputs&quot;</td>
</tr>
<tr>
<td>title</td>
<td>String</td>
<td>No</td>
<td>Short title of the setting. If title is not specified, id will be used.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>For example, title=&quot;Number of Output&quot;</td>
</tr>
<tr>
<td>type</td>
<td>param, input</td>
<td>Yes</td>
<td>A setting could be a Verilog parameter or user input. Both param and input</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>settings can be used to compute values of other param and input settings.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>param and input only differ in generated file. param is written out but</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>input is ignored.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>For example, type=&quot;param&quot;</td>
</tr>
<tr>
<td>value_type</td>
<td>bool, string, int,</td>
<td>Yes</td>
<td>Type of the value. Supported types are bool, int, float, string and path.</td>
</tr>
<tr>
<td></td>
<td>float, path</td>
<td></td>
<td>The path type indicates a string which represents a path.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>For example, value_type=&quot;int&quot;</td>
</tr>
<tr>
<td>conn_mod</td>
<td>String</td>
<td>Yes</td>
<td>Name of soft IP module to which this setting applies to.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>For example, conn_mod=&quot;pll&quot;</td>
</tr>
<tr>
<td>Attribute</td>
<td>Value</td>
<td>Mandatory</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------</td>
<td>------------------------------</td>
<td>-----------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>default</td>
<td>Python expression</td>
<td>No</td>
<td>Default value of the setting. Without default attribute, if it has &quot;options&quot; attribute, the 1st option will be picked as default value, otherwise, the initial value of setting will be set to 0 for \texttt{int}, 0.0 for \texttt{float}, &quot;&quot; for \texttt{string} and \texttt{False} for \texttt{bool}. For example, \texttt{default=&quot;1.0&quot;}</td>
</tr>
<tr>
<td>value_expr</td>
<td>Python expression</td>
<td>No</td>
<td>Python expression to compute the value of the setting. This attribute takes effects only when the setting is disabled.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>For example, \texttt{value_expr=&quot;calc_extdiv_val_add(extdiv_en, extdiv_port_sel)&quot;}</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>(\texttt{calc_extdiv_val_add} is defined in plugin.py extdiv_en and extdiv_port_sel are the setting IDs in metadata.xml)</td>
</tr>
<tr>
<td>options</td>
<td>Python list or list of tuples</td>
<td>No</td>
<td>Candidate options for the setting, which is used by GUI to display a dropdown selector. It could be set to a simple list or a list of tuples. If it's a simple list, elements are displayed and written. If it's a list of tuples, the 1st item in tuple is displayed and the 2nd item in tuple is written. For example, \texttt{options=[0.1, 0.2, 0.5, 1.0]}</td>
</tr>
<tr>
<td>output_formatter</td>
<td>str</td>
<td>No</td>
<td>Control how parameter values are written in output RTL files. Currently, only \texttt{str} is supported.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>\texttt{str}: parameter values are written as strings</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>For example, \texttt{output_formatter=&quot;str&quot;}</td>
</tr>
<tr>
<td>bool_value_mapping</td>
<td>Python tuple or list with 2 string elements</td>
<td>No</td>
<td>The map to map \texttt{bool} values to dedicated strings. By default, \texttt{bool} values are written as 1, 0. For example, \texttt{bool_value_mapping=&quot;(\texttt{True}, \texttt{False})&quot;}</td>
</tr>
<tr>
<td>editable</td>
<td>Python expression</td>
<td>No</td>
<td>Python expression to determine if the setting is editable. When a setting is not editable, it will be grayed out in GUI display and its value will be computed from \texttt{value_expr}. Otherwise user input will be used. For example, \texttt{editable=(\texttt{FEEDBACK_PATH == \texttt{}'PHASE_AND_DELAY'})}</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>(\texttt{FEEDBACK_PATH} is a setting ID in metadata.xml)</td>
</tr>
<tr>
<td>hidden</td>
<td>True</td>
<td>No</td>
<td>Python expression to determine whether the setting is hidden in GUI. If hidden is set to True (default is False), the item is hidden in GUI. Current GUI only support hidden=\texttt{&quot;True&quot;}, which cannot be changed dynamically. For example, \texttt{hidden=&quot;True&quot;}</td>
</tr>
</tbody>
</table>
Packaging IP Using Radiant IP Packager

Lattice Radiant Software 2.2 Help 108

<ports> node. IP module package has some ports in its implementation. These ports should be described in <ports> section as <port> child nodes. The following table lists attributes of <port> nodes.

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Value</th>
<th>Mandatory</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>name</td>
<td>Valid Verilog port name</td>
<td>Yes</td>
<td>Name of port. For example, name=&quot;Clk&quot;</td>
</tr>
<tr>
<td>dir</td>
<td>in, out, inout</td>
<td>Yes</td>
<td>Direction of port. For example, dir=&quot;in&quot;</td>
</tr>
<tr>
<td>range</td>
<td>Python tuple or list with 2 int elements</td>
<td>No</td>
<td>Range of this port. It should be a Python expression whose evaluation result is a tuple or array with 2 elements. For example, range=&quot;(A_WDT-1, 0)&quot; (A_WDT is a setting ID)</td>
</tr>
<tr>
<td>conn_mod</td>
<td>Valid Verilog module name</td>
<td>Yes</td>
<td>Name of IP core module to which this port connects. For example, conn_mod=&quot;counter&quot;</td>
</tr>
<tr>
<td>conn_port</td>
<td>Valid Verilog port name</td>
<td>No</td>
<td>Name of port of IP core module to which this port connects. name will be used if conn_port is not specified. For example, conn_port=&quot;Clk&quot;</td>
</tr>
</tbody>
</table>

Python expression No Python expression to do DRC on the setting. True means DRC pass.

For example, drc="check_valid_addr_pre(I2C_LEFT_ADDRESSING_PRE,i2c_left_addressing_width)"

(check_valid_addr_pre is defined in plugin.py setting ID: I2C_LEFT_ADDRESSING_PRE and i2c_left_addressing_width are IDs of other settings)

Regular expression No Regular expression to do DRC on the setting.

Valid range of setting value, which is used to do DRC on the setting. The maximum value can be infinity "float(‘inf’)".

For example, value_range="(0, 1023) if(i2c_right_enable) else (-9999, 9999)"

Detailed description of the setting.

Group the settings, and be used to display on GUI

For example, group1= "Output Setting"
Packaging IP Using Radiant IP Packager

The componentGenerators node contains a list of componentGenerator elements. Each componentGenerator element defines a generator that is run on generated IP instance package. The description of componentGenerators follows IP-XACT format.

```xml
<lsccip:componentGenerators>
  <lsccip:componentGenerator>
    <lsccip:name>memGenerator</lsccip:name>
    <lsccip:generatorExe>script/mem_gen.py</lsccip:generatorExe>
  </lsccip:Generator>
</lsccip:Generators>
```

The estimatedResources node contains a list of estimatedResource element. Each estimatedResource element defines the formula to calculate one type of resource used in the IP instance package.

```xml
<lsccip:estimatedResources>
  <lsccip:estimatedResource>
    <lsccip:name>LUT4</lsccip:name>
    <lsccip:number>WIDTH * 4</lsccip:number>
  </lsccip:Resource>
</lsccip:Resources>
```

A full description of a soft IP might be large. Metadata.xml supports to build a large XML file from small manageable chunks. The approach is implemented by XInclude.

<table>
<thead>
<tr>
<th>attribute</th>
<th>type</th>
<th>default</th>
<th>description</th>
</tr>
</thead>
<tbody>
<tr>
<td>stick_high</td>
<td>Python expression</td>
<td>No</td>
<td>Python script. True: tie this port to 1. For example, stick_high=&quot;True&quot;</td>
</tr>
<tr>
<td>stick_low</td>
<td>Python expression</td>
<td>No</td>
<td>Python script. True: tie this port to 0. For example, stick_low=&quot;no_seq_pins()&quot; (no_seq_pins is defined in plugin.py)</td>
</tr>
<tr>
<td>stick_value</td>
<td>Python expression</td>
<td>No</td>
<td>Python script. Tie port to the evaluation result of this attribute.</td>
</tr>
<tr>
<td>dangling</td>
<td>Python expression</td>
<td>No</td>
<td>Python script. True: keep this port unconnected. For example, dangling=&quot;not USE_COUT&quot; (USE_COUT is a setting ID)</td>
</tr>
<tr>
<td>bus_interface</td>
<td>Valid bus interface name</td>
<td>No</td>
<td>Bus interface name defined in &lt;busInterfaces&gt; node. For example, bus_interface=&quot;ahb_slave_0&quot;</td>
</tr>
</tbody>
</table>
RTL files (.v) The following is an example of the contents of a typical .v file, written in Verilog:

```
module module_01
#(
    parameter integer in_a_width = 8,
    parameter integer in_b_width = 8,
    parameter in_b_en = "True",
    parameter integer out_width = 16//,
) (
    clk,
    rst_n,
    in_a,
    in_b,
    result
);

localparam integer A_WDT = in_a_width;
localparam integer B_WDT = in_b_width;
localparam integer O_WDT = out_width;
localparam IB_EN = in_b_en;

input    clk;
input    rst_n;
input[A_WDT - 1:0]in_a;
input[B_WDT - 1:0]in_b;
input[O_WDT - 1:0]result;

generate
    if (IB_EN == "True")
        begin
            assign result = in_a;
        end
    else
        begin
            assign result = (in_a, in_b);
        end
endgenerate

endmodule // module_01
```

For more information on encryption and defining pragmas, see “Running HDL Encryption from the Command Line” on page 914.

IP module package has optional parameterized test bench, which shares parameters used in soft IP implementation.

IP generation engine copies test bench files from IP module package and creates two files based on user configuration.

- **dut_params.v**
  
  Contains the parameters used in soft IP implementation

The name “dut_params.v” is fixed.
The following is an example of `dut_params.v`.

```plaintext
localparam ENABLE_A = 1;
localparam ENABLE_B = 0;
localparam BUS_WIDTH = 2;
```

- **dut_inst.v**
  
  Contains the IP instance instantiation. The connected wire name is same as port name.
  
  The name "dut_inst.v" is fixed.

The following is an example of `dut_inst.v`.

```plaintext
INST_NAME u_INST_NAME
{
    .PORT_NAME   (PORT_NAME)
}
```

**LDC file (.ldc)** Template constraint file is written in Tcl language. Settings of the IP can be used as variables in the template file, so that it can be further customized.

The IP generation engine will add additional information in the header of template constraint file. The additional information includes:

- **Architecture, device, and package names**
- **User configurations**

The following is an example template constraint file. Availability of the `create_clock` constraint is controlled by variable `$i2c_left_enable`, and the period value of the constraint is controlled by variable `$i2c_left_period`.

```plaintext
if { $i2c_left_enable == 1 } {
    create_clock -name {clk0} -period $i2c_left_period [get_nets SBCLKi_c]
}
```

The following is an example of generated constraint file.

```plaintext
$architecture = "iCE40UP"
$device = "iCE40UP5K"
$package = "UWG30"
$i2c_left_enable = 1
$i2c_left_period = 1000

if { $i2c_left_enable == 1 } {
    create_clock -name {clk0} -period $i2c_left_period [get_nets SBCLKi_c]
}
```

**Plugin file (.py)** Python expressions can be used in the metadata file to implement complex logic or calculations. However, Python expressions have rather limited capability if restricted to a single line.

To support complex logic, users can define any additional Python function(s) in plugin.py file of the IP package, and then call the functions in Python expressions in metadata file.
Following Python modules can be used in plugin.py:

- json
- xml
- textwrap
- collections
- os
- re
- traceback
- functools
- warnings
- shutil
- math
- itertools
- operator
- time
- weakref
- StringIO
- keyword
- copy
- codecs
- stat
- types
- string
- lxml

The following is an example of the contents of a .py file:

```python
def calc_out_width():
    ret_val = in_a_width
    if in_b_en:
        ret_val += in_b_width
    return ret_val
```

**Document Files (.htm, html)**  The mandatory /doc directory contains:

Mandatory introduction file. The file name should be "introduction.html". The file should include the following information:

- Description
- Devices Supported
- Reference Documents
- Revision History
The following is an example of a typical “introduction.html” file. This example is for the Adder module:

```html
<HEAD>
<TITLE>Adder</TITLE>
</HEAD>
<BODY>
<H1>Adder</H1>
<H2>Description</H2>
<P>A two-input adder that performs signed/unsigned addition of the data from inputs data_a and data_b with an optional cin carry input. The output result carries the Sum of the addition operation with an optional cout carry output.</P>
<H2>Devices Supported</H2>
<P>iCE40UP</P>
<H2>References</H2>
<UL>
</UL>
<H2>Revision History</H2>
<TABLE cellpadding="10">
  <TR>
    <TD><B>1.0.1</B></TD> <TD>Added je5d00 support</TD>
  </TR>
  <TR>
    <TD><B>1.0.0</B></TD> <TD>Initial release.</TD>
  </TR>
</TABLE>
</BODY>
```

The following shows how a typical “introduction.html” page appears when displayed in the IP Information tab of the Radiant IP Catalog tool.

![Adder Page Screenshot]

The /doc directory can also contain other optional documents.

Directory Structure -- This section describes typical directory structure of Radiant IP package.
The example below represents the folder tree for “PLL” IP package. As shown, the top-level folder has the same name as the IP. The metadata.xml file does not reside in a subfolder.

There are four subfolders and one file inside the top folder, namely:

- The “doc” subfolder contains the User Guide for the IP and templates for instantiation in Verilog (if provided, also in VHDL).
- The “plugin” subfolder contains a Python file embedding all necessary functions for parameter validation and checking.
- The “rtl” subfolder contains a parameterized RTL file of the IP. During IP generation, this file is instantiated into the wrapper with the parameters settings selected by the user.
- The “test bench” subfolder contains an optional parameterized test bench for the generated IP.

**License Agreement (.txt)**  User specifies license agreement in a text file. The Radiant IP Packager inserts a default license agreement file if user doesn't specify one.

**See Also**  ➤“Packaging IP Using Radiant IP Packager” on page 103

---

**Running Radiant IP Packager**

Radiant IP Packager is a stand-alone tool. Radiant IP Packager can be run from both Windows and Linux.

**To run IP Packager:**

- In Windows, go to the Windows Start menu and choose Programs > Lattice Radiant Software > Accessories > IP Packager.
- In Linux: from the ./<Radiant Software Install Path>/bin/lin64 directory, enter the following on a command line:
  ```
  ./ippackager
  ```
  The IP Packager dialog box opens.
  - The IP Packager can also be run from the command line. Refer to “IP Packager” on page 949.

**See Also**  ➤“Packaging IP Using Radiant IP Packager” on page 103
Generating an IPK File with IP Packager

IP Packager provides a user interface for IP author to select files and pack them into an IPK file. The IP Packager engine encrypts RTL files if IEEE P1735 V1 pragmas are specified in RTL source.

**Generate an IPK file with IP Packager:**

1. In the IP Packager dialog box, click **Add**.
2. In the Open dialog box, choose the file type that you wish to add from the dropdown menu. File types include:
   - Metadata file (.xml)
   - RTL files (.v)
   - Constraint files (.ldc)
   - Plugin file (.py)
   - Document files (.htm, .html)
   - License Agreement (.txt)
   To remove any unwanted file, highlight the file in the Input files box and click **Remove**.
3. When all IP files are listed in the Input files box, in the **Output Directory** box, browse to the location where you want the IPK file to be generated. The default location is:
   C:\Users\<user name>\RadiantIPLocal\<IP name>
4. Click **Generate**. The IPK file is generated in the default location.

**See Also**

"Packaging IP Using Radiant IP Packager" on page 103

Installing IP Created with IP Packager into IP Catalog

You can download and add IP created with IP Packager into IP Catalog.

**To download and add a User IP:**

1. In the Radiant IP Catalog, click on the **Install a User IP** button.
2. In the **Select user IP package file to install** dialog box, browse to the Radiant Software IP Package (.ipk) file, and click **Open**.
   - The Soft IP will be installed into a folder in the user’s personal directory. For example: C:/Users/<username>/RadiantIPLocal/<IP_name>.
   - The Soft IP will be added into the IP Catalog.
Designing with Soft IP, Modules, and PMI

Modules are functional bits of design that can be re-used wherever that function is needed. Creating such components with hardware design languages is common practice. To help your design along, the Radiant software provides a variety of components for common functions. They are optimized for Radiant software device architectures and can be customized. Use these components to speed up your design work and to get the most effective results.

Radiant software components come in a variety of forms:

- **Modules**: These basic, configurable blocks come with IP Catalog. They provide a variety of functions including I/O, arithmetic, memory, and more. Open IP Catalog to see the full list of what’s available. Also see the “Lattice Module Reference Guide” on page 635.
- **IP**: Intellectual property (IP) are more complex, configurable blocks. They are accessible through IP Catalog, but they do not come with the tool. They must first be downloaded and installed as a separate step before they can be accessed from IP Catalog. To see all that’s available and to learn about licensing and other vendors of IP, go to the Lattice website: www.latticesemi.com/ip.

IP Catalog provides a variety of functions ranging from the most basic, such as arithmetic and memory, to much more complex functions. With IP Catalog these components can be extensively customized and created as part of a specific project or as a library for multiple projects. See “Creating IP Catalog Components” on page 117.

However, many of these components can also be used with PMI (see next item). To decide which method to use, see “PMI or IP Catalog?” on page 117.

- **PMI (Parameterized Module Instantiation)** is an alternate way to use some of the components that come with IP Catalog. Instead of using IP Catalog, PMI can directly instantiate a component into your HDL and customize it by setting parameters in the HDL. You may find this easier than using IP Catalog if your design requires many variations of the same component. To decide which method to use, see “PMI or IP Catalog?” on page 117.

- Reference designs provide you with a starting point on creating your own components. Lattice Reference Designs are available in Verilog and VHDL, and can be downloaded from the Lattice website: www.latticesemi.com/ip.

- Lattice library primitives are very basic functions, such as logic gates and flip-flops. They can be directly instantiated as HDL into designs. But this is an advanced technique and should usually be avoided. For more information, see "Designing with Radiant software Library Primitives" on page 125.
PMI or IP Catalog?
Many IP Catalog components are also available as PMI modules, but PMI doesn’t offer error checking. This and the next two sections discuss the pros and cons of both options to help you decide which is best for your project.

PMI is a convenient way to use components of the same type but that vary from instance to instance. This eliminates the need to create a separate component for each instance using IP Catalog.

For example, a design might require dozens of FIFOs that are functionally the same but require different address depths. With PMI, you could insert the same FIFO instantiation command wherever it’s needed in the HDL and just change the address depth parameter as you go. The alternative would be to use IP Catalog to generate different components for each variation and then insert the instantiation template for each of them. In this situation, you might find the PMI method easier and faster.

Before deciding whether to use a PMI module, compare it to the equivalent IP Catalog module. Often IP Catalog provides more options than PMI does. IP Catalog also assures that all of your option selections and parameter settings are legal. PMI offers no error checking.

See Also
- “Creating IP Catalog Components” on page 117
- “Using PMI” on page 123

Creating IP Catalog Components
IP Catalog is an easy way to use a collection of functional blocks from the Radiant software. There are two types of components available through IP Catalog: modules and IP. IP Catalog enables you to extensively customize these components. They can be created as part of a specific project or as a library for multiple projects.

Overview of the IP Catalog Process  Below are the basic steps of using IP Catalog modules and IP. For details of performing these steps, see the following topics.

1. Open IP Catalog. IP Catalog is accessed via a tab at the lower left of the Radiant software. Click the tab, or click in the tool bar, to view the list of available components.

2. Customize the component. These modules and IP can be extensively customized for your design. The options range from setting the width of a data bus to selecting features in a communications protocol.

3. Generate the component and bring its .ipx file into your project. Prior to generating the component, select the option “Insert to project.” This will
automatically bring the .ipx file into your project after the generation step completes. If you do not select this option, add the .ipx file to your project as you would with any other source file (such as a Verilog or VHDL file) after the generation is complete.

4. Instantiate the component into the project’s design. An HDL instance template is generated during the generation step to simplify this step.

5. IP Catalog modules and IP can be further modified or updated later. After the .ipx file has been added to the Radiant software project, it is visible in the project’s file list. Double-clicking the .ipx file brings up the component’s configuration dialog box where changes can be made and the generation process repeated.

See Also

► “Generating a Component with IP Catalog” on page 120
► “IP Catalog Output Files for Components” on page 120
► “Importing an IP Catalog Component into a Project” on page 121
► “Instantiating an IP Catalog Component” on page 122
► “Lattice Module Reference Guide” on page 635

Downloading IP from IP on Server

You can use the IP on Server tab of IP Catalog to download and install the latest IP available from Lattice Semiconductor. Before you can download any IP, you need to set up an Internet connection. If you haven’t already, choose Tools > Options > General > Network Settings and fill in the dialog box.

The Web site also has links to other vendors of IP. To see all that’s available and to learn about licensing and other vendors of IP, go to the Lattice Web site: www.latticesemi.com/ip.

To download Lattice IP on Server:

1. In IP Catalog, click the IP on Server tab, located at the upper-left of the tool. The software connects to the Lattice Semiconductor Web site.
2. Click the refresh icon to update the list.
3. Expand the folder tree and select the IP you want to download.

Information about the IP appears in the right pane including links for additional information.

IP that are compatible with your selected device have icons highlighted in dark blue . IP that are not compatible with your version of Radiant software are have blue icons with a yellow exclamation point . Look for device support information in the right pane.

4. To download the IP, click the IP and choose to the right of the IP name in the list.
5. The downloaded IP is now added to the IP list in the **IP on Local** tab.

**Note**

If Catalog detects a new version of an IP on Server which has been installed in local, the IP icon in IP on Server will alert you with a red dot next to the IP icon.

**See Also**

- "Lattice Module Reference Guide" on page 635

**Using IP Catalog Search Features**

IP Catalog has search features that allow you to search the list of IP and modules by keywords, and also search by by type.

**To use the IP Catalog search feature:**

1. IP Catalog, click the ☰ icon in the upper right.
2. Search by bus type by clicking one or more of the ABH-Lite, APB, or AS14-Stream boxes. The list of modules and IP will display modules that support these bus types.
3. Search by keyword to display module names or IP that contain the keyword in the name. For example, typing “adder” will display all modules that have adder in the module name.

**See Also**

- "Lattice Module Reference Guide" on page 635

**Regenerating IPs**

The regenerate function is an easy way to update your IP without needing to invoke the IP Catalog tool.

If your design was created in an older version of Radiant software, or if your design was created for a different Lattice device, your IP may need to be regenerated. Regenerating IP will update the IP to the current version.

You can regenerate one or or regenerate all IPs to update device information or new new version to existing .ipx file.

**To regenerate as single IP:**

1. In the Radiant software file list, right-click the IP file you wish to regenerate.
2. In the dropdown menu, choose **Regenerate**.

**To regenerate all IP in your design:**

1. In the Radiant software file list, right-click anywhere in the File List.
2. In the dropdown menu, choose **Regenerate All**. A dialog box will pop up to allow you to select one or more IP to regenerate.

**See Also**

- "Lattice Module Reference Guide" on page 635

---

### Generating a Component with IP Catalog

Use IP Catalog to generate a customized functional block from any module or installed IP.

**To generate a component:**

1. In the Module/IP tree, select the component that you want to generate.
2. To get more information about the component, in either the IP on Local tab, or IP on Server tab, click on the module or IP, and then click on the blue question mark 🤔. The IP Information page will appear on the right.
3. Double-click the component, or click the Generate Module/IP Instance button, located at the upper-left of the tool the In the Configuration tab, specify general project information and the base file name for the component.
   - Instance Name is the base name for the component’s files (that is, with no extension).
   - Create In is the location for the customized component’s files.
4. Click **Next**.
   The component’s dialog box opens.
5. In the dialog box, select your desired options. When generating a PLL, click **Calculate** to calculate divider settings and actual output frequencies based on CLKI and desired frequencies.
6. Click **Generate**.
7. To automatically import the .ipx file into your project when the component is generated, select **Insert to project** in the Check Generating Result dialog box.
8. Click **Finish**.

**See Also**

- "IP Catalog Output Files for Components" on page 120
- "Lattice Module Reference Guide" on page 635

---

### IP Catalog Output Files for Components

IP Catalog creates the following output files for components under the specified Project Path. The `<file_name>` comes from the File Name specified in the Configuration tab.
IP Catalog creates some different files for IP. These are documented in the IP’s associated user guide.

Table 4:

<table>
<thead>
<tr>
<th>File Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>&lt;file_name&gt;.ipx</code></td>
<td>Manifest file. This file is loaded into IP Catalog so that modifications can be made to the component.</td>
</tr>
<tr>
<td><code>&lt;file_name&gt;.tmpl.v</code></td>
<td>Instantiation template for Verilog netlist.</td>
</tr>
<tr>
<td><code>&lt;file_name&gt;.v</code></td>
<td>Verilog HDL file for both synthesis and simulation. Verilog output files declare implicit wire types.</td>
</tr>
<tr>
<td><code>tb_top.v</code></td>
<td>Testbench for associated component.</td>
</tr>
</tbody>
</table>

See Also

▶ “Lattice Module Reference Guide” on page 635

Importing an IP Catalog Component into a Project

After generating component source files using IP Catalog, you can import the component by importing the IP Catalog manifest file (.ipx). Components have several files of different types, but you only need to import the .ipx. The .ipx file identifies the components needed to make up the component.

Importing the component may not be necessary if the “Import IPX to project” option was selected when the component was generated.

To import a component:

1. In the File List view, right-click the implementation folder ( ) and choose Add > Existing File.
2. Browse for the customized component’s .ipx file, `<file_name>.ipx`, and select it.
3. Click Add.
   The .ipx file is added to the File List view.
4. Check the Output Panel for error messages. If the component is not targeted for the current device, try double-clicking the file to regenerate the component.

After importing the component, you can further customize it for your design project by changing options specific to the component. You can also update older components or IP to the latest version.

See Also

▶ “Lattice Module Reference Guide” on page 635
Instantiating an IP Catalog Component

IP Catalog components are instantiated the same way other components are in your HDL. When you generate components in IP Catalog, the tool also generates Verilog and VHDL reference templates. You can instantiate the reference templates for implementation or simulation flow of any design, as needed.

Before instantiating any IP Catalog component, check that it is compatible with your design project’s device. When they were created, the components were optimized for a specific device and may depend on that device’s architecture. A component may not work with a different type of device and may need to be regenerated.

Before running any processes on the design, make sure that the IP Catalog component has been imported into the project. See “Importing an IP Catalog Component into a Project” on page 121.

The instantiation file is located in the folder in which the component was created. The file name is based on the component’s name: `<component name>_tmpl.v` or `<component name>_tmpl.vhd`.

You can instantiate the IP Catalog Module or IP in one of the following ways:

1. If you selected the option of not inserting the generated IP into your project, browse to the `<component name>_tmpl.v` or `<component name>_tmpl.vhd`, open the file in a text editor, copy the text, and paste into your source file. Then, add an instance and signal names to the component ports.

2. If you selected the option of inserting the generated IP into your project, the IP component configuration file (.ipx) appears in your design implementation. You can instantiate the generated component or IP as follows:

   - In the File List, right-click the component or IP .ipx file, and choose the instantiation command.
   - For Verilog, choose Copy Verilog Instantiation, and paste it into your source file. Then, add an instance and signal names to the component ports.
   - For VHDL, choose Copy VHDL Component, and paste it into your source file; then choose Copy VHDL Instantiation, and paste it into your source file. Then, add an instance and signal names to the component ports.

See Also

- “Lattice Module Reference Guide” on page 635
Using PMI

As mentioned earlier, PMI is an alternate way to use some of the components that come with IP Catalog. Instead of using IP Catalog, you directly instantiate a component into your HDL and customize it by setting parameters in the HDL using PMI. You may find this easier than using IP Catalog if your design requires many variations of the same component.

See Also

- “PMI or IP Catalog?” on page 117
- “PMI Process Steps” on page 123
- “Instantiating a PMI Component” on page 123
- “Lattice Module Reference Guide” on page 635

PMI Process Steps

This section provides a brief listing of the process steps taken when using PMI.

1. Using Source Template, insert PMI components in the HDL source files. This is the recommended method because it includes the PMI instance templates, which require minimal editing.
2. If using stand-alone synthesis and simulation tools, add the PMI soft IP from the `<install_path>/ip/pmi/` directory.
3. Perform the remaining implementation steps as you would normally.

See Also

- “Lattice Module Reference Guide” on page 635

Instantiating a PMI Component

PMI components are instantiated the same way other components are in your HDL. The Radiant software provides a template for the Verilog or VHDL instantiation command that specifies the customized component's ports and parameters. Customize the component by changing its parameters.

To instantiate a PMI component:

1. With Source Editor, open the source file that will receive the component. See “Running Source Editor” on page 77.
2. Drag and drop the text into your source file.
3. Add an instance name, set parameter values, and add signal names to the corresponding component ports in the instantiation command, as shown in Figure 20. For information about allowed parameter values, see the section on the component in the “Lattice Module Reference Guide” on page 635.
Designing with Soft IP, Modules, and PMI

Figure 20: PMI Instantiation Command Example

Verilog

```verilog
pmi_add
#(
  .pmi_data_width   ( ),
  .pmi_sign         ( ),
  .pmi_family       ( ),
  .module_type      ( )
) <your_inst_label> (  
  .DataA   ( ), // I:
  .DataB   ( ), // I:
  .Cin     ( ), // I:
  .Result  ( ), // O:
  .Cout    ( ), // O:
  .Overflow ( ) // O:
);
```

VHDL

```vhdl
<your_inst_label> : pmi_add
generic map (  
  pmi_data_width  => ,
  pmi_sign        => ,
  pmi_family      => ,
  module_type     =>
)
port map (  
  DataA  => , -- I:
  DataB  => , -- I:
  Cin    => , -- I:
  Result => , -- O:
  Cout   => , -- O:
  Overflow =>    -- O:
);
```

4. Save and close the source file.

See Also

- "Lattice Module Reference Guide" on page 635

Requirements for Simulation and Synthesis with PMI

The PMI module code is a black box definition of an IP Catalog module. For this reason, simulation models for these blocks must be available to supplement the code for simulation. For synthesis, a PMI synthesis header file needs to be added to the project.

VHDL designs have a few additional requirements for both synthesis and simulation.

**PMI Simulation Models** For Aldec Active-HDL, the PMI models are automatically available. When using ModelSim, or any other simulator, you must first compile the simulation library (pmi_work) from the sources, which are in `<install_dir>/ip/pmi`, where `<install_dir>` is the installation folder of the Radiant software.

To compile PMI library, run the following command in ModelSim/Questa TCL console):

```tcl
vlib pmi_work
vlog -work pmi_work  <install_dir>/ip/pmi/pmi.v
```

**Note**

PMI library name should be ‘pmi_work’ as it will be used in Simulation Wizard mdo script to launch Modelsim/Questa.
PMI Synthesis Header Files  The PMI synthesis header files for Verilog and VHDL are at:

\(<install\_dir>/ip/pmi\)

If you are running synthesis from inside Radiant software (the integrated flow), add the PMI synthesis header file to your design project by right-clicking the implementation folder () in the File List view and choosing Add > Existing Source.

If you are running the synthesis tool outside of Radiant software (the interactive or stand-alone flows), add the PMI synthesis header file to your synthesis tool project.

VHDL Requirements  When performing simulation for VHDL PMI, you also need to compile the PMI component declaration file into your work library. The file is at:

\(<install\_dir>/ip/pmi\_def.vhd\)

At the top of your source file, add two lines:

```
use work.pmi_components.all;
library pmi_work;
```

The first line includes the PMI components defined in the header file. The second line is required by some simulators, such as Active-HDL, for successful library binding.

See Also

- “Lattice Module Reference Guide” on page 635

Designing with Radiant software Library Primitives

Any Radiant software library primitive described in the “FPGA Libraries Reference Guide” on page 637 can be instantiated as a Verilog component or VHDL component in your RTL design. This "gate-level" design approach can be error-prone and should be limited to a small number of primitives if attempted at all. In general, Lattice recommends you rely on IP Catalog to generate components that are built with Radiant software library primitives.

To minimize the amount of code overhead required to design using a library primitive, the Radiant software provides a Verilog and VHDL synthesis header library file for each major FPGA device family. Refer to the “Lattice Synthesis Header Libraries” on page 250 topic for details. The component is generally treated as a "black box", which causes the synthesis tool to pass instances of the library primitive into the target netlist untouched.

The primitive libraries contain descriptions, pin outs, and schematic diagrams of all library primitives for Radiant software FPGA libraries.
See Also

“Simulation Library Files” on page 157
Chapter 4

Securing the Design

The Radiant software provides the IP security based on the *Recommended Practice for Encryption and Management of Electronic Design Intellectual Property (IP)* of the IEEE 1735-2014 version 1 standard.

The implementation enables securing IP while ensuring the design flow and the interoperability across different EDA tools. Upon entering the design into Radiant software, IP author selects the desired level of security by encrypting HDL source files. The set security level propagates through the design and impacts the visibility of secured objects in various Radiant software tools. The current version supports encryption of VHDL and Verilog HDL files. Bitstream Security Settings tool generates various encryption key sets. IP Consumer has the flexibility to use the generated key sets during the bitstream generation.

The Radiant software encrypted IP can be processed by other third-party EDA tools including Aldec Active-HDL, Cadence NCSim, Mentor Graphics ModelSim, Synopsys Synplify Pro, and Synopsys VCS simulator.

**IP Encryption Flow**  IP encryption flow enables you to protect your IP design. Following the industry standard, the Radiant software, through the IP encryption flow, allows the partnership between the IP Vendor, supported EDA vendor, and Lattice.
The encryption flow uses symmetric and asymmetric encryption methods to maximize the design security. The symmetric method only involves a single symmetric key for both, encryption and decryption. The asymmetric method involves the public-private key pair. The public key is published by a vendor and is used by the Radiant software. The private key is never revealed to the public.

The Radiant software supports these cryptographic algorithms:

- **AES-128/AES-256**: symmetric algorithm used to encrypt the content of the HDL source file.
- **RSA-2048**: asymmetric algorithm used to obfuscate a key used in HDL file encryption. The RSA is defined by the public-private key pair. You must be familiar with both keys in order to perform RSA decryption.

**HDL File Encryption Flow** The current software version supports encryption of a single HDL source file per a single command.

The overall HDL file encryption flow is summarized in these steps:

- The source file of the IP design is AES encrypted using a symmetric Session key. The AES encryption uses CBC-128 or CBC-256 algorithm. In the source files, this section is referred to as a data block.
- The Session key is RSA encrypted using the vendor’s Public Key. In the source files, this section is referred to as a key block. Multiple key blocks may be present in the source file.
The encrypted Session key and the encrypted design are merged to file generally named the Encrypted RTL.

Each encrypted source file contains one or more data blocks. Each data block is associated with one or more key blocks. The number of key blocks depends on the number of provided vendor’s public key.

**NOTE**

To decrypt an encrypted source file, you must perform the IP encryption flow steps in the reverse order.

During the next step in the design flow, typically a synthesis, the Encrypted RTL is decrypted to access the original IP design, as shown in the following figure.

By separating the encryption of data and key, you can use public keys from different vendors to encrypt the same HDL file.

For more information on how to perform HDL encryption, refer to “Running HDL Encryption from the Command Line” on page 914.

See Also
- “HDL File Encryption Steps” on page 129
- “Secure Objects in the Design” on page 133

## HDL File Encryption Steps

This section provides step-by-step instructions on how to encrypt an HDL file.

The Radiant software provides the key templates you can simply drag-and-drop into an HDL file. Each key template is specific to an EDA vendor providing the value of a public key.

To view the templates in the Radiant software, choose Source Template > Verilog > Encryption Templates and select the EDA specific key template.
Currently, the Radiant software supports these encryption templates:

- Lattice Semiconductor
- Synplicity-1
- Synplicity-2
- Mentor
- Synopsys
- Aldec
- Cadence
- Combined Sample: provides an example of file holding multiple keys.

**Step 1: Prepare the HDL file**  Annotate the HDL source file with protected pragmas. Protected pragmas provide information regarding type of the key used to encrypt the HDL file, the name of the key, and the encryption algorithm.

In this example, HDL source file will be encrypted by the Lattice Public Key.

```verbatim
'pragma protect version=1
'pragma protect encoding=(enctype="base64")

// optional information
'pragma protect author="<Your_Name>"
'pragma protect author_info="<Your_Information>"
```

**Step 2: Specify the portion of HDL source file that shall be encrypted**

Annotate the HDL file to specify the encryption. Only the portion defined within these protected pragmas is encrypted.

```verbatim
'pragma protect begin
// HDL portion that shall be encrypted
'pragma protect end
```

**Step 3: Prepare Key**  Define the key with which the HDL file should be encrypted. Each key definition must contain the following information:

- **key_keyowner**: specify the owner of the key
- **key_keyname**: specify the name of the key. Same owner may provide multiple keys.
- **key_keymethod**: specify the used cryptographic algorithm. Current version supports RSA algorithm.
- **key_public_key**: specify the exact value of the key.

The key definition can be done in two ways:

**Defining the key in the key.txt file:**  The public encryption key or keys can be defined in any .txt file. The key file may contain a single public key or a list of all available public keys. In the Radiant software, all common EDA vendor public keys are located in `<Radiant_installed_directory>/ispfpga/data/key.txt` file.
The following is an example of Lattice Public Key defined in key.txt file:

```
'pragma protect key_keyowner= "Lattice Semiconductor"
'pragma protect key_keyname= "LSCC_RADIANT_2"
'pragma protect key_method="rsa"
'pragma protect key_public_key
MIIBIjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIBCgKCAQEA0EZKUUhbuB6vSc70hQJ
iNAWJR5unW/0mP/1F71eA13s9bOYE2OL1Kdxbai+nd1eo8xFt2btxetUzuR6SrVh
xrZSbj9bbqI0oo2u8jff3b7A7AmRvLWKR8708DPo4LD7OQA3q0kFfDDWkp2Eausf
LZ2ECvXk97f/y/bDH0uN8xRQCSKj7aguG6kO16ROoZ2Zl1jzDLUQ2hmZqYF88pU1o
tDB/uw53lFShuR33MOB+*xcn2imvSLqdhWuhX6CtiZix5CD4y8inCbcLy/Qqrf6
sdTN5Sag2OZhjeNdzmqSWqhL2JTDw+Ou2fWzhEd0i/HN0y4NMr6h9fNn8nqxRyE7
TwIDAQAB
```

Defining the key directly in the HDL file: You may define the Public Key directly in the HDL file. You may define one or more keys.

```
'pragma protect key_keyowner= "Lattice Semiconductor"
'pragma protect key_keyname= "LSCC_RADIANT_2"
'pragma protect key_method="rsa"
'pragma protect key_public_key
MIIBIjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIBCgKCAQEA0EZKUUhbuB6vSc70hQJ
iNAWJR5unW/0mP/1F71eA13s9bOYE2OL1Kdxbai+nd1eo8xFt2btxetUzuR6SrVh
xrZSbj9bbqI0oo2u8jff3b7A7AmRvLWKR8708DPo4LD7OQA3q0kFfDDWkp2Eausf
LZ2ECvXk97f/y/bDH0uN8xRQCSKj7aguG6kO16ROoZ2Zl1jzDLUQ2hmZqYF88pU1o
tDB/uw53lFShuR33MOB+*xcn2imvSLqdhWuhX6CtiZix5CD4y8inCbcLy/Qqrf6
sdTN5Sag2OZhjeNdzmqSWqhL2JTDw+Ou2fWzhEd0i/HN0y4NMr6h9fNn8nqxRyE7
TwIDAQAB
```

If the key is defined directly in the HDL file, you don’t need to provide `-k` option in `encrypt_hdl` command.

Note
The key defined directly in HDL source file has preference over the key defined in the key.txt file.

---

**Step 4: Select the encryption algorithm for data encryption** The Radiant software supports both, a 128-bit and a 256-bit advanced encryption standard (AES) with CBC mode. Select the type of algorithm by defining one of the two options. The default is set to 256-bit AES with CBC mode.

```
'pragma protect data_method="aes128-cbc"
```

or

```
'pragma protect data_method="aes256-cbc"
```

**Step 5: Run `encrypt_hdl` Tcl Command** In the Tcl console window, type in the command to encrypt an HDL file. The option ‘-k’ may or may not be used depending on the location of the key file. The language selection ‘-l’ and creation of new output file ‘-o’ are optional; selects Verilog by default. If you don’t specify the output file, the tool generates a new output file named `<input_file_name>_enc.v`.

```
eencrypt_hdl -k <keyfile> -l <verilog | vhdl> -o <output_file> <input_file>
```

If key was defined in the key.txt file: The command will encrypt the HDL file with all keys defined in the key.txt.
If key was defined directly in the HDL file:

```
encrypt_hdl -l <verilog | vhdl> -o <output_file> <input_file>
```

The encrypted file is located at the path specified in the `encrypt_hdl` command.

**Step 6: Activate the encrypted HDL source file in Project File**  In the Radiant software File List, add the generated file into the project. Right-click on the encrypted file and select **Include in Implementation**.

To view example of Verilog or VHDL pragma annotated HDL source file, visit “Defining Pragmas” on page 916.

---

**Synthesizing Encrypted IP**

The Radiant software supports Lattice Synthesis Engine (LSE) and Synplify Pro synthesis tool. To synthesize an encrypted design, the synthesis tool must decrypt the encrypted design prior the synthesis. Depending on the selected synthesis tool, LSE or Synplify Pro, you must provide the valid vendor’s public key to process this step.

You may observe these common issues due to the flow obfuscation:

**The design is encrypted with an incorrect key**  The user observes an error message and synthesis process fails.

```
1025000  Synthesis  ERROR: No supported key informations.
```

The error appears when there is a mismatch between a key used to encrypt the IP design and the vendor’s public key.

**The design is missing an encryption key**  The user observes an error message and synthesis process fails.

```
1025000  Synthesis  ERROR: No supported key informations.
```

The error appears when the user encrypts the IP with only Synplify Pro public key. During the synthesis step, given you have selected the Synplify Pro synthesis tool, the design is decrypted and synthesized as expected. When running the Radiant software postsyn flow, the LSE public key must be present in order to properly decrypt the synthesized IP.

To correct this error, the user must add the missing public key to the key file or directly define it in the HDL source file and rerun the encryption tool.

**NOTE**

It is recommended to always define and encrypt your source files with both, LSE and Synplify Pro Public Keys. This ensures that your design is processed through the full Radiant software flow independent of the selection of the synthesis tool.
Cross-probing in Encrypted Design

The Radiant software supports a path cross-probing between Netlist Analyzer, Placement Mode, and Routing Mode.

In the Reports tab, view any analysis report and identify a path to view. If cross-probing is available, the specific icon tools become visible, as shown in the following Figure.

Figure 21: Available tools for Path Cross-probing

Click on icon and the specific tool opens with selected path view.

Due to an encrypted design, in some cases, the path cross-probing is unable to view. The message “Cannot open encrypted design.” appears.

NOTE

Cross-probing to Netlist Analyzer is available only if selected synthesis tool is Lattice LSE.

Secure Objects in the Design

Radiant software protects all aspects of the IP at all times while allowing the tool to work for its intended purpose. The tool also have option to correct overprotected part of the design if proven to be unusable without certain visibility, such as external ports of the design.

You can choose the level of the design obfuscation.

- Unsecured design: The design consists of the original HDL source files.
- Partially-secured design: The design consists of mixture of encrypted HDL source file(s) and original HDL source files.
- Fully-secured design: The entire design is encrypted.

When a design is encrypted, the Radiant tools reflects the changes in displaying the secured objects. Secured objects include instances, nets, ports, and pins. Clock related objects are typically not encrypted.

Visibility  The input and output names inside of the protected design parts contain no reference to real name and are not recognized as names inside of IP.

Messaging  Design names, RTL identifiers names of IP, and RTL source reference are not referenced in messages.
Report files  Design names, RTL identifiers names of IP, and RTL source reference are not referenced in report files.

GUI/Tcl Interface  Design names, RTL identifiers names of IP, and RTL source reference are not referenced in GUI.

The following tools have been enhanced to support this feature.

- “Hierarchical View” on page 134
- “Netlist Analyzer” on page 135
- “Reveal Inserter” on page 136
- “Timing Constraint Editor” on page 137
- “Device Constraint Editor” on page 138
- “Placement Mode” on page 139
- “Routing Mode” on page 141
- “Power Calculator” on page 142
- “Timing Analyzer” on page 142

See Also  “Running HDL Encryption from the Command Line” on page 914

Hierarchical View

Hierarchical view allows you to view the overall design structure.

Unencrypted design allows you to view all design instances and expand all instance’s sub-folders. In partially secured designs, only pragma defined section of an HDL file is encrypted. The Hierarchical view shows the design icon next to the partially encrypted source file. The sub-folders of this file are no longer viewable.

In fully secured design, the entire module is encrypted, and the Hierarchical view shows the secured design icon next to the encrypted source files. The instance is hidden from viewing its sub folder.

```
    ▼ top - top . env
    ▼ serial_reg_custom_uniq_2(U_serial_reg_custom_in_18) - top . env
    ▼ serial_reg_custom_uniq_1(U_serial_reg_custom_in_1A) - top . env
    ▼ serial_reg_custom_first(U_serial_reg_custom_out_{1}) - top . env
        ▼ reg_custom(U_reg_custom_out) - top . env
        ▼ reg_custom(U_reg_custom_in) - top . env
        ▼ add_custom(U_add_custom_{1}) - top . env
```

See Also  “Secure Objects in the Design” on page 133
## Netlist Analyzer

Netlist Analyzer produces a schematic view of your design. Once design is partially or fully encrypted, the encrypted objects and in some cases, the entire design, become hidden from the schematic view.

The visibility of secured objects is described below. In unsecured designs, the entire hierarchical structure is visible. In partially secured designs, the ports of encrypted objects are visible; however, you won’t be able to view the content and/or sub-structure of a secured object. In fully secured design, the entire design is encrypted; thus, the Netlist Analyzer is unable to produce schematic view and displays an error message instead.

| Table 5: Secured Objects in Netlist Analyzer |
|-------------------------------|-----------------|-----------------|-----------------|
| **Object Name** | **Unsecured Design** | **Partially Secured Design** | **Fully Secured Design** |
| **Instances** | [ ] | [ ] | [ ] |
| **Name** | Keeps the original name. | Keeps the original name. | Keeps the original name. |
| **Visibility** | Drop-down icon allows to expand and view the sub-directories. | Unable to view or expand its sub-hierarchy. | Unable to view or expand its sub-hierarchy. |
| **Ports** | Visible | Visible | Visible |
| **Nets** | Visible | Hidden | Hidden |

In figure, two serial_reg_custom modules are fully encrypted and serial_reg_custom_final module is partially encrypted. You are only able to view the peripheral I/O ports.

Be aware of visual representation of secured and unsecured module.

In specific cases when the entire design is encrypted, the Netlist Analyzer is unable to show the design. Instead, an error message appears.
Reveal Inserter

Reveal Inserter performs the logic analysis on your design. When design is partially or fully encrypted, the secured signals are not available for viewing.

The visibility of secured objects is described below.

Table 6: Secured Objects in Reveal Inserter

<table>
<thead>
<tr>
<th>Object Name</th>
<th>Unsecured Design</th>
<th>Partially Secured Design</th>
<th>Fully Secured Design</th>
</tr>
</thead>
<tbody>
<tr>
<td>Instances</td>
<td>![Visible]</td>
<td>![Hidden]</td>
<td>![Hidden]</td>
</tr>
<tr>
<td>Names</td>
<td>Keeps the original name.</td>
<td>Keeps the original name.</td>
<td>Keeps the original name.</td>
</tr>
<tr>
<td>Visibility</td>
<td>Drop-down icon allows to expand and view the subdirectories.</td>
<td>Hidden</td>
<td>Hidden</td>
</tr>
<tr>
<td>Ports</td>
<td>Visible</td>
<td>Visible</td>
<td>Visible</td>
</tr>
<tr>
<td>Nets</td>
<td>Visible</td>
<td>Hidden</td>
<td>Hidden</td>
</tr>
</tbody>
</table>

The visual representation of unsecured and secured objects visible in Design Tree pane of the Reveal Inserter. As shown in the following figure, the secured modules are hidden from the hierarchical structure of partially encrypted design.
In specific cases when the entire design is encrypted, the Reveal Inserter is unable to show the design. Instead, an error message appears.

See Also  "Secure Objects in the Design" on page 133

Timing Constraint Editor

Timing Constraint Editor is updated to support encrypted design.

In both constraint editors, Pre-Synthesis Timing Constraint Editor and Post-Synthesis Timing Constraint Editor, the tool will not write protected design names into constraints.

Table 7: Secured Objects in Timing Constraint Editor

<table>
<thead>
<tr>
<th>Object Name</th>
<th>Unsecured Design</th>
<th>Partially Secured Design</th>
<th>Fully Secured Design</th>
</tr>
</thead>
<tbody>
<tr>
<td>Instance</td>
<td>Visible</td>
<td>Hidden</td>
<td>Hidden</td>
</tr>
<tr>
<td>Net</td>
<td>Visible</td>
<td>Hidden</td>
<td>Hidden</td>
</tr>
<tr>
<td>Pin</td>
<td>Visible</td>
<td>Hidden</td>
<td>Hidden</td>
</tr>
</tbody>
</table>
Table 7: Secured Objects in Timing Constraint Editor

<table>
<thead>
<tr>
<th>Object Name</th>
<th>Unsecured Design</th>
<th>Partially Secured Design</th>
<th>Fully Secured Design</th>
</tr>
</thead>
<tbody>
<tr>
<td>Clock related Pins, Ports, and Nets</td>
<td>Visible</td>
<td>Visible</td>
<td>Visible</td>
</tr>
<tr>
<td>Memory Instance</td>
<td>Visible</td>
<td>Visible</td>
<td>Visible</td>
</tr>
<tr>
<td>Modules and Registers used in synthesis attribute constraints</td>
<td>Visible</td>
<td>Visible</td>
<td>Visible</td>
</tr>
</tbody>
</table>

**IMPORTANT**
The user must not encrypt designs that require to set the constraints at the user's top level.

See Also  "Secure Objects in the Design" on page 133

Device Constraint Editor

Device Constraint Editor is updated to support encrypted design.

In both constraint editors, Pre-Synthesis Timing Constraint Editor and Post-Synthesis Timing Constraint Editor, the tool will not write protected design names into constraint.

The user must not encrypt designs that require setting the constraints at the top level.

Table 8: Secured Objects in Device Constraint Editor

<table>
<thead>
<tr>
<th>Object Name</th>
<th>Unsecured Design</th>
<th>Partially Secured Design</th>
<th>Fully Secured Design</th>
</tr>
</thead>
<tbody>
<tr>
<td>Instance</td>
<td>Visible</td>
<td>Hidden</td>
<td>Hidden</td>
</tr>
<tr>
<td>Net</td>
<td>Visible</td>
<td>Replaced with 'secured_signal'</td>
<td>Replaced with 'secured_signal'</td>
</tr>
<tr>
<td>Pin</td>
<td>Visible</td>
<td>Hidden</td>
<td>Hidden</td>
</tr>
<tr>
<td>Clock related Pins, Ports, and Nets</td>
<td>Visible</td>
<td>Visible</td>
<td>Visible</td>
</tr>
<tr>
<td>Memory Instance</td>
<td>Visible</td>
<td>Visible</td>
<td>Visible</td>
</tr>
<tr>
<td>Modules and Registers used in synthesis attribute constraints</td>
<td>Visible</td>
<td>Visible</td>
<td>Visible</td>
</tr>
</tbody>
</table>
In the following figure, the signal names were replaced by ‘secured_signal’ names.

See Also  “Secure Objects in the Design” on page 133

**Physical Designer**

The Physical Designer is a combined GUI interface that features:

- “Placement Mode” on page 139 – Provides a large-component layout for your design. When design is partially of fully encrypted, the secured signals are not available for viewing.

- “Routing Mode” on page 141 – Provides a detailed layout of your design. When design is partially or fully encrypted, secure objects are renamed or hidden. The logic block of secured object is not viewable.

Physical Designer can be invoked by either: **Tools > Physical Designer** or by clicking on the toolbar icon . Upon opening, the GUI you will be shown is the Placement mode.

**Placement Mode**

Placement Mode provides a large-component layout for your design. When design is partially of fully encrypted, the secured signals are not available for?
viewing. Additionally, the secured components and nets cannot be found using the “Find” dialog box.

Table 9: Secured Objects in Placement Mode

<table>
<thead>
<tr>
<th>Visibility</th>
<th>Unsecured Design</th>
<th>Partially Secured Design</th>
<th>Fully Secured Design</th>
</tr>
</thead>
<tbody>
<tr>
<td>Component</td>
<td>Visible</td>
<td>Hidden</td>
<td>Hidden</td>
</tr>
<tr>
<td>Instance</td>
<td>Visible</td>
<td>Replaced with 'secured_instance'</td>
<td>Replaced with 'secured_instance'</td>
</tr>
<tr>
<td>Grouping Secured Instances</td>
<td>Allowed</td>
<td>Not allowed.</td>
<td>Not allowed.</td>
</tr>
</tbody>
</table>

Secured instances are hidden in Available Instances list of the Create GROUP window.

Logic Block View | Enabled | Disabled | Disabled |

In following the figure, the signal and instance names were replaced by ‘secured_instance’.

See Also  “Secure Objects in the Design” on page 133
Routing Mode

Routing Mode shows a detailed layout of your design. When design is partially or fully encrypted, secure objects are renamed or hidden. The logic block of secured object is not viewable.

Table 10: Secured Objects in Routing Mode

<table>
<thead>
<tr>
<th>Visibility</th>
<th>Unsecured Design</th>
<th>Partially Secured Design</th>
<th>Fully Secured Design</th>
</tr>
</thead>
<tbody>
<tr>
<td>Primitive</td>
<td>Visible</td>
<td>Available with a hidden name</td>
<td>Available with a hidden name</td>
</tr>
<tr>
<td>Component</td>
<td>Visible</td>
<td>Hidden</td>
<td>Hidden</td>
</tr>
<tr>
<td>Instance</td>
<td>Visible</td>
<td>Replaced with 'secured_instance'</td>
<td>Replaced with 'secured_instance'</td>
</tr>
<tr>
<td>Nets</td>
<td>Visible</td>
<td>Replaced with 'secured_signal'</td>
<td>Replaced with 'secured_signal'</td>
</tr>
<tr>
<td>Grouping Secured Instances</td>
<td>Allowed</td>
<td>Not allowed</td>
<td>Not allowed</td>
</tr>
<tr>
<td>Logic Block View</td>
<td>Enabled</td>
<td>Disabled</td>
<td>Disabled</td>
</tr>
</tbody>
</table>
The following figure shows the Routing Mode figure with SLICEs were replaced by 'secured_instance' due to encrypted design.

**See Also**  “Secure Objects in the Design” on page 133

**Power Calculator**

Power Calculator estimates the power dissipation in a design. Typically, Power Calculator displays the design objects relative to clock. When design is partially or fully encrypted, the encrypted signal names are hidden with the exception of clock related nets.

**See Also**  “Secure Objects in the Design” on page 133

**Timing Analyzer**

The timing report file .twr and .twl used by Timing Analyzer is updated to support secured designs.
Secure Objects in the Design

Constraint Table  The secured pin name is replaced with “SECURED_PIN.”

<table>
<thead>
<tr>
<th>Path</th>
<th>Start Point</th>
<th>End Point</th>
<th>Setup/Hold Constraint</th>
<th>Slack</th>
<th>Delay</th>
<th>Source Clock</th>
<th>Destination Clock</th>
<th>Analysis Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>SECURED_PIN</td>
<td>SECURED_PIN</td>
<td>4.086</td>
<td>3.470</td>
<td>38.188</td>
<td>USC/42MH</td>
<td>USC/42MH</td>
<td>setup</td>
</tr>
<tr>
<td>2</td>
<td>SECURED_PIN</td>
<td>SECURED_PIN</td>
<td>4.086</td>
<td>3.626</td>
<td>30.042</td>
<td>USC/42MH</td>
<td>USC/42MH</td>
<td>setup</td>
</tr>
<tr>
<td>3</td>
<td>SECURED_PIN</td>
<td>SECURED_PIN</td>
<td>4.086</td>
<td>4.020</td>
<td>37.049</td>
<td>USC/42MH</td>
<td>USC/42MH</td>
<td>setup</td>
</tr>
<tr>
<td>4</td>
<td>SECURED_PIN</td>
<td>SECURED_PIN</td>
<td>4.086</td>
<td>4.100</td>
<td>37.309</td>
<td>USC/42MH</td>
<td>USC/42MH</td>
<td>setup</td>
</tr>
<tr>
<td>5</td>
<td>SECURED_PIN</td>
<td>SECURED_PIN</td>
<td>4.086</td>
<td>4.151</td>
<td>37.316</td>
<td>USC/42MH</td>
<td>USC/42MH</td>
<td>setup</td>
</tr>
<tr>
<td>6</td>
<td>SECURED_PIN</td>
<td>SECURED_PIN</td>
<td>4.086</td>
<td>4.378</td>
<td>37.288</td>
<td>USC/42MH</td>
<td>USC/42MH</td>
<td>setup</td>
</tr>
<tr>
<td>7</td>
<td>SECURED_PIN</td>
<td>SECURED_PIN</td>
<td>4.086</td>
<td>4.407</td>
<td>37.155</td>
<td>USC/42MH</td>
<td>USC/42MH</td>
<td>setup</td>
</tr>
<tr>
<td>8</td>
<td>SECURED_PIN</td>
<td>SECURED_PIN</td>
<td>4.086</td>
<td>4.262</td>
<td>37.142</td>
<td>USC/42MH</td>
<td>USC/42MH</td>
<td>setup</td>
</tr>
<tr>
<td>9</td>
<td>SECURED_PIN</td>
<td>SECURED_PIN</td>
<td>4.086</td>
<td>4.576</td>
<td>37.000</td>
<td>USC/42MH</td>
<td>USC/42MH</td>
<td>setup</td>
</tr>
<tr>
<td>10</td>
<td>SECURED_PIN</td>
<td>SECURED_PIN</td>
<td>4.086</td>
<td>4.722</td>
<td>35.944</td>
<td>USC/42MH</td>
<td>USC/42MH</td>
<td>setup</td>
</tr>
</tbody>
</table>

Paths for All Timing Constraints Table  The secured pin name is replaced with “SECURED_PIN.”

Path Detail  The secured pin name is replaced by “SECURED_PIN.”

Data Path Table  The secured pin name is replaced by “SECURED_PIN”, secured signal name is replaced by “SECURED_SIGNAL.”

See Also  “Secure Objects in the Design” on page 133
Securing the Bitstream

Bitstream security enables various options of soft and hard IP obfuscations during the bitstream generation. The type of bitstream encryption depends on the key generated in the Bitstream Security Settings tool and the status of your IP license.

If IP license is detected during the Radiant software Bitstream File generation process, the bitstream may be encrypted by user-provided AES key, Bitstream Security Settings tool generated key, or it is not encrypted. Various types of keys for bitstream encryption are generated in “Bitstream Security Settings Tool” on page 144.

If IP license is not detected and you wish to perform the IP evaluation only, before generating the bitstream file, you must first set the IP Evaluation strategy. Refer to “Bitstream Options” on page 542. If the IP Evaluation strategy is enabled, Radiant software enables Soft IP timer to allow usage of temporary IP license. During the evaluation period, the bitstream is always encrypted with Lattice Soft IP Evaluation Key, and if necessary, overwrites user-provided AES key. Alternative types of keys for bitstream encryption can be generated in Bitstream Security Settings Tool, assuming the Lattice Soft IP Evaluation Key is enforced.

IMPORTANT
During the IP Evaluation, the bitstream is always encrypted with Lattice Soft IP Evaluation Key. The Lattice Soft IP Evaluation Key has a precedence over user-provided AES key.

See Also  ► “Bitstream Security Settings Tool” on page 144

Bitstream Security Settings Tool

The Bitstream Security Settings tool (Security GUI) allows you to generate/verify keys that are used for bitstream obfuscation.

Security GUI provides the user entry for Password Protection (128-bit device password), AES-256 Encryption, HMAC Authentication, and ECDSA Authentication.

User login password protection is required in Security GUI. You can either define a new password or use the preset default LATTICESEMI password.

Security GUI generates various output key files that are user login password protected:
► Security Tool project file (.secproj), which is encrypted by user login password.
► Password Protection Key file (.key) contains 128-bit device password.
- Encryption Key file (.bek) contains 256-bit AES key, which is encrypted by user login password.
- Authentication Private Key file (.prv) contains either:
  - 256-bit Private Key for ECDSA Authentication.
  - 256-bit Signature for ECDSA Authentication.
  - 256-bit HMAC Key for HMAC Authentication.
- Authentication Public Key file (.pub) contains 512-bit ECDSA Public Key.

**NOTES**

- The .secproj, .key, .bek, and .prv files should not be edited by user.
- HMAC Authentication and ECDSA Authentication are mutually exclusive.

The level of bitstream obfuscation depends on the options selected in Security GUI.

**Password Protection (Device Password)**  
Password Protection generates a 128-bit device password key.

**To run the Bitstream Security Settings tool and set security settings:**
1. In Lattice Radiant, choose **Tools > Bitstream Security Settings**.
The Enter Password dialog box opens. Because the project does not yet contain a .key file, the dialog box shows LATTICESEMI as the default password.

2. To change the password, click **Change Password** to open the Change Password dialog box.

3. In the Enter Password field, type in a password of at least eight but no more than sixteen characters.

4. Type the password again in the Verify Password field and click **OK**. The Security Settings dialog box opens.

5. To set up device password, check the **Password Protection (Device Password)** option in the Security Settings dialog box.

6. Select a key format from the Key Format drop-down list, Load from file, or Default Key.
   - Select a key from the Key Format drop-down list, and then type a key in the text boxes as follows, depending on the format selected:
     - For the default ASCII format, type alphanumeric values using up to 16 characters.
     - For hex format, type values of 0 through F, using up to 32 characters.
     - For binary format, type 0 and 1 values, using up to 128 characters.
   - Select a key from Load from File.
     - The Load Key from File dialog box opens, select the key file and click Open.
   - Select a key by clicking on Default Key button.
     - The tool generates LATTICESEMICONDU key.

7. Click **OK** to apply the settings.

**AES Encryption**  The AES-256 encryption can be used without any authentication. Since AES is a symmetric-key algorithm, the same key is used for both encrypting and decrypting the bitstream.

To run the Bitstream Security Settings tool and set security settings:

1. In Lattice Radiant, choose **Tools > Bitstream Security Settings**.
   - The Enter Password dialog box opens. Because the project does not yet contain a .key file, the dialog box shows LATTICESEMI as the default password.

2. To change the password, click **Change Password** to open the Change Password dialog box.

3. In the Enter Password field, type in a password of at least eight but no more than sixteen characters.

4. Type the password again in the Verify Password field and click **OK**. The Security Settings dialog box opens.
5. To set up AES key, check the **AES Encryption** option in the Security Settings dialog box.

6. Select a key format from the Key Format drop-down list, Load from file, or Auto Generated Key.
   
   - Select a key from the Key Format drop-down list, and then type a key in the text boxes as follows, depending on the format selected:
     
     - For the default ASCII format, type alphanumeric values using up to 32 characters.
     
     - For hex format, type values of 0 through F, using up to 64 characters.
     
     - For binary format, type 0 and 1 values, using up to 256 characters.
     
   - Select a key from Load from File.
     
   - The Load Key from File dialog box opens, select the key file and click Open.
     
   - Select a key by clicking on Auto Generated Key button.
     
   - The tool generates a random 256-bit AES key in hex format.

7. Click OK to apply the settings.

8. Click OK to close the Security Setting dialog box.

**HMAC Authentication**  A keyed-hash message authentication code (HMAC) is a specific type of message authentication code involving a cryptographic hash function and a secret cryptographic key.

To keep the HMAC Key protected, HMAC Authentication is always used together with AES Encryption. The bitstream, with the HMAC key, is first run through the SHA-256 hash function. The hashed function is then AES encrypted with the 256-bit AES key.

**To run the Bitstream Security Settings tool and set security settings:**

1. In Lattice Radiant, choose **Tools > Bitstream Security Settings**.

   The Enter Password dialog box opens. Because the project does not yet contain a .key file, the dialog box shows LATTICESEMI as the default password.

2. To change the password, click **Change Password** to open the Change Password dialog box.

3. In the Enter Password field, type in a password of at least eight but no more than sixteen characters.

4. Type the password again in the Verify Password field and click OK.

   The Security Settings dialog box opens.

5. To set up AES key, check the **AES Encryption** option in the Security Settings dialog box.

6. Select a key format from the Key Format drop-down list, Load from file, or Auto Generated Key.
Select a key from the Key Format drop-down list, and then type a key in the text boxes as follows, depending on the format selected:

- For the default ASCII format, type alphanumeric values using up to 32 characters.
- For hex format, type values of 0 through F, using up to 64 characters.
- For binary format, type 0 and 1 values, using up to 256 characters.

Select a key from Load from File.

- The Load Key from File dialog box opens, select the key file and click Open.

Select a key by clicking on Auto Generated Key button.

- The tool generates a random 256-bit AES key in hex format.

To set up HMAC key, check the **HMAC Authentication** option in the Security Settings dialog box.

Select a key format from the Key Format drop-down list, Load from file, or Auto Generated Key.

Select a key from the Key Format drop-down list, and then type a key in the text boxes as follows, depending on the format selected:

- For the default ASCII format, type alphanumeric values using up to 32 characters.
- For hex format, type values of 0 through F, using up to 64 characters.
- For binary format, type 0 and 1 values, using up to 256 characters.

Select a key from Load from File.

- The Load Key from File dialog box opens, select the key file and click Open.

Select a key by clicking on Auto Generated Key button.

- The tool generates a random 256-bit HMAC key in hex format.

Click **OK** to apply the settings.

A Security Setting message informs you that the encrypted files have been produced.

Click **OK** to close the Security Setting dialog box.

**NOTE**

You will see ‘AES must be enabled to make HMAC authentication work.’ message if you did not enabled the AES Encryption.

**ECDSA Authentication**

The Elliptical Curve Digital Signature Algorithm (ECDSA) offers a variant of the Digital Signature Algorithm (DSA), which uses the elliptical curve cryptography. The Authentication Private key (or Signature) and Public key are used to encrypt/decrypt the bitstream with ECDSA. The Public key size is 512-bits, the Private key size is 256 bits.
The ECDSA Authentication key pair (Private key and Public key) are verified. Alternatively, the Signature with the Public key can be verified given that you provide SHA-256 Signature and Public key pair. The Signature size is 64 Bytes.

An optional feature allows to verify the SHA-256 Signature against the SHA-256 Digest.

**IMPORTANT**

The SHA-256 digest is used to verify Signature and Public key and is not saved to Security project file.

**To run the Bitstream Security Settings tool and set security settings:**

1. In Lattice Radiant, choose **Tools > Bitstream Security Settings**.
   - The Enter Password dialog box opens. Because the project does not yet contain a .key file, the dialog box shows LATTICESEMI as the default password.

2. To change the password, click **Change Password** to open the Change Password dialog box.

3. In the Enter Password field, type in a password of at least eight but no more than sixteen characters.

4. Type the password again in the Verify Password field and click **OK**.
   - The Security Settings dialog box opens.

5. To set up the key pair, check the **ECDSA Authentication** option in the Security Settings dialog box.
   
   - Check the **Public key and private key** option. Public key and Private key dialog boxes are enabled. Select a key format from the Key Format drop-down list, Load from file, or Auto Generated Key Pair.
   
   - Select keys from the Key Format drop-down list, and then type a key in the text boxes as follows, depending on the format selected:
     
     - For the default ASCII format, type alphanumeric values using up to 32 characters for Private Key and 64 characters for Public Key.
     
     - For hex format, type values of 0 through F, using up to 64 characters for Private Key and 128 characters for Public Key.
     
     - For binary format, type 0 and 1 values, using up to 256 characters for Private Key and 512 characters for Public Key.
   
   - Select Public key and Private key from Load from File.
     
     - The Load Key from File dialog box opens, select the Public key file and click Open.
     
     - The Load Key from File dialog box opens, select the Private key file and click Open.
   
   - Select Public key and Private key by clicking on Auto Generated Key Pair button.
The tool generates random 512-bit Public and 256-bit Private key pair in hex format.

b. Check the **Public key and SHA-256 signature** option. Public key and SHA-256 signature dialog boxes are enabled. Both, Public key and Signature, has size of 512 bits. Select a key format from the Key Format drop-down list or Load from file.

- Select key and signature from the Key Format drop-down list, and then type a key in the text boxes as follows, depending on the format selected:
  - For the default ASCII format, type alphanumeric values using up to 64 characters for Public Key and Signature.
  - For hex format, type values of 0 through F, using up to 128 characters for Public Key and Signature.
  - For binary format, type 0 and 1 values, using up to 512 characters for Public Key and Signature.
- Select Public key and signature from Load from File.
  - The Load Key from File dialog box opens, select the Public key file and click Open.
  - The Load Key from File dialog box opens, select the Private key file and click Open.
- (Optional) Type in the SHA-256 digest. The digest size is 256 bits. Check **Verify** to verify the SHA256 signature against the SHA-256 digest; otherwise, Public key and Signature will be saved, but not verified as a valid pair.

6. Click **OK** to apply the settings.

   If the key pair cannot be verified, the output encrypted files are not generated.

7. Click **OK** to close the Security Setting dialog box.

**ECDSA Authentication with AES encryption**

A merge of AES encryption/decryption with ECDSA authentication allows for additional level of bitstream obfuscation. First, the private/public key pair is used to encrypt/decrypt the bitstream with ECDSA. Second, the bitstream is encrypted/decrypted with the AES-256 key.

To generate/verify appropriate keys, follow sections “AES Encryption” on page 146 and “ECDSA Authentication” on page 148.

**See Also**

- “Secure Objects in the Design” on page 133
- “Securing the Bitstream” on page 144
Simulating the Design

This topic explains how to perform functional and timing simulation by using the Radiant software tools and third-party simulators.

See Also
- “Functional Simulation” on page 152
- “Simulation Environment” on page 152
- “Design Source Files” on page 152
- “Creating a New Simulation Project in the Radiant Software” on page 153
- “Exporting Gate-Level Simulation Files” on page 155
- “Verifying Designs with Timing Simulation” on page 156
- “Third-Party Simulators” on page 157

Simulation in the Radiant Software

The Radiant software provides you with an interface to create a new simulation project file that you can import into a standalone simulator. The Radiant software supports Active-HDL and ModelSim/Questa simulation file for file exports. To create test benches for simulation in the Radiant software, generate all test benches in your third-party tool using an imported simulation project (.spf) file.

See Also
- “Functional Simulation” on page 152
- “Simulation Environment” on page 152
- “Design Source Files” on page 152
- “Creating a New Simulation Project in the Radiant Software” on page 153
- “Exporting Gate-Level Simulation Files” on page 155
Functional Simulation

Functional simulation is the process of verifying that the model of the design matches the functional specification. Functional simulation helps identify logic errors in a design before it is programmed into a device.

To perform functional simulation on designs modeled with Verilog HDL in the Radiant software design flow, perform pre-synthesis functional simulation on your source HDL or netlist using a third party simulator. In the Radiant software, use the subprocesses Gate-Level Simulation File to produce a simulation file for functional simulation of primitive gate-level logic during that stage in the flow.

HDL Simulators The Radiant software and model libraries are qualified with a variety of popular HDL simulators, including Aldec Riviera Pro®, Aldec Active-HDL®, Cadence® NC-Verilog®, Cadence® NC-VHDL®, Cadence® NCSim®, Mentor Graphics® ModelSim/Questa®, Mentor Graphics Questa®, and Synopsys® VCS®.

See Also ▶“Simulation in the Radiant Software” on page 151

Simulation Environment

The Radiant software environment provides library model resources in the Verilog HDL format to support stand-alone simulation with Aldec, Cadence, Mentor Graphics, and Synopsys simulators. Using the simulation wizard inside of the Radiant software, you can create simulation project files that can be exported and brought into standalone simulators.

In addition, you can use the Radiant software's back annotation tools to extract gate-level models and the timing data. This type of simulation is convenient if you want to simulate a design file outside the current project. Stand-alone operation enables you to choose your own settings and preferences.

You can customize the simulation by creating a different script file (.do) that contains commands equivalent to the ModelSim/Questa or Active-HDL graphical user interface (GUI) commands. For information about creating DO (.do) file scripts, see the ModelSim User’s Manual.

See Also ▶“Simulation in the Radiant Software” on page 151

Design Source Files

The third-party simulators enable you to simulate the operation of your design in the following design entry formats:

▶ VHDL format (<design>.vhd) – Describes the circuit in Very High-Speed IC hardware description language (VHDL) format.
▶ Verilog HDL format (<design>.v) – Describes the circuit in Verilog format, which is an industry-standard hardware description language used to
describe the behavior of hardware that can be implemented directly by logic synthesis tools.

- SystemVerilog HDL format (<design>.sv) – Describes the circuit in SystemVerilog format, which includes Verilog and additional extensions to the Verilog language to improve conciseness and productivity.

See Also ➤ “Simulation in the Radiant Software” on page 151

Creating a New Simulation Project in the Radiant Software

This topic describes how to use the Radiant Simulation Wizard to create a simulation project (.spf) file so you can import it into a standalone simulator.

1. In the Radiant software, click Tools > Simulation Wizard or click the icon in the toolbar. The Simulation Wizard opens.

2. In the Preparing the Simulator Interface page click Next.

3. In the Project box, enter the name of your project in the Project Name text box. In the Project Location box browse to the file path location where you want to save your simulation project.

   When you designate a project name in this wizard page, a corresponding folder will be created in the file path you choose. If you add a subdirectory to the default file path the wizard will prompt you to create a new directory. Click Yes in the popup dialog box that appears.

4. In the Simulator box, click either the Active-HDL or ModelSim/Questa Sim simulator check box.

Notes

- If ModelSim/Questa is not installed, it will not be selectable.
- If you change simulation tool, project name will not change. Any previous Simulation Wizard results will be deleted, and a new simulation will be started using new simulation files.

5. In the Process Stage box, choose what type of Process Stage of simulation project you wish to create. Valid types are RTL, Post-Synthesis, Post-Route Gate-Level, and Post-Route Gate-
**Level+Timing.** Only those process stages that are available are activated. Click **Next**.

**Note**

If you want to run a post-synthesis simulation, you must first generate a post-synthesis simulation file (`<file_name>_syn.vo`) as follows:

- In the Radiant Software, click Task Detail View and check **Post-Synthesis Simulation File**.
- In the Process Toolbar, click **Synthesize Design**.

If you want to run a post-route gate-level+timing simulation, you must first generate a post-routed, back-annotated simulation file (`<file_name>_vo.vo`) and a timing constraint file (`<file_name>_vo.sdf`) as follows:

- In the Process Toolbar, click **Export Files**. Ensure that **Gate-Level Simulation File** is selected in the Task Detail View.

6. In the Add and Reorder Source page, select from the source files listed in the Source Files list box or use the browse button to choose a source file not listed.

- By default, the **Automatically Set Simulation Compilation File Order** option is checked.

7. Click **Next**. If the **Automatically Set Simulation Compilation File Order** option was checked in the previous step, you'll need to specify a top level simulation test bench in the **Simulation Top Module** box in the Parse HDL Files for Simulation box.

8. Click **Next**. A Summary page appears that provides information on the project selections, including the simulation libraries. By default the **Run simulator**, **Add top-level signals to waveform display**, and **Run simulation** check boxes are enabled. Their functionality is as follows:

   - The **Run simulator** option launches the simulation tool you chose earlier in the wizard.
   - The **Add top-level signals to waveform display** option can only be selected if the **Run simulator** box is checked. This option adds top-level signals to the waveform in the simulation tool.
   - The **Run simulation** option can only be selected if the **Add top-level signals to waveform display** option is checked. This option causes your simulation tool to run the simulation automatically.

**Note**

Simulation Wizard generation of .ado/.mdo are generated as pure tcl scripts. If you wish to rerun .ado file in Active HDL standalone mode, you will have to issue the command `do -tcl ***.do`.

9. Click **Finish**. After the simulation is complete, the Simulation Wizard Project (.spf) file and a simulation script DO file are generated and the simulation is displayed. If you are using Active-HDL, the wizard will generate an .ado file and if you are using ModelSim/Questa, it creates an .mdo file as well.
Specifying IP Instance Path in Third-Party Simulation Script

If a Radiant project has a generated IP instance, the IP instance directory should be added to search path of simulation script.

The following steps describe how to modify simulation script for Aldec Active HDL and Mentor Graphics ModelSim/QuestaSim tools.

Active HDL  
Active-HDL uses predefined variables "readmempath" which specifies an additional directory search order for the $readmemb and $readmemh tasks if data files or memory files in your design that are not stored in the default design working directories (i.e. $dsn'src or $dsn).

This allows the simulator to properly recognize and find required data/memory files specified in a user-defined Verilog source code without a path (relative or absolute). Specification of multiple directory paths and the use of the environment variables are allowed. If there are several locations specified, they need to be separated with the semicolon character. In this case or when a path contains white spaces, the entire path specification should be enclosed in quotation marks (" "). By default, this variable is not set.

ModelSim/QuestaSim

ModelSim/QuestaSim uses the "mem load" command which updates the simulation memory contents of a specified instance. You can upload contents either from a memory data file, a memory pattern, or both. If both are specified, the pattern is applied only to memory locations not contained in the file.

Example:

Load the memory pattern from the file vals.mem to the memory instance /top/m/mem, filling the rest of the memory with the fixed-value 1'b0.

mem load -infile vals.mem -format bin -filltype value -filldata 1'b0 /top/m/mem

Exporting Gate-Level Simulation Files

In the Radiant software, you can export gate-level project simulation source files into your third-party vendor simulation tool for timing simulation.

To export a Gate-Level simulation files in the Radiant software:

1. From the Quick Run Toolbar, click Task Detail View and select the Gate-Level Simulation File subprocess under Export Files.
2. Double click **Export Files** to run the export feature. This will generate a back-annotated version of your design file in a Verilog netlist (.vo) simulation file and an SDF timing file.

**Note:**
You can also use Tcl Radiant commands in the Tcl Console to accomplish this task, as shown below:

```
prj_run Export -task TimingSimFileVlg
```

**See Also**  ►“Simulation in the Radiant Software” on page 151

### Timing Simulation

The Radiant software supports two types of timing verification:

- Dynamic timing simulation
- Static timing analysis

See the Static Timing Analysis topic and related information for more information on that type of design verification.

To facilitate timing simulation, the Radiant software allows you to export simulation files that you can import into a simulator for design verification using dynamic timing simulation. In the Process view under **Export Files** use **Gate-Level Simulation File** to export a simulation project file to a standalone Aldec Active-HDL® or Mentor Graphics® ModelSim/Questa® hardware design language (HDL) simulator. Some simulators allow a combination of both languages to be simulated concurrently. This scenario is common when mixing IP cores.

**See Also**  ►“Verifying Designs with Timing Simulation” on page 156

### Verifying Designs with Timing Simulation

Timing simulation is based on an event-driven simulator and requires you to specify a test vector (waveform). Where timing analysis returns partial timing information, dynamic timing simulation (timing simulation) gives you detailed information about gate delays and worst-case circuit conditions. Because the total delay of a complete circuit depends on the number of gates the signal sees and on the way the gates have been placed in the device, you can only perform timing simulation after you have implemented the design. Timing simulation also requires several input files to run.

The Radiant software simulation files can be imported into HDL simulators (e.g., Aldec’s Active-HDL or Mentor Graphics’ ModelSim/Questa) for dynamic timing simulation. You can simulate FPGA devices by using any popular third-party HDL simulator. Dynamic simulation analyzers have considerably longer
run times than a static timing analysis tool like the Radiant software TRACE program.

**Note**

You cannot generate text fixtures in the Radiant software. All simulation must be done outside of the Radiant software using simulation files in a supported simulator. For guidelines using third-party EDA simulators with Radiant software, see your vendor documentation or the following references.

**See Also**  ►“Timing Simulation” on page 156

---

## Third-Party Simulators

This section explains how to use Aldec Active-HDL, Aldec Riviera Pro, Cadence NC-Verilog, Cadence NC-VHDL, Cadence NCSim, Mentor Graphics ModelSim/Questa, and Synopsys VCS software to simulate designs that target Lattice Semiconductor FPGAs. It shows you how to use these simulators to perform functional register-transfer-level (RTL) simulation and place-and-route gate-level simulation with and without timing simulation.

**Note**

Lattice Semiconductor does not supply the Synopsys VCS, Cadence NC-Verilog, Cadence NC-VHDL, Cadence NCSim, Aldec Riviera Pro, or Mentor Graphics ModelSim/Questa simulators. You must obtain them independently.

**See Also**  ►“Simulation Library Files” on page 157

► “Performing Simulation with Aldec Riviera Pro” on page 158

► “Performing Simulation with Aldec Active-HDL” on page 160

► “Performing Simulation with Mentor Graphics ModelSim/Questa” on page 162

---

## Simulation Library Files

This section describes where to find the source simulation library files for FPGA device families.

There are pre-compiled library files available for ModelSim/Questa located at: *(install_folder)/modeltech/lib.*

Verilog library source files are also installed in the cae_library directory.
**Verilog Source Library Files**  The Verilog functional and behavioral simulation library files are installed with the Radiant software in the locations shown in Table 11.

<table>
<thead>
<tr>
<th>FPGA Family</th>
<th>Library Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>iCE40UP</td>
<td>&lt;install_dir&gt;/cae_library/simulation/verilog/iCE40UP</td>
</tr>
<tr>
<td>LIFCL</td>
<td>&lt;install_dir&gt;/cae_library/simulation/verilog/lifcl</td>
</tr>
<tr>
<td>LFD2NX</td>
<td>&lt;install_dir&gt;/cae_library/simulation/verilog/lfd2nx</td>
</tr>
</tbody>
</table>

**Compiled Verilog Libraries for Aldec Active-HDL**  Refer to Table 12, which shows the location of the compiled Verilog simulation libraries for Aldec Active-HDL.

<table>
<thead>
<tr>
<th>Library Name</th>
<th>Directory Tree</th>
<th>Files</th>
<th>Devices</th>
</tr>
</thead>
<tbody>
<tr>
<td>iCE40UP</td>
<td>&lt;install_dir&gt;/active-hdl/vlib/iCE40UP/src</td>
<td>*.vhd</td>
<td>iCE40UP</td>
</tr>
<tr>
<td>ovi_iCE40UP</td>
<td>&lt;install_dir&gt;/active-hdl/vlib/ovi_iCE40UP/src</td>
<td>*.v</td>
<td>iCE40UP</td>
</tr>
<tr>
<td>ovi_iCE40UP_timing</td>
<td>&lt;install_dir&gt;/active-hdl/vlib/ovi_iCE40UP_timing/src</td>
<td>*.v</td>
<td>iCE40UP</td>
</tr>
<tr>
<td>LIFCL</td>
<td>&lt;install_dir&gt;/active-hdl/vlib/lifcl/src</td>
<td>*.vhd</td>
<td>LIFCL</td>
</tr>
<tr>
<td>ovi_LIFCL</td>
<td>&lt;install_dir&gt;/active-hdl/vlib/ovi_lifcl/src</td>
<td>*.v</td>
<td>LIFCL</td>
</tr>
<tr>
<td>ovi_LIFCL_timing</td>
<td>&lt;install_dir&gt;/active-hdl/vlib/ovi_lifcl_timing/src</td>
<td>*.v</td>
<td>LIFCL</td>
</tr>
</tbody>
</table>

See Also  “Third-Party Simulators” on page 157

**Performing Simulation with Aldec Riviera Pro**

This section explains how to perform simulation with the Aldec Riviera Pro simulator.

**Creating or Updating Lattice Semiconductor's FPGA Vendor Libraries**

Create VHDL or Verilog libraries by following the procedures in this section.

**Creating VHDL Libraries**  If you do not have Lattice Semiconductor's FPGA VHDL libraries as pre-compiled vendor libraries, the following steps are required to create them:

1. Create Lattice Semiconductor's FPGA VHDL libraries:

   ```
   # create new VHDL libraries
   alib <device>
   ```
2. For each of the above VHDL libraries compile the source files by using the acom command:

```bash
acom -work <library_name> -reorder <vhdl_synth_src_folder>/ *.vhd
```

where:

▶ `<vhdl_synth_src_folder>` is the folder containing VHDL synthesis headers for the appropriate Lattice Semiconductor device. For example:

C:\lscc\radiant\<version_number>\cae_library\synthesis\vhdl

3. Set the status of the newly created library as read-only to prevent accidental overwriting:

```bash
setlibrarymode -ro <library_name>
```

**Creating Verilog Libraries**

If you do not have Lattice Semiconductor's FPGA Verilog libraries as pre-compiled vendor libraries, the following steps are required to create them:

1. Create Lattice Semiconductor's FPGA Verilog libraries:

```bash
# create new Verilog libraries
alib ovi_<device>
```

**Note**

The Verilog library names are not strict, but they conform to Aldec's naming convention for Verilog vendor libraries.

2. For each of the above Verilog libraries, compile the source files by using the alog command:

The Verilog source files are located at:

C:\lscc\radiant\<version_number>\cae_library\simulation\verilog\`

If you want to place the debugging information in the library, use the --dbg switch. Debugging may slow down simulation.

**Note**

Ignore the warning messages.

3. Set the status of the newly created library as read-only to prevent accidental overwriting:

```bash
setlibrarymode -ro <library_name>
```

**Updating Lattice Semiconductor's Vendor Libraries**

If you obtained the updated source code of Lattice Semiconductor's FPGA libraries, you can update the VHDL libraries, Verilog libraries, or both by using the following procedure (for each one of the VHDL or Verilog libraries):
1. Using the cd command, navigate to the directory where your vendor library resides. The vendor libraries are usually located in the <install_dir>/vlib folder when pre-compiled by Aldec.

2. Set the library mode to read-write by using the setlibrarymode command:

   setlibrarymode -rw <library_name>

3. Compile the source code into the library. Use the acom command for VHDL source files and the alog command for Verilog source files.

4. Set the library to the read-only mode to prevent accidental overwriting:

   setlibrarymode -ro <library_name>

**Note**

You can enter the commands either in command-line mode or in the graphical console. Alternatively, you can write a macro that will prepare and compile the libraries, as follows:

1. Include in the macro the appropriate commands for the libraries that you want to create or update.

2. Run the runvsimsa script (Linux) or the runvsimsa.bat batch file (Windows) command with the macro as a command-line argument.

---

**Performing Verilog Simulation**  Use the procedures described in this section to perform a Verilog simulation.

**Functional RTL Simulation**  Use the following commands to perform a functional RTL simulation with one of the libraries shown in Table 11:

   alic work
   alog -v2k -work work <design_name>.v <test_bench>.v
   asim work.<test_bench>

**Note**

If you have a pre-existing work library, you can clear its contents by using the following command:

   adel -lib work -all

**See Also**  “Third-Party Simulators” on page 157

---

**Performing Simulation with Aldec Active-HDL**

You can use the same procedure as in “Performing Simulation with Aldec Riviera Pro” on page 158 for creating or updating Lattice Semiconductor’s FPGA (vendor) libraries and simulating Verilog or VHDL designs in Active-HDL.

**Running Aldec Active-HDL in Stand-Alone Mode**  If you are running Active-HDL in stand-alone mode—that is, you are not accessing it through the Radiant software graphical user interface—you should do the following to
avoid elaboration (ELBREAD) errors when selecting top-level unit or compiling files from the design pop-up menu:

1. From the top-level menu, select **Design > Settings**.
2. Under Category in the left pane of the Design Settings dialog box, select **General > Compilation > Verilog**.
3. In the right (Verilog) pane under Verilog libraries, click the **Add Library** button.
4. Select the reference Verilog libraries that are needed in your design. You can select multiple libraries by holding the CTRL key.
5. Click **OK**.
6. Click **OK** in the Design Settings dialog box.

This design setting also adds the `-l <verilog_library_name>` option to the vlog command, which then recognizes (or allows you to set) the top-level unit.

After setting the top-level unit (or testbench), you can start the simulation by clicking **Simulation > Initialize Simulation** from the top-level menu.

**Note**

If you are compiling and simulating your design by using a .do file, the steps just given are not needed. Instead, you should add `-l` with vlog, add `-L` with vsim, or both in your .do file.

If you are running Active-HDL in stand-alone mode and you are using at least one of the ASIC blocks, such as PCS or SYSBUS in your design, you must do the following:

1. Change the directory to the design folder where the PCS or SYSBUS configuration file resides:
   ```
   cd <design_folder>
   ```
2. Set the simulation directory to the design (current) folder:
   ```
   set SIM_WORKING_FOLDER .
   ```

Setting the `SIM_WORKING_FOLDER` option forces the Active-HDL simulator to look for the configuration or input files in the design folder (by default Active-HDL looks for input files in the `<work>` and `<work>/src` folders only, where `<work>` is the Active-HDL working library folder). If you do not set this option, the simulation will fail and Active-HDL will issue an error about a missing configuration file.

This option is also necessary if your simulation is expecting any input files in the design folder rather than in the `<work>` or `<work>/src` folders, unless you place the input file path in your HDL code.

**See Also** “Third-Party Simulators” on page 157
Performing Simulation with Mentor Graphics ModelSim/Questa

This section explains how to perform simulation with the Mentor Graphics ModelSim/Questa simulator.

Setting Lattice Semiconductor Libraries  Before simulating Lattice Semiconductor FPGA designs in the Mentor Graphics ModelSim/Questa simulator, you must compile the Lattice Semiconductor simulation libraries including device and PMI libraries.

▶ For details on how to run cmpl_libs.tcl, refer to "Running cmpl_libs.tcl from the Command Line" on page 912.

▶ For details on PMI simulation library compilation, refer to "Requirements for Simulation and Synthesis with PMI" on page 124.

To enable the Radiant software’s batch interface to ModelSim/Questa, change the default simulation tool setup and directory reference as follows:

1. Choose Tools > Options.
2. Click on the Directories tab.
3. Change the path setting to the ModelSim/Questa executable on the tab to the new version.
4. Click OK.

Mapping to ModelSim/Questa Libraries  The library compilation target folder should also be your simulation working directory. Otherwise, you need to copy the library mappings into your local or master ModelSim/Questa.ini.

Example for library mapping (using LIFCL device as an example):

1. Open your local or master ModelSim/Questa.ini.
2. Go to [Library] section
3. Add 'LIFCL = D:/radiant_lib/lifcl'
4. Add 'pmi_work = D:/radiant_lib/pmi_work

Performing Verilog Simulation  Use the procedures described in this section to perform a Verilog standalone simulation with ModelSim/Questa.

Functional RTL Simulation  Use the following commands to perform a functional RTL simulation with one of the libraries shown in Table 11:

vlib work
vlog -work work <design_name>.v <test_bench>.v
vsim work.<test_bench>

**Note**

If you have a pre-existing work library, you can clear its contents by using the following command:

```
vdel -lib work -all
```

**See Also**  “Third-Party Simulators” on page 157
Applying Design Constraints

Constraints are instructions applied to design elements that guide the design toward desired results and performance goals. They are critical to achieving timing closure or managing reusable intellectual property (IP). The most common constraints are those for timing and pin assignments, but constraints are also available for placement, routing, and many other functions.

Constraints can include timing or physical constraints defined in Constraint Files (.ldc/.pdc/.sdc/.fdc) or HDL attributes (for physical pin locking) using the Radiant software and third party synthesis tools. Files .ldc/.pdc/.sdc are used for the synthesis tool and specify design goals. Synthesis, map, and place-and-route work to meet these goals. Post-synthesis constraints (.pdc) can also be specified. The flow combines these based on different entry points with the Radiant software design flow. The timing analysis tool reports whether or not the goals were met.

See Also
- “Constraints Reference Guide” on page 545
- “Multiple Entry Constraint Flow” on page 164
- “Integrated Synthesis” on page 253
- “Handling Device Constraints” on page 176

Multiple Entry Constraint Flow

Constraints from multiple sources are used and modified in the Radiant software in multiple ways, including the following timing constraints:
- .ldc (via Lattice Synthesis Engine (LSE))
- .sdc/.fdc (Synopsys Synplify Pro)
- .pdc constraint files
You can set constraints using one or more of the following methods:

- Assigning HDL attributes in the HDL source files. After synthesis and translation, these defined attributes can be viewed and modified in Radiant software views, and the modifications can be saved to the design constraint file.

- Using the LSE, you can assign pre-synthesis constraints using the Timing Constraint Editor and save them to an .ldc constraints file. If you are using Synplify Pro, assign .sdc constraints using the SCOPE editor tool and save them as an.sdc file. Any pre-synthesis constraints that are created by Synplify should be edited in Synplify Pro.

- Assigning physical constraint using a text editor or Radiant software editing views (Device Constraint Editor, and Placement Mode). Post-synthesis timing constraints are assigned via the Post-Synthesis Timing Constraint Editor. Both timing and physical constraints are stored in the .pdc file.

The following figure shows a high-level flow of how constraints from multiple sources can be used and modified in the Radiant software.

**Figure 22:**

---

**Constraint Implementation**

The following steps illustrate how you might assign constraints and implement them at each stage of the design flow, using synthesis constraints and timing analysis.

1. Define the constraints in the pre-synthesis stage using one or both of the following methods:
   - Define constraints as attributes within the HDL.
   - Define timing constraints using Synplify Pro or LSE. Constraints are saved in .ldc file.
2. Synthesize the design.
   When synthesis is performed, the synthesis process synthesizes the design and stores it in a unified database.
   The timing constraints will be displayed in Radiant software Design Constraint Editor View and color-coded as synthesis values.

3. Open one or more of the following views in the Timing Constraint Editor or Device Constraint Editor to define new constraints:
   
   (Pre/post-synthesis) Timing Constraint Editor—Timing constraints, exceptions, delays and synthesis attributes including physical pin locations can be defined in these two tools.

   Device Constraint Editor—Define signaling standards and make pin assignments. Assign clocks to primary or secondary routing resources. Define groups of ports only with current release. Other global settings such as temperature and voltage can be set. Run Constraint design rule checking.

   Placement Mode—View the device layout. Draw bounding boxes for GROUPs. Draw REGIONs for the assignment of groups or to reserve areas. Reserve sites and REGIONs that should be excluded from placement and routing. Run Constraint design rule checking.

4. Save the constraints to the .pdc file.

5. Run the Map Design process (map).
   This process reads all data from the unified design database and processes from there.

6. Run the Place & Route Design process (par).

7. Open one of the following views, as desired, to examine timing and placement.
   

8. Modify constraints or create new ones using any of the design / timing constraint editing views. Save the changes and rerun the Place & Route Design process.

9. Repeat Steps 3 through 8 until design performance objectives are met.

See Also ➤ “Analyzing Static Timing” on page 281

Understanding Implications of Radiant Software Constraint Flows

In order to help understand the Radiant software constraints flow process, Figure 49 below details the entry mechanism for input files and its data flow through the constraints process. The blue boxes indicate design entry mechanism in the form of HDL and synthesized via our internal LSE or third party Synplify Pro synthesis tools. Other yellow boxes also indicate processes run by Radiant software. Green boxes are used to indicate input or output
constraints files or related output report files such as Static Timing Analysis reports out of Map and PAR. Note that Radiant software also generates a post-synthesis timing report just for LSE.

The important process to note is that the Unified Database (.udb) used to store the processed data dictates that certain stages of the constraints need not be re-run in the tool saving processing time. For example, physical constraints on RTL entered as attributes in the HDL, or pre-synthesis constraints entered using the Pre-Synthesis Timing Constraint Editor/Synplify Pro SCOPE (or text editor) including .ldc/.fdc (.sdc converted to .fdc) timing constraints would initially run through synthesis and the data stored is in the .udb file. Subsequent timing and physical constraints entered using tools such as the Post-Synthesis Timing Constraint Editor, Placement Mode or Device Constraint Editor and stored in the .pdc file are processed via the mapping run without the need to re-synthesize the design since the pre-synthesis data resides in the .udb database. As the constraints flow proceeds with each process (i.e. synthesis, Map, PAR) the .udb successively stores a physical netlist, routing and timing constraint.

Transparent to the user, the storage of accumulating data throughout the constraints flow in the .udb and reduction in re-running processes is one reason for the improved speed and efficiency for Radiant software users.

In terms of the necessity of Pre versus post-synthesis timing constraints, usage depends on the complexity and desired performance of the design results. A simple design requiring few timing constraints with a relaxed f_{MAX} may require only pre-synthesis timing constraints and runs through the flow from synthesis to place and route. A complex design requiring a higher f_{MAX} performance may have initial pre-synthesis timing constraints entered for synthesis. Later in the flow, a user may then want to override or fine tune these timing constraints in addition to adding physical constraints to reach the desired performance by driving the place and route process. One example would be a user who initially specifies a higher f_{MAX} to reduce logic levels, then later in the post-synthesis flow lowers the f_{MAX} constraint so that the place and route process is not strained when routing the design.

Figure 23:
Managing Constraints: .ldc/.sdc/.fdc vs .pdc

The pre-synthesis timing constraints .ldc/.sdc/.fdc are passed to the .udb and shown in the Post-Synthesis Timing Constraint Editor as read only. If a user attempts to further re-constrain these constraints, the constraints are saved to the .pdc file.

If two identical constraints exist in the .ldc and .pdc files respectively, the constraint in the .pdc file takes precedence.

Constraints Precedence

Regarding physical / timing constraints, constraints entered via any GUI tool such as Device Constraint Editor or Timing constraint editor will take precedence over the constraints that were entered via a HDL attribute in the RTL or .ldc TCL sdc command.

Constraints entered later in the design flow such as Post-Synthesis Timing Constraint editor (.pdc) will override a constraint entered in the Pre-Synthesis Constraint (.ldc) editor tool.

If there are conflicts in the constraint file such as a ldc_set_location TCL command conflicting with a ldc_prohibit on the same location, then the Radiant software will issue an error message in the design flow.

Timing and Physical Constraints

There are three types of constraints that are supported in Radiant software for constraining your design for maximum performance: Lattice Design Constraints, Post-Synthesis Design Constraints, and Synopsys Design Constraints.

Lattice Design Constraints (.ldc): A combination of both Synopsys Design Constraints (.sdc version 2.0) and the Radiant software’s synthesis attributes. Files have .ldc suffix.

Refer to Constraints Reference Guide > Lattice Synthesis Engine Constraints > Synopsys Design Constraints in the online help for more details.

Post-Synthesis Design Constraints (.pdc): The Radiant software design constraints contain both physical constraints and any post-synthesis timing constraints. These files have .pdc suffix.

Below is a supported list:
- “ldc_create_group” on page 630
Migrating from Former Lattice Diamond Preferences

New to the Radiant software flow are Lattice Design Constraints (.ldc/.pdc). These are a combination of both Synopsys Design Constraints (.sdc version 2.0) and the Radiant software proprietary physical constraints.

All Lattice Diamond constraints were known as Preferences and were defined as .ldc or .pdc files written as .sdc constraints. Lattice Diamond uses a combination of “preferences” and constraints, while Radiant software uses only .ldc constraints. All Lattice Diamond preferences have been converted to constraints in the Radiant software.
The use of .sdc constraints involve some object access commands as indicated below:

- `get_cells`
- `get_pins`
- `get_nets`
- `get_ports`
- `all_inputs`
- `all_outputs`
- `get_clocks`
- `all_clocks`

Figure 13 shows the most commonly used Lattice Diamond preferences for applying physical constraints and how to apply them with the new Radiant software.sdc commands. Listed in alphabetical order, examples are also shown on how to convert Lattice Diamond preferences to a Radiant software .ldc constraint.

<table>
<thead>
<tr>
<th>Lattice Diamond Preference Usage</th>
<th>Radiant Software .ldc Constraint Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>BANK 1 VCCIO 3.3 V</td>
<td><code>ldc_set_vcc -bank 1 3.3</code></td>
</tr>
<tr>
<td>BLOCK PATH FROM PORT “LOCAL_CMD0” TO PORT “RAM_RD”</td>
<td><code>set_false_path -from [get_ports LOCAL_CMD0] -to [get_ports RAM_RD]</code></td>
</tr>
<tr>
<td>CLOCK TO OUT ALLPORTS OUTPUT_DELAY 10ns CLKPORT CKIN1;</td>
<td><code>set_output_delay 10 -clock [get_clocks CKIN1] [get_ports all_outputs]</code></td>
</tr>
<tr>
<td>DEFINE BUS “busA” NET “pen0” NET “pen1” NET “pen2” NET “pen3” NET “pen4” NET “pen5” NET “pen6” NET “pen7”</td>
<td><code>ldc_create_group -name busA [get_nets pen0 pen1 pen2 pen3 pen4 pen5 pen6 pen7]</code></td>
</tr>
<tr>
<td>DEFINE PORT GROUP “grp1” “a1” “a2” “a3”;</td>
<td><code>ldc_create_group -name grp1 [get_ports a1 a2 a3]</code></td>
</tr>
<tr>
<td>FREQUENCY NET “clk1” 100 Mhz</td>
<td><code>create_clock -period 10 -name clk1 [get_nets clk1]</code></td>
</tr>
<tr>
<td>GROUP “rot_grp” BBOX 8 3 BLKNAME rotate_1;</td>
<td><code>ldc_create_group -name rot_grp -bbox 8 3_cells {rotate_1}</code></td>
</tr>
<tr>
<td>GSR_NET NET “rst_pcie”;</td>
<td><code>ldc_set_attribute {GSR_NET = TRUE} [get_nets rst_pcie]</code></td>
</tr>
<tr>
<td>INPUT_SETUP PORT “in1” INPUT_DELAY 2 ns CLKPORT “clk”;</td>
<td><code>set_input_delay 2 -clock [get_clocks clk] [get_ports in1]</code></td>
</tr>
<tr>
<td>IOBUF PORT bchk IO_TYPE=LVCMOS33;</td>
<td><code>ldc_set_port -iobuf {IO_TYPE=LVCMOS33} [get_ports bchk]</code></td>
</tr>
<tr>
<td>LOCATE COMP “A” SITE “11”;</td>
<td><code>ldc_set_location -site 11 [get_ports A]</code></td>
</tr>
<tr>
<td>LOCATE GROUP “GROUP_0” SITE “R2C2D”;</td>
<td><code>ldc_set_location -site R2C2D [ldc_get_groups GROUP_0]</code></td>
</tr>
<tr>
<td>LOCATE GROUP “xyz_GROUP” REGION “my_region”</td>
<td><code>ldc_set_location -region my_region [ldc_get_groups GROUP_0]</code></td>
</tr>
</tbody>
</table>
Migrating Pin Assignments

The Radiant software provides pin compatibility information that helps you migrate pin assignments to a different device of the same family and package as the currently targeted device. This information enables you to save your current pinout while you explore other devices. It shows you which pins in your current device will be unavailable or have different functions when you switch devices, and it allows you to export the pin migration information to a pin layout file.

You use the Incompatible Pins tab of the Device Constraint Editor to select one or more devices that are of the same family and package as your current device. Afterwards, you can view all incompatible pins in Spreadsheet View and Package View. The rows for incompatible pins are dimmed on the Pin
Assignments sheet of Spreadsheet View. In Package View, a dark gray circle appears behind each incompatible pin square.

Pin compatibility information is available for LIFCL only.

**See Also**
- “Selecting a Device for Possible Pin Migration” on page 172
- “Viewing Incompatible Pins” on page 173
- “Prohibiting Incompatible Pins” on page 174

## Selecting a Device for Possible Pin Migration

The Incompatible Pins tab of Device Constraint Editor allows you to select one or more devices for possible pin migration. Afterwards you can view the incompatible pins—those that would not be available or that would have a different function if you were to switch from the current device.

To select one or more devices for pin migration:

1. Open Device Constraint Editor by choosing **Tools > Device Constraint Editor**.

2. Open the Incompatible Pin tab. The Incompatible Pins tab lists all the devices that are of the same device family and package as the current device.

3. Select one or more of the devices from the Compatible Devices list, or select All Devices.

   - If you select one device from the list, the incompatible pins will include those between the current device and the selected device.

   - If you select more than one device or All Devices, the incompatible pins will include those between the current device and the combination of all selected devices.

4. In the Check Areas tab, select the types of incompatibility that you want included for the selected devices: pins whose type, configuration, LVDS/high speed, and bank numbers differ between the current device and the selected devices.

   All of the pins that are incompatible will be displayed in a dim font and with a dark gray circle in the Package View.

5. To unlock any previously assigned pins that would now be incompatible, choose **Design > Disable Incompatible Pin Assignment**.

If you selected the "Disable Incompatible Pin Assignments" option and your design includes pin assignments that are incompatible with the selected devices, a dialog box will warn you that all assignments to incompatible pins will be released. Do one of the following:

- Click Yes to continue.
APPLYING DESIGN CONSTRAINTS: Migrating Pin Assignments

This releases the pin assignments that are now incompatible but retains all other pin assignments. All incompatible pins will be displayed in a dim font and marked as "[Incompatible]" in the "Signal Name" column on the Pin Assignments sheet and with a dark circle in Package View. Names of previously assigned signals whose pins are now incompatible will not be displayed.

There is no Undo for this operation. If the design has already been mapped, it will be initialized back to pre-map status when you save the change.

▲ Click No if you decide that you do not want to release the previously assigned pins.

This maintains all of your current assignments but the incompatible pin assignments will not be disabled.

See Also ▲ “Migrating Pin Assignments” on page 171
▲ “Viewing Incompatible Pins” on page 173
▲ “Prohibiting Incompatible Pins” on page 174
▲ “Exporting Pin Migration Information” on page 175

Viewing Incompatible Pins

An incompatible pin is one that would not be available or would have a different function if you were to switch your design from the current device to a different device. After selecting one or more devices of the same family and package for possible pin migration, you can view the incompatible pins in Spreadsheet View and Package View. In Package View, you can also view the tool tip that explains why a device pin is incompatible.

Note

None of the pin sites that are marked as incompatible can be assigned, if you checked the "Disable Incompatible Pin Assignments". If you need to use any of these sites for your design, you must uncheck the menu or adjust the incompatible device/type selections.

To view incompatible pins in Spreadsheet View:

▲ Select the Pin Assignments sheet and scroll through the list of pins.

The rows for pins that are incompatible are dimmed.

Note

When you use the Assign Ports dialog box from the Port Assignments sheet, all incompatible pins in the dialog box are dimmed.

To view incompatible pins in Package View:

▲ In Package View, maximize the view or choose View > Zoom Fit.
On the Package View layout, each incompatible pin is displayed with a dark gray circle behind the pin square.

- Hold your mouse pointer over an incompatible pin to view the tool tip. The explanation of why the pin is incompatible is listed at the end of the tool tip and will include one of the following:
  - “[TYPE] is not compatible”
  - “[HIGHSPEED] is not compatible”
  - “[CFG] is not compatible”
  - “[Bank Number] is not compatible”

See Also
- “Migrating Pin Assignments” on page 171
- “Selecting a Device for Possible Pin Migration” on page 172
- “Prohibiting Incompatible Pins” on page 174
- “Exporting Pin Migration Information” on page 175

Prohibiting Incompatible Pins

Package View enables you to create a PROHIBIT preference for selected incompatible pins or all incompatible pins. Prohibiting incompatible pins will prevent you from assigning signals to them. It will also prevent the Map and Place & Route processes from using these incompatible pins. When you prohibit incompatible pins, none of the pins that have already been assigned will become unlocked.

To prohibit all incompatible pins:
1. In the Incompatible Pins tab, select the devices for possible pin migration.
2. Click Design > Prohibit Incompatible Pins.
   - On the Pin Assignments sheet of Spreadsheet View, “Prohibit” appears in the signal name column for all prohibited incompatible pins.
   - In Package View, all prohibited incompatible pins are highlighted in dark blue.

To release all prohibited incompatible pins:
- Click Design > Release Incompatible Pins.

To prohibit one or several incompatible pins:
- In Package View, select the incompatible pins that you want to prohibit. Right-click, and choose Prohibit.

To release one or several incompatible pins:
- On the Pin Assignment sheet of Spreadsheet View or in Package View, select the prohibited pins that you want to release. Right-click and choose Release.
See Also

- "Migrating Pin Assignments" on page 171
- “Selecting a Device for Possible Pin Migration” on page 172
- “Viewing Incompatible Pins” on page 173
- “Exporting Pin Migration Information” on page 175

Exporting Pin Migration Information

The Radiant software allows you to include pin migration information in an exported pin layout file of your design. The exported pin layout file uses a delimiter-separator format, such as comma-separator value (.csv), which allows you to view the report in an external spreadsheet application. In addition to pin migration information, the pin layout file provides a report of available device pins, pin assignments, and IOBUF attributes. You can include pin migration information in the report by selecting the options in the Incompatible Pins tab, then selecting Pin Migration in the Export Pin Layout File dialog box.

See Also

- “Exporting a Pin Layout File” on page 245

Using Radiant Software Pre-Synthesis Constraints

Enter constraints in the synthesis design constraints .sdc file using one of the following two synthesis tools:

- Pre/post-synthesis Timing Constraint Editor (TCE)  
  For more information about entering constraints with TCE, refer to “Handling Device Constraints” on page 176.
- Synplify Pro SCOPE Constraints Editor  
  For more information about entering constraints with Synplify Pro SCOPE Constraints Editor, refer to “SCOPE Constraints Editor” help in the Synplify Pro online help.

The following Synopsis Design Constraints can be set in the .sdc:

- "create_clock" on page 568
- "create_generated_clock" on page 570
- "set_clock_groups" on page 571
- "set_false_path" on page 574
- "set_input_delay" on page 574
- "set_load" on page 576
- "set_min_delay" on page 577
- "set_multicycle_path" on page 578
- "set_output_delay" on page 579
- "set_clock_uncertainty" on page 573
Applying Design Constraints

Handling Device Constraints

Here are some general tips for when applying device IP constraints or any primitives that generates or modifies clocking frequencies (i.e. PLL, I2C, SPI etc.). Note this does not include IP primitives from the .GBB timing files.

1. The precedence of device IP constraints supersedes user constraints.
2. User constraints will override device IP constraints.
3. TCL commands for all_xxx and get_xxx with wild-cards are only allowed on top level designs. When an IP is being processed as a top level design, it could contain these commands.
4. If the IPs are using all_xxx and get_xxx with wild cards, the commands have to be converted to get_xxx with a list when the final SDC of the IP is written out for consumption into the top level design.
5. Any device constraints in the IP will be converted to user constraints.
6. The device constraints will be placed before the user constraints in the .SDC file.

Applying Lattice Pre-Synthesis Timing Constraints

Radiant software LSE enables you to set pre-synthesis Synopsys® Design (formatted) Constraints, which are directly interpreted by the synthesis engine. When you use LSE, these .sdc constraints are saved to a Lattice Design Constraints file (.ldc). You can create several .ldc files and select one of them to serve as the active synthesis constraint file for an implementation.

The Source Editor and the Timing Constraint Editor are available for creating and editing .ldc files. Timing Constraint Editor provides a spreadsheet style user interface that enables you to quickly create and edit Synopsys Design Constraints.
Timing Constraint Editor runs a design rule check (DRC) to verify that the constraints you enter are legitimate. These checks are done in real time as you enter them in the GUI.

See “Synopsys Design Constraints” on page 563 for descriptions of the .sdc constraints that are supported by the LSE and Timing Constraint Editor.

See Also → “Creating a New .ldc Synthesis Constraint File” on page 177
  → “Integrated Synthesis” on page 253
  → “Optimizing LSE for Area and Timing” on page 251

Creating a New .ldc Synthesis Constraint File

Before you create a new .ldc file, verify that LSE has been selected as the synthesis tool. In the Processes tab, “Lattice Synthesis Engine” should be listed under “Synthesize Design.” If it is not listed, choose Project > Active Implementation > Select Synthesis Tool, and select Lattice LSE.

To make sure that the .ldc file opens in Timing Constraint Editor instead of Source Editor, verify that Timing Constraint Editor has been selected as the default program in Tool > Options > General > File Associations.

To create a new .ldc synthesis constraint file:

   Alternatively, right-click the Timing Constraint Files folder and choose Add > New File.

2. In the New File dialog box, select Source Files from the Categories list. Select Pre-Synthesis Constraint Files from the Source Files list.

3. Type a name for the new .ldc file and specify the directory location.

4. Click in the Add to Implementation box if you want to use the file with the currently active implementation.

5. Click New.

   Timing Constraint Editor opens and displays the spreadsheet and three tabs for creating and editing synthesis constraints. If you selected the Add to Implementation option, the new .ldc file will appear in the Timing Constraint Files folder.

   Pulldown menus for source elements are provided when you double-click the Clock Source cells or the Inputs/Outputs Ports cells.

6. Enter or edit values for clocks, inputs and outputs, and delay paths:
   a. Double-click a cell and type a new value, or select a value from the pulldown list.
   b. Use the arrow keys or the Tab key to move to another cell and select it for editing.
c. New rows are inserted automatically. You can delete existing rows with data entered by right clicking and selecting Remove Row from the pop-up menu.

7. Choose File > Save.

See Also
- “Defining Clocks Using Timing Constraint Editor” on page 211
- “Setting Input and Output Delays Using Timing Constraint Editor” on page 212
- “Defining Timing Exceptions Using Timing Constraint Editor” on page 213
- “Synopsys Design Constraints” on page 563
- “Managing Constraint Files” on page 26
- “Integrated Synthesis” on page 253
- “Optimizing LSE for Area and Timing” on page 251

Using Source Editor for .ldc Files

Any .ldc file that you have created using the Timing Constraint Editor can be viewed and edited in Source Editor. Likewise, an .ldc file that you have created in Source Editor can be viewed and edited in the Timing Constraint Editor.

One advantage of using Source Editor is that it allows you to open multiple .ldc files at once, whereas Timing Constraint Editor will load only one .ldc file at a time.

To open an .ldc file in Source Editor:
1. In the File List view, expand the Timing Constraints Folder.
2. Right-click the name of the .ldc file you want to open and choose Open With.
3. In the dialog box, select Source Editor and click OK.

   The .ldc file opens in Source Editor window as an ASCII file.

See Also
- “Changing the Default Editor for .ldc Files” on page 178

Changing the Default Editor for .ldc Files

The Radiant software gives you the option of setting Source Editor or Timing Constraint Editor as the default program for .ldc files.

To change the default editor for .ldc files:
1. Choose Tools > Options.
2. In the General section of the Options dialog box, select File Associations.
3. In the Extensions column of File Associations, scroll down to ldc and/or ldc<active>.

4. In the Default Programs column, choose Source Editor from the pulldown menu. The ldc option also allows for Add Program, an option to open with your choice of text editors.

The next time you create or select an .ldc file, it will open in the editor you selected as the default.

See Also  ►"Managing Constraint Files" on page 26

Optimizing for Timing
The pre-synthesis constraints that you set in the .ldc file will drive optimization of the design if you set the optimization goal for timing in the active strategy file.

To set the optimization goal for timing:
1. From the File List view, expand the Strategies folder and double-click the name of the active strategy.


3. In the LSE pane on the right, scroll down to Optimization Goal and select Timing in the Value column.

4. Click OK.

See Also  ►"Synopsys Design Constraints" on page 563
► "Optimizing LSE for Area and Timing" on page 251

Adding an .ldc File to an Implementation
You can add multiple .ldc files to an implementation and view each of them in Timing Constraint Editor.

To add an existing .ldc file to an implementation:
1. In the File List view, right-click the Timing Constraints Files folder and choose Add > Existing File.

2. Browse to the directory that contains the desired .ldc file, select the file, and click Add.

The file is added to the implementation and is displayed in the Timing Constraint Files folder list.

See Also  ►"Managing Constraint Files" on page 26
Activating an .ldc File
To apply the synthesis constraints, you need to identify an .ldc file as the active one for the implementation.

To activate an .ldc file for an implementation:
- Right-click the file name and choose Set as Active .ldc.

By default, the active .ldc file is compiled when you synthesize the design.

See Also ➤ "Managing Constraint Files" on page 26

Constraint Propagation
Users will usually define constraints for their top level design as well as include many other constraints files for any custom included IP or IPs that are generated via Radiant tools such as IP Catalog. Constraints defined at the module IP level may not contain the correct hierarchical names and hence will not be applied correctly when synthesized. To help the user be able to honor as much of their supplied constraints as possible, a constraint propagation engine will run a DRC on all the input constraints and write out a new constraint file to support hierarchical constraints, such as soft IP constraints and be honored in the top-module as to enable optimization across IP boundaries during logic synthesis.

Constraint Handling for Multiple IPs
The diagram show below will give clear examples of how instantiated IPs in the top level design will uniquify ports/pins/net names as it is referenced from the top level.

IP Modules can be instantiated within other hierarchies. This will typically cause implementation tools such as synthesis to rename the design objects within the IP module with hierarchy information. While renaming of design objects is a valid operation that preserves the design functionality it causes the timing/physical constraints to become invalid since the Name/ID of design objects referred in the constraint no longer matches the Name/ID of design objects in the design. This is how constraint propagation can help resolve the issue.
1. set_max_delay -from IP_A.Inst_3/REG_A -to IP_A.Inst_3/REG_B 5ns
2. set_max_delay -from SUB_A.Inst/IP_A.Inst_2/REG_A -to SUB_B.Inst/ SUB_B.Inst/IP_A.Inst_2/REG_B 5ns
3. set_max_delay -from SUB_A.Inst/SUB_B.Inst/IP_A.Inst_1/REG_A -to SUB_A.Inst/SUB_B.Inst/IP_A.Inst_1/REG_B 5ns

Types of Constraint Resolution

In a typical IP flow design methodology, IP modules can be instantiated more than once at potentially multiple hierarchies and at different hierarchical depths. This can cause scenarios where there is a conflict in timing constraints especially if the timing constraints applies to design objects that cross IP boundaries. Constraints are either:

1. Resolved
   - Constraint preserved as written
   - Propagated and name adjusted

2. Ignored
   - Conflict with another constraint i.e. same electrical connection
   - Constraint may be removed.

After constraint propagation finishes analyzing all the constraints, it outputs two files. A full report file detailing the reasons of each constraint if propagated and preserved or conflicted with another and ignored. The output reports file is generated in the implementations directory and called CPEReport.txt.

If constraint propagation decides that there are any constraints that it needs to replace or edit due to conflicts of hierarchical names, it will out put an intermediary constraint file with the new constraints written in <project name>_ <implementation name>_cpe.ldc. This file will automatically be fed
Applying Design Constraints: Constraint Propagation

into synthesis so that all the correct constraints can be processed correctly and proceed forward in the software design flow. If a user opens the post-synthesis constraint editor, all the processed constraints (i.e. removed or refined) are already reflected in this tool. A user cannot edit annotated pre-synthesis constraints but can add new post-synthesis constraints.

It should also be noted that:

1. Constraints at the IP-level may conflict with the design as a whole rather than a specific constraint, in which the constraint will be removed even if there is no similar constraint at the top level.

For example, set_false_path - from [get_clocks clk1] -to [get_port o] will be removed because it has a clock in it.

2. Constraints that are dropped from the IP-level will now still appear in the output .ldc file, but they will be commented out. This is to allow users to visually understand which constraints were dropped so they can examine them again if needed. The resources on these constraints will be updated top-level constraint names with hierarchy i.e. 'top/ip1/a' rather than just 'a' so they can be copy/pasted and used in the top level if necessary.

From the example above, the output constraint will be: #set_false_path - from [get_clocks clk1] -to [get_port o]. The reasoning for why the constraint was removed will also be as specific as possible for the user in the CPEReport.txt file.

Processed Constraint Types

Constraint Propagation will only process the following constraint types. All other types will be passed through the flow to our other tools.

- create_clock
- create_generated_clock
- set_clock_groups
- set_clock_latency
- set_clock_uncertainty
- set_false_path
- set_input_delay
- set_output_delay
- set_load
- set_min_delay
- set_max_delay
- set_multicycle_path
- ldc_set_port
- ldc_set_location
Timing Constraint Resolution

The diagram depicts a sample design and the example table exhibits the analysis that constraint propagation will perform. Constraint propagation will print out a resolution report (aforementioned) including the source constraint, source module of the constraint, resolution status, resolved constraint and the resolution method as shown in the table.

Table 14: Timing Constraint Resolution Summary

<table>
<thead>
<tr>
<th>Constraint Input</th>
<th>Source Module</th>
<th>Resolution Status</th>
<th>Constraint Output</th>
<th>Resolution Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 create_clock -name {clk_top} -period 5 [get_ports gclk]</td>
<td>Top</td>
<td>Resolved</td>
<td>create_clock -name {clk_top} -period 5</td>
<td>Constraint preserved</td>
</tr>
<tr>
<td>2 create_clock -name {clk_ip_a} -period 10 [get_ports clk]</td>
<td>IP_A</td>
<td>Ignored</td>
<td>Constraint #1</td>
<td>Conflict with Constraint #1</td>
</tr>
<tr>
<td>3 create_clock -name {clk_ip_b} -period 10 [get_ports clkb]</td>
<td>IP_B</td>
<td>Ignored</td>
<td>Defined on IP Input Port</td>
<td>Ignore. Warn user</td>
</tr>
<tr>
<td>4 create_generated_clock -divide_by 2 -source [get_ports clkb] [get_pins b_out]</td>
<td>IP_B</td>
<td>Resolved</td>
<td>create_generated_clock -divide_by 2</td>
<td>Propagated and name adjusted</td>
</tr>
<tr>
<td>5 set_input_delay -clock [get_clock sysclk] #9 [get_ports b_in]</td>
<td>IP_B</td>
<td>Ignored</td>
<td>Removed</td>
<td>IP-Level input delay not propagated</td>
</tr>
</tbody>
</table>
Constraint propagation processes all timing constraints that are entered in the original user constraint file.

**Physical Constraint Resolution**

Constraint propagation will resolve two different physical constraints: "ldc_set_location" on page 631 and "ldc_set_port" on page 632. IP modules that can also have physical constraints such as "LOC" specified. All design objects with "LOC" constraint will be resolved with hierarchical names. LOC constraints now check for conflict with top layer, and will accept IP LOC constraints if it is electrically connected to top level port.

All physical attributes ("HDL Attributes" on page 546) that able to be set by ldc_set_port will also be analyzed and processed accordingly.

### Table 14: Timing Constraint Resolution Summary

<table>
<thead>
<tr>
<th>Constraint Input</th>
<th>Source Module</th>
<th>Resolution Status</th>
<th>Constraint Output</th>
<th>Resolution Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>set_clock_groups</td>
<td>IP_B</td>
<td>Ignored</td>
<td>Removed</td>
<td>At least one clock is not internal</td>
</tr>
<tr>
<td>[get_clocks_clk] -group [get_clocks_clk2]</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

| set_max_delay -from [get_ports b_in] -to [get_ports b_out] 5 | IP_B | Resolved | set_max_delay -from [get_pins IP_B/b_in] -to [get_pins IP_B/b_out] 5 | Max and Min delay always propagated |

### Table 15: Physical Constraint Resolution Summary

<table>
<thead>
<tr>
<th>Constraint Input</th>
<th>Source Module</th>
<th>Resolution Status</th>
<th>Constraint Output</th>
<th>Resolution Method</th>
</tr>
</thead>
</table>

| ldc_set_location -site B1 [get_ports b_in] | IP_B | Ignored | Constraint #1 | Conflict with Constraint #1 |

| Attribute example | IP_B | Resolved | ldc_set_location -site MULT_R9C9 [get_cells IP_B/dsp_a] | Propagated, constraint preserved |

| ldc_set_port -iobuf {IO_TYPE=LVTTL33} [get_ports {top_b[0]}] | Top | Resolved | ldc_set_port -iobuf {IO_TYPE=LVTTL33} [get_ports {top_b[0]}] | Constraint preserved |
## Constraint Resolution Specifics

Timing constraints have different situations and environments which they can be applied in. Sometimes a constraint that is valid on an IP module cannot be accepted even when updated to top-level resources due to restrictions on the constraint. The following restrictions have been placed on timing constraints which Constraint Propagation needs to follow.

- **create_clock**: Two create_clock constraints cannot exist on the same net. No two create_clock constraints can have the same -name setting. All IP-level clocks will have their -name changed to be `<instanceName>_<originalName>`

- **create_generated_clock**: This is the same as create_clock rule above.

- **set_clock_latency / set_clock_uncertainty**: When some or all of the clocks that these constraints have been applied to have been removed due to

---

### Table 15: Physical Constraint Resolution Summary

<table>
<thead>
<tr>
<th>Constraint Input</th>
<th>Source Module</th>
<th>Resolution Status</th>
<th>Constraint Output</th>
<th>Resolution Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>ldc_set_port -iobuf {IO_TYPE=LVDS} [get_ports a_in]</td>
<td>IP_A</td>
<td>Ignored</td>
<td>Constraint #1</td>
<td>Conflict with Constraint #1</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>input [1:0] top_b</td>
<td>Top</td>
<td>Resolved</td>
<td>ldc_set_port -iobuf {IO_TYPE=LVDS} [get_ports {top_b[1]}]</td>
<td>Propagated, conflicting port removed</td>
</tr>
<tr>
<td>/* synthesis IO_TYPE=LVDS */;</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>ldc_set_port -iobuf {IO_TYPE=LVDS PULLMODE=UP} [get_ports b_in]</td>
<td>IP_B</td>
<td>Resolved</td>
<td>ldc_set_port -iobuf {PULLMODE=UP} {get_pins IP_B/b_in}</td>
<td>Propagated, conflicting type removed</td>
</tr>
</tbody>
</table>

Constraint propagation processes all timing constraints that are entered in the original user constraint file.
APPLYING DESIGN CONSTRAINTS: Constraint Propagation

conflicts with top or other IP, to avoid constraining incorrect parts of the design, the constraint will be dropped.

- set_input_delay / set_output_delay: These constraints can only exist when applied to a top-level port. Constraint Propagation will remove all IP-Level set_input/output_delay constrains and warn the user.

Attributes and Constraint Propagation

Constraint propagation will not convert attributes from within RTL to find physical constraints. Constraint propagation will act only on physical constraints present in the input .ldc files. These attributes will be processed by Lattice Synthesis engine and post-synthesis engines instead.

Limitations for Constraint Propagation

1. Parameterized module - constraint propagation flow does not support parameterized constraints at the top level.

Table 16: Constraint Resolution Specific Scenarios

<table>
<thead>
<tr>
<th>Constraint Type (IP Level)</th>
<th>When it is Propagated</th>
<th>When it is Ignored</th>
</tr>
</thead>
<tbody>
<tr>
<td>create_clock</td>
<td>When defined internally to the IP or on an output port.</td>
<td>When defined on IP-level input port or net driven by input port. Warn user to redefine at top-level.</td>
</tr>
<tr>
<td>create_generated_clock</td>
<td>All cases.</td>
<td>N/A</td>
</tr>
<tr>
<td>set_clock_groups</td>
<td>N/A</td>
<td>Always, warning given to user to redefine set_clock_groups at top level.</td>
</tr>
<tr>
<td>set_clock_latency</td>
<td>N/A</td>
<td>Always.</td>
</tr>
<tr>
<td>set_clock_uncertainty</td>
<td>Only when clock referenced is internal to IP.</td>
<td>When clock referenced is removed or if the clock is on input port.</td>
</tr>
<tr>
<td>set_input_delay</td>
<td>N/A</td>
<td>All cases.</td>
</tr>
<tr>
<td>set_output_delay</td>
<td>N/A</td>
<td>All cases.</td>
</tr>
<tr>
<td>set_max_delay</td>
<td>All cases.</td>
<td>N/A</td>
</tr>
<tr>
<td>set_min_delay</td>
<td>All cases.</td>
<td>N/A</td>
</tr>
<tr>
<td>set_false_path</td>
<td>Only when all clocks referenced are IP-level clocks and those clocks are not removed. A warning will always be issued.</td>
<td>When any of the clocks referenced are removed or when only one clock is referenced.</td>
</tr>
<tr>
<td>set_multicycle_path</td>
<td>Only if there are no clocks referenced.</td>
<td>Whenever clocks are referenced.</td>
</tr>
<tr>
<td>set_load</td>
<td>N/A</td>
<td>All cases.</td>
</tr>
</tbody>
</table>
2. Object Name Compatibility between LSE and Synplify - Internal design object names may be different between LSE and Synplify Pro flows. Hence, user constraints at the sub-module level for a synthesis tool cannot be guaranteed. This limitation does not apply to Lattice IP.

Using Radiant Software Tools

The Radiant software provides tools for editing design constraints. These tools, which are available from the Radiant software toolbar and Tools menu, include the following:

- “Device Constraint Editor” on page 187
- “Timing Constraint Editor” on page 208
- “Physical Designer” on page 216
- “Physical Designer: Routing Mode” on page 224

The Radiant software constraints tools enable you to develop constraints that shorten turn-around time and achieve a design that conforms to critical circuit performance requirements.

This section describes these Radiant software constraints tools and how to use them.

Device Constraint Editor

Device Constraint Editor is used to edit .pdc constraints. These constraint editing views are available from the Radiant software toolbar and Tools menu.

All modified constraints will be saved to a .pdc file and the flow will return to Map. The Device Constraint Editor shows the pin layout of the device and displays the assignments of signals to device pins. This view allows the user to edit these assignments, reserve sites on the layout to exclude from placement and routing. The Device Constraint Editor is also the entry mechanism for physical constraints.

Device Constraint Editor views enable you to develop constraints that will shorten turn-around time and achieve a design that conforms to critical circuit performance requirements.
The following figure shows the Device Constraints Editor.

![Device Constraints Editor](image)

The Device Constraints Editor allows you to do the following tasks:

- Define physical constraints based on design signals and logic elements.
- Define sysIO Buffer properties based on design signals.
- Constrain clock signals to particular routing spines.
- View, assign, and validate design signals and package pins.
- Assign voltage reference pins.
- Perform DRC tests to ensure legal pin assignments or to detect incomplete or illegal conditions within the physical design database.
- Back annotate post-route pin assignments to a logical constraint file.

**Viewing Pin, Port and Global Assignments in Device Constraint Editor**

The Device Constraint Editor has a spreadsheet view that provides a tabular format for viewing and assigning logical constraints. It displays all constraints, including those that have been assigned.

As soon as you have specified the target device, you can use this view to set global constraints. After synthesis and translation, you can use all of the following constraint sheets to create and modify constraints:

- **Port**  The Port tab provides a signal list of the design and shows any pin assignments that have been made.

  By default, the ports are grouped by direction—Input, Output, and Bidirectional—plus an “Others” category that includes user-defined port groups. This allows you to quickly focus on Outputs, for example, by closing the display of Input ports or vice versa.
The Port tab enables you to assign or edit pin locations and other attributes by entering them directly on the spreadsheet. It also allows you to assign multiple signals, by right-clicking the selected signals and opening the Assign Ports dialog box.

When the Assign Ports dialogue appears, the pins from the right side of the window can be dragged into the desired port shown in the left hand side of the window.

**Pin**  
The Pin tab provides a pin list of the device and shows the signal assignments that have been made. In the Dual Function column, pins that can be used for I/O assignments or for another function, such as Vref, are identified.

You can show differential pin pairs by selecting **View > Show Differential Pairs**.

The Pin tab enables you to edit signal assignments or assign new signals by right-clicking selected pins and opening the Assign Pins dialog box.

**Global**  
The Global tab provides general device information such as junction temperature, voltage, derating, VCCIO (and banks), Global Set/Reset nets and Use Primary Net to select the primary clock or critical nets. When the Global tab is selected, the package view is no longer shown unlike when the Pin or Port tab is selected. See section

See Also
- “Assigning Signals” on page 226
- “Setting Port, Net, and Cell Attributes” on page 230
- “Setting Global Settings” on page 196

**Viewing Package View and Pin Layout in the Device Constraint Editor**

The Device Constraint Editor has a Package View that shows the pin layout of the device and displays the assignments of signals to device pins. The Package View interacts with the Netlist View, which is a listed on the right side of the screen, to assign pins that enable you to drag selected signals to the desired locations on the pin layout.

Each pin that is assigned with a constraint is color-coded to indicate the port direction of the related signal port. The Package View allows you to edit these assignments, and it allows you to reserve sites on the layout that you want to exclude from placement and routing.

The Netlist view displays the RTL netlist objects including ports, instances and nets from RTL view. It will be docked in the package view for easy signal assignment. Selected signals from this view.

See Also  
- “Modifying Signal Assignments using the Device Constraint Editor” on page 228
Using the “Show” Commands

When Device Constraint Editor is open, the View menu provides two groups of “Show” commands. The first group consists of commands that are mutually exclusive; when one command is activated, the others become inactive. The second group consists of commands that are not mutually exclusive; they can be activated at the same time that another “Show” command is active.

In addition to the View menu, the “Show” commands are available from the pop-up menu when you right-click a blank space on the Package View layout.

**Mutually Exclusive Commands**  Only one command can be used at a time:

- Show Bank IO
- Show Port Group
- Show DQS Group
- Show SSO Group

**Non-mutually Exclusive Commands**  The following commands can be activated while another “Show” command is active:

- Display IO Placement
- Show Differential Pairs

Displaying Bank I/O Assignments

By default, Package View displays any assigned I/Os within each color-coded bank. However, the bank I/O display is turned off when the display for Port groups or DQS groups is turned on.

To display bank I/Os:

- In Device Constraint Editor, choose **View > Show Bank IO**.

  The I/O assignments are displayed within each bank. Port groups and DQS groups, and SSO groups are hidden.

Displaying Port Groups in Device Constraint Editor

Device Constraint Editor enables you to view the placement of assigned port groups on the pin layout. Each port group is color-highlighted with the same distinctive color that is displayed in the Group sheet of the Spreadsheet View.

To display port groups:

- In Device Constraint Editor, choose **View > Show Port Group**.
The color-coded port groups are displayed. Bank I/O assignments, DQS groups, and SSO groups are hidden.

**Displaying DQS Groups in Device Constraint Editor**
You can view the placement of DQS groups in color-coded format on Device Constraint Editor pin layout by turning on the “Show DQS Groups” command.

To display DQS Groups:
- In Device Constraint editor, choose **View > Show DQS Group**.

  The color background of each DQS group is displayed. Bank I/O assignments, port groups, and SSO groups are hidden.

**Displaying SSO Groups in Device Constraint Editor**
The “Show SSO View” command, available from Device Constraint Editor, displays the output pins that have been selected for SSO analysis. Tool tips for each pin provide SSO details. Output pins that passed SSO analysis are color-coded green; those that failed are color-coded red. This command also opens the SSO report in the Output window.

To display the SSO View:
- In Device Constraint Editor, choose **View > Show SSO View**.

  The SSO analysis output pins are displayed, color-coded according to pass or fail status. Bank I/O assignments, port groups, and DQS groups are hidden. The tool tip for each SSO pin includes information from the SSO Analysis Report.

**Displaying Differential Pin Pairs in Device Constraint Editor**
The “Show Differential Pairs” command enables you to identify all the differential pin pairs on a layout. When this command is activated, fly wires are displayed that connect the differential pin pairs. Each unplaced positive differential pin displays a small magenta-colored cross in the upper right corner. By default, these indicators are hidden.

To display differential pin pairs:
- In Device Constraint Editor, choose **View > Show Differential Pairs**.

  The layout displays the fly wires connecting differential pins and the cross indicator for each positive differential pin.
The “Show Differential Pairs” command acts as a toggle key and displays a check mark when the differential pair fly wires are displayed. Select View > Show Differential Pairs to turn off the display.

See Also ➤ “Prohibiting Incompatible Pins” on page 230

Displaying I/O Placement Assignments in Device Constraint Editor Package View

After placement and routing, Package View enables you to examine all pin assignments, including those made by Place & Route (PAR). A rotated square in the background of each placed pin serves as a placement indicator when the “Display IO Placement” command is turned on. The pin assignments are displayed with a color fill to distinguish them from PAR-assigned pins.

To display I/O Placement assignments in Package View:

- In Package View, choose View > Display IO Placement or click the Display IO Placement button on the toolbar. The border color around the box indicates the Bank info which is shown in the right hierarchy view. Pin assignments that originated from the .pdc file are displayed with a color fill. Blue is output signal; green is input signal.

The “Display IO Placement” command acts as a toggle key and displays a check mark when the assignments are displayed. Select the command again to turn off the display.

When you edit pin assignments after placement and routing and save them, the placement indicators are cleared from Device Constraint Editor. The “Display IO Placement” command is then unavailable until you rerun Place & Route.

Changing Device Constraint Editor Default Color Coding

The color coding in Package View is used to differentiate each bank and each type of pin. You can easily view the significance of each color by opening the Color Legend by going to Tool > Options, Color Tab on the left and Device tab in the main pain. The Color Legend Tab also enables you to change the default color coding for banks and pin types.
To change the default color coding for banks and pins:
1. Go to Tool > Options, Color tab on the left and Device tab in the main pain.
2. Double-click the color box under the Color column of the desired bank or pin type listed in the Name column that you want to change.
3. In the Select Color dialog box, select a different color and click OK.
4. If you want to change more than one color, click Apply in the dialog box, and then repeat Steps 3 and 4. To revert to the default colors, click Restore.
5. When you have finished color editing, click Close.

Filtering the Display of Banks and Pin Types in Device Constraint Editor
When you open Device Constraint editor, it shows all banks and pin types by default. In the Radiant software, the window to the right of the main device view shows the banks and pin types so that only selected banks and pin types are displayed via the Selection and Attributes tabs.

To filter the display of banks and pin types in Package View:
1. On the right hand side select Selection tab, you can check or uncheck the different types of IOs.

See Also ▶“Using the “Show” Commands” on page 190

Reversing the Pin Layout View in Device Constraint Editor
You can reverse the view of Package View ‘s device pin layout from a bottom to top perspective, or vice versa.

To reverse the pin layout view:
▶ From the Device Constraint Editor, choose View > Top View or View > Bottom View.

The View command acts as a toggle key and changes to its opposite, depending on the current view.

Using the Zoom and Pan Tools in Device Constraint Editor
The Radiant software toolbar provides zoom tools for the Device Constraint Editor. In addition, the vertical toolbar included with Package View and Placement Mode provides commands that work together with the zoom tools to help you navigate to different objects and areas of the layout. Also, both Routing Mode and Logic Block View provide an area zoom that is controlled
through the left mouse button. All of the views enable you to zoom in and out using the mouse wheel and function key combinations, and to pan using the arrow keys.

**Radiant Software Toolbar Zoom Commands**  The following commands are available on the Radiant software toolbar and in the View menu for each layout view.

- **Zoom In** – enlarges the view of the entire layout.
- **Zoom Out** – reduces the view of the entire layout.
- **Zoom Fit** – reduces or enlarges the entire layout so that it fits inside the window.
- **Zoom To** – enlarges the view to only show a selected pin.

**Area Zoom with the Mouse in Device Constraint Editor and Placement MODE**  In Routing Mode and Logic Block View, you can enlarge an area of the layout by holding the left mouse button and dragging to the right and downward. Afterwards, you can zoom out of the area by dragging your mouse upward and to the left. 

**Area Selection Mode** – enables you to select objects on the layout by clicking an individual object or by dragging around an area to select multiple objects. It also enables you to move an assignment to a different location by dragging it. After selecting objects, you can zoom in with the Zoom To command. The Select command is activated by default. When Select is active, the Pan and Zoom Area commands are disabled.

**Zooming with Function Key Shortcuts**  The following key combinations, available for all the layout views, enable you to instantly zoom in or out from your keyboard:

- **Zoom In** – Ctrl++ (numeric keyboard)
- **Zoom Out** – Ctrl+- (numeric keyboard)

**Zooming with the Mouse Wheel**  The mouse wheel gives you finer zoom control, enabling you to zoom in or out in small increments. While pressing the Ctrl key, move the mouse wheel forward to zoom in and backward to zoom out. The mouse wheel zoom is available for all the layout views.

**Panning with the Arrow Keys**  After enlarging the layout with the zoom tools, you can use the keyboard arrow keys to pan horizontally or vertically to different areas of the layout. Panning with the arrow keys is available for all the layout views. You can also press the ‘Ctrl’ key and move your mouse while pressing the left mouse button.

**Searching for Design Elements in Device Constraint Editor**  Device Constraint Editor and Placement Mode enable you to search for design elements—either through a Find dialog box or through Find and Filter text boxes within the view.
Each provide Find and Filter text boxes at the top of the window. Radiant software highlights the found objects and enables you to navigate through them and cross-probe to other views.

Device Constraint Editor and Placement Mode each provide a Find dialog box. The Find dialog box in Placement Mode enables you to search for components, nets, and sites.

To search for design elements in Device Constraint Editor:

1. Open the desired view.
2. The Find text box appears at the top of the window.
3. To narrow the scope of the search, use wildcards in the following ways.
   a. Use the asterisk to match one or more characters.
   b. Use the question mark to match any single character.
   The view displays only those items that contain the characters you entered.
4. To locate a single design element from the list, type the name in the Find text box and press Enter.
   The found element is brought to the top of the view and highlighted.
5. To navigate through a list of elements that contain the same characters, use wildcards in the Find text box, and then press Enter.
   The first element containing the characters you entered is brought to the top of the view and highlighted. Press Enter again to go to the next element in the list.

Using Drag-and-Drop to Make Assignments
Radiant software constraint-editing views provide a convenient drag-and-drop feature for making assignments or editing them. This feature is available between Device Constraint Editor and Placement Mode. The drag-and-drop feature is also available within Package View and within Placement Mode. This feature allows you to perform the following actions:

- Drag signals from Netlist View to Package View to assign them to pin locations all within Device Constraint Editor.
- Drag assigned signals within Device Constraint Editor to reassign them to other locations.
- Drag EBR, DSP, PCS, PLL, and ASIC block instances from Netlist View to Placement Mode all within Device Constraint Editor to set constraints.
- Drag non-SLICE logical components within Placement Mode to reassign them to other locations.
- Drag GROUPs and REGIONS within Placement Mode to reassign them to other locations.
Undoing and Redoing Assignments
Radiant software Undo and Redo commands allow you to reverse constraint changes that were made in a selected constraint view. You can make multiple assignments, undo them all, and then redo them as desired. When all of your manual assignments have been undone or redone, the Undo or Redo command becomes dim. When you save your constraint changes, the undo and redo commands are disabled.

Note
The Undo command will not remove the in-memory constraint change indicators: the asterisk from a constraint view tab or the “constraints Modified” from the status bar. To remove these indicators after all assignments have been undone, use the Save command.

The commands are available from the Edit menu and from the Undo and Redo buttons on the Radiant software toolbar.

The standard Windows keyword shortcuts are also available:

- Press Ctrl+Z to undo an assignment.
- Press Ctry+Y to redo an assignment.

Printing a Constraint View from Device Constraint Editor
You can print any from the Device Constraint Editor and Placement Mode. The Radiant software provides a preview for each view, enabling you to select options before printing.

Printing a Layout View You can print a copy of the layout from Placement Mode or Device Constraint Editor.

To print a layout:
1. Select the layout view that you want to print.
2. Choose File > Print Preview.
3. Select from the toolbar options at the top, and then click the Printer icon to print.

Setting Global Settings
In the Device Constraint Editor tool at the bottom of the tool, there are a series of tabs to allow the user to set many of the device settings such as Junction Temperature, Voltage, SysConfig, User Code, Deratings, Bank VCCIO, Global Set/Reset, Use Primary Net and Vref Locate constraints.
Junction Temperature Setting

Assigns an operating junction temperature for the part that changes the derating factor for timing. You can use this constraint to override the default temperature, which is 85C (commercial) and 100C (industrial) for all speed grades. If no temperature or voltage preference is specified, the derating factor is 1.0.

To set Junction Temperature value:
1. After opening the design project, choose Tools > Device Constraint Editor.
2. Select the Global tab at the bottom of the view.
3. Enter Junction Temperature value in the text box.

Device Support  LIFCL, LFD2NX

Syntax

ldc_set_attribute {TEMPERATURE=<value>C/F/K}

Note

The temperature can be specified in C (Celsius), F (Fahrenheit) or K (Kelvin). Internally it is converted to Celsius. The use of a space between the number and the voltage symbol is optional. See examples.

Examples  The following preference sets the operating junction temperature to 65 degrees Celsius.

ldc_set_attribute {TEMPERATURE=65C}

Voltage Setting

Assigns a value for nominal FPGA core voltage. That is the central array and excluding I/Os. If no temperature or voltage preference is specified, the derating factor is 1.0.

To set voltage value:
1. After opening the design project, choose Tools > Device Constraint Editor.
2. Select the Global tab at the bottom of the view.
3. Enter a Voltage value in the text box.

Device Support  LIFCL, LFD2NX

Syntax  ldc_set_vcc -core <value>
A space between the number and the voltage symbol is optional. See example.

**Example** The following constraint command assigns a value for nominal voltage of 0.95 V.

```tcl
de_c_set_vcc -core 0.95
```

**sysCONFIG Settings**

Defines system configuration option settings for the sysCONFIG feature. If you do not specify these settings in the .pdc file, using the Global tab in Device Constraint Editor or manually, some default sysCONFIG constraints will automatically be generated based on the device selection.

The SYSCONFIG constraint is available for all Lattice FPGA devices that support the sysCONFIG configuration port. The sysCONFIG port can be a single data line or byte-wide (multiple byte) data port that can support serial and parallel configurations streams. The devices also support daisy chaining.

**To set SysConfig parameter values:**
1. After opening the design project, choose **Tools > Device Constraint Editor**.
2. Select the Global tab at the bottom of the view.
3. In the SysConfig drop down setting, for each parameter in the value column, double click to bring up the drop down to select a value or, type in the actual value.

**SYSCONFIG Keyword Settings**

The following table shows the default settings in bold type and the selectable settings for all of the keyword values for the SYSCONFIG constraint. They are ordered as they appear in the Global tab in the Device Constraint Editor.

**Device Support** LIFCL, LFD2NX

**Syntax**

```tcl
ldc_set_sysconfig <keyword>=<value>
```

You should set the constraint configuration using the Device Constraint Editor or by editing the .pdc file directly. If you do not set sysCONFIG options, default SYSCONFIG constraints are automatically set.

**Examples**

The SYSCONFIG constraint allows you to set a series of keyword values in succession after the `ldc_set_sysconfig tcl command.`
**SLAVE_SPI_PORT** =DISABLE (default) | SERIAL | DUAL | QUAD

Specifies if the SLAVE_SPI port should be available after configuration. This option will preserve the dual-purpose pins for PAR.

**MASTER_SPI_PORT** =DISABLE (default) | SERIAL | DUAL | QUAD

Specifies if the MSPI port should be available after configuration. Used for background programming of the connected SPI flash. This option will preserve the dual-purpose pins for PAR. When enabled, it allows the use of...
the external Master SPI port for configuring the SRAM fuses using the bitstream.

**SLAVE_I2C_I3C_PORT** =DISABLE (default) | ENABLE

Specifies if the SLAVE I2C/I3C port should be available after configuration. This option will preserve the dual-purpose pins for PAR.

**JTAG_PORT** =DISABLE (default) | ENABLE

Specifies if the JTAG port should be available after configuration. This option will preserve the dual-purpose pins for PAR. When ENABLED, it is used for configuration settings only, PAR will prohibit them. When DISABLED, it can be used as GPIOs.

**DONE_PORT** =DISABLE (default) | ENABLE

When set to ENABLE, the pin is not available in user mode.

**INITN_PORT** =DISABLE (default) | ENABLE

When set to ENABLE, the pin is not available in user mode.

**PROGRAMN_PORT** =DISABLE (default) | ENABLE

When set to ENABLE, the pin is not available in user mode.

**BACKGROUND_RECONFIG** =OFF (default) | ON | SRAM_EBR | RAM_ONLY

ON turns on background reconfig feature or can be done in embedded blockram or SRAM.

**DONE_EX** = OFF (default) | ON

The customer can select if the device should wake up on its own after the DONE bit is set or wait for an external DONE signal to drive the DONE pin high. The DONE_EX attribute will determine if the wake up sequence is driven by an external DONE signal. If set to ON, the user wishes to delay wake up until the DONE pin is driven high by an external signal and synchronous to the clock. The user will select OFF if they want to synchronously wake up when the DONE bit is set and ignore any external driving of the DONE pin.

**DONE_OD** = ON (default) | OFF

Done Pin Open Drain. Enables you to configure the DONE pin as an open drain pin. By default, the pullup on the DONE pin is active.

The DONE pin used in sysCONFIG to indicate that configuration is done. The DONE pin can be linked to other DONE pins and used to initiate the wake up process. The DONE pin can be open collector or active drive. Default is ON and insures the user needs to make a conscious decision to drive the pin.
MCCLK_FREQ = <frequency_value> (MHz)

MCCLK_FREQ is used to control the Master Clock frequency. When a master configuration mode is used, MCCLK will become an output clock with the frequency set by the user. Until the device is configured, the default Master Clock frequency is the lowest frequency support by the device. For LIFCL, LFD2NX, a 450Mhz oscillator is divided and made available for configuration.

Valid options are 3.5 MHz, 7.0 MHz, 14.1 MHz, 28.1 MHz, 56.2 MHz, 90.0 MHz, 112.5 MHz, and 150.0 MHz. The default is the lowest frequency, 3.5 MHz.

TRANSFR = OFF (default)

TRANSFR is used for the current supported devices, only OFF is available. When ON is selected for a future supported device, it sets the CR0 TransFR option. This will also enable the Hold IO type.

CONFIG_IOSLEW = SLOW (default) | MEDIUM | FAST

CONFIG_IOSLEW controls config output pin slew rate. Sets CR0[7:6].

CONFIGIO_VOLTAGE_BANK0/1 = NOT_SPECIFIED (default) | 3.3 | 2.5 | 1.8 | 1.5 | 1.2

Setting this attribute informs the software which voltage is required in Bank0/1 to satisfy the user’s sysCONFIG requirements. The sysCONFIG pins used for configuration may or may not be used in the design and hence the user shall be able to declare the voltage interface for this bank. DRC errors can then be generated based on CONFIG_IOVOLTAGE and usage of the dual-purpose sysCONFIG pins. BANK0 and 1 values can be different and a combination of the available values including NOT_SPECIFIED.

CONFIG_SECURE = OFF (default) | ON

CONFIG_SECURE is used for Configuration Security. When set to ON, no readback operation is supported through the sysCONFIG port or ispJTAG port of the general contents. The USERCODE area is readable and not considered securable. The OFF setting indicates that readback is enabled through any port. Prevents readback of the configuration memory contents.

WAKE_UP = ENABLE/DISABLE_DONE_SYNC (DONE_EX = OFF) / (DONE_EX = ON)

WAKE_UP is a controlled event after a part has been configured. External control of the DONE pin can be selected to either delay wake up or be ignored. See DONE_EX.

The WAKE_UP sequence controls three internal signals, and the DONE Pin will be driven after configuration and prior to user mode. If DONE_EX = ON, the WAKE_UP keyword will take your selected option (1-7), and then the software will set wake-up signal bits accordingly. If you do not select a wake-up sequence, the default wake-up sequence will be 4. If DONE_EX = OFF (default), the WAKE_UP keyword will take your selected option (1-25), and
then the software will set wake-up signal bits accordingly. If you do not select a wake-up sequence, the default wake-up sequence will be 21.

**COMPRESS_CONFIG** = OFF (default) | ON

Bitstream Compression. When set to ON, for those devices that support bitstream compression, the software generates a compressed version of the bitstream file.

**EARLY_IO_RELEASE** = OFF (default) | ON [once]

Program and wakeup the left/right I/O banks early, before the rest of the device is programmed.

**BOOTMODE** = DUAL (default) | SINGLE | NONE

This setting enables a user to select the booting mode at power up.

DUAL - Perform the dual boot for the booting event. In case the primary booting image (bitstream) fails, the secondary (golden) boot image is invoked to boot device.

SINGLE - Perform a single boot only. If failure occurs, device will move to unprogrammed mode directly.

NONE - No master SPI booting at startup, waits for slave configuration port to configure the device.

### User Code Settings

**To set User Code parameter values:**

1. After opening the design project, choose **Tools > Device Constraint Editor**.
2. Select a the Global tab at the bottom of the view.
3. For each parameter in the value column, double click to bring up the drop down to select a value or, type in the actual value.

The following table shows the default settings in bold type and the selectable settings for all of the keyword values for the User Code setting. They are ordered as they appear in the Global tab in the Device Constraint Editor.

<table>
<thead>
<tr>
<th>Keyword</th>
<th>Default and Selectable Values</th>
<th>Supported Devices</th>
</tr>
</thead>
<tbody>
<tr>
<td>UserCode Format</td>
<td><strong>Binary</strong> (default) [Binary, Hex, ASCII, Auto]</td>
<td>LIFCL, LFD2NX</td>
</tr>
</tbody>
</table>
Applying Design Constraints: Using Radiant Software Tools

**UserCode Format**

The default is Binary but can be any of the above format types. Selecting Auto Radiant, will automatically generate a UserCode to uniquely identify their design. The upper bits will be defined with the Unique Id setting. The lower 16 bits will sequentially auto increment for every bitstream generation.

**UserCode** = value

The UserCode formatted into a 32 bit binary code in the bitstream but can be entered by the user based on the UserCode Format selection.

**Unique Id** = h0000 (default in HEX)

Works in conjunction with UserCode. An automatic Usercode will be created where the upper 16-bits of the Usercode is created by the user to uniquely identify their design. The upper 16-bits is the Unique Id entered in HEX.

**Derating Settings**

The section under ‘Derating’ in the Device Constraint Editor allows a user to define voltage deratings for core voltage, power supplies and bank voltage deratings.

**To set Derating parameter values:**

1. After opening the design project, choose **Tools > Device Constraint Editor**.
2. Select a the Global tab at the bottom of the view.
3. In the Derating drop down section, for each parameter in the value column, double click to bring up the drop down to select a value.

The following shows the default settings in bold type and the selectable settings for all of the keyword values for the Derating settings. They are ordered as they appear in the Global tab in the Device Constraint Editor.

**Core**=NOMINAL (default) | +/- 5% in increments of 1%  
**Device Support**  LIFCL, LFD2NX

**Syntax**

`ldc_set_vcc -core -derate <% value>`

This defines the core voltage for derating. Radiant, will automatically generate a UserCode to uniquely identify their design. The upper bits will be defined
with the Unique Id setting. The lower 16 bits will sequentially auto increment for every bitstream generation.

Nominal VCC core voltage value as specified in Supported Temperature and Voltage Range for Derating topic.

Nominal VCC value plus \(<number>\)% of VCC value or nominal VCC value minus \(<number>\)% of VCC value. The legal range is +5 to –5 in increments of 1.

Example

The following shows how to set the .sdc constraint which is stored in the .pdc file. Core voltage is set at a derating of -3%.

```shell
ldc_set_vcc -core -derate -3
```

**DPHY0/1=value**

**Device Support** LIFCL, LFD2NX

This is used to derate the MIPIDPHY power supply. Valid values are from -5% to 5%, starting from a base 1.2V.

**NOMINAL:** 1.2V

**PERCENT:** Nominal VCC value plus \(<number>\)% of VCC value or nominal VCC value minus \(<number>\)% of VCC value. The legal range is +5 to -5 in increments of 1.

**Syntax**

```shell
ldc_set_vcc -bank <value> -derate <value>
```

**Example** The following constraint include sets MIPIDPHY voltage derating to -4%.

```shell
ldc_set_vcc -dphy DPHY0 -derate -4;
ldc_set_vcc -dphy DPHY1 -derate -4;
```

**VCCIO=value**

**Device Support** LIFCL, LFD2NX

Defines the VCCIO bank voltage for derating. The value can be set for Bank0, 1, 3, 5.

**NOMINAL:** Nominal VCCIO value of the buffer type placed in a particular I/O bank. See available data sheets for information on nominal values.
PERCENT (+<number> | -<number>): Nominal VCCIO value plus or minus the <number>% VCCIO value of the buffer type placed in a particular I/O bank. The legal range is +5 to –5 in increments of 1

**Syntax**

```
ldc_set_vcc -bank <value> -derate <value>
```

**Examples**  The following constraint sets VCCIO derating of Bank0 to -3% and Bank3 to -5%.

```
ldc_set_vcc -bank 0 -derate -3
ldc_set_vcc -bank 3 -derate -5
```

**Bank VCCIO Settings**

Sets the VCCIO voltage level of the I/O bank. In cases where design signals are not assigned to a device site or bank (floating), the BANK constraint can be applied to direct the I/O placer algorithm of Place and Route (par) to assign only design I/O signals with compatible signal standards to the bank.

**Device Support**  LIFCL, LFD2NX

**To set Bank VCCIO parameter values:**

1. After opening the design project, choose **Tools > Device Constraint Editor**.
2. Select a the Global tab at the bottom of the view.
3. In the Bank VCCIO drop down section, for each parameter in the value column, double click to bring up the drop down to select a value.

The following shows the default settings in bold type and the selectable settings for all of the keyword values for the Derating settings. They are ordered as they appear in the Global tab in the Device Constraint Editor.

Banks0, 1, 3, 5 can be set and the values ranges from: 1.0, 1.2, 1.35, 1.50, 1.80, 2.50, 3.30

**Syntax**  ldc_set_vcc -bank <value> <voltage>

**Example**

The following shows how to set the Bank VCCIO for Bank3 to 3.3V and Bank5 to 2.5V.

```
ldc_set_vcc -bank 3 3.3
ldc_set_vcc -bank 5 2.5
```
Global Set/Reset Net Setting
Assigns the specified net as the input to the global set/reset (GSR) buffer inferred by Radiant. The GSR_NET constraint allows you to specify the net to be applied as the GSR buffer input if more than one net qualifies to serve as the GSR signal.

GSR is a signal that will initialize all registered elements of the design that have the GSR input enabled. If no GSR buffer circuit is included in the input database, the tool will infer one based on the set/reset signal that has the most loads. To be considered a legal candidate, the net assigned using the GSR_NET constraint must drive at least one registered element's set/reset input, and the element must be enabled to be sensitive to GSR.

Device Support LIFCL, LFD2NX

To set Global Set/Reset Net:
1. After opening the design project, choose Tools > Device Constraint Editor.
2. Select the Global tab at the bottom of the view.
3. Double click the cell beside the ‘Global Set/Reset Net’ and a dialogue will appear.
4. Click on the “Available Logic Nets” on the left and click on the right arrow to move to “Selected Logic Nets”.

The following shows the default settings in bold type and the selectable settings for all of the keyword values for the Derating settings. They are ordered as they appear in the Global tab in the Device Constraint Editor.

Syntax

ldc_set_attribute {GSR_NET=TRUE/FALSE} {get_nets <net_name>};

where:

<net_name> is a logical net.

Example If your design has multiple set/reset signals, and the automatic detection by logic synthesis or MAP chooses a GSR driver that's not appropriate for your design, you would use the syntax shown in the following example to explicitly assign a net to drive the GSR buffer circuit:

```
ldc_set_attribute {GSR_NET=TRUE} [get_nets VCC_net]
ldc_set_attribute {GSR_NET=TRUE} [get_nets rst_c]
```

Use Primary Net Setting
Uses a primary clock resource to route the specified net. The specified net should be a clock net.
The USE PRIMARY physical constraint is needed when user intervention is required to route nets using primary and secondary clock resources. PAR uses various criteria for selecting the nets, including the number and type of loads, the availability of clock drivers, and the availability of clock trees.

**Device Support**  LIFCL, LFD2NX

**To set User Primary Net:**

1. After opening the design project, choose **Tools > Device Constraint Editor**.
2. Select the Global tab at the bottom of the view.
3. Double click the cell beside the ‘Use Primary Net’ and a dialogue will appear.
4. For each available clock, click on the “Selection” drop down box and select either Primary / Prohibit.

**Syntax**

```
ldc_set_attribute {USE_PRIMARY= TRUE/FALSE (USE_PRIMARY_REGION=<region_value>) [get_nets <clock_net>]
```

where:

- `<clock_net>` = specific clock net name
- `<region_value>` is a region value of 0/1

**Examples**  The following command specifies that a primary clock resource will be used to route a clock net named **clk_c**:

```
ldc_set_attribute {USE_PRIMARY=TRUE} [get_nets clk_c]
```

The following command specifies that a primary clock resource will be used to route the clock net **clk_c** but with a primary region specified.

```
ldc_set_attribute {USE_PRIMARY=TRUE USE_PRIMARY_REGION=1} [get_nets clk_c]
```

**Prohibit Primary**

Prohibits the use of primary clock resources for routing the net. The specified net should be a clock net. This constraint can be used with all devices that have primary clocking structures.

**Syntax**

```
ldc_set_attribute {USE_PRIMARY=TRUE/FALSE} [get_nets <clk_net>];
```

where:

- `<clk_net>` = clock name string
**Example**  This command prohibits the use of a primary clock in routing a clock net named clk_c.

```
ldc_set_attribute {USE_PRIMARY=FALSE} [get_nets clk_c]
```

---

**Vref Locate Setting**

Assigns a PIO site that will serve as the input pin for an on-chip voltage reference. Referenced input voltage pins are required when implementing an externally referenced signaling standard such as HSTL or SSTL. After the Vref location has been established, it can be associated with a port group.

**Device Support**  LIFCL, LFD2NX

**To set User Vref Locate:**

1. After opening the design project, choose **Tools > Device Constraint Editor**.
2. Select the Global tab at the bottom of the view.
3. Double click the cell beside the ‘Vref Locate’ and a dialogue will appear.
4. For each available sites, click on the desired row and enter a unique name in the text box ‘VREF Name’.

**Syntax**  `ldc_create_vref -name <vref_name> -site <site_value>`

where:

- `<vref_name>` = string
- `<site_value>` = already pre-filled by Radiant.

For more details regarding I/O type, see the sysIO Usage Guide for your target device family.

**Example**  This constraint assigns a custom site name TEST_SITE to the selected site.

```
ldc_create_vref -name TESTING_SITE 8
```

---

**Timing Constraint Editor**

The Timing Constraint Editor tool is used to enter all the timing constraints in the Radiant software tool, as well as to edit .ldc/.pdc constraints. There are a total eight tabs to enter different constraint types:

1. Clock - define the clocking scheme of the design.
2. Generated Clock - define generated clocks such as from PLLs.
3. Clock Latency - define the latency in terms of Rise, Fall times.
4. Clock Uncertainty - define From and To constraints.
5. Clock Group - used for complex clocking schemes and groups in terms of being Logically / Physically Exclusive and Asynchronous groups.
6. Load Capacitance - set the capacitive loading for I/Os.
8. Timing Exception - set Min / Max, False and Multicycle path constraints.

The above will be described in more detail below.

**Pre / post-synthesis Timing Constraint Editor**

You will notice under Tools > Timing Constraint Editor, there are two selections:

1. **Pre-Synthesis Timing Constraint Editor**
2. **Post-Synthesis Timing Constraint Editor**

The two GUIs are identical and the entry mechanism of the constraints also the same. The key difference as noted in the tool name is that pre-synthesis are (.ldc) constraints are entered pre-synthesis and will be synthesized by the chosen synthesis tools. Post-Synthesis constraints (.pdc) will populate pre-synthesis timing constraints and allow for entering physical as well as post-synthesis timing constraints. The post-synthesis Timing Constraint Editor is the same GUI with the varying constraints already synthesized and populated in each of the different constraints tab. A user cannot modify the constraints in the post-synthesis constraints that were populated from pre-synthesis, but a user can supply new constraints to either one, override an existing, or supply totally new constraints to better constrain the design for better performance upon analysis.
Defining Synthesis Constraints Using Timing Constraint Editor

Timing Constraint Editor presents the contents of a Lattice Design Constraints File (.ldc) in a spreadsheet style format. You can use Timing Constraint Editor to open and edit a current .ldc file or create a new one. Individual sheets are provided for defining clocks, setting input and output delays, and defining delay paths for multicycle, minimum and maximum delays, and false paths.

By default, Timing Constraint Editor is launched when you create a new .ldc file. Each sheet of Timing Constraint Editor allows you to define synthesis constraints by double-clicking a cell and selecting or typing a value.

Each row includes a Disable check box, which is unchecked by default. If you check this check box, the constraint is ignored by LSE. This can be an easy way to enable / disable the constraint.

See Also
- “Creating a New .ldc Synthesis Constraint File” on page 177
- “Defining Clocks Using Timing Constraint Editor” on page 211
- “Setting Input and Output Delays Using Timing Constraint Editor” on page 212
- “Defining Timing Exceptions Using Timing Constraint Editor” on page 213
- “Defining Clock Groups in Timing Constraint Editor” on page 214
- “Defining Generated Clocks in Timing Constraint Editor” on page 214
- “Setting Attributes in Timing Constraint Editor” on page 215
- “Adding an .ldc File to an Implementation” on page 179
Running Timing Constraint Editor
Launch the Timing Constraint Editor by opening or creating an .ldc file for an implementation.

Note
In order to open or create an .ldc file, LSE must be the selected synthesis tool for the project. Choose Project > Active Implementation > Select Synthesis Tools and select Lattice LSE.

When a user disables a constraint in GUI of TCE, you will see the #DISABLED# appended in front of actual constraint.

You can have multiple .ldc files for an implementation, but only one can be opened in Timing Constraint Editor at a time.

To run Timing Constraint Editor, do one of the following:
- Double-click an .ldc file name in the Timing Constraints Files folder in the File List view.
- If you have set Source Editor to be the default program for .ldc files, right-click the .ldc file name in the File List view and choose Open With. In the Open With dialog box, choose Timing Constraint Editor and click OK.
- If an .ldc file doesn’t yet exist for the active implementation, create an .ldc file as described in Creating a New .ldc Synthesis Constraint File.

See Also
- “Managing Constraint Files” on page 26
- “Using Source Editor for .ldc Files” on page 178

Defining Clocks Using Timing Constraint Editor
The Clock tab of Timing Constraint Editor enables you to define an alias to be associated with an existing clock port or net from the source file. You can also define clocks by dragging-and-dropping from Netlist Analyzer into Timing Constraint Editor.

To define a clock using Timing Constraint Editor:
1. Double-click the Object Clock cell to select an existing clock pin, port, or net. A CLOCKPIN is applied on instances and (CLOCKPORT) ports is applied to top level modules. Clocks coming from the outside should ideally be defined on a port.
2. If desired, enter an alias for the clock in the Clock Name cell.
3. Enter a clock period in nanoseconds in the Period(ns) cell.
4. If desired, you can specify the duty cycle. Double-click the Waveform cell and enter the length of the high portion followed by low portion of the cycle.
in nanosecond. The default duty cycle is 50%. The waveform option is used to control the arrival times of the positive and negative edges and the duty cycle. The waveform edges have to be within the period of the clock. Enter the values with at least one decimal i.e. 5.0;2.0.

**To define a clock in Timing Constraint Editor using Netlist Analyzer:**

1. Start Netlist Analyzer and detach it by clicking the detach tool in the upper right corner. Refer to “About Netlist Analyzer” on page 41.
2. Select desired clock object (port or net) from Netlist Analyzer and drag-and-drop into Clock Object cell of the Timing Constraint Editor Clocks tab.
3. If desired, enter an alias for the clock in the Clock Name cell.
4. Enter a clock period in nanoseconds in the Period(ns) cell.
5. If desired, you can specify the duty cycle. Double-click the Waveform cell and enter the length of the high portion followed by low portion of the cycle in nanosecond. The default duty cycle is 50%. The waveform option is used to control the arrival times of the positive and negative edges and the duty cycle. The waveform edges have to be within the period of the clock. Enter the values with at least one decimal i.e. 5.0;2.0.

**See Also**
- “create_clock” on page 568
- “Creating a New .ldc Synthesis Constraint File” on page 177
- “About Netlist Analyzer” on page 41

**Setting Input and Output Delays Using Timing Constraint Editor**

The Inputs/Output Delay tab of Timing Constraint Editor enables you to specify input and output delays relative to a clock. You can also define input and output delays by dragging-and-dropping from Netlist Analyzer into Timing Constraint Editor.

**To set an input or output delay using Timing Constraint Editor:**

1. Double-click the **Constraint Type** cell to select the type of delay (input or output).
2. Select from the input or output ports in the Port cell.
3. In the Clock cell, select an existing clock or an alias name that has been defined for a clock.
4. Select the Clock Fall check box if you want to clock on negative edge.
5. Select either Max or Min or neither. Do not select both. You can also select Add Delay
   - Max means that the delay value refers to the longest path.
   - Min means that the delay value refers to the shortest path.
   - Neither means that the maximum and minimum delays are assumed to be equal.
Add Delay is used to define more than one input delay on a given port.

6. Enter a delay value in nanoseconds in the Value (ns) cell.

To set an input or output delay in Timing Constraint Editor using Netlist Analyzer:

1. Start Netlist Analyzer and detach it by clicking the detach tool in the upper right corner. Refer to “About Netlist Analyzer” on page 41.
2. Select from the input or output ports from Netlist Analyzer and drag-and-drop into the Port cell of the Timing Constraint Editor Input/Outputs tab.
3. In the Clock cell, select an existing clock or an alias name that has been defined for a clock.
4. Select the Clock Fall check box if you want to clock on negative edge.
5. Select either Max or Min or neither. Do not select both. You can also select Add Delay.
6. Enter a delay value in nanoseconds in the Value(ns) cell.

See Also

► “Defining Clocks Using Timing Constraint Editor” on page 211
► “set_input_delay” on page 574
► “set_output_delay” on page 579
► “Creating a New .ldc Synthesis Constraint File” on page 177
► “About Netlist Analyzer” on page 41

Defining Timing Exceptions Using Timing Constraint Editor

The Timing Exception tab of Timing Constraint Editor enables you to define a Multicycle path, specify a Max_Delay or a Min_Delay for a timing path, and identify a False path that is to be excluded from timing analysis. You can also perform the same functions by dragging-and-dropping from Netlist Analyzer into Timing Constraint Editor.

To define a timing exception using Timing Constraint Editor:

1. Double-click the Constraint Type cell and select the type of delay.
2. Specify the path information, delay, and cycles as appropriate for the selected delay type.

To define a delay path in Timing Constraint Editor using Netlist Analyzer:

1. Start Netlist Analyzer and detach it by clicking the detach tool in the upper right corner. Refer to “About Netlist Analyzer” on page 41.
2. Select object (port, net, or register) from Netlist Analyzer and drag-and-drop into the From or To cell of the Timing Constraint Editor timing exception tab.
3. Specify the path information, delay, and cycles as appropriate for the selected delay type.

**See Also**
- "set_multicycle_path" on page 578
- "set_load" on page 576
- "set_min_delay" on page 577
- "set_false_path" on page 574
- "Creating a New .ldc Synthesis Constraint File" on page 177
- "About Netlist Analyzer" on page 41

### Defining Clock Groups in Timing Constraint Editor

The Clock Group tab of Timing Constraint Editor enables you to define clock groups that are logically / physically exclusive or asynchronous with each other in a design so that the paths between these clocks are not considered during timing analysis.

**To define clock groups using Timing Constraint Editor:**
1. Double-click the **Group** cell and select the appropriate clock group.
2. Now you will be able to select logically / physically or asynchronous type.

**See Also**
- "set_clock_groups" on page 571
- "Creating a New .ldc Synthesis Constraint File" on page 177

### Defining Generated Clocks in Timing Constraint Editor

The Generated Clock tab of Timing Constraint Editor enables you to define internally generated clocks. You can also perform the same functions by dragging-and-dropping from Netlist Analyzer into Timing Constraint Editor.

**To define generated clocks using Timing Constraint Editor:**
1. In the **Source** cell, select the source clock for the generated clock.
2. Specify the other values as appropriate for the generated clock.

**To define generated clocks in Timing Constraint Editor using Netlist Analyzer:**
1. Start Netlist Analyzer and detach it by clicking the detach tool in the upper right corner. Refer to "About Netlist Analyzer" on page 41.
2. Select the source clock from Netlist Analyzer and drag-and-drop into the Source cell of the Timing Constraint Editor Generated Clocks tab.
3. Specify the other values as appropriate for the generated clock. You can also specify the Master Clock and Object values by dragging from Netlist Analyzer.

See Also  
▶ “create_generated_clock” on page 570
▶ “Creating a New .ldc Synthesis Constraint File” on page 177

Defining Clock Latency in Timing Constraint Editor
The Clock Latency tab of Timing Constraint Editor enables you to define the behavior of the clock outside the FPGA. You can also perform the same functions by dragging-and-dropping from Netlist Analyzer into Timing Constraint Editor.

To define clock latency using Timing Constraint Editor:
1. In the Clock cell, double click and select the three dots for the list of source clock for latency reference.
2. Specify the latency value.
3. Check off the check boxes for Rise, Fall, Early, Late and Source check boxes.

See Also  
▶ “set_clock_latency” on page 572
▶ “Creating a New .ldc Synthesis Constraint File” on page 177

Defining Load Capacitance in Timing Constraint Editor
The Load Capacitance tab of Timing Constraint Editor enables you to define load capacitance of ports in the design. You can also perform the same functions by dragging-and-dropping from Netlist Analyzer into Timing Constraint Editor.

To define load capacitance using Timing Constraint Editor:
1. In the Port cell, double click and select the three dots for the list of ports available for setting load capacitance.
2. Enter the value of the load.

See Also  
▶ “set_load” on page 576
▶ “Creating a New .ldc Synthesis Constraint File” on page 177

Setting Attributes in Timing Constraint Editor
The Attribute tab of Timing Constraint Editor enables you to specify Synplify Lattice Attributes that are supported by the LSE. You can also define objects by dragging-and-dropping from Netlist Analyzer into Timing Constraint Editor.
To set attributes using Timing Constraint Editor:
1. Double-click the **Type** cell and select the desired attribute.
2. Specify object, value type, and value, as appropriate for the attribute.

To set attributes in Timing Constraint Editor using Netlist Analyzer:
1. Start Netlist Analyzer and detach it by clicking the detach tool in the upper right corner. Refer to “About Netlist Analyzer” on page 41.
2. In Timing Constraint Editor Attribute tab, double-click the **Type** cell and select the desired attribute.
3. Specify object type and value, as appropriate for the attribute.
4. Select object (port, net, or register) from Netlist Analyzer and drag-and-drop into the Object cell of the Timing Constraint Editor Attribute tab.

**Note**
You can also drag-and-drop an object from Netlist Analyzer to the Object cell of Timing Constraint Editor Attribute tab before you specify the attribute. Object type will then be selected automatically. You can then specify attribute and value.

See Also
- “Lattice Synthesis Engine-Supported HDL Attributes” on page 580
- “About Netlist Analyzer” on page 41

**Compiling the Design Using Timing Constraint Editor**
By default, Timing Constraint Editor is set to compile the design automatically. With automatic compilation, Timing Constraint Editor automatically performs checks as to whether the design data is outdated. This happens whenever the Timing Constraint Editor is launched or activated. If the design data is found to be outdated, the compilation will begin immediately.

**Physical Designer**
The Physical Designer is a combined GUI interface of both the Placement Mode and Routing Mode accessible within this one Radiant software tool. This provides for one central location where a user can do all the floor-planning and be able to view the physical layout of the design.

The tool can be invoked by either: **Tools > Physical Designer** or by clicking on the toolbar icon 🌋. Upon opening, the GUI you will be shown is the Placement mode.

To access the **Routing Mode**, select the 🌋 Placement/IO view icon on the side tool and within this drop down select the Routing icon 🌋 to start routing view.
I/O Planning in IO Mode

Placement Mode is for GROUPS and REGIONs assignment. You can use the IO Mode tool for I/O planning and I/O assignment such as DDR interface, DQS and clock assignments. As you move your mouse pointer slowly over the I/O Abstract layout, details are displayed in tool tips: the number of resources for each items such as ECLK, DDR, PLL, and IO Banks utilization are displayed.

Switching Views: Placement / IO Mode  
To toggle between the Placement Model and IO Mode, click the from the drop down menu.

IO Mode Operations  
Design elements can be placed are shown in the left data panel and a chip-level view of the FPGA and available resources are shown on the right. The search text box at the top can be used to do searches for instances and IOs deep into the hierarchy.

Assignment is merely dragging elements from the left data panel onto the appropriate resource on the main layout I/O view window to be placed. Design elements (i.e. DDR) can be dragged as a group or individual element.

When clicking on the instance/IOs on the IO Abstract view main window, the associated instance/IO in the data pane on the left will be highlighted and vice versa.

- For regular I/O Banks - I/O already placed.

- For regular I/O Banks - I/O constrained and locked.

- For regular I/O Banks – Available for placement.

- For regular Serdes I/Os - I/O already placed.

- For regular Serdes I/Os– Available for placement.

Selection and assigning is performed by clicking and dragging of the I/O selected. Once you find the correct site, the site will be shown in green and the tool-tip will show the “+” to place the selected I/O object, you can release the left button. The tool does a final check and does the assignment accordingly.

Once an I/O object has been placed, you can move it again to a different place. If you select a leaf cell, on the cell or its associated “move-together” instances are selected.

You can also select the I/O object at the data panel. Right-click to activate the action menu and then choose Unplace.
Note that you cannot drag-n-drop for an I/O object which has been partially placed. You need to select low-level groups or leaf cells which have not been placed.

By default, a user cannot change user constraints in the IO view. If a component is constrained by a user "locate" constraint, the component is treated as a locked component. A locked component cannot be drag-n-dropped.

To drag-n-drop a locked component. From the Radiant main window, choose Tools > Options > Tools tab on the left > Physical Designer heading tab, toggle the Overwrite constraint: true.

Exporting I/O Planning Results   Once you complete your I/O planning whether pre/post P&R, you can export the I/O constraints to a PDF file. This is done by choosing File > Export Placement Result. You can overwrite an existing PDC or save to a new .PDC constraint file.

See Also  ▶ "Displaying Assignments and Connections" on page 220
▶ "Assigning Signals" on page 226
▶ "Creating GROUPs" on page 231

Physical Designer: Placement Mode

Placement Mode provides a large-component layout of your design. All connections are displayed as fly-lines. Placement Mode allows you to create REGIONs and bounding boxes for GROUPS and specify the types of components and connections to be displayed. As you move your mouse pointer slowly over the floorplan layout, details are displayed in tool tips: the number of resources for each GROUP and REGION; the number of utilized slices for each PLC component; and the name and location of each component, port, net, and site.

Placement Mode is available as soon as the target device has been specified.

See Also  ▶ "Creating GROUPs" on page 231
▶ "Using the Zoom and Pan Tools in Device Constraint Editor" on page 193

Congestion Timing Mapping Display

The congestion timing display allows you to debug timing congested areas of your design. This congestion timing display gives the timing of the most critical paths within the slack threshold input. Clicking on the timing icon will bring up Time Setting components dialogue in which once set, will display the congestion map.
1. Speed Grade - Choose the speed grade to perform analysis on.
2. Analysis Mode - Choose Setup/Hold.
3. Enter Slack Threshold Values for t1 and t2. Any value less than t1 will be displayed as red, less than t2 as yellow, and the rest green.
4. Select the Connection Display Mode - Critical Instance or Slack Distribution. (The connection display colors can be changed.)
   - Critical Instance - Displays all red colored congestion lines connecting to the critical instances.
   - Slack Distribution - Shows the congestion lines in weighted equal distribution of each of the congestion levels.
5. Click Update Timing. A Worst/Total negative slack is calculated.
6. Click OK. A congestion map is drawn.

**Congestion Display**
The congestion display is a read-only view for viewing the most congested regions based on the wire length and pins selected. Clicking on the timing icon will bring up congestion display view after selecting options.

1. Wires - Select the wire connection from switch box. (x0, x1, x2, x6)
2. Pins - Select Input / Output.
Displaying Assignments and Connections

The Placement Mode toolbar allows you to select the types of elements that will be displayed on the layout, including IOs, DQS GROUPS, placed components, and component connections. These commands are also available from the View menu.

- **Area Selection Mode** - used to drag and select sections of the floorplan.
- **Display Placement** – displays all placed components, including assignments originating from the logical constraint file (.pdc) and those made by Place & Route.
- **Display Placement Groups** – highlights the placed GROUP component sites with the designated color fill.
- **Display Connections To/From Selection(s)** – controls the two Display Connections buttons below it. When active, it enables you to activate one or both of these buttons to view the connections between selected components, outside of selected component, or both.
- **Display Connections Between Selection(s)** - shows the connections between selected components.
- **Display Connections Outside of Selection(s)** - shows the connections that extend outside of the selected components.
- **Display Placement Constraints** - shows placement assignments that originated from the .pdc file. When this button is active, placed components assigned with a LOC constraint are distinguished with a cross-hatch pattern.
- **Display Regions** – displays any defined REGIONS.
- **Display Groups** – displays any defined GROUPS.
- **Display Logical Connections** - shows the logical connections between GROUPs, including those assigned to REGIONs, and between GROUP and assigned Constraint sites. The connections are based on the logical instances within each GROUP.
- **Show World View** – toggles the World View of DCE to On or Off
- **Placement/IO Abstract View** - Toggles between these two views for GROUPS/REGIONS or I/O Placement.
- **Congestion Timing Map View** - Turns on timing congestion map tool for analysis.
- **Congestion Display** - Turns on congestion display analysis tool.

**See Also**
- “Using the Zoom and Pan Tools in Device Constraint Editor” on page 193
- “Viewing Assignments in Placement Mode” on page 221
Searching for Design Elements in Placement Mode

The Find Text... dialog box in Placement Mode enables you to search for components, nets, and sites.

To search for components, nets, or sites in Placement Mode:

1. Choose Tools > Physical Designer, and then choose Edit > Find or press Ctrl+F.
2. In the Find dialog box, type the name of the component, net, or site that you want to find. Use the asterisk and question mark characters to perform wildcard searches.
3. Select the type from the Find Type pulldown menu.
4. Select Match Whole Word and Match Case as desired, to narrow your search to a complete name or to match upper and lower case letters.
5. Click Find Next or Select All.

   The item or items are highlighted on the layout.

   Use the Find Next and Find Previous buttons to navigate from one found item to another. Each will be highlighted on the layout.

Viewing Assignments in Placement Mode

Placement Mode displays assignments at any stage of the design flow. These can include assigned sites, GROUPS, REGIONs, and reserved resources. After routing, all placements assigned by the Place & Route process are displayed.

The “Display” commands on the toolbar or the View menu control the display of assignments. The types of assignments displayed will depend on whether the commands “Display Placement,” “Display Placement Constraints,” or both are activated.

Assigned Sites  After placement and routing, the site a component has been assigned appears on the layout with a solid fill.

If the assignment originated from the HDL source, the site will be filled and overlaid with a cross-hatch pattern when both “Display Placement” and “Display Placement Constraints” are activated.
When only “Display Placement Constraints” is activated, an assignment originating from the logical constraint file or HDL source is displayed with the cross-hatch pattern but without the fill.

**Reserved Sites**  Sites reserved are displayed with a gray pattern.

**PLC Blocks (PFU and PFF)**  After placement and routing, a programmable logic cell (PLC) in which one or more logical components have been placed will appear on the layout with a solid fill. The color fill will be darker or lighter in shade, depending on how many sites are used.

As you zoom in so that individual slices are visible, only the slices that contain placed logical components are displayed with a color fill.
When Display Congestion is turned on, a highlighted rectangle is displayed that represents the amount of congestion for the row and column location. The tool tip shows the precise percentage of congestion.

**GROUPS**   Anchored GROUPS are displayed when both the “Display Placement Constraints” and “Display GROUPS” commands are activated. An anchored unbounded GROUP is indicated with a small square icon at the upper left of the assigned anchor location. The icon becomes visible as you zoom in.

A bounded GROUP is displayed with a solid border, corresponding to the assigned width and height, and a dotted pattern between blocks. GROUPS are distinguished from one another by their designated colors. After placement, the sites that contain the member elements of the GROUP are filled with the designated color when the “Display Placement Groups” command is activated.

**REGIONs**   REGIONs are displayed when both the “Display Placement Constraints” and “Display REGIONs” commands are activated. A REGION bounding box is shown with a solid border and a solid fill between blocks. It is distinguished from other REGIONs by its designated color. When a REGION
is reserved with the “Prohibit” command, it is overlaid with a gray dotted pattern.

See Also
- “Displaying Assignments and Connections” on page 220
- “Assigning Signals” on page 226
- “Creating GROUPs” on page 231

Going to a Specific Site
Placement Mode provides a “Go To Location” dialog box for quick navigation to a specific column and row on the layout.

To go to a specific site:
1. In Placement Mode, right-click an empty space on the layout and choose Go to Location.
2. In the dialog box, enter the desired Row and Column.
3. Click OK.
   Placement Mode zooms in to the location you specified.

See Also
- “Using the Zoom and Pan Tools in Device Constraint Editor” on page 193
- “Searching for Design Elements in Device Constraint Editor” on page 194

Physical Designer: Routing Mode
Routing Mode provides a read-only detailed layout of your design that includes switch boxes and physical wire connections. Routed connections are displayed as Manhattan-style lines, and unrouted connections are displayed as flylines. As you move your mouse slowly over the layout, the name and location of each REGION, group, component, port, net, and site are displayed as tool tips.

On the left hierarchy view in this tool, a user can do design exploration by the Logical tab whereby the netlist is hierarchy and signals exist at the module and instance level, or the Physical tab which displays a flattened netlist showing signals in the sub-module level.
Displaying Components and Connections The routing mode toolbar allows you to select the types of elements that will be displayed on the layout.

- Displays sites, unused or vacant blocks to which logic can be assigned.
- Displays components, blocks that have assigned logic.
- Displays routes, physical connections between resources on the chip after the design has been routed.
- Displays unrouted nets, those that PAR failed to route or those that could not be routed because a site associated with a net was unlocked by the user.
- Displays the latest timing path selected in Timing Analyzer.

Highlighting Elements Use the View menu's Highlight / Unhighlight commands to highlight or unhighlight selected nets or sites.

Viewing Highlighted Items, Prohibited Sites, and Labels Use the View menu's Layer commands to display highlighted items, prohibited sites, and the textual labels of sites and components.

Note
When the text display has been turned on, a label will sometimes overlap the edge of the symbol or even appear aligned with the symbol below it. However, when you hold the mouse pointer over the symbol, the correct label will appear in the tool tip.

See Also ▶ "Using the Zoom and Pan Tools in Device Constraint Editor" on page 193

Applying Radiant Software Physical Constraints

Radiant software constraint-editing views allow you to specify FPGA pre-synthesis constraints without having to write out logical constraints syntax manually. These views include Spreadsheet View, Package View, Netlist View of Device Constraint Editor and Placement Mode.

Setting Global Constraints

The Global tab in Spreadsheet View enables you to set constraints that affect the entire design, such as voltage, temperature, global BLOCK constraints, and configuration constraints. The list of these constraints varies by device family.

To set global constraints:

1. In Spreadsheet View, select the Global tab.
2. To perform a global edit, do one of the following:
   - Double-click the value and enter a new one.
     The table cell changes format. If the cell changes to a text box, type the new value. If it changes to a box with a pulldown menu, choose the value from the list.
   - Right-click the constraint value cell and select the desired value from the pop-up menu. For a text entry, choose Edit Cell, and then type the new value.

3. To return to the default value, highlight the value and press the Delete key or right-click the value and choose Clear.

Assigning Signals
Radiant software Spreadsheet View and Netlist View enable you to assign signals to pin locations. You can also assign signals by dragging them from Netlist View to pin locations on the Package View layout. Signals can be assigned or reassigned at any stage of the design flow.

Assigning Signals in Device Constraint Editor Spreadsheet View
Spreadsheet View provides two methods for assigning signals to pin locations:
   - Use the Port Assignments sheet to assign pins to listed signals. The Port Assignments sheet displays signals by port type and signal names.
   - Use the Pin Assignments sheet to assign signals to listed pins. The Pin Assignments sheet lists pins by pin, pad name, bank, dual function, and polarity.

Both views enable you to make single or multiple assignments.

Assigning Pins Using the Port Assignments Sheet
For a single pin assignment, double-click the pin cell for a given signal and type the desired pin name. For multiple pin assignments, use the Assign Pins dialog box, as explained below.

To assign pin locations:
1. From the Pin column, select the pin cells of the signals to assign.
   To select multiple pin cells, do one of the following:
     - Drag down the pin column or use the Ctrl+click or Shift+click combination.
For a bus, open Device Constraint Editor View and detach it. Select the bus from the Ports list of Netlist View widget and drag it to the Port Assignments Sheet of Spreadsheet View in the lower half. All the rows for the bus signal names become highlighted.

2. Right-click the selected cells in the Pin column and choose Assign Pins.

In the Assign Pins dialog box, the signals you selected are displayed in boldface in the left pane. In the pin list next to it, the same number of pins are displayed in bold at the top of the list. The software automatically interprets the design files and displays the pin filters that should be enabled by default. For example, if you selected an LVDS25 type of port in Spreadsheet View, the polarity section on the right will show the True P-side filter as enabled. If you selected a BLVDS type of port, it shows the Emulated P-side filter as enabled.

3. Clear or select the desired options under Pin Types to narrow or expand the list of available pins, and then select Auto Sort or Manual Sort.

   - If Auto Sort is selected, select the desired sorting option under “Sort by,” and then select Ascending or Descending order.
   
   - If Manual Sort is selected, use one of the following methods to drag pins and place them in the desired order:
     - Click one pin to select it, and then drag it to the desired location.
     - Use the Shift key to select several pins at once and release the mouse button. Next, drag the highlighted pins to the desired position.

4. From the pin list, select the pin location where you would like the assignment to begin.

   The dialog box highlights the selected pin and displays in bold type the sequence of pins following it—one for each signal

5. From the Assign Pin pulldown menu at the bottom left, select one of the following Assign Pin options: every, every second, every third, or every fourth pin.

6. To check the validity of the selected pin assignments, click Check Pins.

   A message box appears that lists any assignment errors. If errors are reported, repeat Steps 4–6 until the pin check is free of errors.

7. Click Assign Pins.

Modifying Assignments in Device Constraint Editor Spreadsheet View

You can modify pin assignments in Spreadsheet View before or after placement and routing. After routing, you can also modify assignments that automatically made by the Place & Route Process.
To modify assignments:

1. From the Port Assignments sheet or Pin Assignments sheet, select the assignments that you want to modify, right-click, and choose Assign Pins or Assign Signals.

2. Follow the same procedure for assigning pins or signals in Spreadsheet View.

To modify assignments made automatically by Place & Route:

1. Choose View > Display IO Placement.

   All placed and routed assignments are displayed in parentheses, including user assignments. User assignments appear twice—once without parentheses and once in parentheses—and they are displayed in black font or the font color that has been designated for “Normal” in the options dialog box. Assignments that were made automatically by Place & Route appear only once. They are displayed in parentheses and are distinguished by blue font or the font color designated for “Default Values.”

2. Select the assignments made by Place & Route that you want to modify, right-click, and choose Assign Pins or Assign Signals.

3. Follow the same procedure for assigning pins or signals in Spreadsheet View.

   The assignments are now displayed in black font. Those that were assigned by Place & Route appear in parentheses, preceded by the new assignments.

To remove assignments:

- Select the assigned pins or signals that you want to delete, and press the Delete key. Optionally, right-click the selected assignments and choose Clear.

   Note

   Only user assignments can be deleted. Assignments made automatically by Place & Route can be modified but not deleted.

Modifying Signal Assignments using the Device Constraint Editor

Device Constraint Editor enables you to use drag-and-drop to move one or more signal assignments to unlocked pins. It also allows you to move a single signal assignment to a pin that is already locked as well as swap the two assignments.

To modify one or more assignments:

1. Select the device pins on the layout that contains the assignments you want to modify.
To select only one pin, click it to highlight it. Use the Ctrl or Shift key or to select more than one pin, or drag your mouse around multiple pins to select them.

2. Move the mouse toward the desired unlocked pin location.

As you begin to drag, the cursor displays a crossed-out circle symbol. The cursor changes to an arrow as you move it over valid pins. Keep dragging until you have reached the targeted location.

3. When the cursor displays the arrow symbol over the targeted location, release the mouse button.

**Note**

If you are modifying a single assignment, make sure that the pin is highlighted before dragging it. If you try to drag a pin before it is highlighted, you will activate the multiple selection tool.

---

**To remove assignments:**

1. Select the pins that contain the assignments you want to remove.

2. Right-click the selected pins and choose **Unlock**.

**See Also**

- "Assigning Signals in Device Constraint Editor Spreadsheet View" on page 226
- "Modifying Assignments in Device Constraint Editor Spreadsheet View" on page 227
- "Prohibiting Incompatible Pins" on page 230

---

**Modifying Signal Assignments in Placement Mode**

In Placement Mode, you can modify a signal assignment by dragging it from one Constraint to another. You can also modify an assignment that originated from the logical constraint file (.pdc) or one that was made automatically by Place & Route (PAR).

**To modify a signal assignment in Placement Mode:**

1. Choose **Tools > Physical Designer**.

2. Make sure that the “Display Placement” button is turned on if you will be modifying a PAR-assigned I/O.

3. In Placement mode, zoom in so that you can easily view the placed Constraint component that you want to reassign and the targeted location.

   Constraint components that were assigned automatically by PAR are displayed with a solid color fill. Constraint components whose assignments originated from the .pdc file are displayed with a color fill and a cross-hatch overlay.

4. Drag from the assigned site to the targeted location and release the mouse button.
The previous location is now displayed with a fill and no cross-hatch, and the targeted location is displayed with the cross-hatch and no fill.

**Setting Port, Net, and Cell Attributes**

Spreadsheet View’s Port Assignments Sheet, Clock Resource sheet, Route Priority sheet, Cell Mapping sheet, and Global constraints sheet enable you to set attributes for ports, nets, and cells. They allow you to set I/O port attributes, assign net priorities, specify registers for flip-flops, and set junction temperature and voltage.

**Defining I/O Defaults**

The Radiant software allows you to set values for all ports in your design at once. You can do this by using the ALLPORTS selection, which is available in the Spreadsheet view section of Device Constraint Editor.

**Defining I/O Defaults Using ALL PORTS**

The ALL PORTS row in Device Constraint Editor’s Spreadsheet View’s Port Assignments sheet enables you to quickly define a default setting for I/O attributes. It can be especially useful for setting the I/O type default.

**To define default settings Using ALL PORTS:**

1. In Spreadsheet View in the Device Constraint Editor, select the Port tab.
2. Double-click the desired attribute cell in the ALL PORTS row and select a value from the pulldown list. Optionally, right-click the cell and select a value from the pop-up list.

   The newly selected value is displayed in orange, or the font color designated for “Reference Value,” for all of the ports that do not have other values already assigned.

   **Note**

   The range of attribute values available with the ALL PORTS row reflect the intersection of valid values across all port types. To access all available values, use individual ports or port groups.

   You can return to the original default setting by selecting the attribute cell and pressing the **Delete** key.

**Prohibiting Incompatible Pins**

Both Spreadsheet View and Package View of Device Constraint Editor enable you to create a PROHIBIT constraints for selected incompatible pins or all incompatible pins. Prohibiting incompatible pins will prevent you from assigning signals to them. It will also prevent the Map and Place & Route
processes from using these incompatible pins. When you prohibit incompatible pins, none of the pins that have already been assigned will become unlocked.

To prohibit one or several incompatible pins:

> On the Pin Assignment sheet of Spreadsheet View or in Package View, select the incompatible pins that you want to prohibit. Right-click, and choose Prohibit.

To release one or several incompatible pins:

> On the Pin Assignment sheet of Spreadsheet View or in Package View, select the prohibited pins that you want to release. Right-click and choose Release.

Creating GROUPs

The GRP constraint consists of logical components that are to be packed close together. GROUPs can include PFU, PFF, EBR, and DSP blocks. You can create GROUPs in Spreadsheet View, Netlist View and Placement Mode. After placement and routing, Placement Mode displays the group member elements with the GROUP color fill.

Note

A GROUP must be anchored if it includes a DSP block. If such a GROUP is not anchored, the Radiant software will issue a warning and ignore the DSP block.

Creating GROUPs in Netlist View in Device Constraint Editor

To create a GROUP in Spreadsheet View:

1. Right click on Netlist View on Ports (Input or Output).
2. Click on Create Port Group.
3. A new Group dialog appears. You can now move available ports to selected ports.
4. After entering a Group name, this constraint will be saved in the ..pdc file as a ldc_create_group constraint.

Creating GROUPs in Placement Mode

In Placement Mode, you can draw a bounding box for a new GROUP, and then select the instances to be included. For routed designs, you can create a GROUP from selected components displayed on the layout.

To create a GROUP bounding box and add instances:

2. Zoom in, as needed, to the desired area on the floorplan layout.
3. Right-click and choose Create GROUP BBox.
The mouse pointer changes from an arrow to a cross symbol.

4. Draw a rectangle around the sites where you want to place the GROUP. Make sure that the bounding box does not overlap the bounding box of another GROUP or REGION.

When you release the mouse button, the Create New GROUP dialog box opens. In the Anchor and BBox sections, it shows the anchor site location and the bounding box size, based on the rectangle you drew on the floorplan. Under GROUP Name, the resources covered by the bounding box are shown: LUTs, registers, and EBRs.

**Note**

A GROUP must be anchored in order to be displayed in Placement Mode.

5. In the boxes at the top of the dialog box, specify a name for the GROUP and select a color.

6. From the list of Available Instances, select those that you want included in the GROUP.

   - Use a string and wildcards (asterisk or question mark) in the Filter text box to narrow the list.
   - Use the Ctrl or Shift key to select multiple instances from the full or filtered list.

7. Click the > button to move the selected instances to the Selected Instances list. Click the >> button to add all instances to the Selected Instances list.

You can further modify the group membership by moving elements between the Available Instances and Selected Instances lists.

8. Click **Add**.

   The new GROUP is displayed in Placement Mode with a bounding box in the color you selected. The new GROUP is added to the Group constraint sheet in Spreadsheet View.

**To create a GROUP from selected placed components in Placement Mode:**

1. In Placement Mode, **zoom in** to the desired area as needed.

2. Select the placed components that you want to include in the GROUP. These can include PFU or PFF slices, EBR blocks, or DSP blocks.

   **Note**

   To view the precise logical identifiers for a PFU or PFF slice, select it on the layout and cross-probe to Netlist View.

3. Right-click the selected components and choose **Create GROUP**.

   The Create New GROUP dialog box opens. In the Selected Instances list, the placed components from the blocks you selected in Placement Mode are shown.
4. In the boxes at the top of the dialog box, specify a name for the GROUP and select a color.

5. To select a different anchor location, select either Region or Site.
   - For Region, select a REGION from the pulldown list. Regions must already be defined in order for them to appear on the list.
     When Region is selected, the group will float inside the selected REGION.
   - For Site, specify the column and row for the anchor. The allowable range is shown in parentheses above each box.
     When Site is selected, the specified site will serve as the northwest corner anchor location.

6. To define a different size for the group’s bounding box, specify the number of columns and rows that the GROUP’s bounding box should cover. The allowable range for height and width is shown in parentheses above each box. Make sure that the bounding box does not overlap the bounding box of another GROUP or REGION.
   The group’s revised resource coverage is now displayed at the top under GROUP Name, including the number of LUTs, registers, and EBRs.

7. Click Add.
   The new GROUP is displayed in Placement Mode with a bounding box in the color you selected, and it is added to the Group constraint sheet in Spreadsheet View.

Grouping Components Along an Individual Signal
In Placement Mode, you can group components along an individual signal of a timing path by cross-probing a signal from Timing Analyzer to Placement Mode. From Placement Mode, you can then select the components along the displayed connection to create a new GROUP.

To group components along an individual signal:
1. After placement and routing, choose Tools > Timing Analyzer.
2. In the timing constraint list in the lower left pane, expand Analysis Results, and then select the desired timing constraint.
   The path table opens in the upper right pane.
3. Select a signal from the path table, right-click, and choose Show in > Placement Mode.
   The connection is highlighted in Placement Mode.
4. While holding the Ctrl key, click each component related to the net.
5. Right-click the selected components and choose Create > GROUP.
   The Create New GROUP dialog box displays the anchor location and bounding box size of the components you selected, and lists the instances in the Selected Instances pane.
6. In the top part of the dialog box, assign a name to the GROUP. Click the color box to assign a different color.

7. Click Add.

The new GROUP is displayed in Placement Mode with a bounding box in the color you selected. The new GROUP is added to the Group constraint sheet in Spreadsheet View.

See Also ►“Using Timing Analyzer” on page 283

Modifying GROUPs

Use the Edit GROUP Property dialog box to quickly modify the name, color, and membership of a group constraint. You can access the dialog box from the Placement Mode. You can also use Placement Mode to delete a GROUP, or you can use the Group constraint sheet to delete a GROUP or GROUP elements.

To modify a group constraint:

1. To access the Edit GROUP Property dialog box, do one of the following:
   - In the Group sheet of Spreadsheet View, double-click the group you want to modify or right-click the group and choose Modify.
   - In Placement Mode, zoom in to the GROUP and click the border or an empty space inside so that the group’s border is highlighted. Right-click and choose Edit GROUP.

2. In the dialog box, make the desired changes and click Update.

To remove elements from a group on the Group constraint sheet:

1. Select the Group constraint sheet and expand the desired GROUP.
2. Select the group elements you want to remove, right-click, and choose Remove GROUP Elements.

To delete a group constraint on the Group sheet:

► Right-click the group you want to delete and choose Delete, or press Delete.

To delete a GROUP using Placement Mode:

1. Zoom in to the GROUP and click the border or an empty space inside so that the group’s border is highlighted.
2. Right-click and choose Remove GROUP.

See Also ►“Creating GROUPs” on page 231
Resizing or Moving a GROUP in Placement Mode
You can resize a GROUP or change its anchor location in Placement Mode.

To resize a GROUP using Placement Mode:
1. In Placement Mode, zoom in to the GROUP and select it by clicking the border or an empty space inside. The border becomes highlighted, and you should see small circles on the GROUP’s border—one in each corner and one on each side.
2. Position your mouse pointer over one of the corner or side circles.
   The cursor symbol changes to a double-headed arrow.
3. Drag the border outward or inward until the bounding box contains the sites you want to include.
   Placement Mode displays the new bounding box dimensions. The Group sheet in Spreadsheet View shows the updated dimensions.

To change the GROUP’s anchor location:
1. Zoom out until you can view the current location on the layout and the targeted location.
2. Click the GROUP’s border or an empty space inside it so that the border is highlighted.
   The crossed arrows symbol should immediately appear. If it does not, move your mouse pointer very slightly until it does.
3. Hold down the left mouse button, drag the GROUP box to the targeted location, and then release the mouse button.
   Placement Mode displays the GROUP in its new location. The Group sheet in Spreadsheet View shows the updated location.

See Also ▶ “Creating GROUPs” on page 231

Constraint Conflict Resolution
When more than one constraint is ascribed to a single design element, some constraints will take precedence over others, depending on the level of specificity, the order of the conflicting preferences, and redundancy between the HDL source and the Lattice design constraints file (.ldc). The software resolves such conflicts by adhering to the following rules of precedence:

▶ Timing constraints that have a higher priority than others take precedence when the same design objects are constrained in two or more preferences.

See “Timing Constraints Priority” on page 236

▶ When more than one constraint applies to a net or path, more specific preferences are honored before less specific ones. For example, individual net/path constraints supersede group (bus) constraints, and group constraints supersede global constraints.
When more than one constraint at the same specificity level exists for a block/comp/net/path, the constraint that occurs last in the constraint file takes precedence.

When an attribute in the HDL conflicts with a constraint in the Lattice design constraint file, the constraint in the .ldc file has precedence. For example, when a given register is included in both a GRP attribute and a logical constraint definition, the logical constraint is honored.

See “Conflicting HDL Attributes and Constraints” on page 237

GRPs in the HDL do not appear in the .ldc unless they have been modified and saved to the .ldc file. Afterwards, the groups in the .ldc file take precedence over those in the HDL. Conversely, logical groups created in the Radiant constraint views are kept in the .ldc file and are not back annotated to the HDL design file.

When two or more GRPs are identified with the same name in the .ldc file, the group that appears last is honored.

When different GRPs in the .ldc file contain one or more of the same members, the GRP that appears last is honored.

### Timing Constraints Priority

The timer uses the following priorities for timing constraints. The highest priority is given to constraints that completely block a path. Under this category we have the set_false_path and the set_clock_groups constraints. Next in line are the timing exception commands. These are the set_max_delay, set_min_delay and set_multicycle_path constraints. These constraints are prioritized by their options from highest to lowest as follows:

1. From pin/port/cell, through pin/net/cell and to pin/port/cell
2. From pin/port/cell and to pin/port/cell
3. From pin/port/cell, through pin/net/cell and to clock
4. From pin/port/cell and to clock
5. From pin/port/cell and through pin/net/cell
6. From pin/port/cell
7. From clock, through pin/net/cell and to pin/port/cell
8. From clock and to pin/port/cell
9. Through pin/net/cell and to pin/port/cell
10. To pin/port/cell
11. From clock through pin/net/cell to clock
12. From clock to clock
13. From clock through pin/net/cell
14. From clock
15. Through pin/net/cell to clock
16. To clock
17. Through pin/net/cell

The set_input_delay and set_output_delay affect the arrival and required times at the design boundaries. The set_clock_latency and set_clock_uncertainty affect the arrival time and behavior of the edges of the clocks.

When multiple IO constraints with the same clock are used on an output port, the last constraint will take priority. Also, when the -add_delay is used, the worst constraint will take precedence. the worst case timing for setup and hold are not the same.

Physical Constraints Priority

Conflict Between ldc_set_location of ldc_create_group and ldc_set_location

The following example contains a combination of group and location constraints that conflict:

ldc_create_group -name Group_0 -bbox {9,9} [get_cells {I1 I2}]

ldc_set_location -site {EBR_R36C6} [ldc_get_groups {Group_0}]

ldc_set_location -site {EBR_R36C22} [get_cells {pdp_ram_o}]

The Group_0 contains two RAMs of the design. One RAM (EBR) named pdp_ram_0, is placed at a specific EBR device site (EBR_R3C22) using the ldc_set_location constraint.

When the place and route program encounters this condition, it honors the ldc_set_location on the specific instance constraint. A warning will be issue to let the user know that the instance is discarded from the ldc_create_group constraint.

Conflicting HDL Attributes and Constraints

Using a combination of HDL attributes and constraints is a powerful technique for constraining the implementation tools. However, it is possible to introduce a combination of HDL attributes and logical constraints that are redundant and in conflict with each other. When such conflicts occur, the constraint in the .ldc file takes precedence.

Conflicting Pin Assignments: When there is a conflicting pin assignment between the HDL and the constraint file, the assignment in the constraint file will take precedence. For example, SPI_PIN_D has a LOC attribute of W25 in the source file. Later, in Spreadsheet View, the pin is assigned to site U21 and saved to the .ldc file. When the design is placed and routed, the U21 location is honored instead of the W25 assignment. The only way to return to the original W25 site assignment is to delete the ldc_set_location constraint from the .ldc file.
The following is an HDL example of conflicting pin assignments:

Input SPI_PIN_D /* synthesis LOC = "W25" */;

The following is an LPF example of conflicting pin assignments, which overwrites HDL:

ldc_set_location -site {U21} [get_cells {SPI_PIN_D}] ; (this is LDC, it over-rides HDL))

The same is true for ldc_set_port -iobuf attributes. For example, the HDL assigns “my_signal” to L5 with OPENDRAIN set to ON. Later, OPENDRAIN is changed to OFF in Spreadsheet View. The pin assignment remains at L5, and the OPENDRAIN setting of OFF is honored.

Redundant GRP Declarations  In the following example, two group constraints with the same name contain different members:

Figure 25:

```
ldc_create_group -name Group_1 [get_cells {reg6 reg7}]
ldc_create_group -name Group_2 [get_cells {reg6 reg7}]
```

During place and route, an error will occur in the place and route report and terminate the process.

Conflict between ldc_create_group and ldc_set_location  The following example contains a combination of group and location preferences that conflict:

Figure 26:

```
ldc_create_group -name Group_0 -bbox {9,9} [get_cells {I1 I2}]
ldc_set_location -site {EBR_R36C6} [ldc_get_groups {Group_0}]
ldc_set_location -site {EBR_R36C22} [get_cells {pdp_ram_0}]
```

The Group_0 contains two RAMs of the design. One RAM (EBR) named pdp_ram_0, is placed at a specific EBR device site (EBR_R3C22) using the ldc_set_location constraint.

When the place and route program encounters this condition, it honors the ldc_set_location of the ldc_create group constraint. No warnings or errors are generated. See Also

▶ “Timing and Physical Constraints” on page 168

**Checking Design Rules**

The Radiant software provides DRC, which enables you to validate I/O placement, logic, and routing.
During load time and initialization, the Radiant software constraints views interpret the database and constraint files in a similar manner as the Map and Place & Route processes. Syntax or semantic violations within the ..ldc and ..pdc files are also treated in a manner similar to the Map and Place & Route processes. Illegal constraints are ignored but retained in the logical and physical constraint files. The Radiant software loads and applies the legal subset it detects and displays error and warning messages.

After the project is loaded, the Radiant software provides access to on-demand and real-time Constraint DRC Check. All DRC reports are presented in the Output window for the current session.

See Also  ➤“Constraint DRC” on page 239

**Constraint DRC**

Constraint DRC can catch many common errors and prevent wrong pin usage at the early stage of the design process, and helps you ensure that design I/Os are assigned correctly before the design is mapped, placed, and routed. This can dramatically reduce design errors, help you meet timing requirements, optimize for both the FPGA and printed circuit design, and reduce the number of design iterations.

Constraint DRC performs logical and physical tests to validate I/O placement such as signal standard and VCCIO combinations bank by bank, true and emulated LVDS combinations, VREF requirements, and potential conflicts with user assignments made to multi-function pins like those of the sysCONFIG interface. It is available as real-time and on-demand DRC.

Constraint DRC now displays all of its messages in the Radiant software Output window.

See Also  ➤“Performing On-Demand Constraint Design Rule Check” on page 239

**Performing On-Demand Constraint Design Rule Check**

The Constraint DRC feature validates pin assignments to banks based on legal combinations of signal standards, including true and emulated LVDS combinations. The Radiant software performs immediate real-time Constraint DRC on any constraint changes. But you can run Constraint DRC on the entire design after modifying constraints, by running on-demand Constraint DRC.

To perform Constraint design rule checking:

1. From the Radiant software Tools menu, select **Device Constraint Editor**. The following views are available:
   ➤ Spreadsheet View
2. Choose **Design > Constraint DRC**.

   The Radiant software checks the I/Os. A message box reports whether errors or warnings were encountered. A log of errors and warnings appears in the Output window.

**See Also**  
▸ "Constraint DRC" on page 239  
▸ "Modifying Assignments in Device Constraint Editor Spreadsheet View" on page 227

### Post-Map DRC Check

In the post-map stage, DRC performs the following logical and physical tests:

- Block
- Net
- Pad
- Clock Buffer
- Name
- Primitive Pin

Reported errors from DRC indicate conditions where routing or component logic does not operate correctly.Warnings indicate conditions where routing or logic is incomplete or the condition is incorrect but not serious. Some conditions listed as warnings might be reported as errors when DRC is performed by the Generate Bitstream Data (bitgen) process.

Post-Map DRC Check is available in the post-map or post-PAR stage in the Spreadsheet View, Package View, Device View in Device Constraint Editor and Placement Mode.

**See Also**  
▸ "Performing On-Demand Constraint Design Rule Check" on page 239

### Analyzing SSO

For many FPGA devices, Radiant enables you to run an analysis of simultaneous switching outputs (SSO). SSO analysis describes the noise on signals caused by a large number of out drivers that are switching at the same time. When multiple output drivers change state at the same time, the changing current in the power system induces a voltage that results in power supply disturbances. These disturbances, or noise, can cause undesired transient behavior among output drivers, input receivers, or internal logic. Analysis of simultaneous switching outputs helps ensure that your I/O plan meets the I/O standards and power integrity requirements of the PCB design.
**SSO Calculator**  The SSO calculator estimates Simultaneous Switching Noise (SSN) affecting a victim pin according to the switching characteristics of aggressor pins. It does this either on a victim-pin-by-victim-pin basis (Pin Analysis) or on the basis of the worst-case victim pin placement in each bank (Bank Analysis). In many cases, adjusting the location of aggressor pins relative to victims can help mitigate noisy conditions. Noise is characterized by the calculator as ground bounce or voltage drop depending on the type of analysis run. The calculator will produce worst-case bank-based ground bounce results for those banks that have partial signal assignments, and it will produce a more accurate pin-based ground bounce and voltage drop results if all signals of a bank are assigned.

The following calculation is made for a victim pin (in Bank-based Analysis, the worst case victim is used for each bank):

Pass/Fail status: Fails if \((\text{Total Noise}) > (\text{Pass/Fail criteria}) \times \text{ALLOWANCE}\)

where:

\[
\text{Total Noise (mV)} = \text{Board Noise} + \text{Device Noise}
\]

Board PCB Noise can be on the ground plane, for ground bounce calculations; or it can be on the power plane, for Vcc drop calculations. PCB estimated ground plane noise is entered as \(+X\) mV. PCB estimated power plane noise is entered as \(-X\) mV.

Device noise is the maximum noise imposed on a victim pin by each of the aggressor pin groups. Aggressor groups are specified by using SwitchingID assignments. Reports show which aggressor group is causing the most noise on a victim.

The Pass/Fail criteria is based on the IO_TYPE of the victim. SSO allowance is a user override that adjusts the pass/fail criteria, where default is no change to the pass/fail criteria (100%).

**SSN Accuracy**  SSO calculator estimations are based off of hardware data collected during characterization. The measurements were taken using Lattice test PC boards with signal loading on individual banks. Because the total SSN is a function of PCB ground and board inductance, care must be given to apply accurate SSO preferences based on the parasitic inductances of your system environment.

**About Pin-Based Analysis Reports**  Pin-based analysis produces estimates for ground bounce and voltage drop SSN per pin. Pin-based analysis is performed after design signals have been assigned to pins. These pin assignments can be made by setting preferences or by placing and routing the design. The analysis calculates the noise that each pin, as a victim, experiences. It reports the pass/fail status of each pin and where the noise originates—the aggressor group identified by SwitchingID.

**About Bank-Based Analysis Reports**  Bank-based analysis produces ground bounce SSN per bank. When at least one signal is assigned only to a bank and not to a pin, bank-based calculation is performed. Compared to pin-based analysis, bank-based analysis assumes worst case placement in the
APPLYING DESIGN CONSTRAINTS

Analyzing SSO

bank for the victim and set of aggressors. Any placement information that does exist is ignored, and worst-case placement is used.

For both Pin-based and Bank-based analysis, pins or banks programmed for signal standards (IO_TYPE) other than those that the calculator supports are ignored.

Addressing SSN Problems  The SSO calculator is a good tool for confirming the quality of an I/O plan. After legal signal assignments have been verified and placed using the I/O Assistant strategy, use the SSO calculator to adjust relative placement where SSN margins are exceeded.

The following adjustments to your I/O plan can help avoid SSN problems:

- Spread aggressors away from victim pins. Use the “Assign Pin” feature of the Assign Pins dialog box in Device Constraint Editor View to stagger package pin assignments.
- Use slow slew outputs.
- Use lower drive strengths

Note

See Also  ▶ “Running SSO Analysis” on page 242
▶ “Viewing SSO Analysis Results” on page 243

Running SSO Analysis

For bank-based SSO analysis, the SSO calculator requires a SwitchingID that indicates the output drivers that will be switching in parallel, and the banks to which the drivers will be assigned. For pin-based analysis, the SSO calculator also requires detailed signal-to-pin placement. You can specify these parameters in the Port Assignments sheet of Device Constraint Editor View at any stage of the design flow. The more complete your assignments, the more accurate the analysis results will be.

Because the SSO calculator uses the in-memory state of constraints, you are not required to save the SSO parameters in order to run an analysis. This enables you to experiment with placement and other parameters before committing a change to the physical design constraint file (.pdc).

To run SSO analysis:

1. In a generic sense, you can edit SSO values in:
   - The Device Constraint Editor View as indicated from Step 4 onward.
In the "Pre / post-synthesis Timing Constraint Editor" on page 209 you can set values in the Load Capacitance tab. Note that change in SSO values will be saved in the physical design constraint file (.pdc).

2. In Device Constraint Editor View, select the Port Assignments tab.

3. Assign pin locations or just the bank locations to the output or bidirectional signals that you wish to analyze.

4. Select from the following attributes for each signal to be analyzed:
   - an appropriate I/O buffer from the IO_TYPE column
   - a drive strength for the output buffers from the DRIVE column
   - a slew rate from the SLEWRATE column

5. Specify settings in the following SSO columns for each signal to be analyzed:
   - SwitchingID – Type an alphanumeric value to identify the aggressor output drivers that can switch at the same time.
     If you do not specify a Switching ID, the Default_ID will be assigned to all output pins.
   - Ground plane PCB noise – Type a floating point value to specify the millivolt units of estimated board noise for bounce.
   - Power plane PCB noise – Type a floating point negative value to specify the estimated board noise for drop.
   - SSO Allowance – Specify an allowable percentage of SSO per bank.
     If any of the settings are estimated to be the same for all output signals, you can use the Allports row to quickly set the values for all outputs.

6. Once you save entered values either from either Device Constraint Editor (DCE) tool or the Pre-Synthesis Timing Constraint Editor, the constraints are written and saved in the physical design constraint (.pdc) file.

7. In the Process bar, re-run Map Design and re-open DCE to see new SSO analysis results.

To view the full I/O SSO Analysis Report, select the Reports tab > Misc Reports > I/O SSO Analysis.

If some of the pin or bank assignments failed the analysis, adjust the assignments or parameters to try to reduce the SSO noise. Afterwards, rerun the Map Design.

See Also  ► “Viewing SSO Analysis Results” on page 243
   ► “Analyzing SSO” on page 240

Viewing SSO Analysis Results
To view results, you can open the I/O SSO Analysis Report in the Reports tab or view it directly in the Device Constraints Editor > SSO tab.
To view the SSO Analysis Report:

- In the Report tab, expand the Misc Reports folder and select I/O SSO Analysis.

The SSO Analysis Report is organized by “Bank SSO Results” and “Pin SSO Results.” Each of these sections is further organized according to the type of change in current—ground bounce or drop—that is caused by the switching aggressor pins.

**Bounce** – When the aggressor pins switch from high to low, the power supply needs to sink current. If a large amount of current needs to be sunk, the ground level will start to rise. This rise in current is the ground bounce.

**Drop** – When the aggressor pins switch from low to high, the power supply needs to source current. If too much current is required, the VCC level will start to drop temporarily as the charge is supplied. This initial drop is the VCC drop. As the charge is supplied, the VCC level starts to go back up to the proper VCC level.

The “Pin SSO Results” section also contains hyperlinks to details organized by pin and bank.

To navigate to bank and pin details in the SSO Analysis Report:

- Click the desired bank number in the “Worst Bounce SSO of each Bank” section or the “Worst Drop SSO of each Bank” section to jump to the appropriate table in “SSO Information of Pins of each Bank”.
- Click a signal name in one of the tables of “SSO Information of Pins of each Bank” to jump to the detailed SSO Report by pin.

To view the SSO information for each output pin in Device Constraint Editor View:

1. In Device Constraint Editor View, choose SSO tab at the bottom of the window.
   - On the pin layout, the SSO pins are highlighted with the status color. Those that failed the analysis are highlighted in red.
2. Hold your mouse pointer over an SSO pin to view the tool tip.
   - The tool tip for each pin includes information from the SSO Analysis Report.

See Also

- “Analyzing SSO” on page 240
- “Running SSO Analysis” on page 242

Exporting an SSO Report in CSV Format

After placement and routing, you can use Package View to export an SSO report as a comma-separated value file (.csv).
To export an SSO report in CSV format:

2. In the dialog box, browse to the desired directory for the report.
3. Type a name in the file name box and click Save.

The SSO report is saved as a .csv file in the location you specified. You can view the report using a spreadsheet program that supports the CSV file format.

See Also  ➤ “Running SSO Analysis” on page 242

Exporting Pin Files

The Design Constraint Editor Spreadsheet View supports delimiter-separated text formats, such as comma-separated value (CSV), to ease the viewing and editing of assignments and attributes. It also supports the exportation of a text version of all Spreadsheet View constraints. The following options are provided for exporting the contents of constraint sheets:

- **Pin Layout File**  A pin layout file is a customizable report of pin information for your design. You can open the file in an external spreadsheet application for editing, and then import the edited pin layout file back into Spreadsheet View.

- **Pinout File**  A pinout file is a comprehensive report, in CSV format, of all available and unbonded pins in the device.

See Also  ➤ “Exporting a Pin Layout File” on page 245

Exporting a Pin Layout File

A pin layout file is a customizable report of pin information for your design. Depending on the stage of the design flow, the pin layout file can be as simple as a list of available pins, pad names, functions, and banks. Or it might be a more detailed report that includes differential polarity, type, user assignments, default attributes, and custom column information. Finally, it can be a comprehensive report that also includes PAR assignments. You select the types of information you want included in the file, specify the order of presentation, and select the delimiter to be used as the value separator.

You can obtain a pin layout file from Spreadsheet View at any stage of the design flow. When you later import a pin layout file back into Spreadsheet View, all the information that was saved in the file is displayed.
To export a pin layout file:

1. In Spreadsheet View, save any assignments that are still in memory, and then choose **File > Export Pin Layout File**.

The Export Pin Layout File dialog box opens and displays a list of all items that can be included in the report. Any custom columns that have been created are listed last, and you might need to scroll down to view them.

2. Select the items from the list that you want to appear as column headings in the file. Clear those that you do not want included.

**Note**

*Pin_Number, Pad_Name, Function, and IO_Bank_Number cannot be cleared. These items will always be included in the pin layout file.*

If you select Pin Migration, a Migration column for each device that you selected in the Incompatible Pins dialog box will be included in the report. In each of these columns, a Y or N will indicate which pins are compatible or incompatible. The incompatible selection in the tab will affect the export result.

3. Select a value separator that will be used to separate the data into columns: comma, semicolon, space, or tab.

4. If you want the default values to be included for the user-assigned signals in the report, select the **Export Default Value** option. If you do not want the default values included, clear this option.

**Note**

*If your design has already been placed and routed, the Export Default Value option will be dimmed.*

5. Do one of the following:

   - To export the pin layout file to your current project directory, type a name in the File Name box. If you are using the comma as the delimiter, include the .csv extension.

   - To export the pin layout file to a different directory, click **Browse**, navigate to the desired directory, and type a name in the File name box. If you are using a delimiter other than the comma, choose **All Files** from the “Save as type” drop-down menu; otherwise, keep the default .csv extension. Click **Save**.

6. Click **OK**.

The pin layout file is saved to your project directory or to the directory you specified. When you open the pin layout file in a spreadsheet program, the columns will appear in the order you selected, including any custom columns. You can edit the cell contents of the columns as desired and import the file back into Spreadsheet View.

**See Also**

- “Exporting a Pinout File in CSV Format” on page 247
- “Migrating Pin Assignments” on page 171
Exporting a Pinout File in CSV Format

The pinout file is a report of all device pins in the targeted device. It includes information such as pin/ball function, pin number, type, bank, dual function usage, and differential type. Information is included for all available pins and unbonded pins. The file is exported in comma-separated value (.csv) format, which enables you to examine it in an external spreadsheet application. You can export a pinout file from Device Constraint Editor at any stage of the design flow.

To export a pinout file:

1. In Spreadsheet View, choose File > Export > Pinout File.
2. In the “Export Pinout File” dialog box, specify the file name and location that you want, and then click Save.
3. The information is saved as a .csv file with the name and location you specified. You can view the file using a spreadsheet program that supports the CSV file format.

Note

The pinout file cannot be imported into Spreadsheet View.

See Also  ► “Exporting a Pin Layout File” on page 245
Design implementation includes the processes of:

- Synthesizing and translating the design to build the internal database.
- Mapping the design to device-specific components.
- Assigning the mapped components to specific locations.
- Establishing physical connections that will join the components in an electrical network.

The Radiant software environment enables you to set options for each of these processes to help optimize results, including placement effort level. These options are available in the active strategy for the design. For descriptions of all design implementation process options, see the “Strategy Reference Guide” on page 516.

See Also

- “Using Strategies” on page 34
- “Synthesizing the Design” on page 248
- “Mapping” on page 255
- “Place and Route” on page 261
- “Applying Design Constraints” on page 164
- “Command Line Reference Guide” on page 904

**Synthesizing the Design**

Synthesis is the process of translating a register-transfer-level design into a process-specific, gate-level netlist that is optimized for Lattice Semiconductor FPGAs.
In different ways, Radiant software can be used with almost any synthesis tool. The Radiant software comes with two tools fully integrated: Synopsys Synplify Pro for Lattice and Lattice Synthesis Engine (LSE). “Fully integrated” means that you can set options and run synthesis entirely from within the Radiant software. If you prefer, you can use other synthesis tools by running them independently of the Radiant software.

Synthesis tools can be run three ways with the Radiant software:

► Integrated synthesis is the simplest way. You work entirely within the Radiant software. See “Integrated Synthesis” on page 253.

► Interactive synthesis provides much greater control of how synthesis is done. You set up a design project in the Radiant software, but set up and run synthesis directly in the synthesis tool. See “Interactive Synthesis” on page 254.

► Stand-alone synthesis allows use of other, non-supported synthesis tools. You set up and run synthesis directly in the synthesis tool and then the Radiant software imports the result. See “Stand-Alone Synthesis” on page 255.

LSE can only be run in integrated synthesis.

Whichever method you use, see “Pre-Synthesis Check List” on page 249 to make sure your project is ready to synthesize.

See Also

► “Selecting a Synthesis Tool” on page 58

► TN1008, “HDL Synthesis Guidelines for Lattice Semiconductor FPGAs” for how coding style influences performance and area utilization

► Synopsys Synplify Pro for Lattice User Guide

► Synopsys Synplify Pro for Lattice Reference Manual

Pre-Synthesis Check List

Following is a list of tasks to be done before running synthesis. Most of these are normally done as parts of other tasks, such as setting up the project and design entry.

In all cases, add or adjust the constraints, attributes, and directives used by the synthesis tool in the source code. See the synthesis tool’s user documentation. For LSE, see “Lattice Synthesis Engine Constraints” on page 563.

Integrated synthesis:

► Specify a synthesis tool. See “Selecting a Synthesis Tool” on page 58.
Implementing the Design

Synthesizing the Design

- Specify the top-level unit. See “Setting the Top-Level Unit for Your Project” on page 29. This is not always required but is a good practice. If not specified, you are relying on the defaults of the synthesis tool.

  **Note**

  In VHDL and mixed-language designs, LSE stops with an error if the top-level unit is not specified. LSE can find the top-level unit in pure Verilog designs.

- Specify a search path for files referenced by Verilog include directives. See “Specifying Search Path for Verilog Include Files” on page 60.

- Specify a VHDL library name. The default is “work.” See “Specifying VHDL Library Name” on page 59.

- Order the source files for synthesis. The synthesis tool processes the files in the order showing in the File List frame.

- Specify the strategy settings for the synthesis tool. See “Using Strategies” on page 34. If using LSE, also see “Optimizing LSE for Area and Timing” on page 251.

Interactive and stand-alone synthesis:

- Reference the Lattice synthesis header library in the source code. See “Lattice Synthesis Header Libraries” on page 250.

- For interactive synthesis, if you want to use the Synplify Pro strategy settings instead of Synplify Pro’s own defaults, change the “Export Radiant Settings to Synplify Pro GUI” option to **Yes** or **Only on First Launch**. See “Export Radiant Software Settings to Synplify Pro GUI” on page 522.

Lattice Synthesis Header Libraries

The synthesis header libraries define primitives from the FPGA libraries. A separate library is available for each device family and in Verilog and VHDL versions. The header libraries support Synplify Pro. If the design has any primitives from the FPGA libraries instantiated, the appropriate header library is required.

The integrated flow automatically includes the FPGA libraries, but if you are running synthesis outside of the Radiant software with interactive or stand-alone synthesis, you need to manually add a reference to the appropriate library. Look in Table 18 for the device family that you are using and add it to the source file list of your synthesis project. If your design is VHDL-based, add the .vhd file. If your design if Verilog-based, add the .v file.
The files are located at:

<install_dir>/cae_library/synthesis/verilog
<install_dir>/cae_library/synthesis/vhdl.

### Table 18: Synthesis Header Files

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Header Library File</th>
<th>Library Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>iCE40UP</td>
<td>iCE40UP.v</td>
<td>ice40UP</td>
</tr>
<tr>
<td></td>
<td>iCE40UP.vhd</td>
<td></td>
</tr>
<tr>
<td>LIFCL</td>
<td>lifcl.v</td>
<td>lifcl</td>
</tr>
<tr>
<td></td>
<td>lifcl.vhd</td>
<td></td>
</tr>
<tr>
<td>LFD2NX</td>
<td>lfd2nx.v</td>
<td>lfd2nx</td>
</tr>
<tr>
<td></td>
<td>lfd2nx.vhd</td>
<td></td>
</tr>
</tbody>
</table>

### Optimizing LSE for Area and Timing

The following strategy settings for Lattice Synthesis Engine (LSE) can help reduce the amount of FPGA resources that your design requires or increase the speed with which it runs. (For other synthesis tools, see those tools’ documentation.) Use these methods along with other generic coding methods to optimize your design. Also, consider using the predefined Area or Timing strategies.

Minimizing area often produces larger delays, making it more difficult to meet timing requirements. Maximizing frequency often produces larger designs, making it more difficult to meet area requirements. Either goal, pushed to an extreme, may cause the place and route process to run longer or not complete routing.

To control the global performance of LSE, modify the strategy settings by choosing Project > Active Strategy > LSE Settings. In the Strategy dialog box, set the following options, which are found in Synthesize Design > LSE.

The [Optimization Goal] strategy can be used as a global high level guidance to guide LSE.

The individual strategies in the table allow lower level control for specific optimization.

For example, you may set [Optimization Goal] to either Area or Timing, and leave the rest to default by LSE.

Or, for example, you can set the global [Optimization Goal] to Area, then continue to control lower level setting (more granular) such as FSM encoding to one-hot encoding, although one-hot encoding is generally recommended for Timing.
See the following text for explanations and more details.

### Table 19: LSE Strategy Settings for Area and Speed

<table>
<thead>
<tr>
<th>Option</th>
<th>Area</th>
<th>Speed</th>
</tr>
</thead>
<tbody>
<tr>
<td>FSM Encoding Style</td>
<td>Binary or Gray</td>
<td>One-Hot</td>
</tr>
<tr>
<td>Max Fanout Limit</td>
<td>&lt;maximum&gt;</td>
<td>&lt;minimum&gt;</td>
</tr>
<tr>
<td>Remove Duplicate Registers</td>
<td>True</td>
<td>False</td>
</tr>
<tr>
<td>Resource Sharing</td>
<td>True</td>
<td>False</td>
</tr>
<tr>
<td>Target Frequency</td>
<td>&lt;minimum&gt;</td>
<td></td>
</tr>
<tr>
<td>Use IO Registers</td>
<td>Auto or True</td>
<td>Auto or False</td>
</tr>
</tbody>
</table>

**FSM Encoding Style**  If your design includes large finite state machines, the Binary or Gray style may use fewer resources than One-Hot. Which one is best depends on the design. One-Hot is usually the fastest style. However, if the finite state machine is followed by a large output decoder, the Gray style may be faster.

**Max Fanout Limit**  A larger fanout limit means less duplicated logic and fewer buffers. A lower fanout limit may reduce delays. The default is 1000, which is essentially unlimited fanout. Select a balanced fanout constraint. A large constraint creates nets with large fanouts, and a low fanout constraint results in replicated logic. You can use this in conjunction with the syn_replicate attribute. See “syn_replicate” on page 613. To minimize area, don’t lower this value any more than needed to meet other requirements. To minimize speed, try much lower values, such as 50.

You can change the fanout limit for portions of the design by using the syn_maxfan attribute. See “syn_maxfan” on page 602. Set Max Fanout Limit to meet your most demanding requirement. Then add syn_maxfan to help other requirements.

**Optimization Goal**  If set to Area, LSE will choose smaller design forms over faster whenever possible.

If set to Timing, LSE will choose faster design forms over smaller whenever possible. If a create_clock constraint is available in an .ldc file, LSE ignores the Target Frequency setting and uses the value from the create_clock constraint instead.

If you are having trouble meeting one requirement (area or speed) while optimizing for the other, try setting this option to Balanced.

**Remove Duplicate Registers**  Removing duplicate registers reduces area, but keeping duplicate registers may reduce delays.

**Resource Sharing**  If set to True (box checked), LSE will share arithmetic components such as adders, multipliers, and counters whenever possible.
If the critical path includes such resources, turning this option off may reduce delays. However, it may also increase delays elsewhere, possibly reducing the overall frequency.

**Target Frequency (MHz)** A lower frequency target means LSE can focus more on area. A higher frequency target may force LSE to increase area. Try setting this value to about 10% higher than your minimum requirement. If Optimization Goal is set to Timing and a create_clock constraint is available in an .ldc file, LSE will use the value from the create_clock constraint instead.

**Use IO Registers** If set to True, LSE will pack all input and output registers into I/O pad cells. Register packing reduces area but adds delays.

Auto, the default setting, enables this register packing if Optimization Goal is set to Area. If Optimization Goal is Timing or Balanced, Auto disables register packing.

You can also control packing on individual registers. See “syn_useioff” on page 628. Set Use IO Registers to meet your most demanding requirement. Then add syn_useioff to help other requirements.

See Also

- “Using Strategies” on page 34
- “LSE Options” on page 526

**Integrated Synthesis**

In integrated synthesis, you create, synthesize, and implement a design completely within the Radiant software environment. This is the simplest method, but it limits your control of synthesis to tools and features directly supported by the Radiant software.

**To synthesize your design in the Radiant software:**

If you haven’t already, check the Pre-Synthesis Check List before running synthesis.

1. If desired, change the strategy settings by choosing **Project > Active Strategy > <Synthesis Tool> Settings**. See also “Using Strategies” on page 34.

   **Note**

   If you are switching from interactive synthesis to integrated, you need to reset all the options in the Radiant software. Options set directly in the synthesis tool have no effect in the Radiant software.

2. In the Process Toolbar, click **Synthesize Design**. Alternatively, right-click **Synthesize Design** and choose **Run Synthesis** from the pop-up menu.

   If Synthesize Design has already been run and does not recognize any changes in the design, it won’t run again. You can force Synthesize Design to run by right-clicking it and choosing **Force Run Synthesis** from
the pop-up menu. Otherwise from each of the process bar items, you can force the whole flow to start from synthesis by selecting **Force Run from Start**.

3. When finished, check the icon next to Synthesize Design in the Process frame. A green check mark ✔ indicates success; a red X ✗ indicates failure.

4. For more information on how the synthesis ran, open the Reports view in the Tools area (choose **View > Reports**). Under Project Summary, choose **Synthesis Reports > [Synthesis Tool]**. This report lists actions taken by the synthesis tool, warnings, and errors. The report also provides a list of FPGA resources used and a timing report based on estimated place-and-route data. See **"Viewing Logs and Reports" on page 70**.

You can find a more detailed area report in the folder of the active implementation. The report is named with an .areasrr extension (for Synplify Pro) or with an .arearep extension (for LSE). The report includes the resources used by each module of the design. Similar information can also be found in the Hierarchy view.

If you are using LSE, you can also find a more detailed timing report in the folder of the active implementation. The report is named *.tws. It is similar to the report described in **"Reading Timing Analysis Reports" on page 282**.

**See Also**

- "Optimizing LSE for Area and Timing" on page 251
- “Running Processes” on page 52

### Interactive Synthesis

In interactive synthesis, you set up a design project in the Radiant software, but set up and run synthesis directly in the synthesis tool. This gives you more complete control of synthesis than integrated synthesis and allows you to make full use of the synthesis tool’s features. Note that LSE cannot be used in interactive synthesis.

**Note**

If you decide to use interactive synthesis, remember to use it every time you make a design change. If you try to repeat the implementation process by simply double-clicking an item in the Process frame, the Radiant software will synthesize the design with integrated synthesis, which may give unexpected and inferior results.

**To synthesize your design using interactive synthesis:**

If you haven’t already, check the **“Pre-Synthesis Check List” on page 249** before running synthesis.

1. Open the synthesis tool from the **Tools** menu.
   
   The synthesis tool opens with the device and source files for your design.

2. Set options in the tool as desired.
3. To re-use the settings, save the synthesis tool’s project file as 
<project_name>_syn.prj (Synplify) in the project folder.

Make sure the Radiant software strategy option, “Export Radiant Settings
to Synplify Pro GUI” (under Synplify Pro in the Strategies dialog box) is set
to No or Only on First Launch. See “Export Radiant Software Settings to
Synplify Pro GUI” on page 522.

4. Synthesize the design.

5. Analyze the results in the synthesis tool.

**Stand-Alone Synthesis**

In stand-alone synthesis, you can use a synthesis tool that is not directly supported by the Radiant software. In this flow you set up and run synthesis directly in the synthesis tool. Then create a design project in the Radiant software using the output of the synthesis tool as the source file. Note that LSE cannot be used in stand-alone synthesis.

If you haven’t already, check the “Pre-Synthesis Check List” on page 249 before running synthesis.

**To set up a project using a stand-alone tool:**

1. Open the synthesis tool directly without using the Radiant software.

2. Using your synthesis tool, create a project, including specifying a device, source files, and options.

3. Synthesize the design.

4. Analyze the results in the synthesis tool.

5. When you are satisfied with the synthesis, create a design project in the Radiant software.

**To re-synthesize your design using the stand-alone tool:**

This procedure assumes that you have already set up the project to use stand-alone synthesis.

1. Open the synthesis tool directly without using the Radiant software.

2. In the synthesis tool, open the project.

3. If desired, change the options.

4. Analyze the results in the synthesis tool.

**Mapping**

Mapping is the process of converting a design represented as a network of device-independent components, such as gates and flip-flops, into a network of device-specific components, such as PFUs and EBRs or configurable logic blocks.
You can use the Map Design process in the Radiant software environment or the MAP program from the command line.

The Map Design process generates physical descriptions of the logical configuration within the programmable device elements. These device elements include programmable function units (PFU), programmable I/O cells (PIC), embedded block RAM (EBR). They also include special function blocks: internal oscillator, global set/reset (GSRN), start-up logic, phase locked loop (PLL), delay locked loop (DLL), and physical coding sublayer (PCS) logic.

Depending upon the attributes specified in the input netlist, mapping includes absolute placement, logical partitioning (hierarchical netlists), component group placement, and regional group placement information in the physical description.

See Also

- “Running MAP from the Command Line” on page 928
- “Setting Map Design Options” on page 256
- “Mapping Output Files” on page 256

### Setting Map Design Options

When you run the Map Design process in the Radiant software, the design is mapped based on design options that are in the active strategy. Mapping options can influence the performance and utilization of the design implementation, ease incremental design changes, or allow you to over map in order to review how many resources are required for a particular implementation.

To set Map Design options:

1. Choose Project > Active Strategy > Map Design Settings to open the Strategies dialog.
2. For each option that you want to change, double-click a cell in the Value column. Select the desired value from the pulldown menu, enter text, or click the browse button, as appropriate.
3. Click OK.

See Also

- “Map Design Options” on page 535
- “Mapping” on page 255
- “Mapping Output Files” on page 256

### Mapping Output Files

The following files are created from the Map Design process:

- MAP Report File (.mrp) — The map report file provides details about how the design was mapped to physical elements and reports any errors.
Mapping details can include such things as how attributes were interpreted, logic that was removed or added, and how signals and symbols in the logical design were mapped to components in the physical design.

See Also  ►“Mapping” on page 255
► “Setting Map Design Options” on page 256

Running Map Design

In the Radiant software environment, the Map Design process automatically maps the design based on the active strategy settings.

To run Map Design in the Radiant software environment:
► In the Process Toolbar, click Map Design.

See Also  ►“Running MAP from the Command Line” on page 928
► “Running Processes” on page 52

MAP Report File

The MAP Report (.mrp) file supplies statistics about component usage in the mapped design and shows the number and percentages of resources used out of the total resources in the device. The report is produced whether you have run Map in the Radiant software environment or the command line.

To view the MAP Report file in the Radiant software:
► Click the Reports tab to activate the Report view and select Map Reports. The Map report is displayed in the Reports window to the right.
  OR
► Using a text editor, open the .mrp ASCII file in your project directory.

Although detailed information varies depending on the device, the format of the .mrp file is the same. The report is divided into sections, which can include the following:
► Design Information – Shows the map command line, the device/performance grade, and the time/date stamp of the run.
► Design Summary – Shows the number and percentage of resources used out of the total of the resources of the mapped device. The MAP Report lists the number of slice registers, I/O registers, LUT4s, and other logic. The number of SLICEs generated from MAP could exceed the device limitation. The Place and Route (PAR) process will determine whether or
not it is necessary to merge two SLICEs into one.

**Note**

The total resources reported represents the total resource count in the device and not the total accessible resources. Since the accessibility of resources can change, depending on the design and design revisions, there will sometimes be a gap between the number of resources that are available for use and the total number in the device.
Design Summary

Number of slice registers: 2140 out of 5280 (41%)
Number of I/O registers: 0 out of 56 (0%)
Number of LUT4s: 3833 out of 5280 (73%)
  Number of logic LUT4s: 3026
  Number of inserted feedthru LUT4s: 39
  Number of ripple logic: 384 (768 LUT4s)
Number of IO sites used: 22 out of 56 (39%)
  Number of IO sites used for general PIOs: 22
  Number of IO sites used for I3Cs: 0 out of 2 (0%)
  Number of IO sites used for PIOs+I3Cs: 22 out of 53 (42%)
  (note: If I3C is not used, its site can be used as
  general PIO)
  Number of IO sites used for OD+RGB IO buffers: 0 out of 3
  (0%)
  Number of DSPs: 4 out of 8 (50%)
  Number of I2Cs: 0 out of 2 (0%)
  Number of High Speed OSCs: 0 out of 1 (0%)
  Number of Low Speed OSCs: 0 out of 1 (0%)
  Number of RGB PWM: 0 out of 1 (0%)
  Number of RGB Drivers: 0 out of 1 (0%)
  Number of SCL FILTERs: 0 out of 2 (0%)
  Number of SRAMs: 0 out of 2 (0%)
  Number of WARMBOOTs: 0 out of 1 (0%)
  Number of SPIs: 0 out of 2 (0%)
  Number of EBRs: 0 out of 30 (0%)
  Number of PLLs: 0 out of 1 (0%)
Number of Clocks: 1
  Net clk_c: 2022 loads, 2022 rising, 0 falling (Driver: Port clk)
Number of Clock Enables: 8
  Net n18836: 38 loads, 38 SLICEs
  Net n9306: 128 loads, 128 SLICEs
  Net n18680: 36 loads, 36 SLICEs
  Net n18773: 36 loads, 36 SLICEs
  Net n18139: 36 loads, 36 SLICEs
  Net n9301: 128 loads, 128 SLICEs
  Net n9296: 128 loads, 128 SLICEs
  Net n9311: 128 loads, 128 SLICEs
Number of LSRs: 6
  Net maxfan_replicated_net_203: 169 loads, 169 SLICEs
  Net data_in_reg_63__N_501: 925 loads, 925 SLICEs
  Net mult32_2/n1818: 4 loads, 4 SLICEs
  Net n9303: 4 loads, 4 SLICEs
  Net n9298: 4 loads, 4 SLICEs
  Net mult32_3/n1821: 4 loads, 4 SLICEs
Top 10 highest fanout non-clock nets:
  Net reset_n_c: 926 loads
  Net data_in_reg_63__N_501: 925 loads

The Number of SLICEs information in the Design Summary will vary.
The number and percentage of PIO sites used, out of the total number, is
given in the Design Summary. Sometimes this is further broken down into
external and differential PIOs. The Number of external PIOs is based on the number of PIO pads programmed with a single-ended signal standard out of the total number of bonded pads on the chip die. The Number of differential PIOs counts those PIOs programmed with a differential signal standard.

**Design Errors/Warnings:**

- Shows any warnings or errors encountered by the mapping process. For example, the section will report a pad that is not connected to any logic, or a bidirectional pad that has signals passing only in one direction.

- Shows any warnings or errors generated as a result of the design rule tests performed at the beginning of the mapping process. These warnings and errors do not depend on the device to which you are mapping.

- Shows errors and warnings associated with problems in assigning components to sites. For example, an attribute on a component specifies that the component must be assigned to site AK, but there is no site AK on the part to which you are mapping. Another example would be a problem in fitting the design to the part where the design maps to 224 logic blocks, but the part only contains 192 logic block sites.

**IO (PIO) Attributes** – Provides a table by input/output port of programmed direction, I/O type, and whether the PIO is registered. Shows any attributes (properties) specified on PIO logic elements.

**Removed Logic** – Describes any logic that was removed when the design was mapped. Logic may be removed for the following reasons:

- A design uses only part of the logic in a library macro.

- The design has been mapped even though it is not yet complete.

- The mapping process has optimized the design logic.

- Unused logic has been created in error during design entry.

This section also indicates which nets were merged when a component separating them was removed.

The Removed Logic section also enumerates how many blocks and signals were removed from the design, including the following kinds of removed logic:

- Blocks clipped – A "clipped" block is removed because it is along a path that has no driver or load. Clipping is recursive; that is, if Block A becomes unnecessary because logic to which it is connected has been clipped, then Block A is also clipped.

- Blocks removed – A removed block is removed because it can be eliminated without changing the operation of the design. Removal is recursive; that is, if Block A becomes unnecessary because logic to which it is connected has been removed, then Block A is also removed.

- Blocks optimized – An "optimized" block is removed because its output remains constant regardless of the state of the inputs—for
example, an AND gate with one input tied to ground. Logic generating an input to this optimized block (and to no other blocks) is also removed, and appears in this section.

- Signals removed – Signals were removed because they were attached only to removed blocks.
- Signals merged – Signals were combined because a component separating them was removed.
- ASIC Components – Lists any ASIC instances in the design by name and specifies the type used for each. These components mostly include IPs, such as Block RAM, DSP, and others.
- Symbol Cross Reference – Shows where symbols in the logical design were mapped in the physical design. By default, Map will not report symbol cross references unless you specify the -xref_sym Map command line option or enable the Report Symbol Cross Reference property for the Map Design process in the Radiant software environment.
- Signal Cross Reference – Shows where nets in the logical design were mapped in the physical design. By default, Map will not report symbol cross references unless you specify the -xref_sig Map command line option or enable the Report Signal Cross Reference property for the Map Design process in the Radiant software environment.
- PLL/DLL Summary – Provides instance name, type, clock frequency, pin/node values, and a listing of all settings for each PLL or DLL in the design.
- OSC Summary – Provides the oscillator’s instance name, possible oscillator primitive type, output clock, and nominal frequency. This section is only included in the map report if the OSC primitive has been instantiated in the design.
- Run Time and Memory Usage – Lists total CPU time, real time, and peak memory usage related to the Map run.

### Packing of Duplicate Registers

Designers often duplicate registers in order to reduce fan-out and improve timing. Duplicated registers are registers with the same data and control paths. The software keeps duplicated registers from being mapped into the same PFU.

If the COMP= attribute is attached to duplicate registers, it will override duplicate register packing.

### Place and Route

After a design has undergone the necessary translation to bring it into the physical design format during mapping, it is ready for placement and routing. Placement is the process of assigning the device-specific components produced by the mapping process to specific locations on the device floorplan. After placement is complete, the route phase establishes physical
connections to join components in an electrical network. The place and route process takes a mapped physical design and places and routes the design. Placement and routing of a design can be cost-based or timing driven.

In most cases, your design will require timing-driven placement and routing, where the timing criteria you specify influences the implementation of the design. Static timing analysis results will show how constrained nets meet or do not meet your timing.

In the Radiant software Task Detail View, there is a Place & Route Timing Analysis process available that runs static timing analysis. This process reports any timing errors and generates a report. The Place & Route Timing Analysis report can be accessed from the Place & Route Reports folder of the Reports window.

See Also  
► “Setting Place & Route Design Options” on page 262  
► “Options and Processes to Improve PAR Results” on page 263  
► “Place & Route Output Files” on page 263  
► “Running Place & Route Design” on page 263  
► “PAR Report File” on page 265

Setting Place & Route Design Options

Placement and routing options can influence the performance and utilization of the design implementation and ease incremental design changes. Some options affect the way the results are reported. You can set Place & Route Design options in the Strategies dialog box in the Radiant software or use the par command-line program.

To set Place & Route Design options in the Radiant software environment:

1. Choose Project > Active Strategy > Place and Route Design Settings to open the Strategies dialog.
2. For each option that you want to change, double-click a cell in the Value column.
3. Select the desired value from the pulldown menu, enter text, or click the browse button, as appropriate.
4. Click OK.

See Also  
► “Place & Route Design Options” on page 537  
► “Running PAR from the Command Line” on page 930  
► “PAR Report File” on page 265
Options and Processes to Improve PAR Results
Experimenting with place and route settings in the Strategies dialog box can help improve your placement and routing results. Try changing certain strategy options to help meet your objectives, as in the following scenarios:

- Some number of connections are left unrouted.
- Timing period/frequency objectives are not met.

Try increasing the number of times the placer runs.

See Also
- “Running Place & Route Design” on page 263
- “Running PAR from the Command Line” on page 930
- “Place & Route Design Options” on page 537
- “Cost-Based Place & Route” on page 269
- “Place & Route Output Files” on page 263
- “Place & Route Output Files” on page 263

Place & Route Output Files
The following files are the output files generated by the Place & Route Design process:

- PAR Report File (.par) — a PAR report including summary information of all placement and routing iterations.
- PAD Specification File (.pad) — a report file containing I/O pin assignments.

See Also
- “Place and Route” on page 261

Running Place & Route Design
In the Radiant software environment, the Place & Route Design process automatically assigns device-specific components to locations and connects them.

To run Place & Route Design in the Radiant software environment:

- In the Process Toolbar, click Place & Route Design.
- Alternatively, right-click Place & Route Design and choose Run PAR from the pop-up menu. You can force run PAR from the pop-up menu as well.

See Also
- “Setting Place & Route Design Options” on page 262
- “Running PAR from the Command Line” on page 930
Multiple PAR Iterations

The “Place Iterations” option for Place & Route Design sets the maximum number of placement/routing passes.

If you specify options that produce a single output design file, your output consists of a single par file and .pad file.

If you run multiple placement and routing iterations, you produce a .par and .pad file for each iteration. After each iteration, the program saves the physical design for every instance where the timing core has improved. This means that during long PAR runs, the current minimal timing score is always available. This behavior prevents a few rare cases where timing scores may have gone up rather than down when performing multiple PAR iterations. The timing score is determined as a weighted sum of several parameters including the number of unrouted nets, number of timing constraints not met, amount by which the timing constraints were not met, maximum delay on nets, and maximum delay on the ten highest nets.

As the par command is performed, PAR records one .par file (a summary of all placement and routing iterations) at the same level as the directory you specified. It also places within the directory a .par and .pad file for each individual iteration.

The file names for the output files use the naming convention <effort-level>_<cost-table-entry>; for example, _1_1.par and _1_1.pad. In this example, the effort level and cost table entries start at 1 (the default effort level is 5).

Note

If you wish to further optimize your place-and-route results beyond multiple PAR iterations, a process which uses timing as the sole criteria for optimization, see “Place & Route Report Files” on page 264. In addition to timing score, the MPARTRCE tool's methodology uses a performance score when it determines the best design run for your purposes.

See Also  ➤“Place and Route” on page 261

Place & Route Report Files

The Reports view in the Radiant software provides immediate access to reports produced by the Place & Route Design process, including the Place & Route report (.par) and the Pad Specification file (.pad). These reports open in the Report view in HTML format.

When you run multiple iterations of Place & Route, a .par file and .pad file, are included in your project directory for each run. You can open these files with a text editor.
PAR Report File

The PAR Report (.par) file contains execution information and shows the steps taken as the process converges on a placement and routing solution.

To view the PAR Report file in the Radiant software:

- In the Design Summary pane of the Reports window, select Place & Route Reports and select one of the three reports:
  - Place & Route
  - Signal/Pad
  - Place & Route Timing Analysis
  - I/O Timing Analysis

  The chosen report will appear in the right pane.

- Alternatively, use a text editor to open the .par ASCII file from your project directory.

By default, the Cost Table Summary is sorted by worst slack for multiple placement seeds, as follows:

1. Worst slack (setup)
2. Timing score (setup)
3. Worst slack (hold)
4. Timing score (hold)
5. Seed #

Device Utilization Summary   This section summarizes the number and percentage utilization of device resources, including I/O, logic, and global signals. For PIOs, twice the number of PIO SITE resources are required for differential I/Os. A single differential PIO COMP uses two PIO SITE resources, whereas non-differential PIO COMPs use one PIO SITE resource.

The PIO report summary counts the number of bonded and unbonded PIOs required to implement single-ended and differential signal standards. PIO utilization reflects the preliminary results reported by the design mapper (map). See the I/O Usage Summary section for details on final results. Utilization reported by Map might be lower, because some SITE resources, such as VREF assignments, are made automatically by PAR.

Report Syntax:

SITE TYPE <# sites used> / <# sites of type available on device> <x>% used
Consider the example below. The first column identifies the device type. The second column provides the actual number of available sites versus those used for that device type; and the third column provides the percentage of available sites used. For PIOs, you will see a breakdown of available versus used bonded pads and a percentage:

<table>
<thead>
<tr>
<th>Device Type</th>
<th>Available</th>
<th>Used</th>
<th>Percentage</th>
</tr>
</thead>
<tbody>
<tr>
<td>APIO</td>
<td>24/36</td>
<td></td>
<td>66% used</td>
</tr>
<tr>
<td>GSR</td>
<td>1/1</td>
<td></td>
<td>100% used</td>
</tr>
<tr>
<td>IOLOGIC</td>
<td>110/506</td>
<td>21%</td>
<td>used</td>
</tr>
<tr>
<td>PIO (prelim)</td>
<td>194/504</td>
<td>38%</td>
<td>used</td>
</tr>
<tr>
<td></td>
<td>194/372</td>
<td>52%</td>
<td>bonded</td>
</tr>
<tr>
<td>DQSBUF</td>
<td>8/16</td>
<td>50%</td>
<td>used</td>
</tr>
<tr>
<td>EBR</td>
<td>135/225</td>
<td>60%</td>
<td>used</td>
</tr>
<tr>
<td>DQSDLL</td>
<td>1/2</td>
<td>50%</td>
<td>used</td>
</tr>
<tr>
<td>MULT18</td>
<td>1/88</td>
<td>1%</td>
<td>used</td>
</tr>
<tr>
<td>PCS</td>
<td>2/2</td>
<td>100%</td>
<td>used</td>
</tr>
<tr>
<td>SLICE</td>
<td>17827/23832</td>
<td>74%</td>
<td>used</td>
</tr>
<tr>
<td>PLL</td>
<td>3/8</td>
<td>37%</td>
<td>used</td>
</tr>
</tbody>
</table>

For total PIO resources, a preliminary (prelim) report shows that out of a possible 504 total PIO resources on the device, the design uses 194 of them, or about 38 percent. The following line shows that 194 bonded out pads are being used out of a possible 372 bonded I/Os, or about 52 percent.

The term “used” means that these I/O are in the design and will be programmed on the device. This report is considered preliminary (prelim) because VREF assignments have not yet been placed. The difference in resource utilization is accounted for later in the PAR report in the I/O Usage Summary (final).

An I/O is considered “bonded” when the packaging of the chip connects the bond pad to a pin on the package.

**Note**

Bonded pad availability is based on packaging, which varies within a device family from part to part. See the Package Diagrams documentation in addition to the Product Selector Guide on the Lattice web site for details when selecting a device and package for your application.

The rest of the example report shows IOLOGIC, PLL, SLICE and other various resource type usage. As utilization percentage approaches 100 percent on logic or any specific key resource types reported in this section, you might want to consider a larger device that can accommodate better design performance.

**Placement** This section provides a log of messages produced during the placement phase.
Clock Report  This section provides a complete listing of all of the clocks used in the design. Aside from the example, the Clock Summary report would reflect a scenario where only global clocking is used as follows:

Quadrants All (TL, TR, BL, BR) - Global Clocks
  PRIMARY : 1 out of 4 (25%)
  DCS : 1 out of 2 (50%)
  SECONDARY : 0 out of 4 (0%)

I/O Usage Summary (final)  This section Summarizes the final number and percentage utilization of device resources, including I/O, logic, and global signals.

Report Syntax:

I/O Bank Usage Summary (final):
  <#PIO sites used> out of <#PIO sites of device> (x%) PIO sites used.
  <#PIO sites used> out of <#PIO sites of device/pkg> (x%) bonded PIO sites used.
  Number of PIO comps:
  Number of Vref pins used: <#VREF pins>

Best Par Run  This section shows the Radiant software version and the P&R commands with any non-default options of the run. In addition, the section lists the design name and device information, including family name, device name, package name and performance grade.

Example:

PAR: Place And Route Radiant Software (64-bit) 2.0.t.311.0.
Command Line: par -w -t 1 -cores 1 -exp parPathBased=OFF
top_impl1_map.udb top_impl1_par.dir/5_1.udb

Design: dphy
Family: LIFCL
Device: LIFCL-40
Package: CSBGA289
Performance Grade: 7_High-Performance_1.0V

NBR Summary  This section summarizes the post-routing results, including the number of unrouted connections, number of timing violated connections, worst setup slack and setup timing score for the design.
**NBR Summary Example:**

```
Number of unrouted connections : 0 (0.00%)
Number of connections with timing violations : 0 (0.00%)
Estimated worst slack<setup> : 0.013ns
Timing score<setup> : 0
```

Notes: The timing info is calculated for SETUP only.

If the design cannot meet the timing requirements, the worst setup slack might be negative and the timing score might be non-zero, as shown below.

**Not Meeting Timing:**

```
Number of unrouted connections : 0 (0.00%)
Number of connections with timing violations : 55 (0.05%)
Estimated worst slack<setup> : -0.265ns
Timing score<setup> : 4165
```

Notes: The timing info is calculated for SETUP only.

**See Also**  ▶“Place & Route Output Files” on page 263

**PAD Specification File**

The PAD specification (.pad) file is an ASCII report file that lists all Programmable I/O Cells (PICs) used in the design and their associated primary pins. The PICs are listed by port name and by pin names.

**To view the PAD Specification Report File in the Radiant software environment:**

- In the Design Summary pane of the Reports window, select **Signal/Pad**. Your report will appear in the pane to the right.
- Alternatively, use a text editor to open the .pad ASCII file from your project directory.

The .pad file may include the following information:

- Pinout by Port Name – This section lists the port names with primary pin designations. It also shows the buffer type and any associated attributes. Buffer type indicates the PIO mode. For example, a PIO in LVDS or LVPECL mode needs two bonded pads for differential signals that are both included in the .pad file.

  In most designs, the top-level HDL design will not include both true and complement sides of differential port signals. The designer assigns I/Os to pads (via LOCATE) using a single signal, assuming that it will represent the true (+) signal. Based on an IOBUF type of LVDS or LVPECL, the
Radiant software will automatically infer the complement (-) signal and assign it to the appropriate site on the device package.

Port signals are reported using the syntax: <port name>+ for positive differential and <port name>- for negative differential in the Pinout by Pin Number table.

- Vccio by Bank – This section lists the voltage by bank.
- Vref by Bank – This section shows the name and location of on-chip voltage references that have been set and the associated port groups or signals.
- Pinout by Pin Number – This section lists pin numbers, which includes the primary pin number, the component name or reference voltage type, and the buffer type. The Dual Function column identifies pins that can be used for I/O assignments or for another function, such as Vref. In the Pin info column, the status of any "unused" pin is reported as “unused, PULL:UP,” because these pins have an internal pull-up.

Cost-Based Place & Route

The standard PAR package is a cost-based tool. This means that placement and routing are performed using various cost tables that assign weighted values to relevant factors such as constraints, length of connection, and available routing resources.

**Placement**  The PAR process places the mapped physical design in two stages: a constructive placement and an optimizing placement. PAR writes the physical design after the completion of each of these two stages.

During constructive placement, PAR places components into sites based on factors such as the following:

- Constraints specified in the input file (for example, certain components must be in certain locations)
- Length of connections
- Available routing resources
- Cost tables that assign random weighted values to each of the relevant factors. There are 100 possible cost tables.

Constructive placement continues until all components are placed. Optimizing placement is a fine-tuning of the results of the constructive placement.

**Routing**  Routing also is done in two stages: iterative routing and delay reduction routing, which is also called cleanup. PAR writes the physical design only after iterations where the routing score has improved.

During iterative routing, the router performs an iterative procedure to converge on a solution that routes the design to completion or minimizes the number of unrouted nets.
During reduction routing, the router takes the result of iterative routing and reroutes some connections to minimize the signal delays within the device. There are two types of reduction (cleanup) routing that you can perform:

- A faster cost-based cleanup routing. This type of routing makes decisions by assigning weighted values to factors, such as the type of routing resources used, that affect delay times between sources and loads.
- A more intensive delay-based cleanup routing. This type of routing makes decisions based on computed delay times between sources and loads on the routed nets.

**Place & Route Considerations**

In primary clock placement, if the primary clock is a PIO, the placer will automatically place it into a "sweet site," a site that can be routed easily to the center. However, if the primary clock is driven by a PFU (internally generated primary clock), the placer will attempt to place it on a sweet site or a proximal location. If you locate a primary clock driver on a non-sweet site, the placer will issue a warning. During pre-placement, all PIO constraints are observed, which means that the pre-placement is always legal.

- The placer prints out a list of selected primary clocks before the constructive placement. You should check that the primary clocks are selected properly.

**Running Multiple PAR Jobs in Parallel**

The PAR Multi-tasking option allows you to use multiple machines (nodes) to run multiple place-and-route jobs at the same time instead of serially. You can run this feature in the Radiant software environment. Use the "Multi-tasking Node List" option in the Place and Route Settings of the Strategies dialog box, or use the PAR -m option from the command line.

The ability to run multiple jobs on different nodes simultaneously can significantly reduce the time it takes to complete these runs. Otherwise, it would take the cumulative time for each job to complete by itself in a consecutive manner, and this could mean the difference between one hour and 10 hours of total time.

The PAR multi-tasking option is supported three ways:

- Local multi-tasking, where multiple PAR runs are executed on a single machine.
- Networked multi-tasking, where multiple PAR runs are executed on multiple machines.
- A combination of local and networked.
Creating a Node List File  For a PC or for Linux, you must first create an ASCII-based node list file input that specifies the candidate machines that allow multiple PAR jobs to be run in parallel.

The node list file contains node description blocks of information on separate lines for each machine in the format shown below:

```
[<node_name>]
System = <linux | pc>
Corenum = <number_of_cores>
Env = <file_name>
Workdir = <directory_name>
```

```
[<node_name2>]
System = < linux | pc>
Corenum = <number_of_cores>
Env = <file_name>
Workdir = <directory_name>
```

where:

The [<node_name>] value contains the machine name in square brackets. For example, if your machine name is jsmith, this line would simply show [jsmith] on the first line.

**Note**

For Linux, you can use many networked nodes to run the PAR job, so the node list will have a corresponding number of node description blocks in it. For PC, there will only be one node description block in the node list since you can only employ one PC that has multiple cores. This feature does not currently support a host of networked PCs.

The System node description line lists the platform the machine runs on. This line can only take Linux or PC as a value.

Corenum specifies how many CPU cores there are on the machine. This line can be omitted when there is only one CPU on the machine. Changing it to zero disables the node from running PAR tasks.

Env specifies an environment setup file to be run before the multiple PAR job is run on the remote machine. If the remote machine environment is ready, then this line can be omitted. To test if a remote machine is ready, run the following command to see if PAR can be run remotely:

```
ssh <remote_machine> <par_cmd_options>
```
Workdir specifies in which working directory on the remote machine the PAR multi-task job should be run. If account permissions allow you to get into that directory automatically after login, this line can also be omitted.

General Node List Rules:

- You must use the equal sign for each node description line and the same line and character spacing illustrated in the node list format example.
- Only the names of files and directories are case sensitive on UNIX and Linux. Node description line markers, for example, “Corenum =” can appear in upper, lower, or mixed case.
- The [<node_name>] and System lines are required for any node list file.
- The Corenum, Env, and Workdir node description lines are optional.
- For PC, the nodelist file should only include one node description block on the local machine. Remotely networked PCs are not supported. Any entries for remote nodes on a PC network will be discarded by the PAR multi-tasking feature. If you do not have a nodelist file created, you can specify the number of cores to be used in your local machine with a -cores option in your command line, or use the “Number of Host Machine Cores” strategy in the Strategies dialog box.
- For UNIX /Linux, the nodelist file can have multiple machine nodes; but it should not include PC type nodes, which will be discarded. If you do not have a nodelist file created, you can specify the number of cores to be used in your local machine with a -cores option in your command line, or use the “Number of Host Machine Cores” strategy in the Strategies dialog box. For cases when the user specifies both -cores and -m with a valid node list file, PAR should apply both settings (merge). If the user repeats the host machine in the node list file, the settings in the node list file take precedence over the setting in -cores.
- By beginning a line with double forward slashes, “//”, you can place a comment line anywhere in the node list file. The PAR multi-tasking feature will ignore its syntax.

PAR Multi-Tasking Environment Setup For PC, running PAR remotely is not supported, so multiple PAR processes can only run in parallel on one PC. Since the child PAR process takes the environment from the parent, no environment variable setup is necessary.

For Linux, there are two ways to set up the environment:

- Use the account login profile and source files.
  - For the account to allow PAR to be run remotely, it should have an .rc file (.bashrc if the bash shell used) that runs automatically when a secure shell (ssh) call is received.
  - The following three environment variables have to be set properly for PAR to run: PATH, FOUNDRY, and LD_LIBRARY_PATH. To set the environment variables, see “Setting Up the Environment to Run Command Line” on page 909. You can test if the remote environment is set up correctly by running the following command locally:
    
    `ssh <remote_machine> par`
You will see the PAR help page if the environment setup is correct.

Use Env and Workdir node description lines in the node list file.

After it reads the node list, the PAR Multi-tasking option will know which script to run and in which working directory to run the par command. The spawned task on the remote machine will run the “Env” file, then it will “cd” to the working directory before it runs PAR.

There is also Linux environment setup information for this feature in the Using the PAR Multi-Tasking (-m) Option section of the topic “Running PAR from the Command Line” on page 930.

Running Multiple PAR Jobs in Parallel in the Radiant software When running the multi-tasking option on the PC, you should use a dual processor or multiple processor configuration, or the feature will provide no benefit. Currently, you cannot run the multi-tasking option using multiple networked PCs.

To run the PAR Multi-tasking on the PC with multiple processors:

1. Prepare a node list ASCII text file that identifies your machine (lpass4), system type (PC), and number of core processors (2). Include any desired comment lines.

   // This file contains a profile node listing for a multipar PC job.
   [lpass4]
   SYSTEM = PC
   CORENUM = 2

   You must use the format above for the node list file and fill in all required parameters. Parameters are case insensitive. The node or machine names are given in square brackets on a single line.

   The System parameter can take the Linux, or PC values, depending upon your platform. However, the PC value cannot be used with Linux because it is not possible to create a multiple computer farm with PCs. Corenum refers to the number of CPU cores or processors available on that single PC. Setting it to zero will disable the node from being used. Setting it to a greater number than the actual number of CPUs will cause PAR to run jobs on the same CPU, lengthening the run time. No further parameters are necessary on the PC.

2. Save your node list file and copy it to your top-level project directory. In our example, we named the node list my_nodelist.txt.

3. In the Radiant software, click Project > Active Strategy > Place and Route Design Settings.

4. Double click the Value cell for the Multi-Tasking Node List option and click the browse (⋯) button.

5. Navigate to the file name in your project directory. If the file is located elsewhere, you must use an absolute file and path name, for example, C:/my_projects/my_nodelist.txt. PAR will issue an error message if it cannot find your node list file, for example:
ERROR - par: Node name file does not exist.

If it cannot find your node list, PAR will continue in a serial fashion without using the node list file to specify the use of multiple processors.

6. Click OK.

In our example, we opted to change the number of placement iterations to 3, set the placement iteration starting point to 3, and limit the number of best saved runs to 2.

7. In the Process view in the Radiant software environment, right click Place & Route Design and choose Run from the pop-up menu to run the flow through the Place & Route process.

Rerun will run the one process over again and nothing else. Rerun All will rerun the design flow up to the Place and Route process.

In the Output view or Automake Log, the multipar run shows that it ran all jobs and completed successfully.

---- Multipar Tool ----
Running par. Please wait . . .
Starting job 5_3 on node lpass4
Starting job 5_4 on node lpass4
Finished job 5_4 on node lpass4
Starting job 5_5 on node lpass4
Finished job 5_5 on node lpass4
Exiting par with exit code 0
Exiting multipar with exit code 0
Done: completed successfully.

Note that we chose the starting point of 3, so the jobs start at 5_3 instead of 5_1.

After the run, PAR creates a <project_name>.dir directory in your top-level project directory.

To learn more about how to use this feature from the command line, see the subsection Using the PAR Multi-Tasking (-m) Option of the topic “Running PAR from the Command Line” on page 930. There is also information there about general usage, environment setup, screen output, interrupting jobs, and requirements.

See Also ➤ “Running PAR from the Command Line” on page 930
➤ “Using the PAR Multi-Tasking (-m) Option” on page 933

Bit Generation

The Bitstream File process in the Process view or bit generation (bitgen) program takes a fully routed physical design and produces a configuration bitstream (bit images). The bitstream file contains all of the configuration
information from the physical design that define the internal logic and interconnections of the FPGA, as well as device-specific information from other files associated with the target device.

The data in the bitstream can then be downloaded directly into the FPGA’s memory cells or used to generate files for PROM programming. You can run bitgen from the Radiant software window by double-clicking the Export Files process or from the command line.

See Also ► “Generating Bitstream Files” on page 276
► “Bit Generation Considerations” on page 277
► “Bit Generation Output Files” on page 275
► “Bit Generation Options” on page 275
► “Running Bit Generation from the Command Line” on page 941

Bit Generation Options
Bit generation options provide you with control over the bit generation process. Bit generation options are accessed from the Strategy dialog box or the bitgen program from the command line. These options allow you to control the format of the bitstream output.

Bit Generation Output Files
The following files are possible output to the Bitstream File process or the bitgen program:

► Bit File (Binary) — binary (.bin) bitstream. Binary bitstream files are the default output of the bitstream process and contain the configuration information in bitstream (zeros and ones) that is represented in the physical design.

► Raw Bit File (ASCII) — ASCII (.rbt) bitstream. The Raw Bit File is a text file containing ASCII ones and zeros representing the bits in the bitstream file. If you are using a microprocessor to configure a single FPGA, you can include the Raw Bit file in the source code as a text file to represent the configuration data. The sequence of characters in the Raw Bit file is the same as the bit sequence that will be written into the FPGA. The .rbt file differs from the .bin file in that it contains design information in the first six lines.

See Also ► “Bit Generation” on page 274
Generating Bitstream Files

In the Radiant software, bitstream generation is automatically performed when you run the Export Files process for either a full or partial design flow. You can set bit generation options before running a design flow by setting a strategy.

To generate bitstream files from the Radiant software:

1. In the Radiant software File List view, double-click the target strategy. The Strategy dialog box opens.
3. In the right-hand pane, double-click the Value box for the Bitstream option that you want to edit, enter the new value or select a value from the pulldown list, and click Apply.
4. When you finish, click OK to close the Strategies dialog box.
5. In the Radiant software Process view, double-click Bitstream File to generate the bitstream files.

See Also
- “Bit Generation” on page 274
- “Bit Generation Output Files” on page 275
- “Bit Generation Considerations” on page 277
- “Running Bit Generation from the Command Line” on page 941

JTAG Setup

Using the bitgen program from the command line, you can generate setup bitstreams (.jbt) files to set JTAG port read and write for the FPGA device using the -J option. Downloading these setup bitstreams requires the serial cable with a JTAG cable connector.

See Also
- “Running Bit Generation from the Command Line” on page 941

JTAG Scan Chains

A scan chain can include any programmable or non-programmable device compliant with IEEE-1149.1. It can also include any programmable devices that are compatible with IEEE-1149.1 but do not have a boundary scan register. This decision should be made on the basis of the test methodology employed for the board. If the test methodology employed is the traditional bed-of-nails approach used on board test systems, all the devices can be included in the same chain.
All scan chains use the simple four-wire TAP. The TCK and TMS pins are common to all devices included in the chain. TDI and TDO are daisy-chained from one device to the next. The input to the chain is TDI, and the output from the chain is TDO. A diagram demonstrating a simple scan chain is shown in Figure 27.

**Figure 27: Diagram of a JTAG Scan Chain**

---

**Bit Generation Considerations**

Note the following information that may require additional steps to implement bit generation options properly.

- If the device is to be configured in other than a serial (master or slave) mode, there are some limitations involving startup options and configuration pins used as outputs after configuration.

- Some former `-g` options for `bitgen`, which correspond to former strategy settings for `Bitgen` in the Strategies dialog box, are now handled by setting SYSCONFIG keyword values.

**See Also**

- "Bit Generation Options" on page 275

---

**Analyzing your Design using Soft Error Injection**

Ambient radiation occasionally collides with a circuit component in a way that alters its logical state. This effect is strongest at high altitudes, where the Earth’s protective electromagnetic field is weaker. SEI (Soft Error Injection) Editor allows you to generate single-bit errors, insert them into a bitstream, and detect them for analysis, simulating the effect of radiation damage on the device’s configuration memory. SEI Editor currently supports the following devices:

- LIFCL
- LFD2NX
SEI Editor is available after you have placed and routed your design and generated a bitstream.

See Also
- “Running SEI Editor” on page 278
- “Adding and Configuring a New Error with SEI Editor” on page 279
- “Removing an Error with SEI Editor” on page 280
- “Inserting an Error into a Device Using SEI Editor” on page 280

Running SEI Editor
You can run SEI Editor after you have placed and routed your design and generated a bitstream.

To run SEI Editor:
- Choose Tools > SEI Editor

SEI Editor appears.

SEI Editor can manage multiple errors with a variety of options. The SEI Editor toolbar has three buttons:
- Run — Run all selected error insertions.
- Add — Add a new error for insertion.
- Remove — Remove the selected error insertion.

SEI Editor has the following columns:
- Enable — Select this option to insert the error described on the current row.
- ID — The error’s ID number. This value is read-only.
- SEI File name — The name of the file containing the inserted error. You can modify this filename by double-clicking it and entering a new name.
- Method — This option determines whether the error is inserted into an unused or random block. Selecting Unused inserts the error into an unused block, which will not affect the design logic. Selecting Random inserts the error into a random block, which may or may not affect the
design logic. You can change an error’s Method by double-clicking it and selecting a new value from the drop-down menu.

- **Block**
  If Method option is set to “Unused”, this option specifies the block where the error was inserted, in one of the following categories:
  - PFU
  - EBR
  - DSP
  - ANY (any of PFU, EBR or DSP)

You can direct errors into unused PFU, EBR, DSP blocks. You can change the destination Block by double-clicking it and selecting a new value from the drop-down menu.

If Method option is set to “Random”, after you run in SEI Editor, the Block will automatically display either Routing or Unclassified, which indicate errors in Routing or any blocks such as PFU, EBR, DSP or Routing.

- **Site** — The exact Site of the inserted error. Errors inserted into a Routing block or Unclassified block do not have a Site. This field is read-only.
- **Frame** — The data frame of the inserted error. This field is read-only.
- **Bit In Frame** — The bit of the inserted error within the displayed data frame.

**See Also**

- “Analyzing your Design using Soft Error Injection” on page 256
- “Adding and Configuring a New Error with SEI Editor” on page 279
- “Removing an Error with SEI Editor” on page 280
- “Inserting an Error into a Device Using SEI Editor” on page 280

### Adding and Configuring a New Error with SEI Editor

You can use SEI Editor to add new errors to your design.

**To add and configure a new error:**

1. Click **Add**.

   The tool adds a new, unconfigured error to the list.

2. Select the option in the Enable column to enable the new error.

3. Choose a new filename for the inserted error by double-clicking the current filename, typing a new one, and pressing Enter.

4. Choose a method by double-clicking the current method and selecting your preferred method from the drop-down menu.
   - If this error’s method is Unused, you can choose a block by double-clicking the current block and selecting your preferred block from the drop-down menu.
IMPLEMENTING THE DESIGN: Bit Generation

Removing an Error with SEI Editor
You can remove a previously inserted error from your design using SEI Editor.

To remove an error:
1. Click a cell in the row of the error you want to remove.
2. Click Remove.

Inserting an Error into a Device Using SEI Editor
Once you have inserted an error into your design, you can insert the error into your device using Radiant Programmer.

To insert the selected errors into a device:
1. Click Run.
   The SEI tool generates a partial bitstream with the selected errors.
2. Program the original bitstream into the device using Radiant Programmer. Refer to “Programming the FPGA” on page 328.
3. In Radiant Programmer, program the partial bitstream into the device using the Static Random Access Memory (SRAM) > Background Programming > SEI Fast Program Programmer settings.

See Also
► “Analyzing your Design using Soft Error Injection” on page 256
► “Running SEI Editor” on page 278
► “Removing an Error with SEI Editor” on page 280
► “Inserting an Error into a Device Using SEI Editor” on page 280
Analyzing Static Timing

Static timing analysis can determine if your circuit design meets timing constraints. Rather than simulation, it employs conservative modeling of gate and interconnect delays that reflect specific operating conditions with a specific FPGA.

You can produce timing analysis reports as part of the synthesize, map, and place-and-route processes. Before running a process, click the Task Detail View in the Process Toolbar and select Timing Analysis for that process.

The reports have similar information shown in the same format. But they are based on information from each process:

- Post-synthesis timing analysis is based on pre-synthesis constraints and estimates of delays.
- Map timing analysis is based on post-synthesis constraints, the actual types of components, and estimates of the routing delays.
- Place-and-route timing analysis is based on post-synthesis constraints, and the actual components and routing.
- Place-and-route I/O timing analysis reports the setup and hold slack for each port that has a timing constraint.

All the reports can be read in the Reports tab.

An alternative to generating the Place & Route Timing Analysis report is the Timing Analyzer tool. Instead of a text report, Timing Analyzer gives you a spreadsheet view that you might find easier to read. Timing Analyzer also has a search function to help you find different data paths.
Options for Timing Analysis Reports

There are several options that can be set for each timing analysis. For the post-synthesis, map, and place-and-route reports, you can specify whether you want hold or setup analysis, the device performance grade, and the number of paths and endpoints in the report.

You can also change the style of the report with the Report Format option. The default is the current Lattice Standard, which follows industry standards for timing analysis tools. But if you have been using the Lattice Diamond tool set, you might prefer the older Diamond Style. One of the key differences is that Lattice Standard provides more information in its detailed description of data paths.

I/O timing analysis has an option to analyze the ports for all the speed grades of the FPGA.

Options are set in the implementation strategies. For more information, see:

- “Specifying Strategy Options” on page 37
- “Post-Synthesis Timing Analysis Options” on page 534
- “Map Timing Analysis Options” on page 536
- “Place & Route Timing Analysis Options” on page 540
- “IO Timing Analysis Options” on page 541

Reading Timing Analysis Reports

The post-synthesis, map, and place-and-route timing analysis reports have four major sections.

1 DESIGN CHECKING “Design Checking” shows the constraints and operating conditions that guided the analysis. It also shows a list of combinational loops that could not be analyzed.

2 CLOCK SUMMARY “Clock Summary” shows an analysis for each clock domain defined in the constraints. The analysis shows the target frequency versus the actual (or maximum possible) and MPW (minimum pulse width) frequencies.

The “Clock Domain Crossing” section shows the slack with any other clocks that connect with the given domain. That is, a data path that has different clocks for its start and end points.

3 TIMING ANALYSIS SUMMARY “Timing Analysis Summary” shows a variety of data including lists of the ten worst data paths for setup slack and for hold slack, unconstrained timing start and end points, unconstrained I/O ports, and registers without clocks.
It is not necessary or desirable for all paths to have constraints. Check section 3.4, "Unconstrained Report" to make sure that all of the important paths are constrained.

4 DETAILED REPORT  “Detailed Report” shows details of the worst paths for setup slack and for hold slack. Each path has a section that starts with a summary of the path and the results of the analysis. This is followed by a table calculating the delay step by step through the path, beginning with the clock at the start of the path and ending with the clock at the end of the path. Each step includes the name of the pin within the FPGA and the hierarchical name of the module’s port, the type of delay, and the fanout from the pin.

If you want to visualize the path, the reports have links to other tools. Physical Designer Placement Mode shows the sites within the FPGA. Physical Designer Routing Mode shows the route within the FPGA. (Physical Designer is only available after place-and-route.) Netlist Analyzer shows a schematic view of the design. However, Netlist Analyzer often cannot show the detailed path.

Using Timing Analyzer

Timing Analyzer is a different way to look at the place-and-route timing analysis that you might find easier to read. Timing Analyzer runs the timing analysis and presents the results on three spreadsheet tabs. Plus, there is a Query tab so you can search through the paths. The information in Timing Analyzer is very similar to that in the Place & Route Timing Analysis report but is presented differently.

Timing Analyzer can be run anytime after completing the place-and-route process. You do not need to select timing analysis in the Task Detail View of the Process Toolbar.

To use Timing Analyzer:

- Choose Tools > Timing Analyzer.
  
  A progress indicator opens, showing that the Radiant software is calculating the delays. This takes a moment. Then Timing Analyzer appears in the Tool Area.

Setting Options in Timing Analyzer

Timing Analyzer has the same options as the Place & Route Timing Analysis Report. But the options are set independently in Timing Analyzer.

The current option settings can be seen on Timing Analyzer’s General Information tab.

To change the timing option settings:
The Timing Option Setting dialogue box appears.

2. Choose option settings. See below for more information.

3. Click **OK**.

A progress indicator opens, showing that the Radiant software is calculating the delays. This takes a moment. Then the Timing Analyzer tabs are updated.

Here are definitions of each option:

- **Run Mode:** Choose whether you want setup or hold analysis, or both.
- **Speed for setup:** Choose the performance grade of the FPGA. "m" is for the fastest performance grade.
- **Speed for hold:** Choose the performance grade of the FPGA. "m" is for the fastest performance grade and is usually the worst case for hold analysis.
- **Report Format:** Choose the style of the report. The default is the current Lattice Standard, which follows industry standards for timing analysis tools. But if you have been using the Lattice Diamond tool set, you might prefer the older Diamond Style.
- **Critical endpoints path number limit:** Enter the number of data paths you want in the Critical Endpoint Summary tab.
- **Unconstrained endpoints path number limit:** Enter the number of data paths you want in the Unconstrained Endpoint Summary tab.
- **Number of paths per constraint:** Enter the number of data paths you want for each constraint in the Critical Paths Summary tab.
- **End point number limit:** Enter the number of endpoints you want in the Critical Endpoint Summary tab.
- **Maximum slack limit:** Enter the maximum delay value for the slack in picoseconds.

### Reading Timing Analyzer

Timing Analyzer has five tabs arranged along the bottom of the view. These tabs have information similar to sections 3 and 4 of the Place & Route Timing Analysis report. The information from sections 1 and 2 are not included. See "Reading Timing Analysis Reports" on page 282.

**General Information**  
This tab shows basic information about the FPGA and the option settings used in the analysis.

**Critical Paths Summary**  
This tab shows the same information as section 4, “Detailed Report,” of the text report. At first you just see introductory information for the paths. You can see the full details on any path by clicking anywhere in the row of that path. See Path Details in Timing Analyzer.

**Note**

The data in this tab is presented in picoseconds, not nanoseconds.
Critical Endpoint Summary  This tab shows the same information as section 3.2, “Setup Summary Report,” and section 3.3, “Hold Summary Report,” of the text report. You can see the full details on any path by clicking anywhere in the row of that path. See Path Details in Timing Analyzer.

Unconstrained Endpoint Summary  This tab shows the same information as section 3.4, “Unconstrained Report,” of the text report.

Query  This tab shows a query form to search for data paths. Select a source clock, destination clock, start point, or end point. You can select one or several items. Click Search to find associated data paths.

Any paths found are shown in a spreadsheet view at the bottom of the form. Again, you might want to enlarge the view by detaching the tool as a separate window. You can see the full details on any path by clicking anywhere in the row of that path. See Path Details in Timing Analyzer.

You can also save queries for future use.

Path Details in Timing Analyzer

In Timing Analyzer, you can see details on any data path listed in the Critical Path Summary, Critical Endpoint Summary, and Query tabs. These details are similar to what you see in section 4, “Detailed Report,” of the text report.

If you want to visualize the data path, you can cross-probe to Physical Designer.

You can also export the data to a .csv (comma-separated value) file that can be read by other software, such as a spreadsheet tool. See Exporting a Path Analysis.

To see path details:

1. Click anywhere in the row of the desired path.

   The window splits into three parts. On the right are two new sections with three tabs. These three tabs have the extra information about the selected path. You might want to enlarge the view by detaching the tool as a separate window.

   The Path Detail tab shows the same the introduction to the path seen in the text report. There are also some delay calculations for the destination and source clocks.

   The third part has two tabs for the table calculating the delay step by step through the path. Data Path shows the steps. Clock Paths shows the clocks at the start and end of the path.

To cross-probe to Physical Designer:

1. Right-click any row in the Data Path or Clock Paths tabs and choose:

   ▶ Show in Physical Designer Placement Mode
Show in Physical Designer Routing Mode
Physical Designer opens showing the path in the desired mode.

Exporting a Path Analysis
You can export the analysis from an individual path to a .csv (comma separated file) that can be read by other software, such as a spreadsheet tool. You can do this from any path in the Critical Path Summary, Critical Endpoint Summary, and Query tabs. The Export command saves all the data in the tab plus all the detail data for the selected path.

To export path data:
1. Right-click anywhere in the row of the desired path and choose Export.
   The Export dialog box opens.
2. Browse to where you want to save the .csv file.
3. Enter a file name.
4. Click Save.
Chapter 9

Analyzing Power Consumption

Included with the Radiant software is Power Calculator, which estimates the power dissipation for a given design. Power Calculator uses parameters such as voltage, temperature, process variations, air flow, heat sink, resource utilization, activity, and frequency to calculate the device power consumption. It reports both static and dynamic estimated power consumption.

Power Calculator allows you to import frequency and activity factors from the post-PAR simulation file (.vcd file). After the design information is added, Power Calculator provides accurate power consumption analysis for the design.

Power Calculator provides two modes for reporting power consumption:

- Estimation mode: Used before completing the design;
- Calculation mode: Based on the physical netlist file (.udb) after placement and routing.

You can open Power Calculator from within the Radiant software or as a stand-alone tool from the Windows Start menu. Either method provides both estimation mode and calculation mode functionality. A stand-alone Power Estimator is also available, which allows you to estimate power consumption without having the Radiant software installed.

**Calculation Mode**  Within the Radiant software environment, Power Calculator calculates power based on the project’s files, including device information. This information is automatically extracted when you open Power Calculator from within the Radiant software. In the stand-alone Power Calculator, power consumption is calculated based on a selected native circuit description (.udb) file or power calculator file (.pcf).

**Estimation Mode**  Within the stand-alone Power Calculator or Power Estimator, the Startup Wizard enables you to estimate power based on a selected device, and it gives you the option of including a template of
ANALYZING POWER CONSUMPTION : Starting Power Calculator from the Radiant Software

resource settings. Within the Radiant software environment, Power Calculator estimates power for an unrouted design. After the design is routed, it enables you to change the device family or other data and obtain the estimated power consumption.

See Also ▶ “Software Mode” on page 293
▶ “Starting Power Calculator from the Radiant Software” on page 288
▶ “Starting Power Calculator as a Stand-Alone Tool” on page 288
▶ “Power Analysis Design Flow” on page 290

Starting Power Calculator from the Radiant Software

Power Calculator is available from the Radiant software as soon as a project is opened.

To start Power Calculator from the Radiant software Tools menu or toolbar:

1. Open a project or create a new one.
2. Choose Tools > Power Calculator or click the button on the toolbar.

Power Calculator opens in estimation mode or calculation mode, depending on the design stage, and displays the Power Summary page.

You can also start Power Calculator by creating or opening a new Power Calculator file (.pcf):

▶ Use the File menu or the Analysis Files folder to create a new Power Calculator file (.pcf).

Power Calculator opens and loads the newly created .pcf file.

▶ Use the File menu or the Analysis Files folder to open an existing .pcf file.

Power Calculator opens in estimation mode or calculation mode, depending on the status of the selected .pcf file.

See Also ▶ “Running Power Calculator from the Tcl Console” on page 290
▶ “Saving a Power Calculator File” on page 302
▶ “Adding Power Calculator Files to the Analysis Files Folder” on page 304
▶ “Setting a Power Calculator File as the Active Analysis File” on page 305

Starting Power Calculator as a Stand-Alone Tool

Power Calculator is available as a stand-alone tool from the Windows Start menu. This allows you to work with a Power Calculator project, in calculation mode or in estimation mode, without opening the Radiant software. The
Startup Wizard enables you to create a new Power Calculator project, based on a selected device or a processed design, or to open an existing Power Calculator project file (.pcf).

**To start Power Calculator as a stand-alone tool:**
1. In the Start menu, choose **Lattice Radiant Power Calculator**.
2. After the Power Calculator Startup Wizard appears, do one of the following and click **OK**:
   - To calculate power consumption based on a mapped or placed and routed design, select **Calculate power with design (udb)**.
     Click the UDB File Browse button to navigate to the .udb file.
     After you select the .udb file, the File Name and File Directory boxes are automatically filled in by the Startup Wizard. If you want to give the Power Calculator project file a different name than the .udb file name, type the name in the File Name text box.
   - To estimate power consumption based on a selected device, select **Estimate power with device selection**.
     The device selection menus appear at the bottom of the Startup Wizard.
     Type a name for the Power Calculator project file in the File Name box and browse to the desired directory for the project. Make your selections from the device menus.
     If you would like to use a template of resource settings, select the **Use Template** option, click **Select**, and do one of the following:
       - Select **Specify Resource by Design Type**, and then select the design type from the drop-down menu and click **OK**.
       - Select **Specify Resource by Component Utilization**, and then select from the options provided and click **OK**.
         The Use Template text box displays the resource settings or the design type that you selected.
         When you click OK, Power Calculator opens in estimation mode and loads the device settings you specified.
   - To open an existing Power Calculator project, select **Open existing PCF file**.
     Click the Browse button to navigate to the .pcf file.
     When you click OK, Power Calculator opens in estimation mode or calculation mode, depending on the status of the .pcf file.

**See Also**
- "Running Power Calculator from the Tcl Console" on page 290
- “Saving a Power Calculator File” on page 302
Running Power Calculator from the Tcl Console

The Radiant software’s Tcl console window enables you to use Tcl commands to perform many power analysis functions. For a complete list and descriptions of Power Calculator Tcl commands, see “Tcl Command Reference Guide” on page 956 in the Tcl Command Reference Guide.

See Also  ➤“Tcl Command Reference Guide” on page 956

Power Analysis Design Flow

Power Calculator supports all Lattice FPGA devices. The design flow involved in using Power Calculator in the Radiant software is as follows.

Figure 28: Power Calculator Design Flow

See Also  ➤“Inputs” on page 290
➤ “Outputs” on page 291

Inputs

When you first launch Power Calculator from the Radiant software, it displays information from your design project. For an unrouted design, it shows default resource information based on the targeted device. For a routed design, it extracts information from the placed and routed .udb file.
Additionally, Power Calculator accepts the following as optional input.

- Value change dump file, `<project_name>.vcd`, which is an ASCII file containing activity and frequency information. Its format is specified by the IEEE 1364 standard. It should be in the format of gate-level simulation and match the design. The .vcd file preserves waveform information that can be displayed in third-party tools such as Active-HDL.

  If you provide a post-routed simulation .vcd file, Power Calculator looks up the clock signals in the .vcd file and compares them to each clock in the Power Calculator pages. If the clock names match, Power Calculator takes the frequency data from the .vcd file and populates the frequency columns, the activity factor (AF(%)) columns, or all, in the pages that contain these columns.

- Timing report file, `<project_name>.twr`, is an ASCII file containing activity and frequency information. The type of frequency and setting can be imported from the timing report file as shown in Figure 29.

Figure 29: Frequency Settings

![Frequency Settings](image)

See Also
- “Importing a Value Change Dump (.vcd) File” on page 311
- “Changing the Global Default Activity Factor” on page 310

Outputs

Power Calculator generates power calculation results in tabular format from information extracted from the design project. All of this information, when saved, is kept in the project’s Power Calculator file (.pcf).

Power Calculator also generates a power calculation report, which can be viewed in HTML or text format. It also generates power graphs that show how power consumption is affected with varying voltage, temperature, and clock frequency.

See Also
- “Saving a Power Calculator File” on page 302
Static and Dynamic Power Consumption

Power Calculator reports the dynamic and static portion of the power dissipation. Power refers to the power consumed by the design. It is based on the extracted data from a placed and routed design file (.udb) or on the estimation information that you provide.

The dynamic portion is the power consumed by the used resources while they are switching. The power dissipation of the dynamic portion is directly proportional to the frequency at which the resource is running and the number of resource units used.

The static portion of power consumption is the total power consumed by the used and unused resources.

Activity Factor Calculation

To calculate the power consumption for the routing interconnect, logic, and the read/write ports in an embedded block, Power Calculator requires a frequency and an activity factor percentage. The activity factor percentage is the percentage of time that a registered output node is active relative to a specified clock. Most of the resources associated with a clock domain run or toggle at a percentage of the frequency at which the clock runs.

The frequency appears as the “Freq. (MHz)” column on most pages. The activity factor percentage appears as the “AF (%)” column.

Enable Factor Calculation

To calculate the power consumption in some IPs, such as IO, DDHY, etc., Power Calculator requires an enable factor “EF (%)” from percentage from 0 to 100%. The enable factor percentage is the percentage of time that a IP mode usage.

The enable factor percentage appears as the “EF (%)” column.
Power Calculator Window Features

Power Calculator main window displays the software mode being used and the currently selected page of power consumption information. When you first open Power Calculator, the Power Summary page appears by default. All other pages of information for the device are made available from the tabs arranged at the bottom of the main window. This section describes these features and the color coding of cells.

Software Mode

The Software Mode in the top right corner of the Power Calculator window indicates whether Power Calculator is running in estimation or calculation mode. This field is read-only.

Estimation Mode  In estimation mode, Power Calculator provides estimates of power consumption based on the device resources or template that you provide. This mode enables you to estimate the power consumption for your design before the design is complete or even started. It is useful for "what if" analysis. You must supply the frequency, activity factor, and voltage.

Calculation Mode  In calculation mode, Power Calculator calculates power consumption on the basis of device resources taken from a design’s .udb file, or from an external file such as a .vcd file, after placement and routing. This mode is intended for accurate calculation of power consumption, because it is based on the actual device utilization.

Reverting to Estimation Mode  Power Calculator will revert to estimation mode from calculation mode in the following circumstances:

- If you start using Power Calculator in calculation mode and change the data in any cell other than AF (%), Freq., V., Dynamic Power Multiplier, Ambient Temperature, Performance Grade, Operating Condition, or Process Type, Power Calculator will automatically revert to estimation mode.

- Rerunning a process before Place & Route will change the software mode if you are working with the unsaved "untitled" temporary power calculator file. For example, if you rerun Map Design while in calculation mode using the "untitled" file, the tool will revert to estimation mode. If you are working with a saved .pcf file, the software mode will not change when you rerun a process.

Reverting to Calculation Mode  For many types of changes, Power Calculator enables you to revert to calculation mode from estimation mode, if you have not yet saved the changes to the .pcf file. See "Reverting to Calculation Mode" on page 310 for more information.
Power Summary

Power Summary provides an overview of power consumption conditions. It is the first page that opens when you run Power Calculator. The Power Summary enables you to change the targeted device, operating conditions, voltage, and other basic parameters. Updated estimates of power consumption are then displayed based on these changes.

Device

The Device section enables you to select a device family, package, part name, performance grade, and operating conditions. It displays power information based on these selections.

You can specify one of the following operating conditions, depending on the device. As this is device dependent, please refer to the device data sheet for more accuracy.

- Industrial – Devices are rated at 105 degrees Celsius.
- Commercial – Devices are rated at 85 degrees Celsius.
- Automotive – Devices are rated at 125 degrees Celsius.

Device Power Parameters Section

The Device Power Parameters section contains information pertaining to the device process conditions and power model status.

The process type specifies the corners or conditions under which the device was manufactured. It can be one of the following:

- Typical – to reflect the typical amount of current consumed by the circuit.
- Worst – to reflect the maximum amount of current consumed by the circuit.

The Power File Revision displays the status of the model:

- Advanced – The power file has all the constants, functions, formulas, and defaults. The constants are based on silicon simulation data without extracted layout parameters. The status of this file is “advanced.”
- Preliminary – The power file has all the constants, functions, formulas, and defaults. The constants are based on nominal silicon characterization data rather than simulation data. The status of this file is “preliminary.”
- Final/Production – The power file has all the constants, functions, formulas, and defaults. The constants are based on silicon characterization data that includes characterization of corner lots and conditions rather than simulation data. The status of this file is “production.”

Environment Section

The Environment section displays information about the operating temperature of the device. The Thermal Profile button enables you to choose the thermal impedance model for the power-consumption or current-consumption calculation. The Ambient Temperature cell allows you to specify the surroundings at which the device is expected to operate, in degrees Celsius. Temperature values must be between -40 and +125 degrees Celsius.
Effective Theta-JA specifies the cumulative thermal impedances of a particular system. This figure is used in calculating the junction temperature (Tj) of a die in a particular environment according to the following formula:

\[ Tj = \text{power} \times \theta_{\text{effective}} + \text{ambient\_temperature} \]

Junction Temperature specifies the temperature of the device within the device package, in degrees Celsius. You can adjust the junction temperature by using the models in the Thermal Profile dialog box. If the calculated value in the Junction Temperature box is either higher than 125 degrees Celsius or higher than the maximum junction temperature allowed for a particular device and operating conditions, a red text appears in the Junction Temperature box.

Maximum Safe Ambient specifies the maximum safe operating temperature for a die. If this temperature is exceeded, the semiconductor physics of the silicon change, so the die can operate erratically. The life of the device is also shortened.

**Voltage/Dynamic Power Multiplier**  This section contains information about the estimated power or current consumption by power supply. The Dynamic Power Multiplier specifies the derating factor for the dynamic portion of the power consumption. Power Calculator does not include derating for dynamic power. This factor enables you to change the number by the derating factor that you want to apply. The derating factor specified must be between 0.5 and 2. The default is 1.0.

**Current by Power Supply**  This section displays the static, dynamic and total current consumption in amperes.

**Power by Power Supply**  This section displays the static, dynamic, and total power consumption in watts.

**Power by Block**  This section displays the total power consumption by the different types of blocks, in watts.

**Peak Startup (A)**  This section shows how much peak startup current each supply in the design draws, in amperes. When the “N/A” notation appears in this column, it means that no data is available yet. However, you can call Lattice Semiconductor Technical Support for this information.

**Power Calculator Pages**

Each time Power Calculator opens, it displays the Power Summary, which shows the targeted device, operating conditions, voltage, and other basic information. Additional pages are available from the tabs arranged at the bottom of the window. Except for Graph and Report, each of these pages allows you to view, edit, and add elements. The number and types of pages that are available depends on the selected device.
Pages Available for Most Device Families

**Block RAM**  The Block RAM page displays the power consumed by the embedded block RAM (EBR) in the design and the factors that affect it. Power-consumption calculation for the Block RAM page requires the frequency and activity factor per clock domain.

**Misc**  The Misc page includes any non-generic IP, such as oscillators, i2c, and spi. These IPs do not have their own page due to negligible power contribution. For LIFCL and LFD2NX devices, the Misc page enables you to calculate its CRE block power.

**PLL**  The PLL page displays the estimated power consumed by the phase locked loops in the design and the factors that influence it. The power-consumption calculation is based on the input frequency, the number of PLLs in the design, and internal feedback architecture of PLL in the device. The PLL page is available for all devices.

**Power Matrix**  The Power Matrix page shows the amount of power pulled by each component in the design from multiple power sources. Two tabs are provided, allowing you to view the current usage (A) and power usage (W) of each type of component.

**Logic Block**  The Logic Block page displays the estimated power consumed by the logic in the design and the factors that affect it. Power-consumption calculation in the Logic section requires both the frequency and an activity factor per clock domain. Power calculation is also based on the specified number and enable factor of LUTs, distributed RAMs, ripple-carry logic circuits, and registers driven by the clock.

**Clocks**  The Clocks page displays the estimated power consumed by the clocks in the design and the factors that affect it. Dynamic power calculation is based on the frequency of each clock.

The Clocks page only reports clocks that go to the clock tree, such as Primary Clock, Secondary Clock and Edge Clock.

**I/O**  The I/O page displays the estimated power consumed by the I/Os in the design and the factors that affect it. The power-consumption calculation for this page requires the frequency, activity factor, and number of inputs or outputs per clock domain. For bidirectional signals, it requires the number of bidirectional I/Os, input and output frequency, and input and output activity factor per clock domain. If you use an .udb file, Power Calculator extracts the information for the I/O page directly from the .udb file. If you do not use an .udb file, Power Calculator assigns the default resource usage values according to the design's family.

**I/O Termination**  The I/O Termination page enables you to provide information about external terminations for the I/Os. You can specify the average equivalent thevenin resistive load in ohms (Rth) and the equivalent
thevenin voltage in volts (Vth). Power-consumption calculation is based on the power consumed by the external termination that you provide.

**Graph**  The Graph page displays three types of graphs:

- Power vs. VCC Supply Voltage
- Power vs. Ambient Temperature
- Power vs. Frequency

Each graph displays two plots—typical and worst case. Use the Edit > Graph Settings command to change the graphs to be displayed. The dialog box enables you to specify the range, step, X axis, and Y axis of each graph. See “Generating Power Graphs” on page 319 for more information.

To prevent any unnecessary calculations and additional processing time, graphs are only generated when you select the Graph tab. During the graph generation time, you cannot change tabs and must wait for the graph calculations to finish before performing any other action. If you switch tabs and change any information that will alter the power, the graphs will be regenerated when you next select the Graph tab.

**Report**  The Report page contains a summary of the estimated power-consumption or current-consumption data calculated by Power Calculator. Information is taken from the Power Summary and from each page of the Power Calculator user interface.

In the Power Model section, the Status can be Preliminary, Advanced, or Final.

- Preliminary – The power file has all the constants, functions, formulas, and defaults. The constants are based on nominal silicon characterization data rather than simulation data.
- Advanced – The power file has all the constants functions, formulas, and defaults. The constants are based on silicon simulation data without extracted layout parameters.
- Final/Production – The power file has all the constants, functions, formulas, and defaults. The constants are based on silicon characterization data that includes characterization of corner lots and conditions rather than simulation data.

The report is available in both text (ASCII) and HTML. It is updated each time you make a change to any of the data in the editable cells.

**Pages Dependent on Selected Device/ Device Architecture**

**LED**  The LED page allows you to generate the constant current sources. The signal name for Input is “EN” and “LEDPU” for Output. Default Signal Value for unconnected port: Input is “0”

Input EN : Logic “0”

The LED page is available for iCE40UP device only.
**DSP**  The DSP page displays the estimated power consumed by the digital signal processors in the design and the factors that affect it. The power-consumption calculation for this page requires the frequency, activity factor, enable factor, and the type and number of DSPs driven by each clock.

**SRAM**  The SRAM page displays the power consumed by the single port RAM used by the design and the factors that affect it. Power-consumption calculation for the SRAM page requires the frequency and activity factor per clock domain.

**LRAM**  The LRAM page displays the power consumed by the Large RAM blocks and the factors that affect it. It allows the entry of LRAM type, frequency, activity factor, enable factor, and number of blocks.

The LRAM page is available for LIFCL and LFD2NX devices only.

**SGMIICDR**  The SGMIICDR page displays the power consumed by the SGMII (Serial Gigabit Media Independent Interface)/CDR (Clock Data Recovery) blocks and the factors that affect it. It allows the entry of frequency, activity factor, enable factor, and number of blocks.

The SGMIICDR page is available for LIFCL and LFD2NX devices only.

**DDRDLL**  The DDRDLL page displays the power consumed by the DDRDLL (Double Data Rate Delay Locked Loop) master delay control blocks and the factors that affect it. It allows the entry of frequency, activity factor, enable factor, and number of blocks.

The DDRDLL page is available for LIFCL and LFD2NX devices only.

**DLLDEL**  The DLLDEL page displays the power consumed by the DLLDEL (Delay Locked Loop Delay) slave delay blocks and the factors that affect it. It allows the entry of frequency, activity factor, enable factor, and number of blocks.

The DLLDEL page is available for LIFCL and LFD2NX devices only.

**DQS**  The DQS page displays the power consumed by the DQS (DDR memory strobe) blocks and the factors that affect it. It allows the entry of DQS gearing mode, frequency, activity factor, enable factor, and number of blocks.

The DQS page is available for LIFCL and LFD2NX devices only.

**MIPIDPHY**  The MIPIDPHY page displays the power consumed by the MIPIDPHY (Mobile Industry Processor Interface Physical layer) blocks and the factors that affect it. It allows the entry of data rate, activity factor, and duty cycles for transmit/receive and low power/high speed.

The MIPIDPHY page is available for LIFCL device only.

**ADC**  The ADC page displays the power consumed by the ADC (Analog to Digital Converter) block and the factors that affect it. It allows the entry of frequency, activity factor, enable factor, number of blocks, and comparator enables.
The ADC page is available for LIFCL and LFD2NX devices only.

**ALU**  The ALU page displays the power consumed by the ALU (Arithmetic Logic Unit) block and the factors that affect it. It allows the entry of frequency, activity factor, enable factor, and number of blocks.

The ALU page is available for LIFCL and LFD2NX devices only.

**PCIE**  The PCIE page displays the power consumed by the PCIe (Peripheral Component Interconnect Express) hardened block and the factors that affect it. It allows the entry of activity factor, enable factor, number of blocks, and PCIe speed. The data rate (2.5G, 5G, 8G) cannot be input directly, it is based on the type.

The PCIE page is available for LIFCL and LFD2NX devices only.

---

**Color Coding of Cells**

The background colors of the cells on Power Calculator pages have the following significance:

- **White** – The cell is editable. When you edit the contents of this type of cell, the software mode does not change. If the software is in calculation mode, it will remain in calculation mode. If the software is in estimation mode, it will remain in estimation mode.

- **Green** – The cell is read-only or contains output from the software.

- **Lite Yellow** – The cell contains data extracted from a design file, such as an .udb file. If you enter data into this type of cell and the software is in calculation mode, it will change to estimation mode unless you enter data into the Performance Grade, Operating Conditions, and Process Type boxes. If the software is in estimation mode, it will remain in estimation mode.

- **Red** – The calculated value in the Junction Temperature box is either higher than 125 degrees Celsius or higher than the maximum junction temperature allowed for a particular device and operating conditions. The Junction Temperature box is the only cell that can display red text.

The font colors in the cells on Power Calculator pages have the following significance:

- **Blue** – Indicates default values.

- **Grey out** – Indicates values that cannot be edited on the I/O page. Since the I/O page has columns for inputs, outputs, and bidirectionals, red font prevents you from altering an I/O that is not valid. For example, if the I/O type belongs only to an I/O input, the cell in the # of Inputs column would display a value in black font, indicating that it is editable. The cells in the # of Outputs and the # of Bidi columns, however, would display values in gray font to indicate that they cannot be edited.

- **Black** – Indicates all other text.
Working with Power Calculator Files

When you first open Power Calculator for a design project, it creates a temporary file that appears in the title bar as “Untitled.” This file contains default information, based on the device, or information extracted from the .udb file. When you enter data into Power Calculator pages and save the changes, the information gets stored in a Power Calculator file (.pcf). You can create a new Power Calculator file (.pcf) by saving the “Untitled” file. Or you can create a new .pcf file from the File menu before or after Power Calculator is opened.

When you use a .pcf file, rather than the “Untitled” temporary file, Power Calculator maintains the information it has already extracted from the .udb file. The saved .pcf file will not get overwritten when you rerun Map or Place & Route Design, and the software mode will not change.

This section describes how to create new Power Calculator files, how to work with multiple existing .pcf files, and how to activate a .pcf file and load it into Power Calculator. It also shows how to import a value change dump file (.vcd) for power calculation.

Creating a New Power Calculator File in the Radiant Software

You can create a new .pcf from the File menu or from the Analysis Files folder pop-up menu. You can do this before or after opening Power Calculator.

To create a new .pcf file:

1. In the Radiant software, do one of the following to open the New file dialog box:
   - choose File > New > File
   - Press Ctrl+N.
   - Right-click the Analysis Files folder in the File List pane and choose Add > New File from the pop-up menu.

2. In the New file dialog box, select Power Calculator Files from the Source Files list.

3. Type a name for the new .pcf file in the name box.

4. In the Location box, enter the path and name of the directory where the Power Calculator file (.pcf) is to be stored. You can use the Browse button to navigate to the desired directory. By default, the file is stored in the current project folder.

   The “Add to Implementation” option adds the new .pcf file to the Analysis files folder and is selected by default. If you do not wish the .pcf file to be added to the Analysis files folder for the current project, clear the “Add to Implementation” option. You cannot clear this option if you are using the Analysis Files folder to add a new file.
5. If your project contains more than one design implementation, select the
desired implementation from the drop-down menu. By default, the active
implementation is already selected.

6. Click **New** to create the .pcf file in the selected directory.

   If Power Calculator is already open and contains unsaved changes to the
current .pcf file, the Confirm dialog box will appear. Click **Yes** if you want
to save the changes or **No** to discard them.

   Power Calculator opens, if it is not open already. This might take a few
seconds. The new .pcf file is loaded into Power Calculator and its name is
displayed in the title bar. The .pcf file is added to the Analysis Files folder
where its name is highlighted in bold type, indicating that it is set as the
active .pcf file for the current implementation. Because the .pcf file is set
as active, it will be loaded automatically when you close and reopen
Power Calculator. When you rerun a process in the Radiant software, the
.pcf file will not get overwritten.

**Note**

Each time you create a new Power Calculator file through the File menu or the
Analysis Files pop-up menu, the new .pcf file is automatically set as the active one
for the current implementation unless you have cleared the "Add to
Implementation" option. To make the .pcf file inactive, right-click the file name in
the Analysis Files folder and choose **Set as Inactive**.

**See Also**

- “Inputs” on page 290
- “Saving a Power Calculator File” on page 302
- “Outputs” on page 291
- “Opening an Existing Power Calculator File in the Radiant Software” on
  page 303

**Creating a New Power Calculator File in the Stand-Alone Power Calculator**

If you have started Power Calculator as a stand-alone tool, you can create a
new Power Calculator project file (.pcf) from the File menu.

**To create a new .pcf file from the stand-alone Power Calculator:**

1. From the stand-alone Power Calculator, choose **File > New File**.
2. In the Power Calculator – New Project dialog box, type a name for the file
   and browse to the desired directory.
3. To use an existing .udb file for the project, browse to the location of the
   .udb file. Otherwise, leave the .udb box empty.
4. Click **OK**.
   
   If you selected an .udb file in Step 3, Power Calculator loads the new
   project in calculation mode. If you did not select an .udb file, Power
   Calculator loads the new project in estimation mode.
Saving a Power Calculator File

When you enter data into Power Calculator, an asterisk appears in both the title bar and the Power Calculator tab to indicate that there are unsaved changes. If you have not yet created a Power Calculator file (.pcf) for your project, or if no .pcf file has been set as the active file, “Untitled” will appear in the title bar. The “Untitled” file is a temporary file that contains default settings based on the device. To add power analysis changes to your project, you must save the “Untitled” as a .pcf file, open an existing .pcf file, or create a new one. Afterwards, you can simply click the Save button to write any changes to the .pcf file. You can also save an existing .pcf file to a different directory or file name.

To save the Untitled file:

1. Choose File > Save Untitled As, and in the dialog box, navigate to the desired directory.
2. Type a name in the file name box and click Save.
   
   The information entered in your project is saved in the .pcf file, and the .pcf file is automatically added to the Analysis Files folder in the File List pane.

To save changes to an existing Power Calculator file:

1. Choose File > Save or press Ctrl+S or click .

To save a Power Calculator file to a different directory or file name:

1. Choose File > Save <file_name>.pcf As to open the Save dialog box.
2. In the Save In box, navigate to the directory in which to save the .pcf file.
3. Type a different name in the File Name box.
4. In the Files of Type box, select Power Calculator File (.pcf).
5. Click Save.
   
   The saved .pcf file is added to the project’s Analysis Files folder in the File List pane.

See Also

►“Adding Power Calculator Files to the Analysis Files Folder” on page 304
► “Setting a Power Calculator File as the Active Analysis File” on page 305
► “Outputs” on page 291
Opening an Existing Power Calculator File in the Radiant Software

You can open an existing Power Calculator (.pcf) file in the Radiant software before or after opening Power Calculator. When you open a .pcf file in the Radiant software, the design information must match the information in the current project. You can open an existing .pcf file from the File menu, or from the Analysis Files folder.

To open an existing .pcf file from the File menu:

1. Choose File > Open > File or press Ctrl+O.
2. In the Open File dialog box, select Power Calculator Files (.pcf) from the Files of Type drop-down menu. If Power Calculator is already open, this will already be selected as the default file type.
3. Navigate to the directory that contains the desired .pcf file, select the file, and click Open.

Power Calculator opens automatically, if it is not already open. The Power Summary page is displayed and the information from the selected .pcf file is loaded. The name of the .pcf file appears in the title bar.

To open a recently opened .pcf file:

- Choose File > Recent Files > filename from the list of the four most recently opened files.

Note

When you open a .pcf file from the File menu, it is not automatically added to the Analysis Files folder. You must add it to the folder manually.

To open an existing .pcf file from the Analysis Files directory:

1. In the Radiant software, select the File List tab in the pane on the left.
2. Expand the Analysis Files folder.

You can open the active .pcf file, if it is not already open, or one that is not active. An active .pcf file appears in bold type.
3. Double-click the name of the .pcf file that you want to open. Optionally, right-click the file name and choose Open.

The information from the .pcf file is loaded into Power Calculator, and the name of the file appears in the title bar.

See Also

- “Adding Power Calculator Files to the Analysis Files Folder” on page 304
- “Setting a Power Calculator File as the Active Analysis File” on page 305
Opening an Existing Power Calculator File in the Stand-Alone Power Calculator

If you have opened Power Calculator as a stand-alone tool, you can open an existing Power Calculator file (.pcf) from the File menu.

To open an existing .pcf file from the stand-alone Power Calculator:
1. Choose **File > Open File**.
2. Navigate to the desired .pcf file and click **Open**.
   
   If you have unsaved changes in the currently loaded .pcf file, a Confirm message box will appear. Click **Yes** if you want to save the changes. Otherwise, click **No**.
   
   If an .udb file is associated with the selected .pcf file, Power Calculator loads the project in calculation mode. If no .udb file is associated with the .pcf file, Power Calculator loads the new project in estimation mode.

See Also
- “Saving a Power Calculator File” on page 302
- “Creating a New Power Calculator File in the Stand-Alone Power Calculator” on page 301

Adding Power Calculator Files to the Analysis Files Folder

The Radiant software enables you to add existing Power Calculator files (.pcf) to the Analysis Files folder. This gives you easy access to the .pcf files in your project and enables you to designate a .pcf file as the active one for a design implementation. When a .pcf file has been set as the active analysis file, it will be loaded into Power Calculator automatically when you close Power Calculator and reopen it.

You can add a .pcf file to the Analysis Files folder before or after starting Power Calculator.

To add an existing .pcf file to the Analysis Files directory:
1. In the Radiant software, select the File List tab in the pane on the left.
2. Right-click the Analysis Files folder and choose **Add > Existing File** from the pop-up menu.
3. In the dialog box, select **Analysis Files (*.pcf)** in the Files of Type box.
4. Navigate to the directory that contains the desired .pcf file, select it, and click **Add**.
The file is added to the Analysis Files folder. You can double-click the .pcf file to open it in Power Calculator.

**Note**

When you add a .pcf file to the Analysis Files folder, it is not automatically set as the Active .pcf file for the implementation. You must set it as the active file manually.

**See Also**

- “Removing Power Calculator Files from the Analysis Files Folder” on page 305
- “Creating a New Power Calculator File in the Radiant Software” on page 300
- “Setting a Power Calculator File as the Active Analysis File” on page 305

## Removing Power Calculator Files from the Analysis Files Folder

There may be times when you want to remove files from the Analysis Files folder to make room for others. When you remove a Power Calculator File (.pcf) from the Analysis Files folder, it is not deleted from your project. You can always add it back later.

**To remove a .pcf file from the Analysis Files folder:**

- Right-click the file name and choose **Remove**.
  
  The file is removed from the Analysis Files list, but it remains in your project directory.

## Setting a Power Calculator File as the Active Analysis File

In order for Power Calculator to load a specific Power Calculator File (.pcf) each time it opens, you must designate the .pcf file as the active one for the implementation. This is done automatically when you create a new .pcf file. If no .pcf file has been set as the active one, Power Calculator will extract information from the placed and routed .udb file when you open Power Calculator. If no .udb file is available, it will display default resource information based on the targeted device.

**To set a .pcf file as the active analysis file:**

1. Make sure that you have added the desired .pcf file to the Analysis Files folder.
2. Right-click the desired .pcf file in the Analysis Files folder and choose **Set as Active PCF**.
The Radiant software displays the .pcf file name in bold type, indicating that it is the active power analysis file for the current design implementation. The Radiant software does not automatically load the newly activated file into Power Calculator if a different .pcf file is already open.

3. To open the active .pcf file, if a previous file is already open, double-click the activated .pcf file name in the Analysis Files folder; or right-click it and choose Open.

   When you close and reopen Power Calculator for the current design project, the active .pcf file will be loaded.

### Changing an Active Power Calculator File to Inactive

It is not required that a Power Calculator File (.pcf) be set as the active one for a design implementation. You can always open a .pcf file manually from the File menu or from the Analysis Files folder.

To change an active Power Calculator File to inactive:

- Right-click the name of the active .pcf file in the Analysis File folder and choose Set as Inactive from the pop-up menu.

   When you close and reopen Power Calculator, it displays default information or information from the routed .udb file. “Untitled” appears in the title bar.

### Entering Data

When you have a design open in the Radiant software, Power Calculator extracts information such as device, package, part, performance grade, and operating conditions. You can modify the device settings and the editable cells on any page. If Power Calculator is in calculation mode when you make any change other than activity factor, enable factor, Frequency, Voltage, Dynamic Power Multiplier, Ambient Temperature, Performance Grade, Operating Condition, or Process Type, it will revert to estimation mode. You can revert to calculation mode after making many types of changes, if they have not yet been saved to the .pcf file.

Power Calculator allows you to enter data directly in the editable cells. It also enables you to make global changes to frequency, activity factor by changing the default setting in the Frequency Settings, Activity Factor, and Enable Factor Settings dialog boxes. You can use a simulation file to populate Frequency, AF (activity factor) cells.

See Also

- “Software Mode” on page 293
- “Reverting to Calculation Mode” on page 310
- “Power Calculator Pages” on page 295
Editing Cells

Power Calculator includes built-in design rule checks. It automatically checks values that you enter into editable cells to ensure that they do not violate design rules. If you attempt to enter an inappropriate value in the Type, # I/P, # O/P, or # Bidi cell in the I/O page, Power Calculator will block the invalid value and display the previous value in the cell.

Power Calculator also provides tool tips that display the valid range of values for an editable cell. To ensure that the value you are entering is a valid one, hold your mouse over the cell to view the tool tip.

Most cells on Power Calculator pages are editable text cells that enable you to type a modified value. Others cells, such as the Device and Power parameters sections of the Power Summary page, contain visible drop-down menus for making a selection. Still others, such as those in the Type column on the I/O page, contain hidden drop-down menus that become visible when you double-click a cell.

To edit a cell:

- Depending on the type of cell you are editing, do one of the following:
  - Double-click the editable cell, type a new value, and then press Enter or click anywhere outside the cell.
  - Select a value from the visible drop-down list.
  - Double-click the cell and select a value from the drop-down list that appears.

Power Calculator calculates the results automatically and displays them. It also updates the Report page.

See Also

- “Power Calculator Pages” on page 295
- “Color Coding of Cells” on page 299
- "Cutting and Pasting Cell Contents" on page 309
- "Copying and Pasting Cell Contents" on page 309
- “Changing Values Automatically” on page 310

Editing Pages

You can change the settings and values on any Power Calculator page and, if desired, save the results to a separate Power Calculator File (.pcf) in the Analysis Files folder.

To edit Power Calculator pages:

1. On the Power Summary page, modify any settings in the Device section as desired.

When you select a different device, Power Calculator compares the design’s requirements against the available resources in the selected...
device. If the selected device is not suitable for the design—for example, if the number of LUTs in the design exceeds those available in the device, the number can't be entered, user may move cursor to the editable cell, and refer to the value range to reduce the design size to fit the smaller device.

2. In the Device Power Parameters section of the Power Summary page, set the Process Type option, which specifies the process corners or conditions under which the device was manufactured. It can be one of the following:
   - Typical – specifies typical conditions to reflect the typical amount of current consumed by the circuit.
   - Worst – specifies fast conditions to reflect the maximum amount of current consumed by the circuit.

3. In the Environment section of the Power Summary page, do the following:
   - Click Thermal Profile to select a thermal impedance model or enter your own Effective Theta-JA value.
   - Change the ambient temperature, as desired.
   See “Controlling Operating Temperature” on page 314

4. In the Voltage/Dynamic Power Multiplier section, enter new values, as desired, for voltage and DPM.
   - The voltage is the estimated power consumption by power supply. DPM is the derating factor for the dynamic portion of the power consumption.

5. Select other tabs and enter values into the editable cells of the other Power Calculator pages. The number and types of pages varies according to the device family.

6. Save your changes.

See Also
   - “Power Calculator Pages” on page 295
   - Saving a Power Calculator File
   - “Adding Power Calculator Files to the Analysis Files Folder” on page 304
   - “Setting a Power Calculator File as the Active Analysis File” on page 305
   - “Editing Cells” on page 307

### Adding and Deleting Clock Rows

You can easily add and delete clock rows on the Power Calculator pages.

**To add a clock row to a page:**

1. Right-click inside the desired table and choose Add Row from the pop-up menu.

2. Enter the appropriate data in the cells that have a white or light yellow background. Some columns with a light yellow background, such as Type, offer drop-down menus from which you can select settings.
To delete a clock row from a page:

- Right-click in the row that you want to delete and choose **Remove Row**.

**See Also** ▶ “Editing Cells” on page 307

---

**Cutting and Pasting Cell Contents**

You can cut the contents of a cell in a clock row and paste them in a cell in the same row or another row.

**To cut and paste cell contents:**

1. Double-click the desired cell to select its contents, and then right-click.
2. From the pop-up menu, select **Cut**. Alternatively, you can press **Ctrl+x**. You cannot cut the contents of any cells or columns that include a drop-down menu or text that is read-only.
3. Double-click the cell into which you want to paste the contents that you have cut, and then right-click.
4. From the pop-up menu, select **Paste**. Alternatively, you can press **Ctrl+v**.

**See Also** ▶ “Editing Cells” on page 307
▶ “Changing Values Automatically” on page 310

---

**Copying and Pasting Cell Contents**

You can copy the contents of a cell in a clock row to a cell in the same row or another row.

**To copy and paste the contents of a cell:**

1. Double-click the desired cell to select its contents, and then right-click.
2. From the pop-up menu, select **Copy**. Alternatively, you can press **Ctrl+c**.
3. Double-click the cell into which you want to paste the contents that you have copied, and then right-click.
4. From the pop-up menu, select **Paste**. Alternatively, you can press **Ctrl+v**.

**See Also** ▶ “Editing Cells” on page 307
▶ “Changing Values Automatically” on page 310
Changing Values Automatically

When you change values on any of the pages, Power Calculator recalculates the results automatically. For example, when you change the frequency of a clock in one cell and press Enter, Power Calculator automatically changes the frequency for that clock in all Frequency cells.

You can also use the Activity Factor Settings and Frequency Settings dialog boxes to make changes to all frequency, activity factor cells.

See Also
- “Changing the Global Default Activity Factor” on page 310
- “Changing the Global Default Frequency Setting” on page 312
- “Importing a Value Change Dump (.vcd) File” on page 311

Reverting to Calculation Mode

After you have made changes that causes the software to run in estimation mode, Power Calculator allows you to revert to calculation mode, under the following circumstances:

- The changes you made have not been saved to the .pcf file.

To revert to calculation mode from estimation mode:
1. Choose Edit > Revert to Calculation Mode.
2. In the Confirm dialog box, click Yes to confirm that you want to discard all the changes that you made in estimation mode.
   - Power Calculator removes all the changes you made and reverts to the settings in the .pcf file.

See Also
- “Software Mode” on page 293

Changing the Global Default Activity Factor

Power Calculator automatically assigns a global default activity factor of 10 percent in the cells of the pages that display an activity factor, such as AF (%), or that use an activity factor in calculations, such as Input AF (%). These default values appear in blue font. You can use the Edit menu to globally change this default activity factor.

To globally change the default activity factor:
1. Choose Edit > Activity Factor Settings.
2. In the Power Calculator - Activity Factor Settings dialog box, enter the new activity factor in the Activity Factor Default text box.
3. Click OK.
All the default activity factors appearing in blue font are changed to the new activity factor. Power Calculator automatically saves the new default.

If you manually change an activity factor in only one cell, the font becomes black to indicate that it is not a default value.

You can use a .vcd file to populate the cells that display or use activity factors. The resulting values are not considered defaults and therefore appear in black font.

**See Also**
- "Activity Factor Calculation" on page 292
- “Importing a Value Change Dump (.vcd) File” on page 311

## Importing a Value Change Dump (.vcd) File

Power Calculator enables you to import a value change dump (.vcd) file of simulation results into your project. Normally, you would import a .vcd file only when you want the Frequency, AF (activity factor) cells on Power Calculator pages to be populated with frequency and activity factor data from the .vcd file.

To ensure that Power Calculator populates the Frequency and AF cells with the VCD information, make sure that you follow these requirements:

- The .vcd file should be in the format of gate-level simulation, and it should match the design.
- A post-PAR timing simulation netlist must be used for name matching. You cannot use the RTL design.
- A stimulus must be used in the simulator that actually toggles the signals you are interested in; otherwise, you will see no difference in Power Calculator after the VCD is read.

**To import a .vcd file into your project:**

2. In the VCD File box, type or select the path and name of the .vcd file that you want to open.
3. In the Module Name in VCD box, specify the name of the module in the .vcd file from which to take the frequency and activity factor data.
4. Select the Case Sensitive option if the name of the .vcd file to be imported is case-sensitive.
5. Click **OK**.

Power Calculator Frequency and AF cells are now populated with the data from the .vcd file.

**See Also**
- “Changing the Global Default Frequency Setting” on page 312
Changing the Global Default Frequency Setting

You can globally change the default frequency values for the clocks listed in the Power Calculator pages. These default values appear in blue font in the Freq. (MHz) columns.

You can change this global frequency value in one of two ways:

► Specify a value in the Frequency Settings dialog box.
► In the Frequency Settings dialog box, select **Use Frequency TWR** options to import frequencies from the timing report.

**Note**

The frequency of some clocks, such as those that have high dependency on user constraints and usage, cannot be imported by using **Use Frequency TWR** options. In cases where clock frequency cannot be imported, you must specify a value.

---

**To globally change the default frequency setting by specifying a value:**

1. Choose **Edit > Frequency Settings**.

2. In the Frequency Settings dialog box, enter the new frequency in the **Frequency Default** cell, in megahertz.
   
   The default is 0 megahertz.

3. Click **OK**.

**To globally change the default frequency setting by using values from the .twr file:**

1. Choose **Edit > Frequency Settings**.

2. In the Power Calculator - Frequency Settings dialog box, select one of the following options in the Frequency TWR box. For all of these options, make sure timing report contains the names of the clocks in the pages for which you want default frequency values.

   ► **Minimum of Constraint And Timing** – Specifies that the default frequency in the Frequency (MHz) column of the Power Calculator pages be taken from the lesser of the constrained frequency or the actual frequency in timing report. The frequency is in megahertz.

   ► **Always Use Constraint** – Specifies that the default frequency in the Frequency (MHz) column of the Power Calculator pages be taken from the constrained frequency in timing report. The frequency is in megahertz.

   ► **Always Use Timing** – Specifies that the default frequency in the Frequency (MHz) column of the Power Calculator pages be taken from the actual frequency in timing report. The frequency is in megahertz.

3. Click **OK**.

Power Calculator now populates the Frequency cells of its pages with the frequency data from the timing report.
Estimating Resource Usage

Power Calculator allows you to specify an estimate of resources that the design will use, for the purpose of power analysis. The estimate can be based on design type or on component utilization. Based on your selections, Power Calculator immediately displays the number of resources that will be utilized for each type.

To estimate resource usage based on design type:
2. In the dialog box, select Specify Resource by Design Type.
3. Select the design type from the drop-down menu.
   Power Calculator calculates the resource usage based on the design and displays the utilization in the bottom portion of the dialog box.
4. Click OK.

To estimate resource usage based on component utilization:
2. In the dialog box, select Specify Resource by Component Utilization.
3. Do one or both of the following:
   ▶ Select a Small, Medium, or Large option based on the design size.
   Power Calculator displays a percentage of Logic, I/O, and EBR based on your selection.
   ▶ Select a percentage from the Logic(%), I/O(%), and EBR(%) drop-down menus.
   Power Calculator calculates the resource usage based on your selections and displays the utilization in the bottom portion of the dialog box.
4. Click OK.

See Also ▶“Estimating Routing Resource Usage” on page 313

Estimating Routing Resource Usage

You can estimate the amount of routing resources that your design will use for the purpose of power analysis.

To estimate routing resource usage:
   The Power Calculator - Estimation Mode Settings dialog box appears.
ANALYZING POWER CONSUMPTION : Controlling Operating Temperature

2. From the Routing Resource Utilization drop-down menu, select the amount of routing resources that you expect your design to use. You can select from the following:
   
   ▶ Low – Uses a small amount of routing resources.
   
   ▶ Medium – Uses an average amount of routing resources. This setting is the default.
   
   ▶ High – Uses a large amount of routing resources.

3. Click OK.

See Also ➤ “Estimating Resource Usage” on page 313

Controlling Operating Temperature

Minimizing the device’s operating temperature is critical to reducing power consumption.

A device has two parts: the die, which is the silicon inside the device, and the package, which is the outer shell. Each die-package combination has a thermal resistance value (often referred to as theta), which is a measure of how well the combination can dissipate heat. Lower values indicate better heat dissipation for the device.

Thermal impedance is the cumulative individual thermal resistances of a defined network. Power Calculator offers different models that provide ways to calculate the thermal impedance for a given device when it is mounted on the board. These models cover scenarios related to board sizes, air flows, and heat sinks that affect the thermal impedance. You can use these models to calculate the thermal impedance for the scenario that you choose.

You can choose the thermal impedance models by clicking the Thermal Profile button in the Environment section at the top right of the Power Summary page.

These thermal impedance models use the following terminology:

▶ Junction temperature – the temperature of the die in the device package, in degrees Celsius. You can adjust the junction temperature by choosing a model that applies a heat sink and changes the air flow value. Junction temperature is also affected by the package that you select in the Package Type box. In addition, the changes that you enter in many of the editable (white and turquoise) cells on the Power Summary page affect junction temperature.

▶ Heat sink – any material or object that dissipates unwanted heat from a device by absorbing it and conducting it away to a surface from which it dissipates into its surroundings. The reduction of junction-to-ambient thermal impedance depends on different factors, such as the speed and direction of the air flow over the heat sink and the materials used to attach the heat sink to the package. For heat-sink properties and proper attachment methods, contact your heat-sink manufacturer for specifications.
Air flow – the movement of air around the device in a package to cool it. It is measured in linear feet per minute (LFM). The higher the air flow value you select, the greater the cooling effect on the device.

Ambient temperature – the expected operating temperature, in degrees Celsius, of the medium surrounding a device in a package.

Theta JA – the thermal impedance between the silicon die and the ambient air within a JEDEC-defined environment. The boards used to measure these values have four layers, and their size is defined by JEDEC specifications.

Effective Theta JA – similar to Theta JA, but defined as the sum of all the package and board thermal resistances outside of a JEDEC-defined environment. It indicates how well the heat dissipates from the die to the ambient (air) for a particular thermal network as a whole outside of a JEDEC-defined environment.

Theta JB – indicates how well the heat dissipates from the junction on the silicon die to the board.

Theta JC – indicates how well the heat dissipates from the junction of the die to the package case in which it is enclosed, as defined by the JEDEC specifications.

Theta BA – indicates how well the heat dissipates from the board to the ambient (air).

Theta CS – indicates how well the heat dissipates from the package case to the heat sink. It is a measure of the thermal resistance of the interface material that makes contact between the package case and the heat sink attached to the package. It can be thermal grease, double-sided sticky tape, glue, or phase-shift material.

Theta SA – indicates how well the heat dissipates from the heat sink to the ambient (air).

See Also

Selecting a Thermal Impedance Model

You can experiment with various board sizes, heat sinks, and air flow settings to select a thermal impedance model for your design. The choice of board affects the Theta JB and Theta BA values, and the heat sink and air-flow selections affect the Theta SA and Theta JA values.

Note

The current values provided with the thermal models are averages of different values, and they are provided as a courtesy. To produce better predictions, it is advised that you submit your own thermal values.

To select a thermal impedance model:

1. In the Environment section of the Power Summary page, click Thermal Profile.
The Effective Theta-JA specifies the cumulative thermal impedance of a particular system. This figure is used in calculating the junction temperature (Tj) of a die in a particular environment according to the following formula:

\[ Tj = power \times \theta_{\text{effective}} + \text{ambient temperature}. \]

2. In the Power Calculator - Thermal Profile dialog box, select the source of the effective thermal impedance (effective Theta JA) value:

- If you want Power Calculator to calculate the effective Theta JA value from the selections that you make in the Board Selection, Heat Sink Selection, and Airflow Selection drop-down menus, choose **Use Thermal Models**.
- If you want to provide your own effective Theta JA value, choose **User-Defined Effective Theta-JA**.

3. If you chose Use Thermal Models:
   a. Select the size of the board that to use from the Board Selection drop-down menu:
      - **JEDEC Board (2S2P)** – Specifies that a board defined by JEDEC specifications be used. These specifications are based on real boards and measurements conducted in the lab used by Lattice Semiconductor. For packages < 27.0 mm in length, the buried planes are 74.2 mm x 74.2 mm (3" x 3"). For packages larger than or equal to 27.0 mm, the buried planes are 99.6 mm x 99.6 mm (4" by 4"). Power Calculator uses Theta JA or Theta JC, depending on the type of heat sink selection you make in the Heat Sink Selection menu. Theta JA is used only if you choose No Heat Sink. The ThetaJA value is the published value measured in the lab.
      - **Small Board** – Specifies that a board that is slightly larger than the JEDEC board be used. The board is assumed to be 6” to 8” square. This setting adds the Theta JB value to the board thermal impedance.
      - **Medium Board** – Specifies that a medium board be used, one that is assumed to be 8” to 12” square. This setting adds the Theta JB value to the board thermal impedance.
ANALYZING POWER CONSUMPTION : Controlling Operating Temperature

- Large Board – Specifies that a large board be used, one that is assumed to be larger than 14" square. This setting adds the Theta JB value to the board thermal impedance.

Note

Many factors can affect the actual thermal properties and change the values, including:

- The number of board layers.
- Airflow over the board.
- Number of devices powered up around the device package and their distance from the package.
- Thickness of the copper and the width of the traces on each layer.
- Number of thermal vias.
- Shape and thickness of each power and ground plane below the transfer of heat from the die to the ambient environment.

As a result, users are encouraged to make their own thermal measurements or simulations and use them in Power Calculator to see what kind of junction temperature might result.

b. Select the type of heat sink from the Heat Sink Selection drop-down menu:

- No Heat Sink – Specifies that no heat sink be used. Theta JA is used, and you must choose the air flow from the Airflow Selection menu. The No Heat Sink setting is the default.
- Low-Profile Heat Sink – Specifies that a short heat sink be used.
- Medium-Profile Heat Sink – Specifies that a medium heat sink be used. This setting adds the Theta JC value to the Heat Sink thermal impedance.
- High-Profile Heat Sink – Specifies that a tall heat sink be used.
- Custom-Profile Heat Sink – Enables you to specify your own heat-sink value in the Theta-SA for Custom Heat Sink box. The Airflow Selection option is not available when you select Custom-Profile Heat Sink.

c. Select the air flow in linear feet per minute (LFM) from the Airflow Selection drop-down menu:

- 0 LFM
- 200 LFM
- 500 LFM

If you use a heat sink, the 0 LFM setting is not available.

The Airflow Selection option is not available when you select Custom-Profile Heat Sink from the Heat Sink Selection menu.

4. If you chose User-Defined Theta-JA Effective, enter your effective thermal impedance value in the Effective Theta-JA box. Values entered must be greater than 0.
This box is not available if you selected Use Thermal Models.

5. Click **OK**.

The new effective Theta JA value now appears in the Effective Theta-JA box in the Environment section of the Power Summary page.

**See Also** ►“Controlling Operating Temperature” on page 314
► “Changing the Ambient Temperature” on page 318

### Changing the Ambient Temperature

The ambient temperature is the expected operating temperature, in degrees Celsius, of the medium surrounding a device in a package. You can select an ambient temperature in the range of -40 to 125 degrees Celsius.

**To change the ambient temperature:**

► In the Environment section of the Power Summary page, enter a value, in degrees Celsius, in the Ambient Temperature box and press **Enter** or click anywhere outside the cell.

The value entered must be between -40 and +125 degrees Celsius. The default value is 25 degrees Celsius for all devices.

When you change the value in the Ambient Temperature box, Power Calculator updates the following cells:

► Junction Temperature.
► Values in the Static (A) and Total (A) columns of the Current by Power Supply and Power by Power Supply sections.
► The totals in the Power by Block Column.

If you enter a value that is beyond the commercial, industrial, or automotive device limits, you will receive an error message that displays the range of valid values.

**See Also** ►“Controlling Operating Temperature” on page 314
► “Selecting a Thermal Impedance Model” on page 315

### Viewing and Printing Results

In addition to the automatically generated reports from power settings, Power Calculator provides graphs of power consumption and enables you to print information from the pages and generate a comma-separate value file (.csv) from the command line.
Generating Power Graphs

Power Calculator can create graphs showing how power consumption is affected when you vary the voltage, temperature, and clock frequency in the design. You can generate three default power graphs on the Graph page:

- Power vs. Supply Voltage
- Power vs. Ambient Temperature
- Power vs. Frequency

Each graph displays a typical and worst case plot. You can select the X axis and Y axis for each graph.

Graphs are only generated when you select the Graph tab. During graph generation, you cannot select a different tab until the calculations are finished. If you change the information in any other page that alters the power, the graphs will be regenerated when you again select the Graph tab. If you do not change any power information, the graphs will not be regenerated.

To generate the Power vs. Supply Voltage graphs:

1. Choose **Edit > Graph Settings**.
2. In the Power by Section part of the Graphs Settings dialog box, set the following options:
   a. In the Y Axis box, select Total Power or the specific type of block power to display, such as I/O or Block RAM, to place on the Y axis of the graph.
   b. In the X Axis box, select the type of supply voltage to place on the X axis of the graph.
   c. In the Lower Limit box, enter the lower boundary of the voltage range on the X axis. The lower limit can be 5 percent lower than the nominal supply value.
   d. In the Upper Limit box, enter the upper boundary of the voltage range on the X axis. The upper limit can be 5 percent higher than the nominal supply value.
   e. In the Resolution box, enter the step in which the supply voltage values on the X axis should appear. The voltage supply step is limited to a resolution of .01.
3. Click **OK** to close the dialog box and apply the settings.
4. Click the **Graph** tab to see the resulting charts.

To generate the Power vs. Ambient Temperature graphs:

1. Choose **Edit > Graph Settings**.
2. In the Power by Temperature part of the Graphs Settings dialog box, set the following options:
   a. In the Y Axis box, select Total Power or the type of block power, such as I/O or Block RAM, to place on the Y axis of the graph.
b. In the X Axis box, select **Ambient Temperature** for the X axis of the graph. Temperature is in degrees Celsius.

c. In the Lower Limit box, enter the lower boundary of the temperature range on the X axis. The range limits are determined by the device’s operating condition:
   - Industrial: –40 through 105
   - Commercial: 0 through 85
   - Automotive: –40 through 125

d. In the Upper Limit box, enter the upper boundary of the temperature range on the X axis. The range limits are determined by the device’s operating condition:
   - Industrial: –40 through 105
   - Commercial: 0 through 85
   - Automotive: –40 through 125

e. In the Resolution box, enter the step in which the temperature values on the X axis should appear. The temperature step is limited to resolution of 10 degrees Celsius.

3. Click **OK** to close the dialog box and apply the settings.

4. Once the graphic data has been prepared, click the Graph tab to see the resulting charts.

---

**To generate the Power vs. Frequency graphs:**

1. Choose **Edit > Graph Settings**.

2. In the Power by Frequency part of the Graphs Settings dialog box, set the following options:
   a. In the YAxis box, select Total Power or the specific type of block power, such as I/O or Block RAM, to place on the Y axis of the graph.
   b. In the X Axis box, select the clock to place on the X axis of the graph. It can be any of the clocks listed on the Clocks page.
   c. In the Lower Limit box, enter the lower boundary of the frequency range on the X axis. The lower boundary is limited to 0 MHz.
   d. In the Upper Limit box, enter the upper boundary of the frequency range on the X axis. The upper boundary is limited to 10000 MHz.
   e. In the Resolution box, enter the step in which the frequency values on the X axis should appear. The default frequency increment is 20 MHz.

3. Click **OK** to close the dialog box and apply the settings.

4. Once the graphic data has been prepared, click the Graph tab to see the resulting charts.
Viewing the Power Calculator Report

The report page contains a summary of the estimated power-consumption or current-consumption data calculated by Power Calculator. It is available in text (ASCII) format and in HTML format, and it is updated each time you make a change to any of the data in the editable cells.

To view the Power Calculator report:

- To view the results in text format, click the Report tab.
- To view the results in HTML format, click View HTML Report.

See Also ➤ "Entering Data" on page 306
➤ "Printing Information" on page 321

Printing Information

After calculating power, you can print the results displayed on any of the pages, including the Report and Graph pages. Optionally, you can preview pages before printing.

To preview and print:

1. In the Power Calculator window, click the tab of the desired page.
2. Choose File > Print Preview to activate the Print Preview dialog box.
   - Use the zoom tools and the Fit Page and Fit Width buttons on the toolbar to position the page in the window.
   - When there are multiple pages, use the Next, Last, Previous, and First arrows to navigate through them.
3. Select the Portrait or Landscape button on the toolbar.
4. Click Print to queue the results to a printer.
5. In the Print dialog box, click Print.

To print information from a page:

1. In the Power Calculator window, click the tab of the desired page.
2. Choose File > Print.
3. In the dialog box, click Print.

See Also ➤ "Entering Data" on page 306
➤ "Power Calculator Pages" on page 295
Chapter 10

Analyzing Signal Integrity

Signal integrity analysis enables characterization of interconnect discontinuities and behaviors. You can use signal integrity analysis models to perform a simulation on your board or to trace setup before laying out the board to look for signal integrity issues, such as crosstalk, reflection, ringing, overshoot, undershoot, impedance mismatch, and line termination.

Lattice Semiconductor supports signal integrity (SI) analysis at the PC board level using IBIS or HSPICE format models. For information, visit the Support Center Web site:

http://www.latticesemi.com/support/

Lattice Semiconductor IBIS Models

The Input/Output Buffer Information Specification (IBIS) is a behavioral model used for simulation. It was developed originally by Intel in the early 1990s and has become a device-modeling standard that is regulated and developed by a forum of electronic design automation (EDA) vendors, computer manufacturers, semiconductor vendors, universities, and end users.

IBIS is a standard supported by all popular signal integrity analysis tool vendors, including Cadence, Mentor Graphics, and Zuken. You can generate design-specific IBIS models for an FPGA project from the Radiant software or you can download general-purpose IBIS models based by family on the Products > Programmable Logic web page on the Lattice web site.

About IBIS Models

IBIS models help you analyze signal integrity and electromagnetic compatibility (EMC) on printed circuit boards. Unlike conventional behavioral simulation models that contain such modeling elements as schematic symbols and polynomial expressions, IBIS models consist of tabular data. This tabular data contains current and voltage values in the output and input pins, as well as the voltage and time relationship at the output pins under rising or falling switching conditions. The IBIS model data represents realistic
device behavior, based on collected data at varied operating conditions. IBIS models provide this data without disclosure of any proprietary design information.

IBIS provides more accurate models because it accounts for non-linear aspects of the I/O structures, the ESD structures, and the package parasitics. It has several advantages over other traditional models such as SPICE, including faster simulation times and no non-convergence problems. Finally, IBIS can be run on nearly any industry-wide platform because of an almost universal EDA vendor support for the IBIS standard.

Lattice Semiconductor IBIS Model Files

In the Lattice Radiant software, Lattice Semiconductor provides IBIS model files for behavioral simulation. IBIS models are located in the following installation directory path in Radiant:

<install_dir>/cae_library/ibis

The following table lists all available IBIS model files in the software.

<table>
<thead>
<tr>
<th>Family</th>
<th>Lattice Semiconductor IBIS Model Files</th>
</tr>
</thead>
<tbody>
<tr>
<td>iCE40UP</td>
<td>iCE40UP.ibs</td>
</tr>
<tr>
<td>LIFCL</td>
<td>lifcl.ibs</td>
</tr>
<tr>
<td>LFD2NX</td>
<td>lfd2nx.ibis</td>
</tr>
</tbody>
</table>

An IBIS model file is not an executable; it is an ASCII file of all the pertinent data that represents a device’s electrical behavior and can be used in a simulator. IBIS files consist of three primary parts:

- file header information that describes the file (revision, date, conventions, source), the device, and the company
- device name, pinout, and pin-to-buffer mapping
- I/O-voltage (I/V) and voltage-time (V/T) data for each model

Lattice Semiconductor IBIS models characterize all available devices in a given device family. Files contain multiple data matrices that contain similar data for a given device in the same family.

**Note**

The collected IBIS source code data in these files is only representative of how a given Lattice Semiconductor device operates. It is still your responsibility to verify your design for consistency and functionality through the use of formal verification methods. There are no guarantees regarding the use or functionality of the IBIS data in the files listed in the table above.
Generating IBIS Models in the Radiant Software

You can generate your own IBIS models by double-clicking the IBIS Model process beneath Export Files in the Task Detail View. This process generates a design-specific model file `project_name.ibs` in your project directory.
Programming the FPGA

After you have created and verified your design, you can use the final output data file to download or upload a bitstream to or from an FPGA device using the Radiant Programmer. Programmer supports serial and microprocessor programming of Lattice devices in PC and Linux environments. A device can be scanned automatically.

The Radiant Programmer is available with the Radiant software, and is also available in a stand-alone version.

Features include:

- Scan and display contents (.xcf file)
- Download data files to devices
- Create/modify/display .xcf file
- Generate embedded file on the .xcf file
- Generate Tester serial vector format (.svf) on the .xcf file

The Radiant Programmer uses a Single Document Interface (SDI) where a single .xcf project is displayed per Programmer instance. Opening an additional .xcf file closes the current .xcf file. To open additional .xcf files in stand-alone mode, a separate instance of the Radiant Programmer needs to be launched.

See Also

- “Programming the FPGA” on page 328
- “File Formats” on page 330
- “SPI Flash Support” on page 330
- “Using the Radiant Programmer” on page 341
- “Programmer Options” on page 366
About the Programmer Window

The Radiant Programmer offers several views to help you set up your connection to a target board and to program the FPGAs. If an item is not showing, choose it in the View menu.

**Table View**  The Programmer window includes a table with the devices in the current Programmer project. Use this table to see information about the devices and to set options for programming them.

- To adjust what information is showing in the table, go to View > Columns and choose what you want to see.
- To add or remove devices from the table, right-click in the table to see commands for editing the rows.
- To adjust options for a device, double-click in its row. The Device Properties dialog box opens. This dialog box gives access to many operations and options. See “Device Properties Dialog Box” on page 367.

Each row has a column for the device status. The status indicates whether the operation performed was successful or not. This field is also used for read back operations to display what is read back if the data to display is short. For larger data sets that are read back, a dialog box is displayed.

**System Viewer**  The Programmer window includes a schematic showing the devices and how they are connected to the host processor. Double-clicking a device opens the Device Properties dialog box, which gives access to many operations and options. See “Device Properties Dialog Box” on page 367.

**Output**  Displays results from Programmer operations similar to the Output view in the Radiant software.

**Tcl Console**  Displays the Tcl commands used similar to the Tcl Console view in the Radiant software.

**Cable Setup**  A dialog box for identifying the cable connection to the target board and setting options for it. See “Cable Setup Dialog Box” on page 377.

**Embedded Options**  A dialog box for specifying options for an embedded design file before generating it. See “Generating Embedded Design Files” on page 352.

**SVF Options**  A dialog box for specifying options for an SVF file before generating it. See “Generating Tester Serial Vector Format (SVF) Files” on page 359.
File Formats

Lattice supports the following file formats.

Data File  A data file can be a hex, or bitstream file. Each of these files is based upon an IEEE programming standard:

Bitstream  Data files used for configuring volatile memory (SRAM) of our FPGAs.

Hex  Hexadecimal PROM data files used for Programming into external non-volatile memory, such as parallel or Serial Peripheral Interface (SPI) Flash devices.

See Also

▶ “Programming the FPGA” on page 328
▶ “Using the Radiant Programmer” on page 341
▶ “Programming and Configuring iCE40 Devices with Programmer” on page 380
▶ “Programming and Configuring LIFCL and LFD2NX Devices with Programmer” on page 388

SPI Flash Support

The Radiant Programmer, combined with a Lattice cable fly-wire, supports the programming of SPI flash devices.

Lattice Devices That Support SPI Flash Configuration  LIFCL, LFD2NX, and iCE40 FPGAs can be configured directly from an SPI flash memory devices.

Third Party SPI Flash Devices  The following tables list supported third-party SPI flash devices. Click the third-party manufacturer name to link to the table of supported third-party SPI flash devices.

Note

The Radiant Programmer support for additional third-party SPI flash devices may be added from time to time. To see if support for third-party SPI flash devices has been added, in addition to those listed in the tables below, check the SPI Flash options in the “Device Properties Dialog Box” on page 367.

Cypress
GigaDevice
ISSI
Macronix
Micron
Spansion
Winbond

Table 21: Cypress

<table>
<thead>
<tr>
<th>Model</th>
</tr>
</thead>
<tbody>
<tr>
<td>S25FL116K</td>
</tr>
<tr>
<td>S25FL132K</td>
</tr>
<tr>
<td>S25FL164K</td>
</tr>
<tr>
<td>S25FL064L</td>
</tr>
<tr>
<td>S25FL128L</td>
</tr>
<tr>
<td>S25FL256L</td>
</tr>
<tr>
<td>S25FL128S</td>
</tr>
<tr>
<td>S25FL256S</td>
</tr>
<tr>
<td>S25FL512S</td>
</tr>
<tr>
<td>S25FS064S</td>
</tr>
<tr>
<td>S25FS128S</td>
</tr>
<tr>
<td>S25FS256S</td>
</tr>
<tr>
<td>S25FS512S</td>
</tr>
</tbody>
</table>

Table 22: GigaDevice

<table>
<thead>
<tr>
<th>Model</th>
</tr>
</thead>
<tbody>
<tr>
<td>GD25Q20C</td>
</tr>
<tr>
<td>GD25Q40C</td>
</tr>
<tr>
<td>GD25Q80C</td>
</tr>
<tr>
<td>GD25Q16C</td>
</tr>
<tr>
<td>GD25Q32C</td>
</tr>
<tr>
<td>GD25Q64C</td>
</tr>
<tr>
<td>GD25Q127C</td>
</tr>
<tr>
<td>GD25Q256D</td>
</tr>
<tr>
<td>GD25LQ20C</td>
</tr>
<tr>
<td>GD25LQ40C</td>
</tr>
<tr>
<td>GD25LQ80C</td>
</tr>
<tr>
<td>GD25LQ16C</td>
</tr>
<tr>
<td>GD25LQ32D</td>
</tr>
<tr>
<td>GD25LQ64C</td>
</tr>
<tr>
<td>GD25LQ128D</td>
</tr>
<tr>
<td>GD25LQ256D</td>
</tr>
</tbody>
</table>
### Table 23: ISSI

<table>
<thead>
<tr>
<th>Model</th>
</tr>
</thead>
<tbody>
<tr>
<td>IS25LP064</td>
</tr>
<tr>
<td>IS25LP128</td>
</tr>
<tr>
<td>IS25LP032A</td>
</tr>
<tr>
<td>IS25LP064A</td>
</tr>
<tr>
<td>IS25LP080D</td>
</tr>
<tr>
<td>IS25LP016D</td>
</tr>
<tr>
<td>IS25LP032D</td>
</tr>
<tr>
<td>IS25LP256D</td>
</tr>
<tr>
<td>IS25LP128F</td>
</tr>
<tr>
<td>IS25LP512M</td>
</tr>
<tr>
<td>IS25LQ020B</td>
</tr>
<tr>
<td>IS25LQ040B</td>
</tr>
<tr>
<td>IS25LQ080B</td>
</tr>
<tr>
<td>IS25LQ16B</td>
</tr>
<tr>
<td>IS25LQ032B</td>
</tr>
<tr>
<td>IS25WP128</td>
</tr>
<tr>
<td>IS25WP064A</td>
</tr>
<tr>
<td>IS25WP040D</td>
</tr>
<tr>
<td>IS25WP080D</td>
</tr>
<tr>
<td>IS25WP016D</td>
</tr>
<tr>
<td>IS25WP032D</td>
</tr>
<tr>
<td>IS25WP128F</td>
</tr>
<tr>
<td>IS25WP256D</td>
</tr>
<tr>
<td>IS25WP512M</td>
</tr>
<tr>
<td>IS25WQ020</td>
</tr>
<tr>
<td>IS25WQ040</td>
</tr>
</tbody>
</table>
### Table 24: Macronix

<table>
<thead>
<tr>
<th>Macronix</th>
<th>MX25R1035F</th>
</tr>
</thead>
<tbody>
<tr>
<td>MX25L2006E</td>
<td></td>
</tr>
<tr>
<td>MX25L4006E</td>
<td></td>
</tr>
<tr>
<td>MX25L8006E</td>
<td></td>
</tr>
<tr>
<td>MX25L1606E</td>
<td></td>
</tr>
<tr>
<td>MX25L3206E</td>
<td></td>
</tr>
<tr>
<td>MX25L6406E</td>
<td></td>
</tr>
<tr>
<td>MX25U2033E</td>
<td></td>
</tr>
<tr>
<td>MX25U4033E</td>
<td></td>
</tr>
<tr>
<td>MX25U8033E</td>
<td></td>
</tr>
<tr>
<td>MX25L1635E</td>
<td></td>
</tr>
<tr>
<td>MX25U3235E</td>
<td></td>
</tr>
<tr>
<td>MX25L6435E</td>
<td></td>
</tr>
<tr>
<td>MX25U6435E</td>
<td></td>
</tr>
<tr>
<td>MX25L12835E</td>
<td></td>
</tr>
<tr>
<td>MX25L25635E</td>
<td></td>
</tr>
<tr>
<td>MX25L6436E</td>
<td></td>
</tr>
<tr>
<td>MX25L12836E</td>
<td></td>
</tr>
<tr>
<td>MX25L6445E</td>
<td></td>
</tr>
<tr>
<td>MX25L12845E</td>
<td></td>
</tr>
<tr>
<td>MX25U1633F</td>
<td></td>
</tr>
<tr>
<td>MX25L3233F</td>
<td></td>
</tr>
<tr>
<td>MX25L6433F</td>
<td></td>
</tr>
<tr>
<td>MX25L12833F</td>
<td></td>
</tr>
<tr>
<td>MX25V1035F</td>
<td></td>
</tr>
</tbody>
</table>
## Table 25: Micron

<table>
<thead>
<tr>
<th>Model</th>
</tr>
</thead>
<tbody>
<tr>
<td>M25P10</td>
</tr>
<tr>
<td>M25P20</td>
</tr>
<tr>
<td>M25P40</td>
</tr>
<tr>
<td>M25P80</td>
</tr>
<tr>
<td>M25P16</td>
</tr>
<tr>
<td>M25P32</td>
</tr>
<tr>
<td>M25P64</td>
</tr>
<tr>
<td>M25P128</td>
</tr>
<tr>
<td>M25PE10</td>
</tr>
<tr>
<td>M25PE20</td>
</tr>
<tr>
<td>M25PE40</td>
</tr>
<tr>
<td>M25PE80</td>
</tr>
<tr>
<td>M25PE16</td>
</tr>
<tr>
<td>M45PE10</td>
</tr>
<tr>
<td>M45PE20</td>
</tr>
<tr>
<td>M45PE40</td>
</tr>
<tr>
<td>M45PE80</td>
</tr>
<tr>
<td>M45PE16</td>
</tr>
<tr>
<td>M25PX80</td>
</tr>
<tr>
<td>M25PX16</td>
</tr>
<tr>
<td>M25PX32</td>
</tr>
<tr>
<td>M25PX64</td>
</tr>
<tr>
<td>N25Q032</td>
</tr>
<tr>
<td>N25Q032A</td>
</tr>
<tr>
<td>N25Q064</td>
</tr>
<tr>
<td>N25Q128</td>
</tr>
<tr>
<td>N25Q128A</td>
</tr>
<tr>
<td>N25Q256</td>
</tr>
<tr>
<td>N25Q512</td>
</tr>
<tr>
<td>MT25QL128</td>
</tr>
<tr>
<td>MT25QL256</td>
</tr>
<tr>
<td>MT25QL512</td>
</tr>
<tr>
<td>MT25QU128</td>
</tr>
<tr>
<td>MT25QU256</td>
</tr>
<tr>
<td>MT25QU512</td>
</tr>
</tbody>
</table>
Table 26: Spansion

<table>
<thead>
<tr>
<th>Model</th>
</tr>
</thead>
<tbody>
<tr>
<td>S25FL064A</td>
</tr>
<tr>
<td>S25FL040A</td>
</tr>
<tr>
<td>S25FL004A</td>
</tr>
<tr>
<td>S25FL008A</td>
</tr>
<tr>
<td>S25FL016A</td>
</tr>
<tr>
<td>S25FL032A</td>
</tr>
<tr>
<td>S25FL004A</td>
</tr>
<tr>
<td>S25FL001D</td>
</tr>
<tr>
<td>S25FL002D</td>
</tr>
<tr>
<td>S25FL004D</td>
</tr>
<tr>
<td>S25FL032P</td>
</tr>
<tr>
<td>S25FL064P</td>
</tr>
<tr>
<td>S25FL128P</td>
</tr>
<tr>
<td>S25FL132K</td>
</tr>
<tr>
<td>S25FL164K</td>
</tr>
<tr>
<td>S25FL204K</td>
</tr>
<tr>
<td>S25FL208K</td>
</tr>
<tr>
<td>S25FL216K</td>
</tr>
</tbody>
</table>
Table 27: Winbond

<table>
<thead>
<tr>
<th>Device</th>
</tr>
</thead>
<tbody>
<tr>
<td>W25Q20</td>
</tr>
<tr>
<td>W25Q80</td>
</tr>
<tr>
<td>W25Q16</td>
</tr>
<tr>
<td>W25Q32</td>
</tr>
<tr>
<td>W25Q64</td>
</tr>
<tr>
<td>W25X10CL</td>
</tr>
<tr>
<td>W25X20CL</td>
</tr>
<tr>
<td>W25X40CL</td>
</tr>
<tr>
<td>W25Q20CL</td>
</tr>
<tr>
<td>W25Q40CL</td>
</tr>
<tr>
<td>W25Q80DV</td>
</tr>
<tr>
<td>W25Q32FV</td>
</tr>
<tr>
<td>W25Q64FV</td>
</tr>
<tr>
<td>W25Q128FV</td>
</tr>
<tr>
<td>W25Q256FV</td>
</tr>
<tr>
<td>W25Q16FW</td>
</tr>
<tr>
<td>W25Q32FW</td>
</tr>
<tr>
<td>W25Q64FW</td>
</tr>
<tr>
<td>W25Q128FW</td>
</tr>
<tr>
<td>W25Q16JV</td>
</tr>
<tr>
<td>W25Q32JV</td>
</tr>
<tr>
<td>W25Q64JV</td>
</tr>
<tr>
<td>W25Q128JV</td>
</tr>
<tr>
<td>W25Q256JV</td>
</tr>
<tr>
<td>W25M512JV</td>
</tr>
<tr>
<td>W25Q32JW</td>
</tr>
<tr>
<td>W25Q64JW</td>
</tr>
<tr>
<td>W25Q128JW</td>
</tr>
<tr>
<td>W25Q256JW</td>
</tr>
</tbody>
</table>

Third Party SPI Flash Devices (Legacy)  The following tables list supported legacy third-party SPI flash devices. Click the third-party
manufacturer name to link to the table of supported legacy third-party SPI flash devices.

**Note**

The Radiant Programmer support for additional legacy third-party SPI flash devices may be added from time to time. To see if support for third-party SPI flash devices has been added, in addition to those listed in the tables below, check the SPI Flash options in the "Device Properties Dialog Box" on page 367.

---

**Table 28: Adesto**

| AT25SF041 |
---|---|

**Table 29: AMIC**

---|---|---|---|---|

Return to Top of Legacy Device List
### Table 30: Atmel

<table>
<thead>
<tr>
<th>Device</th>
</tr>
</thead>
<tbody>
<tr>
<td>MX25L1005</td>
</tr>
<tr>
<td>MX25L2005</td>
</tr>
<tr>
<td>MX25L4005(A)</td>
</tr>
<tr>
<td>MX25L8005</td>
</tr>
<tr>
<td>MX25L1605</td>
</tr>
<tr>
<td>MX25L3205</td>
</tr>
<tr>
<td>MX25L6405</td>
</tr>
<tr>
<td>MX25L12805</td>
</tr>
<tr>
<td>MX25U8035</td>
</tr>
</tbody>
</table>

### Table 31: Eon Silicon

<table>
<thead>
<tr>
<th>Device</th>
</tr>
</thead>
<tbody>
<tr>
<td>EN25Q32B</td>
</tr>
</tbody>
</table>

### Table 32: Intel

<table>
<thead>
<tr>
<th>Device</th>
</tr>
</thead>
<tbody>
<tr>
<td>25F016S33</td>
</tr>
<tr>
<td>25F160S33</td>
</tr>
<tr>
<td>25F320S33</td>
</tr>
<tr>
<td>25F640S33</td>
</tr>
</tbody>
</table>

### Table 33: Macronix

<table>
<thead>
<tr>
<th>Device</th>
</tr>
</thead>
<tbody>
<tr>
<td>MX25L1005</td>
</tr>
<tr>
<td>MX25L2005</td>
</tr>
<tr>
<td>MX25L4005(A)</td>
</tr>
<tr>
<td>MX25L8005</td>
</tr>
<tr>
<td>MX25L1605</td>
</tr>
<tr>
<td>MX25L3205</td>
</tr>
<tr>
<td>MX25L6405</td>
</tr>
<tr>
<td>MX25L12805</td>
</tr>
<tr>
<td>MX25U8035</td>
</tr>
</tbody>
</table>
# Table 34: NewFlash

<table>
<thead>
<tr>
<th>Device</th>
</tr>
</thead>
<tbody>
<tr>
<td>NX25P20</td>
</tr>
<tr>
<td>NX25P40</td>
</tr>
<tr>
<td>NX25P80</td>
</tr>
<tr>
<td>NX25P16</td>
</tr>
<tr>
<td>NX25P32</td>
</tr>
</tbody>
</table>

# Table 35: Numonyx

<table>
<thead>
<tr>
<th>Device</th>
</tr>
</thead>
<tbody>
<tr>
<td>M25P20</td>
</tr>
<tr>
<td>M25P40</td>
</tr>
<tr>
<td>M25P80</td>
</tr>
<tr>
<td>M25P16</td>
</tr>
<tr>
<td>M25P32</td>
</tr>
<tr>
<td>M25P64</td>
</tr>
<tr>
<td>M25P128</td>
</tr>
<tr>
<td>M25PE20</td>
</tr>
<tr>
<td>M25PE40</td>
</tr>
<tr>
<td>M25PE80</td>
</tr>
<tr>
<td>M25PE16</td>
</tr>
<tr>
<td>M25PX80</td>
</tr>
<tr>
<td>M25PX16</td>
</tr>
<tr>
<td>M25PX32</td>
</tr>
<tr>
<td>M25PX64</td>
</tr>
<tr>
<td>M45PE20</td>
</tr>
<tr>
<td>M45PE40</td>
</tr>
<tr>
<td>M45PE80</td>
</tr>
<tr>
<td>M45PE16</td>
</tr>
<tr>
<td>N25Q032</td>
</tr>
<tr>
<td>N25Q064</td>
</tr>
<tr>
<td>N25Q128</td>
</tr>
<tr>
<td>N25Q128A</td>
</tr>
</tbody>
</table>
### Table 36: SSTI

<table>
<thead>
<tr>
<th>SST25VF020</th>
</tr>
</thead>
<tbody>
<tr>
<td>SST25VF040</td>
</tr>
<tr>
<td>SST25VF080</td>
</tr>
<tr>
<td>SST25LF020A</td>
</tr>
<tr>
<td>SST25LF040A</td>
</tr>
<tr>
<td>SST25LF080A</td>
</tr>
<tr>
<td>SST25VF040B</td>
</tr>
<tr>
<td>SST25VF080B</td>
</tr>
<tr>
<td>SST25VF016B</td>
</tr>
<tr>
<td>SST25VF032B</td>
</tr>
<tr>
<td>SST25VF064C</td>
</tr>
<tr>
<td>SST26VF016B</td>
</tr>
<tr>
<td>SST26VF032B</td>
</tr>
<tr>
<td>SST26VF064B</td>
</tr>
</tbody>
</table>

### Table 37: STMicro

<table>
<thead>
<tr>
<th>M25P20</th>
</tr>
</thead>
<tbody>
<tr>
<td>M25P40</td>
</tr>
<tr>
<td>M25P80</td>
</tr>
<tr>
<td>M25P16</td>
</tr>
<tr>
<td>M25P32</td>
</tr>
<tr>
<td>M25P64</td>
</tr>
<tr>
<td>M25PE20</td>
</tr>
<tr>
<td>M25PE40</td>
</tr>
<tr>
<td>M25PE80</td>
</tr>
<tr>
<td>M25PE16</td>
</tr>
<tr>
<td>M45PE20</td>
</tr>
<tr>
<td>M45PE40</td>
</tr>
<tr>
<td>M45PE80</td>
</tr>
<tr>
<td>M45PE16</td>
</tr>
</tbody>
</table>
Using the Radiant Programmer

This section provides procedures for using the Radiant Programmer. Topics include:

- “Plugging the Cable into the PC” on page 342
- “Detecting a Cable” on page 343
- “Selecting from Multiple Cables” on page 343
- “Creating a New Radiant Programmer Project” on page 344
- “Opening an Existing Radiant Programmer Project” on page 345
- “Checking the XCF Project” on page 346
- “Scanning the Device” on page 346
- “Selecting from a Matching Device ID List” on page 347
- “Adding a Lattice Device to a Chain” on page 347

Table 38: WindBond

<table>
<thead>
<tr>
<th>Device</th>
</tr>
</thead>
<tbody>
<tr>
<td>W25P20</td>
</tr>
<tr>
<td>W25P40</td>
</tr>
<tr>
<td>W25P80</td>
</tr>
<tr>
<td>W25P16</td>
</tr>
<tr>
<td>W25P32</td>
</tr>
<tr>
<td>W25X10</td>
</tr>
<tr>
<td>W25X20</td>
</tr>
<tr>
<td>W25X40</td>
</tr>
<tr>
<td>W25X80</td>
</tr>
<tr>
<td>W25X16</td>
</tr>
<tr>
<td>W25X32</td>
</tr>
<tr>
<td>W25X64</td>
</tr>
<tr>
<td>W25Q128BV</td>
</tr>
<tr>
<td>W25Q64DW</td>
</tr>
</tbody>
</table>

See Also

- “Programming the FPGA” on page 328
- “Using the Radiant Programmer” on page 341
- “Programming and Configuring iCE40 Devices with Programmer” on page 380
- “Programming and Configuring LIFCL and LFD2NX Devices with Programmer” on page 388
Plugging the Cable into the PC

You can plug the USB cable into the PC whether the PC is turned on or off. However, make sure that the Radiant Programmer is closed and that the target board’s power is off before plugging the cable into your PC or unplugging it.

To plug the cable into the PC:

1. Make sure that the Radiant Programmer is closed, and that the target board is powered off.
2. Plug the cable into your PC and the target board.
3. If your PC is turned on, wait about one minute for the Windows operating system to recognize the USB cable. The amount of time varies, depending on your PC’s speed.

See Also

- “Using the Radiant Programmer” on page 341
- “Programming the FPGA” on page 328
- “Programming and Configuring iCE40 Devices with Programmer” on page 380
- “Programming and Configuring LIFCL and LFD2NX Devices with Programmer” on page 388
Detecting a Cable

You can use the Radiant Programmer Detect Cable feature to determine which cable and port you are using.

To detect a cable:

1. If Cable Setup dialog box is not showing in the Radiant Programmer window, choose View > Cable Setup.
2. In the Cable Setup dialog box, click Detect Cable.

   The Radiant Programmer detects all available cables connected to your PC, and lists the cable type, port settings, and descriptions in the Output view.

See Also

- “Using the Radiant Programmer” on page 341
- “Cable Setup Dialog Box” on page 377
- “Programming the FPGA” on page 328
- “Programming and Configuring iCE40 Devices with Programmer” on page 380
- “Programming and Configuring LIFCL and LFD2NX Devices with Programmer” on page 388

Selecting from Multiple Cables

The Radiant Programmer can recognize as many as five USB cables plugged into the same PC.

The first USB cable plugged into the PC is assigned port Ez-USB-0. The second is assigned port Ez-USB-1, and so on. The first FTDI USB2 cable is assigned port FTUSB-0, and the second FTUSB-1, and so on.

If the PC is turned off, and then later turned back on, the assigned ports might change, since the PC detects the cables according to the USB port address instead of the order in which they were plugged into the PC. Since the USB cable port assignments might change during power-up, you might have to reselect the USB cable in the Cable Setup dialog box.

To select a USB cable from multiple cables:

- In the Cable Setup dialog box, select the USB cable you want to use from the Port pulldown list.

See Also

- “Using the Radiant Programmer” on page 341
- “Cable Setup Dialog Box” on page 377
- “Programming the FPGA” on page 328
“Programming and Configuring iCE40 Devices with Programmer” on page 380
“Programming and Configuring LIFCL and LFD2NX Devices with Programmer” on page 388

Creating a New Radiant Programmer Project

By creating a new Radiant Programmer project, you create a chain file (.xcf) from a scan with default settings, create an .xcf file from a scan with custom settings, or a new blank project.

Pathnames in the .xcf files are written in “cross platform compatible” format by default. This format uses forward-slashes (/), which work with both Linux and Windows. For Windows-only systems you might prefer to use Native Delimiter format, which uses back-slashes (\). To use the Windows Native Delimiter format, open the Programmer initialization file in a text editor:

Users\<name>\AppData\Roaming\LatticeSemi\DiamondNG\programmer.ini

Go to the end of the file and add a line with: PathDelimiter=1

Programmer can be started from the Radiant software, the Windows Start menu (integrated or stand-alone version), or a Linux command line.

To create a new Radiant Programmer project:

1. Make sure that the board is turned on and that the Lattice parallel or USB cable is properly connected to the computer.

2. Do one of the following to start Programmer:
   - In the Radiant software, choose Tools > Programmer.
   - In the Radiant software, click in the toolbar.
   - In the Windows Start menu, choose Lattice Radiant Software > Accessories > Radiant Programmer.
   - In the Windows Start menu, choose Lattice Radiant Programmer > Radiant Programmer.
   - In Linux, from the <Programmer install path>/bin/lin64 directory, enter the following on a command line:
     ./programmer

3. In the Getting Started dialog box, enter a project name in the Project Name box.

4. Browse to the location where you wish your project to reside in the Project Location box.

5. Choose one of the following:
Create a new project from a scan. This option creates a new project from a scan.

If you have a board connected to your computer, you can click the Detect Cable button to detect the cable and port. Otherwise, you can manually select cable and port from the Cable and Port pulldown lists.

Create a New Blank Project. This option creates a new blank Radiant Programmer project.

6. Click OK.

See Also
- “Using the Radiant Programmer” on page 341
- “Getting Started Dialog Box” on page 367
- “Programming the FPGA” on page 328
- “Programming and Configuring iCE40 Devices with Programmer” on page 380
- “Programming and Configuring LIFCL and LFD2NX Devices with Programmer” on page 388

Opening an Existing Radiant Programmer Project

To open an existing Radiant Programmer project, you must have an existing chain file (.xcf). The daisy chain configuration must be the same as that for which the chain configuration file was created. Each unique chain configuration requires a unique chain configuration file.

Programmer can be started from the Radiant software, the Windows Start menu (integrated or stand-alone version), or a Linux command line.

To start the Radiant Programmer with an existing project:
1. Do one of the following to start Programmer:

- In the Radiant software, choose Tools > Programmer.
- In the Radiant software, click in the toolbar.
- In the Windows Start menu, choose Lattice Radiant Software > Accessories > Radiant Programmer.
- In the Windows Start menu, choose Lattice Radiant Programmer > Radiant Programmer.
- In Linux, from the <Programmer install path>/bin/lin64 directory, enter the following on a command line:

  ./programmer
2. In the Getting Started dialog box, choose **Open an Existing Programmer Project**.

3. Click **OK**.

**See Also**
- “Using the Radiant Programmer” on page 341
- “Getting Started Dialog Box” on page 367
- “Programming the FPGA” on page 328
- “Programming and Configuring iCE40 Devices with Programmer” on page 380
- “Programming and Configuring LIFCL and LFD2NX Devices with Programmer” on page 388

### Checking the XCF Project

The Check XCF button allows you to perform a design rule check on your XCF project setup before performing any actions. This feature is run automatically when the .xcf file is saved.

**To check the XCF project:**

- In the Radiant Programmer, choose **Run > Check XCF Project** or click ![Check XCF Project](image) in the toolbar. The Radiant Programmer checks the XCF project and indicates in the output pane whether or not the project is valid.

**See Also**
- “Using the Radiant Programmer” on page 341
- “Programming the FPGA” on page 328
- “Programming and Configuring iCE40 Devices with Programmer” on page 380
- “Programming and Configuring LIFCL and LFD2NX Devices with Programmer” on page 388

### Scanning the Device

There are several ways to scan a device. When you create a new project, you can choose to scan your board, perform a custom scan, or create a blank project without performing a scan.

**Note**

Not all Lattice device families support Scan capability. Refer to the *Lattice Radiant Software Release Notes* for more information on the device family that does not support Scan.
To scan the device chain on the board that is connected to your PC:

1. Make sure that the board is turned on and that the cable is properly connected to the Radiant Programmer.
2. In the Radiant Programmer, choose Run > Scan Device or click in the toolbar. The Radiant Programmer opens a new configuration file, scans the printed circuit board connected to your computer, and lists the devices in the new file.

See Also
- “Using the Radiant Programmer” on page 341
- “Programming the FPGA” on page 328
- “Programming and Configuring iCE40 Devices with Programmer” on page 380
- “Programming and Configuring LIFCL and LFD2NX Devices with Programmer” on page 388

Selecting from a Matching Device ID List

When a scanned device shares the same device ID with other devices, the software indicates this in the main window with the message “Cannot identify detected device on <row number>. Please manually select correct device.”

To select a different device from the matching ID list:

1. Click the device in the Device column.
2. Select the device you want to use from the drop-down menu.

See Also
- “Using the Radiant Programmer” on page 341
- “Programming the FPGA” on page 328
- “Programming and Configuring iCE40 Devices with Programmer” on page 380
- “Programming and Configuring LIFCL and LFD2NX Devices with Programmer” on page 388

Adding a Lattice Device to a Chain

You can add any Lattice device to an existing chain.

To add a Lattice device to a chain:

1. In the Radiant Programmer, choose Edit > Add Device, click the button on the toolbar, or right-click and choose Add Device.
2. Choose a Lattice device family from the **Device Family** column drop-down menu.

3. Choose a device from the **Device** column drop-down menu.  
The software inserts the new device into the active chain.

**To add an iCE UltraPlus device:**
1. In the Radiant Programmer, choose **Edit > Add Device**, click the button on the toolbar, or right-click and choose **Add Device**.  
2. Select iCE40 UltraPlus from the **Device Family** column drop-down menu.  
3. Select iCE40UP3K or iCE40UP5K from the **Device** column drop-down menu.  
4. Highlight the row, and choose **Edit > Device Properties**, click the button on the toolbar, or right-click and choose **Device Properties**.  
5. In the Device Properties dialog box, click the Browse button and navigate to the bitstream for the device. Select the file and click **Open**.  
The software inserts the new device into the active chain.

**To add an LIFCL device:**
1. In the Radiant Programmer, choose **Edit > Add Device**, click the button on the toolbar, or right-click and choose **Add Device**.  
2. Select LIFCL from the **Device Family** column drop-down menu.  
3. Select LIFCL-40 from the **Device** column drop-down menu.  
4. Highlight the row, and choose **Edit > Device Properties**, click the button on the toolbar, or right-click and choose **Device Properties**.  
5. In the Device Properties dialog box, click the Browse button and navigate to the bitstream for the device. Select the file and click **Open**.  
The software inserts the new device into the active chain.

**To add a LFD2NX device:**
1. In the Radiant Programmer, choose **Edit > Add Device**, click the button on the toolbar, or right-click and choose Add Device.  
2. Select LFD2NX from the Device Family column drop-down menu.  
3. Select LFD2NX-40 from the Device column drop-down menu.  
4. Highlight the row, and choose **Edit > Device Properties**, click the button on the toolbar, or right-click and choose Device Properties.  
5. In the Device Properties dialog box, click the Browse button and navigate to the bitstream for the device. Select the file and click Open.  
The software inserts the new device into the active chain.
To add an LIFCL Engineering Sample device:

1. In the Radiant Programmer, choose Edit > Add Device, click the button on the toolbar, or right-click and choose Add Device.
2. Select LIFCL_ENG from the Device Family column drop-down menu.
3. Select LIFCL-40-ES from the Device column drop-down menu.
4. Highlight the row, and choose Edit > Device Properties, click the button on the toolbar, or right-click and choose Device Properties.
5. In the Device Properties dialog box, click the Browse button and navigate to the bitstream for the device. Select the file and click Open.

The software inserts the new device into the active chain.

See Also

- “Using the Radiant Programmer” on page 341
- “Programming the FPGA” on page 328
- “Programming and Configuring iCE40 Devices with Programmer” on page 380
- “Programming and Configuring LIFCL and LFD2NX Devices with Programmer” on page 388

Adding a Generic JTAG Device to a Chain

You can add any one of the following types of devices to a chain:

- JTAG-NOP Device

To add a Generic JTAG device:

1. In the Radiant Programmer, choose Edit > Add Device, click the button on the toolbar or right-click and choose Add Device.
2. Select Generic JTAG Device from the Device Family column drop-down menu.
3. Select a JTAG-NOP from the Device column drop-down menu.
4. Highlight the row, and choose Edit > Device Properties, click the button on the toolbar, or right-click and choose Device Properties.
5. In the Device Properties dialog box, at the bottom, enter a value for the instruction register length or click Load from File and browse to the .svf file.
6. Click OK.

The software inserts the new device into the active chain.

See Also
Removing a Device from a Chain

To remove a device from the active chain:
1. In the Radiant Programmer, select the device that you want to delete.
2. Choose Edit > Remove Device, click the button on the toolbar, or right-click and choose Remove Device.

Note
There is no Undo for this command.

See Also
► “Using the Radiant Programmer” on page 341
► “Programming the FPGA” on page 328
► “Editing Device Properties” on page 390
► “Programming and Configuring iCE40 Devices with Programmer” on page 380
► “Programming and Configuring LIFCL and LFD2NX Devices with Programmer” on page 388

Editing Device Properties

To edit device properties in a chain:
1. In the Radiant Programmer, select the device that you want to edit.
2. Choose Edit > Device Properties, click the button on the toolbar, or right-click and choose Device Properties.
3. In the Device Properties dialog box, edit the device properties.
4. Click OK to close the Device Properties dialog box.

See Also
► “Using the Radiant Programmer” on page 341
► “Device Properties Dialog Box” on page 367
► “Programming the FPGA” on page 328
► “Programming and Configuring iCE40 Devices with Programmer” on page 380
Moving a Device Up or Down

To move a device up or down in the Radiant Programmer:

- With the left mouse button, select and hold the number in the far left in the row of the device that you want to move. Then drag and drop to the row where you want to move the device.

See Also

- "Using the Radiant Programmer" on page 341
- "Programming the FPGA" on page 328
- "Programming and Configuring iCE40 Devices with Programmer" on page 380
- "Programming and Configuring LIFCL and LFD2NX Devices with Programmer" on page 388

Setting Target Memory, Port Interface, Access Mode, and Operation

To set a device operation:

1. Select a device.
2. Double-click the appropriate column for the device.
3. In the Device Properties dialog box, select the specific Target Memory, Port Interface, Access Mode, and Operation for the device in the drop-down menu boxes.

See Also

- "Using the Radiant Programmer" on page 341
- "Device Properties Dialog Box" on page 367
- "Programming the FPGA" on page 328
- "Programming and Configuring iCE40 Devices with Programmer" on page 380
- "Programming and Configuring LIFCL and LFD2NX Devices with Programmer" on page 388
Setting Programming Characteristics
Use the Settings dialog box to specify how the Radiant Programmer processes the configuration. You can also specify other options.

To specify Programming characteristics:
1. In the Radiant Programmer, choose Edit > Settings.
   The Settings dialog box opens.
2. Select the options you want, and then click OK.

See Also
► "Using the Radiant Programmer" on page 341
► "Settings Dialog Box" on page 376
► "Programming the FPGA" on page 328
► "Programming and Configuring iCE40 Devices with Programmer" on page 380
► "Programming and Configuring LIFCL and LFD2NX Devices with Programmer" on page 388

Downloading Design Files
After you have specified all of the processing options, use the Program command to download the design files to the devices.

► In the Radiant Programmer, choose Run > Program Device, or click on the toolbar.

See Also
► "Using the Radiant Programmer" on page 341
► "Programming the FPGA" on page 328
► "Programming and Configuring iCE40 Devices with Programmer" on page 380
► "Programming and Configuring LIFCL and LFD2NX Devices with Programmer" on page 388

Generating Embedded Design Files
Lattice Embedded VME enables in-field upgrades of Lattice programmable devices by suitable embedded processors. Lattice provides the option to generate several different file formats for different embedded target options.

For iCE40UP, the following embedded solution is supported:
► Slave SPI Embedded: Enables field upgrades via the slave SPI port.
For LIFCL, the following embedded solutions are supported:

- **Slave SPI Embedded**: Enables field upgrades via the slave SPI port.
- **I2C Embedded**: Enables field upgrades via the I2C port.
- **JTAG Embedded**: Enables field upgrades via the JTAG port.

To generate embedded design files:

1. In the Embedded Options tab, select the desired embedded options. For more information on embedded options, refer to the following tables.

2. Choose **Run > Generate Embedded Code**, or click on the toolbar. The files are generated in the specified directory. See the following tables for file types.

---

**Table 39: Slave SPI Embedded—Device Family, Input File 1, Output File 1, and Output File 2**

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Input File</th>
<th>Output File 1</th>
<th>Output File 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>iCE40UP</td>
<td>XCF File (.xcf)</td>
<td>Algorithm VME File (*.algo.iea). This is the algorithm file that specifies which operations will be executed. It must be used with a VME data file. This file is used in device programming or in field upgrading.</td>
<td>Data File (*.data.ied)</td>
</tr>
<tr>
<td></td>
<td>Bitstream (.bit/.hex)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>LIFCL</td>
<td>XCF File (.xcf)</td>
<td>Algorithm VME File (*.algo.iea). This is the algorithm file that specifies which operations will be executed. It must be used with a VME data file. This file is used in device programming or in field upgrading.</td>
<td>Data File (*.data.ied)</td>
</tr>
<tr>
<td>LFD2NX</td>
<td>XCF File (.xcf)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>LIFCL ES</td>
<td>XCF File (.xcf)</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### Table 40: Slave SPI Embedded Options—Compress Embedded Files, Convert VME files to HEX (c.) Prom-Based Embedded VME, and Insert Source Code

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Compress Embedded Files</th>
<th>Convert VME files to HEX (c.) Prom-Based Embedded VME</th>
<th>Include Source Code</th>
</tr>
</thead>
<tbody>
<tr>
<td>iCE40UP</td>
<td>On</td>
<td>On</td>
<td>On</td>
</tr>
<tr>
<td>LIFCL</td>
<td>On</td>
<td>Off</td>
<td>Off</td>
</tr>
<tr>
<td>LFD2NX</td>
<td>Off</td>
<td>On</td>
<td>Off</td>
</tr>
<tr>
<td>LIFCL ES</td>
<td>Off</td>
<td>Off</td>
<td>Off</td>
</tr>
</tbody>
</table>

Compress data. This option reduces the file size of the VME file through compression, using less memory space. Clearing this option generates an uncompressed VME, which is useful for debugging. Compressed and uncompressed VME have the same level of performance.

Do not compress. This operation creates a VME file that is used in file-based embedded programming where the programming of the device is based on the input file. When this option is turned on, it creates a .c file, which is used in EPROM base programming to create a single compiled image that is loaded into the CPU. Then the CPU uses this image to program the device.

Do not generate .c file. Copy contents of sspiembedded/sourcecode directory to working project directory.

Note: If the "Convert VME files to HEX (c.) Prom-Based Embedded VME" option is selected, the contents of the sspiem_eceprom directory is copied.

If the "Convert VME files to HEX (c.) Prom-Based Embedded VME" option is not selected, the contents of the sspiem directory is copied.

### Table 41: I2C Embedded—Device Family, Input File 1, Output File 1, and Output File 2

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Input File</th>
<th>Output File 1</th>
<th>Output File 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIFCL</td>
<td>XCF File (.xcf)</td>
<td>Algorithm VME File (*.algo.iea). This is the algorithm file that specifies which operations will be executed. It must be used with a VME data file. This file is used in device programming or in field upgrading.</td>
<td>Data File (*.data.ied)</td>
</tr>
<tr>
<td>LFD2NX</td>
<td>Bitstream (.bit/.rbl)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>LIFCL ES</td>
<td>XCF File (.xcf)</td>
<td>Algorithm VME File (*.algo.iea). This is the algorithm file that specifies which operations will be executed. It must be used with a VME data file. This file is used in device programming or in field upgrading.</td>
<td>Data File (*.data.ied)</td>
</tr>
</tbody>
</table>
### Table 42: I2C Embedded Options—Compress Embedded Files, Convert VME Files to HEX (c.) Prom-Based Embedded VME, and Insert Source Code

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Compress Embedded Files</th>
<th>Convert VME files to HEX (c.) Prom-Based Embedded VME</th>
<th>Include Source Code</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIFCL</td>
<td>On</td>
<td>Off</td>
<td>Off</td>
</tr>
<tr>
<td>LFD2NX</td>
<td>On</td>
<td>Off</td>
<td>Off</td>
</tr>
<tr>
<td>LIFCL ES</td>
<td>On</td>
<td>Off</td>
<td>Off</td>
</tr>
</tbody>
</table>

- Compress data. This option reduces the file size of the VME file through compression, using less memory space. Clearing this option generates an uncompressed VME, which is useful for debugging. Compressed and uncompressed VME have the same level of performance.

- Do not compress. This operation creates a VME file that is used in file-based embedded programming where the programming of the device is based on the input file. When this option is turned on, it creates a .c file, which is used in EPROM base programming to create a single compiled image that is loaded into the CPU. Then the CPU uses this image to program the device.

- Do not generate .c file. Copy contents of `i2cem/embedded` directory to working project directory.

- Do not copy.

**Note:** If the "Convert VME files to HEX (c.) Prom-Based Embedded VME" option is selected, the contents of the `i2cem/eprom` directory is copied. If the "Convert VME files to HEX (c.) Prom-Based Embedded VME" option is not selected, the contents of the `i2cem` directory is copied.

### Table 43: Full JTAG Embedded—Device Family, Input File 1, Output File 1

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Input File</th>
<th>Output File 1</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIFCL</td>
<td>XCF File (.xcf)</td>
<td>Algorithm VME File (*.algo.iea). This is the algorithm file that specifies which operations will be executed. It must be used with a VME data file. This file is used in device programming or in field upgrading.</td>
</tr>
<tr>
<td>LFD2NX</td>
<td>Bitstream (.bit/.rbt)</td>
<td></td>
</tr>
<tr>
<td>LIFCL ES</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Table 44: JTAG Full VME Embedded Options—Compress VME File, Convert VME Files to HEX (c.)

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Compress Embedded Files</th>
<th>Convert VME files to HEX (c.)</th>
<th>Prom-Based Embedded VME</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIFCL</td>
<td>On</td>
<td>Off</td>
<td>Off (Default)</td>
</tr>
<tr>
<td>LFD2NX</td>
<td></td>
<td></td>
<td>On</td>
</tr>
<tr>
<td>LIFCL ES</td>
<td></td>
<td>Compress data. This option reduces the file size of the VME file through compression, using less memory space. Clearing this option generates an uncompressed VME, which is useful for debugging. Compressed and uncompressed VME have the same level of performance.</td>
<td>Uncompressed data. By default this operation is turned off. This creates a VME file that is used in file-based embedded programming where the programming of the device is based on the input file. When this option is turned on, it creates a .c file that is used in EPROM-base programming to create a single compiled image that will be loaded into the CPU. Then the CPU will use this image to program the device.</td>
</tr>
</tbody>
</table>

Table 45: JTAG Full VME Embedded Options—Compact VME File, Fixed Pulse Width (Rev. D)

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Compact VME File</th>
<th>Fixed Pulse Width (Rev. D)</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIFCL</td>
<td>Off (Default)</td>
<td>On</td>
</tr>
<tr>
<td>LFD2NX</td>
<td></td>
<td>Off (Default)</td>
</tr>
<tr>
<td>LIFCL ES</td>
<td></td>
<td>On</td>
</tr>
<tr>
<td></td>
<td>Compact VME file</td>
<td>Fixed Pulse Width VME file.</td>
</tr>
<tr>
<td></td>
<td>By default this operation is turned off. When this option is turned on it will split the VME data file into two different sections. An algorithm section and a data section. Whenever there is data needed in the algorithm section it will get it from the data section. This option is useful to turn on when the VME file is repeating the same operation even with different data. The operation will be in a loop and will reference the data section. This option will reduce the file size of the VME file.</td>
<td>By default this setting is off enabling looping (status polling algorithm) in the VME file. When it is turned on then there will be no looping (status polling algorithm) and instead commands in loops will be repeated for as many times as the loop iterated for. Status polling algorithm is a Lattice specific command in VME files, turning this option on makes the VME file generic and is useful when programming through a non-Lattice device, but increases file size.</td>
</tr>
</tbody>
</table>
Table 46: JTAG Full VME Embedded Options—Verify USERCODE, Program Device If Fails

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Verify USERCODE, Program Device If Fails</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIFCL</td>
<td>Off (Default)</td>
</tr>
<tr>
<td>LFD2NX</td>
<td>On</td>
</tr>
<tr>
<td>LIFCL ES</td>
<td>By default this operation is turn off and</td>
</tr>
<tr>
<td></td>
<td>preforms the standard erase, program,</td>
</tr>
<tr>
<td></td>
<td>verify flow. When this option is turned</td>
</tr>
<tr>
<td></td>
<td>on then before attempting to program a</td>
</tr>
<tr>
<td></td>
<td>device it will check to see if the USERCODE</td>
</tr>
<tr>
<td></td>
<td>of the device is the same as the file to</td>
</tr>
<tr>
<td></td>
<td>be programmed. If the USERCODEs are the</td>
</tr>
<tr>
<td></td>
<td>same then that device will be skipped and</td>
</tr>
<tr>
<td></td>
<td>will not be reprogrammed, otherwise if the</td>
</tr>
<tr>
<td></td>
<td>USERCODEs do not match then the device</td>
</tr>
<tr>
<td></td>
<td>will be programmed.</td>
</tr>
</tbody>
</table>

Verify USERCODE, program device if USERCODE Verify fails.

Table 47: JTAG Full VME Embedded Options—Include Header, Include Comment, Maximum Memory Allocation Size Per Row of Data (Kbytes)

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Include Header</th>
<th>Include Comment</th>
<th>Maximum Memory Allocation Size Per Row of Data (kB)</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIFCL</td>
<td>Off (Default)</td>
<td>Off (Default)</td>
<td></td>
</tr>
<tr>
<td>LFD2NX</td>
<td>On</td>
<td>On</td>
<td></td>
</tr>
<tr>
<td>LIFCL ES</td>
<td>By default the header is included in the VME file otherwise the header file is omitted from the VME file. The header contains information on the version and is useful in debugging. Turning the header off can be used to reduce the file size of the VME file.</td>
<td>Omit header from VME file.</td>
<td>Include comments in VME file.</td>
</tr>
</tbody>
</table>

Omit header from VME file. The default is off which does not include comments in the VME file, if turned on then comments will appear for the operations. Turning comments on is useful for debugging the VME file, but will increase file size.
The following table lists device family, input file types, and output file extensions for JTAG Slim VME embedded deployment.

### Table 48: JTAG Slim VME Embedded Options -- Device Family, Input File 1, Output File 1, and Output File 2

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Input File</th>
<th>Output File 1</th>
<th>Output File 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIFCL</td>
<td>XCF File (.xcf)</td>
<td>Algorithm VME File (*_algo.vme) - This is the algorithm file that specifies which operations will be executed must be used with a VME data file. This file is used in device programming or in field upgrading.</td>
<td>Data VME File (*_data.vme) - This is the data file that provides the data that the algorithm file will use to preforms executed operations must be used with a VME algorithm file. This file is used in device programming or in field upgrading.</td>
</tr>
<tr>
<td>LFD2NX</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>LIFCL ES</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

The following table lists options -- Compressed Embedded Files, onvert VME files to HEX (c.) File-Based Embedded VME -- for JTAG Slim VME embedded deployment.

### Table 49: JTAG Slim VME Embedded Options -- Compressed VME Data File, Convert VME files to HEX (c.) File-Based Embedded VME

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Compress VME Data File</th>
<th>Convert VME files to HEX (c.) File-Based Embedded VME</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIFCL</td>
<td>On (Default)</td>
<td>Off</td>
</tr>
<tr>
<td>LFD2NX</td>
<td></td>
<td>Off (Default)</td>
</tr>
<tr>
<td>LIFCL ES</td>
<td></td>
<td>On</td>
</tr>
</tbody>
</table>

Compress data. This option reduces the file size of the VME file through compression, using less memory space. Unchecking this option generates an uncompressed VME, which is useful for debugging. Compressed and uncompressed VME have the same level of performance.

Do not compress

By default this operation is turned off, this will create a VME file that will be used in file based embedded programming where the programming of the device is based on the input file. When this option is turned on then it will create a .c file which will be used in EPROM base programming to create a single complied image that will be loaded in to the CPU. Then the CPU will use this image to then program the device.

See Also:
Generating Tester Serial Vector Format (SVF) Files

Lattice provides the option to generate the Serial Vector Format (SVF) files.

To generate an SVF file:

1. In the SVF Options tab, select the desired options. For more information on embedded options, refer to the following tables.
2. Choose Run > Generate SVF File, or click $\text{Svf}$ on the toolbar. The files are generated in the specified directory.

<table>
<thead>
<tr>
<th>Table 50: SVF JTAG Chain—Device Family, Input File 1, and Output File</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Device Family</strong></td>
</tr>
<tr>
<td>Lattice Chain</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Table 51: SVF JTAG Chain—Options—Operation</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Device Family</strong></td>
</tr>
<tr>
<td>Lattice Single Device</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Table 52: SVF JTAG Chain—Options—Write Header and Comments, Write Rev D Standard SVF File</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Device Family</strong></td>
</tr>
<tr>
<td>Lattice Single Device</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Table 53: SVF JTAG Chain—Options—Use RUNTEST from Rev C; For Erase, Program, and Verify Operations, Skip Verify</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Device Family</strong></td>
</tr>
<tr>
<td>Lattice Single Device</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
</tbody>
</table>
Adding a Custom SPI Flash Device

This feature allows you users to add your own SPI Flash device to the Radiant Programmer database.

To create a Custom SPI Flash device:
1. Choose Tools > Custom Flash Device.
2. In the Edit Custom Device dialog box, select SPI Serial Flash Custom, and click Add.
3. In the Custom SPI Flash dialog box, enter:
   - **Device Description**—This can be any alphanumeric string that describes the device (for example: M25P32-VMF6C).
   - **Device Name**—This can be any alphanumeric string that describes the device name (for example: SPI-M25P32).
   - **Package**—This can be any alphanumeric string that describes the package (for example: 16-pin SOIC).
4. In the Device Vendor drop-down menu, choose device vendor.
5. In the Device Density drop-down, choose device density.
6. Device vendor ID—This can be any alphanumeric string that describes the device vendor ID (for example: 0x2C).
7. Device memory ID—This can be any alphanumeric string that describes the device memory capacity ID (for example: 0x15).
8. In the Byte Per Sector drop-down, choose the desired value.
9. If the SPI Flash device supports sector protection, check the Protection Options On box.
10. Click OK.
11. Once the custom SPI flash has been added, it can be selected in the Device Properties dialog box.

See Also
- “Using the Radiant Programmer” on page 341
- “Device Properties Dialog Box” on page 367
- “Custom SPI Flash Dialog Box” on page 375

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Include RESET at the End of the SVF File</th>
<th>Set Maximum Data Size per Row (Kbits)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lattice Single Device</td>
<td>Off (Default)</td>
<td>On</td>
</tr>
<tr>
<td>Do not write RESET at the end of the SVF file.</td>
<td>Write RESET at the end of the SVF file.</td>
<td>64/8/16/32/128/256</td>
</tr>
</tbody>
</table>
Editing a Custom SPI Flash Device

If you have already created a custom SPI Flash device, you can edit its properties in the Custom SPI Flash dialog box.

To edit the properties of a Custom SPI Flash device:

1. Choose Tools > Custom Flash Device.
2. In the Edit Custom Device dialog box, select SPI Serial Flash Custom, select the SPI Flash device you want to edit, and click Edit.
3. In the Custom SPI Flash dialog box, enter:
   - **Device Description**—This can be any alphanumeric string that describes the device (for example: M25P32-VMF6C).
   - **Device Name**—This can be any alphanumeric string that describes the device name (for example: SPI-M25P32).
   - **Package**—This can be any alphanumeric string that describes the package (for example: 16-pin SOIC).
4. In the Device Vendor drop-down menu, choose device vendor.
5. In the Device Density drop-down, choose device density.
6. Device vendor ID—This can be any alphanumeric string that describes the device vendor ID (for example: 0x2C).
7. Device memory capacity ID—This can be any alphanumeric string that describes the device vendor memory capacity ID (for example: 0x15).
8. In the Byte Per Sector drop-down, choose the desired value.
9. If the SPI Flash device supports sector protection, check the Protection Options ON box.
10. Click OK.

See Also

- “Using the Radiant Programmer” on page 341
- “Custom SPI Flash Dialog Box” on page 375
- “Programming the FPGA” on page 328
- “Programming and Configuring iCE40 Devices with Programmer” on page 380
- “Programming and Configuring LIFCL and LFD2NX Devices with Programmer” on page 388
Removing a Custom SPI Flash Device

Once you have created a custom SPI Flash device, you can remove it from the Custom SPI Flash dialog box.

To edit the properties of a Custom SPI Flash device:
1. Choose Tools > Custom Flash Device.
2. In the Edit Custom Device dialog box, select SPI Serial Flash Custom.
3. Select the SPI Flash device you want to remove.
4. Click Remove.
5. Click OK.

See Also
- “Using the Radiant Programmer” on page 341
- “Custom SPI Flash Dialog Box” on page 375
- “Programming the FPGA” on page 328
- “Programming and Configuring iCE40 Devices with Programmer” on page 380
- “Programming and Configuring LIFCL and LFD2NX Devices with Programmer” on page 388

Programming Using Custom SPI Flash Device

After a custom SPI Flash device has been created, you can program it using the Radiant Programmer.

To program using a Custom SPI Flash device:
1. Left-click on the row corresponding to the device you want to edit, and choose Edit > Device Properties, to display the Device Properties dialog box.
2. In the Target Memory Mode drop-down list, choose External SPI Flash memory (SPI FLASH).
3. In the Family drop-down list, choose SPI Serial Flash Custom.
4. In the Device drop-down list, choose the name of the custom device you created.
5. Click OK.

See Also
- “Using the Radiant Programmer” on page 341
- “Device Properties Dialog Box” on page 367
Unlocking Secure SPI Flash Support

If a custom SPI flash device or a SPI flash device was secured and you wish to reprogram the SPI flash, you must first unlock the device before reprogramming it.

To unlock a secure SPI flash:

1. Create a new the Radiant Programmer project as described in “Creating a New Radiant Programmer Project” on page 344 or open an existing Radiant Programmer project as described in “Opening an Existing Radiant Programmer Project” on page 345.

2. Right-click on the row corresponding to the device you would like to edit, and choose Edit > Device Properties.

3. In the Operation drop-down list, chose SPI Flash Unlock Device.

4. Ensure that the Secure SPI Flash Golden Pattern Sectors box is unchecked.

5. Click OK.

6. In the Radiant Programmer, choose Run > Program, or click on the toolbar.

The SPI flash is now unlocked and can be reprogrammed.

See Also

- “Using the Radiant Programmer” on page 341
- “Programming the FPGA” on page 328
- “Programming and Configuring iCE40 Devices with Programmer” on page 380
- “Programming and Configuring LIFCL and LFD2NX Devices with Programmer” on page 388

Configuring SPI Flash Options

You can use the Device Properties dialog box to configure SPI Flash options for Ultra Plus devices.

To configure SPI Flash Options:

1. In Programmer, select the device that you want to edit.
2. Choose **Edit > Device Properties**, or click the button on the toolbar, or right-click and choose **Device Properties** to display the Device Properties dialog box.

3. In the Target Memory pulldown menu, choose **External SPI Flash Memory (SPI FLASH)**.

4. In the Port Interface pulldown menu, choose **SPI** for iCE40UP or **JTAG2SPI** or **SSPI2SPI** for LIFCL or LFD2NX.

5. In the Access Mode pulldown menu, choose **Direct Programming**.

6. In the Options pulldown menu, chose the desired SPI Flash option.

7. In the Programming File box, browse to and select the programming file (.bit, .rbt, .bin, .hex, .mcs, .exo, or .xtek).

8. Select the desired **Family**, **Vendor**, **Device**, and **Package** options.

9. Click **Load from File** to select the data size entered. You can change this size by typing a different file size. This feature is useful if you only want to use a portion of the file for the operation. If you change the file size, it must be no larger than the full file size or the device size.

10. Select start address and end address from the **Start Address (Hex)** and **End Address (Hex)** drop-down menus. For the AMD parallel flash, the starting address is automatically selected and cannot be changed.

11. To erase the flash device if a verify error occurs, click the **Erase SPI Part on Programming Error** box.

12. Click **OK**.

**See Also**

- “Using the Radiant Programmer” on page 341
- “Programming the FPGA” on page 328
- “Device Properties Dialog Box” on page 367
- “Programming and Configuring iCE40 Devices with Programmer” on page 380
- “Programming and Configuring LIFCL and LFD2NX Devices with Programmer” on page 388

**Changing the Port Assignment**

When you first launch the Programmer software with the cables properly connected, it connects to the first available port that it detects. You can change the connecting port, as well as other cable options, using the Cable and Port Setting dialog box.

**To change the port setup:**

1. In Programmer, choose **View > Cable Setup**.

2. In the Cable Setup dialog box, choose the options that you want. Changes are immediately applied.
If the cable is not connected or cannot be detected (if the board power is not on, for example), Programmer software displays an error message.

See Also
- “Using the Radiant Programmer” on page 341
- “Programming the FPGA” on page 328
- “Cable Setup Dialog Box” on page 377
- “Programming and Configuring iCE40 Devices with Programmer” on page 380
- “Programming and Configuring LIFCL and LFD2NX Devices with Programmer” on page 388

Testing the Cable Signal
The Cable Signal Tests dialog box helps you debug or improve the cable signal. You can use an oscilloscope, while running the continuous loop feature, to test your printed circuit board.

To test the cable signal:
1. In Programmer, choose View > Cable Setup.
2. In the Cable Setup dialog box, click the Debug Mode button. The Cable Signal Tests dialog box opens.
3. In the dialog box, click Power Check to test the connection. The VCC Status LED blinks green if the cable and power are detected. It produces an error message and blinks red if the cable or power is not detected.
4. In the dialog box, select an option for the pins you want to test. The options are defined as follows:
   - **Toggle** – Alternates between logic 1 and logic 0.
   - **Hold High** – Holds at logic 1.
   - **Hold Low** – Holds at logic 0.
   - **Read (TDO only)** – Reads back the data from TDO and records the read back data in the Programmer log file.

**Note**
The options available for cable signal testing varies, depending on the type of cable you are using and the options you have selected in the Cable Setup dialog box. Options not available are grayed out.

5. To test the settings you have selected, click Test. This causes the pins that have a Toggle setting to toggle once from logic 1 to logic 0 to logic 1.
6. To perform continuous testing, click Loop Test.
This causes the pins that have a Toggle setting to toggle continuously until you stop the process.

7. To stop the loop process, press ESC.

See Also
- “Using the Radiant Programmer” on page 341
- “Cable Signal Tests Dialog Box” on page 379
- “Programming the FPGA” on page 328
- “Programming and Configuring iCE40 Devices with Programmer” on page 380
- “Programming and Configuring LIFCL and LFD2NX Devices with Programmer” on page 388

Viewing the Log File

An ASCII text log file summarizes the results of the Programmer operations.

To view the log file:
- Click the button on the toolbar. An ASCII text file opens showing the contents of the log.

See Also
- “Using the Radiant Programmer” on page 341
- “Programming the FPGA” on page 328
- “Programming and Configuring iCE40 Devices with Programmer” on page 380
- “Programming and Configuring LIFCL and LFD2NX Devices with Programmer” on page 388

Programmer Options

This section lists the options available in Programmer.

Topics include:
- “Getting Started Dialog Box” on page 367
- “Device Properties Dialog Box” on page 367
- “Custom SPI Flash Dialog Box” on page 375
- “Settings Dialog Box” on page 376
- “Cable Setup Dialog Box” on page 377
- “Cable Signal Tests Dialog Box” on page 379
Getting Started Dialog Box

The following options are available in the Getting Started dialog box:

**Project Name**  Specifies the name of the project.

**Project Location:**  Specifies the location of the project.

**Create a New Project from a Scan**  Scans the attached chain with the last used cable settings.

**Cable**  Specifies the download cable type:

- **HW-USBN-2A**—(Lattice HW-USBN-2A USB port programming cable)
- **HW-USBN-2B (FTDI)**—(Lattice HW-USBN-2B (FTDI) USB programming cable)
- **HW-DLN-3C (Parallel)**—(Lattice HW-DLN-3C parallel programming cable)

**Port**  Specifies the serial port to which the download cable is connected. Select the port from the list or click Detect Cable.

**Detect Cable**  Automatically detects where the download cable is connected.

**Blank Programmer Project**  Creates a new blank project.

**Open an Existing Programmer Project**  Allows you to browse to an existing .xcf configuration file and open an existing Programmer project.

See Also

- “Programmer Options” on page 366
- “Programming and Configuring iCE40 Devices with Programmer” on page 380
- “Programming and Configuring LIFCL and LFD2NX Devices with Programmer” on page 388

Device Properties Dialog Box

The Device Properties dialog box consists of two tabs: General Tab and Device Information Tab.

**General Tab**

The following options are available in the Device Properties dialog box General tab, depending on selected Access Mode and Operation.
**Target Memory**  Target memory is the storage memory type on the FPGA.

### Table 55: Target Memory for iCE40UP

<table>
<thead>
<tr>
<th>Target Memory</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Compressed Random Access Memory (CRAM)</td>
<td>The memory type used for CRAM configuration.</td>
</tr>
<tr>
<td>Non Volatile Configuration Memory (NVCM)</td>
<td>This memory type is used to program the non-volatile configuration memory (NVCM) while the device is not operational.</td>
</tr>
<tr>
<td>External SPI Flash Memory (SPI FLASH)</td>
<td>Serial peripheral interface (SPI) memory flash memory.</td>
</tr>
</tbody>
</table>

### Table 56: Target Memory for LIFCL and LFD2NX

<table>
<thead>
<tr>
<th>Target Memory</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Static Random Access Memory (SRAM)</td>
<td>The memory type used for SRAM configuration.</td>
</tr>
<tr>
<td>Non Volatile Configuration Memory (EFUSE)</td>
<td>This memory type is used to program the non-volatile configuration memory (EFUSE).</td>
</tr>
<tr>
<td>External SPI Flash Memory (SPI FLASH)</td>
<td>Serial peripheral interface (SPI) memory flash memory.</td>
</tr>
</tbody>
</table>

**Port Interface**  The following tables list the port interfaces.

### Table 57: Port Interface for iCE40UP

<table>
<thead>
<tr>
<th>Target Memory</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Slave SPI</td>
<td>The four-wire serial peripheral interface (SPI) communications protocol.</td>
</tr>
<tr>
<td>SPI</td>
<td>Serial peripheral interface (SPI) communications protocol.</td>
</tr>
</tbody>
</table>

### Table 58: Port Interface for LIFCL and LFD2NX

<table>
<thead>
<tr>
<th>Target Memory</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>JTAG</td>
<td>The four-wire JTAG interface communications protocol.</td>
</tr>
<tr>
<td>Slave SPI</td>
<td>The four-wire serial peripheral interface (SPI) communications protocol.</td>
</tr>
<tr>
<td>I2C</td>
<td>The two-wire Integrated Circuit (I2C communications protocol.</td>
</tr>
<tr>
<td>SPI</td>
<td>Serial peripheral interface (SPI) communications protocol.</td>
</tr>
</tbody>
</table>

**Access Mode**  Selects the mode for programming the device.

### Table 59: Access Mode for iCE40UP

<table>
<thead>
<tr>
<th>Access Mode</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Direct Programming</td>
<td>Used for direct programming while the device is not in operation.</td>
</tr>
</tbody>
</table>
**Operation**  Lists the available operation modes for the device. Choose one from the pull-down list.

### Table 60: Access Mode for LIFCL and LFD2NX

<table>
<thead>
<tr>
<th>Access Mode</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Feature Rows Programming</td>
<td>Used to program, read back, and edit the Feature Row sector of the LIFCL or LFD2NX device. This mode also is used to read back and edit the non-volatile Control Register 1 (which also belongs to Feature Row sector).</td>
</tr>
<tr>
<td>Direct Programming</td>
<td>Used for direct programming while the device is not in User mode.</td>
</tr>
<tr>
<td>Background Programming</td>
<td>Used for background programming while the device is in User mode.</td>
</tr>
<tr>
<td>Advanced Security Programming</td>
<td>Used for programming the security keys.</td>
</tr>
</tbody>
</table>

### Table 61: Operations for iCE40UP

<table>
<thead>
<tr>
<th>Operation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Blank Check</td>
<td>Checks if the device is erased (blank).</td>
</tr>
<tr>
<td>CRAM Read and Save</td>
<td>Shifts in a bitstream by directly loading the iCE40 CRAM over the SPI bus. The contents in memory are then read and saved to an output file.</td>
</tr>
<tr>
<td>Erase, Program, Verify</td>
<td>Erases, programs, and verifies the new configuration memory.</td>
</tr>
<tr>
<td>Fast Configuration</td>
<td>Shifts in a bitstream directly into device and the device takes care of the rest for configuration.</td>
</tr>
<tr>
<td>Fast Program, Read and Save</td>
<td>Shifts in a bitstream directly into device and the device takes care of the rest for configuration. The contents in memory are then read and saved to an output file.</td>
</tr>
<tr>
<td>Fast Program, Read and Save without DONE bit</td>
<td>Shifts in a bitstream directly into device and the device takes care of the rest for configuration, but without the DONE bit. The contents in memory are then read and saved to an output file.</td>
</tr>
<tr>
<td>Program Only</td>
<td>Programs a new configuration into memory. Issues programming instructions and then the data is taken from the data file.</td>
</tr>
<tr>
<td>Program, Verify</td>
<td>Programs the memory of the device and then verifies the contents of that memory.</td>
</tr>
<tr>
<td>Program, Verify, Secure</td>
<td>Programs the memory of a device, verifies the contents of memory, secures the configuration block. Secure inhibits readback of the device.</td>
</tr>
<tr>
<td>Read DONE bit</td>
<td>Reads to see if the DONE bit has or has not been set.</td>
</tr>
<tr>
<td>Read Device Properties</td>
<td>Reads the properties of the device.</td>
</tr>
</tbody>
</table>
Table 61: Operations for iCE40UP (Continued)

<table>
<thead>
<tr>
<th>Operation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Secure Device</td>
<td>Secures the configuration block. Secure inhibits readback of the device.</td>
</tr>
<tr>
<td>Verify ID</td>
<td>Verifies the ID of the device.</td>
</tr>
<tr>
<td>Verify Only</td>
<td>Verifies the new configuration memory.</td>
</tr>
</tbody>
</table>
### Table 62: Operations for LIFCL and LFD2NX

<table>
<thead>
<tr>
<th>Target Memory</th>
<th>Ports Interface</th>
<th>Access Mode</th>
<th>Operations</th>
</tr>
</thead>
<tbody>
<tr>
<td>Static Random Access Memory (SRAM)</td>
<td>JTAG Slave SPI, I2C</td>
<td>Direct Programming</td>
<td>Fast Configuration</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Erase, Program, Verify</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Verify Only</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Erase Only</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Verify ID</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Display ID</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Program Control Register0</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Display Control Register0</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Program Control Register1</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Display Control Register1</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Display USERCODE</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Read and Save</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Read Status Register</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Refresh</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Secure Plus</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Bypass</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>External Primary Dry Run</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>External Golden Dry Run</td>
</tr>
<tr>
<td>Non Volatile Configuration Memory</td>
<td>JTAG Slave SPI, I2C</td>
<td>Feature Rows</td>
<td>Program Feature Row</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Programming</td>
<td>Update Feature Row</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Read Feature Row</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Program Control NV Register1</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Display Control NV Register1</td>
</tr>
</tbody>
</table>

**Background Programming**

|                          |                          |                     | SEI Fast Program                                 |
|                          |                          |                     | Verify Only                                       |
|                          |                          |                     | Verify ID                                        |
|                          |                          |                     | Display ID                                       |
|                          |                          |                     | Program Control Register0                        |
|                          |                          |                     | Display Control Register0                        |
|                          |                          |                     | Program Control Register1                        |
|                          |                          |                     | Display Control Register1                        |
|                          |                          |                     | Display USERCODE                                 |
|                          |                          |                     | Read and Save                                    |
|                          |                          |                     | Read Status Register                             |
|                          |                          |                     | Refresh                                          |
|                          |                          |                     | Secure Plus                                      |
|                          |                          |                     | Bypass                                           |
|                          |                          |                     | External Primary Dry Run                         |
|                          |                          |                     | External Golden Dry Run                          |
The following is an alphabetic list of all available operations with a definition of each operation.

### Table 63: Operations

<table>
<thead>
<tr>
<th>Operation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bypass</td>
<td>No operation is performed on the device.</td>
</tr>
<tr>
<td>Display Control NV Register1</td>
<td>Reads and displays the content of non-volatile control register 1, which is in the same location as the Feature Row.</td>
</tr>
<tr>
<td>Display Control Register0</td>
<td>Reads and displays the contents of Control Register 0.</td>
</tr>
<tr>
<td>Display Control Register1</td>
<td>Reads and displays the contents of the SRAM Control Register 1.</td>
</tr>
<tr>
<td>Display ID</td>
<td>Reads and displays the device ID.</td>
</tr>
<tr>
<td>Operation</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------------------</td>
<td>-----------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Display Status Register</td>
<td>Reads and displays the device's Status Register.</td>
</tr>
<tr>
<td>Display USERCODE</td>
<td>Reads and displays the USERCODE.</td>
</tr>
<tr>
<td>Erase Feature Row</td>
<td>Erases the feature row.</td>
</tr>
<tr>
<td>Erase Only</td>
<td>Erases the configuration memory.</td>
</tr>
<tr>
<td>Erase, Program, Verify</td>
<td>Erases, programs, and verifies the new configuration memory.</td>
</tr>
<tr>
<td></td>
<td>In SRAM mode, this operation only supported to program and verify the CFG data array, All other instructions or data related to the LMNI INIT Bus will be ignored.</td>
</tr>
<tr>
<td>External Primary Dry Run</td>
<td>Execute Dry Run on Primary image off External SPI Flash.</td>
</tr>
<tr>
<td>External Golden Dry Run</td>
<td>Execute Dry Run on Golden image off External SPI Flash.</td>
</tr>
<tr>
<td>Enable HMAC Authentication Mode</td>
<td>Program HMAC Authentication Mode Enable Bit.</td>
</tr>
<tr>
<td>Enable ECDSA Authentication Mode</td>
<td>Program ECDSA Authentication Mode Enable Bit.</td>
</tr>
<tr>
<td>Fast Configuration</td>
<td>Shifts in a bitstream directly into device and the device take care of the rest for configuration.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong>: For LIFCL ES devices, power-cycling is required if an error occurs when using SRAM “Fast Configuration” operation.</td>
</tr>
<tr>
<td>Program</td>
<td>Programs a new configuration into memory. Issues programming instructions and then the data are taken from the data file.</td>
</tr>
<tr>
<td>Program Control NV Register1</td>
<td>Programs the content of non-volatile control register 1 which is in the same location of the Feature Row.</td>
</tr>
<tr>
<td>Program Control Register0</td>
<td>Read Back and update the Control Register 0.</td>
</tr>
<tr>
<td>Program Control Register1</td>
<td>Read Back and update the SRAM Control Register 1.</td>
</tr>
<tr>
<td>Program Encryption Key</td>
<td>Programs the encryption key into a device.</td>
</tr>
<tr>
<td>Program Feature Row</td>
<td>Programs the Feature Row.</td>
</tr>
<tr>
<td></td>
<td>Programs the 128-bit feature row data into a device. The setting is from the .fea file.</td>
</tr>
<tr>
<td>Program Password Key</td>
<td>Programs the password keys into the device.</td>
</tr>
<tr>
<td>Program Public Key</td>
<td>Programs the ECDSA public keys into the device.</td>
</tr>
<tr>
<td>Program Locks Policies</td>
<td>Program the device’s Locks Policies.</td>
</tr>
<tr>
<td>Lock Ports Interface</td>
<td>Program the Ports interface locks.</td>
</tr>
</tbody>
</table>
### Table 63: Operations (Continued)

<table>
<thead>
<tr>
<th>Operation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Read and Save</strong></td>
<td>Reads the contents of memory and saves it to an output file. In SRAM mode, this operation only supported to read and save the CFG data array. All other instructions or data related to the LMNI INIT Bus will be ignored.</td>
</tr>
<tr>
<td><strong>Read Encryption Key</strong></td>
<td>Reads the contents of encryption key.</td>
</tr>
<tr>
<td><strong>Read Feature Row</strong></td>
<td>Reads the contents of the Feature Row.</td>
</tr>
<tr>
<td><strong>Read Password Key</strong></td>
<td>Reads the contents of Password Key.</td>
</tr>
<tr>
<td><strong>Read Public Key</strong></td>
<td>Reads the contents of ECDSA Public Key.</td>
</tr>
<tr>
<td><strong>Read Locks Policies</strong></td>
<td>Reads the contents of device’s Locks Policies.</td>
</tr>
<tr>
<td><strong>Read Status Register</strong></td>
<td>Reads the contents of the Status Register.</td>
</tr>
<tr>
<td><strong>Refresh</strong></td>
<td>Configures the pattern in non-volatile memory into SRAM.</td>
</tr>
<tr>
<td><strong>Secure Plus</strong></td>
<td>Secures the configuration block and the user’s fuses memory. Secure inhibits readback of the device.</td>
</tr>
<tr>
<td><strong>SEI Fast Program</strong></td>
<td>Fast Program the SEI (Soft Error Injection) bitstream to support SED features.</td>
</tr>
<tr>
<td><strong>Scan SPI Flash Device</strong></td>
<td>Scans the SPI Flash in the board.</td>
</tr>
<tr>
<td><strong>SPI Flash Calculate Device Size Checksum</strong></td>
<td>Calculates the Checksum of the entire device.</td>
</tr>
<tr>
<td><strong>SPI Flash Calculate File Size Checksum</strong></td>
<td>Calculates the Checksum of the data contained in the device for the address range of the input file.</td>
</tr>
<tr>
<td><strong>SPI Flash Erase All</strong></td>
<td>Erases all of the configuration memory.</td>
</tr>
<tr>
<td><strong>SPI Flash Erase, Program, Verify</strong></td>
<td>Erases, programs, and verifies the new configuration memory.</td>
</tr>
<tr>
<td><strong>SPI Flash Erase, Program, Verify Quad 1</strong></td>
<td>Erases, programs, and verifies the new configuration memory; and enable the SPI-Flash Quad read mode.</td>
</tr>
<tr>
<td><strong>SPI Flash Read and Save</strong></td>
<td>Same as “Read and Save.”</td>
</tr>
<tr>
<td><strong>SPI Flash Verify Only</strong></td>
<td>Same as “Verify Only”/Verify the content of external SPI Flash.</td>
</tr>
<tr>
<td><strong>Upload to Static RAM</strong></td>
<td>Uploads data to SRAM.</td>
</tr>
<tr>
<td><strong>Update Feature Row</strong></td>
<td>Read back and update the feature rows in the device</td>
</tr>
<tr>
<td><strong>Update Locks Policies</strong></td>
<td>Update the Locks Policies.</td>
</tr>
<tr>
<td><strong>Verify ID</strong></td>
<td>Verifies the ID of the device.</td>
</tr>
</tbody>
</table>
Device Information Tab
The Device Information tab displays information on the device selected. The content can vary depending upon the device selected, and can include:

- Family Name
- Device Name
- VCC Voltage Supply
- Programming Pins
- JTAG IDCODE
- JTAG IDCODE MASK
- IDCODE Length
- SOFT IDCODE
- Maximum Erase Pulse Width (ms)
- Maximum Program Pulse Width (ms)

See Also
- “Programmer Options” on page 366
- “Programming and Configuring iCE40 Devices with Programmer” on page 380
- “Programming and Configuring LIFCL and LFD2NX Devices with Programmer” on page 388

Custom SPI Flash Dialog Box
The following options are available in the Custom SPI Flash dialog box:

Device Family  Lists the device family being used.

Device Description  The name that was assigned to the device.

Device Name  This can be any alphanumeric string that describes the device name (for example: SPI-M25P32).

Package  This can be any alphanumeric string that describes the package (for example: 16-pin SOIC).
Device Vendor  The vendor of the custom SPI Flash device.

Device Density  The size of the Serial SPI Flash device (512 kilobits - 256 MB).

Manufacturing ID  The manufacturing ID of the vendor of the custom SPI Flash device. (for example: 0xC2 Macronix).

Device Memory Capacity ID  This can be any alphanumeric string that describes the device ID (for example: 0x15).

Byte Per Sector  Allows you to choose desired bytes per sector value.

Protection Options ON  If the SPI Flash device supports sector protection, select this option to enable protection options. This allows you to select Secure SPI Flash Golden Pattern Sectors in the “Device Properties Dialog Box” on page 367.

See Also
▶ “Programmer Options” on page 366
▶ “Programming and Configuring iCE40 Devices with Programmer” on page 380
▶ “Programming and Configuring LIFCL and LFD2NX Devices with Programmer” on page 388

Settings Dialog Box
The following options are available in the Settings dialog box:

General Tab

At Programmer Start-Up  Allows you to select between showing the Programmer Getting Started dialog box at start-up, or opening the last Programmer project at start-up.

USERCODE Display  Allows you to choose in which format the USERCODE will be displayed. Choices are Hex, ASCII, and Decimal.

Device Family Selection List Order  Allows you to display the Device Family pull-down list in the Programmer main window in either chronological or alphabetical order. The default is chronological order.

Log File Path  Shows the location of the Programmer log file, and allows you to browse to and set a new location for the Programmer.log file.

Clear Log File Each Time Application Starts  Clears the log file each time the application starts. If the option is not selected, the log file continues increase in size until the file is manually erased.
**Programming Tab**

**Sequential Mode** Programs all the devices on the board one at a time. If an Operation Override is selected, all Operation descriptions in the chain file are temporarily changed to the override setting.

**Use Default JTAG States (TLR/TLR)** Uses Test-Logic-Reset (TLR) as the starting and ending JTAG state of the JTAG State Machine for download.

**Avoid Test Logic Reset (TLR) State** Avoids the Test Logic Reset State of the JTAG State Machine during download.

**Use Custom JTAG States** Specify Test-Logic-Reset (TLR) or Run-Test/Idle (RTI) as the starting and ending JTAG state of the JTAG State Machine for download.

**Initial TAP State** Specify TLR or RTI as the starting JTAG state of the JTAG State Machine for download.

**Final TAP State** Specify TLR or RTI as the ending JTAG state of the JTAG State Machine for download.

**Check Cable Setup Before Programming** Confirms that the cable signals are correctly connected to the board and devices in the JTAG chain on the board match the devices selected in the .xcf file.

**Continue Download on Error** Ignores any errors while downloading and continues running.

**See Also**
- “Programmer Options” on page 366
- “Programming and Configuring iCE40 Devices with Programmer” on page 380
- “Programming and Configuring LIFCL and LFD2NX Devices with Programmer” on page 388

**Cable Setup Dialog Box**

The following options are available in the Cable Setup dialog box:

**Detect Cable** Automatically detects where the download cable is connected.

**Cable** Specifies the download cable type:

- **HW-USBN-2A** - (Lattice HW-USBN-2A USB port programming cable)
- **HW-USBN-2B (FTDI)** - (Lattice HW-USBN-2B (FTDI) USB programming cable)
- **HW-DLN-3C (Parallel)** - (Lattice HW-DLN-3C parallel programming cable)
**Port**  Specifies the serial port to which the download cable is connected. Select the port from the list or click Detect Cable.

**Custom Port**  Specifies a custom parallel port to which the download cable is connected. Use hexadecimal format to type the port name.

**Use default Clock Divider**  Uses the fastest TCK clock speed.

**Use custom Clock Divider**  Enables the TCK Divider Setting option.

**TCK Divider Setting (0 - 30x)**  Allows you to slow down the TCK clock. This is done by extending the low period of the clock. Refer the following tables for specific frequency settings for USB-2B (2232H FTDI USB host chip), USB-2B (2232D FTDI USB host chip), and USB-2A and Parallel port cables.

### Table 64: USB-2B (2232H FTDI USB host chip)

<table>
<thead>
<tr>
<th>Divider</th>
<th>Clock Frequency¹</th>
<th>Divider</th>
<th>Clock Frequency¹</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>30 MHz</td>
<td>5</td>
<td>5 MHz</td>
</tr>
<tr>
<td>1</td>
<td>15 MHz</td>
<td>6</td>
<td>4.2 MHz</td>
</tr>
<tr>
<td>2</td>
<td>10 MHz</td>
<td>7</td>
<td>3.7 MHz</td>
</tr>
<tr>
<td>3</td>
<td>7.5 MHz</td>
<td>8</td>
<td>3.1 MHz</td>
</tr>
<tr>
<td>4</td>
<td>6 MHz</td>
<td>9</td>
<td>3 MHz</td>
</tr>
<tr>
<td></td>
<td>10</td>
<td></td>
<td>2.7 MHz</td>
</tr>
</tbody>
</table>

¹Calculation formula for USB-2B (2232H FTDI USB host chip):

Frequency = 60 MHz / (1 + ClockDivider) *2

### Table 65: USB-2B (2232D FTDI USB host chip)

<table>
<thead>
<tr>
<th>Divider</th>
<th>Clock Frequency²</th>
<th>Divider</th>
<th>Clock Frequency²</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>6 MHz</td>
<td>5</td>
<td>1 MHz</td>
</tr>
<tr>
<td>1</td>
<td>3 MHz (Default)</td>
<td>6</td>
<td>0.8 MHz</td>
</tr>
<tr>
<td>2</td>
<td>2 MHz</td>
<td>7</td>
<td>0.7 MHz</td>
</tr>
<tr>
<td>3</td>
<td>1.5 MHz</td>
<td>8</td>
<td>0.65 MHz</td>
</tr>
<tr>
<td>4</td>
<td>1.2 MHz</td>
<td>9</td>
<td>0.6 MHz</td>
</tr>
<tr>
<td></td>
<td>10</td>
<td></td>
<td>0.5 MHz</td>
</tr>
</tbody>
</table>

²Calculation formula for USB-2B (2232D FTDI USB host chip):

Frequency = 12 MHz / (1 + ClockDivider) *2

### Table 66: USB-2A and Parallel port

<table>
<thead>
<tr>
<th>Divider</th>
<th>Low Pulse Width delay³</th>
<th>Divider</th>
<th>Low Pulse Width delay³</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>NA</td>
<td>5</td>
<td>5x</td>
</tr>
<tr>
<td>1</td>
<td>1x</td>
<td>6</td>
<td>6x</td>
</tr>
<tr>
<td>---</td>
<td>---</td>
<td>---</td>
<td>---</td>
</tr>
<tr>
<td>2</td>
<td>2x</td>
<td>7</td>
<td>7x</td>
</tr>
<tr>
<td>3</td>
<td>3x</td>
<td>8</td>
<td>8x</td>
</tr>
<tr>
<td>4</td>
<td>4x</td>
<td>9</td>
<td>9x</td>
</tr>
<tr>
<td></td>
<td></td>
<td>10</td>
<td>10x</td>
</tr>
</tbody>
</table>

The USB-2A frequency fixed at 1.5 MHz and Parallel Port frequency fixed at 500 kHz

**Use Default I/O Settings**  Only use the four JTAG signals.

**Use Custom I/O Settings**  Specify additional non-JTAG signals connected to the board.

**INITN Pin Connected**  Select this option if you connect the INIT pin to the download cable. This option is only available with the Lattice USB port programming cable.

**Done Pin Connected**  Select this option if you connect the DONE pin to the download cable. This option is not available for the Lattice HW-DLN-3C parallel programming cable.

**TRST Pin Connected**  Select this option if you connect the TRST pin to the download cable. Specify active high or active low.

**PROGRAMN Pin Connected**  Select this option if you connect the PROGRAMN pin to the download cable.

**ispEN Pin Connected**  Select this option if you connect the ispEN pin to the download cable. Specify active high or active low.

**Debug Mode**  Opens the Cable Signal Tests dialog box. See "Cable Signal Tests Dialog Box" on page 379.

**See Also**

- "Programmer Options" on page 366
- "Programming and Configuring iCE40 Devices with Programmer" on page 380
- "Programming and Configuring LIFCL and LFD2NX Devices with Programmer" on page 388

**Cable Signal Tests Dialog Box**

The following options are available in the Cable Signal Tests dialog box:

**Toggle**  Alternates between logic 1 and logic 0.
Hold High  Holds at logic 1.

Hold Low  Holds at logic 0.

Test  Applies the selected settings to the selected pin connections. This causes the pins that have a toggle setting to toggle once from logic 1 to logic 0 to logic 1.

Loop Test  Performs continuous testing, causing the pins that have a toggle setting to toggle continuously until you click ESC.

View Log  Opens the log file, an ASCII text file that summarizes the results of the Cable Signal Test operations.

Power Check  Tests the cable and power connections, causing the VCC Status LED to blink green or red to indicate that cable and power are detected or not detected.

VCC Status  Shows the status of the cable and power connection. The LED blinks green when the cable and power are detected. It blinks red and produces an error message when cable or power is not detected.

Toggle Delay  Sets the delay after each operation. Default is 0.

Number of Bytes  Sets the number of bytes read by each operation. Default is 0.

See Also
- “Programmer Options” on page 366
- “Programming and Configuring iCE40 Devices with Programmer” on page 380
- “Programming and Configuring LIFCL and LFD2NX Devices with Programmer” on page 388

Programming and Configuring iCE40 Devices with Programmer

The Radiant Programmer supports programming and configuration of iCE40 devices.

There are three basic flows for programming or configuring iCE40 devices:

- iCE40 CRAM Configuration Flow using .bin and .hex files output from the Radiant software. The default is .bin.
  
  CRAM configuration is accomplished by directly loading the iCE40 CRAM over the SPI bus.

- iCE40 NVCM Programming Flow using Nonvolatile Configuration Memory (.nvcm) files output from the Radiant software.
NCVM programming involves transmitting programming data over the SPI bus to the NVCM array internal to the iCE40 device. The NVCM is one-time programmable (OTP).

- iCE40 SPI Flash Programming Flow using a separate SPI Flash device to configure an iCE40 device.

  In this flow, the iCE40 device acts as the SPI bus master and therefore controls the data flow from the configuration device.

See Also

- Configuring an iCE40 Device Using the CRAM Flow
- Programming an iCE40 Device Using the NVCM Flow
- Programming an iCE40 Device Using SPI Flash Device Flow
- Using the Radiant Programmer
- Lattice Radiant Software User Guide
- TN1248 - iCE40 Programming and Configuration

Configuring an iCE40 Device Using the CRAM Flow

iCE40 CRAM Configuration Flow uses .hex files, .bin files, or Intel-Hex files output from the Radiant software. CRAM configuration is accomplished by directly loading the iCE40 CRAM over the SPI bus.

When using the Radiant Programmer to configure an iCE40 device, you must first create a new Programmer project, or open an existing Programmer project. By creating a new Programmer project, you create a chain file (.xcf).

To create a new Programmer project:

1. Make sure that the board is turned on and that the Lattice USB programming cable is properly connected to the computer.
2. Issue the start command.
   - In Windows, go to the Windows Start menu and choose All Programs > Lattice Radiant Software > Accessories > Radiant Programmer.
   - In Linux, from the $<install_path>/programmer/bin/lin64 directory, enter the following on a command line:
     ```bash```
     ./programmer
   ```bash```
3. In the Getting Started dialog box, enter a project name in the Project Name box.
4. Browse to the location where you wish your project to reside in the Project Location box.
5. Choose one of the following:
   - Create a new project from a scan. This option creates a new project from a scan.
If you have a board connected to your computer, you can click the Detect Cable button to detect the cable and port. Otherwise, you can manually select cable and port from the Cable and Port pulldown lists.

- **Create a New Blank Project** - This option creates a new blank Programmer project.
- Click **OK**.

6. In Programmer:
   - Select the iCE40 family in the Device Family drop-down menu.
   - Select the desired iCE40 device in the Device drop-down menu.

7. Choose **Edit > Device Properties**, or click the button on the toolbar, or right-click and choose **Device Properties**.

8. In the Device Properties dialog box:
   - In the Target Memory pulldown menu, choose **Compressed Random Access Memory (CRAM)**.
   - In the Port Interface pulldown menu, choose **Slave SPI**.
   - In the Access Mode pulldown menu, choose **Direct Programming**.
   - In the Operation pulldown menu, choose the desired operation, as described in the Device Properties dialog box.

9. In the Programming File box, browse to the Radiant software-generated programming file (.hex or .bin).

10. Click **OK** to close the Device Properties dialog box.

After you have specified all of the processing options, use the Program command to download the design file to the iCE40 device.

- In Programmer, choose **Run > Program**, or click on the toolbar.
The diagram below shows the iCE40 CRAM configuration flow

![Diagram showing the iCE40 CRAM configuration flow]

See Also

- “Programming and Configuring iCE40 Devices with Programmer” on page 380
- “Getting Started Dialog Box” on page 367
- “Device Properties Dialog Box” on page 367
- “Using the Radiant Programmer” on page 341
- TN1248 - iCE40 Programming and Configuration
- Lattice Radiant Software User Guide

Programming an iCE40 Device Using the NVCM Flow

iCE40 NVCM Programming Flow uses Nonvolatile Configuration Memory (.nvcm) files output from the Radiant software.

When using the Radiant Programmer to configure an iCE40 device, you must first create a new Programmer project, or open an existing Programmer project. By creating a new Programmer project, you create a chain file (.xcf).

To create a new Programmer project:

1. Make sure that the board is turned on and that the Lattice USB programming cable is properly connected to the computer.
2. Issue the start command.
   - In Windows, go to the Windows Start menu and choose All Programs > Lattice Radiant Software > Accessories > Radiant Programmer.
In Linux, from the `<install_path>/programmer/bin/lin64` directory, enter the following on a command line:

```bash
./programmer
```

3. In the Getting Started dialog box, enter a project name in the **Project Name** box.

4. Browse to the location where you wish your project to reside in the **Project Location** box.

5. Choose one of the following:

   - **Create a new project from a scan.** This option creates a new project from a scan.
     - If you have a board connected to your computer, you can click the **Detect Cable** button to detect the cable and port. Otherwise, you can manually select cable and port from the **Cable** and **Port** pulldown lists.
   - **Create a New Blank Project** - This option creates a new blank Radiant Programmer project.
   - Click **OK**.

6. In Programmer:

   - Select the iCE40 family in the Device Family drop-down menu.
   - Select the desired iCE40 device in the Device drop-down menu.

7. Choose **Edit > Device Properties**, or click the 🏷️ button on the toolbar, or right-click and choose **Device Properties**.

8. In the Device Properties dialog box:

   - In the Target Memory pulldown menu, choose **Non Volatile Configuration Memory (NVCM)**.
   - In the Port Interface pulldown menu, choose **Slave SPI**.
   - In the Access Mode pulldown menu, choose **Direct Programming**.
   - In the Operation pulldown menu, choose the desired operation, as described in the Device Properties dialog box.

9. In the Programming File box, browse to the Radiant software-generated NVCM programming file (.nvcm).

10. Click **OK** to close the Device Properties dialog box.

After you have specified all of the processing options, use the Program command to download the design file to the iCE40 device.

In Programmer, choose **Run > Program**, or click 🛠️ on the toolbar.
The diagram below shows the iCE40 NVCM programming flow

See Also
- “Programming and Configuring iCE40 Devices with Programmer” on page 380
- “Getting Started Dialog Box” on page 367
- “Device Properties Dialog Box” on page 367
- Using the Radiant Programmer
- Lattice Radiant Software User Guide
- TN1248 - iCE40 Programming and Configuration

Programming an iCE40 Device Using SPI Flash Device Flow

iCE40 SPI Flash Programming Flow involves using a separate SPI Flash device to configure an iCE40 device.

When using the Radiant Programmer to configure an iCE40 device, you must first create a new Programmer project, or open an existing Programmer project. By creating a new Programmer project, you create a chain file (.xcf).

To create a new Programmer project:
1. Make sure that the board is turned on and that the Lattice USB programming cable is properly connected to the computer.
2. Issue the start command.
   - In Windows, go to the Windows Start menu and choose All Programs > Lattice Radiant Software > Accessories > Radiant Programmer.
In Linux, from the `<install_path>/programmer/bin/lin64` directory, enter the following on a command line:

```
./programmer
```

3. In the Getting Started dialog box, enter a project name in the **Project Name** box.

4. Browse to the location where you wish your project to reside in the **Project Location** box.

5. Choose one of the following:
   - **Create a new project from a scan.** This option creates a new project from a scan.
     - If you have a board connected to your computer, you can click the **Detect Cable** button to detect the cable and port. Otherwise, you can manually select cable and port from the **Cable** and **Port** pulldown lists.
   - **Create a New Blank Project** - This option creates a new blank Radiant Programmer project.

**Note**

Because iCE40 devices are Slave SPI, and not JTAG, Programmer does not support the “Create a New Project from a Scan” option for iCE40 devices.

6. Click **OK**.

7. In Programmer:
   - Select the iCE40 family in the Device Family drop-down menu.
   - Select the desired iCE40 device in the Device drop-down menu.

8. Choose **Edit > Device Properties**, or click the button on the toolbar, or right-click and choose **Device Properties**.

9. In the Device Properties dialog box:
   - In the Target Memory pulldown menu, choose **External SPI Flash Memory (SPI FLASH)**.
   - In the Port Interface pulldown menu, choose **SPI**.
   - In the Access Mode pulldown menu, choose **Direct Programming**.
   - In the Operation pulldown menu, choose the desired operation, as described in Device Properties dialog box.

10. In the Programming File box, browse to the Radiant software-generated programming file (.hex or .bin).

11. In the Advanced Flash Options box, select **Family**, **Vendor**, **Device**, and **Package**.

12. Click **Load from File** to fill in the Data File Size box. You can change this size by typing a different file size. This feature is useful if you only want to use a portion of the file for the operation. If you change the file size, it must be no larger than the full file size or the device size.
13. Select start address and base address from **Start Address (Hex)** and **Base Address (Hex)** drop-down menus.

14. If you want to erase the flash device if a verify error occurs, click the **Erase SPI Part on Programming Error** box.

15. Click **OK**.

After you have specified all of the processing options, use the Program command to download the design file to the SPI Flash device.

In Programmer, choose **Run > Program**, or click on the toolbar. The diagram below shows the iCE40 SPI Flash programming flow.

---

**See Also**

- “Programming and Configuring iCE40 Devices with Programmer” on page 380
- “Adding a Custom SPI Flash Device” on page 360
- “Editing a Custom SPI Flash Device” on page 361
- “Removing a Custom SPI Flash Device” on page 362
- “Programming Using Custom SPI Flash Device” on page 362
- “Getting Started Dialog Box” on page 367
- “Device Properties Dialog Box” on page 367
- Using the Radiant Programmer
- Lattice Radiant Software User Guide
- TN1248 - iCE40 Programming and Configuration
Programming and Configuring LIFCL and LFD2NX Devices with Programmer

The Radiant Programmer supports programming and configuration of LIFCL and LFD2NX devices.

This section describes:

- “Reading the Feature Row (LIFCL and LFD2NX Only)” on page 391
- “Programming the Feature Row (LIFCL and LFD2NX Only)” on page 392
- “Programming the Password Key (LIFCL and LFD2NX Only)” on page 393
- “Programming the Encryption Key (LIFCL and LFD2NX Only)” on page 394
- “Programming the ECDSA Public Key (LIFCL and LFD2NX Only)” on page 395
- “Executing LIFCL and LFD2NX Dry Run Features” on page 396
- “Setting Lock Policies (LIFCL and LFD2NX)” on page 397
- “Setting External Configuration Ports Interfaces Locking Features (LIFCL and LFD2NX)” on page 399

The following tables describe the feature row that contains user-specified information necessary for device operations. For example, you can specify the device’s I2C slave address without using the default address from the factory.

Table 67: Feature Row Definition - Feature Bit

<table>
<thead>
<tr>
<th>Bit</th>
<th>Name</th>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>1:0</td>
<td>Authentication</td>
<td>00 - No Auth</td>
</tr>
<tr>
<td>2</td>
<td>Decompression Enable</td>
<td></td>
</tr>
<tr>
<td>4:3</td>
<td>Decryption Enable</td>
<td>00 - OFF</td>
</tr>
<tr>
<td></td>
<td></td>
<td>01 - Undefined</td>
</tr>
<tr>
<td></td>
<td></td>
<td>10 - ON</td>
</tr>
<tr>
<td></td>
<td></td>
<td>11 - OFF</td>
</tr>
<tr>
<td>5</td>
<td>CID_EN</td>
<td></td>
</tr>
<tr>
<td>8:6</td>
<td>Boot Select</td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>PWD_EN</td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>PWD_ALL</td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>I3C_ONLY</td>
<td>I3C Only / I2C Disable</td>
</tr>
<tr>
<td>12</td>
<td>SLV_ON</td>
<td>Slave port only when PROGN_EN set</td>
</tr>
<tr>
<td>13</td>
<td>PROGN_EN</td>
<td>Enable user IO on PROGN</td>
</tr>
</tbody>
</table>
### Table 67: Feature Row Definition - Feature Bit

<table>
<thead>
<tr>
<th>Bit</th>
<th>Name</th>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>14</td>
<td>INITN_EN</td>
<td>Enable user IO on INITN</td>
</tr>
<tr>
<td>15</td>
<td>DONE_en</td>
<td>Enable user IO on DONE</td>
</tr>
</tbody>
</table>

### Table 68: Feature Row Definition - Feature

<table>
<thead>
<tr>
<th>Bit</th>
<th>Name</th>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>3:0</td>
<td>I3C Device Character [3:0]</td>
<td></td>
</tr>
<tr>
<td>7:4</td>
<td>I3C Instance ID [3:0]</td>
<td>7:4</td>
</tr>
<tr>
<td>15:8</td>
<td>I3C Slave Address [7:0]</td>
<td>15:8</td>
</tr>
<tr>
<td>16</td>
<td>I3C_bit32</td>
<td>16</td>
</tr>
<tr>
<td>31:17</td>
<td>RESERVED</td>
<td>31:17</td>
</tr>
<tr>
<td>39:32</td>
<td>Unique ID MSB [7:0]</td>
<td>39:32</td>
</tr>
<tr>
<td>47:40</td>
<td>I2C Slave Address [7:0]</td>
<td>47:40</td>
</tr>
<tr>
<td>63:48</td>
<td>RESERVED</td>
<td>63:48</td>
</tr>
<tr>
<td>95:64</td>
<td>Custom ID Code [31:0]</td>
<td></td>
</tr>
</tbody>
</table>

### Table 69: Feature Row Definition - CR1

<table>
<thead>
<tr>
<th>Bit</th>
<th>Name</th>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>31:25</td>
<td>RESERVED</td>
<td>DPA enable for bitstream decryption.</td>
</tr>
<tr>
<td>24</td>
<td>DPA_EN</td>
<td>DPA enable for bitstream decryption.</td>
</tr>
<tr>
<td>23:18</td>
<td>RESERVED</td>
<td></td>
</tr>
<tr>
<td>17</td>
<td>32-bit SPIM address</td>
<td>Enable 32-bit MSPI addressing mode, default 24-bit addressing.</td>
</tr>
<tr>
<td>16</td>
<td>Bulk Erase Enable</td>
<td>Control bit to enable auto SRAM Bulk Erase for refresh or PROGRAMN pin toggle.</td>
</tr>
</tbody>
</table>
Table 69: Feature Row Definition - CR1

<table>
<thead>
<tr>
<th>Bit</th>
<th>Name</th>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>15</td>
<td>SFDP Enable</td>
<td>Enables checking the SFDP signature during master SPI booting. Should be enabled for flash devices that support SFDP.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>1-enable reading SFDP signature from flash SFDP header.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>0-enable reading LSCC signature from flash starting at address 0x000</td>
</tr>
<tr>
<td>14</td>
<td>32-bit SPIM commands</td>
<td>Send 32-bit command set on MSPI, default 24-bit command set.</td>
</tr>
<tr>
<td>13</td>
<td>Disable IO glitch filter</td>
<td>Disable IO Glitch Filter during config</td>
</tr>
<tr>
<td>12</td>
<td>cfg_noise</td>
<td>CFG can enable the HSE noise generation by setting this to 1. If set to 0, gen_con[1] controls the noise generation.</td>
</tr>
<tr>
<td>[7:5]</td>
<td>Master Preamble Timer count value</td>
<td>preamble_count: number of clock cycles to get a valid preamble.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>0 600000</td>
</tr>
<tr>
<td></td>
<td></td>
<td>1 400000</td>
</tr>
<tr>
<td></td>
<td></td>
<td>2 200000</td>
</tr>
<tr>
<td></td>
<td></td>
<td>3 400000</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4 200000</td>
</tr>
<tr>
<td></td>
<td></td>
<td>5 40000</td>
</tr>
<tr>
<td></td>
<td></td>
<td>6 20000</td>
</tr>
<tr>
<td></td>
<td></td>
<td>7 40000</td>
</tr>
<tr>
<td>4</td>
<td>signature_dis</td>
<td>If sfdp_en=0 do not read LSCC signature from flash, go directly to reading preamble.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>1=skip checking signature when sfdp_en=0, 0=signature enabled (default 0).</td>
</tr>
</tbody>
</table>
Table 69: Feature Row Definition - CR1

<table>
<thead>
<tr>
<th>Bit</th>
<th>Name</th>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>[3:2]</td>
<td>Master Preamble Timer retry value</td>
<td>Number of times the Master Preamble detection should be retried. 0-No retry  1-Retry 1 time  2-Retry 3 times  3-Retry forever</td>
</tr>
<tr>
<td>1</td>
<td>RESERVED</td>
<td></td>
</tr>
<tr>
<td>0</td>
<td>IO Ready Disable</td>
<td>When set to 1 disables waiting for IO ready.</td>
</tr>
</tbody>
</table>

Reading the Feature Row (LIFCL and LFD2NX Only)

You can read the contents of the feature row of LIFCL or LFD2NX, edit the settings, and program the new settings into the feature row of the device.

To read the feature row of an LIFCL or LFD2NX device:
1. In Programmer, select the device that you want to edit.
2. Choose Edit > Device Properties, or click the button on the toolbar, or right-click and choose Device Properties to display the Device Properties dialog box.
3. In the Target Memory drop-down menu, choose Non Volatile Configuration Memory.
4. In the Access Mode drop-down menu, choose Feature Row Programming.
5. In the Operation box, select Read Feature Row.
6. Click OK to close the Device Properties dialog box.
7. Choose Design > Program, or click on the toolbar.
   The Feature Row dialog box displays. The fields in the dialog box are not editable.
8. Click Close to close the Feature Row dialog box.

To read the non-volatile control register 1 of an LIFCL or LFD2NX device:
1. In Programmer, select the device that you want to edit.
2. Choose Edit > Device Properties, or click the button on the toolbar, or right-click and choose Device Properties to display the Device Properties dialog box.
3. In the Target Memory drop-down menu, choose **Non Volatile Configuration Memory**.

4. In the Access Mode drop-down menu, choose **Feature Row Programming**.

5. In the Operation box, select **Display Control NV Register1**.

6. Click **OK** to close the Device Properties dialog box.

7. Choose **Design > Program**, or click ![Program icon](image) on the toolbar.

   The non-volatile control register 1 dialog box displays. The fields in the dialog box are not editable.

8. Click **Close** to close the dialog box.

---

**Programming the Feature Row (LIFCL and LFD2NX Only)**

You can program the contents of a .fea file to the feature row of an LIFCL or LFD2NX device.

**To program the feature row of an LIFCL or LFD2NX device:**

1. In Programmer, select the device that you want to edit.

2. Choose **Edit > Device Properties**, or click the ![Device Properties icon](image) button on the toolbar, or right-click and choose **Device Properties** to display the Device Properties dialog box.

3. In the Target Memory drop-down menu, choose **Non Volatile Configuration Memory**.

4. In the Access Mode drop-down menu, choose **Feature Row Programming**.

5. In the Operation box, select **Program Feature Row**.

6. In the Feature Row Programming Options box, browse to the Feature Row (.fea) file.

7. Select the sector lock options and **Lock Read** access, **Lock Write** access, and/or **Lock Wishbone** access based on choice of security.

8. Click **OK** to close the Device Properties dialog box.

9. Choose **Design > Program**, or click ![Program icon](image) on the toolbar.

**To edit the feature row of an LIFCL or LFD2NX device:**

1. In Programmer, select the device that you want to edit.

2. Choose **Edit > Device Properties**, or click the ![Device Properties icon](image) button on the toolbar, or right-click and choose **Device Properties** to display the Device Properties dialog box.

3. In the Target Memory drop-down menu, choose **Non Volatile Configuration Memory**.
4. In the Access Mode drop-down menu, choose Feature Row Programming.

5. In the Operation box, select Update Feature Row.

6. Click OK to close the Device Properties dialog box.

7. Choose Design > Program, or click on the toolbar. The Feature Row dialog box displays.

8. Edit the fields in the dialog box as desired, then click Program. A dialog box asking if you wish to overwrite the selected register. If you click Yes, the LIFCL feature row is programed as edited.

To edit the Non-Volatile Control Register 1 of an LIFCL or LFD2NX device:

1. In Programmer, select the device that you want to edit.

2. Choose Edit > Device Properties, or click the button on the toolbar, or right-click and choose Device Properties to display the Device Properties dialog box.

3. In the Target Memory drop-down menu, choose Non Volatile Configuration Memory.

4. In the Access Mode drop-down menu, choose Feature Row Programming.

5. In the Operation box, select Program Control NV Register1.

6. Click OK to close the Device Properties dialog box.

7. Choose Design > Program, or click on the toolbar.

8. In the non-volatile Control Register 1 dialog box displays.

9. Edit the fields in the dialog box as desired, then click Program. A dialog box asking if you wish to overwrite the selected register. If you click Yes, the LIFCL device non-volatile Control Register 1 is programed as edited.

Programming the Password Key (LIFCL and LFD2NX Only)

You can program the password key from a .key file to the LIFCL or LFD2NX device.

To read the password key of an LIFCL or LFD2NX device:

1. In Programmer, select the device that you want to edit.

2. Choose Edit > Device Properties, or click the button on the toolbar, or right-click and choose Device Properties to display the Device Properties dialog box.

3. In the Target Memory drop-down menu, choose Non Volatile Configuration Memory.
4. In the Access Mode drop-down menu, choose **Advanced Security Keys Programming**.

5. In the Operation box, select **Read Password Key**, if the device is empty, you can read the all 0 password directly. If the device is programmed with password, you need to enable **Password Protection Options** and select the key file.

6. Click OK to close the Device Properties dialog box.

7. Choose **Design > Program**, or click on the toolbar.

---

**To program the password key to an LIFCL or LFD2NX device:**

1. In Programmer, select the device that you want to edit.

2. Choose **Edit > Device Properties**, or click the button on the toolbar, or right-click and choose **Device Properties** to display the Device Properties dialog box.

3. In the Target Memory drop-down menu, choose **Non Volatile Configuration Memory**.

4. In the Access Mode drop-down menu, choose **Advanced Security Keys Programming**.

5. In the Operation box, select **Program Password Key**.

6. In the Password Key Programming Options box, browse to the key (.key) file.

7. Select the sector lock options and Lock Read access, Lock Write access, and/or Lock Wishbone access based on choice of security.

8. Click **OK** to close the Device Properties dialog box.

9. Choose **Design > Program**, or click on the toolbar.

---

**Programming the Encryption Key (LIFCL and LFD2NX Only)**

You can program the encryption key from a .bek file to the LIFCL or LFD2NX device.

---

**To read the encryption key of an LIFCL or LFD2NX device:**

1. In Programmer, select the device that you want to edit.

2. Choose **Edit > Device Properties**, or click the button on the toolbar, or right-click and choose **Device Properties** to display the Device Properties dialog box.

3. In the Target Memory drop-down menu, choose **Non Volatile Configuration Memory**.

4. In the Access Mode drop-down menu, choose **Advanced Security Keys Programming**.

5. In the Operation box, select **Read Encryption Key**.
6. Click **OK** to close the Device Properties dialog box.
7. Choose **Design > Program**, or click on the toolbar.

**To program the encryption key to an LIFCL or LFD2NX device:**
1. In Programmer, select the device that you want to edit.
2. Choose **Edit > Device Properties**, or click the button on the toolbar, or right-click and choose **Device Properties** to display the Device Properties dialog box.
3. In the Target Memory drop-down menu, choose **Non Volatile Configuration Memory**.
4. In the Access Mode drop-down menu, choose **Advanced Security Keys Programming**.
5. In the Operation box, select **Program Encryption Key**.
6. In the Encryption Key Programming Options box, browse to the key (.bek) file.
7. If designed, select “Encrypted Bitstream Only” option, type “yes” to confirm.
8. Select the sector lock options and Lock Read access, Lock Write access, and/or Lock Wishbone access based on choice of security.
9. Click OK to close the Device Properties dialog box.
10. Choose **Design > Program**, or click on the toolbar.

**Programming the ECDSA Public Key (LIFCL and LFD2NX Only)**
You can program the public key from a .pub file to the LIFCL or LFD2NX device.

**To read the public key of an LIFCL or LFD2NX device:**
1. In Programmer, select the device that you want to edit.
2. Choose **Edit > Device Properties**, or click the button on the toolbar, or right-click and choose **Device Properties** to display the Device Properties dialog box.
3. In the Target Memory drop-down menu, choose **Non Volatile Configuration Memory**.
4. In the Access Mode drop-down menu, choose **Advanced Security Keys Programming**.
5. In the Operation box, select **Read Public Key**.
6. Click **OK** to close the Device Properties dialog box.
7. Choose **Design > Program**, or click on the toolbar.
To program the public key to an LIFCL or LFD2NX device:
1. In Programmer, select the device that you want to edit.
2. Choose Edit > Device Properties, or click the button on the toolbar, or right-click and choose Device Properties to display the Device Properties dialog box.
3. In the Target Memory drop-down menu, choose Non Volatile Configuration Memory.
5. In the Operation box, select Program Public Key.
6. In the Public Key Programming Options box, browse to the key (.pub) file.
7. Select the sector lock options and Lock Read access, Lock Write access, and/or Lock Wishbone access based on choice of security.
8. Click OK to close the Device Properties dialog box.
9. Choose Design > Program, or click on the toolbar.

Executing LIFCL and LFD2NX Dry Run Features
LIFCL or LFD2NX can trigger a dry run bitstream downloading from external flash through the master SPI port. “Dry run” means downloading the bitstream but without actually writing the configuration SRAM.

The following are done during the “dry run” process:
- Decrypting the Bitstream if it is encrypted
- Authentication with the Bitstream if it is required
- CRC check if it is enabled
- Execute command “ISC_PROGRAM_USERCODE” inside the bitstream and store the USERCODE to a special shadow register named “DRYRUN USERCODE”. The command does not override “SRAM USERCODE” or “Flash USERCODE”.

After the “dry run” finishes, it reports the execution status, such as execution pass/fail and authentication pass/fail. You can use the command “USERCODE_DRYRUN” to read the shadow register of “DRYRUN USERCODE.”

To execute a dry run from external SPI Flash Primary Image in Programmer:
1. In Programmer, select the device that you want to edit.
2. Choose Edit > Device Properties, or click the button on the toolbar, or right-click and choose Device Properties to display the Device Properties dialog box.
3. In the Access Mode drop-down menu, choose **Static RAM Cell Mode**.
4. In the Port Interface drop-down menu, choose the interface.
5. In the Operation box, select **SRAM External Primary Dry Run**.
6. Click **OK**.
7. Choose **Design > Program**, or click \( \text{️} \) on the toolbar.
   
   The USERCODE from the Primary image is displayed if the “Dry Run” executed successfully.

**To execute a dry run from external SPI Flash Golden Image in Programmer:**

1. In Programmer, select the device that you want to edit.
2. Choose **Edit > Device Properties**, or click the \( \text{️} \) button on the toolbar, or right-click and choose **Device Properties** to display the Device Properties dialog box.
3. In the Access Mode drop-down menu, choose **Static RAM Cell Mode**.
4. In the Port Interface drop-down menu, choose the interface.
5. In the Operation box, select **SRAM External Golden Dry Run**.
6. Click **OK**.
7. Choose **Design > Program**, or click \( \text{️} \) on the toolbar.
   
   The USERCODE from the Golden image is displayed if the “Dry Run” executed successfully.

**Setting Lock Policies (LIFCL and LFD2NX)**

LIFCL or LFD2NX provide read, program permission to access the FPGA configuration sectors. The security setup can be applied inside each individual sector to store security setting bits.

The sectors include:

- SRAM
- Feature Row sector
- Password Key sector
- Public Key sector
- Encryption Key sector

The centralized security settings can be applied to store central security setting bits for all of the FPGA configuration sectors. The detailed explanation of each central security bit is given as follows:
Read Security Lock  Inside dedicated security policy sector. This bit provides Read Protection for a particular sector.

Erase Security Lock  Stops erase activity to the SRAM sector. This bit prevents accidental erasure of user set-up.

Write Security Lock  Inside dedicated security policy sector. This bit provides Write Protection for a particular sector.

To read the locks policies of an LIFCL or LFD2NX device:
1. In Programmer, select the device that you want to edit.
2. Choose Edit > Device Properties, or click the button on the toolbar, or right-click and choose Device Properties to display the Device Properties dialog box.
3. In the Target Memory drop-down menu, choose Non Volatile Configuration Memory.
4. In the Port Interface drop-down menu, choose JTAG Interface.
6. In the Operation box, select Read Locks Policies.
7. Click OK to close the Device Properties dialog box.
8. Choose Design > Program, or click on the toolbar.

To program the locks policies in Programmer:
1. In Programmer, select the device that you want to edit.
2. Choose Edit > Device Properties, or click the button on the toolbar, or right-click and choose Device Properties to display the Device Properties dialog box.
3. In the Target Memory drop-down menu, choose Non Volatile Configuration Memory.
4. In the Port Interface drop-down menu, choose JTAG Interface.
6. In the Operation box, select Program Locks Policies.
7. Select the sector Lock Wishbone Access based on choice of security.
8. Click OK.
Setting External Configuration Ports
Interfaces Locking Features (LIFCL and LFD2NX)

LIFCL or LFD2NX have Write access permission control for external CFG ports and an internal system bus to access the FPGA configuration sectors. External CFG ports include JTAG, slave SPI and slave I2C.

To setup the Ports interfaces security lock policy in Programmer:
1. In Programmer, select the device that you want to edit.
2. Choose Edit > Device Properties, or click the button on the toolbar, or right-click and choose Device Properties to display the Device Properties dialog box.
3. In the Target Memory drop-down menu, choose Non Volatile Configuration Memory.
4. In the Port Interface drop-down menu, choose JTAG Interface.
6. In the Operation box, select Lock Ports Interface.
7. Select Lock Ports Access and/or Lock System Bus Access based on desired choices of security.
8. Click OK.
Deploying the Design with the Deployment Tool

The Radiant software Deployment Tool allows you to generate files for deployment for single devices, a chain of devices, and can also convert data files to other formats and use the data files it produces to generate other data file formats.

Deployment Tool is a stand-alone tool available from the Radiant software Accessories. The Deployment Tool graphical user interface (GUI) is separate from the Radiant software design environment.

A four-step wizard allows you to select deployment type, input file type, and output file type.

See Also

- “Deployment Function Types” on page 400
- “iCE40 Warm Boot/Cold Boot Bitstream Output Options” on page 422
- “Input File Descriptions” on page 423
- “Input File Formats” on page 424
- “Bitstream Output File Descriptions” on page 425
- “Bitstream Output Formats” on page 425
- “SVF, and STAPL Output Formats” on page 426
- “Output Options Descriptions” on page 426
- “Creating a New Deployment” on page 427
- “Opening an Existing Deployment” on page 428
- “Opening an Existing Deployment While Running the Deployment Tool” on page 429
- “Creating a New Deployment While Running the Deployment Tool” on page 430
- “Using Quick Launch Button to Create a New Deployment” on page 430
- “Viewing the Deployment Tool Log File” on page 431
- “Changing the Deployment Tool Log File Settings” on page 432

Deployment Function Types

This section provides tables that list device family, input file types, output file extensions, and options for each available deployment function type.

Click on the list items below to jump to topics that contain lists of device family, input file types, output file type/extensions, and options for each deployment function type.

- “File Conversion Deployment Function Type” on page 401
- “Tester Deployment Function Type” on page 402
File Conversion Deployment Function Type
Not supported for iCE40UP devices.

This topic provides tables that list device family, input file types, output file extensions, and options for File Conversion deployment function type:

<table>
<thead>
<tr>
<th>Table 70: Bitstream—Device Family, Input File 1, Format, and Output File</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Device Family</strong></td>
</tr>
<tr>
<td>-------------------</td>
</tr>
<tr>
<td>LIFCL</td>
</tr>
<tr>
<td>LFD2NX</td>
</tr>
<tr>
<td>LIFCL ES</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Table 71: Bitstream—Options—Encryption</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Device Family</strong></td>
</tr>
<tr>
<td>-------------------</td>
</tr>
<tr>
<td>LIFCL</td>
</tr>
<tr>
<td>LFD2NX</td>
</tr>
<tr>
<td>LIFCL ES</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Table 72: Bitstream—Options—Authentication</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Device Family</strong></td>
</tr>
<tr>
<td>-------------------</td>
</tr>
<tr>
<td>LIFCL</td>
</tr>
<tr>
<td>LFD2NX</td>
</tr>
<tr>
<td></td>
</tr>
</tbody>
</table>
Tester Deployment Function Type

Not supported for iCE40UP devices.

This topic provides tables that list device family, input file types, output file extensions, and options for Tester deployment function type:

- SVF Single Device
- “SVF JTAG Chain” on page 403
- “STAPL Single Device” on page 405
- “STAPL JTAG Chain” on page 405
**Table 75: SVF Single Device**

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Input File 1</th>
<th>Output File</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lattice Single Device</td>
<td>Bitstream (.bit, .rbt)</td>
<td>SVF file (.svf)</td>
</tr>
</tbody>
</table>

**Table 76: SVF Single Device—Options—Operation**

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Operation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lattice Single Device</td>
<td>Device-dependent list</td>
</tr>
</tbody>
</table>

**Table 77: SVF Single Device—Options—Write Header and Comments, Write Rev D Standard SVF File**

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Write Header and Comments</th>
<th>Write Rev D Standard SVF File</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>On (Default)</td>
<td>Off (Default)</td>
</tr>
<tr>
<td>Lattice Single Device</td>
<td>Write headers and comments.</td>
<td>Omit headers and comments.</td>
</tr>
<tr>
<td></td>
<td>Rev. E Standard SVF. Rev. D Standard SVF. For Flash-based FPGAs, Lattice Extended SVF.</td>
<td></td>
</tr>
</tbody>
</table>

**Table 78: SVF Single Device—Options—Use RUNTEST from Rev C; For Erase, Program, and Verify Operations, Skip Verify**

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Use RUNTEST from Rev C</th>
<th>For Erase, Program, and Verify Operations, Skip Verify</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Off (Default)</td>
<td>On</td>
</tr>
</tbody>
</table>

**Table 79: SVF Single Device—Options—Include RESET at the End of the SVF File; Set Maximum Data Size per Row (Kbits)**

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Include RESET at the End of the SVF File</th>
<th>Set Maximum Data Size per Row (Kbits)</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Off (Default)</td>
<td>On</td>
</tr>
<tr>
<td>Lattice Single Device</td>
<td>Do not write RESET at the end of the SVF file.</td>
<td>Write RESET at the end of the SVF file. 8, 16, 32, 64, 128, 256</td>
</tr>
</tbody>
</table>

**Table 80: SVF JTAG Chain**

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Input File 1</th>
<th>Output File</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lattice Chain</td>
<td>XCF file (.xcf)</td>
<td>SVF file (.svf)</td>
</tr>
</tbody>
</table>
Table 81: SVF JTAG Chain—Options—Operation

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Operation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lattice Single Device</td>
<td>Contained in XCF file.</td>
</tr>
</tbody>
</table>

Table 82: SVF JTAG Chain—Options—Write Header and Comments, Write Rev D Standard SVF File

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Write Header and Comments</th>
<th>Write Rev D Standard SVF File</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lattice Single Device</td>
<td>Write headers and comments.</td>
<td>Omit headers and comments.</td>
</tr>
<tr>
<td>On (Default)</td>
<td>Off</td>
<td>Off (Default)</td>
</tr>
</tbody>
</table>

For Flash-based FPGAs, Lattice Extended SVF.

Table 83: SVF JTAG Chain—Options—Use RUNTEST from Rev C; For Erase, Program, and Verify Operations, Skip Verify

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Use RUNTEST from Rev C</th>
<th>For Erase, Program, and Verify Operations, Skip Verify</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lattice Single Device</td>
<td>Standard RUNTEST.</td>
<td>Rev. C RUNTEST.</td>
</tr>
<tr>
<td>Off (Default)</td>
<td>On</td>
<td>Off (Default) On</td>
</tr>
</tbody>
</table>

Include verify in EPV operations. Omit verify in EPV operations.

Table 84: SVF JTAG Chain—Options—Include RESET at the End of the SVF File; Set Maximum Data Size per Row (Kbits)

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Include RESET at the End of the SVF File</th>
<th>Set Maximum Data Size per Row (Kbits)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lattice Single Device</td>
<td>Do not write RESET at the end of the SVF file.</td>
<td>Write RESET at the end of the SVF file.</td>
</tr>
<tr>
<td>Off (Default)</td>
<td>On</td>
<td>Off (Default) On</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

8, 16, 32, 64, 128, 256
### Table 85: STAPL Single Device

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Input File 1</th>
<th>Output File</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lattice Single Device</td>
<td>Bitstream (.bit, .rbt)</td>
<td>STAPL file (.stp)</td>
</tr>
</tbody>
</table>

### Table 86: STAPL Single Device—Options—ACA Compression; Include Print Statements; For Erase, Program, and Verify Operations, Skip Verify

<table>
<thead>
<tr>
<th>Device Family</th>
<th>ACA Compression</th>
<th>Include Print Statements</th>
<th>For Erase, Program, and Verify Operations, Skip Verify</th>
</tr>
</thead>
<tbody>
<tr>
<td>Off (Default)</td>
<td>Off</td>
<td>On</td>
<td>On</td>
</tr>
<tr>
<td>Lattice Single Device</td>
<td>Compress data.</td>
<td>Uncompress data.</td>
<td>Print statements as comments.</td>
</tr>
</tbody>
</table>

### Table 87: STAPL JTAG Chain

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Input File 1</th>
<th>Output File</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lattice Chain</td>
<td>XCF file (.xcf)</td>
<td>STAPL file (.stp)</td>
</tr>
</tbody>
</table>

### Table 88: STAPL JTAG Chain—Options—ACA Compression; Include Print Statements; For Erase, Program, and Verify Operations, Skip Verify

<table>
<thead>
<tr>
<th>Device Family</th>
<th>ACA Compression</th>
<th>Include Print Statements</th>
<th>For Erase, Program, and Verify Operations, Skip Verify</th>
</tr>
</thead>
<tbody>
<tr>
<td>Off (Default)</td>
<td>Off</td>
<td>On</td>
<td>On</td>
</tr>
<tr>
<td>Lattice Chain</td>
<td>Compress data.</td>
<td>Uncompress data.</td>
<td>Print statements as comments.</td>
</tr>
</tbody>
</table>
Embedded System Deployment Function Type

This topic provides tables that list device family, input file types, output file extensions, and options for Embedded System deployment function type.

Table 89: JTAG Full VME Embedded -- Device Family, Input XCF File, and Output File

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Input XCF File</th>
<th>Output File</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIFCL</td>
<td>XCF File (.xcf) - Programmer Project file. XCF files can be used to save the setup of a Programmer Project. XCF files can either be loaded back into Programmer to work on a previous project or loaded into deployment tool for file conversions, generate a tester file, generate an embedded system file, or generate an external memory file.</td>
<td>VME File (.vme)</td>
</tr>
<tr>
<td>LFD2NX</td>
<td></td>
<td></td>
</tr>
<tr>
<td>LIFCL ES</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

The following table lists options -- Compress VME File, Convert VME Files to HEX (c.) File-Based Embedded VME -- for JTAG Full VME embedded deployment.

Table 90: JTAG Full VME Embedded Options -- Compress VME File, Convert VME Files to HEX (c.) File-Based Embedded VME

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Compress VME</th>
<th>Convert VME Files to HEX (c.) File-Based Embedded VME</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIFCL</td>
<td>On (Default)</td>
<td>Off (Default)</td>
</tr>
<tr>
<td>LFD2NX</td>
<td>Off</td>
<td>On</td>
</tr>
<tr>
<td>LIFCL ES</td>
<td>Compress data. This option reduces the file size of the VME file through compression, using less memory space. Unchecking this option generates an uncompressed VME, which is useful for debugging. Compressed and uncompressed VME have the same level of performance.</td>
<td>By default this operation is turned off, this will create a VME file that will be used in file based embedded programming where the programming of the device is based on the input file. When this option is turned on then it will create a .c file which will be used in EPROM base programming to create a single compiled image that will be loaded in to the CPU. An then the CPU will use this image to then program the device.</td>
</tr>
</tbody>
</table>
The following table lists options -- Compact VME File, Fixed Pulse Width (Rev. D) -- for JTAG Full VME embedded deployment.

### Table 91: JTAG Full VME Embedded Options -- Compact VME File, Fixed Pulse Width (Rev. D)

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Compact VME File</th>
<th>Fixed Pulse Width (Rev. D)</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIFCL</td>
<td>Off (Default)</td>
<td>On</td>
</tr>
<tr>
<td>LFD2NX</td>
<td>By default this operation is turned off. When this option is turned on it will split the VME data file into two different sections. An algorithm section and a data section. Whenever there is data needed in the algorithm section it will get it from the data section. This option is useful to turn on when the VME file is repeating the same operation even with different data. The operation will be in a loop and will reference the data section. This option will reduce the file size of the VME file.</td>
<td>Off (Default)</td>
</tr>
<tr>
<td>LIFCL ES</td>
<td>Compact VME file.</td>
<td>By default this setting is off enabling looping (status polling algorithm) in the VME file. When it is turned on then there will be no looping (status polling algorithm) and instead commands in loops will be repeated for as many times as the loop iterated for. Status polling algorithm is a Lattice specific command in VME files, turning this option on makes the VME file generic and is useful when programming through a non-Lattice device, but increases file size.</td>
</tr>
</tbody>
</table>

The following table lists options -- Verify USERCODE, Program Device if Fails -- for JTAG Full VME embedded deployment.

### Table 92: JTAG Full VME Embedded Options -- Verify USERCODE, Program Device if Fails

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Verify USERCODE, Program Device if Fails</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIFCL</td>
<td>Off (Default)</td>
</tr>
<tr>
<td>LFD2NX</td>
<td>By default this operation is turn off and preforms the standard erase, program, verify flow. When this option is turned on then before attempting to program a device it will check to see if the USERCODE of the device is the same as the file to be programmed. If the USERCODEs are the same then that device will be skipped and will not be reprogrammed, otherwise if the USERCODEs do not match then the device will be programmed.</td>
</tr>
<tr>
<td>LIFCL ES</td>
<td></td>
</tr>
</tbody>
</table>
The following table lists options -- Maximum Memory Allocation Size Per Row of Data (Kbytes) -- for JTAG Full VME embedded deployment.

Table 93: JTAG Full VME Embedded Options -- Include Header, Include Comment, Maximum Memory Allocation Size Per Row of Data (Kbytes)

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Include Header</th>
<th>Include Comment</th>
<th>Maximum Memory Allocation Size Per Row of Data (Kbytes)</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIFCL</td>
<td>Off (Default)</td>
<td>On</td>
<td>Set the Maximum buffer size. By default this size of the buffer is 64k, but if a system has a limitation on the max buffer size only being 16k then this option can be set to 16k to compensate for that limitation. Or if the system can support buffers of more than 64k than the setting can be increase to 128k or 256k. Valid values for this operation are 8, 16, 32, 64, 128, 256.</td>
</tr>
<tr>
<td>LFD2NX</td>
<td>By default the header is included in the VME file, otherwise the header file is omitted from the VME file. The header contains information on the version and is useful in debugging. Turning the header off can be used to reduce the file size of the VME file.</td>
<td>Omit header from VME file</td>
<td></td>
</tr>
<tr>
<td>LIFCL ES</td>
<td>The default is off which does not include comments in the VME file, if turned on then comments will appear for the operations. Turning comments on is useful for debugging the VME file, but will increase file size.</td>
<td>Include comments in VME file</td>
<td></td>
</tr>
</tbody>
</table>

The following table lists device family, input file types, and output file extensions for JTAG Slim VME embedded deployment.

Table 94: JTAG Slim VME Embedded -- Device Family, Input File 1, Output File 1, and Output File 2

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Input File</th>
<th>Output File 1</th>
<th>Output File 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIFCL</td>
<td>XCF File (*.xcf)</td>
<td>Algorithm VME File (*.algo.vme) - This is the algorithm file that specifies which operations will be executed must be used with a VME data file. This file is used in device programming or in field upgrading.</td>
<td>Data VME File (*.data.vme) - This is the data file that provides the data that the algorithm file will use to preforms executed operations must be used with a VME algorithm file. This file is used in device programming or in field upgrading.</td>
</tr>
<tr>
<td>LFD2NX</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>LIFCL ES</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Deploying the Design with the Deployment Tool

The following table lists options -- Compressed Embedded Files, convert VME files to HEX (c.) File-Based Embedded VME -- for JTAG Slim VME embedded deployment.

Table 95: JTAG Slim VME Embedded Options -- Compressed VME Data File, Convert VME files to HEX (c.) File-Based Embedded VME

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Compress VME Data File</th>
<th>Convert VME files to HEX (c.) File-Based Embedded VME</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIFCL</td>
<td>On (Default)</td>
<td>Off</td>
</tr>
<tr>
<td>LFD2NX</td>
<td></td>
<td>Off (Default)</td>
</tr>
<tr>
<td>LIFCL ES</td>
<td>Compress data. This option reduces the file size of the VME file through compression, using less memory space. Unchecking this option generates an uncompressed VME, which is useful for debugging. Compressed and uncompressed VME have the same level of performance.</td>
<td>Do not compress. By default this operation is turned off, this will create a VME file that will be used in file based embedded programming where the programming of the device is based on the input file. When this option is turned on then it will create a .c file which will be used in EPROM base programming to create a single complied image that will be loaded into the CPU. An then the CPU will use this image to then program the device.</td>
</tr>
</tbody>
</table>

The following table lists device family, input file types, and output file extensions for Slave SPI embedded deployment.

Table 96: Slave SPI Embedded -- Device Family, Input File 1, Output File 1, and Output File 2

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Input File</th>
<th>Output File 1</th>
<th>Output File 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIFCL</td>
<td>XCF File (.xcf)</td>
<td>Algorithm VME File (*.algo.vme)</td>
<td>Data File (*.data.sed)</td>
</tr>
<tr>
<td>LFD2NX</td>
<td>Bitstream (.bit)</td>
<td>This is the algorithm file that specifies which operations will be executed must be used with a</td>
<td></td>
</tr>
<tr>
<td>LIFCL ES</td>
<td>XCF File (.xcf)</td>
<td>VME data file. This file is used in device programming or in field upgrading.</td>
<td></td>
</tr>
<tr>
<td>iCE40</td>
<td>NVCM (.nvcm)</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
The following table lists options -- Compress Embedded Files, Convert VME files to HEX (.c) File-Based Embedded VME -- for Slave SPI embedded deployment.

Table 97: Slave SPI Embedded Options -- Compress Embedded Files, Convert VME files to HEX (.c) File-Based Embedded VME

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Device Family</th>
<th>Convert VME files to HEX (.c) File-Based Embedded VME</th>
<th>Generate Hex (.c) File</th>
<th>Operation (.xcf and .jed files only)</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIFCL</td>
<td>On (Default)</td>
<td>Off</td>
<td>On (Default)</td>
<td>The list of options and operation is dependent on which device is selected.</td>
</tr>
<tr>
<td>LFD2NX</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>LIFCL ES</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Compress data. This option reduces the file size of the VME file through compression, using less memory space. Unchecking this option generates an uncompressed VME, which is useful for debugging. Compressed and uncompressed VME have the same level of performance.

By default this operation is turned off, this will create a VME file that will be used in file based embedded programming where the programming of the device is based on the input file. When this option is turned on then it will create a .c file which will be used in EPROM base programming to create a single compiled image that will be loaded into the CPU. An then the CPU will use this image to then program the device.

The following table lists device family, input file types, and output file extensions for I2C embedded deployment.

Table 98: I2C Embedded -- Device Family, Input File 1, Output File 1, and Output File 2

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Input File</th>
<th>Output File 1</th>
<th>Output File 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIFCL</td>
<td>XCF File (.xcf)</td>
<td>Algorithm File (*.algo.sea)</td>
<td>Data File (*.data.sed)</td>
</tr>
<tr>
<td>LFD2NX</td>
<td>Bitstream (.bit)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>LIFCL ES</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
The following table lists options -- Compress Embedded Files, Convert VME files to HEX (c.) File-Based Embedded VME, Operation (.xcf and .jed files only), I2C Slave Address -- for I2C embedded deployment.

### Table 99: I2C Embedded Options -- Compress Embedded Files, Convert VME files to HEX (c.) File-Based Embedded VME, Operation (.xcf and .jed files only), I2C Slave Address

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Compressed Embedded Files</th>
<th>Convert VME files to HEX (c.) File-Based Embedded VME</th>
<th>Operation (.jed files only)</th>
<th>I2C Slave Address</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIFCL</td>
<td>On (Default)</td>
<td>Off (Default)</td>
<td>On</td>
<td>The list of options and operation is dependent on which device is selected.</td>
</tr>
<tr>
<td>LFD2NX</td>
<td>Compress embedded files.</td>
<td>Do not compress.</td>
<td>Generate Hex (.c) file.</td>
<td>Used to set the I2C Slave address. By default the value is 0b100000. The user can modify this value if the value of the I2C Slave Address if there project calls for it.</td>
</tr>
<tr>
<td>LIFCL ES</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
The following table lists options -- Include Comments for I2C embedded deployment.

**Table 100: I2C Embedded Options -- Include Comments**

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Include Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIFCL</td>
<td>Off (Default)</td>
</tr>
<tr>
<td>LFD2NX</td>
<td></td>
</tr>
<tr>
<td>LIFCL ES</td>
<td></td>
</tr>
</tbody>
</table>

- The default is off which does not include comments in the VME file, if turned on then comments will appear for the operations. Turning comments on is useful for debugging the VME file, but will increase file size.

The following table lists options -- Fixed Pulse Width for I2C embedded deployment.

**Table 101: I2C Embedded Options -- Fixed Pulse Width**

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Include Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIFCL</td>
<td>Off (Default)</td>
</tr>
<tr>
<td>LFD2NX</td>
<td></td>
</tr>
<tr>
<td>LIFCL ES</td>
<td></td>
</tr>
</tbody>
</table>

- By default this setting is off enabling looping (status polling algorithm) in the VME file. When it is turned on then there will be no looping (status polling algorithm) and instead commands in loops will be repeated for as many times as the loop iterated for. Status polling algorithm is a Lattice specific command in VME files, turning this option on makes the VME file generic and is useful when programming through a non-Lattice device, but increases file size.
External Memory Deployment Type
This topic provides tables that list device family, input file types, output file extensions, and options for File Conversion deployment function type:

- Hex Conversion
- “Dual Boot” on page 415
- “Ping-Pong Boot” on page 417
- “Advanced SPI Flash - iCE40” on page 419
- “sysCONFIG Daisy Chain” on page 422

<table>
<thead>
<tr>
<th>Table 102: Hex Conversion</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Device Family</strong></td>
</tr>
<tr>
<td>---------------------</td>
</tr>
<tr>
<td>iCE40</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>LIFCL</td>
</tr>
<tr>
<td>LFD2NX</td>
</tr>
<tr>
<td>LIFCL ES</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Table 103: Hex Conversion Options—Program Security Bit</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Device Family</strong></td>
</tr>
<tr>
<td>-------------------</td>
</tr>
<tr>
<td>LIFCL</td>
</tr>
<tr>
<td>LFD2NX</td>
</tr>
<tr>
<td>LIFCL ES</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Table 104: Hex Conversion Options—Encryption</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Device Family</strong></td>
</tr>
<tr>
<td>-------------------</td>
</tr>
<tr>
<td>LIFCL</td>
</tr>
<tr>
<td>LFD2NX</td>
</tr>
<tr>
<td>LIFCL ES</td>
</tr>
</tbody>
</table>
**Table 105: Hex Conversion Options—Authentication**

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Encryption</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIFCL</td>
<td><strong>Authentication</strong></td>
</tr>
<tr>
<td>LFD2NX</td>
<td></td>
</tr>
<tr>
<td>LIFCL ES</td>
<td>Public Key and Private Key Signature</td>
</tr>
<tr>
<td></td>
<td>Load from GUI and load Public Key (.pub) file and Private File (.prv).</td>
</tr>
</tbody>
</table>

**Table 106: Hex Conversion Options—Verify ID Code, Frequency, Compression**

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Verify ID Code</th>
<th>Frequency</th>
<th>Compression</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIFCL</td>
<td>Default (Default)</td>
<td>On</td>
<td>Off</td>
</tr>
<tr>
<td>LFD2NX</td>
<td>Include verify ID in bitstream.</td>
<td>Do not verify ID code.</td>
<td>Use setting from input file.</td>
</tr>
<tr>
<td>LIFCL ES</td>
<td>Use setting from input file.</td>
<td>Use Valid frequency device-dependent.</td>
<td>Use setting from input file.</td>
</tr>
<tr>
<td></td>
<td>Compress bitstream data.</td>
<td>Valid frequency device-dependent.</td>
<td>Do not compress.</td>
</tr>
</tbody>
</table>

**Table 107: Hex Conversion Options—CRC Calculation**

<table>
<thead>
<tr>
<th>Device Family</th>
<th>CRC Calculation</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIFCL</td>
<td>Use setting from input file.</td>
</tr>
<tr>
<td>LFD2NX</td>
<td>Include CRC for each data frame.</td>
</tr>
<tr>
<td>LIFCL ES</td>
<td>Include Global CRC only.</td>
</tr>
</tbody>
</table>

**Table 108: Hex Conversion Options—Byte Wide Mirror**

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Off (Default)</th>
<th>On</th>
</tr>
</thead>
<tbody>
<tr>
<td>iCE40</td>
<td>No change to bit order.</td>
<td>No change to bit order.</td>
</tr>
<tr>
<td>LIFCL</td>
<td>No change to bit order.</td>
<td>No change to bit order.</td>
</tr>
<tr>
<td>LFD2NX</td>
<td>No change to bit order.</td>
<td>No change to bit order.</td>
</tr>
<tr>
<td>LIFCL ES</td>
<td>No change to bit order.</td>
<td>No change to bit order.</td>
</tr>
</tbody>
</table>
### Table 109: Hex Conversion Options—Retain Bitstream Header

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Off (Default)</th>
<th>On</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIFCL</td>
<td></td>
<td>Replace Bitstream Header.</td>
</tr>
<tr>
<td>LFD2NX</td>
<td></td>
<td>Retain Bitstream Header.</td>
</tr>
<tr>
<td>LIFCL ES</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

### Table 110: Hex Conversion Options—Starting Address

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Starting Address</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIFCL</td>
<td>Off (Default)</td>
</tr>
<tr>
<td>LFD2NX</td>
<td>Starting Address</td>
</tr>
<tr>
<td>LIFCL ES</td>
<td>No address offset.</td>
</tr>
<tr>
<td></td>
<td>Starting address in 0x010000 increments.</td>
</tr>
</tbody>
</table>

### Table 111: Dual Boot

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Golden Pattern Input File 1</th>
<th>Primary Pattern Input File 2</th>
<th>Format</th>
<th>Output File</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIFCL</td>
<td>Bitstream (.bit, .rbl)</td>
<td>Bitstream (.bit, .rbl)</td>
<td>Intel Hex</td>
<td>Hex (.mcs)</td>
</tr>
<tr>
<td>LFD2NX</td>
<td></td>
<td></td>
<td>Motorola Hex</td>
<td>Hex (.exo)</td>
</tr>
<tr>
<td>LIFCL ES</td>
<td></td>
<td></td>
<td>Extended Tektronix Hex</td>
<td>Hex (.xtek)</td>
</tr>
</tbody>
</table>

### Table 112: Dual Boot Options—SPI Flash Size

<table>
<thead>
<tr>
<th>Device Family</th>
<th>SPI Flash Size</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIFCL</td>
<td>1/2/4/8/16/32/64/128/256/513 (512 Mb)</td>
</tr>
<tr>
<td>LFD2NX</td>
<td></td>
</tr>
<tr>
<td>LIFCL ES</td>
<td></td>
</tr>
</tbody>
</table>
Table 113: Dual Boot Options—Protect Golden Sector

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Protect Golden Sector</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIFCL</td>
<td>Off (Default)</td>
</tr>
<tr>
<td>LFD2NX</td>
<td>On</td>
</tr>
<tr>
<td>LIFCL ES</td>
<td>Locate golden in next available sector.</td>
</tr>
<tr>
<td></td>
<td>Locate Golden at the beginning of the upper half.</td>
</tr>
</tbody>
</table>

Table 114: Dual Boot Options—Byte Wide Mirror and Retain Bitstream Header

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Byte Wide Mirror</th>
<th>Retain Bitstream Header</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIFCL</td>
<td>Off (Default)</td>
<td>On</td>
</tr>
<tr>
<td>LFD2NX</td>
<td>On</td>
<td>Off (Default)</td>
</tr>
<tr>
<td>LIFCL ES</td>
<td>No change to bit order.</td>
<td>Flip each byte of data.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Replace Bitstream Header.</td>
</tr>
</tbody>
</table>

Table 115: Dual Boot Options—SPI Flash Read Mode

<table>
<thead>
<tr>
<th>Device Family</th>
<th>SPI Flash Mode</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIFCL</td>
<td>Off (Default)</td>
</tr>
<tr>
<td>LFD2NX</td>
<td>Fast Read</td>
</tr>
<tr>
<td>LIFCL ES</td>
<td>Dual I/O</td>
</tr>
<tr>
<td></td>
<td>Quad I/O</td>
</tr>
<tr>
<td></td>
<td>Standard Read Opcode</td>
</tr>
<tr>
<td></td>
<td>Fast Read Opcode</td>
</tr>
<tr>
<td></td>
<td>Dual I/O Read Opcode</td>
</tr>
<tr>
<td></td>
<td>Quad I/O Read Opcode</td>
</tr>
</tbody>
</table>

Table 116: Dual Boot Options—Optimize Memory Space

<table>
<thead>
<tr>
<th>Device Family</th>
<th>SPI Flash Mode</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIFCL</td>
<td>Off (Default)</td>
</tr>
<tr>
<td>LFD2NX</td>
<td>On</td>
</tr>
<tr>
<td>LIFCL ES</td>
<td>Use worst case bitstream size.</td>
</tr>
<tr>
<td></td>
<td>Use file size.</td>
</tr>
</tbody>
</table>
## Table 117: Dual Boot Options—Encryption

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Off (Default)</th>
<th>On</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIFCL</td>
<td>Normal bitstream</td>
<td>Primary encrypted bitstream</td>
</tr>
<tr>
<td>LFD2NX</td>
<td></td>
<td></td>
</tr>
<tr>
<td>LIFCL ES</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

## Table 118: Dual Boot Options—Authentication

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Encryption</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIFCL</td>
<td>Authentication</td>
</tr>
<tr>
<td>LFD2NX</td>
<td>Public Key and Private Key Signature</td>
</tr>
<tr>
<td></td>
<td>Load from GUI and load Public Key (.pub) file and Private File (.prv).</td>
</tr>
</tbody>
</table>

## Table 119: Ping-Pong Boot

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Golden Pattern Input File 1</th>
<th>Primary Pattern Input File 2</th>
<th>Format</th>
<th>Output File</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIFCL</td>
<td>Bitstream (.bit, .rbt)</td>
<td>Bitstream (.bit, .rbt)</td>
<td>Intel Hex</td>
<td>Hex (.mcs)</td>
</tr>
<tr>
<td>LFD2NX</td>
<td></td>
<td></td>
<td>Motorola Hex</td>
<td>Hex (.exo)</td>
</tr>
<tr>
<td>LIFCL ES</td>
<td></td>
<td></td>
<td>Extended Tektronix Hex</td>
<td>Hex (.xtek)</td>
</tr>
</tbody>
</table>

## Table 120: Ping-Pong Boot Options—SPI Flash Size

<table>
<thead>
<tr>
<th>Device Family</th>
<th>SPI Flash Size</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIFCL</td>
<td>1/2/4/8/16/32/64/128/256/513 (512 Mb)</td>
</tr>
<tr>
<td>LFD2NX</td>
<td></td>
</tr>
<tr>
<td>LIFCL ES</td>
<td></td>
</tr>
</tbody>
</table>
### Table 121: Ping-Pong Boot Options—Generate Jump Table Only

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Protect Golden Sector</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIFCL</td>
<td>Off (Default)</td>
</tr>
<tr>
<td>LFD2NX</td>
<td>On</td>
</tr>
<tr>
<td>LIFCL ES</td>
<td>Full images</td>
</tr>
<tr>
<td></td>
<td>Jump table only</td>
</tr>
</tbody>
</table>

### Table 122: Ping-Pong Boot Options—Byte Wide Mirror and Retain Bitstream Header

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Byte Wide Mirror</th>
<th>Retain Bitstream Header</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIFCL</td>
<td>Off (Default)</td>
<td>On</td>
</tr>
<tr>
<td>LFD2NX</td>
<td>On</td>
<td>Off (Default)</td>
</tr>
<tr>
<td>LIFCL ES</td>
<td>No change to bit order.</td>
<td>Flip each byte of data.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Replace Bitstream Header.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Retain Bitstream Header.</td>
</tr>
</tbody>
</table>

### Table 123: Ping-Pong Boot Options—SPI Flash Read Mode

<table>
<thead>
<tr>
<th>Device Family</th>
<th>SPI Flash Mode</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIFCL</td>
<td>Off (Default)</td>
</tr>
<tr>
<td>LFD2NX</td>
<td>Fast Read</td>
</tr>
<tr>
<td>LIFCL ES</td>
<td>Dual I/O</td>
</tr>
<tr>
<td></td>
<td>Quad I/O</td>
</tr>
<tr>
<td></td>
<td>Standard Read Opcode</td>
</tr>
<tr>
<td></td>
<td>Fast Read Opcode</td>
</tr>
<tr>
<td></td>
<td>Dual I/O Read Opcode</td>
</tr>
<tr>
<td></td>
<td>Quad I/O Read Opcode</td>
</tr>
</tbody>
</table>

### Table 124: Ping-Pong Boot Options—Primary Starting Address—Secondary Starting Address

<table>
<thead>
<tr>
<th>Device Family</th>
<th>SPI Flash Mode</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIFCL</td>
<td>Use default.</td>
</tr>
<tr>
<td>LFD2NX</td>
<td>Use custom.</td>
</tr>
<tr>
<td>LIFCL ES</td>
<td>Use custom.</td>
</tr>
</tbody>
</table>
### Table 125: Ping-Pong Boot Options—Encryption

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Off (Default)</th>
<th>On</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIFCL</td>
<td>Normal bitstream</td>
<td>Primary encrypted bitstream</td>
</tr>
<tr>
<td>LFD2NX</td>
<td></td>
<td></td>
</tr>
<tr>
<td>LIFCL ES</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

### Table 126: Ping-Pong Boot Options—Authentication

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Encryption</th>
<th>Authentication</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIFCL</td>
<td></td>
<td>Public Key and Private Key Signature</td>
</tr>
<tr>
<td>LFD2NX</td>
<td></td>
<td>Load from GUI and load Public Key (.pub) file and Private File (.prv).</td>
</tr>
</tbody>
</table>

### Table 127: Advanced SPI Flash - iCE40

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Enable Cold Boot</th>
<th>Number of Patterns</th>
<th>Pattern 1 Starting Address 1</th>
<th>Pattern 2 - 3</th>
<th>Pattern 4 Starting Address 4</th>
</tr>
</thead>
<tbody>
<tr>
<td>iCE40</td>
<td>Off (Default)</td>
<td>On</td>
<td>Number of Patterns</td>
<td>Pattern 1</td>
<td>Pattern 2/3/4 Selected</td>
</tr>
<tr>
<td></td>
<td></td>
<td>2/3/4</td>
<td>Selected Pattern 1</td>
<td>0x010000 Sectors</td>
<td>0x010000 Sectors</td>
</tr>
<tr>
<td>POR Boot Pattern</td>
<td>1/2/3/4</td>
<td>Cold Boot</td>
<td>User Data 2 - 3 Selected Pattern 4</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

### Table 128: Advanced SPI Flash—LIFCL, LFD2NX

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Input File 1</th>
<th>Format</th>
<th>Output File</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIFCL</td>
<td>Bitstream (.bit, .rbt)</td>
<td>Intel Hex</td>
<td>Hex (.mcs)</td>
</tr>
<tr>
<td>LFD2NX</td>
<td></td>
<td>Motorola Hex</td>
<td>Hex (.exo)</td>
</tr>
<tr>
<td>LIFCL ES</td>
<td></td>
<td>Extended Tektronix Hex</td>
<td>Hex (.xtek)</td>
</tr>
</tbody>
</table>
### Table 129: Advanced SPI Flash Options—SPI Flash Size

<table>
<thead>
<tr>
<th>Device Family</th>
<th>SPI Flash Size</th>
</tr>
</thead>
<tbody>
<tr>
<td>iCE40</td>
<td>512 (512Kb)/1/2/4/8/16/32/64/128/256/513 (512Mb)</td>
</tr>
<tr>
<td>LIFCL</td>
<td></td>
</tr>
<tr>
<td>LFD2NX</td>
<td></td>
</tr>
<tr>
<td>LIFCL ES</td>
<td></td>
</tr>
</tbody>
</table>

### Table 130: Advanced SPI Flash Options—Byte Wide Mirror

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Byte Wide Mirror Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIFCL</td>
<td>Off (Default)</td>
</tr>
<tr>
<td>LFD2NX</td>
<td>On</td>
</tr>
<tr>
<td>LIFCL ES</td>
<td>No change to bit order. Flip each byte of data.</td>
</tr>
</tbody>
</table>

### Table 131: Advanced SPI Flash Options—Retain Bitstream Header

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Retain Bitstream Header Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIFCL</td>
<td>Off (Default)</td>
</tr>
<tr>
<td>LFD2NX</td>
<td>On</td>
</tr>
<tr>
<td>LIFCL ES</td>
<td>Replace Bitstream Header. Retain Bitstream Header.</td>
</tr>
</tbody>
</table>

### Table 132: Advanced SPI Flash Options—User Hex Files

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Off (Default)</th>
<th>On</th>
<th>Number of User Hex Files</th>
<th>Select User Hex File 1</th>
<th>Select Starting Address 1</th>
<th>User Data 2-3</th>
<th>Select User Hex File 4</th>
<th>Select Starting Address 4</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIFCL</td>
<td>User data</td>
<td></td>
<td>1/2/3/4/5/6/7/8/9/10/11/12/13/14/15/16</td>
<td>Select User Hex File</td>
<td>User Data 2 - 3</td>
<td>Select User Hex File 4</td>
<td>0x010000 Sectors</td>
<td>0x010000 Sectors</td>
</tr>
<tr>
<td>LFD2NX</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>LIFCL ES</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### Table 133: Advanced SPI Flash Options—SPI Flash Read Mode

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Off (Default)</th>
<th>Fast Read</th>
<th>Dual I/O</th>
<th>Quad I/O</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIFCL</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>LFD2NX</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>LIFCL ES</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Off</td>
<td>Fast Read Opcode</td>
<td>Dual I/O Read Opcode</td>
<td>Quad I/O Read Opcode</td>
</tr>
</tbody>
</table>

### Table 134: Advanced SPI Flash Options—Multiple Boot

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Multiple Boot</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIFCL</td>
<td>Off (Default)</td>
</tr>
<tr>
<td>LFD2NX</td>
<td></td>
</tr>
<tr>
<td>LIFCL ES</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Numbr of Altern Data Files</th>
<th>Select Golden Data File</th>
<th>Select Alternate Data File 1</th>
<th>Select Starting Address 1</th>
<th>Next Pattern</th>
<th>Alternates 2 - 3</th>
<th>Select Alternate Data File 4</th>
<th>Select Starting Address 4</th>
<th>Next Pattern</th>
<th>Off (Default)</th>
<th>On</th>
</tr>
</thead>
<tbody>
<tr>
<td>No Multiboot</td>
<td>1/2/3/4</td>
<td>Select golden data file.</td>
<td>Select alternate data file.</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Multiboot</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Use worst case bitstream size.</td>
<td></td>
<td>Use file size.</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Deploying the Design with the Deployment Tool

iCE40 Warm Boot/Cold Boot Bitstream Output Options

The following output format options are available for generating iCE40 warm boot/cold boot bitstreams. Except where otherwise noted, the default setting is listed first for each option.

Intel Hex/Motorola Hex/Extended Tektronix Hex

SPI Flash Size: 64 Mb (512 Kb - 256 Mb): Possible PROM sizes are 512 Kb, 1 Mb, 2 Mb, 4 Mb, 8 Mb, 16 Mb, 32 Mb, 64 Mb, 128 Mb, and 256 Mb.


<table>
<thead>
<tr>
<th>Table 135: sysCONFIG Daisy Chain</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Device Family</strong></td>
</tr>
<tr>
<td>---------------------</td>
</tr>
<tr>
<td>LIFCL</td>
</tr>
<tr>
<td>LFD2NX</td>
</tr>
<tr>
<td>LIFCL ES</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Table 136: sysCONFIG Daisy Chain Options—Merge Format</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Device Family</strong></td>
</tr>
<tr>
<td>---------------------</td>
</tr>
<tr>
<td>Intelligent (Default)</td>
</tr>
<tr>
<td>Combine Slayer Output</td>
</tr>
<tr>
<td>LIFCL</td>
</tr>
<tr>
<td>LFD2NX</td>
</tr>
<tr>
<td>LIFCL ES</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Table 137: sysCONFIG Daisy Chain Options—Byte Wide Mirror and Retain Bitstream Header</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Device Family</strong></td>
</tr>
<tr>
<td>---------------------</td>
</tr>
<tr>
<td>LIFCL</td>
</tr>
<tr>
<td>LFD2NX</td>
</tr>
<tr>
<td>LIFCL ES</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th></th>
<th>No change to bit order.</th>
<th>Flip each byte of data.</th>
<th>Replace Bitstream Header.</th>
<th>Retain Bitstream Header.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>On</td>
<td>On</td>
<td>On</td>
<td>On</td>
</tr>
</tbody>
</table>
Number of Patterns: 2 (2 - 4): Specifies the number of iCE40 configuration files.

Enable Cold Boot: OFF/ON: Optional. Default is warm boot. If selected, cold boot is chosen.

Power On Reset Boot Image 1 (1 - 4): Indicates the input configuration file path and name. Must be specified for each configuration file.

Pattern (1 - 4) Starting Address: SPI flash address location for the configuration file. Must be specified for each configuration file.

See Also
- External Memory Deployment Type
- Creating a New Deployment

Input File Descriptions

The following table shows how files produced by the Radiant software and the Deployment Tool can be used as input files to generate other data file formats. For example, the Deployment Tool uses a binary bitstream generated by Radiant for a Lattice device to output an ISC file. This ISC file can then be used to generate a bitstream ASCII readback file.

The Deployment Tool can read customized bitstreams with various commands and options, such as CRC calculation and comparison.

<table>
<thead>
<tr>
<th>Input File</th>
<th>Description</th>
<th>Output</th>
</tr>
</thead>
<tbody>
<tr>
<td>.isc</td>
<td>In-System Configurable file (ISC) generated from a JEDEC, BIT, RBT, RBK, RBKA, MSK, or MSKA.</td>
<td>Bitstream, SVF, JED, STAPL</td>
</tr>
<tr>
<td>.bit</td>
<td>Bitstream binary file (BIT) generated from a JEDEC, ISC, BIT, or RBT.</td>
<td>Bitstream, ISC, JED, Intel, Motorola, and Extended Tektronix Hex</td>
</tr>
<tr>
<td>.rbt</td>
<td>Bitstream ASCII file (RBT) generated from a JEDEC, ISC, BIT, or RBT.</td>
<td>Bitstream, ISC, JED, Intel, Motorola, and Extended Tektronix Hex</td>
</tr>
<tr>
<td>.rbk</td>
<td>Bitstream binary readback file (RBK) generated from an ISC when the READ option is selected for bitstream binary output.</td>
<td>ISC</td>
</tr>
</tbody>
</table>
Input File Formats

The input file format used with the Deployment Tool depends on the device and the selected output format. The following table shows the data files for Lattice devices that can be used as input files to generate bitstream, serial vector format, or in-system configuration data files.

### Table 139: Input File Formats

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Input for Bitstream</th>
<th>Multiple Input/Output</th>
<th>Input for SVF Output</th>
<th>Input for ISC Output</th>
<th>Input for JEDEC Output</th>
</tr>
</thead>
<tbody>
<tr>
<td>iCE40</td>
<td>.bin</td>
<td>Not available</td>
<td>Not available</td>
<td>Not available</td>
<td>Not available</td>
</tr>
<tr>
<td>LIFCL</td>
<td>.bit, .rbt</td>
<td>.bit, .rbt</td>
<td>.bit, .rbt</td>
<td>Not available</td>
<td>Not available</td>
</tr>
<tr>
<td>LFD2NX</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

See Also

- “Input File Descriptions” on page 423
Bitstream Output File Descriptions

The output file format generated by the Deployment Tool depends on the device and the selected format options. To see a list of all the output formats by device family, see “Bitstream Output Formats” on page 425.

Table 140: Bitstream Output File

<table>
<thead>
<tr>
<th>File Extension</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>.bit</td>
<td>Binary bitstream.</td>
</tr>
<tr>
<td>.rbt</td>
<td>ASCII bitstream.</td>
</tr>
<tr>
<td>.msk</td>
<td>Binary bitstream mask file generated from an In-System Configurable (ISC) file when the READ_MASK option is selected for bitstream binary output.</td>
</tr>
<tr>
<td>.mska</td>
<td>ASCII bitstream mask file generated from an In-System Configurable (ISC) file when the READ_MASK option is selected for ASCII output.</td>
</tr>
<tr>
<td>.rbk</td>
<td>Binary readback bitstream file generated from an ISC file when the READ option is selected for binary output.</td>
</tr>
<tr>
<td>.rbka</td>
<td>ASCII readback bitstream file generated from an ISC file when the READ option is selected for ASCII output.</td>
</tr>
<tr>
<td>.exo</td>
<td>Motorola hexadecimal output data file.</td>
</tr>
<tr>
<td>.mcs</td>
<td>Intel hexadecimal output data file.</td>
</tr>
<tr>
<td>.xtek</td>
<td>Extended Tektronix hexadecimal output data file.</td>
</tr>
</tbody>
</table>

Bitstream Output Formats

The Deployment Tool generates bitstream data files for the LIFCL. The table below shows the types of bitstreams and output formats that can be generated for each of these families.

Table 141: Bitstream Output Formats

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Single Bitstream</th>
<th>Merged Bitstream</th>
</tr>
</thead>
<tbody>
<tr>
<td>iCE40</td>
<td>Intel Hex (.mcs)</td>
<td>Not available</td>
</tr>
<tr>
<td></td>
<td>Motorola Hex (.exo)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Extended Tektronix Hex (.xtek)</td>
<td></td>
</tr>
<tr>
<td>LIFCL</td>
<td>Bitstream Binary (.bit)</td>
<td>Intel Hex Merge (.mcs)</td>
</tr>
<tr>
<td>LFD2NX</td>
<td>Bitstream ASCII (.rbt)</td>
<td>Motorola Hex Merge (.exo)</td>
</tr>
<tr>
<td></td>
<td>Intel Hex (.mcs)</td>
<td>Extended Tektronix Hex Merge</td>
</tr>
<tr>
<td></td>
<td>Motorola Hex (.exo)</td>
<td>(.xtek)</td>
</tr>
<tr>
<td></td>
<td>Extended Tektronix Hex (.xtek)</td>
<td></td>
</tr>
</tbody>
</table>

See Also
SVF, and STAPL Output Formats

The Deployment Tool generates Serial Vector Format (SVF), In-System Configuration (ISC), and Standard Test and Programming Language (STAPL) data files for Lattice devices.

**SVF Output Files**  SVF files are generated from ISC, binary bitstream (BIT), or ASCII bitstream (RBT) input files.

**ISC Output Files**  ISC files are generated from binary bitstream (BIT), ASCII bitstream (RBT), binary readback (RBK), ASCII readback (RBKA), binary mask (MSK), and ASCII mask (MSKA) input files.

**STAPL Output Files**  STAPL files are generated from JEDEC input files.

See Also

⇒ “Input File Descriptions” on page 423

Output Options Descriptions

The following describes each of the options provided by the Deployment Tool for outputting data files. The number and types of options depend on the type of device that you are programming and the output format. For options available by device type, refer to the device-specific options.

**Verify ID Code**  – Generates the bitstream which verifies the ID code.

**Program Secure**  – Generates the data file which secures the device.

**Compression**  – Compresses the bitstream.

**Frequency**  – Generates the bitstream using the specified frequency.

**Byte Wide Bit Mirroring**  – Flips each byte in Intel, Extended Tektronix, and Motorola hexadecimal data files.

**RUNTEST from REV C**  – Generates the serial vector format file using the format specified in the SVF file specification, revision C or earlier.

**For Erase, Program, and Verify Operations, Skip Verify**  – Globally skips the verification step of the Erase, Program, and Verify operation.
Creating a New Deployment

The Deployment Tool has a wizard interface that guides you through the process of creating a deployment for the various function types and output file types.

To create a new Deployment:

1. Issue the start command in one of the following ways:
   ▶ To start Deployment Tool that is integrated in the Radiant software:
     ▶ In the Radiant software, open Programmer by choosing **Tools > Programmer**.
     ▶ In the Programmer window, choose **Tools > Deployment Tool**.
   ▶ To start Deployment Tool from stand-alone Radiant Programmer:
     ▶ In the Programmer window, choose **Tools > Deployment Tool**.
     or
     ▶ From the Windows Start menu, choose **All Programs > Lattice Radiant Programmer > Deployment Tool**.
     ▶ In Linux, from the `<Programmer install_path>/bin/lin64` directory, enter the following on a command line:
       ```
       ./deployment
       ```
   2. In the Getting Started dialog box, choose **Create a New Deployment**.
   3. In the Function Type dropdown menu, choose from one of the following options:
      ▶ File Conversion
      ▶ Tester
      ▶ External Memory
   4. In the Output File Type box, choose an output file type.
   5. Click **OK**. The Deployment Tool loads the device database. A four step process must now be completed.
   6. In “Step 1”, do one of the following, depending on the type of file you are using:
      ▶ If you are creating a deployment from an .xcf file, use the (Browse) button to browse to the project’s .xcf file.
      ▶ If you are creating a deployment from a data file, select Input File(s) window, click ... (Browse) and browse to the projects .jed file. The Device Family and Device boxes are automatically populated by the Deployment Tool.
   7. Click **Next**.
   8. In “Step 2” (Options dialog box), select the desired options for your output file type.
   9. Click **Next**.
10. In the “Step 3” (Select Output File(s) dialog box), select the desired output file type from the dropdown menu, and using the using the button, browse to the desired location of the output file(s).

11. Click Next.

12. In the “Step 4” (Generate Deployment dialog box), review the Deployment Tool Summary and Command Line Information.

13. Choose File > Generate, or click the button, to perform the Deployment. Results of the generation are available for review.

14. Choose File > Save, or click the button, to save the deployment (.ddt) file to your desired location.

See Also  "iCE40 Warm Boot/Cold Boot Bitstream Output Options" on page 422

Opening an Existing Deployment

If a deployment was saved as a deployment (.ddt) file, the deployment can be opened in Deployment Tool and regenerated using the same deployment options, or by applying different deployment options.

To open an existing deployment:

1. Issue the start command in one of the following ways:
   ▶ To start Deployment Tool that is integrated in the Radiant software:
     ▶ In the Radiant software, open Programmer by choosing Tools > Programmer.
     ▶ In the Programmer window, choose Tools > Deployment Tool.
   ▶ To start Deployment Tool from stand-alone Radiant Programmer:
     ▶ In the Programmer window, choose Tools > Deployment Tool.
     ▶ From the Windows Start menu, choose All Programs > Lattice Radiant Programmer > Deployment Tool.
     ▶ In Linux, from the <Programmer install_path>/bin/lin64 directory, enter the following on a command line:
       ./deployment

2. In the Getting Started dialog box, choose Open an Existing Deployment.

3. Click OK. The Deployment Tool loads the device database. A four step process must now be completed.

4. In “Step 1”, do one of the following, depending on the type of file you are using:
   ▶ If you are creating a deployment from an .xcf file, use the (Browse) button to browse to the project’s .xcf file.
Deploying the Design with the Deployment Tool

1. If you are creating a deployment from a data file, select Input File(s) window, click ... (Browse) and browse to the projects .jed file. The Device Family and Device boxes are automatically populated by the Deployment Tool.

5. Click **Next**.

6. In “Step 2” (Options dialog box), select the desired options for your output file type.

7. Click **Next**.

8. In the “Step 3” (Select Output File(s) dialog box), select the desired output file type from the dropdown menu, and using the using the button, browse to the desired location of the output file(s).

9. Click **Next**.

10. In the “Step 4” (Generate Deployment dialog box), review the Deployment Tool Summary and Command Line Information.

11. Choose **File > Generate**, or click the button, to perform the Deployment. Results of the generation are available for review.

12. Choose **File > Save**, or click the button, to save the deployment (.ddt) file to your desired location.

See Also

- “Creating a New Deployment” on page 427
- “iCE40 Warm Boot/Cold Boot Bitstream Output Options” on page 422

Opening an Existing Deployment While Running the Deployment Tool

You can open a different existing deployment while running the Deployment Tool, and save the deployment you are currently working on.

To open an existing deployment while running the Deployment Tool:

1. Choose **File > Open**.

2. In the Open dialog box, browse to the deployment (.ddt) file that you wish to open and select it.

3. Click **Open**.

See Also

- “Creating a New Deployment” on page 427
- “iCE40 Warm Boot/Cold Boot Bitstream Output Options” on page 422
Creating a New Deployment While Running the Deployment Tool

You can create a new deployment while running the Deployment Tool.

**To create a new deployment while running the Deployment Tool:**

1. Choose **File > New**, or click the button.

2. Deployment Tool prompts you to save the .ddt file for the project you are currently working on. If you wish to save the deployment you are currently working on, click **Yes**, and in the Save As dialog box, create a name for the .ddt file and save in the desired location.

3. In the Function Type drop-down menu, choose from one of the options.

4. In the Output File Type box, choose an output file type.

5. Click **OK**. The Deployment Tool loads the device database.

**See Also**

- “Creating a New Deployment” on page 427
- “Using Quick Launch Button to Create a New Deployment” on page 430
- “iCE40 Warm Boot/Cold Boot Bitstream Output Options” on page 422

Using Quick Launch Button to Create a New Deployment

Quick launch buttons allow you to create a new Deployment while running the Deployment Tool without having to use the Getting Started dialog box. The toolbar supports up to six quick launch buttons.

You can customize which quick launch buttons appear in the toolbar. Choices of quick launch buttons include:

- IEEE 1532 ISC Data File
- Application Specific BSDL File
- JEDEC File
- Bitstream
- JEDEC to Hex
- SVF - Single Device
Deploying the Design with the Deployment Tool

To customize which quick launch buttons appear in the Deployment Tool toolbar:

1. Place the cursor over a quick launch button, and right-click.
2. In the drop-down menu, check the box of the quick start button that you want to display in the toolbar. A maximum of six buttons may be selected.

See Also

- "Creating a New Deployment" on page 427
- "Creating a New Deployment While Running the Deployment Tool" on page 430
- "iCE40 Warm Boot/Cold Boot Bitstream Output Options" on page 422

Viewing the Deployment Tool Log File

The log file shows recent actions in a text editor.

To view the log file:

Click the button on the toolbar.

See Also

- "Deploying the Design with the Deployment Tool" on page 400
Changing the Deployment Tool Log File Settings

The log file shows recent actions in a text editor. You can change settings to clear log file path each time the application starts, and you can also change where the log file is saved.

To change where the log file is saved:
1. Choose Edit > Settings.
2. In the Log File Path dialog box, browse to the folder where you wish to save the deployment_tool.log file.

To clear the log file each time the application starts:
1. Choose Edit > Settings.
2. Check the Clear Log File Each Time Application Starts box.

If the Clear Log File Each Time Application Starts box is unchecked, the log file will continue increase in size until the file is manually erased.

See Also
▶ "Deploying the Design with the Deployment Tool" on page 400
Debugging SVF, STAPL, and VME Files

Download Debugger is a stand-alone software tool for debugging the following file types:

- Serial Vector Format (SVF)
- Standard Test And Programming Language (STAPL)
- Lattice Embedded (VME)

Download Debugger allows you to program a device, and edit, debug, and trace the process of SVF, STAPL, and VME files.

Download Debugger also allows you to create, edit, or view a VME file in hexadecimal format.

This section provides procedures for using Download Debugger. Topics include:

- “Understanding SVF Files” on page 434
- “Download Debugger Software Support of SVF Operations” on page 434
- “Running Download Debugger” on page 435
- “Opening an Existing SVF File” on page 435
- “Creating a New SVF File” on page 435
- “Setting Device Programming Options in Download Debugger” on page 436
- “Setting Port Assignments and Options in Download Debugger” on page 436
- “Setting and Removing Breakpoints in an SVF File” on page 436
- “Processing an SVF File” on page 437
- “Viewing the Download Debugger Log File” on page 437
- “Saving a Log File in Download Debugger” on page 438
- “Clearing the Contents of a Log File in Download Debugger” on page 438
- “Editing an SVF File” on page 438
- “Opening an Existing STAPL File” on page 439
- “Creating a New STAPL File” on page 439
- “Viewing STAPL Processing” on page 439
- “Setting and Removing Breakpoints in a STAPL File” on page 439
- “Processing a STAPL File in Download Debugger” on page 440
- “Viewing the Download Debugger Log File” on page 441
- “Saving a Log File in Download Debugger” on page 441
- “Clearing the Contents of a Log File in Download Debugger” on page 441
- “Editing a STAPL File” on page 442
- “Setting Windows Options in Download Debugger” on page 442
Understanding SVF Files

The Serial Vector Format file (.svf) is the medium for exchanging descriptions of high-level 1149.1 bus operations. The SVF file is defined as an ASCII file that consists of a set of SVF statements. The 1149.1 bus operations consist of scan operations and movements between different stable states. Refer to the Serial Vector Format Specification Rev E for detailed definitions of SVF statement formats. Current SVF specifications are available from Asset-Intertech website at www.asset-intertech.com.

See Also  “Debugging SVF, STAPL, and VME Files” on page 433

Download Debugger Software Support of SVF Operations

The Download Debugger supports a selective set of SVF operations. The following table lists SVF operations supported by the Download Debugger.

<table>
<thead>
<tr>
<th>SVF Operation</th>
<th>Description</th>
<th>Support Status</th>
</tr>
</thead>
<tbody>
<tr>
<td>ENDDR</td>
<td>Specifies default end state for DR scan operations.</td>
<td>Full support</td>
</tr>
<tr>
<td>ENDIR</td>
<td>Specifies default end state for IR scan operations.</td>
<td>Full support</td>
</tr>
<tr>
<td>HDR</td>
<td>(Header Data Register) Specifies a header pattern, which is placed at the beginning of subsequent DR, scan operations.</td>
<td>Supports TDI keyword only. SMASK, TDO and MASK are not supported.</td>
</tr>
<tr>
<td>HIR</td>
<td>(Header Instruction Register) Specifies a header pattern, which is placed at the beginning of subsequent IR, scan operations.</td>
<td>Supports TDI keyword only. SMASK, TDO and MASK are not supported.</td>
</tr>
<tr>
<td>RUNTEST</td>
<td>Forces the 1149.1 bus to the RUN_TEST/IDLE state for a specified number of clocks.</td>
<td>Full support</td>
</tr>
<tr>
<td>SDR</td>
<td>(Scan data register) Performs an 1149.1 data register scan.</td>
<td>Supports TDI, TDO, and MASK keywords. SMASK is ignored.</td>
</tr>
<tr>
<td>SIR</td>
<td>(Scan Instruction Register) Performs an 1149.1 instruction register scan.</td>
<td>Supports TDI, TDO, and MASK keywords. SMASK is ignored.</td>
</tr>
<tr>
<td>STATE</td>
<td>Forces the 1149.1 bus to a specified stable state.</td>
<td>Supports only single target state. The Download Debugger does not allow you to specify custom traverse path.</td>
</tr>
<tr>
<td>TDR</td>
<td>(Trailer Data Register) Specifies a trailer pattern, which is appended to the end of subsequent DR scan operations.</td>
<td>Supports TDI keyword only. SMASK, TDO, and MASK are not supported.</td>
</tr>
<tr>
<td>TIR</td>
<td>(Trailer Data Register) Specifies a trailer pattern which is appended to the end of subsequent IR scan operations</td>
<td>Supports TDI keyword only. SMASK, TDO, and MASK are not supported.</td>
</tr>
</tbody>
</table>

See Also  “Debugging SVF, STAPL, and VME Files” on page 433
Running Download Debugger

Download Debugger runs separately from the Radiant software environment.

To start the Download Debugger:

1. Issue the start command in one of the following ways:
   - To start Download Debugger that is integrated in the Radiant software:
     - In the Radiant software, open Programmer by choosing Tools > Programmer.
     - In the Programmer window, choose Tools > Download Debugger.
   - To start Download Debugger from stand-alone Radiant Programmer:
     - In the Programmer window, choose Tools > Download Debugger.
     - or
     - From the Windows Start menu, choose All Programs > Lattice Radiant Programmer > Download Debugger.
   - In Linux, from the <Programmer install_path>/bin/lin64 directory, enter the following on a command line:
     ```bash
     ./debugger
     ```

See Also  “Debugging SVF, STAPL, and VME Files” on page 433

Opening an Existing SVF File

The Download Debugger Edit Window allows you to perform various editing functions on your SVF file. You can check the SVF file for errors line by line when you program your device.

To open an existing SVF file:

1. In Download Debugger, choose File > Open to open the dialog box.
2. Locate and select the desired SVF file, and then click Open.
   - The selected SVF file opens in the Download Debugger Edit Window.

See Also  “Debugging SVF, STAPL, and VME Files” on page 433

Creating a New SVF File

To create a new empty SVF file:

- In Download Debugger, choose File > New to open the SVF Debugger Edit Window and create a new empty SVF file.
Setting Device Programming Options in Download Debugger

To set SVF options:
1. In Download Debugger, choose Configuration > Options. The “Options Dialog Box” on page 444 opens.
2. Select the options that you want and click OK.

Setting Port Assignments and Options in Download Debugger

Use the “Cable and I/O Port Settings Dialog Box” on page 442 to specify the preferred location for download, select the port address or cable, and choose the download cable type.

To set port assignments and options:
1. In Download Debugger, choose Configuration > Cable and I/O Port Setup. The “Cable and I/O Port Settings Dialog Box” on page 442 opens.
2. Select the options that you want and click OK.

Setting and Removing Breakpoints in an SVF File

By using the Download Debugger, you can set a breakpoint in your SVF file before processing it. The process stops at the line that you specify. After clicking OK in the dialog box, you can resume the process.

To set a breakpoint in an SVF File:
1. Select a line in your SVF file.
2. Choose Command > Breakpoint > Toggle Breakpoint.
To select the next breakpoint:
1. Select a line in your SVF file.
2. Choose Command > Breakpoint > Next Breakpoint.

To select the previous breakpoint:
1. Select a line in your SVF file.
2. Choose Command > Breakpoint > Previous Breakpoint.

To clear all breakpoints:
1. In your SVF file, select the breakpoint you want to remove.
2. Choose Command > Breakpoint > Clear All Breakpoints.

See Also “Debugging SVF, STAPL, and VME Files” on page 433

Processing an SVF File
After setting device programming options and port assignments, you can process your SVF file with the Download Debugger. You can program a device with a download cable, step through each line of the process, reset it and begin again.

To process an SVF file:
▶ Choose Command > Go.

To step through a process, line by line:
▶ Choose Command > Step.
   The process will step through the SVF file line by line.

To reset a process and start a process from the beginning:
▶ Choose Command > Reset.

See Also “Debugging SVF, STAPL, and VME Files” on page 433

Viewing the Download Debugger Log File
The Download Debugger generates a log file of the process and reports any errors encountered. When you select Continue on Error in the “Options Dialog Box” on page 444, the log file also reports state machine transitions and delay time for debug.
To view a log file:

- In Download Debugger, choose View > View Log File.

  The log file is displayed in a text editor.

See Also  “Clearing the Contents of a Log File in Download Debugger” on page 438

- “Debugging SVF, STAPL, and VME Files” on page 433

Saving a Log File in Download Debugger

To save a log file:

1. In Download Debugger, choose Configuration > Options.

2. The “Options Dialog Box” on page 444 opens.

3. Use the Browse button to specify the path of the directory you wish to save your log file to.

4. Click OK.

See Also  “Debugging SVF, STAPL, and VME Files” on page 433

Clearing the Contents of a Log File in Download Debugger

To clear the contents of the log file:

- In Download Debugger, choose Edit > Clear Log File.

See Also  “Debugging SVF, STAPL, and VME Files” on page 433

Editing an SVF File

Use the Edit menu commands in the Download Debugger to edit an SVF file.

To edit an SVF file:

1. In Download Debugger, select a line in your SVF file.

2. Make the edits using commands in the Edit menu, and click File > Save.

See Also  “Debugging SVF, STAPL, and VME Files” on page 433
Opening an Existing STAPL File
The Download Debugger allows you to perform various editing functions on your STAPL file. You can check the STAPL file for errors line by line when you program your device.

To open an existing STAPL file:
1. In Download Debugger, choose **File > Open** to open the dialog box.
2. Locate and select the desired STAPL (.stp) file, and then click **Open**.

   The selected STAPL file opens in the Download Debugger.

See Also  “Debugging SVF, STAPL, and VME Files” on page 433

Creating a New STAPL File

To create a new empty STAPL file:

 In Download Debugger, choose **File > New**.

 A blank edit window opens. You can start entering contents for your new STAPL file, and save the file when you finish.

See Also  “Debugging SVF, STAPL, and VME Files” on page 433

Viewing STAPL Processing
To view the output information during STAPL processing, you should open the Output Information dialog box before processing the STAPL file.

See Also  “Debugging SVF, STAPL, and VME Files” on page 433

Setting and Removing Breakpoints in a STAPL File
By using the Download Debugger, you can set a breakpoint in your STAPL file before processing it. The process stops at the line that you specify. After clicking OK in the dialog box, you can resume the process.

To set a breakpoint in a STAPL file:
1. Select a line in your STAPL file.
2. Choose **Command > Breakpoint > Toggle Breakpoint**.
To select the next breakpoint:
1. Select a line in your STAPL file.
2. Choose Command > Breakpoint > Next Breakpoint.

To select the previous breakpoint:
1. Select a line in your STAPL file.
2. Choose Command > Breakpoint > Previous Breakpoint.

To clear all breakpoints:
1. In your STAPL file, select the breakpoint you want to remove.
2. Choose Command > Breakpoint > Clear All Breakpoints.

See Also  “Debugging SVF, STAPL, and VME Files” on page 433

Processing a STAPL File in Download Debugger
After setting device programming options and port assignments, you can process your STAPL file with the Download Debugger and examine the progress in the Output Information dialog box. You can program a device with a download cable, step through each line of the process, reset it and begin again.

To process a STAPL file:
► Choose Command > Go.

To step through a process, line by line:
► Choose Command > Step.

The process will step through the STAPL file line by line.

To reset a process and start a process from the beginning:
► Choose Command > Reset.

See Also  “Debugging SVF, STAPL, and VME Files” on page 433
Viewing the Download Debugger Log File

The Download Debugger generates a log file that tracks the process and reports any errors encountered. The log file contains all the information displayed in the Status window and also the status of the cable. When you select **Continue on Error** in the “Options Dialog Box” on page 444, the log file also reports state machine transitions and delay time for debug.

To view a log file:

1. In Download Debugger, choose **View > View Log File**.
   - The log file is displayed in a text editor.

**See Also**  
- “Saving a Log File in Download Debugger” on page 438  
- “Clearing the Contents of a Log File in Download Debugger” on page 441  
- “Debugging SVF, STAPL, and VME Files” on page 433

Saving a Log File in Download Debugger

To save a log file:

1. In Download Debugger, choose **Configuration > Options**.
   - The “Options Dialog Box” on page 444 opens.
2. Use the Browse button to specify the path of the directory you want to save your log file to.
3. Click **OK**.

**See Also**  
- “Debugging SVF, STAPL, and VME Files” on page 433

Clearing the Contents of a Log File in Download Debugger

To clear the contents of the log file:

1. In Download Debugger, choose **Edit > Clear Log File**.

**See Also**  
- “Debugging SVF, STAPL, and VME Files” on page 433
Editing a STAPL File

Use the Edit menu commands in the Download Debugger to edit a STAPL file.

To edit a STAPL file:
1. In Download Debugger, select a line in your STAPL file.
2. Make the edits using commands in the Edit menu, and click File > Save.

See Also  “Debugging SVF, STAPL, and VME Files” on page 433

Setting Windows Options in Download Debugger

Use the Windows options to change the way how multiple windows are displayed in Download Debugger.

To cascade open windows:
► Choose Window > Cascade.

To tile open windows:
► Choose Window > Tile.

See Also  “Debugging SVF, STAPL, and VME Files” on page 433

Download Debugger Options

This section lists the options available in Download Debugger.

Topics include:
► “Cable and I/O Port Settings Dialog Box” on page 442
► “Options Dialog Box” on page 444

Cable and I/O Port Settings Dialog Box

The following options are available in the Cable and I/O Port Settings dialog box.

Cable Description  This option is displayed when multiple cables are detected. When enabled, this option allows you to select the desired cable.

Cable  Specifies the download cable type: Lattice (parallel port), USB (LSC USB cable), or USB2 (FTDI USB2 cable)
**Port** Specifies the port to which the download cable is connected.

**Custom Port** Specifies a custom parallel port to which the download cable is connected. Use hexadecimal format to type the port name.

**Using Slave SPI Interface Connection** This option allows you to target the slave SPI port of the selected device. This allows you to debug slave SPI device programming.

**Using JTAGI2C Interface Connection (HW-USBN-2B Cable Only)** Only use an HW-USBM-2B cable for a JTAGI2C interface connection.

**Use Default Clock Divider** Uses the fastest TCK clock speed.

**Use Custom Clock Divider** Enables the Use Custom Clock Divider feature.

**TCK Divider Setting (0 - 30x)** Allows you to slow down the TCK clock. This is done by extending the low period of the clock. Refer the following tables for specific frequency settings for USB-2B (2232H FTDI USB host chip), USB-2B (2232D FTDI USB host chip), and USB-2A and Parallel port cables.

### Table 142: USB-2B (2232H FTDI USB host chip)

<table>
<thead>
<tr>
<th>Divider</th>
<th>Clock Frequency¹</th>
<th>Divider</th>
<th>Clock Frequency¹</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>30 MHz</td>
<td>5</td>
<td>5 MHz</td>
</tr>
<tr>
<td>1</td>
<td>15 MHz (Default)</td>
<td>6</td>
<td>4.2 MHz</td>
</tr>
<tr>
<td>2</td>
<td>10 MHz</td>
<td>7</td>
<td>3.7 MHz</td>
</tr>
<tr>
<td>3</td>
<td>7.5 MHz</td>
<td>8</td>
<td>3.1 MHz</td>
</tr>
<tr>
<td>4</td>
<td>6 MHz</td>
<td>9</td>
<td>3 MHz</td>
</tr>
<tr>
<td></td>
<td></td>
<td>10</td>
<td>2.7 MHz</td>
</tr>
</tbody>
</table>

¹Calculation formula for USB-2B (2232H FTDI USB host chip):
Frequency = 60 MHz / (1 + ClockDivider) *2

### Table 143: USB-2B (2232D FTDI USB host chip)

<table>
<thead>
<tr>
<th>Divider</th>
<th>Clock Frequency²</th>
<th>Divider</th>
<th>Clock Frequency²</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>6 MHz</td>
<td>5</td>
<td>1 MHz</td>
</tr>
<tr>
<td>1</td>
<td>3 MHz (Default)</td>
<td>6</td>
<td>0.8 MHz</td>
</tr>
<tr>
<td>2</td>
<td>2 MHz</td>
<td>7</td>
<td>0.7 MHz</td>
</tr>
<tr>
<td>3</td>
<td>1.5 MHz</td>
<td>8</td>
<td>0.65 MHz</td>
</tr>
<tr>
<td>4</td>
<td>1.2 MHz</td>
<td>9</td>
<td>0.6 MHz</td>
</tr>
</tbody>
</table>
Download Debugger Options

Use Default I/O Settings  
Only use the four JTAG signals.

Use Custom I/O Settings  
Specify additional non-JTAG signals connected to the board.

INITN Pin Connected  
Select this option if you connect the INIT pin to the download cable. This option is only available with the ispDOWNLOAD USB cable.

DONE Pin Connected  
Select this option if you connect the DONE pin to the download cable. This option is only available with the ispDOWNLOAD USB cable.

TRST Pin Connected  
Select this option if you connect the TRST pin to the download cable. Specify active high or active low.

PROGRAM Pin Connected  
Select this option if you connect the PROGRAM pin to the download cable.

ispEN Pin Connected  
Select this option if you connect the ispEN pin to the download cable. Specify active high or active low.

See Also  “Download Debugger Options” on page 442

Options Dialog Box

The following options are available in the within the three tabs (General, SVF, STAPL) found in the Options dialog box.

---

Table 143: USB-2B (2232D FTDI USB host chip) (Continued)

<table>
<thead>
<tr>
<th>Divider</th>
<th>Low Pulse Width delay&lt;sup&gt;²&lt;/sup&gt;</th>
<th>Divider</th>
<th>Low Pulse Width delay&lt;sup&gt;²&lt;/sup&gt;</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>0.5 MHz</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<sup>²</sup>Calculation formula for USB-2B (2232D FTDI USB host chip):
Frequency = 12 MHz / (1 + ClockDivider) * 2

---

Table 144: USB-2A and Parallel port

<table>
<thead>
<tr>
<th>Divider</th>
<th>Low Pulse Width delay&lt;sup&gt;³&lt;/sup&gt;</th>
<th>Divider</th>
<th>Low Pulse Width delay&lt;sup&gt;³&lt;/sup&gt;</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>NA</td>
<td>5</td>
<td>5x</td>
</tr>
<tr>
<td>1</td>
<td>1x</td>
<td>6</td>
<td>6x</td>
</tr>
<tr>
<td>2</td>
<td>2x</td>
<td>7</td>
<td>7x</td>
</tr>
<tr>
<td>3</td>
<td>3x</td>
<td>8</td>
<td>8x</td>
</tr>
<tr>
<td>4</td>
<td>4x</td>
<td>9</td>
<td>9x</td>
</tr>
<tr>
<td></td>
<td></td>
<td>10</td>
<td>10x</td>
</tr>
</tbody>
</table>

<sup>³</sup>The USB-2A frequency fixed at 1.5 MHz and Parallel Port frequency fixed at 500 KHz
**Log File Name**  Allows you to specify name and location of log file.

**Clear Log File Each Time Start Application**  A Check to clear the log file each time Download Debugger is started.

**Source Editor**  Allows you to specify font, size, tab size, of Source Editor.

**Show Line Number**  Toggles display of line numbers in left margin of Source Editor.

**Show Indicator Margin**  Toggles display of indicator margin in left side of Source Editor.

**Disable SVF Syntax Checker**  Disables the tool that checks the syntax of the SVF file.

**Ignore IR and DR Header Trailer in SVF**  Ignores the HIR, TIR, HDR, and TDR information in SVF file. If you set up HIR, TIR, HDR, or TDR in this dialog box, this option must be selected.

**Continue on Error**  Continues processing the file even if there is an error. You can look at the log file for the errors encountered. When this option is selected, the log file also reports state machine transitions and delay time for debug.

**Mixed Chain**  Tells the Download Debugger that the hardware configuration is a mixed chain, therefore disabling the ISP chain when processing the SVF file.

**TCK Frequency**  Specifies the TCK clock frequency for the chosen SVF file. This value is used to determine the TCK clock period and the length of the delay times.

**SVF Vendor**  Allows you select from the following SVF vendors for the selected device: JTAG STANDARD, LATTICE, ALTERA, and XILINX. This option is available for JTAG devices only.

**Starting TAP State**  Select the starting JTAG state of the JTAG State Machine for download. Only two states are available: TLR (Test-Logic-Reset) and RTI (Run-Test/Idle).

**Instruction Register Header**  Sets the IR header length in number of bits (0-100).

**Instruction Register Trailer**  Sets the IR trailer length in number of bits (0-100).

**Data Register Header**  Sets the HDR in number of bits (0-100).

**Data Register Trailer**  Sets the TDR in number of bits (0-100).

**Ignore IR and DR Header Trailer in STAPL**  Ignores the HIR, TIR, HDR and TDR information in STAPL file. If you set up HIR, TIR, HDR, or TDR in this dialog box, this option must be selected.
See Also  "Download Debugger Options" on page 442
Using Programming File Utility

The Radiant Programming File Utility is a stand-alone tool that allows you to view, compare, and edit data files. When comparing two data files, the software generates an output (.out) file with the differences highlighted in red.

See Also

- “Running Programming File Utility” on page 447
- “Viewing Data Files” on page 447
- “Comparing Two Data Files” on page 448
- “Editing Feature Row Values” on page 449
- “Editing Control Register0 or Control Register1 Values” on page 449
- “Control Register1 Editor Dialog Box” on page 453
- “Editing the USERCODE in the Data File” on page 450

Running Programming File Utility

Open Programming File Utility from the Tools menu of Programmer. Or you can also open it directly if you have the stand-alone Programmer installed or are working on a Linux system.

To run the Programming File Utility:

- Do one of the following:
  
  - In the Programmer window, choose **Tools > Programming File Utility**.
  
  - In the Windows Start menu, choose **All Programs > Lattice Radiant Programmer > Programming File Utility**. Requires the stand-alone Programmer.
  
  - In Linux, go to the `<Programmer install_path>/bin/lin64` directory, and enter the following on a command line:
    ```
    ./fileutility
    ```

The Programming File Utility window opens.

See Also

- “Using Programming File Utility” on page 447

Viewing Data Files

The data file can be in any of the following formats: .jed, .isc, .rbt, .rbka, .mska, .bit, .rbk, .msk, .bsm, .bsd, .bin, .hex, .mcs, .exo, xtek, nvcm, .out.
To view a data file:

> In the Programming File Utility, choose **File > Open** and select the data file you want to view.

Use the **Edit > Find** and **Edit > Find Next** commands to search for text in the file. Choose **File > Save As** to save the file with another file name.

Change file appearance such as font and font size by choosing **Configuration > Options** and changing settings in the Options dialog box.

**See Also**

> “Using Programming File Utility” on page 447

### Comparing Two Data Files

You can use the Programming File Utility application to compare two data files. After creating the output file, the software displays the output file and highlights the differences between the two files.

**To compare two data files:**

1. Choose **Command > Data Files Comparison** or click  on the toolbar.
   
   The Data Files Comparison Dialog Box opens.

2. Click the Browse buttons under First Data and Second Data to select the two data files you want to compare.

3. Optionally, if you are comparing two readback files (.rbk), browse for the mask file (.msc) to include masked bits in the comparison.

4. If desired, type a different name for the output file or browse to a file name that you want to overwrite. By default, the software uses the first data file name and appends the extension .out.

5. Click **OK**.

   The software compares the files and displays a message indicating whether the two files are identical or contain differences.

6. Click **OK** to close the message box and display the output file in the Programming File Utility window.

7. If the files contain differences, the Next and Previous arrows will become enabled on the toolbar. Use these buttons to examine each difference in the output file.

**Viewing the Output File**

The output file displays lines of data from the first file. Each of these lines is followed by a comparison line which shows dots where the files are the same. When different, the line is highlighted in red and the data from the second file is displayed.

An output file that uses a mask file to compare two readback files displays each line of data from the first readback file in black, followed by a line of data
in green from the mask file, and then a comparison line. The comparison line shows dots where the two readback files are the same. When different, the line is highlighted in red and the data from the second readback file is displayed.

See Also

► “Using Programming File Utility” on page 447

## Editing Feature Row Values

You can use the Feature Row Editor to enable or disable silicon features in Lattice FPGA devices by editing the Feature Row fuse settings in the data file.

To edit control register values:

1. Choose **Tools > Feature Row Editor**.
   
   The “Feature Row Editor Dialog Box” on page 452 opens.

2. Using the (Browse) button, select the data (.jed) file you want to edit.

3. Click **Read** to display current data file settings.
   
   The software displays the default values in the top row. The second row shows the values that can be modified in black, and those that cannot be modified in red.

4. Click the cell of a value displayed in black to change it.
   
   ► To change the value in Feature Row, click the value cell and toggle the value from 1 to 0 or from 0 to 1.

5. To overwrite the existing data file, choose **Save**.

6. To create a new data file with a different name, choose **Save As** and save as a different file name.

See Also

► “Using Programming File Utility” on page 447

## Editing Control Register0 or Control Register1 Values

You can use either the Control Register0 Editor or the Control Register1 Editor to read the control registers of a bitstream file, modify the settings, and save them.

To edit control register values:

1. Choose **Tools > Control Register0 Editor** or choose **Tools > Control Register1 Editor**.
The Control Register 0 editor or Control Register 1 editor opens (see “Control Register0 Editor Dialog Box” on page 453 or “Control Register1 Editor Dialog Box” on page 453 for more information).

2. Using the (Browse) button, browse to the .isc, .rbt, or .bit file that you want to edit, select the file, and then click Open.

   The editor opens with the selected file.

3. Click Read to display the values of the control register.

4. The software displays the default values in the top row.

   The software displays the default values in the top row. The second row shows the values that can be modified in black, and those that cannot be modified in red.

5. Click the cell of a value displayed in black to change it.

   ▶ To change a value, click the value cell and toggle the value from 1 to 0 or from 0 to 1.

6. To overwrite the existing data file, choose Save.

7. To create a new data file with a different name, choose Save As and save as a different file name.

8. A message box pops up, displaying the new control register value. Click OK.

9. A confirmation message box informs you that Write to file was successful. Click OK.

10. Click Close to exit the Control Register 0 or Control Register 1 dialog box.

See Also

▶ “Using Programming File Utility” on page 447

### Editing the USERCODE in the Data File

The USERCODE Editor allows you to add information, such as serial code number, design code, or lot number, to the .jed, .isc, .rbt, or .bit file. This information is written to the USERCODE after the fuse map data in a JEDEC file. The signature must be in either decimal (0-9), ASCII, or hexadecimal (0-F) characters. In an ISC data file, this information is written in the user code data record in hexadecimal.

To use the USERCODE Editor:

1. Choose Tools > USERCODE Editor.

   The USERCODE Editor opens (see “USERCODE Editor Dialog Box” on page 453 for more information).

2. Using the (Browse) button, browse to the .jed, .isc, .rbt, or .bit file that you want to edit, select the file, and then click Open.

   The editor opens with the selected file.

3. Click Read.
If there is no data in the field, you will see a string of 8 Fs (Hexadecimal).

4. Edit the string as required. The USERCODE edit box displays the current bit position as you type. The signature must be in decimal (0-9), ASCII, or hexadecimal (0-F) characters.

5. Click **Save** or **Save As** to save the USERCODE data when finished.

6. Click **Yes** when prompted to overwrite the data file.

7. A confirmation message box informs you that the USERCODE write to file was successful. Click **OK**.

If you open the .jed file in a text editor, you will see the new USERCODE data added to the bottom of the file, as shown in the example below:

```
N User Electronic Signature
Data*U0000000000000000000000010011110011001100*
```

If you open the .isc data file in a text editor, you will see the new USERCODE data added to the end of the bottom of the file, as shown in the example below:

```
data usercode (initialize --LATTICE_NOTEDATA_WIDTH = 32--
LATTICE_NOTEADDRESS_WIDTH = 1(97D84A22) ),
```

**See Also**

- “Using Programming File Utility” on page 447
- “Running Programming File Utility” on page 447

---

**Securing the Device and Setting the Persistent Bit**

The Security and Persistent Fields Editor allows you to read both the security settings and the persistent bit of the bitstream file and to change the setting to ON or OFF.

**To read the settings of the security and persistent fields:**

1. Choose **Tools > Security and Persistent Fields Editor**.

   The Security and Persistent Fields Editor opens (see “Security and Persistent Fields Editor Dialog Box” on page 454 for more information).

2. Click the **Browse** button and select the desired bitstream data file.

3. Click **Read** to view the settings for Security and Persistent Bit and display them in the Status cells.

4. To change a setting from Disabled to Enabled or vice versa, click the status cell.

5. Do either of the following to save the changes:
To save the changes to the current data file, click **Save**. In the pop-up dialog box, click **Yes** to confirm that you want to overwrite the data file.

To save the changed data file to a different location or with a different file name, click **Save As**. In the Save As Data File dialog box, specify file name and location, and click **Save**.

6. A confirmation message box informs you that Write to file was successful. Click **OK**.

7. Click **Close** to exit the Security and Persistent Fields Editor.

**See Also**
- “Using Programming File Utility” on page 447
- “Running Programming File Utility” on page 447

---

**Programming File Utility Options**

This section lists the options available in Programming File Utility. Topics include:

- “Feature Row Editor Dialog Box” on page 452
- “Control Register0 Editor Dialog Box” on page 453
- "Control Register1 Editor Dialog Box" on page 453
- “USERCODE Editor Dialog Box” on page 453
- “Security and Persistent Fields Editor Dialog Box” on page 454

---

**Feature Row Editor Dialog Box**

The following options are available in the Feature Row Editor dialog box:

**Device**  Lists the project’s device. If a device is not displayed, use the browse button to locate the correct data file. Once a device is displayed, click **Read** to get the correct Max Bits/Digits information.

**Read**  Reads the data file values and displays them in the display field.

**Save**  Saves the data file.

**Save As**  saves the data file with another file name.

**Close**  Closes this dialog box.

**See Also**
- “Editing Feature Row Values” on page 449
- “Programming File Utility Options” on page 452
Control Register0 Editor Dialog Box
The following options are available in the Control Register0 Editor dialog box:

Device  Lists the project’s device. If a device is not displayed, use the browse button to locate the correct data file. Once a device is displayed, click Read to get the correct Max Bits/Digits information.

Read  Reads the data file values and displays them in the display field.

Save  Saves the data file.

Save As  saves the data file with another file name.

Close  Closes this dialog box.

See Also
► “Editing Control Register0 or Control Register1 Values” on page 449
► “Programming File Utility Options” on page 452

Control Register1 Editor Dialog Box
The following options are available in the Control Register1 Editor dialog box:

Device  Lists the project’s device. If a device is not displayed, use the browse button to locate the correct data file. Once a device is displayed, click Read to get the correct Max Bits/Digits information.

Read  Reads the data file values and displays them in the display field.

Save  Saves the data file.

Save As  saves the data file with another file name.

Close  Closes this dialog box.

See Also
► “Editing Control Register0 or Control Register1 Values” on page 449
► “Programming File Utility Options” on page 452

USERCODE Editor Dialog Box
The following options are available in the USERCODE Editor dialog box:

Device  Lists the project’s device. If a device is not displayed, use the browse button to locate the correct data file. Once a device is displayed, click Read to get the correct Max Bits/Digits information.
**USERCODE Format**  Allows you to display the USERCODE field in hexadecimal, decimal, or ASCII format.

**Usercode**  Allows you to specify a USERCODE value to override the current value in the data file.

**Read**  Reads the USERCODE field in the data file and displays it in the display field.

**Save**  Writes the value in the USERCODE display field and saves the data file.

**Save As**  Writes the value in the USERCODE display field allows you to save the data file with another file name.

**Close**  Closes this dialog box.

**See Also**
- “Editing the USERCODE in the Data File” on page 450
- “Programming File Utility Options” on page 452

---

**Security and Persistent Fields Editor Dialog Box**

The following options are available in the Security and Persistent Fields Editor dialog box:

**Device**  Lists the project’s device. If a device is not displayed, use the browse button to locate the correct data file. Once a device is displayed, click **Read** to get the correct chip value information.

**Read**  Reads the security and persistent field in the data file and displays it in the display field.

**Save**  Writes the value in the security and persistent field and saves the data file.

**Save As**  Writes the value in the security and persistent field and allows you to save the data file with another file name.

**Close**  Closes this dialog box.

**See Also**
- “Securing the Device and Setting the Persistent Bit” on page 451
- “Programming File Utility Options” on page 452
The final stage of developing a design is testing it on the actual Field Programmable Gate Arrays (FPGA) on either a test board or in your system. Lattice Semiconductor offers the following tool for debugging both the hardware aspect of the design and—if you are using the System Builder microprocessor—the software aspect:

- **Reveal Analyzer** to check for and to analyze specific events on signals

Before you start debugging, Reveal Analyzer requires that a special interface module be added to the design. After it’s been added, rerun the design implementation process (Synthesize Design, Map Design, Place & Route Design) and generate bitstream data file to program the FPGA. The tools can share the same ispDOWNLOAD cable and JTAG port that Programmer uses to download the design.

### About Reveal Logic Analysis

One of the most common activities in debugging is logic analysis. To do this, use Reveal Inserter and Reveal Analyzer. You can use both with all supported FPGA devices.

Reveal continuously monitors signals within the FPGA for specific conditions, which can range from simple to quite complex. When the trigger condition occurs, Reveal can save signal values preceding, during, and following the event for analysis, including a waveform presentation. The data can be saved to a value change dump file (.vcd), which can be used with tools such as ModelSim, or to an ASCII tabular format that can be used with tools such as Excel.

Before running Reveal Analyzer, use Reveal Inserter to add Reveal modules to your design. In these modules, specify the signals to monitor, define the trigger conditions, and other options. Reveal supports multiple logic analyzer
cores using hard/soft JTAG interface. You can have up to 15 modules, typically one for each clock region of interest. When the modules are set up, regenerate the bitstream data file to program the FPGA.

A feature is enabling an added module called Reveal Controller. This new controller module enables:

- Access to the control and status registers of the hard IPs such as I2CFIFO, PLL, PCIe, CDR, and DPHY, via the LMMI (Lattice Memory Mapped Interface) slave interface.
- Virtual switches and LEDs emulating on-board switches and LEDs to control and monitor a user design. Up to 32 switches and 32 LEDs are supported.
- Read/write access to a bank of user registers and/or initialize memory post-configuration.

The main purpose is narrowing down to problem areas during debug cycles using a divide and conquer method into many small functional blocks to control and monitor the status of each block.

Before starting a test run, set up Reveal Analyzer. This includes setting a number of options, including modifying trigger conditions and customizing the waveform display. You can save these settings for later use. During and after a test run, view the incoming data in Reveal's LA Waveform view. You can also save the data to a .vcd or .txt file to analyze with other tools.

**NOTE**

Reveal now supports IEEE-P1735 encryption. If this encryption is applied to a design, the design tree will allow only the visible ports and signals that are not encrypted to be inserted by the Reveal Inserter for triggering purposes.

**See Also**

- *Lattice Radiant Software User Guide*

### Using the Reveal Example Project

For hands-on experience using the Reveal tools, try the following example project while studying the online help.

The example is a simple 3-bit counter coded in Verilog and already has a Reveal module inserted. It also already has trace data that can be viewed in Reveal Analyzer. A test board is not required to open the Reveal tools or to view the existing trace data. To actually run Reveal Analyzer to collect new data, however, you'll need a test board.

**To start the Reveal example project:**

1. Choose **File > Open > Design Example.**

   The Open Example dialog box opens.
2. Click **counter_reveal**.
3. Browse to select the location.
4. Click **OK**.
   The count design project opens. At this point, you can open Reveal Inserter.

   **Note**
  若 you want to preserve the original example for future experiments, choose **File > Archive Project** now.

5. In the Process bar on top, double-click **Export Files** to implement the design.
   If you want to use the example project with a test board, change the device type to match the board by double-clicking the device in the File List view and running the design implementation process.

---

**Creating Reveal Modules**

Create the modules for Reveal logic analysis with Reveal Inserter. The process consists of identifying trace signals, which are the signals that you want to analyze, defining a trigger signal, which is the event you want to analyze, and setting a few options. Then you insert the modules into your design and implement it.

With Reveal Inserter, it is easy to set up simple triggering conditions, as well as extremely complex ones. Triggering in Reveal is based on the trigger unit and the trigger expression. A trigger unit is used to compare signals to a value, and a trigger expression is used to combine trigger units to form a trigger signal.

Currently, you can only have one module due to the soft JTAG core. Each Reveal Inserter project can include up to 15 modules. Each module has its own settings, trace signals, and trigger signal. In many cases, a single module is all that is required to debug a design. However, in designs with multiple clock regions, it may be necessary to sample different clock regions at the same time. For those types of designs, it is recommended that you use multiple modules, one for each clock region.

Take some time to plan the logic analysis, as Reveal modules can take a considerable amount of FPGA resources and creating the modules can take a significant amount of time. Find out how many EBRs and slices are still available, and consider adding all the trace signals and trigger events that you might want to analyze. The trigger signals can be modified in Reveal Analyzer while you’re running tests if the necessary signals and capacity have been specified in the modules.
About Reveal Inserter

Reveal Inserter has several views to help you manage the Reveal modules, find signals, and set up trace and trigger signals.

Dataset  Dataset provides a list of all the modules in the Reveal project. To work on the trace and trigger signals of a module, select the module in the Dataset view. You can also add, remove, or rename modules by right-clicking a module name and choosing from the pulldown menu. See “Managing the Modules in a Project” on page 459.

Design Tree  Design Tree provides a list of all the buses and signals in the design. You can select signals to trace and to trigger on by dragging them from the Design Tree view. To find signals, use the Signal Search function. See “Searching for Signals” on page 460.

Design Tree also keeps track of how signals are being used. See “Viewing Signals in Design Tree” on page 459.

Trigger Output  Trigger Output provides a list of trigger signals available from other modules. These signals can also be traced and triggered on by the current logic analyzer module. Select these signals by dragging them from the Trigger Output view. To make a trigger available in the Trigger Output view, see “Trigger Out” on page 480.

Trace Signal Setup  Trace Signal Setup is where you assemble and organize the list of signals to be traced by the current logic analyzer module. Select signals by dragging them from the Design Tree and Trigger Output views. You can rearrange the signals in the list and organize them into groups. This view also provides several options for the trace operation. See “Setting Up Trace Signals” on page 464.

Trigger Signal Setup  Trigger Signal Setup is where you assemble the trigger for the current logic analyzer module. The trigger is the event that tells the module to save the data from the trace signals. Triggers are built up from “trigger units,” collections of signals compared to specific values, and “trigger expressions,” logical and sequential combinations of trigger units. See:

- “About Trigger Signals” on page 468
- “Setting Up Trigger Units” on page 470
- “Setting Up Trigger Expressions” on page 473
- “Setting Trigger Options” on page 480

Controller Setup  Reveal Controller Setup is where you setup all your Virtual (Configuring) Switch/LED Settings, User Registers, and Hard IP selections. See:

- “Setting Up Virtual Switch/LED Settings” on page 481
- “Configuring User Register Setup” on page 481
- “Configuring Hard IP Setup” on page 482
Managing the Modules in a Project

Each Reveal Inserter project can include up to 15 modules and are listed in the Dataset view. You can add, rename, and remove modules in the Dataset view.

To add a module:
1. Choose Debug > Add New Core.
2. From the submenu, choose a module type.
   Reveal Inserter adds a new module in the Dataset pane.

To rename a module:
1. Double-click the module name in the Dataset pane.
2. Type the new name of the module over the old name. The module name must:
   - Begin with a letter.
   - Consist of letters, numbers, and underscores (_).
   - Be different from all other modules in the Reveal project.
   - Be different from all other modules and instances in the design.
3. Press Enter.

To remove a module:
1. Select the module in the Dataset pane.
2. Press Delete.

Viewing Signals in Design Tree

The Design Tree pane shows the hierarchy of the whole design with all of the signals and buses. From the Design Tree pane, you can select signals and drag them to the Trace Signal Setup and Trigger Signal Setup views. To help you find signals, Design Tree has a search function, explained in “Searching for Signals” on page 460.

The Design Tree pane also gives some information about the signals and how they are being used in the Reveal module. If you select a signal in the hierarchy, the Output tab displays information about it. If a signal is used in the Reveal module, it appears in the Design Tree pane in bold, followed by a symbol showing how the signal is being used:

- @Tc: trace signal
- @Tg: trigger unit signal
- @C: control signal (sample clock or sample enable)
- @Mx: mixed bus. Some of the signals are being used one way and some are not or are being used in another way.
To view all signals in the design hierarchy:

- Right-click on the design name in the Design Tree pane and choose Expand All from the pop-up menu.

To view the buses, ports, top-level signals, and top level of the hierarchy:

- Right-click on the design name in the Design Tree pane and choose Collapse All from the pop-up menu.

Note that if a design, modules or instances are encrypted with the IEEE-P1735 encryption standard, a user will be able to see either only the ports and signals or only the ports of a module or no module altogether depending on where the encryption was placed.

**Searching for Signals**

You can find signals in the Design Tree pane with a text search that includes wild card characters.

**To search for signals:**

1. In the Signal Search box in the Design Tree pane, type the full name of the signal or part of the name with wild cards (see the following table). The search is case-insensitive. The bit range of a bus, such as the “[7:0]” in cout[7:0] is not part of the name and should not be included in the search. Instead, just search for “cout”.

<table>
<thead>
<tr>
<th>Wildcard</th>
<th>Finds</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>?</td>
<td>Any single character</td>
<td>“?out” finds aout, bout, and cout.</td>
</tr>
<tr>
<td>*</td>
<td>A sequence of any number of characters</td>
<td>“c*” finds cin and cout.</td>
</tr>
<tr>
<td>[&lt;string&gt;]</td>
<td>Any character in the string</td>
<td>“[ab]out” finds aout and bout.</td>
</tr>
<tr>
<td>[^&lt;string&gt;]</td>
<td>Any character except those in the string</td>
<td>“[^ab]out” finds cout but not aout or bout.</td>
</tr>
<tr>
<td>[^&lt;c1&gt;-&lt;c2&gt;]</td>
<td>Any character except those in the range from &lt;c1&gt; through &lt;c2&gt;</td>
<td>“cout:[^3-7]” finds cout:0, cout:1, and cout:2.</td>
</tr>
</tbody>
</table>

2. Click **Search**.

   If only one signal is found, it is highlighted it in the Design Tree pane.

   If more than one signal is found, the Search Result dialog box opens with a list of the signals found.
3. Select the desired signals and click **OK**.
   Click on a signal to select it. To select more than one signal, control-click on each one. To select all signals and buses in a range, click on the first signal to select and Shift-click on the last one.
   The selected signals are highlighted in the Design Tree pane.

**See Also** ➤ “Viewing Signals in Design Tree” on page 459

**Checking the Design Rules**
Use the Design Rule Check tool to verify that your Reveal project is not violating any design rules, such as proper module names, number of signals used, and required options set. The design rule check also tells you the total number of EBRs and slices needed for the project.

**To check the Reveal module settings:**
- Choose **Debug > Design Rule Check**.
  The results of the rule check are displayed in the Output tab.

**Saving a Project**
Reveal Inserter automatically performs a design rule check whenever a project is saved. The results are shown in the Output tab.

**Note**
Reveal Inserter generates a new “signature,” or tracking mechanism, whenever a Reveal project is saved. Reveal Analyzer reads this signature to ensure that the FPGA has been programmed with the latest Reveal project. If you save the project without re-programming the FPGA, Reveal Analyzer will issue an error message, even if the Reveal project was not changed.

**To save the project settings in the current directory:**
- Choose **File > Save <filename>**.

**To save the project settings in another directory:**
- Choose **File > Save <filename> As**. In the Save Reveal Project dialog box, browse to the desired directory, enter the name of the new .rvl file name in the File Name box, and click **Save**.

**See Also**
- “Setting Up Virtual Switch/LED Settings” on page 481

**Limitations**
Reveal Inserter has the following limitations:
Unsupported VHDL, Verilog and System Verilog Features in Reveal Inserter  The following features are valid in the VHDL, Verilog and System Verilog languages but not supported in Reveal Inserter:

- Array types of two dimensions or more are not shown in the port or node section.
- Undeclared wires attached to instantiated component instances are not shown in the hierarchical design tree. You must declare these wires explicitly if you want to trace or trigger with them.
- Variables used in conditional statements like if-then-else statements are not available for tracing and triggering.
- Variables used in selection statements like the case statement are not available for tracing and triggering.
- If function calls are used in the array declaration, the actual size of the array is unknown to Reveal Inserter.
- Entity and architecture of the same design cannot be in different files.
- In Verilog, you must declare variables at the beginning of a module body to avoid obtaining different results from various synthesis tools.
- In VHDL, you must declare synthesis attributes within an entity, and not within an architecture, to avoid obtaining different results from various synthesis tools.
- Signals used in VHDL "generate" statements are not available for tracing and triggering.
- Signals that are VHDL user-defined enumerated types, integer type, or Boolean type are not available for tracing and triggering.
- Some signals in a System Verilog design appear in the signal hierarchy but are not available for triggering or tracing. These signals include:
  - Array types of two dimensions or more are not shown in the port or node section
  - Signals that are user defined enumerated types, integer type, byte/shortint/int/longint type
  - Signals that belong to typedef, interface, struct and union

Syn_keep and Preserve_signal Attributes  In VHDL, always define the syn_keep and preserve_signal attributes as Boolean types when you declare them in your design. Synplify defines them as Boolean types, and Reveal Inserter will issue an error message if you define them as strings.

Signals Implemented as Hard Routes  Signals that are implemented as hard routes in the FPGA instead of using the routing fabric are not available for tracing or triggering. Examples are connections to IB and OB components. Many common hard routes are automatically shown as unavailable in Reveal Inserter, but some are not. If you select a signal for tracing or triggering that is implemented as a hard route, an error will occur during the synthesis, mapping, placement, or routing steps.

Dangling or Unconnected Nets  Dangling, or unconnected, nets in Verilog, System Verilog or VHDL code are available for use with Reveal Inserter.
Synthesis Parameters

VHDL generics for synthesis must be added via HDL Parameters field in Project Properties. The current version does not support adding parameters via Command Line Options field in Synthesis Strategy setting.

Creating Logic Analysis Modules

The major steps in creating a Logic Analysis module are shown below.

The design must be successfully synthesized before running Reveal Inserter.

Note

Reveal Inserter has limitations and requirements in how it works with the design. See “Limitations” on page 461 and “Creating Logic Analysis Modules” on page 463.

To create a Logic Analyzer module:

1. After opening the design project, choose Tools > Reveal Inserter.

   Reveal Inserter launches with the active Reveal project (.rvl) file open. If there are no existing projects, Reveal Inserter creates one.

   Reveal Inserter also parses and statically elaborates the design. In some cases, code that was successfully synthesized is flagged as having an error. In these cases, Reveal Inserter is interpreting the HDL code more strictly than the chosen synthesis tool.

   To correct this problem, see the reveal_error.log file in the implementation directory. With the help of this file, locate and correct the problem in the code. Then synthesize the design and open Reveal Inserter again.

2. Select a module in the Dataset view. If you want to add another module to the project, choose Debug > Add New Core > Add Logic Analyzer. See also “Managing the Modules in a Project” on page 459.

3. Set up the trace signals as desired. See “Setting Up Trace Signals” on page 464.

4. Create trigger units, which are collections of signals and the values that are part of causing a trigger signal. See “Setting Up Trigger Units” on page 470.

5. Create trigger expressions, which are logical combinations of trigger units. See “Setting Up Trigger Expressions” on page 473.


7. Once you have set up all of your modules, add them to the design project by choosing Debug > Insert Debug and running the design implementation process. See “Inserting the Reveal Modules” on page 482.

To create a Reveal Controller module:

1. After opening the design project, choose Tools > Reveal Inserter.
Reveal Inserter launches with the active Reveal project (.rvl) file open. If there are no existing projects, Reveal Inserter creates one.

Reveal Inserter also parses and statically elaborates the design. In some cases, code that was successfully synthesized is flagged as having an error. In these cases, Reveal Inserter is interpreting the HDL code more strictly than the chosen synthesis tool.

To correct this problem, see the reveal_error.log file in the implementation directory. With the help of this file, locate and correct the problem in the code. Then synthesize the design and open Reveal Inserter again.

2. Click **Add Core > Add Controller** a module in the Dataset view or you can add a controller by choosing **Debug > Add New Core > Add Controller**. Note that only one Reveal Controller can be added to a project. See also “Managing the Modules in a Project” on page 459.

3. On the bottom tab, select Virtual Switch Switch & LED Setup tab to set up the Virtual Switch/LED Setting as desired. In the Datasets pane, a Signal Search box is located at the bottom for searching signals. Individual bits or buses can be dragged into the LED List pane. The Address Width field on the top of the pane will adjust accordingly. See “Setting Up Virtual Switch/LED Settings” on page 481.

4. On the bottom pane, select User Register Setup tab to setup the user registers. See “Configuring User Register Setup” on page 481.

5. On the bottom pane, select the Hard IP Setup tab to setup IP debug. See “Configuring Hard IP Setup” on page 482.

6. Once you have set up of all your modules, add them to the design project by choosing **Debug > Insert Debug** and running the design implementation process. See “Inserting the Reveal Modules” on page 482.

**Setting Up Trace Signals**

Setting up the trace signals for a module consists of selecting the signals and buses to watch and dragging them into the Trace Signal Setup tab. You can have up to 512 trace signals in a module.

There is no limit to the bus organization of the design, so you can organize the signals according to how you want to view the data. Order them from top to bottom and organize them into buses, or rearrange the trace signals into your own organization of trace buses. You can manage them using the Debug menu or by right-clicking selected signals.

**To set up trace signals:**

1. Click the **Trace Signal Setup** tab.
2. Select a module in the Dataset view.
3. Select signals in the Design Tree and Trigger Output views and drag the signals to the desired position in the Trace Signal Setup tab. For help finding signals, see “Searching for Signals” on page 460.
Check the value to the right of the Implementation box to see how adding trace signals affects the consumption of FPGA resources.

4. You can further organize the signals in the Trace Signal Setup tab by ungrouping buses into individual signals and grouping signals into new buses.

   - To break a bus into individual signals, select the bus and choose Debug > UnGroup Trace Bus.
   - To create a new trace bus, select the desired signals and buses and choose Debug > Group Trace Data. Double-click the new bus and type in the desired name.

You can also drag signals and buses into and out of other buses.

5. To see what happens in the signals that define the trigger units, select Include trigger signals in trace data at the bottom of the Trace Signal Setup tab.

   A bus named “Trigger Signals” appears at the top of your list of trace signals. For details, see “Include Trigger Signals in Trace Data” on page 465.

6. Set the trace options. There are several options that enhance the trace signals or control how data is sampled:

   - “Sample Clock” on page 466
   - “Sample Enable” on page 466
   - “Buffer Depth” on page 467
   - “Timestamp” on page 467
   - “Implementation” on page 468
   - “Data Capture Mode” on page 468

See Also ➤ “Viewing Signals in Design Tree” on page 459

Include Trigger Signals in Trace Data

In order to monitor what happens on the signals that make up a trigger, you can add all signals used in the trigger units to the trace signals.

This option creates a bus named “Trigger Signals” at the top of your list of trace signals. Trigger Signals contains buses named for each trigger unit and contains the buses and signals used in the trigger units. The Trigger Signals bus cannot be moved or modified in any way.

To add the trigger signals to the trace signals:

   - Select Include trigger signals in trace data.
Sample Clock
The sample clock determines when the trace signals are sampled. Reveal Analyzer samples the trace signals once every clock cycle on the clock’s rising edge.

To set the sample clock signal:
- Find the signal in the Design Tree view and drag it to the Sample Clock box of the Trace Signal Setup tab.

Note
On the board, make sure that the sample clock frequency is at least that of the JTAG clock. If the sample clock speed is too slow, you will be unable to complete capturing data with Reveal Analyzer.

The sample clock frequency should be no more than 200 MHz.

See Also  “Searching for Signals” on page 460

Sample Enable
The sample enable is a signal that can be used to turn data capture on and off. Normally, data is captured for every sample clock cycle during a specified number of cycles. With sample enable, data capture only happens when the sample enable signal is active. Use sample enable to reduce the size of the trace buffer when there are stretches of data of no interest that are associated with a single signal.

An example is a design that contains different sections, with some sections only working during certain clock phases. The design uses a master clock and generates different signals for the phases. You can use one of the phase signals as the sample enable.

If the trigger occurs while the sample enable is inactive, Reveal Analyzer cannot accurately calculate the trigger point. Instead of showing the precise trigger point, Reveal Analyzer shows a trigger region that spans five clock cycles. Reveal Analyzer can guarantee that the trigger occurs in this region, but it cannot determine during which clock cycle the trigger occurs.

To set the sample enable:
1. Select Sample Enable.
2. Find the signal in the Design Tree view and drag it to the box in the Sample Enable section of the Trace Signal Setup tab.
3. In the box to the right of the signal name box, choose whether the signal is:
   - Active High. Data can be captured when the sample enable is high.
   - Active Low. Data can be captured when the sample enable is low.

See Also  “Searching for Signals” on page 460
Buffer Depth

The buffer depth specifies the size of the trace memory buffer as the maximum number of samples that can be stored. The buffer should be deep enough to hold enough samples, before and after the trigger, for your analysis multiplied by the number of trigger events that you want to see in one test run. Available values are powers of two from 16 to 65,536.

For example, if you want 20 samples from each of five events, choose a buffer depth of at least 128.

To set the buffer depth:

1. Determine the maximum number of samples for your test run. Be generous to avoid re-implementing the design to get a larger buffer.
2. In the Buffer Depth box, choose a value that is at least as large as the desired number of samples.

Check the value to the right of the Implementation box to see how changing the buffer depth affects the consumption of FPGA resources.

Timestamp

The timestamp is a count of sample clock cycles from the beginning of a test run. This is different from the sample index that Reveal Analyzer automatically supplies. The sample index only provides a count of samples within each trigger's data set. The timestamp continues counting between triggers and when the sample enable signal blocks data capture.

However, unlike the sample index, the timestamp contains extra data in each sample and requires a larger trace buffer.

Use the timestamp when you want to know how long the test ran before triggering or how long the sample enable signal blocked data capture. The timestamp can also help associate triggers with external events or with data from another Reveal module using the same sample clock.

To add timestamps to the trace samples:

1. Select Timestamp.
2. Determine the number of sample clock cycles in the longest test run you want to do.
3. In the pulldown menu next to “Timestamp,” select the size of the timestamp in bits. Choose the smallest value that can hold the count for the desired number of sample clock cycles.
   
   For example, if you want to run a test for 50 thousand cycles, choose 16 bits.

Check the value to the right of the Implementation box to see how changing the timestamp size affects the consumption of FPGA resources.
**Implementation**

The implementation specifies what kind of RAM to use for the Reveal module. Normally EBR would be selected, but distributed RAM can be used if you are short of EBR.

To set the implementation:

1. In the Implementation box, choose a kind of RAM:
   - EBR (embedded block RAM)
   - DistRAM (distributed RAM)

The number of EBR or slices needed is shown on the screen. This value changes as you add or remove trace signals, or change the buffer depth or timestamp size.

**Data Capture Mode**

The data capture mode specifies whether Reveal Analyzer can look for one trigger or multiple triggers in a test run. Multiple Trigger Capture mode provides the greatest flexibility during test runs. Single Trigger Capture mode slightly reduces the amount of FPGA resources needed.

To set the data capture mode:

1. In the Data Capture Mode section, select one of the following:
   - **Single Trigger Capture.** Reveal Analyzer captures the data for only one trigger.
   - **Multiple Trigger Capture.** Reveal Analyzer captures the data for multiple triggers.

2. If you select Multiple Trigger Capture, choose the “Minimum samples per trigger.” The number of samples collected for each trigger is set in Reveal Analyzer but cannot be smaller than this value.

**About Trigger Signals**

Most of the trigger features need to be set up initially in Reveal Inserter but many of them can be modified in Reveal Analyzer while testing the design. See Table 145.

Changes in Reveal Inserter means the design has to be re-implemented (synthesis, map, place, and route) and reloaded into the FPGA. So it is worthwhile to be generous in defining your trigger units, trigger expressions, and other options. Think of setting up a trigger signal as creating capacity and
access to signals and memory. Try to give yourself capacity to define all the triggering events that you might want to analyze later on.

Table 145: Where Trigger Features Can Be Changed

<table>
<thead>
<tr>
<th>Feature</th>
<th>Reveal Inserter</th>
<th>Reveal Analyzer</th>
</tr>
</thead>
<tbody>
<tr>
<td>Trigger Units</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Add</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Signals</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Operator</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Radix</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Value</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Trigger Expressions</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Add</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Remove</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Name</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Expression</td>
<td></td>
<td></td>
</tr>
<tr>
<td>RAM type</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Maximum sequence depth</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Maximum event counter</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Multiple Trigger Capture</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Make available</td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Number of samples per trigger</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Number of triggers</td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Other Features</td>
<td></td>
<td></td>
</tr>
<tr>
<td>AND All versus OR All</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Final event counter</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Trace buffer depth</td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Timestamp</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Trigger position</td>
<td></td>
<td>✓</td>
</tr>
</tbody>
</table>

See Also

- “Setting Up Trigger Units” on page 470
- “Setting Up Trigger Expressions” on page 473
- “Setting Trigger Options” on page 480
- “Setting Up the Trigger Signals” on page 491
Setting Up Trigger Units

The trigger unit is used to compare a number of signals to a value. A number of different operators are available for comparison and can be dynamically changed during analysis, along with the comparison value and the trigger unit name.

Each trigger unit can have up to 256 signals. Since there are 16 allowable trigger units, each module can have a maximum of 4096 trigger signals.

Try to minimize the number of trigger units in a module. The more trigger units there are, the longer it takes for Reveal Analyzer to configure the module at the beginning of a test run. More than eight trigger units may cause a delay of 30 seconds or more; 16 trigger units many cause a delay of 5 minutes.

Before you start setting up the trigger units, set the Default Trigger Radix. This option is in the Trigger Unit section of the Trigger Signal Setup tab. The default trigger radix is applied automatically to any new trigger units that you create but does not affect the radix of any existing trigger units. You can always change the radix of any trigger unit at any time.

To set up a trigger unit:

1. To add a new trigger unit, click Add in the Trigger Unit section of the Trigger Signal Setup tab.

2. Specify the signals in the trigger unit by using one of following methods:
   - Drag and drop signals from the Design Tree and Trigger Output views to the Signals column. For more information on using the Design Tree view, see “Viewing Signals in Design Tree” on page 459 and “Searching for Signals” on page 460.
   - Double-click in the Signals column to open the TU Signals dialog box. See “Selecting and Ordering Trigger Signals” on page 471.

3. To change the order of the signals or to remove them, double-click in the Signals column.
   The TU Signals dialog box opens. See “Selecting and Ordering Trigger Signals” on page 471.

4. Click in the Operator column and choose an operator from the pulldown menu. See “About Trigger Unit Operators” on page 471.
   Both the operator type and the trigger unit value can be changed in Reveal Analyzer during hardware debugging.

5. If you want to change the radix of the Value column, click in the Radix column and choose a radix from the pulldown menu. The menu includes token sets whose bit width matches the trigger unit’s signals.
   Token sets are text labels for values that might appear on trace buses. You can create and apply token sets in Reveal Analyzer. See “Creating Token Sets” on page 499.

6. Enter the comparison value in the Value column. The form of the value must match the specified radix. If you’ve selected a token set in the Radix
column, a pulldown menu opens in the Value column listing the tokens in
the token set.
You can use "x" for a don’t-care value if you selected binary, octal, or
hexadecimal in the Radix column and if you selected ==, !=, or serial
compare in the Operator column.

Selecting and Ordering Trigger Signals
In the Trigger Unit section of the Trigger Signal Setup view, double-click in the
Signals column. The TU Signals dialog box opens.

To select and order trigger unit signals:
1. In the left side of the TU Signals dialog box, select signals that you want to
use in the trigger unit. Click on a signal to select it. To select more than
one signal, control-click on each one. To select all signals and buses in a
range, click on the first signal to select and Shift-click on the last one.
2. Click > to add them to the box on the right.
3. To remove signals from the trigger unit, select them in the right box and
click <.
4. Organize the signals by selecting one and clicking the up or down arrow
until the signal is in its desired position. Continue until all the signals are in
the desired order from least significant bit (LSB) down to the most
significant bit (MSB).
5. Click OK.

About Trigger Unit Operators
Most of the trigger unit operators use standard logical comparisons between
the current value of the combined signals of the trigger unit and a specified
value.

Operators can be changed in Reveal Analyzer, with the exception of "serial
compare".

Standard Logical Operators Reveal includes the following operators:
- == equal to
- != not equal to
- > greater than
- >= greater than or equal to
- < less than
- <= less than or equal to

Rising-Edge and Falling-Edge Operators The "rising edge" and "falling
dge" operators check for change in the signal value, not the value itself. So
the trigger unit’s specified value is a bit mask showing which signals should have a rising or falling edge.

- A 1 means “look for the edge;”
- A 0 means “ignore this bit.” A multiple-bit value is true if any of the specified bits has the edge.

For example, consider a trigger unit defined as cout[3:0], rising edge, 1110. This trigger unit is true only when cout[3], cout[2], or cout[1] have a rising edge. What happens on cout[0] does not matter.

- 0000 > 1110
  True because cout[3], cout[2], and cout[1] rose.
- 0000 > 1111
  True for the same reason. It does not matter whether cout[0] rises or not.
- 0000 > 0100
  True because a rising edge on any of the specified bits is sufficient.
- 1000 > 1000
  False because cout[3] is high, but did not rise.

**Serial Compare** The “serial compare” operator checks for a series of values on a single signal. For example, if a trigger unit’s specified value is 1011, the “serial compare” operator looks for a 1 on the first clock, a 0 on the second clock, a 1 on the third clock, and a 1 on the last clock. Only after those four conditions are met in the four clock cycles is the trigger unit true.

Serial compare is available only when a single signal is listed in the trigger unit’s signal list. The radix is automatically binary.

You can only set the serial compare operator in Reveal Inserter. You cannot change or select it in Reveal Analyzer as you can the other operators.

**Managing Trigger Units**
You can add and remove trigger units only in Reveal Inserter. You cannot add them in Reveal Analyzer.

**To add a trigger unit:**
- To add a new trigger unit, click Add in the Trigger Unit section of the Trigger Signal Setup tab.

**To rename a trigger unit:**
- Click in the Name column of the Trigger Unit section of the Trigger Signal Setup tab and type in the new name. The name can consist of letters, numbers, and underscores. The first character must be either an underscore or a letter.
To remove a trigger unit:
1. In the Trigger Unit section of the Trigger Signal Setup tab, click in any box in the line representing the trigger unit that you want to remove.
2. Click Remove.

See Also  "Setting Up Trigger Units" on page 470

Setting Up Trigger Expressions
You can set up the initial trigger expressions in Reveal Inserter and change them and their names in Reveal Analyzer. You can also enable or disable trigger expressions in Reveal Analyzer. However, you cannot change the maximum sequence depth or the maximum event counter of the trigger expressions in Reveal Analyzer.

To set up a trigger expression:
1. Click Add in the Trigger Expression section of the Trigger Signal Setup tab to add a new trigger expression.
2. Enter the trigger expression in the Expression column. See “Trigger Expression Syntax” on page 474.

Reveal Inserter checks the syntax and displays the syntax in red font if it is erroneous.

Both the trigger units and operators associated with a trigger expression can be changed in Reveal Analyzer during hardware debugging.

3. Click in the Ram Type column and choose whether the trigger expression is to be implemented with EBR (embedded block RAM) or slices (distributed RAM). The menu also shows how many of each resource is needed. Choose EBR if available. If short of EBR, choose slices.

4. Click in the Max Sequence Depth column and choose the maximum number of sequences, or trigger units connected by THEN operators, that can be used in the trigger expression.

The maximum sequence depth must be at least as large as the number in the Sequence Depth column, which shows the number of sequences currently used by the trigger expression. Increasing the maximum sequence depth allows you to use more sequences if you change the trigger expression in Reveal Analyzer, but it also uses more FPGA resources. Consider the largest chain of sequences you might want to use in your test and choose a value at least that large. Reveal supports up to 16 sequence levels.

The Max Sequence Depth value is set statically in Reveal Inserter and cannot be changed in Reveal Analyzer.

5. Click in the Max Event Counter box and choose the maximum size of the count in the trigger expression (the count is how many times a sequence must occur before a THEN statement).

The Max Event Counter value must be at least as large as the largest counter value used in the trigger expression. Increasing the size of the
event counter allows you to use larger counts if you change the trigger expression in Reveal Analyzer, but it also uses more FPGA resources. Consider the largest count you might want to use in your test and choose a value at least that large. The maximum is 65,536.

The Max Event Counter setting can only be changed it in Reveal Inserter.

See Also  ►“Example Trigger Expressions” on page 477

Trigger Expression Syntax
Trigger expressions are combinations of trigger units. Trigger units can be combined in combinatorial, sequential, and mixed combinatorial and sequential patterns. A trigger expression can be dynamically changed at any time. Each core supports up to 16 trigger expressions that can be dynamically enabled or disabled in Reveal Analyzer. Trigger expressions support AND, OR, XOR, NOT, parentheses (for grouping), THEN, NEXT, # (count), and ## (consecutive count) operators. Each part of a trigger expression, called a sequence, can also be required to be valid a number of times before continuing to the next sequence in the trigger expression.

Detailed Trigger Expression Syntax  Trigger expressions in both Reveal Inserter and Reveal Analyzer use the same syntax.

Operators  You can use the following operators to connect trigger units:
► & (AND) – Combines trigger units using an AND operator.
► | (OR) – Combines trigger units using an OR operator.
► ^ (XOR) – Combines trigger units using a XOR operator.
► ! (NOT) – Combines a trigger unit with a NOT operator.
► Parentheses – Groups and orders trigger units.
► THEN – Creates a sequence of wait conditions. For example, the following statement:
  TU1 THEN TU2
  means “wait for TU1 to be true, then wait for TU2 to be true.”
  The following expression:
  (TU1 & TU2) THEN TU3
  means “wait for TU1 and TU2 to be true, then wait for TU3 to be true.”
  Reveal supports up to 16 sequence levels.
  See “Sequences and Counters” on page 475 for more information on THEN statements.
► NEXT – Creates a sequence of wait conditions similar to THEN, except the second trigger unit must come immediately after the first. That is, the second trigger unit must occur in the next clock cycle after the first trigger unit. See “Sequences and Counters” on page 475 for more information on NEXT statements.
Creating Reveal Modules

- # (count) – Inserts a counter into a sequence. See “Sequences and Counters” on page 475 for information on counters.

- ## (consecutive count) – Inserts a counter into a sequence similar to Like # (count) except that the trigger units must come in consecutive clock cycles. That is, one trigger unit immediately after another with no delay between them. See “Sequences and Counters” on page 475 for information on counters.

Case Sensitivity Trigger expressions are case-insensitive.

Spaces You can use spaces anywhere in a trigger expression.

Sequences and Counters Sequences are sequential states connected by THEN or NEXT operators. A counter counts how many times a state must occur before a THEN or NEXT statement or the end of the sequence. The maximum value of this count is determined by the Max Event Counter value. This value must be specified in Reveal Inserter and cannot be changed in Reveal Analyzer.

The following is an example of a trigger expression with a THEN operator:

TU1 THEN TU2

This trigger expression is interpreted as “wait for TU1 to be true, then wait for TU2 to be true.”

Here’s the same example written with a NEXT operator:

TU1 NEXT TU2

It is interpreted as “wait for TU1 to be true, then wait one clock cycle for TU2 to be true.” If TU2 is not true in the next clock cycle, the sequence fails and starts over, waiting for TU1 again.

The next trigger expression:

TU1 THEN TU2 #2

is interpreted as “wait for TU1 to be true, then wait for TU2 to be true for two sample clocks.” TU2 may be true on consecutive or non-consecutive sample clocks and still meet this condition.

The following statement:

TU1 ##5 THEN TU2

means that TU1 must occur for five consecutive sample clocks before TU2 is evaluated. If there are any extra delays between any of the five occurrences of TU1, the sequence fails and starts over.

The next expression:

(TU1 & TU2)#2 THEN TU3

means “wait for the second occurrence of TU1 and TU2 to be true, then wait for TU3.”
The last expression:

TU1 THEN (1)#200

means “wait for TU1 to be true, then wait for 200 sample clocks.” This expression is useful if you know that an event occurs a certain time after a condition.

You can only use one count (# or ##) operator per sequence. For example, the following statement is not valid, because it uses two counts in a sequence:

TU1 #5 & TU2 #2

Multiple count values are allowed for a single trigger expression, but only one per sequence. For two count operators to be valid in a trigger expression, the expression must contain at least one THEN or NEXT operator, as in the following example:

(TU1 & TU2) #5 THEN TU2 #2

This expression means “wait for TU1 and TU2 to be true for five sample clocks, then wait for TU2 to be true for two sample clocks.”

Also, the count operator must be applied to the entire sequence expression, as indicated by parentheses in the expression just given. The following is not allowed:

TU1 #5 & TU2 THEN TU2 #2

The count (#) operator cannot be used as part of a sequence following a NEXT operator. A consecutive count (##) operator may be used after a NEXT operator. The following is not allowed:

TU1 NEXT TU2 #2

The count (# or ##) operators can only be used in one of two areas:

- Immediately after a trigger unit or parentheses(). However, if the trigger unit is combined with another trigger unit without parentheses, a # cannot be used.

- After a closing parenthesis.

**Precedence** The symbols used in trigger expression syntax take the following precedence:

- Because it inserts a sequence, the THEN and NEXT operators always take the highest precedence in trigger expressions.

- Between THEN or NEXT statements, the order is defined by parentheses that you insert. For example, the following trigger expression:

  TU1 & (TU2|TU3)

  means “wait for either TU1 and TU2 or TU1 and TU3 to be true.”

If you do not place any parentheses in the trigger expression, precedence is left to right until a THEN or NEXT statement is reached.

For example, the following trigger expression:
TU1 & TU2 | TU3

is interpreted as “wait for TU1 & TU2 to be true or wait for TU3 to be true.”

- The precedence of the ^ operator is same as that of the & operator and the | operator.
- The logic negation operator (!) has a higher precedence than the ^ operator, & operator, or | operator, for example:

  !TU1 & TU2

means “not TU1 and TU2.”

- The # and ## operators have the same precedence as the ^ operator, & operator, or | operator. However, they can only be used in one of two areas:

  - Immediately after a trigger unit or trigger units combined in parentheses. However, if the trigger unit is combined with another trigger unit without parentheses, a # or ## operator cannot be used.

  Here is an example of correct syntax using the count (#) operator:

  TU1 #2 THEN TU3

  This statement means “wait for TU1 to be true for two sample clocks, then wait for TU3.”

  However, the following syntax is incorrect, because the count operator is applied to multiple trigger units combined without parentheses:

  TU1 & TU2#2 THEN TU3

- Use parentheses to combine multiple trigger units and then apply a count, as in the following example:

  (TU1 & TU2)#2 THEN TU3

  This statement means “wait for the combination of TU1 and TU2 to be true for two sample clocks, then wait for TU3.”

See Also

- “Example Trigger Expressions” on page 477

Example Trigger Expressions

The following is a series of examples that demonstrate the flexibility of trigger expressions.

Example 1: Simplest Trigger Expression-

TU1

This trigger expression is true, causing a trigger to occur when the TU1 trigger unit is matched. The value and operator for the trigger unit is defined in the trigger unit, not in the trigger expression.

Example 2: Combinatorial Trigger Expression-

TU1 & TU2 | TU3
This trigger expression is true when (TU1 and TU2) or TU3 are matched. If no precedence ordering is specified, the order is left to right.

**Example 3: Combinatorial Trigger Expression with Precedence Ordering**

TU1 & (TU2 | TU3)

This trigger expression gives different results than the previous one. In this case, the trigger expression is true if (TU1 and TU2) or (TU1 and TU3) are matched.

**Example 4: Simple Sequential Trigger Expression**

TU1 THEN TU2

This trigger expression looks for a match of TU1, then waits for a match on TU2 a minimum of one sample clock later. Since this expression uses a THEN statement, it is considered to have multiple sequences. The first sequence is “TU1,” since it must be matched first. The second sequence is “TU2,” because it is only checked for a match after the first sequence has been found. The “sequence depth” is therefore 2.

The sequence depth is an important concept to understand for trigger expressions. Since the debug logic is inserted into the design, logic must be used to support the required sequence depth. Matching the depth to the entered expression can be used to minimize the logic. However, if you try to define a trigger expression that has a greater sequence depth than is available in the FPGA, an error will prevent the trigger expression from running. The dynamic capabilities of the trigger expression can therefore be limited. To allow more flexibility, you can specify the maximum sequence depth when you set up the debug logic in Reveal Inserter. You can reserve more room for the trigger expression than is required for the trigger expression currently entered. If you specify multiple trigger expressions, each trigger expression can have its own maximum sequence depth.

**Example 5: Mixed Combinatorial and Sequential Trigger Expression**

TU1 & TU2 THEN TU3 THEN TU4 | TU5

This trigger expression only generates a trigger if (TU1 AND TU2) match, then TU3 matches, then (TU4 or TU5) match. You can set precedence for any sequence, but not across sequences. The expression (TU1 & TU2) | TU3 THEN TU4 is correct. The expression (TU1 & TU2 THEN TU3) | TU4 is invalid and is not allowed.

**Example 6: Sequential Trigger Expression with Sequence Counts**

The next trigger expression shows two new features: the sequence count and a true operator to count sample clocks:

(TU1 & TU2)#2 THEN TU3 THEN TU4#5 THEN (1)#200

This trigger expression means wait for (TU1 and TU2) to be:
1. True twice
2. Wait for TU3 to be true
3. Wait for TU4 to be true five times
4. Wait 200 sample clocks

The count (# followed by number) operator can only be applied to a whole sequence, not part of a sequence. When the count operator is used in a sequence, the count may or may not be contiguous. The always true operator (1) can be used to wait or delay for a number of contiguous sample clocks. It is useful to know an event you want to capture occurs a certain time after a condition, but you did not know the state of the trigger signals at that time.

However, there is a limitation on the maximum size of the counter. This depends on how much hardware is reserved for the sequence counter. When you define a trigger expression, the Max Event Counter setting in the Trigger Expression section of Reveal Inserter and Reveal Analyzer specifies how large a count value is allowed in the trigger expression. Each trigger expression can have a unique Max Event Counter setting.

See Also ▶ “Trigger Expression Syntax” on page 474

Managing Trigger Expressions

Trigger expressions are combinatorial or sequential equations of trigger units or both. Trigger expressions can be defined during insertion and changed in Reveal Analyzer. You can add up to 16 trigger expressions.

You can add trigger expressions in Reveal Inserter but not in Reveal Analyzer. You can dynamically enable or disable individual trigger expressions before triggering is activated during hardware debugging.

To add a trigger expression:

▶ In the Trigger Expression section of the Trigger Signal Setup tab, click Add.

To rename a trigger expression:

▶ Click in the Name column of the Trigger Expression section of the Trigger Signal Setup tab, and type in the new name. The name can consist of letters, numbers, and underscores. The first character must be either an underscore or a letter.

To remove a trigger expression:

1. Click in any box in the line representing the expression that you want to remove.
2. Click Remove.

See Also ▶ “Setting Up Trigger Expressions”
Setting Trigger Options

In addition to the trigger units and trigger expressions, there are two other aspects of triggers: the final event counter and enabling the trigger signal for other Reveal modules.

Event Counter

The final event counter allows a counter to be added to the final trigger of one or more trigger expressions. In order to use the final event counter during logic analysis, you must specify it during insertion, along with the maximum count allowed. The actual count used by the counter during triggering can be dynamically changed during logic analysis.

To add a counter to the output of the final trigger:

1. Select **Enable final trigger counter** in the lower left portion of the Trigger Signal Setup tab.

2. In the **Event Counter Value** pulldown menu, choose the maximum size of the count of all the trigger expression outputs combined. You can choose powers of two between 2 and 65536.

   Clearing the “Enable final trigger counter” option is equivalent to setting the counter to a value of 1.

   You can change the value of this parameter in Reveal Analyzer, but you cannot make the value bigger, so be sure to reserve enough space for the count that you think you will need.

Trigger Out

To support triggers based on multiple sample clocks, cross-triggering is available between different debug modules. Reveal provides an optional trigger-out signal in the triggering section for every module.

If a design has multiple modules, trigger-out signals from other modules are listed as an available signal. To use a trigger-out signal as an input to another module, you must specify it as a NET or BOTH type. The IO type is only used for connecting the trigger-out to an external I/O. Trigger-out signals are listed in the Trigger Output view.

To create a trigger output signal:

1. Select **Enable Trigger Out** from the bottom of the Trigger Signal Setup view.

2. In the Net pulldown menu, choose one of the following:
   - **IO** – Creates an I/O signal that can connect to an I/O pin.
   - **NET** – Creates a net signal that can be used in another module.
   - **BOTH** – Creates a signal that can be used on another module and can connect to an I/O pin.
3. If you want to change the signal’s name, double-click the desired name next to the Net menu and type in the new name.

4. In the Polarity menu, choose whether the signal is **Active High** or **Active Low**.

5. In the “Minimum pulse width” box, enter the minimum pulse width of the trigger output signal, measured in cycles of the sample clock. You can input any value of 0 or greater as the minimum pulse.

**Note**

For soft IP or single core devices, only IO is selectable in the NET pulldown menu.

### Setting Up Virtual Switch/LED Settings

The data pane consists of Virtual Switch/LED panels in which you drag and drop the RTL-defined switch and LED signals. A maximum of 32 bits can be selected for both Virtual Switch/LED signals.

**To set up Virtual Switch/LED signals:**

1. Select the top Controller core in the Dataset view. (There can only be one Controller core.)

2. Click the **Virtual Switch & LED Setup** tab.

3. Select signals in the Design Tree by expanding the hierarchy or doing a name search in the Signal Search text box and clicking on Search. For help finding signals, see “Searching for Signals” on page 460.

4. Drag the desired signals to the Virtual Switch or LED data panels to the right. The width of the signals will automatically update between 1-32 entries at the top.

5. Beside the header title, Virtual Switch/LED Setting, there is a check box in which the Controller function for Virtual Switch/LED can be enabled/disabled.

**Note**

In order for this tab to display the Switch/LED names correctly and for the compilation tool flow to run through successfully, please use the **Reveal Controller template** from the Source Template Editor tool. See “Using Templates” on page 81.

### Configuring User Register Setup

Setting up the User Register setting consists of assigning six mandatory ports. (which must be defined in user RTL design) The maximum data width is 32 bits.

The mandatory signals are:
Clock, Clock_enable, Wr_Rdn, Address, WData and RData.

To set up User Register signals:
1. Select the top_Controller core in the Dataset view. (There can only be one Controller core.)
2. Click the User Register Setup tab.
3. Select signals in the Design Tree and drag the signals to the desired position in the Setting List in the User Register Setup tab. For help finding signals, see “Searching for Signals” on page 460.
4. Drag the desired signals into the User Register data panel to the right. The width of the signals will automatically update between 4-32 entries at the top.
5. Beside the title User Register Setting, there is a check box in which Controller function for User Registers signals can be enabled/disabled.

Configuring Hard IP Setup
The Hard IPs are automatically extracted from the RTL design and displayed in the data pane.

For the Inserter, the starting addresses for the IPs as shown is only for informational purpose. The addresses can be experimented in the Analyzer.

To set up Hard IP:
1. Click the Hard IP Setup tab.
2. Select Controller function for Hard IPs for analysis by enabling check boxes.

Inserting the Reveal Modules
When you finish setting up the trace and trigger signals, you can insert the Reveal modules into the design.

Note
Interactive and stand-alone synthesis are not compatible with Reveal modules. Reveal Inserter automatically uses the integrated synthesis option. Make sure your design project is set up for integrated synthesis if not done already.

To insert the debug logic modules into the design:
1. Choose Debug > Insert Debug.
2. In the Insert Debug to Design dialog box, select the modules to insert.
3. Select Activate Reveal file in design project.
If the .rvl file is not active in the design project, the Reveal modules will not be included during synthesis.

4. **Click OK.**

Reveal Inserter performs a design rule check and saves the Reveal (.rvl) file. The Output view shows resource requirements and the DRC report for the modules. The .rvl file is listed in the File List pane under Debug Files.

5. **Implement the design in the usual way.** See “Implementing the Design” on page 248.

Adding Reveal modules can sometimes cause design implementation to fail. If you have any problems, see “Troubleshooting Design Implementation Errors” on page 483 and “Limitations” on page 461.

### Troubleshooting Design Implementation Errors

If the design implementation process fails after inserting a Reveal module, check this section for solutions.

**Signals Implemented as Hard Routes** Some signals that are implemented as hard routes in the FPGA instead of using the routing fabric are not available for tracing or triggering. Examples are connections to IB and OB components. If you select a signal for tracing or triggering that is implemented as a hard route, an error will occur during the synthesis, mapping, placement, or routing steps. However, the error can take many forms. Following are some examples.

**Example 1:** An example error message from the synthesis log file, `<cktname>.log`:

```
@E:"f:\cws\bugs\cr37986\reveal_workspace\tmpreveal\rx_ddr_rvl.vhd":648:8:
648:12|Port 'serin' on Chip 'RX_DDR' drives 1 PAD loads and 1 non PAD loads
```

**Example 2:** In this example error message, the serin signal is a hard route, but serin is not the name of the original signal that was traced. The hierarchical path shown is for the Reveal module that was generated. It is not part of the original design and is not displayed during the debug module insertion. The error message does not specify which trace or trigger signal is causing the problem.

To manually determine which signal is causing this error, you can use two approaches:

1. Remove signals one by one in Reveal Inserter to see which caused the error. If you have only a few signals, this would be the best approach.

2. Manually look through the design to determine the problem. If you have many signals, this approach would be the best.

The error message refers to the temporary HDL design that is generated during debug logic insertion. Normally this HDL source is deleted after the
database is built. To save this temporary HDL source in the case of errors in mapping, you must set an environment variable by doing the following:

a. In the System control panel, click on the Advanced tab, then click on Environment Variable at the bottom of the window.

b. Create a new environment variable named KEEP_REVEAL_TEMP. The value can be anything, but it is normally set to TRUE.

c. Once this variable is set, exit the Radiant software.

d. Open the Radiant software and synthesize the design.

You can now open the generated and explore the HDL with a text editor or HDL Explorer to determine which signal caused the error. The top-level generated file is located at <project_directory>/reveal_workspace/tmpreveal/<project_name>_rvl.<v or vhd>.

**Example 3:**

**ERROR - map: IO register/latch FF_inst cannot be implemented in PIC.**

In this case, the input of a register is being traced. But the register is being implemented as an input flip-flop because of a preference, USE DIN. Allowing the register to be implemented as an internal flip-flop by removing the preference resolves the issue.

**See Also** ➤“Limitations” on page 461

**Removing Reveal Modules from the Design**

When you want to remove the Reveal modules from your design, you can either remove the .rvl file from the design project or set it as inactive, leaving it easily available for future use. Otherwise, the modules will continue to be inserted.

**To remove the Reveal modules from the design:**

1. In the File List view, right-click the .rvl file.

2. Do one of the following:

   ➤ To remove the Reveal modules but keep the project, choose Set as Inactive.

   ➤ To delete the Reveal project, choose Remove.

3. Implement the design in the usual way. See “Implementing the Design” on page 248.
Performing Logic Analysis

Once you have created one or more Reveal modules in Reveal Inserter, you can use Reveal Analyzer to capture the trace signal data from your evaluation board and view that data as waveforms. As you run your tests and start getting results, you can modify the trigger units and expressions and the use of the trace buffer to test other conditions.

To perform logic analysis:

1. If you are working in a secured lab (without a network connection to the design project files), make a copy of the required files and install them in the lab computer. See “Working in a Secured Lab” on page 485.
2. Connect your evaluation board and program the FPGA. See “Programming the FPGA” on page 486.
3. Start Reveal Analyzer by selecting Create a new file in the Reveal Analyzer Startup Wizard. See “Starting Reveal Analyzer” on page 487.
4. Set up the trigger signals for each module that you want to use. See “Setting Up the Trigger Signals” on page 491.
5. Capture data. See “Capturing Data” on page 501.
6. View the resulting waveforms for each module. See “Viewing Waveforms” on page 503.
7. Optionally, you can save the data in a Reveal Analyzer (.rva) file, a value change dump (.vcd) file for use in third-party tools, or in an ASCII text (.txt) file. See “Saving the Reveal Analyzer Settings and Data” on page 508.

To just view waveforms captured earlier:

1. Start Reveal Analyzer by selecting Open an existing file in the Reveal Analyzer Startup Wizard. See “Starting Reveal Analyzer” on page 487.
2. View the waveforms. See “Viewing Waveforms” on page 503.
3. Optionally, you can save the data in a Reveal Analyzer (.rva) file, a value change dump (.vcd) file for use in third-party tools, or in an ASCII text (.txt) file. See “Saving the Reveal Analyzer Settings and Data” on page 508.

Working in a Secured Lab

The usual process of Reveal logic analysis assumes that you are performing logic analysis on the same computer on which you created the Reveal modules, or that you are using a computer on the same network with easy access to the files. However, if your evaluation system is in a secured lab that is off the network, use the stand-alone Reveal Analyzer and the stand-alone Programmer in the lab.

To perform logic analysis, copy the files needed to program the FPGA and to run Reveal Analyzer over to the lab computer. After you finish collecting trace data, you may want to copy settings or the trace data to bring them out of the lab.
The files you need to run Reveal Analyzer in the lab are:

- Bitstream (.bin or .hex) file produced by the Export Files stage of the design implementation process. This file is required to program the FPGA.
- Reveal project (.rvl) file produced by Reveal Inserter. This is the defining file for a Reveal project and its modules. The .rvl file identifies the trace and trigger signals, and stores the trace and trigger options.
- Reveal settings (.rvs) file produced by Reveal Inserter. This file contains settings that can be changed in Reveal Analyzer while running tests. These settings include important parts of trigger units and trigger expressions.

Files to Bring Back:

After collecting data with Reveal Analyzer, you may want to bring one or more files back from the lab either to update the Reveal project or to analyze the data somewhere else.

If you made changes to the settings for trigger units or trigger expressions in Reveal Analyzer and want to update the project in Reveal Inserter with them, copy the .rvs file.

To analyze the trace data outside the lab using Reveal Analyzer’s LA Waveform view, choose File > Save and copy the following two files:

- Reveal Analyzer (.rva) file defines the Reveal Analyzer project. This file also contains data about the display of signals in the LA Waveform view.
- Reveal Trace (.trc) file contains data recorded from the last test run. This file loads Reveal Analyzer’s LA Waveform view.

To analyze the trace data outside the lab using another tool, save the data as either a value change dump (.vcd) or text (.txt) file and copy that file. See “Saving to Other Formats” on page 509.

**Programming the FPGA**

For an evaluation board using a single FPGA, program the FPGA in the usual way.

For an evaluation board using multiple FPGAs in a JTAG daisy chain, Reveal Analyzer has the following requirements:

- Only one device can be debugged at a time.
- The .xcf file must be in the design project directory.

**To program an FPGA with a Reveal module in a daisy chain:**

1. In Programmer, uncheck the Process column of the devices that do not get the Reveal module. This sets the operation of these devices to Bypass mode.
2. Ensure that the Process column of the device that does get the Reveal module is checked.

3. Double-click in the row of the device that does get the Reveal module. The Device Properties dialog box opens.

4. In the Device Properties dialog box, choose Fast Program from the pulldown menu.

5. Click OK.

For an FPGA that contains its own SPI flash, flash programming is also an option.

See Also
► “Programming the FPGA” on page 328

Starting Reveal Analyzer
Before starting Reveal Analyzer you need to decide if you want to work with a new Reveal Analyzer (.rva) file or an existing one. The .rva file defines the Reveal Analyzer project and contains data about the display of signals in the LA Waveform view. You may want to start Reveal Analyzer with a new file to set up a new test. Start with an existing file to rerun a test, to set up a new test based on existing settings, or to just view the waveforms from an earlier test.

How you start Reveal Analyzer also depends on whether you are using it integrated with the Radiant software or using the stand-alone version, and on your operating system.

Starting with a New File
Before you can start Reveal Analyzer with a new .rva file, you need to be connected to your evaluation board with a download cable and have the board’s power turned on. The following steps can also be seen in Figure 30

To start Reveal Analyzer with a new file:
1. Issue the start command. To start:
   ► For integrated with the Radiant software, go to the Radiant software main window and choose Tools > Reveal Analyzer.
   ► For stand-alone in Windows, go to the Windows Start menu and choose Programs > Lattice Radiant Reveal > Reveal Logic Analyzer.
   ► For stand-alone in Linux, go to a command line and enter the following:
     
     `<Reveal install path>/bin/lin64/revealrva`

     The Reveal Analyzer Startup Wizard dialog box appears.
2. If Reveal Analyzer opens with an existing file, choose File > Save As.

   The Save Reveal Analyzer File dialog box opens. Change the filename and click Save. You now have a new .rva file ready to work with.

3. In the Reveal Analyzer Startup Wizard dialog box, Select Create a new file (at the upper-left of the dialog box).

   The dialog box presents a few rows of boxes that need to be filled in. In the figure below, the numbers match up with the steps in this procedure and show where the boxes, buttons, and menus are for each step.

   **Figure 30: Startup Wizard with Steps for a New File**

4. In the first second row, type in the base name of the file. The extension is added automatically.

5. If there are daisy-chained devices, select Multiple Device in JTAG Chain.

6. To the right of this row is a pulldown menu. Choose the type of cable that your board is connected to.

7. Select the port. The method depends on the cable type:
   - If USB, click Detect. Then choose from the active ports found. The following figure shows the row after choosing a USB type.

   ![USB port selection](image)

   - If parallel, select the port address. If it's not one of the standard addresses given, select 0x and type in the hexadecimal address. Then click Check to verify that the connection is working. The following figure shows the row after choosing a parallel type.
8. If there are daisy-chained devices, click **Browse** in the XCF source row to find the XCF source file.

9. Click **Scan** to find the FPGA.

10. If there is more than one FPGA on your board, go to the “Debug device” menu and choose one that has a Reveal 🎮 icon. The icon indicates the presence of a Reveal module.

11. Click **Browse** in the RVL source row to find the Reveal Inserter project (.rvl) file.

12. To add the new .rva file to the File List view, select **Import file into current implementation**. The .rva file works the same either way.

13. Click **OK**.

**See Also**

- "Creating a New Source File" on page 23

---

**Starting with an Existing File**

If you want to start with an existing file, you just need to have that .rva file in the design project. You need to be connected to the evaluation board only if you want to run a test and capture data.

**To start Reveal Analyzer with an existing file:**

1. Issue the start command. To start:

   - In the Radiant software main window, choose **Tools > 🎮 Reveal Analyzer**.
   - The stand-alone Reveal Analyzer in Windows, go to the Windows Start menu and choose **Programs > Lattice Radiant Reveal > 🎮 Reveal Logic Analyzer**.
   - The stand-alone Reveal Analyzer in Linux, enter the following on a command line:

     ```bash
     <Reveal install path>/bin/lin64/revealrva
     ```

     The Reveal Analyzer Startup Wizard dialog box appears.

     If Reveal Analyzer opens with the .rva file you want to use, you’re ready to go. Otherwise continue with the following steps.

2. In the Reveal Analyzer Startup Wizard dialog box, elect **Open an existing file** (in the lower part of the dialog box). See Figure 31.

3. In the “File name” box, choose one of the available .rva files.
4. If the file you want is not in the menu, click **Browse** and browse to the desired .rva file.

5. To add the .rva file to the File List view, select **Import file into current implementation**. The .rva file works the same either way.

6. Click **OK**.

   If the connection to your evaluation board has changed, either in the cable type or the computer port used, you need to tell Reveal Analyzer about the new connection. See “Changing the Cable Connection” on page 490.

### Changing the Cable Connection

If you need to change how your evaluation board is connected to your computer, go ahead and make the change. Then go through the following procedure to change the Reveal Analyzer project.

**To change the cable setting in a Reveal Analyzer project:**

1. Make sure your evaluation board is connected and that its power is on.

2. If Reveal Analyzer is not already open, start it as described in “Starting with an Existing File” on page 489.

3. Choose **Design > Cable Connection Manager**.

   The Cable Connection Manager dialog box opens.

4. In the dialog box, choose the cable type.

   The second row in the dialog box changes to select the specific port.

5. Select the specific port. The method depends on the port type:

   - If USB, click **Detect**. Then choose from the active ports found.
   - If parallel, select the port address. If it’s not one of the standard addresses given, select **0x** and type in the hexadecimal address. Then click **Check** to verify that the connection is working.

6. To change the clock speed of the cable connection, adjust the value of **TCK Low Pulse Width Delay**.

7. Click **OK**.
Setting Up the Trigger Signals

In Reveal Analyzer, you cannot create new trigger units or trigger expressions, but you can change how they are named and defined. In trigger units, you can change the operators, radices, and values. In trigger expressions, you can change the expression including the operators and which trigger units are used. You can also modify some of the trigger options and the trigger position.

To modify the trigger of a module.
1. Click on the LA Trigger tab.
2. Choose the module from the pulldown menu in the Reveal Analyzer toolbar.
   
The definition of the module’s trigger units and trigger expressions appear. Grayed out cells and options cannot be changed in Reveal Analyzer. To change them, you must go back to Reveal Inserter.
3. Modify the trigger units as desired. If you want to change:
   
   ▶ Operator: Choose an operator from the pulldown menu. You cannot change or select serial compare in Reveal Analyzer. See “About Trigger Unit Operators” on page 492.
   
   ▶ Radix of the value: Choose a radix from the pulldown menu. The menu includes token sets whose bit width matches the trigger unit’s signals.
   
   ▶ Value: Select it and type in a new comparison value. The form of the value must match the specified radix. If you selected a token set in the Radix column, a pulldown menu opens in the Value column listing the tokens in the token set.
     
     You can use “x” for a don’t-care value if you selected binary, octal, or hexadecimal in the Radix column and if you selected ==, !=, or serial compare in the Operator column.
   
4. Modify the trigger expressions as desired. Trigger expressions can be completely rewritten provided that you do not exceed the maximum sequence depth or the maximum event counter. See “Trigger Expression Syntax” on page 493.
5. In the Trigger Expression Name column, select the trigger expressions that you want to use in the next test.
6. In the Trigger Options section, at Enable TE, choose how to combine the selected trigger expressions to form the trigger event:
   
   ▶ AND All means that all of the trigger expressions must be satisfied to form the trigger event.
   
   ▶ OR All means that only one of the trigger expressions must be satisfied to form the trigger event.
7. If you want the trigger event, as specified in the Enable TE option, to happen more than once before capturing trace data, select Final Event Counter in the Trigger Position section, and then specify the number of times the event is to happen to produce the actual trigger on the trigger.
signal. This option is available only if the event counter was enabled for the module in Reveal Inserter.

8. In the Trigger Options section, specify the number of samples per trigger and the number of triggers you want to record. The number of samples multiplied by the number of triggers cannot be greater than the trace buffer depth that was specified in Reveal Inserter. Reveal Analyzer adjusts the values when needed.

9. In the Trigger Position section, specify the trigger position relative to the trace data. The numbers in the section title show the current position. For example, “8/128” means the trigger happens on sample 8 out of the 128 samples per trigger. Select either:

- **Pre-selected** and choose one of the standard positions:
  - Pre-Trigger: 1/16 of the way from the beginning of the samples.
  - Center-Trigger: 1/2 of the way from the beginning of the samples.
  - Post-Trigger: 15/16 of the way from the beginning of the samples.
- **User-selected** and choose a position with the slider.

It should be noted that for each of the Pre-, Center- and Post-Trigger samples, a user is only guaranteed to see the waveforms from that point on. For example if you choose Post-Trigger (15/16), then a user will only see the sample waveforms for the last 1/16 of 256 sample data.

### About Trigger Unit Operators

Most of the trigger unit operators use standard logical comparisons between the current value of the combined signals of the trigger unit and a specified value. But some of the operators are unusual and need some explanation.

With the exception of “serial compare,” the operators can be changed in Reveal Analyzer.

**Standard Logical Operators**  Reveal includes the following operators:

- == equal to
- != not equal to
- > greater than
- >= greater than or equal to
- < less than
- <= less than or equal to

**Rising-Edge and Falling-Edge Operators**  The “rising edge” and “falling edge” operators check for change in the signal value, not the value itself. So the trigger unit’s specified value is a bit mask showing which signals should have a rising or falling edge. A 1 means “look for the edge;” a 0 means “ignore this bit.” A multiple-bit value is true if any of the specified bits have the edge.
For example, consider a trigger unit defined as cout[3:0], rising edge, 1110. This trigger unit will be true only when cout[3], cout[2], or cout[1] have a rising edge. What happens on cout[0] does not matter.

- 0000 > 1110
  True because cout[3], cout[2], and cout[1] rose.
- 0000 > 1111
  True for the same reason. It does not matter whether cout[0] rises or not.
- 0000 > 0100
  True because a rising edge on any of the specified bits is sufficient.
- 1000 > 1000

**Serial Compare**  The “serial compare” operator checks for a series of values on a single signal. For example, if a trigger unit’s specified value is 1011, the “serial compare” operator looks for a 1 on the first clock, a 0 on the next clock, a 1 on the clock after that, and a 1 on the last clock. Only after those four conditions are met in those four clock cycles is the trigger unit true.

Serial compare is available only when a single signal is listed in the trigger unit’s signal list. The radix is automatically binary.

You can only set the serial compare operator in Reveal Inserter. You cannot change it or select it in Reveal Analyzer as you can the other operators.

**Trigger Expression Syntax**

Trigger expressions are combinations of trigger units. Trigger units can be combined in combinatorial, sequential, and mixed combinatorial and sequential patterns. A trigger expression can be dynamically changed at any time. Each core supports up to 16 trigger expressions that can be dynamically enabled or disabled in Reveal Analyzer. Trigger expressions support AND, OR, XOR, NOT, parentheses (for grouping), THEN, NEXT, # (count), and ## (consecutive count) operators. Each part of a trigger expression, called a sequence, can also be required to be valid a number of times before continuing to the next sequence in the trigger expression.

**Detailed Trigger Expression Syntax**  Trigger expressions in both Reveal Inserter and Reveal Analyzer use the same syntax.

**Operators**  You can use the following operators to connect trigger units:

- & (AND) – Combines trigger units using an AND operator.
- | (OR) – Combines trigger units using an OR operator.
- ^ (XOR) – Combines trigger units using a XOR operator.
- ! (NOT) – Combines a trigger unit with a NOT operator.
- Parentheses – Groups and orders trigger units.
THEN – Creates a sequence of wait conditions. For example, the following statement:

TU1 THEN TU2

means “wait for TU1 to be true, then wait for TU2 to be true.”

The following expression:

(TU1 & TU2) THEN TU3

means “wait for TU1 and TU2 to be true, then wait for TU3 to be true.”

Reveal supports up to 16 sequence levels.

See “Sequences and Counters” on page 475 for more information on THEN statements.

NEXT – Creates a sequence of wait conditions, like THEN, except the second trigger unit must come immediately after the first. That is, the second trigger unit must occur in the next clock cycle after the first trigger unit. See “Sequences and Counters” on page 475 for more information on NEXT statements.

# (count) – Inserts a counter into a sequence. See “Sequences and Counters” on page 475 for information on counters.

## (consecutive count) – Inserts a counter into a sequence. Like # (count) except that the trigger units must come in consecutive clock cycles. That is, one trigger unit immediately after another with no delay between them. See “Sequences and Counters” on page 475 for information on counters.

Case Sensitivity  Trigger expressions are case-insensitive.

Spaces  You can use spaces anywhere in a trigger expression.

Sequences and Counters  Sequences are sequential states connected by THEN or NEXT operators. A counter counts how many times a state must occur before a THEN or NEXT statement or at the end of the sequence. The maximum value of this count is determined by the Max Event Counter value. This value must be specified in Reveal Inserter and cannot be changed in Reveal Analyzer.

Here is an example of a trigger expression with a THEN operator:

TU1 THEN TU2

This trigger expression is interpreted as “wait for TU1 to be true, then wait for TU2 to be true.”

If the same example were written with a NEXT operator:

TU1 NEXT TU2

it is interpreted as “wait for TU1 to be true, then wait one clock cycle for TU2 to be true.” If TU2 is not true in the next clock cycle, the sequence fails and starts over, waiting for TU1 again.

The next trigger expression:
TU1 THEN TU2 #2

is interpreted as "wait for TU1 to be true, then wait for TU2 to be true for two sample clocks." TU2 may be true on consecutive or non-consecutive sample clocks and still meet this condition.

The following statement:
TU1 ##5 THEN TU2

means that TU1 must occur for five consecutive sample clocks before TU2 is evaluated. If there are any extra delays between any of the five occurrences of TU1, the sequence fails and starts over.

The next expression:
(TU1 & TU2)#2 THEN TU3

means "wait for the second occurrence of TU1 and TU2 to be true, then wait for TU3."

The last expression:
TU1 THEN (1)#200

means "wait for TU1 to be true, then wait for 200 sample clocks." This expression is useful if you know that an event occurs a certain time after a condition.

You can only use one count (# or ##) operator per sequence. For example, the following statement is not valid, because it uses two counts in a sequence:
TU1 #5 & TU2 #2

Multiple count values are allowed for a single trigger expression, but only one per sequence. For two count operators to be valid in a trigger expression, the expression must contain at least one THEN or NEXT operator, as in the following example:
(TU1 & TU2) #5 THEN TU2 #2

This expression means "wait for TU1 and TU2 to be true for five sample clocks, then wait for TU2 to be true for two sample clocks."

Also, the count operator must be applied to the entire sequence expression, as indicated by parentheses in the expression just given. The following is not allowed:
TU1 #5 & TU2 THEN TU2 #2

The count (#) operator cannot be used as part of a sequence following a NEXT operator. A consecutive count (##) operator may be used after a NEXT operator, however. The following is not allowed:
TU1 NEXT TU2 #2

The count (# or ##) operators can only be used in one of two areas:
Immediately after a trigger unit or parentheses(). However, if the trigger unit is combined with another trigger unit without parentheses, a # cannot be used.

After a closing parenthesis.

**Precedence**  The symbols used in trigger expression syntax take the following precedence:

- Because it inserts a sequence, the THEN and NEXT operators always take the highest precedence in trigger expressions.
- Between THEN or NEXT statements, the order is defined by parentheses that you insert. For example, the following trigger expression:

  \[ \text{TU1} \& (\text{TU2} \| \text{TU3}) \]

  means “wait for either TU1 and TU2 or TU1 and TU3 to be true.”

  If you do not place any parentheses in the trigger expression, precedence is left to right until a THEN or NEXT statement is reached.

  For example, the following trigger expression:

  \[ \text{TU1} \& \text{TU2} \| \text{TU3} \]

  is interpreted as “wait for TU1 & TU2 to be true or wait for TU3 to be true.”

- The precedence of the ^ operator is same as that of the & operator and the | operator.

- The logic negation operator (!) has a higher precedence than the ^ operator, & operator, or | operator, for example:

  \[ !\text{TU1} \& \text{TU2} \]

  means “not TU1 and TU2.”

- The # and ## operators have the same precedence as the ^ operator, & operator, or | operator. However, they can only be used in one of two areas:

  - Immediately after a trigger unit or trigger units combined in parentheses. However, if the trigger unit is combined with another trigger unit without parentheses, a # or ## operator cannot be used.

    Here is an example of correct syntax using the count (#) operator:

    \[ \text{TU1} \# 2 \; \text{THEN} \; \text{TU3} \]

    This statement means “wait for TU1 to be true for two sample clocks, then wait for TU3.”

    However, the following syntax is incorrect, because the count operator is applied to multiple trigger units combined without parentheses:

    \[ \text{TU1} \& \text{TU2} \# 2 \; \text{THEN} \; \text{TU3} \]

  - After a closing parenthesis. Use parentheses to combine multiple trigger units and then apply a count, as in the following example:

    \[ (\text{TU1} \& \text{TU2}) \# 2 \; \text{THEN} \; \text{TU3} \]

    This statement means “wait for the combination of TU1 and TU2 to be true for two sample clocks, then wait for TU3.”
See Also  ➤ “Example Trigger Expressions” on page 497

Example Trigger Expressions
The following is a series of examples that demonstrate the flexibility of trigger expressions.

Example 1: Simplest Trigger Expression  Following is the simplest trigger expression:

TU1

This trigger expression is true, causing a trigger to occur when the TU1 trigger unit is matched. The value and operator for the trigger unit is defined in the trigger unit, not in the trigger expression.

Example 2: Combinatorial Trigger Expression  An example of a combinatorial trigger expression is as follows:

TU1 & TU2 | TU3

This trigger expression is true when (TU1 and TU2) or TU3 are matched. If no precedence ordering is specified, the order is left to right.

Example 3: Combinatorial Trigger Expression with Precedence Ordering  In the following example of a combinatorial trigger expression, precedence makes a difference:

TU1 & (TU2 | TU3)

This trigger expression gives different results than the previous one. In this case, the trigger expression is true if (TU1 and TU2) or (TU1 and TU3) are matched.

Example 4: Simple Sequential Trigger Expression  The following is an example of a simple sequential trigger expression:

TU1 THEN TU2

This trigger expression looks for a match of TU1, then waits for a match on TU2 a minimum of one sample clock later. Since this expression uses a THEN statement, it is considered to have multiple sequences. The first sequence is “TU1,” since it must be matched first. The second sequence is “TU2,” because it is only checked for a match after the first sequence has been found. The “sequence depth” is therefore 2.

The sequence depth is an important concept to understand for trigger expressions. Since the debug logic is inserted into the design, logic must be used to support the required sequence depth. Matching the depth to the entered expression can be used to minimize the logic. However, if you try to define a trigger expression that has a greater sequence depth than is available in the FPGA, an error will prevent the trigger expression from running. The dynamic capabilities of the trigger expression can therefore be
limited. To allow more flexibility, you can specify the maximum sequence depth when you set up the debug logic in Reveal Inserter. You can reserve more room for the trigger expression than is required for the trigger expression currently entered. If you specify multiple trigger expressions, each trigger expression can have its own maximum sequence depth.

**Example 5: Mixed Combinatorial and Sequential Trigger Expressions**
Here is an example showing how you can mix combinatorial and sequential elements in a trigger expression:

```
TU1 & TU2 THEN TU3 THEN TU4 | TU5
```

This trigger expression only generates a trigger if (TU1 AND TU2) match, then TU3 matches, then (TU4 or TU5) match. You can set precedence for any sequence, but not across sequences. The expression (TU1 & TU2) | TU3 THEN TU4 is correct. The expression (TU1 & TU2 THEN TU3) | TU4 is invalid and is not allowed.

**Example 6: Sequential Trigger Expression with Sequence Counts**
The next trigger expression shows two new features, the sequence count and a true operator to count sample clocks:

```
(TU1 & TU2)#2 THEN TU3 THEN TU4#5 THEN (1)#200
```

This trigger expression means wait for (TU1 and TU2) to be true two times, then wait for TU3 to be true, then wait for TU4 to be true five times, then wait 200 sample clocks. The count (# followed by number) operator can only be applied to a whole sequence, not part of a sequence. When the count operator is used in a sequence, the count may or may not be contiguous. The always true operator (1) can be used to wait or delay for a number of contiguous sample clocks. It is useful if you know that an event that you want to capture occurs a certain time after a condition but you did not know the state of the trigger signals at that time.

However, there is a limitation on the maximum size of the counter. This depends on how much hardware is reserved for the sequence counter. When you define a trigger expression, the Max Event Counter setting in the Trigger Expression section of Reveal Inserter and Reveal Analyzer specifies how large a count value is allowed in the trigger expression. Each trigger expression can have a unique Max Event Counter setting.

**See Also**

► "Trigger Expression Syntax" on page 493
Creating Token Sets

You can create sets of “tokens,” or text labels, for values that might appear on trace buses. You can create tokens such as ONE, TWO, THREE, or Reset, Boot, and Load. Tokens can make reading the waveforms in Reveal Analyzer easier and can highlight the occurrence of key values. See Figure 32 for an example. The row for the chstate bus uses tokens.

Figure 32: LA Waveform View Using Tokens

<table>
<thead>
<tr>
<th>Bus/Signal</th>
<th>Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>end_type</td>
<td>1</td>
</tr>
<tr>
<td>pb_done</td>
<td>0</td>
</tr>
<tr>
<td>sort_done</td>
<td>0</td>
</tr>
<tr>
<td>timecount</td>
<td>179</td>
</tr>
<tr>
<td>gstate</td>
<td>finish_hld</td>
</tr>
<tr>
<td>chstate</td>
<td>wait_for_load</td>
</tr>
<tr>
<td>uut/gameen/hstate</td>
<td>1001</td>
</tr>
<tr>
<td>uut/hvson/hvst_loop_dne</td>
<td>1</td>
</tr>
<tr>
<td>game_ready</td>
<td>0</td>
</tr>
<tr>
<td>sel</td>
<td>0</td>
</tr>
</tbody>
</table>

To create or modify a token set:

1. Choose **Design > Token Set Manager**.

   The Token Manager dialog box opens. If the Reveal project already has token sets defined, they are listed in the dialog box.

2. If you want to use token sets that were previously saved to a separate file, right-click in the dialog box and choose **Import**. In the Import Tokens dialog box, browse to the token (.rvt) file and click **Open**.

   The token sets in the .rvt file are added to the list in Token Manager.

3. To create a new token set, click **Add Set**.

   A new token set is started with default values. But it has no tokens defined yet.

4. To change the size of the token values, double-click the value in the Num. of Bits column and type in the new width (up to 256) in bits. The width must be the same as the bus that the token set will be used with.

   The Num. of Bits value can only be changed when the token set is empty. If there are any tokens, you will get an error message.

5. To create a new token, select a token set. Then click **Add Token**.

   A new token is created with default values. Repeat for as many new tokens as needed.

6. You can modify token sets by doing any of the following:

   - To change the name of a token or token set, double-click the name and type a new name. The name can consist of letters, numbers, and underscores (_). It must start with a letter.
To change the value of a token, double-click the value and type in a new value. Token values must be prefixed by one of the radix indicators shown in the following table:

<table>
<thead>
<tr>
<th>Radix</th>
<th>Prefix</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Binary</td>
<td>b'</td>
<td>b'110x0</td>
</tr>
<tr>
<td>Octal</td>
<td>o’</td>
<td>o’53</td>
</tr>
<tr>
<td>Decimal</td>
<td>d’</td>
<td>d’123</td>
</tr>
<tr>
<td>Hexadecimal</td>
<td>h’</td>
<td>x’0F2</td>
</tr>
</tbody>
</table>

If a value does not have a prefix, its radix is assumed to be binary. You can use an "x" in binary numbers as a don’t-care value.

To remove a token or token set, select it and click **Remove**.

7. You can save the collection of token sets showing in the dialog box to a separate file for use in another project. To save the token sets, right-click and choose **Export**. In the Export Tokens dialog box, browse to the desired location and type in the name of the new token (.rvt) file. Click **Save**.

8. When you are done, click **Close** to close the dialog box. The token sets are automatically applied to the current Reveal project.

**Debugging with Reveal Controller**

Reveal Controller is another divide-and-conquer mechanism for you to emulate an otherwise unavailable environment for power debug. For example, your evaluation board would only have a limited number of LEDs or switches but the virtual environment enables up to 32 bits. Register memory mapping and dumping of values is also easily manifested while visibility into Hard IPs is also enabled.

**NOTE**

It should be noted that during a debug session with Controller, the constant polling of the signals ties up the JTAG ports for other operations such as attempting to program an updated bitstream as a parallel operation. You must end the debugging session first.

**Virtual LED Switch Console**

Once Reveal Analyzer is set up and started, you are presented with three tabs, the first of which is a virtual LED/Switch console to emulate the board.

The top section, Virtual LED shows all the LEDs that were defined in the insertion stage. Once the board is running, you can see the LEDs flash in red and green as they would in the real hardware environment.
The lower section shows the virtual switch in which you can either enter the data as a hex value or can set the virtual dip switches.

Select Direct Mode to see the data and switches in real time instead of waiting until the Apply button is clicked.

**NOTE**

Switches are of type in/out. When defining switches in RTL, use the WIRE definition otherwise multiple input driver errors will be encountered later in the flow.

---

### User Register Analysis

The second tab is for User Register Analysis. The title indicates the range of the User Register memory map. Analysis follows no particular steps or order.

- **Default Data**: A value that will initialize all memory locations.
- **Write Address/Data**: Address and data in hex to be written.
- **Read Address/Data**: Enter address. The data is read back when ‘Read’ is selected.
- **Memory File**: You can dump from/to a range of memory addresses to a .mem file. A user can also **Load MemFile** to load a pre-configured memory file.

### Hard IP Debug

All the IP selected for analysis in Reveal Inserter are displayed here.

Main operations are reading/writing to memory locations.

**NOTE**

The detail settings of each IP is beyond the scope of this help. Links will be provided to Application Notes to explain its usage.

---

### Capturing Data

After you have configured trigger settings in the LA Trigger tab, you can capture data.

Before capturing data, however, your evaluation board must be connected and the design downloaded. See “Programming the FPGA” on page 486.

**To capture data:**

1. In the Reveal Analyzer toolbar, select the modules you want to use.
2. Click the Run button in the Reveal Analyzer toolbar.
The Run button changes into the Stop button and the status bar next to the button shows the progress.

Reveal Analyzer first configures the modules selected for the correct trigger condition, then waits for the trigger conditions to occur. When a trigger occurs, the data is uploaded to your computer. The resulting waveforms appear in the LA Waveform tab.

If the trigger condition is not met, Reveal Analyzer continues running. In that case, you can use manual triggering, described in “Using Manual Triggering” on page 502.

See Also “Stopping Data Capture” on page 502

Stopping Data Capture
You can stop capturing data at any time.

To stop data capture:
1. Choose a module from the pulldown menu in the Reveal Analyzer tool bar.
2. Click the Stop button in the Reveal Analyzer toolbar.

This command only stops the data capture for the current module. You must stop each module separately.

Using Manual Triggering
If triggering fails to occur or you want to trigger manually instead of triggering when a signal condition occurs, you can use manual triggering to collect data. The data may then help you find out why triggering did not occur as you originally intended.

When you select manual triggering, Reveal Analyzer fills the buffer with data captured from that moment. In single-trigger capture mode, it fills the buffer and stops. In multiple-trigger capture mode, it captures one trigger and data. You can then continue to manually trigger as many times as the original triggering setup specified. If you want to capture fewer triggers, you can manually trigger the desired number of times, then click the Stop button. Then the buffer starts uploading the data.

To use manual triggering:
1. After you start capturing data with the Run button, choose a module from the pulldown menu in the Reveal Analyzer tool bar.
2. Click the Manual Trigger button.

This command only applies to the data capture on the current module. You must start each module separately.
3. When you have captured the desired number of triggers in multiple trigger capture mode, click the Stop button.

### Viewing Waveforms

After capturing data, you can view the trace data in waveform format in the LA Waveform tab. Whenever the trace stops, Reveal Analyzer reads the trace samples and automatically updates the signal waveforms.

**To view a waveform:**

1. Click the LA Waveform tab.
2. Choose a module from the pulldown menu in the Reveal Analyzer tool bar.

Sometimes the waveform includes fewer clock cycles than you expect; in particular, fewer before the trigger. This happens if the trigger occurs so quickly after the test starts that there are not enough clock cycles before the trigger to fill that part of the trace buffer.

### About the LA Waveform View

Waveforms are presented in a grid layout as shown in Figure 33 along with several features to help you find and analyze the data.

**Figure 33: Elements of the LA Waveform View**

- **Bus/Signal Column**
  - Displays the names of the trace buses and signals in the selected module.

---

Lattice Radiant Software 2.2 Help

503
**Data Column** Displays the value of the bus or signal at the active cursor (a solid, red line that you can set in the waveform display). Buses also have a pulldown menu for setting the radix used in the Data column and in the waveform display. The menu includes token sets whose bit width matches the bus. See “Setting a Trace Bus Radix” on page 507.

**Waveform Display** Displays the trace data in waveform format. When there is room, bus values are included the display using the radix set in the Data column. You can zoom in and out, pan, and jump to various points.

The waveform display includes several other elements to help you read the display and analyze the data:

- **Timestamp.** The gray bar at the top of the display shows “timestamps” of the trace frames (actually, a simple count of the clock cycles). Timestamps are shown only if the Timestamp trace option was selected for the module in Reveal Inserter. See “Timestamp” on page 467.

- **Sample Index.** The green bar near the top of the display shows a count of triggers and trace samples within each trigger’s data set. The sample indexes have the form `<trigger>:<sample>`. For example, 0:2 indicates the first trigger and the third trace sample for that trigger (the counts are zero-based). 2:10 indicates the third trigger and the eleventh trace sample for that trigger.

- **Pointer.** A red line that cuts across the timestamp and sample index bars, the pointer follows the horizontal movement of the mouse pointer across the waveform display. Use the pointer to see where you are in time as you examine the waveform.

- **Cursors.** Vertical lines cutting through all the signals, cursors mark moments in the waveform. See “About Cursors” on page 504.

**See Also**

- “Zooming In and Out” on page 506
- “Moving around the Waveform” on page 506

**About Cursors**

The LA Waveform view comes with three types of “cursors” to highlight moments in the waveform. The cursors are vertical lines cutting through all the signals at the leading edge of a clock cycle. See Figure 33 on page 503. The three types are:

- **Trigger.** A purple line with a “T” at the top, trigger cursors are automatically placed at the moment of each final trigger event. If the module used a sample enable signal and the exact moment of the trigger is unknown, the waveform shows a trigger cursor five clock cycles before the sample enable signal turned inactive and sampling stopped.

- **Active.** A red line appears wherever you click in the waveform. The Data column shows the values of the signals and buses at the moment highlighted by the active cursor.
User. A blue line can be placed anywhere you want. Use these cursors to mark moments of interest. You can also use these cursors to maneuver about a long waveform with the Go to Cursor command. See “Working with User Cursors” on page 505.

Working with User Cursors

You can create any number of user cursors that can be moved or deleted. You can also jump the display to any one of them.

Most cursor functions require that the LA Waveform view be in Select mode. Do so by right-clicking in the LA Waveform view and choosing Select Mode.

To create a user cursor:
1. Click in the desired clock cycle.
   The active cursor appears. Make sure it is where you want the user cursor to be.
2. Right-click and choose Add Cursor.

To move a user cursor:
1. Zoom in so you can easily see and click in individual samples.
2. Click in the desired location.
   The active cursor appears. Make sure it is where you want the user cursor to be.
3. Carefully click in the sample to the right of the user cursor.
   You must click on or to the right of the user cursor. Otherwise you are just moving the active cursor to a neighboring sample.
   The user cursor and the active cursor exchange locations.

To jump to a user cursor:
1. Right-click in the waveform and choose Go to Cursor > <cursor>.
   Cursors are identified by the sample index as shown in the green bar at the top of the waveform display.

To remove a user cursor:
1. Click on or near the cursor.
   The active cursor appears. Make sure it is on or next to the user cursor you want to remove.
2. Right-click and choose Remove Cursor.

To remove all user cursors:
1. Right-click in the waveform and choose Clear All Cursors.
See Also ▶ “Moving around the Waveform” on page 506

Zooming In and Out
You can zoom in to expand the waveform and see more detail, or zoom out to see more of the waveform.

To zoom in on a waveform:
▶ Choose View > + Zoom In.

To zoom in on a specified area:
1. Right-click the waveform and choose Zoom Mode.
   The pointer changes to a cross: +.
2. Hold down the left mouse button and drag the pointer across the area you want to zoom in on.
   A shaded area appears on the waveform display.
3. Release the mouse button.
   The shaded area expands to fill the display.

To zoom out on a waveform:
▶ Choose View > Zoom Out.

To show the entire waveform in the window:
▶ Choose View > Zoom Fit.

See Also ▶ “Moving around the Waveform” on page 506

Moving around the Waveform
The waveform is usually much wider than the display, especially if you zoom in enough to see individual trace samples. To see nearby sections of the waveform, you can pan by sliding it left and right (described below) or by using the horizontal scroll bar at the bottom of the LA Waveform view. You can also jump to various points in the waveform including any cursors you’ve placed, the trigger point, the start of the display, and the end.

To pan the waveform display:
1. Right-click in the waveform and choose Pan Mode.
2. Press the left mouse button and drag to the left or the right.

To jump to a location in the waveform:
▶ Right-click in the waveform and choose one of the following from the menu. To jump to the:
User cursor, choose Go to Cursor > <cursor>. Cursors are identified by the sample index as shown in the green bar at the top of the waveform display.

Trigger point, choose Zoom > Zoom Trigger

Start of the display, choose Zoom > Zoom Start

End of the display, choose Zoom > Zoom End

The display changes to show the selection. The zoom level may change to keep the display filled.

See Also

- “About Cursors” on page 504
- “Working with User Cursors” on page 505
- “Zooming In and Out” on page 506

Setting a Trace Bus Radix

You can set the radix of a trace bus displayed in the LA Waveform tab. You can choose a binary, octal, decimal, or hexadecimal radix. You can also use any token set whose bit width matches the bus.

To set the bus radix of a signal or bus:

1. In the LA Waveform tab, click in the Data cell of the signal or bus.

   A menu appears showing the different radixes and any token sets that fit.

2. Choose the desired radix or token set.

To set the bus radix of multiple signals and buses:

This method can set several signals to the same radix but cannot use tokens.

1. In the LA Waveform tab, select one or more buses.

   Click on a bus to select it. To select multiple buses, Control-click on each one. To select all buses in a range, click on one end of the range and Shift-click the other end. If you want to change all the signals in the waveform to the same radix, you do not need to select anything.

2. Right-click in one of the selected waveforms and choose Set Bus Radix.

   Be careful to click in the same row as one of your selections, or you will change the selection.

   The Set Bus Radix dialog box opens.

3. In the pulldown menu, choose the radix.

4. In the Range pulldown menu, choose Selected signals or, if you want to change all the signals in the waveform to the same radix, choose All signals.

5. Click OK.
Changing LA Waveform Colors
You can change the colors used by the LA Waveform view.

To change the colors:
1. Choose Tools > Options.
2. In the Options dialog box, choose Colors > Reveal Analyzer.
3. Double-click on the color sample for the desired part of the LA Waveform view.
   The Select Color dialog box opens.
4. Select a color.
5. In the Select Color dialog box, click OK.
6. To see the effect of the change, click Apply.
7. Change other colors if desired.
8. Click OK.

Counting Samples
You can easily count the number of samples in a range on the display.

To count samples:
- Click where you want to start counting and drag to the end of the range.
  While you’re dragging, the LA Waveform view shows two red lines and the number of samples between the lines.

Saving the Reveal Analyzer Settings and Data
You can save the waveform data in the following formats:
- Reveal Analyzer (.rva) file, which will also include the trigger settings and waveform setup for future use
- Value change dump (.vcd) file, which can be imported by third-party tools such as ModelSim or Active-HDL
- Text (.txt) file

Save to an .rva file if you want to see the data in the LA Waveform view again or if you want to use the trigger settings. See “Saving a Reveal Analyzer File” on page 508. To save to a different format, see “Saving to Other Formats” on page 509.

Saving a Reveal Analyzer File
You can save the waveform along with the trigger settings and waveform setup in a Reveal Analyzer (.rva) file that you can use in the future. You can also save an existing .rva file in a file with a different name.
To save changes in the current file:

- Choose File > Save <file>.

To save the file with a different name:

1. Choose File > Save <file> As.
   
   The Save Reveal Analyzer File dialog box appears.

2. Browse to the directory in which you want to save the project.

3. In the File name box, type the file name.

4. Click Save.

**Saving to Other Formats**

You can export the data captured for individual modules to a value change dump (.vcd) file, which can be imported by third-party tools such as ModelSim or Active-HDL, or to an ASCII text (.txt) file.

**To export data:**

1. Choose the module from the pulldown menu in the Reveal Analyzer tool bar.

2. If you want the data to include an approximate measure of time instead of a simple count of clock cycles, right-click the waveform and choose Set Clock Period. See “Specifying the Clock Period” on page 510.

3. If you want to export only some of the signals, select them in the waveform. You can only export whole buses. If you select only some of the signals in a bus, you get the whole bus.

4. Right-click in the waveform and choose Export Waveform.

   The Export Waveform dialog box opens.

5. Browse to the location where you want to export the file.

6. Type in a name in the File name box.

7. Choose a file type.

8. If you are exporting only some of the signals, choose Selected signals in the Range box.

9. If you are exporting to .vcd, type in a module name. This will form the title in the .vcd file. If you leave the field empty, the module name will be “<unknown>”.

10. Click Save.
Specifying the Clock Period

By default, Reveal Analyzer refers to time by a count of the sample clock cycles. You can convert this to an approximate measure of time, in nanoseconds or picoseconds, by specifying the length of the clock period. When the waveform is exported, this measure of time is shown instead of a simple count of cycles.

To set the clock period:

1. Right-click the waveform and choose Set Clock Period.

2. Specify the scale by choosing a unit for the period in the pulldown menu on the right side of the dialog box. If you are specifying a frequency in the megahertz range, choose ns. If you are specifying a frequency in the gigahertz range, choose ps.

3. Place the cursor in either the Period or Frequency text box and type in the desired value. The other text box is filled in automatically.
   
   Only integers are allowed. If you try to specify a frequency that requires a non-integer period, the period is truncated to an integer and the frequency is automatically adjusted. For example, typing 150 in the Frequency text box gives you a period of six and a frequency of 166.

4. Click OK.
Chapter 13

Applying Engineering Change Orders

Engineering Change Orders, or ECOs, are requests to make changes to your design after it has been placed and routed. The changes are written into the Unified Database (.udb) file without requiring you to repeat the entire design implementation process. After applying ECOs, you can continue to generate bitstream/JEDEC files for your design.

ECOs are mainly used to correct errors found in the hardware model during debugging, or to facilitate design specification changes when problems are introduced with the integration of other FPGAs or components in your PC board design.

The Radiant software design flow supports interactive ECO editing with the ECO Editor, which is a tabular user interface similar to Spreadsheet View. The ECO Editor includes sheets for editing I/O constraints, and memory initialization values. These features enable you to edit the Unified Database (.udb) file created by the Place & Route Design process. You can also sort the sysIO constraints list and save the sorting order. The ECO Editor provides a Change Log window that enables you to track the changes between the modified .udb file and the post-PAR .udb file.

**Note**

After you have edited your post-PAR UDB file, your functional simulation and timing simulation will no longer match.

**Note**

ECO memory initialization is not supported directly to use instantiate EBR primitives, such as SP16K/DP16K.
**Editing sysIO Settings in ECO Editor**

The ECO Editor provides separate sheets for exporting sysIO constraints. After a design is placed and routed, you can open the ECO Editor to export these constraints. The changes you make in the ECO Editor are written into the Unified Database (.udb) file without requiring you to go through the entire design implementation process.

To export sysIO constraints, click the sysIO Setting tab at the bottom of the ECO Editor window.

**Editing sysIO Settings**

You can use the ECO Editor to export sysIO constraints after the design has been placed and routed.

**To export sysIO constraints:**

1. In Radiant software, make sure that you have already run the Place & Route Design process, and then choose **Tools > ECO Editor**.
2. At the bottom of the ECO Editor, click the **sysIO Setting** tab.
   - In the sysIO Setting window, values from design sources are shown in blue, and modified values are shown in black.
   - You can only edit the values of cells that have white backgrounds.
3. In the sysIO Setting window, double-click the constraint that you want to modify. Select a value from the drop-down menu or type a new value.
4. When you have finished, choose **File > Save <file_name>.udb** to save the changes to the current .udb file.

**Setting Memory Initialization Values in ECO Editor**

Memory Initialization is a feature that allows you to change initial values to EBRs (Embedded Block RAM) for device configuration after the design has been placed and routed. It saves you time by allowing you to fix a few incorrect initialization values in your post-PAR Unified Database (.udb) file without having to repeat the entire flow.

Changing initial memory values might become necessary, for example, if incorrect values were assigned during synthesis or if there is some off-chip device that your FPGA is communicating with that requires a different value than the one that was initially set.

You use the ECO Editor’s Memory Initialization window to update initial memory values.

**See Also**

- “Memory Initialization Update” on page 513
- “Updating Initial Values for EBRs” on page 513
Memory Initialization Update

Setting initial memory values actually writes the initial values directly into your post-PAR Unified Database (.udb) file. For this to be accomplished, you need to provide the following information:

- Unified Database file (.udb) – the <design_name>.udb file that is updated by the Place & Route Design process.
- Memory Initialization File (.mem) – an ASCII-based text file that contains initial data values on various address locations in the memory module. This file should be in the same format that was used in module creation. See

**Note**

You must create .mem files for ROMs. Memory Initialization files are optional for RAM modules.

To learn more about how to create a memory initialization file, see "Applying Engineering Change Orders" on page 511

- Memory block parameters – information on the memory block such as module name, memory mode, depth, width, and format.

If the memory module is created by pure RTL design, the software can update memory initialization from LSE flow.

- Instance name (not a file) – the name that was given to the memory module in your top-level vm.

Updating Initial Values for EBRs

Before updating memory values in ECO Editor, you need to add the memory module to your design and run the Place & Route Design process. The memory modules can be modules created by LSE flow.

**Note**

Once you edit initial memory values in the post-PAR UDB file, your functional simulation and timing simulation results will no longer match. You might need to preserve an original version of your UDB file.

**To update memory initialization values:**

1. Customize a memory initialization file (.mem) in any ASCII text editor. In this step, you should change the values of the INITVALs in your .mem file as necessary and save the file in your project directory. You might also want to create a copy of the original .mem file.

**Note**

You must create a .mem file for ROM instances in your design. RAM instances may or may not need .mem files associated with them.
For example, there might be a ROM memory instance in your design; so you create a .mem file called romb.mem in your project directory. These updated INITVALs will be used to override present ones that were auto-generated through the flow. Although the .mem file can be located anywhere on your system, it is recommended that you place them in your project directory.

2. In the Radiant software main window, make sure that you have already successfully run the Place & Route Design process, and then choose Tools > ECO Editor.

3. Select the Memory Initialization tab at the bottom of the ECO Editor window.

   The Memory Initialization window displays the memory instances, memory file, and any parameters for memory modules that were created by LSE flow.

4. Right-click a memory instance, and choose Update Initial Memory from the pop-up menu. You can also choose Update Initial Memory from the Edit menu.

   The Update Initial Memory dialog box opens, displaying the information about the currently selected memory block.

5. To change the format of the memory file, select a format from the File Format menu.

6. Click the ... button next to the Memory File box to browse to the .mem file that you previously edited, as suggested in Step 1. Make sure that the File Format is correct.

   If your design targets an LIFCL device and uses EBR blocks, you can use the .mem file or one of two other initialization options, as follows:

   - Initialize to all 1s – fills the EBR memory with all 1s instead of the values in the .mem file.
   - Initialize to all 0s – fills the EBR memory with all 0s instead of the values in the .mem file.
   - Memory File – uses the values in the .mem file for initialization.

7. Click Update.

   The ECO Editor attempts to update the current memory block’s initial memory values. A message will appear telling you whether the initialization succeeds or not.

8. Click OK.

   The Update Initial Memory dialog box closes after a successful initialization. If the initialization fails, the dialog box will stay open.

9. After the initialization succeeds, choose File > Save File to save the memory initialization changes to the current UDB file.
Running Design Rule Check

When you export constraints in the ECO Editor, the software automatically runs design rule check and reports errors, if any, in the Radiant software Output view.

You can also manually run the design rule check by choosing View > Run DRC.
A strategy provides a unified view of all the options related to implementation tools such as synthesis, map, and place and route. Strategy options are listed in the Strategy dialog box. Open the dialog box by double-clicking a strategy name in the File List view.

For information about an option, select it. A brief description appears at the bottom of the dialog box. Press F1 to open this guide and see the full description.

The descriptions of the strategy options are grouped by their processes (such as Synplify Pro or Map Timing Analysis).

For detailed information on how to apply strategies to your project, see "Using Strategies" on page 34.

**Synplify Pro Options** Synplify Pro strategy options are listed below:

- “Allow Duplicate Modules (for Synplify Pro)” on page 520
- “Area (for Synplify Pro)” on page 521
- “Arrange VHDL Files” on page 521
- “Clock Conversion” on page 521
- “Command Line Options (for Synplify Pro)” on page 521
- “Default Enum Encoding” on page 522
- “Disable IO Insertion (for Synplify Pro)” on page 522
- “Export Radiant Software Settings to Synplify Pro GUI” on page 522
- “FSM Compiler (for Synplify Pro)” on page 523
- “Fanout Guide” on page 523  
- “Force GSR (for Synplify Pro)” on page 523
Lattice Synthesis Engine (LSE) Options  LSE strategy options are listed below:

- “Allow Duplicate Modules (for LSE)” on page 526
- “Carry Chain Length” on page 526
- “Command Line Options (for LSE)” on page 526
- “DSP Style” on page 527
- “DSP Utilization” on page 527
- “Decode Unreachable States” on page 527
- “Disable Distributed RAM” on page 527
- “EBR Utilization” on page 527
- “FSM Encoding Style” on page 527
- “Fix Gated Clocks” on page 528
- “Force GSR (for LSE) (LIFCL, LFD2NX)” on page 528
- “Intermediate File Dump” on page 528
- “Loop Limit” on page 528
- “Macro Search Path (for LSE)” on page 529
- “Max Fanout Limit” on page 529
- “Memory Initial Value File Search Path (for LSE)” on page 529
- “Optimization Goal” on page 529
- “Propagate Constants” on page 530
- “RAM Style” on page 530
- “ROM Style” on page 531
- “Read Write Check on RAM” on page 531
- “Remove Duplicate Registers” on page 532
Post-Synthesis Post-Synthesis strategy options are listed below:
- “External Module Files (.udb)” on page 533

Post-Synthesis Timing Analysis Options Post-Synthesis Timing Analysis strategy options are listed below:
- “Number of End Points” on page 534
- “Number of Paths Per Constraint (for Post-Synthesis Timing Analysis)” on page 534
- “Number of Paths Per Endpoint (for Post-Synthesis Timing Analysis)” on page 534
- “Number of Unconstrained Paths (for Post-Synthesis Timing Analysis)” on page 534
- “Report Format (for Post-Synthesis Timing Analysis)” on page 534
- “Timing Analysis Options (for Post-Synthesis Timing Analysis)” on page 534

MAP Design Options MAP Design strategy options are listed below:
- “Command Line Options (for Map Design)” on page 535
- “Infer GSR” on page 535
- “Report Signal Cross Reference” on page 535
- “Report Symbol Cross Reference” on page 535

MAP Timing Analysis Options MAP Timing Analysis strategy options are listed below:
- “Number of End Points” on page 536
- “Number of Paths Per Constraint (for Map Timing Analysis)” on page 536
- “Number of Paths Per Endpoint (for Map Timing Analysis)” on page 536
- “Number of Unconstrained Paths (for Map Timing Analysis)” on page 536
- “Report Format (for Map Timing Analysis)” on page 536
- “Speed for Hold Analysis” on page 536
- “Speed for Setup Analysis” on page 536
- “Timing Analysis Options (for Map Timing Analysis)” on page 536
Place & Route Design Options  Place & Route Design strategy options are listed below:

- "Command Line Options (for Place & Route Design)" on page 537
- "Disable Auto Hold Timing Correction (for Place & Route Design)" on page 537
- "Disable Timing Driven (for Place & Route Design)" on page 537
- "Multi-Tasking Node List" on page 537
- "Number of Host Machine Cores" on page 538
- "Pack Logic Block Utility" on page 538
- "Path-based Placement" on page 538
- "Placement Iteration Start Point" on page 538
- "Placement Iterations" on page 538
- "Placement Save Best Run" on page 539
- "Prioritize Hold Correction Over Setup Performance (for Place & Route Design)" on page 539
- "Run Placement Only" on page 539
- "Set Speed Grade for Hold Optimization (for Place & Route Design)" on page 539
- "Set Speed Grade for Setup Optimization" on page 539
- "Stop Once Timing is Met (for Place & Route Design)" on page 539

Place & Route Timing Analysis Options  Place & Route Timing Analysis strategy options are listed below:

- "Number of End Points (for Place & Route Timing Analysis)" on page 540
- "Number of Paths Per Constraint (for Place & Route Timing Analysis)" on page 540
- "Number of Paths Per Endpoint (for Place & Route Timing Analysis)" on page 540
- "Number of Unconstrained Paths (for Place & Route Timing Analysis)" on page 540
- "Report Format (for Place & Route Timing Analysis)" on page 540
- "Speed for Hold Analysis" on page 540
- "Speed for Setup Analysis" on page 540
- "Timing Analysis Options (for Place & Route Timing Analysis)" on page 540

IO Timing Analysis Options  The following option is associated with the IO Timing Analysis process:

- "All Performance Grade" on page 541

Timing Simulation Options  Timing Simulation strategy options are listed below:
Synplify Pro Options

This page lists all the strategy options associated with the Synplify Pro Synthesis process. For information on their use in Synplify Pro, see the Synopsys Synplify Pro for Lattice Reference Manual.

Allow Duplicate Modules (for Synplify Pro)
PROP_SYN_EdfAllowDUPMod

Allows the use of duplicate modules in your design.
When it is set to True, the last definition of the module is used by the software and any previous definitions are ignored. The default is False.

**Area (for Synplify Pro)**  PROP_SYN_EdfArea

Specifies optimization preference for area reduction over timing delay reduction.

The True option specifies the area reduction mode. When set to True, this setting overrides the setting in Frequency (MHz) (for Synplify Pro).

The default is False.

This option is equivalent to the “set_option -frequency 1” command in Synplify Pro.

**Arrange VHDL Files**  PROP_SYN_EdfArrangeVHDLFiles

Allows Synplify Pro to reorder the VHDL source files for synthesis.

The default is True for VHDL or VHDL design entry type projects, and False for other projects. When this is set to False, Synplify Pro will use the file order in the Radiant software File List view.

**Automatic Read/Write Check Insertion for RAM**  PROP_SYN_RamRWCheck

When this option is set in the strategy, the synthesis tool inserts glue logic around inferred RAM to avoid simulation mismatches caused by indeterminate output values when the read and write addresses are same. By default this option is OFF.

Users should design to make sure the read and write addresses are never the same.

**Clock Conversion**  PROP_SYN_ClockConversion

Controls gated and generated clock conversion.

Values are True and False.

**Command Line Options (for Synplify Pro)**  PROP_SYN_CmdLineArgs

Enables additional command line options for the Synplify Pro Synthesis process.

To enter a command line option:

1. In the Strategy dialog box, select Synplify Pro in the Process list.
2. Double-click the Value column for the Command line Options option.
3. Type in the option and its value (if any) in the text box.
4. Click Apply.

For example:
set_option -library_path c:/source

**Default Enum Encoding**  PROP_SYN_EdfDefEnumEncode
(For VHDL designs) Defines how enumerated data types are implemented.

The type of implementation affects the performance and device utilization. Available options are:

- **Default** – Automatically assigns an encoding style based on the number of states:
  - Sequential: 0-4 enumerated types
  - Onehot: 5-40 enumerated types
  - Gray: more than 40 enumerated types

- **Gray** – Only one bit of the state register changes at a time, but because more than one bit can be hot, the value must be decoded to determine the state. For example: 000, 001, 011, 010, 110

- **Onehot** – Only two bits of the state register change (one goes to 0; one goes to 1) and only one of the state registers is hot (driven by a 1) at a time. For example: 0000, 0001, 0010, 0100, 1000

- **Sequential** – More than one bit of the state register can change at a time, but because more than one bit can be hot, the value must be decoded to determine the state. For example: 000, 001, 010, 011, 100

This option is equivalent to the “set_option -default_enum_encoding default | onehot | gray | sequential” command in Synplify Pro.

**Disable IO Insertion (for Synplify Pro)**  PROP_SYN_EdfInsertIO
Controls whether the synthesis tool will add I/O buffers into your design.

If this is set to True, Synplify Pro will not add I/O buffers into your design. If it is set to False (default), the synthesis tool will insert I/O buffers into your design.

This option is equivalent to the “set_option -disable_io_insertion 1 | 0” command in Synplify Pro.

**Disable Register Replication During S/R Optimization**  
PROP_SYN_DisableRegisterRep
(LIFCL and LFD2NX only): When this option is set in the strategy, the synthesis tool will NOT duplicate the registers while inferring the address pointers for the RAM during Shift-register inference. By default this option is OFF and the tool will duplicate the address pointer registers to get better performance.

**Export Radiant Software Settings to Synplify Pro GUI**  
PROP_SYN_ExportSetting

Controls whether the strategy settings are exported to Synplify Pro during interactive synthesis (opening Synplify Pro through the Tools menu). After opening Synplify Pro, you can change settings in Synplify Pro's interface. This option has no effect with integrated or stand-alone synthesis.

Available options are:

- **No** – Synplify Pro opens with its own defaults, ignoring the strategy settings.
- **Yes** (default) – Synplify Pro opens with the strategy settings every time. Options set and saved in a previous Synplify Pro session are ignored.
- **Only on First Launch** – Synplify Pro opens with the strategy settings the first time only. After that, Synplify Pro opens with settings saved in a previous session or with its own defaults. After the first time, the strategy settings are ignored.

For more information, see "Interactive Synthesis" on page 584.

**FSM Compiler (for Synplify Pro) PROP_SYN_EdfSymFSM**

Enables or disables the FSM Compiler and controls the use of FSM synthesis for state machines.

When Synplify Pro is selected as the synthesis tool, it enables or disables the FSM Compiler and controls the use of FSM synthesis for state machines. When this is set to True (default), the FSM Compiler automatically recognizes and optimizes state machines in the design. The FSM Compiler extracts the state machines as symbolic graphs, and then optimizes them by re-encoding the state representations and generating a better logic optimization starting point for the state machines.

This option is equivalent to the "set_option -symbolic_fsm_compiler 1 | 0" command in Synplify Pro.

**Fanout Guide PROP_SYN_EdfFanout**

Controls fanout during synthesis. When the specified fanout limit is achieved, logic will be duplicated.

The default is 1000.

This option is equivalent to the "set_option -maxfan <number>" command in Synplify Pro.

**Force GSR (for Synplify Pro) PROP_SYN_EdfGSR**

Forces Global Set/Reset Pin usage.

Available options are:

- **Auto** (default) – Allows the software to decide whether to infer Global Set/Reset in your design.
- **False** – Does not infer Global Set/Reset in your design.
- **True** – Always infers Global Set/Reset in your design.
This option is equivalent to the “set_option -force_gsr auto | yes | no” command in Synplify Pro.

**Frequency (MHz) (for Synplify Pro)**  PROP_SYN_EdfFrequency

Specifies the global design frequency (in MHz). Nothing in the Value column means “auto” and Synplify Pro will try to maximize the frequency of the clocks.

The setting is ignored when Area (for Synplify Pro) is set to True.

This option is equivalent to the “set_option -frequency <number> | auto” command in Synplify Pro.

**Library Directories**  PROP_SYN_LibPath

Specifies all the paths to the directories which contain the Verilog library files to be included in your design for the project.

You can also add custom library files with module definitions for the design in a single file. The names of files read from the library path must match module names. Mismatches result in error messages.

**Number of Critical Paths (for Synplify Pro)**  PROP_SYN_EdfNumCritPath

Specifies the number of critical timing paths to be reported in the timing report.

This option is equivalent to the “set_option -num_critical_paths <number>” command in Synplify Pro.

**Number of Start/End Points**  PROP_SYN_EdfNumStartEnd

Specifies the number of start and end points you want the software to report in the critical path section of the timing report.

This option is equivalent to the “set_option -num_startend_points <number>” command in Synplify Pro.

**Output Netlist Format (for Synplify Pro)**  PROP_SYN_EdfOutNetForm

Outputs a mapped VHDL netlist for post-synthesis simulation.

Available options are: None (default) and VHDL.

This option is equivalent to the “set_option -write_vhdl 1 | 0” command in Synplify Pro.

**Pipelining and Retiming**  PROP_SYN_EdfRunRetiming

Enables the pipelining and retiming features to improve design performance.

Values are:

- None – Disables the pipelining and retiming features.
- Pipelining Only (default) – Runs the design at a faster frequency by moving registers into the multiplier, creating pipeline stages.

- Pipelining and Retiming – When enabled, registers may be moved into combinational logic to improve performance.

This option is equivalent to the “setup_option -pipe 1 | 0 -retiming 1 | 0” command in Synplify Pro.

**Push Tristates**  PROP_SYN_EdfPushTirstates

When this is set to True, the Synplify Pro compiler pushes tristates through objects such as muxes, registers, latches, buffers, nets, and tristate buffers, and propagates the high impedance state.

The high-impedance states are not pushed through combinational gates such as ANDs or ORs.

The default is False.

This option is equivalent to the “set_option -compiler_compatible 1 | 0” command in Synplify Pro.

**Resolve Mixed Drivers (for Synplify Pro)**  PROP_SYN_ResolvedMixedDrivers

If a net is driven by a VCC or GND and active drivers, setting this option to True will connect the net to the VCC or GND driver.

This option is equivalent to the “set_option -resolve_multiple_driver 1 | 0” command in Synplify Pro.

**Resource Sharing (for Synplify Pro)**  PROP_SYN_EdfResSharing

When this is set to True (default), the synthesis tool uses resource sharing techniques to optimize area.

With resource sharing, synthesis uses the same arithmetic operators for mutually exclusive statements; for example, with the branches of a case statement. Conversely, you can improve timing by disabling resource sharing, but at the expense of increased area.

This option is equivalent to the “set_option -resource_sharing 1 | 0” command in Synplify Pro.

**Update Compile Point Timing Data**  PROP_SYN_UpdateCompilePtTimData

Determines whether (True) or not (False) changes inside a compile point can cause the compile point (or top-level) containing it to change accordingly.

When this is set to False (default), Synplify Pro keeps the top level module the same, which is desired by incremental flow.

When this is set to True, changes in low level partitions will be propagated to top partitions up to top module. Synplify Pro will possibly optimize timing data.
and certainly will write a new timestamp onto the partition for the top level module.

This option is equivalent to the “set_option -update_models_cp 1 | 0” command in Synplify Pro.

**Use Clock Period for Unconstrained I/O**  \( \text{PROP SYN EdfUnconsClk} \)
Controls whether to forward annotate constraints for I/O ports without explicit user-defined constraints.

When this is set to True, only explicit I/O port constraints are forward annotated. When it is set to False (the default), all I/O port constraints are forward annotated.

This option is equivalent to the “set_option -auto_constraint_io 1 | 0” command in Synplify Pro.

**VHDL 2008 (for Synplify Pro)**  \( \text{PROP SYN VHDL2008} \)
When this is set to True, VHDL 2008 is selected as the VHDL standard for the project.

---

**LSE Options**

This page lists all the strategy options associated with the LSE synthesis process.

**Allow Duplicate Modules (for LSE)**  \( \text{PROP LST AllowDUPMod} \)
When set to True, allows the design to keep duplicate modules. LSE issues a warning and uses the last definition of the module. Any previous definitions are ignored. The default is False, which causes an error if there are duplicate modules.

**Carry Chain Length**  \( \text{PROP LST CarryChainLength} \)
Specifies the maximum number of carry chain cells (CCUs) that get mapped to a single carry chain. Default is 0, which is interpreted as infinite length.

This option is equivalent to the “-carry_chain_length” option in the SYNTHESIS command.

This option is equivalent to the “-allow_duplicate_modules” option in the SYNTHESIS command.

**Command Line Options (for LSE)**  \( \text{PROP LST CmdLineArgs} \)
Enables additional command line options for the LSE Synthesis process.

**To enter a command line option:**
1. In the Strategy dialog box, select **LSE** in the Process list.
2. Double-click the Value column for the Command line Options option.
3. Type in the option and its value (if any) in the text box.
4. Click **Apply**.

For detailed description on LSE command line options, see “Running SYNTHESIS from the Command Line” on page 921.

**DSP Style**  PROP_LST_DSPStyle

Specifies how DSP modules should be implemented: with DSP resources or with Logic (LUTs).

This option is equivalent to the “-use_dsp” option in the SYNTHESIS command.

**DSP Utilization**  PROP_LST_DSPUtil

Specifies the percentage of DSP sites that LSE should try to use.

This option is equivalent to the “-dsp_utilization” option in the SYNTHESIS command.

**Decode Unreachable States**  PROP_LST_DecodeUnreachableStates

When set to True, synthesis infers safe recovery logic from unreachable states in all the state machines of the design.

This option is equivalent to the “-decode_unreachable_states” option in the SYNTHESIS command.

**Disable Distributed RAM**  PROP_LST_DisableDistRam

When set to True, inferred memory will not use the distributed RAM of the PFUs.

**EBR Utilization**  PROP_LST_EBRUtil

Specifies EBR utilization target setting in percent of total vacant sites. LSE will honor the setting and do the resource computation accordingly. Default is 100 (in percentage).

This option is equivalent to the “-bram_utilization” option in the SYNTHESIS command.

**FSM Encoding Style**  PROP_LST_FSMEncodeStyle

Specifies the encoding style to use with the design.
This option is equivalent to the “-fsm_encoding_style” option in the SYNTHESIS command. Valid options are auto, one-hot, gray, and binary. The default value is auto, meaning that the tool looks for the best implementation.

**Note**

The encoding type “gray” only works with less than or equal to four machine states. When the number of machine states is larger than four, LSE will use other encoding styles and issue the following warning message:

**WARNING - Gray encoding is not supported for state machines with more than four states.**

---

**Fix Gated Clocks**  PROP_LST_FIXGATEDCLKS

When set to True, LSE changes standard gated clocks to forms more effective for FPGAs. Clocks are gated with AND or OR gates to conserve power, but in FPGAs such clocks cause skew and prevent global clock resources from being used. The Fix Gated Clocks option is ignored if the Optimization Goal option is set to Area.

The gated clocks must be specified in the .ldc file with create_clock constraints. All inputs of the gating logic must be driven by primary inputs and the gating logic must be decomposable. Instantiated primitives and black boxes are not affected.

Converted clocks and the associated registers are reported in the synthesis.log file.

**Force GSR (for LSE) (LIFCL, LFD2NX)**  PROP_LST_ForceGSRInfer

Forces Global Set/Reset Pin usage. (LIFCL, LFD2NX).

Available options are:

- **Auto** – Allows the software to decide whether to infer Global Set/Reset in your design.
- **Yes** (default) – Always infers Global Set/Reset in your design.
- **No** – Does not infer Global Set/Reset in your design.

**Intermediate File Dump**  PROP_LST_InterFileDump

If you set this to True, LSE will produce intermediate encrypted Verilog files. If you supply Lattice with these files, they can be decrypted and analyzed for problems. This option is good for analyzing simulation issues.

This option is equivalent to the “-ifd” option in the SYNTHESIS command.

**Loop Limit**  PROP_LST_LoopLimit

Specifies the maximum number of iterations of “for” and “while” loops in the source code. The limit is applied when the loop index is a variable, not when it is a constant. The higher the loop_limit, the longer the run time. The default value is 1950. Setting a higher value may cause stack overflow during some of the optimizations during synthesis. A lower value will be ignored and the default used instead.
This option is equivalent to the “--loop_limit” option in the SYNTHESIS command.

**Macro Search Path (for LSE)**  \( \text{PROP}_\text{LST} \_\text{EdflnLibPath} \)

Allows you to specify a path (or paths) to locate physical macro files used in a given design. The software will add the specified paths to the list of directories to search when resolving file references. The option can also be used for indicating the directories containing include files that are specified in the RTL design files.

You don’t need to specify a search path if the necessary file is in the directory containing the top-level .ngo file or if the FILE attribute in the design gives a complete path name for the file (instead of a relative path name).

The software follows the following order to search:

1. Current implementation directory
2. Project directory
3. Directories where the LPC or IPX source files reside
4. User-specified macro search paths

To specify a macro search path, double-click the Value box, and directly enter the path or click the ... button to browse for one or more paths.

This option is equivalent to the “--p” option in the SYNTHESIS command.

**Max Fanout Limit**  \( \text{PROP}_\text{LST} \_\text{MaxFanout} \)

Specifies the maximum fanout setting. LSE will make sure that any net in the design is not exceeding this limit. Default is 1000 fanouts.

This option is equivalent to the “--max_fanout” option in the SYNTHESIS command.

**Memory Initial Value File Search Path (for LSE)**  \( \text{PROP}_\text{LST} \_\text{EdfMemPath} \)

Allows you to specify a path (or paths) to locate memory initialization file (.mem) used in a given design. The software will add the specified path(s) to the list of directories to search when resolving file references.

To specify a search path, double-click the Value box, and directly enter the path or click the ... button to browse for one or more paths.

This option is equivalent to the “--p” option in the SYNTHESIS command.

**Optimization Goal**  \( \text{PROP}_\text{LST} \_\text{OptimizeGoal} \)

Enables LSE to optimize the design for area, speed, or balanced.

Valid options are:

- Area – Optimizes the design for area by reducing the total amount of logic used for design implementation.
When Optimization Goal is set to Area, LSE honors the LDC constraints if there are any. If Use IO Registers is set to Auto, LSE packs input and output registers into I/O pad cells.

**Note**
With the Area setting, LSE also ignores all SDC constraints. These constraints are not used by LSE and are not added for use by the later stages of implementation.

- **Timing** – Optimizes the design for speed by reducing the levels of logic.

  When Optimization Goal is set to Timing and a create_clock constraint is available in an .ldc file, LSE ignores the Target Frequency setting and uses the value from the create_clock constraint instead.

  If there are multiple clocks, and if not all the clocks use create_clock constraint, then LSE will assign 200 MHz constraint on the remaining clocks in Timing Mode.

  If Use IO Registers is set to Auto, LSE does not pack input and output registers into I/O pad cells.

- **Balanced** – Optimizes the design for both area and timing.

  When Optimization Goal is set to Balanced, all timing driven optimizations based on static timing analysis will run depending on LDC constraints. If Use IO Registers is set to Auto, LSE does not pack input and output registers into I/O pad cells.

The default setting depends on the device type.

For more information, see "Optimizing LSE for Area and Timing" on page 251.

This option is equivalent to the "-optimization_goal" option in the SYNTHESIS command.

**Propagate Constants**  PROP_LST_PropagatConst

When set to True (default), enables constant propagation to reduce area, where possible. LSE will then eliminate the logic used when constant inputs to logic cause their outputs to be constant.

You can turn off the operation by setting this option to False.

This option is equivalent to the "-propagate_constants" option in the SYNTHESIS command.

**RAM Style**  PROP_LST_RAMStyle

Sets the type of random access memory globally to distributed, embedded block RAM, or registers.

The default is Auto which attempts to determine the best implementation, that is, the synthesis tool will map to technology RAM resources (EBR/Distributed) based on the resource availability.
This option will apply a syn_ramstyle attribute globally in the source to a module or to a RAM instance. To turn off RAM inference, set its value to Registers.

- Registers – Causes an inferred RAM to be mapped to registers (flip-flops and logic) rather than the technology-specific RAM resources.
- Distributed – Causes the RAM to be implemented using the distributed RAM or PFU resources.
- Block_RAM – Causes the RAM to be implemented using the dedicated RAM resources. If your RAM resources are limited, for whatever reason, you can map additional RAMs to registers instead of the dedicated or distributed RAM resources using this attribute.

This option is equivalent to the "-ramstyle" option in the SYNTHESIS command.

**ROM Style**  PROP_LST_ROMStyle

Allows you to globally implement ROM architectures using dedicated, distributed ROM, or a combination of the two (Auto).

This applies the syn_romstyle attribute globally to the design by adding the attribute to the module or entity. You can also specify this attribute on a single module or ROM instance.

Specifying a syn_romstyle attribute globally or on a module or ROM instance with a value of:

- Auto (default) – Allows the synthesis tool to choose the best implementation to meet the design requirements for speed, size, and so on.
- Logic – Causes the ROM to be implemented using the distributed ROM or PFU resources. Specifically, the logic value will implement ROM to logic (LUT4) or ROM technology primitives.
- EBR – Causes the ROM to be mapped to dedicated EBR block resources. ROM address or data should be registered to map it to an EBR block. If your ROM resources are limited, for whatever reason, you can map additional ROM to registers instead of the dedicated or distributed RAM resources using this attribute.

Infer ROM architectures using a CASE statement in your code. For the synthesis tool to implement a ROM, at least half of the available addresses in the CASE statement must be assigned a value. For example, consider a ROM with six address bits (64 unique addresses). The CASE statement for this ROM must specify values for at least 32 of the available addresses.

This option is equivalent to the "-romstyle" option in the SYNTHESIS command.

**Read Write Check on RAM**  PROP_LST_RWCheckOnRam

Adds (True) or does not add (False) the glue logic to resolve read/write conflicts wherever needed. Default is False.
**Remove Duplicate Registers**  
PROP_LST_RemoveDupRegs
Specifies the removal of duplicate registers.

When set to True (default), LSE removes a register if it is identical to another register. If two registers generate the same logic, the second one will be deleted and the first one will be made to fan out to the second one’s destinations. LSE will not remove duplicate registers if this option is set to False.

This option is equivalent to the "-remove_duplicate_regs" option in the SYNTHESIS command.

**Remove LOC Properties (for LSE)**  
PROP_LST_EdfInRemLoc
Setting this to On removes LOC properties in the synthesized design.

**Resolve Mixed Drivers (for LSE)**  
PROP_LST_ResolvedMixedDrivers
If a net is driven by a VCC or GND and active drivers, setting this option to True connects the net to the VCC or GND driver.

**Resource Sharing (for LSE)**  
PROP_LST_ResourceShare
When this is set to True (default), the synthesis tool uses resource sharing techniques to optimize area.

With resource sharing, synthesis uses the same arithmetic operators for mutually exclusive statements; for example, with the branches of a case statement. Conversely, you can improve timing by disabling resource sharing, but at the expense of increased area.

This option is equivalent to the "-resource_sharing" option in the SYNTHESIS command.

**Target Frequency**  
PROP_LST_EdfFrequency
Specifies the target frequency setting. This frequency applies to all the clocks in the design. If there are some clocks defined in an .ldc file, the remaining clocks will get this frequency setting. When a create_clock constraint is available in an .ldc file, LSE ignores the Target Frequency setting for that clock and uses the value from the create_clock constraint instead.

This option is equivalent to the "-frequency" option in the SYNTHESIS command.

**Use Carry Chain**  
PROP_LST_CarryChain
Turns on (True) or off (False) carry chain implementation for adders. Default is True.

This option is equivalent to the "-use_carry_chain" option in the SYNTHESIS command.

**Use IO Insertion**  
PROP_LST_IOInsertion
When set to True, LSE uses I/O insertion and GSR.
This option is equivalent to the "--use_io_insertion" option in the SYNTHESIS command.

**Use IO Registers**  PROP_LST.UseIOReg

When True, this option forces the synthesis tool to pack all input and output registers into I/O pad cells based on the timing requirements for the target device family. Auto, the default setting, enables this register packing if **Optimization Goal** is set to Area. If Optimization Goal is Timing or Balanced, Auto disables register packing.

This option is equivalent to the "use_io_reg" option in the SYNTHESIS command.

You can also control packing on individual registers and ports. See "syn_useioff" on page 628.

**VHDL 2008 (for LSE)**  PROP_LST.VHDL2008

When this is set to True, VHDL 2008 is selected as the VHDL standard for the project.

---

## Post-Synthesis Options

This page lists all strategy options associated with the Post-Synthesis process. The options available for user setting are dependent on the target device of your project.

**External Module Files (.udb)**  PROP_POSTSYN_ExtModuleFiles

Allows the user to supply already synthesized modules for design assembly into the top level design. These modules must be already synthesized in Unified Database (.udb) format.

For example:

c:\case1\ip1.udb; d:\example\aaa\abc.udb

Multiple .udb files can be separated by ‘;’

This internal process, Post-Synthesis, performed after logic synthesis resolves and assembles lower level modules to top level to complete the design contents.

All modules contents must be resolved at this stage before the flow can continue to the next stage.
Post-Synthesis Timing Analysis Options

This page lists all strategy options associated with the Post-Synthesis Timing Analysis process.

**Number of End Points**  
PROP_SYNSTA_EndPtNumber

Controls the number of endpoints in the critical endpoint summary.

**Number of Paths Per Constraint (for Post-Synthesis Timing Analysis)**  
PROP_SYNSTA_NumPathsPerClock

Lists detailed logic and route delays for all constrained paths and nets in the design.

**Number of Paths Per Endpoint (for Post-Synthesis Timing Analysis)**  
PROP_SYNSTA_NPerEnd

Controls maximum number of paths that could be reported for each endpoint.

**Number of Unconstrained Paths (for Post-Synthesis Timing Analysis)**  
PROP_SYNSTA_UnconstrainedPathsNumber

Reports paths not covered by a timing preference.

**Report Format (for Post-Synthesis Timing Analysis)**  
PROP_SYNSTA_ReportFormat

Specifies the report format type.

▶ Lattice Standard – Displays timing report format that is similar to formats used in many industry timing tools.
▶ Diamond Style – Displays timing report that is similar to Diamond software TRACE report.

**Timing Analysis Options (for Post-Synthesis Timing Analysis)**  
PROP_SYNSTA_AnalysisOption

Specifies the analysis type.

▶ Hold Analysis – Performs hold analysis.
▶ Standard Setup Analysis – Performs setup time checks.
▶ Standard Setup and Hold Analysis – Performs both the Standard Setup Analysis and the Hold Analysis.
Map Design Options

This page lists all strategy options associated with the Map Design process. The options available for user setting are dependent on the target device of your project.

**Command Line Options (for Map Design)**  
PROP_MAP_MapModArgs
Enables additional command line options for the associated process.

To enter a command line option:

1. In the Strategy dialog box, select the associated process in the Process list.
2. Double-click the Value column for the Command line Options option.
3. Type in the option and its value (if any) in the text box. For example: -exp parPathBased=ON
4. Click **Apply**.

To reference more information about command line options for the Map Design process, type map -h <architecture> in a command line window. For detailed options description, refer to “Running MAP from the Command Line” on page 928.

**Infer GSR**  
PROP_MAP_MAPInferGSR
(LIFCL and LFD2NX only): Enables or disables the GSR inferencing.

GSR inference is only applicable to PLC slice registers by default. Each black-box can have its own rules to guide mapper to perform GSR inference. Rules to be applied according to device architecture specification. For example, in LIFCL device, it is applicable to SLICE / IO registers, block RAM, large RAM, and DDR components.

When multiple GSR instances are found in the design, mapper is able to merge them if their outputs are actually the same wire in the netlist. Otherwise mapper will issue an error.

Mapper can also create a GSR component if user specified the GSR signal in the constraint file.

**Report Signal Cross Reference**  
PROP_MAP_SigCrossRef
When this is set to True, the map report (.mrp) will show where nets in the logical design were mapped in the physical design.

The default is False.

**Report Symbol Cross Reference**  
PROP_MAP_SymCrossRef
When this is set to True, the map report (.mrp) will show where symbols in the logical design were mapped in the physical design.

The default is False.
Map Timing Analysis Options

This page lists all strategy options associated with the Map Timing Analysis process.

**Number of End Points**  
PROP_MAPSTA_EndPtNumber

Controls the number of endpoints in the critical endpoint summary.

**Number of Paths Per Constraint (for Map Timing Analysis)**  
PROP_MAPSTA_NumPathsPerClock

Lists detailed logic and route delays for all constrained paths and nets in the design.

**Number of Paths Per Endpoint (for Map Timing Analysis)**  
PROP_MAPSTA_NPerEnd

Controls maximum number of paths that could be reported for each endpoint.

**Number of Unconstrained Paths (for Map Timing Analysis)**  
PROP_MAPSTA_UnconstrainedPathsNumber

Reports paths not covered by a timing preference.

**Report Format (for Map Timing Analysis)**  
PROP_MAPSTA_ReportFormat

Specifies the report format type.

- Lattice Standard – Displays timing report format that is similar to formats used in many industry timing tools.
- Diamond Style – Displays timing report that is similar to Diamond software TRACE report.

**Speed for Hold Analysis**  
PROP_MAPSTA_SpeedForHoldAnalysis

Specifies performance grade for hold analysis. This option allows you to override the default m (minimum) performance grade for hold time analysis, which represents faster silicon than the fastest performance grade of the device being targeted.

**Speed for Setup Analysis**  
PROP_MAPSTA_SpeedForSetupAnalysis

Specifies performance grade for setup analysis. This option allows you to override the default performance grade which runs setup analysis against the performance grade of the device currently targeted by the project implementation.

**Timing Analysis Options (for Map Timing Analysis)**  
PROP_MAPSTA_AnalysisOption

Specifies the analysis type.
Place & Route Design Options

This page lists all strategy options associated with the Place & Route Design process. The options available for user setting are dependent on the target device of your project.

Command Line Options (for Place & Route Design)
PROP_PAR_PARModArgs

Allows you to specify options from the par command without directly using the command line. Type in a string of options without the par command. For example: `-exp parPathBased=ON:parHold=1`

For detailed descriptions of placement, routing, and PAR explorer (-exp) command line options, see “Running PAR from the Command Line” on page 930.

Disable Auto Hold Timing Correction (for Place & Route Design)
PROP_PAR_DisableAutoHldTiming

When the switch is used, PAR will not check the hold timing of the design, so no correction of potential hold timing violations will be performed.

Disable Timing Driven (for Place & Route Design)
PROP_PAR_DisableTDParDes

Enables or disables the timing-driven option for the PAR run.

When this is set to True, the timing-driven option for the PAR run will not be used. If this is set to False, PAR automatically uses the timing-driven option if the Timing Wizard is present and if any timing constraints are found in the preference file. If selected, the timing-driven option is not invoked in any case and cost-based placement and routing are done instead.

Two examples of situations in which you might disable this option are:

- You have timing constraints specified in your preference file, but you want to execute a quick PAR run without using the timing-driven option to give you a rough idea of how difficult the design is to place and route.
- You only have a single license for the timing-driven option but you want to use this license for another application (for example, to perform timing-driven routing within EPIC) that will run at the same time as PAR. This option keeps the license free for the other application.

Multi-Tasking Node List
PROP_PAR_ParMultiNodeList

Allows you to specify the node file name for the multi-tasking PAR.
The multi-tasking PAR allows you to use multiple machines (nodes) that are networked together for a multi-run PAR job, significantly reducing the total amount of time for completion.

For more information on multi-tasking PAR, see “Running Multiple PAR Jobs in Parallel” on page 270.

**Number of Host Machine Cores**  \( \text{PROP}_{\text{PAR}} \text{._NumOfHostMachineCores} \)

Allows you to run multiple threads on your local machine by specifying how many cores to be used from your local machine. The range is from 0 to 64.

**Pack Logic Block Utility**  \( \text{PROP}_{\text{PAR}} \text{._PackLogicUtil} \)

Sets the relative density (of available slices) at which the slices within a device are to be packed, in terms of a percentage of the available slices in the device.

This option has great control of the packing density. The value range is 0-100 percent (100 = minimum packing; 0 = maximum density).

If this option is not specified (blank), it defaults to 97 percent. The result will be a less dense packing, depending on the size of the design relative to the number of available slices in the device. If the design is large compared with the number of available slices in the device, the mapper will make a reasonable effort to pack the design so that it fits in the device.

If you specify a density value for this option, the mapper will attempt to pack the device to that density. The “0” setting results in the densest mapping. If the design is large compared with the target density, the mapper will make an aggressive packing effort to meet your target. However, this may adversely impact the design \( f_{\text{MAX}} \) performance.

**Path-based Placement**  \( \text{PROP}_{\text{PAR}} \text{._parPathBased} \)

Allows you to apply path-based placement. Path-based placement gives better performance and more predictable results.

Options are Off and On.

**Placement Iteration Start Point**  \( \text{PROP}_{\text{PAR}} \text{._PlcStCostTblParDes} \)

Specifies the cost table to use (from 1-100) to begin the PAR run.

The default is 1. Cost tables are not an ordered set. There is no correlation between a cost table’s number and its relative value. If cost table 100 is reached, placement does not begin at 1 again, even if command options specify that more placements should be performed.

**Placement Iterations**  \( \text{PROP}_{\text{PAR}} \text{._PlctIterParDes} \)

Specifies the maximum number of placement/routing passes (0-100, 0 = run until solved) to be run (regardless of whether they complete) at the Placement Effort Level.
Each iteration uses a different cost table when the design is placed and will produce a different Uniform Database (.udb) file. If you specify a Starting Cost Table, the iterations begin at that table number.

**Placement Save Best Run**  PROP_PAR_SaveBestRsltParDes

Determine the number (1-100) of best outputs of the Place and Route run to save (defaults to 1).

If no number is specified, all output designs produced by the PLACE & ROUTE run are saved. The best outputs are determined by a scoring system described in the section titled Scoring the Routed Design.

This option does not care how many iterations you performed or how many effort levels were used. It compares every result to every other result.

**Prioritize Hold Correction Over Setup Performance (for Place & Route Design)**  PROP_PAR_PriHldCorrectOverSetup

During hold timing correction, there may be situations when correcting a hold timing violation would cause a setup requirement to become violated. By default, we do not correct the hold violation on such connections so as to preserve the setup performance, but when this switch is used, we will attempt to correct the hold violation and let the setup requirement become violated.

**Run Placement Only**  PROP_PAR_ParRunPlaceOnly

Setting this to True prevents the design from being routed. PAR will output a placed, but not routed Unified Design Database (.udb) file.

This option defaults to False.

**Set Speed Grade for Hold Optimization (for Place & Route Design)**  PROP_PAR_SpdGradeHoldOpt

This overrides the default speed grade used to perform hold timing analysis.

**Set Speed Grade for Setup Optimization**  PROP_PAR_SpdGradeSetupOpt

Change performance grade for setup optimization.

**Stop Once Timing is Met (for Place & Route Design)**  PROP_PAR_StopZero

Setting this to True forces the Place and Route Design process to stop as soon as the timing requirement is satisfied. This option has no effect if the "Generate Timing Analysis report for each iteration" option is set to True or if using Run Manager to produce multiple place-and-route runs.
Place & Route Timing Analysis Options

This page lists all strategy options associated with the Place & Route Timing Analysis process.

Number of End Points (for Place & Route Timing Analysis)
PROP_PARSTA_EndPtNumber
Controls the number of endpoints in the critical endpoint summary.

Number of Paths Per Constraint (for Place & Route Timing Analysis)
PROP_PARSTA_NumPathsPerClock
Lists detailed logic and route delays for all constrained paths and nets in the design.

Number of Paths Per Endpoint (for Place & Route Timing Analysis)
PROP_PARSTA_NPerEnd
Controls maximum number of paths that could be reported for each endpoint.

Number of Unconstrained Paths (for Place & Route Timing Analysis)
PROP_PARSTA_UnconstrainedPathsNumber
Reports paths not covered by a timing preference.

Report Format (for Place & Route Timing Analysis)
PROP_PARSTA_ReportFormat
Specifies the report format type.

- Lattice Standard – Displays timing report format that is similar to formats used in many industry timing tools.
- Diamond Style – Displays timing report that is similar to Diamond software TRACE report.

Speed for Hold Analysis
PROP_PARSTA_SpeedForHoldAnalysis
Specifies performance grade for hold analysis. This option allows you to override the default m (minimum) performance grade for hold time analysis, which represents faster silicon than the fastest performance grade of the device being targeted.

Speed for Setup Analysis
PROP_PARSTA_SpeedForSetupAnalysis
Specifies performance grade for setup analysis. This option allows you to override the default performance grade which runs setup analysis against the performance grade of the device currently targeted by the project implementation.

Timing Analysis Options (for Place & Route Timing Analysis)
PROP_PARSTA_AnalysisOption
IO Timing Analysis Options

The following option is associated with the IO Timing Analysis process.

**All Performance Grade**  PROP_IOTIMING_AllSpeed

Controls whether the I/O timing report (.ior) will give an in-depth analysis on all available performance grades or will just produce a summary report on the worst-case performance grade.

- **True** - The I/O Timing Report will summarize the worst-case scenario of all available performance grades.
- **False (default)** - The I/O Timing Report will only contain a summary of the worst-case performance grade for the given device.

Timing Simulation Options

This page lists all strategy options associated with the Timing Simulation process. The options available for user setting are dependent on the target device of your project.

**Generate PUR in the Netlist**  PROP_TIM_TimSimGenPUR

When this is set to False, the timing simulation file generation process will not write PUR instance in the Verilog/VHDL back-annotation netlist. Then you have to instantiate PUR in the test bench.

**Generate X for Setup/Hold Violation**  PROP_TIM_TimSimGenX

When this is set to True, the Timing Simulation process will place X notifiers in the output file on flip-flops with setup and/or hold time violations.

**Multichip Module Prefix**  PROP_TIM_ModPreSimDes

Adds a prefix to module names to make them unique for multi-chip simulation.

**Negative Setup-Hold Times**  PROP_TIM_NegStupHldTim

Allows you to select negative setup time and negative hold time for better accuracy.

The default is True. You can set it to False for those simulators that might not be able to handle negative setup-hold times.
Retarget Speed Grade  PROP_TIM_TrgtSpeedGrade
Retargets back annotation to a different performance grade than the one used to create the Uniform Database (.udb) file.

You are limited to those performance grades available for the device used in the UDB file.

Timing Check With Min Speed Grade  PROP_TIM_MinSpeedGrade
Setting this to True replaces all timing information for back annotation with the minimum timing for all paths.

This option is used for simulation of hold time requirements. Separate simulations are required for hold time verification (-min switch) and delay time verification (normal output).

Timing Simulation Max Delay between Buffers (ps)  PROP_TIM_MaxDelSimDes
Distributes routing delays by splitting the signal and inserting buffers. The delay value assigned represents the maximum delay number in picoseconds between each buffer (1000 ps by default).

Verilog Hierarchy Separator  PROP_TIM_TimSimHierSep
Specifies the hierarchy separator character which will be used in name generation when the design hierarchy is flattened.

You can specify the following two special characters as the hierarchy separator: "/" (back-slash) or "." (period).

Enter the character as is in the edit box. Encapsulate the character with double quotes, for example, "/", ".".

The option is only available for Verilog designs.

Bitstream Options
This page lists all strategy options associated with the bitstream generation process. The options available for user setting are dependent on the target device of your project.

Command Line Options  PROP_BIT_CmdLineArgs
Enables additional command line options for the associated process.

Enable Early IO Wakeup  PROP_BIT_EnableIOWakeup
Enable IO output as soon as possible. (LIFCL, LFD2NX only)

Enable Timing Check  PROP_TMCHK_EnableCheck
When this is set to true and there is timing error in the Place and Route report file, a dialogue box will display before executing bitstream generation.

**Enable Warm Boot**  
PROP_BIT_WarmBoot

Enables the Warm Boot functionality, provided the design contains an instance of the WARMBOOT primitive. (ICE40UP)

**Initialize EBR Quadrant 0**  
PROP_BIT_INITEBR0

Write the EBR initialization data into the bitstream for quadrant 0. (ICE40UP)

**Initialize EBR Quadrant 1**  
PROP_BIT_INITEBR1

Write the EBR initialization data into the bitstream for quadrant 1. (ICE40UP)

**Initialize EBR Quadrant 2**  
PROP_BIT_INITEBR2

Write the EBR initialization data into the bitstream for quadrant 2. (ICE40UP)

**Initialize EBR Quadrant 3**  
PROP_BIT_INITEBR3

Write the EBR initialization data into the bitstream for quadrant 3. (ICE40UP)

**IP Evaluation**  
PROP_BIT_IPEval

When enabled, a bitstream will be generated for evaluation purposes when an IP license is not found, but will be limited to a maximum of four hours before the device resets itself. When disabled, a bitstream will not be generated if an IP license is not found (LIFCL, LFD2NX only).

**No header**  
PROP_BIT_NoHeader

Don't write the bitstream header section. (ICE40UP)

**Set All Unused IO No Pullup**  
PROP_BIT_NoPullup

Removes the pullup on the unused I/Os, except Bank 3 I/Os which do not have pullup. (ICE40UP)

**Oscillator Frequency Range**  
PROP_BIT_OSCFREQ

Options include Medium and Slow. Fast is not supported for ICE40UP. Only for NVCM configuration, not for programming.

Depending on the speed of external PROM, this option adjusts the frequency of the internal oscillator used by the ICE40UP device during configuration. This is only applicable when the ICE40UP device is used in SPI Master Mode for configuration.

**Output Format**  
PROP_BIT_OutFormatBitGen

Specifies the type of bitstream to create for an FPGA device.

The following options are available:
- **Bit File (Binary)** – Generates a binary configuration file (.bin) that contains the default outputs of the Bit Generation process.

- **Raw Bit File (ASCII)** – Generates an ASCII raw bit text file (.rbt) of ASCII ones and zeros that represent the bits in the bitstream file. If you are using a microprocessor to configure a single FPGA, you can include the Raw Bit file in the source code as a text file to represent the configuration data. The sequence of characters in the Raw Bit file is the same as the bit sequence that will be written into the FPGA.

- **Hex File (Hexadecimal)** – Generates a Hexadecimal (.hex) PROM data file used for Programming into external non-volatile memory, such as parallel or Serial Peripheral Interface (SPI) Flash devices (ICE40UP only).

- **NVCM File (Non-volatile Configuration Memory)** – Generates a Non-volatile Configuration Memory (.nvcm). Each line in this file is a separate NVCM instruction for bitmap programming. The exceptions are comment lines (usually the first few lines in the file) which start with the # sign. Comment lines should be ignored when programming the NVCM array. The comment lines contain comments as well as header information (ICE40UP only).

**Register Initialization**  PROP_BIT_RegInit

Enable register initialization section of the bitstream (LIFCL, LFD2NX only).

**Run DRC**  PROP_BIT_RunDRCBitGen

When this is set to True, the software runs a physical design rule check and saves the output to the Bit Generation report file (.bgn).

Running DRC before a bitstream or JEDEC file is produced will detect any errors that could cause the FPGA to function improperly. If no fatal errors are detected, it will produce a bitstream or JEDEC file. Run DRC is the default.

**SPI Flash Low Power Mode**  PROP_BIT_SPILowPower

Places the PROM in low-power mode after configuration. (ICE40UP)

This option is applicable only when the ICE40UP device is used as SPI Master Mode for configuration.

**Set NVCM Security**  PROP_BIT_NVCMSecurity

Ensures that the contents of the Non-Volatile Configuration Memory (NVCM) are secure and the configuration data cannot be read out of the device. (ICE40UP)
Constraints Reference Guide

Constraints are instructions applied to design elements that guide the design toward desired results and performance goals. They are critical to achieving timing closure or managing reusable intellectual property (IP). The most common constraints are those for timing and pin assignments, but constraints are also available for placement, routing, and many other functions. In the Radiant software design flow, constraints include logical constraints and HDL attributes.

You can assign constraints using one or both of the following methods:

- Assign Lattice design (timing) constraints (.PDC) via the Device Constraint editor tool.
  
  See the “Device Constraint Editor” on page 187 for complete descriptions of each constraint, including syntax rules and examples.

- Assign Lattice design timing constraints (.LDC) via the “Timing Constraint Editor” on page 208.

- Assign HDL or schematic-based attributes using design source files. These attributes are used to direct Map and Place & Route.
  
  See the “HDL Attributes” on page 546 for complete descriptions of each attribute, including conventions and examples.

If you are using the Lattice Synthesis Engine (LSE), constraints will also include Synopsys Design Constraints (SDC) as well as HDL attributes and directives that influence the optimization or structure of the output netlist. See the “Lattice Synthesis Engine Constraints” on page 563 for descriptions of these LSE constraints.

See Also

-“Applying Design Constraints” on page 164
-“Integrated Synthesis” on page 253
HDL Attributes

HDL attributes are constraints that are attached as text to design objects and interpreted by the Radiant software. A design object can be a specific port, component pin, net, instance, instantiation, or even an entire design. An attribute provides information about the object. For example, an attribute might specify where a component in the logical design must be placed in the physical device, or it might specify a frequency constraint for a net that timing-driven place and route will attempt to meet.

The HDL attributes described in this section are those most commonly used as constraints in HDL source files. They generally apply to all designs and are not specific to any architecture.

HDL attributes are typically declared using comment notation in Verilog HDL or the VHDL Attribute keyword.

**Note**

A comprehensive guide to library element HDL attributes is available in the "FPGA Libraries Reference Guide" on page 637. For specific applications, refer to the technical notes that are available on the Lattice web site. Editing these library element attributes is not recommended, as they are usually generated from an array of choices that are made for module generation using IP Catalog.

### BBOX

**Convention**  BBOX= x,x

**Description** Indicates the bounding box or the area given in number of rows and columns for a given GRP. The attribute must appear on the same block as the GRP attribute.

**Device Support** All

**Syntax**  BBOX= H,W

where H is height, W is width.

For example, the following parameter indicates a BBOX that is three rows high and seven columns wide.

**Figure 34: Example of a BBOX Parameter**

BBOX= 3, 7

You will see BBOX with the GRP definition below it.
CLAMP

Convention  CLAMP = OFF | ON

Default value of CLAMP for OUTPUT = OFF.

Default value of CLAMP for INPUT = ON if vccio is same as I/O standard.

Default value of CLAMP for INPUT = OFF if vccio is some other value than I/O standard.

Description  The CLAMP option can be enabled for each IO independently. The CLAMP attribute is not supported for LVCMOS I/O types used in an under-drive or over-drive mode.

Device Support  LIFCL, LFD2NX

VHDL Syntax  ATTRIBUTE CLAMP : string;
ATTRIBUTE CLAMP OF [pin_name]: SIGNAL IS "[mode]";

VHDL Example Code  ATTRIBUTE CLAMP OF Q: SIGNAL IS "ON";

Verilog Syntax – Synplify  PIOType [pin_name] /* synthesis
CLAMP="[mode]"*/;
  [mode] = OFF | ON

Verilog Example Code – Synplify
module rtl_top #(parameter width = 8) (DA, DB, CLK, Q);
output [width-1:0]/* synthesis CLAMP=ON*/;

.ldc TCL command  ldc_set_port -iobuf {CLAMP=ON} [get_ports Q[1]]

DIFFDRIVE

Convention  DIFFDRIVE = 2.0, 3.5

Description  This attribute sets the differential current drive strength for the MINILVDS output standard. An IO bank can only have differential outputs with the same DIFFDRIVE setting. The default is set to 2.0mA for MIPI and 3.5 for LVDS.

Device Support  LIFCL, LFD2NX

VHDL Syntax  ATTRIBUTE DIFFDRIVE : string;
ATTRIBUTE DIFFDRIVE OF [pin_name]: SIGNAL IS "[diffdrive_strength]";

VHDL Example Code  ATTRIBUTE DIFFDRIVE OF portD: SIGNAL IS "2.0";
Verilog Syntax  PinType [pin_name] /* synthesis IO_TYPE="[type_name]" DIFFDRIVE="[diffdrive_strength]"*/;

Verilog Example Code  output mypin /* synthesis IO_TYPE="MINILVDS" DIFFDRIVE="2.0"*/;

.ldc TCL command  ldc_set_port -iobuf {DIFFDRIVE=2.0} [get_ports portD[1]]

DIFFRESISTOR

Convention  DIFFRESISTOR = OFF (default), 120, 150, 220, 420 (Only for differential buffers)

Description  Attribute attached to input and output buffers (e.g., IB, OB) and is used to provide differential termination. It is only available for differential I/O types. In case of a differential output termination, this is only available on the primary pads of the PIO. You have the option to turn on the common mode differential termination.

Device Support  LIFCL, LFD2NX

VHDL Syntax  ATTRIBUTE DIFFRESISTOR : string;
ATTRIBUTE DIFFDRIVE OF [pin_name]: SIGNAL IS "[value]";

VHDL Example Code  ATTRIBUTE DIFFRESISTOR OF portD: SIGNAL IS "120";

Verilog Syntax  PinType [pin_name] /* synthesis IO_TYPE="[type_name]" DIFFRESISTOR="[value]"*/;

Verilog Example Code  output mypin /* synthesis IO_TYPE="MINILVDS" DIFFRESISTOR="220"*/;

.ldc TCL command  ldc_set_port -iobuf {DIFFRESISTOR=220} [get_ports portD[1]]

DRIVE

Convention  DRIVE= NA, 2, 4, 8 (default), 12, 16, 24

Description  Attached to bidirectional and output buffers (e.g., BB, OB, OBZ_B, OB_RGB), the drive strength attribute is available for output standards that support programmable drive strength.

The programmable drive available on a pad depends on the VCCIO. Also, not all drive strengths are available on an alternate PIO pad. Both the single-
ended driver and differential current source driver have programmable drive strength. Only three drive settings are available when operating at 3.3 volts.

### Table 146: Valid Drive Strength Table

<table>
<thead>
<tr>
<th>Drive Strength (mA)</th>
<th>VCCIO 1.2V</th>
<th>VCCIO 1.5V</th>
<th>VCCIO 1.8V</th>
<th>VCCIO 2.5V</th>
<th>VCCIO 3.3V</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>12</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>16</td>
<td></td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>24</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>X</td>
</tr>
</tbody>
</table>

**Device Support**  All

**VHDL Syntax**

ATTRIBUTE DRIVE : string;
ATTRIBUTE DRIVE OF [pin_name]: SIGNAL IS "[drive_strength]";

**VHDL Example Code**

ATTRIBUTE DRIVE OF portD: SIGNAL IS "8";

**Verilog Syntax – Synplify**

PinType [pin_name] /* synthesis
IO_TYPE="[type_name]" DRIVE="[drive_strength]" PULLMODE="[mode]"
SLEWRATE="[value]"*/;
[drive_strength] = 2, 4, 8, 12, 16, 20

**Note**: Example given for Pin I/O Type configuration.

**Verilog Example Code – Synplify**

//output mypin /* synthesis
IO_TYPE="LVTTL33D" DRIVE="16" PULLMODE="UP" SLEWRATE="FAST"*/;

**.ldc TCL command**

ldc_set_port -iobuf {DRIVE=16} get_ports [mypin]

**See Also**  ▶ IO_TYPE

### GRP

**Convention**  GRP = <identifier>

**Description**  Universal grouping construct. Use the GRP attribute to group blocks within different hierarchies or with no hierarchy.
You can add GRP anchor and bounding box information to the HDL with BBOX attribute and anchoring it with a SDC constraint. Alternatively, you can allow a GRP to float within a REGION.

Note that RLOC / GLOC (Region Lock / Group Lock) can only be used with REGION or GRP attributes. The value it takes is a site value on the device itself which can be deciphered as such:

RLOC/GLOC = "R5C19D"

i.e. Row 5, Column 19, Slice D

**Device Support** All

**Syntax**

GRP="<GRP_name>"

[BBOX="<height>,<width>"]

where:

<GRP_name> is a user-defined name.

<site_name> is a row/column Slice D location of the target device in the format R<n>C<m>D, an EBR site in the format EBR_R<n>C<m>, or a DSP site in the format DSP_R<n>C<m>.

<height> is the number of device rows of a rectangular bounding box.

<width> is the number of device columns of a rectangular bounding box.

The VHDL and Verilog examples show anchored GRPs. The current mechanism is to define the BBOX and GRP name in the attribute and the anchor location must be set via the SDC constraint ldc_set_location.

**VHDL Syntax**

attribute GRP: string;
attribute GRP of <object>: label is "<GRP_name>";
attribute BBOX: string;
attribute BBOX of <object>: label is "<height>,<width>";

**VHDL Example Code**

attribute GRP: string;
attribute GRP of x: label is "reg_group";
attribute BBOX: string;
attribute BBOX of <object>: label is "9,7";

**Verilog Syntax – Synplify**

"module serial_reg_custom(D, CLK, CE, RST, Q)
  /* synthesis GRP = "reg_group" GLOC= "R5C19D" BBOX= "6,4"*/;
serial_reg_custom inst1A(.D(A), .CLK(CLK), .CE(CE), .RST(RST), .Q(add1_in1));"
serial_reg_custom inst1B(.D(add1_in2), .CLK(CLK), .CE(CE), .RST(RST),
    .Q);
serial_reg_custom inst1C(.D(add1_sum), .CLK(CLK), .CE(CE),
    .RST(RST), .Q(SUM));

*/

Note

Synthesis directives to preserve hierarchy are typically needed to retain the
instances constrained by the GRP attribute.

.ldc TCL command
"ldc_create_group -name "reg_GROUP" -bbox
{6 4} [get_cells {inst1A inst1B inst1C}]
ldc_set_location -site "R5C19D" [ldc_get_group "reg_GROUP"]

Required to set Anchor location using SDC constraint

Figure 35: Anchor Location using SDC Constraint

.ldc_set_location -site R16C6A [ldc_get_groups reg_group]

GRP Attribute Usage Rules and Restrictions

Observe the following conditions for proper GRP attribute usage:

- All elements within the GRP block belong to that particular GRP.
- Nested GRP blocks are considered as unique individual GRPs.
- All blocks belong to the GRP attached to their nearest ancestor in the
  hierarchy.
- Unlike GRP, the mapper will not append the hierarchical path plus the
  block instance name.

GSR

Convention
GSR= value
GSR=ENABLED | DISABLED

Description
Enables or disables the global set/reset function. Can be applied to a module
or cell.

Device Support
LIFCL, LFD2NX

VHDL Syntax
ATTRIBUTE GSR : string;
ATTRIBUTE GSR OF [module_name]: entity IS "[value]";

VHDL Example Code
ATTRIBUTE GSR : string;
ATTRIBUTE GSR OF behave: entity IS "ENABLED";
**HYSTERESIS**

**Conventional**  
HYSTERESIS = SMALL | LARGE | NA

**Description**  
The ratioed input buffers have 2 input hysteresis settings. The HYSTERESIS option can be used to change the amount of hysteresis for the PCI, LVTTL and LVCMOS input and bidirectional I/O standards, except for the LVCMOS12 inputs.

The LVCMOS25R33, LVCMOS18R25, LVCMOS18R33, LVCMOS15R25, and LVCMOS15R33 input types do not support HYSTERESIS so this setting is always disabled for these types. HYSTERESIS is not supported for LVCMOS I/O types when used in an under-drive or over-drive mode.

The HYSTERESIS option for each of the input pins can be set independently when hysteresis is supported for the IO_TYPE assigned to the input pin.

**Device Support**  
LIFCL, LFD2NX

**VHDL Syntax – Synplify**  
ATTRIBUTE HYSTERESIS: string;
ATTRIBUTE HYSTERESIS OF [signal_name]: SIGNAL IS "[ SMALL | LARGE | NA]";

**VHDL Example Code**  
ATTRIBUTE HYSTERESIS OF q_lvttl33_17: SIGNAL IS "LARGE ";

**Verilog Syntax – Synplify**  
/* synthesis attribute HYSTERESIS [of] signal_name [is] [SMALL | LARGE | NA] */;

**Verilog Example Code**  
/* synthesis attribute HYSTERESIS of q_lvttl33_17 is LARGE */;

**.Icd TCL command**  
ldc_set_port -iobuf {HYSTERESIS=SMALL} [get_ports q_lvttl33_17] */;

**INBUF**

**Conventional**  
INBUF = OFF | ON
**Description**  
INBUF is a global setting. All unused input buffers are disabled when INBUF is OFF to save power. When you need to perform boundary scan testing, you must turn ON the INBUF attribute. Turning ON this INBUF attribute will turn on the input buffers.

**Device Support**  
All

**VHDL Syntax**  
ATTRIBUTE INBUF : string;  
ATTRIBUTE INBUF OF [module_name]: entity IS "[value]";

**VHDL Example Code**  
ATTRIBUTE INBUF : string;  
ATTRIBUTE INBUF OF behave: entity IS "OFF";

**Verilog Syntax – Synplify**  
module [module_name] (ports) /* synthesis INBUF= "[value]"*/;

**Verilog Example Code – Synplify**  
module pci_top (portA, portB) /* synthesis INBUF= "OFF" */;

**.ldc TCL command**  
ldc_set_port -iobuf {INBUF=OFF} [get_ports portA]

---

**INIT**

**Convention**  
INIT= value  
INIT=ENABLED | DISABLED

**Description**  
Initializes the look-up table values for all device families.

**Device Support**  
All

**VHDL Syntax**  
ATTRIBUTE INIT : string;  
ATTRIBUTE INIT OF [module_name]: entity IS "[value]";

**VHDL Example Code**  
ATTRIBUTE INIT : string;  
ATTRIBUTE INIT OF behave: entity IS "ENABLED";

**Verilog Syntax – Synplify**  
module [module_name] (ports) /* synthesis INIT= "[value]"*/;

**Verilog Example Code – Synplify**  
module pci_top (portA, portB) /* synthesis INIT= "ENABLED" */;

**.ldc TCL command**  
ldc_set_port -iobuf {INIT=ENABLED} [get_ports portA]

---

**IO_TYPE**

**Convention**  
IO_TYPE= buffer type
Description  This is used to set the I/O standard for an I/O (input, output, and bidirectional buffers, e.g., IB, OB, and BB). Multiple values may be required that differ slightly depending on which element you are using. The VCCIO required to set these I/O standards are embedded in the attribute names. There is no separate attribute to set the VCCIO requirements.

This attribute is used in conjunction with the IOBUF constraint. Refer to IOBUF to see how global constraints are honored for IO_TYPE. For valid buffer types, refer to the specific element in the FPGA Libraries Help. See the sysIO usage guides for legal IO_TYPE for inputs and outputs.

Examples of attribute usage for VHDL and Verilog are included in this topic.

Device Support  All

Values  LVDS, BLVDS25, MLVDS25, RSDS, LVPECL25, LVPECL33, HSTL15_I, HSTL15_II, HSTL15_III, HSTL15_IV, HSTL15D_I, HSTL15D_II, HSTL18_I, HSTL18_II, HSTL18_III, HSTL18_IV, HSTL18D_I, HSTL18D_II, SSTL18_I, SSTL18_II, SSTL18D_I, SSTL18D_II, SSTL25_I, SSTL25_II, SSTL25D_I, SSTL25D_II, SSTL33_I, SSTL_II, SSTL33D_I, SSTL33D_II, GTLPLUS15, GTL12, LVTTL33, LVTTL3D, LVCMS33, LVCMS25, LVCMS18, LVCMS15, LVCMS12, PCI33, PCI3X33, PCI15, AGP1X33, AGP2X33, LVCMS25D, LVCMS33D, LVCMS18D, LVCMS15D, LVCMS12D

Default  LVCMS33

VHDL Syntax  ATTRIBUTE IO_TYPE : string;
ATTRIBUTE IO_TYPE OF [pin_name]: SIGNAL IS "[type_name]";

Example Code:  ATTRIBUTE IO_TYPE OF portA: SIGNAL IS "PCI33";
ATTRIBUTE IO_TYPE OF portB: SIGNAL IS "LVCMS33";
ATTRIBUTE IO_TYPE OF portC: SIGNAL IS "SSTL33_II";
ATTRIBUTE IO_TYPE OF portD: SIGNAL IS "LVCMS25";

Verilog Syntax – Synplify  PinType [pin_name] /* synthesis
IO_TYPE=type_name" DRIVE=[drive_strength]" PULLMODE=[mode]" SLEWRATE=[value]"*/;
[value] = (valid I/O type, e.g., LVCMSO18)

Note: Example given for Pin I/O Type configuration.

Verilog Example Code – Synplify  output [4:0] portA /* synthesis
IO_TYPE="LVTTL33" DRIVE="16" PULLMODE="UP" SLEWRATE="FAST"*/;

.Ldc TCL command  ldc_set_port -iobuf {IO_TYPE=LVTTL33}
[get_ports portA[1]]

LOC

Convention  LOC= site_name (PIN | POS)
**Description**  Specifies a site location for the component that is created when this block is mapped. Attaching to multiple blocks indicates that these blocks are to be mapped together in the specified site.

When the device is mapped, the Map Design process (map) first maps blocks to PLCs without looking at LOC attributes. It then attempts to merge all PLCs with the same LOC attribute into a single PLC, and then it assigns this PLC to the site with the specified site name. If all of the blocks with the LOC attribute cannot be mapped into a single component, MAP groups together as many as possible.

When it encounters a LOC constraint, MAP also writes a LOCATE constraint for the component into the constraint file. The LOCATE constraint locks the component to the site. When you run PAR, the component cannot be unplaced, moved, swapped, or deleted.

The LOC attribute can be attached to anything that will end up on an I/O cell, and to clocks and internal flip-flops, but it should not be attached to combinational logic that will end up on a logic cell. Doing so could fail the generation of a locate constraint. The LOC attribute overrides register ordering.

**Device Support**  All

**VHDL Syntax**  ATTRIBUTE LOC : string;
ATTRIBUTE LOC OF [pin_name] : SIGNAL IS "[site_name]";

**VHDL Example Code**  ATTRIBUTE LOC : string;
ATTRIBUTE LOC OF output_vector : SIGNAL IS "H5";

**Verilog Syntax – Synplify**  PinType [pin_name] /* synthesis LOC="[site_name]"*/;

**Verilog Example Code – Synplify**  //input rst /* synthesis LOC="H5" */;

**.ldc TCL command**  ldc_set_location -site H5 [get_ports rst]
ldc_define_attribute -attr loc -value A12 -object_type port -object {clk1}

The following examples show slice locations for packing registers:

**VHDL Example Code for Register Packing**  ATTRIBUTE LOC : string;
ATTRIBUTE LOC OF inreg : SIGNAL IS "R2C9D R2C9D R2C8D R2C8D R2C7D R2C7D R2C6D R2C6D R2C5D R2C5D R2C4D R2C4D R2C3D R2C3D R2C2D R2C2D";

**NOCLIP**

**Convention**  NOCLIP=1
**Description**  Assigned to a net or an instance, indicates that the net or instance cannot be removed as unused logic.

When the design is mapped, the default MAP setting removes any unused logic from the design. In most cases, you will want to do this, since unused logic takes up device components and routing resources unnecessarily. However, when you want to keep unused logic in the design, place a NOCLIP attribute on selected nets, and the nets on which you place the attribute are protected from removal, along with any valid logic connected to these nets.

For a path to be considered valid, it must have a valid input and a valid output.

Valid path inputs include:
- An input pad or the input portion of a bidirectional pad.
- A pullup or pulldown resistor.
- An oscillator primitive.
- A logic 1 or logic 0 primitive.
- A net with a NOCLIP attribute on it.

Valid path outputs include:
- An output pad or the output portion of a bidirectional pad.
- A net with a NOCLIP attribute on it.

If a path is not valid, the MAP program removes its logic as unused. To protect all or part of an invalid path from being removed, add a NOCLIP attribute to the appropriate net. The attribute can act as either a valid input or a valid output, depending on what is necessary to complete the path.

Figure 36 shows an example of how a NOCLIP attribute affects clipping:

**Figure 36: Example of NOCLIP Attribute Affects Clipping**

Some notes about using the NOCLIP attribute:
If you design an on-chip oscillator (by building one from components in the device instead of using an oscillator primitive), the MAP program assumes the logic is unused and removes it because the oscillator logic does not contain a valid driver. To retain your oscillator logic, protect it by placing NOCLIP on the appropriate nets.

If you design a circuit with a feedback loop and the looped signal is not driving any other loads but the loop itself, the loop is eliminated as unused logic. If you want to keep the loop in the design, make sure you protect the loop with a NOCLIP attribute.

**Device Support**  All

**Verilog example**

```verilog
wire net_a /* synthesis syn_keep=1 */ /* synthesis NOCLIP=1 */;
```

or

```verilog
wire net_a /* synthesis syn_keep=1 NOCLIP=1 */;
```

"syn_keep" is a logic synthesis directive. "NOCLIP" applies to physical design. Both need to be specified if you want to keep the net throughout the flow and only use syn_keep for synthesis cross-probing without NOCLIP.

**VHDL example**

```vhdl
signal net_a: std_logic;
attribute syn_keep : boolean;
attribute NOCLIP : boolean;

attribute syn_keep of net_a : signal is true;
attribute NOCLIP of net_a : signal is true;
```

Although NOCLIP is declared as boolean in VHDL, synthesis tool writes NOCLIP=1 in synthesis output.

**.ldc TCL command**

`.ldc_set_attribute {NOCLIP} [get_nets net_a]

**NOMERGE**

**Convention**  NOMERGE= <net_name>

**Description**  Assigned to a net, specifies that the net cannot be absorbed into a logic block when the design is mapped. This may happen, for example, if the components connected to each side of a net are mapped into the same logic block. The net may then be absorbed into the block containing the components.

If you want to ensure that a net remains outside of a logic block, attach a NOMERGE attribute to the net. The MAP program then maps the net in a way that ensures you do not “lose” the net inside a logic block.

**Device Support**  All
VHDL Syntax  ATTRIBUTE NOMERGE: string;
ATTRIBUTE NOMERGE OF [signal_name]: SIGNAL IS "ON";

VHDL Example Code  ATTRIBUTE DRIVE OF q_lvttl33_17: SIGNAL IS "ON";

Verilog Example Code – Synplify  output q_lvttl33_17 /* synthesis NOMERGE="ON" */;

.ldc TCL command  ldc_set_location {NOMERGE} [get_nets q_lvttl33_17]

See Also  ►“IO_TYPE” on page 553

OPENDRAIN

Convention  OPENDRAIN = OFF | ON

Description  You can assign OPENDRAIN to all the LVCMOS and LVTTL standards. OFF is the default.

If OPENDRAIN is used on a bidirectional pin or an output pin, to be valid (does not generate design errors) it either must, 1) be a non-differential output buffer with OPENDRAIN attached, or 2) a non-differential outputZ/bidi buffer in which the “I” (input to output buffer) pin is set to GND and “T” (tristate enable) is live whether the OPENDRAIN attribute is passed or not. The “I” and “T” signals connected together, it does not matter. If the “I” and “T” of outputZ are unique signals and the “I” signal is not set to GND, then OPENDRAIN is not valid.

Device Support  LIFCL, LFD2NX

VHDL Syntax  ATTRIBUTE OPENDRAIN: string;
ATTRIBUTE OPENDRAIN OF [signal_name]: SIGNAL IS "[value]";

VHDL Example Code  ATTRIBUTE OPENDRAIN OF q_lvttl33_17: SIGNAL IS "ON";

Verilog Syntax  Poutput signal_name /* synthesis OPENDRAIN="ON | OFF" */;

Verilog Example Code  output q_lvttl33_17 /* synthesis OPENDRAIN="ON" */;

.ldc TCL command  ldc_set_port -iobuf {OPENDRAIN=ON} [get_ports {q_vttl133_17}]
PULLMODE

**Convention**  PULLMODE = UP (default), DOWN, NONE, KEEPER, PCICLAMPPULLMODE = 100K, 3P3K, 6P8K, 10K, NA

**Description**  Attached to output buffer elements (e.g., OB, OBW) and bidirectional buffers, the PULLMODE attribute mode parameters are UP, DOWN, NONE, KEEPER, PCICLAMP. The PULLMODE options can be enabled for each I/O independently. The default is UP.

**Device Support**  All

**VHDL Syntax**  ATTRIBUTE PULLMODE: string;
ATTRIBUTE PULLMODE OF [pin_name]: SIGNAL IS "[mode]";

**Example Code:**  ATTRIBUTE PULLMODE OF md: SIGNAL IS "3P3K";

**Verilog Syntax – Synplify**  PinType [pin_name] /* synthesis IO_TYPE="[type_name]" DRIVE="[drive_strength]" PULLMODE="[mode]" SLEWRATE="[value]"*/;

[mode] = UP (default), DOWN, NONE, KEEPER, PCICLAMP

**Note:** Example given for Pin I/O Type configuration.

**Verilog Example Code Synplify**  portA /* synthesis IO_TYPE="LVCMOS33" DRIVE="NA" PULLMODE="3P3K" */;

**.ldc TCL command**  ldc_set_port -iobuf {PULLMODE=100K [get_ports port A[4]]}

There are also example files for other FPGA architectures available in corresponding directories in the <install_dir>/ispcpld/examples path.

**See Also**  ►“IO_TYPE” on page 553

RBBOX

**Convention**  RBBOX = H,W (where H is height, W is width)

**Description**  RBBOX indicates the area size a region. This attribute must appear on the same block as REGION attribute (old attribute is PREGION). Required if REGION exists. This has replaced the old PRBBOX attribute which is also still valid for backwards compatibility.

**Device Support**  All

**See Also**  ►“GRP” on page 549 (attribute)
**REGION**

**Convention**  
REGION = <identifier>

**Description**  
REGION indicates the region to which a given GRP belongs. This attribute must appear on a block that has a GRP attribute. This has replaced the old PREGION attribute which is also still valid for backwards compatibility.

Note that RLOC / GLOC (Region Lock / Group Lock) can only be used with REGION or GRP attributes. The value it takes is a site value on the device itself which can be deciphered as such:

RLOC/GLOC = "R5C19D"

i.e. Row 5, Column 19, Slice D

**Device Support**  
All

**VHDL Syntax**  
attribute REGION: string;
attribute REGION of <object>: label is "<REGION_name>";
attribute RLOC: string;
attribute RLOC of <object>: label is "<site>";
attribute RBBOX: string;
attribute RBBOX of <object>: label is "<height>,<width>";
attribute GRP: string;
attribute GRP of <object>: label is "<reg_GRP>";
attribute GLOC: string;
attribute GLOC of <object>: label is "<site>";
attribute BBOX: string;
attribute BBOX of <object>: label is "<height>,<width>";

**Example VHDL Code:**  
attribute REGION: string;
attribute REGION of x: label is "reg_group";
attribute RLOC: string;
attribute RLOC of <object>: label is "R5C19D";
attribute RBBOX: string;
attribute RBBOX of <object>: label is "20,15";
attribute GRP: string;
attribute GRP of <object>: label is "reg_GRP";
attribute GLOC: string;
attribute GLOC of <object>: label is "R10C20D";
attribute BBOX: string;
attribute BBOX of <object>: label is "5,5";

**Verilog Syntax – Synplify**  
PinType [pin_name] /* synthesis
IO_TYPE=[type_name] DRIVE=[drive_strength] PULLMODE=[mode] SLEWRATE=[value]*/;

[mode] = UP (default), DOWN, NONE, KEEPER, PCICLAMP

**Note:** Example given for Pin I/O Type configuration.
Verilog Example Code Synplify

```verilog
module serial_reg_custom(D, CLK, CE, RST, Q) /* synthesis REGION="reg_REGION"
RLOC= "R5C19D"
RBBOX= "20,15"
GRP= "reg_GRP"
GLOC="R10C20D"
BBOX= "5,5"*/;
serial_reg_custom inst1A(.D(A), .CLK(CLK), .CE(CE), .RST(RST), .Q(adder1_in1));
serial_reg_custom inst1B(.D(B), .CLK(CLK), .CE(CE), .RST(RST), .Q(adder1_in2));
serial_reg_custom inst1C(.D(adder1_sum), .CLK(CLK), .CE(CE), .RST(RST), .Q(SUM));
count count_inst(A,CLK,RST) /* synthesis REGION="reg_REGION" */
;
.ldc TCL command  "ldc_create_region -name "reg_REGION" -site
"R5C19D" -width 20 -height 15
ldc_create_group -name "reg_GROUP" -bbox {5 5} [get_cells
{inst1A inst1B inst1C}]
ldc_set_location -site "R10C20D" [ldc_get_group "reg_GROUP"]
ldc_set_location -region "reg_REGION" [get_cells {inst1A
inst1B inst1C count_inst}]"

See Also  ►“GRP” on page 549 (attribute)

RGB_TO_GPIO

Convention  RGB_TO_GPIO = String

Description  Specific to the iCE40UP device by default, there are three
dedicated pins for RGB use. In order to free up these pins for use as general
purpose IOs (GPIO), an attribute can be applied to make use of these three
pins.

When an IO port is manually located to one of the RGB pins by the user and
the RGB primitive is not used for the port signal, the software can
automatically configure the port as a GPIO without using this attribute.

This attribute is applicable to the module level in Verilog and architecture level
in VHDL.

Notes
1. When an I/O port is manually located to one of the RGB pins by the user and the
RGB primitive is not used for the port signal, the software can automatically
configure the port as a GPIO without using this attribute.
2. This attribute is not applicable to RTL simulation and post synthesis, but applies to
post route simulation. Also, a pull-up is needed in the test bench to avoid a High-Z
Device Support  iCE40UP

VHDL Syntax  ATTRIBUTE RGB_TO_GPIO : string;
ATTRIBUTE RGB_TO_GPIO of [architecture name]: architecture is
"[pin_name]";

VHDL Example Code  ATTRIBUTE RGB_TO_GPIO : string;
ATTRIBUTE RGB_TO_GPIO OF behav : architecture is
"cam_data[0:0], cam_pclk";

Verilog Syntax  /* synthesis RGB_TO_GPIO = "[pin_name]"*/;

Verilog Example Code  nodule abc (cam_pclk, cam_data, q) /*
synthesis RGB_TO_GPIO = "cam_data[0:1], cam_pclk" */ ;

SLEWRATE

Convention  SLEWRATE = FAST | SLOW | MED

Description  Attached to all output buffers (e.g., OB, OBW) and bidirectional
buffers, the SLEWRATE attribute mode parameters are FAST, SLOW OR
MED for all families.

Each I/O pin has an individual slew rate control. This allows designer to
specify slew rate control on pin by pin basis. The slew rate controls affects
both the rising edge and the falling edges. The default SLEWRATE is MEDIUM.

Device Support  LIFCL, LFD2NX

VHDL Syntax  ATTRIBUTE SLEWRATE: string;
ATTRIBUTE SLEWRATE OF [pin_name]: SIGNAL IS "[value]";

VHDL Example Code  ATTRIBUTE SLEWRATE OF portA: SIGNAL IS
"SLOW";

Verilog Syntax  PinType [pin_name] /* synthesis IO_TYPE="[type_name]"
DRIVE="[drive_strength]" PULLMODE="[mode]" SLEWRATE="[value]" */;

Verilog Example Code  output [4:0] portA /* synthesis
IO_TYPE="LVTTL33_OD" DRIVE="16" PULLMODE="UP" SLEWRATE="FAST"
*/ ;

.Ldc TCL command  ldc_set_port -iobuf {SLEWRATE=FAST}
[get_ports {portA}]

USERCODE

Description  Defines the 32-bit code used to identify the design.
Note that the .TCL command uses a combination of FORMAT and UNIQUE_ID instead to represent USERCODE with no such keyword. See ldc_set_attribute for details.

**Device Support**  LIFCL, LFD2NX

**VHDL Syntax**

```
ATTRIBUTE USERCODE : string;
ATTRIBUTE USERCODE OF entity : component IS "[value]";
```

**VHDL Example Code**

```
ATTRIBUTE USERCODE : component IS "0123ABCD";
```

**Verilog Syntax**

```
module module_name (<ports>) /* synthesis
USERCODE="[value]" */;
```

**Verilog Example Code**

```
module top(CLK, CE, RST, A, B, SUM) /* synthesis USERCODE="0H0123ABCD" */;
```

**.ldc TCL command**

```
ldc_set_attribute {FORMAT=HEX CODE=0123ABCD}
```

---

**Lattice Synthesis Engine Constraints**

The LSE, enables you to use constraints that are directly interpreted by the synthesis engine. This new category of constraints includes “Synopsys Design Constraints” on page 563, and “Lattice Synthesis Engine-Supported HDL Attributes” on page 580. These constraints influence the optimization or structure of the output netlist.

**See Also**  
▶ “Integrated Synthesis” on page 253  
▶ “Handling Device Constraints” on page 176

---

**Synopsys Design Constraints**

This section describes the SDC language elements for timing-driven synthesis that are supported by the LSE. When you use LSE, these SDC constraints are saved to a Lattice Design Constraints file (.ldc). A new .ldc file can be created and edited using the LDC Editor or the Source Editor. You can select the .ldc file to be the active synthesis constraint file for an implementation.

The SDC constraints will drive optimization of the design if LSE’s Optimization Goal is set for timing in the active strategy file.

**Considerations about LSE Timing**  The module delay in LSE is based on the primitive level, before logic is packed into a slice. Therefore, the delay might be different from the slice-based MAP or PAR Timing analysis report (.twr). Also, some elements are modeled as black boxes in LSE.
The routing delay algorithm in LSE is different from the estimated routing delay in Map or Place.

The current LSE timing does not take the PLL/DLL frequency or phase shift properties into account. It also does not model the different IO_TYPE in the PIO. Therefore, it is necessary to adjust the timing constraint. For example, you can explicitly include a timing constraint on the PLL outputs with the phase-shift property.

See Also  ► “Design Objects” on page 564
-----
► “Object Access Commands” on page 567
► “create_clock” on page 568
► “create_generated_clock” on page 570
► “set_clock_groups” on page 571
► “set_clock_latency” on page 572
► “set_clock_uncertainty” on page 573
► “set_false_path” on page 574
► “set_input_delay” on page 574
► “set_load” on page 576
► “set_max_delay” on page 576
► “set_min_delay” on page 577
► “set_multicycle_path” on page 578
► “set_output_delay” on page 579
► “Integrated Synthesis” on page 253
► “Handling Device Constraints” on page 176

Design Objects
Design objects can be referred to in the SDC as a single object, or as a collection of objects. Single objects must be referred to as a collection of a single object. The current implementation of the SDC commands allows only single objects in the collection. The exception to this are the all_* commands.

In the examples below, <target name> is a regular expression that matches one object only.
Clock Object

<table>
<thead>
<tr>
<th>SDC Collection</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>[get_clocks &lt;target name&gt;]</td>
<td>&lt;target name&gt; is the name of the clock. Clock is either given a name or gets its name from the port/net on which it is defined.</td>
</tr>
<tr>
<td>[all clocks]</td>
<td>Collection of all clocks in the design.</td>
</tr>
</tbody>
</table>

Examples:   
[get_clocks clock_fast]
[all_clocks]

Port Object

<table>
<thead>
<tr>
<th>SDC Collection</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>[get_ports &lt;target name&gt;]:</td>
<td>Collection of a design port that matches &lt;target name&gt;</td>
</tr>
<tr>
<td>[all_inputs]</td>
<td>Collection of all design input ports</td>
</tr>
<tr>
<td>[all_outputs]</td>
<td>Collection of all design output ports</td>
</tr>
</tbody>
</table>

Examples:   
[get_ports indata*]
[all_inputs]
Cell Object

SDC Collection | Description
--- | ---
`[get_cells <target name>]` | Collection of a design instance that matches `<target name>`

Net Object

SDC Collection | Description
--- | ---
`[get_nets <target name>]` | Collection of a design net that matches `<target name>`
  - Hierarchy is specified using regular expression.

Pin Object

SDC Collection | Description
--- | ---
`[get_pins <instance name> | <pin name>]` | Collection of a design pin that matches `<target name>`
  - Hierarchy is specified using regular expression.

The `get_nets` command can be used to define the target for a `create_generated_clock` command.

Wildcard support

Only one wildcard (`*`) is supported. In addition, the wildcard should be at the end or beginning of the object name string. For example:

- `ab*` matches `abc`, `ab`, `abdefg`, etc.
- `*bc` matches `abc`, `bbc`, `debc`, etc.

Notes:

1. Wildcard `*` can be used in any position of object name such as `a*`, `*b`, `a*b` etc.
2. Wildcard `*` can’t cross hierarchical separator `/`. For example `get_cells sub1/*` only returns `sub1/sub2` and doesn’t return `sub1/sub2/sub1` or `sub1/sub2/sub1/sub2` etc.
3. When `-hierarchical` is set, it will search all levels of the design hierarchy starting at the current instance.

See Also

- “Synopsys Design Constraints” on page 563
Object Access Commands
The table below summarizes standard SDC access commands and their options.

<table>
<thead>
<tr>
<th>Command</th>
<th>Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>all_clocks</td>
<td>N/A</td>
</tr>
<tr>
<td>all_inputs</td>
<td>-level_sensitive, -edge_triggered, -clock</td>
</tr>
<tr>
<td>all_outputs</td>
<td>-level_sensitive, -edge_triggered, -clock</td>
</tr>
<tr>
<td>all_registers</td>
<td>-no_hierarchy, -hsc_separator, -clock, -rise_clock, -fall_clock, -cells, -data_pins, -clock_pins, -slave_clock_pins, -async_pins, -outpout_pins, -level_sensitive, -edge_triggered</td>
</tr>
<tr>
<td>current_design</td>
<td>N/A</td>
</tr>
<tr>
<td>current_instance</td>
<td>N/A</td>
</tr>
<tr>
<td>get_cells</td>
<td>-hierarchical, -regexp, -nocase, -of_objects</td>
</tr>
<tr>
<td>get_clocks</td>
<td>-regexp, -nocase</td>
</tr>
<tr>
<td>get_lib_cells</td>
<td>-regexp, -hsc_separator, -nocase</td>
</tr>
<tr>
<td>get_lib_pins</td>
<td>-regexp, -nocase</td>
</tr>
<tr>
<td>get_libs</td>
<td>-regexp, -nocase</td>
</tr>
<tr>
<td>get_nets</td>
<td>-hierarchical, -hsc_separator, -regexp, -nocase, -of_objects</td>
</tr>
<tr>
<td>get_pins</td>
<td>-hierarchical, -hsc_separator, -regexp, -nocase, -of_objects</td>
</tr>
<tr>
<td>get_ports</td>
<td>-regexp, -nocase</td>
</tr>
</tbody>
</table>

**Example**  The following example shows how -of_objects is used:

```plaintext
get_pins -of_objects [get_nets {c[2]}]
get_cells -of_objects [get_nets -of_objects [get_pins {c/clock}]]
```
create_clock
Creates a clock and defines its characteristics.

Note
In LSE timing, interclock domain paths are always blocked for create_clock. However, the interclock domain path is still valid for constraints such as set_false_path and set_multicycle_path.

Syntax  create_clock -period <period>[-name <clock name>] [-waveform <value1 value2>] [[get_ports | get_pins | get_nets source_object]]

Arguments  -name name
The name string specifies the name of the clock. If this parameter is not given, the name of the source object is used as the name of the clock.

-period period_value
This value is required and it specifies the clock period in nanoseconds. The value you specify is the minimum time over which the clock waveform repeats. The value specified for the period must be positive as the period of a clock must be greater than zero. The duty cycle of the clock is 50 percent.

-waveform {value1 value2}
The values are a list of edge values. Only two edges are supported. Floating values are accepted. Value1 must be less than value2, and the difference must be less than the clock period. Note that each value must also be less than the clock period.

source_object
The source object is the object on which the clock constraint is defined. The source object can be a port object or a net object in the design. The object is obtained by using one of the get_ports or get_nets commands. If you specify a clock constraint on a source object that already has a clock, the new clock replaces the existing one. Only one source object is accepted. Wildcards are accepted as long as the resolution shows one port or net object.
Example  The following example creates two clocks on ports CK1 and CK2 with a period of 6:

create_clock -name my_user_clock -period 6 [get_ports CK1]
create_clock -name my_other_user_clock -period 6 [get_ports CK2]

Example  The following example creates a clock on port CK3 with a period of 7.1, and has two edges at 0 and 4.1:

create_clock -period 7.1 -waveform {0 4.1} [get_ports CK3]

Example  Radiant Virtual Clocks are external to the FPGA and only trigger flip flops that are outside the FPGA. These clocks do not trigger flip flops from inside the FPGA and are only used as the clocks are constrained with set_input_delay and set_output_delay.

Example  In the following example, CLK1 and CLK3 are virtual clocks.

Input and output delay constraints must take external delays into consideration.
Input side:
create_clock -period T -name CLK1
create_clock -period T -name CLK2 [get_ports CLK]
set_clock_latency t5 [get_clocks CLK2]
set_input_delay t1 + t2 -clock [get_clocks CLK1] [all_inputs]

Output side:
create_clock -period T -name CLK3
set_output_delay t3 + tr - t6 -clock [get_clocks CLK3] [all_outputs]

If there is clock uncertainty:
set_clock_uncertainty tu [get_clocks CLK2]

See Also  “Synopsys Design Constraints” on page 563
**create_generated_clock**

Creates an internally generated clock and defines its characteristics. This command is used when the clock being created is related to another clock. The generated clock is considered a clock when defining constraints such as input_delay.

**Syntax**
```
```

**Arguments**

- **-source reference_object**
  
  The reference object is an object on which the source clock of the generated clock is defined. The source object can be a net object or a port object. The period of the generated clock is derived from the clock on the reference object using the multiply and divide factors.

- **-divide_by factor**
  
  This factor is the frequency division factor. The frequency of the generated clock is equal to the frequency of the source clock divided by this factor, if the multiply by factor is not specified. For instance, if this factor is equal to 2, the generated clock period is twice the reference clock period. Default value is 1.

- **-multiply_by factor**
  
  This factor specifies the frequency multiplication number to be used when finding the generated clock frequency. For instance, if the factor is equal to 2, the generated clock period is half the reference clock period. If both multiply_by and divide_by factors are used, the frequency is obtained by using both factors. Default value is 1.

- **-duty_cycle value**
  
  This value specifies the duty cycle in percentage of the clock period. The value can be floating point and ranges from 0 to 100. The default value is 50.

- **-edges {value1 value2 value3}**
  
  A maximum of three values can be entered. The values entered correspond to the edge of the source clock from which the generated clock has been obtained.

- **-invert**
  
  This inverts the clock edge.

- **net_object**
  
  The net_object specifies the source of the clock constraint. This is usually an internal -net of the design. If you specify a clock constraint on a net that already has a clock, the new clock replaces the existing clock. Only one source is accepted. Wildcards are accepted as long as the resolution shows one net.

This command creates a generated clock in the current design at a declared net_object by defining its frequency with respect to the frequency.
at the reference object. The static timing analysis tool uses this information to compute and propagate the generated clock’s waveform across the clock network to the clock pins of all sequential elements driven by this target.

**Examples**  The following example creates a generated clock on pin pll1/CLKOP with a period twice as long as the period at the reference port CLK:

```plaintext
create_generated_clock -divide_by 2 -source [get_ports CLK] [get_pins pll1/CLKOP]
```

The following example creates a generated clock at the primary output of myPLL with a period three quarters of the period at the reference pin clk:

```plaintext
create_generated_clock -divide_by 3 -multiply_by 4 -source [get_ports clk] [get_pins myPLL/CLK1]
```

The following example shows a clock with a duty cycle of 60 percent:

```plaintext
create_generated_clock -duty_cycle 60 -source [get_ports clk] [get_pins myPLL/CLK1]
```

**See Also**  ►“Synopsys Design Constraints” on page 563

**set_clock_groups**

Specifies clock groups that are mutually exclusive or asynchronous with each other in a design so that the paths between these clocks are not considered during timing analysis.

**Syntax**  set_clock_groups -asynchronous | -exclusive -group clock_objects [-group clock_objects]

```plaintext
set_clock_groups [-logically_exclusive | -physically_exclusive | -asynchronous] -group [get_clocks <clock_objects>] -group [get_clocks <clock_objects>]
```

**Arguments**

- **-asynchronous**
  Specifies that the clock groups are asynchronous to each other (while the Radiant software assume all clocks defined by create_clock and create_generated_clock are synchronous). Two clocks are asynchronous with respect to each other if they have no phase relationship at all.

- **-physically_exclusive**
  Specifies that clocks are mutually exclusive. Only one clock group is active at any given time.

- **-logically_exclusive**
Specifies that clocks are mutually exclusive and will not reach the flip flops at the same time due to logic implementation.

-group clock_object

Specifies the clock objects in a group. Specifying one group indicates that the clocks in that group are exclusive or asynchronous with all other clocks in the design. A default other group is created for this single group. Whenever a new clock is created, it is automatically included in this group.

**Examples**
The following example specifies two clock ports (clka and clkb) are asynchronous to each other.

```plaintext
create_clock -period 10.0000 -name clka_port [get_ports clka]
create_clock -period 10.0000 -name clkb_port [get_ports clkb]
set_clock_groups -asynchronous -group [get_clocks clka_port] -group [get_clocks clkb_port]
```

The previous line is equivalent to the following two commands:

```plaintext
set_false_path -from [get_clocks clka_port] -to [get_clocks clkb_port]
set_false_path -from [get_clocks clkb_port] -to [get_clocks clka_port]
```

The following example specifies four clock constraints that won’t be active at the same time:

```plaintext
create_clock -period 10.0000 -name clka_port [get_ports clka]
create_clock -period 10.0000 -name clkb_port [get_ports clkb]
create_clock -period 10.0000 -name clkc_port [get_ports clkc]
set_clock_groups -exclusive -group [get_clocks {clka_port clkb_port}] -group [get_clocks clkc_port]
```

**set_clock_latency**
Specifies the behavior of the clock outside of the FPGA.

**Syntax**

```plaintext
set_clock_latency <value> -source [-rise] [-fall] [-early | -late] [get_clocks <clock name>]
```

The –source option of the constraint is required because only source latencies are supported by the timer. The value of the latency is the delay of the clock outside the FPGA. The value could be a rise, fall, early or late value. The max and min flags indicate delays that will be used for setup and hold requirement calculations. The early delay will be used as the capture clock delay for setup calculations and the launch delay for hold time calculations. The late delay will be used on the launch clock for setup and on the capture

See Also  
“Synopsys Design Constraints” on page 563
clock for hold. The rise and fall options indicate the delay of the rising and falling edges of the clock.

Examples:

```
set_clock_latency 3 -source -early [get_clocks clk1]
set_clock_latency 4 -source -late [get_clocks clk1]
```

Setup analysis always uses longest path and hold analysis uses shortest path. In setup analysis, "early" value is used to calculate required time, "late" value is to calculate arrival time. While in hold analysis, the "late" value is used to calculate the required time and "early" is used to calculate arrival time.

In the example above, 3ns is in the destination clock of setup and source clock of hold; while 4ns is in source clock of setup and destination clock of hold.

**set_clock_uncertainty**

This constraint indicates that the clock of interest has uncertainties in its period.

**Syntax**

```
set_clock_uncertainty <value> [-from <from clock>] [-to <to clock>] [-setup] [-hold] [get_clocks <clock list>]
```

This constraint requires at least one of the clock options. The number given by value, is the amount by which the clock period is uncertain. The timer will use this value to add additional requirement to all paths affected by the selected clock. The timer requires the 'from' option to be accompanied by a 'to' option. The setup option indicates the constraint for setup analysis and the hold constraint for hold analysis.

**Examples**

The following two examples specify clock uncertainty, one with a from/to.

```
set_clock_uncertainty 0.5 [get_clocks clk1]
set_clock_uncertainty 0.4 -from [get_clocks clk2] -to [get_clocks clk3]
```

The first constraint sets the uncertainty of clk1 to half a nanosecond and the second constraint sets the uncertainty to 400 picoseconds when a path is launched by clk2 and captured by clk3.
**set_false_path**
Identifies paths that are considered false and excluded from timing analysis.

The command requires a minimum of one from, through or to option. This constraint defines paths that should be removed from consideration during timing analysis. All paths that start at one of the 'from' objects, pass through one of the 'through' objects and arrive at one of the 'to' objects will be treated as an unconstrained path. If any of the options are missing, all objects in the design that satisfy the criteria of the missing option will be used as objects of the missing option. A missing "from" option, for instance, implies that all timing starting points are part of the 'from' list for the constraint.

**Syntax**
```
set_false_path [(-from | rise_from | fall_from)<object_list>] [-through object_list] [(-to | -rise_to | -fall_to) <object_list>]
```

**Arguments**
- **-from | rise_from | fall_from**
  Specifies the timing path start point. A valid timing starting point is a clock, a primary input, a combinational logic cell, or a sequential cell (clock-pin).

- **-to**
  Specifies the timing path end point. A valid timing end point is a primary output, a combinational logic cell, or a sequential cell (data-pin).

- **-through**
  Specifies a net through which the paths should be blocked.

**Examples**
The following example specifies all paths from clock pins of the registers in clock domain clk1 to data pins of a specific register in clock domain clk2 as false paths:

```
set_false_path -from [get_ports clk1] -to [get_cells reg_2]
```

The following example specifies all paths through the net UO/sigA as false:

```
set_false_path -through [get_nets UO/sigA]
```

**See Also**
► “Synopsys Design Constraints” on page 563

**set_input_delay**
Defines the arrival time of an input relative to a clock.

**Syntax**
```
set_input_delay -clock <clock_object> [-clock_fall] [-min | -max] [-add_delay] <delay_value> <input_port_object>
```
<input_port_object> = [get_ports <names>] | [all_inputs]

**Arguments**  delay_value

- Specifies the arrival time in nanoseconds that represents the amount of time for which the signal is available at the specified input after a clock edge.

- **-max**
  - Specifies that the delay value is the maximum delay.

- **-min**
  - Specifies that the delay value is the minimum delay.

- **-clock clock_object**
  - Specifies the clock reference to which the specified input delay is related. This is a mandatory argument.

- **-clock_fall**
  - A switch to specify the falling edge of clock to trigger.

**input_port_object**

- Provides one or more input ports in the current design to which delay_value is assigned. You can also use the keyword "all_inputs" to include all input ports.

**add_delay**

- Used to define more than one output delay on a given port.

**Example**  The following example sets an input delay of 1.2 ns for port data1 relative to the rising edge of CLK1:

```bash
set_input_delay 1.2 -clock [get_clocks CLK1] [get_ports data1]
```

**Example**  The following example sets an input delay of 1.2 ns minimum and 1.5 ns maximum for port data1 relative to the rising edge of CLK1:

```bash
set_input_delay 1.2 -min -clock [get_clocks CLK1] [get_ports data1]
set_input_delay 1.5 -max -clock [get_clocks CLK1] [get_ports data1]
```

**See Also**  »“Synopsys Design Constraints” on page 563
**set_load**

To accurately perform timing and SSO analysis, the tool needs information regarding the external load capacitance of nets connected to output ports of the FPGA.

**Syntax**  
`set_load value objects`

**Arguments**  
*delay_value*

Specifies the load in capacitance in pF.

*objects*

Provides one or more output ports in the current design to which delay_value is assigned. Uses TCL search strings.

**Example**  
The following example sets a capacitive load of 25 pF for output port OUT:

```tcl
set_load 25 [get_ports {out}]
```

---

**set_max_delay**

Specifies the maximum delay for the timing paths.

**Syntax**  
`set_max_delay [-from] <port_object or cell_object> [-through port_object or cell_object] [-to] <port_object or cell_object> <delay_value> <port_object or cell_object> = [(get_ports | get_pins | get_nets | get_cells) <names>]`

**Arguments**  
*delay_value*

Specifies a floating point number in nanoseconds that represents the required maximum delay value for specified paths.

If the path ending point is on a sequential device, the tool includes library setup time in the computed delay.

*-from*  
`from port_object or cell_object`

Specifies the timing path start point. A valid timing start point is a clock, a primary input, a combinational logic cell, or a sequential cell (clock pin).

*-to*  
`to port_object or cell_object`

Specifies the timing path end point. A valid timing end point is a primary output, a combinational logic cell, or a sequential cell (data pin).

*-through*  
`through port_object or cell_object`

Specifies the timing path pass through point. The timing path must go through this object.
Examples  The following example sets a maximum delay by constraining all paths from ff1a:CLK to ff2e:D with a delay less than or equal to 5 ns:

```
set_max_delay -from [get_cells ff1a] -to [get_cells ff2e] 5.0
set_max_delay -from [get_pins ff1/Q] -through [get_pins and1/B] -to [get_pins ff2/D] 7.0
```

See Also  “Synopsys Design Constraints” on page 563

```
set_min_delay -from [get_cells ff1a] -to [get_cells ff2e] 5.0
```

set_min_delay

Specifies the minimum delay for the timing paths.

Syntax  set_min_delay [(-from)<port_object or cell_object>] [(-through port_object or cell_object)] [(-to) <port_object or cell_object>] <delay_value>

<object_list> = [ (get_ports | get_pins | get_nets | get_cells) <names>]

Arguments  delay_value

Specifies a floating point number in nanoseconds that represents the required minimum delay value for specified paths.

If the path ending point is on a sequential device, the tool includes library hold time in the computed delay.

-from from port_object or cell_object

Specifies the timing path start point. A valid timing start point is a clock, a primary input, a combinational logic cell, or a sequential cell (clock pin).

-to to port_object or cell_object

Specifies the timing path end point. A valid timing end point is a primary output, a combinational logic cell, or a sequential cell (data pin).

-through port_object or cell_object

Specifies the timing path pass through point. The timing path must go through this object.

Examples  The following example sets a minimum delay by constraining all paths from ff1a:CLK to ff2e:D with a delay greater than or equal to 5 ns:

```
set_min_delay -from [get_cells ff1a] -to [get_cells ff2e] 5.0
```

See Also  “Synopsys Design Constraints” on page 563
set_multicycle_path

Defines a path that takes multiple clock cycles.

**Syntax**

```
set_multicycle_path <ncycles> [(-from | rise_from | fall_from)<object_list>] [-through object_list] [(-to | -rise_to | -fall_to) <object_list>] [-setup | -hold] [-start | -end] <delay_value>
```

**Arguments**

- `<object_list>` = [ (get_clocks | get_ports | get_pins | get_nets | get_cells) <names> ]

- `<ncycles>`
  Specifies a value that represents the number of cycles the data path must have for setup check. The value is relative to the ending point clock and is defined as the delay required for arrival at the ending point.

- `-from from object_list`
  Specifies the timing path start point. A valid timing start point is a sequential cell (clock pin) or a clock net (signal). You can also use the keyword "all_registers" to include all registers' clock inputs.

- `-rise/fall_from from object_list`
  Same as `-from` but only applies to clock objects.

- `-to to object_list`
  Specifies the timing path end point. A valid timing end point is a sequential cell (data-pin) or a clock-net (signal). You can also use the keyword "all_registers" to include all registers' data inputs.

- `-rise/fall_to from object_list`
  Same as `-to` but only applies to clock objects.

- `-through object_list`
  Specifies the timing path pass through point. The timing path must go through this object.

**Note**

The options `-rise_from`, `-fall_from`, `-rise_to` and `-fall_to` are only valid with clock objects.

**Example**

The following example sets all paths between reg1 and reg2 to 3 cycles for setup check. Hold check is measured at the previous edge of the clock at reg2.

```
set_multicycle_path 3 -from [get_cells reg1] -to [get_cells reg2]
set_multicycle_path 3 -from [get_pins ff1/Q] -through [get_pins and1/B] -to [get_pins ff2/D]
```
set_output_delay

Defines the output delay of an output relative to a clock.

Syntax

```plaintext
set_output_delay delay_value [-max | -min] -clock clock_object
output_port_object
```

```plaintext
set_output_delay (-clock | -clock_fall) <clock_name> [-min | -max] [-add_delay] <delay_value> <port_list>
```

```plaintext
<port_list> = [get_ports <names>] | [all_outputs]
```

Arguments

- `delay_value`
  Specifies the amount of time from a reference clock to a primary output port.

- `-max`
  Specifies that the delay value is the maximum delay.

- `-min`
  Specifies that the delay value is the minimum delay.

- `-clock` | `-clock_fall` `clock_object`
  Specifies the clock reference to which the specified input delay is related. `clock_fall` is on the falling edge of clock and is a mandatory argument.

- `output_port_object`
  Provides one or more (by wildcard) output ports in the current design to which delay_value is assigned. Use the keyword “all_outputs” to include all output ports.

- `add_delay`
  Used to define more than one output delay on a given port.

Example

The following example sets an output delay of 1.2 ns for all outputs relative to CLK1

```plaintext
set_output_delay 1.2 -clock [get_clocks CLK1] [get_ports OUT1]
set_output_delay 1.2 -clock [get_clocks CLK1] [all_outputs]
```

Example

The following example sets an output delay of 1.2 ns minimum and 1.5 ns maximum for port data1 relative to the rising edge of CLK1:

See Also

“Synopsys Design Constraints” on page 563
This section describes the Synplify Lattice Attributes that are supported by the LSE. These attributes are directly interpreted by the engine and influence the optimization or structure of the output netlist.

All HDL attributes have priority over Strategy settings.

See Also
- “black_box_pad_pin” on page 582
- “full_case” on page 584
- “loc” on page 585
- “ldc_define_attribute” on page 586
- “parallel_case” on page 588
- “syn_black_box” on page 590
- “syn_encoding” on page 591
- “syn_force_pads” on page 595
- “syn_hier” on page 597
- “syn_insert_pad” on page 598
- “syn_keep” on page 600
- “syn_maxfan” on page 602
- “syn_multstyle” on page 603
- “syn_noprune” on page 605
- “syn_pipeline” on page 607
- “syn_preserve” on page 609
- “syn_ramstyle” on page 611
- “syn_replicate” on page 613
- “syn_romstyle” on page 615
- “syn_srlstyle” on page 616
- “syn_sharing” on page 619
- “syn_state_machine” on page 621
- “syn_use_carry_chain” on page 625
- “syn_useenables” on page 626
- “syn_useioff” on page 628
“translate_off/translate_on” on page 629
black_box_pad_pin
This attribute specifies pins on a user-defined black box module. The pins are defined as I/O pads that are visible outside of the black box. If there is more than one port that is an I/O pad, the ports are listed inside double-quotes (") separated by commas (,), and without enclosed spaces. This attribute must be used in conjunction with the syn_black_box attribute.

Verilog Syntax
```verilog
module black_box_pad_pin2(
    input[4:0] in1,
    input[4:0] in2,
    input clk,
    output[4:0] q
); /* synthesis syn_black_box black_box_pad_pin = "portList" */
```

Verilog Example
```verilog
module black_box_pad_pin2(
    input[4:0] in1,
    input[4:0] in2,
    input clk,
    output[4:0] q
);

reg [4:0] q;
always @(posedge clk)
    begin
        q <= in1 + in2;
    end
endmodule
```

VHDL Syntax
```vhdl
attribute black_box_pad_pin of object : architecture is "portList";
```

VHDL Example
```vhdl
architecture arch of my_arch is
begin
    process (clk)
    begin
        if rising_edge(clk) then
            q <= q + in3;
        end if;
    end process;
end architecture;
```
entity BBDLHS is
    port (D: in std_logic;
        E: in std_logic;
        GIN : in std_logic_vector(2 downto 0);
        Q : out std_logic);
end;

architecture BBDLHS_behav of BBDLHS is
end bl_box_behav;
attribute syn_black_box : boolean;
attribute syn_black_box of BBDLHS_behav : architecture is true;
attribute black_box_pad_pin : string;
attribute black_box_pad_pin of BBDLHS_behav : architecture is "GIN(2:0),Q";
full_case

Directive. For Verilog designs only. When used with a case, casex, or casez statement, this directive indicates that all possible values have been given, and that no additional hardware is needed to preserve signal values.

Verilog Syntax  object /* synthesis full_case */

Verilog Example

module full_case1 (q, in1, in2, in3, in4, sel);
output q;
input in1, in2, in3, in4;
input [3:0] sel;
reg q;

always @(sel or in1 or in2 or in3 or in4)
beging
    casez (sel) /* synthesis full_case */
      4'b11???: q = in4;
      4'b??1?: q = in3;
      4'b???1: q = in1;
      4'b??1?: q = in2;
    endcase
end
endmodule
loc
The loc attribute specifies pin locations for Lattice I/Os, instances, and registers, and forward-annotates them to the place-and-route tool. If the attribute is on a bus, the software writes out bit-blasted constraints for forward-annotation.

Verilog Syntax  object /* synthesis loc = "pinLocations" */ ;
In the syntax, pin_locations is a space free, comma-separated list of pin locations.

Verilog Example

I/O pin location
input [3:0]DATA0 /* synthesis loc="p10,p12,p11,p15" */;

Register pin location
reg data_in_ch1_buf_reg3 /* synthesis loc="R40C47" */;

Vectored internal bus
reg [3:0] data_in_ch1_reg /*synthesis loc = "R40C47,R40C46,R40C45,R40C44" */;

VHDL Syntax  attribute loc of object : objectType is "pinLocations";
In the syntax, pinLocations is a space free, comma-separated list of pin locations.

VHDL Example

entity mycomp is port(DATA0 : in std_logic_vector (3 downto 0);
    .
    .
    .
  );
attribute loc : string;
attribute loc of DATA0 : signal is "p10,p12,p11,p15";}
**ldc DEFINE ATTRIBUTE**

Note this .TCL command is used to define synthesis attributes for the LSE tool. Its main entry mechanism is via the GUI tool, Pre-Synthesis Timing Constraint Editor under the Attribute sub tab. Once a user drags & drops or enters the appropriate values for any of the attributes below in this list, it will be echoed as a .TCL command in the .LDC constraint file.

**Usage**  ldc_define_attribute -attr <attribute> -value <key-value list> -object_type <object type> -object <name>

**Options**  key-value list: constraint attributes to be set to object(s) or design if no object specified. Valid key-values are:

Examples are indicated as **U.LDC TCL command** in each of the HDL Attributes section. (i.e. DRIVE, BBOX, IO_TYPE etc.)

**Example**

ldc_define_attribute -attr loc -value 2 -object_type instance -object (clk)
**ldc_define_global_attribute**

Note this .TCL command is used to define global synthesis attributes for the LSE tool. Its main entry mechanism is via the GUI tool, Pre-Synthesis Timing Constraint Editor under the Attribute sub tab. If the Object Type selected is Global, then this .TCL command will be written out.

**Usage**
```
ldc_define_global_attribute -attr <attr_type> -value <attr_value> [-disable][-comment <comment>]
```

**Options**
- `-attr key-value`: LSE attributes name, such as ‘syn_keep’ etc.
- `-value attr_value`: LSE attribute value such as “1”, “ENABLED” etc.
- `-object_type object_type`: instance, port etc.
- `-object object`: object name such as ‘inst1’, “clk” etc.
- `-disable`: the command is disabled
- `-comment comment`: comment of the command

Examples are indicated as **U.LDC TCL command** in each of the HDL Attributes section. (i.e. DRIVE, BBOX, IO_TYPE etc.)

**Example**
```
ldc_define_global_attribute -attr loc -value A2 -object -object_type instance -object (inst1)
ldc_define_global_attribute -attr syn_keep -value 1 -object_type net -object (clk)
```
parallel_case
Directive. For Verilog designs only. Forces a parallel-multiplexed structure rather than a priority-encoded structure. This is useful because case statements are defined to work in priority order, executing only the first statement with a tag that matches the select value.

If the select bus is driven from outside the current module, the current module has no information about the legal values of select, and the software must create a chain of disabling logic so that a match on a statement tag disables all following statements. However, if you know the legal values of select, you can eliminate extra priority-encoding logic with the parallel_case directive.

In the following example, the only legal values of select are 4'b1000, 4'b0100, 4'b0010, and 4'b0001, and only one of the tags can be matched at a time. Specify the parallel_case directive so that tag-matching logic can be parallel and independent, instead of chained.

Note
Designers should be aware that it is possible for the priority of overlapping cases in post-synthesis simulation to mismatch with the priority behavior in RTL simulation when using this pragma.

Verilog Syntax
You specify the directive as a comment immediately following the select value of the case statement.

object /* synthesis parallel_case */

where object is a case, casex or casez statement declaration.
Verilog Example

module parallel_case1 (q, in1, in2, in3, in4, sel);
output q;
input in1, in2, in3, in4;
input [3:0] sel;
reg q;
always @(sel or in1 or in2 or in3 or in4)
begin
casez (sel) /* synthesis parallel_case */
4'b11??: q = in4;
4'b?1??: q = in3;
4'b??1?: q = in1;
4'b??1?: q = in2;
default: q = 'bx;
endcase
end
endmodule

If the select bus is decoded within the same module as the case statement, the parallelism of the tag matching is determined automatically, and the parallel_case directive is unnecessary.
**syn_black_box**
This attribute specifies that a Verilog module or VHDL architecture declaration is for a black box. Only the module’s interface is defined for synthesis. The contents of a black box cannot be optimized during synthesis. A module can be a black box whether it is empty or not. However, the syn_black_box attribute cannot be used with the top-level module or architecture of a design. Additionally, the syn_black_box attribute is not supported for instances in Verilog or components in VHDL.

This attribute has an implicit Boolean value of 1 or true.

If any of the ports are I/O pads, add the black_box_pad_pin attribute. See "black_box_pad_pin" on page 582.

**Verilog Syntax**
```
object /* synthesis syn_black_box */ ;
```
where `object` is a module declaration.

**Verilog Example**
```
module bl_box(out, data, clk) /* synthesis syn_black_box */;
```

**VHDL Syntax**
```
attribute syn_black_box of object : architecture is true ;
```
where `object` is an architecture name. Data type is Boolean.

**VHDL Example**
```
entity bl_box is
  port (data : in std_logic_vector (7 downto 0);
        clk : in std_logic;
        out : out std_logic);
end;
architecture bl_box_behav of bl_box is
end bl_box_behav;
attribute syn_black_box : boolean;
attribute syn_black_box of bl_box_behav : architecture is true;
```
**syn_encoding**

This attribute specifies the encoding style for a finite state machine (FSM), overriding the default LSE encoding. The default encoding is based on the number of states in the FSM. This attribute takes effect only when LSE infers an FSM. This attribute has no effect when syn_state_machine is 0, which blocks inference of an FSM.

Values for syn_encoding are as follows:

- **Sequential** – More than one bit of the state register can change at a time, but because more than one bit can be hot, the value must be decoded to determine the state. For example: 000, 001, 010, 011, 100

- **Onehot** – Only two bits of the state register change (one goes to 0; one goes to 1) and only one of the state registers is hot (driven by a 1) at a time. For example: 0000, 0001, 0010, 0100, 1000

- **Gray** – Only one bit of the state register changes at a time, but because more than one bit can be hot, the value must be decoded to determine the state. For example: 000, 001, 011, 010, 110

  There can be no more than four states for gray encoding. If the FSM has more than four states, LSE switches to sequential encoding.

- **Safe** – If the state machine enters an invalid state, additional logic will drive the state machine into its reset state. The design must have a defined reset state.

  Safe encoding can be combined with either sequential or onehot encoding (not with gray encoding) as in:

  ```plaintext
  syn_encoding = "safe,onehot"
  ```

  If the safe value is given by itself, it combines with the encoding method of a preceding syn_encoding statement or the default method.
**Verilog Syntax**

Object /* synthesis syn_encoding = "value" */;

Where *object* is an enumerated type and value is from the list above.

**Verilog Example**

```verilog
module fsm (clk, reset, x1, outp);
input clk, reset, x1;
output outp;
reg outp;
reg [1:0] state /* synthesis syn_encoding = "onehot" */;
parameter s1 = 2'b00; parameter s2 = 2'b01;
parameter s3 = 2'b10; parameter s4 = 2'b11;

always @(posedge clk)
begin
  if (reset)
    state <= s1;
  else begin
    case (state)
      s1: if (x1 == 1'b1)
        state <= s2;
      else
        state <= s3; s2: state <= s4;
      s3: state <= s4;
      s4: state <= s1;
    endcase
  end
end

always @(state) begin
  case (state)
    s1: outp = 1'b1;
    s2: outp = 1'b1;
    s3: outp = 1'b0;
    s4: outp = 1'b0;
  endcase
end
endmodule
```
VHDL Syntax  

attribute syn_encoding of object: objectType is "value";

Where object is an enumerated type and value is from the list above.

VHDL Example
library ieee;
use ieee.std_logic_1164.all;
use ieee.std_logic_unsigned.all;

entity syn_encoding1 is
  port(
    clk : in std_logic;
    reset: in std_logic;
    en   : in std_logic;
    q  : out std_logic_vector(1 downto 0)
  );
end entity;

architecture behave of syn_encoding1 is
  signal state : std_logic_vector(3 downto 0);
  constant state0 : std_logic_vector(3 downto 0) := "1000";
  constant state1 : std_logic_vector(3 downto 0) := "0100";
  constant state2 : std_logic_vector(3 downto 0) := "0010";
  constant state3 : std_logic_vector(3 downto 0) := "0001";
  attribute syn_encoding : string;
  attribute syn_encoding of state : signal is "safe,onehot";
begin
  process(clk,reset,en)
  begin
    if reset = '1' then
      state <= state0;
      q <= "00";
    elsif clk'event and clk = '1' then
      case state is
      when state0 =>
        if (en = '1') then
          q <= "00";
        end if;
        state <= state1;
      when state1=>
        if (en = '1') then
          q <= "01";
        end if;
        state <= state2;
      when state2 =>
        if (en = '1') then
          q <= "10";
        end if;
        state <= state3;
      when state3 =>
        if (en = '1') then
          q <= "11";
        end if;
        state <= state0;
      when others => null;
      end case;
    end if;
  end process;
end behave;
**syn_force_pads**

This attribute prevents unused ports from being optimized away to allow I/O pad insertion on the unused port. This attribute is not supported at the global level. Instead, set the use_io_insertion option to control I/O insertion globally.

This attribute is supported in the rtl, and it will override the global use_io_insertion option setting on the given input, output, or bidir port.

For example, in the following Verilog file, the syn_force_pads attribute can be set to 1 on an unused input port (dataz), and it will not be optimized away, regardless of the use_io_insertion global setting.

**Verilog Syntax**

```verilog
object /* synthesis syn_force_pads = {1 | 0} */;
```

where *object* is port declaration.

**Verilog Example**

```verilog
`define DSIZE 9
`define OSIZE 18

module multp9x9(dataout, dataax, dataay, dataz, clk, rst, ce);
  output [`OSIZE-1:0] dataout;
  input [`DSIZE:0] dataz /* synthesis syn_force_pads = 1*/;
  input [`DSIZE-1:0] dataax, dataay;
  input clk, rst, ce;
  reg [`DSIZE-1:0] dataax_reg, dataay_reg;
  reg [`OSIZE-1:0] dataout;
  wire [`OSIZE-1:0] dataout_tmp;
  assign dataout_tmp = dataax_reg * dataay_reg;

  always @(posedge clk or posedge rst)
  begin
    if (rst)
      begin
        dataax_reg <= 0;
        dataay_reg <= 0;
        dataout <= 0;
      end
    else if (ce == 1'b1)
      begin
        dataax_reg <= dataax;
        dataay_reg <= dataay;
        dataout <= dataout_tmp;
      end
  end
endmodule
```

To force I/O pads to be inserted for input ports that do not drive logic, follow the guidelines below.

- To force I/O pad insertion on an individual port, set the syn_force_pads attribute on the port with a value to 1. To disable I/O insertion for a port, set the attribute on the port with a value of 0.
Enable this attribute to preserve user-instantiated pads, insert pads on unconnected ports, insert bi-directional pads on bi-directional ports instead of converting them to input ports, or insert output pads on unconnected outputs.

If you do not set the syn_force_pads attribute, the synthesis design optimizes any unconnected I/O buffers away.

**VHDL Syntax**  
Attribute syn_force_pads of object: objectType is "true | false"

**VHDL Example**

```vhdl
library ieee;
use ieee.std_logic_1164.all;
use ieee.std_logic_arith.all;
use ieee.std_logic_unsigned.all;

entity multp9x9 is
  port ( dataout : out std_logic_vector(17 downto 0);
         dataax, dataay: in std_logic_vector( 8 downto 0);
         dataz : in std_logic_vector(8 downto 0);
         clk,rst,ce: in std_logic
  );
  attribute syn_force_pads : string;
  attribute syn_force_pads of dataz : signal is "true";
end multp9x9;

architecture rtl of multp9x9 is

signal dataax_reg,dataay_reg: std_logic_vector(8 downto 0);
signal dataout_tmp: std_logic_vector(17 downto 0);

begin
  dataout_tmp <= dataax_reg * dataay_reg;
  process (clk, rst)
  begin
    if rst = '1' then
      dataax_reg <= (others => '0');
      dataay_reg <= (others => '0');
      dataout <= (others => '0');
    elsif clk'event and clk = '1' then
      if ce = '1' then
        dataax_reg <= dataax;
        dataay_reg <= dataay;
        dataout <= dataout_tmp;
      end if;
    end if;
  end process;

end rtl;
```
**syn_hier**
This attribute allows you to control the amount of hierarchical transformation that occurs across boundaries on module or component instances during optimization. This attribute cannot be applied globally. The user must set this attribute on the selective modules to stop cross-boundary optimizations.

**syn_hier Values**  
The following value can be used for syn_hier:

- **Hard** – Preserves the interface of the design unit with no exceptions. This attribute affects only the specified design units.

**Verilog Syntax**  
object /* synthesis syn_hier = "value" */ ;

where `object` can be a module declaration and `value` can be any of the values described in syn_hier Values. Check the attribute values to determine where to attach the attribute.

**Verilog Example**
```
module top1 (Q, CLK, RST, LD, CE, D)
    /* synthesis syn_hier = "hard" */;
```

**VHDL Syntax**  
attribute syn_hier of object : architecture is "value";

where `object` is an architecture name and `value` can be any of the values described in syn_hier Values. Check the attribute values to determine the level at which to attach the attribute.

**VHDL Example**
```
architecture struct of cpu is
attribute syn_hier : string;
attribute syn_hier of struct : architecture is "hard";
```
**syn_insert_pad**

This attribute removes an existing I/O buffer from a port or net when I/O buffer insertion is enabled.

The syn_insert_pad attribute is used when the use_io_insertion global option is enabled (when I/O buffers are automatically inserted) to allow users to selectively remove an individual buffer from a port or net.

It can also be used to force an I/O buffer to be inserted on a specific port or net, if the use_io_insertion global option is disabled.

- Setting the attribute to 0 on a port or net removes the I/O buffer (or prevents an I/O buffer from being automatically inserted, if the use_io_insertion global option is enabled).
- Setting the attribute to 1 on a port or net forces an I/O buffer to be inserted if the use_io_insertion global option is disabled.

**Verilog Syntax**

```verilog
object /* synthesis syn_insert_pad = {1 | 0} */;
```

where *object* is a port or net declaration.

**Verilog Example**

```verilog
`define OSIZE 16
`define DSIZE 8

module mac8x8 (dataout, x, y, clk, rst);
    output [OSIZE:0] dataout;
    input [DSIZE-1:0] x, y;
    input clk;
    input rst /* synthesis syn_insert_pad = 0 */;
    reg [OSIZE:0] dataout;
    reg [DSIZE-1:0] x_reg, y_reg;
    wire [OSIZE-1:0] multout;
    wire [OSIZE:0] sum_out;

    assign multout = x_reg * y_reg;
    assign sum_out = multout + dataout;

    always @(posedge clk or posedge rst)
    begin
        if (rst)
            begin
                x_reg = 0;
                y_reg = 0;
                dataout = 0;
            end
        else
            begin
                x_reg = x;
                y_reg = y;
                dataout = sum_out;
            end
    end
endmodule
```
In the previous example, the input port labeled "rst" will not have an input buffer connected to it in the technology-mapped netlist after LSE is completed.

**VHDL Syntax**

```
attribute syn_insert_pad of object : objectType is "true | false";
```

**VHDL Example**

```vhdl
library ieee;
use ieee.std_logic_1164.all;

entity register_en_reset is
  generic (
    width : integer := 8
  );
  port (
    datain  : in std_logic_vector(width-1 downto 0);
    clk     : in std_logic;
    enable  : in std_logic;
    reset   : in std_logic;
    dataout : out std_logic_vector(width-1 downto 0)
  );
  attribute syn_insert_pad : string;
  attribute syn_insert_pad of reset : signal is "false";
end register_en_reset;

architecture lattice_behav of register_en_reset is
begin
  process (clk,reset)
  begin
    if (reset = '1') then
      dataout <= (others => '0');
    elsif (rising_edge(clk) and enable = '1') then
      dataout <= datain;
    end if;
  end process;
end lattice_behav;
```
**syn_keep**
This attribute keeps the specified net intact during optimization and synthesis.

**Verilog Syntax**
```
object /* synthesis syn_keep = 1 */;
```
where `object` is a wire or reg declaration. Make sure that there is a space between the object name and the beginning of the comment slash (/).

**Verilog Example**
```
module syn_keep1(
  input a,
  input b,
  input clk,
  output q1,
  output q2);
reg temp1;
reg temp2;
reg q1;
reg q2;
wire or_result;
wire keep1/* synthesis syn_keep=1 */;
wire keep2/* synthesis syn_keep=1 */;

always @(posedge clk)
  begin
    temp1 = a;
    temp2 = b;
  end
assign or_result = (temp1 | temp2);
assign keep1 = or_result;
assign keep2 = or_result;
always@(posedge clk)
  begin
    q1 = keep1;
    q2 = keep2;
  end
endmodule
```

**VHDL Syntax**
```
attribute syn_keep of object : objectType is true ;
```
where `object` is a single or multiple-bit signal.

**VHDL Example**
```
module syn_keep1(
  input a,
  input b,
  input clk,
  output q1,
  output q2);
reg temp1;
reg temp2;
reg q1;
reg q2;
wire or_result;
wire keep1/* synthesis syn_keep=1 */;
wire keep2/* synthesis syn_keep=1 */;

always @(posedge clk)
  begin
    temp1 = a;
    temp2 = b;
  end
assign or_result = (temp1 | temp2);
assign keep1 = or_result;
assign keep2 = or_result;
always@(posedge clk)
  begin
    q1 = keep1;
    q2 = keep2;
  end
endmodule
```
library ieee;
use ieee.std_logic_1164.all;

entity syn_keep1 is
  port(
    a : in std_logic;
    b : in std_logic;
    clk: in std_logic;
    q1: out std_logic;
    q2: out std_logic
  );
end entity;

architecture behave of syn_keep1 is
  signal temp1 : std_logic;
  signal temp2 : std_logic;
  signal keep1 : std_logic;
  signal keep2 : std_logic;
  signal or_result : std_logic;
  attribute syn_keep: boolean;
  attribute syn_keep of keep1,keep2: signal is true;
begin
  process(clk)
  begin
    if clk'event and clk = '1' then
      temp1 <= a;
      temp2 <= b;
      end if;
  end process;

  or_result <= (temp1 or temp2);
  keep1 <= or_result;
  keep2 <= or_result;

  process(clk)
  begin
    if clk'event andclk = '1' then
      q1 <= keep1;
      q2 <= keep2;
      end if;
  end process;
end behave;
**syn_maxfan**
This attribute overrides the default (global) fan-out guide for an individual input port, net, or register output.

**Verilog Syntax**  
object /* synthesis syn_maxfan = "value" */ ;

**Note**
LSE will take integer values for non-integral values to syn_maxfan attribute.
For example, syn_maxfan value of 5.1 will be truncated to 5.

**Verilog Example**

```verilog
module test (registered_data_out, clock, data_in);
output [31:0] registered_data_out;
input clock;
input [31:0] data_in /* synthesis syn_maxfan=1000 */;
reg [31:0] registered_data_out /* synthesis syn_maxfan=1000 */;
```

**VHDL Syntax**  
attribute syn_maxfan of object : objectType is "value";

**VHDL Example**

```vhdl
entity test is
  port (clock : in bit;
       data_in : in bit_vector(31 downto 0);
       registered_data_out: out bit_vector(31 downto 0) );
attribute syn_maxfan : integer;
attribute syn_maxfan of data_in : signal is 1000;
```
**syn_multstyle**
This attribute specifies whether the multipliers are implemented as dedicated hardware blocks or as logic.

**syn_multstyle Values**  
block_mult | logic

**Value Description Default**  
block_mult Implements the multipliers as dedicated hardware blocks.

This attribute only applies to families that use DSP blocks on the device. To override this behavior, specify a value of logic.

**Verilog Syntax**  
input net /* synthesis syn_multstyle = "block_mult | logic" */;

**Verilog Example**

```verilog
module syn_multstyle1(
    input [7:0] in1, 
    input [7:0] in2, 
    input rst, 
    input clk, 
    output [15:0] result);

    reg [7:0] temp1, temp2;
    reg [15:0] result /*synthesis syn_multstyle = "block_mult"*/;
    wire [15:0] product;

    always@(posedge clk ,negedge rst)
    begin
        if(!rst)
            begin
                temp1 = 'b0;
                temp2 = 'b0;
            end
        else
            begin
                temp1 = in1;
                temp2 = in2;
            end
    end

    assign product = temp1*temp2;

    always@(posedge clk, negedge rst)
    begin
        if(!rst)
            begin
                result = 'b0;
            end
        else
            begin
                result = product;
            end
    end
endmodule
```
**VHDL Syntax**

```vhdl
attribute syn_multstyle of instance : signal is "block_mult | logic";
```

**VHDL Example**

```vhdl
library ieee;
use ieee.std_logic_1164.all;
USE ieee.numeric_std.all;

entity mult is
port (clk : in std_logic;
a : in std_logic_vector(7 downto 0);
b : in std_logic_vector(7 downto 0);
c : out std_logic_vector(15 downto 0))
end mult;

architecture rtl of mult is
signal mult_i : std_logic_vector(15 downto 0);
attribute syn_multstyle : string;
attribute syn_multstyle of mult_i : signal is "logic";
begin
mult_i <= std_logic_vector(unsigned(a)*unsigned(b))
process(clk)
begin
if (clk'event and clk = '1') then
c <= mult_i;
end if;
end process
```
**syn_noprune**
This attribute prevents instance optimization for black-box modules (including
technology-specific primitives) with unused output ports. This attribute is not a
global attribute and works on the component basis. The user must set the
attribute on the instance.

**Verilog Syntax**  
object /* synthesis syn_noprune = 1 */ ;

where *object* is a module instance. The data type is Boolean.

**Verilog Example**

```verilog
module top(a1,b1,c1,d1,y1,clk);
  output y1;
  input a1,b1,c1,d1;
  input clk;
  wire x2,y2;
  reg y1;
  syn_noprune u1(a1,b1,c1,d1,x2,y2) /* synthesis syn_noprune=1 */;
  always @(posedge clk)
    y1<= a1;
endmodule
```

**VHDL Syntax**  
attribute syn_noprune of object : objectType is true ;

where the *data type* is boolean, and *object* is a component.

**VHDL Example**

```vhdl
module top(a1,b1,c1,d1,y1,clk);
  output y1;
  input a1,b1,c1,d1;
  input clk;
  wire x2,y2;
  reg y1;
  syn_noprune u1(a1,b1,c1,d1,x2,y2) /* synthesis syn_noprune=1 */;
  always @(posedge clk)
    y1<= a1;
endmodule
```
library ieee;
use ieee.std_logic_1164.all;
entity top is
  port (a1, b1 : in std_logic;
        c1,d1,clk : in std_logic;
        y1 :out std_logic);
end;
architecture behave of top is
component noprune
  port (a, b, c, d : in std_logic;
        x, y : out std_logic);
end component;
signal x2, y2 : std_logic;
attribute syn_noprune : boolean;
attribute syn_noprune of u1 : label is true;
beg
data: noprune port map(a1, b1, c1, d1, x2, y2);
  process begin
    wait until (clk = '1') and clk'event;
    y1 <= a1;
  end process;
end;
**syn_pipeline**

This attribute permits registers to be moved to improve timing, and specifies that registers that are outputs of Multipliers/Adders can be moved to improve timing. Depending on the criticality of the path, the tool moves the output register to the input side.

**Verilog Syntax**

```verilog
object /* synthesis syn_pipeline = {1 | 0} */ ;
```

where `object` is a register declaration.

- The value of 0 (or false) indicates pipelining for the specified register is disabled, which means the register position in the design is fixed.
- The value of 1 (or true) indicates pipelining for the specified register is allowed, which means the register may be moved if it helps improve timing.

LSE identifies registers that are candidates for possible pipelining based on running RTL timing analysis. It may identify some candidate registers, or it may determine there are none that are suitable.

If LSE decides no candidate registers for pipelining exist, and if the user sets the `syn_pipeline` attribute to “1” on a specific register in the RTL to force pipelining for that register, that attribute will not be honored.

If global pipelining is enabled for a design, and LSE has identified one or more registers as possible candidates for pipelining, the user may prevent these registers from being pipelined by setting synthesis attribute `syn_pipeline=0` for each of those registers in the RTL.

**Verilog Example**

```verilog
module pipeline (a,b,c,d,clk,out);

input [3:0] a,b,c,d;
input clk;
output[7:0]out;

reg[7:0]out,out1 /* synthesis syn_pipeline = 0 */;
reg[3:0] a_temp,b_temp,c_temp,d_temp;

always @(posedge clk)
begin
    a_temp <= a;
    b_temp <= b;
    c_temp <= c;
    d_temp <= d;
    out1 <= (a_temp * b_temp) +(c_temp * d_temp);
    out <= out1;
end
endmodule
```

In the previous example, the registers labeled “out1” will not be moved to the input side of the adder to improve timing.
VHDL Syntax  

```
attribute syn_pipeline of object : objectType is {true|false} ;
```

VHDL Example

```
library ieee;
use ieee.std_logic_1164.all;
USE ieee.numeric_std.all;
use ieee.std_logic_unsigned.all;

entity syn_pipeline_exp is
port (CLK_0 : in std_logic;
      A_IN : in std_logic_vector(3 downto 0);
      B_IN : in std_logic_vector(3 downto 0);
      RST : out std_logic_vector(7 downto 0)
     );
end syn_pipeline_exp;

architecture rtl of syn_pipeline_exp is
signal A_REGSTR : std_logic_vector(3 downto 0);
signal B_REGSTR : std_logic_vector(3 downto 0);
signal TMP : std_logic_vector(7 downto 0);
signal TMP1 : std_logic_vector(7 downto 0);
signal TMP2 : std_logic_vector(7 downto 0);
attribute syn_pipeline : string;
attribute syn_pipeline of TMP1 : signal is "true";
begin
  process(CLK_0)
  begin
    if (CLK_0'event and CLK_0 = '1') then
      TMP <= A_REGSTR * B_REGSTR;
      A_REGSTR <= A_IN;
      B_REGSTR <= B_IN;
      TMP1 <= TMP;
      TMP2 <= TMP1;
      RST <= TMP2;
    end if;
  end process;
end rtl;
```
**syn_preserve**

This attribute prevents sequential optimizations such as constant propagation and inverter push-through from removing the specified register. The syn_encoding attribute is not honored if there is a syn_preserve attribute on any of the state machine registers.

**Note**: Only the objects that are existent in the RTL view netlist (i.e. appearing in Netlist Analyzer) after synthesis will honor the attribute through to the technology mapping.

**Verilog Syntax**

```
object /* synthesis syn_preserve = 1 */;
```

where **object** is a register definition signal or a module.

**Verilog Example**

```vhdl
module syn_preserve1(
    input[3:0]in1,
    input[3:0]in2,
    input[3:0]in3,
    input clk,
    output [7:0] result,
    output [3:0] sum
)/* synthesis syn_preserve= 1 */;
```

```vhdl
reg [7:0] result/*synthesis syn_multstyle = "EBR"*/;
reg [3:0] temp1,temp2,temp3;
reg [3:0] sum;

always@(posedge clk)
    begin
        temp1 = in1 & in2;
        temp2 = !temp1;
        temp3 = temp1 & temp2;
        result = temp3*in3;
        sum = temp3 + in3;
    end
endmodule
```

**VHDL Syntax**

```
attribute syn_preserve of object : objectType is true;
```

where **object** is an output port or an internal signal that holds the value of a state register or architecture.

**VHDL Example**
library ieee;
use ieee.std_logic_1164.all;
use ieee.std_logic_unsigned.all;

entity syn_preserve2 is
port(
in1: in std_logic_vector(3 downto 0);
in2: in std_logic_vector(3 downto 0);
in3: in std_logic_vector(3 downto 0);
clk: in std_logic;
result: out std_logic_vector(7 downto 0);
sum : out std_logic_vector(3 downto 0)
);
end entity;

architecture behave of syn_preserve2 is
signal temp1,temp2,temp3 : std_logic_vector(3 downto 0);
attribute syn_preserve : boolean;
attribute syn_preserve of behave: architecture is true;
attribute syn_multstyle : string;
attribute syn_multstyle of result: signal is "EBR";
begin
process(clk)
begin
if clk'event and clk = '1' then
  temp1 <= in1 and in2;
  temp2 <= not temp1;
  temp3 <= temp1 and temp2;
  result <= temp3*in3;
  sum <= temp3 + in3;
end if;
end process;
end behave;
**syn_ramstyle**

The `syn_ramstyle` attribute specifies the implementation to use for an inferred RAM. You apply `syn_ramstyle` globally to a module or RAM instance. To turn off RAM inference, set its value to registers.

The following values can be specified globally or on a module or RAM instance:

- **Registers** – Causes an inferred RAM to be mapped to registers (flip-flops and logic) rather than the technology-specific RAM resources.
- **Distributed** – Causes the RAM to be implemented using the distributed RAM or PFU resources.
- **Block_ram** – Causes the RAM to be implemented using the dedicated RAM resources. If your RAM resources are limited, you can use this attribute to map additional RAMs to registers instead of the dedicated or distributed RAM resources.
- **no_rw_check (some modes, but all technologies)** – You cannot specify this value alone. Without `no_rw_check`, the synthesis tool inserts bypass logic around the RAM to prevent the mismatch. If you know your design does not read and write to the same address simultaneously, use `no_rw_check` to eliminate bypass logic. Use this value only when you cannot simultaneously read and write to the same RAM location and you want to minimize overhead logic.

**Note**: If the memory size defined (depth x width) is less than thirty registers, then EBRs will not be inferred.

**Verilog Syntax**

```
object /* synthesis syn_ramstyle = "string" */;
```

where `object` is a register definition (reg) signal. The data type is string.

**Verilog Example**

```verilog
module ram4 (datain, dataout, clk);
output [31:0] dataout;
input clk;
input [31:0] datain;
reg [7:0] dataout[31:0] /* synthesis syn_ramstyle="block_ram" */;
```

**VHDL Syntax**

```
attribute syn_ramstyle of object : objectType is "string" ;
```

where `object` is a signal that defines a RAM or a label of a component instance. *Data type* is string.

**VHDL Example**
library ieee;
use ieee.std_logic_1164.all;
entity ram4 is
  port (d : in std_logic_vector(7 downto 0);
       addr : in std_logic_vector(2 downto 0);
       we : in std_logic;
       clk : in std_logic;
       ram_out : out std_logic_vector(7 downto 0) );
end ram4;
library synplify;
architecture rtl of ram4 is
  type mem_type is array (127 downto 0) of std_logic_vector (7 downto 0);
  signal mem : mem_type; -- mem is the signal that defines the RAM
  attribute syn_ramstyle : string;
  attribute syn_ramstyle of mem : signal is "block_ram";
**syn_replicate**
This attribute controls replication. While the synthesis tool can automatically replicate registers during optimization, this attribute disables replication either globally or on a per register basis.

**Verilog Syntax**
```verilog
object /* synthesis syn_replicate = 1 | 0 */;
```

**Verilog Example**
For example:

```verilog
module syn_replicate1 (en1,en2,clk,in1,in2,q);
  input en1,en2;
  input clk;
  input [6:0]in1,in2;
  output [6:0]q;
  reg [6:0]q;
  reg enc /* synthesis syn_maxfan = 1 syn_replicate = 1*/;
  always @(posedge clk)
    begin
      enc = en1 & en2;
      end
  always @(posedge clk)
    begin
      if (enc)
        q = in1;
      else
        q = in2;
      end
  endmodule
```
**VHDL Syntax**

attribute syn_replicate of object : objectType is true | false ;

**VHDL Example**

For example:

```
library ieee;
use ieee.std_logic_1164.all;

entity syn_replicate2 is
  port(
    en1: in std_logic;
    en2: in std_logic;
    clk: in std_logic;
    in1: in std_logic_vector(6 downto 0);
    in2: in std_logic_vector(6 downto 0);
    q:  out std_logic_vector(6 downto 0);
  );
end entity;

architecture behave of syn_replicate2 is
  signal enc : std_logic;
  attribute syn_maxfan: integer;
  attribute syn_maxfan of behave : architecture is 1;
  attribute syn_replicate: boolean;
  attribute syn_replicate of enc : signal is false;
begin
  process(clk)
  begin
    if clk'event and clk = '1' then
      enc <= (en1 and en2);
    end if;
  end process;

  process(clk)
  begin
    if enc = '1' then
      q <= in1;
    else
      q <= in2;
    end if;
  end process;
end behave;
```
**syn_romstyle**

This attribute allows you to implement ROM architectures using dedicated or distributed ROM. Infer ROM architectures uses a CASE statement in your code.

For the synthesis tool to implement a ROM, at least half of the available addresses in the CASE statement must be assigned a value. For example, consider a ROM with six address bits (64 unique addresses). The case statement for this ROM must specify values for at least 32 of the available addresses. You can apply the `syn_romstyle` attribute globally to the design by adding the attribute to the module or entity.

The following values can be specified globally on a module or ROM instance:

- **Auto** – Allows the synthesis tool to choose the best implementation to meet the design requirements for speed, size, etc.
- **Logic** – Causes the ROM to be implemented using the distributed ROM or PFU resources.
- **EBR** – Causes the ROM to be implemented using the dedicated ROM resources. If your ROM resources are limited, you can use this attribute to map additional ROM to registers instead of the dedicated or distributed RAM resources.

**Verilog Syntax**

```verilog
object /* syn_romstyle = "auto(default) | EBR | logic" */ ;
```

**Verilog Example**

```verilog
reg [8:0] z /* synthesis syn_romstyle = "EBR" */;
```

**VHDL Syntax**

```vhdl
attribute syn_romstyle of object : object_type is
  "auto(default) | EBR | logic" ;
```

**VHDL Example**

```vhdl
signal z : std_logic_vector(8 downto 0);
attribute syn_romstyle : string;
attribute syn_romstyle of z : signal is "logic";
```
**syn_srlstyle**
This attribute determines how to implement the sequential shift components.

**Verilog Syntax**  
object /* synthesis syn_srlstyle = "string",  
where *string* can take one of the following values:

- **Registers**: seqShift register components are implemented as registers.
- **Distributed**: seqShift register components are implemented as distributed RAM.
- **Block_ram**: seqShift register components are implemented as block RAM

If the attribute value set by the user cannot be honored (for example, the user sets the attribute value to "block_ram", but the selected device does not contain enough available EBR blocks to implement the shift register), LSE will display a message to indicate this.

" | registers | distributed | block_ram" */ ;

In the above syntax, *object* is a register declaration.

**Note**: If the memory size defined (depth x width) is less than thirty registers, then EBRs will not be inferred.

**Verilog Example**  
The following example implements seqShift components as distributed memory with any required fabric logic.

```verilog
module test_srl(clk, enable, dataIn, result, addr);
  input clk, enable;
  input [3:0] dataIn;
  input [3:0] addr;
  output [3:0] result;
  reg [3:0] regBank[15:0]
    /* synthesis syn_srlstyle="distributed" */;
  integer i;
  always @(posedge clk) begin
    if (enable == 1) begin
      for (i=15; i>0; i=i-1) begin
        regBank[i] <= regBank[i-1];
      end
      regBank[0] <= dataIn;
    end
  end
  assign result = regBank[addr];
endmodule
```

The following example implements a seqShift for 16x256 bits wide and serial in and serial out register using **syn_srlstyle** set to *block_ram*.

**VHDL Syntax**  
attribute syn_srlstyle of object : signal is

" registers | distributed | block_ram " ;
In the above syntax, `object` is a register.

**Verilog Example**  The example below implements seqShift components as distributed memory primitives:

```verilog
// shift left register with 16X256 bits width and serial in and serial out
module test(clock, arst, sr_en, shiftin, shiftout);
parameter sh_len=16;
parameter sh_width=256;
parameter ARESET_VALUE = {(sh_width){1'b0}};
input clock, arst, sr_en;
input [sh_width-1:0] shiftin;
output [sh_width-1:0] shiftout;
integer i;
reg [sh_width-1:0] sreg [sh_len-1:0] /* synthesis
syn_srlstyle="block_ram" */;
always @(posedge clock or posedge arst)
begin
  if(arst)
    begin
      for(i = 0;i <= sh_len-1;i = i+1)
        sreg[i] <= ARESET_VALUE ;
    end
  else
    begin
      if(sr_en)
        begin
          sreg[0] <= shiftin;
          for(i=sh_len-1;i>0;i=i-1)
            sreg[i] <= sreg[i-1];
        end
    end
assign shiftout = sreg[sh_len-1];
extendmodule
```
library ieee;
use ieee.std_logic_1164.all;
use ieee.std_logic_unsigned.all;

entity d_p is
  port (clk : in std_logic;
       data_out : out std_logic_vector(127 downto 0));
end d_p;

architecture rtl of d_p is
  type dataAryType is array(3 downto 0) of
    std_logic_vector(127 downto 0);
  signal h_data_pip_i : dataAryType;

attribute syn_srlstyle : string;
attribute syn_srlstyle of h_data_pip_i : signal
  is "distributed";
begin
  process (Clk)
  begin
    if (Clk'Event And Clk = '1') then
      h_data_pip_i <= (h_data_pip_i(2 DOWNTO 0)) &
                       h_data_pip_i(3);
    end if;
  end process;
  data_out <= h_data_pip_i(0);
end rtl;
**syn_sharing**

Directive. Enables or disables the sharing of operator resources during the compilation stage of synthesis.

The `syn_sharing` directive controls resource sharing during the compilation stage of synthesis. This is a compiler-specific optimization that does not affect the mapper, meaning that the mapper might still perform resource sharing optimizations to improve timing, even if `syn_sharing` is disabled.

If you disable resource sharing globally, you can use the `syn_sharing` directive to turn on resource sharing for specific modules or architectures.

**Verilog Syntax**
```
object /* synthesis syn_sharing="on/1 | off/0" */ ;
```

**Verilog Example**
```
module syn_sharing1 (  
  input [7:0] inA1,  
  input [7:0] inA2,  
  input [7:0] inB1,  
  input [7:0] inB2,  
  input clk,  
  input sel1,  
  input sel2,  
  input rst,  
  output [15:0] product1,  
  output [15:0] product2  
) /*synthesis syn_sharing = 1*/ ;

  reg [15:0] product1,product2;
  wire [15:0] temp1,temp2;
  assign temp1 = inA1*inB1;
  assign temp2 = inA2*inB2;
  always@(posedge clk)
  begin
    if(sel1)
      begin
        if (sel2)
          product1 = temp1;
        else
          product1 = temp2;
      end
    else
      begin
        if (sel2)
          product2 = temp1;
        else
          product2 = temp2;
      end
  end
endmodule
```

**VHDL Syntax**
```
attribute syn_sharing of object : objectType is “true | false” ;
```
**VHDL Example**

```vhdl
library ieee;
use ieee.std_logic_1164.all;
use ieee.std_logic_unsigned.all;

entity syn_sharing2 is
  port(
    inA1 : in std_logic_vector(7 downto 0);
    inA2 : in std_logic_vector(7 downto 0);
    inB1 : in std_logic_vector(7 downto 0);
    inB2 : in std_logic_vector(7 downto 0);
    clk  : in std_logic;
    sel1 : in std_logic;
    sel2 : in std_logic;
    rst  : in std_logic;
    product1 : out std_logic_vector(15 downto 0);
    product2 : out std_logic_vector(15 downto 0)
  );
end entity;

architecture behave of syn_sharing2 is
  signal temp1,temp2: std_logic_vector(15 downto 0);
  attribute syn_sharing : boolean;
  attribute syn_sharing of behave : architecture is false;
begin
  temp1 <= inA1*inB1;
  temp2 <= inA2*inB2;
  process(clk)
  begin
    if clk'event and clk = '1' then
      if sel1 = '1' then
        if sel2 = '1' then
          product1 <= temp1;
        else
          product1 <= temp2;
        end if;
      else
        if sel2 = '1' then
          product2 <= temp1;
        else
          product2 <= temp2;
        end if;
      end if;
    end if;
  end process;
end behave;
```
**syn_state_machine**

This attribute enables/disables state-machine optimization on individual state registers in the design. To extract some state machines, use this attribute with a value of 1 on just those individual state-registers to be extracted. If there are state machines in your design that you do not want extracted, use `syn_state_machine` with a value of 0 to override extraction on those individual state registers.

All state machines are usually detected during synthesis. However, on occasion there are cases in which certain state machines are not detected. You can use this attribute to declare those undetected registers as state machines.

The `syn_sharing` attribute only can be used in architecture. The `syn_sharing` attribute cannot be used in entity.
**Verilog Syntax**

```
object /* synthesis syn_state_machine = 0 | 1 */;
```

where `object` is a state register. Data type is Boolean: 0 does not extract an FSM, 1 extracts an FSM.

**Verilog Example**

```verilog
module syn_state_machine1 (clk, reset, en, q);
    input clk, reset, en;
    output[1:0] q;
    reg q;
    reg [3:0] state, next_state /* synthesis syn_state_machine = 0 */;
    parameter state0 = 4'b1000;
    parameter state1 = 4'b0100;
    parameter state2 = 4'b0010;
    parameter state3 = 4'b0001;
    always @(posedge clk or posedge reset)
        begin
            if (reset)
                state <= state0;
            else
                state <= next_state;
        end
    always @(state)
        begin
            case (state)
                state0:
                    begin
                        if (en == 1)
                            q <= 2'b00;
                            next_state <= state1;
                    end
                state1:
                    begin
                        if (en == 1)
                            q <= 2'b01;
                            next_state <= state2;
                    end
                state2:
                    begin
                        if (en == 1)
                            q <= 2'b10;
                            next_state <= state3;
                    end
                state3:
                    begin
                        if (en == 1)
                            q <= 2'b11;
                            next_state <= state0;
                    end
            endcase
        end
endmodule
```
VHDL Syntax  

    attribute syn_state_machine of object : objectType is true | false;

where `object` is a signal that holds the value of the state machine.

**VHDL Example**

```vhdl
    attribute syn_state_machine of current_state: signal is true;
```

The following is the source code used for the previous example.
library ieee;
use ieee.std_logic_1164.all;
entity syn_statemachine_exp is
port (CLK_0, RESET, IN1 : in std_logic;
       OUT1 : out std_logic_vector (2 downto 0)
);
end syn_statemachine_exp;
architecture behave of syn_statemachine_exp is
type ST_VALS is (STATE0, STATE1, STATE2, STATE3);
signal STATE, NXT_ST: ST_VALS;
attribute syn_state_machine : boolean;
attribute syn_state_machine of STATE : signal is true;
begin
    process (CLK_0, RESET)
    begin
        if RESET = '1' then
            STATE <= STATE0;
        elsif rising_edge(CLK_0) then
            STATE <= NXT_ST;
        end if;
    end process;

    process (STATE, IN1)
    begin
        case STATE is
        when STATE0 =>
            OUT1 <= "000";
            if IN1 = '1' then NXT_ST <= STATE1;
            else NXT_ST <= STATE0;
            end if;
        when STATE1 =>
            OUT1 <= "001";
            if IN1 = '1' then NXT_ST <= STATE2;
            else NXT_ST <= STATE1;
            end if;
        when STATE2 =>
            OUT1 <= "010";
            if IN1 = '1' then NXT_ST <= STATE3;
            else NXT_ST <= STATE2;
            end if;
        when others =>
            OUT1 <= "XXX"; NXT_ST <= STATE0;
        end case;
    end process;
end behave;
**syn_use_carry_chain**
This attribute is used to turn on or off the carry chain implementation for adders.

**Verilog Syntax**
object synthesis syn_use_carry_chain = {1| 0} */ ;

**Verilog Example**
To use this attribute globally, apply it to the module.

module test (a, b, clk, rst, d) /* synthesis
syn_use_carry_chain = 1 */;

**VHDL Syntax**
attribute syn_use_carry_chain of object : objectType is true | false ;

**VHDL Example**

architecture archtest of test is
signal temp : std_logic;
signal temp1 : std_logic;
signal temp2 : std_logic;
signal temp3 : std_logic;
attribute syn_use_carry_chain : boolean;
attribute syn_use_carry_chain of archtest : architecture is true;
**syn_useenables**
This attribute controls the use of clock enables on registers in the design. Exploiting clock enables on registers is usually beneficial. However, there are timing closure situations where clock enable routing causes timing violations. This is one reason why the user may want to stop the use of clock enable on the register.

**Verilog Syntax:**
```
object /* synthesis syn_useenables = "0 | 1" */;
```

**Verilog Example**
```
module syn_useenable1 (Din1,Din2,en,clk,Dout);
    input [7:0] Din1, Din2;
    input clk,en;
    output [7:0] Dout;
    reg [7:0] temp1;
    reg [7:0] Dout /* synthesis syn_useenables = 0*/;
always@(posedge clk)
    begin
        temp1 <= Din1 & Din2;
    end
always @(posedge clk)
    begin
        if(en)
            Dout <= temp1;
    end
endmodule
```
VHDL Syntax: attribute syn_useenables of object : objectType is "true | false";

VHDL Example

```vhdl
library ieee;
use ieee.std_logic_1164.all;

entity syn_useenable2 is
  port(
    Din1 : in std_logic_vector(7 downto 0);
    Din2 : in std_logic_vector(7 downto 0);
    clk  : in std_logic;
    en   : in std_logic;
    Dout : out std_logic_vector(7 downto 0)
  );
end entity;

architecture behave of syn_useenable2 is
  signal temp1 : std_logic_vector(7 downto 0);
  attribute syn_useenables: boolean;
  attribute syn_useenables of Dout: signal is false;
  begin
    process(clk)
    begin
      if clk'event and clk = '1' then
        temp1 <= Din1 and Din2;
      end if;
    end process;

    process(clk)
    begin
      if clk'event and clk = '1' then
        if en = '1' then
          Dout <= temp1;
        end if;
      end if;
    end process;
  end behave;
```
**syn_useioff**
This attribute overrides the default behavior to pack registers into I/O pad cells based on timing requirements for the target Lattice families. Attribute `syn_useioff` is Boolean-valued: 1 enables (default) and 0 disables register packing. You can place this attribute on an individual register or port or apply it globally. When applied globally, the synthesis tool packs all input, output, and I/O registers into I/O pad cells. When applied to a register, the synthesis tool packs the register into the pad cell; and when applied to a port, it packs all registers attached to the port into the pad cell.

The `syn_useioff` attribute can be set on the following ports:
- Top-level port.
- Register driving the top-level port.
- Lower-level port, if the register is specified as part of the port declaration.

**Verilog Syntax**
```
object /*synthesis syn_useioff = {1 | 0} */ ;
```

**Verilog Example** To use this attribute globally, apply it to the module.

```verbatim
module test (a, b, clk, rst, d) /* synthesis syn_useioff = 1 */;
```

To use this attribute on individual ports, apply it to individual port declarations.

```verbatim
module test (a, b, clk, rst, d);
input a;
input b /* synthesis syn_useioff = 1 */;
```

**VHDL Syntax**
```
attribute syn_useioff of object : objectType is true | false ;
```

**VHDL Example**
```
architecture archtest of test is
signal temp : std_logic;
signal temp1 : std_logic;
signal temp2 : std_logic;
signal temp3 : std_logic;
attribute syn_useioff : boolean;
attribute syn_useioff of archtest : architecture is true;
```
**translate_off/translate_on**

This attribute allows you to synthesize designs originally written for use with other synthesis tools without needing to modify source code. All source code that is between these two attributes is ignored during synthesis.

**Verilog Syntax**  
/* pragma translate_off */  
/* pragma translate_on */

**Verilog Example**

```verilog
module real_time (ina, inb, out);
    input ina, inb;
    output out;
    /* synthesis translate_off */
    realtime cur_time;
    /* synthesis translate_on */
    assign out = ina & inb;
endmodule
```

**VHDL Syntax**  
pragma translate_off  
pragma translate_on

**VHDL Example**

```vhdl
library ieee;
use ieee.std_logic_1164.all;
entity adder is
    port (a, b, cin:in std_logic;
         sum, cout:out std_logic);
end adder;
architecture behave of adder is
    signal a1:std_logic;
--synthesis translate_off
    constant a1:std_logic:='0';
--synthesis translate_on
    begin
        sum <= (a xor b xor cin);
        cout <= (a and b) or (a and cin) or (b and cin); end behave;
```

**Synopsys Design Constraints Timing/Physical Constraints**

This section describes the new physical constraints in the Radiant software that are formatted similar to SDC formats to set physical constraints.

**See Also**  
► "ldc_create_group" on page 630
► "ldc_create_region" on page 630
► "ldc_create_vref" on page 631
```
- **ldc** create_group

**Description**
Defines a single identifier that refers to a group of objects. Only slice and IO can be created currently.

**Usage**
create_group -name group_name [-bbox {height  width}] <objects>

**Options**
- **-name**: group name
- **[-bbox]**: is used to optionally define the maximum number of rows (R) and columns (C), of the group’s bounding box, -bbox is not applicable to port
- **<objects>**: objects named in the group, either port, instance, pin or net.

**Example**
create_group -name group1[get_ports{a*}]

---

- **ldc** create_region

**Description**
Define a rectangular area.

**Usage**
create_region -name region_name [-site site] <-width width> <-height height>

**Options**
- **-name**: a user-defined name of the region
- **-site**: a row/column Slice D location of the target device
- **-width**: the width of the region in columns
- **-height**: the height of the region in rows

**Example**
create_region -name region0 -site R16C2D -width 11 -height 30
```
**ldc_create_vref**

**Description**  Define a voltage reference. The PIO site serves as the input pin for an on-chip voltage reference.

**Usage**  ldc_create_vref -name vref_name -site site_name

**Options**
- -name: voltage reference name
- -site: PIO site of the target device

**Example**
ldc_create_vref -name VREF1_BANK_3 -site N21

**ldc_set_location**

**Description**  When applied to a specified component, it places the component at a specified site or bank and locks the component to the site or bank. In this case, -site or -bank and <object> are valid combinations.

When applied to a specified group, it places the group at a specified site or within a region. In this case, -site or -region and -group are valid combinations.

**Usage**  ldc_set_location [-site site_name] [-bank bank_num] [-region region_name] <object>

**Options**
- -site: a row/column Slice D location or PIO site of the target device
- -bank: bank number
- -region: user defined region name
- -Object: object to be located

**Example**
ldc_set_location -site 11 [get_ports {A}]
ldc_set_location -region region0 [get_group {group1}]

**ldc_set_vcc**

**Description**  Sets the voltage and/or derate for the bank or core.

**Usage**  ldc_set_vcc [-bank bank] [-core] [-derate derate] [voltage]

**Options**
- -bank: bank number, set voltage to bank
- -core: set voltage to core
-derate: voltage derating percent
Voltage: can be any compatible voltage supply to that bank or the core; for example, 2.5, 3.3

**Example**
```
ldc_set_vcc -bank 1 3.3
ldc_set_vcc -bank 1 -derate -3
```

**Idc_set_port**
**Description**  Set constraint attributes to ports; -iobuf, is used exclusively; -vref must be combined with -iobuf.
**Usage**  `ldc_set_port [-iobuf [-vref <vref_name>]] <key-value list> <ports>`
**Options**
- -iobuf: set IOBUF attributes. valid key-values are available in LCT file.
- -vref: voltage reference name, must be bound to -iobuf.
- <key-value list>: key-value list must be enclosed with curly braces.
- <ports>: ports to be set. If no port specified, set constraint to all ports.

**Example**
```
ldc_set_port -iobuf {IO_TYPE=HSTL15_II PULLMODE=UP} [get_ports {A}]
```

**Idc_set_sysconfig**
**Description**  Set sysconfig attributes.
**Usage**  `ldc_set_sysconfig <key-value list>`
**Options**  <key-value list>: SYSCONFIG attributes, valid key-values are available in sysConfig file. key-value list must be enclosed with curly braces.

**Example**
```
ldc_set_sysconfig {JTAG_PORT=ENABLE PROGRAMN_PORT=ENABLE MCCLK_FREQ=56.2 DONE_OD=ON}
```

**Idc_set_attribute**
**Description**  Set constraint attributes to the objects or the design if no object is specified.
**Usage**  `ldc_set_attribute <key-value list> <objects>`
**Options**  key-value list: constraint attributes to be set to object(s) or design if no object specified. Valid key-values are:

Global attributes

- **FORMAT** and **UNIQUE_ID** is a valid combination to implement **USERCODE**.
- **FORMAT** specifies one of the available formats for codes: binary (BIN), hexadecimal (HEX), text (ASCII), AUTO.
- **CODE** for binary or BIN format, specify a 32-bit user code string using only 1 or 0 digits. For hexadecimal or HEX format, specify an eight-character user code string using only 0 through F values. For text or ASCII format, specify a four-character user code string using only alpha and numeric values.
- **TEMPERATURE<number>**(C|F|K). No <object> specified.

Net attributes.

- **GSR_NET** is set to **TRUE** / **FALSE**:
  - **TRUE**: specify the net to be GSR net (global reset source driver).
  - **FALSE**: don’t infer the net to be GSR_NET net. <object> must be net.

  **Note**

  The default Synthesis strategy is "Force GSR = Auto".

  The default Map strategy is "infer GSR = FALSE".

  When using "GSR_NET" constraint, user must change the above two strategies to:

  - Synplify - "Force GSR = False",
  - LSE - "Force GSR = No"
  - MAP - "infer GSR = True"

- **USE_PRIMARY** is set to **TRUE** / **FALSE**.
  - **TRUE**: set USE_PRIMARY net to primary clock resource.
  - **FALSE**: prohibit USE_PRIMARY net from using primary clock resource; <object> must be net.

  **USE_PRIMARY_REGION**: Comma-separated list of integers denoting primary clock region(s). Primary clock regions are numbered from top to bottom, left to right based on their position in the chip and start from 0. <object> must be net.

Clock attributes.

- **PAR_ADJ**: 1-50, over-constrain a timing constraint which applies to clock(s)

  **Note**: **GSR_NET**, **PAR_ADJ** are not applicable for iCE40 Ultra Plus.

**Example**

```
ldc_set_attribute {FORMAT=HEX CODE=536*56D69}
```
ldc_set_attribute {PAR_ADJ=10} [get_clocks {clk1}]
ldc_set_attribute {USE_PRIMARY=TRUE} {USE_PRIMARY_REGION=0,1} [get_nets {clk1_c}]
ldc_set_attribute GSR_NET=TRUE [get_nets {my_gsr}]

ldc_prohibit

Description  Prohibits the use of a site or all sites in a region.

Usage  ldc_prohibit –site site OR ldc_prohibit –region region

Options  site: site name, region: region name

Example
ldc_prohibit -site AB
ldc_prohibit -region regionA
IP Catalog provides a variety of modules to assist your design work. These modules cover a variety of common functions and can be customized. They are optimized for Lattice device architectures. Use these modules to speed up your design work and to get the most effective results.

Parameterized Module Instantiation (PMI) is an alternate way to use some of the modules that come with IP Catalog. Instead of using IP Catalog, you directly instantiate a module into your HDL and customize it by setting parameters in the HDL using PMI. As a result, you may find this easier to use than IP Catalog in certain situations.

This guide describes the modules that come with IP Catalog and the related PMI modules. The descriptions mainly cover the options and controls of the configuration dialog boxes for the modules. When there is a related PMI module, the descriptions also include specifications for the PMI module’s customizable parameters and ports.

See Also

- “PMI or IP Catalog?” on page 117
- “Creating IP Catalog Components” on page 117
- “Using PMI” on page 123

Finding Modules in This Guide

Each module and IP has an associated IP Information page.

The IP information page provides description, devices supported, link to User Guide, and revision history.
To open the IP Information page for a module or IP:

- In either the IP on Local tab, or IP on Server tab, click on the module or IP, and then click on the blue question mark 🎨. The IP Information page will appear on the right.

See Also

- “PMI or IP Catalog?” on page 117
- “Creating IP Catalog Components” on page 117
- “Using PMI” on page 123
FPGA Libraries Reference Guide

Lattice Semiconductor supports some libraries used in designing FPGAs with different device architectures in a number of CAE synthesis, schematic capture, and simulation platforms. These libraries are the main front-end design libraries for Lattice FPGAs. Logic design primitives in these libraries offer flexibility and efficiency to facilitate building specific applications with Lattice devices.

A specific primitive can be found according to the device family and functional category. Primitives available to each of the following device families are listed according to appropriate functional categories.

- “Primitive Library - LFD2NX” on page 650
- “Primitive Library - LIFCL” on page 644
- “Primitive Library - iCE40 UltraPlus” on page 639

The “Alphanumeric Primitives List” section contains descriptions of all available primitives in their alphanumeric order. The following information is provided for each primitive, where applicable:

Table 1: Information Provided for Each Primitive

<table>
<thead>
<tr>
<th>Fields</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Primitive name</td>
</tr>
<tr>
<td>Definition</td>
<td>Brief description of primitive</td>
</tr>
<tr>
<td>Architecture Supported</td>
<td>List of FPGA families supported by the primitive</td>
</tr>
</tbody>
</table>
### Table 1: Information Provided for Each Primitive

<table>
<thead>
<tr>
<th>Fields</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Port Interface Symbol</td>
<td>Graphic representing the primitive port interface. Data, address, clock, clock enable type ports appear on the left-hand side of the block. Synchronous ports appear on the top of the symbol. Asynchronous control ports appear on the bottom of the symbol. The output ports appear on the right-hand side of the block. Some of the graphic symbols are shown in bus notation for proper layout. Such primitives must be instantiated in expanded bus notation format with each individual bit.</td>
</tr>
<tr>
<td>Port Description</td>
<td>List of port names, polarity, and function.</td>
</tr>
<tr>
<td>Parameters</td>
<td>List of parameters compatible with the primitive. The first value is usually the default value, if it is not explicitly indicated. Attribute function, range, and port-to-attribute or attribute-to-attribute relationships for the primitive are noted.</td>
</tr>
<tr>
<td>Synthesis Inference Rules</td>
<td>Guideline on whether the component can be inferred by supported synthesis tools.</td>
</tr>
<tr>
<td>User Instantiation Rules</td>
<td>Guideline on whether the component can be directly instantiated in the design.</td>
</tr>
</tbody>
</table>
**Primitive Library - iCE40 UltraPlus**

This library includes compatible primitives supported by the iCE40 UltraPlus device family.

- Adders/Subtractors
- Flip-Flops
- Input/Output Buffer
- Memory
- Multiplier
- PIC Cells
- Special Cells
  - Clock/PLL
  - Combinatorial Primitives
  - Interfaces
  - Oscillators
  - Miscellaneous

**References**
For further information, a variety of technical notes for the iCE40 UltraPlus family are available on the Lattice Web site.

### Table 1: Adders/Subtractors

<table>
<thead>
<tr>
<th>Primitive</th>
<th>Description</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>CCU2_B</td>
<td>Carry Chain.</td>
<td></td>
</tr>
<tr>
<td>FA2</td>
<td>Carry chain two bit full adder.</td>
<td>USER INSTANTIATION: Not Recommended; prefer RTL synthesis inference.</td>
</tr>
</tbody>
</table>

### Table 2: Flip-Flops

<table>
<thead>
<tr>
<th>Primitive</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>FD1P3BZ</td>
<td>Positive edge triggered D flip-flop with positive level enable and positive level asynchronous preset.</td>
</tr>
<tr>
<td>FD1P3DZ</td>
<td>Positive edge triggered D flip-flop with positive level enable and positive level asynchronous clear.</td>
</tr>
<tr>
<td>FD1P3IZ</td>
<td>Positive edge triggered D flip-flop with positive level synchronous clear and positive level enable (clear overrides enable)</td>
</tr>
<tr>
<td>FD1P3JZ</td>
<td>Positive edge triggered D flip-flop with positive level synchronous preset and positive level enable (preset overrides enable).</td>
</tr>
<tr>
<td>FD1P3XZ</td>
<td>Positive edge triggered D flip-flop with synchronous or asynchronous set/reset.</td>
</tr>
</tbody>
</table>
### Table 3: Input/Output Buffer

<table>
<thead>
<tr>
<th>Primitive</th>
<th>Description</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>BB_B</td>
<td>Bidirectional I/O buffer with tri-state.</td>
<td></td>
</tr>
<tr>
<td>IB</td>
<td>Input buffer.</td>
<td></td>
</tr>
<tr>
<td>OB</td>
<td>Output buffer.</td>
<td></td>
</tr>
<tr>
<td>OBZ_B</td>
<td>Output buffer with tristate.</td>
<td>USER INSTANTIATION: Illegal. Please refer to RGB and RGB1P8V.</td>
</tr>
<tr>
<td>OB_RGB</td>
<td>Output Buffer.</td>
<td></td>
</tr>
</tbody>
</table>

### Table 4: Memory

<table>
<thead>
<tr>
<th>Primitive</th>
<th>Description</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>EBR_B</td>
<td>4 Kb pseudo-dual port block ram with configurable write/read width &amp; optional bitstream initialization.</td>
<td>USER INSTANTIATION: Not recommended; prefer either RTL synthesis inference or IP Generation Tool.</td>
</tr>
<tr>
<td>PDP4K</td>
<td>4Kb pseudo-dual port block RAM.</td>
<td></td>
</tr>
<tr>
<td>SP256K</td>
<td>Single Port RAM that can be configured in 16K x 16 mode. This block can be cascaded using logic implemented in fabric to create larger memories.</td>
<td></td>
</tr>
<tr>
<td>VFB_B</td>
<td>256Kb single port RAM.</td>
<td>USER INSTANTIATION: Not recommended. Please refer to SP256K.</td>
</tr>
</tbody>
</table>

### Table 5: Multiplier

<table>
<thead>
<tr>
<th>Primitive</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>MAC16</td>
<td>DSP block capable of being configured as a multiplier, adder, subtractor, accumulator, multiply-adder or multiply-subtractor.</td>
</tr>
</tbody>
</table>

### Table 6: PIC Cells

<table>
<thead>
<tr>
<th>Primitive</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>IFD1P3AZ</td>
<td>Positive edge triggered input D flip-flop with positive level enable.</td>
</tr>
<tr>
<td>IOL_B</td>
<td>Input/output registers, for both single data and double data rate.</td>
</tr>
</tbody>
</table>
## Special Cells

### Table 7: Clock/PLL

<table>
<thead>
<tr>
<th>Primitive</th>
<th>Description</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>PLL_B</td>
<td>Phase locked loop. <strong>For internal use.</strong></td>
<td>USER INSTANTIATION: Not recommended; prefer IP Generation Tool.</td>
</tr>
</tbody>
</table>

### Table 8: Combinatorial Primitives

<table>
<thead>
<tr>
<th>Primitive</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>LUT4</td>
<td>4-Input Look Up Table.</td>
</tr>
</tbody>
</table>

### Table 9: Interfaces

<table>
<thead>
<tr>
<th>Primitive</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>I2C_B</td>
<td>The iCE40 UltraPlus device supports two I2C hard IP primitives.</td>
</tr>
<tr>
<td>BB_I3C</td>
<td>I/O with user controllable pull up resistors.</td>
</tr>
<tr>
<td>SPI_B</td>
<td>Hard SPI interface.</td>
</tr>
</tbody>
</table>

### Table 10: Oscillators

<table>
<thead>
<tr>
<th>Primitive</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>HSOSC</td>
<td>High-frequency oscillator. Generates 48MHz nominal clock, +/- 10 percent, with user programmable divider. Can drive global clock network or fabric routing.</td>
</tr>
<tr>
<td>HSOSC1P8V</td>
<td>High-frequency oscillator. Generates 48MHz nominal clock, +/- 10 percent, with user programmable divider. Can drive global clock network or fabric routing. For use when VPP_2V5 is connected to a voltage below 2.3V.</td>
</tr>
<tr>
<td>HSOSC_CORE</td>
<td>High-frequency oscillator. Generates 48MHz nominal clock, +/- 10 percent, with user programmable divider. Can drive global clock network or fabric routing.</td>
</tr>
<tr>
<td>LSOSC</td>
<td>Low-frequency oscillator. Generates 10KHz nominal clock, +/- 10 percent. Can drive global clock network or fabric routing.</td>
</tr>
</tbody>
</table>
Table 10: Oscillators (Continued)

<table>
<thead>
<tr>
<th>Primitive</th>
<th>Description</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>LSOSC1P8V</td>
<td>Low-frequency oscillator. Generates 10KHz nominal clock, +/- 10 percent. Can drive global clock network or fabric routing. For use when VPP_2V5 is connected to a voltage below 2.3V.</td>
<td></td>
</tr>
<tr>
<td>LSOSC_CORE</td>
<td>Low-frequency oscillator. Generates 10KHz nominal clock, +/- 10 percent. Can drive global clock network or fabric routing.</td>
<td></td>
</tr>
</tbody>
</table>

Table 11: Miscellaneous

<table>
<thead>
<tr>
<th>Primitive</th>
<th>Description</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>BB_OD</td>
<td>Input/Output buffer.</td>
<td></td>
</tr>
<tr>
<td>BUF</td>
<td>Non-inverting buffer.</td>
<td>USER INSTANTIATION: Yes; refer to Template Editor.</td>
</tr>
<tr>
<td>FILTER</td>
<td>Adds a 50ns delay to a signal.</td>
<td></td>
</tr>
<tr>
<td>INV</td>
<td>Inverter.</td>
<td></td>
</tr>
<tr>
<td>OFD1P3AZ</td>
<td>Positive edge triggered output D flip-flop with positive level enable.</td>
<td></td>
</tr>
<tr>
<td>PUR</td>
<td>Power up set/reset.</td>
<td></td>
</tr>
<tr>
<td>RGB</td>
<td>RGB LED drive module, containing three open drain I/O pins for RGB LED outputs.</td>
<td></td>
</tr>
<tr>
<td>RGB1P8V</td>
<td>RGB LED drive module, containing three open drain I/O pins for RGB LED outputs. Trim bits are driven from Fabric.</td>
<td></td>
</tr>
<tr>
<td>RGB_CORE</td>
<td>RGB LED drive module, containing three open drain I/O pins for RGB LED outputs.</td>
<td></td>
</tr>
<tr>
<td>RGBPWM</td>
<td>Generates the PWM signals for the RGB LED drivers.</td>
<td></td>
</tr>
<tr>
<td>VHI</td>
<td>Logic High Generator.</td>
<td></td>
</tr>
<tr>
<td>VLO</td>
<td>Logic Low Generator.</td>
<td></td>
</tr>
<tr>
<td>WARMBOOT</td>
<td>Allows for loading a different configuration during run time.</td>
<td></td>
</tr>
</tbody>
</table>

iCECube2 Primitives vs. Radiant Software Primitives

For complete information on updating iCECube2 Primitives for iCE40 UltraPlus devices to Radiant Software Primitives for iCE40 UltraPlus devices,
refer to the *Migrating iCEcube2 iCE40 UltraPlus Designs to Lattice Radiant 2.0 Software* document.
Primitive Library - LIFCL

This library includes compatible primitives supported by the LIFCL device family.

- "Adders/Subtractors" on page 644
- "Flip-Flops" on page 644
- "Input/Output Buffer" on page 645
- "Memories" on page 645
- "Multipliers" on page 646
- "Clock/PLL" on page 646
- "Combinatorial Primitives" on page 647
- "Interfaces" on page 647
- "Dual Data Rate Cells" on page 647
- "Oscillators" on page 648
- "Miscellaneous" on page 648

Table 1: Adders/Subtractors

<table>
<thead>
<tr>
<th>Primitive</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACC54</td>
<td>54-bit Accumulator for DSP</td>
</tr>
</tbody>
</table>

Table 2: Flip-Flops

<table>
<thead>
<tr>
<th>Primitive</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>BFD1P3KX</td>
<td>Positive Edge Triggered Bidirectional D-Flip Flop with Positive Level Enable and Synchronous Set/Reset for Input/Output/Tri-State Signals (to/from I/O)</td>
</tr>
<tr>
<td>BFD1P3LX</td>
<td>Positive Edge Triggered Bidirectional D-Flip Flop with Positive Level Enable and Asynchronous Set/Reset for Input/Output/Tri-State Signals (to/from I/O)</td>
</tr>
<tr>
<td>FD1P3BX</td>
<td>Positive Edge Triggered D Flip-Flop with Positive Level Enable and Positive Level Asynchronous Preset</td>
</tr>
<tr>
<td>FD1P3DX</td>
<td>Positive Edge Triggered D Flip-Flop with Positive Level Enable and Positive Level Asynchronous Clear</td>
</tr>
<tr>
<td>FD1P3IX</td>
<td>Positive Edge Triggered D Flip-Flop with Positive Level Synchronous Clear and Positive Level Enable (Clear overrides Enable)</td>
</tr>
<tr>
<td>FD1P3JX</td>
<td>Positive Edge Triggered D Flip-Flop with Positive Level Synchronous Preset and Positive Level Enable (Preset overrides Enable)</td>
</tr>
<tr>
<td>FL1P3AZ</td>
<td>Positive Edge Triggered D Flip-Flop with Two Input Data Mux, Data Select, and Positive Level Enable, GSR used for Clear or Preset</td>
</tr>
<tr>
<td>IFD1P3BX</td>
<td>Positive Edge Triggered Input D Flip-Flop with Positive Level Enable and Positive Level Asynchronous Preset</td>
</tr>
<tr>
<td>IFD1P3DX</td>
<td>Positive Edge Triggered Input D Flip-Flop with Positive Level Enable and Positive Level Asynchronous Clear</td>
</tr>
</tbody>
</table>
### Table 2: Flip-Flops

<table>
<thead>
<tr>
<th>Primitive</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>IFD1P3IX</td>
<td>Positive Edge Triggered Input D Flip-Flop with Positive Level Synchronous Clear and Positive Level Enable (Clear overrides Enable)</td>
</tr>
<tr>
<td>IFD1P3JX</td>
<td>Positive Edge Triggered Input D Flip-Flop with Positive Level Synchronous Preset and Positive Level Enable (Preset overrides Enable)</td>
</tr>
<tr>
<td>OFD1P3BX</td>
<td>Positive Edge Triggered Output D Flip-Flop with Positive Level Enable and Positive Level Asynchronous Clear</td>
</tr>
<tr>
<td>OFD1P3DX</td>
<td>Positive Edge Triggered Output D Flip-Flop with Positive Level Enable and Positive Level Asynchronous Clear</td>
</tr>
<tr>
<td>OFD1P3IX</td>
<td>Positive Edge Triggered Output D Flip-Flop with Positive Level Synchronous Clear and Positive Level Enable (Clear overrides Enable)</td>
</tr>
<tr>
<td>OFD1P3JX</td>
<td>Positive Edge Triggered Output D Flip-Flop with Positive Level Synchronous Preset and Positive Level Enable (Preset overrides Enable)</td>
</tr>
</tbody>
</table>

### Table 3: Input/Output Buffer

<table>
<thead>
<tr>
<th>Primitive</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>BB</td>
<td>Bidirectional Buffer with Tri-State</td>
</tr>
<tr>
<td>BB_ADC</td>
<td>Bidirectional Buffer for Analog-to-Digital Converter</td>
</tr>
<tr>
<td>BB_CDR</td>
<td>Bidirectional Buffer for CDR</td>
</tr>
<tr>
<td>BB_I3C_A</td>
<td>Input/Output Buffer with User Controllable Pull-Up Resistors</td>
</tr>
<tr>
<td>IB</td>
<td>Input Buffer</td>
</tr>
<tr>
<td>OB</td>
<td>Output Buffer</td>
</tr>
<tr>
<td>OBZ</td>
<td>Output Buffer with Tri-State</td>
</tr>
</tbody>
</table>

### Table 4: Memories

<table>
<thead>
<tr>
<th>Primitive</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DP16K</td>
<td>16 kb Dual Port Block RAM</td>
</tr>
<tr>
<td>DPR16X4</td>
<td>Distributed Pseudo Dual Port RAM with Synchronous Write and Asynchronous Read</td>
</tr>
<tr>
<td>DPSC512K</td>
<td>512 kb Single Clock Dual Port Block RAM</td>
</tr>
<tr>
<td>FIFO16K</td>
<td>16 kb FIFO</td>
</tr>
<tr>
<td>PDP16K</td>
<td>16 kb Pseudo Dual Port Block RAM</td>
</tr>
<tr>
<td>PDPSC16K</td>
<td>16 kb Pseudo Dual Port Single Clock Block RAM</td>
</tr>
<tr>
<td>PDPSC512K</td>
<td>512 kb Single Clock Pseudo Dual Port Block RAM</td>
</tr>
</tbody>
</table>
### Table 4: Memories

<table>
<thead>
<tr>
<th>Primitive</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SP16K</td>
<td>16 kb Single Port Block RAM</td>
</tr>
<tr>
<td>SP512K</td>
<td>512 kb Single Port Block RAM</td>
</tr>
<tr>
<td>SPR16X4</td>
<td>Distributed Single Port RAM with Synchronous Write and Asynchronous Read</td>
</tr>
</tbody>
</table>

### Table 5: Multipliers

<table>
<thead>
<tr>
<th>Primitive</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ALUREG</td>
<td>Arithmetic Logic Unit and Register File for RISCV Soft Processor</td>
</tr>
<tr>
<td>MULT18X18</td>
<td>18x18 Multiplier with Optional Input/Output Registers</td>
</tr>
<tr>
<td>MULT18X36</td>
<td>18x36 Multiplier with Optional Input/Output Registers</td>
</tr>
<tr>
<td>MULT36X36</td>
<td>36x36 Multiplier with Optional Input/Output Registers</td>
</tr>
<tr>
<td>MULT9X9</td>
<td>9x9 Multiplier with Optional Input/Output Registers</td>
</tr>
<tr>
<td>MULTADD18X18</td>
<td>18x18 Multiplier and Accumulator</td>
</tr>
<tr>
<td>MULTADD18X18WIDE</td>
<td>18x18 Wide Multiplier and Adder/Subtractor</td>
</tr>
<tr>
<td>MULTADD18X36</td>
<td>18x36 Multiplier and Adder/Subtractor</td>
</tr>
<tr>
<td>MULTADD36X36</td>
<td>36x36 Multiplier and Adder/Subtractor</td>
</tr>
<tr>
<td>MULTADD9X9WIDE</td>
<td>9x9 Wide Multiplier and Adder/Subtractor</td>
</tr>
<tr>
<td>MULTPREADD18X18</td>
<td>18x18 Multiplier with Pre-Adder</td>
</tr>
<tr>
<td>MULTPREADD9X9</td>
<td>9x9 Multiplier with Pre-Adder</td>
</tr>
</tbody>
</table>

### Table 6: Clock/PLL

<table>
<thead>
<tr>
<th>Primitive</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DCC</td>
<td>Dynamic Clock Control with Positive Enable</td>
</tr>
<tr>
<td>DCS</td>
<td>Dynamic Clock Selection</td>
</tr>
<tr>
<td>ECLKDIV</td>
<td>Clock Divider for Edge Clock Wrapper</td>
</tr>
<tr>
<td>ECLKSYNC</td>
<td>Clock Synchronizer for Edge Clock Wrapper</td>
</tr>
<tr>
<td>PCLKDIV</td>
<td>Clock Divider for Primary Clock</td>
</tr>
<tr>
<td>PLL</td>
<td>Phase - Locked Loop</td>
</tr>
</tbody>
</table>
### Table 7: Combinatorial Primitives

<table>
<thead>
<tr>
<th>Primitive</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CCU2</td>
<td>Carry Chain</td>
</tr>
<tr>
<td>LUT4</td>
<td>4-Input Look Up Table</td>
</tr>
<tr>
<td>WIDEFN9</td>
<td>9-Input Single Output Logic Block</td>
</tr>
</tbody>
</table>

### Table 8: Interfaces

<table>
<thead>
<tr>
<th>Primitive</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DPHY</td>
<td>Hardened MIPI DPHY Interface Block</td>
</tr>
<tr>
<td>I2CFIFO</td>
<td>Hardened I2C Interface Block</td>
</tr>
<tr>
<td>MIPI</td>
<td>Soft MIPI Interface Block</td>
</tr>
<tr>
<td>MULTIBOOT</td>
<td>Interface for Multiboot Functionality</td>
</tr>
<tr>
<td>PCIE</td>
<td>Hardened PCIE Interface</td>
</tr>
<tr>
<td>SEDC</td>
<td>Interface for Soft Error Detection and Correction Functionality</td>
</tr>
<tr>
<td>SGMIIICDR</td>
<td>Serial Gigabit Media Independent Interface</td>
</tr>
</tbody>
</table>

### Table 9: Dual Data Rate Cells

<table>
<thead>
<tr>
<th>Primitive</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DDRDLL</td>
<td>Delay-Locked Loop Master Block for DDR Functionality</td>
</tr>
<tr>
<td>DELAYA</td>
<td>Dynamic Input/Output Delay Element</td>
</tr>
<tr>
<td>DELAYB</td>
<td>Static Input/Output Delay Element</td>
</tr>
<tr>
<td>DLLDEL</td>
<td>Delay-Locked Loop Slave Block for DDR Functionality</td>
</tr>
<tr>
<td>DQSBUF</td>
<td>Block generating DQS Signal for Memory DDR Functionality</td>
</tr>
<tr>
<td>IDDR71</td>
<td>7:1 LVDS IDDR</td>
</tr>
<tr>
<td>IDDRX1</td>
<td>Generic X1 IDDR</td>
</tr>
<tr>
<td>IDDRX2</td>
<td>Generic X1 IDDR</td>
</tr>
<tr>
<td>IDDRX2DQ</td>
<td>DQ Input for DDR2 &amp; DDR3 memory</td>
</tr>
<tr>
<td>IDDRX4</td>
<td>Generic X4 IDDR</td>
</tr>
<tr>
<td>IDDRX4DQ</td>
<td>DQ Input for DDR3 memory</td>
</tr>
<tr>
<td>IDDRX5</td>
<td>Generic X5 IDDR</td>
</tr>
</tbody>
</table>
### Table 9: Dual Data Rate Cells

<table>
<thead>
<tr>
<th>Primitive</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ODDR71</td>
<td>7:1 LVDS ODDR</td>
</tr>
<tr>
<td>ODDRX1</td>
<td>Generic X1 ODDR</td>
</tr>
<tr>
<td>ODDRX2</td>
<td>Generic X2 ODDR</td>
</tr>
<tr>
<td>ODDRX2DQ</td>
<td>DQ output for DDR2 &amp; DDR3 memory</td>
</tr>
<tr>
<td>ODDRX2DQS</td>
<td>DQS Output for DDR2 &amp; DDR3 memory</td>
</tr>
<tr>
<td>ODDRX4</td>
<td>Generic X4 ODDR</td>
</tr>
<tr>
<td>ODDRX4DQ</td>
<td>DQ Input for DDR3 memory</td>
</tr>
<tr>
<td>ODDRX4DQS</td>
<td>DQS Output for DDR3 memory</td>
</tr>
<tr>
<td>ODDRX5</td>
<td>Generic X5 ODDR</td>
</tr>
<tr>
<td>OSHX2</td>
<td>This primitive is used to generate the address and command for DDR3 memory with x2 gearing and write leveling</td>
</tr>
<tr>
<td>OSHX4</td>
<td>This primitive is used to generate the address and command for DDR3 memory with x4 gearing and write leveling</td>
</tr>
<tr>
<td>TSHX2DQ</td>
<td>DQS tristate control for DDR2 &amp; DDR3 memory</td>
</tr>
<tr>
<td>TSHX2DQS</td>
<td>DQS tristate control for DDR2 &amp; DDR3 memory</td>
</tr>
<tr>
<td>TSHX4DQ</td>
<td>DQS tristate control for DDR3 memory</td>
</tr>
<tr>
<td>TSHX4DQS</td>
<td>DQS tristate control for DDR3 memory</td>
</tr>
</tbody>
</table>

### Table 10: Oscillators

<table>
<thead>
<tr>
<th>Primitive</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>OSC</td>
<td>Oscillator Block</td>
</tr>
<tr>
<td>OSCA</td>
<td>Oscillator Block</td>
</tr>
</tbody>
</table>

### Table 11: Miscellaneous

<table>
<thead>
<tr>
<th>Primitive</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ADC</td>
<td>Analog-to-Digital Converter</td>
</tr>
<tr>
<td>BNKREF18</td>
<td>Bank Reference Block for 1.8V I/O</td>
</tr>
<tr>
<td>BUF</td>
<td>Non-Inverting Buffer</td>
</tr>
<tr>
<td>CRE</td>
<td>Cryptographic Engine</td>
</tr>
<tr>
<td>GSR</td>
<td>Global Set/Reset</td>
</tr>
<tr>
<td>INV</td>
<td>Inverter</td>
</tr>
</tbody>
</table>

Lattice Radiant Software 2.2 Help 648
Table 11: Miscellaneous

<table>
<thead>
<tr>
<th>Primitive</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>JTAG</td>
<td>JTAG Block for Reveal Debugging Tool</td>
</tr>
<tr>
<td>PUR</td>
<td>Power up Set/Reset</td>
</tr>
<tr>
<td>TSALLA</td>
<td>Global Tristate Interface</td>
</tr>
<tr>
<td>VHI</td>
<td>Logic High Generator</td>
</tr>
<tr>
<td>VLO</td>
<td>Logic Low Generator</td>
</tr>
<tr>
<td>WDT</td>
<td>Interface for Configuration Watchdog Timer</td>
</tr>
</tbody>
</table>
**Primitive Library - LFD2NX**

This library includes compatible primitives supported by the LFD2NX device family.

- “Adders/Subtractors” on page 650
- “Flip-Flops” on page 650
- “Input/Output Buffer” on page 651
- “Memories” on page 651
- “Multipliers” on page 652
- “Clock/PLL” on page 652
- “Combinatorial Primitives” on page 653
- “Interfaces” on page 653
- “Dual Data Rate Cells” on page 653
- “Oscillators” on page 654
- “Miscellaneous” on page 654

**Table 1: Adders/Subtractors**

<table>
<thead>
<tr>
<th>Primitive</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACC54</td>
<td>54-bit Accumulator for DSP</td>
</tr>
</tbody>
</table>

**Table 2: Flip-Flops**

<table>
<thead>
<tr>
<th>Primitive</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>BFD1P3KX</td>
<td>Positive Edge Triggered Bidirectional D-Flip Flop with Positive Level Enable and Synchronous Set/Reset for Input/Output/Tri-State Signals (to/from I/O)</td>
</tr>
<tr>
<td>BFD1P3LX</td>
<td>Positive Edge Triggered Bidirectional D-Flip Flop with Positive Level Enable and Asynchronous Set/Reset for Input/Output/Tri-State Signals (to/from I/O)</td>
</tr>
<tr>
<td>FD1P3BX</td>
<td>Positive Edge Triggered D Flip-Flop with Positive Level Enable and Positive Level Asynchronous Preset</td>
</tr>
<tr>
<td>FD1P3DX</td>
<td>Positive Edge Triggered D Flip-Flop with Positive Level Enable and Positive Level Asynchronous Clear</td>
</tr>
<tr>
<td>FD1P3IX</td>
<td>Positive Edge Triggered D Flip-Flop with Positive Level Synchronous Clear and Positive Level Enable (Clear overrides Enable)</td>
</tr>
<tr>
<td>FD1P3JX</td>
<td>Positive Edge Triggered D Flip-Flop with Positive Level Synchronous Preset and Positive Level Enable (Preset overrides Enable)</td>
</tr>
<tr>
<td>FL1P3AZ</td>
<td>Positive Edge Triggered D Flip-Flop with Two Input Data Mux, Data Select, and Positive Level Enable, GSR used for Clear or Preset</td>
</tr>
<tr>
<td>IFD1P3BX</td>
<td>Positive Edge Triggered Input D Flip-Flop with Positive Level Enable and Positive Level Asynchronous Preset</td>
</tr>
<tr>
<td>IFD1P3DX</td>
<td>Positive Edge Triggered Input D Flip-Flop with Positive Level Enable and Positive Level Asynchronous Clear</td>
</tr>
</tbody>
</table>
### Table 2: Flip-Flops

<table>
<thead>
<tr>
<th>Primitive</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>IFD1P3IX</td>
<td>Positive Edge Triggered Input D Flip-Flop with Positive Level Synchronous Clear and Positive Level Enable (Clear overrides Enable)</td>
</tr>
<tr>
<td>IFD1P3JX</td>
<td>Positive Edge Triggered Input D Flip-Flop with Positive Level Synchronous Preset and Positive Level Enable (Preset overrides Enable)</td>
</tr>
<tr>
<td>OFD1P3BX</td>
<td>Positive Edge Triggered Output D Flip-Flop with Positive Level Enable and Positive Level Asynchronous Clear</td>
</tr>
<tr>
<td>OFD1P3DX</td>
<td>Positive Edge Triggered Output D Flip-Flop with Positive Level Enable and Positive Level Asynchronous Clear</td>
</tr>
<tr>
<td>OFD1P3IX</td>
<td>Positive Edge Triggered Output D Flip-Flop with Positive Level Synchronous Clear and Positive Level Enable (Clear overrides Enable)</td>
</tr>
<tr>
<td>OFD1P3JX</td>
<td>Positive Edge Triggered Output D Flip-Flop with Positive Level Synchronous Preset and Positive Level Enable (Preset overrides Enable)</td>
</tr>
</tbody>
</table>

### Table 3: Input/Output Buffer

<table>
<thead>
<tr>
<th>Primitive</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>BB</td>
<td>Bidirectional Buffer with Tri-State</td>
</tr>
<tr>
<td>BB_ADC</td>
<td>Bidirectional Buffer for Analog-to-Digital Converter</td>
</tr>
<tr>
<td>BB_CDR</td>
<td>Bidirectional Buffer for CDR</td>
</tr>
<tr>
<td>BB_I3C_A</td>
<td>Input/Output Buffer with User Controllable Pull-Up Resistors</td>
</tr>
<tr>
<td>IB</td>
<td>Input Buffer</td>
</tr>
<tr>
<td>OB</td>
<td>Output Buffer</td>
</tr>
<tr>
<td>OBZ</td>
<td>Output Buffer with Tri-State</td>
</tr>
</tbody>
</table>

### Table 4: Memories

<table>
<thead>
<tr>
<th>Primitive</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DP16K</td>
<td>16 kb Dual Port Block RAM</td>
</tr>
<tr>
<td>DPR16X4</td>
<td>Distributed Pseudo Dual Port RAM with Synchronous Write and Asynchronous Read</td>
</tr>
<tr>
<td>DPSC512K</td>
<td>512 kb Single Clock Dual Port Block RAM</td>
</tr>
<tr>
<td>FIFO16K</td>
<td>16 kb FIFO</td>
</tr>
<tr>
<td>PDP16K</td>
<td>16 kb Pseudo Dual Port Block RAM</td>
</tr>
<tr>
<td>PDPSC16K</td>
<td>16 kb Pseudo Dual Port Single Clock Block RAM</td>
</tr>
<tr>
<td>PDPSC512K</td>
<td>512 kb Single Clock Pseudo Dual Port Block RAM</td>
</tr>
</tbody>
</table>
### Table 4: Memories

<table>
<thead>
<tr>
<th>Primitive</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SP16K</td>
<td>16 kb Single Port Block RAM</td>
</tr>
<tr>
<td>SP512K</td>
<td>512 kb Single Port Block RAM</td>
</tr>
<tr>
<td>SPR16X4</td>
<td>Distributed Single Port RAM with Synchronous Write and Asynchronous Read</td>
</tr>
</tbody>
</table>

### Table 5: Multipliers

<table>
<thead>
<tr>
<th>Primitive</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ALUREG</td>
<td>Arithmetic Logic Unit and Register File for RISCV Soft Processor</td>
</tr>
<tr>
<td>MULT18X18</td>
<td>18x18 Multiplier with Optional Input/Output Registers</td>
</tr>
<tr>
<td>MULT18X36</td>
<td>18x36 Multiplier with Optional Input/Output Registers</td>
</tr>
<tr>
<td>MULT36X36</td>
<td>36x36 Multiplier with Optional Input/Output Registers</td>
</tr>
<tr>
<td>MULT9X9</td>
<td>9x9 Multiplier with Optional Input/Output Registers</td>
</tr>
<tr>
<td>MULTADDSUB18X18</td>
<td>18x18 Multiplier and Accumulator</td>
</tr>
<tr>
<td>MULTADDSUB18X18WIDE</td>
<td>18x18 Wide Multiplier and Adder/Subtractor</td>
</tr>
<tr>
<td>MULTADDSUB18X36</td>
<td>18x36 Multiplier and Adder/Subtractor</td>
</tr>
<tr>
<td>MULTADDSUB36X36</td>
<td>36x36 Multiplier and Adder/Subtractor</td>
</tr>
<tr>
<td>MULTADDSUB9X9WIDE</td>
<td>9x9 Wide Multiplier and Adder/Subtractor</td>
</tr>
<tr>
<td>MULTPREADD18X18</td>
<td>18x18 Multiplier with Pre-Adder</td>
</tr>
<tr>
<td>MULTPREADD9X9</td>
<td>9x9 Multiplier with Pre-Adder</td>
</tr>
</tbody>
</table>

### Table 6: Clock/PLL

<table>
<thead>
<tr>
<th>Primitive</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DCC</td>
<td>Dynamic Clock Control with Positive Enable</td>
</tr>
<tr>
<td>DCS</td>
<td>Dynamic Clock Selection</td>
</tr>
<tr>
<td>ECLKDIV</td>
<td>Clock Divider for Edge Clock Wrapper</td>
</tr>
<tr>
<td>ECLKSYNC</td>
<td>Clock Synchronizer for Edge Clock Wrapper</td>
</tr>
<tr>
<td>PCLKDIV</td>
<td>Clock Divider for Primary Clock</td>
</tr>
<tr>
<td>PLL</td>
<td>Phase-Locked Loop</td>
</tr>
</tbody>
</table>
### Table 7: Combinatorial Primitives

<table>
<thead>
<tr>
<th>Primitive</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CCU2</td>
<td>Carry Chain</td>
</tr>
<tr>
<td>LUT4</td>
<td>4-Input Look Up Table</td>
</tr>
<tr>
<td>WIDEFN9</td>
<td>9-Input Single Output Logic Block</td>
</tr>
</tbody>
</table>

### Table 8: Interfaces

<table>
<thead>
<tr>
<th>Primitive</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>I2CFIFO</td>
<td>Hardened I2C Interface Block</td>
</tr>
<tr>
<td>MIPI</td>
<td>Soft MIPI Interface Block</td>
</tr>
<tr>
<td>MULTIBOOT</td>
<td>Interface for Multiboot Functionality</td>
</tr>
<tr>
<td>PCIE</td>
<td>Hardened PCIE Interface</td>
</tr>
<tr>
<td>SEDC</td>
<td>Interface for Soft Error Detection and Correction Functionality</td>
</tr>
<tr>
<td>SGMIIICDR</td>
<td>Serial Gigabit Media Independent Interface</td>
</tr>
</tbody>
</table>

### Table 9: Dual Data Rate Cells

<table>
<thead>
<tr>
<th>Primitive</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DDRDLL</td>
<td>Delay-Locked Loop Master Block for DDR Functionality</td>
</tr>
<tr>
<td>DELAYA</td>
<td>Dynamic Input/Output Delay Element</td>
</tr>
<tr>
<td>DELAYB</td>
<td>Static Input/Output Delay Element</td>
</tr>
<tr>
<td>DLLDEL</td>
<td>Delay-Locked Loop Slave Block for DDR Functionality</td>
</tr>
<tr>
<td>DQSBUF</td>
<td>Block generating DQS Signal for Memory DDR Functionality</td>
</tr>
<tr>
<td>IDDR71</td>
<td>7:1 LVDS IDDR</td>
</tr>
<tr>
<td>IDDRX1</td>
<td>Generic X1 IDDR</td>
</tr>
<tr>
<td>IDDRX2</td>
<td>Generic X1 IDDR</td>
</tr>
<tr>
<td>IDDRX2DQ</td>
<td>DQ Input for DDR2 &amp; DDR3 memory</td>
</tr>
<tr>
<td>IDDRX4</td>
<td>Generic X4 IDDR</td>
</tr>
<tr>
<td>IDDRX4DQ</td>
<td>DQ Input for DDR3 memory</td>
</tr>
<tr>
<td>IDDRX5</td>
<td>Generic X5 IDDR</td>
</tr>
<tr>
<td>ODDR71</td>
<td>7:1 LVDS ODDR</td>
</tr>
</tbody>
</table>
### Table 9: Dual Data Rate Cells

<table>
<thead>
<tr>
<th>Primitive</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ODDRX1</td>
<td>Generic X1 ODDR</td>
</tr>
<tr>
<td>ODDRX2</td>
<td>Generic X2 ODDR</td>
</tr>
<tr>
<td>ODDRX2DQ</td>
<td>DQ output for DDR2 &amp; DDR3 memory</td>
</tr>
<tr>
<td>ODDRX2DQS</td>
<td>DQS Output for DDR2 &amp; DDR3 memory</td>
</tr>
<tr>
<td>ODDRX4</td>
<td>Generic X4 ODDR</td>
</tr>
<tr>
<td>ODDRX4DQ</td>
<td>DQ Input for DDR3 memory</td>
</tr>
<tr>
<td>ODDRX4DQS</td>
<td>DQS Output for DDR3 memory</td>
</tr>
<tr>
<td>ODDRX5</td>
<td>Generic X5 ODDR</td>
</tr>
<tr>
<td>OSHX2</td>
<td>This primitive is used to generate the address and command for DDR3 memory with x2 gearing and write leveling</td>
</tr>
<tr>
<td>OSHX4</td>
<td>This primitive is used to generate the address and command for DDR3 memory with x4 gearing and write leveling</td>
</tr>
<tr>
<td>TSHX2DQ</td>
<td>DQS tristate control for DDR2 &amp; DDR3 memory</td>
</tr>
<tr>
<td>TSHX2DQS</td>
<td>DQS tristate control for DDR2 &amp; DDR3 memory</td>
</tr>
<tr>
<td>TSHX4DQ</td>
<td>DQS tristate control for DDR3 memory</td>
</tr>
<tr>
<td>TSHX4DQS</td>
<td>DQS tristate control for DDR3 memory</td>
</tr>
</tbody>
</table>

### Table 10: Oscillators

<table>
<thead>
<tr>
<th>Primitive</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>OSC</td>
<td>Oscillator Block</td>
</tr>
<tr>
<td>OSCA</td>
<td>Oscillator Block</td>
</tr>
</tbody>
</table>

### Table 11: Miscellaneous

<table>
<thead>
<tr>
<th>Primitive</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ADC</td>
<td>Analog-to-Digital Converter</td>
</tr>
<tr>
<td>BNKREF18</td>
<td>Bank Reference Block for 1.8V I/O</td>
</tr>
<tr>
<td>BUF</td>
<td>Non-Inverting Buffer</td>
</tr>
<tr>
<td>CRE</td>
<td>Cryptographic Engine</td>
</tr>
<tr>
<td>GSR</td>
<td>Global Set/Reset</td>
</tr>
<tr>
<td>INV</td>
<td>Inverter</td>
</tr>
<tr>
<td>JTAG</td>
<td>JTAG Block for Reveal Debugging Tool</td>
</tr>
<tr>
<td>Primitive</td>
<td>Description</td>
</tr>
<tr>
<td>-----------</td>
<td>--------------------------------------------------</td>
</tr>
<tr>
<td>PUR</td>
<td>Power up Set/Reset</td>
</tr>
<tr>
<td>TSALLA</td>
<td>Global Tristate Interface</td>
</tr>
<tr>
<td>VHI</td>
<td>Logic High Generator</td>
</tr>
<tr>
<td>VLO</td>
<td>Logic Low Generator</td>
</tr>
<tr>
<td>WDT</td>
<td>Interface for Configuration Watchdog Timer</td>
</tr>
</tbody>
</table>
Alphanumeric Primitives List

This section lists all the Radiant library primitives in alphanumeric order.

ACC54
54-bit Accumulator component for DSP

Architectures supported:
- LFD2NX
- LIFCL

Table 1: Input Ports

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SFTCTRL[3:0]</td>
<td></td>
</tr>
<tr>
<td>DSPIN[53:0]</td>
<td></td>
</tr>
<tr>
<td>PP[71:0]</td>
<td></td>
</tr>
<tr>
<td>CINPUT[53:0]</td>
<td></td>
</tr>
<tr>
<td>LOAD</td>
<td></td>
</tr>
<tr>
<td>M9ADDSUB[1:0]</td>
<td></td>
</tr>
<tr>
<td>ADDSUB[1:0]</td>
<td></td>
</tr>
<tr>
<td>CIN</td>
<td></td>
</tr>
<tr>
<td>CASIN[1:0]</td>
<td></td>
</tr>
<tr>
<td>CEO</td>
<td></td>
</tr>
<tr>
<td>RSTO</td>
<td></td>
</tr>
<tr>
<td>CEC</td>
<td></td>
</tr>
<tr>
<td>RSTC</td>
<td></td>
</tr>
<tr>
<td>CLK</td>
<td></td>
</tr>
<tr>
<td>SIGNEDI</td>
<td></td>
</tr>
<tr>
<td>ROUNDEN</td>
<td></td>
</tr>
<tr>
<td>CECIN</td>
<td></td>
</tr>
<tr>
<td>CECTRL</td>
<td></td>
</tr>
<tr>
<td>RSTCIN</td>
<td></td>
</tr>
<tr>
<td>RSTCTRL</td>
<td></td>
</tr>
</tbody>
</table>
### Table 2: Output Ports

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SUM0[35:0]</td>
<td></td>
</tr>
<tr>
<td>DSPOUT[53:0]</td>
<td></td>
</tr>
<tr>
<td>CASCOUT[1:0]</td>
<td></td>
</tr>
</tbody>
</table>

### Table 3: Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SIGN</td>
<td>&quot;DISABLED&quot; <em>(default)</em> &quot;ENABLED&quot;</td>
<td>Static sign operation enable for ACCU54: Enable</td>
</tr>
<tr>
<td>M9ADDSUB_CTRL</td>
<td>&quot;ADDITION&quot; <em>(default)</em> &quot;ADDSUB&quot; &quot;SUBADD&quot; &quot;SUBTRACTION&quot;</td>
<td>Static add/sub control for stage 1 adder</td>
</tr>
<tr>
<td>ADDSUB_CTRL</td>
<td>&quot;ADD_ADD_CTRL_54_BIT_ADDER&quot; <em>(default)</em> &quot;SUB_ADD_CTRL_54_BIT_ADDER&quot; &quot;ADD_SUB_CTRL_54_BIT_ADDER&quot; &quot;SUB_SUB_CTRL_54_BIT_ADDER&quot;</td>
<td>Static add/sub control for 54-bit adder</td>
</tr>
<tr>
<td>STATICOPCODE_EN</td>
<td>&quot;DISABLED&quot; <em>(default)</em> &quot;ENABLED&quot;</td>
<td>1: Static opcode enable</td>
</tr>
<tr>
<td>OUTREGBYPS</td>
<td>&quot;BYPASS&quot; <em>(default)</em> &quot;REGISTER&quot;</td>
<td>1: Output register bypass</td>
</tr>
<tr>
<td>GSR</td>
<td>&quot;DISABLED&quot; <em>(default)</em> &quot;ENABLED&quot;</td>
<td>1: GSRN enable</td>
</tr>
<tr>
<td>PROGCONST</td>
<td>&quot;0'b0000000000000000000000000000000000000000000000000000000000000000&quot; *(default)</td>
<td>Constant value for C</td>
</tr>
<tr>
<td>CONSTSEL</td>
<td>&quot;BYPASS&quot; <em>(default)</em> &quot;SELECT&quot;</td>
<td>1: Select constant value for C</td>
</tr>
<tr>
<td>DSPCASCADE</td>
<td>&quot;DISABLED&quot; <em>(default)</em> &quot;ENABLED&quot;</td>
<td>1: DSP cascaded enable</td>
</tr>
<tr>
<td>ACC108CASCADE</td>
<td>&quot;BYPASSCASCADE&quot; *(default)&quot;CASCADE2ACCU54TOFORMACCU108&quot;</td>
<td>1: cascade two ACCU54 to form ACCU108</td>
</tr>
<tr>
<td>ACCUMODE</td>
<td>&quot;MODE0&quot; *(default)&quot; &quot;MODE1&quot; &quot;MODE2&quot; &quot;MODE3&quot; &quot;MODE4&quot; &quot;MODE5&quot; &quot;MODE6&quot; &quot;MODE7&quot;</td>
<td>Accumulator mode</td>
</tr>
<tr>
<td>ACCUBYPS</td>
<td>&quot;USED&quot; *(default)&quot; &quot;BYPASS&quot;</td>
<td>1: Bypass ACC54</td>
</tr>
<tr>
<td>CREGBYPS1</td>
<td>&quot;REGISTER&quot; *(default)&quot; &quot;BYPASS&quot;</td>
<td>1: Bypass C register 1</td>
</tr>
</tbody>
</table>
### Table 3: Parameters (Continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CREGBYS2</td>
<td>&quot;REGISTER&quot; <em>(default)</em></td>
<td>1: Bypass C register 2</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS&quot;</td>
<td></td>
</tr>
<tr>
<td>CREGBYS3</td>
<td>&quot;REGISTER&quot; <em>(default)</em></td>
<td>1: Bypass C register 3</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS&quot;</td>
<td></td>
</tr>
<tr>
<td>CINREGBYS1</td>
<td>&quot;REGISTER&quot; <em>(default)</em></td>
<td>1: Bypass Cin register 1</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS&quot;</td>
<td></td>
</tr>
<tr>
<td>CINREGBYS2</td>
<td>&quot;REGISTER&quot; <em>(default)</em></td>
<td>1: Bypass Cin register 2</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS&quot;</td>
<td></td>
</tr>
<tr>
<td>CINREGBYS3</td>
<td>&quot;REGISTER&quot; <em>(default)</em></td>
<td>1: Bypass Cin register 3</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS&quot;</td>
<td></td>
</tr>
<tr>
<td>LOADREGBYS1</td>
<td>&quot;REGISTER&quot; <em>(default)</em></td>
<td>1: Bypass load register 1</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS&quot;</td>
<td></td>
</tr>
<tr>
<td>LOADREGBYS2</td>
<td>&quot;REGISTER&quot; <em>(default)</em></td>
<td>1: Bypass load register 2</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS&quot;</td>
<td></td>
</tr>
<tr>
<td>LOADREGBYS3</td>
<td>&quot;REGISTER&quot; <em>(default)</em></td>
<td>1: Bypass load register 3</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS&quot;</td>
<td></td>
</tr>
<tr>
<td>M9ADDSUBREGBYS1</td>
<td>&quot;REGISTER&quot; <em>(default)</em></td>
<td>1: Bypass M9AddSub register 1</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS&quot;</td>
<td></td>
</tr>
<tr>
<td>M9ADDSUBREGBYS2</td>
<td>&quot;REGISTER&quot; <em>(default)</em></td>
<td>1: Bypass M9AddSub register 2</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS&quot;</td>
<td></td>
</tr>
<tr>
<td>M9ADDSUBREGBYS3</td>
<td>&quot;REGISTER&quot; <em>(default)</em></td>
<td>1: Bypass M9AddSub register 3</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS&quot;</td>
<td></td>
</tr>
<tr>
<td>ADDSUBSIGNREGBYS1</td>
<td>&quot;REGISTER&quot; <em>(default)</em></td>
<td>1: Bypass AddSubSign register 1</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS&quot;</td>
<td></td>
</tr>
<tr>
<td>ADDSUBSIGNREGBYS2</td>
<td>&quot;REGISTER&quot; <em>(default)</em></td>
<td>1: Bypass AddSubSign register 2</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS&quot;</td>
<td></td>
</tr>
<tr>
<td>ADDSUBSIGNREGBYS3</td>
<td>&quot;REGISTER&quot; <em>(default)</em></td>
<td>1: Bypass AddSubSign register 3</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS&quot;</td>
<td></td>
</tr>
<tr>
<td>ROUNDHALFUP</td>
<td>&quot;DISABLED&quot; <em>(default)</em></td>
<td>1: ACCU54 round half up mode enable</td>
</tr>
<tr>
<td></td>
<td>&quot;ENABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>ROUNDRTZI</td>
<td>&quot;ROUND_TO_ZERO&quot; <em>(default)</em></td>
<td>0: ACCU54 round to zero</td>
</tr>
<tr>
<td></td>
<td>&quot;ROUND_TO_INFINITE&quot;</td>
<td>1: ACCU54 round to infinite</td>
</tr>
</tbody>
</table>
Table 3: Parameters (Continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ROUNDBIT</td>
<td>&quot;ROUND_TO_BIT0&quot; (default)</td>
<td>0000: round to bit0</td>
</tr>
<tr>
<td></td>
<td>&quot;ROUND_TO_BIT1&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;ROUND_TO_BIT2&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;ROUND_TO_BIT3&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;ROUND_TO_BIT4&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;ROUND_TO_BIT5&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;ROUND_TO_BIT6&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;ROUND_TO_BIT7&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;ROUND_TO_BIT8&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;ROUND_TO_BIT9&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;ROUND_TO_BIT10&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;ROUND_TO_BIT11&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;ROUND_TO_BIT12&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;ROUND_TO_BIT13&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;ROUND_TO_BIT14&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;ROUND_TO_BIT15&quot;</td>
<td></td>
</tr>
<tr>
<td>CASCOUTREGBYS</td>
<td>&quot;REGISTER&quot; (default)</td>
<td>1: DSP cascaded enable</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS&quot;</td>
<td></td>
</tr>
<tr>
<td>SFTEN</td>
<td>&quot;DISABLED&quot; (default)</td>
<td>Shift enable</td>
</tr>
<tr>
<td></td>
<td>&quot;ENABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>RESET</td>
<td>&quot;SYNC&quot; (default)</td>
<td></td>
</tr>
</tbody>
</table>

**ADC**

Wrapper for Analog-to-Digital Converter

Architectures supported:

- LFD2NX
- LIFCL

Table 4: Input Ports

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DN0</td>
<td></td>
</tr>
<tr>
<td>DN1</td>
<td></td>
</tr>
<tr>
<td>DP0</td>
<td></td>
</tr>
<tr>
<td>DP1</td>
<td></td>
</tr>
<tr>
<td>ADCEN</td>
<td></td>
</tr>
<tr>
<td>CAL</td>
<td></td>
</tr>
<tr>
<td>CHAEN</td>
<td></td>
</tr>
<tr>
<td>CHASEL[3:0]</td>
<td></td>
</tr>
</tbody>
</table>
### Table 4: Input Ports (Continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CHBEN</td>
<td></td>
</tr>
<tr>
<td>CHBSEL[3:0]</td>
<td></td>
</tr>
<tr>
<td>CLKDCLK</td>
<td></td>
</tr>
<tr>
<td>CLKFAB</td>
<td></td>
</tr>
<tr>
<td>COMP1IN</td>
<td></td>
</tr>
<tr>
<td>COMP1IP</td>
<td></td>
</tr>
<tr>
<td>COMP2IN</td>
<td></td>
</tr>
<tr>
<td>COMP2IP</td>
<td></td>
</tr>
<tr>
<td>COMP3IN</td>
<td></td>
</tr>
<tr>
<td>COMP3IP</td>
<td></td>
</tr>
<tr>
<td>CONVSTOP</td>
<td></td>
</tr>
<tr>
<td>GPION[15:0]</td>
<td></td>
</tr>
<tr>
<td>GPIOP[15:0]</td>
<td></td>
</tr>
<tr>
<td>RESETN</td>
<td></td>
</tr>
<tr>
<td>RSTN</td>
<td></td>
</tr>
<tr>
<td>SOC</td>
<td></td>
</tr>
</tbody>
</table>

### Table 5: Output Ports

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CALRDY</td>
<td></td>
</tr>
<tr>
<td>COG</td>
<td></td>
</tr>
<tr>
<td>COMP1OL</td>
<td></td>
</tr>
<tr>
<td>COMP2OL</td>
<td></td>
</tr>
<tr>
<td>COMP3OL</td>
<td></td>
</tr>
<tr>
<td>DA[11:0]</td>
<td></td>
</tr>
<tr>
<td>DB[11:0]</td>
<td></td>
</tr>
<tr>
<td>EOC</td>
<td></td>
</tr>
<tr>
<td>COMP1O</td>
<td></td>
</tr>
<tr>
<td>COMP2O</td>
<td></td>
</tr>
<tr>
<td>COMP3O</td>
<td></td>
</tr>
</tbody>
</table>
LIFCL 17K devices have ADC usage restriction. GPIOP[4, 10, 11, 12, 15] and GPION[4, 10, 11, 12, 15] are not available.

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ADC_ENP</td>
<td>&quot;ENABLED&quot; (default)</td>
<td>ADC enabling signal by MIB</td>
</tr>
<tr>
<td></td>
<td>&quot;DISABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>CLK_DIV</td>
<td>&quot;2&quot; (default)</td>
<td>DCLK divider control</td>
</tr>
<tr>
<td>CTLCOMPSW1</td>
<td>&quot;DISABLED&quot; (default)</td>
<td>Internal comparator switch control</td>
</tr>
<tr>
<td></td>
<td>&quot;ENABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>CTLCOMPSW2</td>
<td>&quot;DISABLED&quot; (default)</td>
<td>Internal comparator switch control</td>
</tr>
<tr>
<td></td>
<td>&quot;ENABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>CTLCOMPSW3</td>
<td>&quot;DISABLED&quot; (default)</td>
<td>Internal comparator switch control</td>
</tr>
<tr>
<td></td>
<td>&quot;ENABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>DF</td>
<td>&quot;STRAIGHT_BINARY&quot;</td>
<td>Output data format control between straight binary</td>
</tr>
<tr>
<td></td>
<td>&quot;TWOS_COMPLEMENT&quot;</td>
<td>and 2's complement coding</td>
</tr>
<tr>
<td>EN_COMP1</td>
<td>&quot;ENABLED&quot; (default)</td>
<td>Auxiliary Comparator 1 enable</td>
</tr>
<tr>
<td></td>
<td>&quot;DISABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>EN_COMP2</td>
<td>&quot;ENABLED&quot; (default)</td>
<td>Auxiliary Comparator 2 enable</td>
</tr>
<tr>
<td></td>
<td>&quot;DISABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>EN_COMP3</td>
<td>&quot;ENABLED&quot; (default)</td>
<td>Auxiliary Comparator 3 enable</td>
</tr>
<tr>
<td></td>
<td>&quot;DISABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>OMA</td>
<td>&quot;BIPOLAR&quot; (default)</td>
<td>Channel A Analog input bi-polar/uni-polar configuration</td>
</tr>
<tr>
<td></td>
<td>&quot;UNIPOLAR&quot;</td>
<td></td>
</tr>
<tr>
<td>OMB</td>
<td>&quot;BIPOLAR&quot; (default)</td>
<td>Channel B Analog input bi-polar/uni-polar configuration</td>
</tr>
<tr>
<td></td>
<td>&quot;UNIPOLAR&quot;</td>
<td></td>
</tr>
<tr>
<td>REFBUFAEN</td>
<td>&quot;DISABLED&quot; (default)</td>
<td>Channel A internal reference buffer enable</td>
</tr>
<tr>
<td></td>
<td>&quot;ENABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>REFBUFBEN</td>
<td>&quot;DISABLED&quot; (default)</td>
<td>Channel B internal reference buffer enable</td>
</tr>
<tr>
<td></td>
<td>&quot;ENABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>SLEEP</td>
<td>&quot;DISABLED&quot; (default)</td>
<td>Sleep mode enable</td>
</tr>
<tr>
<td></td>
<td>&quot;ENABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>VREFACFG</td>
<td>&quot;1P0_TO_1P2&quot; (default)</td>
<td>Channel A external reference voltage level selection</td>
</tr>
<tr>
<td></td>
<td>&quot;1P2_TO_1P4&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;1P4_TO_1P6&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;1P6_TO_1P8&quot;</td>
<td></td>
</tr>
<tr>
<td>VREFASEL</td>
<td>&quot;EXTERNAL&quot; (default)</td>
<td>Channel A reference voltage input configuration</td>
</tr>
<tr>
<td></td>
<td>&quot;INTERNAL&quot;</td>
<td>between internal and external reference voltage</td>
</tr>
<tr>
<td>VREFBCFG</td>
<td>&quot;1P0_TO_1P2&quot; (default)</td>
<td>Channel B external reference voltage level selection</td>
</tr>
<tr>
<td></td>
<td>&quot;1P2_TO_1P4&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;1P4_TO_1P6&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;1P6_TO_1P8&quot;</td>
<td></td>
</tr>
<tr>
<td>VREFBSEL</td>
<td>&quot;EXTERNAL&quot; (default)</td>
<td>Channel B reference voltage input configuration</td>
</tr>
<tr>
<td></td>
<td>&quot;INTERNAL&quot;</td>
<td>between internal and external reference voltage</td>
</tr>
</tbody>
</table>
The ADC macro is composed of two blocks: the external IP and its wrapper.

The external IP consists of two ADCs and three continuous-time comparators. Two ADCs convert unipolar or bipolar input signal into 12-bit resolution data with maximum 1MSPS (Mega Samples Per Second) conversion speed sequentially or simultaneously. This XML covers the wrapper for ADC IP block.

**ALUREG**
Wrapper for Arithmetic Logic Unit and Register File for RISC-V Soft Processor

Architectures supported:

- LFD2NX
- LIFCL

<table>
<thead>
<tr>
<th>Table 7: Input Ports</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
</tr>
<tr>
<td>ALUCLK</td>
</tr>
<tr>
<td>ALUFORWARDA</td>
</tr>
<tr>
<td>ALUFORWARDB</td>
</tr>
<tr>
<td>ALUIREGEN</td>
</tr>
<tr>
<td>ALUOREGEN</td>
</tr>
<tr>
<td>ALURST</td>
</tr>
<tr>
<td>DATAA[31:0]</td>
</tr>
<tr>
<td>DATAB[31:0]</td>
</tr>
<tr>
<td>DATAC[4:0]</td>
</tr>
<tr>
<td>OPC[6:0]</td>
</tr>
<tr>
<td>OPCCUSTOM</td>
</tr>
<tr>
<td>RADDRA[4:0]</td>
</tr>
<tr>
<td>RADDRA[4:0]</td>
</tr>
<tr>
<td>REGCLK</td>
</tr>
<tr>
<td>REGCLKEN</td>
</tr>
<tr>
<td>REGRST</td>
</tr>
<tr>
<td>WADDR[4:0]</td>
</tr>
<tr>
<td>WDROTATE[1:0]</td>
</tr>
<tr>
<td>WDSIGNEXT</td>
</tr>
</tbody>
</table>
### Table 7: Input Ports (Continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>WDSIZE[1:0]</td>
<td></td>
</tr>
<tr>
<td>WDATA[31:0]</td>
<td></td>
</tr>
<tr>
<td>WREN</td>
<td></td>
</tr>
</tbody>
</table>

### Table 8: Output Ports

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ALUFLAGC</td>
<td></td>
</tr>
<tr>
<td>ALUFLAGV</td>
<td></td>
</tr>
<tr>
<td>ALUFLAGZ</td>
<td></td>
</tr>
<tr>
<td>RDATAA[31:0]</td>
<td></td>
</tr>
<tr>
<td>RDATAB[31:0]</td>
<td></td>
</tr>
<tr>
<td>RESULT[31:0]</td>
<td></td>
</tr>
</tbody>
</table>

### Table 9: Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ALURST_ACTIVELOW</td>
<td>&quot;DISABLE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;ENABLE&quot;</td>
<td></td>
</tr>
<tr>
<td>GSR</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;DISABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>INREG</td>
<td>&quot;DISABLE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;ENABLE&quot;</td>
<td></td>
</tr>
<tr>
<td>MULFXP_ROUND</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;DISABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>OUTREG</td>
<td>&quot;DISABLE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;ENABLE&quot;</td>
<td></td>
</tr>
<tr>
<td>REGRST_ACTIVELOW</td>
<td>&quot;DISABLE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;ENABLE&quot;</td>
<td></td>
</tr>
<tr>
<td>RETAIN</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;DISABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>RFASYNC_RD</td>
<td>&quot;SYNC_RD&quot; (default)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;ASYNC_RD&quot;</td>
<td></td>
</tr>
<tr>
<td>RFR0_RO</td>
<td>&quot;R0READONLY&quot; (default)</td>
<td></td>
</tr>
</tbody>
</table>
BB
Bidirectional Buffer with Tri-state

Architectures supported:
- LFD2NX
- LIFCL

Table 10: Input Ports

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>I</td>
<td>Data to pad</td>
</tr>
<tr>
<td>T</td>
<td>Tri-state control</td>
</tr>
</tbody>
</table>

Table 11: Output Ports

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>O</td>
<td>Data from pad</td>
</tr>
</tbody>
</table>

Table 12: Bidirectional Ports

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>B</td>
<td>Connection to pad</td>
</tr>
</tbody>
</table>

Table 13: Truth Table

<table>
<thead>
<tr>
<th>INPUTS</th>
<th>OUTPUTS</th>
<th>BIDIRECTIONAL</th>
</tr>
</thead>
<tbody>
<tr>
<td>I</td>
<td>T</td>
<td>O</td>
</tr>
<tr>
<td>X</td>
<td>1</td>
<td>U</td>
</tr>
<tr>
<td>X</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>X</td>
<td>1</td>
<td>0</td>
</tr>
<tr>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>1</td>
<td>0</td>
<td>1</td>
</tr>
</tbody>
</table>
X = Don't care
U = Unknown

**BB_ADC**
Single-Ended I/O Block for 1.8V

Architectures supported:
- LFD2NX
- LIFCL

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>INADC</td>
<td></td>
</tr>
</tbody>
</table>

**Table 15: Bidirectional Ports**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>IOPAD</td>
<td></td>
</tr>
</tbody>
</table>

**BB_B**
Bidirectional I/O Buffer with Tri-state

Architectures supported:
- iCE40 UltraPlus

**Table 16: Input Ports**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>T_N</td>
<td>Tri-state control, active low meaning T_N = 0' O = Z</td>
</tr>
<tr>
<td>I</td>
<td>Data to pad</td>
</tr>
</tbody>
</table>

**Table 17: Output Ports**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>O</td>
<td>Data from pad</td>
</tr>
</tbody>
</table>
Table 18: Bidirectional Ports

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>B</td>
<td>Connection to pad</td>
</tr>
</tbody>
</table>

Table 19: Truth Table

<table>
<thead>
<tr>
<th>INPUTS</th>
<th>OUTPUTS</th>
<th>BIDIRECTIONAL</th>
</tr>
</thead>
<tbody>
<tr>
<td>I</td>
<td>T_N</td>
<td>O</td>
</tr>
<tr>
<td>X</td>
<td>0</td>
<td>U</td>
</tr>
<tr>
<td>X</td>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>X</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
<td>0</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
<td>1</td>
</tr>
</tbody>
</table>

X = Don't care
U = Unknown

**BB_CDR**

Single-Ended I/O Block for 1.8V

Architectures supported:

- LFD2NX
- LIFCL

Table 20: Output Ports

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>INADC</td>
<td></td>
</tr>
</tbody>
</table>

Table 21: Bidirectional Ports

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>IOPAD</td>
<td></td>
</tr>
</tbody>
</table>

**BB_I3C**

I/O with User Controllable Pull-Up Resistors

Architectures supported:

- iCE40 UltraPlus
### Table 22: Input Ports

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>PU_ENB</td>
<td>Pull-up enable</td>
</tr>
<tr>
<td>WEAK_PU_ENB</td>
<td>Weak pull-up enable</td>
</tr>
<tr>
<td>T_N</td>
<td>Tri-state control active low</td>
</tr>
<tr>
<td>I</td>
<td>Data to pad</td>
</tr>
</tbody>
</table>

### Table 23: Output Ports

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>O</td>
<td>Data from pad</td>
</tr>
</tbody>
</table>

### Table 24: Bidirectional Ports

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>B</td>
<td>Pad</td>
</tr>
</tbody>
</table>

### Table 25: Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>PULLMODE</td>
<td>&quot;100K&quot;  (default)</td>
</tr>
<tr>
<td></td>
<td>&quot;3P3K&quot;</td>
</tr>
<tr>
<td></td>
<td>&quot;6P8K&quot;</td>
</tr>
<tr>
<td></td>
<td>&quot;10K&quot;</td>
</tr>
<tr>
<td></td>
<td>&quot;NA&quot;</td>
</tr>
<tr>
<td>IO_TYPE</td>
<td>&quot;LVCMOS33&quot; (default)</td>
</tr>
<tr>
<td></td>
<td>&quot;LVCMOS25&quot;</td>
</tr>
<tr>
<td></td>
<td>&quot;LVCMOS18&quot;</td>
</tr>
<tr>
<td></td>
<td>&quot;LVCMOS12&quot;</td>
</tr>
<tr>
<td></td>
<td>&quot;LVDSE&quot;</td>
</tr>
</tbody>
</table>
LVDSE for BIDI may not be supported, but for stability-sake, better to leave it as an option to make it 1:1 with PIO physical cell model. LCT table will correctly stop LDVSE from going through for I3C.

**BB_I3C_A**
Single-Ended I/O Block for 3.3V

Architectures supported:
- LFD2NX
- LIFCL

<table>
<thead>
<tr>
<th>Table 26: Input Ports</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
</tr>
<tr>
<td>PADDO</td>
</tr>
<tr>
<td>PADDT</td>
</tr>
<tr>
<td>I3CRESEN</td>
</tr>
<tr>
<td>I3CWKPU</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Table 27: Output Ports</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
</tr>
<tr>
<td>PADDI</td>
</tr>
</tbody>
</table>
**BB_OD**
Input/Output Buffer

Architectures supported:
- iCE40 UltraPlus

<table>
<thead>
<tr>
<th>Table 28: Input Ports</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Name</strong></td>
</tr>
<tr>
<td>T_N</td>
</tr>
<tr>
<td>I</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Table 29: Output Ports</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Name</strong></td>
</tr>
<tr>
<td>O</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Table 30: Bidirectional Ports</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Name</strong></td>
</tr>
<tr>
<td>B</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Table 31: Truth Table</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Inputs</strong></td>
</tr>
<tr>
<td>I</td>
</tr>
<tr>
<td>X</td>
</tr>
<tr>
<td>X</td>
</tr>
<tr>
<td>X</td>
</tr>
<tr>
<td>0</td>
</tr>
<tr>
<td>1</td>
</tr>
</tbody>
</table>

X = Don’t care
U = Unknown

**BFD1P3KX**
Positive Edge Triggered Bidirectional D Flip-Flop with Positive Level Enable and Synchronous Set/Reset for Input/Output/Tri-state Signals (to/from IO)

Architectures supported:
- LFD2NX
### Table 32: Input Ports

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DOUT</td>
<td>Data out from fabric</td>
</tr>
<tr>
<td>DIN</td>
<td>Data in from I/O</td>
</tr>
<tr>
<td>DT</td>
<td>Tri-state in from fabric</td>
</tr>
<tr>
<td>CEOUT</td>
<td>Output/Tri-state clock enable, active high</td>
</tr>
<tr>
<td>CLKOUT</td>
<td>Output/Tri-state clock</td>
</tr>
<tr>
<td>SROUT</td>
<td>Output/Tri-state set/reset</td>
</tr>
<tr>
<td>CEIN</td>
<td>Input clock enable, active high</td>
</tr>
<tr>
<td>CLKin</td>
<td>Input clock</td>
</tr>
<tr>
<td>SRIN</td>
<td>Input set/reset</td>
</tr>
</tbody>
</table>

### Table 33: Output Ports

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>QOUT</td>
<td>Data out to IO</td>
</tr>
<tr>
<td>QIN</td>
<td>Data in to fabric</td>
</tr>
<tr>
<td>QT</td>
<td>Tri-state out to IO</td>
</tr>
</tbody>
</table>

### Table 34: Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>GSR</td>
<td>&quot;ENABLED&quot; (default) &quot;DISABLED&quot;</td>
<td>Enable global set/reset</td>
</tr>
<tr>
<td>OUTSET</td>
<td>&quot;RESET&quot; (default) &quot;SET&quot;</td>
<td>Controls the set/reset behavior of the output register</td>
</tr>
<tr>
<td>INSET</td>
<td>&quot;RESET&quot; (default) &quot;SET&quot;</td>
<td>Controls the set/reset behavior of the input register</td>
</tr>
<tr>
<td>TSSET</td>
<td>&quot;RESET&quot; (default) &quot;SET&quot;</td>
<td>Controls the set/reset behavior of the tri-state register</td>
</tr>
</tbody>
</table>
When INSET/OUTSET/TSSSET = "SET", truth table is the same as *FD1P3JX.

When INSET/OUTSET/TSSSET = "RESET", truth table is the same as *FD1P3I!

CEOUT/CEIN, SROUT/SRIN, CLKOUT/CLKIN must be driven by the same signal, with the exception that they may be driven by the logical inversion of one another.

**BFD1P3LX**
Positive Edge Triggered Bidirectional D Flip-Flop with Positive Level Enable and Asynchronous Set/Reset, for Input/Output/Tri-state Signals (to/from IO)

Architectures supported:
- LFD2NX
- LIFCL

**Table 35: Input Ports**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DOUT</td>
<td>Data out from fabric</td>
</tr>
<tr>
<td>DIN</td>
<td>Data in from I/O</td>
</tr>
<tr>
<td>DT</td>
<td>Tri-state in from fabric</td>
</tr>
</tbody>
</table>
### Table 35: Input Ports (Continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CEOUT</td>
<td>Output/Tri-state clock enable, active high</td>
</tr>
<tr>
<td>CLKOUT</td>
<td>Output/Tri-state clock</td>
</tr>
<tr>
<td>SROUT</td>
<td>Output/Tri-state set/reset</td>
</tr>
<tr>
<td>CEIN</td>
<td>Input clock enable, active high</td>
</tr>
<tr>
<td>CLKIN</td>
<td>Input clock</td>
</tr>
<tr>
<td>SRIN</td>
<td>Input set/reset</td>
</tr>
</tbody>
</table>

### Table 36: Output Ports

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>QOUT</td>
<td>Data out to IO</td>
</tr>
<tr>
<td>QIN</td>
<td>Data in to fabric</td>
</tr>
<tr>
<td>QT</td>
<td>Tri-state out to IO</td>
</tr>
</tbody>
</table>

### Table 37: Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>GSR</td>
<td>&quot;ENABLED&quot; (default) &quot;DISABLED&quot;</td>
<td>Enable global set/reset</td>
</tr>
<tr>
<td>OUTSET</td>
<td>&quot;RESET&quot; (default) &quot;SET&quot;</td>
<td>Controls the set/reset behavior of the output register</td>
</tr>
<tr>
<td>INSET</td>
<td>&quot;RESET&quot; (default) &quot;SET&quot;</td>
<td>Controls the set/reset behavior of the input register</td>
</tr>
<tr>
<td>TSSET</td>
<td>&quot;RESET&quot; (default) &quot;SET&quot;</td>
<td>Controls the set/reset behavior of the tri-state register</td>
</tr>
</tbody>
</table>

![Diagram of Lattice Radiant Software 2.2 Help](image)
When INSET/OUTSET/TSSET = “SET”, truth table is the same as *FD1P3BX.

When INSET/OUTSET/TSSET = “RESET”, truth table is the same as *FD1P3DX.

CEOUT/CEIN, SROUT/SRIN, CLKOUT/CLKIN must be driven by the same signal, with the exception that they may be driven by the logical inversion of one another.

![Diagram showing the relationships between signals](image)

**BNKREF18**

Bankref Block for IOS18

Architectures supported:
- LFD2NX
- LIFCL

**Table 38: Input Ports**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>STDBYINR</td>
<td></td>
</tr>
<tr>
<td>STDBYDIF</td>
<td></td>
</tr>
</tbody>
</table>

**Table 39: Output Ports**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>PVTCODE</td>
<td></td>
</tr>
</tbody>
</table>

**Table 40: Parameters**

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>BANK</td>
<td>&quot;0'b0000&quot; (default)</td>
<td>Virtual attribute, used to tell placer where to place it.</td>
</tr>
</tbody>
</table>
Table 40: Parameters (Continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>STANDBY_DIFFIO</td>
<td>&quot;DISABLED&quot; (default)</td>
<td>Enables SLVS/LVDS output standby mode</td>
</tr>
<tr>
<td></td>
<td>&quot;ENABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>STANDBY_INR</td>
<td>&quot;DISABLED&quot; (default)</td>
<td>Enables INR standby mode: 0 off, 1 on</td>
</tr>
<tr>
<td></td>
<td>&quot;ENABLED&quot;</td>
<td></td>
</tr>
</tbody>
</table>

**BUF**

Non-Inverting Buffer

Architectures supported:

- LFD2NX
- LIFCL
- iCE40 UltraPlus

Table 41: Input Ports

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td></td>
</tr>
</tbody>
</table>

Table 42: Output Ports

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Z</td>
<td></td>
</tr>
</tbody>
</table>

**CCU2**

Carry Chain

Architectures supported:

- LFD2NX
- LIFCL

Table 43: Input Ports

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>A0</td>
<td>Input bit 0 for non-operand signal</td>
</tr>
<tr>
<td>B0</td>
<td>Input bit 0 of the first operand</td>
</tr>
<tr>
<td>C0</td>
<td>Input bit 0 of the second operand</td>
</tr>
</tbody>
</table>
Table 43: Input Ports (Continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>D0</td>
<td>Input bit 0 of the third operand</td>
</tr>
<tr>
<td>A1</td>
<td>Input bit 1 for non-operand signal</td>
</tr>
<tr>
<td>B1</td>
<td>Input bit 1 of the first operand</td>
</tr>
<tr>
<td>C1</td>
<td>Input bit 1 of the second operand</td>
</tr>
<tr>
<td>D1</td>
<td>Input bit 1 of the third operand</td>
</tr>
<tr>
<td>CIN</td>
<td>Carry in</td>
</tr>
</tbody>
</table>

Table 44: Output Ports

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>S0</td>
<td>Output bit 0 of the sum</td>
</tr>
<tr>
<td>S1</td>
<td>Output bit 1 of the sum</td>
</tr>
<tr>
<td>COUT</td>
<td>Carry out</td>
</tr>
</tbody>
</table>

Table 45: Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>INIT0</td>
<td>&quot;0x0000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>INIT1</td>
<td>&quot;0x1111&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>INJECT</td>
<td>&quot;YES&quot; (default)</td>
<td></td>
</tr>
</tbody>
</table>

**CCU2_B**

Carry Chain

Architectures supported:
- iCE40 UltraPlus

Table 46: Input Ports

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>A0</td>
<td>Input bit 0 for non-operand signal</td>
</tr>
<tr>
<td>B0</td>
<td>Input bit 0 of the first operand</td>
</tr>
<tr>
<td>C0</td>
<td>Input bit 0 of the second operand</td>
</tr>
<tr>
<td>CIN</td>
<td>Carry in</td>
</tr>
<tr>
<td>A1</td>
<td>Input bit 1 for non-operand signal</td>
</tr>
</tbody>
</table>
Table 46: Input Ports (Continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>B1</td>
<td>Input bit 1 of the first operand</td>
</tr>
<tr>
<td>C1</td>
<td>Input bit 1 of the second operand</td>
</tr>
</tbody>
</table>

Table 47: Output Ports

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>COUT</td>
<td>Carry out</td>
</tr>
<tr>
<td>S0</td>
<td>Output bit 0 of the sum</td>
</tr>
<tr>
<td>S1</td>
<td>Output bit 1 of the sum</td>
</tr>
</tbody>
</table>

Table 48: Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>INIT0</td>
<td>Hexadecimal value &quot;0xc33c&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>INIT1</td>
<td>Hexadecimal value &quot;0xc33c&quot; (default)</td>
<td></td>
</tr>
</tbody>
</table>

![Diagram of FA2 with inputs A0 B0 C0 CIN A1 B1 C1 and outputs S1 S0 CO1 CO0 COUT]
Table 49: Truth Table

<table>
<thead>
<tr>
<th>Inputs</th>
<th>Outputs</th>
</tr>
</thead>
<tbody>
<tr>
<td>B1</td>
<td>C1</td>
</tr>
<tr>
<td>0 0 0 0 0 0 0</td>
<td>0 0 0 0 1 0 1 0</td>
</tr>
<tr>
<td>0 0 0 1 0 0 1 0</td>
<td>0 0 1 1 1 0 0 0</td>
</tr>
<tr>
<td>0 0 1 0 1 1 0 0</td>
<td>0 0 1 1 1 0 0 1</td>
</tr>
<tr>
<td>0 0 1 1 1 0 0 1</td>
<td>0 1 0 0 0 0 0 1</td>
</tr>
<tr>
<td>0 1 0 0 1 1 0 0</td>
<td>0 1 0 0 1 1 1 0</td>
</tr>
<tr>
<td>0 1 0 1 1 1 1 0</td>
<td>0 1 0 1 1 1 1 0</td>
</tr>
<tr>
<td>0 1 1 0 1 0 0 1</td>
<td>0 1 1 0 0 0 1 1</td>
</tr>
<tr>
<td>0 1 1 1 1 1 0 1</td>
<td>0 1 1 1 0 0 1 1</td>
</tr>
<tr>
<td>0 1 1 1 1 0 0 1</td>
<td>0 1 1 1 1 0 0 1</td>
</tr>
<tr>
<td>0 1 1 1 1 1 1 1</td>
<td>0 1 1 1 1 1 1 1</td>
</tr>
</tbody>
</table>
Note: This is the truth table for an example full adder using CCU2. B1, B0 and C1, C0 are used as operands, while A1, A0 are not used and are tied to ground.

Rules & Restrictions

COUT can only go to D input of LUT above it or next CIN.

To drive VHI to the carry-in “half” a CCU2 must be used. This is done by driving B0 or C0 or both (if S0 can be a don’t care value) to VHI and leaving CIN floating. Your real CCU2 will then start with B1, C1 and the carry-in will be VHI.

To drive VLO to the carry-in “half” a CCU2 must be used. This is done by driving VLO for B0 and C0 and leaving CIN floating. Your real CCU2 starts with B1, C1 and CIN1 will be driven by VLO.

If you want to bring out last COUT to fabric, simply connect COUT to whatever is your fabric logic. MAP and Placer will work to insert a LUT and place it in the appropriate location automatically (thus ensuring rule 1 is followed).

See examples below that takes into account the above rules.

---

Table 49: Truth Table (Continued)

<table>
<thead>
<tr>
<th>Inputs</th>
<th>Outputs</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Inputs</td>
<td>Outputs</td>
</tr>
<tr>
<td>B1</td>
<td>B0</td>
</tr>
<tr>
<td>1</td>
<td>0</td>
</tr>
<tr>
<td>1</td>
<td>0</td>
</tr>
<tr>
<td>1</td>
<td>0</td>
</tr>
<tr>
<td>1</td>
<td>0</td>
</tr>
<tr>
<td>1</td>
<td>0</td>
</tr>
<tr>
<td>1</td>
<td>0</td>
</tr>
<tr>
<td>1</td>
<td>0</td>
</tr>
<tr>
<td>1</td>
<td>0</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
</tr>
</tbody>
</table>
Note: The examples below do not make use of the A0 or A1 ports as they are not needed for carry-chain functionality.

**Burning half a CCU2 for carry-chain:**

```verilog
CCU2_B counter_12_add_4_0 ( 
  .B0(GND_net),
  .C0(GND_net),
  .CIN(),
  .B1(firstB),
  .C1(firstC),
  .COUT(firstCarry),
  .S0(),
  .S1(firstSum)
);
```

**Using LUT to bring last Carry Out:**

```verilog
CCU2_B counter_12_add_4_7 ( 
  .B0(GND_net),
  .C0(out_c_5),
  .CIN(COUT_prev),
  .B1(GND_net),
  .C1(out_c_6),
  .COUT(LAST_CARRY),
  .S0(n40),
  .S1(n39)
);
```

```verilog
LUT   lutInst(
  .D(LAST_CARRY),
  .F(CARRYOUT_TO_FABRIC)
); //eqn : F=D
```

**Using CCU2 to bring last Carry Out:**

**Why it works:** Last Sum = GND XOR GND XOR CIN_PREV = lastCarryOut.

```verilog
CCU2_B counter_12_add_4_9 ( 
  .B0(GND_net),
  .C0(out_c_7),
  .CIN(COUT_prev),
  .B1(GND_net),
  .C1(GND_net),
  .COUT(),
  .S0(n40),
  .S1(lastCarryOut)
);
```

---

**CRE**

**Cryptographic Engine**

**Note**

CRE is only available with the CRE Control Pack.
Architectures supported:

- LFD2NX
- LIFCL

**Table 50: Input Ports**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>LMMICLK</td>
<td></td>
</tr>
<tr>
<td>LMMIRESET_N</td>
<td></td>
</tr>
<tr>
<td>LMMIREQUEST</td>
<td></td>
</tr>
<tr>
<td>LMMIWRD_N</td>
<td></td>
</tr>
<tr>
<td>LMMIOFFSET[17:0]</td>
<td></td>
</tr>
<tr>
<td>LMMIWDATA[31:0]</td>
<td></td>
</tr>
<tr>
<td>ASFCLKI</td>
<td></td>
</tr>
<tr>
<td>ASFRDI</td>
<td></td>
</tr>
<tr>
<td>ASFRESETI</td>
<td></td>
</tr>
<tr>
<td>ASFWRI</td>
<td></td>
</tr>
<tr>
<td>CFG_CLK</td>
<td></td>
</tr>
<tr>
<td>CRE_CLK</td>
<td></td>
</tr>
<tr>
<td>CRE禄RSTN</td>
<td></td>
</tr>
</tbody>
</table>

**Table 51: Output Ports**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>LMMIRDATA[31:0]</td>
<td></td>
</tr>
<tr>
<td>LMMIRDATAVALID</td>
<td></td>
</tr>
<tr>
<td>LMMIREADY</td>
<td></td>
</tr>
<tr>
<td>ASFEMPTYO</td>
<td></td>
</tr>
<tr>
<td>ASFFULLO</td>
<td></td>
</tr>
</tbody>
</table>

**Table 52: Parameters**

<table>
<thead>
<tr>
<th>Name</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CRE_DISABLE</td>
<td>ENABLED (default)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>DISABLED</td>
<td></td>
</tr>
</tbody>
</table>
Table 52: Parameters (Continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>GSR</td>
<td>ENABLED (default)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>DISABLED</td>
<td></td>
</tr>
<tr>
<td>OTP_EN</td>
<td>ENABLED</td>
<td></td>
</tr>
<tr>
<td></td>
<td>DISABLED (default)</td>
<td></td>
</tr>
</tbody>
</table>

Table 53: Attributes

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>syn_black_box</td>
<td></td>
</tr>
</tbody>
</table>

DCC
Dynamic Clock Control with Positive Enable

Architectures supported:

- LFD2NX
- LIFCL

Table 54: Input Ports

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CLKI</td>
<td>Clock in</td>
</tr>
<tr>
<td>CE</td>
<td>Clock enable</td>
</tr>
</tbody>
</table>

Table 55: Output Ports

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CLKO</td>
<td>Clock out. Zero when CE is 0. CLKI when CE is 1.</td>
</tr>
</tbody>
</table>

Table 56: Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DCCEN</td>
<td>&quot;0&quot; (default)</td>
<td>Enables dynamic control.</td>
</tr>
<tr>
<td></td>
<td>&quot;1&quot;</td>
<td>&quot;0&quot;: CLKO = CLKI regardless of the CE input.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>&quot;1&quot;: CLKO depends on the CE input.</td>
</tr>
</tbody>
</table>

DCS
Dynamic Clock Selection
Architectures supported:
> LFD2NX
> LIFCL

**Table 57: Input Ports**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CLK0</td>
<td></td>
</tr>
<tr>
<td>CLK1</td>
<td></td>
</tr>
<tr>
<td>SEL</td>
<td></td>
</tr>
<tr>
<td>SELFORCE</td>
<td></td>
</tr>
</tbody>
</table>

**Table 58: Output Ports**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DCSOUT</td>
<td></td>
</tr>
</tbody>
</table>

**Table 59: Parameters**

<table>
<thead>
<tr>
<th>Name</th>
<th>Value</th>
<th>Description</th>
<th>Output (SEL = 0)</th>
<th>Output (SEL = 1)</th>
</tr>
</thead>
<tbody>
<tr>
<td>DCSMODE</td>
<td>&quot;VCC&quot;</td>
<td>Rising edge triggered. Latched state is high.</td>
<td>CLK0</td>
<td>CLK1</td>
</tr>
<tr>
<td></td>
<td>&quot;GND&quot;</td>
<td>Falling edge triggered. Latched state is low.</td>
<td>CLK0</td>
<td>CLK1</td>
</tr>
<tr>
<td></td>
<td>&quot;BUFGCECLK1_0&quot;</td>
<td>SEL is active high. Disabled output is low.</td>
<td>0</td>
<td>CLK1</td>
</tr>
<tr>
<td></td>
<td>&quot;BUFGCECLK1&quot;</td>
<td>SEL is active high. Disabled output is high.</td>
<td>1</td>
<td>CLK1</td>
</tr>
<tr>
<td></td>
<td>&quot;BUFGCECLK0&quot;</td>
<td>SEL is active low. Disabled output is low.</td>
<td>CLK0</td>
<td>0</td>
</tr>
<tr>
<td></td>
<td>&quot;BUFGCECLK0_1&quot;</td>
<td>SEL is active low. Disabled output is high.</td>
<td>CLK0</td>
<td>1</td>
</tr>
<tr>
<td></td>
<td>&quot;BUF0&quot;</td>
<td>Buffer for CLK0</td>
<td>CLK0</td>
<td>CLK0</td>
</tr>
<tr>
<td></td>
<td>&quot;BUF1&quot;</td>
<td>Buffer for CLK1</td>
<td>CLK1</td>
<td>CLK1</td>
</tr>
</tbody>
</table>

**DDRDLL**

Delay-Locked Loop Master Block for DDR Functionality
Architectures supported:
- LFD2NX
- LIFCL

Table 60: Input Ports

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>FREEZE</td>
<td></td>
</tr>
<tr>
<td>CLKIN</td>
<td></td>
</tr>
<tr>
<td>RST</td>
<td></td>
</tr>
<tr>
<td>UDDCNTL_N</td>
<td></td>
</tr>
</tbody>
</table>

Table 61: Output Ports

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CODE[8:0]</td>
<td></td>
</tr>
<tr>
<td>LOCK</td>
<td></td>
</tr>
<tr>
<td>DCNTL[8:0]</td>
<td></td>
</tr>
</tbody>
</table>

Table 62: Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>GSR</td>
<td>&quot;ENABLED&quot; (default) &quot;DISABLED&quot;</td>
<td>GSRN signal enable/disable select</td>
</tr>
<tr>
<td>ENA_ROUNDOFF</td>
<td>&quot;ENABLED&quot; (default) &quot;DISABLED&quot;</td>
<td>DLL counter round-off select.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>0: Disable round-off</td>
</tr>
<tr>
<td></td>
<td></td>
<td>1: Enable round-off, more stable code</td>
</tr>
<tr>
<td>FORCE_MAX_DELAY</td>
<td>&quot;CODE_OR_LOCK_FROM_DLL_LOOP&quot; (default) &quot;FORCE_LOCK_AND_CODE&quot;</td>
<td>DLL control code forcing.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>0: Code/lock generated from DLL loop</td>
</tr>
<tr>
<td></td>
<td></td>
<td>1: Force lock and code is set to maximum of 255 for lower input frequency mode.</td>
</tr>
</tbody>
</table>

DDRDDL can generate a phase shift code (90 degree) according to its running frequency and provide this code to every individual DQS block and DLLDEL slave delay element located in two adjacent sides if available.

**DELAYA**

Dynamic Input/Output Delay Element.
Architectures supported:

- LIFCL
- LFD2NX
### Table 63: Input Ports

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>Data input from pin or output register block.</td>
</tr>
<tr>
<td>LOADN</td>
<td>0 resets to default delay setting.</td>
</tr>
<tr>
<td>MOVE</td>
<td>A pulse changes delay setting. The DIRECTION pin is sampled at falling edge of MOVE.</td>
</tr>
<tr>
<td>DIRECTION</td>
<td>1 to decrease delay and 0 to increase delay.</td>
</tr>
</tbody>
</table>
| COARSE[1:0]| Dynamic coarse delay control:  
00: No coarse delay  
01: 800 ps delay  
10: 1600 ps delay  
11: Invalid |
| RANKSELECT| 0 - Select delay rank 0  
1 - Select delay rank 1 |
| RANKENABLE| 0 - Select bypassed actual path delay code  
1 - Select registered actual path delay code |
| RANK0UPDATE| 0 - Rank-0 registers not enabled  
1 - Enable Rank-0 registers |
| RANK1UPDATE| 0 - Rank-1 registers not enabled  
1 - Enable Rank-1 registers |

### Table 64: Output Ports

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Z</td>
<td>Delayed data to input register block or to pin.</td>
</tr>
<tr>
<td>EDETERR</td>
<td>Error detected when using the edge monitor logic.</td>
</tr>
<tr>
<td>CFLAG</td>
<td>Flag indicating the delay counter has reached the max (when moving up) or min (when moving down) value.</td>
</tr>
</tbody>
</table>
This primitive can be used to delay the input data from the input pin to the IDDR, IREG, or FPGA OR to delay the output data from the ODDR, OREG, or FPGA fabric to the output pin. DELAYA is useful to adjust for any skews amongst the input or output data buses. DELAYA can also be used to generate skew between the bits of an output bus to reduce SSO noise.

DELAYA can be used with IDDR, ODDR, or SDR modules, as well as on the direct input to the FPGA. DELAYA is shared by the input and output paths, and so it can only be used to delay the input data or the output data on a given pin.

The data input to this primitive can be delayed using:

- Pre-determined delay value (for Zero Hold time, delay based on Interface Type)
- Fixed Delay values entered by user

### Table 65: Parameters

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DEL_MODE</td>
<td>&quot;USER_DEFINED&quot; <em>(default)</em></td>
<td>Sets the delay mode.</td>
</tr>
<tr>
<td></td>
<td>&quot;SCLK_ZEROHOLD&quot;</td>
<td>DQS_CMD_CLK is only for the DDR Memory CMD and CLK outputs.</td>
</tr>
<tr>
<td></td>
<td>&quot;ECLK_ALIGNED&quot;</td>
<td>DQS_ALIGNED is shared by DQS generic and the DDR memory inputs.</td>
</tr>
<tr>
<td></td>
<td>&quot;ECLK_CENTERED&quot;</td>
<td>DQS_CENTERED is used for DQS generic inputs.</td>
</tr>
<tr>
<td></td>
<td>&quot;SCLK_ALIGNED&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;SCLK_CENTERED&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;DQS_CMD_CLK&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;DQS_ALIGNED_X2&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;DQS_ALIGNED_X4&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;DQS_CENTERED_X2&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;DQS_CENTERED_X4&quot;</td>
<td></td>
</tr>
<tr>
<td>DEL_VALUE</td>
<td>0 - 127 <em>(0 default)</em></td>
<td>Sets delay value when DEL_MODE is set to USER_DEFINED. Step is 12.5 ps.</td>
</tr>
<tr>
<td>COARSE_DELAY_MODE</td>
<td>&quot;STATIC&quot; <em>(default)</em></td>
<td>Selects coarse delay code control:</td>
</tr>
<tr>
<td></td>
<td>&quot;DYNAMIC&quot;</td>
<td>0 - Selects from MC1 (STATIC)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>1 - Selects from CIB (DYNAMIC)</td>
</tr>
<tr>
<td>COARSE_DELAY</td>
<td>&quot;0NS&quot; <em>(default)</em></td>
<td>Coarse delay setting for lol delay cell.</td>
</tr>
<tr>
<td></td>
<td>&quot;0P8NS&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;1P6NS&quot;</td>
<td></td>
</tr>
<tr>
<td>EDGE_MONITOR</td>
<td>&quot;ENABLED&quot; <em>(default)</em></td>
<td>Enables edge monitor when in IDDR X2, X7to1, X4, or X5 mode.</td>
</tr>
<tr>
<td></td>
<td>&quot;DISABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>WAIT_FOR_EDGE</td>
<td>&quot;ENABLED&quot; <em>(default)</em></td>
<td>Used for SPI4.2 implementation.</td>
</tr>
<tr>
<td></td>
<td>&quot;DISABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>GSR</td>
<td>&quot;ENABLED&quot; <em>(default)</em></td>
<td>Enable global set/reset.</td>
</tr>
<tr>
<td></td>
<td>&quot;DISABLED&quot;</td>
<td></td>
</tr>
</tbody>
</table>
The delay can also be dynamically updated using counter up and down controls.

You can optionally bypass DELAYA completely as well.

By default, DELAYA is configured to factory delay settings based on the clocking structure. You can overwrite the DELAYA setting using the MOVE and DIRECTION control inputs. The LOADN pin will reset the delay back to the default value.

**DELAYB**
Static Input/Output Delay Element.

Architectures supported:
- LFD2NX
- LIFCL

**Table 66: Input Ports**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>Data input from pin or output register block.</td>
</tr>
</tbody>
</table>

**Table 67: Output Ports**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Z</td>
<td>Delayed data to input register block or to pin.</td>
</tr>
</tbody>
</table>

**Table 68: Parameters**

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>COARSE_DELAY</td>
<td>&quot;0NS&quot; (default)</td>
<td>Coarse delay setting for lol delay cell.</td>
</tr>
<tr>
<td></td>
<td>&quot;0P8NS&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;1P6NS&quot;</td>
<td></td>
</tr>
<tr>
<td>DEL_VALUE</td>
<td>0 - 127 (0 default)</td>
<td>Sets delay value when DEL_MODE is set to USER_DEFINED. Step is 12.5 ps.</td>
</tr>
</tbody>
</table>
This primitive can be used to delay the input data from the input pin to the
IDDR, IREG, or FPGA OR to delay the output data from the ODDR, OREG, or
FPGA fabric to the output pin. DELAYB is useful to adjust for any skews
amongst the input or output data buses. DELAYB can also be used to
generate skew between the bits of an output bus to reduce SSO noise.

DELAYB can be used with IDDR, ODDR, or SDR modules, as well as on the
direct input to the FPGA. DELAYB is shared by the input and output paths,
and so it can only be used to delay the input data or the output data on a
given pin.

The data input to this primitive can be delayed using:

- Predetermined delay value (for Zero Hold time, delay based on Interface
  Type)
- Fixed Delay values entered by user

The delay can also be dynamically updated using counter up and down
controls.

You can optionally bypass DELAYB completely as well.

By default, DELAYB is configured to factory delay settings based on the
clocking structure. You cannot change the delay when using this module.

**DLLDEL**

Slave delay elements are used to support generic DDR RX modes to shift
input clock phase by 90 degrees.

Architectures supported:
Alphanumeric Primitives List

- LFD2NX
- LIFCL

Table 69: Input Ports

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CLBIN</td>
<td></td>
</tr>
<tr>
<td>CODE[8:0]</td>
<td></td>
</tr>
<tr>
<td>DIR</td>
<td></td>
</tr>
<tr>
<td>LOAD_N</td>
<td></td>
</tr>
<tr>
<td>MOVE</td>
<td></td>
</tr>
</tbody>
</table>

Table 70: Output Ports

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CLKOUT</td>
<td></td>
</tr>
<tr>
<td>COUT</td>
<td></td>
</tr>
</tbody>
</table>

Table 71: Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
</table>
| ADJUST   | 0 (default)             | Offset for slave delay adjustment. \(mc1\_adjust[9]\) is the sign bit. Examples:
|          |                         | \(mc1\_adjust[9:0] = 0\_000000000\): adds 0 units of delay
|          |                         | \(mc1\_adjust[9:0] = 0\_000000010\): adds 2 units of delay
|          |                         | \(mc1\_adjust[9:0] = 0\_111111111\): adds 511 units of delay
| DEL_ADJUST| "PLUS" (default)       | Sign bit for \(mc1\_adjust\), bit [9].
|          | "MINUS"                |             |
| ENABLE   | "ENABLED" (default)    | Enables the block and ties off the clk output when not using this block.
|          | "DISABLED"             |             |

DP16K
16Kb Dual Port Block RAM

Architectures supported:
- LFD2NX
Table 72: Input Ports

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DIA[17:0]</td>
<td>Port A data in</td>
</tr>
<tr>
<td>DIB[17:0]</td>
<td>Port B data in</td>
</tr>
<tr>
<td>ADA[13:0]</td>
<td>Port A address</td>
</tr>
<tr>
<td>ADB[13:0]</td>
<td>Port B address</td>
</tr>
<tr>
<td>CLKA</td>
<td>Port A clock</td>
</tr>
<tr>
<td>CLKB</td>
<td>Port B clock</td>
</tr>
<tr>
<td>CEA</td>
<td>Port A clock enable</td>
</tr>
<tr>
<td>CEB</td>
<td>Port B clock enable</td>
</tr>
<tr>
<td>WEA</td>
<td>Port A write enable</td>
</tr>
<tr>
<td>WEB</td>
<td>Port A write enable</td>
</tr>
<tr>
<td>CSA[2:0]</td>
<td>Port A chip select</td>
</tr>
<tr>
<td>CSB[2:0]</td>
<td>Port B chip select</td>
</tr>
<tr>
<td>RSTA</td>
<td>Port A output register reset</td>
</tr>
<tr>
<td>RSTB</td>
<td>Port B output register reset</td>
</tr>
</tbody>
</table>

Table 73: Output Ports

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DOA[17:0]</td>
<td>Port A data out</td>
</tr>
<tr>
<td>DOB[17:0]</td>
<td>Port B data out</td>
</tr>
</tbody>
</table>

Table 74: Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DATA_WIDTH_A</td>
<td>&quot;X18&quot; (default)</td>
<td>Port A data width</td>
</tr>
<tr>
<td></td>
<td>&quot;X9&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;X4&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;X2&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;X1&quot;</td>
<td></td>
</tr>
<tr>
<td>DATA_WIDTH_B</td>
<td>&quot;X18&quot; (default)</td>
<td>Port B data width</td>
</tr>
<tr>
<td></td>
<td>&quot;X9&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;X4&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;X2&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;X1&quot;</td>
<td></td>
</tr>
<tr>
<td>OUTREG_A</td>
<td>&quot;BYPASSED&quot; (default)</td>
<td>Register port A output</td>
</tr>
<tr>
<td></td>
<td>&quot;USED&quot;</td>
<td></td>
</tr>
</tbody>
</table>
It is not legal to drive the two clocks such that their active edges switch simultaneously.
All inputs (except the register control signals) and all outputs are registered in the following manner:

Port assignments for different data widths follow the table below:

<table>
<thead>
<tr>
<th>Data Width</th>
<th>Input Data</th>
<th>Output Data</th>
<th>Address A (MSB to LSB)</th>
<th>Address B (MSB to LSB)</th>
</tr>
</thead>
<tbody>
<tr>
<td>16Kx1</td>
<td>DI[0]</td>
<td>DO[0]</td>
<td>ADA[13:0]</td>
<td>ADB[13:0]</td>
</tr>
</tbody>
</table>

**DPHY**

The MIPI wrapper IP is used for MIPI DPHY v1.2: 4 channels DPHY with VCC= 0.9/V/1.0V

**Warning**

You should not try to use this primitive directly. Instead, use the related IP in IP Catalog. The following information is for reference only.

Architectures supported:

- LIFCL

**Table 75: Input Ports**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>LMMICLK</td>
<td></td>
</tr>
<tr>
<td>LMMIRESET_N</td>
<td></td>
</tr>
<tr>
<td>LMMIREQUEST</td>
<td></td>
</tr>
<tr>
<td>LMMIWRRD_N</td>
<td></td>
</tr>
</tbody>
</table>
Table 75: Input Ports (Continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>LMMIOFFSET[4:0]</td>
<td></td>
</tr>
<tr>
<td>LMMIWDATA[3:0]</td>
<td></td>
</tr>
<tr>
<td>BITCKEXT</td>
<td></td>
</tr>
<tr>
<td>CLKREF</td>
<td></td>
</tr>
<tr>
<td>PDDPHY</td>
<td></td>
</tr>
<tr>
<td>PDPLL</td>
<td></td>
</tr>
<tr>
<td>SCCLKIN</td>
<td></td>
</tr>
<tr>
<td>UED0THEN</td>
<td></td>
</tr>
<tr>
<td>UFRXMODE</td>
<td></td>
</tr>
<tr>
<td>UTXMDTX</td>
<td></td>
</tr>
<tr>
<td>URXCKINE</td>
<td></td>
</tr>
<tr>
<td>UTDIS</td>
<td></td>
</tr>
<tr>
<td>UTXCKE</td>
<td></td>
</tr>
<tr>
<td>UDE0D0TN</td>
<td></td>
</tr>
<tr>
<td>UDE1D1TN</td>
<td></td>
</tr>
<tr>
<td>UDE2D2TN</td>
<td></td>
</tr>
<tr>
<td>UDE3D3TN</td>
<td></td>
</tr>
<tr>
<td>UDE4CKTN</td>
<td></td>
</tr>
<tr>
<td>UDE5D0RN</td>
<td></td>
</tr>
<tr>
<td>UDE6D1RN</td>
<td></td>
</tr>
<tr>
<td>UDE7D2RN</td>
<td></td>
</tr>
<tr>
<td>UTXDHS[31:0]</td>
<td></td>
</tr>
<tr>
<td>UTXENER</td>
<td></td>
</tr>
<tr>
<td>UTXRD0EN</td>
<td></td>
</tr>
<tr>
<td>UTRD0SEN</td>
<td></td>
</tr>
<tr>
<td>UTXSKD0N</td>
<td></td>
</tr>
<tr>
<td>UTXTGE0</td>
<td></td>
</tr>
<tr>
<td>UTXTGE1</td>
<td></td>
</tr>
<tr>
<td>UTXTGE2</td>
<td></td>
</tr>
<tr>
<td>UTXTGE3</td>
<td></td>
</tr>
<tr>
<td>UTXULPSE</td>
<td></td>
</tr>
<tr>
<td>UTXUPSEX</td>
<td></td>
</tr>
</tbody>
</table>
### Table 75: Input Ports (Continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>UTXVDE</td>
<td></td>
</tr>
<tr>
<td>UTXWVDHS[3:0]</td>
<td></td>
</tr>
<tr>
<td>U1ENTHEN</td>
<td></td>
</tr>
<tr>
<td>U1FRXMD</td>
<td></td>
</tr>
<tr>
<td>U1FTXST</td>
<td></td>
</tr>
<tr>
<td>U1TDIS</td>
<td></td>
</tr>
<tr>
<td>U1TREQ</td>
<td></td>
</tr>
<tr>
<td>U1TDE0D3</td>
<td></td>
</tr>
<tr>
<td>U1TDE1CK</td>
<td></td>
</tr>
<tr>
<td>U1TDE2D0</td>
<td></td>
</tr>
<tr>
<td>U1TDE3D1</td>
<td></td>
</tr>
<tr>
<td>U1TDE4D2</td>
<td></td>
</tr>
<tr>
<td>U1TDE5D3</td>
<td></td>
</tr>
<tr>
<td>U1TDE6</td>
<td></td>
</tr>
<tr>
<td>U1TDE7</td>
<td></td>
</tr>
<tr>
<td>U1TXDHS[31:0]</td>
<td></td>
</tr>
<tr>
<td>U1TXLPD</td>
<td></td>
</tr>
<tr>
<td>U1TXREQ</td>
<td></td>
</tr>
<tr>
<td>U1TXREQH</td>
<td></td>
</tr>
<tr>
<td>U1TXSK</td>
<td></td>
</tr>
<tr>
<td>U1TXTGE0</td>
<td></td>
</tr>
<tr>
<td>U1TXTGE1</td>
<td></td>
</tr>
<tr>
<td>U1TXTGE2</td>
<td></td>
</tr>
<tr>
<td>U1TXTGE3</td>
<td></td>
</tr>
<tr>
<td>U1TXUPSE</td>
<td></td>
</tr>
<tr>
<td>U1TXUPSX</td>
<td></td>
</tr>
<tr>
<td>U1TXVDE</td>
<td></td>
</tr>
<tr>
<td>U1TXWVHS[3:0]</td>
<td></td>
</tr>
<tr>
<td>U2END2</td>
<td></td>
</tr>
<tr>
<td>U2FRXMD</td>
<td></td>
</tr>
<tr>
<td>U2FTXST</td>
<td></td>
</tr>
<tr>
<td>U2TDIS</td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>U2TREQ</td>
<td></td>
</tr>
<tr>
<td>U2TDE0D0</td>
<td></td>
</tr>
<tr>
<td>U2TDE1D1</td>
<td></td>
</tr>
<tr>
<td>U2TDE2D2</td>
<td></td>
</tr>
<tr>
<td>U2TDE3D3</td>
<td></td>
</tr>
<tr>
<td>U2TDE4CK</td>
<td></td>
</tr>
<tr>
<td>U2TDE5D0</td>
<td></td>
</tr>
<tr>
<td>U2TDE6D1</td>
<td></td>
</tr>
<tr>
<td>U2TDE7D2</td>
<td></td>
</tr>
<tr>
<td>U2TXDHS[31:0]</td>
<td></td>
</tr>
<tr>
<td>U2TPDTE</td>
<td></td>
</tr>
<tr>
<td>U2TXREQ</td>
<td></td>
</tr>
<tr>
<td>U2TXREQH</td>
<td></td>
</tr>
<tr>
<td>U2TXSKC</td>
<td></td>
</tr>
<tr>
<td>U2TXTGE0</td>
<td></td>
</tr>
<tr>
<td>U2TXTGE1</td>
<td></td>
</tr>
<tr>
<td>U2TXTGE2</td>
<td></td>
</tr>
<tr>
<td>U2TXTGE3</td>
<td></td>
</tr>
<tr>
<td>U2TXUPSE</td>
<td></td>
</tr>
<tr>
<td>U2TXUPSX</td>
<td></td>
</tr>
<tr>
<td>U2TXVDE</td>
<td></td>
</tr>
<tr>
<td>U2TXWVHS[3:0]</td>
<td></td>
</tr>
<tr>
<td>U3END3</td>
<td></td>
</tr>
<tr>
<td>U3FRXMD</td>
<td></td>
</tr>
<tr>
<td>U3FTXST</td>
<td></td>
</tr>
<tr>
<td>U3TDISD2</td>
<td></td>
</tr>
<tr>
<td>U3TREQD2</td>
<td></td>
</tr>
<tr>
<td>U3TDE0D3</td>
<td></td>
</tr>
<tr>
<td>U3TDE1D0</td>
<td></td>
</tr>
<tr>
<td>U3TDE2D1</td>
<td></td>
</tr>
<tr>
<td>U3TDE3D2</td>
<td></td>
</tr>
<tr>
<td>U3TDE4D3</td>
<td></td>
</tr>
</tbody>
</table>
### Table 75: Input Ports (Continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>U3TDE5CK</td>
<td></td>
</tr>
<tr>
<td>U3TDE6</td>
<td></td>
</tr>
<tr>
<td>U3TDE7</td>
<td></td>
</tr>
<tr>
<td>U3TXDHS[31:0]</td>
<td></td>
</tr>
<tr>
<td>U3TXLPDT</td>
<td></td>
</tr>
<tr>
<td>U3TXREQ</td>
<td></td>
</tr>
<tr>
<td>U3TXREQH</td>
<td></td>
</tr>
<tr>
<td>U3TXSKC</td>
<td></td>
</tr>
<tr>
<td>U3TXTGE0</td>
<td></td>
</tr>
<tr>
<td>U3TXTGE1</td>
<td></td>
</tr>
<tr>
<td>U3TXTGE2</td>
<td></td>
</tr>
<tr>
<td>U3TXTGE3</td>
<td></td>
</tr>
<tr>
<td>U3TXULPS</td>
<td></td>
</tr>
<tr>
<td>U3TXUPSX</td>
<td></td>
</tr>
<tr>
<td>U3TXVD3</td>
<td></td>
</tr>
<tr>
<td>U3TXWVHS[3:0]</td>
<td></td>
</tr>
<tr>
<td>UCENCK</td>
<td></td>
</tr>
<tr>
<td>UCTXREQH</td>
<td></td>
</tr>
<tr>
<td>UCTXUPSC</td>
<td></td>
</tr>
<tr>
<td>UCTXUPSX</td>
<td></td>
</tr>
<tr>
<td>LTSTEN</td>
<td></td>
</tr>
<tr>
<td>LTSTLANE[1:0]</td>
<td></td>
</tr>
<tr>
<td>UTRNREQ</td>
<td></td>
</tr>
</tbody>
</table>

### Table 76: Output Ports

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>LMMIRDATA[3:0]</td>
<td></td>
</tr>
<tr>
<td>LMMIRDATAVALID</td>
<td></td>
</tr>
<tr>
<td>LMMIREADY</td>
<td></td>
</tr>
<tr>
<td>D0ACTIVE[1:0]</td>
<td></td>
</tr>
<tr>
<td>D0BYTCNT[9:0]</td>
<td></td>
</tr>
<tr>
<td>D0ERRCNT[9:0]</td>
<td></td>
</tr>
</tbody>
</table>
### Table 76: Output Ports (Continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>D0PASS[1:0]</td>
<td></td>
</tr>
<tr>
<td>D0VALID[1:0]</td>
<td></td>
</tr>
<tr>
<td>D1ACTIVE[1:0]</td>
<td></td>
</tr>
<tr>
<td>D1BYTCNT[9:0]</td>
<td></td>
</tr>
<tr>
<td>D1ERRCNT[9:0]</td>
<td></td>
</tr>
<tr>
<td>D1PASS[1:0]</td>
<td></td>
</tr>
<tr>
<td>D1VALID[1:0]</td>
<td></td>
</tr>
<tr>
<td>D2ACTIVE[1:0]</td>
<td></td>
</tr>
<tr>
<td>D2BYTCNT[9:0]</td>
<td></td>
</tr>
<tr>
<td>D2ERRCNT[9:0]</td>
<td></td>
</tr>
<tr>
<td>D2PASS[1:0]</td>
<td></td>
</tr>
<tr>
<td>D2VALID[1:0]</td>
<td></td>
</tr>
<tr>
<td>D3ACTIVE[1:0]</td>
<td></td>
</tr>
<tr>
<td>D3BYTCNT[9:0]</td>
<td></td>
</tr>
<tr>
<td>D3ERRCNT[9:0]</td>
<td></td>
</tr>
<tr>
<td>D3PASS[1:0]</td>
<td></td>
</tr>
<tr>
<td>D3VALID[1:0]</td>
<td></td>
</tr>
<tr>
<td>DCTSTOUT[9:0]</td>
<td></td>
</tr>
<tr>
<td>LOCK</td>
<td></td>
</tr>
<tr>
<td>UDIR</td>
<td></td>
</tr>
<tr>
<td>UERCLP0</td>
<td></td>
</tr>
<tr>
<td>UERCLP1</td>
<td></td>
</tr>
<tr>
<td>UERCTRL</td>
<td></td>
</tr>
<tr>
<td>UERE</td>
<td></td>
</tr>
<tr>
<td>UERSTHS</td>
<td></td>
</tr>
<tr>
<td>UERSHHS</td>
<td></td>
</tr>
<tr>
<td>UERSE</td>
<td></td>
</tr>
<tr>
<td>URXACTHS</td>
<td></td>
</tr>
<tr>
<td>URXCKE</td>
<td></td>
</tr>
<tr>
<td>URXDE[7:0]</td>
<td></td>
</tr>
<tr>
<td>URXDHS[15:0]</td>
<td></td>
</tr>
<tr>
<td>URXLPDTE</td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>URXSKCHS</td>
<td></td>
</tr>
<tr>
<td>URXDRX</td>
<td></td>
</tr>
<tr>
<td>URXSHS[3:0]</td>
<td></td>
</tr>
<tr>
<td>URE0D3DP</td>
<td></td>
</tr>
<tr>
<td>URE1D3DN</td>
<td></td>
</tr>
<tr>
<td>URE2CKDP</td>
<td></td>
</tr>
<tr>
<td>URE3CKDN</td>
<td></td>
</tr>
<tr>
<td>URXULPSE</td>
<td></td>
</tr>
<tr>
<td>URXVDE</td>
<td></td>
</tr>
<tr>
<td>URXVDHS[3:0]</td>
<td></td>
</tr>
<tr>
<td>USSTT</td>
<td></td>
</tr>
<tr>
<td>UTXRRS</td>
<td></td>
</tr>
<tr>
<td>UTXRYP</td>
<td></td>
</tr>
<tr>
<td>UTXRYSK</td>
<td></td>
</tr>
<tr>
<td>UUSAN</td>
<td></td>
</tr>
<tr>
<td>U1DIR</td>
<td></td>
</tr>
<tr>
<td>U1ERCLP0</td>
<td></td>
</tr>
<tr>
<td>U1ERCLP1</td>
<td></td>
</tr>
<tr>
<td>U1ERCTRL</td>
<td></td>
</tr>
<tr>
<td>U1ERE</td>
<td></td>
</tr>
<tr>
<td>U1ERSTHS</td>
<td></td>
</tr>
<tr>
<td>U1ERSSHSHS</td>
<td></td>
</tr>
<tr>
<td>U1ERSE</td>
<td></td>
</tr>
<tr>
<td>U1RXATHS</td>
<td></td>
</tr>
<tr>
<td>U1RXCKE</td>
<td></td>
</tr>
<tr>
<td>U1RXDE[7:0]</td>
<td></td>
</tr>
<tr>
<td>U1RXDHS[15:0]</td>
<td></td>
</tr>
<tr>
<td>U1RXDTE</td>
<td></td>
</tr>
<tr>
<td>U1RXSKS</td>
<td></td>
</tr>
<tr>
<td>U1RXSK</td>
<td></td>
</tr>
<tr>
<td>U1RXSHS[3:0]</td>
<td></td>
</tr>
<tr>
<td>U1RE0D</td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>----------------</td>
<td>-------------</td>
</tr>
<tr>
<td>U1RE1CN</td>
<td></td>
</tr>
<tr>
<td>U1RE2D</td>
<td></td>
</tr>
<tr>
<td>U1RE3N</td>
<td></td>
</tr>
<tr>
<td>U1RXUPSE</td>
<td></td>
</tr>
<tr>
<td>U1RXVDE</td>
<td></td>
</tr>
<tr>
<td>U1RXVDHS[3:0]</td>
<td></td>
</tr>
<tr>
<td>U1SSTT</td>
<td></td>
</tr>
<tr>
<td>U1TXRYE</td>
<td></td>
</tr>
<tr>
<td>U1TXRY</td>
<td></td>
</tr>
<tr>
<td>U1TXRYSK</td>
<td></td>
</tr>
<tr>
<td>U1USAN</td>
<td></td>
</tr>
<tr>
<td>U2DIR</td>
<td></td>
</tr>
<tr>
<td>U2ERCLP0</td>
<td></td>
</tr>
<tr>
<td>U2ERCLP1</td>
<td></td>
</tr>
<tr>
<td>U2ERCTRL</td>
<td></td>
</tr>
<tr>
<td>U2ERE</td>
<td></td>
</tr>
<tr>
<td>U2ERSTHS</td>
<td></td>
</tr>
<tr>
<td>U2ERSSHS</td>
<td></td>
</tr>
<tr>
<td>U2ERSE</td>
<td></td>
</tr>
<tr>
<td>U2RXACHS</td>
<td></td>
</tr>
<tr>
<td>U2RXCKE</td>
<td></td>
</tr>
<tr>
<td>U2RXDE[7:0]</td>
<td></td>
</tr>
<tr>
<td>U2RXDHS[15:0]</td>
<td></td>
</tr>
<tr>
<td>U2RPDTE</td>
<td></td>
</tr>
<tr>
<td>U2RXSK</td>
<td></td>
</tr>
<tr>
<td>U2RXSKC</td>
<td></td>
</tr>
<tr>
<td>U2RXSHS[3:0]</td>
<td></td>
</tr>
<tr>
<td>U2RE0D2</td>
<td></td>
</tr>
<tr>
<td>U2RE1D2</td>
<td></td>
</tr>
<tr>
<td>U2RE2D3</td>
<td></td>
</tr>
<tr>
<td>U2RE3D3</td>
<td></td>
</tr>
<tr>
<td>U2RXUPSE</td>
<td></td>
</tr>
</tbody>
</table>
# Table 76: Output Ports (Continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>U2RXVDE</td>
<td></td>
</tr>
<tr>
<td>U2RXVDHS[3:0]</td>
<td></td>
</tr>
<tr>
<td>U2SSSTT</td>
<td></td>
</tr>
<tr>
<td>U2TXRYE</td>
<td></td>
</tr>
<tr>
<td>U2TXRYH</td>
<td></td>
</tr>
<tr>
<td>U2TXRYSK</td>
<td></td>
</tr>
<tr>
<td>U2USAN</td>
<td></td>
</tr>
<tr>
<td>U3DIR</td>
<td></td>
</tr>
<tr>
<td>U3ERCLP0</td>
<td></td>
</tr>
<tr>
<td>U3ERCLP1</td>
<td></td>
</tr>
<tr>
<td>U3ERCTRL</td>
<td></td>
</tr>
<tr>
<td>U3ERE</td>
<td></td>
</tr>
<tr>
<td>U3ERSTHS</td>
<td></td>
</tr>
<tr>
<td>U3ERSSSHS</td>
<td></td>
</tr>
<tr>
<td>U3ERSE</td>
<td></td>
</tr>
<tr>
<td>U3RXATHS</td>
<td></td>
</tr>
<tr>
<td>U3RXCKE</td>
<td></td>
</tr>
<tr>
<td>U3RXDE[7:0]</td>
<td></td>
</tr>
<tr>
<td>U3RXDHS[15:0]</td>
<td></td>
</tr>
<tr>
<td>U3RPDTE</td>
<td></td>
</tr>
<tr>
<td>U3RXSK</td>
<td></td>
</tr>
<tr>
<td>U3RXSKC</td>
<td></td>
</tr>
<tr>
<td>U3RXSHS[3:0]</td>
<td></td>
</tr>
<tr>
<td>U3RE0CK</td>
<td></td>
</tr>
<tr>
<td>U3RE1CK</td>
<td></td>
</tr>
<tr>
<td>U3RE2</td>
<td></td>
</tr>
<tr>
<td>U3RE3</td>
<td></td>
</tr>
<tr>
<td>U3RXUPSE</td>
<td></td>
</tr>
<tr>
<td>U3RXVDE</td>
<td></td>
</tr>
<tr>
<td>U3RXVDHS[3:0]</td>
<td></td>
</tr>
<tr>
<td>U3SSTT</td>
<td></td>
</tr>
<tr>
<td>U3TXRY</td>
<td></td>
</tr>
</tbody>
</table>
### Table 76: Output Ports (Continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>U3TXRYHS</td>
<td></td>
</tr>
<tr>
<td>U3TXRYSK</td>
<td></td>
</tr>
<tr>
<td>U3USAN</td>
<td></td>
</tr>
<tr>
<td>UCRXCKAT</td>
<td></td>
</tr>
<tr>
<td>UCRXUCKN</td>
<td></td>
</tr>
<tr>
<td>UCSSTT</td>
<td></td>
</tr>
<tr>
<td>UCUSAN</td>
<td></td>
</tr>
<tr>
<td>URWDCKHS</td>
<td></td>
</tr>
<tr>
<td>UTWDCKHS</td>
<td></td>
</tr>
<tr>
<td>UCRXWCHS</td>
<td></td>
</tr>
<tr>
<td>CLKLBACT</td>
<td></td>
</tr>
</tbody>
</table>

### Table 77: Bidirectional Ports

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CKN</td>
<td></td>
</tr>
<tr>
<td>CKP</td>
<td></td>
</tr>
<tr>
<td>DN0</td>
<td></td>
</tr>
<tr>
<td>DN1</td>
<td></td>
</tr>
<tr>
<td>DN2</td>
<td></td>
</tr>
<tr>
<td>DN3</td>
<td></td>
</tr>
<tr>
<td>DP0</td>
<td></td>
</tr>
<tr>
<td>DP1</td>
<td></td>
</tr>
<tr>
<td>DP2</td>
<td></td>
</tr>
<tr>
<td>DP3</td>
<td></td>
</tr>
</tbody>
</table>

### Table 78: Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>GSR</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;DISABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>AUTO_PD_EN</td>
<td>&quot;POWERED_UP&quot; (default)</td>
<td>Powers down inactive lanes reported by CFG_NUM_LANES input bus</td>
</tr>
<tr>
<td></td>
<td>&quot;POWERED_DOWN&quot;</td>
<td></td>
</tr>
<tr>
<td>CFG_NUM_LANES</td>
<td>&quot;ONE_LANE&quot; (default)</td>
<td>Sets the number of active lanes</td>
</tr>
<tr>
<td></td>
<td>&quot;TWO_LANES&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;THREE_LANES&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;FOUR_LANES&quot;</td>
<td></td>
</tr>
</tbody>
</table>
### Table 78: Parameters (Continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CM</td>
<td>0'b00000000 (default)</td>
<td>PLL dividers should be set to produce the required high speed BITCLK to be used for testing</td>
</tr>
<tr>
<td>CN</td>
<td>0'b00000 (default)</td>
<td>PLL dividers should be set to produce the required high speed BITCLK to be used for testing</td>
</tr>
<tr>
<td>CO</td>
<td>0'b000 (default)</td>
<td>PLL dividers should be set to produce the required high speed BITCLK to be used for testing</td>
</tr>
<tr>
<td>CONT_CLK_MODE</td>
<td>&quot;DISABLED&quot; (default)</td>
<td>This static input pin enables the slave clock lane feature to maintain HS reception state during continuous clock mode operation, despite line glitches</td>
</tr>
<tr>
<td>DESKEW_EN</td>
<td>&quot;DISABLED&quot; (default)</td>
<td>Enables Deskew feature that modifies ERRSYNC/NOSYNC behavior</td>
</tr>
<tr>
<td>DSI_CSI</td>
<td>&quot;CSI2_APP&quot; (default)</td>
<td>Selects the PHY IP Application</td>
</tr>
<tr>
<td>EN_CIL</td>
<td>&quot;CIL_ENABLED&quot; (default)</td>
<td>This signal should start with 1b1 then move to 1b0 to reset internal registers when in CIL Bypass mode</td>
</tr>
<tr>
<td>HSEL</td>
<td>&quot;DISABLED&quot; (default)</td>
<td>High Speed Select</td>
</tr>
<tr>
<td>LANE0_SEL</td>
<td>&quot;LANE_0&quot; (default)</td>
<td>This input determines which lane will act as data lane0 in HS Operation mode</td>
</tr>
<tr>
<td>LOCK_BYP</td>
<td>&quot;GATE_TXBYTECLKHS&quot; (default)</td>
<td>When clock lane exits from ULPS, this input determines if the PLL LOCK signal will be used to gate the TxByteClkHS</td>
</tr>
<tr>
<td>MASTER_SLAVE</td>
<td>&quot;SLAVE&quot; (default)</td>
<td>Should be set to 1 for HS-TX and LP-TX Tests and set to 0 for remaining tests</td>
</tr>
<tr>
<td>PLLCLKBYPASS</td>
<td>&quot;REGISTERED&quot; (default)</td>
<td>PLL Clock bypass</td>
</tr>
<tr>
<td>RSEL</td>
<td>0'b00 (default)</td>
<td></td>
</tr>
<tr>
<td>RXCDRP</td>
<td>0'b000 (default)</td>
<td>On-chip termination control bits for manual calibration of HS-RX</td>
</tr>
<tr>
<td>RXDATAWIDTHHHS</td>
<td>0'b000 (default)</td>
<td>One-time programming bits that adjust the threshold voltage of LP-CD default setting 2b01</td>
</tr>
<tr>
<td>RXLPRP</td>
<td>0'b000 (default)</td>
<td>High-Speed Receive Data Width Select</td>
</tr>
<tr>
<td>TEST_ENBL</td>
<td>0'b000000 (default)</td>
<td>Enable TEST_PATTERN</td>
</tr>
<tr>
<td>TEST_PATTERN</td>
<td>0'b00000000000000000000000000000000000000000 (default)</td>
<td>32-bit BIST pattern to check loopback.</td>
</tr>
</tbody>
</table>
Table 78: Parameters (Continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>TST</td>
<td>0'b1001 (default) 0000</td>
<td>PLL charge pump current control</td>
</tr>
<tr>
<td>TXDATAWIDTHHS</td>
<td>0'b00 (default)</td>
<td>High-Speed Transmit Data Width Select</td>
</tr>
<tr>
<td>U_PRG_HS_PREPARE</td>
<td>0'b00 (default)</td>
<td>Bits used to program T_HS_PREPARE time in the beginning of high speed transmission mode</td>
</tr>
<tr>
<td>U_PRG_HS_TRAIL</td>
<td>0'b000000 (default)</td>
<td>Bits used to program T_HS_TRAIL time in the end of high speed transmission mode</td>
</tr>
<tr>
<td>U_PRG_HS_ZERO</td>
<td>0'b000000 (default)</td>
<td>Bits used to program T_HS_ZERO time in the beginning of high speed transmission mode</td>
</tr>
<tr>
<td>U_PRG_RXHS_SETTLE</td>
<td>0'b000000 (default)</td>
<td>Bits used to program T_HS_SETTLE. HS-RX waits for Time-out T_HS_SETTLE in order to neglect transition effects</td>
</tr>
<tr>
<td>UC_PRG_HS_PREPARE</td>
<td>&quot;1P0_TXCLKESC&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>UC_PRG_HS_TRAIL</td>
<td>0'b000000 (default)</td>
<td></td>
</tr>
<tr>
<td>UC_PRG_HS_ZERO</td>
<td>0'b0000000 (default)</td>
<td></td>
</tr>
<tr>
<td>UC_PRG_RXHS_SETTLE</td>
<td>0'b0000000 (default)</td>
<td></td>
</tr>
</tbody>
</table>

**DPR16X4**

Distributed Pseudo Dual Port RAM with Synchronous Write and Asynchronous Read

Architectures supported:
- LFD2NX
- LIFCL

Table 79: Input Ports

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>D[3:0]</td>
<td>Data in</td>
</tr>
<tr>
<td>WAD[3:0]</td>
<td>Write address</td>
</tr>
<tr>
<td>WCK</td>
<td>Write clock</td>
</tr>
<tr>
<td>WRE</td>
<td>Write enable</td>
</tr>
<tr>
<td>RAD[3:0]</td>
<td>Read address</td>
</tr>
</tbody>
</table>
For the output to be Data = Address (Address 0 = Data 0 and so on), the INIT must be:

INIT = 0xFF00F0F0CCCCAAAA

LUT3.INIT = "FF00"

LUT2.INIT = "F0F0"

LUT1.INIT = "CCCC"

LUT0.INIT = "AAAA"
DPSC512K
512Kb Single Clock Dual Port Block RAM

Architectures supported:
▶ LFD2NX
▶ LIFCL

Table 83: Input Ports

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DIA[31:0]</td>
<td>Port A data in</td>
</tr>
<tr>
<td>DIB[31:0]</td>
<td>Port B data in</td>
</tr>
<tr>
<td>ADA[13:0]</td>
<td>Port A address</td>
</tr>
<tr>
<td>ADB[13:0]</td>
<td>Port B address</td>
</tr>
<tr>
<td>CLK</td>
<td>Clock</td>
</tr>
<tr>
<td>CEA</td>
<td>Port A clock enable</td>
</tr>
<tr>
<td>CEB</td>
<td>Port B clock enable</td>
</tr>
<tr>
<td>WEA</td>
<td>Port A write enable</td>
</tr>
<tr>
<td>WEB</td>
<td>Port A write enable</td>
</tr>
<tr>
<td>CSA</td>
<td>Port A chip select</td>
</tr>
<tr>
<td>CSB</td>
<td>Port B chip select</td>
</tr>
<tr>
<td>RSTA</td>
<td>Port A output register reset</td>
</tr>
<tr>
<td>RSTB</td>
<td>Port B output register reset</td>
</tr>
<tr>
<td>BENA_N[3:0]</td>
<td>Write byte enable, 0=write 1=disable. BENA_N[3] corresponds to the MSB of DI, BENA_N[0] corresponds to the LSB</td>
</tr>
<tr>
<td>BENB_N[3:0]</td>
<td>Write byte enable, 0=write 1=disable. BENB_N[3] corresponds to the MSB of DI, BENB_N[0] corresponds to the LSB</td>
</tr>
<tr>
<td>CEOUTA</td>
<td>Port A output register clock enable</td>
</tr>
<tr>
<td>CEOUTB</td>
<td>Port B output register clock enable</td>
</tr>
</tbody>
</table>

Table 84: Output Ports

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DOA[31:0]</td>
<td>Port A data out</td>
</tr>
<tr>
<td>DOB[31:0]</td>
<td>Port B data out</td>
</tr>
</tbody>
</table>
All inputs (except the register control signals) and all outputs are registered in the following manner:

**Table 84: Output Ports (Continued)**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ERRDECA[1:0]</td>
<td>Port A one and two bit error flag</td>
</tr>
<tr>
<td>ERRDECB[1:0]</td>
<td>Port B one and two bit error flag</td>
</tr>
</tbody>
</table>

**Table 85: Parameters**

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>OUTREG_A</td>
<td>&quot;NO_REG&quot; <em>(default)</em>, &quot;OUT_REG&quot;</td>
<td>Register output A</td>
</tr>
<tr>
<td>OUTREG_B</td>
<td>&quot;NO_REG&quot; <em>(default)</em>, &quot;OUT_REG&quot;</td>
<td>Register output B</td>
</tr>
<tr>
<td>GSR</td>
<td>&quot;ENABLED&quot; <em>(default)</em>, &quot;DISABLED&quot;</td>
<td>Enable global set/reset</td>
</tr>
<tr>
<td>RESETMODE</td>
<td>&quot;SYNC&quot; <em>(default)</em>, &quot;ASYNC&quot;</td>
<td>Reset async/sync control</td>
</tr>
<tr>
<td>INITVAL_00...INITVAL_7F</td>
<td>Hex string, 1280 bits</td>
<td>LRAM initialization data</td>
</tr>
<tr>
<td>ASYNC_RESET_RELEASE</td>
<td>&quot;SYNC&quot; <em>(default)</em>, &quot;ASYNC&quot;</td>
<td>Reset release async/sync</td>
</tr>
<tr>
<td>ECC_BYTE_SEL</td>
<td>&quot;ECC_EN&quot; <em>(default)</em>, &quot;BYTE_EN&quot;</td>
<td>Enable ECC or Byte-enable support</td>
</tr>
</tbody>
</table>

All inputs (except the register control signals) and all outputs are registered in the following manner:

**DQSBUF**

Architectures supported:

- LFD2NX
- LIFCL
### Table 86: Input Ports

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DQSI</td>
<td></td>
</tr>
<tr>
<td>PAUSE</td>
<td></td>
</tr>
<tr>
<td>RDCCLKSEL[3:0]</td>
<td></td>
</tr>
<tr>
<td>RDDIR</td>
<td></td>
</tr>
<tr>
<td>RDLOADN</td>
<td></td>
</tr>
<tr>
<td>READ[3:0]</td>
<td></td>
</tr>
<tr>
<td>READMOVE</td>
<td></td>
</tr>
<tr>
<td>RST</td>
<td></td>
</tr>
<tr>
<td>SCLK</td>
<td></td>
</tr>
<tr>
<td>SELCLK</td>
<td></td>
</tr>
<tr>
<td>WRDIR</td>
<td></td>
</tr>
<tr>
<td>WRLOAD_N</td>
<td></td>
</tr>
<tr>
<td>WRLVDIR</td>
<td></td>
</tr>
<tr>
<td>WRLVLOAD_N</td>
<td></td>
</tr>
<tr>
<td>WRLVMOVE</td>
<td></td>
</tr>
<tr>
<td>WRMOVE</td>
<td></td>
</tr>
<tr>
<td>ECLKIN</td>
<td></td>
</tr>
<tr>
<td>RSTMTCN</td>
<td></td>
</tr>
<tr>
<td>DLLCODE[8:0]</td>
<td></td>
</tr>
</tbody>
</table>

### Table 87: Output Ports

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>BTDETECT</td>
<td></td>
</tr>
<tr>
<td>BURSTDETECT</td>
<td></td>
</tr>
<tr>
<td>DATAVALID</td>
<td></td>
</tr>
<tr>
<td>DQSW</td>
<td></td>
</tr>
<tr>
<td>DQSWRD</td>
<td></td>
</tr>
<tr>
<td>RDPNTR[2:0]</td>
<td></td>
</tr>
<tr>
<td>READCOUT</td>
<td></td>
</tr>
<tr>
<td>DQSR90</td>
<td></td>
</tr>
<tr>
<td>DQSW270</td>
<td></td>
</tr>
</tbody>
</table>
### Table 87: Output Ports (Continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>WRCOUT</td>
<td></td>
</tr>
<tr>
<td>WRLVCOUT</td>
<td></td>
</tr>
<tr>
<td>WRPNTR[2:0]</td>
<td></td>
</tr>
</tbody>
</table>

### Table 88: Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>GSR</td>
<td>&quot;ENABLED&quot; (default)</td>
<td>GSRN signal enable/disable select</td>
</tr>
<tr>
<td></td>
<td>&quot;DISABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>ENABLE_FIFO</td>
<td>&quot;DISABLED&quot; (default)</td>
<td>Enable FIFO control</td>
</tr>
<tr>
<td></td>
<td>&quot;ENABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>FORCE_READ</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;ENABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>FREE_WHEEL</td>
<td>&quot;DDR&quot; (default)</td>
<td>FIFO mode select</td>
</tr>
<tr>
<td></td>
<td>&quot;GDDR&quot;</td>
<td></td>
</tr>
<tr>
<td>MODX</td>
<td>&quot;NOT_USED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;MDDRX2_WL_DDR2&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;MDDRX2_WL_DDR3&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;MDDRX4_WL_DDR3&quot;</td>
<td></td>
</tr>
<tr>
<td>MT_EN_READ</td>
<td>&quot;DISABLED&quot; (default)</td>
<td>0 - Disable margin test for READ mode</td>
</tr>
<tr>
<td></td>
<td>&quot;ENABLED&quot;</td>
<td>1 - Enable</td>
</tr>
<tr>
<td>MT_EN_WRITE</td>
<td>&quot;DISABLED&quot; (default)</td>
<td>0 - Disable margin test for WRITE mode</td>
</tr>
<tr>
<td></td>
<td>&quot;ENABLED&quot;</td>
<td>1 - Enable</td>
</tr>
<tr>
<td>MT_EN_WRITE_LEVELING</td>
<td>&quot;DISABLED&quot; (default)</td>
<td>0 - Disable margin test for WRITE LEVELING mode</td>
</tr>
<tr>
<td></td>
<td>&quot;ENABLED&quot;</td>
<td>1 - Enable</td>
</tr>
<tr>
<td>RD_PNTR</td>
<td>0'b000 (default)</td>
<td>FIFO control READ pointer (3-bits) to FIFO in PIC (through each tree to IOL)</td>
</tr>
<tr>
<td>READ_ENABLE</td>
<td>&quot;DISABLED&quot; (default)</td>
<td>DQS delay enable for read</td>
</tr>
<tr>
<td></td>
<td>&quot;ENABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>RX_CENTERED</td>
<td>&quot;ENABLED&quot; (default)</td>
<td>For GDDR-DQS RX Centered mode</td>
</tr>
<tr>
<td></td>
<td>&quot;DISABLED&quot;</td>
<td>[delay code = 0]</td>
</tr>
<tr>
<td>Name</td>
<td>Values</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------</td>
<td>----------------------------</td>
<td>------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>S_READ</td>
<td>0 <em>(default)</em></td>
<td>Offset for READ slave delay adjustment. For example:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>S_WRITE</td>
<td>000000000 <em>(default)</em></td>
<td>Offset for WRITE slave delay adjustment. For example:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>SIGN_READ</td>
<td>&quot;POSITIVE&quot; <em>(default)</em></td>
<td>Sign bit for READ slave delay adjustment.</td>
</tr>
<tr>
<td></td>
<td>&quot;COMPLEMENT&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>SIGN_WRITE</td>
<td>&quot;POSITIVE&quot; <em>(default)</em></td>
<td>Sign bit for WRITE slave delay adjustment.</td>
</tr>
<tr>
<td></td>
<td>&quot;COMPLEMENT&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>UPDATE_QU</td>
<td>&quot;UP1_AND_UP0SAME&quot; <em>(default)</em></td>
<td>Update 0/1 timing relationship control adjustment.</td>
</tr>
<tr>
<td></td>
<td>&quot;UP1_AHEAD_OF_UP0&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>WRITE_ENABLE</td>
<td>&quot;DISABLED&quot; <em>(default)</em></td>
<td>DQS delay enable for write</td>
</tr>
<tr>
<td></td>
<td>&quot;ENABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>SEL_READ_BIT_ENABLE_CYCLES</td>
<td>&quot;NORMAL&quot; <em>(default)</em></td>
<td>Used to select the cycle latency for the read enable signal generated by the read[3:0] bits and read_clk_sel[3:0].</td>
</tr>
<tr>
<td></td>
<td>&quot;DELAYED_0P5_ECLK&quot;</td>
<td></td>
</tr>
<tr>
<td>BYPASS_WR_LEVEL_SMTH_LATCH</td>
<td>&quot;SMOOTHING_PATH&quot; <em>(default)</em></td>
<td>1b0: Select the write leveling smoothing path</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS_PATH&quot;</td>
<td></td>
</tr>
</tbody>
</table>
To support DDR memory interfaces (DDR2/3, LPDDR2/3), the DQS strobe signal from the memory must be used to capture the data (DQ) in the PIC registers during memory reads.

**EBR_B**
4 Kb pseudo-dual port block ram with configurable write/read width and optional bitstream initialization.

Architectures supported:

- iCE40 UltraPlus

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>BYPASS_WR_SMTH_LATCH</td>
<td>&quot;SMOOTHING_PATH&quot; (default)</td>
<td>1b0: Select the write smoothing path</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS_PATH&quot;</td>
<td>1b1: Select the write smoothing bypass path, counter control based on Sapphire</td>
</tr>
<tr>
<td>BYPASS_READ_SMTH_LATCH</td>
<td>&quot;SMOOTHING_PATH&quot; (default)</td>
<td>1b0: Select the read smoothing path</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS_PATH&quot;</td>
<td>1b1: Select the read smoothing bypass path, counter control based on Sapphire</td>
</tr>
</tbody>
</table>
### Table 89: Input Ports

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>RADDR10...RADDR0</td>
<td>Read address</td>
</tr>
<tr>
<td>WADDR10...WADDR0</td>
<td>Write address</td>
</tr>
<tr>
<td>MASK_N15...MASK_N0</td>
<td>Write mask</td>
</tr>
<tr>
<td>WDATA15...WDATA0</td>
<td>Write data</td>
</tr>
<tr>
<td>RCLKE</td>
<td>Read clock enable</td>
</tr>
<tr>
<td>RCLK</td>
<td>Read clock</td>
</tr>
<tr>
<td>RE</td>
<td>Read enable</td>
</tr>
<tr>
<td>WCLKE</td>
<td>Write clock enable</td>
</tr>
<tr>
<td>WCLK</td>
<td>Write clock</td>
</tr>
<tr>
<td>WE</td>
<td>Write enable</td>
</tr>
</tbody>
</table>

### Table 90: Output Ports

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>RDATA15...RDATA0</td>
<td>Read data</td>
</tr>
</tbody>
</table>

### Table 91: Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>INIT_0</td>
<td>&quot;0x0000000000000000000000000000000000000000000000000000000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>INIT_1</td>
<td>&quot;0x0000000000000000000000000000000000000000000000000000000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>INIT_2</td>
<td>&quot;0x0000000000000000000000000000000000000000000000000000000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>INIT_3</td>
<td>&quot;0x0000000000000000000000000000000000000000000000000000000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>INIT_4</td>
<td>&quot;0x0000000000000000000000000000000000000000000000000000000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>INIT_5</td>
<td>&quot;0x0000000000000000000000000000000000000000000000000000000000000000&quot; (default)</td>
<td></td>
</tr>
</tbody>
</table>
Table 91: Parameters (Continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>INIT_6</td>
<td>&quot;0x0000000000000000000000000000000000000000000000000000000000000000 (default)</td>
<td></td>
</tr>
<tr>
<td>INIT_7</td>
<td>&quot;0x0000000000000000000000000000000000000000000000000000000000000000 (default)</td>
<td></td>
</tr>
<tr>
<td>INIT_8</td>
<td>&quot;0x0000000000000000000000000000000000000000000000000000000000000000 (default)</td>
<td></td>
</tr>
<tr>
<td>INIT_9</td>
<td>&quot;0x0000000000000000000000000000000000000000000000000000000000000000 (default)</td>
<td></td>
</tr>
<tr>
<td>INIT_A</td>
<td>&quot;0x0000000000000000000000000000000000000000000000000000000000000000 (default)</td>
<td></td>
</tr>
<tr>
<td>INIT_B</td>
<td>&quot;0x0000000000000000000000000000000000000000000000000000000000000000 (default)</td>
<td></td>
</tr>
<tr>
<td>INIT_C</td>
<td>&quot;0x0000000000000000000000000000000000000000000000000000000000000000 (default)</td>
<td></td>
</tr>
<tr>
<td>INIT_D</td>
<td>&quot;0x0000000000000000000000000000000000000000000000000000000000000000 (default)</td>
<td></td>
</tr>
<tr>
<td>INIT_E</td>
<td>&quot;0x0000000000000000000000000000000000000000000000000000000000000000 (default)</td>
<td></td>
</tr>
<tr>
<td>INIT_F</td>
<td>&quot;0x0000000000000000000000000000000000000000000000000000000000000000 (default)</td>
<td></td>
</tr>
<tr>
<td>DATA_WIDTH_W</td>
<td>&quot;2&quot; (default), &quot;4&quot;, &quot;8&quot;, &quot;16&quot;</td>
<td>Write data width in bits.</td>
</tr>
<tr>
<td>DATA_WIDTH_R</td>
<td>&quot;2&quot; (default), &quot;4&quot;, &quot;8&quot;, &quot;16&quot;</td>
<td>Read data width in bits.</td>
</tr>
</tbody>
</table>

Same as SB_RAM4K.

**ECLKDIV**

Wrapper for Clock Divider for Edge Clock

Architectures supported:

- LFD2NX
- LIFCL
**ECLKSYNC**

Wrapper for Clock Synchronizer for Edge Clock

Architectures supported:
- LFD2NX
- LIFCL
**FA2**

Carry chain 2-bit full adder

Architectures supported:
- iCE40 UltraPlus

---

**Table 95: Input Ports**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ECLKIN</td>
<td></td>
</tr>
<tr>
<td>STOP</td>
<td></td>
</tr>
</tbody>
</table>

**Table 96: Output Ports**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ECLKOUT</td>
<td></td>
</tr>
</tbody>
</table>

**Table 97: Parameters**

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>STOP_EN</td>
<td>&quot;DISABLE&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;ENABLE&quot;</td>
<td></td>
</tr>
</tbody>
</table>

**Table 98: Input Ports**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>A0</td>
<td>Non-operand A bit 0</td>
</tr>
<tr>
<td>B0</td>
<td>Operand B bit 0</td>
</tr>
<tr>
<td>C0</td>
<td>Operand C bit 0</td>
</tr>
<tr>
<td>D0</td>
<td>Operand D bit 0</td>
</tr>
<tr>
<td>CI0</td>
<td>Carry-in 0</td>
</tr>
<tr>
<td>A1</td>
<td>Non-operand A bit 1</td>
</tr>
<tr>
<td>B1</td>
<td>Operand B bit 1</td>
</tr>
<tr>
<td>C1</td>
<td>Operand C bit 1</td>
</tr>
<tr>
<td>D1</td>
<td>Operand D bit 1</td>
</tr>
<tr>
<td>CI1</td>
<td>Carry-in 1</td>
</tr>
</tbody>
</table>
### Table 99: Output Ports

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CO0</td>
<td>Carry-out 0</td>
</tr>
<tr>
<td>CO1</td>
<td>Carry-out 1</td>
</tr>
<tr>
<td>S0</td>
<td>Output bit 0 of the sum</td>
</tr>
<tr>
<td>S1</td>
<td>Output bit 1 of the sum</td>
</tr>
</tbody>
</table>

### Table 100: Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>INIT0</td>
<td>&quot;0xc33c&quot; (default)</td>
<td>Hexadecimal value.</td>
</tr>
<tr>
<td>INIT1</td>
<td>&quot;0xc33c&quot; (default)</td>
<td>Hexadecimal value.</td>
</tr>
</tbody>
</table>

### Table 101: Truth Table

<table>
<thead>
<tr>
<th>Inputs</th>
<th>Outputs</th>
</tr>
</thead>
<tbody>
<tr>
<td>B1</td>
<td>C1</td>
</tr>
<tr>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
</tr>
</tbody>
</table>

Lattice Radiant Software 2.2 Help 715
Note: In the Truth Table, ports A0 and A1 are tied low or are unconnected.

Rules and restrictions:

- Carry-out (CO0, CO1) can only go to D input of LUT above it or next (CI0, CI1).

- To drive VHI to the first carry-in, CI0, do not tie CI0 to 1 or VHI. Instead, leave it dangling. Bitgen will ensure that CI0 will correctly be VHI as expected.

- To drive VLO to the first carry-in, CI0 should be left dangling and half a FA2 must be used. This is done by grounding B0 and C0 and leaving D0 floating. This will ensure that CI1 will correctly be VLO as expected and the second half of FA2 can be used normally.

- If you want to bring out last carry-out (CO0, CO1) to fabric, simply connect the carry-out to whatever is your fabric logic. Map and Placer will work to insert a LUT and place it in the appropriate location automatically (thus ensuring the first rule is followed).
See Figure 1, Figure 2, and Figure 3, below, that take into account the above rules. The examples below do not make use of the A0 or A1 ports as they are not needed for 2-bit full-adder functionality.

**Figure 1: Burning Half an FA2 for Carry-Chain**

FA2 counter_12_add_4_1 (  
  .B0(GND_net), .C0(GND_net),  
  .B1(VCC_net), .C1(out_c_0),  
  .D1(n192), .CI1(n192),  
  .CO0(n192), .CO1(n78),  
  .S1(n45)  
);  

FA2 counter_12_add_4_9 (  
  .B0(GND_net), .C0(out_c_7),  
  .D0(n84), .CI0(n84),  
  .B1(GND_net), .C1(GND_net),  
  .D1(n204), .CI1(n204),  
  .CO0(n204), .S0(n38)  
);  

FA2 counter_12_add_4_7 (  
  .B0(GND_net), .C0(out_c_5),  
  .D0(n82), .CI0(n82),  
  .B1(GND_net), .C1(out_c_6),  
  .D1(n201), .CI1(n201),  
  .CO0(n201), .CO1(n84),  
  .S0(n40), .S1(n39)  
);  

FA2 counter_12_add_4_5 (  
  .B0(GND_net), .C0(out_c_3),  
  .D0(n80), .CI0(n80),  
  .B1(GND_net), .C1(out_c_4),  
  .D1(n198), .CI1(n198),  
  .CO0(n198), .CO1(n82),  
  .S0(n42), .S1(nn41)  
);  

FA2 counter_12_add_4_3 (  
  .B0(GND_net), .C0(out_c_1),  
  .D0(n78), .CI0(n78),  
  .B1(GND_net), .C1(out_c_2),  
  .D1(n195), .CI1(n195),  
  .CO0(n195), .CO1(n80),  
  .S0(n44), .S1(nn43)  
);
**Figure 2: Using LUT to Bring Last Carry Out**

```vhdl
FA2 counter_12_add_4_7 (  
  .B0(GND_net),  
  .C0(out_c_5),  
  .D0(n82),  
  .CI0(n82),  
  .B1(GND_net),  
  .C1(out_c_6),  
  .D1(n201),  
  .CI1(n201),  
  .CO0(n201),  
  .CO1(LAST_CARRY),  
  .S0(n40),  
  .S1(n39)  
);

LUT  lutInst(  
  .D(LAST_CARRY),  
  .F(CARRYOUT_TO_FABRIC)  
);  //eqn : F=D
```

**Figure 3: Using FA2 to Bring Last Carry Out**

```vhdl
FA2 counter_12_add_4_9 (  
  .B0(GND_net),  
  .C0(out_c_7),  
  .D0(n84),  
  .CI0(n84),  
  .B1(GND_net),  
  .C1(GND_net),  
  .S1(CARRYOUT_TO_FABRIC),  
  .D1(lastCarryOut),  
  .CI1(lastCarryOut),  
  .CO0(lastCarryOut),  
  .S0(n38)  
);
```

**FD1P3BX**

Positive-Edge-Triggered D Flip-Flop with Positive-Level Enable and Positive-Level Asynchronous Preset

Architectures supported:

- LFD2NX
- LIFCL
Table 102: Input Ports

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>D</td>
<td>Data in</td>
</tr>
<tr>
<td>SP</td>
<td>Clock enable</td>
</tr>
<tr>
<td>CK</td>
<td>Clock</td>
</tr>
<tr>
<td>PD</td>
<td>Preset</td>
</tr>
</tbody>
</table>

Table 103: Output Ports

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Q</td>
<td>Data out</td>
</tr>
</tbody>
</table>

Table 104: Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>GSR</td>
<td>&quot;ENABLED&quot; (default)</td>
<td>Enable global set/reset</td>
</tr>
<tr>
<td></td>
<td>&quot;DISABLED&quot;</td>
<td></td>
</tr>
</tbody>
</table>

Table 105: Truth Table

<table>
<thead>
<tr>
<th>Inputs</th>
<th>Output</th>
</tr>
</thead>
<tbody>
<tr>
<td>D</td>
<td>SP</td>
</tr>
<tr>
<td>X</td>
<td>0</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
</tr>
</tbody>
</table>

X = Don’t care

When GSR = 0, Q = 1 (D = SP = CK = PD = X)

**FD1P3BZ**

Positive-Edge-Triggered D Flip-Flop with Positive-Level Enable and Positive-Level Asynchronous Preset

Architectures supported:

- iCE40 UltraPlus
### Table 106: Input Ports

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>D</td>
<td>Data in</td>
</tr>
<tr>
<td>CK</td>
<td>Clock</td>
</tr>
<tr>
<td>SP</td>
<td>Clock enable, active high</td>
</tr>
<tr>
<td>PD</td>
<td>Preset, active high</td>
</tr>
</tbody>
</table>

### Table 107: Output Ports

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Q</td>
<td>Data out</td>
</tr>
</tbody>
</table>

### Table 108: Truth Table

<table>
<thead>
<tr>
<th>Inputs</th>
<th>Output</th>
</tr>
</thead>
<tbody>
<tr>
<td>D</td>
<td>SP</td>
</tr>
<tr>
<td>X</td>
<td>0</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
</tr>
</tbody>
</table>

X = Don't care

**FD1P3DX**

Positive-Edge-Triggered D Flip-Flop with Positive-Level Enable and Positive-Level Asynchronous Clear

Architectures supported:
- LFD2NX
- LIFCL
- FD1P3DX

**INPUTS:**
- D (Data in)
- SP (Clock enable)
- CK (Clock)
- CD (Clear)

**OUTPUT:**
- Q (Data out)

**Table 109: FD1P3DX Parameters**

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>GSR</td>
<td>ENABLED (default)</td>
<td>Enable global set/reset.</td>
</tr>
<tr>
<td></td>
<td>DISABLED</td>
<td></td>
</tr>
</tbody>
</table>

**Table 110: FD1P3DX Truth Table**

<table>
<thead>
<tr>
<th>Inputs</th>
<th>Output</th>
</tr>
</thead>
<tbody>
<tr>
<td>D</td>
<td>SP</td>
</tr>
<tr>
<td>X</td>
<td>0</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
</tr>
</tbody>
</table>

X = Don't care

When GSR = 0, Q = 0 (D = SP = CK = CD = X)

**FD1P3DZ**
Positive-Edge-Triggered D Flip-flop with Positive-Level Enable and Positive-Level Asynchronous Clear

Architectures supported:
- iCE40 UltraPlus

**FD1P3DZ**
**INPUTS:**
- D (Data in)
- CK (Clock)
- SP (Clock enable, active high)
- CD (Clear, active high)

**OUTPUTS:**
- Q (Data out)

### Table 111: FD1P3DZ Truth Table

<table>
<thead>
<tr>
<th>Inputs</th>
<th>Output</th>
</tr>
</thead>
<tbody>
<tr>
<td>D</td>
<td>SP</td>
</tr>
<tr>
<td>X</td>
<td>0</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
</tr>
</tbody>
</table>

X = Don't care

## FD1P3IX
Positive-Edge-Triggered D Flip-Flop with Positive-Level Synchronous Clear and Positive-Level Enable

Clear overrides enable.

### Architectures Supported:
- LFD2NX
- LIFCL

```
FD1P3IX
```

**INPUTS:**
- D (Data in)
- SP (Clock enable)
- CK (Clock)
- CD (Clear)
OUTPUT:
▶ Q (Data out)

Table 112: FD1P3IX Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>GSR</td>
<td>&quot;ENABLED&quot; (default) &quot;DISABLED&quot;</td>
<td>Enable global set/reset.</td>
</tr>
</tbody>
</table>

Table 113: FD1P3IX Truth Table

<table>
<thead>
<tr>
<th>Inputs</th>
<th>Output</th>
</tr>
</thead>
<tbody>
<tr>
<td>D</td>
<td>SP</td>
</tr>
<tr>
<td>X</td>
<td>0</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
</tr>
</tbody>
</table>

X = Don't care

When GSR = 0, Q = 0 (D = SP = CK = CD = X)

FD1P3IZ
Positive-Edge-Triggered D Flip-Flop with Positive-Level Synchronous Clear and Positive-Level Enable

Clear overrides enable.

Architectures Supported:
▶ iCE40 UltraPlus

FD1P3IZ

INPUTS:
Alphanumeric Primitives List

INPUTS:

- D (Data in)
- CK (Clock)
- SP (Clock enable, active high)
- CD (Clear, active high. Clock enable must be active to clear).

OUTPUTS:

- Q (Data out)

Table 114: FD1P3IZ Truth Table

<table>
<thead>
<tr>
<th>Inputs</th>
<th>Output</th>
</tr>
</thead>
<tbody>
<tr>
<td>D</td>
<td>SP</td>
</tr>
<tr>
<td>X</td>
<td>0</td>
</tr>
<tr>
<td>X</td>
<td>1</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
</tr>
</tbody>
</table>

X = Don't care

FD1P3JX
Positive-Edge-Triggered D Flip-Flop with Positive-Level Synchronous Preset and Positive-Level Enable

Preset overrides enable.

Architectures Supported:

- LFD2NX
- LIFCL

INPUTS:

- D (Data in)
- SP (Clock enable)
- CK (Clock)
- PD (Preset)

OUTPUT:
Q (Data out)

Table 115: FD1P3JX Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>GSR</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;DISABLED&quot;</td>
<td>Enable global set/reset</td>
</tr>
</tbody>
</table>

Table 116: FD1P3JX Truth Table

<table>
<thead>
<tr>
<th>Inputs</th>
<th>Output</th>
</tr>
</thead>
<tbody>
<tr>
<td>D</td>
<td>SP</td>
</tr>
<tr>
<td>X</td>
<td>0</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
</tr>
</tbody>
</table>

X = Don't care

When GSR = 0, Q = 1 (D = SP = CK = PD = X)

FD1P3JZ

Positive-Edge-triggered D Flip-flop with Positive-level Synchronous Preset and Positive-level Enable

Preset overrides enable.

Architectures Supported:

- iCE40 UltraPlus

FD1P3JZ

INPUTS:

- D (Data in)
- CK (Clock)
- SP (Clock enable, active high)
PD (Preset, active high. Clock enable must be active to preset).

OUTPUTS:
► Q (Data out)

**Table 117: FD1P3JZ Truth Table**

<table>
<thead>
<tr>
<th>Inputs</th>
<th>Output</th>
</tr>
</thead>
<tbody>
<tr>
<td>D</td>
<td>SP</td>
</tr>
<tr>
<td>X</td>
<td>0</td>
</tr>
<tr>
<td>X</td>
<td>1</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
</tr>
</tbody>
</table>

X = Don't care

**FD1P3XZ**

Positive-Edge-triggered D Flip-flop with Synchronous or Asynchronous Set/reset

Architectures Supported:
► iCE40 UltraPlus

**INPUTS:**
► D (Data in)
► SP (Clock enable, active high)
► SR (Set/reset, active high)
► CK (Clock)

**OUTPUTS:**
► Q (Data out)

**PARAMETERS:**
► REGSET: "RESET" (default), "SET"
► SRMODE: "CE_OVER_LSR" (default), "ASYNC"
FIFO16K

Architectures Supported:

- LFD2NX
- LIFCL

INPUTS:

- DI[35:0]: Input data.
- CLKW: Write clock. Active on the rising edge. Has polarity control.
- WE: Write enable. Active high. Has polarity control.
- FULLI: Write inhibit. Active high. Has polarity control.
- CSW[1:0]: Write cascade select. Active high. Has polarity control.
- RSTW: Write reset. Active high. Has polarity control.
- CLKR: Read clock. Active on the rising edge. Has polarity control.
- RE: Read enable. Active high. Has polarity control.
- EMPTYI: Read inhibit. Active high. Has polarity control.
- CSR[1:0]: Read cascade select. Active high. Has polarity control.
- RPRST: Read point reset. Active high. Has polarity control.

OUTPUTS:

- DO[35:0]: Output data.
- ONEBITERR: ECC error flag for a 1-bit error.
- TWOBITERR: ECC error flag for a 2-bit error.
- ALMOSTFULL: Almost full flag.
- FULL: Full flag.
- ALMOSTEMPTY: Almost empty flag.
- EMPTY: Empty flag.
PARAMETERS:
MC1 (EBR). Not inferable.

Table 118: FIFO16K Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DATA_WIDTH_W</td>
<td>&quot;X36&quot; (default)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;X32&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;X18&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;X9&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;X4&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;X2&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;X1&quot;</td>
<td></td>
</tr>
<tr>
<td>DATA_WIDTH_R</td>
<td>&quot;X36&quot; (default)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;X32&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;X18&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;X9&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;X4&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;X2&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;X1&quot;</td>
<td></td>
</tr>
<tr>
<td>OUTREG</td>
<td>&quot;BYPASSED&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>(default)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;USED&quot;</td>
<td></td>
</tr>
<tr>
<td>GSR</td>
<td>&quot;ENABLED&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>(default)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;DISABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>RESETMODE</td>
<td>&quot;SYNC&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>(default)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;ASYNC&quot;</td>
<td></td>
</tr>
<tr>
<td>ASYNC_RST_RELEASE</td>
<td>&quot;SYNC&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>(default)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;ASYNC&quot;</td>
<td></td>
</tr>
<tr>
<td>ECC</td>
<td>&quot;DISABLED&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>(default)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;ENABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>CSDECODE_W</td>
<td>00 (default)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>01</td>
<td></td>
</tr>
<tr>
<td></td>
<td>10</td>
<td></td>
</tr>
<tr>
<td></td>
<td>11</td>
<td></td>
</tr>
<tr>
<td>CSDECODE_R</td>
<td>00 (default)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>01</td>
<td></td>
</tr>
<tr>
<td></td>
<td>10</td>
<td></td>
</tr>
<tr>
<td></td>
<td>11</td>
<td></td>
</tr>
<tr>
<td>FULLBITS</td>
<td>1000000000000000 (default)</td>
<td>Specifies the FIFO size for FULL flag. By default, it is 18k.</td>
</tr>
<tr>
<td>ALMOST_FULL</td>
<td>000000000000000 (default)</td>
<td>The value must be less than FULLBITS.</td>
</tr>
<tr>
<td>ALMOST_EMPTY</td>
<td>000000000000000 (default)</td>
<td>The value must be greater than 0.</td>
</tr>
</tbody>
</table>
FILTER
Adds a 50ns delay to a signal

Architectures Supported:
- iCE40 UltraPlus

INPUTS:
- FILTERIN (Filter input)

OUTPUTS:
- FILTEROUT (Filter output)

FL1P3AZ
Positive Edge Triggered D Flip-Flop with 2 Input Data Mux, Data Select, and Positive Level Enable, GSR Used for Clear or Preset

Architectures Supported:
- LFD2NX
- LIFCL

INPUTS:
- D0 (Data in 0)
- D1 (Data in 1)
- SP (Clock enable)
- CK (Clock)
- SD (Data select)

OUTPUT:
- Q (Data out)

Table 119: FL1P3AZ Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>GSR</td>
<td>&quot;ENABLED&quot; (default)</td>
<td>Enable global set/reset</td>
</tr>
<tr>
<td></td>
<td>&quot;DISABLED&quot;</td>
<td></td>
</tr>
</tbody>
</table>
NOTES:

Data input D1 can only come from a LUT output.

Table 120: FL1P3AZ Truth Table

<table>
<thead>
<tr>
<th>Inputs</th>
<th>Output</th>
</tr>
</thead>
<tbody>
<tr>
<td>D0</td>
<td>D1</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>0</td>
<td>X</td>
</tr>
<tr>
<td>1</td>
<td>X</td>
</tr>
<tr>
<td>X</td>
<td>0</td>
</tr>
<tr>
<td>X</td>
<td>1</td>
</tr>
</tbody>
</table>

X = Don’t care

When GSR = 0, Q = D0 (D1 = SP = SD = CK = X)

**GSR**

Wrapper for Global Set/Reset

Architectures Supported:
- LFD2NX
- LIFCL

```
GSR
```

**INPUTS:**
- GSR_N
- CLK

Table 121: GSR Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SYNCMODE</td>
<td>&quot;ASYNC&quot; (default)</td>
<td>&quot;SYNC&quot;</td>
</tr>
</tbody>
</table>

**DESCRIPTION:**

GSR is used to reset or set all register elements in your design. The GSR component can be connected to a net from an input buffer or an internally
generated net. It is active LOW and when pulsed will set or reset all flip-flops, latches, registers, and counters to the same state as the local set or reset functionality. When input GSR is HIGH, the global signal is released at the positive edge of the clock (CLK) if SYNCMODE is SYNC; otherwise, the signal is released asynchronously.

It is not necessary to connect signals for GSR to any register elements explicitly. The function will be implicitly connected globally. The functionality of the GSR for sequential cells without a local set or reset are described in the appropriate primitive description.

**HSOSC**
High-frequency oscillator. Generates 48MHz nominal clock, +/- 10 percent, with user programmable divider. Can drive global clock network or fabric routing.

Architectures Supported:
- iCE40 UltraPlus

![HSOSC](image)

**INPUTS:**
- CLKFHPU (Power up the oscillator. After power up, output will be stable after 100 µs. Active high).
- CLKFHEN (Enable the clock output. Enable should be low for the 100-µs power-up period. Active high).

**OUTPUT:**
- CLKF (Oscillator output)

**PARAMETERS:**
- CLKF_DIV: "0'b00" (default), "0'b01", "0'b10", "0'b11" (Clock divider selection. 0'b00 = 48 MHz, 0'b01 = 24 MHz, 0'b10 = 12 MHz, 0'b11 = 6 MHz)

SAME AS: SB_HFOSC

**HSOSC1P8V**
High-frequency oscillator. Generates 48MHz nominal clock, +/- 10 percent, with user programmable divider. Can drive global clock network or fabric routing. For use when VPP_2V5 is connected to a voltage below 2.3V.
Architectures Supported:

- iCE40 UltraPlus

**HSOSC1P8V**

**INPUTS:**

- CLKHFPU (Power up the oscillator. After power up, output will be stable after 100 µs. Active high).
- CLKHFEN (Enable the clock output. Enable should be low for the 100-µs power up period. Active high).

**OUTPUTS:**

- CLKHF (Oscillator output)

**PARAMETERS:**

- CLKHF_DIV: "0'b00" (default), "0'b01", "0'b10", "0'b11" (Clock divider selection. 0'b00 = 48 MHz, 0'b01 = 24 MHz, 0'b10 = 12 MHz, 0'b11 = 6 MHz)

**HSOSC_CORE**

High-Frequency Oscillator

Generates 48MHz nominal clock, +/- 10 percent, with user-programmable divider. Can drive global clock network or fabric routing.

Architectures Supported:

- iCE40 UltraPlus

**INPUTS:**

- CLKHFPU (Power up the oscillator. After power up, output will be stable after 100us. Active high).
- CLKHFEN (Enable the clock output. Enable should be low for the 100us power up period. Active high).
TRIM9...TRIM0

OUTPUTS:
- CLKHF (Oscillator output)

PARAMETERS:
- CLKHF_DIV: "0'b00" (default), "0'b01", "0'b10", "0'b11" (Clock divider selection. 0'b00 = 48 MHz, 0'b01 = 24 MHz, 0'b10 = 12 MHz, 0'b11 = 6 MHz)
- FABRIC_TRIME: "DISABLE" (default), "ENABLE" (Trim bits source selection. ENABLE - Trim bits sourced from Fabric. DISABLE - Trim bits sourced from NVCM.)

I2C_B
Hard I2C interface

Architectures Supported:
- iCE40 UltraPlus

I2C_B

<table>
<thead>
<tr>
<th>INPUTS:</th>
<th>OUTPUTS:</th>
</tr>
</thead>
<tbody>
<tr>
<td>SBCLKI</td>
<td>SBDATO7...SBDATO0</td>
</tr>
<tr>
<td>SBRWI</td>
<td>SBACK0</td>
</tr>
<tr>
<td>SBSTBI</td>
<td>I2CIRQ</td>
</tr>
<tr>
<td>SBADRI7...SBADRI0</td>
<td>I2CWKUP</td>
</tr>
<tr>
<td>SBDATI7...SBDATI0</td>
<td>SCLO</td>
</tr>
<tr>
<td>SCLI</td>
<td>SCLOE</td>
</tr>
<tr>
<td>SDAI</td>
<td>SDAO</td>
</tr>
<tr>
<td>SDAI</td>
<td>SDAOE</td>
</tr>
</tbody>
</table>

INPUTS:
- SBCLKI (System clock input)
- SBRWI (System read/write input)
- SBSTBI (Strobe signal)
- SBADRI7...SBADRI0 (System bus control register address)
- SBDATI7...SBDATI0 (System data input)
- SCLI (Serial clock input)
- SDAI (Serial data input)

OUTPUTS:
- SBDATO7...SBDATO0 (System data output)
- SBACKO (System acknowledgment)
- I2CIRQ (I2C interrupt output)
- I2CKWUP (I2C wakeup from standby signal)
- SCLO (Serial clock output)
- SCLOE (Serial clock output enable, active high)
- SDAO (Serial data output)
- SDAOE (Serial data output enable, active high)

PARAMETERS:
- I2C_SLAVE_INIT_ADDR: "0'b1111100001" (default), "0'b1111100010" (Upper bits [9:2] can be changed through control registers. Lower bits [1:0] are fixed to 01 in the upper left and 10 in the upper right)
- BUS_ADDR74: "0'b0001" (default), "0'b0011" (Fixed value. Upper left corner should be 0'b0001, upper right corner should be 0'b0011. SBADR[7:4] should match this value to activate the IP)
Alphanumeric Primitives List

```
"1002", "1003", "1004", "1005", "1006", "1007", "1008", "1009", "1010",
"1011", "1012", "1013", "1014", "1015", "1016", "1017", "1018", "1019",
"1020", "1021", "1022", "1023" (Ratio of SBCLKI/SCLO)
```

- **SDA_INPUT_DELAYED**: "0" (default), "1" (Add 50-ns delay to the SDAI signal)
- **SDA_OUTPUT_DELAYED**: "0" (default), "1" (Add 50-ns delay to the SDAO signal)
- **FREQUENCY_PIN_SBCLKI**: "NONE" (default) (SDC constraint entry on SBCLKI port of I2C.)

**SAME AS**: SB_I2C

### I2CFIFO

Wrapper for Hardened I2C Interface Block

**Architectures Supported:**
- **LFD2NX**
- **LIFCL**

**I2CFIFO**

```
LMMICLK  LMMIRDATA[0]
LMMRESET_N  LMMIRDATAVALID
LMMREQUEST  LMMREADY
LMMWRD_N  ALTSCLDEN
LMMOFFSET[0]  ALTSCLOUT
LMMIRDATA[0]  ALTSDAOEN
ALTSCLIN  ALTSDAOUT
ALTSDAIN  BUSY
FINORESET  INSLP
I2CBLERRSTN  IRQ
SCLIN  MRDCMPL
SDAIN  RXFIFOCA
RXFIFOE  RXFIFOF
SCLOE  SCLOEN
SCLIN  SCLOUT
SDAE  SDAOE
SDAOEN  SDAOUT
SLVADDRMATCH  SLVADDRMATCHSCL
SNDWR  TXFIFOAM
TXFIFOE  TXFIFOF
```

**INPUTS:**
- **LMMICLK**
LMMIRESET\_N
LMMIREQUEST
LMMIWRRD\_N
LMMIOFFSET[5:0]
LMMIWDATA[7:0]
ALTSCLIN
ALTSDAIN
FIFORESET
I2CLSRRSTN
SCLIN
SDAIN

OUTPUTS:
LMMIRDATA[7:0]
LMMIRDATAVALID
LMMIREADY
ALTSCLOEN
ALTSCLOUT
ALTSDAOEN
ALTSDAOUT
BUS_BUSY
INSLEEP
IRQ
MRDCMPL
RXFIFOAF
RXFIFOE
RXFIFOF
SCLOE
SCLOEN
SCLOUT
SDAOE
SDAOEN
SDAOUT
SLVADDRMATCH
SLVADDRMATCHSCL
SRDWR
TXFIFOAE
Table 122: I2CFIFO Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>BRNBASEDELAY</td>
<td>0'b0000 (default)</td>
<td></td>
</tr>
<tr>
<td>CR1CKDIS</td>
<td>&quot;EN&quot; (default)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;DIS&quot;</td>
<td></td>
</tr>
<tr>
<td>CR1FIFOMODE</td>
<td>&quot;REG&quot; (default)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;FIFO&quot;</td>
<td></td>
</tr>
<tr>
<td>CR1GCEN</td>
<td>&quot;DIS&quot; (default)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;EN&quot;</td>
<td></td>
</tr>
<tr>
<td>CR1I2CEN</td>
<td>&quot;DIS&quot; (default)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;EN&quot;</td>
<td></td>
</tr>
<tr>
<td>CR1SDADELSEL</td>
<td>&quot;NDLY0&quot; (default)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;NDLY1&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;NDLY2&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;NDLY4&quot;</td>
<td></td>
</tr>
<tr>
<td>CR1SLPCLKEN</td>
<td>&quot;DIS&quot; (default)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;EN&quot;</td>
<td></td>
</tr>
<tr>
<td>CR2CORERSTN</td>
<td>&quot;DIS&quot; (default)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;RST&quot;</td>
<td></td>
</tr>
<tr>
<td>CR2HARDTIE</td>
<td>&quot;TIE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;NOTIE&quot;</td>
<td></td>
</tr>
<tr>
<td>CR2INTCLREN</td>
<td>&quot;DIS&quot; (default)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;EN&quot;</td>
<td></td>
</tr>
<tr>
<td>CR2MRDCMPLWKUP</td>
<td>&quot;DIS&quot; (default)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;EN&quot;</td>
<td></td>
</tr>
<tr>
<td>CR2RXFIFOAFWKUP</td>
<td>&quot;DIS&quot; (default)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;EN&quot;</td>
<td></td>
</tr>
<tr>
<td>CR2SLVADDRWKUP</td>
<td>&quot;DIS&quot; (default)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;EN&quot;</td>
<td></td>
</tr>
<tr>
<td>GSR</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;DISABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>I2CRXFIFOAFVAL</td>
<td>0'b00000 (default)</td>
<td></td>
</tr>
<tr>
<td>I2CSLVADDRA</td>
<td>0'b00000000000 (default)</td>
<td></td>
</tr>
<tr>
<td>I2CTXFIFOAEVAL</td>
<td>0'b0000 (default)</td>
<td></td>
</tr>
<tr>
<td>INTARBLIE</td>
<td>&quot;DIS&quot; (default)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;EN&quot;</td>
<td></td>
</tr>
</tbody>
</table>
### Table 122: I2CFIFO Parameters (Continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>INTBUSFREEIE</td>
<td>&quot;DIS&quot; (default) &quot;EN&quot;</td>
<td></td>
</tr>
<tr>
<td>INTHGCEIE</td>
<td>&quot;DIS&quot; (default) &quot;EN&quot;</td>
<td></td>
</tr>
<tr>
<td>INTMRDCMPLIE</td>
<td>&quot;DIS&quot; (default) &quot;EN&quot;</td>
<td></td>
</tr>
<tr>
<td>INTRNACKIEORRSVD</td>
<td>&quot;DIS&quot; (default) &quot;EN&quot;</td>
<td></td>
</tr>
<tr>
<td>INTRSVDOTROEIE</td>
<td>&quot;DIS&quot; (default) &quot;EN&quot;</td>
<td></td>
</tr>
<tr>
<td>INTRSVDORTRRDYIE</td>
<td>&quot;DIS&quot; (default) &quot;EN&quot;</td>
<td></td>
</tr>
<tr>
<td>INTRXOVERFIEORRSVD</td>
<td>&quot;DIS&quot; (default) &quot;EN&quot;</td>
<td></td>
</tr>
<tr>
<td>INTRXUNDERFIE</td>
<td>&quot;DIS&quot; (default) &quot;EN&quot;</td>
<td></td>
</tr>
<tr>
<td>INTTXOVERTIE</td>
<td>&quot;DIS&quot; (default) &quot;EN&quot;</td>
<td></td>
</tr>
<tr>
<td>INTTXSERRIEORRSVD</td>
<td>&quot;DIS&quot; (default) &quot;EN&quot;</td>
<td></td>
</tr>
<tr>
<td>LMMI_EXTRA_ONE</td>
<td>&quot;DIS&quot; (default) &quot;EN&quot;</td>
<td></td>
</tr>
<tr>
<td>LMMI_EXTRA_TWO</td>
<td>&quot;DIS&quot; (default) &quot;EN&quot;</td>
<td></td>
</tr>
<tr>
<td>NCRALTOEN</td>
<td>&quot;FABRIC&quot; (default) &quot;IO&quot;</td>
<td></td>
</tr>
<tr>
<td>NCRFILTERDIS</td>
<td>&quot;EN&quot; (default) &quot;DIS&quot;</td>
<td></td>
</tr>
<tr>
<td>NCRSDAINDLYEN</td>
<td>&quot;DIS&quot; (default) &quot;EN&quot;</td>
<td></td>
</tr>
<tr>
<td>NCRSDAOUTDLYEN</td>
<td>&quot;DIS&quot; (default) &quot;EN&quot;</td>
<td></td>
</tr>
<tr>
<td>NONUSRTSTSOFTTRIMEN</td>
<td>&quot;DIS&quot; (default) &quot;EN&quot;</td>
<td></td>
</tr>
<tr>
<td>NONUSRTSTSOFTTRIMVALUE</td>
<td>0'b000 (default)</td>
<td></td>
</tr>
<tr>
<td>REGI2CBR</td>
<td>0'b0000000000 (default)</td>
<td></td>
</tr>
<tr>
<td>TSPTIMERVVALUE</td>
<td>0'b10010010111 (default)</td>
<td>000000000000</td>
</tr>
</tbody>
</table>
**IB**

Input Buffer

Architectures Supported:
- LFD2NX
- LIFCL
- iCE40 UltraPlus

![IB Diagram]

**INPUTS:**
- I (Data from pad)

**OUTPUTS:**
- O (Data to fabric)

In iCE40 UltraPlus, refer to Source Template.

---

**Table 123: IB Truth Table**

<table>
<thead>
<tr>
<th>Input</th>
<th>Output</th>
</tr>
</thead>
<tbody>
<tr>
<td>I</td>
<td>O</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Z</td>
<td>U</td>
</tr>
</tbody>
</table>

**IDDR71**

7:1 LVDS IDDR

Architectures Supported:
- LFD2NX
LIFCL

This primitive is used for 7:1 LVDS input implementation.

INPUTS:
- D: DDR data input.
- ECLK: Fast edge clock.
- SCLK: Primary clock input (divide-by-3.5 of ECLK).
- RST: Reset to DDR registers.
- ALIGNWD: Shifts word alignment by one bit.

OUTPUT:
- Q[6:0]: Output data.

Table 124: IDDR71 Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
<th>Values</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>GSR</td>
<td>Enable global set/reset.</td>
<td>&quot;ENABLED&quot; &quot;DISABLED&quot;</td>
<td>&quot;ENABLED&quot;</td>
</tr>
</tbody>
</table>

IDDRX1

Generic X1 IDDR

Architectures Supported:
- LFD2NX
- LIFCL

This primitive is used for the Generic x1 IDDR implementation.

INPUTS:
- D: DDR data input.
- SCLK: Primary clock input.
RST: Reset to DDR registers.

OUTPUTS:
- Q0: Data at the positive edge of the clock.
- Q1: Data at the negative edge of the clock.

### Table 125: IDDRX1 Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
<th>Values</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>GSR</td>
<td>Enable global set/reset</td>
<td>&quot;ENABLED&quot;</td>
<td>&quot;ENABLED&quot;</td>
</tr>
<tr>
<td></td>
<td></td>
<td>&quot;DISABLED&quot;</td>
<td></td>
</tr>
</tbody>
</table>

**IDDRX2**

Generic X2 IDDR

Architectures Supported:
- LFD2NX
- LIFCL

This primitive is used for the Generic x2 IDDR implementation.

INPUTS:
- D: DDR data input.
- SCLK: Primary clock input (divide-by-2 of ECLK).
- RST: Reset to DDR registers.
- ECLK: Fast edge clock.
- ALIGNWD: Shifts word alignment by one bit.

OUTPUTS:
- Q[3:0]: Parallel data output. Q0, Q2 are the data at the positive edges of the input ECLK. Q1 and Q3 are the data at negative edge of input ECLK.

### Table 126: IDDRX2 Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
<th>Values</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>GSR</td>
<td>Enable global set/reset</td>
<td>&quot;ENABLED&quot;</td>
<td>&quot;ENABLED&quot;</td>
</tr>
<tr>
<td></td>
<td></td>
<td>&quot;DISABLED&quot;</td>
<td></td>
</tr>
</tbody>
</table>
IDDRX2DQ

DQ Input for DDR2 and DDR3 Memory

Architectures Supported:
- LIFCL
- LFD2NX

This primitive is used to implement DDR3/DDR3L and LPDDR2/LPDDR3 memory interfaces.

INPUTS:
- D: DDR data input.
- DQSR90: DQS clock input.
- ECLK: Fast edge clock.
- SCLK: Primary clock input (divide-by-2 of ECLK).
- RST: Reset to DDR registers.
- RDPNTR[2:0]: Read pointer from the DQSBUF module used to transfer data to ECLK.
- WRPNTR[2:0]: Write pointer from the DQSBUF module used to transfer data to ECLK.

OUTPUTS:
- Q[3:0]: Parallel data output. Q0 and Q2 are the data at the positive edges of the input ECLK. Q1 and Q3 are the data at negative edge of input ECLK.

Table 127: IDDRX2DQ Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
<th>Values</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>GSR</td>
<td>Enable global set/reset.</td>
<td>&quot;ENABLED&quot;</td>
<td>&quot;ENABLED&quot;</td>
</tr>
</tbody>
</table>

"DISABLED"
IDDRX4
Generic X4 IDDR

Architectures Supported:
- LFD2NX
- LIFCL

This primitive is used for the Generic x4 IDDR implementation.

INPUTS:
- D: DDR data input.
- SCLK: Primary clock input (divide-by-4 of ECLK).
- RST: Reset to DDR registers.
- ECLK: Fast edge clock.
- ALIGNWD: Shifts word alignment by one bit.

OUTPUTS:
- Q[7:0]: Parallel data output. Q0, Q2, Q4, Q6 are the data at the positive edges of the input ECLK. Q1, Q3, Q5, Q7 are data at negative edge of input ECLK.

Table 128: IDDRX4 Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
<th>Values</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>GSR</td>
<td>Enable global set/reset.</td>
<td>&quot;ENABLED&quot;</td>
<td>&quot;ENABLED&quot;</td>
</tr>
</tbody>
</table>

IDDRX4DQ
DQ Input for DDR3 memory

Architectures Supported:
- LFD2NX
LIFCL

This primitive is used to implement DDR3/DDR3L and LPDDR2/LPDDR3 memory interfaces at higher speeds.

INPUTS:
- D: DDR data input.
- DQSR90: DQS clock input.
- ECLK: Fast edge clock.
- SCLK: Primary clock input (divide-by-4 of ECLK).
- RST: Reset to DDR registers.
- RDPNTR[2:0]: Read pointer from the DQSBUF module used to transfer data to ECLK.
- WRPNTR[2:0]: Write pointer from the DQSBUF module used to transfer data to ECLK.

OUTPUTS:
- Q[7:0]: Parallel data output. Q0, Q2, Q4, Q6 are the data at the positive edges of the input ECLK. Q1, Q3, Q5, Q7 are data at negative edge of input ECLK.

Table 129: IDDRX4DQ Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
<th>Values</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>GSR</td>
<td>Enable global set/reset.</td>
<td>&quot;ENABLED&quot;</td>
<td>&quot;ENABLED&quot;</td>
</tr>
</tbody>
</table>

IDDRX5

Generic X5 IDDR

Architectures Supported:
- LFD2NX
LIFCL

This primitive is used for the Generic x5 IDDR implementation.

INPUTS:
- D: DDR data input.
- ECLK: Fast edge clock.
- SCLK: Primary clock input (divide-by-5 of ECLK).
- RST: Reset to DDR registers.
- ALIGNWD: Shifts word alignment by one bit.

OUTPUTS:
- Q[9:0]: Parallel data output. Q0, Q2, Q4, Q6, Q8 are the data at the positive edges of the input ECLK. Q1, Q3, Q5, Q7, Q9 are data at negative edge of input ECLK.

Table 130: IDDRX5 Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
<th>Values</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>GSR</td>
<td>Enable global set/reset.</td>
<td>&quot;ENABLED&quot;</td>
<td>&quot;ENABLED&quot;</td>
</tr>
</tbody>
</table>

IFD1P3AZ

Positive Edge Triggered Input D Flip-Flop with Positive Level Enable

Architectures Supported:
- iCE40 UltraPlus

IFD1P3AZ
INPUTS:
- D (data in)
- SP (clock enable, active high)
- CK (clock)

OUTPUTS:
- Q (data out)

Table 131: IFD1P3AZ Truth Table

<table>
<thead>
<tr>
<th>Inputs</th>
<th>Output</th>
</tr>
</thead>
<tbody>
<tr>
<td>D</td>
<td>SP</td>
</tr>
<tr>
<td>X</td>
<td>0</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
</tr>
</tbody>
</table>

X = Don't care

**IFD1P3BX**
Positive Edge Triggered Input D Flip-Flop with Positive Level Enable and Positive Level Asynchronous Preset

Architectures Supported:
- LFD2NX
- LIFCL

INPUTS:
- D (Data in from IO)
- SP (Clock enable, active high)
- CK (Clock)
- PD (Preset, active high)

OUTPUT:
Q (Data out)

**Table 132: IFD1P3BX Parameters**

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>GSR</td>
<td>&quot;ENABLED&quot; (default)  &quot;DISABLED&quot;</td>
<td>Enable global set/reset</td>
</tr>
</tbody>
</table>

**NOTES:**

Any IO driving an IO register may **only** drive that IO register and nothing else.

**Table 133: IFD1P3BX Truth Table**

<table>
<thead>
<tr>
<th>Inputs</th>
<th>Outputs</th>
</tr>
</thead>
<tbody>
<tr>
<td>D</td>
<td>SP</td>
</tr>
<tr>
<td>X</td>
<td>0</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
</tr>
</tbody>
</table>

X = Don’t Care

When GSR = 0, Q = 1 (D = SP = CK = PD = X)

**IFD1P3DX**

Positive Edge Triggered Input D Flip-Flop with Positive Level Enable and Positive Level Asynchronous Clear

Architectures Supported:

- LFD2NX
- LIFCL
- IFD1P3DX

**INPUTS:**

- D (Data in from IO)
- SP (Clock enable, active high)
- CK (Clock)
CD (Reset, active high)

OUTPUT:
Q (Data out)

Table 134: IFD1P3DX Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>GSR</td>
<td>&quot;ENABLED&quot; (default)</td>
<td>Enable global set/reset</td>
</tr>
<tr>
<td></td>
<td>&quot;DISABLED&quot;</td>
<td></td>
</tr>
</tbody>
</table>

NOTES:

Any IO driving an IO register may **only** drive that IO register and nothing else.

Table 135: IFD1P3DX Truth Table

<table>
<thead>
<tr>
<th>Inputs</th>
<th>Output</th>
</tr>
</thead>
<tbody>
<tr>
<td>D</td>
<td>SP</td>
</tr>
<tr>
<td>X</td>
<td>0</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
</tr>
</tbody>
</table>

X = Don't care

When GSR = 0, Q = 0 (D = SP = CK = CD = X)

**IFD1P3IX**

Positive Edge Triggered Input D Flip-Flop with Positive Level Synchronous Clear and Positive Level Enable (Clear Overrides Enable)

Architectures Supported:
LFD2NX
LIFCL

INPUTS:
D (Data in from IO)
SP (Clock enable, active high)
CK (Clock)
CD (Reset, active high)

OUTPUT:
Q (Data out)

Table 136: IFD1P3IX Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>GSR</td>
<td>&quot;ENABLED&quot; (default)</td>
<td>Enable global set/reset</td>
</tr>
<tr>
<td></td>
<td>&quot;DISABLED&quot;</td>
<td></td>
</tr>
</tbody>
</table>

NOTES:
Any IO driving an IO register may only drive that IO register and nothing else.

Table 137: IFD1P3IX Truth Table

<table>
<thead>
<tr>
<th>Inputs</th>
<th>Output</th>
</tr>
</thead>
<tbody>
<tr>
<td>D</td>
<td>SP</td>
</tr>
<tr>
<td>X</td>
<td>0</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
</tr>
</tbody>
</table>

X = Don't care

When GSR = 0, Q = 0 (D = SP = CK = CD = X)

IFD1P3JX
Positive Edge Triggered Input D Flip-Flop with Positive Level Synchronous
Preset and Positive Level Enable (Preset Overrides Enable)

Architectures Supported:
LFD2NX
LIFCL
INPUTS:
- D (Data in from IO)
- SP (Clock enable, active high)
- CK (Clock)
- PD (Preset, active high)

OUTPUT:
- Q (Data out)

Table 138: IFD1P3JX Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>GSR</td>
<td>&quot;ENABLED&quot; (default)</td>
<td>Enable global set/reset</td>
</tr>
<tr>
<td></td>
<td>&quot;DISABLED&quot;</td>
<td></td>
</tr>
</tbody>
</table>

NOTES:

Any IO driving an IO register may only drive that IO register and nothing else.

Table 139: IFD1P3JX Truth Table

<table>
<thead>
<tr>
<th>Inputs</th>
<th>Output</th>
</tr>
</thead>
<tbody>
<tr>
<td>D</td>
<td>SP</td>
</tr>
<tr>
<td>X</td>
<td>0</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
</tr>
</tbody>
</table>

When GSR = 0, Q = 1 (D = SP = CK = PD = X)

**INV**

Inverter

Architectures Supported:
- LFD2NX
- LIFCL
iCE40 UltraPlus

**INPUT:**
- A

**OUTPUT:**
- Z

**IOL_B**
Input/Output Registers, for Both Single Data and Double Data Rate

Architectures Supported:
- iCE40 UltraPlus

**INPUTS:**
- PADDI (Data from pad)
- DO1 (Data to pad)
- DO0 (Data to pad)
- CE (Clock enable)
- IOLTO (Tri-state enable (active low))
- HOLD (Hold DI0 state)
- INCLK (Input clock)
- OUTCLK (Output clock)

**OUTPUTS:**
- PADDO (Data to pad)
- PADDT (Tri-state control to pad)
- DI1 (Data from pad)
- DI0 (Data from pad)
PARAMETERS:
- LATCHIN: "NONE_REG" (default), "LATCH_REG", "LATCH_BYPASS", "NONE DDR" (NONE REG = no latch, just register, LATCH_REG = latch DI0 when HOLD is asserted, LATCH_BYPASS = latch non-registered DO0, and NONE DDR = No latch, DDR operation.)
- DDROUT: "NO" (default), "YES" (Select double data rate output)

**JTAG**
JTAG Block for Reveal Debugging Tool

Architectures Supported:
- LFD2NX
- LIFCL

**JTAG**

```
<table>
<thead>
<tr>
<th>JTDO1</th>
<th>JCE1</th>
</tr>
</thead>
<tbody>
<tr>
<td>JTDO2</td>
<td>JCE2</td>
</tr>
<tr>
<td>SMCLK</td>
<td>JRSTN</td>
</tr>
<tr>
<td>TCK</td>
<td>JRTI1</td>
</tr>
<tr>
<td>TDI</td>
<td>JRTI2</td>
</tr>
<tr>
<td>TMS</td>
<td>JSHIFT</td>
</tr>
<tr>
<td></td>
<td>JTDI</td>
</tr>
<tr>
<td></td>
<td>JUPDTE</td>
</tr>
<tr>
<td></td>
<td>JTCR</td>
</tr>
<tr>
<td></td>
<td>TD0_OEN</td>
</tr>
<tr>
<td></td>
<td>TD0</td>
</tr>
</tbody>
</table>
```

**INPUT:**
- JTDO1
- JTDO2
- SMCLK
- TCK
- TDI
- TMS

**OUTPUTS:**
- JCE1
- JCE2
- JRSTN
- JRTI1
- JRTI2
- JSHIFT
Alphanumeric Primitives List

- JTDI
- JUPDATE
- JTCK
- TDO_OEN
- TDO

**Table 140: JTAG Parameters**

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>MCER1EXIST</td>
<td>&quot;NEXIST&quot; (default)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;EXIST&quot;</td>
<td></td>
</tr>
<tr>
<td>MCER2EXIST</td>
<td>&quot;NEXIST&quot; (default)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;EXIST&quot;</td>
<td></td>
</tr>
</tbody>
</table>

**LSOSC**

Low-frequency oscillator. Generates 10-kHz nominal clock, +/- 10 percent. Can drive global clock network or fabric routing.

Architectures Supported:

- iCE40 UltraPlus

**LSOSC**

```
CLKLFPU        CLKLF
         CLKLFEN
```

**INPUTS:**

- CLKLFPU (Power up the oscillator. After power up, output will be stable after 100 μs. Active high)
- CLKLFEN (Enable the clock output. Enable should be low for the 100-μs power-up period. Active high)

**OUTPUTS:**

- CLKLF (Oscillator output)

**PARAMETERS:** None

**SAME AS:** SB_LFOSC
**LSOSC1P8V**
Low-frequency oscillator. Generates 10-kHz nominal clock, +/- 10 percent. Can drive global clock network or fabric routing. For use when VPP_2V5 is connected to a voltage below 2.3 V.

Architectures Supported:
- iCE40 UltraPlus

**LSOSC1P8V**
- CLKLFPU (Power up the oscillator. After power up, output will be stable after 100 µs. Active high)
- CLKLFEN (Enable the clock output. Enable should be low for the 100-µs power-up period. Active high)

**OUTPUTS:**
- CLKLF (Oscillator output)

**INPUTS:**
- CLKLFPU (Power up the oscillator. After power up, output will be stable after 100 µs. Active high)
- CLKLFEN (Enable the clock output. Enable should be low for the 100-µs power-up period. Active high)

**LSOSC_CORE**
Low-frequency oscillator. Generates 10-kHz nominal clock, +/- 10 percent. Can drive global clock network or fabric routing.

Architectures Supported:
- iCE40 UltraPlus

**INPUTS:**
- CLKLFPU (Power up the oscillator. After power up, output will be stable after 100 µs. Active high)
- CLKLFEN (Enable the clock output. Enable should be low for the 100-µs power-up period. Active high)
- TRIM9...TRIM0
OUTPUTS:
- CLKLF (Oscillator output)

PARAMETERS:
- FABRIC_TRIME: "DISABLE" (default), "ENABLE" (Trim bits source selection. ENABLE - Trim bits sourced from Fabric, DISABLE - Trim bits sourced from NVCM.)

**LUT4**
4-Input Look-Up Table

Architectures Supported:
- LFD2NX
- iCE40 UltraPlus
- LIFCL

```
+---+---+---+---+
|  A |  B |  C |  D |
+---+---+---+---+
     |   |   |   |
     +---+---+---+---+
```

INPUTS:
- A
- B
- C
- D

OUTPUT:
- Z

PARAMETERS:
- INIT: hexadecimal value (default: "0x0000")

NOTES:

The programming of the LUT4 (that is, the 0 or 1 value of each memory location within the LUT4) is determined by the value assigned with INIT. The
value is expressed in hexadecimal code. Highest memory locations are in the most significant hex digit, the lowest in the least significant digit.

### Table 141: LUT4 Truth Table

<table>
<thead>
<tr>
<th>Inputs</th>
<th>Output</th>
</tr>
</thead>
<tbody>
<tr>
<td>D C B A</td>
<td>INIT[0]</td>
</tr>
<tr>
<td>0 0 0 0</td>
<td>INIT[0]</td>
</tr>
<tr>
<td>0 0 0 1</td>
<td>INIT[1]</td>
</tr>
<tr>
<td>0 0 1 0</td>
<td>INIT[2]</td>
</tr>
<tr>
<td>0 0 1 1</td>
<td>INIT[3]</td>
</tr>
<tr>
<td>0 1 0 0</td>
<td>INIT[4]</td>
</tr>
<tr>
<td>0 1 0 1</td>
<td>INIT[5]</td>
</tr>
<tr>
<td>0 1 1 0</td>
<td>INIT[6]</td>
</tr>
<tr>
<td>0 1 1 1</td>
<td>INIT[7]</td>
</tr>
<tr>
<td>1 0 0 0</td>
<td>INIT[8]</td>
</tr>
<tr>
<td>1 0 0 1</td>
<td>INIT[9]</td>
</tr>
<tr>
<td>1 0 1 0</td>
<td>INIT[10]</td>
</tr>
<tr>
<td>1 0 1 1</td>
<td>INIT[11]</td>
</tr>
<tr>
<td>1 1 0 0</td>
<td>INIT[12]</td>
</tr>
<tr>
<td>1 1 0 1</td>
<td>INIT[13]</td>
</tr>
<tr>
<td>1 1 1 0</td>
<td>INIT[14]</td>
</tr>
<tr>
<td>1 1 1 1</td>
<td>INIT[15]</td>
</tr>
</tbody>
</table>

**MAC16**

DSP block capable of being configured as a multiplier, adder, subtractor, accumulator, multiply-adder, or multiply-subtractor.
Architectures Supported:

- iCE40 UltraPlus

**MAC16**

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>CLK</td>
<td>O31...00</td>
</tr>
<tr>
<td>CE</td>
<td>CO</td>
</tr>
<tr>
<td>C15...C0</td>
<td>ACCUMCO</td>
</tr>
<tr>
<td>A15...A0</td>
<td>SIGEXTOUT</td>
</tr>
<tr>
<td>B15...B0</td>
<td></td>
</tr>
<tr>
<td>D15...D0</td>
<td></td>
</tr>
<tr>
<td>A-HOLD</td>
<td></td>
</tr>
<tr>
<td>B-HOLD</td>
<td></td>
</tr>
<tr>
<td>C-HOLD</td>
<td></td>
</tr>
<tr>
<td>D-HOLD</td>
<td></td>
</tr>
<tr>
<td>IRSTTOP</td>
<td></td>
</tr>
<tr>
<td>IRSTBOT</td>
<td></td>
</tr>
<tr>
<td>CRSTTOP</td>
<td></td>
</tr>
<tr>
<td>CRSTBCT</td>
<td></td>
</tr>
<tr>
<td>CLOADTOP</td>
<td></td>
</tr>
<tr>
<td>CLOADBOT</td>
<td></td>
</tr>
<tr>
<td>ADDSUBTOP</td>
<td></td>
</tr>
<tr>
<td>ADDSUBBOT</td>
<td></td>
</tr>
<tr>
<td>CHOLDDOP</td>
<td></td>
</tr>
<tr>
<td>CHOLDBOT</td>
<td></td>
</tr>
<tr>
<td>CI</td>
<td></td>
</tr>
<tr>
<td>ACCUMCI</td>
<td></td>
</tr>
<tr>
<td>SIGEXTIN</td>
<td></td>
</tr>
</tbody>
</table>

**INPUTS:**

- **CLK**: Clock input. Applies to all clocked elements in the MAC16A block.
- **CE**: Clock Enable input. Active High.
- **C15...C0**: Input to the C Register/Direct input to the adder accumulator.
- **A15...A0**: Input to the A Register/Direct input to the multiplier blocks/Direct input to the adder accumulator.
- **B15...B0**: Input to the B Register/Direct input to the multiplier blocks/Direct input to the adder accumulator.
- **AHOLD**: Hold A registers Data. Controls data flow into the input register A. Active High. 0 - Update (load) register at next active clock edge. 1 - Hold (retain) current register value, regardless of clock.
BHOLD: Hold B registers Data. Controls data flow into the B input register. Active High. 0 - Update (load) register at next active clock edge. 1 - Hold (retain) current register value, regardless of clock.

CHOLD: Hold C registers Data. Controls data flow into the C input register. Active High. 0 - Update (load) register at next active clock edge. 1 - Hold (retain) current register value, regardless of clock.

DHOLD: Hold D registers Data. Controls data flow into the D input register. Active High. 0 - Update (load) register at next active clock edge. 1 - Hold (retain) current register value, regardless of clock.

IRSTTOP: Reset input to the A and C input registers, and the pipeline registers in the upper half of the multiplier block. Active High.

IRSTBOT: Reset input to the B and C input registers, and the pipeline registers in the lower half of the multiplier block, and the 32-bit multiplier result pipeline register. Active High.

ORSTTOP: Reset the high-order bits of the accumulator register ([31:16]). Active High.

ORSTBOT: Reset the low-order accumulator register bits ([15:0]). Active High.

OLOADTOP: High-order Accumulator Register Accumulate/Load. Controls whether the accumulator register accepts the output of the adder/subtractor or whether the register is loaded with the value from Input C (or Register C, if configured). 0 - Accumulator Register [31:16] loaded with output from adder/subtractor. 1 - Accumulator Register [31:16] loaded with Input C or Register C, depending on primitive parameter value.

OLOADBOT: Low-order Accumulator Register Accumulate/Load. Controls whether the low-order accumulator register bits ([15:0]) accepts the output of the adder/subtractor or whether the register is loaded with the value from Input D (or Register D, if configured). 0 - Accumulator Register [15:0] loaded with output from adder/subtractor. 1 - Accumulator Register [15:0] loaded with Input D or Register D, depending on primitive parameter value.

ADDSUBTOP: High-order Add/Subtract. Controls whether the adder/subtractor adds or subtracts. 0 - Add: W+X+HCI 1 - Subtract: W-X-HCI.

ADDSUBBOT: Low-order Add/Subtract. Controls whether the adder/subtractor adds or subtracts. 0 - Add: Y+Z+LCI 1 - Subtract: Y-Z-LCI.

OHOLDTOP: High-order Accumulator Register Hold. Controls data flow into the high-order ([31:16]) bits of the accumulator. 0 - Update (load) register at next active clock edge. 1 - Hold (retain) current register value, regardless of clock.

OHOLDBOT: Low-order Accumulator Register Hold. Controls data flow into the high-order ([15:0]) bits of the accumulator. 0 - Update (load) register at next active clock edge. 1 - Hold (retain) current register value, regardless of clock.

CI: Carry/borrow input from lower logic tile.

ACCUMCI: Cascade carry/borrow input from lower MAC16 block.
SIGNEXTIN: Sign extension input from lower MAC16 block.

OUTPUTS:
- O31...O0: 32-bit MAC16 output.
- O[31:0]: 32-bit result of a 16x16 multiply operation or a 32-bit adder/accumulate function.
- O[31:16]: 16-bit result of an 8x8 multiply operation or a 32-bit adder/accumulate function.
- O[15:0]: 16-bit result of an 8x8 multiply operation or a 32-bit adder/accumulate function.
- CO: Carry/borrow output to higher logic tile.
- ACCUMCO: Cascade carry/borrow output to higher MAC16 block.
- SIGNEXTOUT: Sign extension output to higher MAC16 block.

PARAMETERS:
- NEG_TRIGGER: "0'b0" (default), "0'b1" (Controls input clock polarity.)
- A_REG: "0'b0" (default), "0'b1" (Input A register Control, 0'b1 = registered (C1))
- B_REG: "0'b0" (default), "0'b1" (Input B register Control, 0'b1 = registered (C2))
- C_REG: "0'b0" (default), "0'b1" (Input C register Control, 0'b1 = registered (C0))
- D_REG: "0'b0" (default), "0'b1" (Input D register Control, 0'b1 = registered (C3))
- TOP_8x8_MULT_REG: "0'b0" (default), "0'b1" (Top 8x8 multiplier output register control, 0'b1 = registered (C4))
- BOT_8x8_MULT_REG: "0'b0" (default), "0'b1" (Bottom 8x8 multiplier output register control, 0'b1 = registered (C5))
- PIPELINE_16x16_MULT_REG1: "0'b0" (default), "0'b1" (16x16 intermediate register control, 0'b1 = registered (C6))
- PIPELINE_16x16_MULT_REG2: "0'b0" (default), "0'b1" (16x16 multiplier pipeline register control, 0'b1 = registered (C7))
- TOPOUTPUT_SELECT: "0'b00" (default), "0'b01", "0'b10", "0'b11" (Selects top output O[31:16], 0'b00 = top accumulator, 0'b01 = top accumulator (registered), 0'b10 = top mult8x8, 0'b11 = mult16x16 (C8, C9))
- TOPADDSUB_LOWERINPUT: "0'b00" (default), "0'b01", "0'b10", "0'b11" (Selects lower input for the upper adder/subtractor, 0'b00 = input A, 0'b01 = top mult8x8, 0'b10 = mult16x16, 0'b11 = sign extend from lower adder/subtractor (C10, C11))
- TOPADDSUB_UPPERINPUT: "0'b0" (default), "0'b1" (Selects upper input for the upper adder/subtractor, 0'b0 = accumulate, 0'b1 = input C (C12))
- TOPADDSUB_CARRYSELECT: "0'b00" (default), "0'b01", "0'b10", "0'b11" (Carry/borrow input select to upper adder/subtractor, 0'b00 = constant 0,
0'b01 = constant 1, 0'b10 = carry from lower adder/subtractor, 0'b11 = carry from lower adder/subtractor (C13, C14)

- **BOTOUTPUT_SELECT**: "0'b00" (default), "0'b01", "0'b10", "0'b11" (Selects lower output O[15:0], 0'b00 = bottom adder/subtractor, 0'b01 = bottom adder/subtractor (registered), 0'b10 = bottom mult8x8, 0'b11 = mult16x16 (C15, C16))

- **BOTADDSUB_LOWERINPUT**: "0'b00" (default), "0'b01", "0'b10", "0'b11" (Selects lower input for the lower adder/subtractor, 0'b00 = input B, 0'b01 = bottom mult8x8, 0'b10 = mult16x16, 0'b11 = sign extend from previous MAC16 (C17, C18))

- **BOTADDSUB_UPPERINPUT**: "0'b0" (default), "0'b1" (Selects upper input for the lower adder/subtractor, 0'b0 = accumulate, 0'b1 = input C (C19))

- **BOTADDSUB_CARRYSELECT**: "0'b00" (default), "0'b01", "0'b10", "0'b11" (Carry/borrow input select to lower adder/subtractor, 0'b00 = constant 0, 0'b01 = constant 1, 0'b10 = ACCUMCI, 0'b11 = CI (C20, C21))

- **MODE_8x8**: "0'b0" (default), "0'b1" (Selects 8x8 Multiplier mode and 8x8 Low-Power Multiplier Blocking Option, 0'b1 = 8x8 mode (C22))

- **A_SIGNED**: "0'b0" (default), "0'b1" (Indicates whether multiplier input A is signed or unsigned, 0'b1 = signed)

- **B_SIGNED**: "0'b0" (default), "0'b1" (Indicates whether multiplier input B is signed or unsigned. 0'b1 = signed)
NOTES

SAME AS: SB_MAC16

Rules & Restrictions:

As noted by pin description, ACCUMCI and SIGNEXTIN can only come from previous MAC16’s ACCUMCO and SIGNEXTOUT.

Failure to do so will cause connectivity DRC error.

If MODE_8x8 is 1, then PIPELINE_16x16_MULT_REG1 and PIPELINE_16x16_MULT_REG2 must be 0'b0.

Note:

If the operation is 8x8, then these PIPELINE attributes are irrelevant. However, we have to be strict because we don’t know the intended use of the DSP. If operation is truly 16x16, then this illegal combination setting would cause an incorrect operation.
**MIPI**
Soft MIPI Interface Block

Architectures Supported:
- LFD2NX
- LIFCL

![MIPI Diagram]

**INPUTS:**
- AP
- AN
- TP
- TN
- HSRXEN
- HSTXEN
- IHS

**OUTPUTS:**
- OLSP
- OLSN
- OHS

**BIDIS:**
- BP
- BN

**Table 142: MIPI Parameters**

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>MIPI_ID</td>
<td>0 (default)</td>
<td></td>
</tr>
</tbody>
</table>

**MULT18X18**
18x18 Multiplier with Optional Input/Output Registers
Architectures Supported:
- LFD2NX
- LIFCL

### MULT18X18

#### INPUTS:
- A[17:0] (Operand A)
- B[17:0] (Operand B)
- CLK (Clock)
- CEA (Input A enable)
- RSTA (Input A reset)
- CEB (Input clock enable)
- RSTB (Input register reset)
- SIGNEDA (Operand A signed)
- SIGNEDB (Operand B signed)
- RSTOUT (Output register reset)
- CEOUT (Output clock enable)

#### OUTPUT:
- Z[35:0] (Multiplication result)

### Table 143: MULT18X18 Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>REGINPUTA</td>
<td>&quot;REGISTER&quot; (default) &quot;BYPASS&quot;</td>
<td>Register operand A</td>
</tr>
<tr>
<td>REGINPUTB</td>
<td>&quot;REGISTER&quot; (default) &quot;BYPASS&quot;</td>
<td>Register operand B</td>
</tr>
<tr>
<td>REGOUTPUT</td>
<td>&quot;REGISTER&quot; (default) &quot;BYPASS&quot;</td>
<td>Register output</td>
</tr>
<tr>
<td>GSR</td>
<td>&quot;ENABLED&quot; (default) &quot;DISABLED&quot;</td>
<td>Enable global set/reset</td>
</tr>
<tr>
<td>RESETMODE</td>
<td>&quot;SYNC&quot; (default)</td>
<td></td>
</tr>
</tbody>
</table>
NOTES:


$A[17:0]$  $B[17:0]$  $\times$  $Z[35:0]$  

= Bypassable Register

**MULT18X36**

18x36 Multiplier with Optional Input/Output Register

Architectures Supported:
- LFD2NX
- LIFCL

**INPUTS:**
- $A[17:0]$ (Operand A)
- $B[35:0]$ (Operand B)
- CLK (Clock)
- CEA (Input clock enable)
- RSTA (Input register reset)
- CEB (Input clock enable)
- RSTB (Input register reset)
- SIGNEDA (Operand A signed)
- SIGNEDB (Operand B signed)
RSTOUT (Output register reset)
CEOUT (Output clock enable)

OUTPUT:
Z[53:0] (Multiplication result)

Table 144: MULT18X36 Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>REGINPUTA</td>
<td>&quot;REGISTER&quot; (default)</td>
<td>Register operand A</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS&quot;</td>
<td></td>
</tr>
<tr>
<td>REGINPUTB</td>
<td>&quot;REGISTER&quot; (default)</td>
<td>Register operand B</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS&quot;</td>
<td></td>
</tr>
<tr>
<td>REGOUTPUT</td>
<td>&quot;REGISTER&quot; (default)</td>
<td>Register output</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS&quot;</td>
<td></td>
</tr>
<tr>
<td>GSR</td>
<td>&quot;ENABLED&quot; (default)</td>
<td>Enable global set/reset</td>
</tr>
<tr>
<td></td>
<td>&quot;DISABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>RESETMODE</td>
<td>&quot;SYNC&quot; (default)</td>
<td></td>
</tr>
</tbody>
</table>

NOTES:

MULT36X36
36x36 Multiplier with Optional Input/Output Registers

Architectures Supported:
LFD2NX
LIFCL
MULT36X36

INPUTS:
► A[35:0] (Operand A)
► B[35:0] (Operand B)
► CLK (Clock)
► CEA (Input A clock enable)
► RSTA (Input A register reset)
► CEB (Input B clock enable)
► RSTB (Input B register reset)
► SIGNEDA (Operand A signed)
► SIGNEDB (Operand B signed)
► RSTOUT (Output register reset)
► CEOUT (Output clock enable)

OUTPUT:
► Z[71:0] (Multiplication result)

Table 145: MULT36X36 Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>REGINPUTA</td>
<td>&quot;REGISTER&quot; (default)</td>
<td>Register operand A</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS&quot;</td>
<td></td>
</tr>
<tr>
<td>REGINPUTB</td>
<td>&quot;REGISTER&quot; (default)</td>
<td>Register operand B</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS&quot;</td>
<td></td>
</tr>
<tr>
<td>REGOUTPUT</td>
<td>&quot;REGISTER&quot; (default)</td>
<td>Register output</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS&quot;</td>
<td></td>
</tr>
<tr>
<td>GSR</td>
<td>&quot;ENABLED&quot; (default)</td>
<td>Enable global set/reset</td>
</tr>
<tr>
<td></td>
<td>&quot;DISABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>RESETMODE</td>
<td>&quot;SYNC&quot; (default)</td>
<td></td>
</tr>
</tbody>
</table>

NOTES:

**MULT9X9**
9x9 Multiplier with Optional Input/Output Registers

Architectures Supported:

- LFD2NX
- LIFCL

**INPUTS:**
- A[8:0] (Operand A)
- B[8:0] (Operand B)
- CLK (Clock)
- CEA (Input A clock enable)
- RSTA (Input A reset)
- CEB (Input B clock enable)
- RSTB (Input B reset)
- SIGNEDA (Operand A signed)
- SIGNEDB (Operand B signed)
- RSTOUT (Output register reset)
- CEOUT (Output clock enable)
OUTPUT:

- \( Z[17:0] \) (Multiplication result)

**Table 146: MULT9X9 Parameters**

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>REGINPUTA</td>
<td>&quot;REGISTER&quot; (default)</td>
<td>Register operand A</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS&quot;</td>
<td></td>
</tr>
<tr>
<td>REGINPUTB</td>
<td>&quot;REGISTER&quot; (default)</td>
<td>Register operand B</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS&quot;</td>
<td></td>
</tr>
<tr>
<td>REGOUTPUT</td>
<td>&quot;REGISTER&quot; (default)</td>
<td>Register output</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS&quot;</td>
<td></td>
</tr>
<tr>
<td>GSR</td>
<td>&quot;ENABLED&quot; (default)</td>
<td>Enable global set/reset</td>
</tr>
<tr>
<td></td>
<td>&quot;DISABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>RESETMODE</td>
<td>&quot;SYNC&quot; (default)</td>
<td>Synchronous/asynchronous reset control.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Reset release is always asynchronous.</td>
</tr>
</tbody>
</table>

NOTES:

Implements \( Z[17:0] = A[8:0] \times B[8:0] \)

**MULTADDSUB18X18**

18x18 Multiplier and Accumulator

Architectures Supported:

- LFD2NX
**LIFCL**

**MULTADDSUB18X18**

- **A[17:0]** (Operand A)
- **B[17:0]** (Operand B)
- **C[53:0]** (Operand C)
- **CLK** (Input clock)
- **CEA** (Input clock enable)
- **RSTA** (Input register reset)
- **CEB** (Input clock enable)
- **RSTB** (Input register reset)
- **CEC** (Input clock enable)
- **RSTC** (Input register reset)
- **SIGNEDA** (Operand A signed)
- **SIGNEDB** (Operand B signed)
- **SIGNEDC** (Operand C signed)
- **RSTPIPE** (Output register reset)
- **CEPIPE** (Output clock enable)
- **LOADC** (1=Load value from C input)
- **ADDSUB** (0=Add, 1=subtract)
- **RSTOUT** (Output register reset)
Alphanumeric Primitives List

- CEOUT (Output clock enable)
- CIN (Carry in)

OUTPUT:
- Z[53:0] (Multiplication result)

Table 147: MULTADDSUB18X18 Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>REGINPUTA</td>
<td>&quot;REGISTER&quot; (default)  &quot;BYPASS&quot;</td>
<td>Register operand A</td>
</tr>
<tr>
<td>REGINPUTB</td>
<td>&quot;REGISTER&quot; (default)  &quot;BYPASS&quot;</td>
<td>Register operand B</td>
</tr>
<tr>
<td>REGINPUTC</td>
<td>&quot;REGISTER&quot; (default)  &quot;BYPASS&quot;</td>
<td>Register operand C</td>
</tr>
<tr>
<td>REGADDSUB</td>
<td>&quot;REGISTER&quot; (default)  &quot;BYPASS&quot;</td>
<td>Register ADDSUB</td>
</tr>
<tr>
<td>REGLOADC</td>
<td>&quot;REGISTER&quot; (default)  &quot;BYPASS&quot;</td>
<td>Register LOADC</td>
</tr>
<tr>
<td>REGCIN</td>
<td>&quot;REGISTER&quot; (default)  &quot;BYPASS&quot;</td>
<td>Register CIN</td>
</tr>
<tr>
<td>REGPIPELINE</td>
<td>&quot;REGISTER&quot; (default)  &quot;BYPASS&quot;</td>
<td>Register between multiplier and accumulator</td>
</tr>
<tr>
<td>REGOUTPUT</td>
<td>&quot;REGISTER&quot; (default)  &quot;BYPASS&quot;</td>
<td>Register output</td>
</tr>
<tr>
<td>GSR</td>
<td>&quot;DISABLED&quot; (default) &quot;ENABLED&quot;</td>
<td>Enable global set/reset</td>
</tr>
<tr>
<td>RESETMODE</td>
<td>&quot;SYNC&quot; (default)</td>
<td></td>
</tr>
</tbody>
</table>

NOTES:

If LOADC = 1: Z[53:0] = C[53:0] +/- (A[17:0] x B[17:0]) +/- CIN
If LOADC = 0: $Z_{[53:0]} = Z_{\text{prev}[53:0]} \pm (A_{[17:0]} \times B_{[17:0]}) \pm CIN$.

**MULTADDSUB18X18WIDE**
18x18 Wide Multiplier and Adder/Subtractor

**Architectures Supported:**
- LFD2NX
INPUTS:

- A0[17:0]
- B0[17:0]
- A1[17:0]
- B1[17:0]
- C[53:0]
- CLK
- CEA0
- CEA1
- RSTA0
- RSTA1
- CEB0
- CEB1
- RSTB0
- RSTB1
- CEC
- RSTC
- RSTCTRL
- CECCTRL
- SIGNED
- RSTPIPE
- CEPPIPE
- RSTOUT
- CEBOUT
- LOADC
- ADDSUB[1:0]
RSTCTRL
• CECTRL
• SIGNED
• RSTPIPE
• CEPipe
• RSTOUT
• CEOUT
• LOADC
• ADDSUB[1:0]

OUTPUT:
• Z[53:0] (Multiplication result)

Table 148: MULTADDSUB18X18WIDE Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>REGINPUTAB0</td>
<td>&quot;REGISTER&quot; (default) &quot;BYPASS&quot;</td>
<td>Register operand A/B 0</td>
</tr>
<tr>
<td>REGINPUTAB1</td>
<td>&quot;REGISTER&quot; (default) &quot;BYPASS&quot;</td>
<td>Register operand A/B 1</td>
</tr>
<tr>
<td>REGINPUTC</td>
<td>&quot;REGISTER&quot; (default) &quot;BYPASS&quot;</td>
<td>Register operand C</td>
</tr>
<tr>
<td>REGADDSUB</td>
<td>&quot;REGISTER&quot; (default) &quot;BYPASS&quot;</td>
<td>Register ADDSUB</td>
</tr>
<tr>
<td>REGLOADC</td>
<td>&quot;REGISTER&quot; (default) &quot;BYPASS&quot;</td>
<td>Register LOADC</td>
</tr>
<tr>
<td>REGLOADC2</td>
<td>&quot;REGISTER&quot; (default) &quot;BYPASS&quot;</td>
<td></td>
</tr>
<tr>
<td>REGPIPELINE</td>
<td>&quot;REGISTER&quot; (default) &quot;BYPASS&quot;</td>
<td>Register between multiplier and accumulator</td>
</tr>
<tr>
<td>REGOUTPUT</td>
<td>&quot;REGISTER&quot; (default) &quot;BYPASS&quot;</td>
<td>Register output</td>
</tr>
<tr>
<td>GSR</td>
<td>&quot;DISABLED&quot; (default) &quot;ENABLED&quot;</td>
<td>Enable global set/reset</td>
</tr>
<tr>
<td>RESETMODE</td>
<td>&quot;SYNC&quot; (default)</td>
<td></td>
</tr>
</tbody>
</table>

NOTES:

If LOADC = 1:
Z[53:0] = C[53:0] +/- (A0[17:0] x B0[17:0]) +/- (A1[17:0] x B1[17:0])

Else: Z[53:0] = Z_{prev}[53:0] +/- (A0[17:0] x B0[17:0]) +/- (A1[17:0] x B1[17:0])
If \( \text{LOADC} = 0 \), \( \text{REGOUTPUT} \) must be REGISTERED. Else, will result into a combinatorial lock.

\( \text{ADDSUB}[1] \) controls add/sub between \( C/Z_{\text{prev}} \) and \( A0B0 \).

\( \text{ADDSUB}[0] \) controls add/sub between \( A0B0 \) and \( A1B1 \).

\textbf{MULTADDSUB18X36}

18x36 Multiplier and Adder/Subtractor

Architectures Supported:

- LFD2NX
INPUTS:
- A[17:0] (Operand A)
- B[35:0] (Operand B)
- C[53:0] (Operand C)
- CLK (Clock)
- CEA (Input A clock enable)
- RSTA (Input A register reset)
- CEB (Input B clock enable)
- RSTB (Input B register reset)
- CEC (Input C clock enable)
- RSTC (Input C register reset)
- SIGNEDA (Operand A signed)
- SIGNEDB (Operand B signed)
- SIGNEDC (Operand C signed)
- RSTPIPE (Pipeline register reset)
- CEPIPE (Pipeline clock enable)
- RSTOUT (Output register reset)
- CEOUT (Output clock enable)
- LOADC (1=Load value from input C)
- ADDSUB (0=add, 1=subtract)
- CIN (Carry in)
OUTPUT:

- \( Z[53:0] \) (Multiplication result)

**Table 149: MULTADDSUB18X36 Parameters**

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>REGINPUTA</td>
<td>&quot;REGISTER&quot; (default)</td>
<td>Register input A</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS&quot;</td>
<td></td>
</tr>
<tr>
<td>REGINPUTB</td>
<td>&quot;REGISTER&quot; (default)</td>
<td>Register input B</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS&quot;</td>
<td></td>
</tr>
<tr>
<td>REGINPUTC</td>
<td>&quot;REGISTER&quot; (default)</td>
<td>Register input C</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS&quot;</td>
<td></td>
</tr>
<tr>
<td>REGADDSUB</td>
<td>&quot;REGISTER&quot; (default)</td>
<td>Register ADDSUB</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS&quot;</td>
<td></td>
</tr>
<tr>
<td>REGLOADC</td>
<td>&quot;REGISTER&quot; (default)</td>
<td>Register LOADC</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS&quot;</td>
<td></td>
</tr>
<tr>
<td>REGLOADC2</td>
<td>&quot;REGISTER&quot; (default)</td>
<td>Register LOADC, second stage</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS&quot;</td>
<td></td>
</tr>
<tr>
<td>REGCIN</td>
<td>&quot;REGISTER&quot; (default)</td>
<td>Register CIN</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS&quot;</td>
<td></td>
</tr>
<tr>
<td>REGPIPELINE</td>
<td>&quot;REGISTER&quot; (default)</td>
<td>Register between multiplier and accumulator</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS&quot;</td>
<td></td>
</tr>
<tr>
<td>REGOUTPUT</td>
<td>&quot;REGISTER&quot; (default)</td>
<td>Register output</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS&quot;</td>
<td></td>
</tr>
<tr>
<td>GSR</td>
<td>&quot;DISABLED&quot; (default)</td>
<td>Enable global set/reset</td>
</tr>
<tr>
<td></td>
<td>&quot;ENABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>RESETMODE</td>
<td>&quot;SYNC&quot; (default)</td>
<td></td>
</tr>
</tbody>
</table>

**NOTES:**

If \( \text{LOADC} = 1 \):
\[
Z[53:0] = C[53:0] +/- ((A[17:0] \times B[35:0]) +/- CIN)
\]
If $\text{LOADC} = 0$: $Z[53:0] = Z_{\text{prev}}[53:0] \pm/-(A[17:0] \times B[35:0]) \pm/- \text{CIN}$

**MULTADDSUB36X36**

36x36 Multiplier and Adder/Subtractor

Architectures Supported:

- LFD2NX
- LIFCL

**MULTADDSUB36X36**

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>CLK</td>
<td>CEA</td>
<td>RSTA</td>
</tr>
<tr>
<td>CEB</td>
<td>RSTB</td>
<td>CEC</td>
</tr>
<tr>
<td>RSTC</td>
<td>RSTCTRL</td>
<td>CECTRL</td>
</tr>
<tr>
<td>RSTCIN</td>
<td>CEIN</td>
<td>SIGNED</td>
</tr>
<tr>
<td>RSTPIPE</td>
<td>CEPIPE</td>
<td>RSTOUT</td>
</tr>
<tr>
<td>CEDOUT</td>
<td>LOADC</td>
<td>ADDSUB</td>
</tr>
<tr>
<td>CIN</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
INPUTS:
- A[35:0] (Operand A)
- B[35:0] (Operand B)
- C[107:0] (Operand C)
- CLK (Clock)
- CEA (Input A clock enable)
- RSTA (Input A register reset)
- CEB (Input B clock enable)
- RSTB (Input B register reset)
- CEC (Input C clock enable)
- RSTC (Input C register reset)
- RSTCTRL (Input control (addsub, m9addsub, signed, and loadc) reset)
- CECTRL (Input control (addsub, m9addsub, signed, and loadc) enable)
- RSTCIN (Input carry-in reset)
- CECIN (Input carry-in enable)
- SIGNED (One SIGNED port for all inputs due to ACC54 HW limitation.)
- RSTPIPE (Pipeline register reset)
- CEPIPE (Pipeline clock enable)
- RSTOUT (Output register reset)
- CEOUT (Output clock enable)
- LOADC (1=Load value from input C)
- ADDSUB (0=add, 1=subtract)
- CIN (Carry in)

OUTPUT:
- Z[107:0] (Multiplication result)

Table 150: MULTADDSUB36X36 Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>REGINPUTA</td>
<td>&quot;REGISTER&quot; (default) &quot;BYPASS&quot;</td>
<td>Register input A</td>
</tr>
<tr>
<td>REGINPUTB</td>
<td>&quot;REGISTER&quot; (default) &quot;BYPASS&quot;</td>
<td>Register input B</td>
</tr>
<tr>
<td>REGINPUTC</td>
<td>&quot;REGISTER&quot; (default) &quot;BYPASS&quot;</td>
<td>Register input C</td>
</tr>
<tr>
<td>REGADDSUB</td>
<td>&quot;REGISTER&quot; (default) &quot;BYPASS&quot;</td>
<td>Register ADDSUB</td>
</tr>
<tr>
<td>REGLOADC</td>
<td>&quot;REGISTER&quot; (default) &quot;BYPASS&quot;</td>
<td>Register LOADC</td>
</tr>
</tbody>
</table>
### Table 150: MULTADDSUB36X36 Parameters (Continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>REGLOADC2</td>
<td>&quot;REGISTER&quot; (default)</td>
<td>Register LOADC, Second stage</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS&quot;</td>
<td></td>
</tr>
<tr>
<td>REGCIN</td>
<td>&quot;REGISTER&quot; (default)</td>
<td>Register CIN</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS&quot;</td>
<td></td>
</tr>
<tr>
<td>REGPIPELINE</td>
<td>&quot;REGISTER&quot; (default)</td>
<td>Register between multiplier and accumulator</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS&quot;</td>
<td></td>
</tr>
<tr>
<td>REGOUTPUT</td>
<td>&quot;REGISTER&quot; (default)</td>
<td>Register output</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS&quot;</td>
<td></td>
</tr>
<tr>
<td>GSR</td>
<td>&quot;ENABLED&quot; (default)</td>
<td>Enable global set/reset</td>
</tr>
<tr>
<td></td>
<td>&quot;DISABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>RESETMODE</td>
<td>&quot;SYNC&quot; (default)</td>
<td>Synchronous/asynchronous reset control. Reset release is always asynchronous</td>
</tr>
<tr>
<td></td>
<td>&quot;ASYNC&quot;</td>
<td></td>
</tr>
</tbody>
</table>

**NOTES:**

If LOADC = 1: \( Z[107:0] = C[107:0] +/-(A[35:0] \times B[35:0]) +/-(\text{CIN}) \)

If LOADC = 0: \( Z[107:0] = Z_{\text{prev}}[107:0] +/-(A[35:0] \times B[35:0]) +/-(\text{CIN}) \)

---

**MULTADDSUB9X9WIDE**

9x9 Wide Multiplier and Adder/Subtractor
Architectures Supported:

- LFD2NX
- LIFCL

INPUTS:

- A0[8:0] (Operand A0)
- B0[8:0] (Operand B0)
- A1[8:0] (Operand A1)
- B1[8:0] (Operand B1)
- A2[8:0] (Operand A2)
- B2[8:0] (Operand B2)
- A3[8:0] (Operand A3)
- B3[8:0] (Operand B3)
- C[53:0] (Operand C)
- CLK (Clock)
- CEA0A1 (Input A0 and A1 clock enable)
- CEA2A3 (Input A2 and A3 clock enable)
- RSTA0A1 (Input A0 and A1 register reset)
- RSTA2A3 (Input A2 and A3 register reset)
- CEB0B1 (Input B0 and B1 clock enable)
- CEB2B3 (Input B2 and B3 clock enable)
- RSTB0B1 (Input B0 and B1 register reset)
- RSTB2B3 (Input B2 and B3 register reset)
- CEC (Input C clock enable)
- RSTC (Input C register reset)
- RSTCTRL (Input control (addsub, m9addsub, signed, and loadc) reset)
- CECTRL (Input control (addsub, m9addsub, signed, and loadc) enable)
- SIGNED (One SIGNED port for all inputs due to ACC54 HW limitation)
- RSTPIPE (Output register reset)
- CEPIPE (Output clock enable)
- RSTOUT (Output register reset)
- CEOUT (Output register clock enable)
- LOADC (1=Load value from input C)
- ADDSUB[3:0] (0=add, 1=subtract)

OUTPUT:
- Z[53:0] (Multiplication result)

**Table 151: MULTADDSUB9X9WIDE Parameters**

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>REGINPUTAB0</td>
<td>&quot;REGISTER&quot; (default)</td>
<td>Register operand A/B 0</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS&quot;</td>
<td></td>
</tr>
<tr>
<td>REGINPUTAB1</td>
<td>&quot;REGISTER&quot; (default)</td>
<td>Register operand A/B 1</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS&quot;</td>
<td></td>
</tr>
<tr>
<td>REGINPUTAB2</td>
<td>&quot;REGISTER&quot; (default)</td>
<td>Register operand A/B 2</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS&quot;</td>
<td></td>
</tr>
<tr>
<td>REGINPUTAB3</td>
<td>&quot;REGISTER&quot; (default)</td>
<td>Register operand A/B 3</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS&quot;</td>
<td></td>
</tr>
<tr>
<td>REGINPUTC</td>
<td>&quot;REGISTER&quot; (default)</td>
<td>Register operand C</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS&quot;</td>
<td></td>
</tr>
<tr>
<td>REGADDSUB</td>
<td>&quot;REGISTER&quot; (default)</td>
<td>Register ADDSUB</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS&quot;</td>
<td></td>
</tr>
<tr>
<td>REGLOADC</td>
<td>&quot;REGISTER&quot; (default)</td>
<td>Register LOADC</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS&quot;</td>
<td></td>
</tr>
<tr>
<td>REGLOADC2</td>
<td>&quot;REGISTER&quot; (default)</td>
<td>Register LOADC, Second stage</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS&quot;</td>
<td></td>
</tr>
</tbody>
</table>
Alphanumeric Primitives List

NOTES:

If LOADC = 1:

\[ Z[53:0] = C[53:0] \pm/-( (A0[8:0] \times B0[8:0]) \pm/-(A1[8:0] \times B1[8:0])) \]
\[ \pm/-( (A2[8:0] \times B2[8:0]) \pm/-(A3[8:0] \times B3[8:0])) ) \]

If LOADC = 0:

\[ Z[53:0] = Z\text{prev}[53:0] \pm/-( (A0[8:0] \times B0[8:0]) \pm/-(A1[8:0] \times B1[8:0])) \]
\[ \pm/-( (A2[8:0] \times B2[8:0]) \pm/-(A3[8:0] \times B3[8:0])) ) \]

If LOADC = 0: REGOUTPUT must be **registered**; otherwise, it will result in a combinatorial lock.

Bits ADDSUB[3:0] controls the ‘addition’ or ‘subtraction’ options:

ADDSUB[3]: controls selection of addition/subtraction between A2B2 and A3B3

ADDSUB[2]: controls selection of addition/subtraction between A0B1 and A1B1

ADDSUB[1]: controls selection of addition/subtraction between C/Z\text{prev} and (A0B0 +/- A1B1)

ADDSUB[0]: controls selection of addition/subtraction between (A0B0 +/- A1B1) and (A2B2 +/- A3B3)

---

**Table 151: MULTADDSUB9X9WIDE Parameters (Continued)**

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>REGPIPELINE</td>
<td>&quot;REGISTER&quot; (default) &quot;BYPASS&quot;</td>
<td>Register between multiplier and accumulator</td>
</tr>
<tr>
<td>REGOUTPUT</td>
<td>&quot;REGISTER&quot; (default) &quot;BYPASS&quot;</td>
<td>Register output</td>
</tr>
<tr>
<td>GSR</td>
<td>&quot;ENABLED&quot; (default) &quot;DISABLED&quot;</td>
<td>Enable global set/reset</td>
</tr>
<tr>
<td>RESETMODE</td>
<td>&quot;SYNC&quot; (default) &quot;ASYNC&quot;</td>
<td>Synchronous/asynchronous reset control. Reset release is always asynchronous.</td>
</tr>
</tbody>
</table>

Register between multiplier and accumulator

Register output

Enable global set/reset

Synchronous/asynchronous reset control. Reset release is always asynchronous.
ADDSUB[0]: controls selection of addition/subtraction between (A0B0 +/- A1B1) and (A2B2 +/- A3B3)

MULTIBOOT
Wrapper for Interface for Multiboot Functionality

Architectures Supported:
- LFD2NX
- LIFCL

MULTIBOOT
AUTOREBOOT
MSPIMADDR[31:0]

INPUTS:
- AUTOREBOOT
- MSPIMADDR[31:0]
OUTPUT: None

Table 152: MULTIBOOT Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>MSPIADDR</td>
<td>0'b00000000000000000000000000000000 (default)</td>
<td></td>
</tr>
<tr>
<td>SOURCESEL</td>
<td>&quot;DIS&quot; (default)</td>
<td>&quot;EN&quot;</td>
</tr>
</tbody>
</table>

MULTPREADD18X18

18x18 Multiplier with Pre-Adder

Architectures Supported:
- LFD2NX
- LIFCL

MULTPREADD18X18

```
+------------------+
| A[8:0] | B[8:0] | C[8:0] |
+------------------+
| +CLK             |
| +CEA             |
| +RSTA            |
| +CEB             |
| +RSTB            |
| +CEC             |
| +RTC             |
| +SIGNEDA         |
| +SIGNEDB         |
| +SIGNEDC         |
| +RSTOUT          |
| +CEOUT           |
+------------------+
```

INPUTS:
- A[8:0] (Operand A)
- B[8:0] (Operand B)
- C[8:0] (Operand C)
- CLK (Clock)
- CEA (Input clock enable)
- RSTA (Input register reset)
- CEB (Input clock enable)
- RSTB (Input register reset)
- CEC (Input clock enable)
- RSTC (Input register reset)
- SIGNEDA (Operand A signed)
- SIGNEDB (Operand B signed)
- SIGNEDC (Operand C signed)
- RSTOUT (Output register reset)
- CEOUT (Output clock enable)

**OUTPUT:**
- Z[17:0] (Multiplication result)

### Table 153: MULTPREADD18X18 Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>REGINPUTA</td>
<td>&quot;REGISTER&quot; (default)</td>
<td>Register operand A</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS&quot;</td>
<td></td>
</tr>
<tr>
<td>REGINPUTB</td>
<td>&quot;REGISTER&quot; (default)</td>
<td>Register operand B</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS&quot;</td>
<td></td>
</tr>
<tr>
<td>REGINPUTC</td>
<td>&quot;REGISTER&quot; (default)</td>
<td>Register operand C</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS&quot;</td>
<td></td>
</tr>
<tr>
<td>REGOUTPUT</td>
<td>&quot;REGISTER&quot; (default)</td>
<td>Register output</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS&quot;</td>
<td></td>
</tr>
<tr>
<td>GSR</td>
<td>&quot;ENABLED&quot; (default)</td>
<td>Enable global set/reset</td>
</tr>
<tr>
<td></td>
<td>&quot;DISABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>RESETMODE</td>
<td>&quot;SYNC&quot; (default)</td>
<td></td>
</tr>
</tbody>
</table>

### NOTES:

Implements \( Z[17:0] = (B[8:0] + C[8:0]) \times A[8:0] \)
MULTPREADD9X9
9x9 Multiplier with Pre-adder

Architectures Supported:

- LFD2NX
- LIFCL

INPUTS:

- A[8:0] (Operand A)
- B[8:0] (Operand B)
- C[8:0] (Operand C)
- CLK (Clock)
- CEA (Input clock enable)
- RSTA (Input register reset)
- CEB (Input clock enable)
- RSTB (Input register reset)
- CEC (Input clock enable)
- RSTC (Input register reset)
- SIGNEDA (Operand A signed)
- SIGNEDB (Operand B signed)
- SIGNEDC (Operand C signed)
- RSTOUT (Output register reset)
- CEOUT (Output clock enable)

OUTPUT:

- Z[17:0] (Multiplication result)
Table 154: MULTPREADD9X9 Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>REGINPUTA</td>
<td>&quot;REGISTER&quot; (default) &quot;BYPASS&quot;</td>
<td>Register operand A</td>
</tr>
<tr>
<td>REGINPUTB</td>
<td>&quot;REGISTER&quot; (default) &quot;BYPASS&quot;</td>
<td>Register operand B</td>
</tr>
<tr>
<td>REGINPUTC</td>
<td>&quot;REGISTER&quot; (default) &quot;BYPASS&quot;</td>
<td>Register operand C</td>
</tr>
<tr>
<td>REGOUTPUT</td>
<td>&quot;REGISTER&quot; (default) &quot;BYPASS&quot;</td>
<td>Register output</td>
</tr>
<tr>
<td>GSR</td>
<td>&quot;ENABLED&quot; (default) &quot;DISABLED&quot;</td>
<td>Enable global set/reset</td>
</tr>
<tr>
<td>RESETMODE</td>
<td>&quot;SYNC&quot; (default) &quot;ASYNC&quot;</td>
<td>Synchronous/asynchronous reset control. Reset release is always asynchronous.</td>
</tr>
</tbody>
</table>

NOTES:

\[ Z[17:0] = A[8:0] \cdot ( B[8:0] + C[8:0] ) \]

OB

Output Buffer

Architectures Supported:

- LFD2NX
- LIFCL
iCE40 UltraPlus

\[
\begin{array}{c}
\text{OB} \\
\end{array}
\]

INPUT:
- I (Data from fabric)

OUTPUT:
- O (Data to pad)

PARAMETERS: None

In iCE40 UltraPlus, refer to Source Template.

**Table 155: OB Truth Table**

<table>
<thead>
<tr>
<th>Input</th>
<th>Output</th>
</tr>
</thead>
<tbody>
<tr>
<td>I</td>
<td>O</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Z</td>
<td>U</td>
</tr>
</tbody>
</table>

**OB_RGB**

Architectures Supported:
- iCE40 UltraPlus

\[
\begin{array}{c}
\text{OB_RGB} \\
\end{array}
\]

INPUTS:
- T_N (Tri-state control, active low)
- I (Data to pad)

OUTPUT:
O (Data from pad)

BIDIS:

B (Pad)

**OBZ**
Output Buffer with Tri-state

Architectures Supported:

- LIFCL
- LFD2NX

**Inputs:**

- I (Data to pad)
- T (Tri-state control)

**Output:**

- O (Output from pad)

**Table 156: OBZ Truth Table**

<table>
<thead>
<tr>
<th>Inputs</th>
<th>Output</th>
</tr>
</thead>
<tbody>
<tr>
<td>I</td>
<td>T</td>
</tr>
<tr>
<td>X</td>
<td>1</td>
</tr>
<tr>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>1</td>
<td>0</td>
</tr>
</tbody>
</table>

X = Don't care

**OBZ_B**
Output Buffer with Tri-state
Architectures Supported:

- iCE40 UltraPlus

**OBZ_B**

INPUTS:
- I (Data from fabric)
- T_N (Tri-state control, active low meaning T_N=0 → O = Z)

OUTPUTS:
- O (Data to pad)

### Table 157: OBZ_B Truth Table

<table>
<thead>
<tr>
<th>Inputs</th>
<th>Output</th>
</tr>
</thead>
<tbody>
<tr>
<td>I</td>
<td>T_N</td>
</tr>
<tr>
<td>X</td>
<td>0</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
</tr>
</tbody>
</table>

X = Don't care

**ODDR71**

7:1 LVDS ODDR

Architectures Supported:
- LFD2NX
LIFCL

This primitive is used for 7:1 LVDS ODDR implementation.

**INPUTS:**
- D[6:0]: Parallel data input to the ODDR. D0 is sent out first and D6 last.
- ECLK: Fast edge clock.
- SCLK: Primary clock input (divide-by-3.5 of ECLK).
- RST: Reset to DDR registers.

**OUTPUT:**
- Q: DDR data output on both edges of ECLK.

### Table 158: ODDR71 Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
<th>Values</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>GSR</td>
<td>Enable global set/reset.</td>
<td>&quot;ENABLED&quot;</td>
<td>&quot;DISABLED&quot;</td>
</tr>
</tbody>
</table>

ODDRX1

Generic X1 ODDR

**Architectures Supported:**
- LIFCL
- LFD2NX

This primitive is used to generate the address, command, and control except for CS_N for DDR3/DDR3L memory interfaces using X2 gearing.

**INPUTS:**
D0, D1: Parallel data input to ODDR. D0 is sent out first, then D1.

SCLK: Primary clock input.

RST: Reset to DDR registers.

**INPUT:**

- Q: DDR data output on both edges of SCLK.

**Table 159: ODDRX1 Parameters**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
<th>Values</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>GSR</td>
<td>Enable global set/reset.</td>
<td>&quot;ENABLED&quot;</td>
<td>ENABLED</td>
</tr>
<tr>
<td></td>
<td></td>
<td>&quot;DISABLED&quot;</td>
<td></td>
</tr>
</tbody>
</table>

**ODDRX2**

Generic X2 ODDR

**Architectures Supported:**

- LFD2NX
- LIFCL

This primitive is used to generate the address, command, and control except for CS_N for DDR3/DDR3L memory interfaces using X4 gearing.

**INPUTS:**

- D[3:0]: Parallel data input to the ODDR. D0 is sent out first and D3 last.
- ECLK: Fast edge clock.
- SCLK: Primary clock input (divide-by-2 of ECLK).
- RST: Reset to DDR registers.

**OUTPUT:**

- Q: DDR data output on both edges of ECLK.

**Table 160: ODDRX2 Parameters**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
<th>Values</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>GSR</td>
<td>Enable global set/reset.</td>
<td>&quot;ENABLED&quot;</td>
<td>ENABLED</td>
</tr>
<tr>
<td></td>
<td></td>
<td>&quot;DISABLED&quot;</td>
<td></td>
</tr>
</tbody>
</table>
ODDRX2DQ
DQ output for DDR2 & DDR3 memory

Architectures Supported:
- LFD2NX
- LIFCL

![ODDRX2DQ Diagram]

This primitive is used to generate the DQ data output for DDR3/DDR3L and LPDDR2/LPDDR3 memory interfaces. It is also used to generate the CA bus for LPDDR2/LPDDR3 interfaces.

INPUTS:
- D[3:0]: Data input to the ODDR. D0 is output first, D3 last.
- DQSW270: Clock that is 90° ahead of clock used to generate the DQS output.
- ECLK: Fast edge clock.
- SCLK: Primary clock input (divide-by-2 of ECLK).
- RST: Reset to DDR registers.

OUTPUT:
- Q: DDR data output on both edges of DQSW270.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
<th>Values</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>GSR</td>
<td>Enable global set/reset.</td>
<td>&quot;ENABLED&quot;</td>
<td>ENABLED</td>
</tr>
<tr>
<td></td>
<td></td>
<td>&quot;DISABLED&quot;</td>
<td></td>
</tr>
</tbody>
</table>

Table 161: ODDRX2DQ Parameters

ODDRX2DQS
DQS Output for DDR2 & DDR3 memory

Architectures Supported:
- LFD2NX
LIFCL

This primitive is used to generate the DQS data output for DDR3/DDR3L and LPDDR2/LPDDR3 memory interfaces. It is also used to generate CK and control signals (CKE, CS_N, ODT) for LPDDR2/LPDDR3 memory interfaces in X2 gearing mode.

INPUTS:
- D[3:0]: Data input to the ODDR. D0 is output first, D3 last.
- DQSW: DQSW includes write leveling phase shift from ECLK.
- ECLK: Fast edge clock.
- SCLK: Primary clock input (divide-by-2 of ECLK).
- RST: Reset to DDR registers.

INPUT:
- Q: DDR data output on both edges of DQSW.

Table 162: ODDRX2DQS Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
<th>Values</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>GSR</td>
<td>Enable global set/reset.</td>
<td>&quot;ENABLED&quot;  &quot;DISABLED&quot;</td>
<td>ENABLED</td>
</tr>
</tbody>
</table>

ODDRX4
Generic X4 ODDR

Architectures Supported:
- LFD2NX
**LIFCL**

This primitive is used for Generic x4 ODDR implementation.

**INPUTS:**
- **D[7:0]:** Parallel data input to the ODDR. D0 is sent out first and D7 last.
- **ECLK:** Fast edge clock.
- **SCLK:** Primary clock input (divide-by-4 of ECLK).
- **RST:** Reset to DDR registers.

**INPUT:**
- **Q:** DDR data output on both edges of ECLK.

**Table 163: ODDRX4 Parameters**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
<th>Values</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>GSR</td>
<td>Enable global set/reset.</td>
<td>&quot;ENABLED&quot;</td>
<td>&quot;DISABLED&quot;</td>
</tr>
</tbody>
</table>

**ODDRX4DQ**

DQ output for DDR3 memory

**Architectures Supported:**
- **LFD2NX**
This primitive is used to generate DQ data output for DDR3/DDR3L and LPDDR2/LPDDR3 memory interfaces using x4 gearing. It is also used to generate the CA bus for LPDDR2/LPDDR3 interfaces using X4 gearing.

**INPUTS:**
- D[7:0]: Data input to the ODDR. D0 is output first, D7 last.
- DQSW270: Clock that is 90° ahead of DQSW used to generate DQ. DQSW includes write leveling phase shift from ECLK.
- ECLK: Fast edge clock.
- SCLK: Primary clock input (divide-by-4 of ECLK).
- RST: Reset to DDR registers.

**INPUT:**
- Q: DDR data output on both edges of DQSW270.

**Table 164: ODDRX4DQ Parameters**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
<th>Values</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>GSR</td>
<td>Enable global set/reset.</td>
<td>&quot;ENABLED&quot;  &quot;DISABLED&quot;</td>
<td>ENABLED</td>
</tr>
</tbody>
</table>

**ODDRX4DQS**

DQS Output for DDR3 memory

Architectures Supported:
- LFD2NX
LIFCL

This primitive is used to generate DQS clock output for DDR3/DDR3L and LPDDR2/LPDDR3 memory interfaces using x4 gearing. It is also used to generate CK and control (CKE, CS_N, ODT) for LPDDR2/LPDDR3 memory interfaces using x4 gearing.

**INPUTS:**
- D[7:0]: Data input to the ODDR. D0 is output first, D7 last.
- DQSW: DQSW includes write leveling phase shift from ECLK.
- ECLK: Fast edge clock.
- SCLK: Primary clock input (divide-by-4 of ECLK).
- RST: Reset to DDR registers.

**OUTPUT:**
- Q: DDR data output on both edges of DQSW.

**Table 165: ODDRX4DQS Parameters**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
<th>Values</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>GSR</td>
<td>Enable global set/reset.</td>
<td>&quot;ENABLED&quot;</td>
<td>ENABLED</td>
</tr>
<tr>
<td></td>
<td></td>
<td>&quot;DISABLED&quot;</td>
<td></td>
</tr>
</tbody>
</table>

**ODDRX5**

Generic X5 ODDR

Architectures Supported:
- LFD2NX
LIFCL

This primitive is used for Generic x5 ODDR implementation.

INPUTS:
- D[9:0]: Parallel data input to the ODDR. D0 is sent out first and D9 last.
- ECLK: Fast edge clock.
- SCLK: Primary clock input (divide-by-5 of ECLK).
- RST: Reset to DDR registers.

OUTPUT:
- Q: DDR data output on both edges of ECLK.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
<th>Values</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>GSR</td>
<td>Enable global set/reset.</td>
<td>&quot;ENABLED&quot;</td>
<td>ENABLED</td>
</tr>
<tr>
<td></td>
<td></td>
<td>&quot;DISABLED&quot;</td>
<td></td>
</tr>
</tbody>
</table>

OFD1P3AZ
Positive edge triggered output D flip-flop with positive level enable.

Architectures Supported:
- iCE40 UltraPlus

OFD1P3AZ
INPUTS:
- D (data in)
- SP (clock enable, active high)
- CK (clock)

OUTPUT:
- Q (data out)

Table 167: OFD1P3AZ Truth Table

<table>
<thead>
<tr>
<th>Inputs</th>
<th>Output</th>
</tr>
</thead>
<tbody>
<tr>
<td>D</td>
<td>SP</td>
</tr>
<tr>
<td>X</td>
<td>0</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
</tr>
</tbody>
</table>

X = Don't care

**OFD1P3BX**
Positive Edge Triggered Output D Flip-Flop with Positive Level Enable and Positive Level Asynchronous Preset

Architectures Supported:
- LFD2NX
- LIFCL

INPUTS:
- D (Data in)
- SP (Clock enable, active high)
- CK (Clock)
- PD (Preset, active high)

OUTPUT:
Q (Data out to IO)

Table 168: OFD1P3BX Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>GSR</td>
<td>&quot;ENABLED&quot; (default)</td>
<td>Enable global set/reset</td>
</tr>
<tr>
<td></td>
<td>&quot;DISABLED&quot;</td>
<td></td>
</tr>
</tbody>
</table>

Table 169: OFD1P3BX Truth Table

<table>
<thead>
<tr>
<th>Inputs</th>
<th>Output</th>
</tr>
</thead>
<tbody>
<tr>
<td>D</td>
<td>SP</td>
</tr>
<tr>
<td>CK</td>
<td>PD</td>
</tr>
<tr>
<td>Q</td>
<td></td>
</tr>
</tbody>
</table>

X = Don't care

When GSR=0, Q=1 (D=SP=CK=PD=X)

**OFD1P3DX**

Positive Edge Triggered Output D Flip-Flop with Positive Level Enable and Positive Level Asynchronous Clear

Architectures Supported:

- **LFD2NX**
- **LIFCL**
- **OFD1P3DX**

INPUTS:

- D (Data in)
- SP (Clock enable, active high)
- CK (Clock)
- CD (Reset, active high)

OUTPUT:
Alphanumeric Primitives List

Q (Data out to IO)

Table 170: OFD1P3DX Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>GSR</td>
<td>&quot;ENABLED&quot; (default) &quot;DISABLED&quot;</td>
<td>Enable global set/reset</td>
</tr>
</tbody>
</table>

Table 171: OFD1P3DX Truth Table

<table>
<thead>
<tr>
<th>Inputs</th>
<th>Output</th>
</tr>
</thead>
<tbody>
<tr>
<td>D</td>
<td>SP</td>
</tr>
<tr>
<td>X</td>
<td>0</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
</tr>
</tbody>
</table>

X = Don't care

When GSR=0, Q=0 (D=SP=CK=CD=X)

**OFD1P3IX**
Positive Edge Triggered Output D Flip-Flop with Positive Level Synchronous clear and Positive Level Enable (Clear Overrides Enable)

Architectures Supported:

- LFD2NX
- LIFCL
- OFD1P3IX

INPUTS:

- D (Data in)
- SP (Clock enable, active high)
- CK (Clock)
- CD (Reset, active high)
OUTPUT:

- Q (Data out to IO)

### Table 172: OFD1P3IX Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>GSR</td>
<td>&quot;ENABLED&quot; (default)</td>
<td>Enable global set/reset</td>
</tr>
<tr>
<td></td>
<td>&quot;DISABLED&quot;</td>
<td></td>
</tr>
</tbody>
</table>

### Table 173: OFD1P3IX Truth Table

<table>
<thead>
<tr>
<th>Inputs</th>
<th>Output</th>
</tr>
</thead>
<tbody>
<tr>
<td>D</td>
<td>SP</td>
</tr>
<tr>
<td>X</td>
<td>0</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
</tr>
</tbody>
</table>

X = Don't care

When GSR=0, Q=0 (D=SP=CK=CD=X)

**OFD1P3JX**

Positive Edge Triggered Output D Flip-Flop with Positive Level Synchronous Preset and Positive Level Enable (Preset Overrides Enable)

Architectures Supported:

- LFD2NX
- LIFCL
- OFD1P3JX

INPUTS:

- D (Data in)
- SP (Clock enable, active high)
- CK (Clock)
- PD (Preset, active high)
OUTPUT:

- Q (Data out to IO)

Table 174: OFD1P3JX Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>GSR</td>
<td>&quot;ENABLED&quot; (default)</td>
<td>Enable global set/reset</td>
</tr>
<tr>
<td></td>
<td>&quot;DISABLED&quot;</td>
<td></td>
</tr>
</tbody>
</table>

Table 175: OFD1P3JX Truth Table

<table>
<thead>
<tr>
<th>Inputs</th>
<th>Output</th>
</tr>
</thead>
<tbody>
<tr>
<td>D</td>
<td>SP</td>
</tr>
<tr>
<td>X</td>
<td>0</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
</tr>
</tbody>
</table>

X = Don't care

When GSR=0, Q=1 (D=SP=CK=PD=X)

**OSC**

Wrapper for Oscillator Block

It includes a trimmed low frequency oscillator, and a trimmed high frequency oscillator.

Architectures Supported:

- LFD2NX
 INPUTS:
  ▶ HFSDSCEN
  ▶ JTAG_LRST_N
  ▶ LMMI_CLK
  ▶ LMMI_LRST_N
  ▶ SEDC_CLK
  ▶ SEDC_LRST_N
  ▶ WDT_LRST_N

 OUTPUTS:
  ▶ HFCLKOUT
  ▶ LFCLKOUT
  ▶ HFSDCOUT
  ▶ HSE_CLK
  ▶ LMMI_CLK_O
  ▶ LMMI_RST
  ▶ SEDC_RST
  ▶ CFG_CLK
  ▶ SMCLK_RST
  ▶ WDT_CLK
  ▶ WDT_RST
### NOTES:

The timer uses these device constraint equations to know what the periods of the output clocks of the Oscillator will be based on user design settings.

The numerical values in the equations have units of picoseconds.

For LFCLKOUT (created clock): ADJUSTED\_PERIOD=31250000

For I2CCKOUT (created clock): ADJUSTED\_PERIOD=7812500

For HFCLKOUT (created clock): ADJUSTED\_PERIOD=6666.66667 * HF\_CLK\_DIV

---

#### Table 176: OSC Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DTR_EN</td>
<td>&quot;ENABLED&quot; (default) &quot;DISABLED&quot;</td>
<td>DTR block enable from MIB</td>
</tr>
<tr>
<td>HF_CLK_DIV</td>
<td>1 (default) 0</td>
<td>User assignable HF oscillator output divider configuration (div2~div256)</td>
</tr>
<tr>
<td>HF_SED_SEC_DIV</td>
<td>1 (default) 0</td>
<td>User assignable HF oscillator output divider configuration (div2~div256)</td>
</tr>
<tr>
<td>HF_FABRIC_EN</td>
<td>&quot;DISABLED&quot; (default) &quot;ENABLED&quot;</td>
<td>High frequency oscillator trim source mux select</td>
</tr>
<tr>
<td>HF_OSC_EN</td>
<td>&quot;ENABLED&quot; (default) &quot;DISABLED&quot;</td>
<td>HF oscillator enable, controlled by the user</td>
</tr>
<tr>
<td>HFDIV_FABRIC_EN</td>
<td>&quot;ENABLED&quot; (default) &quot;DISABLED&quot;</td>
<td>High frequency oscillator divider configuration mux select, fabric divider enable</td>
</tr>
<tr>
<td>LF_FABRIC_EN</td>
<td>&quot;DISABLED&quot; (default) &quot;ENABLED&quot;</td>
<td>Low frequency oscillator trim source mux select, fabric driven trim enable (for TEST only)</td>
</tr>
<tr>
<td>LF_OUTPUT_EN</td>
<td>&quot;DISABLED&quot; (default) &quot;ENABLED&quot;</td>
<td>Low frequency clock output enable</td>
</tr>
<tr>
<td>DEBUG_N</td>
<td>&quot;DISABLED&quot; (default) &quot;ENABLED&quot;</td>
<td>Ignore/enable the SLEEP/STOP function during the USER mode. 0: Ignore the SLEEP/STOP mode</td>
</tr>
<tr>
<td>MCJTAGGSRNDIS</td>
<td>&quot;EN&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>MCCLMMIGSRNDIS</td>
<td>&quot;EN&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>MCSECDCGSRNDIS</td>
<td>&quot;EN&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>MCWDTGSRNDIS</td>
<td>&quot;EN&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SMCLK_DIV</td>
<td>3 (default)</td>
<td></td>
</tr>
</tbody>
</table>
For HFSDCOUT (created clock): \( \text{ADJUSTED\_PERIOD}=6666.66667 \times \text{HF\_SED\_SEC\_DIV} \)

**OSCA**

Internal Oscillator

Architectures Supported:

- LFD2NX
- LIFCL

**Inputs:**

- HFOUTEN
- HFSDSCEN

**Outputs:**

- HFCLKOUT
- LFCLKOUT
- HFCLKCFG
- HFSDCOUT

**Table 177: OSCA Parameters**

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
<th>Inferable</th>
</tr>
</thead>
<tbody>
<tr>
<td>HF_CLK_DIV</td>
<td>1 (default)</td>
<td></td>
<td>No</td>
</tr>
<tr>
<td>HF_SED_SEC_DIV</td>
<td>1 (default)</td>
<td></td>
<td>No</td>
</tr>
<tr>
<td>HF_OSC_EN</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
<td>No</td>
</tr>
<tr>
<td>LF_OUTPUT_EN</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
<td>No</td>
</tr>
</tbody>
</table>
OSCA is the source of the internal clock for configuration. After configuration this oscillator is disabled by default. If needed, it can be enabled by instantiating OSCA or Sysbus (with sys_clk_sel=OSC option). OSCA may be used as a general-purpose clock to drive FPGA logic.

**OSHX2**

Architectures Supported:
- LFD2NX
- LIFCL

This primitive is used to generate the CS_N control for DDR3/DDR3L memory with x2 gearing.

**INPUTS:**
- D0, D1: Data input. D0 is output first, followed by D1.
- ECLK: ECLK input.
- SCLK: Primary clock input (divide-by-2 of ECLK).
- RST: Reset input.

**OUTPUT:**
- Q: Address and command output.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
<th>Values</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>GSR</td>
<td>Enable global set/reset.</td>
<td>&quot;ENABLED&quot; &quot;DISABLED&quot;</td>
<td>ENABLED</td>
</tr>
</tbody>
</table>

**OSHX4**

Architectures Supported:
- LFD2NX
This primitive is used to generate the CS_N control for DDR3 memory with x4 gearing and write leveling.

INPUTS:
► D[3:0]: Data input. D0 is output first, D3 last.
► ECLK: ECLK input.
► SCLK: Primary clock input (divide-by-4 of ECLK):
► RST: Reset input.

OUTPUT:
► Q: Address and command output.

Table 179: OSHX4 Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
<th>Values</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>GSR</td>
<td>Enable global set/reset</td>
<td>&quot;ENABLED&quot;</td>
<td>&quot;DISABLED&quot;</td>
</tr>
</tbody>
</table>

PCIE
Wrapper for Hardened PCIE Interface

Note
You should not try to use this primitive directly. Instead, use the related IP in IP Catalog. The following information is for reference only.

Architectures Supported:
► LIFCL
INPUTS:
- LMMICLK (Clock)
- LMMIRESET_N (Reset)
- LMMIREQUEST (Start transaction)
- LMMIWR RD_N (Write = HIGH, Read = LOW)
- LMMIOFFSET[16:0] (Word Address/Offset)
- LMMIWDATA[31:0] (Write data)
- AUXCK
- CKUSRI
- ECKIN
- ECKIND2
- ERSTN
- ERSTND2
- ERXCKD2
- ERXRSND2
- ETXCKD2
- ETXRSND2
- FLRACK[3:0]
- MINTLEG[3:0]
- PERSTN
- PMDPAST[4:0]
- PRMSGSD
- PRNOSNP[12:0]
- PRNSNPRE
- PRSNOOP[12:0]
- PRSNPRE
- PPBDREG[31:0]
- REXTCK
- REXTRST
- RSTUSRN
- ULTSDIS
- UCFGADDR[9:0]
- UCFGF[2:0]
- UCFGSERD
- UCFGVD
- UCFGWRBE[3:0]
- UCFGWRD[31:0]
- UCFGWRDN
- USERAUPD
- USERTRS[3:0]
- VRXCINIT
- VRXCNH[11:0]
- VRXCNINF
- VRXCRRE
- VRXRDY
- VXD[31:0]
- VXDP[3:0]
- VXEOPE
- VXEOPN
- VXSOPE
- VXVDE
- S0REFCKN
- S0REFCKP
- S0REFRET
- S0REXT
- S0RXN
- S0RXP
- CLKREQI

OUTPUTS:
- LMMIRDATA[31:0] (Read data)
- LMMIRDATAVALID (Valid data indicator)
- LMMIREADY (Slave ready signal.)
- ACJNOUT
- ACJPOUT
- CKUSRO
- ECKINDO
- ERXCKDO
- ETXCKDO
- FLR[3:0]
- MINTO
- PMCTRL[4:0]
- PMCTRLLEN
- PPBDSEL[7:0]
- UDLLKUP
- UPLLKUP
- UTLLKUP
- UCFGRDD[31:0]
- UCFGRDE
- UCFGRDY
- VRXCMDD[12:0]
- VRXD[31:0]
- VRXD[31:0]
- VRXDP[3:0]
- VRXEOP
- VRXERR
- VRXF[1:0]
- VRXSEL[1:0]
- VRXSOP
- VRXVD
- VXCDINIT
- VXCDNH[11:0]
- VTXCRRE
- VXRDY
- TESTOUT[7:0]
- S0TXN
- S0TXP
- CLKREQO
- CLKREQOE

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>A_CHNGD_MAX</td>
<td>&quot;0b100&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>A0_FORCE</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>A0_FREEZE</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>A0_INIT</td>
<td>&quot;0b000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>A0_DIR_VAL</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>A1_FORCE</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>A1_FREEZE</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>A1_INIT</td>
<td>&quot;0b000000&quot; (default)</td>
<td></td>
</tr>
</tbody>
</table>
### Table 180: PCIE Parameters (Continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>A1DIR_VAL</td>
<td>&quot;DISABLED&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>A2_FORCE</td>
<td>&quot;DISABLED&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>A2_FREEZE</td>
<td>&quot;DISABLED&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>A2_INIT</td>
<td>&quot;0'b000000&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>A2GAIN_CALIB</td>
<td>&quot;0'b100110&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>ACJTAG_REG</td>
<td>&quot;0'b00&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>ADDR_LIMIT_PRE_MTHD_CTRL</td>
<td>&quot;0'b0100&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>ADDR_LIMIT_TABLE_MTHD_CTRL</td>
<td>&quot;0'b00101&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>ADIR_OVR</td>
<td>&quot;DISABLED&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>ADV_CH_CD_SEL</td>
<td>&quot;IMPLEMENT_CH&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>ADV_TARGET_LINK_SPEED_USPORT_A</td>
<td>&quot;DISABLED&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>ADV_TARGET_LINK_SPEED_USPORT_B</td>
<td>&quot;DISABLED&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>ADV_TARGET_LINK_SPEED_USPORT_C</td>
<td>&quot;DISABLED&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>ADV_TARGET_LINK_SPEED_USPORT_D</td>
<td>&quot;DISABLED&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>ADVANCE</td>
<td>&quot;DISABLED&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>ALERT_ENABLE</td>
<td>&quot;0'b000&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>ALMOST_EMPTY_10B</td>
<td>&quot;0'b001110&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>ALMOST_EMPTY_20B</td>
<td>&quot;0'b001111&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>ALMOST_EMPTY_GEN3</td>
<td>&quot;0'b001100&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>ALMOST_FULL_10B</td>
<td>&quot;0'b110000&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>ALMOST_FULL_20B</td>
<td>&quot;0'b011000&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>ALMOST_FULL_GEN3</td>
<td>&quot;0'b010110&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>ALT_CLK_SEL_VCC</td>
<td>&quot;PAD&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>ARRAY_DA</td>
<td>&quot;0'b000000000000000000000000000000000000000</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
: Alphanumeric Primitives List

Table 180: PCIE Parameters (Continued)
Name

Values

ARRAY_MT

"0’b000000000000000000000000000000000000000
000000000000000000000000000000000000000000
000000000000000000000000000000000000000000
000000000000000000000000000000000000000000
000000000000000000000000000000000000000000
000000000000000000000000000000000000000000
000000000000000000000000000000000000000010
000000000011100000000000010000000000000001
001000000000000011000000000000001010000000
000000100" (default)

ARXCAL_OUT

"DISABLED" (default)

ARXCDRICP_RATE0

"0’b011" (default)

ARXCDRICP_RATE1

"0’b011" (default)

ARXCDRICP_RATE2

"0’b011" (default)

ARXDMPWRDWN

"DISABLED" (default)

ARXDPPWRDN

"DISABLED" (default)

ARXEOM_PWRDN

"POWERED_DOWN" (default)

ARXICP_RATE0

"0’b011" (default)

ARXICP_RATE1

"0’b011" (default)

ARXICP_RATE2

"0’b011" (default)

ARXOVR_OUT

"DISABLED" (default)

ARXRSACTAT

"0’b0001" (default)

ARXRSAPTAT

"0’b1000" (default)

ARXRSVCTL

"0’b00000000" (default)

ARXSEL_OUT

"DISABLED" (default)

ASPM_L1_1_SUPPORTED

"SUPPORTED" (default)

ASPM_L1_2_SUPPORTED

"SUPPORTED" (default)

ASPM_SUPPORT

"L0S_AND_L1_SUPPORTED" (default)

ATTENTION_BUTTON_PRESENT

"NOT_SUPPORTED" (default)

ATTENTION_INDICATOR_PRESENT

"NOT_SUPPORTED" (default)

ATXICP_RATE0

"0’b101" (default)

ATXICP_RATE1

"0’b101" (default)

ATXICP_RATE2

"0’b100" (default)

AUTO_SHIFT

"ENABLED" (default)

AUTONOMOUS_WIDTH_CHANGE

"OTHERWISE" (default)

AUX_CLK_PERIOD

"0’b1111010000100100" (default)

Lattice Radiant Software 2.2 Help

Description

815


<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AUX_CURRENT</td>
<td>&quot;SELFPOWERED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>AUXCLK1US_MAX</td>
<td>&quot;0'b00001001&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>AUXIDL_MAX</td>
<td>&quot;0'b00000100&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>BAR_INDEX_CFG0_A</td>
<td>&quot;0'b000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>BAR_INDEX_CFG0_B</td>
<td>&quot;0'b000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>BAR_INDEX_CFG0_C</td>
<td>&quot;0'b000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>BAR_INDEX_CFG0_D</td>
<td>&quot;0'b000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>BAR_INDEX_CFG1_A</td>
<td>&quot;0'b001&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>BAR_INDEX_CFG1_B</td>
<td>&quot;0'b001&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>BAR_INDEX_CFG1_C</td>
<td>&quot;0'b001&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>BAR_INDEX_CFG1_D</td>
<td>&quot;0'b001&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>BAR_INDEX_CFG2_A</td>
<td>&quot;0'b010&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>BAR_INDEX_CFG2_B</td>
<td>&quot;0'b010&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>BAR_INDEX_CFG2_C</td>
<td>&quot;0'b010&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>BAR_INDEX_CFG2_D</td>
<td>&quot;0'b010&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>BAR_INDEX_CFG3_A</td>
<td>&quot;0'b011&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>BAR_INDEX_CFG3_B</td>
<td>&quot;0'b011&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>BAR_INDEX_CFG3_C</td>
<td>&quot;0'b011&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>BAR_INDEX_CFG3_D</td>
<td>&quot;0'b011&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>BAR_INDEX_CFG4_A</td>
<td>&quot;0'b100&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>BAR_INDEX_CFG4_B</td>
<td>&quot;0'b100&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>BAR_INDEX_CFG4_C</td>
<td>&quot;0'b100&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>BAR_INDEX_CFG4_D</td>
<td>&quot;0'b100&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>BAR_INDEX_CFG5_A</td>
<td>&quot;0'b101&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>BAR_INDEX_CFG5_B</td>
<td>&quot;0'b101&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>BAR_INDEX_CFG5_C</td>
<td>&quot;0'b101&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>BAR_INDEX_CFG5_D</td>
<td>&quot;0'b101&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>BIR_MSIX_PBA_A</td>
<td>&quot;BAR0&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>BIR_MSIX_PBA_B</td>
<td>&quot;BAR0&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>BIR_MSIX_PBA_C</td>
<td>&quot;BAR0&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>BIR_MSIX_PBA_D</td>
<td>&quot;BAR0&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>BIR_MSIX_TABLE_A</td>
<td>&quot;BAR0&quot; (default)</td>
<td></td>
</tr>
</tbody>
</table>
### Table 180: PCIE Parameters (Continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>BIR_MSIX_TABLE_A</td>
<td>&quot;BAR0&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>BIR_MSIX_TABLE_B</td>
<td>&quot;BAR0&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>BIR_MSIX_TABLE_C</td>
<td>&quot;BAR0&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>BIR_MSIX_TABLE_D</td>
<td>&quot;BAR0&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>BYP_AVG</td>
<td>&quot;USED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>BYPASS</td>
<td>&quot;PERFORM_RECEIVER_DETECTION&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>BYPASS_ADDR_DEC</td>
<td>&quot;NORMAL&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>C_RX_LIM_D</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>C_RX_LIM_H</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>C_TX_LIM_D</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>C_TX_LIM_H</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CALIB_3DB</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CALIB_SETTLE_MAX</td>
<td>&quot;0'b001&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CALIB_STABLE_MAX</td>
<td>&quot;0'b11000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CAPABILITY_VERSION</td>
<td>&quot;0'b0010&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CDR_ERR</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CDR_P1</td>
<td>&quot;CDR_PLL_RESET&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CDR_PLL_DELTA</td>
<td>&quot;0P4_PERCENT&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CDR_REFERENCE</td>
<td>&quot;0'b000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CDRPLL_CMP_MAX</td>
<td>&quot;0'b00010100&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CDRPLL_CNT_MAX</td>
<td>&quot;0'b00000100&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CDRPLL_PRE_RXEQ_COARSE_TIMER</td>
<td>&quot;0'b01010000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CDRPLL_PRE_RXEQ_FINE_TIMER</td>
<td>&quot;0'b10110100&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CDRPLL_PST_RXEQ_COARSE_TIMER</td>
<td>&quot;0'b01000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CDRPLL_PST_RXEQ_FINE_TIMER</td>
<td>&quot;0'b01000010&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CFG_A_BAR0</td>
<td>&quot;0'b11111111111111110000000000001100&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CFG_A_BAR1</td>
<td>&quot;0'b11111111111111111111111111111111&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CFG_A_BAR2</td>
<td>&quot;0'b11111111111111111111111111111111&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CFG_A_BAR3</td>
<td>&quot;0'b11111111111111111111111111111111&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CFG_A_BAR4</td>
<td>&quot;0'b11111111111111111111111111111111&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CFG_A_BAR5</td>
<td>&quot;0'b11111111111111111111111111111111&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CFG_B_BAR0</td>
<td>&quot;0'b11111111111111111111111111111111&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CFG_B_BAR1</td>
<td>&quot;0'b11111111111111111111111111111111&quot; (default)</td>
<td></td>
</tr>
</tbody>
</table>
### Table 180: PCIE Parameters (Continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CFG_B_BAR2</td>
<td>&quot;0'b11111111111111111111111111111111&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CFG_B_BAR3</td>
<td>&quot;0'b11111111111111111111111111111111&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CFG_B_BAR4</td>
<td>&quot;0'b11111111111111111111111111111111&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CFG_B_BAR5</td>
<td>&quot;0'b11111111111111111111111111111111&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CFG_C_BAR0</td>
<td>&quot;0'b11111111111111110000000000001100&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CFG_C_BAR1</td>
<td>&quot;0'b11111111111111111111111111111111&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CFG_C_BAR2</td>
<td>&quot;0'b11111111111111111111111111111111&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CFG_C_BAR3</td>
<td>&quot;0'b11111111111111111111111111111111&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CFG_C_BAR4</td>
<td>&quot;0'b11111111111111111111111111111111&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CFG_C_BAR5</td>
<td>&quot;0'b11111111111111111111111111111111&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CFG_D_BAR0</td>
<td>&quot;0'b11111111111111111111111111111111&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CFG_D_BAR1</td>
<td>&quot;0'b11111111111111111111111111111111&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CFG_D_BAR2</td>
<td>&quot;0'b11111111111111111111111111111111&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CFG_D_BAR3</td>
<td>&quot;0'b11111111111111111111111111111111&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CFG_D_BAR4</td>
<td>&quot;0'b11111111111111111111111111111111&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CFG_D_BAR5</td>
<td>&quot;0'b11111111111111111111111111111111&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CFG_EXP_ROM_A</td>
<td>&quot;0'b00000000000000000000000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CFG_EXP_ROM_B</td>
<td>&quot;0'b00000000000000000000000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CFG_EXP_ROM_C</td>
<td>&quot;0'b00000000000000000000000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CFG_EXP_ROM_D</td>
<td>&quot;0'b00000000000000000000000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CIS_POINTER_CARDBUS_A</td>
<td>&quot;0'b00000000000000000000000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CIS_POINTER_CARDBUS_B</td>
<td>&quot;0'b00000000000000000000000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CIS_POINTER_CARDBUS_C</td>
<td>&quot;0'b00000000000000000000000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CIS_POINTER_CARDBUS_D</td>
<td>&quot;0'b00000000000000000000000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CLASS_CODE_ID3A</td>
<td>&quot;0'b00010001100000000000000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CLASS_CODE_ID3B</td>
<td>&quot;0'b00010001100000000000000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CLASS_CODE_ID3C</td>
<td>&quot;0'b00010001100000000000000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td>Values</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>---------------------------------------------</td>
<td>--------------------------------------------------</td>
</tr>
<tr>
<td>CLASS_CODE_ID3D</td>
<td>&quot;0'b000100011000000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CM_RESTORE_TIME</td>
<td>&quot;0'b00000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CNT250NS_MAX</td>
<td>&quot;0'b0011111100&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>COARSE_GAIN</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>COEF_EN_LPBK_MASTER</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>COEF_EN_LPBK_SLAVE</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>COEF_ENABLE</td>
<td>&quot;DETERMINE_LOCAL_PHY&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>COEF_ENABLE_8G</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>COEF_EQTX_FORCE</td>
<td>&quot;0'b000000000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>COEF_LPBK_MASTER</td>
<td>&quot;0'b000000000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>COEF_LPBK_SLAVE</td>
<td>&quot;0'b000000000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>COEF0_POST</td>
<td>&quot;0'b000101&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>COEF0_POST_CURSOR</td>
<td>&quot;0'b000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>COEF0_PRE</td>
<td>&quot;0'b000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>COEF0_PRE_CURSOR</td>
<td>&quot;0'b000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>COEF1_POST</td>
<td>&quot;0'b000011&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>COEF1_POST_CURSOR</td>
<td>&quot;0'b000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>COEF1_PRE</td>
<td>&quot;0'b000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>COEF1_PRE_CURSOR</td>
<td>&quot;0'b000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>COEF10_POST</td>
<td>&quot;0'b000111&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>COEF10_PRE</td>
<td>&quot;0'b000111&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>COEF2_POST</td>
<td>&quot;0'b000100&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>COEF2_POST_CURSOR</td>
<td>&quot;0'b000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>COEF2_PRE</td>
<td>&quot;0'b000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>COEF2_PRE_CURSOR</td>
<td>&quot;0'b000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>COEF3_POST</td>
<td>&quot;0'b000010&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>COEF3_POST_CURSOR</td>
<td>&quot;0'b000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>COEF3_PRE</td>
<td>&quot;0'b000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>COEF3_PRE_CURSOR</td>
<td>&quot;0'b000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>COEF4_POST</td>
<td>&quot;0'b000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>COEF4_PRE</td>
<td>&quot;0'b000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>COEF5_POST</td>
<td>&quot;0'b000000&quot; (default)</td>
<td></td>
</tr>
</tbody>
</table>
Table 180: PCIE Parameters (Continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>COEF6_POST</td>
<td>&quot;0'b000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>COEF6_PRE</td>
<td>&quot;0'b000010&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>COEF7_POST</td>
<td>&quot;0'b000100&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>COEF7_PRE</td>
<td>&quot;0'b000011&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>COEF8_POST</td>
<td>&quot;0'b000011&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>COEF8_PRE</td>
<td>&quot;0'b000010&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>COEF9_POST</td>
<td>&quot;0'b000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>COEF9_PRE</td>
<td>&quot;0'b000011&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>COMP_128_SUPPORTED</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>COMP_32_SUPPORTED</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>COMP_64_SUPPORTED</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>COMPLETE</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>COMPLIANCE</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CONV_METHOD</td>
<td>&quot;COMPUTE_PCIE_SPEC&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CORE_BYPASS</td>
<td>&quot;NORMAL&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CORE_EN</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>COUNT_ACK_TO_NAK</td>
<td>&quot;0'b00000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CPL_TIMEOUT_DISABLE_SUPPORTED</td>
<td>&quot;SUPPORTED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CPL_TIMEOUT_RANGES_SUPPORTED</td>
<td>&quot;NOT_SUPPORTED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CRS_ENABLE</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CSTAT_DATA_SCALE</td>
<td>&quot;UNKNOWN_SCALE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CSTAT_DATA_SELECT</td>
<td>&quot;D0_POWER_CONSUMED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CTLE_SETTLE</td>
<td>&quot;0'b100&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CTLEBIAS_1</td>
<td>&quot;0'b1000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CTLEBYPASS</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CUR_FOM</td>
<td>&quot;NUMBER_OF_CLOCK&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CUR_FOM_AVG</td>
<td>&quot;0'b101&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CUST_AUTO</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CUST_CHK</td>
<td>&quot;SET&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CUST_SEL</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CUST_SKIP</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>CUST_TYP</td>
<td>&quot;0'b000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td>Values</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>------------------------------------------------------------------------</td>
<td>--------------------------------------</td>
</tr>
<tr>
<td>CUSTOM_PATTERN</td>
<td>&quot;0'b000000000000000000000000000000000000000000000000000000000000000</td>
<td><em>(default)</em></td>
</tr>
<tr>
<td>D1_SUPPORT</td>
<td>&quot;SUPPORTED&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>D2_SUPPORT</td>
<td>&quot;SUPPORTED&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>DATA_DETECT0</td>
<td>&quot;OTHERWISE&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>DATA_DETECT1</td>
<td>&quot;OTHERWISE&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>DATA_DETECT2</td>
<td>&quot;OTHERWISE&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>DATA_DETECT3</td>
<td>&quot;OTHERWISE&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>DATA_INJECT</td>
<td>&quot;0'b00000000000000000000000000000000&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>DATA_PM</td>
<td>&quot;0'b00000000&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>DB_UPSTREAM</td>
<td>&quot;6DB&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>DEEMPH_5G_3_5DB_6DB_N</td>
<td>&quot;6DB&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>DEEMPH_5G_ENABLE</td>
<td>&quot;DISABLED&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>DEEMPH_LPBK_MASTER</td>
<td>&quot;6P0DB&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>DEEMPH_LPBK_SLAVE</td>
<td>&quot;6P0DB&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>DEVICE_ID_ID1A</td>
<td>&quot;0'b1110000000000000100&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>DEVICE_ID_ID1B</td>
<td>&quot;0'b1110000000000000100&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>DEVICE_ID_ID1C</td>
<td>&quot;0'b1110000000000000100&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>DEVICE_ID_ID1D</td>
<td>&quot;0'b1110000000000000100&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>DEVICE_PORT_TYPE</td>
<td>&quot;PCIE_ENDPOINT&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>DFE_BIAS</td>
<td>&quot;0'b0001&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>DFE_PWDN</td>
<td>&quot;DISABLED&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>DIR</td>
<td>&quot;RECEIVE&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>DIR_PRE_GAIN</td>
<td>&quot;0'b00&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>DIR_PST_GAIN</td>
<td>&quot;0'b01&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>DIRECT_SPEED_CHANGE</td>
<td>&quot;OTHERWISE&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>DIRECT_TO_DETECT_FAST</td>
<td>&quot;OTHERWISE&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>DIRECT_TO_DISABLE</td>
<td>&quot;OTHERWISE&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>DIRECT_TO_HOT_RESET</td>
<td>&quot;OTHERWISE&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>DIRECT_TO_LPBK_ENTRY</td>
<td>&quot;OTHERWISE&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>DIRECT_TO_RCVRY_CH_BOND</td>
<td>&quot;OTHERWISE&quot; <em>(default)</em></td>
<td></td>
</tr>
</tbody>
</table>
Table 180: PCIE Parameters (Continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DIRECT_TO_RCVRY_FRAME</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>DIRECT_TO_RCVRY_PHY</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>DIRECT_TO_RCVRY_REPLAY</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>DIS_ARI_CAP</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>DIS_CSR_RST</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>DIS_FUNC_B</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>DIS_FUNC_C</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>DIS_FUNC_D</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>DIS_INTERRUPT</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>DIS_INTERRUPT_B</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>DIS_INTERRUPT_C</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>DIS_INTERRUPT_D</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>DIS_MSI_CAP</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>DIS_MSI_CAP_B</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>DIS_MSI_CAP_C</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>DIS_MSI_CAP_D</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>DIS_PREVENT</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>DISABLE_FLR_CAPABILITY</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>DLLP_CRC_ERR_ENABLE</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>DLLP_CRC_ERR_RATE</td>
<td>&quot;0'b000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>DLLP_INJECT_ENABLE</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>DOUBLE_TX_DATA_VALID</td>
<td>&quot;ONE_CLK_EVERY_64_CLKS&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>DOWNSTREAM_EQ_SKIP_PHASE_2_3</td>
<td>&quot;NORMAL_OPERATION&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>DS_DRIVE_CLKREQ</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>DS_PORT_RX_PRESET_HINT</td>
<td>&quot;0'b001&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>DS_PORT_TX_PRESET</td>
<td>&quot;0'b0011&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>DS_US_N_PORTTYPE</td>
<td>&quot;UPSTREAM&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>DSI</td>
<td>&quot;NO_DSI_NECESSARY&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>DSP_DIR</td>
<td>&quot;ANALYSIS_OF_DATA_BY_DSP&quot; (default)</td>
<td></td>
</tr>
</tbody>
</table>
Table 180: PCIE Parameters (Continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DSPDIR_PRESGN</td>
<td>&quot;0'b11110000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>DSPDIR_PREVAL</td>
<td>&quot;0'b00011000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>DSPDIR_PSTSGN0</td>
<td>&quot;0'b11111111&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>DSPDIR_PSTSGN1</td>
<td>&quot;0'b00000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>DSPDIR_PSTVAL0</td>
<td>&quot;0'b00000010&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>DSPDIR_PSTVAL1</td>
<td>&quot;0'b01000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EARLY_RX_EVAL</td>
<td>&quot;RX_SIGNAL_AFTER_TS1&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>ECRC_GEN_CHK_CAPABLE</td>
<td>&quot;SUPPORTED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EFF_LPBK</td>
<td>&quot;PASSED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EI4</td>
<td>&quot;EI_IV&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EIE_DETECT0</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EIE_DETECT1</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EIE_DETECT2</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EIE_DETECT3</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EIOS_DETECT0</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EIOS_DETECT1</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EIOS_DETECT2</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EIOS_DETECT3</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EM_INTERLOCK_PRESENT</td>
<td>&quot;NOT_SUPPORTED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EN</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EN_ACK_TO_DIV</td>
<td>&quot;ACK_SPEC&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EN_ACK_TO_NAK</td>
<td>&quot;DO NOTHING&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EN_ACS_VIOLATION</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EN_ASPM_L0S</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EN_ASPM_L1</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EN_ATOMIC_OP_CAP</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EN_ATOMICOP_EGRESS_BLOCKED</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EN_ATS_CAP</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EN_BDGT_CAP</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EN_CAP</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EN_CAP_B</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EN_CAP_C</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
</tbody>
</table>
Table 180: PCIE Parameters (Continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>EN_CAP_D</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EN_COMPLETER_ABORT</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EN_COMPLETION_TIMEOUT</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EN_CORR_INTERNAL_ERROR</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EN_DPA_CAP</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EN_DRCT_SCR_OFF</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EN_DRCT_TO_LPBK</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EN_EQTX_OVERRIDE</td>
<td>&quot;PIPE_LOCAL_FS_AND_PIPE_LOCAL_LF&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EN_FORCE_SCR_OFF_FAST</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EN_L1</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EN_L1PMSS_CAP</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EN_L2</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EN_LPBK_ERR_RST</td>
<td>&quot;MASTER_LPBK_INCREMENT&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EN_LTR_CAP</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EN_MC_BLOCKED_TLP</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EN_NWL_VSEC_CAP</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>ENPIPE_IF_CTRL</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EN_PORT_DIS</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EN_PORT_INTLEG</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EN_RBAR_CAP_A</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EN_RBAR_CAP_C</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EN_RBAR_CAP_D</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EN_RECEIVER_OVERFLOW</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EN_RX_ALLOC_SEL</td>
<td>&quot;HW&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EN_SELF_XLINK</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EN_SURPRISE_DOWN_ERROR</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EN_TLP_PREFIX_BLOCKED</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EN_TX_ALLOC_SEL</td>
<td>&quot;HW&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EN_UCORR_INTERNAL_ERROR</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EN_USER_WRITE</td>
<td>&quot;READ_WRITE_ACCESS&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>ENABLE_USER_CFG</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>END_END_PREFIXES_SUPPORTED</td>
<td>&quot;NOT_SUPPORTED&quot; (default)</td>
<td></td>
</tr>
</tbody>
</table>
Table 180: PCIE Parameters (Continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>END_ON_HOLD</td>
<td>&quot;YES_EXIT_ON_HOLD&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>ENDCALLIB_MAX</td>
<td>&quot;0'b10000100&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>ENDPOINT_L0S_ACCEPTABLE_LATENCY</td>
<td>&quot;MAX_64_NS&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>ENDPOINT_L1_ACCEPTABLE_LATENCY</td>
<td>&quot;MAX_1_US&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>ENTRY_TIME_ASHPM_L0S</td>
<td>&quot;0'b0000000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>ENTRY_TIME_ASHPM_L1</td>
<td>&quot;0'b0000000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EOM_TIME</td>
<td>&quot;0'b0000000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EOMDIR</td>
<td>&quot;SELECT_DIR_1&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EOM1DIR</td>
<td>&quot;SELECT_DIR_0&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EOMCTRL0_LOW</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EOMDIVDIS</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EOMMODE</td>
<td>&quot;0'b00&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EOMRDSEL</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EOMSTART</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EOMX</td>
<td>&quot;0'b0000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EOMX_UPDATE_CNT_VALUE</td>
<td>&quot;0'b0011111&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EOMY</td>
<td>&quot;0'b000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>ERR_AER_BAD_DLLP</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>ERR_AER_BAD_TLP</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>ERR_AER_DL_PROTOCOL_ERROR</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>ERR_AER_RECEIVER_ERROR</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>ERR_AER_REPLAY_NUM_ROLLOVER</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>ERR_AER_REPLAY_TIMER_TIMEOUT</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>ERR_AER_SURPRISE_DOWN</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>ERR_AER_TX_PAR2</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>ERR_AER_TX_REPLAY_ECC1</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>ERR_AER_TX_REPLAY_ECC2</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>ERR_REC_ENTRY_SEL</td>
<td>&quot;RCVRY_AFTER&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>ERR_TX_PIPE_UNDERFLOW</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>ERRCNT_DEC</td>
<td>&quot;0'b00100000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>ERRCNT_THR</td>
<td>&quot;0'b1000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>ES_PWDN</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td>Values</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------------</td>
<td>-----------------------------</td>
<td>--------------------------------------------------</td>
</tr>
<tr>
<td>EVAL_RST</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EXCLUDE_CFG_COMPLETE</td>
<td>&quot;INCLUDE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EXCLUDE_CFG_IDLE</td>
<td>&quot;INCLUDE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EXCLUDE_L0</td>
<td>&quot;INCLUDE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EXCLUDE_LOOPBACK_MASTER</td>
<td>&quot;INCLUDE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EXCLUDE_REC_IDLE</td>
<td>&quot;INCLUDE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EXCLUDE_REC_RCVR_CFG</td>
<td>&quot;INCLUDE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EXIT_DIRECT_TO_DETECT</td>
<td>&quot;DO_NOT_EXIT_TO_DETECT&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EXT_CONTROL</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EXTENDED_TAG_FIELD_EN_DEFAULT</td>
<td>&quot;EIGHT_BIT&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EXTENDED_TAG_FIELD_SUPPORTED</td>
<td>&quot;EIGHT_BIT&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>F_ARXCTLEDIR</td>
<td>&quot;IGNORED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>F_ARXCTLENULL</td>
<td>&quot;0'b0000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>F_ARXDMDIR</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>F_ARXDMNULL</td>
<td>&quot;0'b000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>F_ARXDPPDIR</td>
<td>&quot;IGNORED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>F_ARXDPNULL</td>
<td>&quot;0'b000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>F_ARXEOMDIR</td>
<td>&quot;IGNORED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>F_ARXEOMNULL</td>
<td>&quot;0'b000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>F_ARXESDIR</td>
<td>&quot;IGNORED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>F_ARXESNULL</td>
<td>&quot;0'b000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>F_ARXTDIR</td>
<td>&quot;IGNORED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>F_ARXTDNULL</td>
<td>&quot;0'b000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>F_ASCHCAL</td>
<td>&quot;IGNORED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>F_ASCHDIR</td>
<td>&quot;IGNORED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>F_ASCHNNULL</td>
<td>&quot;0'b00000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>FAIL_LIMIT_ERR</td>
<td>&quot;RXEQ_NOT_FAIL&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>FAST</td>
<td>&quot;L0&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>FC_UPDATE_TIMER_DISABLE</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>FC_UPDATE_TIMER_DIV</td>
<td>&quot;PCIE_REC_VALUES&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>FILTER</td>
<td>&quot;0'b1001&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>FINE_GAIN</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td>Values</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------</td>
<td>------------------------------------------------------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>FOM_COMPARE</td>
<td>&quot;0'b00000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>FOM_HIRES</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>FOM_ITERCNT</td>
<td>&quot;0'b101&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>FOM_THR</td>
<td>&quot;0'b0100&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>FORCE_ATXDRA</td>
<td>&quot;0'b000000000000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>FORCE_ATXDRP</td>
<td>&quot;0'b000000000000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>FORCE_ATXDRR</td>
<td>&quot;0'b000000000000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>FORCE_ATXDRT</td>
<td>&quot;0'b000000000000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>FORCE_DIR_RSLT</td>
<td>&quot;0'b000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>FORCE_FOM_RSLT</td>
<td>&quot;0'b00000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>FORCE_IDLE</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>FORCE_RX_DETECT</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>FORCE_SIGNAL</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>FREQ_LOCK</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>FS</td>
<td>&quot;0'b110000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>FTS_DETECT0</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>FTS_DETECT1</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>FTS_DETECT2</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>FTS_DETECT3</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>GEN12_ENA_POST_A0</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>GEN12_ENA_POST_A1A2</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>GEN12_ENA_PREA0</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>GEN3_ENA_POST_A0</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>GEN3_ENA_POST_A1A2</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>GEN3_ENA_PREA0</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>GLOBAL_INVAL_SUPPORT</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>GSR</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>HINT</td>
<td>&quot;0'b000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>HINT0_3DB</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>HINT0_A0GAIN</td>
<td>&quot;0'b111&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>HINT0_A2GAIN</td>
<td>&quot;0'b111&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>HINT1_3DB</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
</tbody>
</table>
Table 180: PCIE Parameters (Continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>HINT1_A0GAIN</td>
<td>&quot;0'b011&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>HINT1_A2GAIN</td>
<td>&quot;0'b101&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>HINT2_3DB</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>HINT2_A0GAIN</td>
<td>&quot;0'b011&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>HINT2_A2GAIN</td>
<td>&quot;0'b111&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>HINT3_3DB</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>HINT3_A0GAIN</td>
<td>&quot;0'b000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>HINT3_A2GAIN</td>
<td>&quot;0'b111&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>HINT4_3DB</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>HINT4_A0GAIN</td>
<td>&quot;0'b111&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>HINT4_A2GAIN</td>
<td>&quot;0'b111&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>HINT5_3DB</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>HINT5_A0GAIN</td>
<td>&quot;0'b011&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>HINT5_A2GAIN</td>
<td>&quot;0'b101&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>HINT6_3DB</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>HINT6_A0GAIN</td>
<td>&quot;0'b011&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>HINT6_A2GAIN</td>
<td>&quot;0'b111&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>HINT7_3DB</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>HINT7_A0GAIN</td>
<td>&quot;0'b000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>HINT7_A2GAIN</td>
<td>&quot;0'b111&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>HINT7_OVR</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>HLD_RST</td>
<td>&quot;WRITE_1&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>HOT_PLUG_CAPABLE</td>
<td>&quot;NOT_SUPPORTED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>HOT_PLUG_SURPRISE</td>
<td>&quot;NOT_POSSIBLE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>HOT_RESET</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>ID_DS_PORT</td>
<td>&quot;0'b0000000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>ID_NWL_VSEC_CAP</td>
<td>&quot;0'b0000000000000001&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>IDDQ_PCS</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>IDLE_INFER_L0_TO_REC_RCVR_LOCK</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>IDLE_INFER_LPBK_SLAVE</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>IDLE_INFER_REC_RCVR_CFG</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>IDLE_INFER_REC_SPEED2_SUCCESS</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
</tbody>
</table>
### Table 180: PCIE Parameters (Continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>IDLE_INFER_REC_SPEED2_UNSUCCESS</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>IGNORE_ECRC</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>IGNORE_POISON</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>INDICATOR</td>
<td>&quot;0'b00000000000000000000000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>INFO_BAD_TLP_CRC_ERR</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>INFO_BAD_TLP_ECRC_ERR</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>INFO_BAD_TLP_MALF_ERR</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>INFO_BAD_TLP_NULL_ERR</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>INFO_BAD_TLP_PHY_ERR</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>INFO_BAD_TLP_SEQ_ERR</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>INFO_DESKEW_OVERFLOW_ERROR</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>INFO_NAK_RECEIVED</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>INFO_REPLAY_STARTED</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>INFO_SCHEDULE_DUPL_ACK</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>INFO_TX_DATA_UNDERFLOW</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>INHIBIT</td>
<td>&quot;PERFORM_RECEIVER_DETECTION&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>INJECT_DATA_ERROR_0</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>INJECT_DATA_ERROR_1</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>INJECT_DATA_ERROR_2</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>INJECT_DATA_ERROR_3</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>INJECT_DATA_ERROR_EN</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>INJECT_ERR_LANE_SELECT_0</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>INJECT_ERR_LANE_SELECT_1</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>INJECT_ERR_LANE_SELECT_2</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>INJECT_ERR_LANE_SELECT_3</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>INJECT_RX_1BIT_DATA_ERR</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>INJECT_RX_2BIT_DATA_ERR</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>INJECT_RX_SKP_ERR</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>INJECT_RX_VALID_ERR</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>INT_CLR</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>INT_EN</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
</tbody>
</table>
Table 180: PCIE Parameters (Continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>INTERRUPT_MESSAGE_NUMBER</td>
<td>&quot;0'b000000&quot;</td>
<td>(default)</td>
</tr>
<tr>
<td>INVAL_Q_DEPTH</td>
<td>&quot;0'b000000&quot;</td>
<td>(default)</td>
</tr>
<tr>
<td>ITERATION_MAX</td>
<td>&quot;0'b0000000&quot;</td>
<td>(default)</td>
</tr>
<tr>
<td>L0_TO_REC_RCVR_LOCK_RX_8G_EIE</td>
<td>&quot;OTHERWISE&quot;</td>
<td>(default)</td>
</tr>
<tr>
<td>L0_TO_REC_RCVR_LOCK_RX_INFER</td>
<td>&quot;OTHERWISE&quot;</td>
<td>(default)</td>
</tr>
<tr>
<td>L0_TO_REC_RCVR_LOCK_RX_TS12</td>
<td>&quot;OTHERWISE&quot;</td>
<td>(default)</td>
</tr>
<tr>
<td>L0S_ADJ</td>
<td>&quot;0'b00000110000000&quot;</td>
<td>(default)</td>
</tr>
<tr>
<td>L0S_EXIT_LATENCY</td>
<td>&quot;MORE_4_US&quot;</td>
<td>(default)</td>
</tr>
<tr>
<td>L1_ENTER_PLL_RESET_TIME</td>
<td>&quot;0'b100&quot;</td>
<td>(default)</td>
</tr>
<tr>
<td>L1_EXIT_LATENCY</td>
<td>&quot;MORE_64_US&quot;</td>
<td>(default)</td>
</tr>
<tr>
<td>L1_EXIT_PLL_LOCK_TIME</td>
<td>&quot;0'b01110&quot;</td>
<td>(default)</td>
</tr>
<tr>
<td>L1PM_SUPPORTED</td>
<td>&quot;SUPPORTED&quot;</td>
<td>(default)</td>
</tr>
<tr>
<td>L2_D3HOT_ENABLE</td>
<td>&quot;DISABLED&quot;</td>
<td>(default)</td>
</tr>
<tr>
<td>LANE</td>
<td>&quot;0&quot;</td>
<td>(default)</td>
</tr>
<tr>
<td>LANE_SELECT</td>
<td>&quot;0'b0000&quot;</td>
<td>(default)</td>
</tr>
<tr>
<td>LEGACY_MODE</td>
<td>&quot;MATCH_TS&quot;</td>
<td>(default)</td>
</tr>
<tr>
<td>LF</td>
<td>&quot;0'b001000&quot;</td>
<td>(default)</td>
</tr>
<tr>
<td>LF_PHY</td>
<td>&quot;0'b001010&quot;</td>
<td>(default)</td>
</tr>
<tr>
<td>LINK_LANE</td>
<td>&quot;ENABLED&quot;</td>
<td>(default)</td>
</tr>
<tr>
<td>LOOPBACK</td>
<td>&quot;ENABLED&quot;</td>
<td>(default)</td>
</tr>
<tr>
<td>LPBK_EN</td>
<td>&quot;DISABLED&quot;</td>
<td>(default)</td>
</tr>
<tr>
<td>LW_START_UPDN_ACK_EN</td>
<td>&quot;DISABLED&quot;</td>
<td>(default)</td>
</tr>
<tr>
<td>LW_START_UPDN_COUNT</td>
<td>&quot;0'b000011111010&quot;</td>
<td>(default)</td>
</tr>
<tr>
<td>LW_START_UPDN_EIE_EN</td>
<td>&quot;DISABLED&quot;</td>
<td>(default)</td>
</tr>
<tr>
<td>LW_START_UPDN_EN_DIR_DS</td>
<td>&quot;DO_NOT_ASSERT&quot;</td>
<td>(default)</td>
</tr>
<tr>
<td>LW_START_UPDN_END_DELAY</td>
<td>&quot;0'b1001&quot;</td>
<td>(default)</td>
</tr>
<tr>
<td>LW_START_UPDN_RATE_EN_16G</td>
<td>&quot;DISABLED&quot;</td>
<td>(default)</td>
</tr>
<tr>
<td>LW_START_UPDN_RATE_EN_2P5G</td>
<td>&quot;ENABLED&quot;</td>
<td>(default)</td>
</tr>
<tr>
<td>LW_START_UPDN_RATE_EN_5G</td>
<td>&quot;ENABLED&quot;</td>
<td>(default)</td>
</tr>
<tr>
<td>LW_START_UPDN_RATE_EN_8G</td>
<td>&quot;ENABLED&quot;</td>
<td>(default)</td>
</tr>
<tr>
<td>LW_START_UPDN_START_DELAY</td>
<td>&quot;0'b1000&quot;</td>
<td>(default)</td>
</tr>
<tr>
<td>LW_START_UPDN_TIMER_EN</td>
<td>&quot;DISABLED&quot;</td>
<td>(default)</td>
</tr>
</tbody>
</table>
### Table 180: PCIE Parameters (Continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>MARGIN_ENABLE</td>
<td>&quot;PCIE_SPEC&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>MARGIN_VALUE</td>
<td>&quot;0'b000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>MASK_0</td>
<td>&quot;SKIP_RCVR_DETECTION&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>MASK_1</td>
<td>&quot;SKIP_RCVR_DETECTION&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>MASK_2</td>
<td>&quot;SKIP_RCVR_DETECTION&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>MASK_3</td>
<td>&quot;SKIP_RCVR_DETECTION&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>MAX_LINK_WIDTH</td>
<td>&quot;1_LANE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>MAX_PAYLOAD_SIZE_SUPPORTED</td>
<td>&quot;256_BYTES&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>MAX_RSA_WAIT</td>
<td>&quot;0'b00101000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>MAX_SPEED</td>
<td>&quot;8G&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>MAX_VAR</td>
<td>&quot;0'b001000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>MERGE_LMMI_RDATA</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>MESO_LPBK</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>METHOD_FMERIT_CTRL</td>
<td>&quot;STEP_PCIE_TX_PRESETS&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>METHOD_TX_CRED_CLEANUP</td>
<td>&quot;HEADER&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>MGMT_INTLEG</td>
<td>&quot;0'b0000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>MGMT_LTSSM_DIS</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>MID_VALUE_10B</td>
<td>&quot;0'b011110&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>MID_VALUE_20B</td>
<td>&quot;0'b010100&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>MID_VALUE_GEN3</td>
<td>&quot;0'b001110&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>MIN_TIME</td>
<td>&quot;0_MS&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>MIN_TIME_CFG</td>
<td>&quot;4US&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>MIX_DIR</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>MODE_BFF</td>
<td>&quot;RESTART&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>MPS_VIOLATION_RX</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>MPS_VIOLATION_TX</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>MRL_SENSOR_PRESENT</td>
<td>&quot;NOT_SUPPORTED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>MULT_ENABLE</td>
<td>&quot;RECOMMENDED_VALUES&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>MULT_MESSAGE_CAPABLE_MSICAP_A</td>
<td>&quot;EIGHT&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>MULT_MESSAGE_CAPABLE_MSICAP_B</td>
<td>&quot;EIGHT&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>MULT_MESSAGE_CAPABLE_MSICAP_C</td>
<td>&quot;EIGHT&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>MULT_MESSAGE_CAPABLE_MSICAP_D</td>
<td>&quot;EIGHT&quot; (default)</td>
<td></td>
</tr>
</tbody>
</table>
### Table 180: PCIE Parameters (Continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>N_RX_LIM_D</td>
<td>&quot;DISABLED&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>N_RX_LIM_H</td>
<td>&quot;DISABLED&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>N_TX_LIM_D</td>
<td>&quot;DISABLED&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>N_TX_LIM_H</td>
<td>&quot;DISABLED&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>NFTS</td>
<td>&quot;0'b11111111&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>NO_COMMAND_COMPLETED_SUPPORT</td>
<td>&quot;SW_NOTIF_PROVIDED&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>NO_FCMP</td>
<td>&quot;DISABLED&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>NO_REMOTE_CHANGE</td>
<td>&quot;DISABLED&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>NO_TX_IDLE_DELAY</td>
<td>&quot;DATA_VALID_GAP&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>NUM_LANES</td>
<td>&quot;1_LANE&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>NUMBER_DSLINK</td>
<td>&quot;0'b00000&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>NUMH1_A</td>
<td>&quot;0'b00000000000000000000000000000000&quot; *(default)</td>
<td></td>
</tr>
<tr>
<td>NUMH1_B</td>
<td>&quot;0'b00000000000000000000000000000000&quot; *(default)</td>
<td></td>
</tr>
<tr>
<td>NUMH1_C</td>
<td>&quot;0'b00000000000000000000000000000000&quot; *(default)</td>
<td></td>
</tr>
<tr>
<td>NUMH1_D</td>
<td>&quot;0'b00000000000000000000000000000000&quot; *(default)</td>
<td></td>
</tr>
<tr>
<td>NUMHOLD</td>
<td>&quot;SINGLE_HOLD_RESPONSE&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>NUMLO_A</td>
<td>&quot;0'b00000000000000000000000000000000&quot; *(default)</td>
<td></td>
</tr>
<tr>
<td>NUMLO_B</td>
<td>&quot;0'b00000000000000000000000000000000&quot; *(default)</td>
<td></td>
</tr>
<tr>
<td>NUMLO_C</td>
<td>&quot;0'b00000000000000000000000000000000&quot; *(default)</td>
<td></td>
</tr>
<tr>
<td>NUMLO_D</td>
<td>&quot;0'b00000000000000000000000000000000&quot; *(default)</td>
<td></td>
</tr>
<tr>
<td>OBFF_SUPPORTED</td>
<td>&quot;NOT_SUPPORTED&quot; <em>(default)</em></td>
<td></td>
</tr>
<tr>
<td>OFFSET_MSIX_PBA_A</td>
<td>&quot;0'b00000000000000000111000000000000&quot; *(default)</td>
<td></td>
</tr>
<tr>
<td>OFFSET_MSIX_PBA_B</td>
<td>&quot;0'b00000000000000000111000000000000&quot; *(default)</td>
<td></td>
</tr>
<tr>
<td>OFFSET_MSIX_PBA_C</td>
<td>&quot;0'b00000000000000000111000000000000&quot; *(default)</td>
<td></td>
</tr>
<tr>
<td>OFFSET_MSIX_PBA_D</td>
<td>&quot;0'b00000000000000000111000000000000&quot; *(default)</td>
<td></td>
</tr>
<tr>
<td>OFFSET_MSIX_TABLE_A</td>
<td>&quot;0'b00000000000000000110000000000000&quot; *(default)</td>
<td></td>
</tr>
<tr>
<td>OFFSET_MSIX_TABLE_B</td>
<td>&quot;0'b00000000000000000110000000000000&quot; *(default)</td>
<td></td>
</tr>
</tbody>
</table>
Table 180: PCIE Parameters (Continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>OFFSET_MSIX_TABLE_C</td>
<td>&quot;0'b000000000000000011000000000000000110000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>OFFSET_MSIX_TABLE_D</td>
<td>&quot;0'b000000000000000011000000000000001100000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>OVER_CTALE</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>OVER_RX</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>OVER_RXDM</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>OVER_RXDP</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>OVER_RXES</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>OVER_RXT</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>OVER_SCH</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>OVER_TX</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>OVERFLOW</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>OVR_CDR</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>OVR_DIR</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>OVR_FOM</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>OVR_GAIN3DB</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>OVR_HINT3DB</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>P_CLK_PERIOD</td>
<td>&quot;0'b0000111110100000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>P_RX_LIM_D</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>P_RX_LIM_H</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>P_TX_LIM_D</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>P_TX_LIM_H</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PAR_LPbk</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PAS</td>
<td>&quot;10X&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PATTERN_0</td>
<td>&quot;UNSCRAMBLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PATTERN_1</td>
<td>&quot;UNSCRAMBLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PATTERN_2</td>
<td>&quot;UNSCRAMBLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PCIPM_L1_1_SUPPORTED</td>
<td>&quot;SUPPORTED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PCIPM_L1_2_SUPPORTED</td>
<td>&quot;SUPPORTED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PCLKREQ_N</td>
<td>&quot;DEASSERTED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PERIOD_SRIS_128B130B</td>
<td>&quot;0'b00000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PERIOD_SRIS_8B10B</td>
<td>&quot;0'b00000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PERIOD_SRNS_128B130B</td>
<td>&quot;0'b00000000&quot; (default)</td>
<td></td>
</tr>
</tbody>
</table>
Table 180: PCIE Parameters (Continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>PERIOD_SRNS_8B10B</td>
<td>&quot;0'b00000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PHANTOM_FUNCTIONS_SUPPORTED</td>
<td>&quot;NO_FUNCTION_BITS&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PHY_MODE</td>
<td>&quot;0'b0000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PHYSICAL_SLOT_NUMBER</td>
<td>&quot;0'b0000000000001&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PIN_INTERRUPT_A</td>
<td>&quot;INTA&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PIN_INTERRUPT_B</td>
<td>&quot;INTA&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PIN_INTERRUPT_C</td>
<td>&quot;INTA&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PIN_INTERRUPT_D</td>
<td>&quot;INTA&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PIPE_PWRDN</td>
<td>&quot;P1&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PIPE_TX_SWING</td>
<td>&quot;FULL_SWING&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PLESIO_LPBK</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PM_REDUCE_TIMEOUTS</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PMA_DRIVEN_MODE</td>
<td>&quot;PCS_DRIVEN&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PMCSR_B2_B3_SUPPORT</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PMCSR_BUS_P_C_EN</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PME_CLOCK</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PME_SUPPORT</td>
<td>&quot;0'b11111&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PMFF_ALL</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PORT_CM_RESTORE_TIME</td>
<td>&quot;0'b00000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PORT_NUMBER</td>
<td>&quot;0'b00000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PORT_TPOWER_ON_SCALE</td>
<td>&quot;2_US&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PORT_TPOWER_ON_VALUE</td>
<td>&quot;0'b00000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>POST</td>
<td>&quot;0'b0000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>POST_A0COEF</td>
<td>&quot;0'b001&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>POST_A1COEF</td>
<td>&quot;0'b001&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>POST_A2COEF</td>
<td>&quot;0'b001&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>POST_CURSOR_LIMIT</td>
<td>&quot;0'b100000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>POST_CURSOR_STEP_SIZE</td>
<td>&quot;0'b001000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>POST_ITERCNT</td>
<td>&quot;0'b100&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>POST_STEP</td>
<td>&quot;STEP_SIZE_4&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>POWER_CONTROLLER_PRESENT</td>
<td>&quot;NOT_SUPPORTED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>POWER_INDICATOR_PRESENT</td>
<td>&quot;NOT_SUPPORTED&quot; (default)</td>
<td></td>
</tr>
</tbody>
</table>
### Table 180: PCIE Parameters (Continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>POWER_REQUIRED</td>
<td>&quot;AUX_POWER_NOT_REQUIRED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PRBS_CHK</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PRBS_GEN</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PRBS_TYP</td>
<td>&quot;PRBS7&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PRE</td>
<td>&quot;0'b0000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PRE_A0COEF</td>
<td>&quot;0'b101&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PRE_A1COEF</td>
<td>&quot;0'b101&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PRE_A2COEF</td>
<td>&quot;0'b101&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PRE_CURSOR_LIMIT</td>
<td>&quot;0'b010000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PRE_CURSOR_STEP_SIZE</td>
<td>&quot;0'b000100&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PRE_FOM</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PRE_FOM_AVG</td>
<td>&quot;0'b100&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PRE_ITERCNT</td>
<td>&quot;0'b100&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PRE_RXREQ_TIMER</td>
<td>&quot;0'b00010100&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PRE_STEP</td>
<td>&quot;STEP_SIZE_2&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PRESET_COUNT_INI</td>
<td>&quot;0'b0000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PRESET_EN_LPBK_MASTER</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PRESET_EN_LPBK_SLAVE</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PRESET_ENABLE</td>
<td>&quot;NORMAL_OP&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PRESET_ENABLE_8G</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PRESET_EQTX_FORCE</td>
<td>&quot;0'b0000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PRESET_LPBK_MASTER</td>
<td>&quot;0'b0000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PRESET_LPBK_SLAVE_0</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PRESET_LPBK_SLAVE_1</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PRESET_LPBK_SLAVE_3</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PRESET_REJECT</td>
<td>&quot;0'b00000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PRESET0_POSTCURSOR</td>
<td>&quot;0'b1000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PRESET0_PRECURSOR</td>
<td>&quot;0'b0000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PRESET1_POSTCURSOR</td>
<td>&quot;0'b0101&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PRESET1_PRECURSOR</td>
<td>&quot;0'b0000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PRESET10_POSTCURSOR</td>
<td>&quot;0'b1010&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PRESET10_PRECURSOR</td>
<td>&quot;0'b0000&quot; (default)</td>
<td></td>
</tr>
</tbody>
</table>
## Table 180: PCIE Parameters (Continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>PRESET2_POSTCURSOR</td>
<td>&quot;0'b0110&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PRESET2_PRECURSOR</td>
<td>&quot;0'b0000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PRESET3_POSTCURSOR</td>
<td>&quot;0'b0100&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PRESET3_PRECURSOR</td>
<td>&quot;0'b0000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PRESET4_POSTCURSOR</td>
<td>&quot;0'b0000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PRESET4_PRECURSOR</td>
<td>&quot;0'b0000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PRESET5_POSTCURSOR</td>
<td>&quot;0'b0000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PRESET5_PRECURSOR</td>
<td>&quot;0'b0011&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PRESET6_POSTCURSOR</td>
<td>&quot;0'b0000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PRESET6_PRECURSOR</td>
<td>&quot;0'b0100&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PRESET7_POSTCURSOR</td>
<td>&quot;0'b0110&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PRESET7_PRECURSOR</td>
<td>&quot;0'b0011&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PRESET8_POSTCURSOR</td>
<td>&quot;0'b0100&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PRESET8_PRECURSOR</td>
<td>&quot;0'b0100&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PRESET9_POSTCURSOR</td>
<td>&quot;0'b0000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PRESET9_PRECURSOR</td>
<td>&quot;0'b0101&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PS_REENTRY_TIME</td>
<td>&quot;0'b00000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PWDN_N</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RATE</td>
<td>&quot;2P5G&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RATE_ENABLE</td>
<td>&quot;INITIAL_SPEED_CHANGES&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RCB</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>REC_SPD_INFER_EQ_PH0123</td>
<td>&quot;EXCLUDE_TIME_SPENT&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>REC_SPD_INFER_RCVR_CFG</td>
<td>&quot;EXCLUDE_TIME_SPENT&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>REC_SPD_INFER_RCVR_LOCK</td>
<td>&quot;EXCLUDE_TIME_SPENT&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>REDO</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>REDUCE_TIMEOUTS_LTSSMSIM</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>REDUCE_TIMEOUTS_SIM</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>REDUCE_TS1</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>REENTRY_DISABLE</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>REENTRY_TIME</td>
<td>&quot;0'b0000000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>REQ_EQ_MAX_COUNT</td>
<td>&quot;0'b10&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>REQ_FEEDBACK</td>
<td>&quot;0'b00000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td>Values</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------------------</td>
<td>-------------------------</td>
<td>------------------------------</td>
</tr>
<tr>
<td>RESET_EIEOS_INTERVAL_COUNT</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>REVISION_ID_ID3A</td>
<td>&quot;0'b000000100&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>REVISION_ID_ID3B</td>
<td>&quot;0'b000000100&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>REVISION_ID_ID3C</td>
<td>&quot;0'b000000100&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>REVISION_ID_ID3D</td>
<td>&quot;0'b000000100&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RL1</td>
<td>&quot;0'b0011&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RL2</td>
<td>&quot;0'b0101&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RL3</td>
<td>&quot;0'b0011&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>ROUTING_SUPPORTED</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RP_COMPLETER_EN</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RSTCDR_ERR</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RSTCDR_FRQ</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RSTCDR_ID</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RX_BYPASS_DECODE_EN</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RX_BYPASS_MSG_DEC</td>
<td>&quot;NORMAL_OPERATION&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RX_CONVERT_UR_TO_CA</td>
<td>&quot;NORMAL_OPERATION&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RX_D_ALLOC_C</td>
<td>&quot;0'b0000000001100000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RX_D_ALLOC_N</td>
<td>&quot;0'b0000000000000110&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RX_D_ALLOC_P</td>
<td>&quot;0'b0000000001101100&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RX_DIV_MODE0</td>
<td>&quot;DIV_2&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RX_DIV_MODE1</td>
<td>&quot;0'b10&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RX_DIV_MODE2</td>
<td>&quot;0'b00&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RX_DL_ACTIVE_DISABLE</td>
<td>&quot;BLOCK_RECEPTION_TLP&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RX_EARLY_FORWARD_DISABLE</td>
<td>&quot;FWD_RX_DATA_LL&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RX_ECC1_HANDLE_DISABLE</td>
<td>&quot;ENABLE_HANDLING&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RX_ECC1_INJECT_EN</td>
<td>&quot;DO_NOT_INJECT_ERR&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RX_ECC1_INJECT_M_1_N</td>
<td>&quot;INJECT_1_ERR&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RX_ECC1_INJECT_TYPE</td>
<td>&quot;POSTED_DATA_RAM&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RX_ECC1_REPORT_DISABLE</td>
<td>&quot;ENABLE_REPORTING&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RX_ECC2_HANDLE_DISABLE</td>
<td>&quot;ENABLE_HANDLING&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RX_ECC2_INJECT_EN</td>
<td>&quot;DO_NOT_INJECT_ERR&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RX_ECC2_INJECT_M_1_N</td>
<td>&quot;INJECT_1_ERR&quot; (default)</td>
<td></td>
</tr>
</tbody>
</table>
Table 180: PCIE Parameters (Continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>RX_ECC2_INJECT_TYPE</td>
<td>&quot;POSTED_DATA_RAM&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RX_ECC2_REPORT_DISABLE</td>
<td>&quot;ENABLE_REPORTING&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RX_EI_DIS</td>
<td>&quot;DEASSERTED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RX_ERR_COR</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RX_ERR_ECC1</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RX_ERR_ECC2</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RX_ERR_PAR</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RX_ERR_UCOR</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RX_ESP_RESP_WAIT</td>
<td>&quot;0'b01000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RX_FORCE_RO</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RX_H_ALLOC_C</td>
<td>&quot;0'b000000100000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RX_HALLOC_N</td>
<td>&quot;0'b000000001000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RX_H_ALLOC_P</td>
<td>&quot;0'b000000010000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RX_HIZ</td>
<td>&quot;IGNORED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RX_IMPED_RATIO</td>
<td>&quot;0'b10000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RX_INHIBIT_ACK_NAK</td>
<td>&quot;PROCESS_RCVD_ACK&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RX_INHIBIT_TLP</td>
<td>&quot;PROCESS_RCVD_TLP&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RX_L0S_DIRECT_TO_RCVRY</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RX_LCRC_INJECT_EN</td>
<td>&quot;DO_NOT_INJECT_ERROR&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RX_MALF_INJECT_EN</td>
<td>&quot;DO_NOT_INJECT_ERROR&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RX_PAR_INJECT_EN</td>
<td>&quot;DO_NOT_INJECT_ERR&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RX_PAR_REPORT_DISABLE</td>
<td>&quot;ENABLE_REPORTING&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RX_POLINV</td>
<td>&quot;NORMAL&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RX_PRIORITY</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RX_PRIORITY_N_STARVE_THRESH</td>
<td>&quot;0'b00010000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RX_PRIORITY_P_STARVE_THRESH</td>
<td>&quot;0'b00010000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RX_PWRDN</td>
<td>&quot;IGNORED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RX_TLP_VALID</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RXEQ_ALGO</td>
<td>&quot;0'b111&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RXEQ_ENABLE</td>
<td>&quot;0'b100&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RXEQ_EVAL_MAX</td>
<td>&quot;0'b11111111&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RXEQ_MANUAL</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
</tbody>
</table>
### Table 180: PCIE Parameters (Continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>RXEQ_STATE</td>
<td>&quot;0'b0000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RXF_A</td>
<td>&quot;0'b0100&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RXF_B</td>
<td>&quot;0'b0100&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RXF_C</td>
<td>&quot;0'b0100&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RXHF_CLKDN</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RXIDLE_MAX</td>
<td>&quot;0'b1111&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RXIDLE_MAX2</td>
<td>&quot;0'b000001000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RXIDLE_MSB</td>
<td>&quot;0'b11&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RXM_A</td>
<td>&quot;0'b10&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RXM_B</td>
<td>&quot;0'b01&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RXM_C</td>
<td>&quot;0'b00&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RXN_A</td>
<td>&quot;0'b00100&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RXN_B</td>
<td>&quot;0'b01001&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RXN_C</td>
<td>&quot;0'b01111&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RXOFF_SETTLE_MAX</td>
<td>&quot;0'b011&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RXOFF_STABLE_MAX</td>
<td>&quot;0'b10000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RXPLLINIT</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>RXPLLRST</td>
<td>&quot;SET&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SDS_DETECT0</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SDS_DETECT1</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SDS_DETECT2</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SDS_DETECT3</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SEL_PCLK_DIV2</td>
<td>&quot;PCLK_DIV2&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SELECT_DIR_FOM_N</td>
<td>&quot;FME_METHOD&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SELECTABLE_DEEMPHASIS</td>
<td>&quot;6P0DB&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SEQ_NUM</td>
<td>&quot;0'b0000000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SIGNAL_DETECT_THRESHOLD</td>
<td>&quot;125_MV&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SIZE_CFG0_A</td>
<td>&quot;0'b00000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SIZE_CFG0_B</td>
<td>&quot;0'b00000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SIZE_CFG0_C</td>
<td>&quot;0'b00000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SIZE_CFG0_D</td>
<td>&quot;0'b00000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SIZE_CFG1_A</td>
<td>&quot;0'b00000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td>Values</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------------</td>
<td>------------------</td>
<td>----------------------</td>
</tr>
<tr>
<td>SIZE_CFG1_B</td>
<td>&quot;0'b00000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SIZE_CFG1_C</td>
<td>&quot;0'b00000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SIZE_CFG1_D</td>
<td>&quot;0'b00000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SIZE_CFG2_A</td>
<td>&quot;0'b00000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SIZE_CFG2_B</td>
<td>&quot;0'b00000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SIZE_CFG2_C</td>
<td>&quot;0'b00000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SIZE_CFG2_D</td>
<td>&quot;0'b00000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SIZE_CFG3_A</td>
<td>&quot;0'b00000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SIZE_CFG3_B</td>
<td>&quot;0'b00000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SIZE_CFG3_C</td>
<td>&quot;0'b00000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SIZE_CFG3_D</td>
<td>&quot;0'b00000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SIZE_CFG4_A</td>
<td>&quot;0'b00000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SIZE_CFG4_B</td>
<td>&quot;0'b00000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SIZE_CFG4_C</td>
<td>&quot;0'b00000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SIZE_CFG4_D</td>
<td>&quot;0'b00000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SIZE_CFG5_A</td>
<td>&quot;0'b00000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SIZE_CFG5_B</td>
<td>&quot;0'b00000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SIZE_CFG5_C</td>
<td>&quot;0'b00000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SIZE_CFG5_D</td>
<td>&quot;0'b00000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SKIP_FINAL_COEF_CHECK</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SKP_DETECT0</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SKP_DETECT1</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SKP_DETECT2</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SKP_DETECT3</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SLOT_CLOCK_CONFIGURATION</td>
<td>&quot;REFCLK_BY_SLOT&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SLOT_IMPLEMENTED</td>
<td>&quot;UNCONNECTED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SLOT_POWER_LIMIT_SCALE</td>
<td>&quot;0'b00&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SLOT_POWER_LIMIT_VALUE</td>
<td>&quot;0'b00001010&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SPEED_CHANGE_FAIL</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SPEED_LP8K_CTRL</td>
<td>&quot;2P5G&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>START_PRESET</td>
<td>&quot;PRESET_VALUE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>START_REMOTE_ADV</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
</tbody>
</table>
Table 180: PCIE Parameters (Continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>STATE_DATA_N</td>
<td>&quot;USE_RX_DATA_OBSERVATION&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>STEP_SELECT</td>
<td>&quot;0'b00000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>STP_OVERRIDE_EN</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>STP_OVERRIDE_LEN</td>
<td>&quot;0'b00000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>STP_OVERRIDE_NEW_LEN</td>
<td>&quot;0'b00000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>STS_PHY_STATUS</td>
<td>&quot;DEASSERTED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>STS_PIPE_RSTN</td>
<td>&quot;DEASSERTED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SUBSTATE_MAX</td>
<td>&quot;0'b00000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SUBSYSTEM_ID_ID2A</td>
<td>&quot;0'b1110000000000100&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SUBSYSTEM_ID_ID2B</td>
<td>&quot;0'b1110000000000100&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SUBSYSTEM_ID_ID2C</td>
<td>&quot;0'b1110000000000100&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SUBSYSTEM_ID_ID2D</td>
<td>&quot;0'b1110000000000100&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SUBSYSTEM_VENDOR_ID_ID2A</td>
<td>&quot;0'b0001100110101010&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SUBSYSTEM_VENDOR_ID_ID2B</td>
<td>&quot;0'b0001100110101010&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SUBSYSTEM_VENDOR_ID_ID2C</td>
<td>&quot;0'b0001100110101010&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SUBSYSTEM_VENDOR_ID_ID2D</td>
<td>&quot;0'b0001100110101010&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SUPP_SIZE_CFG0_A</td>
<td>&quot;0'b00000000000000001111&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SUPP_SIZE_CFG0_B</td>
<td>&quot;0'b00000000000000001111&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SUPP_SIZE_CFG0_C</td>
<td>&quot;0'b00000000000000001111&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SUPP_SIZE_CFG0_D</td>
<td>&quot;0'b00000000000000001111&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SUPP_SIZE_CFG1_A</td>
<td>&quot;0'b00000000000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SUPP_SIZE_CFG1_B</td>
<td>&quot;0'b00000000000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SUPP_SIZE_CFG1_C</td>
<td>&quot;0'b00000000000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SUPP_SIZE_CFG1_D</td>
<td>&quot;0'b00000000000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SUPP_SIZE_CFG2_A</td>
<td>&quot;0'b00000000000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SUPP_SIZE_CFG2_B</td>
<td>&quot;0'b00000000000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SUPP_SIZE_CFG2_C</td>
<td>&quot;0'b00000000000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SUPP_SIZE_CFG2_D</td>
<td>&quot;0'b00000000000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SUPP_SIZE_CFG3_A</td>
<td>&quot;0'b00000000000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SUPP_SIZE_CFG3_B</td>
<td>&quot;0'b00000000000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SUPP_SIZE_CFG3_C</td>
<td>&quot;0'b00000000000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SUPP_SIZE_CFG3_D</td>
<td>&quot;0'b00000000000000000000&quot; (default)</td>
<td></td>
</tr>
</tbody>
</table>
### Table 180: PCIE Parameters (Continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SUPP_SIZE_CFG4_A</td>
<td>&quot;0'b00000000000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SUPP_SIZE_CFG4_B</td>
<td>&quot;0'b00000000000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SUPP_SIZE_CFG4_C</td>
<td>&quot;0'b00000000000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SUPP_SIZE_CFG4_D</td>
<td>&quot;0'b00000000000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SUPP_SIZE_CFG5_A</td>
<td>&quot;0'b00000000000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SUPP_SIZE_CFG5_B</td>
<td>&quot;0'b00000000000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SUPP_SIZE_CFG5_C</td>
<td>&quot;0'b00000000000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SUPP_SIZE_CFG5_D</td>
<td>&quot;0'b00000000000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SYS_ALLOC</td>
<td>&quot;PWR_BUDGET_CAP_VALUES&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>T0_RX_BYPASS_MSG_DEC</td>
<td>&quot;NORMAL_OPERATION&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TABLE_SIZE_MSIXCAP_A</td>
<td>&quot;0'b000000000111&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TABLE_SIZE_MSIXCAP_B</td>
<td>&quot;0'b000000000111&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TABLE_SIZE_MSIXCAP_C</td>
<td>&quot;0'b000000000111&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TABLE_SIZE_MSIXCAP_D</td>
<td>&quot;0'b000000000111&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TARGET_LINK_SPEED</td>
<td>&quot;8G&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TARGET_ONLY</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TD1_MEANS_ADD_HAS_N</td>
<td>&quot;ECRC_CONTAINED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TIMEOUT_THRESHOLD_PME</td>
<td>&quot;0'b000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TIMEOUT_THRESHOLD_PME_TO_ACK_DS</td>
<td>&quot;0'b00000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TIMER</td>
<td>&quot;0'b00000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TLP_LCRC_ERR_ENABLE</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TLP_LCRC_ERR_RATE</td>
<td>&quot;0'b000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TLP_SEQ_ERR_ENABLE</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TLUNIT</td>
<td>&quot;1_MS&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TO_EXTEND</td>
<td>&quot;0'b01111111&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TRNG_A0COEF</td>
<td>&quot;0'b101&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TRNG_A1COEF</td>
<td>&quot;0'b101&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TRNG_A2COEF</td>
<td>&quot;0'b101&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TRNG_FAST</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TRNG_ITERCNT</td>
<td>&quot;0'b100&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TRNG_RXEQ_TIMER</td>
<td>&quot;0'b00100000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TS1_ACK_BLOCK_USE_PRESET</td>
<td>&quot;FORCED_TO_ZERO&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td>Values</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-------------------------</td>
<td>---------------------------</td>
</tr>
<tr>
<td>TS1_ACK_DELAY</td>
<td>&quot;0'b00011111&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TS1_ACK_MASK_USE_PRESET</td>
<td>&quot;IGNORES_USE_PRESET&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TS1_DETECT0</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TS1_DETECT1</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TS1_DETECT2</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TS1_DETECT3</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TS1I_DETECT0</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TS1I_DETECT1</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TS1I_DETECT2</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TS1I_DETECT3</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TS2I_DETECT0</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TS2I_DETECT1</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TS2I_DETECT2</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_AMP_RATIO_MARGIN0_FULL</td>
<td>&quot;0'b10000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_AMP_RATIO_MARGIN0_HALF</td>
<td>&quot;0'b01010000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_AMP_RATIO_MARGIN1_FULL</td>
<td>&quot;0'b01111000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_AMP_RATIO_MARGIN1_HALF</td>
<td>&quot;0'b01011000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_AMP_RATIO_MARGIN2_FULL</td>
<td>&quot;0'b01101000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_AMP_RATIO_MARGIN2_HALF</td>
<td>&quot;0'b01001000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_AMP_RATIO_MARGIN3_FULL</td>
<td>&quot;0'b01100000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_AMP_RATIO_MARGIN3_HALF</td>
<td>&quot;0'b01000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_AMP_RATIO_MARGIN4_FULL</td>
<td>&quot;0'b01011000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_AMP_RATIO_MARGIN4_HALF</td>
<td>&quot;0'b00111000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_AMP_RATIO_MARGIN5_FULL</td>
<td>&quot;0'b01010000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_AMP_RATIO_MARGIN5_HALF</td>
<td>&quot;0'b00110000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_AMP_RATIO_MARGIN6_FULL</td>
<td>&quot;0'b01001000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_AMP_RATIO_MARGIN6_HALF</td>
<td>&quot;0'b00101000&quot; (default)</td>
<td></td>
</tr>
</tbody>
</table>
Table 180: PCIE Parameters (Continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>TX_Amp_RATIO_MARGIN7_FULL</td>
<td>&quot;0'b01000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_Amp_RATIO_MARGIN7_HALF</td>
<td>&quot;0'b00100000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_BYPASS_DECODE_EN</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_BYPASS_MSG_DEC</td>
<td>&quot;NORMAL_OPERATION&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_CM_DIS</td>
<td>&quot;DEASSERTED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_COMP_RECEIVE</td>
<td>&quot;DOES_NOT_ASSERT&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_CONVERT_UR_TO_CA</td>
<td>&quot;NORMAL_OPERATION&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_D_ALLOC_N</td>
<td>&quot;0'b0000000000000110&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_D_ALLOC_P</td>
<td>&quot;0'b00000000101100&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_DIV_MODE0</td>
<td>&quot;0'b10&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_DIV_MODE1</td>
<td>&quot;0'b10&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_DIV_MODE2</td>
<td>&quot;0'b10&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_ECC1_HANDLE_DISABLE</td>
<td>&quot;ENABLE_HANDLING&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_ECC1_INJECT_EN</td>
<td>&quot;DO_NOT_INJECT_ERR&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_ECC1_INJECT_M_1_N</td>
<td>&quot;INJECT_1_ERR&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_ECC1_INJECT_TYPE</td>
<td>&quot;POSTED_DATA_RAM&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_ECC1_REPORT_DISABLE</td>
<td>&quot;ENABLE_REPORTING&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_ECC2_HANDLE_DISABLE</td>
<td>&quot;ENABLE_HANDLING&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_ECC2_INJECT_EN</td>
<td>&quot;DO_NOT_INJECT_ERR&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_ECC2_INJECT_M_1_N</td>
<td>&quot;INJECT_1_ERR&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_ECC2_INJECT_TYPE</td>
<td>&quot;POSTED_DATA_RAM&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_ECC2_REPORT_DISABLE</td>
<td>&quot;ENABLE_REPORTING&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_EQ_EVAL_CNT_SEL</td>
<td>&quot;WAIT_8_CLKS&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_ERR_COR</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_ERR_ECC1</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_ERR_ECC2</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_ERR_PAR</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_ERR_UCOR</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_FORCE_RO</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_GAP_INJECT_EN</td>
<td>&quot;DO_NOT_INJECT_GAP&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_H_ALLOC_C</td>
<td>&quot;0'b000000100000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_H_ALLOC_N</td>
<td>&quot;0'b000000001000&quot; (default)</td>
<td></td>
</tr>
</tbody>
</table>
### Table 180: PCIE Parameters (Continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>TX_H_ALLOC_P</td>
<td>&quot;0'b0000000010000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_HIZ</td>
<td>&quot;IGNORED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_IMPED_RATIO</td>
<td>&quot;0'b10000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_PAR_INJECT_EN</td>
<td>&quot;DO_NOT_INJECT_ERR&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_PAR_REPORT_DISABLE</td>
<td>&quot;ENABLE_REPORTING&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_PAR1_INJECT_EN</td>
<td>&quot;DO_NOT_INJECT_ERR&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_PAR2_HANDLE_DISABLE</td>
<td>&quot;ENABLE_HANDLING&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_PAR2_INJECT_EN</td>
<td>&quot;DO_NOT_INJECT_ERR&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_PAR2_REPORT_DISABLE</td>
<td>&quot;ENABLE_REPORTING&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_POLINV</td>
<td>&quot;NORMAL&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_PRE_RATIO</td>
<td>&quot;0'b00000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_PRE_RATIO_DEEMP0_FULL</td>
<td>&quot;0'b00000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_PRE_RATIO_DEEMP0_HALF</td>
<td>&quot;0'b00000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_PRE_RATIO_DEEMP1_FULL</td>
<td>&quot;0'b00000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_PRE_RATIO_DEEMP1_HALF</td>
<td>&quot;0'b00000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_PRIORITY</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_PRIORITY_N_STARVE_THRESH</td>
<td>&quot;0'b00010000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_PRIORITY_P_STARVE_THRESH</td>
<td>&quot;0'b00010000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_PST_RATIO</td>
<td>&quot;0'b00010101&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_PST_RATIO_DEEMP0_FULL</td>
<td>&quot;0'b00100000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_PST_RATIO_DEEMP0_HALF</td>
<td>&quot;0'b00100000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_PST_RATIO_DEEMP1_FULL</td>
<td>&quot;0'b00010101&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_PST_RATIO_DEEMP1_HALF</td>
<td>&quot;0'b00010101&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_QUIESCE</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_REPLAY_ECC1_HANDLE_DISABLE</td>
<td>&quot;ENABLE_CORRECTION&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_REPLAY_ECC1_INJECT_EN</td>
<td>&quot;DO_NOT_INJECT_ERR&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_REPLAY_ECC1_INJECT_M_1_N</td>
<td>&quot;INJECT_1_ERR&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_REPLAY_ECC1_REPORT_DISABLE</td>
<td>&quot;ENABLE_REPORTING&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_REPLAY_ECC2_HANDLE_DISABLE</td>
<td>&quot;ENABLE_HANDLING&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_REPLAY_ECC2_INJECT_EN</td>
<td>&quot;DO_NOT_INJECT_ERR&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_REPLAY_ECC2_INJECT_M_1_N</td>
<td>&quot;INJECT_1_ERR&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_REPLAY_ECC2_REPORT_DISABLE</td>
<td>&quot;ENABLE_REPORTING&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td>Values</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------</td>
<td>-----------------------------------</td>
<td>-------------------------------</td>
</tr>
<tr>
<td>TX_REQ_EQ</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_SELECT_RX_FEEDBACK</td>
<td>&quot;REFCLK&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_TLP_VALID</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TXF_A</td>
<td>&quot;0'b0100&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TXF_B</td>
<td>&quot;0'b0100&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TXF_C</td>
<td>&quot;0'b0100&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TXHF_CLKDN</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TXM_A</td>
<td>&quot;0'b10&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TXM_B</td>
<td>&quot;0'b01&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TXM_C</td>
<td>&quot;0'b00&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TXN_A</td>
<td>&quot;0'b00100&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TXN_B</td>
<td>&quot;0'b01001&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TXN_C</td>
<td>&quot;0'b01111&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TXPLL_INIT</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TXPLL_RST</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TYPE1_TYPE0_N</td>
<td>&quot;ENDPOINT&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>U_CLK_PERIOD</td>
<td>&quot;0'b0001111101000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>US_PORT_PS_ENTRY_TIME</td>
<td>&quot;0'b0000000000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>US_PORT_RX_PRESET_HINT</td>
<td>&quot;0'b010&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>US_PORT_TX_PRESET</td>
<td>&quot;0'b0100&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>USE_COEF_PRE_MTHD_CTRL</td>
<td>&quot;PRESET_VALUE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>USE_COEF_UPDN_CTRL</td>
<td>&quot;PRESET_VALUE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>USER_AUTO_N</td>
<td>&quot;AUTOMATIC_ON_RECEPTION&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>VALUE_8G_POST</td>
<td>&quot;0'b000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>VALUE_8G_PRE</td>
<td>&quot;0'b000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>VEC_MASK_CAPABLE_MSICAP_A</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>VEC_MASK_CAPABLE_MSICAP_B</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>VEC_MASK_CAPABLE_MSICAP_C</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>VEC_MASK_CAPABLE_MSICAP_D</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>VENDOR_ID_ID1A</td>
<td>&quot;0'b0001100110101010&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>VENDOR_ID_ID1B</td>
<td>&quot;0'b0001100110101010&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>VENDOR_ID_ID1C</td>
<td>&quot;0'b0001100110101010&quot; (default)</td>
<td></td>
</tr>
</tbody>
</table>
### PCLKDIV

Clock Divider for Primary Clock

Architectures Supported:
- LFD2NX
- LIFCL

![PCLKDIV Diagram](image)

**INPUT:**
- CLKin
- LSRPDIV

**OUTPUT:**
- CLKOUT

**PARAMETERS:**

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>VENDOR_ID_ID1D</td>
<td>&quot;0'b0001100110101010&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>VENDOR0_UR</td>
<td>&quot;REPORT&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>VERSION_AER_CAP</td>
<td>&quot;VER_0X2&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>VERSION_PM_CAP</td>
<td>&quot;0'b011&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>XLCY0</td>
<td>&quot;0'b000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>XLCY1</td>
<td>&quot;0'b000000000&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>COEF5_PRE</td>
<td>&quot;0'b000001&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>DIRECTED_RETRAIN_LINK</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>DIS_MSI_CAP_D</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>EN_RBAR_CAP_B</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>GAIN_TIMER1</td>
<td>&quot;0'b0101&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>MIN_SPEED</td>
<td>&quot;2P5G&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>OVERRIDE</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>PRESET_LPBK_SLAVE_2</td>
<td>&quot;OTHERWISE&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>SPEED</td>
<td>&quot;8G&quot; (default)</td>
<td></td>
</tr>
<tr>
<td>TX_DALLOC_C</td>
<td>&quot;0'b0000000001100000&quot; (default)</td>
<td></td>
</tr>
</tbody>
</table>
DIV_PCLKDIV: "X1" (default), "X2", "X4", "X8", "X16", "X32", "X64", "X128"

GSR: "ENABLED" (default), "DISABLED"

**Table 181: PCKLDIV Parameters**

<table>
<thead>
<tr>
<th>Inputs</th>
<th>Parameters</th>
<th>Outputs</th>
</tr>
</thead>
<tbody>
<tr>
<td>CLKI</td>
<td>DIV_PCLKDIV</td>
<td>CLKO</td>
</tr>
<tr>
<td>CLKI</td>
<td>X1</td>
<td>CLKI/1</td>
</tr>
<tr>
<td>CLKI</td>
<td>X2</td>
<td>CLKI/2</td>
</tr>
<tr>
<td>CLKI</td>
<td>X4</td>
<td>CLKI/4</td>
</tr>
<tr>
<td>CLKI</td>
<td>X8</td>
<td>CLKI/8</td>
</tr>
<tr>
<td>CLKI</td>
<td>X16</td>
<td>CLKI/16</td>
</tr>
<tr>
<td>CLKI</td>
<td>X32</td>
<td>CLKI/32</td>
</tr>
<tr>
<td>CLKI</td>
<td>X64</td>
<td>CLKI/64</td>
</tr>
<tr>
<td>CLKI</td>
<td>X128</td>
<td>CLKI/128</td>
</tr>
</tbody>
</table>

**PDP4K**

4 kb Pseudo-dual Port Block RAM

**Architectures Supported:**

- iCE40 UltraPlus

**Inputs:**

- D[15:0] (data in)
- ADW[10:0] (write address)
- ADR[10:0] (read address)
- CKW (write clock)
: Alphanumeric Primitives List



CKR (read clock)



CEW (write clock enable, active high)



CER (read clock enable, active high)



RE (read enable, active high), WE (write enable, active high)



MASK_N[15:0] (per-bit write enable mask, active low)
Note
MASK_N input is functional only for the 16-bit mode. PDP4K is used to configure
2-, 4-, 8- or 16-bit mode EBR operations. MASK_N functions only when it is
configured to 16-bit data.

OUTPUTS:


DO[15:0] (data output)

PARAMETERS:


INITVAL_0:
"0x00000000000000000000000000000000000000000000000000000000
00000000" (default)



INITVAL_1:
"0x00000000000000000000000000000000000000000000000000000000
00000000" (default)



INITVAL_2:
"0x00000000000000000000000000000000000000000000000000000000
00000000" (default)



INITVAL_3:
"0x00000000000000000000000000000000000000000000000000000000
00000000" (default)



INITVAL_4:
"0x00000000000000000000000000000000000000000000000000000000
00000000" (default)



INITVAL_5:
"0x00000000000000000000000000000000000000000000000000000000
00000000" (default)



INITVAL_6:
"0x00000000000000000000000000000000000000000000000000000000
00000000" (default)



INITVAL_7:
"0x00000000000000000000000000000000000000000000000000000000
00000000" (default)



INITVAL_8:
"0x00000000000000000000000000000000000000000000000000000000
00000000" (default)



INITVAL_9:
"0x00000000000000000000000000000000000000000000000000000000
00000000" (default)

Lattice Radiant Software 2.2 Help

849


Alphanumeric Primitives List

- INITVAL_A: "0x0000000000000000000000000000000000000000000000000000000000000000" (default)
- INITVAL_B: "0x0000000000000000000000000000000000000000000000000000000000000000" (default)
- INITVAL_C: "0x0000000000000000000000000000000000000000000000000000000000000000" (default)
- INITVAL_D: "0x0000000000000000000000000000000000000000000000000000000000000000" (default)
- INITVAL_E: "0x0000000000000000000000000000000000000000000000000000000000000000" (default)
- INITVAL_F: "0x0000000000000000000000000000000000000000000000000000000000000000" (default)
- DATA_WIDTH_W: "2" (default), "4", "8", "16" (Write data width)
- DATA_WIDTH_R: "2" (default), "4", "8", "16" (Read data width)

Rules & Restrictions:

See EBR_B section. The same rules regard port mapping and initial value parameter conversion for EBR_B apply for PDP4K (only difference is that for EBR_B → INIT_#, while for PDP4K → INITVAL_#).

PDP16K

16Kb Pseudo Dual Port Block RAM

Architectures Supported:
- LFD2NX
- LIFCL

PDP16K
INPUTS:
- DI[35:0] (Data in)
- ADW[13:0] (Write address)
- ADR[13:0] (Read address)
- CLKW (Write clock)
- CLKR (Read clock)
- CEW (Clock enable)
- CER (Clock enable)
- CSW[2:0] (Write chip select)
- CSR[2:0] (Read chip select)
- RST (Output register reset)

OUTPUT:
- DO[35:0] (Data out)
- ONEBITERR (ECC error flag (single bit error))
- TWOBITERR (ECC error flag (two bit error))

Table 182: PDP16K Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DATA_WIDTH_W</td>
<td>&quot;X36&quot; (default)</td>
<td>Write port width</td>
</tr>
<tr>
<td></td>
<td>&quot;X32&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;X18&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;X9&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;X4&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;X2&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;X1&quot;</td>
<td></td>
</tr>
<tr>
<td>DATA_WIDTH_R</td>
<td>&quot;X36&quot; (default)</td>
<td>Read port width</td>
</tr>
<tr>
<td></td>
<td>&quot;X32&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;X18&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;X9&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;X4&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;X2&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;X1&quot;</td>
<td></td>
</tr>
<tr>
<td>OUTREG</td>
<td>&quot;BYPASSSED&quot; (default)</td>
<td>Register output</td>
</tr>
<tr>
<td></td>
<td>&quot;USED&quot;</td>
<td></td>
</tr>
<tr>
<td>RESETMODE</td>
<td>&quot;SYNC&quot; (default)</td>
<td>Reset sync/async control</td>
</tr>
<tr>
<td></td>
<td>&quot;ASYNC&quot;</td>
<td></td>
</tr>
<tr>
<td>GSR</td>
<td>&quot;ENABLED&quot; (default)</td>
<td>Enable global set/reset for the output registers</td>
</tr>
<tr>
<td></td>
<td>&quot;DISABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>ECC</td>
<td>&quot;DISABLED&quot; (default)</td>
<td>Enable ECC</td>
</tr>
<tr>
<td></td>
<td>&quot;ENABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>INITVAL_00...INITVAL_3F</td>
<td>hex string, 80 bits</td>
<td>EBR initialization data</td>
</tr>
</tbody>
</table>
Table 182: PDP16K Parameters (Continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CSDECODE_W</td>
<td>&quot;000&quot; <em>(default)</em>, &quot;001&quot;, &quot;010&quot;, &quot;011&quot;, &quot;100&quot;, &quot;101&quot;, &quot;110&quot;, &quot;111&quot;</td>
<td>Write chip select active level, 0=active high 1=active low</td>
</tr>
<tr>
<td>CSDECODE_R</td>
<td>&quot;000&quot; <em>(default)</em>, &quot;001&quot;, &quot;010&quot;, &quot;011&quot;, &quot;100&quot;, &quot;101&quot;, &quot;110&quot;, &quot;111&quot;</td>
<td>Read chip select active setting, 0=active high 1=active low</td>
</tr>
<tr>
<td>ASYNC_RST_RELEASE</td>
<td>&quot;SYNC&quot; <em>(default)</em>, &quot;ASYNC*&quot;</td>
<td>Reset release sync/async control</td>
</tr>
<tr>
<td>INIT_DATA</td>
<td>&quot;STATIC&quot; <em>(default)</em>, &quot;DYNAMIC*, &quot;NO_INIT*&quot;</td>
<td></td>
</tr>
</tbody>
</table>

NOTES:

It is not legal to drive the read and write clock such that their active edges switch simultaneously.

All inputs (except the register control signals) and all outputs are registered in the following manner:
Port assignments for different data widths will follow the table below:

<table>
<thead>
<tr>
<th>Data Width</th>
<th>Input Data</th>
<th>Output Data</th>
<th>Write Address (MSB to LSB)</th>
<th>Read Address (MSB to LSB)</th>
</tr>
</thead>
<tbody>
<tr>
<td>16Kx1</td>
<td>DI[0]</td>
<td>DO[0]</td>
<td>ADW[13:0]</td>
<td>ADR[13:0]</td>
</tr>
</tbody>
</table>

For data widths that do not use all available address bits, the unused bits **must** be tied high for proper functionality.

**PDPSC16K**

16Kb Pseudo Dual Port Single Clock Block RAM

Architectures Supported:

- LFD2NX
- LIFCL

INPUTS:

- DI[35:0] (Data in)
- ADW[13:0] (Write address)
- ADR[13:0] (Read address)
- CLK (Clock)
- CER (Read clock enable)
- CEW (Write clock enable)
- CSW[2:0] (Write chip select)
- CSR[2:0] (Read chip select)
- RST (Output register reset)

OUTPUT:
- DO[35:0] (Data out)
- ONEBITERR (ECC error flag (single bit error))
- TWOBITERR (ECC error flag (two bit error))

### Table 183: PDPSC16K Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DATA_WIDTH_W</td>
<td>&quot;X36&quot; <em>(default)</em></td>
<td>Write port width</td>
</tr>
<tr>
<td></td>
<td>&quot;X18&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;X9&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;X4&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;X2&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;X1&quot;</td>
<td></td>
</tr>
<tr>
<td>DATA_WIDTH_R</td>
<td>&quot;X36&quot; <em>(default)</em></td>
<td>Read port width</td>
</tr>
<tr>
<td></td>
<td>&quot;X18&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;X9&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;X4&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;X2&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;X1&quot;</td>
<td></td>
</tr>
<tr>
<td>OUTREG</td>
<td>&quot;BYPASSED&quot; <em>(default)</em></td>
<td>Register output</td>
</tr>
<tr>
<td></td>
<td>&quot;USED&quot;</td>
<td></td>
</tr>
<tr>
<td>RESETMODE</td>
<td>&quot;SYNC&quot; <em>(default)</em></td>
<td>Reset sync/async control</td>
</tr>
<tr>
<td></td>
<td>&quot;ASYNC&quot;</td>
<td></td>
</tr>
<tr>
<td>GSR</td>
<td>&quot;ENABLED&quot; <em>(default)</em></td>
<td>Enable global set/reset for the output registers</td>
</tr>
<tr>
<td></td>
<td>&quot;DISABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>ECC</td>
<td>&quot;DISABLED&quot; <em>(default)</em></td>
<td>Enable ECC</td>
</tr>
<tr>
<td></td>
<td>&quot;ENABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>INITVAL_00...INITVAL_3F</td>
<td>Hex string, 80 bits</td>
<td>EBR Initialization data</td>
</tr>
<tr>
<td>CSDECODE_W</td>
<td>&quot;000&quot; <em>(default)</em></td>
<td>Write chip select active setting</td>
</tr>
<tr>
<td></td>
<td>&quot;001&quot;</td>
<td>0: active high</td>
</tr>
<tr>
<td></td>
<td>&quot;010&quot;</td>
<td>1: active low</td>
</tr>
<tr>
<td></td>
<td>&quot;011&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;100&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;101&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;110&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;111&quot;</td>
<td></td>
</tr>
<tr>
<td>CSDECODE_R</td>
<td>&quot;000&quot; <em>(default)</em></td>
<td>Read chip select active setting</td>
</tr>
<tr>
<td></td>
<td>&quot;001&quot;</td>
<td>0: active high</td>
</tr>
<tr>
<td></td>
<td>&quot;010&quot;</td>
<td>1: active low</td>
</tr>
<tr>
<td></td>
<td>&quot;011&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;100&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;101&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;110&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;111&quot;</td>
<td></td>
</tr>
</tbody>
</table>
NOTES:

When a pseudo-dual port RAM is desired, if only a single clock is required it is preferred to use PDPSC16K over PDP16K as performance in hardware will be faster with PDPSC16K.

All inputs (except the register control signals) and all outputs are registered in the following manner:

Port assignments for different data widths will follow the table below:

<table>
<thead>
<tr>
<th>Data Width</th>
<th>Input Data</th>
<th>Output Data</th>
<th>Write Address (MSB to LSB)</th>
<th>Read Address (MSB to LSB)</th>
</tr>
</thead>
<tbody>
<tr>
<td>16Kx1</td>
<td>DI[0]</td>
<td>DO[0]</td>
<td>ADW[13:0]</td>
<td>ADR[13:0]</td>
</tr>
</tbody>
</table>

For data widths that don’t use all available address bits, the unused bits must be tied high for proper functionality.

**PDPSC512K**

512Kb Single Clock Pseudo Dual Port Block RAM
Architectures Supported:

- LFD2NX
- LIFCL

<table>
<thead>
<tr>
<th>INPUTS:</th>
</tr>
</thead>
<tbody>
<tr>
<td>DI[31:0] (Data in)</td>
</tr>
<tr>
<td>ADW[13:0] (Write address)</td>
</tr>
<tr>
<td>ADR[13:0] (Read address)</td>
</tr>
<tr>
<td>CLK (Clock)</td>
</tr>
<tr>
<td>CEW (Write clock enable)</td>
</tr>
<tr>
<td>CER (Read clock enable)</td>
</tr>
<tr>
<td>WE (Write enable)</td>
</tr>
<tr>
<td>CSW (Write chip select)</td>
</tr>
<tr>
<td>CSR (Read chip select)</td>
</tr>
<tr>
<td>RSTR (Read register reset)</td>
</tr>
<tr>
<td>BYTEEN_N[3:0] (Write byte enable, 0=write, 1=disable. BYTEEN_N[3] corresponds to the MSB of DI, BYTEEN_N[0] corresponds to the LSB)</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>OUTPUT:</th>
</tr>
</thead>
<tbody>
<tr>
<td>DO[31:0] (Data out)</td>
</tr>
<tr>
<td>ERRDECA[1:0] (Port A one and two bit error flag)</td>
</tr>
<tr>
<td>ERRDECB[1:0] (Port B one and two bit error flag)</td>
</tr>
</tbody>
</table>

**Table 184: PDPSC512K Parameters**

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>OUTREG</td>
<td>&quot;NO_REG&quot; (default)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;OUT_REG&quot;</td>
<td>Register output</td>
</tr>
<tr>
<td>GSR</td>
<td>&quot;ENABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;DISABLED&quot;</td>
<td>Enable global set/reset</td>
</tr>
</tbody>
</table>
NOTES:

All inputs (except the register control signals) and all outputs are registered in the following manner:

**PLL**

*Wrapper for Phase Locked Loop*

PLL is capable of frequency synthesis and clock phase management including clock injection delay cancellation.

Architectures Supported:

- LFD2NX
### LIFCL

**PLL**

- **DIR**
- **DIRSEL[2:0]**
- **LOADREG**
- **DYNROTATE**
- **LMMICLK**
- **LMMRESET_N**
- **LMMIREQUEST**
- **LMMIIWRRD_N**
- **LMMIOFFSET[0:0]**
- **LMMIREADY**
- **PWRDOWN**
- **REFCLK**
- **CLKOS**
- **CLKOS3**
- **INTLOCK**
- **LEOYDYN**
- **LOCK**
- **PDDN**
- **PFDD**
- **REFMUX**
- **REGA**
- **REGB**
- **REGOB1**
- **CLKOUT**
- **GRAY**[4:0]
- **BIN**[3:0]
- **DIRDEL**
- **GRAY**[4:0]
- **BIN**[3:0]

### INPUTS:

- **DIR** (Valid if MC1_DYN_SOURCE = 1. Specifies direction that CIB_ROTATE changes VCO phase. 0 - phase rotates to later phase, 1 - phase rotates to earlier phase.)
- **DIRSEL[2:0]** (Valid if MC1_DYN_SOURCE = 1. CIB_DYN_SEL must be stable before initiating a rotation with CIB_LOAD_REG.)
- **LOADREG** (Valid if MC1_DYN_SOURCE = 1. Initiates a divider output phase shift on negative edge of CIB_LOAD_REG.)
- **DYNROTATE** (Valid if MC1_DYN_SOURCE = 1. Initiates a change from current VCO clock phase to an earlier or later phase on the negative edge of CIB_ROTATE.)
- **LMMICLK** (LMMI clock from fabric.)
- **LMMIRESET_N** (LMMI reset signal to reset the state machine if the IP gets locked.)
- **LMMIREQUEST** (LMMI request signal from fabric.)
- **LMMIIWRRD_N** (LMMI write-high/read-low from fabric.)
- **LMMIOFFSET[6:0]** (LMMI offset address from fabric. Not all bits are required for an IP.)
- **LMMIWDATA[7:0]** (LMMI write data from fabric. Not all bits are required for an IP.)
- **PLLPWRDOWN_N** (Active low to power down PLL from CIB port.)
- **REFCK**
- **ENCLKOP** (Enable A output (CLKOP). Active high. PLL CIB input.)
- **ENCLKOS** (Enable B output (CLKOS). Active high. PLL CIB input.)
- **ENCLKOS2** (Enable C output (CLKOS2). Active high. PLL CIB input.)
- **ENCLKOS3** (Enable D output (CLKOS3). Active high. PLL CIB input.)
- **ENCLKOS4** (Enable E output (CLKOS4). Active high. PLL CIB input.)
- **ENCLKOS5** (Enable F output (CLKOS5). Active high. PLL CIB input.)
- **FBKCK**
- **LEGACY** (PLL legacy mode signal. Active high to enter the mode. Enabled by lmmi_legacy fuse. PLL CIB input.)
- **PLLRESET** (Active high to reset PLL. Enabled by MC1_PLLRESET. PLL CIB input.)
- **STDBY** (PLL standby signal. Active high to put PLL clocks in low. Not used.)
- **ROTDEL**
- **DIRDEL**
- **ROTDELP1**
- **GRAYTEST[4:0]**
- **BINTEST[1:0]**
- **DIRDELP1**
- **GRAYACT[4:0]**
- **BINACT[1:0]**

**OUTPUTS:**
- **INTFBKOP**
- **INTFBKOS**
- **INTFBKOS2**
- **INTFBKOS3**
- **INTFBKOS4**
- **INTFBKOS5**
- **LMMIRDATA[7:0]** (LMMI read data to fabric.)
- **LMMIRDATVALID** (LMMI read data valid to fabric.)
- **LMMIREADY** (LMMI ready signal to fabric.)
- CLKOP (Primary (A) output clock.)
- CLKOS (Secondary (B) output clock.)
- CLKOS2 (Secondary (C) output clock.)
- CLKOS3 (Secondary (D) output clock.)
- CLKOS4 (Secondary (E) output clock.)
- CLKOS5 (Secondary (F) output clock.)
- INTLOCK (PLL internal lock indicator. PLL CIB output.)
- LEGRDYN
- LOCK (PLL lock indicator. PLL CIB output.)
- PFDDN (PFD DN output signal to PLL CIB port.)
- PF Dup (PFD UP output signal to PLL CIB port.)
- REFMUXCK (Reference CLK mux output. PLL CIB output.)
- REGQA
- REGQB
- REGQB1
- CLKOUTDL

### Table 185: PLL Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>BW_CTL_BIAS</td>
<td>&quot;0'b0101&quot; <em>(default)</em>  &quot;0000&quot;</td>
<td>Input control signal to tune the bias current of ppath cp, when the bit increase, the bias current increase. This current branch is combined with the lvco_fb current.</td>
</tr>
<tr>
<td>CLKOP_TRIM</td>
<td>&quot;0'b0000&quot; <em>(default)</em></td>
<td>CLKOP output trim control bits</td>
</tr>
<tr>
<td>CLKOS_TRIM</td>
<td>&quot;0'b0000&quot; <em>(default)</em></td>
<td>CLKOS output trim control bits</td>
</tr>
<tr>
<td>CLKOS2_TRIM</td>
<td>&quot;0'b0000&quot; <em>(default)</em></td>
<td>CLKOS2 output trim control bits</td>
</tr>
<tr>
<td>CLKOS3_TRIM</td>
<td>&quot;0'b0000&quot; <em>(default)</em></td>
<td>CLKOS3 output trim control bits</td>
</tr>
<tr>
<td>CLKOS4_TRIM</td>
<td>&quot;0'b0000&quot; <em>(default)</em></td>
<td>CLKOS4 output trim control bits</td>
</tr>
<tr>
<td>CLKOS5_TRIM</td>
<td>&quot;0'b0000&quot; <em>(default)</em></td>
<td>CLKOS5 output trim control bits</td>
</tr>
<tr>
<td>CRIPPLE</td>
<td>&quot;5P&quot; <em>(default)</em>  &quot;4P&quot;  &quot;3P&quot;  &quot;7P&quot;  &quot;9P&quot;  &quot;11P&quot;  &quot;13P&quot;  &quot;15P&quot;</td>
<td>LPF cap control</td>
</tr>
</tbody>
</table>
### Table 185: PLL Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CSET</td>
<td>&quot;40P&quot; (default) &quot;8P&quot; &quot;12P&quot; &quot;16P&quot; &quot;20P&quot; &quot;24P&quot; &quot;28P&quot; &quot;32P&quot; &quot;36P&quot; &quot;44P&quot; &quot;48P&quot; &quot;52P&quot; &quot;56P&quot; &quot;60P&quot; &quot;64P&quot; &quot;68P&quot;</td>
<td>LPF cap control</td>
</tr>
<tr>
<td>DELAY_CTRL</td>
<td>&quot;200PS&quot; (default) &quot;300PS&quot;</td>
<td>Control signal to adjust the delay of the PFD: default 1b0 = 200 ps; 1b1 = 300 ps.</td>
</tr>
<tr>
<td>DELA</td>
<td>&quot;0&quot; (default)</td>
<td>Output divider phase shift. Works with lmmi_diva.</td>
</tr>
<tr>
<td>DELB</td>
<td>&quot;0&quot; (default)</td>
<td>Output divider phase shift. Works with lmmi_divb.</td>
</tr>
<tr>
<td>DELC</td>
<td>&quot;0&quot; (default)</td>
<td>Output divider phase shift. Works with lmmi_divc.</td>
</tr>
<tr>
<td>DELD</td>
<td>&quot;0&quot; (default)</td>
<td>Output divider phase shift. Works with lmmi_divd.</td>
</tr>
<tr>
<td>DELE</td>
<td>&quot;0&quot; (default)</td>
<td>Output divider phase shift. Works with lmmi_divf.</td>
</tr>
<tr>
<td>DELF</td>
<td>&quot;0&quot; (default)</td>
<td>Output divider phase shift. Works with lmmi_divf.</td>
</tr>
<tr>
<td>DIRECTION</td>
<td>&quot;DISABLED&quot; (default) &quot;ENABLED&quot;</td>
<td>LMMI equivalent of CIB direction signal</td>
</tr>
<tr>
<td>DIVA</td>
<td>&quot;0&quot; (default)</td>
<td>Output dividers for CLKOP</td>
</tr>
<tr>
<td>DIVB</td>
<td>&quot;0&quot; (default)</td>
<td>Output dividers for CLKOS</td>
</tr>
<tr>
<td>DIVC</td>
<td>&quot;0&quot; (default)</td>
<td>Output dividers for CLKOS2</td>
</tr>
<tr>
<td>DIVD</td>
<td>&quot;0&quot; (default)</td>
<td>Output dividers for CLKOS3</td>
</tr>
<tr>
<td>DIVE</td>
<td>&quot;0&quot; (default)</td>
<td>Output dividers for CLKOS4</td>
</tr>
<tr>
<td>DIFV</td>
<td>&quot;0&quot; (default)</td>
<td>Output dividers for CLKOS5</td>
</tr>
<tr>
<td>DYN_SEL</td>
<td>&quot;0'b000&quot; (default)</td>
<td>Dynamic phase selection</td>
</tr>
<tr>
<td>DYN_SOURCE</td>
<td>&quot;STATIC&quot; (default) &quot;DYNAMIC&quot;</td>
<td>1'b1 selects CIB signals for dynamic phase shift.</td>
</tr>
<tr>
<td>ENCLK_CLKOP</td>
<td>&quot;DISABLED&quot; (default) &quot;ENABLED&quot;</td>
<td>Bit 0. Clock output enable. Active high.</td>
</tr>
<tr>
<td>ENCLK_CLKOS</td>
<td>&quot;DISABLED&quot; (default) &quot;ENABLED&quot;</td>
<td>Bit 1. Clock output enable. Active high.</td>
</tr>
<tr>
<td>ENCLK_CLKOS2</td>
<td>&quot;DISABLED&quot; (default) &quot;ENABLED&quot;</td>
<td>Bit 2. Clock output enable. Active high.</td>
</tr>
</tbody>
</table>
### Table 185: PLL Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ENCLK_CLKOS3</td>
<td>&quot;DISABLED&quot; (default) &quot;ENABLED&quot;</td>
<td>Bit 3. Clock output enable. Active high.</td>
</tr>
<tr>
<td>ENCLK_CLKOS4</td>
<td>&quot;DISABLED&quot; (default) &quot;ENABLED&quot;</td>
<td>Bit 4. Clock output enable. Active high.</td>
</tr>
<tr>
<td>ENCLK_CLKOS5</td>
<td>&quot;DISABLED&quot; (default) &quot;ENABLED&quot;</td>
<td>Bit 5. Clock output enable. Active high.</td>
</tr>
<tr>
<td>ENABLE_SYNC</td>
<td>&quot;DISABLED&quot; (default) &quot;ENABLED&quot;</td>
<td>1'b1 enables output sync with CLKOP.</td>
</tr>
<tr>
<td>FAST_LOCK_EN</td>
<td>&quot;DISABLED&quot; (default) &quot;ENABLED&quot;</td>
<td>Enables signal for fast lock.</td>
</tr>
<tr>
<td>V2I_1V_EN</td>
<td>&quot;DISABLED&quot; (default) &quot;ENABLED&quot;</td>
<td>1V supply enable or disable</td>
</tr>
<tr>
<td>FBK_CUR_BLE</td>
<td>&quot;0'b00000000&quot; (default)</td>
<td>Bleeding current for PI to adjust the linearity</td>
</tr>
<tr>
<td>FBK_EDGE_SEL</td>
<td>&quot;POSITIVE&quot; (default) &quot;NEGATIVE&quot;</td>
<td>Select the positive or negative phase of PI output. 0: positive phase; 1: negative phase</td>
</tr>
<tr>
<td>FBK_IF_TIMING_CTL</td>
<td>&quot;0'b00&quot; (default)</td>
<td>Interface timing control for feedback divider</td>
</tr>
<tr>
<td>FBK_INTEGER_MODE</td>
<td>&quot;DISABLED&quot; (default) &quot;ENABLED&quot;</td>
<td>Enable the integer mode for feedback divider</td>
</tr>
<tr>
<td>FBK_MASK</td>
<td>&quot;0'b00001000&quot; (default) &quot;00000000&quot;</td>
<td>Minimum divider ratio control word for feedback divider. For example if n_pll[7:0] or mmd_dig[7:0] is less than lmmi_fbk_mask[7:0], then the MMD divider ratio is determined by lmmi_fbk_mask[7:0]. Otherwise the divider ratio will be determined by n_pll[7:0] or mmd_dig[7:0].</td>
</tr>
<tr>
<td>FBK_MMD_DIG</td>
<td>&quot;8&quot; (default) &quot;0&quot;</td>
<td>MMD divider ratio setting in integer mode</td>
</tr>
<tr>
<td>FBK_MMD_PULS_CTL</td>
<td>&quot;0'b0000&quot; (default)</td>
<td>Pulse width control for MMD output clock. If lmmi_fbk_mmd_puls_ctl[3:0]=4'b0110, it means that there’s 6 VCO cycles in the MMD output clock.</td>
</tr>
<tr>
<td>FBK_MODE</td>
<td>&quot;0'b00&quot; (default)</td>
<td>Reserved floating control bits</td>
</tr>
<tr>
<td>FBK_PI_BYPASS</td>
<td>&quot;NOT_BYPASSED&quot; (default) &quot;BYPASSED&quot;</td>
<td>PI bypass control bit. 0; PI not bypass, 1; PI bypass; it should be connected to lmmi_ssc_pi_bypass</td>
</tr>
<tr>
<td>FBK_PI_RC</td>
<td>&quot;0'b1100&quot; (default) &quot;0000&quot;</td>
<td>RC time constant control in PI</td>
</tr>
<tr>
<td>FBK_PR_CC</td>
<td>&quot;0'b0000&quot; (default)</td>
<td>Current control for PI to adjust the linearity</td>
</tr>
<tr>
<td>FBK_PR_IC</td>
<td>&quot;0'b1000&quot; (default) &quot;0000&quot;</td>
<td>Bias current control for PI</td>
</tr>
<tr>
<td>FBK_RSV</td>
<td>&quot;0'b000000000000000&quot; (default)</td>
<td>Reserved control bit for feedback divider.</td>
</tr>
<tr>
<td>FLOAT_CP</td>
<td>&quot;DISABLED&quot; (default) &quot;ENABLED&quot;</td>
<td>Active high to tri-state the ICP output.</td>
</tr>
</tbody>
</table>

Lattice Radiant Software 2.2 Help 862
### Table 185: PLL Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>FLOCK_CTRL</td>
<td>&quot;2X&quot; <em>(default)</em></td>
<td>2 bits control the fast lock period, 00 is 1x, 01 is 2x, 10 is 4x and 11 is 8x</td>
</tr>
<tr>
<td></td>
<td>&quot;1X&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;4X&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;8X&quot;</td>
<td></td>
</tr>
<tr>
<td>FLOCK_EN</td>
<td>&quot;ENABLED&quot; <em>(default)</em></td>
<td>1b1 to enable fast lock; after char, default to enabled</td>
</tr>
<tr>
<td></td>
<td>&quot;DISABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>FLOCK_SRC_SEL</td>
<td>&quot;REFCLK&quot; <em>(default)</em></td>
<td>Fast lock source selection; 0 is ref clock; 1 is feedback clock</td>
</tr>
<tr>
<td></td>
<td>&quot;FBCLK&quot;</td>
<td></td>
</tr>
<tr>
<td>FORCE_FILTER</td>
<td>&quot;DISABLED&quot; <em>(default)</em></td>
<td>force internal vctrl=analog pad</td>
</tr>
<tr>
<td></td>
<td>&quot;ENABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>I_CTRL</td>
<td>&quot;10UA&quot; <em>(default)</em></td>
<td>Current tuning</td>
</tr>
<tr>
<td></td>
<td>&quot;8P3UA&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;14P9UA&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;12P4UA&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;19P8UA&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;17P3UA&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;24P8UA&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;22P3UA&quot;</td>
<td></td>
</tr>
<tr>
<td>IPI_CMP</td>
<td>&quot;0'b1000&quot; <em>(default)</em></td>
<td>i-path CP compensate up/dn mismatch at process variation</td>
</tr>
<tr>
<td></td>
<td>&quot;0000&quot;</td>
<td></td>
</tr>
<tr>
<td>IPI_CMPN</td>
<td>&quot;0'b0011&quot; <em>(default)</em></td>
<td>Input control bits to compensate the i-path bias current</td>
</tr>
<tr>
<td></td>
<td>&quot;0000&quot;</td>
<td></td>
</tr>
<tr>
<td>IPI_COMP_EN</td>
<td>&quot;DISABLED&quot; <em>(default)</em></td>
<td>Enable ipi_cmp</td>
</tr>
<tr>
<td></td>
<td>&quot;ENABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>IPP_CTRL</td>
<td>&quot;0'b1000&quot; <em>(default)</em></td>
<td>Input control signal to tune the bias current of ppath cp</td>
</tr>
<tr>
<td></td>
<td>&quot;0000&quot;</td>
<td></td>
</tr>
<tr>
<td>IPP_SEL</td>
<td>&quot;0'b1111&quot; <em>(default)</em></td>
<td>Input control signal to select which ppath cp is on, there are 4 branches at max</td>
</tr>
<tr>
<td></td>
<td>&quot;0000&quot;</td>
<td></td>
</tr>
<tr>
<td>KP_VCO</td>
<td>&quot;0'b00000&quot; <em>(default)</em></td>
<td>ICO gain controls</td>
</tr>
<tr>
<td>LDT_INT_LOCK_STICKY</td>
<td>&quot;DISABLED&quot; <em>(default)</em></td>
<td>Active high to have INT_LOCK_STICKY. Default to be 1b1. 1b0 is for PDE/DE purpose.</td>
</tr>
<tr>
<td></td>
<td>&quot;ENABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>LDT_LOCK</td>
<td>&quot;98304CYC&quot; <em>(default)</em></td>
<td>Frequency lock-detector resolution sensitivity</td>
</tr>
<tr>
<td></td>
<td>&quot;24576CYC&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;6144CYC&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;1536CYC&quot;</td>
<td></td>
</tr>
<tr>
<td>LDT_LOCK_SEL</td>
<td>&quot;U_FREQ&quot; <em>(default)</em></td>
<td>Lock-detector type select</td>
</tr>
<tr>
<td></td>
<td>&quot;UFREQ&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;SPHASE&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;SFREQ&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;UFREQ_SPHASE&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;U_PHASE&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;S_FREQ&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;U_FREQ_S_PHASE&quot;</td>
<td></td>
</tr>
<tr>
<td>LEGACY_ATT</td>
<td>&quot;DISABLED&quot; <em>(default)</em></td>
<td>Active HIGH; enable Legacy mode</td>
</tr>
<tr>
<td></td>
<td>&quot;ENABLED&quot;</td>
<td></td>
</tr>
</tbody>
</table>
**Table 185: PLL Parameters**

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>LOAD_REG</td>
<td>&quot;DISABLED&quot; (default)</td>
<td>For load control of divider phase control</td>
</tr>
<tr>
<td></td>
<td>&quot;ENABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>OPENLOOP_EN</td>
<td>&quot;DISABLED&quot; (default)</td>
<td>Open loop mode enable for mfg testing</td>
</tr>
<tr>
<td></td>
<td>&quot;ENABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>PHIA</td>
<td>&quot;0&quot; (default)</td>
<td>Select VCO phase-shift (0..7) for A section</td>
</tr>
<tr>
<td>PHIB</td>
<td>&quot;0&quot; (default)</td>
<td>Select VCO phase-shift (0..7) for B section</td>
</tr>
<tr>
<td>PHIC</td>
<td>&quot;0&quot; (default)</td>
<td>Select VCO phase-shift (0..7) for C section</td>
</tr>
<tr>
<td>PHID</td>
<td>&quot;0&quot; (default)</td>
<td>Select VCO phase-shift (0..7) for D section</td>
</tr>
<tr>
<td>PHIE</td>
<td>&quot;0&quot; (default)</td>
<td>Select VCO phase-shift (0..7) for E section</td>
</tr>
<tr>
<td>PHIF</td>
<td>&quot;0&quot; (default)</td>
<td>Select VCO phase-shift (0..7) for F section</td>
</tr>
<tr>
<td>PLLPDN_EN</td>
<td>&quot;DISABLED&quot; (default)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;ENABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>PLLPD_N</td>
<td>&quot;UNUSED&quot; (default)</td>
<td>Active LOW PLL power-down; PLL is NOT USED</td>
</tr>
<tr>
<td></td>
<td>&quot;USED&quot;</td>
<td></td>
</tr>
<tr>
<td>PLLRESET_ENA</td>
<td>&quot;DISABLED&quot; (default)</td>
<td>Active HIGH; Enable PLLRESET CIB Signal</td>
</tr>
<tr>
<td></td>
<td>&quot;ENABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>REF_INTEGER_MODE</td>
<td>&quot;DISABLED&quot; (default)</td>
<td>Integer mode control bit for reference clock pre-divider. Default to Integer, 1b1.</td>
</tr>
<tr>
<td></td>
<td>&quot;ENABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>REF_MASK</td>
<td>&quot;0'b00000000&quot; (default)</td>
<td>Minimum divider ratio control word for reference pre-divider</td>
</tr>
<tr>
<td>REF_MMD_DIG</td>
<td>&quot;8&quot; (default)</td>
<td>MMD divider ratio setting for reference pre-divider when Immi_ref_integer_mode=1</td>
</tr>
<tr>
<td></td>
<td>&quot;0&quot;</td>
<td></td>
</tr>
<tr>
<td>REF_MMD_IN</td>
<td>&quot;0'b00001000&quot; (default)</td>
<td>MMD divider ratio setting for reference pre-divider when Immi_ref_integer_mode=0</td>
</tr>
<tr>
<td></td>
<td>&quot;0'00000000&quot;</td>
<td></td>
</tr>
<tr>
<td>REF_MMD_PULS_CTL</td>
<td>&quot;0'b0000&quot; (default)</td>
<td>Pulse width control for MMD output clock in reference pre-divider</td>
</tr>
<tr>
<td>REF_TIMING_CTL</td>
<td>&quot;0'b00&quot; (default)</td>
<td>Interface timing control for reference divider. Default to be 2b00.</td>
</tr>
<tr>
<td>REFIN_RESET</td>
<td>&quot;SET&quot; (default)</td>
<td>Lmmi_refin_reset = 1b1 and with switching of REFin_SEL (either L-H or H-L) will generate a PLL reset</td>
</tr>
<tr>
<td></td>
<td>&quot;RESET&quot;</td>
<td></td>
</tr>
<tr>
<td>RESERVED</td>
<td>&quot;0'b0000000&quot; (default)</td>
<td>Reserved fuses for PLL internal setting</td>
</tr>
<tr>
<td>RESET_LF</td>
<td>&quot;DISABLED&quot; (default)</td>
<td>LPF reset enable</td>
</tr>
<tr>
<td></td>
<td>&quot;ENABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>ROTATE</td>
<td>&quot;DISABLED&quot; (default)</td>
<td>For VCO phase rotation</td>
</tr>
<tr>
<td></td>
<td>&quot;ENABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>SEL_OUTA</td>
<td>&quot;DISABLED&quot; (default)</td>
<td>Select output to CLKOP</td>
</tr>
<tr>
<td></td>
<td>&quot;ENABLED&quot;</td>
<td></td>
</tr>
</tbody>
</table>
### Table 185: PLL Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SEL_OUTB</td>
<td>&quot;DISABLED&quot; <em>(default)</em> &quot;ENABLED*</td>
<td>Select output to CLKOS</td>
</tr>
<tr>
<td>SEL_OUTC</td>
<td>&quot;DISABLED&quot; <em>(default)</em> &quot;ENABLED*</td>
<td>Select output to CLKOS2</td>
</tr>
<tr>
<td>SEL_OUTD</td>
<td>&quot;DISABLED&quot; <em>(default)</em> &quot;ENABLED*</td>
<td>Select output to CLKOS3</td>
</tr>
<tr>
<td>SEL_OUTE</td>
<td>&quot;DISABLED&quot; <em>(default)</em> &quot;ENABLED*</td>
<td>Select output to CLKOS4</td>
</tr>
<tr>
<td>SEL_OUTF</td>
<td>&quot;DISABLED&quot; <em>(default)</em> &quot;ENABLED*</td>
<td>Select output to CLKOS5</td>
</tr>
<tr>
<td>SLEEP</td>
<td>&quot;DISABLED&quot; <em>(default)</em> &quot;ENABLED*</td>
<td>Active HIGH: Enable STOP PMU signal</td>
</tr>
<tr>
<td>SSC_DITHER</td>
<td>&quot;DISABLED&quot; <em>(default)</em> &quot;ENABLED*</td>
<td>Dither enable or disable for SDM</td>
</tr>
<tr>
<td>SSC_EN_CENTER_IN</td>
<td>&quot;DOWN_TRIANGLE&quot; <em>(default)</em> &quot;CENTER_TRIANGLE*</td>
<td>Down triangle or center triangle control bit in SSC profile generator.</td>
</tr>
<tr>
<td>SSC_EN_SDM</td>
<td>&quot;ENABLED&quot; <em>(default)</em> &quot;DISABLED*</td>
<td>Enable or disable SDM</td>
</tr>
<tr>
<td>SSC_EN_SSC</td>
<td>&quot;DISABLED&quot; <em>(default)</em> &quot;ENABLED*</td>
<td>Enable or disabled SSC profile generator</td>
</tr>
<tr>
<td>SSC_F_CODE</td>
<td>&quot;0'b0000000000000000&quot; <em>(default)</em></td>
<td>Fractional part of the feedback divider ratio</td>
</tr>
<tr>
<td>SSC_N_CODE</td>
<td>&quot;0'b000010100&quot; <em>(default)</em> &quot;000000000&quot;</td>
<td>Integer part of the feedback divider ratio</td>
</tr>
<tr>
<td>SSC_ORDER</td>
<td>&quot;SDM_ORDER2&quot; <em>(default)</em> &quot;SDM_ORDER1*</td>
<td>SDM order control bit; 0 - SDM order = 1; 1 - SDM order = 2</td>
</tr>
<tr>
<td>SSC_PI_BYPASS</td>
<td>&quot;NOT_BYPASSED&quot; <em>(default)</em> &quot;BYPASSED&quot;</td>
<td>PI bypass control bit. 0; PI not bypass, 1; PI bypass; it should be connected to Immi_fbk_pi_bypass</td>
</tr>
<tr>
<td>SSC_REG_WEIGHTING_SEL</td>
<td>&quot;0'b000&quot; <em>(default)</em></td>
<td>Weighting control bit for Immi_ssc_step_in</td>
</tr>
<tr>
<td>SSC_SQUARE_MODE</td>
<td>&quot;DISABLED&quot; <em>(default)</em> &quot;ENABLED*</td>
<td>Two-point FSK modulation control bit</td>
</tr>
<tr>
<td>SSC_STEP_IN</td>
<td>&quot;0'b0000000&quot; <em>(default)</em></td>
<td>SSC modulation depth control bit</td>
</tr>
<tr>
<td>SSC_TBASE</td>
<td>&quot;0'b0000000000000000&quot; <em>(default)</em></td>
<td>SSC modulation frequency control. The frequency should be 30-33 kHz.</td>
</tr>
<tr>
<td>STDBY_ATT</td>
<td>&quot;DISABLED&quot; <em>(default)</em> &quot;ENABLED*</td>
<td>Enable STDBY CIB signal</td>
</tr>
<tr>
<td>TRIMOP_BYPASS_N</td>
<td>&quot;BYPASSED&quot; <em>(default)</em> &quot;USED*</td>
<td>1b0: bypass CLKOP output trim</td>
</tr>
<tr>
<td>TRIMOS_BYPASS_N</td>
<td>&quot;BYPASSED&quot; <em>(default)</em> &quot;USED*</td>
<td>1b0: bypass CLKOS output trim</td>
</tr>
<tr>
<td>Name</td>
<td>Values</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------</td>
<td>-------------------------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>TRIMOS2_BYPASS_N</td>
<td>&quot;BYPASSED&quot; <em>(default)</em> &quot;USED&quot;</td>
<td>1b0: bypass CLKOS2 output trim</td>
</tr>
<tr>
<td>TRIMOS3_BYPASS_N</td>
<td>&quot;BYPASSED&quot; <em>(default)</em> &quot;USED&quot;</td>
<td>1b0: bypass CLKOS3 output trim</td>
</tr>
<tr>
<td>TRIMOS4_BYPASS_N</td>
<td>&quot;BYPASSED&quot; <em>(default)</em> &quot;USED&quot;</td>
<td>1b0: bypass CLKOS4 output trim</td>
</tr>
<tr>
<td>TRIMOS5_BYPASS_N</td>
<td>&quot;BYPASSED&quot; <em>(default)</em> &quot;USED&quot;</td>
<td>1b0: bypass CLKOS5 output trim</td>
</tr>
<tr>
<td>V2I_KVCO_SEL</td>
<td>&quot;85&quot; <em>(default)</em> &quot;40&quot; &quot;45&quot; &quot;50&quot; &quot;55&quot; &quot;60&quot; &quot;65&quot; &quot;70&quot; &quot;75&quot; &quot;80&quot; &quot;90&quot; &quot;95&quot; &quot;100&quot; &quot;105&quot; &quot;110&quot; &quot;115&quot;</td>
<td>Mk choose such as frequency range of ICO from 800-1600 MHz over PVT. Mk larger (more current withdraw from ICO), ICO runs slower.</td>
</tr>
<tr>
<td>V2I_PP_ICTRL</td>
<td>&quot;0'b00110&quot; <em>(default)</em> &quot;0'b00000&quot;</td>
<td>P-path v2i gm control</td>
</tr>
<tr>
<td>V2I_PP_RES</td>
<td>&quot;10K&quot; <em>(default)</em> &quot;11P3K&quot; &quot;11K&quot; &quot;10P7K&quot; &quot;10P3K&quot; &quot;9P7K&quot; &quot;9P3K&quot; &quot;9K&quot;</td>
<td>P-path high frequency pole resistor control</td>
</tr>
<tr>
<td>CLKMUX_FB</td>
<td>&quot;CMUX_CLKOP&quot; <em>(default)</em> &quot;CMUX_CLKOS&quot; &quot;CMUX_CLKOS2&quot; &quot;CMUX_CLKOS3&quot; &quot;CMUX_CLKOS4&quot; &quot;CMUX_CLKOS5&quot;</td>
<td>Fuses used to determine the feedback selection in the wake up stage, center mux about the clock tree feedback</td>
</tr>
</tbody>
</table>
PLL Device Constraints:

Below are the device constraint equations used by the timer for the periods, phases, and delays of the output clocks based on user settings. START_PERIOD must be provided as a constraint. These equations only apply for the integer mode divider values.

For CLKOP (generated clock):

- \[ \text{ADJUSTED} \text{PERIOD} = \text{START} \text{PERIOD} \times (\text{REF} \text{MMD} \text{DIG} + 1) \times (\text{DIVA} + 1) \times (1/(\text{FBK} \text{MMD} \text{DIG} + 1)) \]
- \[ \text{ADJUSTED} \text{PHASE} = ((\text{PHIA} \times 45)/360) \times \text{ADJUSTED} \text{PERIOD} \]
- \[ \text{ADJUSTED} \text{DELAY} = \text{START} \text{PERIOD} \times (\text{REF} \text{MMD} \text{DIG} + 1) \times (1/(\text{FBK} \text{MMD} \text{DIG} + 1)) \times \text{DELA} \]
For CLKOS (generated clock):

- \( \text{ADJUSTED\_PERIOD} = \text{START\_PERIOD} \times (\text{REF\_MMD\_DIG} + 1) \times (\text{DIVB} + 1) \times \left(\frac{1}{(\text{FBK\_MMD\_DIG} + 1)}\right) \)
- \( \text{ADJUSTED\_PHASE} = \left(\frac{\text{PHIB} \times 45}{360}\right) \times \text{ADJUSTED\_PERIOD} \)
- \( \text{ADJUSTED\_DELAY} = \text{START\_PERIOD} \times (\text{REF\_MMD\_DIG} + 1) \times \left(\frac{1}{(\text{FBK\_MMD\_DIG} + 1)}\right) \times \text{DELB} \)

For CLKOS2 (generated clock):

- \( \text{ADJUSTED\_PERIOD} = \text{START\_PERIOD} \times (\text{REF\_MMD\_DIG} + 1) \times (\text{DIVC} + 1) \times \left(\frac{1}{(\text{FBK\_MMD\_DIG} + 1)}\right) \)
- \( \text{ADJUSTED\_PHASE} = \left(\frac{\text{PHIC} \times 45}{360}\right) \times \text{ADJUSTED\_PERIOD} \)
- \( \text{ADJUSTED\_DELAY} = \text{START\_PERIOD} \times (\text{REF\_MMD\_DIG} + 1) \times \left(\frac{1}{(\text{FBK\_MMD\_DIG} + 1)}\right) \times \text{DEL\_C} \)

For CLKOS3 (generated clock):

- \( \text{ADJUSTED\_PERIOD} = \text{START\_PERIOD} \times (\text{REF\_MMD\_DIG} + 1) \times (\text{DIVD} + 1) \times \left(\frac{1}{(\text{FBK\_MMD\_DIG} + 1)}\right) \)
- \( \text{ADJUSTED\_PHASE} = \left(\frac{\text{PHID} \times 45}{360}\right) \times \text{ADJUSTED\_PERIOD} \)
- \( \text{ADJUSTED\_DELAY} = \text{START\_PERIOD} \times (\text{REF\_MMD\_DIG} + 1) \times \left(\frac{1}{(\text{FBK\_MMD\_DIG} + 1)}\right) \times \text{DEL\_D} \)

For CLKOS4 (generated clock):

- \( \text{ADJUSTED\_PERIOD} = \text{START\_PERIOD} \times (\text{REF\_MMD\_DIG} + 1) \times (\text{DIVE} + 1) \times \left(\frac{1}{(\text{FBK\_MMD\_DIG} + 1)}\right) \)
- \( \text{ADJUSTED\_PHASE} = \left(\frac{\text{PHIE} \times 45}{360}\right) \times \text{ADJUSTED\_PERIOD} \)
- \( \text{ADJUSTED\_DELAY} = \text{START\_PERIOD} \times (\text{REF\_MMD\_DIG} + 1) \times \left(\frac{1}{(\text{FBK\_MMD\_DIG} + 1)}\right) \times \text{DEL\_E} \)

For CLKOS5 (generated clock):

- \( \text{ADJUSTED\_PERIOD} = \text{START\_PERIOD} \times (\text{REF\_MMD\_DIG} + 1) \times (\text{DIVF} + 1) \times \left(\frac{1}{(\text{FBK\_MMD\_DIG} + 1)}\right) \)
- \( \text{ADJUSTED\_PHASE} = \left(\frac{\text{PHIF} \times 45}{360}\right) \times \text{ADJUSTED\_PERIOD} \)
- \( \text{ADJUSTED\_DELAY} = \text{START\_PERIOD} \times (\text{REF\_MMD\_DIG} + 1) \times \left(\frac{1}{(\text{FBK\_MMD\_DIG} + 1)}\right) \times \text{DEL\_F} \)

**PLL\_B**

Phase Locked Loop

Architectures Supported:

- iCE40 UltraPlus

USER INSTANTIATION: Illegal. Please refer to **PUR**.
Alphanumeric Primitives List

**INPUTS:**

- **REFERENCECLK** (Reference clock)
- **FEEDBACK** (External feedback input)
- **DYNAMICDELAY7...DYNAMICDELAY0** (Dynamic control of delay for adjusting the phase alignment. Only used when DELAY_ADJUSTMENT_MODE is set to DYNAMIC. RESETB must be active before this bus can change value in order to ensure proper PLL functionality. Once value is changed user must set RESETB high and wait for PLL to lock)
- **BYPASS** (Bypass PLL core (directly connect REFERENCECLK to OUTCORE/OUTGLOBAL pins))
- **RESET_N** (Asynchronously reset the PLL, active low)
- **SCLK** (Clock for internal testing)
- **SDI** (Data for internal testing)
- **LATCH** (Enable low power mode, active high. OUTGLOBAL*/OUTCORE* ports are held static at their last value when ENABLE_ICEGATE_PORT* is set to 1)

**OUTPUTS:**

- **INTFBOUT** (For internal feedback PLL operation, must route this output to FEEDBACK)
- **OUTCORE** (Output clock A, drives regular fabric routing)
- **OUTGLOBAL** (Output clock A, drives global clock network)
- **OUTCOREB** (Output clock B, drives regular fabric routing)
- **OUTGLOBALB** (Output clock B, drives global clock network)
- **SDO** (Data for internal testing)
- **LOCK** (Indicates that the output signal on OUTGLOBALB/OUTCOREB is locked to the REFERENCECLK port, active high)

**PARAMETERS:**

- **FEEDBACK_PATH:** "SIMPLE" (default), "DELAY", "PHASE_AND_DELAY" (Selects the feedback path. SIMPLE = internal feedback, directly from VCO. DELAY = internal feedback, through the...
delay adjustment block. PHASE_AND_DELAY = internal feedback, through the phase shifter and delay adjustment block)

- **DELAY_ADJUSTMENT_MODE_FEEDBACK**: "FIXED" (default), "DYNAMIC" (Selects the mode for the delay adjustment block in the feedback path. FIXED = fixed delay, selected with the FDA_FEEDBACK parameter. DYNAMIC = dynamic delay, selected by the DYNAMICDELAY port)

- **FDA_FEEDBACK**: "0" (default), "1", "2", "3", "4", "5", "6", "7", "8", "9", "10", "11", "12", "13", "14", "15" (Sets a constant value for the delay adjustment block. OUTGLOBALA and OUTCOREA are delayed by (n+1)*150ps)

- **DELAY_ADJUSTMENT_MODE_RELATIVE**: "FIXED" (default), "DYNAMIC" (Selects the mode for the delay adjustment block)

- **FDA_RELATIVE**: "0" (default), "1", "2", "3", "4", "5", "6", "7", "8", "9", "10", "11", "12", "13", "14", "15" (Selects a constant value for the delay adjustment block. OUTGLOBALA and OUTCOREA are delayed with regards to the B output signals, by (n+1)*150ps)

- **SHIFTREG_DIV_MODE**: "0" (default), "1" (Selects shift register configuration. 0 = divide by 4, 1 = divide by 7. Used when FEEDBACK_PATH is set to PHASE_AND_DELAY)

- **PLLOUT_SELECT_PORTA**: "SHIFTREG_0deg" (default), "SHIFTREG_90deg", "GENCLK", "GENCLK_HALF" (Configures the OUTCOREA and OUTGLOBALA ports. SHIFTREG_0deg = 0 degree phase shift (FEEDBACK_PATH must also be set to PHASE_AND_DELAY), SHIFTREG_90deg = 90 degree phase shift (FEEDBACK_PATH must be set to PHASE_AND_DELAY, and SHIFTREG_DIV_MODE to 0), GENCLK = the internally generated frequency and no phase shift, GENCLK_HALF = half of the internally generated frequency and no phase shift)

- **PLLOUT_SELECT_PORTB**: "SHIFTREG_0deg" (default), "SHIFTREG_90deg", "GENCLK", "GENCLK_HALF" (Configures the OUTCOREB and OUTGLOBALB ports. SHIFTREG_0deg = 0 degree phase shift (FEEDBACK_PATH must also be set to PHASE_AND_DELAY), SHIFTREG_90deg = 90 degree phase shift (FEEDBACK_PATH must be set to PHASE_AND_DELAY, and SHIFTREG_DIV_MODE to 0), GENCLK = the internally generated frequency and no phase shift, GENCLK_HALF = half of the internally generated frequency and no phase shift)

- **DIVR**: "0" (default), "1", "2", "3", "4", "5", "6", "7", "8", "9", "10", "11", "12", "13", "14", "15" (REFERENCECLK divider)

Alphanumeric Primitives List


- DIVQ: “1” (default), “2”, “3”, “4”, “5”, “6” (VCO divider)
- FILTER_RANGE: “0” (default), “1”, “2”, “3”, “4”, “5”, “6”, “7” (PLL filter range)
- EXTERNAL_DIVIDE_FACTOR: “NONE” (default), (Divide-by factor of a divider in the external feedback path. Can be set to any integer value.)
- ENABLE_ICEGATE_PORTA: “0” (default), “1” (Enables the PLL power-down control for port A, 0 = disabled, 1 = controlled by LATCH input)
- ENABLE_ICEGATE_PORTB: “0” (default), “1” (Enables the PLL power-down control for port B, 0 = disabled, 1 = controlled by LATCH input)
- TEST_MODE: “0” (default), “1” (Enables the use of test ports, SCLK, SDI, SDO. Disabled = 0, Enabled = 1)
- FREQUENCY_PIN_REFERENCECLK: “NONE” (default), (SDC Constraint entry on REFERENCECLK port of PLL)

Rules & Restrictions:

FEEDBACK port (external feedback input pin) CANNOT be VHI, VLO, or floating. Otherwise, PLL in HW will not operate correctly.

When EXTERNAL_DIVIDE_FACTOR != NONE, DELAY_ADJUSTMENT_MODE should be set to either FIXED or DYNAMIC.

When EXTERNAL_DIVIDE_FACTOR != NONE, PLLOUT_SELECT_PORTA != SHIFTREG_0deg, PLLOUT_SELECT_PORTA != SHIFTREG_90deg, PLLOUT_SELECT_PORTB != SHIFTREG_0deg, PLLOUT_SELECT_PORTB != SHIFTREG_90deg.

When FEEDBACK_PATH = DELAY, DELAY_ADJUSTMENT_MODE_FEEDBACK should be set to either FIXED or DYNAMIC.

When FEEDBACK_PATH = DELAY, PLLOUT_SELECT_PORTA != SHIFTREG_0deg, PLLOUT_SELECT_PORTA != SHIFTREG_90deg, PLLOUT_SELECT_PORTB != SHIFTREG_0deg, PLLOUT_SELECT_PORTB != SHIFTREG_90deg.

When FEEDBACK_PATH = PHASE_AND_DELAY, DELAY_ADJUSTMENT_MODE_FEEDBACK should be set to either FIXED or DYNAMIC.

When FEEDBACK_PATH = PHASE_AND_DELAY both PLLOUT_SELECT_PORTA and PLLOUT_SELECT_PORTB must be set to either SHIFTREG_0deg or SHIFTREG_90deg.

When EXTERNAL_DIVIDE_FACTOR = NONE, make sure INTFBOUT is connected to FEEDBACK.
When \( \text{EXTERNAL\_DIVIDE\_FACTOR} \neq \text{NONE} \), make sure \( \text{INTFBOU} \)T is NOT connected to \( \text{FEEDBACK} \).

\( \text{REFERENCECLK} \) input must be between 10 and 133 MHz.

**How to calculate output frequency:**

When \( \text{FEEDBACK\_PATH} = \text{"SIMPLE,"} \) the calculation of the period of the output clock of \( \text{PLL\_B} \) is:

\[
\text{Output\_period} = \text{reference\_clk\_period} \times \left[ \begin{array}{c}
\text{EQ}\[\text{EXTERNAL\_DIVIDE\_FACTOR}, \text{NONE}, (2^{\text{DIVQ}}), 1/\text{EXTERNAL\_DIVIDE\_FACTOR} \] \times (\text{DIVR} + 1) \times (1/(\text{DIVF} + 1)) \times \\
\text{EQ}\[\text{PLLOUT\_SELECT\_PORTB}, \text{GENCLK\_HALF}, 2, 1] \end{array} \right]
\]

When \( \text{FEEDBACK\_PATH} = \text{"DELAY,"} \) the calculation of the period of the output clock of \( \text{PLL\_B} \) is:

\[
\text{Output\_period} = \text{reference\_clk\_period} \times \left[ \begin{array}{c}
\text{EQ}\[\text{EXTERNAL\_DIVIDE\_FACTOR}, \text{NONE}, 1, 1/\text{EXTERNAL\_DIVIDE\_FACTOR} \] \times (\text{DIVR} + 1) \times (1/(\text{DIVF} + 1)) \times \\
\text{EQ}\[\text{PLLOUT\_SELECT\_PORTB}, \text{GENCLK\_HALF}, 2, 1] \end{array} \right]
\]

When \( \text{FEEDBACK\_PATH} = \text{"PHASE\_AND\_DELAY,"} \) the calculation of the period of the output clock of \( \text{PLL\_B} \) is:

\[
\text{Output\_period} = \text{reference\_clk\_period} \times \left[ \begin{array}{c}
\text{EQ}\[\text{EXTERNAL\_DIVIDE\_FACTOR}, \text{NONE}, 1, 1/\text{EXTERNAL\_DIVIDE\_FACTOR} \] \times (\text{DIVR} + 1) \times (1/(\text{DIVF} + 1)) \times \\
\text{EQ}\[\text{PLLOUT\_SELECT\_PORTA}, \text{GENCLK\_HALF}, 2, 1] \times \\
\text{EQ}\[\text{PLLOUT\_SELECT\_PORTA}, \text{SHIFTREG\_0deg,} \times \\
\text{EQ}\[\text{SHIFTREG\_DIV\_MODE}, 1, 7, 4, 1] \times \\
\text{EQ}\[\text{PLLOUT\_SELECT\_PORTA}, \text{SHIFTREG\_0deg,} \times \\
\text{EQ}\[\text{SHIFTREG\_DIV\_MODE}, 1, 7, 4, 1] \end{array} \right]
\]

In the above equations, the sections beginning with "\( \text{EQ}\[\)" and enclosed in "\( \]" are treated as if/else statements during calculation. For example, "\( \text{EQ}[\text{EXTERNAL\_DIVIDE\_FACTOR}, \text{NONE}, 1, 1/\text{EXTERNAL\_DIVIDE\_FACTOR}] \)" means that if \( \text{EXTERNAL\_DIVIDE\_FACTOR} \) is set to \( \text{NONE} \) then use the value "1," otherwise use the value "1/\text{EXTERNAL\_DIVIDE\_FACTOR}" in the calculation.

**NOTE:**

\text{EXTERNAL\_DIVIDE\_FACTOR} is embedded in each of the equations, so even if you are using external feedback in your design, you will still need to choose one of the above equations based on the \( \text{FEEDBACK\_PATH} \) setting.

**Example PLL\_B Instantiation (External Feedback):**

```vhdl
PLL_B PLL_B_inst ( 
  .REFERENCECLK (REFERENCECLK ), 
  .FEEDBACK (FEEDBACK ), 
  .DYNAMICDELAY7 (DYNAMICDELAY7 ), 
  .DYNAMICDELAY6 (DYNAMICDELAY6 ), 
)```

.DYNAMICDELAY5     (DYNAMICDELAY5  ),
.DYNAMICDELAY4     (DYNAMICDELAY4  ),
.DYNAMICDELAY3     (DYNAMICDELAY3  ),
.DYNAMICDELAY2     (DYNAMICDELAY2  ),
.DYNAMICDELAY1     (DYNAMICDELAY1  ),
.DYNAMICDELAY0     (DYNAMICDELAY0  ),
.BYPASS            (BYPASS         ),
.RESET_N           (RESET_N        ),
.SCLK              (SCLK           ),
.SDI               (SDI            ),
.LATCH             (LATCH          ),
.INTFBOUT           (*(NOT CONNECTED*)),
.OUTCORE           (OUTCORE        ),
.OUTGLOBAL         (               ),
.OUTCOREB          (OUTCOREB       ),
.OUTGLOBALB        (               ),
.SDO               (SDO            ),
.LOCK              (LOCK           );

defparam PLL_B_inst.EXTERNAL_DIVIDE_FACTOR = "15";
defparam PLL_B_inst.DELAY_ADJUSTMENT_MODE_FEEDBACK = "DYNAMIC";

Example PLL_B Instantiation (Internal Feedback):
PLL_B PLL_B_inst (  
  .REFERENCECLK      (REFERENCECLK   ),
  .FEEDBACK          (INTFBOUT       ),
  .DYNAMICDELAY7     (DYNAMICDELAY7  ),
  .DYNAMICDELAY6     (DYNAMICDELAY6  ),
  .DYNAMICDELAY5     (DYNAMICDELAY5  ),
  .DYNAMICDELAY4     (DYNAMICDELAY4  ),
  .DYNAMICDELAY3     (DYNAMICDELAY3  ),
  .DYNAMICDELAY2     (DYNAMICDELAY2  ),
  .DYNAMICDELAY1     (DYNAMICDELAY1  ),
  .DYNAMICDELAY0     (DYNAMICDELAY0  ),
  .BYPASS            (BYPASS         ),
  .RESET_N           (RESET_N        ),
  .SCLK              (SCLK           ),
  .SDI               (SDI            ),
  .LATCH             (LATCH          ),
  .INTFBOUT           (INTFBOUT       ),
  .OUTCORE           (OUTCORE        ),
  .OUTGLOBAL         (               ),
  .OUTCOREB          (OUTCOREB       ),
  .OUTGLOBALB        (               ),
  .SDO               (SDO            ),
  .LOCK              (LOCK           );

defparam PLL_B_inst.EXTERNAL_DIVIDE_FACTOR = "NONE";
defparam PLL_B_inst.FEEDBACK_PATH = "SIMPLE";

**PUR**
Power Up Set/Reset
Architectures Supported:

- LFD2NX
- LIFCL
- iCE40 UltraPlus

**INPUT:**

- PUR

**PARAMETERS:**

- RST_PULSE: "1" (default), any integer

PUR is used to reset or set all register elements in your design upon device configuration/startup. The PUR component can be connected to a net from an input buffer or an internally generated net. It is active LOW and when pulsed will set or reset all register bits to the same state as the local set or reset functionality. The pulse will be of the length specified by RST_PULSE.

It is not necessary to connect signals for PUR to any register elements explicitly. The function will be implicitly connected globally.

**RGB**

RGB LED drive module, containing three open drain I/O pins for RGB LED outputs.

Architectures Supported:

- iCE40 UltraPlus

**INPUTS:**

- CURREN: Enable reference current to IR drivers. Enabling the drivers takes 100us to reach a stable reference current value. Active high.
- RGBLEDEN: Enable the RGB driver. Active high.
RGB0PWM: Input data to drive RGB0 LED pin.
RGB1PWM: Input data to drive RGB1 LED pin.
RGB2PWM: Input data to drive RGB2 LED pin.

OUTPUTS:
RGB2: RGB2 LED output.
RGB1: RGB1 LED output.
RGB0: RGB0 LED output.

PARAMETERS:
CURRENT_MODE: "0" (default), "1" (0 = full current, 1 = half current)
RGB0_CURRENT: "0'b000000" (default), "0'b000001", "0'b000011", 
"0'b000111", "0'b011111" (0'b000000 = 0mA, 
0'b000001 = 4mA, 0'b000011 = 8mA, 0'b000111 = 16mA, 0'b011111 = 20mA, 0'b111111 = 24mA. Divide by 2 for half current mode)
RGB1_CURRENT: "0'b000000" (default), "0'b000001", "0'b000011", 
"0'b000111", "0'b011111" (0'b000000 = 0mA, 
0'b000001 = 4mA, 0'b000011 = 8mA, 0'b000111 = 16mA, 0'b011111 = 20mA, 0'b111111 = 24mA. Divide by 2 for half current mode)
RGB2_CURRENT: "0'b000000" (default), "0'b000001", "0'b000011", 
"0'b000111", "0'b011111" (0'b000000 = 0mA, 
0'b000001 = 4mA, 0'b000011 = 8mA, 0'b000111 = 16mA, 0'b011111 = 20mA, 0'b111111 = 24mA. Divide by 2 for half current mode)

ATTRIBUTES: syn_black_box black_box_pad_pin="RGB2,RGB1,RGB0"

RGB1P8V
RGB LED drive module, containing three open drain I/O pins for RGB LED outputs. Trim bits are driven from Fabric.

Architectures Supported:
ICE40 UltraPlus
INPUTS:
- **CURREN**: Enable reference current to IR drivers. Enabling the drivers takes 100us to reach a stable reference current value. Active high.
- **RGBLEDEN**: Enable the RGB driver. Active high.
- **RGB0PWM**: Input data to drive RGB0 LED pin.
- **RGB1PWM**: Input data to drive RGB1 LED pin.
- **RGB2PWM**: Input data to drive RGB2 LED pin.

OUTPUTS:
- **RGB2**: RGB LED output.
- **RGB1**: RGB LED output.
- **RGB0**: RGB LED output.

PARAMETERS:
- **CURRENT_MODE**: "0" (default), "1" (0 = full current, 1 = half current)
- **RGB0_CURRENT**: "0'b000000" (default), "0'b000001", "0'b000011", "0'b000111", "0'b011111" (0'b000000 = 0mA, 0'b000001 = 4mA, 0'b000011 = 8mA, 0'b000111 = 12mA, 0'b011111 = 16mA, 0'b011111 = 20mA, 0'b111111 = 24mA. Divide by 2 for half current mode)
- **RGB1_CURRENT**: "0'b000000" (default), "0'b000001", "0'b000011", "0'b000111", "0'b011111" (0'b000000 = 0mA, 0'b000001 = 4mA, 0'b000011 = 8mA, 0'b000111 = 12mA, 0'b011111 = 16mA, 0'b011111 = 20mA, 0'b111111 = 24mA. Divide by 2 for half current mode)
- **RGB2_CURRENT**: "0'b000000" (default), "0'b000001", "0'b000011", "0'b000111", "0'b011111" (0'b000000 = 0mA, 0'b000001 = 4mA, 0'b000011 = 8mA, 0'b000111 = 12mA, 0'b011111 = 16mA, 0'b011111 = 20mA, 0'b111111 = 24mA. Divide by 2 for half current mode)

ATTRIBUTES: syn_black_box black_box_pad_pin="RGB2,RGB1,RBG0"

**RGB_CORE**
RGB LED drive module containing three open drain I/O pins for RGB LED outputs.

Architectures Supported:
**iCE40 UltraPlus**

### RGB_CORE

- **CURRENT**: Enable reference current to IR drivers. Enabling the drivers takes 100us to reach a stable reference current value. Active high.
- **RGBLEDEN**: Enable the RGB driver. Active high.
- **RGB0PWM**: Input data to drive RGB0 LED pin.
- **RGB1PWM**: Input data to drive RGB1 LED pin.
- **RGB2PWM**: Input data to drive RGB2 LED pin.
- **TRIM9…TRIM0**: Trim bit ports to trim output PWM signals. Pre-set value.

### INPUTS:

### OUTPUTS:

### PARAMETERS:
- **CURRENT_MODE**: "0" (default), "1"
- **RGB0_CURRENT**: "0'b000000" (default), "0'b000001", "0'b000011", "0'b000111", "0'b011111", "0'b111111"
- **RGB1_CURRENT**: "0'b000000" (default), "0'b000001", "0'b000011", "0'b000111", "0'b011111", "0'b111111"
- **RGB2_CURRENT**: "0'b000000" (default), "0'b000001", "0'b000011", "0'b000111", "0'b011111", "0'b111111"
- **FABRIC_TRIME**: "DISABLE" (default), "ENABLE"

**SAME AS: SB_RGBA_DRV**

### RGBPWM

Generates the PWM signals for the RGB LED drivers.

**Architectures Supported:**
iCE40 UltraPlus

RGBPWM

INPUTS:
- LEDDCS: Chip select.
- LEDDCLK: Write clock.
- LEDDAT7...LEDDAT0: Data input.
- LEDDADDR3...LEDDADDR0: Data address.
- LEDDDEN: Data enable input to indicate data and address are stable.
- LEDDEXE: Enable the IP to run the blinking sequence. When it is low, the sequence stops at the nearest OFF state.

OUTPUTS:
- PWMOUT2...PWMOUT0: PWM outputs.
- LEDDON: Indicates the LED is on.

PARAMETERS: None

SAME AS: SB_LEDDA_IP

SEDC
Interface for Soft Error Detection and Correction Functionality

Architectures Supported:
- LFD2NX
LIFCL

Table 186: SEDC Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SEDCEN</td>
<td>&quot;DIS&quot; (default)</td>
<td>&quot;EN&quot;</td>
</tr>
</tbody>
</table>
**SGMIICDR**

SGMI stands for Serial Gigabit Media Independent Interface, widely used for the interface to a discrete Ethernet PHY chip, it is defined as a 1.25 Gbps DDR interface with both clock and data pairs.

**Note**

You should not try to use this primitive directly. Instead, use the related IP in IP Catalog. The following information is for reference only.

*Architectures Supported:*

- LFD2NX
- LIFCL

*INPUTS:*

- LMMICLK
- LMMIRESET_N
- LMMIRESET
- LMMIRWD_N
- LMMIWRITE[3:0]
- DCALIRST
- DFACQRST
- RRST
- SPCLK
- SGMIIN
- SREIFCLK

You should not try to use this primitive directly. Instead, use the related IP in IP Catalog. The following information is for reference only.
SREFCLK

OUTPUTS:
- LMMIRDATA[7:0]
- LMMIRDATVALID
- LMMIREADY
- SRCLK
- SRXD[9:0]
- CDRLOL

Table 187: SGMIIICDR Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>GSR</td>
<td>&quot;ENABLED&quot; (default)</td>
<td>&quot;DISABLED&quot;</td>
</tr>
<tr>
<td>DCOITUNE4LSB</td>
<td>&quot;0_PERCENT&quot; (default)</td>
<td>DACLSB current tuning.</td>
</tr>
<tr>
<td></td>
<td>&quot;15_PERCENT&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;34_PERCENT&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;60_PERCENT&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;NEG_34_PERCENT&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;NEG_28_PERCENT&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;NEG_20_PERCENT&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;NEG_12_PERCENT&quot;</td>
<td></td>
</tr>
<tr>
<td>DCOCTLGI</td>
<td>&quot;0_PERCENT&quot; (default)</td>
<td>DCO global current control.</td>
</tr>
<tr>
<td></td>
<td>&quot;15_PERCENT&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;34_PERCENT&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;60_PERCENT&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;NEG_34_PERCENT&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;NEG_28_PERCENT&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;NEG_20_PERCENT&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;NEG_12_PERCENT&quot;</td>
<td></td>
</tr>
<tr>
<td>DCOSTEP</td>
<td>&quot;100_PERCENT&quot; (default)</td>
<td>Calibration step current adjust.</td>
</tr>
<tr>
<td></td>
<td>&quot;17_PERCENT&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;NEG_34_PERCENT&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;NEG_17_PERCENT&quot;</td>
<td></td>
</tr>
<tr>
<td>DCOCALDIV</td>
<td>&quot;100_PERCENT&quot; (default)</td>
<td>Calibration Input current adjust.</td>
</tr>
<tr>
<td></td>
<td>&quot;NEG_10_PERCENT&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;NEG_17_PERCENT&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;NEG_25_PERCENT&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;60_PERCENT&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;42_PERCENT&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;25_PERCENT&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;11_PERCENT&quot;</td>
<td></td>
</tr>
</tbody>
</table>
### Table 187: SGMIICDR Parameters (Continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DCOIOSTUNE</td>
<td>&quot;0_PERCENT&quot; (default)</td>
<td>DCO offset current tuning.</td>
</tr>
<tr>
<td></td>
<td>&quot;10_PERCENT&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;NEG_40_PERCENT&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;NEG_20_PERCENT&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;39_PERCENT&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;49_PERCENT&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;20_PERCENT&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;30_PERCENT&quot;</td>
<td></td>
</tr>
<tr>
<td>DCOFLTDAC</td>
<td>&quot;80MHZ&quot; (default)</td>
<td>DAC output current filter option.</td>
</tr>
<tr>
<td></td>
<td>&quot;51MHZ&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;181MHZ&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;103MHZ&quot;</td>
<td></td>
</tr>
<tr>
<td>DCOSTARTVAL</td>
<td>&quot;NOMINAL&quot; (default)</td>
<td>Calibration start band current adjust.</td>
</tr>
<tr>
<td></td>
<td>&quot;12P5_PERCENT&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;NEG_50_PERCENT&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;NEG_25_PERCENT&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;100_PERCENT&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;125_PERCENT&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;50_PERCENT&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;75_PERCENT&quot;</td>
<td></td>
</tr>
<tr>
<td>DCONUOFLSB</td>
<td>&quot;NEG_60_PERCENT&quot; (default)</td>
<td>Up/down current option.</td>
</tr>
<tr>
<td></td>
<td>&quot;NEG_80_PERCENT&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;NEG_20_PERCENT&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;NEG_40_PERCENT&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;20_PERCENT&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;0_PERCENT&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;60_PERCENT&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;40_PERCENT&quot;</td>
<td></td>
</tr>
<tr>
<td>RPWDNB</td>
<td>&quot;POWER_UP&quot; (default)</td>
<td>SGMII CDR IP power-down control.</td>
</tr>
<tr>
<td></td>
<td>&quot;POWER_DOWN&quot;</td>
<td></td>
</tr>
<tr>
<td>CDR_CNT4SEL</td>
<td>&quot;BYPASSED&quot; (default)</td>
<td>Selection for CDR random walk divider4.</td>
</tr>
<tr>
<td></td>
<td>&quot;BY_2&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;BY_3&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;BY_4&quot;</td>
<td></td>
</tr>
<tr>
<td>DCOITUNE</td>
<td>&quot;100_PERCENT&quot; (default)</td>
<td>ICO current adjustment.</td>
</tr>
<tr>
<td></td>
<td>&quot;NEG_33_PERCENT&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;NEG_50_PERCENT&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;NEG_60_PERCENT&quot;</td>
<td></td>
</tr>
<tr>
<td>BAND_THRESHOLD</td>
<td>0'b000000 (default)</td>
<td>Stop point for DCO band calibration.</td>
</tr>
<tr>
<td>AUTO_FACQ_EN</td>
<td>&quot;ENABLED&quot; (default)</td>
<td>Enable automatic DCO frequency acquisition.</td>
</tr>
<tr>
<td></td>
<td>&quot;DISABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>AUTO_CALIB_EN</td>
<td>&quot;ENABLED&quot; (default)</td>
<td>Enable automatic DCO band calibration.</td>
</tr>
<tr>
<td></td>
<td>&quot;DISABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>CDR_LOL_SET</td>
<td>&quot;1000_PPM&quot; (default)</td>
<td>CDR loss of lock setting.</td>
</tr>
<tr>
<td></td>
<td>&quot;2000_PPM&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;4000_PPM&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;300_PPM&quot;</td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td>Values</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------</td>
<td>---------------------------------</td>
<td>----------------------------------</td>
</tr>
<tr>
<td>FC2DCO_FLOOP</td>
<td>&quot;DISABLED&quot; (default)</td>
<td>Force DCO lock to the frequency loop.</td>
</tr>
<tr>
<td></td>
<td>&quot;ENABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>FC2DCO_DLOOP</td>
<td>&quot;DISABLED&quot; (default)</td>
<td>Force DCO lock to the data loop.</td>
</tr>
<tr>
<td></td>
<td>&quot;ENABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>CALIB_TIME_SEL</td>
<td>&quot;24_CYC&quot; (default)</td>
<td>Time to wait for DCO to be stable.</td>
</tr>
<tr>
<td></td>
<td>&quot;26_CYC&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;28_CYC&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;210_CYC&quot;</td>
<td></td>
</tr>
<tr>
<td>CALIB_CK_MODE</td>
<td>&quot;BY_2&quot; (default)</td>
<td>DCO calibration clock mode.</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASSSED&quot;</td>
<td></td>
</tr>
<tr>
<td>BAND_CALIB_MODE</td>
<td>&quot;256_FDBK_CLK_CYC&quot; (default)</td>
<td>Waiting time to move to the next band.</td>
</tr>
<tr>
<td></td>
<td>&quot;512_FDBK_CLK_CYC&quot;</td>
<td></td>
</tr>
<tr>
<td>REG_BAND_SEL</td>
<td>0'b00000 (default)</td>
<td>DCO band selection.</td>
</tr>
<tr>
<td>REG_BAND_OFFSET</td>
<td>0'b0000 (default)</td>
<td>DCO band offset control.</td>
</tr>
<tr>
<td>REG_IDAC_SEL</td>
<td>0'b00000000 (default)</td>
<td>Manual idac selection when reg_idac_en = 1.</td>
</tr>
<tr>
<td>LB_Ctl</td>
<td>&quot;DISABLED&quot; (default)</td>
<td>Loopback control for testing lb_ctl.</td>
</tr>
<tr>
<td></td>
<td>&quot;DATA_OUT&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;CLK_OUT&quot;</td>
<td></td>
</tr>
<tr>
<td>REG_IDAC_EN</td>
<td>&quot;DISABLED&quot; (default)</td>
<td>Enable manual idac selection.</td>
</tr>
<tr>
<td></td>
<td>&quot;ENABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>ATDCFG</td>
<td>&quot;0_PS&quot; (default)</td>
<td>Adjust atd pulse width (unit width 2 inv delay).</td>
</tr>
<tr>
<td></td>
<td>&quot;92P5_PS&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;160_PS&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;248_PS&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;NEG_565_PS&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;NEG_475P5_PS&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;NEG_407P5_PS&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;NEG_343P5_PS&quot;</td>
<td></td>
</tr>
<tr>
<td>ATDDLY</td>
<td>&quot;0_PS&quot; (default)</td>
<td>Delay atd pulse (unit width 2 inv delay).</td>
</tr>
<tr>
<td></td>
<td>&quot;62_PS&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;78P5_PS&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;NEG_12_PS&quot;</td>
<td></td>
</tr>
<tr>
<td>BDAVOID_ENB</td>
<td>&quot;ENABLED&quot; (default)</td>
<td>DAC 10b boundary code avoidance mode: 0 = enable, 1 = disable.</td>
</tr>
<tr>
<td></td>
<td>&quot;DISABLED&quot;</td>
<td></td>
</tr>
<tr>
<td>BYPASSATD</td>
<td>&quot;NOT_BYPASS&quot; (default)</td>
<td>Bypass atd.</td>
</tr>
<tr>
<td></td>
<td>&quot;BYPASS&quot;</td>
<td></td>
</tr>
<tr>
<td>DCOIUPDNX2</td>
<td>&quot;1X&quot; (default)</td>
<td>Up/down current option.</td>
</tr>
<tr>
<td></td>
<td>&quot;2X&quot;</td>
<td></td>
</tr>
<tr>
<td>IDAC_EN</td>
<td>&quot;DISABLED&quot; (default)</td>
<td>Enable manual idac selection.</td>
</tr>
<tr>
<td></td>
<td>&quot;ENABLED&quot;</td>
<td></td>
</tr>
</tbody>
</table>
Table 187: SGMIIICDR Parameters (Continued)

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>FB_CLK_DIV</td>
<td>0'b010 (default)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>000</td>
<td></td>
</tr>
<tr>
<td>EN_RECALIB</td>
<td>&quot;ENABLED&quot; (default)</td>
<td>Enable re-calibration.</td>
</tr>
<tr>
<td></td>
<td>&quot;DISABLED&quot;</td>
<td></td>
</tr>
</tbody>
</table>

**SP16K**

16 kb Single Port Block RAM

Architectures Supported:

- LFD2NX
- LIFCL

**SP16K**

**INPUTS:**

- DI[17:0]. Data in.
- AD[13:0]: Address.
- CLK: Clock
- CE: Clock enable.
- WE: Write enable.
- CS[2:0]: Chip select.
- RST: Output register reset.

**OUTPUT:**
DO[17:0]: Data out.

**Table 188: SP16K Parameters**

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DATA_WIDTH</td>
<td>&quot;X18&quot; (default)</td>
<td>Data width</td>
</tr>
<tr>
<td></td>
<td>&quot;X9&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;X4&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;X2&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;X1&quot;</td>
<td></td>
</tr>
<tr>
<td>OUTREG</td>
<td>&quot;BYPASSED&quot; (default)</td>
<td>Enable output register</td>
</tr>
<tr>
<td></td>
<td>&quot;USED&quot;</td>
<td></td>
</tr>
<tr>
<td>RESETMODE</td>
<td>&quot;SYNC&quot; (default)</td>
<td>Reset mode</td>
</tr>
<tr>
<td></td>
<td>&quot;ASYNC&quot;</td>
<td></td>
</tr>
<tr>
<td>GSR</td>
<td>&quot;ENABLED&quot; (default)</td>
<td>Enable global set/reset</td>
</tr>
<tr>
<td></td>
<td>&quot;DISABLED&quot;</td>
<td>for the output registers</td>
</tr>
<tr>
<td>INITVAL_00...INITVAL_3F</td>
<td>Hex string, 80 bits</td>
<td>EBR initialization data</td>
</tr>
<tr>
<td>CSDECODE</td>
<td>000 (default)</td>
<td>Chip select active setting</td>
</tr>
<tr>
<td></td>
<td>001</td>
<td></td>
</tr>
<tr>
<td></td>
<td>010</td>
<td></td>
</tr>
<tr>
<td></td>
<td>011</td>
<td></td>
</tr>
<tr>
<td></td>
<td>100</td>
<td></td>
</tr>
<tr>
<td></td>
<td>101</td>
<td></td>
</tr>
<tr>
<td></td>
<td>110</td>
<td></td>
</tr>
<tr>
<td></td>
<td>111</td>
<td></td>
</tr>
<tr>
<td>ASYNC_RST_RELEASE</td>
<td>&quot;SYNC&quot; (default)</td>
<td>Reset release mode</td>
</tr>
<tr>
<td></td>
<td>&quot;ASYNC&quot;</td>
<td></td>
</tr>
<tr>
<td>INIT_DATA</td>
<td>&quot;STATIC&quot; (default)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;DYNAMIC&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&quot;NO_INIT&quot;</td>
<td></td>
</tr>
</tbody>
</table>

**NOTES:**

All inputs (except the register control signals) and all outputs are registered in the following manner:
Port assignments for different data widths will follow the table below:

<table>
<thead>
<tr>
<th>Data Width</th>
<th>Input Data</th>
<th>Output Data</th>
<th>Address (MSB to LSB)</th>
</tr>
</thead>
<tbody>
<tr>
<td>16Kx1</td>
<td>DI[0]</td>
<td>DO[0]</td>
<td>AD[13:0]</td>
</tr>
<tr>
<td>8Kx2</td>
<td>DI[1:0]</td>
<td>DO[1:0]</td>
<td>AD[13:1]</td>
</tr>
<tr>
<td>2Kx9</td>
<td>DI[8:0]</td>
<td>DO[8:0]</td>
<td>AD[13:3]</td>
</tr>
</tbody>
</table>

For data widths that do not use all available address bits, the unused bits must be tied high for proper functionality.

The initial value of the memory may be given in the INITVAL property. The format is little endian, with bytes (up to 9 bits) packed as follows, where byte[n] is the most significant byte and byte[0] is the least significant byte:

INITVAL_XX = { {0, byte[n]}, {0, byte[n-1]}, … {0, byte[1]}, {0, byte[0]} }

**SP256K**

Single Port RAM that can be configured in 16K x 16 mode. This block can be cascaded using logic implemented in fabric to create larger memories.

Architectures Supported:

- iCE40 UltraPlus

**SP256K**

<table>
<thead>
<tr>
<th>INPUTS:</th>
</tr>
</thead>
<tbody>
<tr>
<td>AD[13:0]: This Address input port is used to address the location to be written during the write cycle and read during the read cycle.</td>
</tr>
<tr>
<td>DI[15:0]: The data input bus used to write the data into the memory location specified by address input port during the write cycle.</td>
</tr>
</tbody>
</table>
- **MASKWE[3:0]**: The Bit Write feature where selective write to individual I/O's can be done using the Maskable Write Enable signals. Each bit masks a nibble of DI.
- **WE**: When the Write Enable input is Logic High, the memory is in the write cycle. When the Write enable is Logic Low, the memory is in the Read Cycle.
- **CS**: When the memory enable input is Logic High, the memory is enabled and read/write operations can be performed. When memory Enable input is logic Low, the memory is deactivated.
- **CK**: This is the external clock for the memory.
- **STDBY**: When this pin is active then memory goes into low leakage mode, there is no change in the output state.
- **SLEEP**: This pin shut down power to periphery and maintain memory contents. The outputs of the memory are pulled low.
- **PWROFF_N**: This pin turns off the power to the memory core when it is driven low. There is no memory data retention when it is driven low. When PWROFF_N is driven high, the SPRAM is powered on.

**OUTPUTS:**
- **DO[15:0]**: It outputs the contents of the memory location addressed by the Address Input signals.

**SP512K**
512Kb Single Port Block RAM

Architectures Supported:
- **LFD2NX**
- **LIFCL**

**SP512K**

**INPUTS:**
- **DI[31:0]**: Data in.
- **AD[13:0]**: Address
- **CLK**: Clock.
- CE: Clock enable.
- WE: Write enable.
- CS: Chip select.
- RSTOUT: Output register reset.
- CEOUT: Output register clock enable.
- BYTEEN_N[3:0]: Write byte enable: 0=enable, 1=disable. BYTEEN_N[3] corresponds to the MSB of DI. BYTEEN_N[0] corresponds to the LSB.

OUTPUT:
- DDO[31:0]: Data out.
- ERRDECA[1:0]: Port A 1- and 2-bit error flag.
- ERRDECB[1:0]: Port B 1- and 2-bit error flag.

**Table 189: SP512K Parameters**

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>OUTREG</td>
<td>&quot;NO_REG&quot; (default) &quot;OUT_REG&quot;</td>
<td>Register output</td>
</tr>
<tr>
<td>GSR</td>
<td>&quot;GSR_EN&quot; (default) &quot;GSR_DIS&quot;</td>
<td>Enable global set/reset</td>
</tr>
<tr>
<td>RESETMODE</td>
<td>&quot;SYNC&quot; (default) &quot;ASYNC&quot;</td>
<td>Reset sync/async control</td>
</tr>
<tr>
<td>INITVAL_00...INITVAL_7F</td>
<td>Hex string, 1280 bits</td>
<td></td>
</tr>
<tr>
<td>ASYNC_RESET_RELEASE</td>
<td>&quot;SYNC&quot; (default) &quot;ASYNC&quot;</td>
<td>Reset release sync/async</td>
</tr>
<tr>
<td>ECC_BYTE_SEL</td>
<td>&quot;BYTE_EN&quot; &quot;ECC_EN&quot; (default)</td>
<td></td>
</tr>
</tbody>
</table>

**NOTES:**

All inputs (except the register control signals) and all outputs are registered in the following manner:
**SPI_B**

Hard SPI interface

Architectures Supported:
- iCE40 UltraPlus

<table>
<thead>
<tr>
<th>INPUTS:</th>
</tr>
</thead>
<tbody>
<tr>
<td>SBCLKI: System clock input.</td>
</tr>
<tr>
<td>SBRWI: System read/write input.</td>
</tr>
<tr>
<td>SBSTBI: Strobe signal.</td>
</tr>
<tr>
<td>SBADRI7...SBADRI0: System bus control registers address.</td>
</tr>
<tr>
<td>SBDATI7...SBDATI0: System data input.</td>
</tr>
<tr>
<td>MI: Master input from PAD.</td>
</tr>
<tr>
<td>SI: Slave input from PAD.</td>
</tr>
<tr>
<td>SCKI: Slave clock input from PAD.</td>
</tr>
<tr>
<td>SCSNI: Slave chip select input from PAD.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>OUTPUTS:</th>
</tr>
</thead>
<tbody>
<tr>
<td>SBDATO7...SBDATO0: System data output.</td>
</tr>
<tr>
<td>SBACKO: System acknowledgment.</td>
</tr>
<tr>
<td>SPIIRQ: SPI interrupt output.</td>
</tr>
<tr>
<td>SPIWKUP: SPI wake up from standby signal.</td>
</tr>
<tr>
<td>SO: Slave output to PAD.</td>
</tr>
<tr>
<td>SOE: Slave output enable to PAD. Active high.</td>
</tr>
</tbody>
</table>
MO: Master output to PAD.
MOE: Master output enable to PAD. Active high.
SCKO: Slave clock output to PAD.
SCKOE: Slave clock output enable to PAD.
MCSNO3...MCSNO0: Master chip select output to PAD.
MCSNOE3...MCSNOE0: Master chip select output enable to PAD.

PARAMETERS:
BUS_ADDR74: "0'b0000" (default), "0'b0010". Fixed value. Upper left corner should be '0'b0000. Upper right corner should be '0'b0010. SBARDI[7:4] should match this value to activate the IP.
FREQUENCY_PIN_SBCLKI: SDC constraint entry on SBCLKI port of SPI. "NONE" (default).

**SPR16X4**
Distributed Single Port RAM with Synchronous Write and Asynchronous Read

Architectures Supported:
- LFD2NX
- LIFCL

**SPR16X4**

```
  D[3:0]  DO[3:0]
  |      |
  |      |
  |      |
  |      |
CK
WRE
AD[3:0]
```

INPUTS:
- D[3:0]: Data in.
- AD[3:0]: Read/write address.
- CK: Write clock.
- WRE: Write enable.

OUTPUT:
- DO[3:0]: Data out.

PARAMETERS:
TSALLA
Global Tristate Interface

Architectures Supported:
- LFD2NX
- LIFCL

INPUTS:
- TSALL

TSALLA is used to tristate buffers in your design. The TSALLA component is connected to a net to drive all output and bidirectional buffers into a HIGH impedance state when active HIGH.

It is not necessary to connect signals to buffers explicitly. The function will be implicitly connected globally.

TSHX2DQ
DQ tristate control for DDR2 & DDR3 memory

Architectures Supported:
- LFD2NX
LIFCL

This primitive is used to generate the tristate control for DQ data output for DDR3/DDR3L and LPDDR2/LPDDR3 memory interface with x2 gearing.

OUTPUTS:
- T0, T1: Tristate input. T0 is output first, followed by T1.
- DQSW270: Clock that is 90° ahead of the clock used to generate the DQS output.
- ECLK: ECLK input.
- SCLK: Primary clock input (divide-by-2 of ECLK).
- RST: Reset input.

OUTPUT:
- Q: Tristate output.

Table 190: TSHX2DQ Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
<th>Values</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>GSR</td>
<td>Enable global set/ reset.</td>
<td>&quot;ENABLED&quot;</td>
<td>&quot;ENABLED&quot;</td>
</tr>
</tbody>
</table>

TSHX2DQS

DQS tristate control for DDR2 & DDR3 memory

Architectures Supported:
- LIFCL
This primitive is used to generate the tristate control for DQS output.

**INPUTS:**
- T0, T1: Tristate input. T0 is output first, followed by T1.
- DQSW: DQSW includes write leveling phase shift from ECLK.
- ECLK: ECLK input.
- SCLK: Primary clock input (divide-by-2 of ECLK).
- RST: Reset input.

**OUTPUT:**
- Q: Tristate output.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
<th>Values</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>GSR</td>
<td>Enable global set/reset.</td>
<td>&quot;ENABLED&quot; &quot;DISABLED&quot;</td>
<td>&quot;ENABLED&quot;</td>
</tr>
</tbody>
</table>

**TSHX4DQ**
DQ tristate control for DDR3 memory

Architectures Supported:
- LFD2NX
This primitive is used to generate the tristate control for DQ data output for DDR3/DDR3L and LPDDR2/LPDDR3 memory interfaces with x4 gearing.

**INPUTS:**
- T[3:] : Tristate input. T0 is output first, T3 last.
- DQSW270: Clock that is 90° ahead of the clock used to generate the DQS output.
- ECLK: ECLK input.
- SCLK: Primary clock input (divide-by-4 of ECLK).
- RST: Reset input.

**OUTPUT:**
- Q: Tristate output.

**Table 192: TSHX4DQ Parameters**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
<th>Values</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>GSR</td>
<td>Enable global set/reset.</td>
<td>&quot;ENABLED&quot;</td>
<td>&quot;ENABLED&quot;</td>
</tr>
</tbody>
</table>

**TSHX4DQS**

DQS tristate control for DDR3 memory

**Architectures Supported:**
- LIFCL
This primitive is used to generate the tristate control for DQS output for DDR3/DDR3L and LPDDR2/LPDDR3 memory interfaces with x4 gearing.

**INPUTS:**
- T[3:0]: Tristate input. T0 is output first, T3 last.
- DQSW: DQSW includes write leveling phase shift from ECLK.
- ECLK: ECLK input.
- SCLK: Primary clock input (divide-by-4 of ECLK).
- RST: Reset input.

**OUTPUT:**
- Q: Tristate output.

### Table 193: TSHX4DQS Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
<th>Values</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>GSR</td>
<td>Enable global set/reset.</td>
<td>&quot;ENABLED&quot;</td>
<td>&quot;ENABLED&quot;</td>
</tr>
</tbody>
</table>

### VFB_B

256 kb Single Port RAM

Architectures Supported:
### VFB_B

<table>
<thead>
<tr>
<th>INPUTS</th>
<th>OUTPUTS</th>
</tr>
</thead>
<tbody>
<tr>
<td>iCE40 UltraPlus</td>
<td></td>
</tr>
<tr>
<td>ADDRESS13...ADDRESS0</td>
<td>DATAOUT15...DATAOUT0</td>
</tr>
<tr>
<td>DATAIN15...DATAIN0</td>
<td></td>
</tr>
<tr>
<td>MASKWREN3...MASKWREN0</td>
<td></td>
</tr>
<tr>
<td>WREN</td>
<td></td>
</tr>
<tr>
<td>CHIPSELECT</td>
<td></td>
</tr>
<tr>
<td>CLOCK</td>
<td></td>
</tr>
<tr>
<td>RDMARGINEN</td>
<td></td>
</tr>
<tr>
<td>RDMARGIN3...RDMARGIN0</td>
<td></td>
</tr>
<tr>
<td>STANDBY</td>
<td></td>
</tr>
<tr>
<td>SLEEP</td>
<td></td>
</tr>
<tr>
<td>POWEROFF_N</td>
<td></td>
</tr>
<tr>
<td>TEST</td>
<td></td>
</tr>
</tbody>
</table>

#### INPUTS:
- ADDRESS13...ADDRESS0: Read/write address.
- DATAIN15...DATAIN0: Data input
- MASKWREN3...MASKWREN0: Write mask. Each bit masks a nibble of DATAIN.
- WREN: Write enable.
- CHIPSELECT: Chip select.
- CLOCK: Clock.
- RDMARGINEN: Read margin enable.
- RDMARGIN3...RDMARGIN0: Read margin.
- STANDBY: Standby mode enable. Active high.
- SLEEP: Sleep enable. Active high.
- POWEROFF_N: Power off enable. Active low.
- TEST: Test enable.

#### OUTPUTS:
- DATAOUT15...DATAOUT0: Data output.

---

**VHI**
Logic High Generator

Architectures Supported:
- LIFCL
- iCE40 UltraPlus
LFD2NX

OUTPUT:
- Z

VLO
Logic Low Generator

Architectures Supported:
- LIFCL
- iCE40 UltraPlus
- LFD2NX

OUTPUT:
- Z

WARMBOOT
Allows for loading a different configuration during run time

Architectures Supported:
- iCE40 UltraPlus

INPUTS:
- S1...S0: Select desired configuration image.
- BOOT: Trigger the re-configuration process
**WDT**
Interface for Configuration Watchdog Timer

Architectures Supported:
- LFD2NX
- LIFCL

**WDT**

![WDT](image)

**INPUTS:**
- WDTRELOAD
- WDT_CLK
- WDT_RST

**OUTPUT:** none

**Table 194: WDT Parameters**

<table>
<thead>
<tr>
<th>Name</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>WDTEN</td>
<td>&quot;DIS&quot; (default) &quot;EN&quot;</td>
<td></td>
</tr>
<tr>
<td>WDTMODE</td>
<td>&quot;SINGLE&quot; (default) &quot;CONTINUOUS&quot;</td>
<td></td>
</tr>
<tr>
<td>WDTVALUE</td>
<td>0'b000000000000000000 (default)</td>
<td></td>
</tr>
</tbody>
</table>

**WIDEFN9**
9-Input Single Output Logic Block

Architectures Supported:
- LFD2NX
**LIFCL**

**INPUTS:**
- A0
- B0
- C0
- D0
- A1
- B1
- C1
- D1
- SEL

**OUTPUT:**
- Z

**PARAMETERS:**
- INIT0: hexadecimal value (default: “0x0000”)
- INIT1: hexadecimal value (default: “0x0000”)

---

Lattice Radiant Software 2.2 Help 899
DSP Inference Guide

The following are examples if DSP Inference.

// Multiply without register example, corresponding to the following parameter settings of MAC16:
//      A_REG = "0b0"
//      B_REG = "0b0"
//      TOP_8x8_MULT_REG = "0b0"
//      BOT_8x8_MULT_REG = "0b0"
//      PIPELINE_16x16_MULT_REG1 = "0b0"
//      PIPELINE_16x16_MULT_REG0 = "0b0"
//      TOPOUTPUT_SELECT = "0b10"
//      BOTOUTPUT_SELECT = "0b10"

module mult_unsign_7_6(a,b,c);
  parameter A_WIDTH = 7;
  parameter B_WIDTH = 6;

  input unsigned [(A_WIDTH - 1):0] a;
  input unsigned [(B_WIDTH - 1):0] b;
  output unsigned [(A_WIDTH + B_WIDTH - 1):0] c;

  assign c = a * b;
endmodule

// Multiply/add without register example, corresponding to the following parameter settings of
// MAC16:
//      A_REG = "0b0"
//      B_REG = "0b0"
//      TOP_8x8_MULT_REG = "0b0"
//      BOT_8x8_MULT_REG = "0b0"
//      PIPELINE_16x16_MULT_REG1 = "0b0"
//      PIPELINE_16x16_MULT_REG0 = "0b0"
//      TOPADDSUB_LOWERINPUT = "0b01"
//      BOTADDSUB_LOWERINPUT = "0b01"
module multaddsub_add_unsign_7_6(a,b,c,din);
  parameter A_WIDTH = 7;
  parameter B_WIDTH = 6;

  input unsigned [(A_WIDTH - 1):0] a;
  input unsigned [(B_WIDTH - 1):0] b;
  input unsigned [(A_WIDTH + B_WIDTH - 1):0] din;
  output unsigned [(A_WIDTH + B_WIDTH - 1):0] c;

  assign c = a * b + din;
endmodule

// Mult/sub with input registers, corresponding to the following parameter settings of MAC16:
//      A_REG = "0b1"
//      B_REG = "0b1"
//      TOP_8x8_MULT_REG = "0b0"
//      BOT_8x8_MULT_REG = "0b0"
//      PIPELINE_16x16_MULT_REG1 = "0b0"

module multaddsub_sub_unsign_7_6(a,b,c,din);
  parameter A_WIDTH = 7;
  parameter B_WIDTH = 6;

  input unsigned [(A_WIDTH - 1):0] a;
  input unsigned [(B_WIDTH - 1):0] b;
  input unsigned [(A_WIDTH + B_WIDTH - 1):0] din;
  output unsigned [(A_WIDTH + B_WIDTH - 1):0] c;

  assign c = a * b - din;
endmodule
module multaddsub_sub_sign_ir_7_6(clk,a,b,din,c,rst,set);
    parameter A_WIDTH = 7;
    parameter B_WIDTH = 6;

    input rst;
    input set;
    input clk;
    input signed [(A_WIDTH - 1):0] a;
    input signed [(B_WIDTH - 1):0] b;
    input signed [(A_WIDTH + B_WIDTH - 1):0] din;
    output signed [(A_WIDTH + B_WIDTH - 1):0] c;

    reg signed [(A_WIDTH - 1):0] reg_a;
    reg signed [(B_WIDTH - 1):0] reg_b;
    reg signed [(A_WIDTH + B_WIDTH - 1):0] reg_din;
    assign c = reg_a * reg_b - reg_din;
    always @(posedge clk)
    begin
        if(rst)
            begin
                reg_a <= 0;
                reg_b <= 0;
                reg_din <= 0;
            end
        else if(set)
            begin
                reg_a <= -1;
                reg_b <= -1;
                reg_din <= -1;
            end
        else
            begin
                reg_a <= a;
                reg_b <= b;
                reg_din <= din;
            end
    endmodule
## Synthesis Attributes

This table lists synthesis attributes, and compares Radiant software and Lattice Diamond.

<table>
<thead>
<tr>
<th>Function</th>
<th>Synplify Pro Diamond</th>
<th>Synplify Pro Radiant</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Attribute</td>
<td>Value</td>
</tr>
<tr>
<td>ROM Synthesis</td>
<td>syn_romstyle</td>
<td>logic</td>
</tr>
<tr>
<td>block_rom</td>
<td>Specifies that the inferred ROM be mapped to the appropriate vendor-specific memory.</td>
<td>logic</td>
</tr>
<tr>
<td>distributed</td>
<td>Implements the ROM structure as distributed ROM.</td>
<td>EBR</td>
</tr>
<tr>
<td>distributed</td>
<td>Implements the ROM structure as distributed ROM.</td>
<td>DSP</td>
</tr>
<tr>
<td>DSP Synthesis</td>
<td>syn_dspstyle</td>
<td>DSP</td>
</tr>
<tr>
<td>logic</td>
<td>Implements the multipliers as logic.</td>
<td>logic</td>
</tr>
</tbody>
</table>
Command Line Reference Guide

This help guide contains information necessary for running the core design flow development from the command line. For tools that appear in the Radiant software graphical user interface, use Tcl commands to perform commands that are described in the “Tcl Command Reference Guide” on page 956.

Command Line Program Overview

Lattice FPGA command line programs can be referred to as the FPGA flow core tools. These are tools necessary to run a complete design flow and are used for tasks such as module generation, design implementation, design verification, and design configuration. This topic provides an overview of those tools, their functions, and provides links to detailed usage information on each tool.

Each command line program provides multiple options for specifying device information, applying special functions using switches, designating desired output file names, and using command files. The programs also have particular default behavior often precludes the need for some syntax, making commands less complex. See “Command Line General Guidelines” on page 907 and “Command Line Syntax Conventions” on page 908.
To learn more about the applications, usage, and syntax for each command line program, click on the hyperlink of the command line name in the section below.

**Note**

Many of the command line programs described in this topic are run in the background when using the tools you run in the Radiant software environment. Please also note that in some cases, command line tools described here are used for earlier FPGA architectures only, are not always recommended for command line use, or are only available from the command line.

**Design Implementation Using Command Line Tools**  The table below shows all of the command line tools used for various design functions, their graphical user interface counterparts, and provides functional descriptions of each.

<table>
<thead>
<tr>
<th>Design Function</th>
<th>Command Line Tool</th>
<th>Radiant Process</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Encryption</td>
<td>Encryption</td>
<td>Encrypt Verilog/VHDL files</td>
<td>Encrypts the input HDL source file with provided encryption key.</td>
</tr>
<tr>
<td>Synthesis</td>
<td>Synpwrap</td>
<td>Synthesis Design</td>
<td>Used to manage Synopsys Synplify Pro synthesis programs.</td>
</tr>
<tr>
<td>Mapping</td>
<td>MAP</td>
<td>Map Design</td>
<td>Converts a design represented in logical terms into a network of physical components or configurable logic blocks.</td>
</tr>
<tr>
<td>Placement and Routing</td>
<td>PAR</td>
<td>Place &amp; Route Design</td>
<td>Assigns physical locations to mapped components and creates physical connections to join components in an electrical network.</td>
</tr>
<tr>
<td>Static Timing Analysis</td>
<td>Timing</td>
<td>Post-Synthesis Timing Report, MAP Timing Report, Place &amp; Route Timing Report</td>
<td>Generates reports that can be used for static timing analysis.</td>
</tr>
<tr>
<td>Back Annotation</td>
<td>Backanno</td>
<td>Tool does not exist in the Radiant software interface as process but employed in file export.</td>
<td>Distributes the physical design information back to the logical design to generate a timing simulation file.</td>
</tr>
</tbody>
</table>
Command Line Basics

This section provides basic instructions for running any of the core design flow development and tools from the command line.

Topics include:

- “Command Line Data Flow” on page 906
- “Command Line General Guidelines” on page 907
- “Command Line Syntax Conventions” on page 908
- “Setting Up the Environment to Run Command Line” on page 909
- “Invoking Core Tool Command Line Programs” on page 910
- “Invoking Core Tool Command Line Tool Help” on page 910

Command Line Data Flow

The following chart illustrates the FPGA command line tool data flow through a typical design cycle.

Command Line Tool Data Flow

See Also

- “Command Line Reference Guide” on page 904
- “Command Line General Guidelines” on page 907
Command Line General Guidelines

You can run the FPGA family Radiant software design tools from the command line. The following are general guidelines that apply.

- Files are position-dependent. Generally, they follow the convention [options] <infile> <outfile> (although order of <outfile> and <infile> are sometimes reversed). Use the -h command line option to check the exact syntax; for example, par -h.

- For any Radiant software FPGA command line program, you can invoke help on available options with the -h or -help command. See “Invoking Core Tool Command Line Programs” on page 910 for more information.

- Command line options are entered on the command line in any order, preceded by a hyphen (-), and separated by spaces.

- Most command line options are case-sensitive and must be entered in lowercase letters. When an option requires an additional parameter, the option and the parameter must be separated by spaces or tabs (i.e., -l 5 is correct, -l5 is not).

- Options can appear anywhere on the command line. Arguments that are bound to a particular option must appear after the option (i.e., -f <command_file> is legal; <command_file> -f is not).

- For options that may be specified multiple times, in most cases the option letter must precede each parameter. For example, -b romeo juliet is not acceptable, while -b romeo -b juliet is acceptable.

- If you enter the FPGA family Radiant software application name on the command line with no arguments and the application requires one or more arguments (par, for example), you get a brief usage message consisting of the command line format string.
For any Radiant software FPGA command line program, you can store program commands in a command file. Execute an entire batch of arguments by entering the program name, followed by the -f option, and the command file name. This is useful if you frequently execute the same arguments each time you execute a program or to avoid typing lengthy command line arguments. See “Using Command Files” on page 951.

See Also
- “Command Line Reference Guide” on page 904
- “Invoking Core Tool Command Line Tool Help” on page 910
- “Command Line Syntax Conventions” on page 908
- “Using Command Files” on page 951
- “Command Line Data Flow” on page 906

Command Line Syntax Conventions

The following conventions are used when commands are described:

Table 2: Command Line Syntax Conventions

<table>
<thead>
<tr>
<th>Convention</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>( )</td>
<td>Encloses a logical grouping for a choice between sub-formats.</td>
</tr>
<tr>
<td>[ ]</td>
<td>Encloses items that are optional. (Do not type the brackets.) Note that &lt;infile[.udb]&gt; indicates that the .udb extension is optional but that the extension must be UDB.</td>
</tr>
<tr>
<td>{ }</td>
<td>Encloses items that may be repeated zero or more times.</td>
</tr>
<tr>
<td></td>
<td>Logical OR function. You must choose one or a number of options. For example, if the command syntax says pan up</td>
</tr>
<tr>
<td>&lt;&gt;</td>
<td>Encloses a variable name or number for which you must substitute information.</td>
</tr>
<tr>
<td>, (comma)</td>
<td>Indicates a range for an integer variable.</td>
</tr>
<tr>
<td>- (dash)</td>
<td>Indicates the start of an option name.</td>
</tr>
<tr>
<td>:</td>
<td>The bind operator. Binds a variable name to a range.</td>
</tr>
<tr>
<td><strong>bold</strong></td>
<td>Indicates text to be taken literally. You type this text exactly as shown (for example, &quot;Type autoroute -all -i 5 in the command area.&quot;) Bold text is also used to indicate the name of an EPIC command, a Linux command, or a DOS command (for example, “The playback command is used to execute the macro you created.”).</td>
</tr>
</tbody>
</table>
Setting Up the Environment to Run Command Line

For Windows The environments for both the Radiant Tcl Console window or Radiant Standalone Tcl Console window (pnmainc.exe) are already set. You can start entering Tcl tool command or core tool commands in the console and the software will perform them.

When running the Radiant software from the Windows command line (via cmd.exe), you will need to add the following values to the following environment variables:

- **PATH** includes, for 64-bit

  <Install_directory>\bin\nt64;<Install_directory>\ispfpga\bin\nt64

  **Example** <Install_directory>:

  c:\lsc\radiant\1.0\bin\nt64;c:\lsc\radiant\1.0\ispfpga\bin\nt64

- **FOUNDRY** includes

  set FOUNDRY= <Install_directory>\ispfpga

For Linux On Linux, the Radiant software provides a similar standalone Tcl Console window (radiantc) that sets the environment. The user can enter Tcl commands and core tool commands in it.

If you do not use the Tcl Console window, you need to run "bash" to switch to BASH first, then run the following command.

- For BASH (64-bit):
After setting up for either Windows or PC, you can run the Radiant software executable files directly. For example, you can invoke the Place and Route program by:

```
par test_map.udb test_par.udb
```

See Also ▶ “Invoking Core Tool Command Line Programs” on page 910
▶ “Invoking Core Tool Command Line Tool Help” on page 910

### Invoking Core Tool Command Line Programs

This topic provides general guidance for running the Radiant software FPGA flow core tools. Refer to “Command Line Program Overview” on page 904 to see what these tools include and for further information.

For any the Radiant software FPGA command line programs, you begin by entering the name of the command line program followed by valid options for the program separated by spaces. Options include switches (-f, -p, -o, etc.), values for those switches, and file names, which are either input or output files. You start command line programs by entering a command in the Linux™ or DOS™ command line. You can also run command line scripts or command files.

See Table 2 on page 908 for details and links to specific information on usage and syntax. You will find all of the usage information on the command line in the Running FPGA Tools from the Command Line > Command Line Tool Usage book topics.

See Also ▶ “Command Line Reference Guide” on page 904
▶ “Command Line Syntax Conventions” on page 908
▶ “Invoking Core Tool Command Line Tool Help” on page 910
▶ “Setting Up the Environment to Run Command Line” on page 909
▶ “Using Command Files” on page 951

### Invoking Core Tool Command Line Tool Help

To get a brief usage message plus a verbose message that explains each of the options and arguments, enter the FPGA family Radiant software application name on the command line followed by -help or -h. For example, enter bitgen -h for option descriptions for the bitgen program.
To redirect this message to a file (to read later or to print out), enter this command:

command_name -help | -h > filename

The usage message is redirected to the filename that you specify.

For those FPGA family Radiant software applications that have architecture-specific command lines (e.g., iCE UltraPlus), you must enter the application name, `-help` (or `-h`), and the architecture to get the verbose usage message specific to that architecture. If you fail to specify the architecture, you get a message similar to the following:

Use `<appname> -help <architecture>` to get detailed usage for a particular architecture.

**See Also**
- “Command Line Reference Guide” on page 904
- “Command Line Data Flow” on page 906
- “Command Line General Guidelines” on page 907
- “Command Line Syntax Conventions” on page 908
- “Setting Up the Environment to Run Command Line” on page 909
- “Using Command Files” on page 951

---

**Command Line Tool Usage**

This section contains usage information of all of the command line tools and valid syntax descriptions for each.

Topics include:
- “Running cmpl_libs.tcl from the Command Line” on page 912
- “Running HDL Encryption from the Command Line” on page 914
- “Running SYNTHESIS from the Command Line” on page 921
- “Running Postsyn from the Command Line” on page 927
- “Running MAP from the Command Line” on page 928
- “Running PAR from the Command Line” on page 930
- “Running Timing from the Command Line” on page 936
- “Running Backannotation from the Command Line” on page 938
- “Running Bit Generation from the Command Line” on page 941
- “Running Various Utilities from the Command Line” on page 947
- “Using Command Files” on page 951
- “Using Command Line Shell Scripts” on page 953
Running cmpl_libs.tcl from the Command Line

The cmpl_libs.tcl command allows you to perform simulation library compilation from the command line.

The following information is for running cmpl_libs.tcl from the command line using the tclsh application. The supported TCL version is 8.5 or higher.

If you don't have TCL installed, or you have an older version, perform the following:

- Add `<Radiant_install_path>/tcltk/windows/BIN` to the front of your PATH, and
- For Linux users only, add `<Radiant_install_path>/tcltk/linux/bin` to the front of your LD_LIBRARY_PATH

**Note**

The default version of TCL on Linux could be older and may cause the script to fail. Ensure that you have TCL version 8.5 or higher.

To check TCL version, type:

```bash
tclsh
% info tclversion
% exit
```

For script usage, type:

```bash
tclsh cmpl_libs.tcl [-h|-help]
```

**Notes**

- If Modelsim/Questa is already in your PATH and preceding any Aldec tools, you can use: `-sim_path .' for simplification; '.' will be added to the front of your PATH.
- Ensure the FOUNDRY environment variable is set. If the FOUNDRY environment variable is missing, then you need to set it before running the script. For details, refer to “Setting Up the Environment to Run Command Line” on page 96.
- To execute this script error free, Questasim 10.4e or a later 10.4 version, or Questasim 10.5b or a later version should be used for compilation.

Check log files under `<target_path>` (default = .) for any errors, as follows:

- For Linux, type:
  ```bash
grep -i error *.log
  ```
- For Windows, type:
  ```bash
  find /i "error" *.log
  ```
Subjects included in this topic:

- Running compl_lib.tcl
- Command Line Syntax
- cmpl_libs.tcl Options
- Examples

Running compl_lib.tcl  cmpl_libs.tcl allows you to compile simulation libraries from the command line.

Command Line Syntax  tclsh <Radiant_install_path>/cae_library/simulation/scripts/cmpl_libs.tcl -sim_path <sim_path> [-sim_vendor {mentor<default>}] [-device {ice40up|all<default>}] [-target_path <target_path>]

cmpl_libs.tcl Options  The table below contains all valid options for cmpl_libs.tcl

Table 3: cmpl_libs.tcl Command Line Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-sim_path &lt;sim_path&gt;</td>
<td>The -sim_path argument specifies the path to the simulation tool executable (binary) folder. This option is mandatory. Currently only Modelsim and Questa simulators are supported. NOTE: If &lt;sim_path&gt; has spaces, then it must be surrounded by &quot; &quot;. Do not use {}.</td>
</tr>
<tr>
<td>[-sim_vendor {mentor&lt;default&gt;}]</td>
<td>The -sim_vendor argument is optional, and intended for future use. It currently supports only Mentor Graphics simulators (Modelsim / Questa).</td>
</tr>
<tr>
<td>[-device {ice40up</td>
<td>all&lt;default&gt;}]</td>
</tr>
<tr>
<td>[-target_path &lt;target_path&gt;]</td>
<td>The -target_path argument specifies the target path, where you want the compiled libraries and modelsim.ini file to be located. This argument is optional, and the default target path is the current folder. NOTES: (1) This argument is recommended if the current folder is the Radiant software's startup (binary) folder, or if the current folder is write-protected. (2) If &lt;target_path&gt; has spaces, then it must be surrounded by &quot; &quot;. Do not use {}.</td>
</tr>
</tbody>
</table>

Examples  This section illustrates and describes a few examples of Simulation Libraries Compilation Tcl command.

Example 1  The following command will compile all the Lattice FPGA libraries for Verilog simulation, and place them under the folder specified by -target_path. The path to Modelsim is specified by -sim_path.
tclsh c:/lscc/radiant/1.0/>/cae_library/simulation/script/cmpl_libs.tcl -sim_path C:/modeltech64_10.0c/win64 -target_path c:/mti_libs

See Also  ►“Command Line Program Overview” on page 904

Running HDL Encryption from the Command Line
Radiant software allows you to encrypt the individual HDL source files.

The tool supports encryption of Verilog HDL and VHDL files. Per command’s execution, single source file is encrypted.

The HDL file can be partially or fully encrypted depending on pragmas’ placements within the HDL file. To learn more about pragmas’ placements, see “Defining Pragmas” on page 916.

Running HDL Encryption  Before running the utility, you need to annotate the HDL file with the appropriate pragmas. Additionally, you may need to create a key file containing an encryption key. To view the key file’s proper formatting, see “Key File” on page 920.

Command Line Syntax  encrypt_hdl [-k <keyfile>] [-l language] [-o <output_file>] <input_HDL_file>
Encryption Option

The table below contains descriptions of all valid options for HDL encryption.

### Table 4: Encryption Command Line Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-h(elp)</td>
<td>Print command help message.</td>
</tr>
<tr>
<td>-k &lt;keyfile&gt;</td>
<td>A key repository file. Depending on the location of the key, this option is required or optional.</td>
</tr>
<tr>
<td></td>
<td>▶ If the HDL source file contains no pragma, the key file is required. The tool encrypts the entire HDL file using all key sets declared in the key file.</td>
</tr>
<tr>
<td></td>
<td>▶ If the HDL source file contains only <code>begin</code> and <code>end</code> pragmas and no key pragmas, the key file is required. The tool encrypts the section between <code>begin</code> and <code>end</code> using all key sets declared in the key file.</td>
</tr>
<tr>
<td></td>
<td>▶ If the HDL source file contains the proper key pragma, <code>key_keyowner</code>, <code>key_keyname</code>, but the key file is missing the provided <code>key_public_key</code>, the tool fetches the first public key string matching the <code>key_keyowner</code> and <code>key_keyname</code> requirement in the key file.</td>
</tr>
<tr>
<td></td>
<td>If the HDL source file contains the proper definition of key, this option is not required.</td>
</tr>
<tr>
<td></td>
<td>NOTE: If the same key name is defined in both, HDL source file and key.txt file, the key defined in HDL source file has a precedence.</td>
</tr>
<tr>
<td>-l &lt;language&gt;</td>
<td>Directive language, vhdl or verilog (default).</td>
</tr>
<tr>
<td>-o &lt;output_file&gt;</td>
<td>An encrypted HDL file. This is an optional field. If not defined during the encryption, the tool generates a new output file <code>&lt;input_file_name&gt;_enc.v</code>.</td>
</tr>
</tbody>
</table>

### Examples

This section illustrates and describes a few examples of HDL encryption using Tcl command.

**Example1:** This example shows a successful encryption of HDL file with default options. It is assumed that key is properly defined in HDL file. Since output file name was not specified, the tool generates an output file `<file_name>_enc.v` in the same directory as the location of the input file.

```
> encrypt_hdl -k source/impl_1/keys.txt -o top.v top.v
```

Options:
- Key repository file: `source/impl_1/keys.txt`
- Directive language: `<not specified>`, use verilog as default
- Output file: `top.v`

Processed 2 envelopes.

**Example2:** This example shows a successful encryption of HDL file by generating a new output file.

```
> encrypt_hdl -k source/impl_1/keys.txt -o remote_files/top_vl_enc.v remote_files/sources/top_vl_part.
```

Options:
- Key repository file: `source/impl_1/keys.txt`
- Directive language: `<not specified>`, use verilog as default
- Output file: `remote_files/top_vl_enc.v`

Processed 2 envelopes.
**Example3:** This example shows unsuccessful HDL encryption due to a missing key file. To correct this issue, the user must either define the appropriate key file key.txt or annotated the HDL file with appropriate pragmas. To correct the issue, define the key either in key.txt file or directly in HDL source file.

```bash
> encrypt_hdl -o remote_files/sources/top_v1_part_en.v remote_files/sources/top_v1_part.v
Options:
  Key repository file: <not specified>
  Directive language: <not specified>, use verilog as default
  Output file: remote_files/sources/top_v1_part_en.v
ERROR - remote_files/sources/top_v1_part.v at line 88: missing key.
```

**NOTE**
A key is always required in the encryption tool while key file is optional. If the complete key: `key_keyowner, key_keyname, key_method, and key_public_key`, is defined within HDL source file, key file is not required.

For specific steps and information on how to encrypt HDL files in the Radiant software, refer to the following section in the Radiant software online help: [User Guides > Securing the Design](#).

**Defining Pragmas**
Pragmas are used to specify the portion of the HDL source file that must be encrypted. Pragma' definition is compliant with IEEE 1735-2014 V1 standard.

Pragma syntax in Verilog HDL file:

```verilog
`pragma protect <pragma’s option>
```

Pragma syntax in VHDL file:

```vhdl
`protect <pragma’s option>
```

**Table 5: List of available Pragma Options**

<table>
<thead>
<tr>
<th>Name</th>
<th>Available Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>version</td>
<td>1 (default)</td>
<td>Specifies the current Radiant software encryption version.</td>
</tr>
<tr>
<td>author</td>
<td>string</td>
<td>Specifies the file creator.</td>
</tr>
<tr>
<td>author_info</td>
<td>string</td>
<td>Additional information you would like to include in file.</td>
</tr>
<tr>
<td>encoding</td>
<td>base64</td>
<td>The output format of processed data.</td>
</tr>
<tr>
<td>begin</td>
<td></td>
<td>The start point for data obfuscation.</td>
</tr>
<tr>
<td>end</td>
<td></td>
<td>The end point for data obfuscation.</td>
</tr>
<tr>
<td>key_keyowner</td>
<td>string</td>
<td>The key creator.</td>
</tr>
<tr>
<td>key_keyname</td>
<td>string</td>
<td>The RSA key name to specify the private key.</td>
</tr>
<tr>
<td>key_method</td>
<td>rsa</td>
<td>The cryptographic algorithm used for key obfuscation.</td>
</tr>
</tbody>
</table>
To encrypt HDL source file, encryption version, encoding type, and key specific pragmas must be defined in the HDL source file by HDL designer; only the content within the pragmas is encrypted.

**NOTE**

Multiple key sets can be declared in a single key file.

---

### Table 5: List of availablePragma Options

<table>
<thead>
<tr>
<th>Name</th>
<th>Available Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>key_public_key</td>
<td></td>
<td>The RSA public key file name.</td>
</tr>
<tr>
<td>data_method</td>
<td>aes128-cbc</td>
<td>The AES encryption data method.</td>
</tr>
<tr>
<td></td>
<td>aes256-cbc (default)</td>
<td></td>
</tr>
</tbody>
</table>

---

**Example of Verilog source file marked with Pragmas:**

```verilog
// 3-bit counter with asynchronous reset
module count(
    .clk, rst);

input clk, rst;
output [2:0] e;
reg [2:0] e;

    //pragma protect version=1
    //pragma protect author="<Your Name>"
    //pragma protect author_info="<Your info>"
    //pragma protect key_keyword="Lattice Demiconductor"
    //pragma protect key_keyname="LSCC_RADIANT"?
    //pragma protect key_method="rsa"
    //pragma protect key_public_key
    key_public_key The RSA public key file name.

    data_method aes128-cbc aes256-cbc (default) The AES encryption data method.

    // put a blank line above
    //pragma protect data_method="aes256-cbc"
    //pragma protect begin
    always @ (posedge clk or posedge rst)
    begin
        if (rst)
            o = 3'b000;
        else
            o = 0 + 1;
    end
    //pragma protect end

countendmodule
```

The encrypted file may contain multiple encrypted key sets.
Example of encrypted Verilog file:

```
// 3 bit counter with asynchronous reset
module count(c,clk,reset);
   input clk, reset;
   output [2:0] c;
   reg [2:0] c;

   // put a blank line above

   //pragma protect begin Protected
   //pragma protect version=1
   //pragma protect author="<Your Name>"
   //pragma protect author_info="<Your info>"
   //pragma protect encrypt_agent="Radiant encrypt_hdl"
   //pragma protect encrypt_agent_info="Radiant encrypt_hdl Version 1.0"
   //pragma protect encoding=encrypt("base64", line_length=64, bytes=256)
   //pragma protect key_password="Lattice Semiconductor"
   //pragma protect key_password="LATTICE_RADIANT"
   //pragma protect key_method="rs"'

   //pragma protect begin_protected
   //pragma protect key_block
   //pragma protect data_method="aes256-cbc"
   //pragma protect data_encoding=encrypt("base64", line_length=64, bytes=178)
   //pragma protect end_protected

endmodule
```
Example of VHDL source file marked by Pragmas:

```vhdl
library ieee;
use ieee.std_logic_1164.all;
use ieee.std_logic_unsignned.all;
use ieee.std_logic_arith.all;

entity top_test is
  port(
    cvr : out std_logic_vector(7 downto 0);
    reset : in std_logic;
    clk : in std_logic
  );
end top_test;

architecture top_test_arch of top_test is
signal count : std_logic_vector(7 downto 0);
begin
  'protect version=1
  'protect begin
  PROCESS(clk, reset)
  BEGIN
    IF (reset = '1') THEN
      count <= (others => '0');
    ELSE
      IF (clk'event and clk = '1') THEN
        count <= count + 1;
      END IF;
    END IF;
  END PROCESS;
  'protect end

end top_test_arch;
```
Example of encrypted VHDL file:

```vhdl
library ieee;
use ieee.std_logic_1164.all;
use ieee.std_logic_unsigned.all;
use ieee.std_logic_arith.all;

entity top_test is
  port( 
    cost : out std_logic_vector(7 downto 0); 
    reset : in std_logic; 
    clk : in std_logic 
  );
end top_test;

architecture top_test_arch of top_test is

signal count : std_logic_vector(7 downto 0);

begin

  process begin 
    protected 
      process 
          variable key : std_logic_vector(63 downto 0);
          variable iv : std_logic_vector(15 downto 0);
          variable c : std_logic_vector(63 downto 0);
      begin 
          key := "SECRET_KEY";
          iv := "IV";
          c := encrypt_key(key, iv);
          count <= encrypt(c);
        end process;
    end process;

  end protected;

end top_test_arch;
```

See Also

- "Running HDL Encryption from the Command Line" on page 914
- "Key File" on page 920

Key File

The key repository file defines the cryptographic public key used for RSA encryption. In Radiant software, the key file contains Lattice public key. Additionally, it may contain some of the common EDA vendors public keys.
The Lattice public key file key.txt is located at `<Radiant_installed_directory>/ispfpga/data/` folder. Aside of Lattice public key, the current version contains the public key for Synopsys, Aldec, and Cadence.

**NOTE**

If using Synplify Pro synthesis tool, both, the Lattice Public Key and the Synplify Pro Public Key must be defined in the key file. The Synplify Pro Public Key is used during the synthesis step to decrypt an encrypted design. The Lattice Public Key is used during the post-synthesis flow to decrypt an encrypted design.

A key file must contain properly declared pragmas such as `key_keyowner`, `key_keyname`, `key_method`, and `key_public_key` for each of the specified keys. The key value follows the `key_public_key` pragma.

The key file typically also contains the `data_method` pragma. It defines the algorithm used in data block encryption of HDL source file.

**Example of a Key File:**

```plaintext
// Use Verilog pragma syntax in this file
'pragma protect version=1
'pragma protect author="<Your Name>"
'pragma protect author_info="<Your info>"
'pragma protect key_keyowner="Lattice Semiconductor"
'pragma protect key_keyname="LOG_RADIANT_1"
'pragma protect key_method=rsa
'pragma protect key_public_key
MIJBjNREqcksl6QSEF2rDKGAQANMIIBgkGAsEQAw8gbw7Kub68e70bQfI3N
1MJ255R5umv9n/0lp/64T11aL1s9h0Y201M1dab-ndTmExRzSbrxeDunS6S
xR2519E1Q0boU1f2E57AMVwM96007105F0L2V1H3mJzHgCowEnE5Rza2Es
ia2R7=sgy7y/k9F5eVX6mQ25X7eqp649X600c2111yQ5ahm240bL0c1c
td004dkfz8hS500C6+zcirz33jyZqg8M866C7a55N4y8inC0c1y/0y76
edt904aq204jEehbq259plz57rD+04429shL2Dq01/254y144cfnf2DnznqK3vE7
1wVQAgB

// Put a blank line above
// Add additional public keys below this line

'pragma protect data_method="aes256-cbc"

// End of File
```

See Also

- “Running HDL Encryption from the Command Line” on page 914
- “Defining Pragmas” on page 916

**Running SYNTHESIS from the Command Line**

The Lattice synthesis tool SYNTHESIS allows you to synthesize Verilog and VHDL HDL source files into netlists for design entry into the Radiant software environment. Based on your strategy settings you specify in the Radiant software, a synthesis project (.synproj) file is created and then used by SYNTHESIS using the `-f` option. The Radiant software translates strategy options into command line options described in this topic.

Verilog source files are passed to the program using the `-ver` option and VHDL source files are passed using the `-vhd` option. For mixed language
designs the language type is automatically determined by SYNTHESIS based on the top module of the design. For IP design, you must also specify IP location (-ip_dir), IP core name (-corename), and encrypted RTL file name (-ertl_file).

Subjects included in this topic:

- Running SYNTHESIS
- Command Line Syntax
- SYNTHESIS Options
- Examples

Running SYNTHESIS  SYNTHESIS will convert your input netlist (.v) file into a structural Verilog file that is used for the remaining mapping process.

- To run SYNTHESIS, type synthesis on the command line with valid options. A sample of a typical SYNTHESIS command would be as follows:

There are many command line options that give you control over the way SYNTHESIS processes the output file. Please refer to the rest of the subjects in this topic for more details. See examples.


Lattice Radiant Software 2.2 Help 922
SYNTHESIS Options  The table below contains descriptions of all valid options for SYNTHESIS.

Table 6: SYNTHESIS Command Line Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-a &lt;arch&gt;</td>
<td>Sets the FPGA architecture. This synthesis option must be specified and if the value is set to any unsupported FPGA device architecture the command will fail.</td>
</tr>
<tr>
<td>-p &lt;device&gt;</td>
<td>Specifies the device type for the architecture (optional).</td>
</tr>
<tr>
<td>-f &lt;proj_file_name&gt;</td>
<td>Specifies the synthesis project file name (.synproj). The project file can be edited by the user to contain all desired command line options.</td>
</tr>
<tr>
<td>-t &lt;package_name&gt;</td>
<td>Specifies the package type of the device.</td>
</tr>
<tr>
<td>-path &lt;searchpath&gt;</td>
<td>Add searchpath for Verilog &quot;include&quot; files (optional).</td>
</tr>
<tr>
<td>-top &lt;top_module_name&gt;</td>
<td>Name of top module (optional, but better to have to avoid ambiguity).</td>
</tr>
<tr>
<td>-lib &lt;lib_name&gt;</td>
<td>Name of VHDL library (optional).</td>
</tr>
<tr>
<td>-vhd &lt;vhdl_file.vhd/vhdl&gt;</td>
<td>Names of VHDL design files (must have, if language is VHDL or mixed language).</td>
</tr>
<tr>
<td>-ver &lt;verilog_file.v&gt;</td>
<td>Names of Verilog design files (must have, if language is Verilog, or mixed language).</td>
</tr>
<tr>
<td>-hdl_param &lt;name, value&gt;</td>
<td>Allows you to override HDL parameter pairs in the design file.</td>
</tr>
<tr>
<td>-optimization_goal &lt;balanced (default)</td>
<td>area</td>
</tr>
<tr>
<td></td>
<td>balanced balances the levels of logic.</td>
</tr>
<tr>
<td></td>
<td>area optimizes the design for area by reducing the total amount of logic used for design implementation.</td>
</tr>
<tr>
<td></td>
<td>timing optimizes the design for timing.</td>
</tr>
<tr>
<td></td>
<td>The default setting depends on the device type. Smaller devices, such as ice40tp default to balanced.</td>
</tr>
<tr>
<td>-force_gsr &lt;auto</td>
<td>yes</td>
</tr>
</tbody>
</table>
-ramstyle <auto (default) | distributed | block_ram(EBR) | registers>

Sets the type of random access memory globally to distributed, embedded block RAM, or registers. The default is auto which attempts to determine the best implementation, that is, synthesis tool will map to technology RAM resources (EBR/Distributed) based on the resource availability.

This option will apply a syn_ramstyle attribute globally in the source to a module or to a RAM instance. To turn off RAM inference, set its value to registers.

- **registers** causes an inferred RAM to be mapped to registers (flip-flops and logic) rather than the technology-specific RAM resources.

- **distributed** causes the RAM to be implemented using the distributed RAM or PFU resources.

- **block_ram (EBR)** causes the RAM to be implemented using the dedicated RAM resources. If your RAM resources are limited, for whatever reason, you can map additional RAMs to registers instead of the dedicated or distributed RAM resources using this attribute.

- **no_rw_check** (Certain technologies only). You cannot specify this value alone. Without no_rw_check, the synthesis tool inserts bypass logic around the RAM to prevent the mismatch. If you know your design does not read and write to the same address simultaneously, use no_rw_check to eliminate bypass logic. Use this value only when you cannot simultaneously read and write to the same RAM location and you want to minimize overhead logic.
Table 6: SYNTHESIS Command Line Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-romstyle &lt;auto (default)</td>
<td>Allows you to globally implement ROM architectures using dedicated, distributed ROM, or a combination of the two (auto). This applies the syn_romstyle attribute globally to the design by adding the attribute to the module or entity. You can also specify this attribute on a single module or ROM instance. Specifying a syn_romstyle attribute globally or on a module or ROM instance with a value of:</td>
</tr>
<tr>
<td></td>
<td>▶ <strong>auto</strong> allows the synthesis tool to choose the best implementation to meet the design requirements for performance, size, etc.</td>
</tr>
<tr>
<td></td>
<td>▶ <strong>EBR</strong> causes the ROM to be mapped to dedicated EBR block resources. ROM address or data should be registered to map it to an EBR block. If your ROM resources are limited, for whatever reason, you can map additional ROM to registers instead of the dedicated or distributed RAM resources using this attribute.</td>
</tr>
<tr>
<td></td>
<td>Infer ROM architectures using a CASE statement in your code. For the synthesis tool to implement a ROM, at least half of the available addresses in the CASE statement must be assigned a value. For example, consider a ROM with six address bits (64 unique addresses). The case statement for this ROM must specify values for at least 32 of the available addresses.</td>
</tr>
<tr>
<td>-output_hdl &lt;filename.v&gt;</td>
<td>Specifies the name of the output Verilog netlist file.</td>
</tr>
<tr>
<td>-sdc &lt;sdc_file.ldc&gt;</td>
<td>Specifies a Lattice design constraint (.ldc) file input.</td>
</tr>
<tr>
<td>-loop_limit</td>
<td>Specifies the iteration limits for “for” and “while” loops in the user RTL for loops that have the loop index as a variable and not a constant. The higher the loop_limit, the longer the run time. Also, for some designs, a higher loop limit may cause stack overflow during some of the optimizations during compile/synthesis. The default value is 1950. Setting a higher value may cause stack overflow during some of the optimizations during synthesis.</td>
</tr>
<tr>
<td></td>
<td>&lt;max_loop_iter_cnt (default 1950)&gt;</td>
</tr>
<tr>
<td>-logfile</td>
<td>Specifies the name of the synthesis log file in ASCII format. If you do not specify a name, SYNTHESIS will output a file named synthesis.log by default.</td>
</tr>
<tr>
<td></td>
<td>&lt;synthesis_logfile&gt;</td>
</tr>
<tr>
<td>-frequency</td>
<td>Specifies the target frequency setting. Default frequency value is 200.0 MHz.</td>
</tr>
<tr>
<td></td>
<td>&lt;target_frequency (default 200.0MHz (ICE40))&gt;</td>
</tr>
<tr>
<td>-max_fanout &lt;value&gt;</td>
<td>Specifies maximum global fanout limit to the entire design at the top level. Default value is 1000 fanouts.</td>
</tr>
<tr>
<td>-bram_utilization</td>
<td>Specifies block RAM utilization target setting in percent of total vacant sites. Default is 100 percent.</td>
</tr>
<tr>
<td></td>
<td>&lt;value&gt;</td>
</tr>
</tbody>
</table>
### Table 6: SYNTHESIS Command Line Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>-fsm_encoding_style</code></td>
<td>Specifies One-Hot, Gray, or Binary style. The <code>-fsm_encoding_style</code> allows the user to determine which style is faster based on specific design implementation. Valid options are <code>auto</code>, <code>one-hot</code>, <code>gray</code>, and <code>binary</code>. The default value is <code>auto</code>, meaning that the tool looks for the best implementation.</td>
</tr>
<tr>
<td>`-use_carry_chain &lt;0</td>
<td>1&gt;`</td>
</tr>
<tr>
<td><code>-carry_chain_length &lt;chain_length&gt;</code></td>
<td>Specifies the maximum length of the carry chain.</td>
</tr>
<tr>
<td>`-use_io_insertion &lt;0</td>
<td>1&gt;`</td>
</tr>
</tbody>
</table>
| `-use_io_reg <0|1|auto(default)>`        | Packs registers into I/O pad cells based on timing requirements for the target Lattice families. The value 1 enables and 0 disables (default) register packing. This applies it globally forcing the synthesis tool to pack all input, output, and I/O registers into I/O pad cells. NOTE: You can place the syn_useioff attribute on an individual register or port. When applied to a register, the synthesis tool packs the register into the pad cell, and when applied to a port, packs all registers attached to the port into the pad cell. The syn_useioff attribute can be set on a:  
  - top-level port  
  - register driving the top-level port  
  - lower-level port, only if the register is specified as part of the port declaration |
| `-resource_sharing <0|1>`                       | Specifies the resource sharing option. The 1 or true setting is the default.                                                                                                                                |
| `-propagate_constants <0|1>`                      | Prevents sequential optimization such as constant propagation, inverter push-through, and FSM extraction. The 1 or true setting is the default.                                                               |
| `-remove_duplicate_regs <0|1>`                    | Specifies the removal of duplicate registers. The 1 or true setting is the default.                                                                                                                        |
| `-twr_paths <timing_path_cnt>` | Specifies the number of critical paths.                                                                                                                                                                     |
| `-dt`                         | Disables the hardware evaluation capability.                                                                                                                                                                |
| `-udb <udb_file.udb>`         | Sets option to dump intermediate files. If you run the tool with this option, it will dump about 20 intermediate encrypted Verilog files. If you supply Lattice with these files, they can be decrypted and analyzed for problems. This option is good to for analyzing simulation issues. |
Examples  Following are a few examples of SYNTHESIS command lines and a description of what each does.

```
synthesis -a "ice40tp" -p itpa08 -t SG48 -sp "6" -mux_style Auto
-use_io_insertion 1
-sdc "C:/my_radiant_tutorial/impl1/impl1.ldc"
-path "C:/lscc/radiant/1.0/ispfpga/ice40tp/data" "C:/my_radiant_tutorial/impl1"
-ver "C:/my_radiant_tutorial/impl1/source/LED_control.v"
"C:/my_radiant_tutorial/impl1/source/spi_gpio.v"
"C:/my_radiant_tutorial/impl1/source/spi_gui_led_top.v"
-path "C:/my_radiant_tutorial"
-top spi_gui_led_top
-output_hdl "LEDtest_impl1.vm"
```

See Also  ➤ “Command Line Program Overview” on page 904

Running Postsyn from the Command Line

The Postsyn process converts synthesized VM and integrates IPs into a completed design in UDB format for the remaining mapping process.


<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-fix_gated_clocks</td>
<td>Allows you to enable/disable gated clock optimization. By default, the option is enabled.</td>
</tr>
<tr>
<td>-vh2008</td>
<td>Enables VHDL 2008 support.</td>
</tr>
</tbody>
</table>
Running MAP from the Command Line

The Map Design process in the Radiant software environment can also be run through the command line using the map program. The map program takes an input database (.udb) file and converts this design represented as a network of device-independent components (e.g., gates and flip-flops) into a network of device-specific components (e.g., PFUs, PFFs, and EBRs) or configurable logic blocks in the form of a Unified Database (.udb) file.

Subjects included in this topic:

- Running MAP
- Command Line Syntax
- MAP Options
- Examples

Running MAP MAP uses the database (.udb) file that was the output of the Synthesis process and outputs a mapped Unified Database (.udb) file with constraints embedded.
To run MAP, type `map` on the command line with, at minimum, the required options to describe your target technology (i.e., architecture, device, package, and performance grade), the input .udb along with the input .ldc file. The output .udb file specified by the `-o` option. That additional physical constraint file (*.pdc) can be applied optionally. A sample of a typical MAP command would be as follows:

```
map counter_impl1_syn.udb impl1.pdc -o counter_impl1.udb
```

**Note**

The `-a` (architecture) option is not necessary when you supply the part number with the `-p` option. There is also no need to specify the constraint file here, but if you do, it must be specified after the input .udb file name. The constraint file automatically takes the name “output” in this case, which is the name given to the output .udb file. If the output file was not specified with the `-o` option as shown in the above case, `map` would place a file named input.udb into the current working directory, taking the name of the input file. If you specify the input.ldc file and it is not there, `map` will error out.

Table 8: MAP Command Line Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>-h &lt;arch&gt;</code></td>
<td>Displays all of the available MAP command options for mapping to the specified architecture.</td>
</tr>
<tr>
<td><code>&lt;infile.udb&gt;</code></td>
<td>Specifies the output design file name in .udb format. The .udb extension is optional.</td>
</tr>
<tr>
<td><code>-inferGSR</code></td>
<td>GSR inferencing if applicable.</td>
</tr>
<tr>
<td><code>-o &lt;name.udb&gt;</code></td>
<td>Optional output design file .udb.</td>
</tr>
<tr>
<td><code>-mp &lt;name.mrp&gt;</code></td>
<td>Optional report file (.mrp).</td>
</tr>
<tr>
<td><code>-xref_sig</code></td>
<td>Report signal cross reference for renamed signals.</td>
</tr>
<tr>
<td><code>-xref_sym</code></td>
<td>Report symbol cross reference for renamed symbols.</td>
</tr>
<tr>
<td><code>-u</code></td>
<td>Unclip unused instances.</td>
</tr>
</tbody>
</table>

**Examples** Following are some examples of MAP command lines and a description of what each does.

**Example 1** The following command maps an input database file named mapped.udb and outputs a mapped Unified Database file named mapped.udb.
map counter_impl1_syn.udb impl1.pdc -o counter_impl1.udb

See Also
► “Command Line Data Flow” on page 906
► “Command Line Program Overview” on page 904

Running PAR from the Command Line

The Place & Route Design process in the Radiant software environment can also be run through the command line using the par program. The par program takes an input mapped Unified Database (.udb) file and further places and routes the design, assigning locations of physical components on the device and adding the inter-connectivity, outputting a placed and routed .udb file.

The Implementation Engine multi-tasking option available in Linux is explained in detail here because the option is not available for PCs.

Subjects included in this topic:
► Running PAR
► Command Line Syntax
► General Options
► Placement Options
► Routing Options
► PAR Explorer (-exp) Options
► Examples
► PAR Multi-Tasking Options

Running PAR

PAR uses your mapped Unified Database (.udb) file that were the outputs of the Map Design process or the map program. With these inputs, par outputs a new placed-and-routed .udb file, a PAR report (.par) file, and a PAD (specification (.pad) file that contains I/O placement information.

To run PAR, type par on the command line with at minimum, the name of the input .udb file and the desired name of the output .udb file. Design constraints from previous stages are automatically embedded in the input .udb file, however the par program can accept additional constraints with either a .pdc or .sdc file. A sample of a basic PAR command would be as follows:

par input.udb output.udb

There are many command line options that give you control over PAR. Please refer to the rest of the subjects in this topic for more details.

Command Line Syntax

```
par [-w] [-n <iterations:0,100>] [-t <iteration:0,100>] [-stopzero] [-s <savecount:0,100>] [-m <nodelistfile>] [-cores <number of cores>] [-r] [-k] [-p] [-x] [-pack <density:0,100>] [-sp
```

Note
All filenames without special switches must be in the order <infile> <outfile> <pdcfile>. Options may exist in any order.

General Options

Table 9: General PAR Command Line Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-f</td>
<td>Read par command line arguments and switches from file.</td>
</tr>
<tr>
<td>-w</td>
<td>Overwrite. Allows overwrite of an existing file (including input file).</td>
</tr>
<tr>
<td>-n</td>
<td>Number of iterations (seeds). Use &quot;-n 0&quot; to run until fully routed and a timing score of zero is achieved. Default: 1.</td>
</tr>
<tr>
<td>-t</td>
<td>Start at this placer cost table entry. Default is 1.</td>
</tr>
<tr>
<td>-stopzero</td>
<td>Stop running iterations once a timing score of zero is achieved.</td>
</tr>
<tr>
<td>-s</td>
<td>Save &quot;n&quot; best results for this run. Default: Save All.</td>
</tr>
<tr>
<td>-m</td>
<td>Multi task par run. File &quot;&lt;node list file&gt;&quot;, contains a list of node names to run the jobs on.</td>
</tr>
<tr>
<td>-cores</td>
<td>Run multiple threads on the local machine. You can specify &quot;&lt;number of cores&gt;&quot; to run the jobs. For cases when the user specifies both -cores and -m with a valid node list file, PAR should apply both settings (merge). If the user repeats the host machine in the node list file, the settings in the node list file take precedence over the setting in -cores (for backwards compatibility).</td>
</tr>
<tr>
<td>-p</td>
<td>Don't run placement.</td>
</tr>
<tr>
<td>-r</td>
<td>Don't run router.</td>
</tr>
<tr>
<td>-k</td>
<td>Keep existing routing in input UDB file. Note: only meaningful when used with -p.</td>
</tr>
<tr>
<td>-x</td>
<td>Ignore timing constraints.</td>
</tr>
<tr>
<td>-pack</td>
<td>Set the packing density parameter. Default: auto.</td>
</tr>
</tbody>
</table>
Examples

Following are a few examples of PAR command lines and a description of what each does.

Example 1

The following command places and routes the design in the file input.udb and writes the placed and routed design to output.udb.

```
par input.udb output.udb
```

Example 2

The following command runs 20 place and route iterations. The iterations begin at cost table entry 5. Only the best 3 output design files are saved.

```
par -n 20 -t 5 -s 3 input.udb output.udb
```

Example 3 (Lattice FPGAs only)

This is an example of par using the -io switch to generate .udb files that contain only I/O for viewing in the PAD Specification file for adjustment of ldcc_set_location constraints for optimal I/O placement. You can display I/O placement assignments in the Radiant Spreadsheet View and choosing View > Display IO Placement.

```
par -io -w lev1bist.udb lev1bist_io.udb
```
Using the PAR Multi-Tasking (-m) Option  This section provides information about environment setup, node list file creation, and step-by-step instructions for running the PAR Multi-tasking (-m) option from the command line. The PAR -m option allows you to use multiple machines (nodes) that are networked together for a multi-run PAR job, significantly reducing the total amount of time for completion. Before the multi-tasking option was developed, PAR could only run multiple jobs in a linear or serial fashion. The total time required to complete PAR was equal to the amount of time it took for each of the PAR jobs to run.

For example, the PAR command:

```
par -n 10 mydesign.udb output.udb
```

tells PAR to run 10 place and route passes (-n 10). It runs each of the 10 jobs consecutively, generating an output .udb file for each job, i.e., `output_par.dir/5_1.udb`, `output_par.dir/5_2.udb`, etc. If each job takes approximately one hour, then the run takes approximately 10 hours.

Suppose, however, that you have five nodes available. The PAR Multi-tasking option allows you to use all five nodes at the same time, dramatically reducing the time required for all ten jobs.

To run the PAR multi-tasking option from the command line:

1. First generate a file containing a list of the node names, one per line as in the following example:

```
# This file contains a profile node listing for a PAR multi
# tasking job.
[machine1]
SYSTEM = linux
CORENUM = 2
[machine2]
SYSTEM = linux
CORENUM = 2
Env = /home/user/setup_multipar.lin
Workdir = /home/user/myworkdir
```

You must use the format above for the node list file and fill in all required parameters. Parameters are case insensitive. The node or machine names are given in square brackets on a single line.

The **System** parameter can take linux or pc values depending upon your platform. However, the PC value cannot be used with Linux because it is not possible to create a multiple computer farm with PCs. **Corenum** refers to the number of CPU cores available. Setting it to zero will disable the node from being used. Setting it to a greater number than the actual number of CPUs will cause PAR to run jobs on the same CPU lengthening the runtime.

The **Env** parameter refers to a remote environment setup file to be executed before PAR is started on the remote machine. This is optional. If the remote machine is already configured with the proper environment, this line can be omitted. To test to see if the remote environment is responsive to PAR commands, run the following:
**Command Line Tool Usage**

```bash
ssh <remote_machine> par <par_option>
```

See the [System Requirements](#) section below for details on this parameter.

**Workdir** is the absolute path to the physical working directory location on the remote machine where PAR should be run. This item is also optional. If an account automatically changes to the proper directory after login, this line can be omitted. To test the remote directory, run the following,

```bash
ssh <remote_machine> ls <udb_file>
```

If the design can be found then the current directory is already available.

2. Now run the job from the command line as follows:

```bash
par -m nodefile_name -n 10 mydesign.udb output.udb
```

This runs the following jobs on the nodes specified.

- Starting job 5_1 on node NODE1 at ...
- Starting job 5_2 on node NODE2 at ...
- Starting job 5_3 on node NODE3 at ...
- Starting job 5_4 on node NODE4 at ...
- Starting job 5_5 on node NODE5 at ...

As the jobs finish, the remaining jobs start on the nodes until all 10 jobs are complete. Since each job takes approximately one hour, all 10 jobs will complete in approximately two hours.

**Note**

If you attempt to use the multi-tasking option and you have specified only one placement iteration, PAR will disregard the `-m` option from the command and run the job in normal PAR mode. In this case you will see the following message:

```
WARNING - par: Multi task par not needed for this job. -m switch will be ignored.
```

**System Requirements**  
`ssh` must be located through the PATH variable. On Linux, the utility program’s secure shell (`ssh`) and secure shell daemon (`sshd`) are used to spawn and listen for the job requests.

The executables required on the machines defined in the node list file are as follows:

- `/bin/sh`
- `par` (must be located through the PATH variable)

Required environment variable on local and remote machines are as follows:

- `FOUNDORY` (points at FOUNDRY directory structure must be a path accessible to both the machine from which the Implementation Engine is run and the node)
- `LM_LICENSE_FILE` (points to the security license server nodes)
- `LD_LIBRARY_PATH` (supports par path for shared libraries must be a path accessible to both the machine from which the Implementation Engine is run and the node)
To determine if everything is set up correctly, you can run the `ssh` command to the nodes to be used.

Type the following:

```bash
ssh <machine_name> /bin/sh -c par
```

If you get the usage message back on your screen, everything is set correctly. Note that depending upon your setup, this check may not work even though your status is fine.

If you have to set up your remote environment with the proper environment variables, you must create a remote shell environment setup file. An example of an ASCII file used to setup the remote shell environment would be as follows for ksh users:

```bash
export FOUNDRY=<install_directory>/ispfpga/bin/lin64
export PATH=$FOUNDRY/bin/lin64:$PATH
export LD_LIBRARY_PATH=$FOUNDRY/bin/lin:$LD_LIBRARY_PATH
```

For csh users, you would use the `setenv` command.

**Screen Output**  When PAR is running multiple jobs and is not in multi-tasking mode, output from PAR is displayed on the screen as the jobs run. When PAR is running multiple jobs in multi-tasking mode, you only see information regarding the current status of the feature.

For example, when the job above is executed, the following screen output would be generated:

```
Starting job 5_1 on node NODE1
Starting job 5_2 on node NODE2
Starting job 5_3 on node NODE3
Starting job 5_4 on node NODE4
Starting job 5_5 on node NODE5
```

When one of the jobs finishes, this message will appear:

```
Finished job 5_3 on node NODE3
```

These messages continue until there are no jobs left to run.

**See Also**  
► “Implementing the Design” in the Radiant software online help
► “Command Line Data Flow” on page 906
► “Command Line Program Overview” on page 904
Running Timing from the Command Line

The MAP Timing and Place & Route Timing processes in the Radiant software environment can also be run through the command line using the timing program. Timing can be run on designs using the placed and routed Unified Design Database (.udb) and associated timing constraints specified in the design's (.ldc,.fdc,.sdc or .pdc) file or device constraints extracted from the design. Using these input files, timing provides static timing analysis and outputs a timing report file (.tw1/.twr).

Timing checks the delays in the Unified Design Database (.udb) file against your timing constraints. If delays are exceeded, Timing issues the appropriate timing error. See “Implementing the Design” in the Radiant software online help and associated topics for more information.

Subjects included in this topic:

- Running Timing
- Command Line Syntax
- Timing Options
- Examples

Running Timing Timing uses your input mapped or placed-and-routed Unified Design Database (.udb) file and associated constraint file to create a Timing Report.

To run Timing, type timing on the command line with, at minimum, the names of your input .udb and sdc files to output a timing report (.twr) file. A sample of a typical Timing command would be as follows:

```
timing design.udb (constraint is embedded in udb)
```

Note

The above command automatically generates the report file named design.twr which is based on the name of the .udb file.

There are several command line options that give you control over the way Timing generates timing reports for analysis. Please refer to the rest of the subjects in this topic for more details. See “Examples” on page 106.

**Timing Options**  The following tables contain descriptions of all valid options for Timing.

**Table 11: Compulsory Timing Command Line Options**

<table>
<thead>
<tr>
<th>Compulsory Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-db-file arg</td>
<td>design database file name.</td>
</tr>
</tbody>
</table>

**Table 12: Optional Timing Command Line Options**

<table>
<thead>
<tr>
<th>Optional Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-endpoints arg (=10)</td>
<td>number of end points.</td>
</tr>
<tr>
<td>-u arg (=10)</td>
<td>number of unconstrained end points printed in the table.</td>
</tr>
<tr>
<td>-ports arg (=10)</td>
<td>number of top ports printed in the table.</td>
</tr>
<tr>
<td>-help</td>
<td>print the usage and exit.</td>
</tr>
<tr>
<td>-hld</td>
<td>hold report only.</td>
</tr>
<tr>
<td>-sp arg (=None)</td>
<td>Setup speed grade.</td>
</tr>
<tr>
<td>-hsp arg (=M)</td>
<td>Hold speed grade.</td>
</tr>
<tr>
<td>-rpt-file arg</td>
<td>timing report file name.</td>
</tr>
<tr>
<td>-o arg</td>
<td>timing report file name.</td>
</tr>
<tr>
<td>-alt_report</td>
<td>Diamond like report.</td>
</tr>
<tr>
<td>-sdc-file arg</td>
<td>sdc file name.</td>
</tr>
<tr>
<td>-sethld</td>
<td>both setup and hold report.</td>
</tr>
<tr>
<td>-v arg (=10)</td>
<td>number of paths per constraint.</td>
</tr>
<tr>
<td>-time_through_async</td>
<td>Timer will time through async resets.</td>
</tr>
<tr>
<td>-iotime</td>
<td>compute the input setup/hold and clock to output delays of the FPGA.</td>
</tr>
<tr>
<td>-io_allspeed</td>
<td>Get worst IO results for all speed grades.</td>
</tr>
<tr>
<td>-pwrprd</td>
<td>Output clock information for PowerCalculator.</td>
</tr>
<tr>
<td>-nperend arg (=1)</td>
<td>Number of paths per end point.</td>
</tr>
<tr>
<td>-html</td>
<td>HTML format report.</td>
</tr>
<tr>
<td>-gui</td>
<td>Call from GUI.</td>
</tr>
<tr>
<td>-msg arg</td>
<td>Message log file.</td>
</tr>
<tr>
<td>-msgset arg</td>
<td>Message setting.</td>
</tr>
</tbody>
</table>

**Examples**  Following are a few examples of Timing command lines and a description of what each does.
Example 1  The following command verifies the timing characteristics of the design named design1.udb, generating a summary timing report. Timing constraints contained in the file group1.prf are the timing constraints for the design. This generates the report file design1.twr.

timing design1.udb (constraint is embedded in udb)

Example 2  The following command produces a file listing all delay characteristics for the design named design1.udb. Timing constraints contained in the file group1.prf are the timing constraints for the design. The file output.twr is the name of the verbose report file.

timing -v design1.udb -o output.twr

Example 3  The following command analyzes the file design1.udb and reports on the three worst errors for each constraint in timing.prf. The report is called design1.twr.

timing -e 3 design1.udb

Example 4  The following command analyzes the file design1.udb and produces a verbose report to check on hold times on any FREQUENCY, CLOCK_TO_OUT, INPUT_SETUP and OFFSET constraints in the timing.prf file. With the output report file name unspecified here, a file using the root name of the .udb file (i.e., design1.twr) will be output by default.

timing -v -hld design1.udb

Example 5  The following command analyzes the file design1.udb and produces a summary timing report to check on both setup and hold times on any INPUT_SETUP and CLOCK_TO_OUT timing constraints in the timing.prf file. With the output report file name unspecified here, a file using the root name of the .udb file (i.e., design1.twr) will be output by default.

timing -sethld design1.udb

See Also  ► “Command Line Program Overview” on page 904
► “Command Line Data Flow” on page 906

Running Backannotation from the Command Line

The Generate Timing Simulation Files process in the Radiant software environment can also be run through the command line using the backanno program. The backanno program back-annotates physical information (e.g., net delays) to the logical design and then writes out the back-annotated design in the desired netlist format. Input to backanno is a Unified Database file (.udb) a mapped and partially or fully placed and/or routed design.

Subjects included in this topic:
Running Backanno  backanno uses your input mapped and at least partially placed-and-routed Unified Database (.udb) file to produce a back-annotated netlist (.v) and standard delay (.sdf) file. This tool supports all FPGA design architecture flows. Only Verilog netlist is generated.

To run backanno, type `backanno` on the command line with, at minimum, the name of your input .udb file. A sample of a typical backanno command would be as follows:

```
backanno backanno.udb
```

There are several command line options that give you control over the way backanno generates back-annotated netlists for simulation. Please refer to the rest of the subjects in this topic for more details.

Command Line Syntax (Verilog)  
```
```

Backanno Options  The table below contains descriptions of all valid options for backanno.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-w</td>
<td>Overwrite the output files.</td>
</tr>
<tr>
<td>-sp &lt;grade&gt;</td>
<td>Override performance grade for backannotation.</td>
</tr>
<tr>
<td>-pre &lt;prfx&gt;</td>
<td>Prefix to add to module name to make them unique for multi-chip simulation.</td>
</tr>
<tr>
<td>-min</td>
<td>Override performance grade to minimum timing for hold check.</td>
</tr>
<tr>
<td>-dis &lt;del&gt;</td>
<td>Distribute routing delays by splitting the signal and inserting buffers. &lt;del&gt; is the maximum delay (in ps) between each buffer (1000ps by default).</td>
</tr>
<tr>
<td>-m &lt;limit&gt;</td>
<td>Shortens the block names to a given character limit in terms of some numerical integer value.</td>
</tr>
</tbody>
</table>
Examples Following are a few examples of backanno command lines and a description of what each does.

Example 1 The following command back annotates design.udb and generates a Verilog file design.vo and an SDF file design.sdf. If the target files exist, they will be overwritten.

backanno -w design.udb

Example 2 The following command back annotates design.udb and generates a Verilog file backanno.vo and an SDF file backanno.sdf. Any signal in the design that has an interconnection delay greater than 2000 ps (2 ns) will be split and a series of buffers will be inserted. The maximum interconnection delay between each buffer would be 2000 ps.

backanno -dis 2000 -o backanno design.udb

Example 3 The following command re-targets backannotation to performcuxmance grade -2, and puts a buffer at each block input to isolate the interconnection delay (ends at that input) and the pin to pin delay (starts from that input).

backanno -sp 2 -i design.udb

Example 4 The following command generates Verilog netlist and SDF files without setting the negative setup/hold delays to 0:

-Add pads for top-level dangling nets.
-Add pads for top-level dangling nets.
-Negative setup/hold delay support. Without this option, all negative numbers are set to 0 in SDF.
-Negative setup/hold delay support. Without this option, all negative numbers are set to 0 in SDF.
-Write out 0 for negative setup/hold time in SDF for SC.
-Write out 0 for negative setup/hold time in SDF for SC.
-Generate x for setup/hold timing violation.
-Generate x for setup/hold timing violation.
-Create a buffer for each block input that has interconnection delay.
-Create a buffer for each block input that has interconnection delay.
-Do not write PUR instance in the backannotation netlist. Instead, user has to instantiate it in a test bench.
-Do not write PUR instance in the backannotation netlist. Instead, user has to instantiate it in a test bench.
-Netlist type to write out.
-Netlist type to write out.
-Library element type to use.
-Library element type to use.
-The name of the output netlist file. The extension on this file will change depending on which type of netlist is being written. Use -h <type>, where <type> is the output netlist type, for more specific information.
The name of the output netlist file. The extension on this file will change depending on which type of netlist is being written. Use -h <type>, where <type> is the output netlist type, for more specific information.
-Input file '.udb '.
-Input file '.udb '.

Table 13: Backanno Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-u</td>
<td>Add pads for top-level dangling nets.</td>
</tr>
<tr>
<td>-neg</td>
<td>Negative setup/hold delay support. Without this option, all negative numbers are set to 0 in SDF.</td>
</tr>
<tr>
<td>-pos</td>
<td>Write out 0 for negative setup/hold time in SDF for SC.</td>
</tr>
<tr>
<td>-x</td>
<td>Generate x for setup/hold timing violation.</td>
</tr>
<tr>
<td>-i</td>
<td>Create a buffer for each block input that has interconnection delay.</td>
</tr>
<tr>
<td>-nopur</td>
<td>Do not write PUR instance in the backannotation netlist. Instead, user has to instantiate it in a test bench.</td>
</tr>
<tr>
<td>&lt;type&gt;</td>
<td>Netlist type to write out.</td>
</tr>
<tr>
<td>&lt;libtype&gt;</td>
<td>Library element type to use.</td>
</tr>
<tr>
<td>&lt;netfile&gt;</td>
<td>The name of the output netlist file. The extension on this file will change depending on which type of netlist is being written. Use -h &lt;type&gt;, where &lt;type&gt; is the output netlist type, for more specific information.</td>
</tr>
<tr>
<td>&lt;udb file&gt;</td>
<td>Input file '.udb '.</td>
</tr>
</tbody>
</table>
backanno -neg -n verilog design.udb

See Also
► “Command Line Program Overview” on page 904
► “Command Line Data Flow” on page 906

Running Bit Generation from the Command Line

The Bitstream process in the Radiant software environment can also be run through the command line using the bit generation (bitgen) program. This topic provides syntax and option descriptions for usage of the bitgen program from the command line. The bitgen program takes a fully routed Unified Database (.udb) file as input and produces a configuration bitstream (bit images) needed for programming the target device.

Subjects included in this topic:
► Running BITGEN
► Command Line Syntax
► BITGEN Options
► Examples

Running BITGEN BITGEN uses your input, fully placed-and-routed Unified Database (.udb) file to produce bitstream (.bit, .msk, or .rbt) for device configuration.

► To run BITGEN, type bitgen on the command line with, at minimum, the bitgen command. There is no need to specify the input .udb file if you run bitgen from the directory where it resides and there is no other .udb present.

There are several command line options that give you control over the way BITGEN outputs bitstream for device configuration. Please refer to the rest of the subjects in this topic for more details.


LIFCL Command Line Syntax bitgen [-d] [-w] [-m <format>] {-site <seirule>} {-site <seitype>} <infile> [<outfile>]
**BITGEN Options**  
The table below contains descriptions of all valid options for BITGEN.

**Note**  
Many BITGEN options are only available for certain architectures. Please use the `bitgen -h <architecture>` help command to see a list of valid bitgen options for the particular device architecture you are targeting.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>-d</code></td>
<td>Disable DRC.</td>
</tr>
<tr>
<td><code>-b</code></td>
<td>Produce .rbt file (ASCII form of binary).</td>
</tr>
<tr>
<td><code>-a</code></td>
<td>Produce .hex file.</td>
</tr>
<tr>
<td><code>-w</code></td>
<td>Overwrite an existing output file.</td>
</tr>
<tr>
<td><code>-freq</code></td>
<td>Can setup different frequency: 0 = slow, 1 = medium, 2 = fast.</td>
</tr>
<tr>
<td><code>&lt;frequency_bit_setting&gt;</code></td>
<td>Depending on the speed of external PROM, this options adjusts the frequency of the internal oscillator used by the iCE40UP device during configuration. This is only applicable when the iCE40UP device is used in SPI Master Mode for configuration.</td>
</tr>
<tr>
<td><code>-nvcm</code></td>
<td>Produce NVCM file.</td>
</tr>
<tr>
<td><code>-nvcmsecurity</code></td>
<td>Set security. Ensures that the contents of the Non-Volatile Configuration Memory (NVCM) are secure and the configuration data cannot be read out of the device.</td>
</tr>
<tr>
<td><code>-spilowpower</code></td>
<td>SPI flash low power mode. Places the PROM in low-power mode after configuration.</td>
</tr>
<tr>
<td><code>-warmboot</code></td>
<td>Enable warm boot. Enables the Warm Boot functionality, provided the design contains an instance of the WARMBOOT primitive.</td>
</tr>
<tr>
<td><code>-noheader</code></td>
<td>Don’t include the bitstream header.</td>
</tr>
<tr>
<td><code>-noebrinitq0</code></td>
<td>Don’t include EBR initialization for quadrant 0.</td>
</tr>
<tr>
<td><code>-noebrinitq1</code></td>
<td>Don’t include EBR initialization for quadrant 1.</td>
</tr>
<tr>
<td><code>-noebrinitq2</code></td>
<td>Don’t include EBR initialization for quadrant 2.</td>
</tr>
<tr>
<td><code>-noebrinitq3</code></td>
<td>Don’t include EBR initialization for quadrant 3.</td>
</tr>
<tr>
<td><code>-g NOPULLUP:ENABLED</code></td>
<td>No IO pullup. Removes the pullup on the unused I/Os, except Bank 3 I/Os which do not have pullup.</td>
</tr>
</tbody>
</table>
Table 14: iCE40UP BITGEN Command Line Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-h &lt;architecture&gt; or -help &lt;architecture&gt;</td>
<td>Display available BITGEN command options for the specified architecture. The <code>bitgen -h</code> command with no architecture specified will display a list of valid architectures.</td>
</tr>
<tr>
<td>&lt;infile&gt;</td>
<td>The input post-PAR design database file (.udb).</td>
</tr>
<tr>
<td>&lt;outfile&gt;</td>
<td>The output file. If you do not specify an output file, BITGEN creates one in the input file's directory. If you specify -b, the extension is .rbt. If you specify -a, the extension is .hex. If you specify -nvcm, the extension is .nvcm. Otherwise the extension is .bin. A report (.bgn) file containing all of BITGEN's output is automatically created under the same directory as the output file.</td>
</tr>
</tbody>
</table>

Table 15: LIFCL BITGEN Command Line Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-d</td>
<td>Disable DRC.</td>
</tr>
<tr>
<td>-w</td>
<td>Overwrite an existing output file.</td>
</tr>
<tr>
<td>-m &lt;format&gt;</td>
<td>Create &quot;mask&quot; and &quot;readback&quot; files. Valid formats are: 0: Output files in ASCII 1: Output files in binary.</td>
</tr>
<tr>
<td>-g <a href="">opt:val</a></td>
<td>Set option to value, options are (First is default): CfgMode Disable, Flowthrough, Bypass RamCfg Reset, NoReset DONEPHASE T3, T2, T1, T0 GOEPHASE T1, T3, T2 GSRPHASE T2, T3, T1 GWEPHASE T2, T3, T1 ES Yes, No.</td>
</tr>
<tr>
<td>-h &lt;architecture&gt; or -help &lt;architecture&gt;</td>
<td>Display available BITGEN command options for the specified architecture. The <code>bitgen -h</code> command with no architecture specified will display a list of valid architectures.</td>
</tr>
</tbody>
</table>
Example  The following command tells bitgen to overwrite any existing bitstream files with the -w option, prevents a physical design rule check (DRC) from running with -d, specifies a raw bits (.rbt) file output with -b. Notice how these three options can be combined with the -wdb syntax.

    bitgen -wdb <design.udb>

See Also  ►“Command Line Program Overview” on page 904
        ► “Command Line Data Flow” on page 906

Running Programmer from the Command Line

You can run Programmer from the command line. The PGRCMD command uses a keyword preceded by a hyphen for each command line option.

Running PGRCMD  PGRCMD allows you to download data files to an FPGA device.

► To run PGRCMD, type pgrcmd on the command line with, at minimum, the pgrcmd command.

There are several command line options that give you control over the way PGRCMD programs devices. Please refer to the rest of the subjects in this topic for more details.

Command Line Syntax  The following describes the PGRCMD command line syntax:

    pgrcmd [-help] [-infile <input_file_path>] [-logfile <log_file_path>] [-cabletype <cable>]

    -cabletype
        lattice [ -portaddress < 0x0378 | 0x0278 | 0x03bc | 0x <custom address> > ]
        usb [ -portaddress < EZUSB-0 | EZUSB-1 | ... | EZUSB-15 > ]
        usb2 [ -portaddress < FTUSB-0 | FTUSB-1 | ... | FTUSB-15 > ]
TCK [0, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10]

**PGRCMD Options**  The following are PGRCMD options.

**Help (Optional)**

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-help or -h</td>
<td>Displays the Programmer command line options.</td>
</tr>
</tbody>
</table>

**Input File (required)**

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-infile filename.xcf</td>
<td>Specifies the chain configuration file (.xcf). If the file path includes spaces, enclose the path in quotes.</td>
</tr>
</tbody>
</table>

**Log File (optional)**

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-logfile logfilename.log</td>
<td>Specifies the location of the Programmer log file.</td>
</tr>
</tbody>
</table>

**Cable Type (optional)**

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-cabletype lattice</td>
<td>Lattice HW-DLN-3C parallel port programming cable (default).</td>
</tr>
<tr>
<td>-cabletype usb</td>
<td>Lattice HW-USBN-2A USB port programming cable.</td>
</tr>
<tr>
<td>-cabletype usb2</td>
<td>Lattice FHW-USBN-2B (FTDI) USB programming cable and any FTDI based demo boards.</td>
</tr>
</tbody>
</table>

**Parallel Port Address (optional)**

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-portaddress 0x0378</td>
<td>LPT1 parallel port (default)</td>
</tr>
<tr>
<td>-portaddress 0x0278</td>
<td>LPT2 parallel port</td>
</tr>
<tr>
<td>-portaddress 0x03BC</td>
<td>LPT3 parallel port</td>
</tr>
<tr>
<td>-portaddress 0x&lt;custom address&gt;</td>
<td>Custom parallel port address</td>
</tr>
</tbody>
</table>

This option is only valid with parallel port cables.
USB Port Address (optional)

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-portaddress EZUSB-0 ... EZUSB-15</td>
<td>HW-USBN-2A USB cable number 0 through 15</td>
</tr>
<tr>
<td>-portaddress FTUSB-0 ... FTUSB-15</td>
<td>FTDI based demo board or FTDI USB2 cable number 0 through 15</td>
</tr>
</tbody>
</table>

Default is EZUSB-0 and FTUSB-0. Only valid with the USB port cables.

FTDI Based Demo Board or Cable Frequency Control (optional)

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
</table>
| -TCK 0, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10 | 0 = 30 Mhz  
1 = 15 Mhz (default)  
2 = 10 Mhz  
3 = 7.5 Mhz  
4 = 6 Mhz  
5 = 5 Mhz  
6 = 4 Mhz  
7 = 3 Mhz  
8 = 2 Mhz  
9 = 1 Mhz  
10 = 900 Khz |

Calculation formula for USB-2B (2232H FTDI USB host chip): Frequency = 60 MHz / (1 + ClockDivider) *2

Calculation formula for USB-2B (2232D FTDI USB host chip): Frequency = 12 MHz / (1 + ClockDivider) *2

Only applicable for FTDI based demo boards or programming cable.

Return Codes

<table>
<thead>
<tr>
<th>Code</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Success</td>
</tr>
<tr>
<td>-1</td>
<td>Log file error</td>
</tr>
<tr>
<td>-2</td>
<td>Check configuration setup error</td>
</tr>
<tr>
<td>-3</td>
<td>Out of memory error</td>
</tr>
<tr>
<td>-4</td>
<td>NT driver error</td>
</tr>
</tbody>
</table>
Examples  The following is a PGRCMD example.

pgrcmd -infile c:\test.xcf

See Also  ► “Command Line Data Flow” on page 906  
“Command Line Program Overview” on page 904

Running Various Utilities from the Command Line

The command line utilities described in this section are not commonly used by command line users, but you often see them in the auto-make log when you run design processes in the Radiant software environment. Click each link below for its function, syntax, and options.

Note

For information on commonly-used FPGA command line tools, see “Command Line Basics” on page 906.

Synpwrap

The synpwrap command line utility (wrapper) is used to manage Synplicity Synplify and Synplify Pro synthesis programs from the Radiant software environment processes: Synplify Synthesize Verilog File or Synplify Synthesize VHDL File.
The `synpwrap` utility can also be run from the command line to support a batch interface. For details on Synplify see the Radiant software online help. The `synpwrap` program drives `synplify_pro` programs with a Tcl script file containing the synthesis options and file list.

**Note**

This section supersedes the “Process Optimization and Automation” section of the Synplicity Synplify and Synplify Pro for Lattice User Guide.

This section illustrates the use of the `synpwrap` program to run Synplify Pro for Lattice synthesis scripts from the command line. For more information on synthesis automation of Synplify Pro, see the “User Batch Mode” section of the Synplicity Synplify and Synplify Pro for Lattice User Guide.

If you use Synplify Pro, the Lattice OEM license requires that the command line executables `synplify_pro` be run by the Lattice "wrapper" program, `synpwrap`.

**Command Line Syntax**  

**Table 16: SYNPWRAP Command Line Options**

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>-log &lt;log_file&gt;</code></td>
<td>Specifies the log file name.</td>
</tr>
<tr>
<td><code>-nolog</code></td>
<td>Does not print out the log file after the process is finished.</td>
</tr>
<tr>
<td><code>-options &lt;arguments&gt;</code></td>
<td>Passes all arguments to Synplify/Pro. Ignores all other options except <code>-notoem/-oem</code> and <code>-notpro/-pro</code>. The <code>-options</code> switch must follow all other <code>synpwrap</code> options.</td>
</tr>
<tr>
<td><code>-prj &lt;project_file&gt;</code></td>
<td>Runs Synplify or Synplify Pro using an external prj Tcl file instead of the Radiant software command file.</td>
</tr>
<tr>
<td><code>-rem</code></td>
<td>Does not automatically include Lattice library files.</td>
</tr>
<tr>
<td><code>-e &lt;command_file&gt;</code></td>
<td>Runs the batch interface based on a Radiant software generated command file. The <code>synpwrap</code> utility reads <code>&lt;project&gt;.cmd</code> with its command line to obtain user options and creates a Tcl script file.</td>
</tr>
<tr>
<td><code>-gui</code></td>
<td>Invokes the Synplify or Synplify Pro graphic user interface.</td>
</tr>
<tr>
<td><code>-int &lt;command_file&gt;</code></td>
<td>Enables the interactive mode. Runs Synplify/Pro UI with project per command file.</td>
</tr>
<tr>
<td><code>-dyn</code></td>
<td>Brings the Synplify installation settings in the Radiant software environment.</td>
</tr>
<tr>
<td><code>-notoem</code></td>
<td>Does not use the Lattice OEM version of Synplify or Synplify Pro.</td>
</tr>
</tbody>
</table>
Example  Below shows a synpwrap command line example.

```
synpwrap -rem -e prep1 -target iCE40UP
```

See Also  
- “Command Line Program Overview” on page 904
- “Command Line Data Flow” on page 906

**IP Packager**

The IP Packager (ippkg) tool can be run from the command line, allowing IP developers to select files from disks and pack them into one IPK file.

The process of IP packager is as following:

- IP author prepares metadata files, RTL files, HTML files, etc (all files of a Soft IP).
- IP Packager GUI provides UI for IP author to select files from the disk, and call IP Packaging engine to pack them into an IPK file.
- IP Packaging engine encrypts RTL files if IEEE P1735-2014 V1 pragmas are specified in RTL source.

**Command Line Syntax**  
```
```

**Table 17: IPPKG Command Line Options**

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-name</td>
<td>Specify the IP name.</td>
</tr>
<tr>
<td>-metadata</td>
<td>The file name will be fixed to ‘metadata.xml’.</td>
</tr>
</tbody>
</table>
The following is an ippkg command line example:

ippkg -metadata c:/test/test.xml -rtl_files c:/test/rtl_list -help_file c:/test/introduction.html

See Also

- “Command Line Program Overview” on page 904
- “Command Line Data Flow” on page 906

ECO Editor

The ECO Editor tool can be run from the command line too.

ECO Editor is also able to dump the ECO TCL commands which user acted in GUI view without saving any UDB file.

In the meanwhile, we will have one non-GUI ECO engine tool, it accepts the dumped TCL script file with a UDB file and output a new UDB file.

User can set ‘Place & Route design’ milestone post-script by Tcl command prj_set_postscript par <eco.tcl>, then Radiant flow runs the ECO Tcl script automatically after running place & route.

Table 17: IPPKG Command Line Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-metadata_files</td>
<td>Location of the file which stores the metadata files. One line is a file path in specified file. Must have a file named metadata.xml.</td>
</tr>
<tr>
<td>-rtl</td>
<td>Specify the IP RTL file.</td>
</tr>
<tr>
<td>-rtl_files</td>
<td>One line is a file path in specified file.</td>
</tr>
<tr>
<td>-plugin</td>
<td>The file name will be fixed to ‘plugin.py’.</td>
</tr>
<tr>
<td>-ldc</td>
<td>Specify the LDC file.</td>
</tr>
<tr>
<td>-testbench</td>
<td>Specify the testbench file.</td>
</tr>
<tr>
<td>-testbench_files</td>
<td>One line is a file path in specified file.</td>
</tr>
<tr>
<td>-help_file</td>
<td>Specify the help file, must be &lt;path&gt;/introduction.html.</td>
</tr>
<tr>
<td>-help_files</td>
<td>One line is a file path in specified file.</td>
</tr>
<tr>
<td>-license_file</td>
<td>Specify the license file.</td>
</tr>
<tr>
<td>-o</td>
<td>Specify the output zip file.</td>
</tr>
<tr>
<td>-key_file</td>
<td>Specify the key file to encrypt the RTL files.</td>
</tr>
<tr>
<td>--force-run</td>
<td>Force program to run regardless of errors.</td>
</tr>
</tbody>
</table>
Command Line Syntax  
```
ecoc [-s <script_file>] [-o <output.udb>] <input.udb>
```

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-s</td>
<td>ECO Tcl script file.</td>
</tr>
<tr>
<td>-o</td>
<td>Output UDB file.</td>
</tr>
<tr>
<td>&lt;input.udb&gt;</td>
<td>Input UDB file.</td>
</tr>
</tbody>
</table>

Example  The following is an ecoc command line example:

```
ecoc -s mem.tcl ebr_test_impl_1.udb
```

See Also  
▶ “Command Line Program Overview” on page 904  
▶ “Command Line Data Flow” on page 906

Using Command Files

This section describes how to use command files.

Creating Command Files  The command file is an ASCII file containing command arguments, comments, and input/output file names. You can use any text editing tool to create or edit a command file, for example, **vi**, **emacs**, **Notepad**, or **Wordpad**.

Here are some guidelines when you should observe when creating command files:

▶ Arguments (executables and options) are separated by space and can be spread across one or more lines within the file.

▶ Place new lines or tabs anywhere white space would otherwise be allowed on the Linux or DOS command line.

▶ Place all arguments on the same line, or one argument per line, or any combination of the two.

▶ There is no line length limitation within the file.

▶ All carriage returns and other non-printable characters are treated as space and ignored.

▶ Comments should be preceded with a # (pound sign) and go to the end of the line.

Command File Example  This is an example of a command file:

```
#command line options for par for design mine.udb
-a -n 10
-w
-l 5
-s 2 #will save the two best results
/home/users/jimbob/designs/mine.udb
```
Using the Command File The –f Option

Use the –f option to execute a command file from any command line tool. The –f option allows you to specify the name of a command file that stores and then executes commonly used or extensive command arguments for a given FPGA command line executable tool. You can then execute these arguments at any time by entering the Linux or DOS command line followed by the name of the file containing the arguments. This can be useful if you frequently execute the same arguments each time you perform the command, or if the command line becomes too long. This is the recommended way to get around the DOS command line length limitation of 127 characters. (Equivalent to specifying a shell Options file.)

The –f indicates fast startup, which is performed by not reading or executing the commands in your .cshrc | .kshrc | .shrc (C-shell, Korn-shell, Bourne-shell) file. This file typically contains your path information, your environment variable settings, and your aliases. By default, the system executes the commands in this file every time you start a shell. The –f option overrides this process, discarding the ‘set’ variables and aliases you do not need, making the process much faster. In the event you do need a few of them, you can add them to the command file script itself.

Command File Usage Examples

You can use the command file in two ways:

▶ To supply all of the command arguments as in this example:

```
par -f <command_file>
```

where:

<command_file> is the name of the file containing the command line arguments.

▶ To insert certain command line arguments within the command line as in the following example:

```
par -i 33 -f placeoptions -s 4 -f routeoptions design_i.udb design_o.udb
```

where:

placeoptions is the name of a file containing placement command arguments.

routeoptions is the name of a file containing routing command arguments.
Using Command Line Shell Scripts

This topic discusses the use of shell scripts to automate either parts of your design flow or entire design flows. It also provides some examples of what you can do with scripts. These scripts are Linux-based; however, it is also possible to create similar scripts called batch files for PC but syntax will vary in the DOS environment.

Creating Shell Scripts  A Linux shell script is an ASCII file containing commands targeted to a particular shell that interprets and executes the commands in the file. For example, you could target Bourne Shell (sh), C-Shell (csh), or Korn Shell (ksh). These files also can contain comment lines that describe part of the script which then are ignored by the shell. You can use any text editing tool to create or edit a shell script, for example, vi or emacs.

Here are some guidelines when you should observe when creating shell scripts:

► It is recommended that all shell scripts with "#!" followed by the path and name of the target shell on the first line, for example, #!/bin/ksh. This indicates the shell to be used to interpret the script.

► It is recommended to specify a search path because oftentimes a script will fail to execute for users that have a different or incomplete search path. For example:

```
PATH=/home/usr/lsmith:/usr/bin:/bin; export PATH
```

► Arguments (executables and options) are separated by space and can be spread across one or more lines within the file.

► Place new lines or tabs anywhere white space would otherwise be allowed on the Linux command line.

► Place all arguments on the same line, or one argument per line, or any combination of the two.

► There is no line length limitation within the file.

► All carriage returns and other non-printable characters are treated as space and ignored.

► Comments are preceded by a # (pound sign) and can start anywhere on a line and continue until the end of the line.

► It is recommended to add exit status to your script, but this is not required.

```
# Does global timing meet acceptable requirement range?
if [ $timing -lt 5 -o $timing -gt 10 ]; then
echo 1>&2 Timing "$timing" out of range
exit 127
fi
etc...
# Completed, Exit OK
exit 0
```

Advantages of Using Shell Scripts  Using shell scripts can be advantageous in terms of saving time for tasks that are often used, in
reducing memory usage, giving you more control over how the FPGA design flow is run, and in some cases, improving performance.

**Scripting with DOS** Scripts for the PC are referred to as batch files in the DOS environment and the common practice is to ascribe a .bat file extension to these files. Just like Linux shell scripts, batch files are interpreted as a sequence of commands and executed. The COMMAND.COM or CMD.EXE (depending on OS) program executes these commands on a PC. Batch file commands and operators vary from their Linux counterparts. So, if you wish to convert a shell script to a DOS batch file or vice-versa, we suggest you find a good general reference that shows command syntax equivalents of both operating systems.

**Examples** The following example shows running design “counter” on below device package

- **Architecture:** iCE40UP
- **Device:** iCE40UP3K
- **Package:** UWG30
- **Performance:** Worst Case

**Command 1: logic synthesis**

```
synthesis -f counter_impl1_lattice.synproj
  which the *.synproj contains
  -a "iCE40UP"
  -p iCE40UP3K
  -t UWG30
  -sp "Worst Case"
  -optimization_goal Area
  -bram_utilization 100
  -ramstyle Auto
  -romstyle auto
  -dsp_utilization 100
  -use_dsp 1
  -use_carry_chain 1
  -carry_chain_length 0
  -force_gsr Auto
  -resource_sharing 1
  -propagate_constants 1
  -remove_duplicate_regs 1
  -mux_style Auto
  -max_fanout 1000
  -fsm_encoding_style Auto
  -twr_paths 3
  -fix_gated_clocks 1
  -loop_limit 1950
  -use_io_reg auto
  -use_io_insertion 1
  -resolve_mixed_drivers 0
  -sdc "impl1.ldc"
  -path "C:/lscc/radiant/1.0/ispfpga/ice40tp/data" "impl1"
  -ver "C:/lscc/radiant/1.0/ip/pmi/pmi.v"
  -ver "count_attr.v"
  -path "."
```
-top count
-udb "counter_impl1.udb"
-output_hdl "counter_impl1.vm"

**Command 2: post synthesis process**
postsyn -a iCE40UP3K -p iCE40UP3K -t UWG30 -sp Worst Case -top -
ldc counter_impl1.ldc -keeprtl -w -o counter_impl1.udb
counter_impl1.vm

**Command 3: Mapper**
map "counter_impl1_syn.udb" "impl1.pdc" -o "counter_impl1.udb"

**Command 4: Placer and router**
par -f "counter_impl1.p2t" "counter_impl1_map.udb"
"counter_impl1.udb"

**Command 5: Timer**
timing -sethld -v 10 -u 10 -endpoints 10 -nperend 1 -html -rpt
"counter_impl1_twr.html" "counter_impl1.udb"

**Command 6: back annotation**
backanno "counter_impl1.udb" -n Verilog -o
"counter_impl1_vo.vo" -w -neg

**Command 7: bitstream generation**
bitgen -w "counter_impl1.udb" -f "counter_impl1.t2b"
Chapter 19

Tcl Command Reference Guide

The Radiant software supports Tcl (Tool Command Language) scripting and provides extended Radiant software Tcl commands that enable a batch capability for running tools in the Radiant software’s graphical interface. The command set and the Tcl Console used to run it affords you the speed, flexibility and power to extend the range of useful tasks that the Radiant software tools are already designed to perform.

In addition to describing how to run the Radiant software’s Tcl Console, this guide provides you with a reference for Tcl command line usage and syntax for all Radiant software point tools within the graphical user interface so that you can create command scripts, modify commands, or troubleshoot existing scripts.

About the Radiant software Tcl Scripting Environment

The Radiant software development software features a powerful script language system. The user interface incorporates a complete Tcl command interpreter. The command interpreter is enhanced further with additional Radiant software-specific support commands. The combination of fundamental Tcl along with the commands specialized for use with the Radiant software allow the entire Radiant software development environment to be manipulated.

Using the command line tools permits you to do the following:

- Develop a repeatable design environment and design flow that eliminates setup errors that are common in GUI design flows
- Create test and verification scripts that allow designs to be checked for correct implementation
- Run jobs on demand automatically without user interaction

The Radiant software command interpreter provides an environment for managing your designs that are more abstract and easier to work with than using the core Radiant software engines. The Radiant software command interpreter does not prevent use of the underlying transformation tools. You
can use either the TCL commands described in this section or you can use the core engines described in the “Command Line Reference Guide” on page 904.

**Additional References**  If you are unfamiliar with the Tcl language you can get help by visiting the Tcl/tk web site at [http://www.tcl.tk](http://www.tcl.tk). If you already know how to use Tcl, see the Tcl Manual supplied with this software. For information on command line syntax for running core tools that appear as Radiant software processes, such as synthesis, map, par, backanno, and timing, see the “Command Line Reference Guide” on page 904.

**See Also**  
- “Running the Tcl Console” on page 957  
- “Accessing Command Help in the Tcl Console” on page 959  
- “Radiant Software Tool Tcl Command Syntax” on page 963  
- “Creating and Running Custom Tcl Scripts” on page 959  
- “Accessing Command Help in the Tcl Console” on page 959  
- Tcl Manual (Windows only)  
- Tcl Manual (Linux only)

---

**Running the Tcl Console**

The Radiant software TCL Console environment is made available for your use in multiple different ways. In order to take full advantage of the FPGA development process afforded by the Radiant software you must gain access to the Radiant Tcl Console user interface.

**On Windows**  In Windows 7 you can interact with the Tcl Console by any one of the following methods:

- To launch the Radiant software GUI from the Windows Start menu, choose Start > All Programs > Lattice Radiant Software > Radiant Software.

  After the Radiant software loads you can click on the TCL Console tab. With the TCL Console tab active, you are able to start entering standard syntax TCL commands or the Radiant software specific support commands.

- To launch the **TCL Console** independently from the Radiant software GUI from the Windows Start menu choose Start > All Programs > Lattice Radiant Software > Accessories > TCL Console.

  A Windows command interpreter will be launched that automatically runs the TCL Console.

- To run the interpreter from the command line, type the following:

  ```
  c:/lscc/radiant/<version_number>/bin/nt64/pnmainc
  ```

  The Radiant **TCL Console** is now available to run.
To run the interpreter from a Windows 7 PowerShell from the Windows Start menu choose Start > All Programs > Accessories > Windows PowerShell > Windows PowerShell (x86).

A PowerShell interpreter window will open. At the command line prompt type the following:

c:/lscc/radiant/<version_number>/bin/nt64/pnmainc

The Radiant **TCL Console** is now available to run.

**Note**

The arrangement and location of each of the programs in the Windows Start menu will differ depending on the version of Windows you are running.

**On Linux** In Linux operating systems you can interact with the Tcl Console by one of the following methods:

- To launch the Radiant software GUI from the command line, type the following:

  /usr/<user_name>/radiant/<version_number>/bin/lin64/radiant

  The path provided assumes the default installation directory and that the Radiant software is installed. After the Radiant software loads you can click on the **TCL Console** tab. With the **TCL Console** tab active, you are able to start entering standard syntax TCL commands or the Radiant software specific support commands.

- To launch the **TCL Console** independently from the Radiant software GUI from the command line, type the following:

  /usr/<user_name>/Radiant/<version_number>/bin/lin64/radiantc

  The path provided assumes the default installation directory and that the Radiant software is installed, and that you have followed the Radiant software for Linux installation procedures. The Radiant **TCL Console** is now ready to accept your input.

  The advantage of running the **TCL Console** from an independent command interpreter is the ability to directly pass the script you want to run to the Tcl interpreter. Another advantage is that you have full control over the Tk graphical environment, which allows you to create your own user interfaces.

**See Also**

- "Running the Tcl Console" on page 957
- "Radiant Software Tool Tcl Command Syntax" on page 963
- "Creating and Running Custom Tcl Scripts" on page 959
- "Accessing Command Help in the Tcl Console" on page 959
- Tcl Manual (Windows only)
- Tcl Manual (Linux only)
Accessing Command Help in the Tcl Console

You can access command syntax help for all of the tools in the Tcl Console.

To access command syntax help in the Tcl Console:

1. In the prompt, type `help <tool_name>`* and press Enter as shown below:
   
   ```
   help prj*
   ```
   
   A list of valid command options appears in the Tcl Console.

2. In the Tcl Console, type the name of the command or function for more details on syntax and usage. For the `prj` tool, for example, type and enter the following:
   
   ```
   prj_open
   ```
   
   A list of valid arguments for that function appears.

Note

Although you can run the Radiant software's core tools such as synthesis, postsyn, map, par, and timing from the Tcl Console, the syntax for accessing help is different. For proper usage and syntax for accessing help for core tools, see the “Command Line Reference Guide” on page 904.

See Also

- “Running the Tcl Console” on page 957
- “Radiant Software Tool Tcl Command Syntax” on page 963
- “Creating and Running Custom Tcl Scripts” on page 959
- “Running Tcl Scripts When Launching the Radiant Software” on page 962
- Tcl Manual (Windows only)
- Tcl Manual (Linux only)

Creating and Running Custom Tcl Scripts

This topic describes how to easily create Tcl scripts using the Radiant software’s user interface and manual methods. FPGA design using Tcl scripts provides some distinct advantages over using the graphical user interface’s lists, views and menu commands. For example, Tcl scripts allow you to do the following:

- Set the tool environment to exactly the same state for every design run. This eliminates human errors caused by forgetting to manually set a critical build parameter from a drop-down menu.
- Manipulate intermediate files automatically, and consistently on every run. For example, .vm file errors can be corrected prior to performing additional netlist transformation operations.
- Run your script automatically by using job control software. This gives you the flexibility to run jobs at any time of day or night, taking advantage of idle cycles on your corporate computer system.
Creating Tcl Scripts  There are a couple of different methods you can use to create the Radiant software Tcl scripts. This section will discuss each one and provide step-by-step instructions for you to get started Tcl scripting repetitious Radiant software commands or entire workflows.

One method you have available is to use your favorite text editor to enter a sequence of the Radiant software Tcl commands. The syntax of each the Radiant software Tcl commands is available in later topics in this portion of the online help. This method should only be used by very experienced Radiant software Tcl command line users.

The preferred method is to let the Radiant software GUI assist you in getting the correct syntax for each Tcl command. When you interact with the Radiant software user interface each time you launch a scriptable process and the corresponding Radiant software Tcl command is echoed to the Tcl Console. This makes it much simpler to get the correct command line syntax for each Radiant software command. Once you have the fundamental commands executed in the correct order, you can then add additional Tcl code to perform error checking, or customization steps.

To create a Tcl command script in the Radiant software:

1. Start the Radiant software design software and close any project that may be open.
2. In the Tcl Console execute the custom reset command. This clears the Tcl Console command history.
3. Use the Radiant software graphical user interface to start capturing the basic command sequence. The Tcl Console echos the commands in its window. Start by opening the project for which you wish to create the TCL script. Then click on the processes in the Process bar to run them. For example, run these processes in their chronological order in the design flow:
   - Synthesize Design
   - Map Design
   - Place & Route Design
   - Export Files
4. In the Tcl Console window enter the command,
   
   ```tcl
   save_script <filename.ext>
   ```

   The `<filename.ext>` is any file identifier that has no spaces and contains no special characters except underscores. For example, `myscript.tcl` or `design_flow_1.tcl` are acceptable save_script values, but `my$script` or `my script` are invalid. The `<filename.ext>` entry can be preceded with an absolute or relative path. Use the "/" (i.e. forward slash) character to delimit the path elements. If the path is not specified explicitly the script is saved in the current working directory. The current working directory can be determined by using the TCL pwd command.

5. You can now use your favorite text editor to make any changes to the script you feel are necessary. Start your text editor, navigate to the
directory the save_script command saved the base script, and open the file.

**Note**

In most all cases, you will have to clean up the script you saved and remove any invalid arguments or any commands that cannot be performed in the Radiant software environment due to some conflict or exception. You will likely have to revisit this step later if after running your script you experience any run errors due to syntax errors or technology exceptions.

### Sample Radiant software Tcl Script

The following the Radiant software Tcl script shows a very simple script that opens a project, runs the entire design flow through the Place & Route process, then closes the project. A typical script will contain more tasks and will check for failure conditions. Use this simple example as a general guideline.

#### Figure 1: Simple Radiant software Script

```
prj_archive -dir "C:/my_radiant/counter" -extract "C:/lscc/radiant/1.1/examples/counter.zip"
prj_run_par
prj_close
```

### Running Tcl Scripts

The Radiant software TCL scripts are run exclusively from the Radiant TCL Console. You can use either the TCL Console integrated into the Radiant software UI, or by launching the stand-alone TCL Console.

**To run a Tcl script in the Radiant software:**

1. Launch the Radiant software GUI, or the stand-alone TCL Console.
   - Open the Radiant software but do not open your project. If your project is open, choose **File > Close Project**.
2. If you are using the Radiant software main window, click the small arrow pane switch in the bottom of the Radiant software main window, and then click on the **Tcl Console tab** in the Output area at the bottom to open the console.
3. Use the TCL `source` command to load and run your TCL script. The `source` command requires, as it's only argument, the filename of the script you want to load and run. Prefix the script file name with any required relative or absolute path information. To run the example script shown in the previous section use:

   ```
source C:/lscc/radiant/<version_number>/examples/counter/myscript2.tcl
   ```

As long as there are no syntax errors or invalid arguments, the script will open the project, synthesize, map, and place-and-route the design. Once the design finishes it closes the project. If there are errors in the script, you will see the errors in red in the Tcl Console after you attempt to run it. Go back to your script and correct the errors that prevented the script from running.
Running Tcl Scripts When Launching the Radiant Software

This topic describes how to launch the Radiant software and automatically run Tcl scripts using a command line shell or the stand-alone Tcl console. Your Tcl script can be standard Tcl commands as well as the Radiant software-specific Tcl commands.

Refer to "Creating and Running Custom Tcl Scripts" on page 959 for more information on creating custom Tcl scripts.

To launch the Radiant software and run a Tcl script from a command line shell or the stand-alone Tcl console:

Enter the following command:

On Windows:

```
pnmain.exe -t <tcl_path_file>
```

On Linux:

```
radiant -t <tcl_path_file>
```

Sample Radiant Software Tcl Script The following Radiant software Tcl script shows a very simple script, running in Windows, that opens a project and runs the design flow through the MAP process. Use this simple example as a general guideline.

Figure 2: Simple Radiant Software Script

```
prj_open C:/test/iobasic_radiant/io1.rdf
prj_run_map
```

The above example is saved in Windows as the file mytcl.tcl in the directory C:/test. By running the following command from either a DOS shell or the Tcl console in Windows, the Radiant software GUI starts, the project io1.rdf opens, and the MAP process automatically runs.

```
pnmain.exe -t c:/test/mytcl.tcl
```
Radiant Software Tool Tcl Command Syntax

This part of the Tcl Command Reference Guide introduces the syntax of each of the Radiant software tools and provides you with examples to help you construct your own commands and scripts.

The Radiant software tries to make it easy to develop TCL scripts by mirroring the correct command syntax in the Tcl Console based on the actions performed by you in the GUI. This process works well for most designs, but there are times when a greater degree of control is required. More control over the build process is made available through additional command line switches. The additional switches may not be invoked by actions taken by you when using the GUI. This section provides additional information about all of the Tcl commands implemented in the Radiant software.

The Tcl Commands are broken into major categories. The major categories are:

- Radiant Software Tcl Console Commands
- Radiant Software Timing Constraints Tcl Commands
- Radiant Software Physical Constraints Tcl Commands
- Radiant Software Project Tcl Commands
- Reveal Inserter Tcl Commands
- Reveal Analyzer Tcl Commands
- Power Calculator Tcl Commands
- Programmer Tcl Commands
- Engineering Change Order Tcl Commands

Radiant Software Tcl Console Commands

The Radiant software Tcl Console provides a small number of commands that allow you to perform some basic actions upon the Tcl Console Pane. The Radiant software Tcl Console commands differ from the other Tcl commands...
provided in the Radiant software. This dtc program’s general Tcl Console commands do not use the _dtc_ prefix in the command syntax as is the convention with other tools in the Radiant software.

**Note**

TCL Command Log is always listed after the project is closed. You can find it in the Reports section under Misc Report > TCL Command Log.

The following table provides a listing of all valid Radiant software Tcl Console-related commands.

### Table 19: Radiant Software Tcl Console Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Arguments</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>clear</td>
<td>N/A</td>
<td>The <code>clear</code> command erases anything present in the Tcl Console pane, and prints the current prompt character in the upper left corner of the Tcl Console pane without erasing the command history.</td>
</tr>
<tr>
<td>history</td>
<td>N/A</td>
<td>The <code>history</code> command lists the command history in the Tcl Console that you executed in the current session. Every command entered into the Tcl Console, either by the GUI, or by direct entry in the Tcl Console, is recorded so that it can be recalled at any time. The command history list is cleared when a project is opened or when the Tcl Console reset command is executed.</td>
</tr>
</tbody>
</table>
| reset   | N/A       | The `reset` command clears anything present in the Tcl Console pane, and erases all entries in the command line history. **It’s only used in GUI Tcl console and not supported in stand-alone Tcl console.**
**Table 19: Radiant Software Tcl Console Commands**

<table>
<thead>
<tr>
<th>Command</th>
<th>Arguments</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>save_script</td>
<td><code>&lt;filename.ext&gt;</code></td>
<td>Saves the contents of the command line history memory buffer into the script file specified. The script is, by default, stored into the current working directory. File paths using forward slashes used with an identifier are valid if using an absolute file path to an existing script folder. <strong>It's only used in GUI Tcl console and not supported in stand-alone Tcl console.</strong></td>
</tr>
<tr>
<td>set_prompt</td>
<td><code>&lt;new_character&gt;</code></td>
<td>The default prompt character in the Tcl Console is the &quot;greater than&quot; symbol or angle bracket (i.e., &gt;). You can change this prompt character to some other special character such as a dollar sign ($) or number symbol (#) if you prefer. <strong>It's only used in GUI Tcl console and not supported in stand-alone Tcl console.</strong></td>
</tr>
</tbody>
</table>

**Radiant Software Tcl Console Command Examples** This section illustrates and describes a few samples of Radiant Tcl Console commands.

**Example 1** To save a script, you simply use the `save_script` command in the Tcl Console window with a name or file path/name argument. In the first example command line, the file path is absolute, that is, it includes the entire path. Here you are saving "myscript.tcl" to the existing current working directory. The second example creates the same "myscript.tcl" file in the current working directory.

```
save_script C:/lscc/radiant/myproject/scripts/myscript.tcl
save_script myscript.tcl
```

See "Creating and Running Custom Tcl Scripts" on page 959 for details on how to save and run scripts in the Radiant software.

**Example 2** The following `set_prompt` command reassigns the prompt symbol on the command line as a dollar sign ($). The default is an angle bracket or “greater than” sign (>).

```
set_prompt $
```

**Example 3** The following `history` command will print all of the command history that was recorded in the current Tcl Console session.

```
history
```
# Radiant Software Timing Constraints

## Tcl Commands

The following table provides a listing of all valid Radiant software Timing Constraints Tcl commands.

<table>
<thead>
<tr>
<th>Command</th>
<th>Arguments</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>create_clock</td>
<td>create_clock -period &lt;period_value&gt; [-name &lt;clock_name&gt;] [-waveform &lt;edge_list&gt;] [&lt;port_list</td>
<td>pin_list</td>
</tr>
<tr>
<td>ldc_define_attribute</td>
<td>ldc_define_attribute -attr &lt;attr_type&gt; -value &lt;attr_value&gt; -object_type &lt;object_type&gt; -object &lt;object&gt; [-disable] [-comment &lt;comment&gt;]</td>
<td>Set LSE synthesis attributes for given objects</td>
</tr>
<tr>
<td>set_clock_groups</td>
<td>set_clock_groups -group &lt;clock_list&gt; &lt;-logically_exclusive</td>
<td>physically_exclusive</td>
</tr>
<tr>
<td>set_clock_latency</td>
<td>set_clock_latency [-rise] [-fall] [-early</td>
<td>-late] &lt;source&gt; &lt;latency&gt; &lt;object_list&gt;</td>
</tr>
</tbody>
</table>
Table 20: Radiant Software Timing Constraints Tcl Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Arguments</th>
<th>Description</th>
</tr>
</thead>
</table>
| set_false_path   | set_false_path [-from <port_list|pin_list|instance_list|net_list|clock_list>]
                     [-to <port_list|pin_list|instance_list|net_list|clock_list>]
                     [-through <port_list|pin_list|instance_list|net_list>]
                     [-rise_from <clock_list>] [-rise_to <clock_list>]
                     [-fall_from <clock_list>] [-fall_to <clock_list>]
                     [-comment string] | Define false path in the net list.
| set_load         | set_load <capacitance> <objects> | Commands to set capacitance on ports.
| set_max_delay    | set_max_delay [-from <port_list|pin_list|instance_list|net_list|clock_list>]
                     [-to <port_list|pin_list|instance_list|net_list|clock_list>]
                     [-through <port_list|pin_list|instance_list|net_list>]
                     [-rise_from <clock_list>] [-rise_to <clock_list>]
                     [-fall_from <clock_list>] [-fall_to <clock_list>] <delay_value>
                     [-comment string] | Specify maximum delay for timing paths.
| set_min_delay    | set_min_delay [-from <port_list|pin_list|instance_list|net_list|clock_list>]
                     [-to <port_list|pin_list|instance_list|net_list|clock_list>]
                     [-through <port_list|pin_list|instance_list|net_list>]
                     [-rise_from <clock_list>] [-rise_to <clock_list>]
                     [-fall_from <clock_list>] [-fall_to <clock_list>] <delay_value>
                     [-comment string] | Specify minimum delay for timing paths.
Radiant Software Physical Constraints
Tcl Commands

The following table provides a listing of all valid Radiant software Physical Constraints Tcl commands

Table 20: Radiant Software Timing Constraints Tcl Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Arguments</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>set_multicycle_path</td>
<td>set_multicycle_path [-from &lt;port_list</td>
<td>pin_list</td>
</tr>
<tr>
<td>set_output_delay</td>
<td>set_output_delay -clock &lt;clock_name&gt; [-clock_fall] [-max] [-min] [-add_delay] &lt;delay_value&gt; &lt;port_list&gt;</td>
<td>Set output delay on ports</td>
</tr>
</tbody>
</table>

Table 21: Radiant Software Physical Constraints Tcl Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Arguments</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ldc_create_group</td>
<td>ldc_create_group -name &lt;group_name&gt; [-bbox {height width}] &lt;objects&gt;</td>
<td>Defines a single identifier that refers to a group of objects</td>
</tr>
<tr>
<td>ldc_create_region</td>
<td>ldc_create_region -name &lt;region_name&gt; -site &lt;site&gt; -width &lt;width&gt; -height &lt;height&gt;</td>
<td>Define a rectangular area</td>
</tr>
<tr>
<td>ldc_create_vref</td>
<td>ldc_create_vref -name &lt;vref_name&gt; -site &lt;site_name&gt;</td>
<td>Define a voltage reference</td>
</tr>
<tr>
<td>ldc_prohibit</td>
<td>ldc_prohibit -site &lt;site&gt; -region &lt;region&gt;</td>
<td>Prohibits the use of a site or all sites inside a region</td>
</tr>
<tr>
<td>ldc_set_attribute</td>
<td>ldc_set_attribute &lt;key-value list&gt; [objects]</td>
<td>Set object attributes</td>
</tr>
</tbody>
</table>
Table 21: Radiant Software Physical Constraints Tcl Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Arguments</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ldc_define_global_attribute</td>
<td>ldc_define_global_attribute -attr &lt;attr_type&gt; -value &lt;attr_value&gt; [-disable] [-comment &lt;comment&gt;]</td>
<td>Set LSE synthesis global attributes</td>
</tr>
<tr>
<td>ldc_define_attribute</td>
<td>ldc_define_attribute -attr &lt;attr_type&gt; -value &lt;attr_value&gt; -object_type &lt;object_type&gt; -object &lt;object&gt; [-disable] [-comment &lt;comment&gt;]</td>
<td>Set LSE synthesis attributes for given objects</td>
</tr>
<tr>
<td>ldc_set_location</td>
<td>ldc_set_location [-site &lt;site_name&gt;] [-bank &lt;bank_num&gt;]</td>
<td>Set object location</td>
</tr>
<tr>
<td>ldc_set_port</td>
<td>ldc_set_port [-iobuf [-vref &lt;vref_name&gt;]] [-sso] &lt;key-value list&gt; &lt;ports&gt;</td>
<td>Set port constraint attributes</td>
</tr>
<tr>
<td>ldc_set_sysconfig</td>
<td>ldc_set_sysconfig &lt;key-value list&gt;</td>
<td>Set sysconfig attributes</td>
</tr>
<tr>
<td>ldc_set_vcc</td>
<td>ldc_set_vcc [-bank bank</td>
<td>-core] [-derate derate] [voltage]</td>
</tr>
</tbody>
</table>

Radiant Software Physical Constraints Tcl Commands Examples

This section illustrates and describes a few samples of Radiant Physical Constraints Tcl commands.

Example 1  The following `ldc_create_group` command creates a sample group with 3 instances, and places all instances within the group to a 2x2 bbox.

```
ldc_create_group -name sample_group -bbox {2 2} [get_cells {i16_1_lut i18_2_lut i25_3_lut }]
```

Example 2  The following `ldc_set_location` command places the port clk to pin E7.

```
ldc_set_location -site {E7} [get_ports clk]
```

Example 3  The following `ldc_set_port` command sets IO_TYPE, DRIVE, SLEWRATE attributes of the port rst.

```
ldc_set_port -iobuf {IO_TYPE=LVCMOS33 DRIVE=8 SLEWRATE=FAST} [get_ports rst]
```
### Radiant Software Project Tcl Commands

The Radiant software Project Tcl Commands allow you to control the contents and settings applied to the tools, and source associated with your design. Projects can be opened, closed, and configured to a consistent state using the commands described in this section.

**Radiant Software Project Tcl Command Descriptions**  
The following table provides a listing of all valid Radiant software project-related Tcl command options and describes option functionality.

<table>
<thead>
<tr>
<th>Command</th>
<th>Function (Argument)</th>
<th>Description</th>
</tr>
</thead>
</table>
| prj_create | prj_create -name <project name> [-dev <device name>] [-performance <performance grade>] [-impl <initial implementation name>] [-impl_dir <initial implementation directory>] [-synthesis <synthesis tool name>] | Creates a new project inside the current working directory. The new command can only be used when no other project is currently open.  
The -name <project name> argument specifies the name of the project. This creates a <project name>.rdf file in the current working directory.  
The -dev <device name> argument specifies the FPGA family, density, footprint, performance grade, and temperature grade to generate designs for. Use the Lattice OPN (Ordering Part Number) for the <device name> argument.  
The -performance <performance grade> argument specifies the device performance grade explicitly. For iCE40UP device, performance grade can’t be inferred from the device part name such as iCE40UP3K-UWG30ITR. If no performance grade specified, default performance value is used.  
The -impl <initial implementation name> argument specifies the active implementation when the project is created. If this left unspecified a default implementation called "Implementation0" is created.  
The -impl_dir <initial implementation directory> argument defines the directory where temporary files are stored. If this is not specified the current working directory is used. |
| prj_close  | prj_close                                                                         | Exits the current project. Any unsaved changes are discarded.                                                                                                                                              |
### Table 22: Radiant Software Project Tcl Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Function (Argument)</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>prj_open</code></td>
<td><code>prj_open &lt;projectfile.rdf&gt;</code></td>
<td>Opens the specified project in the software environment.</td>
</tr>
<tr>
<td><code>prj_save</code></td>
<td><code>prj_save [projectfile.rdf]</code></td>
<td>Updates the project with all changes made during the current session and the project file is saved.</td>
</tr>
<tr>
<td><code>prj_saveas</code></td>
<td><code>prj_saveas -name &lt;new project name&gt; -dir &lt;new project directory&gt; [-copy_gen]</code></td>
<td>Save the current project as a new project with specified name and directory.</td>
</tr>
<tr>
<td><code>prj_set_opt</code></td>
<td><code>prj_set_opt</code></td>
<td>List, set or remove a project option.</td>
</tr>
<tr>
<td></td>
<td><code>prj_set_opt &lt;option name&gt; [option value list]</code></td>
<td>: List all the options in the current project</td>
</tr>
<tr>
<td></td>
<td></td>
<td>: List or set the option value</td>
</tr>
<tr>
<td></td>
<td><code>prj_set_opt -append &lt;option name&gt; &lt;option value&gt;</code></td>
<td>: Append a value to the specified option value</td>
</tr>
<tr>
<td></td>
<td><code>prj_set_opt -rem &lt;option name&gt;...</code></td>
<td>: Remove the options of the current project</td>
</tr>
<tr>
<td><code>prj_archive</code></td>
<td><code>prj_archive [-includeAll] &lt;archive_file&gt;</code></td>
<td>Archive the current project.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>: Archive the current project into the archive_file</td>
</tr>
<tr>
<td></td>
<td><code>prj_archive -extract -dir &lt;destination directory&gt; &lt;archive_file&gt;</code></td>
<td>Extract the archive file and load the project</td>
</tr>
<tr>
<td></td>
<td></td>
<td>: Change the device to the specified family, device, package, performance, operation, part</td>
</tr>
</tbody>
</table>
## Table 22: Radiant Software Project Tcl Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Function (Argument)</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>prj_add_source</td>
<td>prj_add_source [-impl &lt;implement name&gt;] [-simulate_only</td>
<td>-synthesis_only]</td>
</tr>
<tr>
<td></td>
<td>[-include &lt;path list for Verilog include search path&gt;]</td>
<td></td>
</tr>
<tr>
<td></td>
<td>[-work &lt;VHDL lib name&gt;] [[-opt &lt;name=value&gt;] ...] [-exclude]</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&lt;src file&gt;...</td>
<td></td>
</tr>
<tr>
<td>prj_enable_source</td>
<td>prj_enable_source [-impl &lt;implement name&gt;] &lt;src file&gt; ...</td>
<td>Enables the excluded design sources from the current project, that is, it will activate a source file for synthesis, to be used as a constraint, or for Reveal debugging.</td>
</tr>
<tr>
<td>prj_disable_source</td>
<td>prj_disable_source [-impl &lt;implement name&gt;] &lt;src file&gt; ...</td>
<td>Disables the excluded design sources from the current project, that is, it will activate a source file for synthesis, to be used as a constraint or for Reveal debugging.</td>
</tr>
<tr>
<td>prj_remove_source</td>
<td>prj_remove_source [-impl &lt;implement name&gt;] -all</td>
<td>Deletes the specified source files from the specified implementation. If an implementation is not listed explicitly the source files are removed from the active implementation. The source files are not removed from the file system, they are only removed from consideration in the specified implementation.</td>
</tr>
<tr>
<td></td>
<td>prj_remove_source [-impl &lt;implement name&gt;] &lt;src file&gt;</td>
<td></td>
</tr>
</tbody>
</table>
### Table 22: Radiant Software Project Tcl Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Function (Argument)</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>prj_set_source_opt</td>
<td>prj_set_source_opt -src &lt;source name&gt; [-impl &lt;implement name&gt;]</td>
<td>List, set or remove a source option.</td>
</tr>
<tr>
<td></td>
<td>prj_set_source_opt -impl &lt;implement name&gt;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>-src &lt;source name&gt; [-impl &lt;implement name&gt;]</td>
<td></td>
</tr>
<tr>
<td></td>
<td>&lt;option name&gt; [option value list]</td>
<td></td>
</tr>
<tr>
<td></td>
<td>prj_set_source_opt -append &lt;option name&gt; &lt;option value&gt;</td>
<td>Append a value to the specified option value</td>
</tr>
<tr>
<td></td>
<td>prj_set_source_opt -rem &lt;option name&gt;...</td>
<td>Remove the options of the source</td>
</tr>
<tr>
<td>prj_create_impl</td>
<td>prj_create_impl &lt;new impl name&gt; [-dir &lt;implementation directory&gt;] [-strategy &lt;default strategy name&gt;] [-synthesis &lt;synthesis tool name&gt;]</td>
<td>Create a new implementation in the current project with ‘&lt;new impl name&gt;’. The new implementation will use the current active implementation’s strategy as the default strategy if no valid strategy is set.</td>
</tr>
<tr>
<td>prj_remove_impl</td>
<td>prj_remove_impl &lt;implement name&gt;</td>
<td>Delete the specified implementation in the current project with '&lt;impl name&gt;'.</td>
</tr>
</tbody>
</table>
Table 22: Radiant Software Project Tcl Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Function (Argument)</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>prj_set_impl_opt</td>
<td>prj_set_impl_opt [-impl &lt;implement name&gt;]</td>
<td>Allows you to add, list, or remove implementation options with the name &lt;implement name&gt; in the specified or active implementation of the current project.</td>
</tr>
<tr>
<td></td>
<td>prj_set_impl_opt [-impl &lt;implement name&gt;] &lt;option name&gt; [option value list]</td>
<td>If the -rem option is used, the following option names appearing after it will be removed.</td>
</tr>
<tr>
<td></td>
<td>prj_set_impl_opt [-impl &lt;implement name&gt;] -append &lt;option name&gt; &lt;option value&gt;</td>
<td>If no argument is used (i.e., &quot;prj_impl option&quot;), the default is to list all implementation options.</td>
</tr>
<tr>
<td></td>
<td>prj_set_impl_opt [-impl &lt;implement name&gt;] -rem &lt;option name&gt;...</td>
<td>If only the &lt;option name&gt; argument is used (i.e., &quot;prj_impl option &lt;option name&gt;&quot;), then the value of that option in the project will be returned.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>The command will set the option value to the option specified by &lt;option name&gt;. If the &lt;option value&gt; is empty then the option will be removed and ignored (e.g., prj_impl option -rem).</td>
</tr>
<tr>
<td></td>
<td></td>
<td>The -run_flow argument allows you to switch from the normal mode to an &quot;initial&quot; incremental flow mode and &quot;incremental&quot; which is the mode you should be in after an intial design run during the incremental design flow. With no value parameters specified, -run_flow will return the current mode setting.</td>
</tr>
<tr>
<td>prj_set_prescript</td>
<td>prj_set_prescript [-impl &lt;implement name&gt;] &lt;milestone name&gt; &lt;script_file&gt;</td>
<td>List or set user Tcl script before running milestone.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>: milestone name can be 'syn', 'map', 'par', 'export'</td>
</tr>
<tr>
<td>prj_set_postscript</td>
<td>prj_set_postscript [-impl &lt;implement name&gt;] &lt;milestone name&gt; &lt;script_file&gt;</td>
<td>List or set user Tcl script after running milestone.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>: milestone name can be 'syn', 'map', 'par', 'export'</td>
</tr>
<tr>
<td>prj_activate_impl</td>
<td>prj_activate_impl &lt;implement name&gt;</td>
<td>Activates the implementation with the name &lt;implement name&gt;.</td>
</tr>
<tr>
<td>prj_clean_impl</td>
<td>prj_clean_impl [-impl &lt;implement name&gt;]</td>
<td>Clean up the implementation result files in the current project.</td>
</tr>
<tr>
<td>prj_clone_impl</td>
<td>prj_clone_impl &lt;new impl name&gt; [-dir &lt;new impl directory&gt;] [-copyRef] [-impl &lt;original impl name&gt;]</td>
<td>Clone an existing implementation.</td>
</tr>
<tr>
<td>prj_run_synthesis</td>
<td>prj_run_synthesis</td>
<td>Run synthesis process.</td>
</tr>
</tbody>
</table>
Radiant Software Project Tcl Command Examples  This section illustrates and describes a few samples of Radiant software Project Tcl commands.

Example 1  To create a new project, your command may appear something like the following which shows the creation of a ThunderPlus device.

```tcl
prj_create -name "m" -impl "m" -dev iCE40UP3K-UWG30ITR
```

Example 2  To save a project and give it a certain name (save as), use the project save command as shown below:

```tcl
prj_save "my_project"
```

To simply save the current project just use the save function with no values:

```tcl
prj_save
```

Example 3  To open an existing project, the command syntax would appear with the absolute file path on your system as shown in the following example:

```tcl
prj_open "C:/projects/radiant/adder/my_project.rdf"
```
Example 4  To add a source file, in this case a source LDC file, use the prj_src add command as shown below and specify the complete file path:

```
prj_add_source "C:/my_project/radiant/counter/counter.ldc"
```

Example 5  The following examples below shows the prj_run command being used:

```
prj_run_par
```

In this final example, synthesis is run.

```
prj_run_synthesis
```

Example 6  To copy another project strategy that is already established in another Radiant software project from your console, use the prj_copy_strategy copy command as shown below and specify the new strategy name and the strategy file name.

```
prj_copy_strategy -from source_strategy -name new_strategy -file strategy.stg
```

Example 7  The prj_add_source command allows you to set a custom, user-defined option. This -opt argument value, however, cannot conflict with existing options already in the system, that is, its identifier must differ from system commands such as "include" and "lib" for example. In addition, a user-defined option may not affect the internal flow but can be queried for any usage in a user's script to arrange their design and sources. All user-defined options can be written to the Radiant software project RDF file.

In the example below, the -opt argument is used as a qualifier to make a distinction between to .rvl file test cases.

```
prj_add_source test1.rvl -opt "debug_case=golden_case"
prj_add_source test2.rvl -opt "debug_case=bad_case"
```

Example 8  After you modify your strategy settings in the Radiant software interface the values are saved to the current setting via a Tcl command. For example, a command similar to the following will be called if Synplify frequency and area options are changed.

```
prj_set_strategy_value -strategy strategy1 SYN_Frequency=300 SYN_Area=False
```

Simulation Libraries Compilation Tcl Commands

This section provides Simulation Libraries Compilation extended Tcl command syntax and usage examples.
Simulation Libraries Compilation Tcl Command Descriptions

The following table provides a listing of all valid Simulation Libraries Compilation Tcl Command arguments and describes their usage.

Note

Running cmpl_libs may take a long time and may cause the Radiant software to hang.

- It is recommended to run cmpl_libs using the Radiant TCL Console (Start Menu > Lattice Radiant Software > Accessories > TCL Console).
- or,
- Run cmpl_libs.tcl using the command line console. Refer to “Running cmpl_libs.tcl from the Command Line” on page 912.

Table 23: Simulation Libraries Compilation Tcl Command

<table>
<thead>
<tr>
<th>Command</th>
<th>Function (Argument)</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>cmpl_libs</td>
<td><code>-sim_path &lt;sim_path&gt;</code></td>
<td>The -sim_path argument specifies the path to the simulation tool executable (binary) folder. This option is mandatory. Currently only Modelsim and Questa simulators are supported. NOTE: If you are a Windows user and prefer the \ notation in the path, you must surround it with {}. And &quot;&quot; or {} will be needed if the path has spaces. NOTE: To execute this command error free, Questasim 10.4e or a later 10.4 version, or Questasim 10.5b or a later version should be used for compilation.</td>
</tr>
<tr>
<td></td>
<td>[-sim_vendor {mentor&lt;default&gt;}]</td>
<td>The -sim_vendor argument is optional, and intended for future use. It currently supports only Mentor Graphics simulators (Modelsim / Questa).</td>
</tr>
<tr>
<td></td>
<td>[-device {ice40up</td>
<td>LIFCL</td>
</tr>
<tr>
<td></td>
<td>[-target_path &lt;target_path&gt;]</td>
<td>The -target_path argument specifies the target path, where you want the compiled libraries and modelsim.ini file to be located. This argument is optional, and the default target path is the current folder. NOTES: (1) This argument is recommended if you did not change the current folder from the Radiant software startup (binary) folder, or if the current folder is write-protected. (2) If you are a Windows user and prefer the \ notation in the path, you must surround it with {}. And &quot;&quot; or {} will be needed if the path has spaces.</td>
</tr>
</tbody>
</table>
Simulation Libraries Compilation Tcl Command Examples  This section illustrates and describes a few examples of Simulation Libraries Compilation Tcl command.

Example 1  The following command will compile all the Lattice FPGA libraries for both Verilog and VHDL simulation, and place them under the folder specified by -target_path. The path to Modelsim is specified by -sim_path.

cmpl_libs -sim_path C:/questasim64_10.4e/win64 -target_path c:/mti_libs

Reveal Inserter Tcl Commands

This section provides Reveal Inserter extended Tcl command syntax, command options, and usage examples.

Reveal Inserter Tcl Command Descriptions  The following table provides a listing of all valid Reveal Inserter Tcl command options and describes option functionality.

Table 24: Reveal Inserter Tcl Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Function (Argument)</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>rvl_new_project</td>
<td>rvl_new_project &lt;rvl file&gt;</td>
<td>Create a new reveal inserter project.</td>
</tr>
<tr>
<td>rvl_open_project</td>
<td>rvl_open_project &lt;rvl file&gt;</td>
<td>Open a reveal inserter project file.</td>
</tr>
<tr>
<td>rvl_save_project</td>
<td>rvl_save_project &lt;rvl file&gt;</td>
<td>Save the current reveal inserter project.</td>
</tr>
<tr>
<td>rvl_close_project</td>
<td>rvl_close_project</td>
<td>Close the current reveal inserter project.</td>
</tr>
</tbody>
</table>
| rvl_run_project  | rvl_run_project [-save] [-saveAs <file>] [-overwrite] [-drc] [-insert_core <core_name>] | ▶ "Run inserting debug core task or DRC checking on the current reveal inserter project  
▶ -save: Save the project before run command  
▶ -saveAs: Save as a different file before run command  
▶ -overwrite: Overwrite the existing file if the saved as to file exists already  
▶ -drc: Run DRC checking only  
▶ -insert_core: Specify the core to be inserted. All cores will be inserted if none is specified" |
| rvl_add_core     | rvl_add_core <core name> | Add a new core in current project.                                         |
| rvl_del_core     | rvl_del_core <core name> | Remove an existing core from current project.                             |
### Table 24: Reveal Inserter Tcl Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Function (Argument)</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>rvl_rename_core</code></td>
<td><code>rvl_rename_core &lt;core name&gt;</code></td>
<td>Rename an existing core from current project.</td>
</tr>
<tr>
<td><code>rvl_set_core</code></td>
<td><code>rvl_set_core [core name]</code></td>
<td>List the default core or select a core as the default core in current project.</td>
</tr>
<tr>
<td><code>rvl_list_core</code></td>
<td><code>rvl_list_core</code></td>
<td>List all cores in current project.</td>
</tr>
<tr>
<td><code>rvl_add_serdes</code></td>
<td><code>rvl_add_serdes</code></td>
<td>Add the Serdes core into current project.</td>
</tr>
<tr>
<td><code>rvl_del_serdes</code></td>
<td><code>rvl_del_serdes</code></td>
<td>Remove the Serdes core from current project.</td>
</tr>
<tr>
<td><code>rvl_set_serdes</code></td>
<td><code>rvl_set_serdes [clk=&lt;clock name&gt;] [rst=&lt;reset signal, default value is VLO&gt;]</code></td>
<td>List or set options of Serdes core.</td>
</tr>
<tr>
<td><code>rvl_add_controller</code></td>
<td>`rvl_add_controller [-item LED</td>
<td>Switch</td>
</tr>
<tr>
<td><code>rvl_del_controller</code></td>
<td><code>rvl_del_controller</code></td>
<td>Remove the Controller Core from current project.</td>
</tr>
<tr>
<td><code>rvl_set_controller</code></td>
<td>`rvl_set_controller [-item LED</td>
<td>Switch</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Insert=[on</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Width=[1..32] for LED and Switch</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- AddrWidth=[4..16] for Register</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- DataWidth=[4..32] for Register</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- AddrBus=addr_bus for Register</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- WData=wdata_bus for Register</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- RData=rdata_bus for Register</td>
</tr>
<tr>
<td><code>rvl_add_trace</code></td>
<td><code>rvl_add_trace [-core &lt;core name&gt;] [-insert_at &lt;position&gt;] &lt;signals list&gt;</code></td>
<td>Add trace signals in a debug core in current project. You can specify an existing trace signal/bus name or a position number in a trace bus as the inserting position.</td>
</tr>
<tr>
<td><code>rvl_del_trace</code></td>
<td><code>rvl_del_trace [-core &lt;core name&gt;] &lt;signals list&gt;</code></td>
<td>Delete trace signals in a debug core in current project.</td>
</tr>
<tr>
<td>Command</td>
<td>Function (Argument)</td>
<td>Description</td>
</tr>
<tr>
<td>------------------</td>
<td>--------------------------------------------------</td>
<td>------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>rvl_rename_trace</td>
<td>rvl_rename_trace [-core &lt;core name&gt;] -bus &lt;bus name&gt; &lt;new bus name&gt;</td>
<td>Change the name of a trace bus in a debug core in current project.</td>
</tr>
<tr>
<td>rvl_list_trace</td>
<td>rvl_list_trace [-core &lt;core name&gt;]</td>
<td>List all trace signals in a debug core in current project.</td>
</tr>
<tr>
<td>rvl_move_trace</td>
<td>rvl_move_trace [-core &lt;core name&gt;] [move_to &lt;position&gt;] &lt;signals list&gt;</td>
<td>Move and rearrange the order of trace signals in a debug core in current project. You can specify an existing trace signal/bus name or a position number in a trace bus as the new position.</td>
</tr>
<tr>
<td>rvl_group_trace</td>
<td>rvl_group_trace [-core &lt;core name&gt;] -bus &lt;bus name&gt; &lt;signals list&gt;</td>
<td>Group specified trace signals in a debug core in current project into a bus.</td>
</tr>
<tr>
<td>rvl_ungroup_trace</td>
<td>rvl_ungroup_trace [-core &lt;core name&gt;] &lt;bus name&gt;</td>
<td>Ungroup trace signals in a trace bus in a debug core in current project.</td>
</tr>
<tr>
<td>rvl_set_traceoptn</td>
<td>rvl_set_traceoptn [-core &lt;core name&gt;] [option=value]</td>
<td>List or set trace options of a debug core in current project. You can set the following option: SampleClk = [signal name].</td>
</tr>
<tr>
<td>rvl_set_trigoptn</td>
<td>rvl_set_trigoptn [-core &lt;core name&gt;] [option=value]</td>
<td>List or set trigger options of a debug core in current project. You can set the following option: DefaultRadix = [bin</td>
</tr>
<tr>
<td>rvl_list_tu</td>
<td>rvl_list_tu [-core &lt;core name&gt;]</td>
<td>List all trigger units in a debug core in current project.</td>
</tr>
</tbody>
</table>
### Table 24: Reveal Inserter Tcl Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Function (Argument)</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>rvl_add_tu</td>
<td>rvl_add_tu [-core &lt;core name&gt;] [-radix &lt;bin</td>
<td>oct</td>
</tr>
<tr>
<td></td>
<td>TU definition format: &quot;{signal list} Operator Value&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Operator must be &quot;==&quot;, &quot;!=&quot;, &quot;&gt;&quot;, &quot;&gt;=&quot;, &quot;&lt;&quot;, &quot;&lt;=&quot;. .RE.&quot;(rising edge), .FE.&quot;(falling edge) and .SC.&quot;(serial compare).</td>
<td></td>
</tr>
<tr>
<td></td>
<td>A default trigger unit name will be created if it's omitted in command..</td>
<td></td>
</tr>
<tr>
<td>rvl_del_tu</td>
<td>rvl_del_tu [-core &lt;core name&gt;] &lt;TU name&gt;</td>
<td>Remove an existing core from current project.</td>
</tr>
<tr>
<td>rvl_rename_tu</td>
<td>rvl_rename_tu [-core &lt;core name&gt;] &lt;old name&gt; &lt;new name&gt;</td>
<td>Rename an existing core in current project.</td>
</tr>
<tr>
<td>rvl_set_tu</td>
<td>rvl_set_tu [-core &lt;core name&gt;] [-radix &lt;bin</td>
<td>oct</td>
</tr>
<tr>
<td></td>
<td>TU definition format: &quot;{signal list} Operator Value&quot;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Operator must be &quot;==&quot;, &quot;!=&quot;, &quot;&gt;&quot;, &quot;&gt;=&quot;, &quot;&lt;&quot;, &quot;&lt;=&quot;. .RE.&quot;(rising edge), .FE.&quot;(falling edge) and .SC.&quot;(serial compare)..&lt;</td>
<td></td>
</tr>
<tr>
<td>rvl_list_te</td>
<td>rvl_list_te [-core &lt;core name&gt;]</td>
<td>List all trigger expressions in a debug core in current project.</td>
</tr>
<tr>
<td>rvl_add_te</td>
<td>rvl_add_te [-core &lt;core name&gt;] [-ram EBR</td>
<td>slice] [-name &lt;new TE name&gt;] &lt;expression string&gt; &lt;max_seq_depth &lt;max depth&gt;] &lt;max_event_count &lt;max event count&gt;</td>
</tr>
<tr>
<td></td>
<td>A default trigger expression name will be created if it's omitted in command.</td>
<td></td>
</tr>
<tr>
<td>rvl_del_te</td>
<td>rvl_del_tu [-core &lt;core name&gt;] &lt;TE name&gt;</td>
<td>Delete an existing trigger expression in a debug core in current project.</td>
</tr>
<tr>
<td>rvl_rename_te</td>
<td>rvl_rename_tu [-core &lt;core name&gt;] &lt;old name&gt; &lt;new name&gt;</td>
<td>Rename an existing trigger expression in a debug core in current project.</td>
</tr>
<tr>
<td>rvl_set_te</td>
<td>rvl_set_tu [-core &lt;core name&gt;] [-ram EBR</td>
<td>slice] [-expression &lt;expression string&gt;] &lt;max_seq_depth &lt;max depth&gt;] &lt;max_event_count &lt;max event count&gt;</td>
</tr>
</tbody>
</table>
Reveal Inserter Tcl Command Examples  This section illustrates and describes a few samples of Reveal Inserter Tcl commands.

Example 1  To create a new Reveal Inserter project with the .rvl file extension in your project directory, use the rvl_project command as shown below using the new option.

rvl_new_project my_project.rvl

Example 2  The following example shows how to set up TU parameters for Reveal Inserter:

rvl_set_tu -name TU -add_sig {count[7:0]} -op == -val C3 -radix Hex

Reveal Analyzer Tcl Commands

This section provides Reveal Analyzer extended Tcl command syntax, command options, and usage examples.

Reveal Analyzer Tcl Command Descriptions  The following table provides a listing of all valid Reveal Analyzer Tcl command options and describes option functionality.

<table>
<thead>
<tr>
<th>Command</th>
<th>Function (Argument)</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>rva_new_project</td>
<td>rva_new_project &lt;file&gt;</td>
<td>Create a new Reveal Analyzer project.</td>
</tr>
<tr>
<td>rva_open_project</td>
<td>rva_open_project &lt;file&gt;</td>
<td>Open a Reveal Analyzer project file.</td>
</tr>
<tr>
<td>rva_save_project</td>
<td>rva_save_project &lt;file&gt;</td>
<td>Save the current Reveal Analyzer project.</td>
</tr>
<tr>
<td>rva_close_project</td>
<td>rva_close_project &lt;file&gt;</td>
<td>Close the current Reveal Analyzer project.</td>
</tr>
<tr>
<td>rva_export_project</td>
<td>rva_export_project -vcd &lt;file&gt; [-module &lt;title&gt;]</td>
<td>Export VCD file. Optional to include a title in the VCD file. By default the title will be &quot;&lt;unknown&gt;&quot;.</td>
</tr>
<tr>
<td></td>
<td>rva_export_project -txt &lt;file&gt; [-siglist &lt;signal list&gt;]</td>
<td>Export TEXT file. Optional to export selected signal list only. By default all signals are exported.</td>
</tr>
</tbody>
</table>
## Table 25: Reveal Analyzer Tcl Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Function (Argument)</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>rva_set_project</td>
<td>rva_set_project [-frequency &lt;val&gt;] [-period &lt;val&gt;] [-tckdelay &lt;val&gt;] [-cabletype &lt;val&gt;] [-cableport &lt;val&gt;]</td>
<td>No arguments specified will return options. -frequency: sets the frequency value for sample clock in MHz -period: sets a period value for sample clock in ns or ps -tckdelay: sets a TCK clock pin pulse width delay value -cabletype: sets the type of cable. Values are LATTICE</td>
</tr>
<tr>
<td>rva_run</td>
<td>rva_run</td>
<td>Runs until trigger condition to capture data.</td>
</tr>
<tr>
<td>rva_stop</td>
<td>rva_stop</td>
<td>Stops without capturing data.</td>
</tr>
<tr>
<td>rva_manualtrig</td>
<td>rva_manualtrig</td>
<td>Manual Trigger to capture data.</td>
</tr>
<tr>
<td>rva_get_trace</td>
<td>rva_get_trace</td>
<td>Lists all trace signals in a core.</td>
</tr>
<tr>
<td>rva_set_core</td>
<td>rva_set_core [-name &lt;name&gt;] [-run &lt;on</td>
<td>off&gt;]</td>
</tr>
<tr>
<td>rva_set_tu</td>
<td>rva_set_tu [-name &lt;name&gt;] [-operator {==</td>
<td>!=</td>
</tr>
<tr>
<td>rva_rename_tu</td>
<td>rva_rename_tu &lt;name&gt; &lt;new name&gt;</td>
<td>This function renames TU.</td>
</tr>
<tr>
<td>rva_set_te</td>
<td>rva_set_te [-name &lt;name&gt;] [-expression &lt;expression list&gt;] [-enable &lt;on</td>
<td>off&gt;]</td>
</tr>
</tbody>
</table>
**Table 25: Reveal Analyzer Tcl Commands**

<table>
<thead>
<tr>
<th>Command</th>
<th>Function (Argument)</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>rva_rename_te</strong></td>
<td><em>rva_rename_te</em> &lt;name&gt; &lt;new name&gt;</td>
<td>This function renames TE.</td>
</tr>
<tr>
<td><strong>rva_set_trigoptn</strong></td>
<td><em>rva_set_trigoptn</em> [-teall &lt;AND</td>
<td>OR&gt;] [-finalcounter &lt;on</td>
</tr>
<tr>
<td></td>
<td></td>
<td>-teall: Sets AND ALL or OR ALL for all TEs</td>
</tr>
<tr>
<td></td>
<td></td>
<td>-finalcounter: Turns final trigger counter on/off</td>
</tr>
<tr>
<td></td>
<td></td>
<td>-finalcountervalue: Sets final trigger counter value</td>
</tr>
<tr>
<td></td>
<td></td>
<td>-samples: Sets number of samples to capture</td>
</tr>
<tr>
<td></td>
<td></td>
<td>-numtriggers: Sets number of triggers to capture</td>
</tr>
<tr>
<td></td>
<td></td>
<td>-position: Sets trigger position to pre-selected or user value.</td>
</tr>
<tr>
<td><strong>rva_add_token</strong></td>
<td><em>rva_add_token</em> &lt;tokenset name&gt; &lt;name=value&gt;</td>
<td>Add a token with new name and value in a specific token set.</td>
</tr>
<tr>
<td><strong>rva_del_token</strong></td>
<td><em>rva_del_token</em> &lt;tokenset name&gt; &lt;token name&gt;</td>
<td>Delete a specific token in a specific token set.</td>
</tr>
<tr>
<td><strong>rva_set_token</strong></td>
<td><em>rva_set_token</em> &lt;tokenset name&gt; &lt;token name&gt; -name &lt;new token name&gt; -value &lt;new token value&gt;</td>
<td>Select specific token in specific token set.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>-name: Set token name</td>
</tr>
<tr>
<td></td>
<td></td>
<td>-value: Set token value</td>
</tr>
<tr>
<td><strong>rva_add_tokenset</strong></td>
<td><em>rva_add_tokenset</em> [-tokenset &lt;tokenset name&gt;] [-bits &lt;token bits&gt;] [-token &lt;name=value&gt;]</td>
<td>No arguments, add a token set with default name and bits.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>-tokenset: Set token set name</td>
</tr>
<tr>
<td></td>
<td></td>
<td>-bits: Set token set bits</td>
</tr>
<tr>
<td></td>
<td></td>
<td>-token: Add extra tokens</td>
</tr>
<tr>
<td><strong>rva_del_tokenset</strong></td>
<td><em>rva_del_tokenset</em> &lt;tokenset name&gt;</td>
<td>Delete the specific token set.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>-all</td>
</tr>
<tr>
<td><strong>rva_set_tokenset</strong></td>
<td><em>rva_set_tokenset</em> &lt;tokenset name&gt; -name &lt;new token set name&gt; -bits &lt;new token bits&gt;</td>
<td>Select specific token set</td>
</tr>
<tr>
<td></td>
<td></td>
<td>-name: Rename a token set</td>
</tr>
<tr>
<td></td>
<td></td>
<td>-bits: Set number of bits in tokens.</td>
</tr>
<tr>
<td><strong>rva_export_tokenset</strong></td>
<td><em>rva_export_tokenset</em> &lt;file name&gt;</td>
<td>Export all token set to a specific file.</td>
</tr>
<tr>
<td><strong>rva_import_tokenset</strong></td>
<td><em>rva_import_tokenset</em> &lt;file name&gt;</td>
<td>Import and merge all token set from a specific file.</td>
</tr>
<tr>
<td><strong>rva_open_controller</strong></td>
<td><em>rva_open_controller</em></td>
<td>Open Controller connection to Lattice device before read/write begins.</td>
</tr>
<tr>
<td><strong>rva_target_controller</strong></td>
<td><em>rva_target_controller</em></td>
<td>Set Controller core as target before read/write begins.</td>
</tr>
</tbody>
</table>
Table 25: Reveal Analyzer Tcl Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Function (Argument)</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>rva_close_controller</td>
<td>rva_close_controller</td>
<td>Close Controller connection to Lattice device after read/write finished.</td>
</tr>
<tr>
<td>rva_read_controller</td>
<td>rva_read_controller -addr &lt;addr32&gt;</td>
<td>Read data from 32-bit address in hex.</td>
</tr>
<tr>
<td>rva_write_controller</td>
<td>rva_write_controller -addr &lt;addr32&gt; -data &lt;data&gt;</td>
<td>Write data to 32-bit address in hex.</td>
</tr>
</tbody>
</table>
| rva_run_controller   | rva_run_controller -readLed|-read_switch|-write_switch <data>|-dump_memfile <mem_file>|-load_memfile <mem_file>|-read_ip <ipname>|-write_ip <ipname> | Run command for Virtual LED, Virtual Switch, User Register, and Hard IP.  
  -readLed: Read data from Virtual LED.  
  -read_switch: Read data from Virtual Switch.  
  -write_switch: Write data to Virtual Switch.  
  -dump_memfile: Dump data from User Register to mem_file.  
  -load_memfile: Load data from mem_file to User Register.  
  -read_ip: Read data from Hard IP register.  
  -write_ip: Write data to Hard IP register.  |
| rva_set_controller   | rva_set_controller -option <value>            | Set the options for Controller core.                                        
  -cable_type: Set type of cable as USB or USB2.  
  -cable_port: Set logical port of cable as integer.  
  If no arguments specified, then return list of options and values.  |
| rva_export_controller| rva_export_controller <rvc_file>             | Export Controller options to RVC file.                                       |
| rva_import_controller| rva_import_controller <rvc_file>             | Import Controller options from RVC file.                                    |

Reveal Analyzer Tcl Command Examples This section illustrates and describes a few samples of Reveal Analyzer Tcl commands.

Example 1 The following command line example shows how to specify a new project that uses a parallel cable port.

```
rva_new_project -rva untitled -rvl "count.rvl" -dev "LFXP2-5E:0x01299043" -port 888 -cable LATTICE
```

Example 2 The following example shows how to set up TU parameters for Reveal Analyzer:

```
rva_set_tu -name TU1 -operator == -value 10110100 -radix bin
```
Power Calculator Tcl Commands

This section provides Power Calculator extended Tcl command syntax, command options, and usage examples.

**Power Calculator Tcl Command Descriptions** The following table provides a listing of all valid Power Calculator Tcl command options and describes option functionality.

Table 26: Power Calculator Tcl Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Function (Argument)</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>pwc_new_project</code></td>
<td><code>pwc_new_project &lt;file&gt;</code></td>
<td>Create a new project.</td>
</tr>
<tr>
<td><code>pwc_open_project</code></td>
<td><code>pwc_open_project &lt;file&gt;</code></td>
<td>Open a project file.</td>
</tr>
<tr>
<td><code>pwc_save_project</code></td>
<td><code>pwc_save_project &lt;file&gt;</code></td>
<td>Save the current project.</td>
</tr>
<tr>
<td><code>pwc_close_project</code></td>
<td><code>pwc_close_project</code></td>
<td>Close the current project.</td>
</tr>
<tr>
<td><code>pwc_set_afpervcd</code></td>
<td><code>pwc_set_afpervcd &lt;file&gt;</code></td>
<td>Open vcd file and set frequency and activity factor.</td>
</tr>
<tr>
<td><code>pwc_set_device</code></td>
<td><code>pwc_set_device -family &lt;family name&gt;</code></td>
<td>Set family.</td>
</tr>
<tr>
<td></td>
<td><code>pwc_set_device -device &lt;device name&gt;</code></td>
<td>Set device.</td>
</tr>
<tr>
<td></td>
<td><code>pwc_set_device -package &lt;package name&gt;</code></td>
<td>Set package.</td>
</tr>
<tr>
<td></td>
<td><code>pwc_set_device -speed &lt;speed name&gt;</code></td>
<td>Set speed.</td>
</tr>
<tr>
<td></td>
<td><code>pwc_set_device -operating &lt;operating name&gt;</code></td>
<td>Set operating.</td>
</tr>
<tr>
<td></td>
<td><code>pwc_set_device -part &lt;part name&gt;</code></td>
<td>Set part.</td>
</tr>
<tr>
<td><code>pwc_set_processtype</code></td>
<td><code>pwc_set_processtype &lt;value&gt;</code></td>
<td>Set device power process type.</td>
</tr>
<tr>
<td><code>pwc_set_ambienttemp</code></td>
<td><code>pwc_set_ambienttemp &lt;value&gt;</code></td>
<td>Set ambient temperature value.</td>
</tr>
<tr>
<td><code>pwc_set_thetaja</code></td>
<td><code>pwc_set_thetaja &lt;value&gt;</code></td>
<td>Set user defined theta JA.</td>
</tr>
<tr>
<td><code>pwc_set_freq</code></td>
<td><code>pwc_set_freq &lt;frequency&gt;</code></td>
<td>Set default frequency.</td>
</tr>
<tr>
<td></td>
<td><code>pwc_set_freq -clock &lt;frequency&gt;</code></td>
<td>Set Clock frequency.</td>
</tr>
<tr>
<td></td>
<td><code>pwc_set_freq -timing &lt;option&gt;</code></td>
<td>Set frequency by timing.</td>
</tr>
<tr>
<td></td>
<td>option: min</td>
<td>pref</td>
</tr>
<tr>
<td><code>pwc_set_af</code></td>
<td><code>pwc_set_af &lt;value&gt;</code></td>
<td>Set default activity factor.</td>
</tr>
<tr>
<td><code>pwc_set_estimation</code></td>
<td><code>pwc_set_estimation &lt;value&gt;</code></td>
<td>Sets estimated routing option.</td>
</tr>
<tr>
<td><code>pwc_set_supply</code></td>
<td><code>pwc_set_supply -type &lt;value&gt; -voltage &lt;value&gt; -dpm &lt;value&gt;</code></td>
<td>Set multiplication factor and voltage of named power supply.</td>
</tr>
</tbody>
</table>
Power Calculator Tcl Command Examples  This section illustrates and describes a few samples of Power Calculator Tcl commands.

Example 1  The follow command below creates a PWC project (.pcf) file named “abc.pcf” from an input UDB file named “abc.UDB”:

```
pwc_new_project abc.pcf -udb abc.udb
```

Example 2  To set the default frequency to, for example, 100 Mhz:

```
pwc_set_freq 100
```

Example 3  The command below saves the current project to a new name:

```
pwc_save_project newname.pcf
```

Example 4  To create an HTML report, you would run a command like the one shown below:

```
pwc_gen_htmlreport c:/abc.html
```

Programmer Tcl Commands

This section provides the Programmer extended Tcl command syntax, command options, and usage examples. The below commands are only supported in standalone Programmer currently.
Programmer Tcl Command Descriptions  The following table provides a listing of all valid Programmer Tcl command options and describes option functionality.

Table 27: Programmer Tcl Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Function (Argument)</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>pgr_project</td>
<td>pgr_project open &lt;project_file&gt;</td>
<td>The open command will open the specified project file in-memory.</td>
</tr>
<tr>
<td></td>
<td>pgr_project save [&lt;file_path&gt;]</td>
<td>Writes the current project to the specified path. If there is no file path specified then it will overwrite the original file.</td>
</tr>
<tr>
<td></td>
<td>pgr_project close</td>
<td>Closes the current project. If a Programmer GUI is open with the associated project, then the corresponding Programmer GUI will be closed as well.</td>
</tr>
<tr>
<td></td>
<td>pgr_project help</td>
<td>Displays help for the pgr_project command.</td>
</tr>
</tbody>
</table>
This section illustrates and describes a few samples of Programmer Tcl commands.

### Table 27: Programmer Tcl Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Function (Argument)</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>pgr_program</td>
<td>&lt;no_argument&gt;</td>
<td>When pgr_program is run without arguments it will display the current status of the available settings. Note that specifying a key without a value will display the current value. The following keys can be used to modify those settings. Generally, the pgr_program command and its sub-commands allow you to run the equivalent process commands from the TCL Console window in the Radiant software interface. These commands can override connection options that are set in user defaults.</td>
</tr>
<tr>
<td>pgr_program set -cable</td>
<td>&lt;LATTICE</td>
<td>USB</td>
</tr>
<tr>
<td>pgr_program set -portaddress</td>
<td>&lt;0x0378</td>
<td>0x0278</td>
</tr>
<tr>
<td>pgr_program run</td>
<td></td>
<td>Executes the current xcf with the current settings. Note that there may be warnings that are displayed in the TCL Console window. These warnings will be ignored and processing will continue.</td>
</tr>
<tr>
<td>pgr_program help</td>
<td></td>
<td>Displays help for pgr_program command.</td>
</tr>
<tr>
<td>pgr_genfile</td>
<td>&lt;no_argument&gt;</td>
<td>Programmer generate files command (not supported for customer use)</td>
</tr>
<tr>
<td>pgr_genfile set -process</td>
<td>&lt;svf</td>
<td>vme12&gt;</td>
</tr>
<tr>
<td>pgr_genfile set -outfile</td>
<td>&lt;file path&gt;</td>
<td>Sets the output file.</td>
</tr>
<tr>
<td>pgr_genfile run</td>
<td></td>
<td>Generates file based on the current xcf and current settings.</td>
</tr>
<tr>
<td>pgr_genfile help</td>
<td></td>
<td>Displays help for pgr_genfile command.</td>
</tr>
</tbody>
</table>

**Programmer Tcl Command Examples**

This section illustrates and describes a few samples of Programmer Tcl commands.
Example 1  The first command below opens a Programmer XCF project file that exists in the system. There can be many programming files associated with one project. In the GUI interface, the boldfaced file in the Radiant software is the active project file.

```
pgr_project open /home/mdm/config_file/myfile.xcf
```

Example 2  The following command sets programming option using a USB2 cable at port address “FTUSB-1, then using pgr_program run to program”.

```
pgr_program set -cable USB2 -portaddress FTUSB-1
```

Example 3  The following command sets the file generation type for JTAG SVF file, then using pgr_genfile run to generates an output file “mygenfile.svf” in a relative path.

```
pgr_genfile set -process svf -outfile ../genfiles/mygenfile.svf
```

---

**Engineering Change Order Tcl Commands**

This section provides Engineering Change Order (ECO) extended Tcl command syntax, command options, and usage examples.

**ECO Tcl Command Descriptions**  The following table provides a listing of all valid ECO Tcl command options and describes option functionality.

<table>
<thead>
<tr>
<th>Command</th>
<th>Function (Argument)</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>eco_save_design</td>
<td>eco_save_design [-udb &lt;udb_file&gt;]</td>
<td>Saves an existing design or macro.</td>
</tr>
<tr>
<td>eco_config_sysio</td>
<td>eco_config_sysio -comp &lt;comp name&gt; {&lt;key=value&gt;}...</td>
<td>Config sysio setting.</td>
</tr>
<tr>
<td>eco_config_memory</td>
<td>eco_config_memory -mem_id &lt;memory_id&gt; {-init_file &lt;mem_file&gt; -format HEX</td>
<td>BIN</td>
</tr>
</tbody>
</table>

**ECO Tcl Command Examples**  This section illustrates and describes a few samples of ECO Tcl commands.

Example 1  The following demonstrates the sysio command:

```
eco_config_sysio -comp {data}
{clamp=OFF;diffdrive=NA;diffresistor=OFF;drive=2;glitchfilter=OFF;hysteresis=NA;opendrain=OFF;pullmode=NONE;slewrate=SLOW;termination=OFF};vref=OFF}
```
Example 2  The following demonstrates the `memory` command:

```
eco_config_mem -mem_id {mem} -init_file {D:/mem/init_hex.mem}
-format HEX
```
# Revision History

The following table gives the revision history for this document.

<table>
<thead>
<tr>
<th>Date</th>
<th>Version</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>11/05/2020</td>
<td>2.2</td>
<td>Updates for Radiant 2.2 software.</td>
</tr>
<tr>
<td>06/12/2020</td>
<td>2.1</td>
<td>Updates for Radiant 2.1 software.</td>
</tr>
<tr>
<td>02/25/2020</td>
<td>2.0 SP1</td>
<td>Updates for Radiant 2.0 SP1 software.</td>
</tr>
<tr>
<td>12/04/2019</td>
<td>2.0</td>
<td>Updates for Radiant 2.0 software.</td>
</tr>
<tr>
<td>03/29/2019</td>
<td>1.1</td>
<td>Updates for Radiant 1.1 software.</td>
</tr>
<tr>
<td>02/13/2018</td>
<td>1.0</td>
<td>Initial Release.</td>
</tr>
</tbody>
</table>