Copyright
This document may not, in whole or part, be copied, photocopied, reproduced, translated, or reduced to any electronic medium or machine-readable form without prior written consent from Lattice Semiconductor Corporation.

The software described in this manual is copyrighted and all rights are reserved by Lattice Semiconductor Corporation. Information in this document is subject to change without notice.

The distribution and sale of this product is intended for the use of the original purchaser only and for use only on the computer system specified. Lawful users of this product are hereby licensed only to read the programs on the disks, cassettes, or tapes from their medium into the memory of a computer solely for the purpose of executing them. Unauthorized copying, duplicating, selling, or otherwise distributing this product is a violation of the law.

Trademarks
The following trademarks are recognized by Lattice Semiconductor Corporation:

Generic Array Logic, ISP, ispANALYZER, ispATE, ispCODE, ispDCD, ispDOWNLOAD, ispDS, ispDS+, ispEXPERT, ispGDS, ispGDX, ispHDL, ispJTAG, ispSmartFlow, ispStarter, ispSTREAM, ispTA, ispTEST, ispTURBO, ispVECTOR, ispVerilog, ispVHDL, Latch-Lock, LHDL, pDS+, RFT, and Twin GLB are trademarks of Lattice Semiconductor Corporation.

E²CMOS, GAL, ispGAL, ispLSI, pDS, pLSI, Silicon Forest, and UltraMOS are registered trademarks of Lattice Semiconductor Corporation.

Project Navigator is a trademark of Data I/O Corporation.

ABEL-HDL is a registered trademark of Data I/O Corporation.

Microsoft, Windows, and MS-DOS are registered trademarks of Microsoft Corporation.

IBM is a registered trademark of International Business Machines Corporation.

Lattice Semiconductor Corporation
5555 NE Moore Ct.
Hillsboro, OR 97124
(503) 681-0118

September 1998
Limited Warranty

Lattice Semiconductor Corporation warrants the original purchaser that the Lattice Semiconductor software shall be free from defects in material and workmanship for a period of ninety days from the date of purchase. If a defect covered by this limited warranty occurs during this 90-day warranty period, Lattice Semiconductor will repair or replace the component part at its option free of charge.

This limited warranty does not apply if the defects have been caused by negligence, accident, unreasonable or unintended use, modification, or any causes not related to defective materials or workmanship.

To receive service during the 90-day warranty period, contact Lattice Semiconductor Corporation at:

Phone: 1-800-LATTICE
Fax: (408) 944-8450
E-mail: applications@latticesemi.com

If the Lattice Semiconductor support personnel are unable to solve your problem over the phone, we will provide you with instructions on returning your defective software to us. The cost of returning the software to the Lattice Semiconductor Service Center shall be paid by the purchaser.

Limitations on Warranty

Any applicable implied warranties, including warranties of merchantability and fitness for a particular purpose, are hereby limited to ninety days from the date of purchase and are subject to the conditions set forth herein. In no event shall Lattice Semiconductor Corporation be liable for consequential or incidental damages resulting from the breach of any expressed or implied warranties.

Purchaser’s sole remedy for any cause whatsoever, regardless of the form of action, shall be limited to the price paid to Lattice Semiconductor for the Lattice Semiconductor software.

The provisions of this limited warranty are valid in the United States only. Some states do not allow limitations on how long an implied warranty lasts, or exclusion of consequential or incidental damages, so the above limitation or exclusion may not apply to you.

This warranty provides you with specific legal rights. You may have other rights which vary from state to state.
# Table of Contents

**Preface** ......................................................... 6

**Add Menu** .......................................................... 12
  Add ⇒ Arc ......................................................... 13
  Add ⇒ Bubble/Big Bubble ........................................ 14
  Add ⇒ Bus Tap .................................................... 15
  Add ⇒ Circle ...................................................... 16
  Add ⇒ Expanded Bus Name ....................................... 17
  Add ⇒ I/O Marker ................................................ 18
  Add ⇒ Instance Name ............................................. 19
  Add ⇒ Line ......................................................... 22
  Add ⇒ Net Name .................................................. 23
  Add ⇒ New Block Symbol ....................................... 28
  Add ⇒ Pin .......................................................... 30
  Add ⇒ Rectangle ................................................ 31
  Add ⇒ Symbol ..................................................... 32
  Add ⇒ Table ....................................................... 35
  Add ⇒ Text ........................................................ 39
  Add ⇒ Wire ......................................................... 40

**Edit Menu** .......................................................... 42
  Edit ⇒ Attribute ⇒ Attribute Location ....................... 43
  Edit ⇒ Attribute ⇒ Attribute Window ......................... 45
  Edit ⇒ Attribute ⇒ Pin Name Location ......................... 47
  Edit ⇒ Attribute ⇒ Pin Attribute ............................... 48
  Edit ⇒ Attribute ⇒ Symbol Attribute .......................... 49
  Edit ⇒ Attribute ⇒ Net Attribute ............................... 52
  Edit ⇒ Attribute ⇒ Net Attribute Window .................... 54
  Edit ⇒ Expand Page ............................................... 55
  Edit ⇒ Symbol Type ............................................... 56
  Edit ⇒ Constants ................................................. 57
  Edit ⇒ Copy ......................................................... 58
  Edit ⇒ Copy Image ................................................ 60
  Edit ⇒ Cut ........................................................ 61
  Edit ⇒ Delete ..................................................... 62
  Edit ⇒ Drag ........................................................ 64
  Edit ⇒ Duplicate .................................................. 66
  Edit ⇒ Mirror ...................................................... 68

Schematic Entry Reference Manual
Edit ⇒ Paste ........................................................................................................ 69
Edit ⇒ Redo ......................................................................................................... 70
Edit ⇒ Rotate ...................................................................................................... 71
Edit ⇒ Schematic ................................................................................................. 72
Edit ⇒ Symbol Origin ........................................................................................... 73
Edit ⇒ Symbol ...................................................................................................... 74
Edit ⇒ Table Data ................................................................................................. 75
Edit ⇒ Undo .......................................................................................................... 76

File Menu ........................................................................................................... 77
File ⇒ New ........................................................................................................... 78
File ⇒ Open .......................................................................................................... 79
File ⇒ Print ........................................................................................................... 80
File ⇒ Print Image ................................................................................................. 81
File ⇒ Print Setup ................................................................................................. 82
File ⇒ Restart ....................................................................................................... 83
File ⇒ Save ........................................................................................................... 84
File ⇒ Save As ....................................................................................................... 85
File ⇒ Sheets ........................................................................................................ 86
File ⇒ Statistics ................................................................................................... 89
File ⇒ View Report ............................................................................................... 91

Help Menu .......................................................................................................... 92

DRC Menu ........................................................................................................ 93
DRC ⇒ Highlight ................................................................................................. 94
DRC ⇒ Mark ......................................................................................................... 95
DRC ⇒ Query ....................................................................................................... 96
DRC ⇒ Consistency Check .................................................................................. 100
DRC ⇒ Check Circuit .......................................................................................... 102

Option Menu ..................................................................................................... 103
Options ⇒ Display Options .................................................................................. 104
Options ⇒ Graphic Options .................................................................................. 106

Tools Menu ........................................................................................................ 108
Tools ⇒ Find Item ................................................................................................. 109
Tools ⇒ Probe Item ............................................................................................... 110

View Menu ......................................................................................................... 111
View ⇒ Full Fit ..................................................................................................... 112
View ⇒ Pan ........................................................................................................... 113
View ⇒ Push/Pop ................................................................................................. 114
View ⇒ Redraw ................................................................................................... 115
View ⇒ Zoom In ................................................................................................. 116
View ⇒ Zoom Out ............................................................................................... 117
This manual provides a detailed explanation of the Symbol Editor, Schematic Editor, and Hierarchy Navigator commands. The following topics are discussed:

- Purpose and Scope
- Documentation Conventions
- Quick Command Reference
Purpose and Scope

The Schematic Entry Reference Manual documents the command reference in the Symbol Editor, Schematic Editor, and Hierarchy Navigator. This manual provides the following information about each command:

- **Menu ⇒ Command**: The menu command.
- **Description**: What the command is.
- **Use**: Intended use of the command.
- **See Also**: References to other commands.
Documentation Conventions

The following conventions are used:

- Commands are listed in alphabetical order by menu, then command.
- Many commands have a keyboard accelerator key. This key is shown in the following quick-reference table, as well as on the top line of each command.
- The abbreviations Sch, Sym, and Nav at the right of the header indicate which program(s) the command appears in. If a command appears in a different menu in one of the programs, the alternate menu is shown in parentheses.

For example, the Symbol Attribute command appears in the Edit menu of the Schematic Editor and the Hierarchy Navigator. The right side of the header for the Add menu listing shows:

Sch, Nav (Edit)

The figure below explains how the commands are shown in the reference.

**Add ⇒ Pin Attribute**

<table>
<thead>
<tr>
<th>Menu</th>
<th>Command</th>
<th>Keyboard shortcut</th>
<th>Program(s) in which command appears</th>
<th>The Menu the Command is under in the Hierarchy Navigator</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add</td>
<td>Pin Attribute</td>
<td>F3</td>
<td>Sch, Sym, Nav (Edit)</td>
<td></td>
</tr>
</tbody>
</table>
# Quick Command Reference

The following table gives a brief description of each command and its accelerator and program(s) which command appears.

<table>
<thead>
<tr>
<th>Menu ⇒ Command</th>
<th>Accelerator</th>
<th>Program</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add ⇒ Arc</td>
<td>F4</td>
<td>Sch, Sym</td>
</tr>
<tr>
<td>Add ⇒ Bubble/Big Bubble</td>
<td></td>
<td>Sym</td>
</tr>
<tr>
<td>Add ⇒ Bus Tap</td>
<td></td>
<td>Sch</td>
</tr>
<tr>
<td>Add ⇒ Circle</td>
<td></td>
<td>Sch, Sym</td>
</tr>
<tr>
<td>Add ⇒ Expanded Bus Name</td>
<td></td>
<td>Sch</td>
</tr>
<tr>
<td>Add ⇒ I/O Marker</td>
<td>Alt+M</td>
<td>Sch</td>
</tr>
<tr>
<td>Add ⇒ Instance Name</td>
<td></td>
<td>Sch</td>
</tr>
<tr>
<td>Add ⇒ Line</td>
<td>Ctrl+L</td>
<td>Sch, Sym</td>
</tr>
<tr>
<td>Add ⇒ Net Name</td>
<td>F4</td>
<td>Sch</td>
</tr>
<tr>
<td>Add ⇒ New Block Symbol</td>
<td></td>
<td>Sch</td>
</tr>
<tr>
<td>Add ⇒ Pin</td>
<td>F2</td>
<td>Sym</td>
</tr>
<tr>
<td>Add ⇒ Rectangle</td>
<td></td>
<td>Sch, Sym</td>
</tr>
<tr>
<td>Add ⇒ Symbol</td>
<td>F2</td>
<td>Sch</td>
</tr>
<tr>
<td>Add ⇒ Table</td>
<td></td>
<td>Sch</td>
</tr>
<tr>
<td>Add ⇒ Text</td>
<td></td>
<td>Sch, Sym</td>
</tr>
<tr>
<td>Add ⇒ Wire</td>
<td>F3</td>
<td>Sch</td>
</tr>
<tr>
<td>Edit ⇒ Attribute ⇒</td>
<td></td>
<td>Sch</td>
</tr>
<tr>
<td>Attribute Location</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Edit ⇒ Attribute ⇒</td>
<td>F4</td>
<td>Sym</td>
</tr>
<tr>
<td>Attribute Window</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Edit ⇒ Attribute ⇒</td>
<td>Ctrl+P</td>
<td>Nav, Sch (Add)</td>
</tr>
<tr>
<td>Pin Name Location</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Edit ⇒ Attribute ⇒</td>
<td>Ctrl+A</td>
<td>Nav, Sch (Add)</td>
</tr>
<tr>
<td>Symbol Attribute</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Edit ⇒ Attribute ⇒</td>
<td>Ctrl+A</td>
<td>Nav, Sch (Add)</td>
</tr>
<tr>
<td>Net Attribute</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Edit ⇒ Attribute ⇒</td>
<td>F4</td>
<td>Nav, Sch</td>
</tr>
<tr>
<td>Net Attribute Window</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Edit ⇒ Expand Page</td>
<td></td>
<td>Sym</td>
</tr>
<tr>
<td>Edit ⇒ Symbol Type</td>
<td></td>
<td>Sym</td>
</tr>
<tr>
<td>Menu  ⇒  Command</td>
<td>Accelerator</td>
<td>Program</td>
</tr>
<tr>
<td>---------------------------</td>
<td>-------------</td>
<td>------------------</td>
</tr>
<tr>
<td>Edit  ⇒  Constants</td>
<td></td>
<td>Nav</td>
</tr>
<tr>
<td>Edit  ⇒  Copy</td>
<td>Ctrl+C</td>
<td>Sch, Sym</td>
</tr>
<tr>
<td>Edit  ⇒  Copy Image</td>
<td></td>
<td>Sch, Sym, Nav</td>
</tr>
<tr>
<td>Edit  ⇒  Cut</td>
<td>Ctrl+X</td>
<td>Sch, Sym</td>
</tr>
<tr>
<td>Edit  ⇒  Delete</td>
<td>F5</td>
<td>Sch, Sym</td>
</tr>
<tr>
<td>Edit  ⇒  Drag</td>
<td>F8</td>
<td>Sch, Sym</td>
</tr>
<tr>
<td>Edit  ⇒  Duplicate</td>
<td>F6</td>
<td>Sch, Sym</td>
</tr>
<tr>
<td>Edit  ⇒  Mirror</td>
<td>Ctrl+E</td>
<td>Sch, Sym</td>
</tr>
<tr>
<td>Edit  ⇒  Move</td>
<td>F7</td>
<td>Sch, Sym</td>
</tr>
<tr>
<td>Edit  ⇒  Paste</td>
<td>Ctrl+V</td>
<td>Sch, Sym</td>
</tr>
<tr>
<td>Edit  ⇒  Redo</td>
<td>Shift+F9</td>
<td>Sch, Sym</td>
</tr>
<tr>
<td>Edit  ⇒  Rotate</td>
<td>Ctrl+R</td>
<td>Sch, Sym</td>
</tr>
<tr>
<td>Edit  ⇒  Schematic</td>
<td></td>
<td>Sym, Nav</td>
</tr>
<tr>
<td>Edit  ⇒  Symbol Origin</td>
<td></td>
<td>Sch</td>
</tr>
<tr>
<td>Edit  ⇒  Symbol</td>
<td></td>
<td>Sch, Sym</td>
</tr>
<tr>
<td>Edit  ⇒  Table Data</td>
<td></td>
<td>Sch</td>
</tr>
<tr>
<td>Edit  ⇒  Undo</td>
<td>F9</td>
<td>Sch, Sym</td>
</tr>
<tr>
<td>File  ⇒  Back Annotate</td>
<td></td>
<td>Nav</td>
</tr>
<tr>
<td>File  ⇒  Exit</td>
<td></td>
<td>Sch, Sym, Nav</td>
</tr>
<tr>
<td>File  ⇒  Matching Symbol</td>
<td></td>
<td>Sch</td>
</tr>
<tr>
<td>File  ⇒  New</td>
<td></td>
<td>Sch, Sym</td>
</tr>
<tr>
<td>File  ⇒  Open</td>
<td></td>
<td>Sch, Sym, Nav</td>
</tr>
<tr>
<td>File  ⇒  Print</td>
<td></td>
<td>Sch, Sym, Nav</td>
</tr>
<tr>
<td>File  ⇒  Print Image</td>
<td></td>
<td>Sch, Sym, Nav</td>
</tr>
<tr>
<td>File  ⇒  Print Setup</td>
<td></td>
<td>Sch, Sym, Nav</td>
</tr>
<tr>
<td>File  ⇒  Restart</td>
<td></td>
<td>Nav</td>
</tr>
<tr>
<td>File  ⇒  Save</td>
<td>Ctrl+S</td>
<td>Sch, Sym, Nav</td>
</tr>
<tr>
<td>File  ⇒  Save As</td>
<td></td>
<td>Sch, Sym, Nav</td>
</tr>
<tr>
<td>File  ⇒  Sheets</td>
<td></td>
<td>Sch</td>
</tr>
<tr>
<td>Menu ⇒ Command</td>
<td>Accelerator</td>
<td>Program</td>
</tr>
<tr>
<td>----------------------------------</td>
<td>-------------</td>
<td>-------------</td>
</tr>
<tr>
<td>File ⇒ Statistics</td>
<td></td>
<td>Sch, Nav</td>
</tr>
<tr>
<td>File ⇒ View Report</td>
<td></td>
<td>Nav</td>
</tr>
<tr>
<td>Help Menu</td>
<td></td>
<td></td>
</tr>
<tr>
<td>DRC ⇒ HiLight</td>
<td></td>
<td>Sch</td>
</tr>
<tr>
<td>DRC ⇒ Mark</td>
<td>F3</td>
<td>Nav</td>
</tr>
<tr>
<td>DRC ⇒ Query</td>
<td>Ctrl+Q</td>
<td>Sch, Nav</td>
</tr>
<tr>
<td>DRC ⇒ Consistency Check</td>
<td></td>
<td>Sch</td>
</tr>
<tr>
<td>DRC ⇒ Check Circuit</td>
<td></td>
<td>Nav</td>
</tr>
<tr>
<td>Options ⇒ Display Options</td>
<td></td>
<td>Sch, Nav</td>
</tr>
<tr>
<td>Options ⇒ Graphic Options</td>
<td>Ctrl+G</td>
<td>Sch, Sym</td>
</tr>
<tr>
<td>Tools ⇒ Find Item</td>
<td></td>
<td>Nav</td>
</tr>
<tr>
<td>Tools ⇒ Probe Item</td>
<td></td>
<td>Nav</td>
</tr>
<tr>
<td>View ⇒ Full Fit</td>
<td>Ctrl+F</td>
<td>Sch, Sym, Nav</td>
</tr>
<tr>
<td>View ⇒ Pan</td>
<td>Ctrl+W</td>
<td>Sch, Sym, Nav</td>
</tr>
<tr>
<td>View ⇒ Push/Pop</td>
<td>F2</td>
<td>Nav</td>
</tr>
<tr>
<td>View ⇒ Redraw</td>
<td></td>
<td>Sch, Sym, Nav</td>
</tr>
<tr>
<td>View ⇒ Zoom In</td>
<td></td>
<td>Sch, Sym, Nav</td>
</tr>
<tr>
<td>View ⇒ Zoom Out</td>
<td></td>
<td>Sch, Sym, Nav</td>
</tr>
</tbody>
</table>
Add Menu

This chapter contains information on the following menu items:

- Add ⇒ Arc
- Add ⇒ Bubble/Big Bubble
- Add ⇒ Bus Tap
- Add ⇒ Circle
- Add ⇒ Expanded Bus name
- Add ⇒ I/O marker
- Add ⇒ Instance Name
- Add ⇒ Line
- Add ⇒ Net name
- Add ⇒ New Block Symbol
- Add ⇒ Pin
- Add ⇒ Rectangle
- Add ⇒ Symbol
- Add ⇒ Table
- Add ⇒ Text
- Add ⇒ Wire
**Add ⇒ Arc**

**Description**

Adds arcs to the drawing. These arcs are graphic only and have no electrical meaning in either the schematic or symbol.

**Use**

An arc is drawn from a starting to an ending point. These points can be defined by either clicking or dragging:

**Click**

Point the cursor at the starting point of the arc and click. Move the mouse to the end point and click again.

**Drag**

Drag the mouse from the starting point to the end point, then release the button.

In either case, you see a “rubber-band” arc that starts and ends on the selected points and passes through the cursor. Move the cursor to change the shape of the arc. When the arc has the shape you want, click to add the arc to the drawing. If you decide not to draw the arc, click right anywhere in the window to discard the selected points and restart the command.

If you move the cursor outside the sheet's border, the arc disappears until you move the cursor inside.

The start and end points must fall on the grid. If the Primary grid is not fine enough, use the Graphic Options command from the Options menu to choose half- or quarter-grid resolution.
Add ⇒ Bubble/Big Bubble

**Description**

Add “negation bubbles” to symbols. They are graphic and have no electrical meaning.

**Use**

The Big Bubble command draws a bubble one major grid in diameter. The Bubble command draws a bubble one-half a major grid in diameter. A bubble of the selected size is attached to the cursor. Click to add a bubble.

For the Bubble commands, the cursor tracks a finer grid. The grid selected is the smaller of the bubble’s radius or half the currently active grid. For more precise positioning, use the Graphic Options command from the Options menu to choose half- or quarter-grid resolution.
Add ⇒ Bus Tap

Description

A bus tap is the point at which a signal enters or leaves a bus. The Bus Tap command creates a bus tap from an existing named signal, or a signal that can be named at a later time.

The tap is shown as a small triangle on the side of the bus, with a signal wire leaving the triangle perpendicular to the bus. Each signal tapped from a bus should have a net name to identify it.

Use

Bus taps can be made only on vertical or horizontal sections of a bus. A tap cannot be made on a diagonal section.

To create a tap:
1. Select the Bus Tap command.
2. Click on the bus or wire at the location you want the tap to originate. If a tap is made from a wire, that wire is promoted to a bus.
3. Click at the desired end point. The tap is drawn from the bus to this point.

Once a tap has been added, you can use the Wire command to extend the connection to a symbol pin, net name, or another net.

The Net Name command can be used to create bus taps because it simultaneously places the tap, a wire, and the net name.

See Also

Add ⇒ Net name
Add ⇒ Wire
Add ⇒ Circle  Sch, Sym

Description

Draws circles. They are graphic and have no electrical meaning. You can draw as many circles as you want until you select another command.

Use

This command operates in both click and drag modes.

Click
1. Click at the desired center of the circle.
2. Move the cursor to set the size of the radius.
3. Click again to draw the circle.

Drag
1. Position the cursor at a point on the circumference of the circle.
2. Drag the mouse. The diameter of the circle is the distance between the first point and the cursor. The center of the circle is the mid-point of the line joining the first point to the cursor.
3. Release the button to draw the circle.

The points that define the circle can only be placed on a grid point. If the Primary grid is not fine enough, use the Graphic Options command from the Options menu to choose half- or quarter-grid resolution.
Add ⇒ Expanded Bus Name

Description

Breaks a bus name attached to the cursor into its constituent signal names. Each successive element of the bus is then attached to the cursor as you click on the bus elements to name them.

Use

This command is available only when the Net Name command is active and there is a bus name attached to the cursor. Use the following procedure to expand a bus name:

1. Use the Net Name command to attach a compound name (bus name) to the cursor.
2. Select the Expanded Bus Name command, or click right anywhere in the window. The first element of the bus is now attached to the cursor, ready for placement. (See the Net Name command for details on net name placement.)
3. After you place the first bus element, the second is attached to the cursor. This continues until all individual elements of the compound name have been extracted and placed on the schematic.

See Also

Add ⇒ Net Name
Add ⇒ I/O Marker

Alt+M Sch

Description

An I/O marker is a special indicator attached to a net name that identifies it as an input, output, or bidirectional signal. All primary inputs and outputs must be marked with I/O markers. In hierarchical designs, all schematics must have I/O markers whose names and polarities match those assigned to the pins of the corresponding symbol.

The Schematic Editor Consistency Check command uses I/O markers to ensure that the polarity of marked signals agrees with the polarity of any corresponding symbol pins. Any discrepancies are displayed. Discrepancies in polarity are also displayed each time you use the Hierarchy Navigator.

Use

To mark a net as input, output, or bidirectional:
1. Select the I/O Marker command. Then:
2. Select the appropriate polarity from the pop-up dialog box (Figure 1). Or select None to remove the marker.
3. Click on the net name at the end of a horizontal or vertical wire segment or bus. (Several markers can be placed (or removed) at one time by dragging a box around the wire ends that are to receive markers.)

An I/O marker can only be added to flags at the end of a horizontal or vertical wire segment. A net should have only one I/O marker in the schematic.

Figure 1. I/O Markers Dialog Box

See Also

Add ⇒ Net Name
Add ⇒ Instance Name

**Description**

Each symbol instance must have a unique reference name. The Schematic Editor automatically assigns names to unnamed symbols each time the schematic is saved. These names are of the form $I_n$, where $n$ is an integer between 1 and $2^{32} - 1$ (4,294,967,295).

The Instance Name command lets you assign your own instance names. An instance name can be any alphanumeric sequence of up to 80 characters (including all-number sequences). Names are not case-sensitive.

**Use**

You are prompted for an instance name. Type in the name, then press Enter. The name is now attached to the cursor. (If your instance name is already in use, you will receive the error message “Name Already Assigned to Another Instance.”)

Click on an instance to attach the name. If the instance already has a name, the new name will overwrite it. You are then prompted for another instance name. The Instance Name command remains active until you select another command.

The Editor always checks to be sure the name is not already used. If it is, you will receive an error message and be prompted for a new name.

If you decide not to place the name, or want to change it, click right anywhere in the window. The name is removed from the cursor and you are prompted for a new name.

Instance Name is most often used to add a single name. You can also add a sequence of names, such as INV4, INV5, INV6, ... This is called *auto-increment* mode.

*To use auto-increment mode to add instance names:*

1. Type the prefix, the first sequence number, and a plus sign without spaces or tabs. For example, INV4+. Then press Enter.

2. Click on the first instance. This attaches the instance name, consisting of the prefix name and the first number in the sequence (for example, INV4). If the name is already assigned elsewhere, the number increments to the next unused number.

3. Click on each additional instance in the sequence. The next name in the sequence is attached to the cursor after each placement (in this example, INV5, INV6, INV7, ...).

4. To terminate auto-increment, click right anywhere in the window. You can then enter a new instance name.
Iterated Instances

Add ⇒ Instance Name can also be iterated (automatically generate an array of instances), even though only a single symbol is shown in the schematic. Only Block, Cell, and Component symbol instances can be iterated. (The count of the instances is specified by assigning an instance name of the form name\[x:z\], where \(x\) and \(z\) are the beginning and ending values of the desired range of values separated by a colon.)

To create an array of eight inverters:
1. Type in the base or prefix name, such as INV.
2. Add a numerical sequence in brackets, such as [8:15].
3. Press ENTER. The expression is attached to the cursor.
4. Click on the desired instance.

The example of INV[8:15] now represents a bank of eight inverters with the names INV[8], INV[9], INV[10], ... INV[15]. This is a compact notation for representing bit-slice structures.

Even though only one inverter is displayed, the Schematic Editor has placed eight inverters. You can push into an inverter instance in the Hierarchy Navigator by selecting the inverter name. For example, if you are viewing the iterated instance INV[8:15], you can push into INV[9]. This also allows you to change the attributes of individual members.

Connections to the pins of iterated instances are made according to the following rules:

<table>
<thead>
<tr>
<th>Connection</th>
<th>Rule</th>
</tr>
</thead>
<tbody>
<tr>
<td>Simple net to simple pin</td>
<td>The net connects to corresponding pin on each instance.</td>
</tr>
<tr>
<td>Bus to bus pin</td>
<td>Successive bus signals connect to successive bus pins on each instance. The bus and bus pin must have the same number of nets.</td>
</tr>
<tr>
<td>Simple net to bus pin</td>
<td>Not permitted. Only a bus can connect to a bus pin.</td>
</tr>
<tr>
<td>Bus to scalar pin</td>
<td>The (N)th signal of the bus connects to the scalar pin of the (N)th instance. The width of the bus and the number of instances must match.</td>
</tr>
</tbody>
</table>
To assign reference designators to iterated component symbols, provide a comma- or blank-delimited list of reference designators as the reference designator attribute on the iterated symbol. A sequence of reference designators can be included by enclosing the numeric range in parentheses () or brackets [ ].

For example, instance name C[1:20] specifies 20 iterations of a symbol. Reference designator C1,C3,C(5:20),C22,C24 assigned to the symbol causes the 20 iterations to be assigned the reference designators: C1, C3, C5, C6, C7–C20, C22, C24.
Add ⇒ Line

Description

Adds line segments to the drawing. These line segments are graphic and have no electrical meaning in the schematic or symbol. You can draw as many lines as you want until you select another command.

Use

The Line command operates in either click or drag mode.

Click
1. Click where you want the line to start.
2. Each subsequent click adds a single line segment. The segment can be placed only at 45° increments.
3. Terminate the line by clicking left a second time at the last point, or clicking right anywhere in the window.

Drag
4. Drag the mouse from the starting point of the line to its end point. The line can be at any angle, not just at 45° increments.
5. Release the button. A line is drawn between the two points.

Lines can be drawn only between grid points. If the regular grid is not fine enough to let you position the line as you want, use the Graphic Options command from the Options menu to choose half- or quarter-grid resolution.
Add ⇒ Net Name

Description

Each net must have a unique reference name. The Schematic Editor automatically assigns names to unnamed nets each time the schematic is saved. These names are of the form N\_n, where n is an integer between 1 and 2^{32} – 1 (4,294,967,295).

The Net Name command lets you assign your own net names. Only alphanumeric characters are allowed (except in compound bus names or iterated instances). Names can start with numbers or contain all numbers. (If you check the First Character Must be Alphabetic box in the System Controls dialog box of the INI Editor, the first character cannot be a number. If you check Coerce Net Names To uppercase, all characters are converted to uppercase.) You can use any mixture of upper- and lowercase for readability.

Simple and Compound Names

A simple name is a single name that represents a single signal. A simple name can be no more than 64 characters. Examples of simple names are:

- READ
- WRITE
- MYGOODNESSTHISISALONGSIMPLENAME

Compound names are used to name buses. A compound name can be a list containing more than one net name, separated by commas. For example:

- READ, WRITE, MYNAME

which represents the three signals READ, WRITE, and MYNAME. Spaces within compound names are ignored.

You can also create a compound name by appending a numerical sequence to a simple name. The sequence is specified as a starting number, an ending number, and an optional increment (default = 1). The numbers are positive integers and are delimited by commas (,), dashes (–), or semicolons (:). The sequence can be enclosed in parentheses ( ), brackets [ ], or curly braces { }.

The following are examples of sequential names.

- ADDR(0,14,2) represents ADDR(0) ADDR(2) ADDR(4) ADDR(14)
- ZIPPY(0:15:2) represents ZIPPY(0) ZIPPY(2) ZIPPY(4) ZIPPY(14)

If the increment is greater than one, and the ending number does not equal the starting number plus an integral multiple of the increment, the sequence might not include the ending number (as in the third example above).

A compound name can itself be a list of sequences. For example:

- CLOCK, ADDR[0–7], DATA(0:7) represents
- CLOCK ADDR[0] ADDR[7] DATA(0) DATA(7)
Entering the Net Name

There are two ways to enter net names.

■ Single or compound names can be entered from the keyboard. Or ...
■ A name can be copied from an existing net or bus by clicking on the wire.

Once the name is attached to the cursor, it is placed by clicking on the selected wire. A compound name promotes a net to a bus. (The constituent signals of the bus are the individual signals obtained by expanding the compound name.)

A compound name can be very long. Long names can be wrapped onto several lines using a backslash (\) as the continuation character. The backslash replaces a comma (,) in the compound name at the point you want the line to break. This multi-line naming is only available on net names at right or left ends of buses. The following example shows how the compound name is entered to achieve the multi-line effect:

A_NAME\ANOTHER\DATA[0-3]\AND,MORE\LAST

This results in the net name below, where the net extends to the right:

A_NAME    --\  
ANOTHER    ----\  
DATA[0-3]  ----->----------
AND,MORE   ---/  
LAST       --/  

Attaching the Net Name

Once a name (or sequence of names) has been entered, the name (or the first name in sequence) is attached to the cursor. There are three ways to place the net name:

■ Click on an empty point to place a net name flag. Note that this is will be an error in the completed schematic unless a wire is eventually connected to the name.
■ Click on a wire. A name placed at the end of a wire is left- or right-justified. A name in the middle of a wire is centered.

The position of the name is determined by the segment ends. If both ends are connected, the name is placed in the middle. If neither end of the segment is connected, the name is placed at the starting point. If only one end of the segment is connected, the name is placed at the unconnected end.
■ Drag the mouse to simultaneously add a single wire segment and its name to a pin, wire, or bus. If either end of the segment connects to a perpendicular wire or bus, a bus tap is created at that end. If the wire was not a bus, it is promoted to a bus.
Once you have dragged the mouse to or from a pin, you can place subsequent wires and names by clicking on a pin. (You don't need to drag.) A wire segment the same length as previously created is added, with the name attached as above.

**Attaching Names Sequentially**

If the net name is a compound name, you can attach the individual names sequentially to individual wires. After entering the name, select the Expanded Bus Name from the Add menu, or click right anywhere in the Editor's window. As you click on wires, the individual names from the compound name are added sequentially. Click right at any time to cancel the operation.

You can also add a sequence of names for non-compound nets, such as NET4, NET5, NET6, .... This is called *auto-increment* mode.

*To use auto-increment mode to add net names:*

1. Type the prefix, the first sequence number, and a plus sign without spaces or tabs separating them. For example, NET4+. Then press Enter.
2. Click on the first net. This attaches the net name, consisting of the prefix name and the first number in the sequence (for example, NET4). The number increments to the next number.
3. Click on each additional instance in the sequence. The next name in the sequence is attached to the cursor after each placement (in this example, NET5, NET6, NET7, ...).
4. To terminate auto-increment, click right anywhere in the window. You can then enter a new net name.

Regardless of how you attach the name, the Schematic Editor highlights the net you are attaching the name to when you click.

The Net Name command remains active, prompting for the next name, until you select a different command.

**Renaming a Net**

*To rename all branches of a net, across all sheets:*

1. Select the Net command, or click right to restart the command (if it is already selected).
2. Type the new net name and press ENTER.
3. Hold down SHIFT and click on the net to be renamed. The net is automatically renamed on all sheets.

Be sure to click directly on the name to avoid an error. An error is also flagged if you try to rename a branch that has been named at more than one point. (You must remove the extra names before you can rename the branch.)
If the net to be renamed has an I/O marker:
- The I/O marker is kept if you hold down SHIFT to rename all branches of the net.
- The I/O marker is removed if you only click to rename an individual branch.

**Editing Existing Net Names**

You can also edit net names with the Net Name command.

*To edit a net name:*
1. Select the Net Name command, or if it's already active, click right anywhere on the screen to restart it. Then:
2. Hold down SHIFT and click on the net whose name you want to edit. The name of the net is placed on the prompt line.
3. Edit the name using the BACKSPACE, DELETE, and ARROW keys. Press Enter when you have the name the way you want it.
4. The edited name is then attached to the cursor and can be placed on the schematic in the ways described above.

**Global Net Names**

Global signals can be accessed from all schematics and hierarchy levels in a design. Names assigned as global signals cannot, therefore, be used as local signal names. shows the Global Signals dialog box in the INI Editor.

You can choose from three different types of global signals. They are:

**Unlabeled Symbol**

You can attach a single name to each symbol in columns 1 and 3 of Figure 2. When you name a net with one of these names, the corresponding symbol is attached to the net. The name is not shown. The symbol is the only external indication of the net name. Use the Query command to view the name.

The selection of unlabeled symbols is limited to the power and ground symbols shown in columns 1 and 3 of Figure 2.
Figure 2. Global Nets Dialog Box

**Labeled Symbol**

You can attach one or more names to the symbols in columns 2 and 4 of the global signal editor. These names are separated with spaces, not commas. When a net is assigned one of these names, the corresponding symbol is attached to the net. (The symbol will be displayed only if the net is a vertical wire whose upper end is free (for VCC or VDD) or whose lower end is free (for GND).) The “T” or “TTT” in a symbol is replaced with the actual net name.

The selection of named symbols is limited to the power and ground symbols shown in columns 2 and 4 of Figure 2.

**No Symbol**

You can attach names to the box containing “TTT” at the center top of the global signal editor. These names are global at all hierarchy levels. The name appears attached to the net.

Global supply symbols are drawn only at the top of vertical wires. Global ground symbols are drawn only at the bottom of vertical wires. In all other cases, global signals are shown with their names inside a box, like `net_name`.

**See Also**

Add ⇒ Bus Tap
Add ⇒ Expanded Bus Name
Add ⇒ New Block Symbol

Description

Complex or repeated sections of circuitry are often represented as hierarchical blocks to simplify a schematic. The New Block Symbol command is a quick and efficient way to create symbols for these blocks without leaving the Schematic Editor.

All Block symbols have the same basic design: a rectangle with pin leads extending outward. Input pins are on the left side and output pins on the right. Pin lead length is based on the Default Pin Name Offset parameter from the Symbol Controls dialog box of the INI Editor.

The Block symbol has an attribute window near the top for displaying the name, and a window near the bottom for displaying the instance name. Rectangle height and width are proportional to the number of pins and the length of their names, respectively.

Use

The New Block Symbol command displays a dialog box (Figure 3) with four edit fields in which you specify the symbol name, plus the names of the input pins, output pins, and bidirectional pins. The pin names are separated by commas.

![New Block Symbol Dialog Box](image)

Figure 3. New Block Symbol Dialog Box

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Block Name</td>
<td>Your name for the symbol</td>
</tr>
<tr>
<td>Input Pins</td>
<td>The names of all nets with an Input I/O marker</td>
</tr>
<tr>
<td>Output Pins</td>
<td>The names of all nets with an Output I/O marker</td>
</tr>
<tr>
<td>Bidir Pins</td>
<td>The names of all nets with a Bidirectional I/O marker</td>
</tr>
<tr>
<td>Use Data...</td>
<td>Creates a block symbol using information from the current schematic</td>
</tr>
</tbody>
</table>
Bus Pin Names

A bus pin name (whether single or compound) must be enclosed in equals signs (= =). If a compound name is not surrounded by equals signs, each name is expanded to an individual pin. The following examples illustrate three possible ways to enter pin names in the Inputs field:

- A, B[0:3], C

- A, =B[0:3] =, C
  Creates 3 pins: A B[0:3] C

- =A, B[0:3], C=
  Creates 1 pin: A, B[0:3], C

Pin Order

Block symbols are completely arbitrary and do not have to be based on existing schematics or behavioral files. However, if you are eventually going to connect an ordered bus to the symbol’s pins, you should make sure the pin order specified in the symbol matches the order of the signals in the bus. The names of the signals do not have to match.

Making a Symbol for the Current Schematic

If you want to create a symbol that represents the current schematic, click on "Use Data From This Block." The edit fields are automatically filled with the names of those nets that are labeled with I/O markers. If you have already labeled all nets with I/O markers, you won't have to enter anything manually.

Creating the Symbol

Once all information has been entered, the symbol can be created or edited. Click on the Run button to create a .sym file in the project directory. If the symbol's name is different from the name of the currently loaded schematic, the new symbol is also attached to the mouse cursor for immediate placement. Click on the Edit button to create the symbol and load it into the Symbol Editor. You can inspect the symbol, or alter it as desired.

See Also

Add ⇒ Symbol
Add ⇒ Pin

Description

Specifies the locations of symbol pins. Pins correspond to I/O markers on the underlying schematic and connect the device represented by the symbol to the rest of the circuit.

Use

To add a pin, click at the desired location. If that point already has a pin, an error message is displayed. Pins appear in the Symbol Editor as small squares.

Pins are usually attached to the symbol on short lines extending outward from the symbol’s body. However, pins can be attached anywhere inside or outside the symbol, with or without connecting lines.

Pins are electrical elements and are therefore restricted to locations on major grid intersections. There can be only one pin at any location.

You can create special pin symbols to indicate items such as test points and edge connectors. These pin symbols are added to schematics with the Symbol command. The use of these symbols of type Pin is described in Chapter 4, “Using the Schematic Editor” in the *Schematic Entry User Manual*. 
Add ⇒ Rectangle

Description

Adds rectangles to the drawing. These rectangles are graphic only and have no electrical meaning.

Use

The Rectangle command operates in either click or drag mode.

Click
1. Click at one corner of the rectangle.
2. Move the cursor to the diagonally opposite corner. A dotted line shows the outline of the rectangle.
3. Click again to draw the rectangle.

Drag
1. Drag the mouse from one corner of the rectangle to the diagonally opposite corner. A dotted line shows the outline of the rectangle.
2. Release the button to draw the rectangle.

The corners of a rectangle must fall on grid points. If the regular grid is not fine enough, use the Graphic Options command from the Options menu to choose half- or quarter-grid resolution.

You can continue drawing rectangles until you select another command.
Add ⇒ Symbol

Description

Places instances of symbols in schematics. You can place symbols from a supplied library, or create your own symbols with the Symbol Editor. The symbol files can be in the project directory or in library directories. Symbol files have the file extension .sym. Symbol libraries have the file extension .lib.

Use

Selecting the Symbol

When you select the Symbol command, a dialog box with two list boxes appears (Figure 4).

Figure 4. Symbol Libraries Dialog Box

The upper list box contains the libraries or library directories in their search order. One of these lines is highlighted, indicating the currently selected directory. Use the ARROW keys or click on a name to select a different library.

The lower list box contains a list of the symbol files contained in the selected directory. Select a symbol by clicking on its name.

There are two other ways to specify the symbol:

- Enter the file name of the symbol in the Prompt line and press Enter. (Only the base name is needed, not the .sym suffix.) The system selects the first symbol it finds (following the search path specified in the Symbol Libraries dialog box of the INI Editor) with the name you entered. Or ...
- If a symbol of the desired type is already on the schematic, click on an instance of it.
**Placing the Symbol**

Once a symbol is selected, the symbol outline is attached to the mouse cursor. Click left to place it, as many times as you want. Click right anywhere in the Schematic Editor window to reset the Symbol command and choose another symbol.

**Changing the Symbol’s Orientation**

Before a symbol is placed, you can rotate or mirror it with the Rotate and Mirror commands from the Edit menu. These commands can be combined to create any of eight possible orientations. The outline on the mouse cursor changes to show the new orientation. Refer to the Rotate and Mirror commands for a full description.

**Replacing a Symbol**

*To replace an existing symbol:*

Position the cursor so that at least 50% of the new symbol overlaps the one to be replaced, then click. If the overlap is less than 50%, the new symbol does not replace the old one, but overlaps it. None of the override attributes associated with the previous symbol are applied to the new symbol.

**Pre-Placement Checks**

The Schematic Editor will not place a symbol if:

- Any part of it extends past the edge of the sheet. The symbol’s “extent” is an imaginary rectangle enclosing the symbol and its pins. (This rectangle is also used to evaluate the 50% overlap described in the preceding paragraph.) You can view the extent rectangle by selecting the Query command from the Object menu, then clicking on the symbol.

- A pin falls on the intersection of crossing wires. This would implicitly connect two previously unconnected nets, and the command fails.

- The placement directly connects two pins (there must be a wire between pins). A pin may not directly touch an isolated net name.

If none of these checks fail, an instance of the symbol, rotated and mirrored as specified, is added to the schematic. If any check fails, the symbol is not placed, and you can try again.

**Pin Connections**

Each symbol pin that touches a wire is connected to its respective net. If the appropriate display options are enabled, unconnected pins are marked with a error dot, and pins with two or more wires are marked with a connect dot.
Occasionally a symbol is placed so that a pin lands on the wire near, but not on, its end. The resulting stub may be obscured by the symbol graphics. This condition is identified by the connect dot on the pin and the hanging end mark on the end of the stub. (Both the Show Connect Dots and Mark Hanging Wires options must be enabled.)

**See Also**

- Edit ⇒ Mirror
- Edit ⇒ Rotate
Add ⇒ Table

Description

Adds a table of information, which is displayed graphically (that is, it has no electrical meaning). Elements in the schematic can reference values stored in these tables.

Graphical Format

A table displays rows and columns of data with lines separating the rows and columns. The first row of the table is the column labels. The height of the first row can be different from the height of the remaining rows. The text in the first row can have a different size and justification from the rest of the table, allowing column labels to be written vertically. Column labels are typically names of attributes or the value of a global constant.

The first column of the table is the row labels. The width of the first column can be different from the width of the remaining columns. The text in the first column can have a different size and justification from the rest of the table. Row labels are typically instance names or reference designators of symbol instances in the schematic.

In addition, each table has an optional title written above the table. Each table has a name that identifies the table to the symbol instances.

Figure 5. Add/Modify Data Tables Dialog Box
The Table command displays a dialog box as in Figure 5. This dialog box provides independent control of the following parameters:

- Number of rows
- Number of columns
- Height of first row
- Height of remaining rows
- Width of first column
- Width of remaining columns
- Table name (Identifies table to symbol instances.)
- Table title (Any text the user wants displayed at the top.)
- Justification of table name
- Justification and rotation of column labels (first row)
- Justification of row labels (first column)
- Justification of remaining data
- Justification of title

The **Edit ⇒ Table Data** command is used to enter the data after you have created the table.

### Accessing Table Data

Derived symbol attributes can reference values stored in tables. To retrieve information from a table, you have to specify the table (T), row (R), and column (C).

### Specifying Rows and Columns

There are several ways to specify R and C. The simplest method for rows is to enter the row number. A more flexible method is to request the row whose label is equal to *value*, where *value* may be specified as a string, the value of a global constant, or the value of an attribute (for example, RefDes).

The simplest method for columns is to enter the column number. A more flexible method is to request the column whose label is equal to *value*, where *value* can be the value of a string, the value of a global constant, or the value of an attribute. You can then change many references to that column by editing the single value of the global constant.

A useful way to access rows is to reference them using instance names. The row labels can correspond to instance names in a schematic. When you reference the table from a given instance, the row labels are scanned to see if any correspond to the given instance name. This lets you change the order of rows in the table without altering the data references.
Command Syntax

To access table data using derived attributes, use the following syntax:

```plaintext
&table_name[row,column]
```

table_name  The table's name spelled exactly.

row  Can be either a number, or =value, or =#attr, or =$const. When row contains an equals sign (=), the table is searched for the row with a label equal to value or equal to the value of the attribute on the current symbol instance. Row numbers start at one. Row zero is the column label.

column  Can be either a number, or =value, or =#attr, or =$const. When a column contains an equals sign (=), the table is searched for the column with a label equal to value or equal to the value of the global constant. Column numbers start at one. Column zero is the row label.

Example

The following example shows how to specify a symbol attribute to retrieve data from a table. The table Ohm contains resistor values that correspond to symbol attribute #3, whose name is Value. The resistance is therefore determined by the table entry rather than by the value attribute.

```plaintext
&Ohm[2,3]  Gets the data from row 2 and column 3 of the table named Ohm.

&Ohm[=R1,=Resistance]  Gets the data from the column labeled Resistance and the row labeled R1.

&Ohm[=#[RefDes],3]  Gets the data from column 3 and the row whose label matches the RefDes of the current symbol.

&Ohm[=#2,$[country]]  The row whose label matches the value of attribute #2 (RefDes) of the current symbol determines which row the data is taken from. The global constant "country" determines which column to use.
```
Since global constants can be used anywhere for string substitution, you can simplify entry by defining the string in the preceding example as a global constant. For example, set the global constant 0 to &Ohm[#2,$[country]] . Then set the Value attribute of the symbol to $0.
Add ⇒ Text

Description

Adds fixed text to the drawing (as opposed to the text that appears in attribute windows).

Use

Text is used to add notes, title blocks, and other information to the symbol or schematic. Text has no electrical meaning.

The size, orientation, and justification of text is set by parameters in the Graphic Options dialog box. Eight text sizes are available (3 on UNIX). Text can be left-justified, right-justified, or centered.

The Text command operates in either the Add or Edit modes:

Add

Type the desired text, then press ENTER. (Use the Graphic Options command from the Options menu to change the font size and justification before entering the text.) The text is attached to the cursor.

Click at the desired point to place the text. If you make a mistake, or decide not to place the text, click right anywhere in the window to remove the text from the cursor and reset the command.

Edit

Click on an existing text string. The text is removed from the drawing and placed on the edit line where it can be modified. Justification and font size can be changed with the Graphic Options command.

When the text has been edited, press ENTER. The text is returned to the drawing in its original position. If you change your mind, click right anywhere in the Editor's window to cancel your changes and restore the previous version of the text.

The Text command remains active until you select another command.
Description

Wire is the principal command for adding wires between symbol pins. Net Name and Bus Tap can also be used to add single wire segments.

The Wire command operates in several modes. The mode is set when the first point is entered. Click right at any time to cancel the wire.

Point-to-point Mode

Point-to-point mode draws single line segments, one segment at a time. Point-to-point is commonly used to draw multi-segment wires.

1. Click at the first point. This is the starting point for the wire. A “rubber band” line, consisting of a horizontal and a vertical segment stretches to the current mouse location.
2. Move the mouse until the segment connected to the first point has the length and orientation you want.
3. Click to fix the first segment. The line becomes solid and takes the “wire” color.
4. Repeat steps 3 to 4 to place additional wire segments.
5. Click a second time on the last point of the wire to terminate the wire. If the new segment ends on a pin, name, or other wire, the segment is automatically completed.

The Wire command remains active until you select another command. You can continue to place wires without having to reselect the Wire command.

Wires are normally constrained to the four 90˚ directions. Hold down SHIFT while clicking to position the next wire segment diagonally (at 45˚ angles). Point-to-point is the only mode in which diagonal wires can be added.

Single-segment Mode

Single-segment mode draws just one segment, and automatically completes it.

Drag the mouse horizontally from one point to another, then release the mouse button. A single-wire segment is added, and the Wire command returns to its initial state.
"Z" and "C" Mode

Drag the mouse vertically or diagonally to partially automate routing the wire.

- Drag the mouse between two points that are not on a horizontal line. A three-segment connection appears as dotted lines.
- If you drag the mouse vertically, the segments form a “C” shape. If you drag the mouse diagonally, the segments form a “Z” shape instead.
- In either case, you move the mouse to alter the length of the horizontal segments without changing their spacing. When the lines are where you want them, click to set the wire.
- If you drag vertically and can't properly route the wire using the initial “C” shape, click right to cancel the Wire command.
- If you drag horizontally and can't properly route the wire using the initial “Z” shape, click right. The pattern changes to two vertical lines, with a horizontal line connecting them (a reverse “Z” shape).
- Move the mouse to change the length of the vertical segments without changing their spacing.
- Move the mouse above or below the ends of the vertical segments to change the connection to a vertical C shape. Click left to create a wire.
- If you still can't route the wire properly, or you decide not to place the wire, click right to cancel the wire and reset the Wire command.
- Crossing wires are not normally connected. To form a four-way connection, start with a single wire, then add two additional wires at right angles to the first wire. This type of connection is automatically marked with a connect dot to distinguish it from unconnected crossing wires.

![Z and C Wire Connections](image)

‘Z’ CONNECT  ‘Z’ CONNECT REVERSED  ‘C’ CONNECT

Figure 6. Z and C Wire Connections

See Also

Add ⇒ Bus Tap
Add ⇒ Net name
This Edit menu chapter contains information on the following menu items and submenu items:

- Edit ⇒ Attribute ⇒ Attribute Location
- Edit ⇒ Attribute ⇒ Attribute Window
- Edit ⇒ Attribute ⇒ Pin Name Location
- Edit ⇒ Attribute ⇒ Pin Attribute
- Edit ⇒ Attribute ⇒ Symbol Attribute
- Edit ⇒ Attribute ⇒ Net Attribute
- Edit ⇒ Attribute ⇒ Net Attribute Window
- Edit ⇒ Expand Page
- Edit ⇒ Symbol Type
- Edit ⇒ Constants
- Edit ⇒ Copy
- Edit ⇒ Copy Image
- Edit ⇒ Cut
- Edit ⇒ Delete
- Edit ⇒ Drag
- Edit ⇒ Duplicate
- Edit ⇒ Mirror
- Edit ⇒ Paste
- Edit ⇒ Redo
- Edit ⇒ Rotate
- Edit ⇒ Schematic
- Edit ⇒ Symbol Origin
- Edit ⇒ Symbol
- Edit ⇒ Table Data
- Edit ⇒ Undo
Edit ⇒ Attribute ⇒ Attribute Location

Description

Moves attribute windows on an instance-by-instance basis.

Use

1. Select the Attribute Location command. You are prompted to select a symbol.
2. Select a symbol instance whose attribute windows you want to modify. The Attribute Windows dialog box displays the attributes that are or can be displayed on the selected instance.

![Attribute Windows Dialog Box in Schematic Editor](image)

Figure 1. Attribute Windows Dialog Box in Schematic Editor

For an attribute value to appear in the list box, the attribute must have both an attribute window number and an attribute value assigned to it. (Attribute window numbers are assigned with the INI Editor.)

3. Click on the attribute whose window you want to modify.

There are two buttons above the list of attributes. If the attribute you select is already displayed, these buttons will be labeled Move and Restore. If the attribute you select is not displayed, these buttons will be labeled Add and Delete.
4. Click on the appropriate button

Move  Repositions the selected attribute, attaching it to the cursor. Click where you want to reposition it. The attribute is displayed at the new location using the current graphic options for size, orientation and justification.

Restore  Restores an attribute displayed on the selected instance to its original location on the symbol definition.

Add  Attaches a selected attribute that is not displayed on the target instance to the cursor. Click where you want to position it.

Delete  Deletes the selected attribute.

See Also

“Attributes” in the *Schematic Entry User Manual* for a more detailed explanation of attributes and attribute windows.

Edit ⇒ Attribute ⇒ Net Attribute
Edit ⇒ Attribute ⇒ Attribute Window
Edit ⇒ Attribute ⇒ Attribute Window

Description

Defines attribute windows.

Use

Before selecting the Attribute Window command, use the Graphics Options command from the Options menu to set the text size, justification, and orientation for the attribute window.

Select the Attribute Window command. It displays a dialog box listing the defined attributes that can be displayed in attribute windows.

Click on the desired attribute window. Its name is attached to the cursor.

Click at the desired location to place the attribute window. (The window can be outside the symbol, as well as within it.) The attribute's name appears in the window with the text size and justification selected in the Graphics Options command. When the symbol is placed in a schematic, the attribute's value replaces the name.

The next window name in the dialog box is highlighted and is attached to the cursor. Click to place it and advance to the next window name. Continue in this way to place all the names.

To reposition an attribute window, click on its name in the list box. Then click at the new position.

The text appearing in the window might be longer or shorter than the attribute name. Position the window to accommodate the expected length.

You can use the Graphics Option dialog box at any time to change the text size, justification, or orientation for the next attribute window you place. The graphics of previously placed windows are not changed.

Attribute windows can be reassigned after the symbol and schematic have been created. This reassignment can be temporary or permanent.

Attribute Windows are permanently reassigned with the INI Editor.
Attribute Windows are temporarily reassigned with the Attribute Display command from the **Edit ⇒ Attribute ⇒ Attribute Display** menu item in the Schematic Editor or the Hierarchy Navigator.

**See Also**

- Edit ⇒ Attribute ⇒ Symbol Attribute
- Edit ⇒ Attribute ⇒ Attribute Display

“Attributes” in the *Schematic Entry User Manual* for a more detailed explanation of attributes and attribute windows.
Edit ➔ Attribute ➔ Pin Name Location

Description

Specifies where to display the pin name. Its position is expressed as a direction and offset from the pin. The direction is limited to the four primary directions (up, down, left, and right). The distance is limited to 0 through 31 fine grids (one-fourth of a major grid).

Use

The Pin Name Location command displays the dialog box shown in Figure 3.

Figure 3. Pin Name Location Dialog Box

To change the position of a pin name:

- To indicate where the name should display: click the appropriate radio button (L, R, T, or B), then click on the pin.
  
  The L ("left") button is typically used for pins on the left of the symbol and displays the name to the right of the pin. The R ("right") button displays the name to the left of the pin. The T ("top") button displays the name below the pin. The B ("bottom") button displays the name above the pin.

- To display a pin name as vertical text: click the Vertical button.

- To hide a pin name: click the Don't Show radio button, then click on that pin.

- To change the distance of the pin name from the pin: click in the Offset edit box, then enter an offset value (0–31). This value is in units of one-quarter the main grid. The initial setting for the offset is set by the PinNameOffset parameter in the INI Editor.

You can select more than one pin at a time by dragging a box around them. All the pin names are added, repositioned, or deleted when you release the mouse button.
Edit ⇒ Attribute ⇒ Pin Attribute

Description

The Pin Attribute command adds and edits pin attributes. Each pin can have its own set of attributes. These attributes are assigned during the symbol's creation and are the default attributes. Pin attributes can also be added or changed in the Schematic Editor or Hierarchy Navigator.

Use

Selecting this command displays a dialog box. The left side of the dialog box lists the names for each pin. Until names are assigned, unnamed pins are represented by rows of dashes.

The right side of the dialog box lists the attributes that can be assigned to a symbol pin. In the Schematic Editor and Hierarchy Navigator, only attributes that have a value defined are displayed. To display all assignable attributes, check List All Attributes.

If more than one pin is selected, attribute changes apply to all selected pins.

If one pin is selected, any attributes that have been assigned to the pin are shown in the format:

\[attribute\_name = value\]

To assign a pin attribute:

1. Select a pin or pins using one of the following methods:
   - In the Pin Attribute Editor, click on a pin name.
   - In the Pin Attribute Editor, shift-click for additional pin names.
   - Click on a pin.
   - In the Schematic Editor and Hierarchy Navigator, click on a symbol to select all pins on the symbol.
   - In the Symbol Editor, drag a box around pins.

2. Select the attribute to be assigned or modified by clicking on the corresponding line in the right-hand list box. The attribute name is copied to the top line in the dialog box. If a value has already been assigned, that value appears in the edit field.

NOTE

You can select pins from only one symbol at a time.

The pin is highlighted and the right list box is updated to show the attributes assigned to the selected pin.
Edit ⇒ Attribute ⇒ Symbol Attribute

Description
Assigns values to symbol attributes.

Use
Selecting this command displays a dialog box with two edit boxes at the top and two list boxes at the bottom (the Symbol Editor has one edit box and one list box).

The left list box displays the selected symbols. The right list box displays all the attributes that can be modified. Their values are changed in the edit box.

To select a symbol or symbols:
- Click on the desired symbol.
- Shift-click to select additional symbols.
- Drag a box around the desired symbols.
- Use the Find button (Sch, Nav only) to select all symbols that match a specific criteria (see "Selecting Symbols by Attribute Criteria" below).

In the Schematic Editor and Hierarchy Navigator, after a symbol is selected, the list box contains the assigned attributes. To list all assignable attributes, check the List All Attributes box. Change the value in the edit field.

In the Symbol Editor, all attributes that can be assigned to a given symbol are visible in the Attribute Editor list box when you edit a symbol.

NOTE
When you select more than one symbol, attribute changes apply to all selected symbols. Also, if the values for an attribute are different for selected symbols, the value is displayed as ** Mixed **.

NOTE
You may need to define an attribute window in the Symbol Editor before new attributes are displayed.
Selecting Symbols by Attribute Criteria

The **Find** button brings up the **Instance Filter** dialog box. You use this dialog box to select all instances that satisfy a comparison criteria on their attributes.

1. Select the attribute to be compared to from the left box.
2. Select the comparison function (such as ==, <, or <= ) from the center box.
3. Enter a value for the attributes to be compared against.

To add the selected symbol to the list instead of replacing it, unmark the **Replace Current Selection** check box.

*To modify a symbol attribute:*

1. Select Edit ⇒ Attribute ⇒ Symbol Attribute.
2. Select the symbol or symbols as described above.
3. Click on the name of the attribute you want to modify. The attribute name and its current value appear in the edit box (Figure 4).

![Symbol Attribute Dialog Box](image)

Figure 4. Symbol Attribute Dialog Box

4. Edit the attribute value.

These attributes are defined in the INI Editor. Access to the definitions is through the Attribute menu of the INI Editor.

*To go to a specific symbol:*

1. Select a single symbol in the left list box.
2. Click the GoTo button to center the selected instance in the display window.
See Also

Edit ⇒ Attribute ⇒ Net Attribute
Edit ⇒ Attribute ⇒ Pin Attribute
Edit ⇒ Attribute ⇒ Attribute Window
Edit ⇒ Attribute ⇒ Attribute Location

“Attributes” in the *Schematic Entry User Manual* for a detailed description of attributes.

“The SCS INI Editor” in the *Schmatic Entry User Manual* for a explanation of how to modify attribute definitions and values.
Edit ⇒ Attribute ⇒ Net Attribute

Description

Assigns values to net attributes.

Use

The command displays the Net Attribute Editor dialog box with one edit field on the top and two list boxes on the bottom. The status bar prompts you to select a net.

The left list box displays the names of the selected nets. The right list box displays all attributes that are assignable for the selected nets.

To select a net or nets:
1. Click on the desired net.
2. Shift-click to select additional nets.
3. Drag a box around the desired nets. It will select all nets that have a name, window, or end point contained in the box.

After a net is selected, the list box contains the attributes that can be modified. The value of an attribute is changed in the edit field at top.

NOTE When you select more than one net, attribute changes apply to all selected nets.

NOTE You may need to define a net attribute window before new attributes are displayed.

To modify a net attribute:
1. Click on the net (or nets) you want to change.
2. Click on the name of the attribute you want to modify. The attribute name and its current value appear in the edit box.
3. Edit the attribute value.
Buses

In the Hierarchy Navigator, selecting a bus selects all nets in the bus. Click in the left list box to select or de-select nets in the bus. The Net Attribute dialog box shows the net attributes that can be modified. Attribute values are changed in the edit field at top.

pósito

**NOTE**  
Do not alter bus attributes in the Schematic Editor.

To modify a bus attribute:

1. Click on the bus whose attribute you want to change. The elements of the selected bus are displayed in a list box.
2. Click in the left list box to select or de-select nets in the bus.
3. Click on the name of the attribute you want to modify. The attribute name and its current value appear in the edit box. When you change an attribute value, it is changed for all selected nets.
4. Edit the attribute value.

To delete an attribute value:

You can remove any attribute value by erasing it, instead of editing it. If the attribute has a default, the default value then becomes the active value.

Attributes are defined in the INI Editor. Access to the definitions is through the Attribute menu of the INI Editor.

See Also

- Edit ⇒ Attribute ⇒ Pin Attribute
- Edit ⇒ Attribute ⇒ Symbol Attribute
- The "Attributes" chapter in the *Schematic Entry User Manual*.
Edit ⇒ Attribute ⇒ Net Attribute Window

Description

Defines display locations for net attributes.

Use

Net attributes are typically not displayed unless or until a display location is defined.

To define a net attribute window:
2. Click on the net where you want the attributes to be displayed. The attributes are displayed as a flag at the location you clicked.

NOTE

If displayable attributes are already defined for the selected net, those attributes are displayed in the new location. Nothing is displayed if no attributes are defined.
Edit ⇒ Expand Page

Description

Increases the work area for the symbol.

Use

The initial work area is 40 x 40 Primary grids. After a symbol has been created, the Symbol Editor provides a work area that is approximately twice the height and width of the symbol.

When a symbol grows too large to fit, use Expand Page to enlarge the work area. Its initial use increases the size to 80 x 80 Primary grids. Subsequent use adds increments of 20 grids, up to a maximum of 400 x 400 grids.

The extra area is added at the right and bottom of the symbol. If more space is needed on the left or top, use the Move command to shift the entire symbol.

▲ CAUTION  The Origin is not part of the symbol. If you move the symbol, the Origin does not move with it. Be sure to reposition the Origin if you move the symbol.
Edit ⇒ Symbol Type

Description

Changes the symbol type from within the Symbol Editor.

Use

Change Symbol Type displays a dialog box like the one in Figure 5. Click the radio button corresponding to the desired symbol type, then click **OK**. This symbol is immediately changed to the new type.

You cannot reverse Change Symbol Type with Undo. You must apply the command a second time to return the symbol to its original type.

![Figure 5. Change Symbol Type Dialog Box](image_url)
Edit ⇒ Constants

Description

Changes global constants in the Hierarchy Navigator.

Use

Use the following procedure to temporarily change the value of a global constant:

1. Select the Constants command. A list box is displayed as shown in Figure 6.
2. Click on the constant you want. The selected constant is highlighted and its value is displayed on the edit line.
3. Change the value. Press Enter to accept the new value.

These changes last only for the current session. Use the Global Attributes dialog box in the INI Editor to make permanent changes.

Figure 6. Global Constants List Box
Description
Copies items from the symbol or schematic to the Clipboard. The items can then be pasted in another symbol or schematic. The copied item is not deleted from the drawing.

Use
The Copy command has three modes: Single-Item, Box-Select, and Group-Select.

Single-Item
Single-item mode copies one item at a time. Click on the desired item. Net names and attributes are copied, as well as the physical representation of wires and symbols. Instance names are not copied, because each instance must be unique.

If the cursor points at more than one item when you click, the Editor decides which item is selected according to a priority list. This priority is outlined in the description of Delete.

Box-Select
In box-select mode, the items contained in a rectangular area are copied. Drag the mouse from one corner of the desired area to the diagonally opposite corner and release the button.

All items totally enclosed by the box are copied to the Clipboard. Portions of wire segments enclosed by the box are also copied. Net names and attributes are copied, as well as the physical representation of wires and symbols. Instance names are not copied, because each instance must be unique.

The Copy command fails if wires cross on the boundary of the area. See “Edit ⇒ Delete” for a discussion of this restriction.

Group-Select
The group-select mode combines single-item and box mode to permit copying arbitrary groups of items.

To group-select items:
1. Press and hold SHIFT before selecting the first item or area.
2. Select one or more items, in either single-item or group mode. As each item or area is selected, it is redrawn in the phantom color. You can continue to select items, in either mode, as long as you hold down SHIFT.
3. To complete the group, click right anywhere in the window after making the last selection. Or release SHIFT before selecting the last item or area. All selected items are then copied from the drawing to the Clipboard. The relative position of the items in the group is maintained. It is therefore not possible to group items from different sheets.
NOTE  Schematic items cannot be copied to symbol drawings, and vice versa.

See Also

Edit ⇒ Duplicate
Edit ⇒ Delete
Edit ⇒ Paste
Edit ⇒ Copy Image

Description

Copies a rectangular portion of a schematic or symbol to the Clipboard. You can then paste the Clipboard contents into another application, such as a word processor or DTP program.

If the ClipboardFormat variable in the INI file is set to Yes (the default value), the image is in Windows MetaFile (.wmf) format. If this variable is set to No, the image is in bitmap (.bmp) format. This variable cannot be accessed from the INI Editor; you must modify it manually.

Use

Select the Copy Image Command. You are prompted for one corner of the rectangle.

■ Click at any corner. Move the mouse to the diagonally opposite corner, then click a second time to fix the rectangle. Its contents are copied to the Clipboard. Or ...

■ Point the mouse cursor at any corner, then drag the mouse to outline the rectangle in a single motion. When you release the button, the contents of the rectangle are copied to the Clipboard.

The Copy Image command remains in effect until you select another command. If you make a mistake or change your mind, you can select a different area without having to reselect the command.

See Also

File ⇒ Print Image
Edit ⇒ Cut

Description

Removes items (wires, graphics, symbols, or text) from the schematic or symbol and places them on the Clipboard. The previous contents of the Clipboard are erased. The items can then be pasted from the Clipboard into another schematic or symbol.

Cut operates in the same three modes as Copy. See the description of Edit ⇒ Copy for a full explanation.

See Also

Edit ⇒ Delete
Edit ⇒ Paste
**Edit ⇒ Delete**

**Description**

Deletes items from the schematic or symbol drawing. Deleted items *are not* copied to the Clipboard and the Clipboard's contents are not altered.

**Use**

Delete operates in the single-item mode or box-select mode.

**Single-Item Mode**

Click on any item to delete it. If the cursor points at more than one item, the item nearest the top of the following lists is deleted. Click on the indicated point or item to delete it unambiguously.

**Schematic Editor Selection Priority**

- **Net Name**: Click on the connect point.
- **Wire Segments**: Click anywhere on the wire.
- **Symbols**: Click within the symbol extent box.
- **Graphics**: Click on the graphic element.
- **Text**: Click on the text.

**Symbol Editor Selection Priority**

- **Symbols Pins**: Graphics
- **Graphics**: Graphics
- **Text**: Click on the text.
- **Attribute Windows**: Click within the window text area.

If you click at the point where a net flag is attached to a wire, the net flag is deleted first. A second click removes the wire segment. To delete a wire segment and leave the net name, you must click on a section of wire away from the net name.

**Box-Select Mode**

Drag the mouse to form a rectangle. All *totally enclosed* items are deleted when you release the mouse button. Portions of wire segments enclosed by the rectangle are also deleted.
Crossing Wires Limitation

If a corner of the box coincides with the crossing point of a vertical and a horizontal wire, deleting the two partial segments would leave the remaining segments ending on the original crossing point, and thus would be connected.

A similar condition occurs when diagonal wires cross on the perimeter of the rectangle Figure 7. Deleting the wire segments inside the box would leave the remaining wires connected.

If the nets have different names, either of the above conditions is an error. If one or both nets are unnamed, the results are logical, but probably not what you intended. The Editor therefore flags an error and does not allow the deletion.

Figure 7. Illegal Delete Selections
Description

Moves portions of objects while the rest of the object remains in place. The effect is to “stretch” or reposition the item, altering its basic shape or direction. Drag works differently in the Symbol and Schematic Editors.

Use in the Symbol Editor

The Drag command is used principally to resize or reposition a graphic element. Click on (or near) an item to select it. Drag works only in single-item mode and only on the following graphic elements:

- Lines: Moves the end nearest the point at which the line was selected.
- Rectangles: If the selection point is near a corner, the rectangle can be stretched by moving the corner. If the point is closer to the center of a side, the rectangle can be stretched by moving the side.
- Circles: The radius of the circle can be changed; the center remains fixed.
- Arcs: The end of the arc nearest the point where the arc is selected can be moved to increase or decrease the angle of the arc. The center and radius of the arc remain fixed.

Use in the Schematic Editor

The Drag command moves one or more elements while keeping them connected to the rest of the circuit. There are two modes, drag-point and drag-box.

Drag-Point

Click on any point in the schematic. There are three possibilities:

- If the point is within the extent box of a symbol, the command switches to the drag-box mode, with the extent box of the symbol as the area to be dragged.
- If the point is on a wire or net name, the name and/or any wires connected to the point are highlighted. The connections are shown as moving lines connected to the cursor.
- If the point is on a graphic element, the drag command operates the same way it does in the Symbol Editor.
Drag the connection to the desired location and click. You cannot, in general, move the cursor to a point that would create a broken or illegal wire pattern. If the connections do not violate any interconnection constraints, the connections are made.

The command fails if a new connection violates a layout rule. If this occurs, the Editor returns the drawing to its original state and you can try again. See the Delete command for a discussion of layout rules.

**NOTE**
Clicking on or near a pin may disconnect the wire from the pin, or connect two wires you didn't intend to connect. Select Undo (or press F9) to restore the drawing. Then try clicking further away from the symbol.

**Drag-Box**
Drag the mouse to define a rectangular area, or click within the extent box of a symbol. In the latter case, the extent box defines the rectangular area selected.

All items within the rectangle, including partially-enclosed wires, are highlighted. Symbols must be totally enclosed by the rectangle in order to be included.

The highlighted items are attached to the cursor. Any connections that cross the border of the area are kept. As the cursor is moved, these connections are maintained with three-segment wires. The cursor cannot be moved to a position that would force these connections to be broken. Click to reposition the items and make the new connections.

The command can fail if a new connection violates a layout rule. If this occurs, the Editor returns the drawing to its original state and you can try again. See the Delete command for a discussion of layout rules.

**NOTE**
Clicking on a wire selects the entire wire segment. Dragging a box around part of a wire selects only that section of the wire. If you want to move a complete wire segment, either click on the segment, or drag a box around the entire segment.
**Description**

The Duplicate command lets you copy one or more elements, then place them at different locations within the same symbol or schematic. You can place the duplicated item(s) as many times as you want until you select another command.

Net names and attributes are copied as well as the physical representation of wires and symbols. Instance names are not copied, because each instance must be unique.

**Use**

The Duplicate command can be used in three modes:

**Single-Item Mode**

Single-item mode duplicates one item at a time. Click on the desired item. A copy is attached to the cursor. Place the item by clicking at the desired position.

A priority system determines which item is selected if the cursor points at two or more items when the mouse is clicked. The priority order is outlined in the description of the Delete command.

**Box-Select Mode**

Box-select mode copies all items within a rectangular area. Drag the mouse to define the area. When the mouse button is released, all items totally enclosed by the rectangle are selected. Portions of wire segments enclosed by the rectangle are also selected. Net names and attributes are copied as well as the physical representation of wires and symbols. Instance names are not copied because each instance must be unique.

The selected items are attached to the cursor. Click to place them at the desired position. The rectangle outlining the selected items must be entirely within the boundaries of the symbol or schematic sheet when you click, or the command will fail. In this case, the group remains attached to the cursor and you can try again.

Duplicate also fails if a crossing point of wires is on the boundary of the area. See Delete for a discussion of this restriction. The command can partially fail if a rules violation occurs for one or more items. Everything is duplicated except the item(s) that violate the rules. Use the Undo command to erase the duplicated items and restore the drawing to its original state.
**Group-Select Mode**

The group-select mode combines the two other modes to move arbitrary collections of items.

*To group-select items:*

1. Press SHIFT before selecting the first item or area.
2. Select one or more items and/or areas, keeping SHIFT depressed. As each item or area is selected, it is redrawn in the phantom color to indicate that it has been selected.
3. To complete the group, click right anywhere in the window. Or, release SHIFT before selecting the last item or area. The group of items is removed from the drawing and attached to the cursor. The last point clicked on becomes the group’s origin when it is placed.
4. Click to place the group at the desired position. The group has the same placement restrictions as described for box-select mode.

The relative position of the items is maintained. It is therefore not possible to group items from different sheets.

If you make a mistake, or decide not to place the selected items, click right anywhere in the window to cancel the selection and restart the Duplicate command.

**See Also**

- Edit ⇒ Copy
- Edit ⇒ Delete
Edit ⇒ Mirror

Description

Mirror works with objects that have already been selected by the Symbol, Paste, Duplicate, or Move commands, and are attached to the cursor. The object is “reflected” through an imaginary vertical line each time Mirror is selected. Mirror can be combined with Rotate to produce eight standard orientations, as shown in Figure 8. Standard Orientations.

![Figure 8. Standard Orientations](image)

Symbol text is positioned and justified to read left-to-right or bottom-to-top, regardless of the object’s orientation.

See Also

Edit ⇒ Rotate
Edit ⇒ Paste

Description

Pastes the contents of the Clipboard into the schematic or symbol.

Use

Selecting the Paste command attaches the Clipboard item(s) to the cursor. They are placed in the usual way, by clicking at the desired position. The Rotate and Mirror commands can be used to rotate and/or mirror the item before placement.

Paste fails if any of the items extend beyond the border of the sheet or symbol. In this case, the group remains attached to the cursor and you can try again.

Paste can partially fail if a rules violation occurs for one or more items. Everything is pasted except the item(s) that violate the rules. Use the Undo command to erase the pasted items and restore the drawing to its original state.

The Paste command does not clear the Clipboard. You can use Paste repeatedly to add as many copies as you want. The Clipboard is not cleared until the next Cut or Copy command.

NOTE

Schematic and symbol items are not compatible; you cannot paste schematic items into a symbol, or vice versa. However, you can open more than one Schematic Editor or Symbol Editor session, and paste items copied or cut from one session into the other.

See Also

Edit ⇒ Mirror
Edit ⇒ Rotate
Edit ⇒ Redo

Description

Reverses changes caused by the Undo command.

Use

Redo can move forward, recreating the undone events until it reaches the end of the Undo log (the point when the first Undo in the sequence was issued). The Undo and Redo logs are discarded when

- The current version of a symbol or schematic is saved. Or ...
- The sheet size is changed. Or ...
- The symbol work space expanded.

Once the logs are discarded, Redo cannot recover undone commands.

Redo does not work with the Sheet Setup command. That is, if Undo is used to restore the original sheet size after changing the sheet size, Redo cannot return the drawing to the changed sheet size.

Undo and Redo do not work with View commands, since those commands do not change the symbol or schematic.

See Also

Edit ⇒ Undo
Edit ➔ Rotate

Description

Rotate works with objects that have already been selected by the Symbol, Duplicate, Paste, or Move commands, and are attached to the cursor. The object is rotated 90° clockwise each time Rotate is selected.

NOTE
If an object has been mirrored, each application of Rotate turns it 90° counter-clockwise.

Rotate can be combined with Mirror to produce eight standard orientations, as shown in Figure 9. Symbol text is positioned and justified to read left-to-right or bottom-to-top, regardless of the object's orientation.

Figure 9. Eight Possible Orientations Using Rotate and Mirror

See Also

Edit ➔ Mirror
Edit ➔ Schematic

Description

Use the Schematic command to start the Schematic Editor while you're working in the Symbol Editor or Hierarchy Navigator. You can modify the schematic for the symbol being edited or the hierarchical design you're analyzing, then return to the Symbol Editor or Hierarchy Navigator.

If you use the Schematic Editor to change a schematic currently being analyzed in the Hierarchy Navigator, the design being viewed is automatically rebuilt the next time you execute a Hierarchy Navigator command.

See Also

Edit ➔ Symbol
Edit ➔ Symbol Origin

Description
Symbols are placed on a schematic relative to a fixed point on (or near) the symbol called the origin. Symbol Origin positions (or repositions) the origin on a symbol.

Use
When a symbol is created, it has no origin. When a symbol with no origin is saved for the first time, the origin defaults to the upper-left corner of the symbol.

To set (or change) the origin, select the Symbol Origin command and click at the desired location. The location of the assigned origin is marked with long pin-color tick marks along the border of the symbol window.

Master Symbols
The position of the origin determines the location of a Master symbol on the schematic. For example, if a Master symbol's origin is at the lower-right corner, that Master symbol will automatically be positioned at the lower-right corner of the schematic sheet.

⚠️ CAUTION The Origin is not part of the symbol. If you reposition a symbol in the Symbol Editor, the Origin does not move. If you move the symbol, you must also reposition the Origin.
Use the Symbol command to run the Symbol Editor while working in the Hierarchy Navigator or Schematic Editor.

**Use**

The Symbol command is run as follows:
1. Choose the Symbol command. You are prompted to select a symbol.
2. Click inside the desired symbol. The Symbol Editor is run on that symbol.

If you use the Symbol Editor to change a symbol from the Hierarchy Navigator, the hierarchical design currently being viewed is automatically rebuilt the next time you execute a Hierarchy Navigator command.

You can also edit a Symbol by calling the Symbol Editor directly. Select Symbol Editor from the Window menu of the Synario Project Navigator (or from the SCS Executive on UNIX/Motif systems).

**See Also**

Edit ⇒ Schematic
Edit ⇒ Table Data

Description

Enters or modifies data in tables. A table must first have been created with the Table command.

Use

Use the following procedure to modify existing data or enter new data:
1. Select the Table Data command. You are prompted to select an entry from an existing table.
2. Click on a table entry. The selected element in the table is highlighted.
3. Type the required data, then press Enter. The next element in the table is highlighted. Enter data for that element, press Enter, and continue until you've entered all the data.

The data entered can be any keyboard character except Enter. Enter is used to terminate data entry.

See Also

Add ⇒ Table

The sections on derived attributes in “Attributes” in the Schematic Entry User Manual.
**Edit ⇒ Undo**

**Description**

Reverses the editing process.

**Use**

Undo backs up one edit each time it is issued. Undo can reverse all changes since the file was opened or last saved. Saving a file, or changing the sheet size or expanding the symbol work space discards the record of the preceding changes, and they cannot be undone or redone.

Undo operates on all commands that change a schematic or symbol. It does not reverse the View or Sheet Setup commands, since these do not change the drawing. In the Symbol Editor, Undo cannot reverse a change in symbol type; you must use the Symbol Type command.

If you Undo too far, you can recover with Redo.

**See Also**

Edit ⇒ Redo
This **File** menu chapter contains information on the following menu items:

- File ⇒ New
- File ⇒ Open
- File ⇒ Print
- File ⇒ Print Image
- File ⇒ Print Setup
- File ⇒ Restart
- File ⇒ Save
- File ⇒ Save As
- File ⇒ Sheets
- File ⇒ Statistics
- File ⇒ View Report
Description

Closes the current drawing and starts a new drawing without exiting.

Use

New checks the drawing for changes since it was last saved. If the drawing was modified, New offers three options:

Save

If a file for this drawing (or database) already exists, the drawing is saved to this file. If there is no file, a dialog box prompts you for a file name. The .sym file extension for the Symbol Editor, .sch for the Schematic Editor, and .tre for the Hierarchy Navigator are automatically supplied. (If you specify an extension, it’s ignored.) The drawing (or database) is then saved in the specified file. New then clears the current drawing from the window and starts a new schematic or symbol. The new drawing is untitled until you save it.

Discard

Discards any changes made since the drawing was last saved, clears the current drawing from the window, and starts a new schematic or symbol. The new drawing is untitled until you save it.

Cancel

Returns to the current drawing.
File ⇒ Open

Description

Closes the current drawing and loads a different drawing or design, without exiting.

Use

Open checks the current drawing (or Hierarchy Navigator database) for changes since it was last saved. If the drawing was modified, Open offers three options:

Save

If a file for this drawing (or database) already exists, the drawing is saved to this file. If there is no file, a dialog box prompts you for a file name. The .sym file extension for the Symbol Editor, .sch for the Schematic Editor, and .tre for the Hierarchy Navigator are automatically supplied. (If you specify an extension, it's ignored.) The drawing (or database) is then saved in the specified file.

Discard

Discards any changes made to the drawing or design since the last Save.

Cancel

Cancels the Open command and returns to the current drawing or design.

Once changes to the current file have been saved or discarded, the Open command displays a dialog box with a list of the drawings or designs in the current directory. The list displays only those files that are of the correct type for the application. Click on a file from the list, then click on OK. (Or, just double-click on the file’s name.) You can also type a name in the File Name edit box and click on OK.

If the file you want to edit is not located in the current directory, you can change directories in the Directories edit box. Or, type the file’s full path name in File Name edit box and click on OK.
Description

Produces a hard copy of a schematic or symbol.

Use

■ **Symbol Editor** — Print immediately sends an image of the symbol to the printer.

■ **Schematic Editor** — Print checks for multiple sheets. If there is only one sheet, that sheet is printed.

  If the schematic has more than one sheet, the sheet-selector dialog box is displayed. Select a sheet by clicking on the corresponding line, then clicking on the Print button. Click on the All Sheets button to print all sheets.

■ **Hierarchy Navigator** — The sheet-selector dialog box is always displayed. Click on All Sheets to print all the sheets. Or highlight a sheet from the list box and click on This Sheet to print just that sheet.

  Click on **All Instances** to print an image of every instance in the Hierarchy.

▲ **CAUTION**  The All Instances option prints each device instance on a separate page. This can be a time- and paper-consuming print job: be sure you want to print all of the instances before selecting this option.

See Also

File ⇒ Print Image
File ⇒ Print Setup
**File ⇒ Print Image**

**Description**

Prints a rectangular portion of the current drawing.

**Use**

Drag the mouse from one corner of the area you want to print to the opposite corner. A dotted line outlines the area. This area is sent to the printer when you release the mouse button.

If the area you outline is vertically oriented (that is, it's taller than it is wide), you might want to use the Print Setup dialog box to set the paper orientation to Portrait. The image will then fill the paper.

**See Also**

File ⇒ Print
File ⇒ Print Setup
**File ➔ Print Setup**

**Description**

Calls the Windows function that sets print options.

**Use**

The most commonly used option is Orientation. Most text documents are printed with the long edge of the paper vertical (portrait orientation). Most schematics and symbols are printed with the long edge horizontal (landscape orientation).

The default setting for Synario is Landscape, and this is the orientation you would use for full schematics. However, if you are printing only a selected area from a schematic, and that area is taller than it is wide, select Portrait Orientation before printing. The selected area will then fill the sheet.

The other options (such as file type and paper tray) vary with the printer. Refer to your printer’s manual for information on these options.

**See Also**

- File ➔ Print
- File ➔ Print Image
**File ⇒ Restart**

**Description**

Initiates a forced rebuild of the current design tree loaded in the Hierarchy Navigator.

**Use**

Use Restart if you used the Symbol Editor or Schematic Editor to modify the design while it was loaded in the Hierarchy Navigator. Rebuilding the design incorporates the new symbols and new schematics in the Hierarchy Navigator's design database.

There is no need to use Restart before running a netlister (or other process). The Hierarchy Navigator automatically rebuilds the design before calling the process.

The Restart command is also used to incorporate back annotation data. If you had a design loaded in the Hierarchy Navigator and either modified a back annotation file or created a completely new back annotation file, you could incorporate the new data by executing the Restart command.
**File ⇒ Save**

**Description**

Saves the current work session in the existing file. In the Symbol and Schematic Editors, the items saved consist of wires, symbols, attributes, or graphic material added to the drawing. In the Hierarchy Navigator, they consist of the context and assigned attributes of the navigation.

**Use in the Schematic and Symbol Editors**

Save checks for an existing file. If the file exists, the drawing is updated and saved. If no file had been specified (as when saving a new drawing), you are prompted for a file name.

The Schematic Editor automatically discards any blank sheets when a Save, Save As, or Exit is performed.

**NOTE** Whenever you save a symbol or schematic, its file is fully updated and the log file containing the previous series of editing changes is discarded. You cannot, therefore, undo or redo any of those changes. Do not save a file if there are still changes you wish to undo or redo.

**Use in the Hierarchy Navigator**

Save saves the display context for the schematics being viewed. This includes such items as marked nets, the hierarchy level being viewed, and the image magnification. Save also saves any attributes added to the hierarchy since the beginning of the work session.

When the Hierarchy Navigator is started, it requires the name of the file containing the root (top-level) schematic. The Save command derives the save file name by replacing the .sch extension with .tre. Subsequent Save commands store changes in the .tre file.

**See Also**

File ⇒ Save As
**File ⇒ Save As**

**Description**

Saves the current work session under a new file name. The file with the previous name is not erased. The new file contains whatever was in the previous file, plus any changes that were made since the work was last saved under the previous name.

**Use**

Save As displays a dialog box with an edit field for the file name. Type in the desired name and click on OK. The proper file extension of .sym for the Symbol Editor, .sch for the Schematic Editor, and .tre for the Hierarchy Navigator is automatically supplied. If you specify a file extension, it's ignored.

The Schematic Editor automatically discards any blank sheets when a Save or Save As is performed.

- **NOTE**  
  Whenever you save a symbol or schematic, its file is fully updated and the log file containing the previous series of editing changes is discarded. You cannot, therefore, undo or redo any of those changes. Do not save a file if there are still changes you wish to undo or redo.

**See Also**

- File ⇒ Save
Description

The Schematic Editor can create multiple-sheet drawings. It can also display several views of the same sheet. The Sheet Setup command controls these functions. In the Hierarchy Navigator, this command is called Sheet, and it works almost identically (see the end of this reference section).

The Sheet Setup command creates a new window for each sheet displayed. Each new window is opened on top of the previous with enough offset so that some of the previous window can be seen. You can bring any sheet to the front by clicking on the visible part of its border.

Up to three views of a sheet can be opened. This permits working with a combination of an overview and two detail views of the drawing. Up to eight windows can be open at one time.

A window that is no longer needed can be closed. When only one window is left, it is enlarged to fill the main window. The title bar and border are also removed.

Use in the Schematic Editor

The Sheet Setup command displays a dialog box with a list of the existing sheets. Click on the desired sheet or enter a sheet number in the edit box, then click on one of the buttons (Figure 1).

![Figure 1. Sheets Dialog Box](image_url)
Open

Opens the selected sheet. The sheet being edited remains open.

Replace

Closes the sheet you were previously editing, then opens the selected sheet.

Modify

Allows you to modify the sheet size and sheet number. Modify displays a list box containing the sheets in the current schematic, as shown in Figure 18.

To change the sheet size, click on the new size, then click on the OK button. (Only sheet sizes large enough to accommodate the schematic data are listed.) To change the sheet number, type the new number in the edit field and click on the OK button. The maximum sheet size is 4095 x 4095 Primary grid units.

Cancel

Exits the Sheet Setup command and returns to the drawing you were editing.

![Resize Sheet Dialog Box](image)

Figure 2. Resize Sheet Dialog Box

Undo returns the sheet to the previous state and clears the Undo buffer. Redo is therefore not available after Undoing a change in sheet size.

**Selecting and Adding Sheets**

To select a sheet, click on its number in the list box. To add a new sheet, type a number for the sheet in the edit box and press ENTER. You can enter any number, even one that is not the next number in the current sequence.

When the desired sheet has been selected, click on Open or Replace. If the designated sheet does not exist, it is created using the default sheet size.

The Schematic Editor automatically deletes any blank sheets when the Save, Save As, or Exit commands are executed.
Use in the Hierarchy Navigator

The Hierarchy Navigator can view the sheets of a multiple-sheet schematic. The Sheet Setup command in the Hierarchy Navigator works identically to the command in the Schematic Editor, except that you cannot create new sheets, or modify sheet sizes or numbers.
Description

Displays the amount of memory used by the Schematic Editor or Hierarchy Navigator. The report appears in a pop-up text window. This command has different displays in the Schematic Editor and Hierarchy Navigator.

Use in the Schematic Editor

The Schematic Editor report lists each type of element in the schematic database. In most cases, the report includes the number of elements consumed, the number available, and the percentage of the block that has been consumed.

Attributes are an exception, because they're stored as variable-length records. The number of bytes consumed is shown.

On a multiple-sheet schematic, the statistics for each sheet are reported separately. The sheet numbers are at the extreme right of the line; you might need to enlarge the window to see them.

Use in the Hierarchy Navigator

The Hierarchy Navigator report lists the number of each of the following found in the design:

<table>
<thead>
<tr>
<th>Description</th>
<th>Count</th>
</tr>
</thead>
<tbody>
<tr>
<td>Types of symbols</td>
<td>The number of distinct symbols. It is equal to the sum of primitive cells and hierarchical blocks.</td>
</tr>
<tr>
<td>Primitive cells</td>
<td>The number of distinct symbols in the lowest hierarchical level.</td>
</tr>
<tr>
<td>Hierarchical blocks</td>
<td>The number of different non-primitive symbols.</td>
</tr>
<tr>
<td>Instances</td>
<td>The total number of symbol instances.</td>
</tr>
<tr>
<td>Instance pins</td>
<td>The total number of pin instances.</td>
</tr>
<tr>
<td>Primitive instances</td>
<td>The total number of symbol instances in the lowest hierarchical level.</td>
</tr>
<tr>
<td>Primitive pins</td>
<td>The total number of pin instances in the lowest hierarchical level.</td>
</tr>
<tr>
<td>Nets connected</td>
<td>The total number of nets.</td>
</tr>
</tbody>
</table>

This information gives a rough indication of the size of your design.
Record Types

The report is followed by a list of ten types of records used to store information. Each record type is followed by a measure of the capacity consumed. The following record types are fixed-length and are reported as number consumed, number available, and percentage of the block that has been consumed:

- Definitions
- Instances
- Nets
- Pins
- Generic pins

The remaining five types are attribute records. Because each of these records is of variable length, only the percentage of the memory block consumed is shown:

- Definition attributes
- Instance attributes
- Net attributes
- Pin attributes
- Generic pin attributes
**File ➔ View Report**

**Description**
Displays error (.err) files for the current project. You would most often use view error files, but the View Report command can display any text file, with any extension.

**Use**
The View Report command displays the generic "Open File" dialog box, labeled "Report File Name." All error files in the current directory are listed. If you want to list all the files in the directory, type "*.*" in the File Name edit box, then press Enter.

Highlight one of the files in the list and click on OK (or just double-click on its name) to load it. If the file you want isn't displayed, use the Drives and Directories controls to select a different file. If you know the name and location of the file, you can type the full pathname in the File Name edit box and click on OK.

The files contents are displayed in a list box. Clicking on any line in the box highlights the error (or the component with the error) in the Hierarchy Navigator's window.
Help Menu

Description

Accesses the Help system.

Use

Online help is available at any time. Choose the Contents command from the Help menu to enter the top level of the help system for the Schematic and Symbol Editors, and the Hierarchy Navigator. Or choose the Search for Help On command to select from a list of Editor and Navigator topics.

Most commands remain active until you select another command. To get help on the currently active command, simply press F1.

If you are not familiar with the Microsoft Help system, the How to Use Help command explains how to navigate the Help system.
This DRC menu chapter contains information on the following menu item:

- DRC ⇒ Highlight
- DRC ⇒ Mark
- DRC ⇒ Query
- DRC ⇒ Consistency Check
- DRC ⇒ Check Circuit
DRC $\Rightarrow$ Highlight

Description

Helps trace nets in a schematic. Highlighting a net changes its color (or turns it into a dashed line on a monochrome monitor). If the net is a signal in a bus, the bus is also highlighted.

Use

To trace a net:

1. Select the HiLite command.
2. Click on a wire in the net to be highlighted. More than one net at a time can be highlighted.

To remove the highlight from a net:

Click on any branch of the highlighted net. If a bus containing this net was highlighted, it also returns to its original color (if none of its other signals are still highlighted).

To remove the highlights from all nets in the schematic:

Click right anywhere in the window.
DRC ⇒ Mark

Description
Assigns nets and symbols to a special group. Nets are highlighted in the Net Highlight color (or as dashed lines on monochrome monitors). Symbols are highlighted in the HighlightSymbol color (in gray on monochrome monitors). Marked symbols are redrawn on top of a colored or shaded background.

Use Mark to trace nets through the hierarchy. By marking a net and then entering each sub-block, you can view the entire net.

Net marking can also be used by some of the post-processors to identify special nets and symbols. It's used in the Simulator interface to identify nets to be monitored or graphed.

Use
Marked nets and symbol instances are saved when the hierarchy is saved.

To mark a net or symbol:
1. Select the Mark command.
2. Mark a net or symbol by clicking on it, or by typing a full hierarchical name and pressing Enter.

To unmark a net or symbol:
Clicking on the marked item. Or ...

You can unmarked all nets and symbols simultaneously by typing All in the prompt line and pressing Enter. You cannot unmark an individual net by name.

To list all marked nets and symbol instances:
Enter a question mark (?) to display a text window with a list of all the marked nets and symbol instances.
DRC \(\Rightarrow\) Query

Description
Displays additional information about circuit elements. The information appears in a text box that pops up when the first element is selected, and is updated when another element is selected. In the Hierarchy Navigator, the Query box remains on-screen as the Push/Pop command is used to traverse the hierarchy.

Use
Select the circuit element to be queried by clicking on it, or by typing either its instance name or reference designator and pressing ENTER. In the Hierarchy Navigator, use the full hierarchical name of a bus or net as it would appear on a net name.

Four types of objects can be queried. If the mouse cursor points at more than one object when you click, the object closest to the top of the following list will be selected:

- Pin
- Net
- Bus
- Symbol

You can also select a pin or net by typing \(p=\text{pin\_name}\) or \(n=\text{net\_name}\) on the prompt line and pressing Enter. If the \(\text{pin\_name}\) does not duplicate a net name, or the \(\text{net\_name}\) duplicate a pin name, you can enter the name directly, without the \(p=\) or \(n=\).

Pins
Symbol pins can be queried in the Schematic Editor or Hierarchy Navigator. If you select a bus pin, a dialog box prompts you for a specific pin from that bus to query. The information displayed for a pin query is:

- Pin name
- Instance attachment
- Net attachment
- Polarity
- Fan-out
- Other pin attributes
Nets

A queried net is highlighted by a change in color (or by dashed lines on a monochrome display). The information displayed is:

- Net name
- Polarity (if input or output node)
- Local net name (applicable only on underlying schematics)
- Node number in database
- Symbol connections
- Other net attributes

![Figure 1. Bus Query Net List Box](image)

Buses

A queried bus is highlighted by a change in color (or being drawn in dashed lines on a monochrome display). The information displayed is:

- Bus name
- Individual nets contained in the bus
- Symbol connections (Schematic Editor only)

When you click on individual nets in the bus list box (Figure 2), a netlist box (Figure 1) is displayed with all the information for the selected net. The behavior of the second list box is the same as described for querying nets, with this exception. Clicking on the line

**In Bus=**

returns to the bus list box, allowing you to jump between all the elements in a bus and more detailed information about a single bus element.
Symbols

A symbol instance can be queried by clicking on it, or by typing its name and pressing Enter. In the Hierarchy Navigator, use the full hierarchical name as it would appear in the instance name text window. When querying an iterated instance in the Hierarchy Navigator, a dialog box lets you choose which instance to query.

*To resolve a name conflict between an instance and a net:*  
Precede the instance name with `I` to force its selection.

The selected symbol is highlighted with a colored (or shaded) background. The field of view automatically changes to display a queried symbol that is not currently visible.

![Figure 2. Bus List Box Displayed from Bus Query](image)

**Query Information**

The information displayed by Query is:

- The name (for example, NAND2, NOR3) and type (gate, component, block, cell, master, pin) of the symbol
- Full path (showing location of symbol file in the file structure)
- Instance name
- Reference designator
- Other symbol attributes
- Reference location on the schematic (sheet/vertical zone/horizontal zone)
- Gate section (A, B, C, and so on) on gate symbols
- Instance number in the hierarchical database (Hierarchy Navigator only)
- Pin/net connections
Type

All instances of a symbol type can be queried. Press SHIFT while clicking on a symbol of that type. Or, type the symbol’s name and press ENTER. All instances of the selected symbol type are highlighted with a colored (or shaded) background.

To resolve a name conflict between a net or symbol instance with the same name as the symbol type:

Precede the type name with T to force its selection.

The information displayed by Query in this case is:

- Internal net count
- Instance names and locations (sheet / vertical zone / horizontal zone)

Reference Designator

To query a symbol with a specified reference designator:

Enter the name of the reference designator. In the case of gate symbols, the first section with a specified reference designator is queried.

The specified symbol is highlighted with a colored (or shaded) background, and a plus cursor is centered on the symbol. The queried element remains highlighted until a new element is selected, a new command is selected, or you click right anywhere on the screen. The information display remains visible as long as an element is selected for interrogation.

For Gate symbols, the Query box displays the gate letter as A for the first gate, B for the second, and so on.

To find a particular gate:

Enter the reference designator, followed by a slash (/) and the gate letter. For example, enter U1/B to find the symbol whose reference designator is U1.

NOTE

In the Hierarchy Navigator, Query allows querying of nodes or instances by name or number.
DRC ⇒ Consistency Check

Description

These commands locate errors (and potential errors) in schematics and symbols.

Use

The error report is written to the file `design.err` and displayed in a pop-up text window. Click on an error in the window to display the sheet (or section of the symbol) with that error and highlight the error.

Schematic Errors (Consistency Check Command)

The Consistency Check command warns about the following potential schematic errors:

- Bus taps should be named.
- Isolated net names are not permitted.
- If the Show Symbol Pins option is enabled, each pin on symbols in this schematic should be connected to a net (unless the pin has its OpenOK attribute set to Yes).
- If the Mark Open Ends option is enabled, there should not be any unconnected wire ends.
- Unordered buses must not be connected to a bus pin on a symbol.
- Unordered buses must not be marked with I/O markers.
- Nets should not be marked with more than one I/O marker.
- A bus tap and its bus should not both be marked with an I/O marker.
- If there is a Block symbol for this schematic, the Consistency Check command marks the following as errors:
  - Each pin must have a corresponding net with an I/O marker whose direction matches the Polarity of the pin.
  - Each net marked with an I/O marker must correspond to a pin.

Symbol Errors (Check Command)

The Check command warns about the following potential symbol errors:

- Block symbols should have a schematic with the same name in the symbol's directory.
- Symbols other than Blocks are usually primitives and should not have a schematic of the same name.
- Each pin in a Block or Cell should have a Name. Each pin in a Gate or Component should have a PinNumber.
- Pins in Component and Pin symbols should have only one PinNumber.
■ Pins on non-Block symbols should specify Load or Drive. Input pins should have Load but not Drive. Output pins should have Drive, but not Load, unless the pin is tristate. In that case it should have a Load that represents the load in the High-Z state. Bidirectional pins should have both Load and Drive.

The Check command marks the following as symbol errors:

■ Every pin in a Gate must appear in the same number of sections. Therefore, all PinNumber attributes must have the same number of pin numbers.

■ Pins in the same Gate group must have the same Polarity, Load and Drive.
DRC ⇒ Check Circuit

Description

The Check Circuit command from the Tools menu performs basic connectivity checks and analyzes the current loading or fanout of a completed design. It also performs a packaging check on PCB designs to ensure that gates are correctly assigned to physical components.

Use

Check Circuit generates a list box with the errors. Click left on any of the errors listed and the portion of the circuit responsible for the error is highlighted on the schematic.

The Check Circuit utility is a separate module, `checkckt.exe`. It is more fully described in “Hierarchy Navigator” in the *Schematic Entry User Manual*. 
This **Option** menu chapter contains information on the following menu items:

- Option ⇒ Display Options
- Option ⇒ Graphic Options
Options ⇒ Display Options

Description
Sets a number of display options in the Schematic Editor and Hierarchy Navigator. Unless otherwise noted, an option applies to both the Editor and the Navigator. Any changes are temporary. Use the INI Editor to make permanent changes.

Use
The Display Options dialog box offers the following options:

Connect Dots
Three nets connected to a symbol pin or the junction of four nets are always drawn with a connect dot. When this check box is marked, the connect dot is also displayed when two nets are connected to a symbol pin, and at the junction of three nets.

Border
When this check box is marked, the sheet border and zone numbers are displayed.

Symbol Pins
When this check box is marked, unconnected pins are drawn with an error dot to highlight them.

Net Attributes
When this check box is not marked, text for net attribute values is not displayed. This decreases redrawing time and visual clutter. Note that only net attributes that have net attribute windows defined are displayed even when this check box is marked.

Pin Attributes
When this check box is unmarked, pin attributes are not displayed. This decreases redrawing time and visual clutter.

Symbol Text
When this check box is unmarked, fixed text in symbols is not displayed. This decreases redrawing time and visual clutter.

Symbol Attributes
When this check box is not marked, text for symbol attribute values is not displayed. This decreases redrawing time and visual clutter.

Open Ends
When this check box is marked, nets not terminating on a net name, symbol pin, or another net are marked with an error dot at their ends. An error dot is also placed on any net name not connected to a net.

Off Page Connects
When this check box is marked, nets that appear on more than one sheet will display a cross-reference to the other sheets, if you placed the name at the off-page end of the wire.
Simulation Values  When this check box is marked, simulation values can be displayed directly on a schematic in the Hierarchy Navigator (Hierarchy Navigator only).

Show Node Numbers  When this check box is marked, SPICE node numbers are displayed next to the node names (Hierarchy Navigator only).

Figure 1. Display Options Dialog Box
Options ⇒ Graphic Options

Description

Sets parameter values for the graphics drawing and attribute-window commands in the Symbol and Schematic Editors.

Use

When you select the Graphic Options command, a dialog box offers the following options:

Figure 2. Graphic Options Dialog Box

- **Text** — Selects the text size. The choices are Small, Medium, and Large, corresponding to 5, 7, and 9 quarter-grid units in height. Text Font affects only the text to be added, not existing text.

- **Justification** — Text can be left-justified, right-justified, or centered. This parameter applies to fixed graphic text and symbol attribute windows. Justify affects only the text to be added, not existing text.

- **Constrain Cursor To** — All electrical elements in schematics and symbols are drawn on the main working grid, as specified in the INI Editor. Graphic elements and text can be positioned on a finer grid of one-half (Mid) or one-quarter (Sec) the main grid.

- **Display** — Controls whether the primary grid is displayed. The grid appears as dots, with one dot at every grid intersection. Every tenth grid point is larger. As you zoom out and the grid points get closer, some grid dots might not be displayed.

- **Full Cursor** — Choose between a small “plus” cursor (the default) and a full-screen cursor. The full-screen cursor makes it easy to align objects.

- **Graphics** — There are two line weights for drawing lines and rectangles. The Wide Line check box selects the heavier weight. Heavy lines have the same weight as buses on schematics.
■ **Vertical Text** — Fixed text and attribute window text can be horizontal or vertical. Horizontal is the default. Mark the Vertical Text check box for vertical. Vertical Text affects only the text to be added, not existing text.
Tools Menu

This Tools menu chapter contains information on the following menu items:

- Tools ⇒ Find Item
- Tools ⇒ Probe Item
Tools ⇒ Find Item

Description
Locates the output pin driving the net being queried. This is useful for back-tracing signals during the analysis of simulation results.

Use
Select the command, then click on a net. The schematic with the pin that drives that net is displayed, and the pin is highlighted.
Tools ⇒ Probe Item

Description

Identifies the name of a symbol instance or net to the currently running tool.

Use

To probe an item:

1. Choose Tools: Probe Item
2. Click on the item you want to probe.

The name of the item is sent to the tool. Probe Item does not display the Query box, but it uses the Query box if it is already open when the command is run. This lets you Query several nodes without sending the names to the tool, then switch to the Probe Item command to send more names to the tool.

The Probe Item command is initially disabled. When a tool is running that allows its use, Probe Item is enabled.
View Menu

This View menu chapter contains information on the following menu items:

- View ⇒ Full Fit
- View ⇒ Pan
- View ⇒ Push/Pop
- View ⇒ Redraw
- View ⇒ Zoom In
- View ⇒ Zoom Out
View ⇒ Full Fit

Description

Adjusts the magnification so the current drawing just fills the screen. The cursor changes to the zoom cursor, a capital Z.

Use

The Full Fit command has two operating modes, click and drag:

Click Mode

Click mode toggles between a full-screen display, and display at the magnification before the command was run.

Click once to fill the window with the drawing. Then click again on the part of the drawing you want to see in more detail. The window is returned to the original magnification, with the selected component centered. (The component may not be centered if it is near an edge.) Using Click mode is a way to move quickly around a schematic, looking at various areas in detail.

Drag Mode

Click to fill the screen with the drawing. Then drag the mouse to select a rectangular area you want to view in more detail. The selected area is centered in the window, at the highest magnification that permits the full area to be viewed.

You can drag repeatedly to view smaller and smaller areas of the drawing. Or you can click a second time to see the full drawing, then drag to select a different area.

Limits

There is an upper limit to the magnification. When you have reached that limit, a message in the message line will warn you.

Text cannot be drawn below a minimum magnification that corresponds to one vertical pixel for one-quarter of a major grid. Below this point, text strings are replaced by outline boxes. The minimum magnification scale for displayable text is the base magnification. The allowable magnifications in terms of this base are 1/8x, 1/4x, 1/2x, 1x, 2x, 3x, and 4x.

View commands are “nested.” If run while another command (not a View command) is active, the active command's status is saved. When the View command is terminated by clicking right, the previous command is restored. You can also terminate Full Fit by selecting another command.
**View ⇒ Pan**

**Ctrl+W**  
**Sch, Sym, Nav**

**Description**

Increases the magnification and repositions the viewing window at the object of interest. The cursor changes to the zoom cursor, a capital Z.

**Use**

Pan has two operating modes, click and drag:

**Click**

Click at the point you want centered. The window is redrawn at the current magnification with the selected point at the center. (If the point is near an edge of the drawing, it may not be centered.)

**Drag**

Drag the mouse to outline a rectangular area. When you release the mouse button, the window is redrawn with the rectangular area centered at the highest magnification that permits the entire area to be displayed.

Pan can be terminated and any previously active command restored by clicking right anywhere in the window. Selecting any other command also terminates Pan.

**Limits**

There is a limit to the magnification. When the maximum magnification is reached, additional use of Pan in the drag mode changes the center point, but does not change the magnification.

View commands are “nested.” If run while another command (not a View command) is active, the active command's status is saved while the View command is executed. When the View command is terminated by clicking right, the previous command is restored.
**View ⇒ Push/Pop**

**Description**
Traverses the design hierarchy.

**Use**

**Push** moves to a lower (more detailed) level in the hierarchy.

**Pop** moves to a higher (less-detailed) level in the hierarchy.

*To push into a symbol:*
1. Choose View: Push/Pop.
2. Click within the symbol boundary. If the symbol represents a lower-level schematic, that schematic replaces the schematic currently on the screen. If the symbol represents a behavioral file, that file is displayed in the Text Editor.

*To pop back to the parent of the current schematic:*
3. Choose View: Push/Pop.

Click outside all symbol boundaries. The parent schematic replaces the schematic currently on the screen, unless the current schematic is the highest level (root) of the hierarchy.

Alternatively, you can type the instance name of the destination schematic at the prompt and press Enter.

**NOTE**

If you are viewing a behavioral file, you must close the file to return to the previous level.

**Hierarchical Context**

Full hierarchical context is maintained when pushing or popping. All net names are shown with their full hierarchical representations. Symbol instance names are shown in an abbreviated format that replaces the leading portion of an instance name with a dot. For example, the instance .AB.CD.EF is displayed as .EF.

**Nested Command**

Push/Pop is a “nested” command. If Push/Pop is run during another command (such as Query or Attribute), you can cancel Push/Pop and return control to the previously active command by clicking right anywhere in the window.
**View ⇒ Redraw**

**Description**

Repaints the current window.

**Use**

Some operations (such as Copy or Delete) can leave “trash” pixels or incomplete lines. Use the Redraw command to clean up the image. The screen is redrawn as soon as this command is selected.
View ⇒ Zoom In

Description

Increases the magnification, showing a portion of the current drawing in more detail. The cursor changes to the zoom cursor, a capital Z.

Use

Zoom In operates in two modes, click and drag:

Click

Click at the point in the drawing to be centered. The screen is redrawn at the next-higher magnification, centered at the selected point. (If the point is near an edge of the drawing, it may not be centered.)

Each click increases the magnification one step in the scale (1/8x, 1/4x, 1/2x, 1x, 2x, 3x, and 4x). At 4x, a message reminds you that you have reached the maximum magnification.

Drag

Drag the mouse to define a rectangular area. When you release the mouse button, the selected area is centered at the highest magnification that permits the selected area to be fully displayed. Magnification is limited to the same values listed in click mode.

Zoom In can be terminated and the previous command restored by clicking right anywhere in the window. Selecting any other command also terminates Zoom In.

View commands are “nested.” If run while another command (not a View command) is active, the active command’s status is saved while the View command is executed. When the View command is terminated by clicking right, the previous command is restored.
**View ➔ Zoom Out**

Sch, Sym, Nav

**Description**

Decreases the magnification, displaying more of the current drawing in less detail.

**Use**

Click at the point in the drawing that you want to be the new center. The drawing is displayed with the new magnification and center point. (If the point is too near an edge, it may not be centered.)

**Limits**

Each click decreases the magnification one step in the scale (4x, 3x, 2x, 1x, 1/2x, 1/4x, and 1/8x). At 1/8x, a message reminds you that you have reached the minimum magnification.

Zoom Out can be terminated and the previous command restored by clicking right anywhere in the window. Selecting any other command also terminates Zoom Out.

Text cannot be drawn below a minimum magnification. This corresponds to one vertical pixel for one-quarter of a major grid. Below this point, text strings are replaced by outline boxes. The minimum magnification scale for displayable text is the base magnification. The allowable magnifications in terms of this base are 1/8x, 1/4x, 1/2x, 1x, 2x, 3x, and 4x.

View commands are “nested.” If run while another command (not a View command) is active, the active command's status is saved while the View command is executed. When the View command is terminated by clicking right, the previous command is restored.
### Index

**A**
- Add menu 12
- Arc command 13
- Attribute Location command 43
- Attribute Window command 45
- Attribute windows 45
  - defining 45
  - display options 106
  - moving 43
  - positioning 45
  - reassigning 45
- Attributes 49
  - assigning values to symbols 49
  - defining windows 45
  - deleting values 53
  - modifying bus attributes 53
  - moving windows 43
  - pin 48
  - table data 37
  - window options 106
- Auto-increment 19
  - instance names 19
  - of net names 25

**B**
- Back annotation 25
  - incorporating data 83
- Big Bubble command 14
- Block symbol 28
- Creating 28
- Border 104
- Bubble command 14

**Bus names**
- attaching compound name 17, 18

**Bus Tap command**
- Add menu 15

**Bus taps**
- adding 15

**Buses**
- entering in the block symbols 29
  - expanded bus name 17
  - modifying attributes 53
  - querying 97
  - tapping 15

**C**
- C mode (drawing wires) 41
- Check Circuit command 102
  - DRC menu 102
- Circuit checking 102
- Circuit elements 96
  - querying 96
- Clipboard 60
  - copy to 60
  - cutting to 61
  - pasting 69
- Connect dots 104
- Consistency Check command 100
  - DRC menu 100
- Constants command 57
  - Edit menu 57
- Copy command 58
  - Edit menu 58
- Copy Image command 60
  - Edit menu 60
- Copying 58, 60
- Crossing wires limitations 63
- Cursor 106
- Cut command 61
  - Edit menu 61
  - Cutting 61
<table>
<thead>
<tr>
<th>Index</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>D</strong></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
</tbody>
</table>

**E**  
Edit menu 42  
Error checking 100  
Errors  
  - checking 102  
  - viewing 91  
Expand Page command  
  Edit menu 55  
Expanded Bus Name command  
  Add menu 17  
Expanding the symbol work area 55  

**F**  
File menu 77  
Find button 50  
Find Item command  
  Tools menu 109  
Font 106  
Full cursor 106  
Full Fit command  
  View menu 112  

**G**  
Gates  
  querying 99  
Global constants  
  changing 57  
Global nets 26  
  named symbol 27  
  no symbol 27  
  types 26  
  unnamed symbol 26  
Graphic elements  
  Arc 13  
  Line 22  
  Rectangle 31  
  tables 35  
  text 39  
Graphic options 106  
Graphic options command  
  Options menu 106  
Grid 106  
  displaying 106  
Group-select 58  

**H**  
Help menu 92  
Hierarchy  
  moving through 114  
Highlight command  
  DRC menu 94  

**I**  
I/O Marker command  
  Add menu 18  
I/O markers  
  adding/deleting 26  
Incorporating back annotation data 83  
Instance Name command  
  Add menu 19  
Instance names  
  assigning 19  
  auto-increment mode 19  
  conflicts 98  
  iterated instances 20  
  pin connections to iterated 20  
Iterated instances  
  pin connections 20  

_Schematic Entry Reference Manual_ 119
Index

J
Justification 106

L
Line command
Add menu 22
Lines
changing weight 106

M
Mark command
DRC menu 95
Master symbols
positioning 73
Mirror command
Edit menu 68
Mirroring 68
Moving through hierarchy 114

N
Net Attribute command
Edit menu 52
Net Attribute Window command
Edit menu 54
Net attributes
assigning values 52
displaying 54
modifying 52
Net Name command
Add menu 23
Net names
auto-increment mode 25
compound 23
conflicts 98
editing 26
entering 24
sequential 23, 25
simple 23
simple and compound 23
Nets
adding attributes 52
displaying connect dots 104
displaying off-page connects 105
editing names 26
global 26
probing for name of 110
querying 97
renaming 25
selecting 52
tracing 94, 95

New Block Symbol command
Add menu 28
New command
File menu 78

O
Off page connects 104
Open command
File menu 79
Open ends 104
Option menu 103
Orientation
of symbols 33
page 82
Origin
setting 73

P
Page orientation 82
Pan command
View menu 113
Paste command
Edit menu 69
Pasting 69
Pin Attribute command
Edit menu 48
Pin attributes 48
Pin command
Add menu 30
Pin Name Location command
Edit menu 47
Pin names
location of 47
Pins
adding 30
assigning attributes 48
order in block symbol 29
querying 96
symbol connections 33
tracing signals 109
Point-to-point mode (drawing wires) 40
Print command
File menu 80
Print Image command
File menu 81
Print Setup command
File menu 82
Printer setup 82
Printing
  page orientation 82
  parts of the screen 81
  printer setup 82
  schematics and symbols 80
Probe Item command
  Tools menu 110
Push/Pop command
  View menu 114

Q
Query command
  DRC menu 96
Query information 98
Querying circuit elements 96

R
Rebuilding the design 83
Rectangle command
  Add menu 31
Redo command
  Edit menu 70
Redraw command
  View menu 115
Reference designators
  querying symbols by 99
Repeating commands 70
Replacing symbols 33
Restart command
  File menu 83
Reversing commands 76
Rotate command
  Edit menu 71
Rotating 71

S
Save As command
  File menu 85
Save command
  File menu 84
Saving files 84, 85
Schematic command
  Edit menu 72
Schematics
  making symbols for 29
  opening 79
  opening new 78
  printing 80
  saving 84
  saving as 85
Selecting items to copy 58
Selection
  of nets 52
Setting pin location 47
Setting symbol origin 73
Sheet Setup command 86
Sheets
  selecting 86
Sheets command
  File menu 86
Show node numbers 105
Signal tracing 109
Single-segment mode (drawing wires) 40
Statistics
  design types 90
  use in the Hierarchy Navigator 89
  use in the Schematic Editor 89
Statistics command
  File menu 89
Symbol Attribute command
  Edit menu 49
Symbol attributes
  adding 49
  modifying 50
Symbol command
  Add menu 32
  Edit menu 74
Symbol Editor
  calling from Schematic Editor 74
Symbol origin
  setting 73
Symbol Origin command
  Edit menu 73
Symbol pins
  location 47
Symbol Type command
  Edit menu 56
Symbols
  assigning attribute values 49
  calling the Symbol Editor 74
  changing orientation 33
  changing type of 56
  expanding work area for 55
  labeled 27
  making schematics for 29
  new block 28
  pin connections 33
  placement checks 33
  placing 33
Index

positioning Master symbols 73
printing 80
probing for name of 110
querying 98
querying by reference designator 99
querying instances of 99
replacing 33
saving 84
saving as 85
schematic and symbol incompatibility 69
selecting 32
selecting by attribute 50
selecting by attribute criteria 50
tracing 95
unlabeled 26

T
Table command
   Add menu 35
Table data
   adding/editing 35
   referencing 36
Table Data command
   Edit menu 75
Tables
   editing data 75
   rows and columns 36
Text
   adding 39
   font 106
   formatting 107
   justification 106
   vertical 107
Text command
   Add menu 39
Tools menu 108
Tracing nets
   highlighting 94
   marking 95
Tracing signals 109

U
Unconnected symbol pins 104
Undo command
   Edit menu 76
Undoing commands 76
User-assigned instance names 19

V
View menu 111
View Report command
   File menu 91
Viewing controls
   Full Fit 112
   Pan 113
   push/pop 114
   redraw 115
   Zoom In 116
   Zoom Out 117
Viewing errors 91

W
Window
   net attribute 54
Wire command
   Add menu 40
Wires
   adding 40
   crossing limitations 63
   delete limitations 63

Z
Z mode (drawing wires) 41
Zoom In command
   View command 116
Zoom Out command
   View menu 117