Lattice Diamond 1.3
Installation Notice

Lattice Semiconductor Corporation
5555 NE Moore Court
Hillsboro, OR 97124
(503) 268-8001

July 2011
Copyright
Copyright © 2011 Lattice Semiconductor Corporation.

This document may not, in whole or part, be copied, photocopied, reproduced, translated, or reduced to any electronic medium or machine-readable form without prior written consent from Lattice Semiconductor Corporation.

Trademarks
Lattice Semiconductor Corporation, L Lattice Semiconductor Corporation (logo), L (stylized), L (design), Lattice (design), LSC, CleanClock, E²CMOS, Extreme Performance, FlashBAK, FlexiClock, flexiFlash, flexiMAC, flexiPCS, FreedomChip, GAL, GDX, Generic Array Logic, HDL Explorer, IPexpress, ISP, ispATE, ispClock, ispDOWNLOAD, ispGAL, ispGDS, ispGDX, ispGDXV, ispGDX2, ispGENERATOR, ispJTAG, ispLEVER, ispLeverCORE, ispLSI, ispMACH, ispPAC, ispTRACY, ispTURBO, ispVIRTUAL MACHINE, ispVM, ispXP, ispXPGA, ispXPLD, Lattice Diamond, LatticeCORE, LatticeEC, LatticeECP, LatticeECP-DSP, LatticeECP2, LatticeECP2M, LatticeECP3, LatticeMico8, LatticeMico32, LatticeSC, LatticeSCM, LatticeXP, LatticeXP2, MACH, MachXO, MachXO2, MACO, ORCA, PAC, PAC-Designer, PAL, Performance Analyst, Platform Manager, ProcessorPM, PURESPED, Reveal, Silicon Forest, Speedlocked, Speed Locking, SuperBIG, SuperCOOL, SuperFAST, SuperWIDE, sysCLOCK, sysCONFIG, sysDSP, sysHSI, sysI/O, sysMEM, The Simple Machine for Complex Design, TransFR, UltraMOS, and specific product designations are either registered trademarks or trademarks of Lattice Semiconductor Corporation or its subsidiaries in the United States and/or other countries. ISP, Bringing the Best Together, and More of the Best are service marks of Lattice Semiconductor Corporation.

Other product names used in this publication are for identification purposes only and may be trademarks of their respective companies.
## Type Conventions Used in This Document

<table>
<thead>
<tr>
<th>Convention</th>
<th>Meaning or Use</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Bold</strong></td>
<td>Items in the user interface that you select or click. Text that you type into the user interface.</td>
</tr>
<tr>
<td><em>Italic</em></td>
<td>Variables in commands, code syntax, and path names.</td>
</tr>
<tr>
<td><strong>Ctrl+L</strong></td>
<td>Press the two keys at the same time.</td>
</tr>
<tr>
<td><strong>Courier</strong></td>
<td>Code examples. Messages, reports, and prompts from the software.</td>
</tr>
<tr>
<td>...</td>
<td>Omitted material in a line of code.</td>
</tr>
<tr>
<td>.</td>
<td>Omitted lines in code and report examples.</td>
</tr>
<tr>
<td>.</td>
<td>.</td>
</tr>
<tr>
<td>[ ]</td>
<td>Optional items in syntax descriptions. In bus specifications, the brackets are required.</td>
</tr>
<tr>
<td>( )</td>
<td>Grouped items in syntax descriptions.</td>
</tr>
<tr>
<td>{ }</td>
<td>Repeatable items in syntax descriptions.</td>
</tr>
<tr>
<td></td>
<td>A choice between items in syntax descriptions.</td>
</tr>
</tbody>
</table>
Contents

Installing Diamond Tools   1
System Requirements   1
   Memory Requirements   2
   Required Support Libraries   3
Contacting Technical Support   5
Installer Contents   6
Diamond Installed Directory Structure   6
Installing Lattice Diamond   7
   Installing Stand-Alone Reveal Analyzer   8
   Installing Stand-Alone Programmer   9
Licensing Lattice Diamond   9
   Obtaining a License   10
   Editing the License File   10
   Starting the License Manager   11
   Stopping the License Manager   11
   Setting Up a Floating License on Linux   12
Running the Lattice Diamond GUI   12
   Using the Examples Directory   13
   Finding the Installation History   13
Running Lattice Diamond from the Command Line   14
   Running Tcl Console   14
   Running Executables   14
Installing Diamond Tools

This document provides installation instructions for the Lattice Diamond® Linux software.

Diamond supports LatticeEC™, LatticeECP™, LatticeECP2™, LatticeECP2M™, LatticeECP3™, LatticeSC™, LatticeSCM™, LatticeXP™, LatticeXP2™, MachXO™, MachXO2™, and Platform Manager™ designs.

**Note**

The available devices vary depending on the type of license.

**System Requirements**

The following are the basic system requirements for Lattice Diamond on Linux:

- Intel Pentium or Pentium-compatible PC, or AMD Opteron system support
  For Programmer and ispVM System, it contains a 32-bit driver to support the 32-bit system only.

- Red Hat Enterprise Linux version 4.X or 5.X, or Novell SUSE Linux Enterprise 10 SP1 or 11 operating system
The host operating system can be either 32-bit or 64-bit. Diamond is a 32-bit application requiring 32-bit support libraries in order to run on a 64-bit host operating system.

- Approximately 5.75 GB free disk space
- Network adapter and network connectivity

**Note**

A floating license requires access to the license server, so both a network adapter and connectivity are required.

- 1024 x 768 graphics display
- JScript-capable Web browser
- Adobe Acrobat Reader, or equivalent PDF reader

## Memory Requirements

Table 1 lists the minimum memory requirements and recommended memory for all the Lattice Semiconductor FPGA families.

### Table 1: Recommended Memory for Linux

<table>
<thead>
<tr>
<th>Device</th>
<th>Size</th>
<th>Minimum</th>
<th>Recommended</th>
</tr>
</thead>
<tbody>
<tr>
<td>LatticeEC,</td>
<td>Up to 20K LUT</td>
<td>512 MB</td>
<td>768 MB</td>
</tr>
<tr>
<td>LatticeECP</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Up to 50K LUT</td>
<td>768 MB</td>
<td>1 GB</td>
</tr>
<tr>
<td>LatticeECP2/M</td>
<td>Up to 20K LUT</td>
<td>768 MB</td>
<td>1 GB</td>
</tr>
<tr>
<td></td>
<td>Up to 50K LUT</td>
<td>1 GB</td>
<td>1.5 GB</td>
</tr>
<tr>
<td></td>
<td>Up to 100K LUT</td>
<td>1 GB</td>
<td>2 GB</td>
</tr>
<tr>
<td>LatticeECP3</td>
<td>Up to 95K LUT</td>
<td>2 GB</td>
<td>3 GB</td>
</tr>
<tr>
<td></td>
<td>Up to 150K LUT</td>
<td>3 GB</td>
<td>4 GB</td>
</tr>
<tr>
<td>LatticeSC/M</td>
<td>Up to 40K LUT</td>
<td>768 MB</td>
<td>1 GB</td>
</tr>
<tr>
<td></td>
<td>Up to 115K LUT</td>
<td>1 GB</td>
<td>2.5 GB</td>
</tr>
<tr>
<td>LatticeXP,</td>
<td>Up to 20K LUT</td>
<td>512 MB</td>
<td>768 MB</td>
</tr>
<tr>
<td>LatticeXP2</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Up to 50K LUT</td>
<td>768 MB</td>
<td>1 GB</td>
</tr>
</tbody>
</table>
Required Support Libraries

Diamond is packaged in Red Hat Package Manager format (RPM). In order to install Diamond, several support libraries must be acquired from the operating system vendor's repository. See the following tables.

Also, the Perl 5 site library needs to be updated in order to use Lattice Mico System. To update the site library, enter the following sequence of commands:

```bash
sudo cpan App::cpanminus
sudo cpanm XML::DOM
sudo cpanm XML::Parser
sudo cpanm XML::RegExp
```

<table>
<thead>
<tr>
<th>Device</th>
<th>Size</th>
<th>Minimum</th>
<th>Recommended</th>
</tr>
</thead>
<tbody>
<tr>
<td>MachXO, MachXO2</td>
<td>All</td>
<td>256MB</td>
<td>512MB</td>
</tr>
<tr>
<td>Platform Manager</td>
<td>All</td>
<td>256 MB</td>
<td>512 MB</td>
</tr>
</tbody>
</table>

Table 2: Diamond Base

<table>
<thead>
<tr>
<th>Module</th>
<th>Size</th>
<th>Minimum</th>
<th>Recommended</th>
</tr>
</thead>
<tbody>
<tr>
<td>libc.so.6</td>
<td>libgthread-2.0.so.0</td>
<td>libstdc++.so.5</td>
<td></td>
</tr>
<tr>
<td>libdl.so.2</td>
<td>libgtk-1.2.so.0</td>
<td>libtiff.so.3</td>
<td></td>
</tr>
<tr>
<td>libfontconfig.so.1</td>
<td>libICE.so.6</td>
<td>libutil.so.1</td>
<td></td>
</tr>
<tr>
<td>libfreetype.so.6</td>
<td>libjpeg.so.62</td>
<td>libX11.so.6</td>
<td></td>
</tr>
<tr>
<td>libgd-1.2.so.0</td>
<td>libm.so.6</td>
<td>libXext.so.6</td>
<td></td>
</tr>
<tr>
<td>libglib-1.2.so.0</td>
<td>libpng12.so.0</td>
<td>libXft.so.2</td>
<td></td>
</tr>
<tr>
<td>libglib-2.0.so.0</td>
<td>libpthread.so.0</td>
<td>libXi.so.6</td>
<td></td>
</tr>
<tr>
<td>libgmodule-1.2.so.0</td>
<td>libr.so.1</td>
<td>libXrender.so.1</td>
<td></td>
</tr>
<tr>
<td>libghread-1.2.so.0</td>
<td>libSM.so.6</td>
<td>libXt.so.6</td>
<td></td>
</tr>
</tbody>
</table>

Table 3: Diamond Encryption (Optional)

<table>
<thead>
<tr>
<th>Module</th>
<th>Size</th>
<th>Minimum</th>
</tr>
</thead>
<tbody>
<tr>
<td>diamond_1_3-base</td>
<td>libm.so.6</td>
<td></td>
</tr>
<tr>
<td>libc.so.6</td>
<td>libpthread.so.0</td>
<td></td>
</tr>
</tbody>
</table>
### Table 4: LatticeMico System

<table>
<thead>
<tr>
<th>Library</th>
<th>Library</th>
<th>Library</th>
</tr>
</thead>
<tbody>
<tr>
<td>libasound.so.2</td>
<td>libm.so.6</td>
<td>libthread_db.so.1</td>
</tr>
<tr>
<td>libatk-1.0.so.0</td>
<td>libncurses.so.5</td>
<td>libX11.so.6</td>
</tr>
<tr>
<td>libc.so.6</td>
<td>libnsl.so.1</td>
<td>libXext.so.6</td>
</tr>
<tr>
<td>libdl.so.2</td>
<td>libnspr4.so</td>
<td>libXft.so.2</td>
</tr>
<tr>
<td>libexpat.so.0</td>
<td>libnss3.so</td>
<td>libXi.so.6</td>
</tr>
<tr>
<td>libfontconfig.so.1</td>
<td>libpango-1.0.so.0</td>
<td>libXp.so.6</td>
</tr>
<tr>
<td>libfreetype.so.6</td>
<td>libpangox-1.0.so.0</td>
<td>libXrender.so.1</td>
</tr>
<tr>
<td>libgcc_s.so.1</td>
<td>libpangoxt-1.0.so.0</td>
<td>libXt.so.6</td>
</tr>
<tr>
<td>libgd_kpixbuf-2.0.so.0</td>
<td>libplc4.so</td>
<td>libXtst.so.6</td>
</tr>
<tr>
<td>libgd_kx11-2.0.so.0</td>
<td>libplds4.so</td>
<td>libz.so.1</td>
</tr>
<tr>
<td>libgil-2.0.so.0</td>
<td>libpng12.so.0</td>
<td>perl(File::Copy)</td>
</tr>
<tr>
<td>libgmodule-2.0.so.0</td>
<td>libpthread.so.0</td>
<td>perl(File::Glob)</td>
</tr>
<tr>
<td>libgmp.so.3</td>
<td>librtd.so.1</td>
<td>perl(File::Path)</td>
</tr>
<tr>
<td>libgobject-2.0.so.0</td>
<td>libsmime3.so</td>
<td>perl(Getopt::Std)</td>
</tr>
<tr>
<td>libgthread-2.0.so.0</td>
<td>libSM.so.6</td>
<td>perl(POSIX)</td>
</tr>
<tr>
<td>libgtk-x11-2.0.so.0</td>
<td>libsoftokn3.so</td>
<td>perl(Scalar::Util)</td>
</tr>
<tr>
<td>libICE.so.6</td>
<td>libssl3.so</td>
<td>perl(strict)</td>
</tr>
<tr>
<td>libjpeg.so.62</td>
<td>libstdc++.so.5</td>
<td>perl(XML::DOM)</td>
</tr>
</tbody>
</table>

### Table 5: Diamond Programmer Stand-Alone

<table>
<thead>
<tr>
<th>Library</th>
<th>Library</th>
<th>Library</th>
</tr>
</thead>
<tbody>
<tr>
<td>libc.so.6</td>
<td>libgthread-2.0.so.0</td>
<td>libSM.so.6</td>
</tr>
<tr>
<td>libdl.so.2</td>
<td>libICE.so.6</td>
<td>libX11.so.6</td>
</tr>
<tr>
<td>libfontconfig.so.1</td>
<td>libm.so.6</td>
<td>libXext.so.6</td>
</tr>
<tr>
<td>libfreetype.so.6</td>
<td>libpng12.so.0</td>
<td>libXft.so.2</td>
</tr>
<tr>
<td>libgcc_s.so.1</td>
<td>libpthread.so.0</td>
<td>libXrender.so.1</td>
</tr>
<tr>
<td>libgil-2.0.so.0</td>
<td>librtd.so.1</td>
<td>libz.so.1</td>
</tr>
</tbody>
</table>

### Table 6: Diamond Programmer Encryption (Optional)

<table>
<thead>
<tr>
<th>Library</th>
<th>Library</th>
<th>Library</th>
</tr>
</thead>
<tbody>
<tr>
<td>programmer_1_3</td>
<td>libgcc_s.so.1</td>
<td>libpthread.so.0</td>
</tr>
<tr>
<td>libc.so.6</td>
<td>libm.so.6</td>
<td></td>
</tr>
</tbody>
</table>
Contacting Technical Support

**FAQs**  The first place to look. The Lattice FAQs (frequently asked questions) provide solutions to questions that many of our customers have already asked. Lattice Applications Engineers are continuously adding to the FAQs.

**Online Forums**  Lattice Forums contain a wealth of knowledge and are actively monitored by Lattice Applications Engineers.

**Telephone Support Hotline**  Receive direct technical support for all Lattice products by calling Lattice Applications from 5:30 a.m. to 6 p.m. Pacific Time.

- For USA & Canada: 1-800-LATTICE (528-8423)
- For other locations: +1 503 268 8001

In Asia, call Lattice Applications from 8:30 a.m. to 5:30 p.m. Beijing Time (CST), +0800 UTC. Chinese and English language only.

- For Asia: +86 21 52989090

**E-mail Support**

- techsupport@latticesemi.com
- techsupport-asia@latticesemi.com

**For Local Support**  Contact your nearest Lattice Sales Office.

---

**Table 7: Reveal Analyzer Stand-Alone**

<table>
<thead>
<tr>
<th>Library</th>
<th>Version</th>
<th>Library</th>
<th>Version</th>
</tr>
</thead>
<tbody>
<tr>
<td>libc.so.6</td>
<td></td>
<td>libgthread-2.0.so.0</td>
<td></td>
</tr>
<tr>
<td>libdl.so.2</td>
<td></td>
<td>libICE.so.6</td>
<td>libSM.so.6</td>
</tr>
<tr>
<td>libfontconfig.so.1</td>
<td></td>
<td>libm.so.6</td>
<td>libX11.so.6</td>
</tr>
<tr>
<td>libfreetype.so.6</td>
<td></td>
<td>libpng12.so.0</td>
<td>libXext.so.6</td>
</tr>
<tr>
<td>libgcc_s.so.1</td>
<td></td>
<td>libpthread.so.0</td>
<td>libXft.so.2</td>
</tr>
<tr>
<td>libglib-2.0.so.0</td>
<td></td>
<td>librt.so.1</td>
<td>libXrender.so.1</td>
</tr>
</tbody>
</table>

---
Installer Contents

The Lattice Diamond RPM installation packages are available for download from the Lattice Semiconductor Web site.

The following describes the contents of the Lattice Diamond installer.

- The Lattice Diamond "base" RPM installs Lattice Diamond and Synplify Pro for Lattice. See “Installing Lattice Diamond” on page 7 for more information.

- The Reveal installation file (.rpm) installs the stand-alone Reveal Analyzer. It is not necessary to install this package if the Diamond Base RPM is installed. See “Installing Stand-Alone Reveal Analyzer” on page 8 for more information.

- The Programmer installation file (.rpm) installs the stand-alone Diamond Programmer. It is not necessary to install this package if the Diamond Base RPM is installed. See “Installing Stand-Alone Programmer” on page 9 for more information.

- The LatticeMico installation file (.rpm) installs LatticeMico Development Tools and GNU-based Compiler Tools. The LatticeMico tools can only be installed with Diamond base. See “Installing LatticeMico Development Tools” on page 19 for more information.

- The Installation Notice contains installation and licensing information.

Diamond Installed Directory Structure

Table 8 shows the Lattice Diamond software directory structure after installation:

<table>
<thead>
<tr>
<th>File or Directory</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>bin/lin/</td>
<td>This directory contains files for running the Lattice Diamond GUI.</td>
</tr>
<tr>
<td>cae_library/</td>
<td>This directory contains synthesis header libraries for Synplify Pro in both Verilog and VHDL formats. It also contains the libraries for interface kits (ispLSI® design and simulation libraries).</td>
</tr>
<tr>
<td>data/</td>
<td>This directory contains files for the Lattice Diamond software.</td>
</tr>
<tr>
<td>docs/</td>
<td>This directory contains Lattice Diamond documentation, including manuals, tutorials, and the online Help.</td>
</tr>
</tbody>
</table>
Before installing the Lattice Diamond software, download the installation files from the Lattice Semiconductor Web site. For more information on how to download the Diamond software, go to www.latticesemi.com/latticediamond.

RPM installation files are provided to simplify the installation process. The RPM file has a companion MD5 checksum file. The MD5 file permits you to validate the integrity of the RPM file.

**Note**

- You need root privilege to install an RPM package.
- In the Diamond installation, blank space characters are not allowed in the installation directory path name.

Lattice Diamond is installed with the `diamond_1_3-base-xx-i386-linux.rpm` installation file. The file installs all Lattice Semiconductor FPGA devices on your system. It also installs the Synplify Pro for Lattice software. The following section guides you through the installation procedure step by step.

*To install the Diamond software:*

1. Verify the integrity of the first RPM file. Make sure the companion MD5 file is located in the same directory as the RPM file.

   ```
   cd <directory_with_RPM>
   rpm -K diamond_1_3-base-xx-i386-linux.rpm
   ```
2. Install the Diamond software. The default installation directory for Diamond is /usr/local/diamond. You have the option of changing the installation directory.

- To install to the default location (/usr/local/diamond):
  ```
  sudo rpm -Uvh <path_to_package>/diamond_1_3-base-xx-i386-linux.rpm
  ```

- To override the default location:
  ```
  sudo rpm -Uvh --prefix <prefix_directory> <path_to_package>/diamond_1_3-base-xx-i386-linux.rpm
  ```

The rpm command analyzes the RPM package and the installed components on your system and determines whether the Diamond software can be installed successfully. If all of the necessary components are present on your system, Diamond will be installed.

**Important!**

The RPM installation process for Diamond verifies the Linux operating system has all of the required support libraries installed. If library files required for running Diamond are not installed on the system Diamond will not be installed.

If you want to force the installation to continue, you can use "--nodeps" on the rpm command to ignore the dependency information. Diamond may not function correctly if the "--nodeps" switch is used to force installation of Diamond to proceed.

---

### Installing Stand-Alone Reveal Analyzer

Reveal Analyzer is included in the Diamond installation. If you want to use the tool without installing Lattice Diamond, use the `reveal_1_3-xx-i386-linux.rpm` file to install the stand-alone Reveal Analyzer.

**To install the stand-alone Reveal Analyzer:**

1. Verify the integrity of the RPM file. Make sure the companion MD5 file is located in the same directory as the RPM file.

   ```
   cd <directory_with_RPM>
   rpm -K reveal_1_3-xx-i386-linux.rpm
   ```

2. Install the Reveal Analyzer software. The default installation directory for Reveal Analyzer is `/usr/local/reveal`. You have the option of changing the installation directory.

   - To install to the default location (/usr/local/reveal):
     ```
     sudo rpm -Uvh <path_to_package>/reveal_1_3-xx-i386-linux.rpm
     ```
To override the default location:

```
sudo rpm -Uvh --prefix <prefix_directory>
<path_to_package>/reveal_1_3-xx-i386-linux.rpm
```

### Installing Stand-Alone Programmer

Programmer is included in the Diamond installation. If you want to use the tool without installing Lattice Diamond, use the `programmer_1_3-xx-i386-linux.rpm` file to install the stand-alone Programmer.

**To install the stand-alone Programmer:**

1. Verify the integrity of the RPM file.
   
   `cd <directory_with_RPM>
   rpm -K programmer_1_3-xx-i386-linux.rpm`

2. Install the Programmer software. The default installation directory for Programmer is `/usr/local/programmer`. You have the option of changing the installation directory.
   - To install to the default location (`/usr/local/programmer`):
     
     `sudo rpm -Uvh <path_to_package>/programmer_1_3-xx-i386-linux.rpm`
   - To override the default location:
     
     `sudo rpm -Uvh --prefix <prefix_directory>
     <path_to_package>/programmer_1_3-xx-i386-linux.rpm`

### Licensing Lattice Diamond

The Lattice Diamond development tool is licensed software. In order for you to launch the design tools you have to configure a Flexera license. The license can be either node-locked to the local machine, or acquired from a license server accessible from a LAN connection.

**Note**

Diamond permits the creation of configuration bitstreams for all of Lattice Semiconductor's FPGAs and CPLDs. However, a license is required for some devices.
The default location of the license file is \texttt{<prefix_directory>/diamond/1.3/license/license.dat}. If this location is changed, you must set the \texttt{LM_LICENSE_FILE} environment variable to include the new path name.

\textbf{Note}

In order to change the \texttt{LM_LICENSE_FILE} variable, you may need to edit the .cshrc or .bashrc configuration file located in your home directory.

\section*{Obtaining a License}

\emph{To register and license your Diamond software:}

1. Obtain the host ID of your license server with the following command:
   
   \texttt{<prefix_directory>/diamond/1.3/ispfpga/bin/lin/lmutil lmhostid}

2. Go to the Licensing section of the Lattice Semiconductor Web site (www.latticesemi.com/license) and follow the on-screen instructions.

\textbf{Note}

Lattice Semiconductor supports licensing for a single server or three redundant servers. If you are using three redundant servers, enter all three server host IDs on the License File/Registration Form.

Lattice Semiconductor will send your Diamond license file (license.dat) to you by e-mail within one working day. After you receive the license file from Lattice Semiconductor, copy the license.dat file to the Diamond license directory as follows:

\texttt{<prefix_directory>/diamond/1.3/license/license.dat}

\section*{Editing the License File}

You must edit a floating license file to specify the server name and the path to the Lattice daemon.

The following example shows part of a floating license file:

\begin{verbatim}
SERVER nodename 1234abcd 1710
DAEMON lattice daemon_path
FEATURE LSC_DIAMOND_A lattice 10.0 01-jan-9999 100 \ \85B686493C86
VENDOR_STRING=LSC_DIAMOND_A
\end{verbatim}

Edit the SERVER line by replacing the \textit{nodename} with the host name and the port ID (1710). The port ID, 1710 in this example, must be assigned a TCP/IP
port number that is not already in use on the server, so you might need to change it.

Edit the Lattice DAEMON line, replacing `daemon_path` with the path to Lattice Diamond. For lmgrd V11, the path is:

```
<prefix_directory>/diamond/1.3/ispfpga/bin/lin
```

When editing these lines, type them exactly as you received them. All entries are case-sensitive.

**Note**
The encryption codes are in hexadecimal format (digits 0-9, and lower-case letters a-f or upper-case letters A-F).

### Starting the License Manager
Type the following command on one line to start the license manager daemon:

```
<prefix_directory>/diamond/1.3/ispfpga/bin/lin/lmgrd
   -l <prefix_directory>/diamond/1.3/license/license.log
   -c <prefix_directory>/diamond/1.3/license/license.dat
```

Redirecting output to a log file is helpful when you debug licensing problems. The `-l` switch tells the license manager to send its output to a log file (license.log), and `-c` tells it which license to serve. The log file contains information on the status of the server and the daemon and TCP port in use. It also shows which users have checked out the license and the checkout time.

### Stopping the License Manager
If it is necessary to stop the FLEXlm license manager, follow this procedure:

1. Confirm that the daemon is running by typing the following command:
   ```
   ps -ef | grep lmgrd
   ```
2. If lmgrd.exe is running, type the following command on one line to stop the daemon:
   ```
   <prefix_directory>/diamond/1.3/ispfpga/bin/lin/lmutil lmdown
   -c <prefix_directory>/diamond/1.3/license/license.dat
   ```
   The following prompt appears:
   ```
   Shutting down FLEXlm on nodes: hostname
   Are you sure? [y/n]:
   ```
3. Type **Y** and press **Enter** to shut down the license daemon.

### Setting Up a Floating License on Linux

The licensing steps just outlined can be performed on a centralized license server. Then each client points to the license file on that machine. To gain access to the licenses on the remote license server, you need to set the environment variable LM_LICENSE_FILE value to `license_port_number@linux_host_name`.

### Running the Lattice Diamond GUI

The Lattice Diamond software has a graphical user interface (GUI). When you run the diamond executable file, the software automatically performs the environment setup.

**To start the Lattice Diamond GUI:**

1. Set the PATH environment variable as follows:

   For CSH users:
   ```
   set path = (<prefix_directory>/diamond/1.3/bin/lin $path)
   ```

   For BASH users:
   ```
   export PATH=<prefix_directory>/diamond/1.3/bin/lin:$PATH
   ```

   **Note**

   If your license file (license.dat) is not under `<prefix_directory>/1.3/license`, you must set the LM_LICENSE_FILE variable to the location of your license file. For example:

   For CSH users:
   ```
   setenv LM_LICENSE_FILE (/<license_directory>/license.dat $LM_LICENSE_FILE)
   ```

   For BASH users:
   ```
   export LM_LICENSE_FILE=$LM_LICENSE_FILE:/<license_directory>/license.dat
   ```

2. Run the diamond executable file in the command line:

   ```
   diamond
   ```

   With the `diamond` script, you can also run the following tools in standalone mode.
To invoke stand-alone Power Calculator, run:

```
diamond -pwc
```

To invoke stand-alone Reveal Analyzer, run:

```
diamond -rva
```

To invoke stand-alone IPexpress, run:

```
diamond -ipx
```

To invoke stand-alone Epic, run:

```
diamond -epic
```

Refer to the online Help for more information about the Diamond GUI.

**Using the Examples Directory**

In order to use the design examples directory, you must copy the files from the server to your local system and change the write permissions. Copy the files from the server examples directory (`prefix_directory>/diamond/1.3/examples`) to the equivalent path and directory on your local system.

**Finding the Installation History**

The Diamond software records a log of your installation history. You can find the history in the Diamond main window.

*To view the installation history:*

1. Open the Diamond GUI.
2. Choose Help > About Lattice Diamond.
Running Lattice Diamond from the Command Line

There are two ways to run from the command line: through Diamond's Tcl Console or by running executable files directly.

Running Tcl Console
The Lattice Diamond development environment includes Tcl Console, which allows you to run scripts for automating common tasks. Tcl Console is also available outside of the user interface in order to run custom scripts. To launch the stand-alone Tcl Console, enter the following on a command line:

```
<prefix_directory>/diamond/1.3/bin/lin/pnminc
```

This command configures the environment allowing all of the underlying design tools to be run.

Refer to the online Help for more information about the command line.

Running Executables
Before running any other commands, you need to run the following command:

```
cd <prefix_directory>/diamond/1.3/bin/lin
source setupenv
```

After that, you can run the executable files directly. For example, you can invoke the Diamond GUI by:

```
pnmain
```

Or, you can run Power Calculator by running:

```
pwcmain
```

Running Synplify Pro for Lattice
To run Synplify Pro for Lattice, do the following:

1. Open the Diamond GUI.
2. Open any project to enable the commands on the Tools menu.
3. Choose **Tools > Synplify Pro for Lattice**.
Running Stand-Alone Reveal Analyzer

After the installation, you can invoke the stand-alone Reveal Analyzer in the command line:

% cd <prefix_directory>/reveal/1.3/bin/lin
% revealrva

Running Stand-Alone Programmer

After the installation, you can invoke the stand-alone Programmer in the command line:

% cd <prefix_directory>/programmer/1.3/bin/lin
% programmer

Running Multiple Versions of Lattice Software

You can run multiple versions of ispLEVER and Lattice Diamond at the same time from either the command line or the graphical user interface. You can run current and previous versions.

Updating Lattice Diamond

After you have registered and licensed your installation, check the Lattice Semiconductor Web site for new software updates, device support, and enhancements. Make sure that you have the latest software by checking for updates regularly.

This process will only find updates to the version you have installed. For upgrades to a new version, check the Lattice Web site.

Running the UPDATE Tool

To run the UPDATE tool:

- Run the update executable file in the command line:
  
  update
  
  The UPDATE window appears, as shown below.
Changing the Automatic Checking Settings

The Diamond software can automatically check for updates and open a window showing the Diamond updates that are available. If you want to change or turn off the automatic checking, change the settings in UPDATE as follows.

To change the automatic checking settings:
1. In the UPDATE window, choose Settings > Update Settings.
2. In the Update Settings dialog box, select the Auto Setting tab.
3. In the Auto Setting tab, do either of the following:
   - To enable automatic checking for software updates, make sure that the Automatic check for software updates when application starts option is selected (it is selected by default). Then specify the frequency with which you want the checking to be performed: every
time when Diamond is started, daily, or weekly. The default is Every time.

- To disable the automatic checking, clear the Automatic check for software updates when application starts option.

4. Click OK.

**Changing the Network Setting**

To enable online checking for software updates, you must indicate how your computer accesses the Internet.

To change the Internet connection settings:

1. In the UPDATE window, choose **Settings > Update Settings**.
2. In the Update Settings dialog box, select the **Network Setting** tab.

3. In the Network Setting tab, do either of the following:
   - If you must go through a proxy server before connecting to the Internet, select **Use a Proxy Server** (it is selected by default). The proxy server prevents outsiders from breaking into your organization’s private network. Ask your system administrator for the URL address and port assignment.
   - If you use direct Internet access, clear the **Use a Proxy Server** option.

4. Click **OK**.

**Downloading and Installing Software Updates**

When you use the automatic checking feature, the Diamond software notifies you whenever an update version becomes available.

You can also manually check for software updates.
To manually check for and download a Diamond update version:

1. In the UPDATE window, click Update.
   The software goes online to check for updates, and lists the available Diamond update versions (if any) in the Available update versions box.

2. Select the update version that you want to download, and click Download.
   The software starts downloading the installer of the update version to your computer. You may install it later.

Note
You can also use the Help > Check for Updates command in the Diamond window to check for and download software update.

To install a downloaded Diamond update version:

1. Close all Diamond tools.
2. Uncompress the downloaded installer.
3. Go to the location where you put the uncompressed installer.
4. From the command line, execute the RPM installation file.

Note
You need the root privilege to install an RPM package.
Installing LatticeMico Development Tools

This document explains how to install LatticeMico Development Tools on the Linux operating system.

Installing the LatticeMico Development Tools without Diamond, or stand-alone, is not supported.

System and Software Requirements

Your system must meet the following minimum system and software requirements to run LatticeMico Development Tools on Linux.

System Requirements
- Intel Pentium or Pentium-compatible PC with USB port
- 32-bit Red Hat Enterprise Linux version 4.X or 5.X operating system
- 2 GB memory recommended for FPGAs
- Approximately 436 megabytes of free disk space
- 1024 x 768 graphics display
Software Requirements

- Lattice Diamond 1.3
- For Verilog users: Synplify Pro® or Precision®
  
  For VHDL users: Synplify Pro version 8.9 or later

Note

- Synplify Pro is required for LatticeMico MSB generation.
- Synplify Pro for Lattice is included in the Lattice Diamond installation.

- Perl version 5.8.0 or later. The following Perl modules are required:
  - XML::DOM
  - Getopt::Std
  - Scalar::Util
  - FindBin::Bin

  These modules are normally found in the native version of Perl that comes with Red Hat Linux.
- PDF browser, such as Adobe Acrobat
- Mozilla or Netscape browser (optional)

Additional Notes for Linux

You may need the following information to run LatticeMico on Linux:

- If you want to configure your system to use an external browser instead of the Eclipse help browser, you can change this in the LatticeMico main window by choosing the Window > Preferences command.

- Eclipse requires shared libraries from the Mozilla (also known as Seamonkey) Web browser. The Eclipse software expects to find a set of IA32 shared libraries. It may be necessary for you to manually configure the MOZILLA_FIVE_HOME environment variable to point to a valid Mozilla browser library installation.

- If you cannot access the PDF files referenced in the LatticeMico online Help, you can configure LatticeMico to use an external browser by following these steps:
  
a. In the LatticeMico software, choose Window > Preferences.

  b. Click on Help.
c. Select **Use external browser**.
d. Click on **Web Browser**.
e. Select **Use external Web browser**.
f. Select **Firefox** or **Netscape**.
g. Click **OK**.

---

## Installation Procedure

The LatticeMico Development Tools are installed with an RPM file. LatticeMico System software is installed within the Lattice Diamond software directory, and relies on components provided by Lattice Diamond.

### Note

You need the root privilege to install an RPM package.

To install LatticeMico Development Tools:

1. Install Lattice Diamond 1.3 first, for example, in `<prefix_directory>/diamond`.
2. Verify the integrity of the RPM file.
   
   ```
   cd <directory_with_RPM>
   rpm -K diamond_1_3-lm-xx-i386-linux.rpm
   ```

3. Execute the RPM installation file as follows:

   ```
   rpm -Uvh --prefix /<prefix_directory> <path_to_package>/diamond_1_3-lm-xx-i386-linux.rpm
   ```

### For Red Hat 5 Users

If you get an error message such as this:

```
error: Failed dependencies:
   perl(XML::DOM) is needed ...
```

the problem may be the version number of your Perl. Check that the required Perl modules are present, as described in “Software Requirements” on page 20. If they are, repeat the rpm command with the --nodeps argument added. The --nodeps argument causes the rpm command to ignore the dependency information. Make sure all other dependencies have been resolved before running with this argument.
This will install LatticeMico Development Tools to the `<prefix_directory>/diamond/1.3/micosystem` directory.

4. After the installation is completed, verify that the `/micosystem` directory is created in the `<prefix_directory>/diamond/1.3` directory, for example, `/usr/local/diamond/1.3/micosystem`.

5. You can then run LatticeMico System as follows:
   a. Go to `<prefix_directory>/diamond/1.3/micosystem`, and type:
      ```
      ./LatticeMicoLauncher &
      ```
   b. The LatticeMico System Builder software can be configured to run from alternate locations. Use the `NEW_LM_INSTALL_PATH` environment variable to change to a different MSB installation.