## Type Conventions Used in This Document

<table>
<thead>
<tr>
<th>Convention</th>
<th>Meaning or Use</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Bold</strong></td>
<td>Items in the user interface that you select or click. Text that you type into the user interface.</td>
</tr>
<tr>
<td><em>Italic</em></td>
<td>Variables in commands, code syntax, and path names.</td>
</tr>
<tr>
<td><strong>Ctrl+L</strong></td>
<td>Press the two keys at the same time.</td>
</tr>
<tr>
<td><strong>Courier</strong></td>
<td>Code examples. Messages, reports, and prompts from the software.</td>
</tr>
<tr>
<td>...</td>
<td>Omitted material in a line of code.</td>
</tr>
<tr>
<td>.</td>
<td>Omitted lines in code and report examples.</td>
</tr>
<tr>
<td>[ ]</td>
<td>Optional items in syntax descriptions. In bus specifications, the brackets are required.</td>
</tr>
<tr>
<td>( )</td>
<td>Grouped items in syntax descriptions.</td>
</tr>
<tr>
<td>{ }</td>
<td>Repeatable items in syntax descriptions.</td>
</tr>
<tr>
<td></td>
<td>A choice between items in syntax descriptions.</td>
</tr>
</tbody>
</table>
# Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Installing Diamond Tools</td>
<td>1</td>
</tr>
<tr>
<td>System Requirements</td>
<td>1</td>
</tr>
<tr>
<td>Memory Requirements</td>
<td>2</td>
</tr>
<tr>
<td>Extending Memory</td>
<td>3</td>
</tr>
<tr>
<td>Contacting Technical Support</td>
<td>3</td>
</tr>
<tr>
<td>Installing Diamond 2.0 for Windows</td>
<td>4</td>
</tr>
<tr>
<td>Software Product Options</td>
<td>4</td>
</tr>
<tr>
<td>Installation Procedure</td>
<td>5</td>
</tr>
<tr>
<td>Licensing for Diamond and Stand-Alone Power Estimator</td>
<td>8</td>
</tr>
<tr>
<td>Finding the Installation History</td>
<td>10</td>
</tr>
<tr>
<td>Optional Floating License Setup</td>
<td>10</td>
</tr>
<tr>
<td>Editing the License File</td>
<td>10</td>
</tr>
<tr>
<td>License Server Setup</td>
<td>11</td>
</tr>
<tr>
<td>Windows License Server Setup for Active-HDL Lattice Edition</td>
<td>12</td>
</tr>
<tr>
<td>Floating License Configuration</td>
<td>13</td>
</tr>
<tr>
<td>Setting up Floating License on Linux</td>
<td>13</td>
</tr>
<tr>
<td>Troubleshooting Licensing Problems</td>
<td>14</td>
</tr>
<tr>
<td>Running Multiple Versions</td>
<td>15</td>
</tr>
<tr>
<td>Running Diamond</td>
<td>15</td>
</tr>
<tr>
<td>Running Diamond Locally</td>
<td>15</td>
</tr>
<tr>
<td>Running Diamond using Windows Remote Desktop</td>
<td>15</td>
</tr>
<tr>
<td>Updating Diamond</td>
<td>15</td>
</tr>
<tr>
<td>Installing Stand-Alone Programmer/Deployment Tool</td>
<td>18</td>
</tr>
<tr>
<td>Starting Stand-Alone Programmer/Deployment Tool</td>
<td>19</td>
</tr>
<tr>
<td>Installing Stand-Alone Reveal Logic Analyzer</td>
<td>19</td>
</tr>
<tr>
<td>Starting Stand-Alone Reveal Logic Analyzer</td>
<td>20</td>
</tr>
<tr>
<td>Installing Stand-Alone Power Estimator</td>
<td>21</td>
</tr>
<tr>
<td>Starting Stand-Alone Power Estimator</td>
<td>22</td>
</tr>
<tr>
<td>Troubleshooting</td>
<td>22</td>
</tr>
<tr>
<td>When All Else Fails</td>
<td>23</td>
</tr>
</tbody>
</table>
CONTENTS

Installing LatticeMico Development Tools  25
Installing LatticeMico with Diamond    25
Installing LatticeMico as Stand-Alone Software 27
Starting LatticeMico Development Tools  29
Chapter 1

Installing Diamond Tools

This chapter provides installation instructions for the Lattice Diamond® 2.0 software for Windows.

Diamond supports LatticeEC™, LatticeECP™, LatticeECP2™, LatticeECP2M™, LatticeECP3™, LatticeSC™, LatticeSCM™, LatticeXP™, LatticeXP2™, MachXO™, MachXO2™, and Platform Manager™ designs.

Note
The available devices vary depending on the type of license.

Lattice Diamond is available in 32-bit and 64-bit versions.

- The 32-bit version of Lattice Diamond is optimized to run on Windows 32-bit systems.
- The 64 bit version of Lattice Diamond is optimized to run on Windows 64-bit systems.

System Requirements

The following are the basic system requirements for Lattice Diamond on Windows:

- Intel Pentium or Pentium-compatible PC
- Windows XP (32-bit only), Windows Vista (32-bit only), or Windows 7 (32-bit or 64-bit)

Note
If your operating system is Windows Vista, make sure you have installed all the latest patches from Microsoft.
INSTALLING DIAMOND TOOLS

System Requirements

- Approximately 5.75 GB free disk space
- Network adapter

Note

A node-locked license is based on the physical (hard-coded) address provided by the network adapter. Network connectivity is not necessarily required for a node-locked license. In the absence of a network connection, you can install the NWLink IPX/SPX protocol to force the recognition of your NIC card ID (see “Licensing for Diamond and Stand-Alone Power Estimator” on page 8).

A floating license requires access to the license server, so both a network adapter and connectivity are required.

- 1024 X 768 graphics display
- Microsoft-compatible mouse and mouse driver
- A Web browser with Javascript capability
- Adobe Acrobat Reader

Memory Requirements

Table 1 lists the minimum memory requirements and the recommended memory for all the Lattice Semiconductor FPGA families. Designing for the largest FPGAs may require more than the usual 2 GB of memory. For help in extending your memory to 3 or 4 GB, see “Extending Memory” on page 3.

Table 1: Recommended Memory for Windows

<table>
<thead>
<tr>
<th>Device</th>
<th>Size</th>
<th>Minimum</th>
<th>Recommended</th>
</tr>
</thead>
<tbody>
<tr>
<td>LatticeEC, LatticeECP</td>
<td>Up to 20K LUT</td>
<td>512 MB</td>
<td>768 MB</td>
</tr>
<tr>
<td>LatticeECP</td>
<td>Up to 50K LUT</td>
<td>768 MB</td>
<td>1 GB</td>
</tr>
<tr>
<td>LatticeECP2/M</td>
<td>Up to 20K LUT</td>
<td>768 MB</td>
<td>1 GB</td>
</tr>
<tr>
<td>LatticeECP2/M</td>
<td>Up to 50K LUT</td>
<td>1 GB</td>
<td>1.5 GB</td>
</tr>
<tr>
<td>LatticeECP3</td>
<td>Up to 100K LUT</td>
<td>1 GB</td>
<td>2 GB</td>
</tr>
<tr>
<td>LatticeSC/M</td>
<td>Up to 40K LUT</td>
<td>768 MB</td>
<td>1 GB</td>
</tr>
<tr>
<td>LatticeXP, LatticeXP2</td>
<td>Up to 20K LUT</td>
<td>512 MB</td>
<td>768 MB</td>
</tr>
<tr>
<td>LatticeXP, LatticeXP2</td>
<td>Up to 50K LUT</td>
<td>768 MB</td>
<td>1 GB</td>
</tr>
<tr>
<td>MachXO, MachXO2</td>
<td>All</td>
<td>256 MB</td>
<td>512 MB</td>
</tr>
<tr>
<td>Platform Manager</td>
<td>All</td>
<td>256 MB</td>
<td>512 MB</td>
</tr>
</tbody>
</table>
1. Designing for LatticeECP3 with more than 95K LUT, requires a Windows 7 64-bit operating system.

**Extending Memory**

Designing for the largest FPGAs may require more than the usual 2 GB of memory. For help in extending your memory to 3 or 4 GB, see the following.

**In Windows XP**

Normally, the Windows XP platform limits the amount of memory to a maximum of 2 GB for any Diamond program. You can configure Windows XP to allow 2-3 GB of memory by adding the `/3GB` switch to the end of the startup line in the boot.ini file. Before you take advantage of this capability, it is important that you read the following information:

- Microsoft Knowledge Base Article #328269, which addresses a potential problem with the `/3GB` switch. Go to: support.microsoft.com/?kbid=328269.
- Microsoft article, “Memory Support and Windows Operating Systems,” which explains the use of the physical address extension (PAE) for Windows XP Professional and Windows Server 2003 Memory Support. Go to: www.microsoft.com/whdc/system/platform/server/PAE/PAEmem.mspx
- Microsoft Knowledge Base article #289022, “How to edit the Boot.ini file in Windows XP.” Go to: support.microsoft.com/default.aspx?scid=kb;en-us;q289022

**In Windows 7**

Lattice Diamond is a 32-bit application that can run in a Windows 7 64-bit system. With a Windows 7 32-bit system, Diamond can access up to 3 GB. With a Windows 7 64-bit system, Diamond can access up to 4 GB. See also:


**Contacting Technical Support**

**FAQs**  The first place to look. The Lattice FAQs provide solutions to questions that many of our customers have already asked. Lattice Applications Engineers are continuously adding to the FAQs as customer issues are resolved.

**Online Forums**  Lattice Forums contain a wealth of knowledge and are actively monitored by Lattice Applications Engineers.
Telephone Support Hotline  Receive direct technical support for all Lattice products by calling Lattice Applications from 5:30 a.m. to 6 p.m. Pacific Time.

- For USA & Canada: 1-800-LATTICE (528-8423)
- For other locations: +1 503 268 8001

In Asia, call Lattice Applications from 8:30 a.m. to 5:30 p.m. Beijing Time (CST), +0800 UTC. Chinese and English language only.

- For Asia: +86 21 52989090

E-mail Support

- techsupport@latticesemi.com
- techsupport-asia@latticesemi.com

For Local Support  Contact your nearest Lattice Sales Office.

Installing Diamond 2.0 for Windows

The following sections describe product options and installation instructions for Diamond.

Software Product Options

Table 2 shows the product options for the installation of Diamond for both 32-bit and 64-bit versions.

<table>
<thead>
<tr>
<th>Product Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Diamond for Windows</td>
<td>Installs the Diamond design tools for all Lattice Semiconductor FPGA designs. Table 3 lists the tools included in this option.</td>
</tr>
<tr>
<td>FPGAs</td>
<td>Installs the FPGA design environment.</td>
</tr>
<tr>
<td>Synplify Pro for Lattice</td>
<td>Installs the Synopsys® Synplify Pro® for Lattice synthesis tool. A license for Synplify Pro is included.</td>
</tr>
<tr>
<td>Active-HDL Lattice Edition</td>
<td>Installs Aldec® Active-HDL™ Lattice Edition simulation tool. A license for Active-HDL is included.</td>
</tr>
<tr>
<td>Programmer Drivers</td>
<td>Installs drivers for the Programmer tool, which loads FPGAs with the designs.</td>
</tr>
</tbody>
</table>

4 Lattice Diamond 2.0 Installation Notice for Windows
Table 3 shows the tools included in the Diamond for Windows option.

### Table 3: Tools included in the Diamond for Windows Option

<table>
<thead>
<tr>
<th>Tool</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Project Management Tools</strong></td>
<td>Include the Reports view, Run Manager, and the Security Setting tool to enable you to create and maintain the project, keep track of the stages in the design implementation process, review reports, and compare different implementations of the project.</td>
</tr>
<tr>
<td><strong>Design Entry Tools</strong></td>
<td>Include Source Editor, Schematic Editor, Symbol Editor, Symbol Library Manager, IPexpress, Memory Generator, LatticeMico System, and HDL Diagram, which offer VHDL, Verilog, EDIF, schematic, and mixed-mode design entry support and design structure check.</td>
</tr>
<tr>
<td><strong>Design Simulation Tools</strong></td>
<td>Include Simulation Wizard, Active-HDL Lattice Edition, and Waveform Editor for performing functional simulation for the projects and creating the test stimulus files.</td>
</tr>
<tr>
<td><strong>Design Constraints Application Tools</strong></td>
<td>Include Spreadsheet View, Package View, Device View, Netlist View, NCD View, Floorplan View, and Physical View to enable you to set constraints for implementing the design.</td>
</tr>
<tr>
<td><strong>Design Implementation Tools</strong></td>
<td>Include the Process view, Synplify Pro for Lattice, and Clear Tool Memory to ease the design implementation process.</td>
</tr>
<tr>
<td><strong>Analyzing Static Timing, Power Consumption, and Signal Integrity Tools</strong></td>
<td>Include Timing Analysis View and Power Calculator to enable you to estimate the design performance, experiment with different configurations, and to calculate power consumption.</td>
</tr>
<tr>
<td><strong>Programming the FPGA Tool</strong></td>
<td>Includes Programmer to let you program the FPGAs.</td>
</tr>
<tr>
<td><strong>Testing and Debugging On-chip Tools</strong></td>
<td>Include Reveal Inserter, Reveal Analyzer, and LatticeMico Debugger to let you complete the final stage of developing a design: testing in the actual FPGA, either on a test board or in your system.</td>
</tr>
<tr>
<td><strong>Applying Engineering Change Order Tool</strong></td>
<td>Includes ECO Editor which supports engineering change orders by editing the output files from the place-and-route stage of the design implementation process.</td>
</tr>
<tr>
<td><strong>EPIC Device Editor</strong></td>
<td>Provides device editing capability for engineering change management and detailed manipulation of FPGA implementation.</td>
</tr>
<tr>
<td><strong>HTML Help and User Documentation</strong></td>
<td>Includes complete instructions for designing with Diamond design tools and third-party tools. Also provides user manuals, tutorials, example design projects, and access to technical documentation from the Lattice Semiconductor Web site.</td>
</tr>
<tr>
<td><strong>Tcl/Tk Scripting Tool</strong></td>
<td>Enables you to automate Diamond design processing.</td>
</tr>
</tbody>
</table>

### Installation Procedure

The Lattice Diamond software is available for download from the Lattice Diamond Downloads & Licensing web page located at [http://www.latticesemi.com/latticediamond/downloads](http://www.latticesemi.com/latticediamond/downloads). Follow the product download instructions and uncompress the software.
To install the Lattice Semiconductor Diamond software:

1. Close all applications before starting Diamond installation.
2. Double-click on the Diamond installer you downloaded to launch the installation process.

   **Note**

   In this release, the 32-bit version of Diamond software executable file is named 2.0.0.154_Diamond.exe. The 64-bit version of Diamond software executable file is named 2.0.0.155_Diamond_x64.exe.

   If you are installing the Encryption Control Pack, you should install the file named 2.0.0.154_Control_Pack_Encryption.exe for the 32-bit version of Diamond, and the file named 2.0.0.154_Control_Pack_Encryption_x64.exe for the 64-bit version of Diamond.

3. The Welcome To Lattice Semiconductor Diamond Setup dialog box opens.
4. Click **Next** to open the License Agreement dialog box.
5. Read the license agreement. If you agree, click **Yes** to open the Choose Destination Location dialog box.
6. The default destination folder is C:\lscc. Click **Browse** to change the drive or destination folder.
7. Click **Next** to open the Product Options dialog box.
8. Select the Diamond components that you want to install by selecting or clearing each of the listed options. If you have purchased third-party synthesis and simulation tools directly from the third-party vendors, you can clear the **Synplify Pro for Lattice** and **Active-HDL Lattice Edition** product options.

   The FPGAs product option has additional options for selecting the Lattice FPGA devices that you want to install. To set the additional options, select **FPGAs** and click **Change**.

   In the pop-up Select Subfeatures dialog box, you can select or deselect the features from the list. Click **Continue** to come back to the Product Options dialog box.
9. Click **Next** to open the Select Program Folder dialog box. The default name of the program group is **Lattice Diamond 2.0** (or **Lattice Diamond 2.0 (64-bit)** if you installed the 64-bit version). If you want to change the name, change it in the Program Folder text box.
10. If you have selected the Active-HDL Lattice Edition option, you will be prompted to select a license option as shown in Figure 1.
11. Select the desired license option and click **Next**.

**Note**

Clicking the Cancel button cancels the entire Diamond installation. Installation of Active-HDL cannot be cancelled at this point.

12. In the Create Shortcut on Desktop dialog box, select desired option and click **Next**.

Parallel port or USB drivers are required to program Lattice devices using the Lattice download cables. To install the drivers, you should have administrative privileges.

Three drivers are installed with the Programmer Download Parallel/USB Port Driver dialog box.

- **Parallel port driver** – Supports device programming through the parallel port of your PC. The driver can be installed on Windows XP, Server 2003, Vista (32-bit), and Windows 7 (32-bit).

- **USB port driver** – Supports device programming through the USB port of your PC. The driver can be installed on Windows XP, Server 2003, Vista (32-bit or 64-bit), and Windows 7 (32-bit or 64-bit).

- **FTDI USB driver** – Supports Lattice evaluation boards with FTDI (Future Technology Devices International) USB host chip. The driver does not support Windows 2000 and earlier operating systems.

13. In the Programmer Download Parallel/USB Port Driver dialog box (Figure 2), select the desired license option and click **Next**.

14. In the Start Copying Files dialog box, verify Diamond environment settings and click **Next**.
15. In the InstallShield Wizard Complete dialog box, read the note and click Finish.

Note
Do not close the installation window. The window will automatically close when the installation completes.

Licensing for Diamond and Stand-Alone Power Estimator
At the end of the installation, you will use the Web-based licensing capability to license your Diamond and stand-alone Power Estimator software.

Note
The available devices for Diamond can vary, depending on the type of license.

To use the software, you must receive a permanent Lattice Semiconductor software license based on the identification of your network interface card (NIC). The NIC ID or equivalent is the 12-character hexadecimal physical address. License your software early to avoid any down time.

To obtain a license file for your Diamond software:
1. Go to Lattice Semiconductor Software Licensing page: www.latticesemi.com/licensing
2. Select Lattice Diamond.
You will get the Lattice Diamond Software Licensing page.

3. Follow the on-screen instructions.

You can also get the NIC via an alternate network interface, such as a wireless interface.

In the absence of a network connection, you can install the NWLink IPX/SPX protocol to force the recognition of your NIC card ID.

To install the NWLink IPX/SPX protocol on Windows NT:
1. Right-click My Network Places on the desktop and select Properties.
   A list of all the networks available opens.
2. Right-click Local Area Network and select Properties.
3. In the Local Area Connection Properties dialog box that appears, perform the following steps:
   a. Click Install.
   b. Select Protocol and click Add.
   c. Select NWLink IPX/SPX.
   d. Click OK and follow the instructions on the screen.
4. If needed, reboot your machine.

To install the NWLink IPX/SPX protocol on Windows Vista or Windows 7 (32-bit only):
1. Click Start > Control Panel > Network and Internet > Network and Sharing Center.
2. Click Change Adapter Settings.
3. Click Local Area Network and select Properties.
4. In the Local Area Connection Properties dialog box that appears, perform the following steps:
   a. Click Install.
   b. Select Protocol and click Add.
   c. Select NWLink IPX/SPX.
   d. Click OK and follow the instructions on the screen.
5. If needed, reboot your machine.

Note
There is no native IPX/SPX support from Microsoft starting with Windows Vista and Windows Server 2003 x64. Contact Novell for IPX/SPX support:
http://www.novell.com/home/index.html
Finding the Installation History

Diamond records a log of the installation history, which you can find from the Diamond main window.

To view the installation history:
1. Open the Diamond main window.
2. Select Help > About Lattice Diamond. See the Installation History tab.

Optional Floating License Setup

To enable a floating license, you must have a license server set up on a Windows NT server to monitor your Diamond software license. Each client PC must have the LM_LICENSE_FILE variable set to point to the license file on the server.

Before you start the server setup, ensure that TCP/IP is installed and that the client machines can communicate with the server by name. At the prompt in an MS-DOS window, type the following:

```
ping <hostname>
```

Table 4 lists the files used for license management. The files are located at:
```
<diamond_install_path>\ispFPGA\bin\nt
```

<table>
<thead>
<tr>
<th>Filename</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>LMGRD.exe</td>
<td>The license server program</td>
</tr>
<tr>
<td>LMUTIL.exe</td>
<td>FLEXlm utility for diagnosing, reporting, and controlling licensing</td>
</tr>
<tr>
<td>LMTOOLS.exe</td>
<td>Program that sets up the server for floating licenses</td>
</tr>
<tr>
<td>ispdsdmn.exe</td>
<td>The Lattice Semiconductor licensing daemon</td>
</tr>
</tbody>
</table>

**Note**
The Diamond software uses FLEXlm 11.10 license administration software. Users of the ispLEVER 7.0 or older software must bring down the previous license daemon and start the new license daemon.

Editing the License File

After obtaining a floating license from Lattice Semiconductor, you must edit the license file to specify the server name and the paths to the Lattice daemon. An example of a floating license file is shown below.

```
SERVER nodename 001143D94535 7788
DAEMON lattice daemon_path
```
FEAURE LSCADVANCED lattice 8.0 01-jan-9999 100 EE7E589FB0D53 \
VENDOR_STRING=ispLEVER Advanced" 
FEAURE LSCBASE lattice 8.0 01-jan-9999 100 F901F7E7F4F1 \
VENDOR_STRING=ispLEVER Base" 
FEAURE LSCDIAMOND_A lattice 10.0 01-jan-9999 100 6D8288983379 \
VENDOR_STRING=LSC_DIAMOND_A 
FEAURE LSCPBASE_HOLE DEVICE lattice 10.0 01-jan-9999 100 7D131CCD0F18 \
VENDOR_STRING=LSC_OBSOLETEDEVICE

Note
The "\" followed by a carriage return indicates a line continuation.

To edit the license file:
1. Edit the SERVER line by replacing nodename with the host name of the 
server for which you requested your license.dat file. You may also need to 
change the PORT NUMBER (7788).
2. Edit the DAEMON lattice line by replacing daemon_path with the path 
to the lattice daemon, for example:
   C:\lscc\diamond\2.0\ispfpga\bin\nt\ispdsdmn.exe

When you are editing these lines, make sure that they are typed exactly as 
you received them.

License Server Setup
To set up your license manager as a system service:
1. Copy the license file (license.dat) to <diamond_install_path>license\license.dat.
2. Double-click the <diamond_install_path>ispfpga\bin\nt\lmtools.exe file to 
open the LMTOOLS dialog box.

Note
Windows 7 users may need to right click on LMTOOLS.exe and select Run as 
Administrator.

3. Choose the Config Services tab in the LMTOOLS dialog box.
4. Change Service Name to Lattice FLEXlm Service 1.
5. Browse and set lmgrd.exe to <install_path>\ispfpga\bin\nt\lmgrd.exe.
6. Browse and set the license file to <install_path>\license\license.dat.
7. Browse and set the debug log file to <install_path>\license\lattice.log.
8. Click Save Service.
10. Click Start Server.
11. Select the Config Services tab.
12. Select **View Log** to view the lattice.log file. Check to see if there are any problems starting the license server. If there are no problems, close the log file.

13. Choose **Start > All Programs > Lattice Semiconductor > Lattice Diamond 2.0** to verify license checkout (this will be reflected in the lattice.log file). Close Diamond.

14. Choose the **Start/Stop/Reread** tab in the LMT OOLS dialog box.

15. Select **Stop Server**.

16. Select the **Config Services** tab. Select **Use Services** and **Start Server at Power-Up**.

17. Click **Save Service**, and then select **File > Exit**.

18. Restart the Windows server system.

19. Start Diamond again to verify that the license server is running as a service.

---

**Windows License Server Setup for Active-HDL Lattice Edition**

If you want to use a floating license on a Windows system to run the Active-HDL Lattice Edition software, you should have a USB FLEXid keylock dongle and a separate license file (aldec_license.dat) for Active-HDL Lattice Edition. Before running the software, you need to install the dongle driver and set up the license server.

The steps below show you how to install the dongle driver and set up a Windows floating license server for Active-HDL Lattice Edition.

1. Obtain the USB FLEXid keylock dongle and the Active-HDL Lattice Edition license file (aldec_license.dat) from Lattice Semiconductor.

2. Install the driver files for the USB FLEXid keylock dongle by running `<diamond_install_path>\active-hdl\Drivers\HASP\hasp_driver_install.bat`.

3. Plug in the USB FLEXid keylock dongle to the PC that will run the license server.

4. Download the Aldec license daemon package from ftp://reguser:reguser@ftp.aldec.com/daemons/12.0/ aldec_windows_floating_license.zip.

5. Unpack the zip archive to a directory where you want to install the license server.

6. Copy the license file (aldec_license.dat) to the directory where you unpacked the server.

7. Modify the license file (aldec_license.dat) as follows.

   ```
   Modify the SERVER line to reflect the nodename of your PC:
   
   SERVER nodename FLEXID=9-xxxxxxxx 27000
   SERVER myservername FLEXID=9-xxxxxxxx 27000
   ```
(Optional) Modify the VENDOR line to specify the vendor daemon path:

VENDOR ALDEC path_to_aldec

If the license file is in the local directory, you may remove the path parameter:

VENDOR ALDEC

8. Start the license server by running startlicense.bat.

   The Active-HDL License dialog box appears. Click Run license information. The Diagnose License dialog box then appears.

10. Confirm that the installation directory for Active-HDL is accurate and click Next. The Diagnose (License File) dialog box appears.

11. Specify the location of the license server using the syntax: <TCP-port>@host_computer_name (27000@myservername). Click Refresh. Then click Next.

12. Click Finish.

13. Restart the Active-HDL Lattice Edition software.

Floating License Configuration
In this configuration, Diamond is installed on your Windows license server (for license manager utilities and daemons) and on each client that uses Diamond. This configuration gives the best run-time performance.

Install Diamond on the license server first. After you receive your floating license and ensure that the license manager is running, install Diamond locally on each client that will use the floating license.

Set your system variable LM_LICENSE_FILE to point to TCP/IP_PORT@hostname

Setting up Floating License on Linux
You can also put the Diamond license on a Linux machine. Then each client (Windows or Linux) points to the license file on the Linux machine. In this case, you need to set the environment variable LM_LICENSE_FILE value to License_Port_number@linux_host_name. Or, have the LM_LICENSE_FILE value set to the path to a license file on the client that is set up with the SERVER name of the Linux_host_name and License_Port_number.
Troubleshooting Licensing Problems

If you encounter problems with your license, refer to Table 5 for common FLEXlm error messages and possible causes or solutions.

Table 5: FLEXlm Error Messages

<table>
<thead>
<tr>
<th>FLEXlm Error Message</th>
<th>Possible Causes or Solutions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Invalid parameter [-42, 252]</td>
<td>The LM_LICENSE_FILE variable has not been set properly.</td>
</tr>
<tr>
<td></td>
<td>The license file is invalid.</td>
</tr>
<tr>
<td></td>
<td>An invalid feature is specified in the license file.</td>
</tr>
<tr>
<td>Invalid parameter [-42, 252:10061]</td>
<td>You have a floating license, and the license daemon has not</td>
</tr>
<tr>
<td>Winsock error code</td>
<td>been started at the Windows NT server.</td>
</tr>
<tr>
<td></td>
<td>The network connection between the server and the client</td>
</tr>
<tr>
<td></td>
<td>has not been established.</td>
</tr>
<tr>
<td>Invalid parameter [-12, 122]</td>
<td>The node name of the Windows NT server does not match the</td>
</tr>
<tr>
<td>Invalid returned data from license server</td>
<td>one in your floating license file.</td>
</tr>
<tr>
<td>No such feature exists</td>
<td>The feature could not be found in the license file.</td>
</tr>
<tr>
<td>! License Check Failed</td>
<td>You either have a node-locked license or you do not have a</td>
</tr>
<tr>
<td></td>
<td>license file. Contact Lattice Semiconductor Technical Support</td>
</tr>
<tr>
<td></td>
<td>for a valid floating license file.</td>
</tr>
</tbody>
</table>

If you encounter any software-related problems, review the following common troubleshooting scenarios before calling Lattice Semiconductor Technical Support:

► Ensure that your environment variable settings are set correctly, including the TEMP user variable.

► For Windows, your system should contain the following environment settings:

```
SET LM_LICENSE_FILE=<install_path>\license\license.dat
```

You can verify these settings by accessing the System Properties dialog box from your Windows system. Select the Advanced tab and the Environment Variables section.

If Diamond still does not run after you have installed your new license file and confirmed that your environment variables are correct, gather the following items:

► A screen capture showing the error message

► A text file that contains a listing of the environment setup for your PC. From an MS-DOS prompt window, issue the `set > env.txt` command.

► Your license.dat file

Combine these items in a zip file and e-mail it to techsupport@latticesemi.com. Include an explanation of the problem.
Running Multiple Versions

Diamond enables you to run FPGA designs on platforms on which Diamond 2.0 and previous ispLEVER or Diamond versions are installed.

Running Diamond

After the installation and the license configuration, you can invoke Diamond.

Running Diamond Locally

If you have installed Diamond on your local machine, choose Start > All Programs > Lattice Diamond 2.0 > Lattice Diamond. The Diamond main window is invoked.

Running Diamond using Windows Remote Desktop

You can also install Diamond on a shared disk, installation procedure of which is exactly the same as that for the local installation. After the license file setup, you can access that shared disk from the Windows Explorer and then invoke Diamond from that installation directory by double-clicking `<boot_drive>:\<diamond_install_directory>\lscc\diamond\2.0\bin\nt\pnwrap.exe`

Licensing Diamond on a shared disk is the same as with a local installation. Refer to “Licensing for Diamond and Stand-Alone Power Estimator” on page 8 for details.

Updating Diamond

After you have registered and licensed your installation, check the Lattice Semiconductor Web site for new software updates, device support, and enhancements. Make sure that you have the latest software by checking for updates regularly.

This process will only find updates to the version you have installed. For an upgrade to a new version, check the Lattice Web site.

To activate UPDATE:

1. Choose Start > All Programs > Lattice Diamond 2.0 > UPDATE.

The UPDATE window appears, as shown in Figure 3.
After you invoke UPDATE, it will connect to the Internet automatically to check for updates.

2. In the UPDATE window, click **Settings > Update Settings**.

   The Update Settings dialog box now appears, as shown in Figure 4.

### Changing the Automatic Checking Settings

Diamond can automatically check for updates and activate a window showing the Diamond updates that are available.

If you want to change or turn off the automatic update checking, change the settings in UPDATE as follows:

1. Select the **Auto Setting** tab of the Update Settings dialog box.

2. If you want to enable the automatic checking for software updates, make sure that the **Automatic check for software updates when application starts** option is turned on. By default, this option is turned on.
If you turned on the **Automatic check for software updates when application starts** option, indicate the frequency with which you want the checking to be performed: every time that Diamond is started, daily, or weekly. An every-time check is the default.

If you want to disable the automatic checking, turn off the **Automatic check for software updates when application starts** option.

3. Click **OK**.

**Changing the Network Setting**

To enable automatic checking, you must indicate how your computer accesses the Internet.

**To change the Internet connection settings:**

1. Select the **Network Setting** tab of the Update Settings dialog box, shown in Figure 5.

**Figure 5: Network Settings Tab of the Update Settings Dialog Box**

2. Select the **Use a Proxy Server** option if you must go through a proxy server before connecting to the Internet. The proxy server prevents outsiders from breaking into your organization’s private network. Ask your system administrator for the URL address and port assignment. This option is turned on by default.

If you use direct Internet access, do not select the **Use a Proxy Server** option on this tab.

**Installing Updates**

When you use the Auto Check feature, UPDATE notifies you whenever an update version of Diamond becomes available. You receive notification when you open the Diamond main window.
To check and install the recommended update:

- Click **Update**. The UPDATE software goes online to check for an update. If one is available, the Diamond update version will be displayed in the **Available update versions** field.
- Click **Download** to save the update to a directory and install it later.
- Click **Install** to download and install the selected update version (as the version number specified in the **Available update versions** field) right away.

To install a downloaded update:

1. Close all Diamond tools.
2. Go to the location where you saved the update version.
3. Double-click the update file and follow the on-screen instructions.

---

**Installing Stand-Alone Programmer/Deployment Tool**

Programmer/Deployment Tool are included in the Diamond installation. If you want to use the Programmer/Deployment Tool without installing Lattice Diamond, first download it from the Lattice Semiconductor Web site.

Lattice Programmer/Deployment Tool is available in 32-bit and 64-bit versions.

- The 64 bit version of Lattice Programmer/Deployment Tool is optimized to run on Windows 64-bit systems.
- The 32-bit version of Lattice Programmer/Deployment Tool is optimized to run on Windows 32-bit systems.

Follow the product download instructions and uncompress the software. For more information on how to download Programmer/Deployment Tool, go to: [http://www.latticesemi.com/latticediamond](http://www.latticesemi.com/latticediamond).

To install the stand-alone Programmer/Deployment Tool:

1. Close all applications before starting installation.
2. Double-click on the Programmer/Deployment Tool installer you downloaded to launch the installation process.
3. The Welcome To Lattice Diamond Programmer setup dialog box opens.
4. Click **Next** to open the License Agreement dialog box.
5. Read the license agreement. If you agree, click **I Accept the terms of the License Agreement** and then click **Next** to open the Choose Destination Location dialog box.
6. The default destination folder is C:\lsc. Click **Browse** to change the drive or destination folder.
7. Click **Next**. The default name of the program group is **Lattice Diamond Programmer 2.0** (or **Lattice Diamond Programmer 2.0 (64-bit)**) if you installed the 64-bit version. If you want to change the name, change it in the Program Folder text box.

8. Click **Next** to open the Select Features dialog box. Your choices are:
   - Lattice Diamond Programmer Components
   - Programmer Drivers
   
   Choose the desired features.

9. Click **Next** to start installing the selected components.

10. In the InstallShield Wizard Complete dialog box, read the note and click **Finish**

### Starting Stand-Alone Programmer/Deployment Tool

You can start the Programmer or Deployment Tool from the Windows Start menu.

**To start the 32-bit version of stand-alone Programmer:**

- Choose **Programs > Lattice Diamond Programmer 2.0 > Programmer** from the Windows Start menu.

**To start the 64-bit version of stand-alone Programmer:**

- Choose **Programs > Lattice Diamond Programmer 2.0 (64-bit) > Programmer** from the Windows Start menu.

**To start the 32-bit version of stand-alone Deployment Tool:**

- Choose **Programs > Lattice Diamond Programmer 2.0 > Deployment Tool** from the Windows Start menu.

**To start the 64-bit version of stand-alone Deployment Tool:**

- Choose **Programs > Lattice Diamond Programmer 2.0 (64-bit) > Deployment Tool** from the Windows Start menu.

### Installing Stand-Alone Reveal Logic Analyzer

Reveal Logic Analyzer is included in the Diamond installation. If you want to use the tool without installing Lattice Diamond, first download it from the Lattice Semiconductor Web site.

Reveal Logic Analyzer is available in 32-bit and 64-bit versions.
The 64 bit version of Reveal Logic Analyzer is optimized to run on Windows 64-bit systems.

The 32-bit version of Reveal Logic Analyzer is optimized to run on Windows 32-bit systems.

Follow the product download instructions and uncompress the software. For more information on how to download stand-alone Reveal Logic Analyzer, go to: http://www.latticesemi.com/latticediamond.

To install the stand-alone Reveal Logic Analyzer:
1. Close all applications before starting installation.
2. Double-click on the Reveal installer you downloaded to launch the installation process.
3. The Welcome To Lattice Diamond Reveal Analyzer setup dialog box opens.
4. Click Next to open the License Agreement dialog box.
5. Read the license agreement. If you agree, click I Accept the terms of the License Agreement and then click Next to open the Choose Destination Location dialog box.
6. The default destination folder is C:\lsc. Click Browse to change the drive or destination folder.
7. Click Next. The default name of the program group is Lattice Diamond Reveal 2.0. If you want to change the name, change it in the Program Folder text box.
8. Click Next to open the Select Features dialog box. Your choices are:
   - Lattice Diamond Reveal Logic Analyzer Components
   - Lattice Diamond Programmer Components
   - Programmer Drivers
   Choose the desired features.
9. Click Next to start installing the selected components.
10. In the InstallShield Wizard Complete dialog box, read the note and click Finish.

Starting Stand-Alone Reveal Logic Analyzer
You can start the Reveal Logic Analyzer from the Windows Start menu.

To start the 32-bit version of stand-alone Reveal Logic Analyzer:
- Choose Programs > Lattice Diamond Reveal 2.0 > Reveal Logic Analyzer from the Windows Start menu.
To start the 64-bit version of stand-alone Reveal Logic Analyzer:

- Choose Programs > Lattice Diamond Reveal 2.0 (64-bit) > Reveal Logic Analyzer from the Windows Start menu.

Installing Stand-Alone Power Estimator

Power Calculator is included in the Diamond installation. If you want to use the tool without installing Lattice Diamond, you can install the stand-alone Power Estimator, available for download from the Lattice Semiconductor Web site.

Power Estimator is available in 32-bit and 64-bit versions.

- The 64 bit version of Power Estimator is optimized to run on Windows 64-bit systems.
- The 32-bit version of Power Estimator is optimized to run on Windows 32-bit systems.

Follow the product download instructions and uncompress the software. For more information on how to download stand-alone Power Estimator, go to: http://www.latticesemi.com/latticediamond.

To install the stand-alone Power Estimator:

1. Close all applications before starting installation.
2. Double-click on the Power Estimator installer you downloaded to launch the installation process.
3. The Welcome To Lattice Diamond Power Estimator setup dialog box opens.
4. Click Next to open the License Agreement dialog box.
5. Read the license agreement. If you agree, click I Accept the terms of the License Agreement and then click Next to open the Choose Destination Location dialog box.
6. The default destination folder is C:\lsc. Click Browse to change the drive or destination folder.
7. Click Next. The default name of the program group is Lattice Diamond Power Estimator 2.0 (or Lattice Diamond Power Estimator 2.0 (64-bit) if you installed the 64-bit version). If you want to change the name, change it in the Program Folder text box.
8. Click Next to open the Select Features dialog box. Your choices are:
   - Diamond Power Estimator Components
9. Click Next to start installing the selected components.
10. In the InstallShield Wizard Complete dialog box, read the note and click Finish.
Starting Stand-Alone Power Estimator

You can start the Power Estimator from the Windows Start menu.

To start the 32-bit version of stand-alone Diamond Power Estimator:

► Choose Programs > Lattice Diamond Power Estimator 2.0 > Diamond Power Estimator from the Windows Start menu.

To start the 64-bit version of stand-alone Reveal Logic Analyzer:

► Choose Programs > Lattice Diamond Power Estimator 2.0 (64-bit) > Diamond Power Estimator from the Windows Start menu.

Note


Troubleshooting

If you encounter any software-related problems after installing Diamond, review the following common troubleshooting scenarios before calling Lattice Semiconductor Technical Support:

► Ensure that your environment variable settings are set correctly, including the TEMP user variable.

► Your should also have the following system environment setting pointing to the license file:

```
SET LM_LICENSE_FILE=\<Lattice_license_path>\license.dat
```

If you have multiple installations of Lattice software, this variable may have multiple paths in it. If there are problems, you may need to manually edit the variable.

You can verify these settings by accessing the System Properties dialog box from your Windows system. Select the Advanced tab from that dialog box and go to the “Environment Variables” section.

► If you have problems with the display, ensure that your system video display is set to a screen resolution of 1024 x 768 or more and that your video display is set to use 256 or more screen colors.

► If Diamond is installed on a Windows XP, Windows Vista, or Windows 7 system with administrator privilege and is to be used by an account in the “Users” group, make sure that the user account has permission to write the following folder and the configuration file in that folder:

```
<boot_drive>:\Documents and Settings\<login_name>\Application Data\LatticeSemi\*.ini
```

For a Windows 7 system, the folder is located at:

```
<boot_drive>:\users\<login_name>\AppData\LatticeSemi\*.ini
```
For the Windows Vista platform, the tools might not be displayed in the Diamond main window Tools menu. To display them properly, the user must have read/write permission for the .ini file.

- Opening the online Help may be interrupted by one of the following messages on the Internet Explorer Information Bar:
  - “To help protect your security, Internet Explorer has restricted this file from showing active content that could access your computer. Click here for options…”
  - “To help protect your security, Internet Explorer has restricted this file from running scripts or ActiveX controls that could access your computer. Click here for options…”
  - “To help protect your security, Internet Explorer has restricted this webpage from running scripts or ActiveX controls that could access your computer. Click here for options…”

This can happen if you are using Windows XP with Service Pack 2 and have Internet Explorer 6 or higher as your default browser.

To see the Help, click on the Information Bar and choose Allow Blocked Content. A dialog box with an expanded warning opens. Click Yes.

To avoid these warnings, either use a different browser or turn off the warning for active content in Internet Explorer.

**Note**

Doing either of these means that when you open any Web page that is resident on your computer—not just Diamond Help—the page will automatically run any active content that it has. While active content is common and can be very useful, malicious content can damage your files. Be sure you trust the software on your computer.

**To turn off the warning:**

a. In the Internet Explorer, choose Tools > Internet Options.

b. Click the Advanced tab.

c. Under Security, select Allow active content to run in files on My Computer.

d. Click OK.

### When All Else Fails

If Diamond still does not run after you have installed your new license file and confirmed that your environment variables are correct, gather the following items:

- A screen capture showing the error message
- A text file that contains a listing of the environment setup for your PC. From an MS-DOS Prompt window, issue the set > env.txt command.
- Your license.dat file
Put these items into a zip file and e-mail it to techsupport@latticesemi.com, including an explanation of the problem.
Installing LatticeMico Development Tools

You can install the LatticeMico Development Tools as a part of the Diamond software or as stand-alone software if Diamond is not installed.

- If the 2.0 version of Diamond is installed on your computer, the LatticeMico Development Tools will be installed by default in a folder called micosystem, which resides in the folder in which Diamond was installed. For example, the LatticeMico Development Tools could be installed in the `<install_drive>:\lscc\diamond\2.0\micosystem` directory.

- If the 2.0 version of Diamond is not installed on your computer, the LatticeMico Development Tools will be installed by default in a folder called micosystem, which resides in the LatticeMico folder. For example, the LatticeMico Development Tools could be installed in the `<install_drive>:\LatticeMico\micosystem` directory.

Whether you install LatticeMico Development Tools with Diamond or as stand-alone tools, you can download them from the Lattice Semiconductor Web site.

Installing LatticeMico with Diamond

To take advantage of the full features and functionality of the LatticeMico Development Tools, Lattice Semiconductor recommends that you install the 2.0 version of Diamond before installing the LatticeMico Development Tools. See “Installing Diamond 2.0 for Windows” on page 4 for detailed instructions on installing Diamond.

Note

The LatticeMico software works with both 32-bit and 64-bit Windows systems.
This section describes how to install the LatticeMico Development Tools on top of the Diamond software. These procedures assume that you have already installed Diamond 2.0.

**Note**

If you do not have Lattice Diamond installed, you can install the LatticeMico Development Tools as stand-alone tools. For information on this procedure, see “Installing LatticeMico as Stand-Alone Software” on page 27.

To install the LatticeMico Development Tools:

1. Make sure you have installed Lattice Diamond 2.0.

2. Double-click on the LatticeMico setup file you downloaded to launch the installation process. The LatticeMico Development Tools Setup dialog box automatically appears.

3. Click **Next**.

4. In the Product Options dialog, for full functionality, be sure that both the LatticeMico System and the GNU-based Compiler Tools options are selected.

**Note**

You can install LatticeMico System and the GNU-based Compiler Tools separately by checking only one box, but Lattice Semiconductor recommends that you accept the defaults and install both tools at the same time.

When you select the LatticeMico System option, the LatticeMico Development Tools do the following:

- Install the Eclipse graphical user interfaces, which are components, or plug-ins, of the Eclipse development environment on which the LatticeMico System is based.
- Enable Mico System Builder (MSB) to access all Lattice Diamond executables and functions.
- Add the LatticeMico System icon to the Lattice Diamond 2.0 Accessories folder on the Windows Start menu.
- Add the LATTICEMICOSYSTEM environment variable.

If the LatticeMico System option is not selected to install, you cannot use the LatticeMico System graphical user interface. You can only use the LatticeMico Development Tools through the command line.

When you select the GNU-based Compiler Tools option, the LatticeMico Development Tools do the following:

- Install gtools (C++/C tool chain) and cygwin.
- Add the LatticeMico System SDK Shell icon to the Lattice Diamond 2.0 Accessories folder on the Windows Start menu.
- Enable the command-line mode for building C/C++ source codes.
- Add the LATTICEGNUTOOLS environment variable.
If the GNU-based compiler is not installed, the C++/C and debug graphical user interfaces will not function correctly.

5. Click **Next**. You will get the License Agreement for LatticeMico System dialog.

6. Click **Yes** to accept the terms of the licensing agreement for LatticeMico Systems.

7. Click **Yes** to accept the terms of the licensing agreement for the GNU-Based Compiler Tools.

8. The Choose Destination Location part of the LatticeMico Development Tools Setup dialog box now appears. As the current version of Diamond is installed, the default destination folder will be the same folder in which Diamond was installed.

9. Click **Next** to accept the default destination folder.

10. The Select Program Folder dialog box opens. The default name of the program group is **Lattice Diamond 2.0**. If you want to change the name, change it in the Program Folder text box.

11. Click **Next**.

12. In the Start Copying Files part of the LatticeMico Development Tools Setup dialog box, click **Next**.

   The installation begins. When it is finished, the LatticeMico Development Tools Installation Completing dialog box appears.

13. Click **Finish**.

14. Because the installation process added new environment variables, reboot your computer.

### Installing LatticeMico as Stand-Alone Software

If you do not have the current version of Diamond installed, you can still install the LatticeMico Development Tools, but their functionality will be limited. Mico System Builder (MSB) will not be fully functional. You can create platforms, but the platform generator will not be fully functional because of missing Diamond executables and functions. The design-rule checker will also not be fully functional. However, the graphical user interfaces of the C/C++ Software Project Environment (C/C++ SPE) and the debug environment will be fully functional.

The procedure for installing the LatticeMico Development Tools as stand-alone tools is similar to the procedure for installing the LatticeMico Development Tools on top of Diamond, but the content of some of the dialog boxes is different.

By default, the LatticeMico Development Tools are installed in the `C:\LatticeMico\micosystem` folder when you install them as stand-alone tools.
To install LatticeMico as stand-alone software:

1. Double-click on the LatticeMico setup file you downloaded to launch the installation process. The LatticeMico Development Tools Setup dialog box automatically appears.

2. Click Next.

3. In the Product Options dialog, for full functionality, be sure that both the **LatticeMico System** and the **GNU-based Compiler Tools** options are selected.

**Note**

You can install LatticeMico System and the GNU-based Compiler Tools separately by checking only one box, but Lattice Semiconductor recommends that you accept the defaults and install both tools at the same time.

When you select the LatticeMico System option, the LatticeMico Development Tools do the following:

- Install the Eclipse graphical user interfaces, which are components, or plug-ins, of the Eclipse development environment on which the LatticeMico System is based.
- Enable Mico System Builder (MSB) to access all Lattice Diamond executables and functions.
- Add the LatticeMico System icon to the Windows Start menu.

If the LatticeMico System option is not selected to install, you cannot use the LatticeMico System graphical user interface. You can only use the LatticeMico Development Tools through the command line.

When you select the GNU-based Compiler Tools option, the LatticeMico Development Tools do the following:

- Install gtools (C++/C tool chain) and cygwin.
- Add the LatticeMico System SDK Shell icon to the Windows Start menu.
- Enable the command-line mode for building C/C++ source codes.

If the GNU-based compiler is not installed, the C++/C and debug graphical user interfaces will not function correctly.

A warning message is shown as follows:

LatticeMico Development Tools setup did not detect an installed version of Diamond 2.0 software. The LatticeMico System requires that the Diamond 2.0 software be installed to be fully functional.

If Diamond 2.0 is installed at a later time, LatticeMico System must be uninstalled and re-installed after Diamond 2.0 has been installed.

4. Click OK.

5. Click Yes to accept the terms of the licensing agreement for LatticeMico System.

6. Click Yes to accept the terms of the licensing agreement for the GNU-Based Compiler Tools.
7. The Choose Destination Location part of the LatticeMico Development Tools Setup dialog box now appears. You can choose the folder in which the LatticeMico Development Tools will be installed.

The path of the destination folder will then be the path of the previous installation of the LatticeMico Development Tools or the GNU-Based Compiler Tools. If there was no previous installation of either, the destination folder will be the C:\LatticeMico folder.

To accept the default destination folder, click Next. Otherwise, click Browse to change the drive or destination folder, and then click OK and click Next.

8. The Select Program Folder dialog box opens. The default name of the program group is LatticeMico. If you want to change the name, change it in the Program Folder text box. Click Next.

9. In the Start Copying Files part of the LatticeMico Development Tools Setup dialog box, click Next.

The installation begins. When it is finished, the LatticeMico Development Tools Installation Completing dialog box appears.

10. Click Finish.

---

**Starting LatticeMico Development Tools**

You can start the LatticeMico Development Tools from the Windows Start menu.

**To start the LatticeMico Development Tools:**

- If you have installed LatticeMico System on top of the Lattice Diamond 2.0 software, choose Programs > Lattice Diamond 2.0 > Accessories > LatticeMico System from the Windows Start menu.

- If you have installed LatticeMico System as stand-alone software, choose Programs > Lattice Diamond 2.0 > LatticeMico System from the Windows Start menu.