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Introduction
PAC-Designer® (version 4.0 and later) provides an improved Waveform Editor that is integrated into the LogiBuilder
design environment. This editor greatly simplifies the creation and editing of stimulus files that are used to simulate
LogiBuilder or ABEL designs. To highlight a few of the new features, the user-defined names are automatically
extracted from the design and placed into the Waveform Editor and a simplified interface is provided for editing the
waveforms. This application note covers these and many more new features provided in the improved Waveform
Editor.

Starting the Waveform Editor
After a LogiBuilder design has been successfully compiled, the Waveform Editor can be started from either the
menu item Tools > Run Waveform Editor or the toolbar icon as shown in Figure 1. The Waveform Editor is a separate application and will start in a new window.
Figure 1. The Waveform Editor can be Started from Menu or Toolbar

When the Waveform Editor opens, it automatically reads the user defined names for the VMONS and logic inputs
from the LogiBuilder generated ABEL file and displays them on the left side of a split-window display as shown in
Figure 2. The Waveform Editor also reads the default WDL file (waveform descriptive language) that contains
default waveforms for “RESET,” “AGOOD,” and “CLK_IN.” While each user defined name is given a placeholder in
the editor, only the signals that are used in the design need to have a waveform defined to provide a valid stimulus
for simulation.
Figure 2. Waveform Editor Launches with Design Names in Left Window
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Defining and Editing Waveforms
The Waveform Editor displays all user-defined input names from the LogiBuilder design files for reference, accuracy, and to simplify the simulation phase of a design. To define a waveform for a signal, double-click on its name to
open an Edit Waveform dialog box. Figure 3 shows the first three steps required to define a waveform for the
“VM1_5V_GOOD” signal using the Edit Waveform dialog. As steps 2 and 3 are repeated to define the waveform
the transition list is updated and maintains a Total Time column for reference. The Total Time column lists the
cumulative time from the start time of simulation to assist in synchronizing multiple waveforms. After all the required
transitions have been added, click the OK button to save the changes and observe the waveform. Note the Add
Segment button will always add to the bottom of the list.
Figure 3. Edit Waveform Dialog is Used to Define a Waveform
1. Select Initial state of
waveform (High or Low).

2. Enter Initial duration in
microseconds.
3. Add the entry to the list.

To edit or modify an existing waveform, double-click on either the name in the left windowpane or the waveform on
the right windowpane to re-open the Edit Waveform dialog box. If a particular segment of the waveform was targeted with the mouse when it is double-clicked then that segment will be highlighted in the list and its duration will
be placed in the edit window as shown in Figure 4. Change the Segment Duration value to make it longer or
shorter and click on the Change Segment button to update the list. The Delete Segment button can be used to
remove the highlighted segment from the list altogether which results in a shorter waveform. Of course when a segment is deleted, the segments that follow it undergo both shift forward in time and inversion of their logic level.
WARNING: The Waveform Editor dialog supports editing the user defined Waveform Name but the names in the
stimulus file must match the names in the design file in order obtain valid simulation results. The Waveform Editor
prevents changing the name of the “CLK_IN,” “RESET,” and “AGOOD” waveforms as they are not user definable.
The Waveform Name edit feature is one method of synchronizing name changes that may occur in the design cycle
to an existing stimulus file. However, there exists a more elegant feature in the software to synchronize name
changes in the design that does not require manual editing. This is covered later in the Synchronizing User Defined
Names section of this document.
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Figure 4. Editing the Second Segment of a Waveform

Clicking and Dragging
Waveforms that have been defined can also be modified using the “click-and-drag” method. A single mouse click
on a waveform is required to first “select” the waveform. Selected waveforms and their names will change color
from blue to red to indicate they are selected. As the mouse is positioned over a transition or the end of a selected
waveform, the cursor will change, as shown in Figure 5, to indicate that dragging is possible. With the dragging cursor shown, click, hold, and drag the transition to a new location to shorten or lengthen the segment. The time scale
at the top of the screen and the time index in the lower right are provided to assist in setting the new position of the
waveform transition. The time index in the lower right indicates the position of the active cursor: cross-hair or dragbars.
Figure 5. Click and Drag Cursor is Used to Modify Waveforms
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Zoom-In and Zoom-Out
The default time scale for the Waveform Editor will automatically adjust to display the longest waveform in the
stimulus file. This often results in a coarse time scale that makes it difficult to accurately click-and-drag waveform
transitions. The waveform display window supports a zoom-in feature that when used results in a finer time scale
for more accurate placement of the transitions. When the display is zoomed in a standard scroll bar is provided to
navigate the display over the waveform data. Figure 6 shows that either the menu entries or the magnifying glass
icons on the toolbar can be used to zoom in or zoom out.
Figure 6. Menu or Tools can be Used to Zoom In or Zoom Out

Cut, Copy and Paste
The Waveform Editor supports standard editing features such as cut, copy, and paste. These are supported with
the Edit menu, the standard toolbar icons, and the standard keystrokes (Ctrl-X, Ctrl-C, and Ctrl-V). The waveform
to be operated upon is first selected using a single mouse click. If the waveform has been defined both the name
and waveform will be displayed in bright red to indicate the selection. If the waveform has not been defined, then
the name will switch from grey to dark red to indicate the selection and only a paste operation is allowed as shown
in Figure 7. When a waveform is selected, the corresponding edit tools and menu items will become active to support cutting, copying, and pasting.
Figure 7. Pasting the Copied Waveform into VMON2_B

Input Clock
The simulator requires a clock waveform to drive the sequence, registered logic, and timers that may be used in a
design. The “CLK_IN” waveform is the input clock and is displayed at the top of the window. By default it has a frequency of 250 kHz and duration of 100 milliseconds. To modify the frequency or duration, double-click on either the
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name “CLK_IN” in the left windowpane or the waveform in the right windowpane to open the Edit Clock and Simulation Time dialog box that is shown in Figure 8.
Figure 8. Edit Clock and Simulation Time Dialog

In the upper section of the dialog box the Clock Frequency can be edited to reflect the use of an external clock
source. This is useful for Power Manager devices such as the ispPAC-POWR604 and ispPAC-POWR1208, both of
which support slower external clock sources. However, for the ispPAC-POWR1220AT8 and ispPAC-POWR1208P1
the clock input to the PLD divider and the timers is fixed at 250 kHz; thus, changing its frequency for simulations is
not recommended.
In the lower portion of the dialog box the duration of the input clock can be changed. The default value for the Clock
Duration is 100 milliseconds. For accurate simulations, the “CLK_IN” waveform should be as long or just a bit
longer than any other waveform in the stimulus file; as such, it defines the duration of the simulation.

Save and Simulate
Use the save icon from the toolbar or the file menu to save the waveform edits to the WDL file. From the LogiBuilder
window in PAC-Designer, the simulator can be started using the menu item Tools > Run PLD Simulator or the
simulator icon from the toolbar. The Waveform Editor can remain open to support multiple edit, save, and simulate
cycles.

Managing Multiple Stimulus Files
It is a good design practice to simulate a design not only with a stimulus file that demonstrates how a design works,
but also with stimulus files that may reveal potential design faults. For example, if a design drives the same output
using both the sequencer and supervisory logic (or in two separate state machines) then the fitter will OR the two
conditions to drive the output. The first stimulus file would provide one required condition to see that the output is
being driven. Subsequent stimuli might be used that do not provide the required condition to verify the output is not
being driven.
Simulating with multiple stimuli can be managed in one of two ways. The first is to create multiple simulations within
a single WDL file by setting “RESET” low some time after each simulation is complete. Of course, the respective
inputs (VMONS and logic inputs) should be reset at the same time to provide a valid startup. In simulation this is
effectively the same as pressing the reset button on a real design. While this approach may result in some lengthy
simulations it does provide all the results in a single simulation.
Multiple simulation scenarios can also be divided into separate stimulus files as PAC-Designer can support simulating with multiple stimulus files. In the LogiBuilder window of PAC-Designer the menu item Tools->Run PLD Simulator... is used to open the Launch Simulator dialog that is shown in Figure 9. From here a designer can browse
the design files folder to specify the stimulus file for simulation. The specified stimulus file will be used for all subse-
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quent simulations. However, when PAC-Designer is restarted the default stimulus file will be used for simulations
until the Launch Simulator dialog is used to specify another.
Figure 9. PAC-Designer Supports Simulating with Multiple Stimulus Files

To create multiple stimulus files, use the Waveform Editor to modify the waveforms and then use the File->Save
As... menu to create a new WDL file. To re-open stimulus files other than the default WDL, the File->Open... menu
item can be used.

Synchronizing User Defined Names
As a design grows or is modified the user defined names for VMONS and logic inputs may undergo a change. The
existing stimulus file will not have waveforms defined to support the new names and the simulator will be unable to
properly predict the outcome. The existing stimulus file can be synchronized and modified in order to simulate the
changed design. The menu item Edit -> Update Pin Names shown in Figure 10 will automatically scan the pins list
in the ABEL file and update the user defined names to match the design.
Note that simply changing the VMON name in the Analog Input Settings dialog box of PAC-Designer will not
update the pins list in the ABEL file. The LogiBuilder design has to be compiled in order that name changes made
in the schematic make their way into the ABEL file. Of course if the design is already in ABEL then the file has to be
saved after changing any pin names before trying to synchronize the stimulus file.
Figure 10. Synchronizing Design Name Changes to the Stimulus File
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Legacy Waveform Editor
PAC-Designer maintains the older Waveform Editor for reference. It can be launched using the Tools_Design Utilities... menu to open the Design Utilities dialog. The Waveform Editor is selected from the list and the OK button
will start the program as shown in Figure 11.
Figure 11. Legacy Waveform Editor is Provided in Design Utilities

Summary
The Waveform Editor features covered in this application note have shown the simplicity of creating and maintaining stimulus files used to simulate Power Manager PLD designs. The Waveform Editor reads the user-defined
names from the LogiBuilder-generated ABEL file pins list to automate the tedious task of copying and pasting that
was required with previous tools. It also prevents misspellings that can result in invalid simulations. Multiple methods are provided to edit a waveform. A user friendly dialog box can be used to precisely define or edit a waveform
and the on-screen click-and-drag feature provides a quick and easy visual interface. The Waveform Editor supports
standard cut, copy, and paste functions as well as an update pin names feature to keep stimulus files synchronized
to a dynamic design. The improved Waveform Editor allows users an easy way to set up and run multiple simulation
files for verification of design flow.
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